.netEcommerce

Please feel free to navigate this help document for information on installation, developer documentation, reference and samples.


.netCART version 6.0 is a multi-year development effort and our most significant release to date. Aimed to meet every developer need for a complete range of ecommerce solutions, .netCART offers unparallel flexibility for customization though a clear and accessible API. As the first shopping cart component for ASP.NET, .netCART was in development before the framework was officially released and has continued to be enhanced based on client feedback. Now a comprehensive ecommerce toolkit for ASP.NET developers, .netCART is seamlessly integrated with a number of products as part of the .netECOMMERCE bundle.

This integration brings class leading support for real-time payment processing including native processor support (no more gateway fees!) using .netCHARGE, real-time rate calculations and tracking with .netSHIP, currency exchange with per customer preferences with .netCURRENCY, dynamic button generation with .netBUTTON, IP geo-location including automated country selection dropdowns and advanced FraudScore calculations and risk management systems, seamlessly integrated live help with cart browsing (view the items customer have in their cart as you assist them in real-time) using .netLIVEHELP, plus advanced reporting and visualization dashboards with .netCHARTING.

In addition to the unique suite of integrated stand alone products, .netCART has an extensive feature set designed to provide complete customization at all levels. Sample store source is included and a powerful API enables customization of any aspect of the ecommerce implementation. A purpose built data engine seamlessly handles database connectivity supporting MS SQL server, MS Access, MySQL and Oracle and removing this complexity from the developer. A fully featured template and image generation system enables unlimited image variations with border, sizing and background support. Built in browser based upload with progress bar provides an intuitive interface for uploading and generating image variations based on your created templates or you can use the API for easy batch processing of large numbers of items and images. A complete size optimized cart object is easily serialized to XML with built in methods, enabling you to manage state in a totally flexible way. No longer are you tied to the original development teams vision for dataflow and creating stores with the same look, feel and behavior as other solutions. You have total freedom of dataflow from a single page store that collects all item and order details on one page to a multi-stage catalog, cart, checkout, billing, thank you implementation to a multistage process executing on different machines or even different data centers around the world. .netCART can even disconnect the cart from the data store so simple stores can work even without a database sending encrypted orders by email and using a custom order viewer on the desktop for processing. Regardless of company size, .netCART has the features to grow with your ecommerce needs.

Of course, a comprehensive order management system with data history is also provided. All modifications, edits and deletes are archived in the background so you have a full transactional history and historical data integrity. Price changes, item deletions, name changes and more will not break any previous dependencies on past orders placed with older versions of that data.

A generic item relationship system enables any number of defined relationships from related items, to suggested items, to recommended items or accessories. These groupings can easily be displayed with item details in the catalog or used for up selling and cross selling purposes.

An advanced tax system supports location based taxes and a powerful tax API is provided to handle any unique circumstances, including non tax items such as bottle deposits and fees (environmental fees, government fees etc). Easily apply taxes before or after coupons and shipping to handle various global and regional requirements with ease. Calculate included taxes such as VAT automatically. .netCART has been used throughout the world since shortly after the release of ASP.NET itself.

Integrated SMTP mail sending functionality is built in to .netCART enabling easy and automated receipt and invoice generation, password resets and more. Combined with the powerful .netCART API, you can access the full cart and customer details, iterate through the data and format emails exactly as required without limitations.

An advanced SoftGood delivery system combined with our unique FraudScore system makes .netCART and ideal match for electronic software delivery or any other digital payload. In addition to utilizing the built in SMTP mail sender to deliver smaller payloads directly by email, .netCART also supports file streaming for larger files. This enables customer specific download links with payloads located securely in a folder that does not allow direct downloading. .netCART will stream the payload from the secure location and note the requests made for it. A quota / date control system can prevent future access once the file has been requested a specific number of time or once the download date is past.

The FraudScore system is designed to use weighting on proven fraud risk criteria to determine potential likelihood of a fraudulent order based on a large set of fraud specific variables. Typically, each criteria would contribute to the fraudscore and if that total was within a specific low threshold, the order would be fulfilled in real-time. If the score was higher, a manual review may be required to complete the order and a very high score could include some addition warning or prevent fulfillment until a manager could review it. FraudScore calculations can be turned to specific industries and help greatly to reduce the labor and chargeback costs associated with online orders of softgoods and the direct losses associated with physical goods. The behaviors of the system are totally customizable by the developer to take the actions required based on the score levels typical to your specific business.

A comprehensive customer and supplier interface enables managing stock, supplier details, reviewing customer and address records. In addition to backend customer management, customers have a powerful address book and can create any number of addresses plus set two as the defaults for billing and shipping addresses. Of course, .netCART supports per item addresses with grouping, so customers are free to define as many shipping addresses for one order as they wish including custom fields and special instructions should the developer wish to expose such functionality.

Advanced state management ensures customers carts are not lost and handles seamlessly merging temporary carts with customer carts after login. Unlike many stores, .netCART has the flexibility for data flow to support accepting orders with no login, even if the customer has previously registered. Removing barriers to order processing helps to increase sales and order frequency. In addition, it is simple to configure customized stores with special behavior such as no shipping, if shipping is not applicable or even no billing for internal company use stores or loan based implementations. Combine pages as you see fit and collect information in any order at any time on any page. The state management system does not force a fixed order of collection and there are no fixed dependencies on certain data being collected first. The cart object holds everything in an easy to access model you can use with the provided user controls or directly in your own code to meet any custom requirement. Calculation methods enable you to determine totals, taxes and derived values at any time you wish. You can also easily override any calculated value and have it used in place of your value. Want no tax or no shipping base on a complex criteria? No problem, simply set the total to zero with a single property setting.

A built in coupon system enables you provide discounts with quotas, validate coupon validity in the cart without postback. In addition, you can allow partial application of coupons and offer gift certificates with carry over balances.

The Displaycart control utilizes AJAX to minimize postbacks and ensure calculated values display inline. Quantity management and updates on focus change ensure that orders are not made incorrectly due to lost changes when a customer makes and update and does not submit. Per item adjustments in pricing and unlimited options and choices can handle any variations. Options support image swatches to clearly show color or fabric samples instead of depending on text descriptors alone. Choices can also modify weight and pricing for a given item.

An advanced tracking system enables you to persist the referrer domain and querystring value that the sale should be attributed to. This enables a clear record of sites or ad campaigns that generate sales for accurate cost per acquisition (CPA) and dollar spent per dollar gained reporting. Should a customer visit and return later to purchase using the same browser, the order source will still be tracked an recorded for the purchase.

Advanced reporting provides charts plus the ability to add and customize your own visualizations for data in the .netCART database. Day based comparisons provide useful sales comparisons since sales vary based on day, you can easily compare the specific Mondays instead of comparing Sunday to Monday. Easily page through data and if you have advanced reporting or dashboard needs, you have the complete power and flexibility of .netCHARTING to use for data in your .netCART database.


Version 6

Version 6.0 released August 2016 adds many new features including:

·

Payment Support sending credit card information directly from client's browser to Authorize.NET or Stripe. This method complies with the Payment Card Industry Data Security Standards (PCI DSS).

·

Mail: Support STARTTLS connection for port 587

·

Updated StoreAdmin, samples and documentation

Version 6.0 released July 2016 adds many new features including:

·

Payment: Updated FirstData Global Gateway

·

Currency: Rates update with free and 3rd party provider using your account

·

Updated StoreAdmin, samples and documentation

Version 6.0 released March 2016 adds many new features including:

·

Payment: Support Payeezy (rebranding for FirstData Global Gateway E4)

·

Payment: Support Converge (rebranding for Elavon Virtual Merchnant)

·

Updated StoreAdmin, samples and documentation

Version 6.0 update released November 2015 adds many new features including:

·

Mobile compatibility: Updated css style to show in mobile correctly.

·

Fraud score: Enhanced Fraud score calculation and adding credit card attempts tracking.

·

AdjustRate: Apply Category adjust rate to all items in the category.

·

Item: New GetCategoryIdsDB() method for returning multiple categories

·

Updated installer and automated deployment for Windows Server 2012 R2 with IIS 8 and Windows 10 with IIS10

·

Updated StoreAdmin, samples and documentation

Version 6.0 released July 2015 adds many new features including:

·

Shipping: New USPS International Api version 2 support

·

Shipping: EasyPost support for getting rates / Tracking / labels for all carriers

·

Updated StoreAdmin, samples and documentation

Version 5.1 Update released May 2015 adds many new features including:

·

Location: Support phone number lookup (PhoneToCode)

·

StoreAdmin->Location: Support US sales tax by zip codes

·

Updated StoreAdmin, samples and documentation

Version 5.1 Update released January 2015 adds many new features including:

·

Shipping: Support ShipTime for UPS and FedEx, and template for DisplayRate

·

Payment: Support First Data Global Gateway e4

·

Database: Support Sql server database in Azure and MS Access *.accdb

·

New CustomerDetails and CalculateShipping user controls

·

Updated StoreAdmin, samples and documentation

Version 5.1 released October 2014 adds many new features including:

·

Support company property for billing and shipping address

·

Payment: Support Authorize.Net Customer Information Manager (CIM)

·

Updated samples and documentation

Version 5.0 Update released April 2014 adds many new features including:

·

Shipping: LimitRates and ExlcudeRates now have wildcard support

·

Payment: Set payment currency from your store base currency automatically

·

Updated samples and documentations

Version 5.0 Update released February 2014 adds many new features including:

·

Checkout Handling special characters in UPS rates.

·

DisplayCart: Enhanced performance and handling special characters in option value.

· | Billing: Enhanced credit card validation and correction handling.
· | StoreAdmin: Enhanced user interface and help information.
· | Mail: Fixed email time and exposes setting for time zone adjustment.

Version 5.0 released December 2013 adds many new features including:

·

Shipping: UPS supported with rating and tracking.

·

Shipping: USPS return handling updated.

· | Payment: Google checkout removed (closed down by Google)
· | Added License Agreement template before completing an order.

Version 4.8 Update released September 2013 adds many new features including:

·

Shipping: Updated DHL rate and tracking.

·

Fraud score: Enhanced Fraud score calculation and adding FreeEmails property for overwriting default free emails.

· | Enhanced store front display in mobile and tablets.
· | Fixed uploading items and categories images in IE 10.

Version 4.8 Update released March 2013 adds many new features including:

·

Search enhancement: Support sub-Items search with different criteria same as regular items.

·

Sub-Items: Show subItems stock in Inventory report.

·

Customer Invoice: New user control with html and Pdf print versions.

·

Payment: New "TransFirst" gateway support has been added.

·

Payment: Support overriding address for PayPal payment.

Version 4.8 Update released December 2012 adds many new features including:

·

Support adding existing options to the items via StoreAdmin->Catalog->Item details-> options tab.

·

DisplayCatalog: New user control with more options and easy configuration.

·

Payment: New "Stripe" gateway support has been added.

·

Payment: Supporting recurring billing for PaymentTechOrbital, Authorize.NET , GlobalPayments, LinkPoint, Stripe and PayFlowPro.

Version 4.8 Update released September 2012 adds many new features including:

·

Supporting Items cloning in StoreAdmin-> Catalog -> Item Details

·

PDF Report: You can now create PDF reports with embedded charts via StoreAdmin -> Report -> Dashboard

·

DisplayCatalog: Show related and suggested items for each item in your store’s front-end catalog

·

Payment: New "PayPal Advanced" gateway support has been added

·

Payment: Paymentech orbital and Authorize.net account verification support (zero dollar authorization)

Version 4.8 released July 2012 adds many new features including:

·

Email body format configuration (Text or html) via StoreAdmin->Settings->Email section.

·

Supporting items with more than one version using subItem: eBook, Paper cover, Hard cover.

·

FedEx shipping: support Account rate, Smart Post and home delivery services.

·

PDF Invoice: Creating a printable order invoice in PDF format. See CustomerInovicePdf user control.

·

Item Review API with user controls for adding a review, displaying all reviews for an item or customer.

·

Managing Reviews via StoreAdmin->Catalog->Reviews

·

MiniCartLink: Provide a mini cart with a link to checkout or catalog. See ItemControls\MiniCartLink.ascx

Version 4.7 released March 2012 adds many new features including:

·

Shipping: New USPS API support and package type settings.

·

Payment: New First Data Global Gateway Connect 2.0 method support including bypass form.

·

Language: Supports adding custom name/value strings. See StoreAdmin->Settings->Language tab, "Add New String" button.

·

Bundle: New user controls for mini cart, suggested and related items and customer also bought items.

·

Bundle: New GridView catalog user control with the same skin as DisplayCart user control.

·

Customer admin new design with multiple skin selections.

·

Supplier item management added to the backend administration interface. See StoreAdmin->Inventory->Order Items section.

·

DisplayCart: Enhanced user control with Header and footer settings for simplified customization and new column sorting support.

·

AddItems: Demonstrates different ways for adding items to cart for custom integration. See DisplayCatalogSamples/AddItems.aspx

·

Skin Templates: A set of skin templates has been added to help with other custom areas of your store design. See the Templates folder.

·

GlobalPayments: Updated certification for different transaction types including partial payments.

·

Profit Report: New item cost enables item and customer based profit reports. See StoreAdmin->Reports->Profit

·

Billing: Enhanced credit card handling by displaying accepted credit cards images and customer's credit card type image as the number is provided.

·

Payment: Supports multiple payment providers at the same time alongside traditional gateways and processors including PayPal, PayPalExpress, Amazon

Version 4.6 released February 2011 adds many new features including:

·

New design with multiple skin selections.

·

Support for multiple admin users created by the master admin account. See StoreAdmin->Settings->AdminUsers for details

·

ActivityLogs report. See StoreAdmin->Settings->ActivityLogs section.

·

Item inventory reporting. StoreAdmin->Inventory->Report.

Version 4.5 released November 2010 adds many new features including:

·

Ad Campaigns and customer tracking system: Provides comprehensive information detailing where sales and store visitors are coming from.

·

Referrer's report: Provides different charts and web based reports for sales, orders, items and visits by referrer, predefined querystring value and domain.

·

Enhance grids control: extended language string support to cover grid settings and support column sorting.

·

DisplayCart: Added estimate shipping features and calculation to help customer determine shipping costs prior to checkout.

·

Vital native processing: Updated certification for different transaction types including partial payments.

Version 4.4 released October 2010 adds many new features including:

·

Imgnav: An image navigation control which allows for intuitive browsing of large images at multiple zoom levels. Includes an automated administration system for seamless upload and just-in-time image processing. For more information, follow then "ImgNav Zoomer Sample" link in the bundle's first page.

·

Language System:Extended to cover the StoreAdmin section in addition to the sample store frontend.

·

Visual studio web application compatibility enhancements. Now you can convert the sample store to a Web Application in a few clicks.

Version 4.3 released September 2010 adds many new features including:

·

Language System: All text values used by the bundle can be now customized from the store admin language GUI for simple internationalization. See StoreAdmin->Settings->Language tab to customize string values or create new language files.

·

Customer passwords now support unique hashes. As always, passwords strings are not stored and the only person who knows a password is the customer. Password updates are completed by sending a temp password to the customer's email which they can use to reset the password to a value of their choice.

·

Automatic AJAX detection and support for different framework versions and the GUI web controls.

·

Orders: Added new search options including ReferenceID.

Version 4.2 released July 2010 adds many new features including:

·

Currency: Displays all the currency values based on store currency setting or customer.Currency.

·

Multiple images: Supports displaying multiple images for a single item in store catalog.

·

Checkout: Provide an option to checkout as guest for registered or unregistered customers. Evaluate customers' registration status as soon as they entered their emails.

·

Store Stock handling: Provide an option to enable or disable stock handling easily. See How To...

·

Price group: Load and displays different price for an item based on the customer.Group.

·

Rotator: Rotate items with 4 options: SmoothScroll, SlideShow, ContentScroll and RandomSlide.

·

MiniCart: Provide a mini cart for quick review.

Version 4.1 released April 2010 adds many new features including:

·

Payment: Supports FirstData, Elavon, SagePay, QuickBooks, RBS WorldPay, PayPalPro 3D Secure Authentication and other enhancements.

·

Shipping: Supports International and Freight for FedEx.

·

DisplayCart: Supports AJAX for updating coupons and taxes when changing an item's quantity or options.

·

Store Catalog: Supports AJAX for displaying item's price based on option's selection.

·

StoreAdmin Catalog: Supports changing item's category and orders through store admin UI.

·

StoreAdmin: Supports changing "StoreAdmin" folder's name to any arbitrary name with full functionality.

·

dotnetButtonSamples: A complete set of samples for generating buttons using the .netBUTTON add-on.

·

Tracking: Saves and displays customer's tracking information (Referrer, Inbound querystring and IP address)


System Requirements

.netCART is designed to be used in a web server environment for online ecommerce implementations.

Supported Development Operating Systems:
  • Windows XP
  • Windows Vista
  • Windows 7
  • Windows 8
  • Windows 8.1

Supported Deployment (Server) Operating Systems:

  • Windows 2000 Server
  • Windows Server 2003
  • Windows Server 2008
  • Windows Server 2012
    •

Additional Requirements:

  • .NET Framework 2.0 or later (3.5, 4.0 etc.)
  • Internet Information Server 5.0 or later (6.0, 7.0 etc.)
  • ASP.NET 2.0 or later (3.5, 4.0 etc.)

Optional development tools:

  • Visual Studio 2005 or later (2008, 2010 etc.)
  • Or use your favorite text or html editor. There is no dependency or requirement to use Visual Studio with .netCART.


Instructions

.netCART can be deployed quickly and easily without any special installation or registration requirements. It will work with a dedicated server, shared server, hosted server etc. so long as the server supports ASP.NET 2.0 or greater - as soon as you transfer your files to your web server you can start using .netCART!

Installation Options:

The automated MSI installer will deploy the product without any manual install required. If you select the manual install / unpack only option or need to deploy to a remote host you don't have desktop access to run the installer on, please use these steps:

Procedure:
· Unzip distribution
· Copy / FTP web files to a directory of your choice within your web servers root directory
· Ensure that dotnetcart.dll is located in the /bin directory and that the /bin directory is in the root (top level) of your web site or, if not, that you have created an application for the subdirectory which contains your /bin directory.
· Ensure that your purchase key is located in the /bin directory along with dotnetcart.dll. There is no key for 30 days trial period.
· Ensure the anonymous web user (typically ASPNET or Network Service) with read, write and modify permissions to the App_Data, Images and StoreAdmin/temp directories.
· You may now use the .netCART samples

Using a Virtual Directory:
Using the IIS administration (MMC), create a virtual directory under your web site pointing to the root directory that contains the .netCART samples. Click here for more information on virtual directory creation.

Using Visual Studio.NET:
In Visual Studio, use File -> Open Web site and locate the root directory VB.NET or C# bundle. Currently there is limited integration with Visual Studio.NET beyond its role as an ASP.NET editor.

Security:
.netCART has a number of features to ensure that your ecommerce implementation remains as secure as possible. Please consult the PA-DSS Security Checklist topic before making any .netCART based ecommerce store live for your customers.


Quick Start

Quick Start Guide for the .netECOMMERCE Bundle and .netCART

This section walks you through configuration and customization. Most pages in store admin have tooltips which provide a description for the feature when holding your mouse over the [image] icon.

Home

After installation, the home page provides the links for exploring different sections of the bundle. There is no necessary modifications required for testing and reviewing the bundle. For customizing the bundle based on your needs to host your own online store, you can follow the steps below. In case of a customization which is not supported through the store admin web interface, you can review Store Files and How to ... sections to review the bundle files and determine how to customize or use a specific feature. In case you can't find the information you require in docs, please don't hesitate to email us at support@dotnetecommerce.com, we will be happy to help you and thank you for your feedback. .netCART has a full API support for users want to integrate it to their current store or implement the online store interface themselves and use .netCART API for database operations and server side features.

Accessing your Store Administration

In the home page, the "Administration" link, directs you to the store admin login page (For direct access: http://www.your-domain.com/StoreAdmin/Default.aspx). If you are accessing for the first time, you can enter any string as username, and password should be more than 6 characters with at least one number and one letter. This is the main store administrator account, please remember your user name and password for future login. Later you can change the password through StoreAdmin->Settings->Password tab. Only the main administrator can create other admin users through StoreAdmin->Settings->AdminUsers and view administrators' activities in StoreAdmin->Settings->ActivityLogs.

Configure Store Settings

Store admin settings section allows configuring different store settings features. Here we review those settings which are necessary for reviewing and updating before launching your own online store.

General tab: This section configures your store default currency, country and more. The tax related checkboxes are only applicable if configuring tax for one or more locations in StoreAdmin->Locations->Taxes. An encryption key is generated during installation, but you can set a new encryption key and check "Use DPAPI" check box for protecting the encryption key.

Website tab: This section configures some of the appearance and data flow of your online store. Although you can customize the pages directly or create your online store from scratch using .netCART API, for quick start you can change the store logo, link and data flow. If your store is only selling softgoods or digital files, see softgoods delivery.

You don't require all the folders and files in the bundle for your online store and customer admin, some of them are for demonstrating different .netCART features.

  • Default.htm: This file should be replaced with your custom home page. In StoreAdmin->Settings-Website, the home page can be set to another page like Displaycatalog.aspx page. If using DisplayCatalog page, it should be set as default document page as well. To highlight the menu when selecting the page, add the following code at the end of the page:

<script type="text/javascript"> $('#menu_store').addClass('current'); </script>

  • Aboutus.aspx, Contactus.aspx: The text content of these two pages should be updated manually with your companies information.
  • DisplayCatalogSamples folder: Contains the files for displaying catalog with different styles. You can replace DisplayCatalog.aspx with one of them or create your own catalog and set it in StoreAdmin->Settings-Website.
  • DotnetButtonSamples folder: Contains the files for creating buttons with different styles. If you want to change the button style of the store front, you can modify StoreButton.ascx in the root directory.
  • Templates folder: A set of skin templates for store design. Beside those 6 available skins through StoreAdmin->Settings-Website, you can use these templates to create new page or customize the current pages.

Email: If using any emails features like password recovery for customers, softgoods delivery by email, sending order's confirmation by email to the customer,... the smtp mail server setting for sending out email should be set in Settings->Email tab.

Payment: If using online credit card processing, in payment tab configure one of the gateways/processors and review PA-DSS security checklist.

Shipping: If using online shipping calculation, configure one or more real-time or custom shipping in StoreAdmin->Shipping, otherwise in StoreAdmin->Settings->Website, un-check "Shipping Calculation" checkbox and set Checkout Page to the "CheckoutNoShipping.aspx" page.


.netCART Sample Store Files:
The following is a summary of the files and folders included with the .netCART sample store. Folders or files with a [image] icon require write permissions.
The provided sample store is configured as web site project. If working with a web application project please use the following configuration steps:

For more information see Web Application Projects versus Web Site Projects

1) Copy dotnetcart.dll and your license key to the /bin directory and add dotnetcart.dll to the project references.
2) Copy App_Data, Images, Currencies, StoreAdmin, CustomerAdmin folders and any other files from the bundle's root directory to the WebApplication.
3) Copy or merge Web.config from the bundle's root directory to the WebApplication.
4) Right click on the StoreAdmin, CustomerAdmin, Currencies folders and the new added files from the root directory and Include them to the project.
5) Right click on the StoreAdmin, CustomerAdmin, Currencies folders and the new added files from the root directory and select "Convert to Web Application."

Aboutus.aspx: A sample aboutus page.
AddSkin.ascx: A user control for setting and persisting different skins.
Billing.ascx: Demonstrates the use of Payment API for accepting payment details with the add method, optionally processing a real-time transaction with the charge method and saving the completed order with the saveorderdb method.
Billing.aspx: Shows read-only displaycart user control including details of item pricing, discounts, taxes, and shipping. It also shows billing user control for accepting payment details with the add method, optionally processing a real-time transaction with the charge method and saving the completed order with the saveorderdb method.
billing.js: Used in billing.aspx page for client side validations and features.
ExpressPayment.aspx: It is used for handling callback from PayPal. It is used only if you configure PayPalPro or PayflowPro in StoreAdmin/Payment.
PayPalAdvanced.aspx: It is used for handling callback from PayPal. It is used only if you configure PayPalAdvanced StoreAdmin/Payment.
Checkout.aspx: Demonstrates the checkout process using CalculateShipping and CustomerDetails user controls.
checkout.js: Used in Checkout.aspx page for client side validations and features.
CalculateShipping.ascx: Demonstrates the use of shipping calculation and displaying the shipping options. it calculates and returns the available shipping options based on the users shipping address/item addresses.
CustomerDetails.ascx: Demonstrates the use of Customer, shipping and billing address APIs for capturing and displaying customer's information.
CustomerInvoice.ascx: Demonstrates the use of Order’s API for displaying a printable order invoice.
CustomerInvoice.aspx: Demonstrates the use of CustomerInvoice user control.
CustomerInvoicePdf.ascx: This user control creates a printable order invoice in PDF format.
Default.htm: Provides links to different sections of the sample store.
DisplayCart.ascx: Demonstrates the use of the Cart and Items API to create and display the cart contents including details of item pricing, discounts, taxes, and shipping. This user control is used in displaycart.aspx and billing.aspx page.
Breadcrumbs.ascx: This is the user control for Breadcrumb in imgnavControl.aspx page which shows the categories as Breadcrumb navigation links.
DisplayCart.aspx: Demonstrates the use of the Displaycart user control.
displayCart.js: Used in displaycart user control to provide high performance cart update using Ajax.
DisplayCatalog.ascx: Demonstrates the use of catalog API for display and navigation of categories and items as well as item addition by passing item details to the add method.
DisplayCatalog.aspx: Demonstrates the use of the Displaycatalog user control.
displayCatalog.js: Used in displayCatalog.ascx to provide high performance catalog using Ajax.
dotnetButtonHandler.aspx: It is used for displaying buttons in DisplayCatalog and DisplayCart.
dotnetLiveHelp.aspx: Demonstrates usage of .netLIVEHELP with .netCART including a chat button.
DXService.asmx: This is a web service used by .netLIVEHELP for .netCART integration. If you are not using .netLIVEHELP this file may be removed.
Footer.ascxThis is the user control for displaying footer in the pages.
Main.aspx: Validates the .NET framework version to ensure it is 2.0 or greater and loads store global settings.
Menu.ascxThis is the user control for displaying the menu in the pages.
imgnavControl.aspx: Shows a zoomed image for an item using imgnav control. It is called from DisplayCatalog.
ReviewItem.ascx: Demonstrates the use of review API to add a review to an item.
ReviewsCustomer.ascx: Demonstrates the use of review API to display all the reviews for a customer.
ReviewsItem.ascx: Demonstrates the use of review API to display all the reviews for an item.
ReviewItem.aspx: Demonstrates the use of the ReviewItem.ascx user control.
ReviewsCustomer.aspx: Demonstrates the use of the ReviewsCustomer.ascx user control.
ReviewsItem.aspx: Demonstrates the use of the ReviewsItem.ascx user control.
Search.aspx: It is used in DisplayCatalog for searching the catalog.
ShowZoomImageItem.aspx: Shows a zoomed image for an item. It is called from DisplayCatalog.
SoftGoodsDownLoad.aspx: A file handler used in conjunction with the file based softgood delivery system. This page streams softgood packages to the user from a secure non accessible (no direct downloads) location.
StoreButton.ascx: An image button user control which is used in all the pages in this directory.
global.asax: Loads .netCART application settings and saved customer's referrer's URL information to Referrers table.
Web.config: Sets the location of the data directory and password protects the /storeadmin directory.

 API_Samples: Folder Containing a collection of stand alone API sample aspx pages. API samples are intended to demonstrate in the simplest way possible the appropriate API section and are designed for developers to learn and understand the functionality exposed using .netCART.
default.aspx: Provides link to all of the API samples.
API_AdCampaignsDB.aspx: Demonstrates the usage of Ad campaigns with Referrer.SaveDB() method to provide comprehensive information detailing where sales and store visitors are coming from.See also: StoreAdmin Campaign tab and Reports/Referrer sub tab.
API_CatalogAdmin.aspx: Demonstrates the usage of catalog API for adding, updating and removing a category, item, option and choice.
API_CatalogAdminDB.aspx: Demonstrates the usage of catalog API using the database for adding, updating and removing a category, item, option and choice. See also: StoreAdmin catalog tab.
API_CatalogLoadDB.aspx: Demonstrates the usage of catalog API for loading the categories and items from database and display them. See DisplayCatalog.aspx
API_CouponDB.aspx: Demonstrates the usage of coupon API with database. See also: StoreAdmin Coupons tab.
API_Customer.aspx: Demonstrates the usage of customer and address API.
API_CustomerDB.aspx: Demonstrates the usage of customer and address API using a database. See also: StoreAdmin Customers tab.
API_CustomFieldsDB.aspx: Demonstrates the usage of adding custom fields in different tables and using custom API for database operations.
API_database.aspx: Demonstrates the usage of database settings API. See also: StoreAdmin Settings-> Database tab.
API_FraudScore.aspx: Demonstrates the usage of fraud score API. See also: StoreAdmin Settings -> FraudScore tab.
API_Image.aspx: Demonstrates the usage of image API. See also: StoreAdmin Images tab.
API_ImageDB.aspx: Demonstrates the usage of image API using Database. See also: StoreAdmin Images tab.
API_InventoryDB.aspx: Demonstrates the usage of Supplier and Stock API for creating an inventory system. See also: StoreAdmin Inventory tab.
API_ItemRelationships.aspx: Demonstrates the usage of ItemRelationships API for creating a specific relationship between 2 items. See also: StoreAdmin catalog tab, item’s details “Related/Suggested Items” sub tab.
API_Location.aspx: Demonstrates the usage of the Location API.
API_LocationDB.aspx: Demonstrates the usage of Location API with a database. See also: StoreAdmin Locations tab.
API_LocationTaxDB.aspx: Demonstrates the usage of Location and Tax API with a database. See also: StoreAdminUI Locations-> Taxes tab.
API_Mail.aspx: Demonstrates the usage of Mail API for sending email. See also: StoreAdmin Settings->Mail tab.
API_OptionAdminDB.aspx: Demonstrates the usage of Option API. See also: StoreAdmin catalog tab, item’s details “Options” sub tab.
API_Order.aspx: Demonstrates the usage of Order API.
API_OrderDB.aspx: Demonstrates the usage of Order API with a database. See also: StoreAdmin Orders tab.
API_Payment.aspx: Demonstrates the usage of Payment API. See also: StoreAdmin Payment tab.
API_QueryDB.aspx: Demonstrates the usage of Database layer API.
API_ShipCompaniesDB.aspx: Demonstrates the usage of ShipCompany API with database. See also: StoreAdmin Shipping tab.
API_Shipping.aspx: Demonstrates the usage of Shipping API for calculating shipping rates.
API_Settings.aspx: Demonstrates the usage of Store.Settings API. See also: StoreAdmin Settings tab
API_Supplier.aspx: Demonstrates the usage of Supplier and Address API.
API_SupplierDB.aspx: Demonstrates the usage of Supplier and Address API with database. See also: StoreAdmin Inventory tab.
CartHierarchy.aspx: Demonstrates the usage of Cart API for filling the shopping cart.
CartHierarchyDB.aspx: Demonstrates the usage of Cart API for filling the shopping cart using a database.
CartHierarchyDisplay.aspx: Demonstrates the usage of Cart API for displaying the populated shopping cart. It is useful to run this after one of the previous two samples.

 App_Data: Folder containing setting and database related files.
 country.data: It is used by .netCOUNTRY to get the country information based on the IP address.
 country.xml: It is used by .netCOUNTRY to convert between country codes and names.
 currencies.xml: It is used by .netCURRENCY for storing and updating currency rates.
 dotnetcart.config: The MS Access database created by default by .netCART. The product also supports working with MS SQL Server, Oracle and MySQL database backends.
 settings.config: It is used to store global application settings. This file can be updated using Store.Settings API or StoreAdmin/Settings tab.

App_Code: Folder containing GlobalStore.cs file.
GlobalStore.cs: Settings some of the application's global variables.

Styles: Folder containing styles, javascripts and images configuration files including.
ComboBox: The style and images are used in dropdown lists in the root pages.
css: Includes all the css files for store front pages.
js: Includes all the javascript files for manipulating store front style.
images: Contains static.png used for MaskInput.
colors: Includes different skins for store front pages.
demo: Includes different skins demo for store front pages.
fancybox: Includes all the images for fancy box used in DisplayCatalog.aspx.
general: Includes all the images used in store front menu.
Icons: Includes all the icons for store front pages.

bin: Contains the dotnetcart.dll assembly and license key file.

Currencies: User control that contains a dropdown list of all currencies.

CustomerAdmin: Files for the frontend customer administration interface.
AddCustomerSubMenu.ascx: User control that contains the top page tabs in all CustomerAdmin pages.
AddressBook.aspx: Displays all the addresses for a customer.
ChangePassword.aspx: Enables a customer to update their password.
CustomerAdminButton.ascx: User control that contains the buttons in the pages. This file controls the styles used for all the buttons in CustomerAdmin pages.
CustomerSettings.aspx: Allows a customer to modify their settings.
default.aspx: Customer login page.
dotnetCART_CustomerAdmin.css: Styles for different controls in CustomerAdmin pages.
EditCustomerAddress.aspx: Enables a customer to add, update or delete an address.
Logout.aspx: Logs out the customer.
newPassword.aspx: Generates a new password and send to a customer by email.
OrderDetails.aspx: Allows a customer to view / search past orders details and check on order status.
Orders.aspx: Allows a customer to view / search past orders details.
signup.aspx: Creates a new customer.
BlackIce: BlackIce styles and images for different controls.
 Calendar: Includes the styles and images used in CalendarCustomerAdmin user control.
 ComboBox: Includes the styles and images used for dropdown list in customer admin pages.
 css: Includes MainFont.css which used in most pages of customer admin.
 ImagesGrid: Includes the styles and images used for grid view in orders.aspx page.
 TabStrip: Includes the styles and images used for tabs in CustomerAdminTab.ascx user control.
 Input: Includes the styles and images used for Input control in customer admin pages.
 Images\Buttons: Includes all the buttons are used in the CustomerAdmin pages.

 Images: Includes all the images are used in the catalog.
 Buttons: Includes all the buttons are used in the store root pages.
 temp: Used for temporary files while uploading an image.

 StoreAdmin: Contains the files used for the stores backend administration.
AdminButton.ascx: This is a dotnetButton user control which is used in all StoreAdmin aspx files. If you change any design, it will effect buttons across the entire StoreAdmin.
AdCampaigns.aspx This page shows all AdCampaigns in a the Grid in the Campaign tab.
AdCampaignDetails.aspx: This page is for editing a given AdCampaign when you choose a given AdCampaign from the Campaigns tab page.
AdminTab.ascx: An user control for StoreAdmin top menu tab selection.
AdminTab.xml: This xml contains all settings for AdminTab.ascx user control
Breadcrumbs.ascx: This is the user control for Breadcrumb in EditCatalog, EditCategoryDetails and EditItem sections which shows the categories as Breadcrumb navigation links.
CalendarStoreAdmin.ascx: This user control is used in OrderDetails.aspx and OrderDetailsEdit.aspx page
Coupons.aspx: This page shows all Coupons in a the Grid in the Coupons tab.
CouponDetails.aspx: This page is for editing a given Coupon when you choose a given coupon from the Coupons tab page.
DeleteOldCreditCardData.aspx: This page is deleting credit card information from Orders and OrdersHistory.
Customers.aspx: This page shows all Customers in a Grid in the Customer tab.
CustomerDetails.aspx: This page is for editing a given Customer when you choose one from the Customers tab page.
Default.aspx: Login page for StoreAdmin.
EditCatalog.aspx: This is main page for editing Catalog when you choose the Catalog tab.
EditCategoryDetails.aspx: This page is for adding or editing a given Category.
EditCategoryImages.aspx:This page is for adding/editing images for a given Category.
EditCustomerAddress.aspx: This page is for editing addresses for a given Customer.
EditItem.aspx: This page is for adding/editing Items in the store.
EditItemCategories.aspx: This page is for assigning categories to an item in Edit Catalog.
EditItemImages.aspx:This page is for adding/editing images for a given Item
EditItemOptions.aspx: This page is for adding/editing Options/Choices for a given Item
EditItemRelated.aspx:This page is for assigning Related/Suggested Items for an Item.
EditItemTaxes.aspx:This page is for assigning Taxes for an Item.
EditSupplierAddress.aspx:This page is for editing address for a given Supplier.
FrameTop.ascx: This is user control for the top black frame in StoreAdmin.
Framebottom.ascx: This user control is for black frame for StoreAdmin, bottom section.
Images.aspx: This page is for editing Templates when you select the Images tab.
Inventory.aspx: This page is for editing Item Stock Adjustment in the Inventory tab.
InventoryReport.aspx: This page is for item inventory reporting in the Inventory tab/Report.
ItemEditorToolBar.xml: This is a setting file for the Editor Control in EditCategoryDetails.aspx and EditItem.aspx.
Locations.aspx: This is page for editing Countries/States/Provinces data in the Locations tab.
LocationsTaxes.aspx: This is page for editing Taxes for Countries/States/Provinces in Locations tab.
Logout.aspx: Logout page for StoreAdmin.
OrderDetails.aspx: Shows order details after selection an order in the Orders tab.
OrderDetailsEdit.aspx: This page is for editing order details.
Orders.aspx: Shows all Orders in Grid form, when you choose the Orders tab.
Payment.aspx: This page is for editing all payment settings when you choose the Payment tab.
Payment.js: Used in payment.aspx.
Reports.aspx: Shows Dashboard Reports when you select the Reports tab.
ReportPdf.aspx: It is called in Reports.aspx page for hosting ReportPdf user control for creating PDF report..
ReportPdf.ascx: This is the user control for creating PDF sales report with embeded chart.
ReportsCustom.aspx: Shows Custom Reports when you choose the Reports tab, Custom subtab.
ReportsHistoricalSales.aspx: Shows historical sales Report when you choose the Reports tab, Historical Sales subtab.
ReportsProfit.aspx: Shows items and customers profit Reports when you choose the Reports tab, Profit subtab.
ReportsReferrer.aspx: Shows Referrer Reports when you choose the Reports tab, Referrer subtab.
ReviewsItem.aspx: Shows all the new reviews and allows the administrator to review them and change the status.
SettingActivityLogs.aspx: This is for displaying activity logs in the Setting/ctivityLogs subtab.
SettingAdminUsers.aspx: This is for ceating multiple admin users by the master admin account in the Setting/AdminUsers.
SettingsDatabase.aspx: This is for configuring the database settings in the Settings/Database subtab.
SettingsEmail.aspx: This is for setting the Email configuration in the Settings/Email subtab.
SettingsFraudScore.aspx: This is for setting FraudScrore configuration in the Settings/FraudScore subtab.
SettingPassword.aspx: This is for changing the password in the Setting/Password subtab.
SettingLanguage.aspx: This is for customizing strings or creating a new resource for a language in the Settings->Language subtab.
SettingLanguageAdd.aspx: This is for adding a new string name/value to an existing resource.
SettingLanguageSeach.aspx: This is for searching a string key or value in a language.
Settings.aspx: This is for general settings in the Settings/General subtab.
Shipping.aspx: This page is for Real Time Shipping settings in the Shipping tab.
ShippingCustom.aspx: This page is for Custom Shipping settings in the Shipping tab.
imgnavControl.aspx: Shows a zoomed image for an item using imgnav control. It is called from EditCatalog.aspx.
SupplierDetails.aspx: This page is for editing Supplier details when you choose a supplier from the Inventory/Supplier subtab.
Suppliers.aspx: This page is for showing the Supplier list as grid when you choose the Inventrory/Suppllier subtab.
SupplierOrder.aspx: This page is for adding or editing an order item to a supplier when you click a new order or edit an order item from Inventrory/Order Items subtab.
SupplierOrders.aspx: This page is for showing the orders items list as grid when you choose the Inventrory/Order Items subtab.
TreeCatalog.aspx: This page is for moving items to another category or changing the items' order in a category.
TreeCatalog2.aspx: This page shows a second tree catalog to make moving items in a large catalog easier.
XmlFromFileSystem.aspx: This file is used in for Editor Control
Images: temporary images for .netBUTTON will be created here.
 Locations: User control used in OrderDetails.aspx page
 ColorPicker: ColorPicker used for EditCategoryImages.aspx, EditItemImages.aspx, and Images.aspx pages.
 Temp: Folder used for chart images from the store administration's reporting section.
 BlackIce: This folder contain css, images, User controls and javascripts which are used in Controls.
 Calendar : Contains css and Images for Calendar control: Orders.aspx, CouponsDetails.aspx, and ReportCustom.aspx
 css: Folder containing the css used for the text and labels.
 CustomShippingGrid: css,images used in Shipping.aspx
 Dialog: Dialog control used in EditCategories.aspx, EditItemImages.aspx
 Editor: Contains all images,css,user controls for Editor control used in EditItem.aspx, EditCategoryDetails.aspx
 images: Uses static.png in OrderDetailsEdit.aspx, login.aspx, dotnetCART_input.css
 ImagesGrid: css and images for grid control, Used in Coupons.aspx, Customers.aspx, EditCategoryImages.aspx, EditItemCategories.aspx, EditItemImages.aspx, EditItemRelated.aspx, EditItemSubItems.aspx, EditItemTaxes.aspx, LocationsTaxes.aspx, OrderDetailsEdit.aspx, Orders.aspx, ShippingCustom.aspx, and Suppliers.aspx.
 Input: Contains dotnetCART_input.css which is used in the following files: EditCategoryImages.aspx, EditCustomerAddress.aspx, EditItemCategories.aspx, EditItemImages.aspx, EditItemOptions.aspx, EditItemRelated.aspx, EditItemSubItems.aspx, EditItemTaxes.aspx, EditSupplierAddress.aspx, Images.aspx, Inventory.aspx, Locations.aspx, LocationsTaxes.aspx, OrderDetailsEdit.aspx, Payment.aspx, SettingDatabase.aspx, SettingEmail.aspx, SettingFraudScore.aspx, Settings.aspx, Shipping.aspx, and SupplierDetails.aspx.
 j s: Contains javascript functions including text fade out.
 menu: Contains all css and images for Menu control.
 multipage_tabstrip: Contains all css and images for Tabsrip control.
 Snap: Contains all css and images for Snap control.
 SpinnerButton: Images used in CouponDetails.aspx page
ReportCustom: css and images used in ReportsCustom.aspx
 TabStrip: Contains all css and images for TabStrip control.
 Tree: Contains all css and images for Tree control.
 Upload: Contains all css and images for Upload control.
 ColorPicker: Used in EditCategoryImages.aspx, EditItemImages.aspx, Images.aspx pages in Admin UI

DisplayCatalogSamples: Contains the files for displaying catalog with different styles.
AddItems.aspx: Demonstrates different ways for adding items to cart for custom integration.

GridView: Using Grid view control for displaying the catalog.
Images : The images for grid view and location for temporary images for .netButton control.
Default.aspx: The main page for displayCatalog.
StoreButton.ascx: The .netButton user control which used in the user control.
GridView.ascx: The GridView user control which used in the main page.
GridViewStyle.css: css type for GridView control.
DisplayCatalogGridView.js: Contains javascript functions for GridView control.

MenuBlackIce: Using Tree control for displaying the catalog.
Images : The images for menu and location for temporary images for .netButton control.
Default.aspx: The main page for displayCatalog.
StoreButton.ascx: The .netButton user control which used in the main page.
Menu.ascx: The Menu user control which used in the main page.
MenuStyle.css: css type for Menu control.

Rotator: Using Rotator user control for displaying some items.
Default.aspx: The link page for the rotation controls.
CatalogScroller.aspx: The page for using rotator scroller .
CatalogSlideshow.aspx: The page for using rotator slideshow.
Rotator_UC.ascx: The rotator user control which is used in apsx pages.
Rotator_UC.css: css type for GridView control.

TreeBlackIce: Using Tree control for displaying the catalog.
Images : The images for tree and location for temporary images for .netButton control.
Default.aspx: The main page for displayCatalog.
StoreButton.ascx: The .netButton user control which used in the main page.
Tree.ascx: The Tree user control which used in the main page.
TreeStyle.css: css type for Tree control.

DotnetButtonSamples: Contains the files for creating buttons with different styles.
Default.htm: Links to all the samples.
Samples: Contains all the samples.
 Images: The location for the generated images for .netButton control.
DynamicButtons.aspx: Shows dynamic button generation with input as button text, font, size, shape and style.
JavascriptSample.aspx: Shows Javascript usage.
SampleFilenames.aspx: Shows file name usage..
SimpleUsage.aspx: Shows a more typically usage case.
StyleSample.aspx: Shows hundreds of buttons on a single aspx page is not typical and some browser may take some time to render this sample.

ItemControls: Provides different user controls for displaying items
Default.aspx: The main page for displaying the item user controls.
CustomersAlsoBought.ascx: The CustomersAlsoBought user control displays the items other customers bought related to the items in the customer's cart.
CustomersAlsoBought.css: css type for CustomersAlsoBought control.
MiniCart.ascx: The MiniCart user control displays the items in the customer's cart for quick preview.
MiniCart.css: css type for MiniCart control.
MiniCartLink.ascx: A user control displays the total number of items in the cart, total amount and a link to checkout. If there is no item in the cart, shows a link to the catalog.
MiniCartLink.css: css type for MiniCartLink control.
RelatedItems.ascx: The RelatedItems user control displays the items related to the items in the customer's cart.
RelatedItems.css: css type for RelatedItems control.
SuggestedItems.ascx: The SuggestedItems user control displays suggested items related to the items in the customer's cart.
SuggestedItems.css: css type for SuggestedItems control.

Templates: A set of skin templates for store design.


Database Creation and Configuration:

.netCART supports a number of database backends including MS SQL server, MS Access, MySQL and Oracle. For all databases, on first connection .netCART will create the database tables and fields. If the sample data checkbox is enabled in the database settings, the tables will also be populated with some sample data. To create a database, full db permissions are required. This may be restricted later once the database is created.

MS Access:
No special steps are required. This is the default case and on first request, an Access database will be created in the App_Data directory. If you are working on a 64bit OS, MS access (JET) is not supported. In that case, you will need to access the storeadmin and provide valid database settings under settings, database for an alternate database type. The database will be created in the App_Data folder as dotnetcart.config. IIS does not allow web users to download files from App_Data nor can .config files be downloaded; however, you may also use a path outside of your web root to store the database for enhanced security. In this way, the file would not be web accessible at all. This file is a regular MS Access database which can be opened with MS Access however we do not recommend directly modifying the database, instead use the provided .netCART API.

MS SQL Server:
1) Login to your database server
2) Create a new database such as dotnetcart
3) Create a new user such as cartuser or select an existing user and assign them permissions (db_owner) on the dotnetcart database
4) go to Settings /database tab in Admin UI in Cart and enter

Server name/IP: "MachineName\SQLEXPRESS" or the server IP such as "255.24.22.52" for remote.
Login: cartuser (the actual username from step 3)
Password: 39j3nsd8 (the actual password for the user you granted permissions in step 3)
Database: dotnetcart

First click on "Check Connection" button, if you see "Database connection is correct" then proceed and click on "Update" button.

5) For enhanced security, please ensure you modify the permissions for the cartuser from db_owner to db_datareader and db_datawriter after your database is created.

Oracle:
Oracle 10g Express:
1) Go to database home page and login as the "system" user.
2) Choose Administration Icon and go to Manage database users
3) Create an user e.g. "cartuser" enabling the checkbox for "Connect and Resource".

In the Cart web administration:
1) Select the settings/database tab.
2) Select Oracle and enter Server Name, Login, password, service name(i.e: xe), port number and database. The default port number is 1521.

3) First click on the "Check Connection" button, if you see "Database connection is correct" then proceed and click on the "Update" button.

If you are testing with Oracle which is installed in on your local system, you do not need to enter values for Server name or Service Name.

MySQL:
Here are the steps for configuring MySql server with .netCART.

1) Login to MySql Administrator and create an empty database e.g. "dotnetcart"
2) Create a user and assign Select, Insert, Update, Delete, Create and Drop privileges to the database for the new user.
3) go to Settings /database tab in the store administration for .netCART and enter your valid details for

Server name/IP: the server name or IP address of the SQL server instance. If this is for local testing it may be "localhost" value should be entered without quotes.
Login: cartuser (the actual use you created and assigned in step 2)
Password: the password you selected for the user
Database: dotnetcart

First click on the "Check Connection" button, if you see "Database connection is correct" then proceed and click on the "Update" button.


Guidelines for securely using the .netCHARGE add-on with .netCART

1. Do not retain full magnetic stripe or CVV2 data: The application should not store the full contents of any track from the magnetic stripe (on the back of a card, in a chip, etc.) or CVV2 data. .netCART does not store this information by default. If your application uses a modified codebase, you must ensure that your code also does not store this sensitive authentication data.

2. Protect stored data: Protect numbers by masking account numbers when displayed (the first six and last four digits are the maximum number of digits to be displayed) except those employees and other parties with a specific need to see full credit card numbers. Encryption key is stored in the settings.config by default and for PA-DSS compliance you should utilize the Data Protection API (DPAPI) feature of .netCART from the store settings to further secure this value.

3. Provide secure password features: .netCART requires a unique username and complex password for all administrative access and access to cardholder data. These controls are applicable for POS (point-of-sale) access by employees with administrative capabilities, or for server access controlled by the application.
Access to PCs, servers, and databases with payment applications should require a unique username and complex password. No shared accounts or passwords, passwords should be changed every 90 days, password length of at least 7 characters long, passwords with both numeric and alphabetic characters, special characters are accepted, password history is maintained, etc. In addition to authentication credentials the encryption key string should be set to a complex value following similar rule sets to your password.

4. Log application activity: The application will automatically log all access by individual users to any credit card data. These logs can be found in the ActivityLogs table.

5. Develop secure applications: Your own code and customization should be based on industry best practices and include information security throughout the software development life cycle. The application should be based on secure coding guidelines such as the Open Web Application Security Project guidelines. Review custom application code to identify coding vulnerabilities. See www.owasp.org—"The Ten Most Critical Web Application Security Vulnerabilities." Cover prevention of common coding vulnerabilities in software development processes, to include:
· Invalidated input.
· Broken access control (e.g., malicious use of user IDs).
· Broken authentication and session management (use of account credentials and session cookies).
· Cross-site scripting (XSS) attacks.
· Buffer overflows.
· Injection flaws (e.g., SQL injection).
· Improper error handling
· Insecure storage
· Insecure configuration management.

6. Protect wireless transmissions: If wireless technology is used within the payment environment, it should be implemented securely.

7. Test applications to address vulnerabilities: Software developers should establish a process to identify newly discovered security vulnerabilities (e.g., subscribe to alert services freely available on the Internet), test their applications for vulnerabilities, and for timely development and deployment of security patches and upgrades. Updates and patches should be delivered in a secure manner with a known chain-of-trust. Any underlying software or systems that are provided along with the payment application (e.g. web servers) should be included in this process.

8. Facilitate secure network implementation: The payment application should be able to be implemented into a secure network environment. Application should not interfere with use of network address translation (NAT), port address translation (PAT), traffic filtering network devices, anti-virus protection, patch or update installation, or use of encryption.

9. Cardholder data must never be stored on a server connected to the Internet: The payment application should not require that the database server and web server be on the same server, or in the DMZ with the web server. We suggest to use a remote database such as MS SQL server, MySQL or Oracle. You could also store the access database outside of your web root or on another server through a network share or on a NAS.

10. Facilitate secure remote software updates: If software updates are delivered via remote access into customers' systems, software vendors should tell customers to turn on modem only when needed for downloads from vendor, and to turn off immediately after download completes. Alternatively, if delivered via VPN or other high-speed connection, software vendors should advise customers to properly configure a personal firewall product to secure "always-on" connections.

11. Facilitate secure remote access to application: If employees, administrators, or vendors can access the application remotely, access should be authenticated using a 2-factor authentication mechanism. The application should allow for technologies such as RADIUS or TACACS with tokens, or VPN with individual certificates.

12. Encrypt sensitive traffic over public networks: Use strong cryptography and encryption techniques (at least 128 bit) such as Secure Sockets Layer (SSL), Point-to-Point Tunneling Protocol (PPTP), or Internet Protocol Security (IPSEC) to safeguard sensitive cardholder data during transmission over public networks. The application should never send cardholder information via unencrypted e-mail. ..netCART with the integrated .netCHARGE functionality for payment processing handles security between the server and gateway or processor. You must secure the acquisition of data from the client browser to the server through SSL.


StoreAdmin Catalog

Catalog

The catalog admin provides a web based interface to manage items and categories within your store. Unique to .netCART, the interface mirrors the interface provided to regular visitors to your store. If you can browse a store you can build a store with .netCART!

When you first select the catalog administration option you will be presented with a list of the highest level categories and items similar to the view you would have when browsing your store. The main different is the additional buttons in edit mode where you can edit, delete and add items and categories.

When editing items or category descriptions with IE5.5 or greater .netCART will render a browser based HTML editor that will allow you to format HTML and copy and paste from other html editors without reformatting.

The edit catalog provides advanced options for item and category addition including automated image generation and resizing based on the settings in images.

For each item you can define item level details, images, options with choices, categories, taxes, related/suggested items and subItems.

For each category you can define details and images.

You can generates an image variations for an item or category based on the image templates in Images tab.

Custom fields are supported for both categories and items. See Custom Fields

Reviews sub tab allows to change the status of reviews. By default when a review is added by a customer, the status is set to New and it doesn't show to public. Only the reviews with "Public" status are displayed in store front.


Orders

The orders administration provides a paged listing of all orders. You can filter/ search on a number of criteria including status, orderID, referenceID company, first name, last name, customer id, username, email and date range selection which is provided through the use of a popup calendar. Orders can be sorted by clicking on the column header.

Order id link for any given order drill down to the complete order information. On the order details page you can modify the order status and update shipping and some payment details. Selecting delete from status dropdown only changes the order status to "Deleted" without deleting the actual order from database. By clicking the edit button, you can update the order other information including customer and payment details, billing and shipping address and items. By clicking the "Delete" button, you can delet the order from database. The deleted orders from database, still exist in OrdersHistory and history associated tables.


Locations

Locations admin allows you to add, edit and delete country and state/province entries used within your store. When you modify the data in this administration system it will affect the country and state/province listings in all pages like checkout in the bundle.

Taxes

For any given country, state/province or zip code any number of taxes can be defined. If a match is made based on the billing address of the customers country, state/province and/or zip code the selected tax will be applied.
Any country, state/province or zip can have one or more tax definitions. You can also enter item level tax overrides when adding an item through the catalog. To override a tax in the item level, the tax must already exist in a location.
Taxes can be set as a default (in that they will apply by default to an item) and as included (where the tax is already included in the item price and back calculated for summary only)

For custom field, the same entries apply. Make sure the custom field is already added to address table or address object.
1-Add new entry for new type to LocationTypes. e.g. Name: county Source:BillAddress.County
2-Add one or more entries to Locations table TypeID: 4 Name: Orange Parent: 247 (ID for California),Code: Orange (TypeID, Code and Parent are mandatory)
3-Add a tax for Orange county to Taxes table: LocationID: 481 (ID of Orange in Locations table), Name: Sales Tax Orange (this name can be anything as you want), Rate: 7.5%

If you want to import the large number of tax rates from another data source like Excel to .netCART database, please contact support@dotnetecommerce.com .


Settings

General: It provides an interface for general store settings like encryption key, default currency, country, state/province and more.

Website: In this section, you can customize the look and data flow of the store front and customer admin. Read more here.

Database: In this section, you can configure the database back ends including MS SQL server, MS Access, MySQL and Oracle. For all databases, on first connection .netCART will create the database tables and fields. If the sample data checkbox is enabled in the database settings, the tables will also be populated with some sample data. To create a database, full db permissions are required. This may be restricted later once the database is created. After updating database setting, first click on the "Check Connection" button, if you see "Database connection is correct" then proceed and click on the "Update" button. For more information about setting each database type, see database setting.

Email: In this section, you can configure SMTP mail which enabling easy and automated receipt and invoice generation, password resets and more.

FraudScore: It allows to set formulas or values to control all aspects of the system to ensure the most effective FraudScore calculation. The FraudScore system works most effectively with minimal validation at the store level. Analysis is performed on the input data and, using characteristics common to fraudulent orders, scores are assigned for a number of unique factors. The FraudScore is cumulative and it is expected that every order will have at least a minimal score. With your ecommerce implementation you can control the score thresholds which you take action on. For example, for scores of less than 500 you may choose to process the order as usual with real-time delivery. At scores between 500-1000 you may have more stringent rules on payment processing, on scores over 1000 you may elect to defer real-time delivery so that a human can review the order before shipment. Or, on higher scores perhaps you would like to send an automated a credit card faxback authorization form or email confirmation validation request. Read more here.

Password: Reset your current password for store admin login.

Language: In this section, all text values used by the bundle can be customized. After apply a new language file, a new file for the language is created in App_Data folder. e.g. dotnetCARTstrings.en-US.resx All the available language files are added automatically to the language listing in checkout and customer admin and signup pages and customers can select one of the available languages. Write permissions are required for the asp.net web user on the /images/buttons folders in order for dynamic buttons to be created for the new language settings. Through the "Add New String" button, a new name/value string can be added to a resource file, then use Strings.GetString(name) method to get the value in your code.

AdminUsers: The main admin (first created admin user) can creates other admin users. They have the same access to the store admin except they can not access to "AdminUsers" and "ActivityLogs" sections.

ActivityLogs: Displays a list of all the admin users activities. You can log more activities by using ActivityLog API.


Settings

General: It provide an interface for general store settings:

Encryption Key: It is used to encrypt and decrypt cart.ID in the cookie, credit card number in the database, database connection string, mail server name and SMTP password in the settings.config file. Using DPAPI, protects the encryption key. If moving the application to another system and using DPAPI feature, the same EncryptionKey should be set in Settings-> General -> Encryption Key and apply the save button. In some cases, the same database settings should be set and apply the save button.

Authorized Server: Controls which addresses the Cart.Add method will accept information from and prevents remote posts from entering cart data with altered pricing or any other data. This accepts a comma delimited list of URL's which the add method will work on.

Image Folder: The related path for store images.

Admin Image Folder: The related path for the StoreAdmin images.

Adjust Rate: The store level adjust rate can be set as a dollar amount or percentage based on dollar or quantity ranges. $1-100=-10%;$101-=-20%;

Base Currency: The base currency used for the store. If the update value greater than 0, then the rates are updated from Oanda site.

Default Country: The default country selected for the countries control. It is used in checkout and customer's address page to set the default country. If you check default by visitor IP or phone, it is set dynamically by IP, then by customer's phone number.

Default State/Province: The default state or province for the country. If there is no state/province associate with the country, an empty textbox is displayed.

Time Zone Adjustment: It is used in orders section for adjusting the time for the order and its shipping.

Carry Over Gift Certificate: It is automatically updated the gift certificate amount if it is not used in a single purchase. Create gift certificate in 'Coupons' tab."

Apply tax after adjust: Determines whether to apply tax after Cart.Adjust or before it in Cart.Calculate method.

Apply tax after coupon: Determines whether to apply tax after Cart.TotalCoupon or before it in Cart.Calculate method.

Apply tax after shipping: Determines whether to apply tax after Cart.TotalShipping or before it in Cart.Calculate method.


Settings Website

Website: In this section, you can customize the look and data flow of the store front. In case of a customization requirement which is not supported through the web admin interface, you can see the Store Files and How to ... sections to review the bundle files and learn how to customize or use a specific feature. In case you can't find a solution in the docs, please don't hesitate to email us at support@dotnetecommerce.com,

Store Address: It is used in CustomerInvoice.

Store Name: It is used in menu.ascx user control for the image tooltip. The menu user control is being used in all the store front and customer admin pages.

Store Logo: It is used in menu.ascx user control for displaying the store logo in the top-left of the store. If setting to a logo larger than 272 X 92 pixels, you will also need to modify Styles\css\default.css file. The menu user control is being used in all the store front and customer admin pages.

Store Link: The URL link which is used in store logo image.

Home Page: The store default page. It is usually the first page customers view in your store web site, it can be the same as DisplayCatalog page as well.

DisplayCatalog Page: The store frontend catalog. Beside Displaycatalog.aspx page, there are other catalog samples in DisplayCatalogSamples folder as well.

DisplayCart Page: It is the page for showing the customer's items in his/her shopping cart.

DisplayCart Header: Controls the columns and orders of DisplayCart.

DisplayCart Footer: It Controls the footer rows and orders of the DisplayCard Footer.

Checkout Page: It is the page for entering customer's information or login for existing customers and calculated and selecting the shipping options.

Billing Page: It is the page for final order review and making the payment.

Customer Invoice Page: It is the page for the order confirmation and customer's invoice.

Store Logo: It is used in customer invoice pdf file for displaying the store logo in the top-left of the invoice. If setting to a logo other than 498 X 102 pixels, you may need to modify CustomerInvoicePdf user control.

ImgNav Control Page: ImgNav control is useful for large images for multiple zoom levels. This page is used for showing imgNav control when clicking on an item's image with imgnav control enabled. To enable ImgNav control for an item, include "imgnav" in the image's name (e.g. MountainCity_ZoomImage_imgnav ).

Show in Popup Window: Determines whether to show the ImgNav control in a popup window or not.

Store Skin: Provides different skins for store front and customer admin. You can create other skins manually by modifying the pages and css files or use these templates to create new page or customize the current pages.

Softgoods Options: It provides 2 options for digital items delivery: attaching to an email or sending a link by email to the customer for download. See Softgood Delivery.

Catalog Page Size: The Number of items in each catalog page.

Maximum Review Rating: The maximum review rating. Defaults to 5.

Stock Checking: Determines whether to check the item's stock before adding the item to cart, while completing the order and adjusting the item's stock after order completion. If using this feature, set the stock property for all the items through StoreAdmin->Catalog->Item Details.

Shipping Address: Determines whether to show the shipping address option in display cart, checkout and billing pages or not.

Shipping Calculation: Determines whether to show the calculation shipping option in checkout pages or not.

Multi Items Add to Cart: Determines whether to allow adding multiple items at once to the shopping cart or not.

Allow Item Review Without Login: Determines whether to allow submitting a review without login or not.

Allow Item Review Auto Publish: Determines whether to publish a customer review without administrative review or not.

Show Item Review Link: Determines whether to show an item review link in catalog or not.

Show Display Card Header: Determines whether to show DisplayCard header or not.

Show Display Card Footer: Determines whether to show DisplayCard footer or not.


Email

Email: In this section, you can configure SMTP mail which enabling easy and automated receipt and invoice generation (see billing.aspx.cs/vb in the bundle), customer password resets (see CustomerAdmin/NewPassword.aspx.cs/vb) and more.

Sender Name: Name for outgoing emails.

Sender Address: Email address for outgoing emails.

SMTP Server: SMTP mail server address. e.g. "smtp.mydomain.com"

SMTP User Name: User name for SMTP authentication.

SMTP Password: Password for SMTP authentication.

SMTP Port: If you are using a non standard port you can set this. Defaults to 25.

Server Requires SSL: Determines whether to use SSL for connecting to the mail server or not.

Body Format: Determines whether to use HTML or Text for sending email.

Time Zone Adjustment: Adjusts the email time. It can be set in case mail server is different than web server for timing.


FraudScore

FraudScore: It allows setting formulas or values to control all aspects of the system to ensure the most effective FraudScore calculation. The FraudScore system works most effectively with minimal validation at the store level. Analysis is performed on the input data and, using characteristics common to fraudulent orders, scores are assigned for a number of unique factors. The FraudScore is cumulative and it is expected that every order will have at least a minimal score. With your ecommerce implementation you can control the score thresholds which you take action on. For example, for scores of less than 500 you may choose to process the order as usual with real-time delivery. At scores between 500-1000 you may have more stringent rules on payment processing, on scores over 1000 you may elect to defer real-time delivery so that a human can review the order before shipment. Or, on higher scores perhaps you would like to send an automated a credit card faxback authorization form or email confirmation validation request.

Quantity: This fraud score is a ranged formula which assigns a specific score based on the total quantity of items in the cart. In many stores order over a given quantity are unheard of and this property allows you to reflect this rarity as part of the overall fraud score. e.g. "1-2=1;3-13=90;14-=1000"

Amount: This fraud score is a ranged formula which assigns a specific score based on the total dollar amount of all items in the cart. In many stores orders over a given dollar value are unheard of and this property allows you to reflect this rarity as part of the overall fraud score. e.g. "1-2=1;3-13=90;14-=1000"

Vowel Consonant: Within any given language there is an expected ration of vowels to consonants. This property examines customer's information and assigns the appropriate score based on the ranged percentage formula. e.g. "0-5=100;6-20=70;21-30=10;41-50=100;51-=200"

Letter Repeats: This property accepts a ranged formula for the score to be added based on percentage of letter repeats. Valid input would typically have a minimal repeats. Above a certain range invalid data is a certainty.
e.g. "2-10=10;11-20=17;21-=30"

Duplicate Inputs: This property assigns a score based on duplicate inputs, that is inputs that are the same across separate input fields. The likelyhood that the address would be the same as the telephone number is extremely low as such the fraud score system can be set to treat such cases appropriately. e.g. "1-1=10;2-20=17;21-=30"

Home Row: This analysis examines the total number of home row characters used as a percentage of total inputs. A high percentage of home row characters typically indicates that the input is fraudulent. e.g. "0-=10;11-20=17;21-=30"

Symbols: This property examines the total number of symbols (non alpha-numeric) characters used as a percentage of total inputs. A high percentage of symbols typically indicates that the input is fraudulent.

Item Combinations: For many ecommerce implementations certain item combinations or high profile items are rarely ordered. You may wish to assign such items or combinations a high fraud score to ensure human processing. This is particularly true for softgood delivery. If you sell a number of softgood packages and your total number of unique items is low a combination of 1 of every package almost certainly indicates fraud. Also, if you have multiple version of a product it may be highly unlikely that they would be ordered in combination within 1 order. This property can be used to assign an appropriate fraud score addition for such cases.
e.g. "d1=10;d1,d2=17"

Address: The score defined for this property is added if the address appears invalid. It is expected that an address will contain both letters and numbers and not be less than 10 characters in length.

Free Mail: A fixed score is added per unique email address in the order that is from a free email provider such as hotmail.com. Typically fraudulent orders originate from free email accounts.

Valid Mail: A fixed score is added if the email address provided is not valid. Validity is determined through a syntactical check of the address provided.

Billing Same as Shipping: It has been found that orders using the same address for billing and shipping are less prone to being fraudulent. For this reason this score is added if the billing and shipping addresses differ.

Name on Card Match: A fixed score is added if the first or last name of the billing address do not match the name on the credit card. For example, if the fixed value is defined as 100 and both FirstName and LastName are located within the NameOnCard the score is not increased. If FirstName is not found, score is incremented by the fixed value and if both FirstName and LastName are not found, it is incremented by twice the fixed value.

IP Country: Using the built in .netCOUNTRY support the fraud score system is able to determine, with 90+% accuracy, the location of the visitor based on their IP address. This score is added if the BillAddress.Country or ShipAddress.Country does not matches the IP country. If both are not matched, the fraud score value is incremented by twice of the fixed value.

Browser Country: Using the built in .netCOUNTRY support the fraud score system is able to determine the country based on the users culture configuration in their web browser. If this does not match the country provided the score is added.

Anonymous Proxy: Using the built in .netCOUNTRY support the fraud score system is able to determine if the IP address is from one of many documented anonymous proxy systems. In such a case the web user is specifically attempting to mask their identity and fraud is highly likely. The score defined for this property is added in such a case.

Credit Card Number Attempt: A fixed score is added each time a credit card is rejected and a new credit card number is applied.

Credit Card Expiry Attempt: A fixed score is added each time a credit card is rejected and a new credit card expiry is applied.

Credit Card Code (CVV2) Attempt: A fixed score is added each time a credit card is rejected and a new credit card security code is applied.


Image Templates

The image template settings for the store. .netCART includes unique image generation functionality which allows you to upload a single image and have different images, each with their own unique settings, be generated.

Each image template has the following settings:

Name: A unique string which is used in item or category image section for generating new image with this template settings.
 Format: Determines the image format: png, jpg, gif and bmp Defaults to jpg.
Width/Height: The width and height of the generated image in pixels.
Quality: The image quality setting out of 100. The higher the quality the better the image looks and the larger the file size.
Border: Controls and optional border around the image in pixels with any color.
Padding: The padding is outside the border, often used as an image spacer. Padding can be set to a size in pixels and any color.
Expand / Crop / Scale with x background color: These options control how the image is created from the original. When expand to full size is selected it means that the image will be put into the new image size selected with the best possible fit. If the original image proportions do not match the new image proportions the image will display with a background color as defined. When crop to full size is selected it will do a best fit crop so that the image takes up the full frame regardless if the dimensions match or not (assuming there is enough image to fill the newly selected size). Scale proportionally by width / height means that only 1 dimension is examined for the scaling. If setting by height the image height will always remain constant but the width can change based on the image proportions. When scaling by width the width remains constant but the height will change depending on the proportions.
Auto Generate for: Determines whether to select this template when generating images for an item or category in the item or category image section.

Note: the image size defined with width / height is the final image size including border / padding. For example if you select 100X100 your final image will be 100X100 if you have no border / padding. If you set a border of 1 pixel your final image will still be 100X100, the image size will shrink to show 99X99 with a 1 pixel border. This ensures that the image size you select will always be the image size you get!


Payment Settings

Payment

NEW: For Authorize.NET and Stripe gateways, If setting the Public Key all credit card information is sent to the gateway server from the client browser in a secure way without having the information touch your server, then internally using the token returned by the gateway server to process and charge payments. This method complies with the Payment Card Industry Data Security Standards (PCI DSS).

Supports multiple payment methods including PayPal, PayPalExpress and Amazon. Therefore, you can configure one gateway/processor for the payment by credit card and PayPal and Amazon as other methods of payment. They are automatically added to the payment dropdown in billing page.

Gateway / Processor: There is a full description for each gateway/processor after it is selected from the list. You can see a complete list with their sites here.

Accepted Card Types: A thumbnail of the accepted cards are displayed in the billing page when selecting credit card payment. The card number is validated and only allow the accepted card types.


Inventory

Provides necessary tools for managing and controlling items inventory.

Order Items: Displays a list of all the items have been ordered to their suppliers. The list can be sort, filtered and searched for delivery status, date range and supplier. Each order has a link to the item, supplier and editing the order. The top-right "New Order" button allows you to make an order for an item to its supplier. In the new order page, the items list shows all the items with their stocks in the parentheses. The supplier for an item is automatically displayed after selecting an item from the items list. An item supplier can be changed in item details page. When the delivery date is set and saved to database, the item's stock is updated and a new StockTransaction record inserted to StockTransactions table.

Suppliers: Displays a list of all the suppliers. The list can be sort clicking on the header columns. It also allows to add a new supplier, edit or delete an existing supplier.

Report: Displays a list of all items with stock and supplier information. The list can be filtered to show only ReOrder items for all or only one supplier. ReOrder value indicates when the item should be ordered and it can be set in the item detail page.

Stock Adjustment: It allows to add or remove the stock for an item manually.


Customers

The customers administration provides an interface to edit and search on customer details. From the customer listing you can jump to edit customer and address specifics or jump to orders with a specific listing of that customers orders.
Customers can be sorted by clicking on the column header.


Coupons Configuration

Coupons

The coupons administration provides an interface to add, edit or delete coupon or gift certification. From the coupon listing you can jump to edit a coupon.
Coupons enable conditional adjustments for the cart with their own line item in displaycart. Coupons can adjust the price of a cart and be used multiple times or for single use. Quotas can be maintained to limit coupon use and the system can also be used for gift certificates which are in effect a special type of one time use coupon

Type: When selecting gift certificate, it only accepts a positive number. Each gift certificate can only used one time, therefore, quota is not applicable. There is a 'Carry Over Gift Certificate Balances' option in storeAdmin->Setting, when it is checked, the remaining balance of the certificate stored in the Coupons table when saving the order (calling SaveOrderDB) and the customer can use the remainder of the gift certificate the next time they shop.

Code: The code should be a unique string, and this is the value the site visitor must enter to redeem the coupon.
Name: The coupons name, this is used for the line item information in displaycart.
Start Date: The start date that the coupon can be can be used.
End Date: The expiry date of the coupon.
Quota: Number of available coupons. If Quota is not set, an unlimited number maybe redeem.
Adjust Rate: It can be set as a dollar amount or percentage based on dollar or quantity ranges.
Examples:

  • Different discounts based on the purchase value: "$1-100=-10%;$101-200=-20%;$201-=-30%;"
  • %10 discount for 1 to 10 items, %20 discount for 20 or more items: "1-10=-10%;11-=-20%;"
  • $10 discount for 5 to 10 items, $20 discount for 20 or more items: "5-10=10;11-=20;"
  • 10% discount with any purchase of $100 or more: "100-=%10;"
  • $10 discount with any purchase of $100 or more: "100-=10;"

Comments: A comment for the coupon.
Items: The list of the items that the coupon doesn't apply to those items or only applies to them.


Shipping

Shipping allows you to configure both algorithm based custom (non real-time) shipping and real-time shipping options through the .netSHIP add-on.

Real-time shipping
On the real-time shipping tab you can define origin shipping address which is used when calculating rating. The origin information from your store along with the destination shipping address from your customer is passed to determine the rating for a given order. .netCART also supports grouping and rating multiple packages from a single order sent to more than one address.

Each process can be enabled or disabled with a checkbox on the real-time shipping tab. In addition, there are a number of settings specific to each shipping company required before rating can be performed.

Limit Rate: Accepts a comma delimited list of rate names. Only rate names listed here will be returned if this is set. The rate name from the rates collection is what needs to be specified in this string. For a list of rate names run a rating without setting this and then set Limit Rate to any rate names returned that you wish to be included. The rate names are not case sensitive for use with this property and can be set with or with the company name prefix. By default this property is not set and all available rates are returned.
Exclude Rate: Accepts a comma delimited list of rate names. Any rate names listed here will be excluded from the return if this is set. The Limit Rate has the opposite functionality and can be used instead of this to control the returned rates. The rate name from the rates collection is what needs to be specified. For a list of rate names run rate without setting this property and then set this property to any rate names returned that you wish to be excluded. By default this property is not set and all available rates are returned.
 Adjust Rates: Adjusts all returned rates by the specified rate (fixed amount or %: e.g. "10%" or "1.25" or "-5%"
Rate Backup: If real-time rating fails for any reason (network outage etc) then the specified backup ship company services are applied as defined in custom shipping rates.
 Rate Failover: The code should be a unique string, and this is the value the site visitor must enter to redeem the coupon.
Origin Country: The origin Country (shipped from). supported countries.
Origin State/Province: The Origin State / Province (shipped from).
Origin Postal Code: The origin Zip / Postal Code (shipped from).

.netSHIP add-on Registration Requirements:
In order to return rates from USPS, Canada Post, FedEx, DHL/Airborne or Conway you must unchecked disabled and complete registration with these shipping companies.

USPS Registration Address: https://secure.shippingapis.com/registration/
Information Provided by USPS: Username, Password (if only Username is provided use this value for both Username and Password)
Additional Requirements: After registration you will still not be able to return rates, you must contact USPS to request your account be enabled for the production server.
Services Used: XML domestic rating, XML international rating, and XML tracking.

CanadaPost Registration: Email eparcel@canadapost.ca to request a merchant ID for the XML system.
Information Provided by Canada Post: Merchant ID
Services Used: Native XML

FedEx: You must have a FedEx account number to obtain rates from FedEx. Visit fedex.com/developer and Login using an existing account or create a new account. This would typically be the same as your fedex shipping account. Go to the website's Technical Resources area and obtain a production key by filling out an application. The site should provide you with an authentication key after applying. You will then recieve an email with a production security code and meter number. Use this value with your account number in the following format: accountnumber,meter for the login setting. Since you are using rating / tracking you do not need to complete certification with FedEx.
Services Used: Fedex XML / Direct (Rate Available Services and Tracking). FedEx may also refer to this interface as FedEx Web Services.

DHL, Airborne: Your must have a DHL account (customer number) to obtain rates / tracking. Register your DHL account for the ShipIT XML API and obtain your username, password, and shipping key(s) by completing the following form and returning it to DHL. If you are shipping to international locations you will require both domestic and international shipping keys. Note: Airborne has been purchased by DHL and its services rolled into DHL.
Services Used: XML Rating and Tracking (ShipIT / TrackIT) Domestic and International.

UPS: UPS technical support has provided the following instructions for obtaining required credentials:
1. Browse to http://www.ups.com. 2. Log in with your User ID and password. If you do not have a UPS.com User ID and password, click on the New User link at the top of the page and follow the prompts to complete the registration process. Please note: If you have already registered for My UPS.com, we recommend you create a new user ID and password for use with UPS Developer APIs. 3. Hover over the "Support" tab near the top of the page and then click on "Technology Support." 4. Click the "UPS Developer Kit" link, located in the Tools and Resources section. 5. Click on the "Request an access key" link, located in the How to Get Started section. 6. Complete the "Secondary Contact Information." 7. Select the account number you wish to associate with the Access Key. a. If you do not have a UPS account number click the "Open a UPS Account" link. b. If you already have a UPS account number but it is not listed, click the "Add a UPS Account" link. 8. Click the "Request Access Key" button.

EasyPost: EasyPost is a flexible system which allows you to send shipments using all carriers, buying postages, create and print labels and tracking shipments. Signup here and get your account API Key in Account tab.

Custom Shipping:
The algorithm based shipping system can be used for special shipping offers or custom shipping rate calculations. Custom shipping definitions can be always returned (enable through the check box) or returned only in the case of a backup or failover call. This ensures that even when depending on a real-time processor your order pipeline will always be functional.

Other common uses for custom shipping definitions include special offers, for example you could define "Free Ground Shipping" as a type and set the condition as total over greater than $100. This way a free shipping option would be presented to the client only if they had more than $100 of items in their cart. They will still be presented with other shipping options should they require a most costly paid shipping option that would get their good to them sooner.

Each custom shipping, can have one or more services with different settings. Formula format: "type range = base charge + per unit charge, type range2 = base charge2 + per unit charge2 etc." Where type is w for weight (also default if no type is set), q for quantity, and $ for amount. The amount, quantity and weight are obtained by the ship level properties of the same names. Range is a numeric range such as 0-10 and can also include open ended ranges such as 10- (everything over 10). Base charge is a fixed amount for the package and the per unit charge is the value the actual w,q,$ will be multiplied by to determine that part of the rating. Country and StateProvince: if the distination Country or StateProvince matches a value defined in these text boxes then this custom shipping choice will be calculated and return in the rates collection. If you wish to include all countries except those listed with this property enclose the values in brackets. If they are not set, the destination Country and StateProivne will not be not checked.

The heart of .netCART's real-time shipping processing is its integrated shipping functionality exposed through the CartShip class. If you require stand alone shipping for another part of your web site, or another project all together, a dedicated .netSHIP license is available for purchase at http://www.dotnetship.com


Reports

Reports provide over 500 high end reports with stunning charts to provide a visual representation of all your store data. The .netCART reporting engine goes well beyond typical simple reports. High quality charts that surpass even high end desktop solutions are suitable for color printing or inclusion in company documents or summary reports.

Total flexibility is provided for selecting charting type, orientation, display and series options. Furthermore, options are provided for derived and calculated series and elements per series.

There are 5 sub-tabs in reports tab:

  • Dashboard: The first report combo selection provides the sales for 4 date grouping charts by Days, Weeks, Months and Years with drilldown. The 2nd combo selection "WeeksByDays", provides the sales report for week days. The 3rd selection provides sales by each category.
  • Custom: It provides reports for sales, orders and items with different date grouping, date range, chart types and visual customization.
  • Referrer: (Ad Campaign) It provides reports for sales, orders, items and customer visits by querystring and domain with a date range and visual customization.
  • Historical Sales: It provides an interactive chart by using Silverlight platform for creating a sales report for a long term with the ability to view the sales details for a specific date range.
  • Profit: It provides reports for store profits by items and customers, displays most profitable customers or items with a date range and visual customization.

The heart of .netCART's reporting engine is its integrated charting functionality exposed through the chart web control. This control may be used exclusively with your .netCART database for reporting for your store. If you require stand alone charting for another part of your web site, or another project all together, a dedicated charting license is available for purchase at http://www.dotnetcharting.com


Advertisement Campaign Configuration

Advertisement Campaign

The advertisement campaign administration provides an interface to add, edit or delete ad campaign. From the ad campaign listing you can jump to edit an ad-campaign.

You can create campaigns to track and view the reports for the effectiveness of a given advertisement in Reports->Referrer tab, and see sales in dollars, items and orders. You can define ad campaigns which will bind a given referrer URL or inbound querystring value to your set data. From this you can know the specific sales generated by a given advertisement in your store.

When you don't know where sales are coming from, the referrer domain will provide this information. For example, say a search engine is linking to your store such as www.yahoo.com, you will see this reported when someone visits by clicking through from www.yahoo.com and then purchasing in your store.

When you have an ad you are aware of and want to track, you can still use the same automated system and track from the referrer URL. In some cases, you may wish to track multiple ads from a single URL. In this case you can link to your site with a querystring parameter such as www.yourstore.com/default.aspx?Ad1 or www.yourstore.com/default.aspx?Ad2. In this case you will be able to track sales attributed to Ad1 or Ad2. These querystring values could be any string and you would need to have them setup as the links used for the given ads you were tracking.

Name: The ad campaign name, this is used to track the sales.
Start Date: The start date to the ad campaign.
End Date: The expiry date of ad campaign.
Referrer Domain: The ad campaign referrer's domain for tracking. e.g. google.com"
Referrer Querystring: The ad campaign referrer's query string for tracking. e.g. Ad=google1234"
Details: A description for the ad campaign.
Total Cost: The cost of the ad campaign.

In the bundle global.asax, cartObject.Customer.Referrer.SaveDB() automatically gets the customer's referrer URL from the remote site, parses out the domain and the adCampaign's keyword from querystring (if present).
For the CartID property, it first tries to get the CartID from dotnetCART cookie using cart.LoadCookieDB() method and if it doesn't exist, it will create a new one. When a new CartID is created, it is saved to Cart table using cart.SaveCookieDB() and synchronized between the current cart string and referrer. A customer may visit your store web site multiple times from different links, all of them are saved in Referrers table, but when the customer completes shopping, the querystring and domain from the last link is saved to orders table when invoking cart.SaveOrderDB(). This data is used in Reports->Referrer to show which links have been derived the most sales.


How To...

Save and Load the cart and merge carts
See state management guide.

Disable/enable stock handling
In StoreAdmin->Settings->Website, change the setting for "Stock Checking" checkbox. It is used in DisplayCatalog.aspx.cs/vb, Billing.aspx.cs/vb, and StoreAdmin/OrderDetailsEdit.aspx.cs/vb.

Set different price, image or stock for an item with options and choices?
See SubItem tutorial.

Change the displayed strings in the bundle
In the StoreAdmin->Settings->Language tab, you can customize the strings for the current language or create a new language file for other languages. Customers can then select a language and strings will display based on the strings you defined for that language.

Send an order confirmation email
First, check the "Send Invoice by Email" checkbox in StoreAdmin->Settings->Website tab and set the global mail settings in the StoreAdmin->Settings->Email tab. Then in Billing.aspx.cs (csharp bundle) or Billing.aspx.vb (VB bundle), at the end of CompleteOrder_ButtonClicked method, there is a section "Send the order by email." Customize the mail subject and message. To customize the body of the email, update the strBody in the CreateCustomerInvoice() function. Using the .netCART API you can access the complete cart object and items to implement any special handling you wish for the email formatting and composition. For example of such API usage, please see the API_Sample folder.

Recover the store admin password
Open App_Data/settings.config and delete the username element from the AdminUsers section, then the StoreAdmin/Default.aspx (login page) will display 3 text boxes for username, password and password confirmation and you can create a new username and password. If it doesn't show the password text box confirmation, please restart the application and open a new browser to clear the cache.

U se the provided StoreAdmin sample with a web application project
1) Copy dotnetcart.dll and your license key to the /bin directory and add dotnetcart.dll to the project references.
2) Copy App_Data, StoreAdmin, Images and Currencies folders to the WebApplication.
3) Copy or merge Web.config from the bundle's root directory to the WebApplication.
4) Right click on the StoreAdmin and Currencies folders and Include them to the project.
5) Right click on the StoreAdmin and Currencies folders and select "Convert to Web Application."

Save and Load custom fields from database
Add the custom fields to the associated table, then add the custom fields and values to the object.Customs collection; they are automatically saved to the table when calling object.SaveDB method.
For loading from database, add it to Store.Settings.Database.CustomFields collection before calling object.LoadDB method. e.g. Store.Settings.Database.CustomFields.Add(Tables.Orders, "myCusomField")
For more information see custom fields guide.

Add or remove a column from DisplayCart
Set Displaycart user control Header property.
For more information see DisplayCart guide.

Remove shipping address from the store samples?
In StoreAdmin->Settings->Website, un-check the setting for "Shipping Address" checkbox and set Checkout Page to "CheckoutNoShipping.aspx" page.

Remove shipping calculation from the front store samples?
In StoreAdmin->Settings->Website, un-check the setting for "Shipping Calculation" checkbox and set Checkout Page to "CheckoutNoShipping.aspx" page.

Implement Softgood delivery
.netCART currently incorporates comprehensive canned support for softgood delivery including fraud screen prevention in Billing.aspx.cs/vb. See Softgood Delivery for more information.

Change visual appearance and styles of the front store and customerAdmin samples
There are 6 built-in skins available for your review through Skins menu and can be apply permanently StoreAdmin->Settings->Website. There are more skin templates for more customization.
All the style related files for front store are in /styles folder and for customerAdmin in customerAdmin/BlackIce folder.

Know which advertisements, banners or inbound traffic generates derive the most sales
See Advertisement Campaign guide.

Modify an item programmatically
See also: carthierachy.aspx and carthierachydisplay.aspx
The items collection is a powerful facility where you can loop through items and directly modify the data in the cart, from price to name or options! It is useful for both displaying data in a very custom fashion beyond the scope of the powerful displaycart features and for making item modifications.

For example, if you wanted to adjust the price based on some specific text in an option, you can do so in script! Of course, .netCART has built in functionality for per option price adjustments, for example, a textbox for jewelry engraving, if set to custom value, add $5. However what if you wanted to charge $0.10 per letter for the engraving and not use a flat fee? No problem:

Grab the length of the text from the items collection and then based on this set the option level choice price adjustment!

See the code snippet below:
foreach(Item itemObj in cart.Items)
foreach(Option itemOption in itemObj.Options)
foreach(Choice itemOptionChoice in itemOption.Choices)
{
if(itemOption.Name.ToLower().Equals("engraving"))
itemOptionChoice.AdjustPrice = (itemOptionChoice.Name.Length * 0.1).ToString();
}
...

This is just one simple example of a real world case easily handled with .netCART. When you need more power and control it is available, when you don't the high level features provided do the work for you! The best of both worlds are provided.

Test your ecommerce store with a domain other than the domain in the purchased license key
For testing, beside "localhost" you can add test to your domain, like test.yourdomain.com where yourdomain.com is the domain in your purchased license key.

Use ImgNav control for showing a zoomed image for an item
Include "imgnav" in the image's name (e.g. MountainCity_ZoomImage_imgnav ). It is useful for large images for multiple zoom levels.

Remove / customize specific countries from the country dropdown list in checkout and other areas
In the StoreAdmin->Locations tab, select the country, then apply the delete button. If you want to show only USA and Canada in the country list, as a shortcut, you can open the database, and in Locations table, delete all the countries except USA, Canada and their states/provinces.

Calculate sales tax based on customer's zip code
Please see Locations->Taxes.

Use .netCART in Medium trust
See Medium Trust customization guide.

Remove the add coupon row from the shopping cart
Delete "AddCoupon" from myShoppingCart.Footer property in Displaycart.aspx.cs/vb file. For more information see Displaycart customization guide.

Allow shoppers to checkout without creating an account (as a guest) and not have to enter a password in the Checkout page
Password is optional and if it is not set, the account is not created. For removing the passwords fields completely, in Checkout.aspx.cs/vb file, set the following settings to false:
PlaceHolderNewCustomer.Visible = false;
PlaceHolderNewCustomer2.Visible = false;
PlaceHolderNewCustomer3.Visible = false;


.netCART Support

.netCART is a powerful ecommerce component. In addition to common shopping cart functionality, .netCART offers a full ecommerce toolkit. For details on some of the unique features of .netCART please see our web site at http://www.dotnetecommerc e.com

If you have a suggestion or feature request for .netCART please email support@dotnetecommerce.com


Store Dataflow

In a typically store implementation, such as the provided sample, the .netCART component is used in the following dataflow. It is important to note that the .netCART product is the component, not the sample store. Working with the product you are free to create a store that meets your visual and functional requirements - there is no limit to the number of completely different implementations that could be used. For example:

The included sample has a traditional approach:
1) Dynamic Catalog
2) Display Cart
3) Checkout (shipping details + shipping option selection)
4) Payment and order finalization

You could also:
- use a static catalog
- use your own catalog with a separate database
- use your own frontend database and .netCART's backend database
- break shipping / order detail collection across multiple pages
- not redirect to displaycart after an item addition
- break information collection into any number of pages with the data you want collected on the page you want
- show any information in the cart, it is all accessible programmatically
- integrate all steps into a simple single page store
- send encrypted order details via email
- not use a database on the backend
- use your own or pre-existing catalog
- not use a database at all

As a component .netCART does not enforce application specific rules on your ecommerce implementation. This leaves you free to implement the store you want, the way you want.


Credit card Payment Options

Payment Processing

With the .netCHARGE add-on as part of the .netECOMMERCE Bundle, .netCART has unprecedented integrated real-time payment processing support for over 45 gateways / processing companies.

For most, you can start processing real-time transactions with a few simple administration settings from the Payment tab in the store administration web interface (setting the login details for your account with the payment processor company).

The integrated payment system securely passes the transaction information to the gateway or processor and gets a real-time return regarding the success of the transaction. If there is a problem the client can immediately correct the transaction or submit alternative payment details ensuring maximum order completions. If the charges are successful their order is completed.

Support is also available for working with PayPal and Amazon. Unlike traditional processors which process securely in the background, they require that your visitors leave your site to provide payment details. For small sites this may be suitable and you can seamlessly migrate to another supported payment processor as your sales increase.

When utilizing the .netCHARGE add-on as part of the .netECOMMERCE bundle, first a payment gateway or processor should be configured through StoreAdmin->Payment.

Then, there are some points to be made aware of:

.netCART does not save data until the SaveOrderDB() call. Since all information is collected and persisted in the cart object prior to the save and, in the sample store, no save occurs until a successful payment the orderid (db autonumber) is not known until after payment processing is completed. For this reason, the dynamically generated Cart.ID is used so there can be a reference between the payment processing / gateway and your order should you wish to cross reference the records.

You have 2 choices:

1) You can generate an invoice number and set cartObj.Payment.ID = invoiceNumber before calling the cartObj.Payment.Charge() method in your billing page. Then, when calling SaveOrderDB, the payment.ID will be saved in the PaymentID field of the OrderTransactions table.

2) You can set cart.Payment.CartIDSet=true; before calling cart.Payment.Charge() method, then, the Cart.ID will automatically be set to the
payment.ID and then during SaveOrderDB operation, the ID will be saved as PaymentID in the OrderTransactions table.

Recurring Billing: .netCART supports recurring billing for PaymentTechOrbital, Authorize.NET , GlobalPayments, LinkPoint, Stripe and PayFlowPro. For enabling recurring billing, set the following properties in the billing page before calling cartObject.Payment.Charge method:

cartObject.Payment.RecurringBilling = true;
cartObject.Payment.StartDate = DateTime.Now; (Now or a future date)
cartObject.Payment.BillingCount = 2; (To submit a subscription with no end date (an ongoing subscription), this field must be submitted with a value of “9999”)
cartObject.Payment.SettleInterval = "1months";

The format of SettleInterval property is different for each gateway, please see .netCHARGE documentation

The heart of .netCART's payment processing is its integrated payment functionality exposed through the payment class. If you require stand alone payment processing for another part of your web site, or another project all together, a dedicated .netCHARGE license is available for purchase at http://www.dotnetcharge.com

NEW: For Authorize.NET and Stripe gateways, If setting the Public Key all credit card information is sent to the gateway server from the client browser in a secure way without having the information touch your server, then internally using the token returned by the gateway server to process and charge payments. This method complies with the Payment Card Industry Data Security Standards (PCI DSS).


State Management

 State Management Tutorial:

.netCART does not enforce application specific limitations on your custom implementation. It can be used with or without cookies, with or without sessions, even with or without a database. The choice remains with you, the developer. Collect the data in the order you want, collect only the information you want and maintain state as you wish.

How to manage the state of the cart in the shopping process?

1-Cookie with DB: This method is used in the bundle. It calls SaveCookieDB() to serialize cart object, pushes to cart table the entire cart XML and stores only the encrypted cart ID in a cookie,
then, calls LoadCookieDB() to get cartObject.ID from Cookie and load from cart table

cartObject.LoadCookieDB();

cartObject.SaveCookieDB();

[VBNET]

cartObject.LoadCookieDB()

cartObject.SaveCookieDB()

2-Session: Serialize cart object to a string using cartObject.Save() and store it in a session variable, then load to the cart object using cartObject.Load() :

Session ["cart"] = cartObject.Save ();

cartObject.Load (Session ["cart"]);

[VBNET]

Session ["cart"] = cartObject.Save ()

cartObject.Load (Session ["cart"])

3-Cookieless Session: By default the server gives the client a key using an HTTP cookie for maintaining sessions. However, Individual application can be configured to support either cookie or cookieless. Set cookieless="true" in web.config

<configuration>
<system.web>
<sessionState cookieless="true" mode="InProc" timeout="100"/>
</system.web>
</configuration>

Note: SessionState mode indicates where to store the session state:

· InProc: Indicates that session state is stored locally.
· StateServer: Indicates that session state is stored on a remote server.
· SQLServer: Indicates that session state is stored on the SQL Server.

For more information please see the MSDN documentation on this subject.

4-QueryString: The cart can be saved in cart table automatically using the SaveDB() method enabling you to pass only the customer.ID or cartObject.ID between pages using the querystring. Then, in the new page, getting the value passed and calling LoadDB(), loads cart back to the cart object.

[C#]
Page1.aspx:
cartObject.SaveDB ();
String strID = cartObject.Tools.Encrypt( cartObject.Customer.ID.ToString());
Response.Redirect("page2.aspx?customerID=" + HttpUtility.UrlEncode(strID));

Page2.aspx
String strID = cartObject.Tools.Decrypt(Request.QueryString["customerID"]);
cartObject.Customer.ID = Convert.ToInt64(strID);
cartObject.LoadDB ();

[VBNET]
Page1.aspx:
cartObject.SaveDB ()
String strID = cartObject.Tools.Encrypt( cartObject.Customer.ID.ToString())
Response.Redirect("page2.aspx?customerID=" + HttpUtility.UrlEncode(strID))

Page2.aspx
String strID = cartObject.Tools.Decrypt(Request.QueryString["customerID"])
cartObject.Customer.ID = Convert.ToInt64(strID)
cartObject.LoadDB ()

Note: Serializing the entire cart object to a string by cartObject.Save() and passing it through the query string is an option, but not recommended, because of security and size limitation of the querystring. If this is done, please ensure the string is first encrypted and then encoded with the HttpUtility.UrlEncode method.

5- Form: The cart can be saved in cart table using the SaveDB() method, and only customer.ID or cartObject.ID passed to another page using a hidden form field. Then, in the new page, setting customer.ID or cartObject.ID and calling LoadDB(), loads cart string to cart object.

[C#]
Page1.aspx:
cartObject.SaveDB ();
<INPUT TYPE="HIDDEN" NAME="HiddenCartID" VALUE="<%=cartObject.Tools.Encrypt(cartObject.ID)%>">

Page2.aspx
cartObject.ID = cartObject.Tools.Decrypt( Request.Form["HiddenCartID "]);
cartObject.LoadDB ();

[VBNET]
Page1.aspx:
cartObject.SaveDB ()
<INPUT TYPE="HIDDEN" NAME="HiddenCartID" VALUE="<%=cartObject.Tools.Encrypt(cartObject.ID)%>">

Page2.aspx
cartObject.ID = cartObject.Tools.Decrypt( Request.Form["HiddenCartID "])
cartObject.LoadDB ()

Note: Serializing cart object to a string by cartObject.Save() and pass it as hidden field is an option however you should ensure the data is encrypted.

How to manage the state of a customer after login?
cartObject.Customer.SaveCookie(), LoadCookie() and DeleteCookie are the helpder methods for managing a customer's state with cookie after login.

In the bundle, after a customer login in CustomerAdmin/default.aspx page, cartObject.Customer.SaveCookie is being called and it encrypts the Customer.ID and stores in dotnetcartCustomer cookie. In other customerAdmin pages or checkout.aspx, cartObject.Customer.LoadCookie(); is being called to determine whether the customer already login or not. In CustomerAdmin/logout.aspx page, cartObject.Customer.DeleteCookie() is being called to clear the customer's cookie.

How to merge a customer's old cart with their new cart?
If a customer logs out before completing shopping, you can save the items or the entire cart object to the cart table or a cookie by calling the following methods:

These methods only save the items collection:

bool SaveItemsDB(): calls saveItems and pushes them to the db with customerID if exists, otherwise by cartObject.ID
bool SaveItemsCookieDB(): called saveItems and pushes the serialized items to db, store only ID in cookie

These methods save the entire cart object including the items collection:

bool SaveDB(): calls Save and pushes to cart table the cart with customerID if exist, otherwise by cartObject.ID
bool SaveCookieDB(): calls Save and pushes to cart table the entire cart XML and stores only ID in cookie

Later, when the customer visits the store again and, with the following methods, loads the customer's old cart information and adds to the new cartObject. The Load[...] method should match the Save[...] method.

LoadItemsDB():Load from cart table by customerID with customerID if exist, otherwise by cartObject.ID
LoadItemsCookieDB(): get cartObject.ID from Cookie and load from cart table

LoadDB():Load from cart table by customerID with customerID if exist, otherwise by cartObject.ID
LoadCookieDB():get cartObject.ID from Cookie and load from cart table

When the customer has completed and order, calling DeleteTemporaryCart(), deletes any temporary cart in the cookie or cart table associated with this customer.

Note: The LoadDB and LoadCookieDB methods, overwrite the entire cart object and merge the items to the cartObject.Items collection. If you don't want to overwrite the values currently in the cart object, use LoadItemsDB or LoadItemsCookieDB methods.

Samples:
-Case 1: The customer should register or login before starting any shopping: In the customerAdmin/logout.aspx page add cartObject.Load and one of the Save…() methods:

[C#]
cartObject.Load(Session["cart"]);
cartObject.SaveDB();

[VBNET]
cartObject.Load(Session["cart"])
cartObject.SaveDB()

and in customerAdmin/default.aspx page call one of the Load…() method:

[C#]
cartObject.LoadDB();

[VBNET]
cartObject.LoadDB();

Then, add a hyperlink button in any page to logout.aspx page.

-Case 2: The site visitors can view catalog and start shopping without registration or login: In this scenario, cart string or only cartObject.ID can store in a cookie and updated in each page:

[C#]
cartObject.SaveCookieDB();

[VBNET]
cartObject.SaveCookieDB()

and in global.asax, i.e. Session_OnStart load the cookie and merge to the new cart by calling Load…() methods:

[C#]
cartObject.LoadCookieDB();

[VBNET]
cartObject.LoadCookieDB()


LiveHelp for .netCART

.netCART includes .netLIVEHELP integration support. .netLIVEHELP is a solution for providing live help or assistance in your online store. It can assist with greater sales and customer satisfaction. Seamless integration between .netLIVEHELP and .netCART enables you to view and modify the carts of customers you assist using .netLIVEHELP. For example, you could put live help chat on your order form and provide an adjustment to their order prior to submission or save abandoned carts by offering a special incentive for completing the order.

Usage with the provided sample store:
1) Deploy and install .netLIVEHELP as per the instructions included with the trial. It is available at www.dotnetlivehelp.com
2) Deploy and install .netCART as per the instructions included with the trial.
3) Edit dotnetlivehelp.aspx sample to set the .netLIVEHELP URL using the Cart.LiveHelp.Url property (the same URL you enter to use the .netLIVEHELP console application)
4) Run the dotnetlivehelp.aspx and start a chat to test the data exchange functionality.

NOTE: .netLIVEHELP and .netCART can and would typically be deployed into separate applications as defined in IIS, but must be installed on the same web site.

Usage within your own cart pages:
We have a new LiveHelp object in Cart as follows:

Cart.LiveHelp.Url
Cart.LiveHelp.Xslt

and a method
cart.LiveHelp.Register()

How to use LiveHelp in aspx page:

Set the Cart.LiveHelp.Url the .netLIVEHELP install URL (the same URL you use for the operator console login) and the add following line

if (!Page.IsPostBack)
cart.LiveHelp.Register();

to the aspx page. You need only to add cart.LiveHelp.Register(); to first aspx page (typically your default.apx) . For example, you have
page1.aspx , page2.aspx and page3.aspx . page1 redirects to page2.aspx and page2.aspx redirects to page3.aspx You add cart.LiveHelp.Register(); to page1.aspx only.

Also you should call:

cart.LoadCookieDB();
to load cart data from DB in all aspx page in loading the aspx page part and
cart.SaveCookieDB(); to save the cart in DB.

For example, you need to add cart.LoadCookieDB() and cart.SaveCookieDB()
in all pages you wish to maintain state or access the cart object. See state management for more details.

LiveHelp uses same cart methods to read and save cart data in DB . So in your custom aspx page, you should always load and save cart data using those methods (cart.LoadCookieDB() and cart.SaveCookieDB() ) or otherwise you will not see any exchange data between LiveHelp Console App and your page.

DB session state is required since the state needs to be altered and the session scope is not accessible outside of the .netCART application.

The .netLIVEHELP console app communicates with the .netLIVEHELP site through a Web Service (DXService.asmx) which is included in the bundle and should be in cart's root directory site.


Skin Templates

Templates documentation

How it works

  1. HTML Structure
  2. CSS Files and Structure
  3. JavaScript
  4. Content elements
    • Column systems and spacing
    • Fancybox
    • Tooltip
    • Nivo Slider
    • jQuery Cycle
    • Image/video gallery
    • Images in content
    • Bullets
  5. Skins
  6. Did you know? IMPORTANT

1) HTML structure

Explanation

I did not mention all the elements in the picture on the top. But this is the base of the template. But i think you get the point by seeing this picture. I will explain later more in detail about the menu, columns, footer and elements like the galley with adding YouTube and Vimeo videos and adding different bullets.

Sidebar columns Top

If you want a column (left or right) there is a simple structure that you can apply.

For a left column

<"id="contentWrap">                      // wrapper for all content

  <div id="column" class="lefttcol">     // where the column content is placed
    some column content
  </div>

    <div id="content">                   // where the content is placed
      some content content
    </div>

</div>                                   // end contentWrap

For a right column

<"id="contentWrap">                      // wrapper for all content

    <div id="content">                   // where the content is placed
      some content content
    </div>

  <div id="column" class="righttcol">    // where the column content is placed
    some column content
  </div>

</div>                                  // end contentWrap
Headings Top

All the headings are styled in the CSS so you can use all of these headings:

<h1>This is a H1 header</h1>
<h2>This is a H2 header</h2>
<h3>This is a H3 header</h3>
<h4>This is a H4 header</h4>
<h5>This is a H5 header</h5>
<h6>This is a H6 header</h6>

Note: The <h1> is used as pagetitle and can only be used one time a page, so don't use it in your content.

2) CSS files and structure Top

  • reset.css
  • basics.css
  • default.css
  • elements.css
  • jquery.fancybox-1.3.1.css
  • nivo-slider.css
  • ie.css
  • skin-1.css
  • skin-2.css
  • skin-3.css
  • skin-4.css
  • skin-5.css
  • skin-6.css

Explanation

The reset.css i used to reset all browsers standards. So the browser has no styling anymore and we can style it ourselfs.
skin-[NUMBER].css is the CSS that defines the skin of the template. This template has 6 skins, but more on this here.
jquery.fancybox-1.3.1.css is the CSS for the lightbox that is used for the images and the images/video gallery.
nivo-slider.css is the CSS for the fancy slider on the index page.
ie.css , you get it right? Some fixes for the IE browsers that not listen and need to be punished.
The other CSS files are custom and detailed below.
You can find all CSS files in Styles/css

basic.css Top
/* LINKS */
some code

/* HEADINGS */
some code

/* DEFAULT CONTENT CSS */
some code

/* FORMS CSS */
some code

/* CSS FOR SLIDERS, TOOLTIP */
some code
Explanation

This file contains all basic elements that are used all over the template like links, headings, paragraphs.

default.css Top
/* DEFAULT STRUCTURE */
some code

/* MAINMENU * */
some code

/* HOMEPAGE CSS */
some code

/* ABOUT US CSS */
some code

/* CONTENT COLUMN SYSTEM CSS */
some code

/* SUBMENU CSS */
some code

/* BLOG */
some code

/* PRE MADE PAGES */
some code
Explanation

This is the main CSS of this template. Here you can find the structure of the template like the body, header, menu, footer, column and css for specific pages

elements.css Top
/* IMAGE / VIDEO GALLERY AND PORTFOLIO */
some code

/* CONTENT SLIDER, used for portfolio and other pages like services */
some code

/* PAGE NAVIGATION */
some code

/* LIST STYLE TYPES */
some code

/* QUOTEBOX IN COLUMN CSS */
some code

/* INFOBOXES */
some code

/* QUOTEBOX IN CONTENT CSS */
some code

/* PRICE TABLE CSS */
some code

/* CONTENT TOGGLE */
some code
Explanation

elements.css is the file that take cares of elements like the image/video gallery, portfolio, (1,2,3,4) page navigation, bullets with different styles and some more elements.

skin-[number].css Top
/* LINKS */
some code

/* Setting some backgrounds */
some code

/* Setting some buttons sprites */
some code

/* MAINMENU */
some code

/* FOOTER */
some code
Explanation

Currently there are 6 skins available, you can set the skin by edit some code but i will explain that later in this document. Every skin file is mainly the same, but there are some elements that are extra styled in skin-6.css compared to skin-1.css

3) Javascript files and structure Top

  • jquery-1.4.2.min.js
  • jquery.easing.1.2.js
  • hoverIntent.js
  • jquery.bgiframe.min.js
  • superfish.js
  • supersubs.js
  • custom.js (explained below)
  • Myriad_Pro.js
  • nivo.slider.js
  • jquery.fancybox-1.3.1.js
  • tooltip.js
  • scrollEverthing.js
  • jquery.cycle.all.min.js
  • coin-slider.js

Explanation

jquery-1.4.2.min.js is a javascript libary that reduces the code you must write. Some of the elements in this template need this libary to work.
jquery.easing.1.2.js is a plugin for jQuery for smooth animations like for the lightbox.
hoverIntent.js, jquery.bgiframe.min.js, superfish.js, supersubs.js are for the mainmenu to run smoothly on all browsers.
nivo.slider.js is the javascript used for the fancy slider on the index page.
jquery.fancybox-1.3.1.js is the javascript used for the fancybox that is used at the galleries and can be used all over the site. More on the usage of Fancybox here.
You can find all JS files in / tooltip.js is a plugin for jQuery to get tooltips. Like in the footer social buttons.
scrollEverthing.js is used for the content slider. Now used in the Sevices 2 and Portfolio Slider page.
jquery.cycle.all.min.js Is used for the big header cycle on the homepage
coin-slider.js is used as a slider on the homepage.

jquery-1.4.2.min.js
jquery.easing.1.2.js
hoverIntent.js
jquery.bgiframe.min.js
superfish.js
supersubs.js
jquery.fancybox-1.3.1.js
custom.js

Note: Not every javascript file has to be included in your template. Only the .js files here on the top are needed. The rest of the javascript files are only needed when you are going to use a homepage or content slider or the fancy tooltip. Although it's recommended to include all javascript files but just letting you know.

custom.js Top
// JQUERY CYCLE
some code

// Lightbox for images
some code

// Lightbox for vimeo videos
some code

// Lightbox for YouTube videos
some code

// TOOLTIP
some code

// FORMS
some code

// IMAGE GALLERY FADE OPACITY WHEN HOVER
some code

// PAGENAV CLICK
some code

//* CONTENT TOGGLE
some code

// MAINNAV
some code

// JAVASCRIPT FOR DEMO, CAN BE REMOVED
some code
Explanation

The custom.js is mainly custom written for this template. If you want edit to selectors for the lightboxe or fading images when you hover, you can do it in this file. More information about the lightbox and fading images explained below.

4) Content elements

4 a) Column system One Fourth

<div class="one-fourth"> CONTENT </div>
<div class="one-fourth"> CONTENT </div>
<div class="one-fourth"> CONTENT </div>
<div class="one-fourth"> CONTENT </div>

<div class="hr"></div>
// the "hr" is used for spacing between these elements
// and the elements below

Next content elements

Column system One Third

<div class="one-third"> CONTENT </div>
<div class="one-third"> CONTENT </div>
<div class="one-third"> CONTENT </div>

<div class="hr"></div>
// the "hr" is used for spacing between these elements
// and the elements below

Next content elements

Column system Two Third

<div class="two-third"> CONTENT </div>
<div class="one-third"> CONTENT </div>

<div class="hr"></div>
// the "hr" is used for spacing between these elements
// and the elements below

Next content elements

Column system Half Page

<div class="half-page"> CONTENT </div>
<div class="half-page"> CONTENT </div>

<div class="hr"></div>
// the "hr" is used for spacing between these elements
// and the elements below

Next content elements

Column system Full Page

<div class="full-page"> CONTENT </div>

<div class="hr"></div>
// the "hr" is used for spacing between these elements
// and the elements below

Next content elements

Column system The HR

The seperator line between the columns can be used with or without a seperator line. The normal usage is with a line according the design. But i made a class that will remove the line and keeps the space.

// With seperator line
<div class="hr"></div>

// Without seperator line
<div class="hr noLine"></div>

4 b) Fancybox (lightbox) Top

The lightbox is used for a fancy image or video popup

Explanation

The lightbox is only used at the image and video gallery. But you can set all kind of images with this lightbox. Just give an <a> the class: fancy. So in full code it will be:

<a class="fancy" href="image/path/demo.jpg" />

OR

<li class="image">
  <a href="image/path/demo.jpg" />
</li>

// Both codes triggers the lightbox
Fancybox videos

In the custom.js is some code to make YouTube and Vimeo videos available in the Fancybox.
The only thing you must do is add the class vimeo for vimeo videos or youtube for YouTube videos to the <li> element.

Example

<li class="vimeo">
  <a href="http://vimeo.com/13444299" title="Title of this Vimeo">
    <img src="images/sample.jpg" alt="Example Vimeo" />
  </a>
</li>

<li class="youtube">
  <a href="http://www.youtube.com/watch?v=v_FfHA5whXc" title="Title of this YouTube">
    <img src="images/sample.jpg" alt="Example YouTube " />
  </a>
</li>

4 c) Tooltip

To enable the tooltip on a element you must add this class to an image:

    <img class="ttip" src="styles/images/icons/cart.gif" alt="Example Vimeo"
    title="This is the text for the tooltip" />

4 d) Nivo slider Top

The Nivo Slider in used in the index page for a fancy slider.
What you see below is the code that is needed to make the slider on the index page. In the <div id="headerWrap">section

Want a BIG header? Just use this class on the headerWrap:
<div id="headerWrap full-width">

The images width and height for the small and the big header:

SMALL: width: 630px, height: 250px;

BIG: width: 960px, height: 350px;

Explanation

The files that are needed for this slider are: jquery-1.4.2.min.js, nivo.slider.js

The code on the top can be found in index.aspx

Also you need some code in the <head> section:

<script type="text/javascript">
$(window).load(function() {
 $('#slider').nivoSlider({
  effect:'random', // random effects
  slices:15,	   // how many slides to show
  animSpeed:500,   // animation speed
  pauseTime:5000   // time between slides
 });
});
</script>

4 e) jQuery Cycle Top

The jQuery Cycle in used in the index page.
What you see below is the code that is needed to make the slider on the index page. In the <div id="headerWrap">section

This Slider is only available in a BIG header. So just use this class on the headerWrap:
<div id="headerWrap" full-width">

The images width and height for the small and the big header:

SMALL: width: 630px, height: 250px;

BIG: width: 960px, height: 350px;

Explanation

The files that are needed for this slider are: jquery-1.4.2.min.js, nivo.slider.js

The code on the top can be found in the index-jquerycycle.aspx

All the code in in custom.js and the CSS in elements.css so you don't have to include anything for this slider.

4 f) Image and video gallery Top

This template supports image - and video galleries that will be opened in Fancybox (lightbox). It supports images, YouTube and Vimeo videos. And it's very easy to apply them!

Just copy and paste the link of the image or (YouTube/Vimeo) video in the href="" <a href="">

Explanation

There are some attributes that are very important for the galleries:

<div class="gallery"> The gallery must be on a DIV with the CLASS "gallery" because the CSS target is on it.

<li class="image"> When you hover the image then a magnifier. That's what this class handles. Also as class you can use "video", that will trigger the PLAY button when you hover the image.

The code of an image and video gallery Top
<div class="gallery">
  <ul>
    <li class="image">
      <a href="images/sample.jpg">
        <img src="images/sample.jpg" alt="Example image" />
      </a>
    </li>

    <li class="vimeo">
      <a href="http://vimeo.com/13444299" rel="fancy" title="Vimeo video">
        <img src="images/sample.jpg" alt="Example Vimeo Video" />
      </a>
    </li>

    <li class="youtube">
      <a href="http://www.youtube.com/watch?v=v_FfHA5whXc" rel="fancy" title="YouTube video">
        <img src="images/sample.jpg" alt="Example YouTube Video" />
      </a>
    </li>
  </ul>
</div>
5 g) Content image left float Top

You can simple add an image to your content and will let it float on the top side of your content. See code below.

  <img class="left" src="image-source.jpg" alt="demo" />
    Sed ut perspic Sed ut perspic Sed ut perspic
5 d) Content image right float Top

You can simple add an image to your content and will let it float on the right side of your content. See code below.

  <img class="right" src="image-source.jpg" alt="demo" />
    Sed ut perspic Sed ut perspic Sed ut perspic
5 h) Bullets Top

There are different bullet styles in this template. This is the right way to use them:

<ul class="bullets"> for normal black bullets
<ul class="bullets arrow"> for arrow bullets
<ul class="bullet star"> for star bullets
<ul class="bullets green"> for green bullets
<ul class="bullets red"> for red bullets

5) Skins Top

This Site Template brings you 6 skins. It's quite simple to apply another skin. In the <head> head section you must include one of these stylesheets:

<link href="skin-1.css" type="text/css" rel="stylesheet" media="screen" />
OR
<link href="skin-2.css" type="text/css" rel="stylesheet" media="screen" />
OR
<link href="skin-3.css" type="text/css" rel="stylesheet" media="screen" />
OR
<link href="skin-4.css" type="text/css" rel="stylesheet" media="screen" />
OR
<link href="skin-5.css" type="text/css" rel="stylesheet" media="screen" />
OR
<link href="skin-6.css" type="text/css" rel="stylesheet" media="screen" />

Be sure you include one of these stylesheets, and not more than one!

In the skin CSS files you only can find adjustments of colors and images. Everything is commented so it's easy to edit those skin files to your own needs.

6) Did you know? Top

No sidebar columns?
If you have no sidebar columns, always use the class "full-width" on the CONTENT DIV. So in code:
<div id="content" class="full-width">

Full width header?
If you use a full-width header, set the class "full-width" on the headerWrap DIV. So in code:
<div id="headerWrap" class="full-width">

You use the blog pages?
If you use the blog pages, set the class "blog" on the contentWrap DIV. So in code:
<div id="contentWrap" class="blog">

You use the gallery pages?
If you use the gallry pages, wrap a div with a class around your gallery named "gallery". So in code:

<div class="gallery">
// A gallery explained as above
</div>

You don't like the border around the images?
If you don't like the borders around the images you can use this class:
<img class="no-border">


Related Items

 RelatedItems.ascx user control is in /ItemControls folder in the bundle and displaying the items related to the items in the customer's cart and can be fully customized:

The related items relationship can be configured through StoreAdmin->Catalog->Item Details in "Related/Suggested Items" section, one or more items can be bind as a related item for the item. The relatedItems user control can be added to a sidebar of any pages like catalog or displaycart. If the customer's cart is empty, the user control is invisible because the items in this control are related to the items in the cart. For the usage please see ItemControls\default.aspx page. ItemControls\RelatedItems.css file controls the style of the user control

RelatedItems Properties:

CartObject: This property accepts a cart object to use as the source of the item and cart data source.
relatedItems.CartObject = Cart

ColumnNames: Controls the columns that are included in the relatedItems. By default it shows only Image and Name, but ItemID and Price can be added. To change the order simply change the order of the comma delimited column names, to remove a column, remove the name from the list.
relatedItems..ColumnNames ="Image,Name"

HeaderText: Displays a text in the header, if it is set to an empty string, it removes the header.
relatedItems.Header="Related Items"

LinkItemImage: Controls whether to create a link on the image to the item details in catalog or not.
relatedItems.LinkItemImage= true

LinkItemName: Controls whether to create a link on the name to the item details in catalog or not.
relatedItems.LinkItemName= true

RelativePathToRoot: It should be set to the relative path of the relatedItems user control file to the application root. In the bundle, it is in /ItemControls folder, therefore, it is set to "../", but it is moved to other location, it should be update it.
relatedItems.RelativePathToRoot="../"

Need more customization? RelatedItems user control uses .netCART API, therefore, if you need more customization, you can modify the codes directly, but in some cases ItemControls\RelatedItems.css should be updated as well.


AddSkin

AddSkin.ascx user control sets the skin of a page.

In the sample bundle, the skin setting type is retrieved from GlobalStore.StoreSkin. This value can be set through StoreAdmin->Settings-Website or directly in App_Data\GlobalStore.cs file. The AddSkin user control is used in all the store front and customer admin pages.

Need more customization? AddSkin user control uses style sheets in Styles\css folder and templates structure in Template folder , therefore, if you need more customization, you can modify the codes directly.


Catalog Breadcrumbs

Breadcrumbs.ascx is the user control displays the categories as Breadcrumb navigation links.

In the sample bundle, the Breadcrumb user control is used in imgnavControl.aspx page and in StoreAdmin/EditCatalog, EditCategoryDetails and EditItem sections to show the navigation links. It can be used in DisplayCatalog as well, but in the bundle for providing a better performance, the breadcrumbs is created in displayCatalog.js

Need more customization? Breadcrumbs user control uses .netCART API, therefore, if you need more customization, you can modify the codes directly.


Billing

 Billing.ascx user control is used in Billing.aspx page and can be fully customized:

Billing is a user control for completing an order and saving it to database, handling payment and sending customer's invoice through email. For credit card payment, you need to configure a credit card processor/gateway though StoreAdmin->Payment. For controlling softgoods handling and customer's invoice settings, see StoreAdmin->Settings->Website. For customizing the customer's invoice, modify CreateCustomerInvoice function in billing user control.

How to change the appearance of Billing? All the styles like border, background,... are defined Styles/css/Billing.css file.

Need more customization? Billing user control uses .netCART API to display the cart contents, therefore, if you need more customization, you can modify the codes directly, but in some cases Billing.js and Styles/css/Billing.css should be updated as well.


CustomerInvoicePdf

 CustomersAlsoBought.ascx user control is in /ItemControls folder in the bundle and displaying the items other customers bought related to items in the customer's cart and can be fully customized:

The CustomersAlsoBought user control can be added to a sidebar of any pages like catalog or displaycart. If the customer's cart is empty, the user control is invisible because the items in this control are related to the items in the cart. For the usage please see ItemControls\default.aspx page. ItemControls\CustomersAlsoBought.css file controls the style of the user control

CustomersAlsoBought Properties:

CartObject: This property accepts a cart object to use as the source of the item and cart data source.
customersAlsoBought.CartObject = Cart

ColumnNames: Controls the columns that are included in the customersAlsoBought. By default it shows only Image and Name, but ItemID and Price can be added. To change the order simply change the order of the comma delimited column names, to remove a column, remove the name from the list.
customersAlsoBought..ColumnNames ="Image,Name"

HeaderText: Displays a text in the header, if it is set to an empty string, it removes the header.
customersAlsoBought.Header="Customers also bought"

LinkItemImage: Controls whether to create a link on the image to the item details in catalog or not.
customersAlsoBought.LinkItemImage= true

LinkItemName: Controls whether to create a link on the name to the item details in catalog or not.
customersAlsoBought.LinkItemName= true

RelativePathToRoot: It should be set to the relative path of the relative path of the customersAlsoBought user control file to the application root. In the bundle, it is in /ItemControls folder, therefore, it is set to "../", but it is moved to other location, it should be update it.
customersAlsoBought.RelativePathToRoot="../"

Need more customization? CustomersAlsoBought user control uses .netCART API, therefore, if you need more customization, you can modify the codes directly, but in some cases ItemControls\CustomersAlsoBought.css should be updated as well.


Customer Invoice PDF

 CustomerInvoice.ascx user control is used in CustomerInvoice.aspx page for generating order invoice and can be fully customized:

There is a "Print version" link in CustomerInvoice.aspx which creates the same user control but without any extras.
Need more customization? CustomerInvoice user control uses .netCART API to display the order contents, therefore, if you need more customization, you can modify the codes directly.


Customer Invoice PDF

 CustomerInvoicePdf.ascx user control is used in CustomerInvoice.aspx page for generating order invoice in PDF format and can be fully customized:

When running customerInvoice.aspx page, there is a PDF icon in top-right of customerInvoice page, when clicking on it, the CustomerInvoicePdf user control is invoked in CreateInvoicePdf method and the customer invoice in PDF format is created and opened.

CustomerInvoicePdf Properties:

OrderObject: This property accepts an order object to use as the source of the item and order data source.
pdf.OrderObject = order

StoreLogo: This property accepts a full or relative path to the store logo which is used in top-left of the invoice. The default size of of the image is configured to 249x51 pixels, but it can be changed by StoreLogoWidth and StoreLogoHeight.
pdf.StoreLogo = "Style/images/icons/storelogo.gif"

StoreLogoWidth: The width of the store logo image in pixel.
pdf.StoreLogoWidth = 180

StoreLogoHeight: The height of the store logo image in pixel.
pdf.StoreLogoWidth = 60

CompanyInformation: This property accepts a string and it is used to replace the "%CompanyInformation%" token in Strings.CustomerInvoice_Payment_Check_Message for check payment.
pdf.CompanyInformation = "Company Name, Compnay Address"

FilePath: This property accepts a full or relative path of the Pdf file. In the customerInvoice.aspx page, it is set to "App_Data\Invoices\Invoice_orderID.pdf" and "orderID" is replaced by the orderObject.ID.
pdf.FilePath = Store.Settings.DataDirectory + "/Invoices/Invoice_" + orderID.ToString() + ".pdf"

Header: This property accepts a string and it is used in the header after store logo for all invoice pages.
pdf.Header ="Company Name\r\n23 Main street\r\nLos Angeles 90210 CA\r\nUSA"

Footer: This property accepts a string and it is used in the footer of all invoice pages.
pdf.Footer="Company Name 23 Main street, Los Angeles 90210 CA USA";

Note: Sets a note which is displayed before the footer.
pdf.Note="Please contact us if you have any questions/suggestions.";
Creator: Sets the creator of the pdf file which is displayed in the PDF tab of the generated file properties. (To view the file properties, right click on the generated pdf file.)
pdf.Creator=""Your company name"

Subject: Sets the subject of the pdf file which is displayed in the PDF tab of the generated file properties. (To view the file properties, right click on the generated pdf file.)
pdf.Title=""Your order invoice."

Title: Sets the title of the pdf file which is displayed in the PDF tab of the generated file properties. (To view the file properties, right click on the generated pdf file.) It defaults to "Invoice #%invoiceid%" and %invoiceid% is replaced by the order.ID.
pdf.Title=""Invoice #%invoiceid%"

Need more customization? CustomerInvoicePdf user control uses .netCART API to display the order contents, therefore, if you need more customization, you can modify the codes directly.


DisplayCart

 DisplayCatalog.ascx user control is used in DisplayCatalog.aspx page and can be fully customized:

DisplayCatalog is a powerful and high performance user control for rending categories and items in store catalog and providing an intuitive interface for customers to navigate and add items their shopping cart. It automatically saves and loads the items in the shopping cart after adding new items, navigating to other store's page and back to displayCatalog.
There are two ways to specify control properties, programmatically referencing the controls ID (myCatalog.Property =" value") or declaratively within the control call block (Property="Value")

DisplayCatalog Properties:

DisplaycartPage: The display cart page for redirecting after adding an item or clicking on view cart button.
myCatalog.DisplaycartPage = "Displaycart.aspx"

DisplayCatalogPage: The page hosting displayCatalog user control.
myCatalog.DisplayCatalogPage = "DisplayCatalog.aspx"

ImgNavControlPage: The page shows a zoomed image for an item using imgnav control.
myCatalog.ImgNavControlPage = "imgnavControl.aspx"

ItemPageSize: The number of items in each catalog page.
myCatalog.ItemPageSize = 2

MaximumItemReviewRating: The number of starts for the review rating. Defaults to 5.
myCatalog.MaximumItemReviewRating = 5

MultiItemsAddToCart: Controls whether to allow adding multiple items to cart or not.
myCatalog.MultiItemsAddToCart = true

SortItemField: The field used to sort the item. Defaults to ItemID, other options are any fields exist in Items table like: Name, Price,.. or customer fields you add. For search result, it is hardcoded to "Price".
myCatalog.SortItemField = "Price"

ShowItemReviewLink: Controls whether to show the review link for each item or not.
myCatalog.ShowItemReviewLink = True

ShowImgNavControlInPopupWindow: Controls whether to show the item image in a popup window or not.
myCatalog.ShowImgNavControlInPopupWindow = False

ShowSearch: Controls whether to show the search or not.
myCatalog.ShowSearch = True

ShowSearchAdvanced: Controls whether to show the advanced search or not.
myCatalog.ShowSearchAdvanced = True

SearchItemPageSize: The number of search result items in each page. By default there is no paging for search result.
myCatalog.SearchItemPageSize = 2

StockChecking: Controls whether to check for the availability of the item before adding the item to the cart or not.
myCatalog.StockChecking = False

ShowSortDropdown: Controls whether to show the sort items dropdown or not.
myCatalog.ShowSortDropdown = True

ShowSearchSortDropdown: Controls whether to show the sort dropdown for search items result or not.
myCatalog.ShowSearchAdvanced = True

How to change the appearance of DisplayCatalog? All the styles like border, background,... are defined Styles/css/DisplayCatalog.css file.

Need more customization? DisplayCatalog user control uses .netCART API to display the cart contents, therefore, if you need more customization, you can modify the codes directly, but in some cases DisplayCatalog.js and Styles/css/DisplayCatalog.css should be updated as well.


DisplayCart

 DisplayCart.ascx user control is used in DisplayCart.aspx page and Billing.aspx page and can be fully customized:

DisplayCart is a powerful and high performance user control for rending the cart contents and providing an intuitive interface for the customer to manage their cart data. In addition to a read only interface, DisplayCart provides an editable system where customers can alter the quantity of items in the cart, remove items from the cart, and even adjust item options directly without returning to the catalog.
The control is extremely flexible and provides options for controlling the naming, order and which specific columns are included.
An address edit mode is also provided for per item address settings. Using displaycart customers can define and assign different addresses on a per item basis.
The elements and order of the cart footer is also easily controlled including the naming, order, and which elements are included.
There are two ways to specify control properties, programmatically referencing the controls ID (myShoppingCart.Property =" value") or declaratively within the control call block (Property="Value")

DisplayCart Properties:

CartObject: This property accepts a cart object to use as the source of the item and cart data source.
myShoppingCart.CartObject = Cart

Edit: Controls if the DisplayCart controls renders in edit or display mode. This option defaults to true. When set to false the cart will display in read only mode where the cart contents can not be modified.
myShoppingCart.Edit = False

Footer: Controls the rows that are included in the displaycart footer listings, the order of inclusion. To change the order simply change the order of the comma delimited field names, to remove a row, remove the name from the list. To add coupons, use StoreAdmin->Coupons.
To override the name use StoreAdmin/Settings/Language section which you can set different strings for each language. The footer strings name are: DisplayCart_Subtotal, DisplayCart_Adjustment, DisplayCart_TotalShipping, DisplayCart_TotalTax, DisplayCart_TotalCoupon, DisplayCart_AddCoupon, DisplayCart_ToolTip_AddCoupon and DisplayCart_Total.
myShoppingCart.Footer="SubTotal,Shipping,Tax,Coupon,AddCoupon,Adjust,Total"

Header: Controls the columns that are included in the displaycart, the order of inclusion for column headers. To change the order simply change the order of the comma delimited column names, to remove a column, remove the name from the list.
To override the name use StoreAdmin/Settings/Language section which you can set different strings for each language. The header strings name are: DisplayCart_Item_Remove, DisplayCart_Item_Name, DisplayCart_Item_Address, DisplayCart_Item_Image, DisplayCart_Item_Quantity, DisplayCart_Item_Options, DisplayCart_Item_Price, DisplayCart_Item_Adjust and DisplayCart_Item_Total.
myShoppingCart..Header ="Remove,Address,Name,Image,Quantity,Options,Price,Adjust,Total"

HeaderVisible: Controls if the displaycart header is visible.
myShoppingCart.HeaderVisible=false

IsCallBack: This read-only property indicates whether a request is an AJAX callback or not. DisplayCart uses AJAX callback for displaying and updating cart data.

How to change the appearance of DisplayCart? All the styles like border, background,... are defined Styles/css/DisplayCartUC.css file. For changing the images like remove, quantity plus and minus, ... , they are all in Styles\images\icons folder, replace them with your images.

Need more customization? DisplayCart user control uses .netCART API to display the cart contents, therefore, if you need more customization, you can modify the codes directly, but in some cases displaycart.js and Styles/css/DisplayCartUC.css should be updated as well.


Mini Cart

 MiniCart.ascx user control is in /ItemControls folder in the bundle and displaying the items in the customer's cart for quick preview and can be fully customized:

The MiniCart user control can be added to a sidebar of any pages like catalog or displaycart. If the customer's cart is empty, the user control is invisible because the items in this control are related to the items in the cart. For the usage please see ItemControls\default.aspx page. ItemControls\MiniCart.css file controls the style of the user control

MiniCart Properties:

CartObject: This property accepts a cart object to use as the source of the item and cart data source.
minicart.CartObject = Cart

ColumnNames: Controls the columns that are included in the minicart. By default it shows only Image, Name and Quantity, but ItemID, Options, Price and Total can be added. To change the order simply change the order of the comma delimited column names, to remove a column, remove the name from the list.
minicart..ColumnNames ="Image,Name,Quantity"

HeaderText: Displays a text in the header, if it is set to an empty string, it removes the header.
minicart.Header="Your Items"

LinkItemImage: Controls whether to create a link on the image to the item details in catalog or not.
minicart.LinkItemImage= true

LinkItemName: Controls whether to create a link on the name to the item details in catalog or not.
minicart.LinkItemName= true

RelativePathToRoot: It should be set to the relative path of the relative path of the minicart user control file to the application root. In the bundle, it is in /ItemControls folder, therefore, it is set to "../", but it is moved to other location, it should be update it.
minicart.RelativePathToRoot="../"

Need more customization? MiniCart user control uses .netCART API, therefore, if you need more customization, you can modify the codes directly, but in some cases ItemControls\MiniCart.css should be updated as well.


Mini Cart Link

 MiniCartLink.ascx user control is in /ItemControls folder in the bundle and displaying the total number of items in the customer's cart and a link to checkout or catalog and can be fully customized:

The MiniCartLink user control can be added to a sidebar of any pages like catalog or checkout. If the customer's cart is empty, the user control automatically shows a link to the catalog otherwise a link to checkout page. For the usage please see ItemControls\default.aspx page. ItemControls\MiniCartLink.css file controls the style of the user control

MiniCartLink Properties:

CartObject: This property accepts a cart object to use as the source of the item and cart data source.
minicartlink.CartObject = Cart

ImageCart: An image file for cart with items.
minicartlink.ImageCart="Styles/images/icons/shopping_cart.png"

ImageCartEmpty: An image file for empty cart.
minicartlink.ImageCartEmpty="Styles/images/icons/shopping_cart_empty.png"

ContinueShoppingButton: An image button link to the catalog page. By default it shows a text link.
minicartlink.ContinueShoppingButton="Styles/images/icons/continueshopping.png"

C heckoutButton: An image button link to the checkout page. By default it shows a text link.
minicartlink.ImageCart="Styles/images/icons/CheckoutButton.png"

RelativePathToRoot: It should be set to the relative path of the relative path of the minicartlink user control file to the application root. In the bundle, it is in /ItemControls folder, therefore, it is set to "../", but it is moved to other location, it should be update it.
minicartlink.RelativePathToRoot="../"

Need more customization? MiniCartLink user control uses .netCART API, therefore, if you need more customization, you can modify the codes directly, but in some cases ItemControls\MiniCartLink.css should be updated as well.


Footer

Footer.ascx user control displays footer in the pages.

In the sample bundle, the Footer user control is used in all the store front and customer admin pages. This user control must be updated to your store information before making your store website live.

Need more customization? Footer user control uses style sheets and images in Styles folder, therefore, if you need more customization, you can modify the codes directly. For complete template documentation, see templates structure page and for samples see Template folder.


Menu

Menu.ascx user control displays menu in the pages.

In the sample bundle, the menu user control is used in all the store front and customer admin pages. This user control must be updated to your store information before making your store website live.

Need more customization? Menu user control uses style sheets and images in Styles folder, therefore, if you need more customization, you can modify the codes directly. For complete template documentation, see templates structure page and for samples see Template folder.


Customer Admin Sub-Menu

AddCustomerSubMenu.ascx user control displays sub-menu in customer admin pages.

In the sample bundle, the AddCustomerSubMenu user control is used in all the customer admin pages. This user control can be updated to your store information before making your store website live.

Need more customization? AddCustomerSubMenu user control uses style sheets and images in Styles folder, therefore, if you need more customization, you can modify the codes directly. For complete template documentation, see templates structure page and for samples see Template folder.


Reviews

 There are 3 user controls in the root of the bundle. ReviewItem.ascx user control adds a new review for an item, ReviewsItem.ascx user control displays all the reviews for an item and ReviewsCustomer.ascx user control displays all the reviews for a customer.

Each of the review user controls has a corresponding css file in \Styles\css folder: ReviewItemUC.css, ReviewsItemUC.css and ReviewsCustomerUC.css.

Each of them was added to an aspx page in the bundle: ReviewItem.aspx, ReviewsItem.aspx and ReviewsCustomer.aspx, but they can be added to any page.

The store admin can be review the new reviews and change the status through StoreAdmin->Catalog->Reviews

Need more customization? The 3 user controls use .netCART API, therefore, if you need more customization, you can modify the codes directly, but in some cases associated css file should be updated as well.


Suggested Items

 SuggestedItems.ascx user control is in /ItemControls folder in the bundle and displaying suggested items related to the items in the customer's cart and can be fully customized:

The suggested items relationship can be configured through StoreAdmin->Catalog->Item Details in "Related/Suggested Items" section, one or more items can be bind as a suggested item for the item. The suggestedItems user control can be added to a sidebar of any pages like catalog or displaycart. If the customer's cart is empty, the user control is invisible because the items in this control are related to the items in the cart. For the usage please see ItemControls\default.aspx page. ItemControls\SuggestedItems.css file controls the style of the user control

SuggestedItems Properties:

CartObject: This property accepts a cart object to use as the source of the item and cart data source.
suggestedItems.CartObject = Cart

ColumnNames: Controls the columns that are included in the suggestedItems. By default it shows only Image and Name, but ItemID and Price can be added. To change the order simply change the order of the comma delimited column names, to remove a column, remove the name from the list.
suggestedItems..ColumnNames ="Image,Name"

HeaderText: Displays a text in the header, if it is set to an empty string, it removes the header.
suggestedItems.Header="Suggested Items"

LinkItemImage: Controls whether to create a link on the image to the item details in catalog or not.
suggestedItems.LinkItemImage= true

LinkItemName: Controls whether to create a link on the name to the item details in catalog or not.
suggestedItems.LinkItemName= true

RelativePathToRoot: It should be set to the relative path of the relative path of the suggestedItems user control file to the application root. In the bundle, it is in /ItemControls folder, therefore, it is set to "../", but it is moved to other location, it should be update it.
suggestedItems.RelativePathToRoot="../"

Need more customization? SuggestedItems user control uses .netCART API, therefore, if you need more customization, you can modify the codes directly, but in some cases ItemControls\SuggestedItems.css should be updated as well.


Button User control

StoreButton.ascx user control creates and displays an image button.

In the sample bundle, the storeButton user control is used in all the store front pages. Similar user control is used in CustomerAdmin\CustomerAdminButton.ascx and StoreAdmin\AdminButton.ascx for creating and displaying buttons in these sections.

Button Properties:

Size: Width and Height of the button in pixels.
MaximimSize: Determines the maximum Width and Height of the button in pixels. Regardless of SizeType the button will not be rendered larger than this size.
MinimumSize: Determines the minimum Width and Height of the button in pixels. Regardless of SizeType the button will not be rendered smaller than this size.
SizeType: Determines the sizing type. Options include Normal (uses provided size), ButtonToText (sizes the button to fit the provided text size), TextToButton (sizes the text to fit the provided button size).

Filename: Typically this property would not be set. Filename by default is set to the controls UniqueID plus _0-3 for the 4 states Normal, Hovered , Pushed and Disabled plus 3 letter extension based on the image type. If you need to control the filename for some reason you can set this property in which case the filename will be the value provided plus the state suffix, plus the file type extension. e.g. yourfilename_03.png. This property is specific to the webforms (asp.net) control and usage can be seen in sampleFilenames.aspx.
ImageType: Controls if the image is rendered as a Png or Jpeg. This property is specific to the webforms (asp.net) control usage

Enabled: Determines if the button is enabled or not. When disabled the button may not be clicked and is rendered as a greyscale version.
EnabledStates: Determines if any or all of the supported states are enabled. Options include: Normal, Hovered, Pushed, Disabled.

ServerCache: If set to true, image files will not be recreated if they already exist on disk.
StyleSettings: Controls the visual appearance of the button.
StyleType: Determines the style type from a set of predefined button styles. In addition to StyleType, ShapeType also has a large impact on the final button rendering. Options for StyleType include: Blank, LineGradient, GradientInnerOutline, MultigradientWave, MultigradientWaveUp, MultiGradient3Colors, GradientSplit, GradientSplitBorder, GradientSplitHighlight, GradientSplitCenterHighlight, GradientSplitBorderHighLight, GradientSplitCenterGlow, GradientSplitGlow, GradientBevelTextOffset, GradientBevel, Bevel, Glass3d, Smooth3dHighlight, HighlightTopFade, MirroredText, Chrome, Brushed Metal, GlassCube, BevelRounded, Plastic, GradientBevelTextOffsetGlow.
ShapeType: Determines the button shape. Options include Rectangle, RoundedRectangle and Ellipse. The ellipse shape will render either an oval or circular button depending on if the width and height are the same or not.
RoundingPercentage: Determines how much the corners are rounded for the RoundedRectangle shape.
Color: The buttons color.
Font: Sets the font object including properties for font name, size, bold etc.
FontColor: Sets the fonts color.

Text: Determines the button text.


%%ItemTitle%%

dotnetCART Send comments on this topic.
dotnetCART Namespace
See Also Inheritance Hierarchy

Classes

 | Class | Description
Class | ActivityLog | Logs users' activities.
Class | ActivityLogs | A collection of ActivityLog objects.
Class | AdCampaign | Creates an AdCampaign object.
Class | AdCampaigns | A collection of AdCampaign objects.
Class | Address | Represents an address object for a customer, supplier or affiliate.
Class | Addresses | A collection of Address objects.
Class | Cart | Represents a Cart object.
Class | CartCurrency | Represents a Currency object.
Class | CartLiveHelp | Represent a CartLiveHelp object for communicating between Cart and LiveHelp.
Class | CartShip | Represents a ship object.
Class | Catalog | This class used for the store catalog.
Class | Categories | A collection of Category objects.
Class | Categories.categoryComparerClass |
Class | Category | Represents a Category object.
Class | Choice | Represents a Choice object.
Class | Choices | A collection of Choice objects.
Class | Coupon | Represents a Coupon object.
Class | Coupons | A collection of Coupon objects.
Class | Custom | Defines a custom property for different objects.
Class | Customer | Represents a Customer object.
Class | Customers | A collection of Customer objects.
Class | CustomFields | Defines custom fields for different tables. For more information see custom fields
Class | Customs | A collection of Custom objects.
Class | Error | Represents an Error object.
Class | Image | Represents an Image object.
Class | Images | A collection of Image objects.
Class | ImageTemplate | An image template for generating different images for Item or Category.
Class | ImageTemplates | A collection of ImageTemplate objects.
Class | IPCheker |
Class | Item | Represents an Item object.
Class | ItemRelationships | A collection of Item objects for an ItemRelationshipType ItemRelationshipType.
Class | ItemRelationshipType | Represents an ItemRelationshipType.
Class | Items | A collection of Item objects.
Class | LacnicRir |
Class | Location | Represents a location object.
Class | LocationType | Represents a location type object.
Class | LocationTypes | A collection of LocationType objects.
Class | Mail | Represents an email object.
Class | MailLabel |
Class | Option | Represents an Option object.
Class | Options | A collection of Option objects.
Class | OptionSelection | Represents an option's selction object.
Class | Order | Represents an order object.
Class | OrderAddress | Represents an address object in an Order object.
Class | OrderCoupon | Represents a coupon in an Order object.
Class | OrderCoupons | A collection of OrderCoupon objects.
Class | OrderItem | Represents an item in Order object.
Class | OrderItemOption | Represents an option in an item in an Order object.
Class | OrderItemOptions | A collection of OrderItemOption objects.
Class | OrderItems | A collection of OrderItem objects.
Class | Orders | A collection of Order objects.
Class | OrderTax | Represents a tax in an item in an Order object.
Class | OrderTaxes | A collection of OrderTax objects.
Class | OrderTransaction | Represents an OrderTransaction object.
Class | OrderTransactions | A collection of OrderTransaction objects.
Class | ParseResult |
Class | Payment | Represents a Payment object.
Class | Price | Represents a Price object.
Class | Prices | A collection of Price objects.
Class | Rate | Represents a shipping rate object.
Class | Referrer | Defines a Referrer object.
Class | Referrers | A collection of Referrer objects.
Class | Review | Represents a Review object.
Class | Reviews | A collection of Review objects.
Class | RipeRir |
Class | Settings | Store settings.
Class | SettingsButton | Button Settings.
Class | SettingsCurrency | Currency settings. They usually set through StoreAdmin->Settings.
Class | SettingsDatabase | Database settings.
Class | SettingsFraudScore | Fraud score settings.
Class | SettingsLocation | Location settings.
Class | SettingsMail | Mail settings.
Class | SettingsPayment | Payment settings.
Class | SettingsShip | Shipping settings.
Class | SettingsTax | Tax settings.
Class | ShipCompanies | A collection of ShipCompany objects.
Class | ShipCompany | Represents a ShipCompany object. .netSHIP supports an advanced custom shipping rating system for rateback and failover purposes as well as custom defined algorithm based shipping implementations. Common uses of this system include providing backup for a real-time processor, providing free shipping for certain cases, providing shipping or special messages for overweight packages that can't be rated through the realtime systems or simply to provide your own custom rating based on a variety of criteria.
Class | SoftGood | Represents a SoftGood object.
Class | SoftGoods | A collection of SoftGood objects.
Class | SoftGoodsLog | Represents a SoftGoodsLog object which is used for tracking softgoods downloads.
Class | StockTransaction | Represents a StockTransaction object.
Class | StockTransactions | A collection of StockTransaction objects.
Class | Store | This high level class allows you to access the store Settings and Catalog.
Class | StoreAddress | Store Address
Class | SubItemMapping | Represents a sub-item mapping object.
Class | SubItemMappings | A collection of SubItemMapping objects.
Class | Supplier | Represents a supplier object.
Class | SupplierItem | Represents a SupplierItem object for storing an item order information to its supplier.
Class | SupplierItems | A collection of SupplierItem objects.
Class | Suppliers | A collection of Supplier objects.
Class | Tax | Represents a tax object.
Class | Taxes | A collection of Tax objects.
Class | Tools | Provide a reference to Tools object.

Structures

 | Structure | Description
Structure | PaymentProfile |

Enumerations

 | Enumeration | Description
Enumeration | CardNumberStorage | Defines different credit card number storage options.
Enumeration | CouponType | Defines the type of the coupon.
Enumeration | DataProviderType | Specifies a database type.
Enumeration | OptionType | Defines different option types.
Enumeration | PaymentMethod | Defines different payment methods.
Enumeration | Processor | A list of the processors or gateways, for full documentation please see .netCHARGE documentation
Enumeration | ShipCompanyType | Defines the type of ship company.
Enumeration | SortOrder |
Enumeration | Tables | A list of the tables with custom fields support. For more information see custom fields
Enumeration | TimeZone | The list of different time zones.
Enumeration | TransactionType | Defines different transaction types.

See Also

Reference

dotnetCART Assembly

© Corporate Web Solutions Ltd. 2001-2016 All Rights Reserved.


%%PageItemTitle%%

ActivityLog Class
See Also Members
[image]
dotnetCART Namespace : ActivityLog Class

Logs users' activities.

Object Model

Syntax

Visual Basic (Declaration)
Public Class ActivityLog
   Inherits DbTableCart(Of ActivityLog, Long)
C#
public class ActivityLog : DbTableCart<ActivityLog, long>

Remarks

You can use this class to track any activity by using SaveDB and view all the activities in StoreAdmin->Settings->ActivityLogs tab.

Inheritance Hierarchy

System.Object
dotnetDATA.DbTable<Int64>
dotnetDATA.DbTable<ActivityLog, Int64>
dotnetCART.DbTableCart<ActivityLog, Int64>
dotnetCART.ActivityLog

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLog Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

ActivityLog Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : ActivityLog Class

The following tables list the members exposed by ActivityLog.

Public Constructors

 | Name | Description
Public Constructor | ActivityLog Constructor | Creates a new instance of the ActivityLog class.
Top

Public Properties

 | Name | Description
Public Property | ActionDate | The action date.
Public Property | ActionLog | The action description.
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<ActivityLog, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<ActivityLog, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<ActivityLog, Int64>)
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<ActivityLog, Int64>)
Public Property | ID | Overridden. The auto number ID populated from the database.
Public Property | IP | The IP address of the person makes the action.
Public Property | UserName | The user name of the person makes the action.
Top

Public Methods

 | Name | Description
Public Method | Clear | Initializes all the properties without recreating the object. (Inherited from dotnetCART.DbTableCart<ActivityLog, Int64>)
Public Method | DeleteDB | Overloaded. Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<ActivityLog, Int64>)
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<ActivityLog, Int64>)
Public Method | LoadDB | Overloaded. Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<ActivityLog, Int64>)
Public Method | SaveDB | Overloaded. Overridden. Saves the action to the database.
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<ActivityLog, Int64>)
Top

See Also

Reference

ActivityLog Class
dotnetCART Namespace


%%PageItemTitle%%

ActivityLog Constructor
See Also
[image]
dotnetCART Namespace > ActivityLog Class : ActivityLog Constructor

Creates a new instance of the ActivityLog class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ActivityLog()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLog Class
ActivityLog Members


%%PageItemTitle%% $$Methods$$

ActivityLog Class Methods
[image]
dotnetCART Namespace : ActivityLog Class

For a list of all members of this type, see ActivityLog members.

Public Methods

 | Name | Description
Public Method | Clear | Initializes all the properties without recreating the object. (Inherited from dotnetCART.DbTableCart<ActivityLog, Int64>)
Public Method | DeleteDB | Overloaded. Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<ActivityLog, Int64>)
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<ActivityLog, Int64>)
Public Method | LoadDB | Overloaded. Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<ActivityLog, Int64>)
Public Method | SaveDB | Overloaded. Overridden. Saves the action to the database.
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<ActivityLog, Int64>)
Top

See Also

Reference

ActivityLog Class
dotnetCART Namespace


%%PageItemTitle%%

SaveDB Method
[image]
dotnetCART Namespace > ActivityLog Class : SaveDB Method

Saves the action to the database.

Overload List

Overload | Description
SaveDB() | Saves the action to the database.
SaveDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLog Class
ActivityLog Members


%%PageItemTitle%%

SaveDB() Method
See Also Example
[image]
dotnetCART Namespace > ActivityLog Class > SaveDB Method : SaveDB() Method

Saves the action to the database.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function SaveDB() As Integer
C#
public override int SaveDB()

Return Value

Returns 1 for the success, and -1 if failed. For the reason of fail, check the Error property.

Example

C# Copy Code
ActivityLog myActivity = new ActivityLog();
myActivity.ActionLog = "StoreAdmin.Login";
myActivity.UserName = AdminUserName.Text;
if (myActivity.SaveDB() < 1)
     //Handle error
else
    //Continue the process
Visual Basic Copy Code
Dim myActivity As New ActivityLog()
myActivity.ActionLog = "StoreAdmin.Login"
myActivity.UserName = AdminUserName.Text
If myActivity.SaveDB() < 1 Then
    'Handle error
Else
    'Continue the process
End If

Remarks

If the IP property not set, it is set by the value of HttpContext.Current.Request.ServerVariables["REMOTE_ADDR"].

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLog Class
ActivityLog Members
Overload List


%%PageItemTitle%% $$Properties$$

ActivityLog Class Properties
[image]
dotnetCART Namespace : ActivityLog Class

For a list of all members of this type, see ActivityLog members.

Public Properties

 | Name | Description
Public Property | ActionDate | The action date.
Public Property | ActionLog | The action description.
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<ActivityLog, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<ActivityLog, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<ActivityLog, Int64>)
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<ActivityLog, Int64>)
Public Property | ID | Overridden. The auto number ID populated from the database.
Public Property | IP | The IP address of the person makes the action.
Public Property | UserName | The user name of the person makes the action.
Top

See Also

Reference

ActivityLog Class
dotnetCART Namespace


%%PageItemTitle%%

ActionDate Property
[image]
dotnetCART Namespace > ActivityLog Class : ActionDate Property

The action date.

Syntax

Visual Basic (Declaration)
Public Property ActionDate As Date
C#
public DateTime ActionDate {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLog Class
ActivityLog Members


%%PageItemTitle%%

ActionLog Property
[image]
dotnetCART Namespace > ActivityLog Class : ActionLog Property

The action description.

Syntax

Visual Basic (Declaration)
Public Property ActionLog As String
C#
public string ActionLog {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLog Class
ActivityLog Members


%%PageItemTitle%%

ID Property
[image]
dotnetCART Namespace > ActivityLog Class : ID Property

The auto number ID populated from the database.

Syntax

Visual Basic (Declaration)
Public Overrides Property ID As Long
C#
public override long ID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLog Class
ActivityLog Members


%%PageItemTitle%%

IP Property
[image]
dotnetCART Namespace > ActivityLog Class : IP Property

The IP address of the person makes the action.

Syntax

Visual Basic (Declaration)
Public Property IP As String
C#
public string IP {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLog Class
ActivityLog Members


%%PageItemTitle%%

UserName Property
[image]
dotnetCART Namespace > ActivityLog Class : UserName Property

The user name of the person makes the action.

Syntax

Visual Basic (Declaration)
Public Property UserName As String
C#
public string UserName {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLog Class
ActivityLog Members


%%PageItemTitle%%

ActivityLogs Class
See Also Members
[image]
dotnetCART Namespace : ActivityLogs Class

A collection of ActivityLog objects.

Object Model

Syntax

Visual Basic (Declaration)
Public Class ActivityLogs
   Inherits ListBase(Of ActivityLog)
C#
public class ActivityLogs : ListBase<ActivityLog>

Inheritance Hierarchy

System.Object
System.Collections.Generic.List<ActivityLog>
dotnetCART.ListBase<ActivityLog>
dotnetCART.ActivityLogs

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLogs Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

ActivityLogs Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : ActivityLogs Class

The following tables list the members exposed by ActivityLogs.

Public Constructors

 | Name | Description
Public Constructor | ActivityLogs Constructor | Initializes a new instance of the ActivityLogs.
Top

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from dotnetCART.ListBase<ActivityLog>)
Public Property | Count | Gets the number of elements actually contained in the collection. (Inherited from dotnetCART.ListBase<ActivityLog>)
Public Property | Error | Returns an object with the error information. (Inherited from dotnetCART.ListBase<ActivityLog>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from dotnetCART.ListBase<ActivityLog>)
Top

Public Methods

 | Name | Description
Public Method | Add | Adds an object to the end of the collection. (Inherited from dotnetCART.ListBase<ActivityLog>)
Public Method | AddRange | Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetCART.ListBase<ActivityLog>)
Public Method | AsReadOnly | Returns a read-only IList wrapper for the current collection. (Inherited from dotnetCART.ListBase<ActivityLog>)
Public Method | BinarySearch | Overloaded. (Inherited from dotnetCART.ListBase<ActivityLog>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetCART.ListBase<ActivityLog>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetCART.ListBase<ActivityLog>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<ActivityLog>)
Public Method | CopyTo | Overloaded. (Inherited from dotnetCART.ListBase<ActivityLog>)
Public Method | GetCountDB | Overloaded. Gets the total number of items in the ActivityLogs table.
Public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from dotnetCART.ListBase<ActivityLog>)
Public Method | IndexOf | Overloaded. (Inherited from dotnetCART.ListBase<ActivityLog>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetCART.ListBase<ActivityLog>)
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from dotnetCART.ListBase<ActivityLog>)
Public Method | LastIndexOf | Overloaded. (Inherited from dotnetCART.ListBase<ActivityLog>)
Public Method | LoadDB | Overloaded. Overridden. Loads all the items based on the parameters from ActivityLogs table.
Public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from dotnetCART.ListBase<ActivityLog>)
Public Method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from dotnetCART.ListBase<ActivityLog>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetCART.ListBase<ActivityLog>)
Public Method | RemoveRange | Removes a range of elements from the List. (Inherited from dotnetCART.ListBase<ActivityLog>)
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<ActivityLog>)
Top

See Also

Reference

ActivityLogs Class
dotnetCART Namespace


%%PageItemTitle%%

ActivityLogs Constructor
[image]
dotnetCART Namespace > ActivityLogs Class : ActivityLogs Constructor

Initializes a new instance of the ActivityLogs.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ActivityLogs()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLogs Class
ActivityLogs Members


%%PageItemTitle%% $$Methods$$

ActivityLogs Class Methods
[image]
dotnetCART Namespace : ActivityLogs Class

For a list of all members of this type, see ActivityLogs members.

Public Methods

 | Name | Description
Public Method | Add | Adds an object to the end of the collection. (Inherited from dotnetCART.ListBase<ActivityLog>)
Public Method | AddRange | Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetCART.ListBase<ActivityLog>)
Public Method | AsReadOnly | Returns a read-only IList wrapper for the current collection. (Inherited from dotnetCART.ListBase<ActivityLog>)
Public Method | BinarySearch | Overloaded. (Inherited from dotnetCART.ListBase<ActivityLog>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetCART.ListBase<ActivityLog>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetCART.ListBase<ActivityLog>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<ActivityLog>)
Public Method | CopyTo | Overloaded. (Inherited from dotnetCART.ListBase<ActivityLog>)
Public Method | GetCountDB | Overloaded. Gets the total number of items in the ActivityLogs table.
Public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from dotnetCART.ListBase<ActivityLog>)
Public Method | IndexOf | Overloaded. (Inherited from dotnetCART.ListBase<ActivityLog>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetCART.ListBase<ActivityLog>)
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from dotnetCART.ListBase<ActivityLog>)
Public Method | LastIndexOf | Overloaded. (Inherited from dotnetCART.ListBase<ActivityLog>)
Public Method | LoadDB | Overloaded. Overridden. Loads all the items based on the parameters from ActivityLogs table.
Public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from dotnetCART.ListBase<ActivityLog>)
Public Method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from dotnetCART.ListBase<ActivityLog>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetCART.ListBase<ActivityLog>)
Public Method | RemoveRange | Removes a range of elements from the List. (Inherited from dotnetCART.ListBase<ActivityLog>)
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<ActivityLog>)
Top

See Also

Reference

ActivityLogs Class
dotnetCART Namespace


%%PageItemTitle%%

GetCountDB Method
[image]
dotnetCART Namespace > ActivityLogs Class : GetCountDB Method

Gets the total number of items in the ActivityLogs table.

Overload List

Overload | Description
GetCountDB() | Gets the total number of items in the ActivityLogs table.
GetCountDB(Where) | Gets the total number of items in the ActivityLogs table.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLogs Class
ActivityLogs Members


%%PageItemTitle%%

GetCountDB() Method
[image]
dotnetCART Namespace > ActivityLogs Class > GetCountDB Method : GetCountDB() Method

Gets the total number of items in the ActivityLogs table.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCountDB() As Integer
C#
public int GetCountDB()

Return Value

Returns the number of elements in the ActivityLogs table.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLogs Class
ActivityLogs Members
Overload List


%%PageItemTitle%%

GetCountDB(Where) Method
[image]
dotnetCART Namespace > ActivityLogs Class > GetCountDB Method : GetCountDB(Where) Method

whereClause
The where clause to filter the items.
Gets the total number of items in the ActivityLogs table.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCountDB( _
   ByVal whereClause As Where _
) As Integer
C#
public int GetCountDB(
   Where whereClause
)

Parameters

whereClause
The where clause to filter the items.

Return Value

Returns the number of elements in the ActivityLogs table.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLogs Class
ActivityLogs Members
Overload List


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > ActivityLogs Class : LoadDB Method

Loads all the items based on the parameters from ActivityLogs table.

Overload List

Overload | Description
LoadDB(Where,Int32,Int32,String,OrderDirection) | Loads all the items based on the parameters from ActivityLogs table.
LoadDB() | Loads all the items from its associated table. (Inherited from dotnetCART.ListBase<ActivityLog>)
LoadDB(Where) | Loads all the items from its associated table based on the where clause. (Inherited from dotnetCART.ListBase<ActivityLog>)
LoadDB(Int32,Int32) | Loads the count number of elements from start value. (Inherited from dotnetCART.ListBase<ActivityLog>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLogs Class
ActivityLogs Members


%%PageItemTitle%%

LoadDB(Where,Int32,Int32,String,OrderDirection) Method
[image]
dotnetCART Namespace > ActivityLogs Class > LoadDB Method : LoadDB(Where,Int32,Int32,String,OrderDirection) Method

whereClause
The where clause to filter the items.
start
The start page which starts from 0.
count
The number of items in the page.
orderBy
The order of the loaded items.
orderDirection
The order direction of the loaded items. Defaults is
Loads all the items based on the parameters from ActivityLogs table.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function LoadDB( _
   ByVal whereClause As Where, _
   ByVal start As Integer, _
   ByVal count As Integer, _
   ByVal orderBy As String, _
   ByVal orderDirection As OrderDirection _
) As Integer
C#
public override int LoadDB(
   Where whereClause,
   int start,
   int count,
   string orderBy,
   OrderDirection orderDirection
)

Parameters

whereClause
The where clause to filter the items.
start
The start page which starts from 0.
count
The number of items in the page.
orderBy
The order of the loaded items.
orderDirection
The order direction of the loaded items. Defaults is

Return Value

The total number of items have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLogs Class
ActivityLogs Members
Overload List


%%PageItemTitle%%

AdCampaign Class
See Also Members
[image]
dotnetCART Namespace : AdCampaign Class

Creates an AdCampaign object.

Object Model

Syntax

Visual Basic (Declaration)
Public Class AdCampaign
   Inherits DbTableCart(Of AdCampaign, Long)
C#
public class AdCampaign : DbTableCart<AdCampaign, long>

Inheritance Hierarchy

System.Object
dotnetDATA.DbTable<Int64>
dotnetDATA.DbTable<AdCampaign, Int64>
dotnetCART.DbTableCart<AdCampaign, Int64>
dotnetCART.AdCampaign

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaign Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

AdCampaign Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : AdCampaign Class

The following tables list the members exposed by AdCampaign.

Public Constructors

 | Name | Description
Public Constructor | AdCampaign Constructor | Initializes a new instance of the AdCampaign class.
Top

Public Properties

 | Name | Description
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<AdCampaign, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<AdCampaign, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<AdCampaign, Int64>)
Public Property | Details | Gets or sets this ad campaign details.
Public Property | EndDate | Gets or sets this ad campaign end date.
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<AdCampaign, Int64>)
Public Property | ID | Overridden. The autonumber ID populated from the database.
Public Property | Name | Gets or sets this ad campaign name.
Public Property | ReferrerDomain | Gets or sets this ad campaign referrer domain.
Public Property | ReferrerQuerystring | Gets or sets this ad campaign referrer querystring.
Public Property | StartDate | Gets or sets this ad campaign start date.
Public Property | TotalCost | Gets or sets this ad campaign total cost.
Top

Public Methods

 | Name | Description
Public Method | Clear | Initializes all the properties without recreating the object. (Inherited from dotnetCART.DbTableCart<AdCampaign, Int64>)
Public Method | DeleteDB | Overloaded. Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<AdCampaign, Int64>)
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<AdCampaign, Int64>)
Public Method | LoadDB | Overloaded. Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<AdCampaign, Int64>)
Public Method | SaveDB | Overloaded. Overridden. Saves an ad campaign object to AdCampaigns table.
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<AdCampaign, Int64>)
Top

See Also

Reference

AdCampaign Class
dotnetCART Namespace


%%PageItemTitle%%

AdCampaign Constructor
[image]
dotnetCART Namespace > AdCampaign Class : AdCampaign Constructor

Initializes a new instance of the AdCampaign class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public AdCampaign()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaign Class
AdCampaign Members


%%PageItemTitle%% $$Methods$$

AdCampaign Class Methods
[image]
dotnetCART Namespace : AdCampaign Class

For a list of all members of this type, see AdCampaign members.

Public Methods

 | Name | Description
Public Method | Clear | Initializes all the properties without recreating the object. (Inherited from dotnetCART.DbTableCart<AdCampaign, Int64>)
Public Method | DeleteDB | Overloaded. Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<AdCampaign, Int64>)
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<AdCampaign, Int64>)
Public Method | LoadDB | Overloaded. Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<AdCampaign, Int64>)
Public Method | SaveDB | Overloaded. Overridden. Saves an ad campaign object to AdCampaigns table.
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<AdCampaign, Int64>)
Top

See Also

Reference

AdCampaign Class
dotnetCART Namespace


%%PageItemTitle%%

SaveDB Method
[image]
dotnetCART Namespace > AdCampaign Class : SaveDB Method

Saves an ad campaign object to AdCampaigns table.

Overload List

Overload | Description
SaveDB() | Saves an ad campaign object to AdCampaigns table.
SaveDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaign Class
AdCampaign Members


%%PageItemTitle%%

SaveDB() Method
[image]
dotnetCART Namespace > AdCampaign Class > SaveDB Method : SaveDB() Method

Saves an ad campaign object to AdCampaigns table.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function SaveDB() As Integer
C#
public override int SaveDB()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaign Class
AdCampaign Members
Overload List


%%PageItemTitle%% $$Properties$$

AdCampaign Class Properties
[image]
dotnetCART Namespace : AdCampaign Class

For a list of all members of this type, see AdCampaign members.

Public Properties

 | Name | Description
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<AdCampaign, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<AdCampaign, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<AdCampaign, Int64>)
Public Property | Details | Gets or sets this ad campaign details.
Public Property | EndDate | Gets or sets this ad campaign end date.
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<AdCampaign, Int64>)
Public Property | ID | Overridden. The autonumber ID populated from the database.
Public Property | Name | Gets or sets this ad campaign name.
Public Property | ReferrerDomain | Gets or sets this ad campaign referrer domain.
Public Property | ReferrerQuerystring | Gets or sets this ad campaign referrer querystring.
Public Property | StartDate | Gets or sets this ad campaign start date.
Public Property | TotalCost | Gets or sets this ad campaign total cost.
Top

See Also

Reference

AdCampaign Class
dotnetCART Namespace


%%PageItemTitle%%

Details Property
[image]
dotnetCART Namespace > AdCampaign Class : Details Property

Gets or sets this ad campaign details.

Syntax

Visual Basic (Declaration)
Public Property Details As String
C#
public string Details {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaign Class
AdCampaign Members


%%PageItemTitle%%

EndDate Property
[image]
dotnetCART Namespace > AdCampaign Class : EndDate Property

Gets or sets this ad campaign end date.

Syntax

Visual Basic (Declaration)
Public Property EndDate As Date
C#
public DateTime EndDate {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaign Class
AdCampaign Members


%%PageItemTitle%%

ID Property
[image]
dotnetCART Namespace > AdCampaign Class : ID Property

The autonumber ID populated from the database.

Syntax

Visual Basic (Declaration)
Public Overrides Property ID As Long
C#
public override long ID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaign Class
AdCampaign Members


%%PageItemTitle%%

Name Property
[image]
dotnetCART Namespace > AdCampaign Class : Name Property

Gets or sets this ad campaign name.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaign Class
AdCampaign Members


%%PageItemTitle%%

ReferrerDomain Property
[image]
dotnetCART Namespace > AdCampaign Class : ReferrerDomain Property

Gets or sets this ad campaign referrer domain.

Syntax

Visual Basic (Declaration)
Public Property ReferrerDomain As String
C#
public string ReferrerDomain {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaign Class
AdCampaign Members


%%PageItemTitle%%

ReferrerQuerystring Property
[image]
dotnetCART Namespace > AdCampaign Class : ReferrerQuerystring Property

Gets or sets this ad campaign referrer querystring.

Syntax

Visual Basic (Declaration)
Public Property ReferrerQuerystring As String
C#
public string ReferrerQuerystring {get; set;}

Remarks

This value is used in Referrer.SaveDB to search in the query string of the customer's ReferrerURL, if there is a match, it is saved to Referrers table Querystring field.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaign Class
AdCampaign Members


%%PageItemTitle%%

StartDate Property
[image]
dotnetCART Namespace > AdCampaign Class : StartDate Property

Gets or sets this ad campaign start date.

Syntax

Visual Basic (Declaration)
Public Property StartDate As Date
C#
public DateTime StartDate {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaign Class
AdCampaign Members


%%PageItemTitle%%

TotalCost Property
[image]
dotnetCART Namespace > AdCampaign Class : TotalCost Property

Gets or sets this ad campaign total cost.

Syntax

Visual Basic (Declaration)
Public Property TotalCost As Double
C#
public double TotalCost {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaign Class
AdCampaign Members


%%PageItemTitle%%

AdCampaigns Class
See Also Members
[image]
dotnetCART Namespace : AdCampaigns Class

A collection of AdCampaign objects.

Object Model

Syntax

Visual Basic (Declaration)
Public Class AdCampaigns
   Inherits ListBase(Of AdCampaign)
C#
public class AdCampaigns : ListBase<AdCampaign>

Inheritance Hierarchy

System.Object
System.Collections.Generic.List<AdCampaign>
dotnetCART.ListBase<AdCampaign>
dotnetCART.AdCampaigns

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaigns Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

AdCampaigns Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : AdCampaigns Class

The following tables list the members exposed by AdCampaigns.

Public Constructors

 | Name | Description
Public Constructor | AdCampaigns Constructor | Initializes a new instance of the AdCampaigns.
Top

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from dotnetCART.ListBase<AdCampaign>)
Public Property | Count | Gets the number of elements actually contained in the collection. (Inherited from dotnetCART.ListBase<AdCampaign>)
Public Property | Error | Returns an object with the error information. (Inherited from dotnetCART.ListBase<AdCampaign>)
Public Property | Item | Overloaded. Gets the AdCampaign with the specified name.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds an object to the end of the collection. (Inherited from dotnetCART.ListBase<AdCampaign>)
Public Method | AddRange | Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetCART.ListBase<AdCampaign>)
Public Method | AsReadOnly | Returns a read-only IList wrapper for the current collection. (Inherited from dotnetCART.ListBase<AdCampaign>)
Public Method | BinarySearch | Overloaded. (Inherited from dotnetCART.ListBase<AdCampaign>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetCART.ListBase<AdCampaign>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetCART.ListBase<AdCampaign>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<AdCampaign>)
Public Method | CopyTo | Overloaded. (Inherited from dotnetCART.ListBase<AdCampaign>)
Public Method | GetCountDB | Overloaded. Gets the total number of items in the AdCampaigns table.
Public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from dotnetCART.ListBase<AdCampaign>)
Public Method | IndexOf | Overloaded. (Inherited from dotnetCART.ListBase<AdCampaign>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetCART.ListBase<AdCampaign>)
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from dotnetCART.ListBase<AdCampaign>)
Public Method | LastIndexOf | Overloaded. (Inherited from dotnetCART.ListBase<AdCampaign>)
Public Method | LoadDB | Overloaded. Overridden. Loads all the items based on the parameters from AdCampaigns table.
Public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from dotnetCART.ListBase<AdCampaign>)
Public Method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from dotnetCART.ListBase<AdCampaign>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetCART.ListBase<AdCampaign>)
Public Method | RemoveRange | Removes a range of elements from the List. (Inherited from dotnetCART.ListBase<AdCampaign>)
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<AdCampaign>)
Top

See Also

Reference

AdCampaigns Class
dotnetCART Namespace


%%PageItemTitle%%

AdCampaigns Constructor
[image]
dotnetCART Namespace > AdCampaigns Class : AdCampaigns Constructor

Initializes a new instance of the AdCampaigns.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public AdCampaigns()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaigns Class
AdCampaigns Members


%%PageItemTitle%% $$Methods$$

AdCampaigns Class Methods
[image]
dotnetCART Namespace : AdCampaigns Class

For a list of all members of this type, see AdCampaigns members.

Public Methods

 | Name | Description
Public Method | Add | Adds an object to the end of the collection. (Inherited from dotnetCART.ListBase<AdCampaign>)
Public Method | AddRange | Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetCART.ListBase<AdCampaign>)
Public Method | AsReadOnly | Returns a read-only IList wrapper for the current collection. (Inherited from dotnetCART.ListBase<AdCampaign>)
Public Method | BinarySearch | Overloaded. (Inherited from dotnetCART.ListBase<AdCampaign>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetCART.ListBase<AdCampaign>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetCART.ListBase<AdCampaign>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<AdCampaign>)
Public Method | CopyTo | Overloaded. (Inherited from dotnetCART.ListBase<AdCampaign>)
Public Method | GetCountDB | Overloaded. Gets the total number of items in the AdCampaigns table.
Public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from dotnetCART.ListBase<AdCampaign>)
Public Method | IndexOf | Overloaded. (Inherited from dotnetCART.ListBase<AdCampaign>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetCART.ListBase<AdCampaign>)
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from dotnetCART.ListBase<AdCampaign>)
Public Method | LastIndexOf | Overloaded. (Inherited from dotnetCART.ListBase<AdCampaign>)
Public Method | LoadDB | Overloaded. Overridden. Loads all the items based on the parameters from AdCampaigns table.
Public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from dotnetCART.ListBase<AdCampaign>)
Public Method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from dotnetCART.ListBase<AdCampaign>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetCART.ListBase<AdCampaign>)
Public Method | RemoveRange | Removes a range of elements from the List. (Inherited from dotnetCART.ListBase<AdCampaign>)
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<AdCampaign>)
Top

See Also

Reference

AdCampaigns Class
dotnetCART Namespace


%%PageItemTitle%%

GetCountDB Method
[image]
dotnetCART Namespace > AdCampaigns Class : GetCountDB Method

Gets the total number of items in the AdCampaigns table.

Overload List

Overload | Description
GetCountDB() | Gets the total number of items in the AdCampaigns table.
GetCountDB(Where) | Gets the total number of items in the AdCampaigns table.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaigns Class
AdCampaigns Members


%%PageItemTitle%%

GetCountDB() Method
[image]
dotnetCART Namespace > AdCampaigns Class > GetCountDB Method : GetCountDB() Method

Gets the total number of items in the AdCampaigns table.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCountDB() As Integer
C#
public int GetCountDB()

Return Value

Returns the number of elements in the AdCampaigns table.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaigns Class
AdCampaigns Members
Overload List


%%PageItemTitle%%

GetCountDB(Where) Method
[image]
dotnetCART Namespace > AdCampaigns Class > GetCountDB Method : GetCountDB(Where) Method

whereClause
The where clause to filter the items.
Gets the total number of items in the AdCampaigns table.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCountDB( _
   ByVal whereClause As Where _
) As Integer
C#
public int GetCountDB(
   Where whereClause
)

Parameters

whereClause
The where clause to filter the items.

Return Value

Returns the number of elements in the AdCampaigns table.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaigns Class
AdCampaigns Members
Overload List


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > AdCampaigns Class : LoadDB Method

Loads all the items based on the parameters from AdCampaigns table.

Overload List

Overload | Description
LoadDB(Where,Int32,Int32,String,OrderDirection) | Loads all the items based on the parameters from AdCampaigns table.
LoadDB() | Loads all the items from its associated table. (Inherited from dotnetCART.ListBase<AdCampaign>)
LoadDB(Where) | Loads all the items from its associated table based on the where clause. (Inherited from dotnetCART.ListBase<AdCampaign>)
LoadDB(Int32,Int32) | Loads the count number of elements from start value. (Inherited from dotnetCART.ListBase<AdCampaign>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaigns Class
AdCampaigns Members


%%PageItemTitle%%

LoadDB(Where,Int32,Int32,String,OrderDirection) Method
[image]
dotnetCART Namespace > AdCampaigns Class > LoadDB Method : LoadDB(Where,Int32,Int32,String,OrderDirection) Method

whereClause
The where clause to filter the items.
start
The start page which starts from 0.
count
The number of items in the page.
orderBy
The order of the loaded items.
orderDirection
The order direction of the loaded items. Defaults is Asc.
Loads all the items based on the parameters from AdCampaigns table.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function LoadDB( _
   ByVal whereClause As Where, _
   ByVal start As Integer, _
   ByVal count As Integer, _
   ByVal orderBy As String, _
   ByVal orderDirection As OrderDirection _
) As Integer
C#
public override int LoadDB(
   Where whereClause,
   int start,
   int count,
   string orderBy,
   OrderDirection orderDirection
)

Parameters

whereClause
The where clause to filter the items.
start
The start page which starts from 0.
count
The number of items in the page.
orderBy
The order of the loaded items.
orderDirection
The order direction of the loaded items. Defaults is Asc.

Return Value

The total number of items have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaigns Class
AdCampaigns Members
Overload List


%%PageItemTitle%% $$Properties$$

AdCampaigns Class Properties
[image]
dotnetCART Namespace : AdCampaigns Class

For a list of all members of this type, see AdCampaigns members.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from dotnetCART.ListBase<AdCampaign>)
Public Property | Count | Gets the number of elements actually contained in the collection. (Inherited from dotnetCART.ListBase<AdCampaign>)
Public Property | Error | Returns an object with the error information. (Inherited from dotnetCART.ListBase<AdCampaign>)
Public Property | Item | Overloaded. Gets the AdCampaign with the specified name.
Top

See Also

Reference

AdCampaigns Class
dotnetCART Namespace


%%PageItemTitle%%

Item Property
[image]
dotnetCART Namespace > AdCampaigns Class : Item Property

Gets the AdCampaign with the specified name.

Overload List

Overload | Description
Item(String) | Gets the AdCampaign with the specified name.
Item(Int32) | Gets or sets the element at the specified index. (Inherited from dotnetCART.ListBase<AdCampaign>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaigns Class
AdCampaigns Members


%%PageItemTitle%%

Item(String) Property
[image]
dotnetCART Namespace > AdCampaigns Class > Item Property : Item(String) Property

name
The name of the AdCampaign.
Gets the AdCampaign with the specified name.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal name As String _
) As AdCampaign
C#
public AdCampaign Item(
   string name
) {get;}

Parameters

name
The name of the AdCampaign.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaigns Class
AdCampaigns Members
Overload List


%%PageItemTitle%%

Address Class
See Also Members
[image]
dotnetCART Namespace : Address Class

Represents an address object for a customer, supplier or affiliate.

Object Model

Syntax

Visual Basic (Declaration)
Public Class Address
   Inherits BaseAddress(Of Address)
C#
public class Address : BaseAddress<Address>

Inheritance Hierarchy

System.Object
dotnetDATA.DbTable<Int64>
dotnetDATA.DbTable<Address, Int64>
dotnetCART.DbTableCart<Address, Int64>
dotnetCART.BaseAddress<Address>
dotnetCART.Address

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Address Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

Address Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : Address Class

The following tables list the members exposed by Address.

Public Constructors

 | Name | Description
Public Constructor | Address Constructor | Creates a new instance of the Address class.
Top

Public Properties

 | Name | Description
Public Property | City | Gets or sets this address's city. (Inherited from dotnetCART.BaseAddress<Address>)
Public Property | Company | The company name of the address.
Public Property | Country | Gets or sets this address's county. (Inherited from dotnetCART.BaseAddress<Address>)
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<Address, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<Address, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<Address, Int64>)
Public Property | Email | Gets or sets this address's email. (Inherited from dotnetCART.BaseAddress<Address>)
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<Address, Int64>)
Public Property | Fax | Gets or sets this address's fax. (Inherited from dotnetCART.BaseAddress<Address>)
Public Property | ID | Overridden. The auto number ID populated from the database.
Public Property | Name | Gets or set the name of the address.
Public Property | ParentID | The ID of the parent object.
Public Property | ParentObject | Gets or sets the parent object.
Public Property | ParentType | The name of the parent object, currently Customer, Supplier or Affiliate.
Public Property | Phone | Gets or sets this address's phone. (Inherited from dotnetCART.BaseAddress<Address>)
Public Property | Rates | A shipping Rates collection associates with this address.
Public Property | Residential | Gets or sets a boolean that specifies whether this address is residential or not. (Inherited from dotnetCART.BaseAddress<Address>)
Public Property | ShipAmount | The total amount of the shipping calculated for the shipment to this address.
Public Property | ShipBy | The shipping company selected to ship by for this address.
Public Property | ShipDate | The estimate shipping date for this address.
Public Property | ShipError | The error while calculaing the shipping rates.
Public Property | ShipMessage | The end user message while calculaing the shipping rates.
Public Property | ShipTracking | The shipping tracking information associated with this address.
Public Property | StateProvince | Gets or sets this address's state. (Inherited from dotnetCART.BaseAddress<Address>)
Public Property | Street | Gets or sets this address's street. (Inherited from dotnetCART.BaseAddress<Address>)
Public Property | ZipPostal | Gets or sets this address's zip postal code. (Inherited from dotnetCART.BaseAddress<Address>)
Top

Public Methods

 | Name | Description
Public Method | AddDB | Add this address object to Addresses table.
Public Method | Clear | Overridden. Initializes all the properties without recreating the object.
Public Method | Clone | Creates a copy of the current Address
Public Method | DeleteDB | Overloaded. Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<Address, Int64>)
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<Address, Int64>)
Public Method | LoadDB | Overloaded. Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<Address, Int64>)
Public Method | SaveDB | Overloaded. Add or update this address object in Addresses table.
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<Address, Int64>)
Public Method | UpdateDB | Update this address object in Addresses table.
Top

See Also

Reference

Address Class
dotnetCART Namespace


%%PageItemTitle%%

Address Constructor
[image]
dotnetCART Namespace > Address Class : Address Constructor

Creates a new instance of the Address class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Address()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Address Class
Address Members


%%PageItemTitle%% $$Methods$$

Address Class Methods
[image]
dotnetCART Namespace : Address Class

For a list of all members of this type, see Address members.

Public Methods

 | Name | Description
Public Method | AddDB | Add this address object to Addresses table.
Public Method | Clear | Overridden. Initializes all the properties without recreating the object.
Public Method | Clone | Creates a copy of the current Address
Public Method | DeleteDB | Overloaded. Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<Address, Int64>)
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<Address, Int64>)
Public Method | LoadDB | Overloaded. Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<Address, Int64>)
Public Method | SaveDB | Overloaded. Add or update this address object in Addresses table.
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<Address, Int64>)
Public Method | UpdateDB | Update this address object in Addresses table.
Top

See Also

Reference

Address Class
dotnetCART Namespace


%%PageItemTitle%%

AddDB Method
[image]
dotnetCART Namespace > Address Class : AddDB Method

parentID
The ID of the parent object.
parentType
The name of the parent type, currently Customer, Supplier or Affiliate
Add this address object to Addresses table.

Syntax

Visual Basic (Declaration)
Public Function AddDB( _
   ByVal parentID As Long, _
   ByVal parentType As String _
) As Integer
C#
public int AddDB(
   long parentID,
   string parentType
)

Parameters

parentID
The ID of the parent object.
parentType
The name of the parent type, currently Customer, Supplier or Affiliate

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Address Class
Address Members


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > Address Class : Clear Method

Initializes all the properties without recreating the object.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Clear()
C#
public override void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Address Class
Address Members


%%PageItemTitle%%

Clone Method
[image]
dotnetCART Namespace > Address Class : Clone Method

Creates a copy of the current Address

Syntax

Visual Basic (Declaration)
Public Function Clone() As Address
C#
public Address Clone()

Return Value

Returns an Address object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Address Class
Address Members


%%PageItemTitle%%

SaveDB Method
[image]
dotnetCART Namespace > Address Class : SaveDB Method

Add or update this address object in Addresses table.

Overload List

Overload | Description
SaveDB(Int64,String) | Add or update this address object in Addresses table.
SaveDB() | Inserts or updates this object into the database. (Inherited from dotnetCART.DbTableCart<Address, Int64>)
SaveDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Address Class
Address Members


%%PageItemTitle%%

SaveDB(Int64,String) Method
[image]
dotnetCART Namespace > Address Class > SaveDB Method : SaveDB(Int64,String) Method

parentID
The ID of the parent object.
parentType
The name of the parent type, currently Customer, Supplier or Affiliate
Add or update this address object in Addresses table.

Syntax

Visual Basic (Declaration)
Public Overloads Function SaveDB( _
   ByVal parentID As Long, _
   ByVal parentType As String _
) As Integer
C#
public int SaveDB(
   long parentID,
   string parentType
)

Parameters

parentID
The ID of the parent object.
parentType
The name of the parent type, currently Customer, Supplier or Affiliate

Return Value

In case of error -1, check Error property, otherwise the number of saved records.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Address Class
Address Members
Overload List


%%PageItemTitle%%

UpdateDB Method
[image]
dotnetCART Namespace > Address Class : UpdateDB Method

Update this address object in Addresses table.

Syntax

Visual Basic (Declaration)
Public Function UpdateDB() As Integer
C#
public int UpdateDB()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Address Class
Address Members


%%PageItemTitle%% $$Properties$$

Address Class Properties
[image]
dotnetCART Namespace : Address Class

For a list of all members of this type, see Address members.

Public Properties

 | Name | Description
Public Property | City | Gets or sets this address's city. (Inherited from dotnetCART.BaseAddress<Address>)
Public Property | Company | The company name of the address.
Public Property | Country | Gets or sets this address's county. (Inherited from dotnetCART.BaseAddress<Address>)
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<Address, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<Address, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<Address, Int64>)
Public Property | Email | Gets or sets this address's email. (Inherited from dotnetCART.BaseAddress<Address>)
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<Address, Int64>)
Public Property | Fax | Gets or sets this address's fax. (Inherited from dotnetCART.BaseAddress<Address>)
Public Property | ID | Overridden. The auto number ID populated from the database.
Public Property | Name | Gets or set the name of the address.
Public Property | ParentID | The ID of the parent object.
Public Property | ParentObject | Gets or sets the parent object.
Public Property | ParentType | The name of the parent object, currently Customer, Supplier or Affiliate.
Public Property | Phone | Gets or sets this address's phone. (Inherited from dotnetCART.BaseAddress<Address>)
Public Property | Rates | A shipping Rates collection associates with this address.
Public Property | Residential | Gets or sets a boolean that specifies whether this address is residential or not. (Inherited from dotnetCART.BaseAddress<Address>)
Public Property | ShipAmount | The total amount of the shipping calculated for the shipment to this address.
Public Property | ShipBy | The shipping company selected to ship by for this address.
Public Property | ShipDate | The estimate shipping date for this address.
Public Property | ShipError | The error while calculaing the shipping rates.
Public Property | ShipMessage | The end user message while calculaing the shipping rates.
Public Property | ShipTracking | The shipping tracking information associated with this address.
Public Property | StateProvince | Gets or sets this address's state. (Inherited from dotnetCART.BaseAddress<Address>)
Public Property | Street | Gets or sets this address's street. (Inherited from dotnetCART.BaseAddress<Address>)
Public Property | ZipPostal | Gets or sets this address's zip postal code. (Inherited from dotnetCART.BaseAddress<Address>)
Top

See Also

Reference

Address Class
dotnetCART Namespace


%%PageItemTitle%%

Company Property
[image]
dotnetCART Namespace > Address Class : Company Property

The company name of the address.

Syntax

Visual Basic (Declaration)
Public Property Company As String
C#
public string Company {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Address Class
Address Members


%%PageItemTitle%%

ID Property
[image]
dotnetCART Namespace > Address Class : ID Property

The auto number ID populated from the database.

Syntax

Visual Basic (Declaration)
Public Overrides Property ID As Long
C#
public override long ID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Address Class
Address Members


%%PageItemTitle%%

Name Property
[image]
dotnetCART Namespace > Address Class : Name Property

Gets or set the name of the address.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Address Class
Address Members


%%PageItemTitle%%

ParentID Property
[image]
dotnetCART Namespace > Address Class : ParentID Property

The ID of the parent object.

Syntax

Visual Basic (Declaration)
Public Property ParentID As Long
C#
public long ParentID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Address Class
Address Members


%%PageItemTitle%%

ParentObject Property
[image]
dotnetCART Namespace > Address Class : ParentObject Property

Gets or sets the parent object.

Syntax

Visual Basic (Declaration)
Public Property ParentObject As Object
C#
public object ParentObject {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Address Class
Address Members


%%PageItemTitle%%

ParentType Property
[image]
dotnetCART Namespace > Address Class : ParentType Property

The name of the parent object, currently Customer, Supplier or Affiliate.

Syntax

Visual Basic (Declaration)
Public Property ParentType As String
C#
public string ParentType {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Address Class
Address Members


%%PageItemTitle%%

Rates Property
[image]
dotnetCART Namespace > Address Class : Rates Property

A shipping Rates collection associates with this address.

Syntax

Visual Basic (Declaration)
Public Property Rates As Rates
C#
public Rates Rates {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Address Class
Address Members


%%PageItemTitle%%

ShipAmount Property
[image]
dotnetCART Namespace > Address Class : ShipAmount Property

The total amount of the shipping calculated for the shipment to this address.

Syntax

Visual Basic (Declaration)
Public Property ShipAmount As Decimal
C#
public decimal ShipAmount {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Address Class
Address Members


%%PageItemTitle%%

ShipBy Property
[image]
dotnetCART Namespace > Address Class : ShipBy Property

The shipping company selected to ship by for this address.

Syntax

Visual Basic (Declaration)
Public Property ShipBy As String
C#
public string ShipBy {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Address Class
Address Members


%%PageItemTitle%%

ShipDate Property
[image]
dotnetCART Namespace > Address Class : ShipDate Property

The estimate shipping date for this address.

Syntax

Visual Basic (Declaration)
Public Property ShipDate As Date
C#
public DateTime ShipDate {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Address Class
Address Members


%%PageItemTitle%%

ShipError Property
[image]
dotnetCART Namespace > Address Class : ShipError Property

The error while calculaing the shipping rates.

Syntax

Visual Basic (Declaration)
Public Property ShipError As String
C#
public string ShipError {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Address Class
Address Members


%%PageItemTitle%%

ShipMessage Property
[image]
dotnetCART Namespace > Address Class : ShipMessage Property

The end user message while calculaing the shipping rates.

Syntax

Visual Basic (Declaration)
Public Property ShipMessage As String
C#
public string ShipMessage {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Address Class
Address Members


%%PageItemTitle%%

ShipTracking Property
[image]
dotnetCART Namespace > Address Class : ShipTracking Property

The shipping tracking information associated with this address.

Syntax

Visual Basic (Declaration)
Public Property ShipTracking As String
C#
public string ShipTracking {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Address Class
Address Members


%%PageItemTitle%%

Addresses Class
See Also Members
[image]
dotnetCART Namespace : Addresses Class

A collection of Address objects.

Object Model

Syntax

Visual Basic (Declaration)
Public Class Addresses
   Inherits ListBase(Of Address)
C#
public class Addresses : ListBase<Address>

Inheritance Hierarchy

System.Object
System.Collections.Generic.List<Address>
dotnetCART.ListBase<Address>
dotnetCART.Addresses

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

Addresses Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : Addresses Class

The following tables list the members exposed by Addresses.

Public Constructors

 | Name | Description
Public Constructor | Addresses Constructor | Overloaded. Initializes a new instance of the Addresses.
Top

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from dotnetCART.ListBase<Address>)
Public Property | Count | Gets the number of elements actually contained in the collection. (Inherited from dotnetCART.ListBase<Address>)
Public Property | Error | Returns an object with the error information. (Inherited from dotnetCART.ListBase<Address>)
Public Property | Item | Overloaded. Gets the address with the specified name.
Public Property | Parent | Gets the parent object of the Addresses: Customer, or Supplier
Top

Public Methods

 | Name | Description
Public Method | Add | Adds an object to the end of the collection. (Inherited from dotnetCART.ListBase<Address>)
Public Method | AddRange | Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetCART.ListBase<Address>)
Public Method | AsReadOnly | Returns a read-only IList wrapper for the current collection. (Inherited from dotnetCART.ListBase<Address>)
Public Method | BinarySearch | Overloaded. (Inherited from dotnetCART.ListBase<Address>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetCART.ListBase<Address>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetCART.ListBase<Address>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<Address>)
Public Method | CopyTo | Overloaded. (Inherited from dotnetCART.ListBase<Address>)
Public Method | DeleteDB | Overloaded. Deletes all the addresses associated with this parent from Addresses table.
Public Method | GetCountDB | Overloaded. Gets the total number of items in the Addresses table.
Public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from dotnetCART.ListBase<Address>)
Public Method | GetIndex | Overloaded. Determines the index of a matching address by using IsEqual method, if the address not found, return -2.
Public Method | IndexOf | Overloaded. (Inherited from dotnetCART.ListBase<Address>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetCART.ListBase<Address>)
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from dotnetCART.ListBase<Address>)
Public Method | IsExist | Determines the index of an address with the specified name, if the address not found, return -1.
Public Method | LastIndexOf | Overloaded. (Inherited from dotnetCART.ListBase<Address>)
Public Method | LoadDB | Overloaded. Overridden. Loads all the addresses associated with its parent from Addresses table. This method must be called through Customer.Addresses or Supplier.Addresses
Public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from dotnetCART.ListBase<Address>)
Public Method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from dotnetCART.ListBase<Address>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetCART.ListBase<Address>)
Public Method | RemoveRange | Removes a range of elements from the List. (Inherited from dotnetCART.ListBase<Address>)
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<Address>)
Top

See Also

Reference

Addresses Class
dotnetCART Namespace


%%PageItemTitle%%

Addresses Constructor
[image]
dotnetCART Namespace > Addresses Class : Addresses Constructor

Initializes a new instance of the Addresses.

Overload List

Overload | Description
Addresses Constructor() | Initializes a new instance of the Addresses.
Addresses Constructor(Object) | Initializes a new instance of the Addresses.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members


%%PageItemTitle%%

Addresses Constructor()
See Also
[image]
dotnetCART Namespace > Addresses Class > Addresses Constructor : Addresses Constructor()

Initializes a new instance of the Addresses.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Addresses()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members
Overload List


%%PageItemTitle%%

Addresses Constructor(Object)
See Also
[image]
dotnetCART Namespace > Addresses Class > Addresses Constructor : Addresses Constructor(Object)

parentObject
The parent object.
Initializes a new instance of the Addresses.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parentObject As Object _
)
C#
public Addresses(
   object parentObject
)

Parameters

parentObject
The parent object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members
Overload List


%%PageItemTitle%% $$Methods$$

Addresses Class Methods
[image]
dotnetCART Namespace : Addresses Class

For a list of all members of this type, see Addresses members.

Public Methods

 | Name | Description
Public Method | Add | Adds an object to the end of the collection. (Inherited from dotnetCART.ListBase<Address>)
Public Method | AddRange | Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetCART.ListBase<Address>)
Public Method | AsReadOnly | Returns a read-only IList wrapper for the current collection. (Inherited from dotnetCART.ListBase<Address>)
Public Method | BinarySearch | Overloaded. (Inherited from dotnetCART.ListBase<Address>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetCART.ListBase<Address>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetCART.ListBase<Address>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<Address>)
Public Method | CopyTo | Overloaded. (Inherited from dotnetCART.ListBase<Address>)
Public Method | DeleteDB | Overloaded. Deletes all the addresses associated with this parent from Addresses table.
Public Method | GetCountDB | Overloaded. Gets the total number of items in the Addresses table.
Public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from dotnetCART.ListBase<Address>)
Public Method | GetIndex | Overloaded. Determines the index of a matching address by using IsEqual method, if the address not found, return -2.
Public Method | IndexOf | Overloaded. (Inherited from dotnetCART.ListBase<Address>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetCART.ListBase<Address>)
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from dotnetCART.ListBase<Address>)
Public Method | IsExist | Determines the index of an address with the specified name, if the address not found, return -1.
Public Method | LastIndexOf | Overloaded. (Inherited from dotnetCART.ListBase<Address>)
Public Method | LoadDB | Overloaded. Overridden. Loads all the addresses associated with its parent from Addresses table. This method must be called through Customer.Addresses or Supplier.Addresses
Public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from dotnetCART.ListBase<Address>)
Public Method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from dotnetCART.ListBase<Address>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetCART.ListBase<Address>)
Public Method | RemoveRange | Removes a range of elements from the List. (Inherited from dotnetCART.ListBase<Address>)
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<Address>)
Top

See Also

Reference

Addresses Class
dotnetCART Namespace


%%PageItemTitle%%

DeleteDB Method
[image]
dotnetCART Namespace > Addresses Class : DeleteDB Method

Deletes all the addresses associated with this parent from Addresses table.

Overload List

Overload | Description
DeleteDB(Int64,String) | Deletes all the addresses associated with this parent from Addresses table.
DeleteDB() | Deletes all the addresses associated with its parent from Addresses table. This method must be called through Customer.Addresses or Supplier.Addresses

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members


%%PageItemTitle%%

DeleteDB(Int64,String) Method
[image]
dotnetCART Namespace > Addresses Class > DeleteDB Method : DeleteDB(Int64,String) Method

parentID
The parent id of these addresses.
parentType
The address type: Customer or Supplier
Deletes all the addresses associated with this parent from Addresses table.

Syntax

Visual Basic (Declaration)
Public Overloads Function DeleteDB( _
   ByVal parentID As Long, _
   ByVal parentType As String _
) As Integer
C#
public int DeleteDB(
   long parentID,
   string parentType
)

Parameters

parentID
The parent id of these addresses.
parentType
The address type: Customer or Supplier

Return Value

The number of addresses have been deleted.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members
Overload List


%%PageItemTitle%%

DeleteDB() Method
[image]
dotnetCART Namespace > Addresses Class > DeleteDB Method : DeleteDB() Method

Deletes all the addresses associated with its parent from Addresses table. This method must be called through Customer.Addresses or Supplier.Addresses

Syntax

Visual Basic (Declaration)
Public Overloads Function DeleteDB() As Integer
C#
public int DeleteDB()

Return Value

The number of addresses have been deleted.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members
Overload List


%%PageItemTitle%%

GetCountDB Method
[image]
dotnetCART Namespace > Addresses Class : GetCountDB Method

Gets the total number of items in the Addresses table.

Overload List

Overload | Description
GetCountDB() | Gets the total number of items in the Addresses table.
GetCountDB(Where) | Gets the total number of items in the Addresses table.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members


%%PageItemTitle%%

GetCountDB() Method
[image]
dotnetCART Namespace > Addresses Class > GetCountDB Method : GetCountDB() Method

Gets the total number of items in the Addresses table.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCountDB() As Integer
C#
public int GetCountDB()

Return Value

Returns the number of elements in the Addresses table.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members
Overload List


%%PageItemTitle%%

GetCountDB(Where) Method
[image]
dotnetCART Namespace > Addresses Class > GetCountDB Method : GetCountDB(Where) Method

whereClause
The where clause to filter the items.
Gets the total number of items in the Addresses table.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCountDB( _
   ByVal whereClause As Where _
) As Integer
C#
public int GetCountDB(
   Where whereClause
)

Parameters

whereClause
The where clause to filter the items.

Return Value

Returns the number of elements in the Addresses table.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members
Overload List


%%PageItemTitle%%

GetIndex Method
[image]
dotnetCART Namespace > Addresses Class : GetIndex Method

Determines the index of a matching address by using IsEqual method, if the address not found, return -2.

Overload List

Overload | Description
GetIndex(Address) | Determines the index of a matching address by using IsEqual method, if the address not found, return -2.
GetIndex(Int64) | Determines the index of an address with the specified id, if the address not found, return -2.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members


%%PageItemTitle%%

GetIndex(Address) Method
[image]
dotnetCART Namespace > Addresses Class > GetIndex Method : GetIndex(Address) Method

item
An address object.
Determines the index of a matching address by using IsEqual method, if the address not found, return -2.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetIndex( _
   ByVal item As Address _
) As Integer
C#
public int GetIndex(
   Address item
)

Parameters

item
An address object.

Return Value

The address index in the collection.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members
Overload List


%%PageItemTitle%%

GetIndex(Int64) Method
[image]
dotnetCART Namespace > Addresses Class > GetIndex Method : GetIndex(Int64) Method

id
The address id.
Determines the index of an address with the specified id, if the address not found, return -2.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetIndex( _
   ByVal id As Long _
) As Integer
C#
public int GetIndex(
   long id
)

Parameters

id
The address id.

Return Value

The address index in the collection.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members
Overload List


%%PageItemTitle%%

IsExist Method
[image]
dotnetCART Namespace > Addresses Class : IsExist Method

addName
The address name.
Determines the index of an address with the specified name, if the address not found, return -1.

Syntax

Visual Basic (Declaration)
Public Function IsExist( _
   ByVal addName As String _
) As Integer
C#
public int IsExist(
   string addName
)

Parameters

addName
The address name.

Return Value

The address index in the collection.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > Addresses Class : LoadDB Method

Loads all the addresses associated with its parent from Addresses table. This method must be called through Customer.Addresses or Supplier.Addresses

Overload List

Overload | Description
LoadDB() | Loads all the addresses associated with its parent from Addresses table. This method must be called through Customer.Addresses or Supplier.Addresses
LoadDB(Int64,String) | Loads all the addresses associated with this parent from Addresses table.
LoadDB(Where,Int32,Int32,String,OrderDirection) | Loads all the items based on the parameters from Addresses table.
LoadDB(Where) | Loads all the items from its associated table based on the where clause. (Inherited from dotnetCART.ListBase<Address>)
LoadDB(Int32,Int32) | Loads the count number of elements from start value. (Inherited from dotnetCART.ListBase<Address>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > Addresses Class > LoadDB Method : LoadDB() Method

Loads all the addresses associated with its parent from Addresses table. This method must be called through Customer.Addresses or Supplier.Addresses

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function LoadDB() As Integer
C#
public override int LoadDB()

Return Value

The number of addresses have been deleted.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members
Overload List


%%PageItemTitle%%

LoadDB(Int64,String) Method
[image]
dotnetCART Namespace > Addresses Class > LoadDB Method : LoadDB(Int64,String) Method

parentID
The parent id of these addresses.
parentType
The address type: Customer or Supplier
Loads all the addresses associated with this parent from Addresses table.

Syntax

Visual Basic (Declaration)
Public Overloads Function LoadDB( _
   ByVal parentID As Long, _
   ByVal parentType As String _
) As Integer
C#
public int LoadDB(
   long parentID,
   string parentType
)

Parameters

parentID
The parent id of these addresses.
parentType
The address type: Customer or Supplier

Return Value

The number of addresses have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members
Overload List


%%PageItemTitle%%

LoadDB(Where,Int32,Int32,String,OrderDirection) Method
[image]
dotnetCART Namespace > Addresses Class > LoadDB Method : LoadDB(Where,Int32,Int32,String,OrderDirection) Method

whereClause
The where clause to filter the items.
start
The start page which starts from 0.
count
The number of items in the page.
orderBy
The order of the loaded items.
orderDirection
The order direction of the loaded items. Defaults is
Loads all the items based on the parameters from Addresses table.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function LoadDB( _
   ByVal whereClause As Where, _
   ByVal start As Integer, _
   ByVal count As Integer, _
   ByVal orderBy As String, _
   ByVal orderDirection As OrderDirection _
) As Integer
C#
public override int LoadDB(
   Where whereClause,
   int start,
   int count,
   string orderBy,
   OrderDirection orderDirection
)

Parameters

whereClause
The where clause to filter the items.
start
The start page which starts from 0.
count
The number of items in the page.
orderBy
The order of the loaded items.
orderDirection
The order direction of the loaded items. Defaults is

Return Value

The total number of items have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members
Overload List


%%PageItemTitle%% $$Properties$$

Addresses Class Properties
[image]
dotnetCART Namespace : Addresses Class

For a list of all members of this type, see Addresses members.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from dotnetCART.ListBase<Address>)
Public Property | Count | Gets the number of elements actually contained in the collection. (Inherited from dotnetCART.ListBase<Address>)
Public Property | Error | Returns an object with the error information. (Inherited from dotnetCART.ListBase<Address>)
Public Property | Item | Overloaded. Gets the address with the specified name.
Public Property | Parent | Gets the parent object of the Addresses: Customer, or Supplier
Top

See Also

Reference

Addresses Class
dotnetCART Namespace


%%PageItemTitle%%

Item Property
[image]
dotnetCART Namespace > Addresses Class : Item Property

Gets the address with the specified name.

Overload List

Overload | Description
Item(String) | Gets the address with the specified name.
Item(Int32) | Gets or sets the element at the specified index. (Inherited from dotnetCART.ListBase<Address>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members


%%PageItemTitle%%

Item(String) Property
[image]
dotnetCART Namespace > Addresses Class > Item Property : Item(String) Property

name
The name of the address.
Gets the address with the specified name.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal name As String _
) As Address
C#
public Address Item(
   string name
) {get;}

Parameters

name
The name of the address.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members
Overload List


%%PageItemTitle%%

Parent Property
[image]
dotnetCART Namespace > Addresses Class : Parent Property

Gets the parent object of the Addresses: Customer, or Supplier

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As Object
C#
public object Parent {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members


%%PageItemTitle%%

Cart Class
See Also Members
[image]
dotnetCART Namespace : Cart Class

Represents a Cart object.

Object Model

Syntax

Visual Basic (Declaration)
Public Class Cart
C#
public class Cart

Inheritance Hierarchy

System.Object
dotnetCART.Cart

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

Cart Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : Cart Class

The following tables list the members exposed by Cart.

Public Constructors

 | Name | Description
Public Constructor | Cart Constructor | Initializes a new empty instance of the cart.
Top

Public Properties

 | Name | Description
Public Property | Adjust | Gets or sets an Adjust amount associated with this cart. The total cart level adjustment calculated based on the AdjustRate value or formula. This property is populated by a calculate method call and typically would be treated as read only.
Public Property | AdjustRate | The cart level adjust rate can be set as a dollar amount or percentage based on dollar or quantity ranges. This formula accepts quantity and price ranges and adjusts based on a fixed amount or percentage. Ranges can be defined as quantity (1-10), dollars ($1-10) and also support open ended ranges e.g. 10 and up (10-). Adjustments can also be made as surcharges by using "+" rather than "-".
Public Property | BillAddress | Gets or sets the current billing address.
Public Property | CatalogUrl | The URL of the catalog page, this property can be used to link back to the last area in the catalog the customer was shopping in prior to adding an item to the cart.
Public Property | Country | A referecne to the Country object.
Public Property | Coupon | Gets or sets a Coupon which is added to the cart's Coupons when the cart.Coupons.Add() method is invoked.
Public Property | Coupons | Collection of Coupon objects associated with this cart.
Public Property | Currency | A referecne to the Currency object.
Public Property | Custom | Gets or sets a Custom which is added to the cart's Customs when the cart.Customs.Add() method is invoked.
Public Property | Customer | Gets or sets a Customer associated with this cart.
Public Property | Customs | A collection of Custom objects associated with Orders and OrdersHistory tables.
Public Property | Error | Returns an object with the error information.
Public Property | Errors | A collection of Error object.
Public Property | FraudScore | A reference to the FraudScore object.
Public Property | ID | Unique ID assigned to each cart. This ID is generated by .netCART.
Public Property | IsBillingSameAsShipping | Determines whether cart ShipAddress is the same as BillAddress or not.
Public Property | Item | Gets or sets an Item which is added to the cart's Items when the cart.Items.Add() method is invoked.
Public Property | Items | Collection of Item objects associated with this cart.
Public Property | LiveHelp | A reference to the LiveHelp object for setting its properties.
Public Property | OrderID | Gets or sets an orderID associated with this cart.
Public Property | Payment | Gets or sets a Payment associated with this cart.
Public Property | Ship | A referecne to the Ship.
Public Property | ShipAddress | Gets or sets the current shipping address.
Public Property | SubTotal | Gets or sets a SubTotal amount associated with this cart.
Public Property | Tax | Gets or sets a Tax which is added to the cart's Taxes when the cart.Taxes.Add() method is invoked.
Public Property | Taxes | A collection of Tax objects associated with this cart.
Public Property | Total | Gets or sets a Total amount associated with this cart.
Public Property | TotalAdjust | Calculates all items and cart adjust.
Public Property | TotalCoupon | Gets or sets a TotalCoupon amount associated with this cart.
Public Property | TotalQuantity | Total items in the cart.
Public Property | TotalShipping | Total shipping charges for the cart.
Public Property | TotalTax | Gets or sets a TotalTax amount associated with this cart.
Public Property | TotalWeight | Gets or sets a TotalWeight amount associated with this cart.
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds data from the user to the cart. For example, for adding items to the cart or for adding customer details to the cart. This method expects the data in either the forms or query collection. See a detailed listing of all supported elements for the add method.
Public Method | AdjustQuantity | Adjusts the item's quantity in the cart to the available item's stock.
Public Method | Calculate | Calculates the derived cart values (total, adjustments, shipping etc) based on the items, tax and shipping details that exist in the cart. This method sets SubTotal, TotalTax, TotalShipping, TotalCoupon and Adjust. Note if you have manually set one of the subtotal properties calculate will recognise this and not calculate it, instead the provided value will be used and totaled with any other calculated values.
Public Method | CalculateShipping | Calculates and sets Cart.TotalShipping based on the current values in ShipAmount in Customer.Addresses. Note, this method does not calculate the actual ShipAmount, it just adds them and sets Cart.TotalShipping. If you wish to calculate the ShipAmount, Cart.SetRates method should be used instead.
Public Method | CalculateTotal | Calculates and sets Cart.Total based on the current values in SubTotal, TotalTax, TotalShipping, TotalCoupon and Adjust. Note, this method does not calculate the actual values Cart.Total is based on, it just adds them and sets Cart.Total. If you wish to calculate the values based on the current cart the Calculate method should be used instead.
Public Method | DeleteTemporaryCart | Deletes cart string from Cart table using Customer.ID or Cart.ID.
Public Method | DisplayErrors | Returns Errors property in a serialized string and in a table format.
Public Method | Empty | Remove all the items from the cart. Any other information in the cart object remains, if you wish to clear the cart object simply create a new object without loading the cart string.
Public Method | GetCustom | Overloaded. Gets the value of a cart level custom field based on its name in the customs collection.
Public Method | GetItemStockDB | Returns the available item's stock.
Public Method | Load | Overloaded. Loads the XML representation of the cart back into the cart object.
Public Method | LoadCookieDB | Gets cart.ID from the Cookie and loads the cart XML string from the cart table using this ID. Then calls Load method.
Public Method | LoadDB | Overloaded. Loads the complete XML string from the cart table by customerID if populated, otherwise by Cart.ID. Then calls Load.
Public Method | LoadItems | Overloaded. Loads the XML representation of the Cart.Items back into the cart.
Public Method | LoadItemsCookieDB | Gets cart.ID from the Cookie and loads the items XML string from the cart table using this ID. Then calls LoadItems.
Public Method | LoadItemsDB | Loads the items XML string from the cart table by customerID if populated, otherwise by Cart.ID. Then calls LoadItems.
Public Method | ReloadItemsDB | Reloads the current items in the cart from the db. If an item doesn't exist in the db, it will be removed from the cart. If the options for an item are different from the db, it overrides the options with the db options. It persists all the quantity, address and custom address data for the current items.
Public Method | Remove | Overloaded. Decrements the quantity of the specified itemID in the cart.Items collection.
Public Method | Save | Serialize cart object to an XML string.
Public Method | SaveCookieDB | Calls Save and pushes items XML to the cart table with Customer.ID if populated and otherwise uses Cart.ID, then storing Cart.ID in a Cookie.
Public Method | SaveDB | Calls Save and pushes cart XML to the cart table with Customer.ID if populated and otherwise uses Cart.ID
Public Method | SaveItems | Overloaded. Serialize cart.Items to an XML string.
Public Method | SaveItemsCookieDB | Calls SaveItems and pushes items XML to the cart table with Customer.ID if populated and otherwise uses Cart.ID, then storing Cart.ID in a Cookie.
Public Method | SaveItemsDB | Calls SaveItems and pushes items XML to the cart table with Customer.ID if populated and otherwise uses Cart.ID
Public Method | SaveOrderDB | Overloaded. Saves a complete order to the relational database back end. This method saves customer, address, item, orderitem, option, payment and all other data for the order.
Public Method | SetCustom | Sets the value of a custom field based on the key and value provided. If it finds a key with the same name already exists it updates the value, if there is no such value a new entry will be added.
Top

See Also

Reference

Cart Class
dotnetCART Namespace


%%PageItemTitle%%

Cart Constructor
[image]
dotnetCART Namespace > Cart Class : Cart Constructor

Initializes a new empty instance of the cart.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Cart()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%% $$Methods$$

Cart Class Methods
[image]
dotnetCART Namespace : Cart Class

For a list of all members of this type, see Cart members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds data from the user to the cart. For example, for adding items to the cart or for adding customer details to the cart. This method expects the data in either the forms or query collection. See a detailed listing of all supported elements for the add method.
Public Method | AdjustQuantity | Adjusts the item's quantity in the cart to the available item's stock.
Public Method | Calculate | Calculates the derived cart values (total, adjustments, shipping etc) based on the items, tax and shipping details that exist in the cart. This method sets SubTotal, TotalTax, TotalShipping, TotalCoupon and Adjust. Note if you have manually set one of the subtotal properties calculate will recognise this and not calculate it, instead the provided value will be used and totaled with any other calculated values.
Public Method | CalculateShipping | Calculates and sets Cart.TotalShipping based on the current values in ShipAmount in Customer.Addresses. Note, this method does not calculate the actual ShipAmount, it just adds them and sets Cart.TotalShipping. If you wish to calculate the ShipAmount, Cart.SetRates method should be used instead.
Public Method | CalculateTotal | Calculates and sets Cart.Total based on the current values in SubTotal, TotalTax, TotalShipping, TotalCoupon and Adjust. Note, this method does not calculate the actual values Cart.Total is based on, it just adds them and sets Cart.Total. If you wish to calculate the values based on the current cart the Calculate method should be used instead.
Public Method | DeleteTemporaryCart | Deletes cart string from Cart table using Customer.ID or Cart.ID.
Public Method | DisplayErrors | Returns Errors property in a serialized string and in a table format.
Public Method | Empty | Remove all the items from the cart. Any other information in the cart object remains, if you wish to clear the cart object simply create a new object without loading the cart string.
Public Method | GetCustom | Overloaded. Gets the value of a cart level custom field based on its name in the customs collection.
Public Method | GetItemStockDB | Returns the available item's stock.
Public Method | Load | Overloaded. Loads the XML representation of the cart back into the cart object.
Public Method | LoadCookieDB | Gets cart.ID from the Cookie and loads the cart XML string from the cart table using this ID. Then calls Load method.
Public Method | LoadDB | Overloaded. Loads the complete XML string from the cart table by customerID if populated, otherwise by Cart.ID. Then calls Load.
Public Method | LoadItems | Overloaded. Loads the XML representation of the Cart.Items back into the cart.
Public Method | LoadItemsCookieDB | Gets cart.ID from the Cookie and loads the items XML string from the cart table using this ID. Then calls LoadItems.
Public Method | LoadItemsDB | Loads the items XML string from the cart table by customerID if populated, otherwise by Cart.ID. Then calls LoadItems.
Public Method | ReloadItemsDB | Reloads the current items in the cart from the db. If an item doesn't exist in the db, it will be removed from the cart. If the options for an item are different from the db, it overrides the options with the db options. It persists all the quantity, address and custom address data for the current items.
Public Method | Remove | Overloaded. Decrements the quantity of the specified itemID in the cart.Items collection.
Public Method | Save | Serialize cart object to an XML string.
Public Method | SaveCookieDB | Calls Save and pushes items XML to the cart table with Customer.ID if populated and otherwise uses Cart.ID, then storing Cart.ID in a Cookie.
Public Method | SaveDB | Calls Save and pushes cart XML to the cart table with Customer.ID if populated and otherwise uses Cart.ID
Public Method | SaveItems | Overloaded. Serialize cart.Items to an XML string.
Public Method | SaveItemsCookieDB | Calls SaveItems and pushes items XML to the cart table with Customer.ID if populated and otherwise uses Cart.ID, then storing Cart.ID in a Cookie.
Public Method | SaveItemsDB | Calls SaveItems and pushes items XML to the cart table with Customer.ID if populated and otherwise uses Cart.ID
Public Method | SaveOrderDB | Overloaded. Saves a complete order to the relational database back end. This method saves customer, address, item, orderitem, option, payment and all other data for the order.
Public Method | SetCustom | Sets the value of a custom field based on the key and value provided. If it finds a key with the same name already exists it updates the value, if there is no such value a new entry will be added.
Top

See Also

Reference

Cart Class
dotnetCART Namespace


%%PageItemTitle%%

Add Method
[image]
dotnetCART Namespace > Cart Class : Add Method

Adds data from the user to the cart. For example, for adding items to the cart or for adding customer details to the cart. This method expects the data in either the forms or query collection. See a detailed listing of all supported elements for the add method.

Overload List

Overload | Description
Add() | A shortcut method for cart.Add("item")
Add(String) | This add method is used for adding data from the user to the cart. For example, for adding items to the cart or for adding customer details to the cart. This method expects the data in either the forms or query collection. See a detailed listing of all supported elements for the add method.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

Add() Method
[image]
dotnetCART Namespace > Cart Class > Add Method : Add() Method

A shortcut method for cart.Add("item")

Syntax

Visual Basic (Declaration)
Public Overloads Function Add() As String
C#
public string Add()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members
Overload List


%%PageItemTitle%%

Add(String) Method
[image]
dotnetCART Namespace > Cart Class > Add Method : Add(String) Method

command
A comma delimited list of additions to perform. Options include item, shipaddress, billaddress, shipping, customer and payment.
This add method is used for adding data from the user to the cart. For example, for adding items to the cart or for adding customer details to the cart. This method expects the data in either the forms or query collection. See a detailed listing of all supported elements for the add method.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal command As String _
) As String
C#
public string Add(
   string command
)

Parameters

command
A comma delimited list of additions to perform. Options include item, shipaddress, billaddress, shipping, customer and payment.

Example

Detailed listing

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members
Overload List


%%PageItemTitle%%

AdjustQuantity Method
[image]
dotnetCART Namespace > Cart Class : AdjustQuantity Method

Adjusts the item's quantity in the cart to the available item's stock.

Syntax

Visual Basic (Declaration)
Public Function AdjustQuantity() As Boolean
C#
public bool AdjustQuantity()

Return Value

Returns the result of adjustment.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

Calculate Method
[image]
dotnetCART Namespace > Cart Class : Calculate Method

Calculates the derived cart values (total, adjustments, shipping etc) based on the items, tax and shipping details that exist in the cart. This method sets SubTotal, TotalTax, TotalShipping, TotalCoupon and Adjust. Note if you have manually set one of the subtotal properties calculate will recognise this and not calculate it, instead the provided value will be used and totaled with any other calculated values.

Syntax

Visual Basic (Declaration)
Public Function Calculate() As Boolean
C#
public bool Calculate()

Return Value

A Boolean indicates whether the operation is successful or not.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

CalculateShipping Method
[image]
dotnetCART Namespace > Cart Class : CalculateShipping Method

Calculates and sets Cart.TotalShipping based on the current values in ShipAmount in Customer.Addresses. Note, this method does not calculate the actual ShipAmount, it just adds them and sets Cart.TotalShipping. If you wish to calculate the ShipAmount, Cart.SetRates method should be used instead.

Syntax

Visual Basic (Declaration)
Public Function CalculateShipping() As Decimal
C#
public decimal CalculateShipping()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

CalculateTotal Method
[image]
dotnetCART Namespace > Cart Class : CalculateTotal Method

Calculates and sets Cart.Total based on the current values in SubTotal, TotalTax, TotalShipping, TotalCoupon and Adjust. Note, this method does not calculate the actual values Cart.Total is based on, it just adds them and sets Cart.Total. If you wish to calculate the values based on the current cart the Calculate method should be used instead.

Syntax

Visual Basic (Declaration)
Public Function CalculateTotal() As Decimal
C#
public decimal CalculateTotal()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

DeleteTemporaryCart Method
[image]
dotnetCART Namespace > Cart Class : DeleteTemporaryCart Method

Deletes cart string from Cart table using Customer.ID or Cart.ID.

Syntax

Visual Basic (Declaration)
Public Function DeleteTemporaryCart() As Boolean
C#
public bool DeleteTemporaryCart()

Return Value

Returns the result.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

DisplayErrors Method
[image]
dotnetCART Namespace > Cart Class : DisplayErrors Method

Returns Errors property in a serialized string and in a table format.

Syntax

Visual Basic (Declaration)
Public Function DisplayErrors() As String
C#
public string DisplayErrors()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

Empty Method
[image]
dotnetCART Namespace > Cart Class : Empty Method

Remove all the items from the cart. Any other information in the cart object remains, if you wish to clear the cart object simply create a new object without loading the cart string.

Syntax

Visual Basic (Declaration)
Public Sub Empty()
C#
public void Empty()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

GetCustom Method
[image]
dotnetCART Namespace > Cart Class : GetCustom Method

Gets the value of a cart level custom field based on its name in the customs collection.

Overload List

Overload | Description
GetCustom(String) | Gets the value of a cart level custom field based on its name in the customs collection.
GetCustom(Int32) | Gets the value of a cart level custom field based on its index in the customs collection.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

GetCustom(String) Method
[image]
dotnetCART Namespace > Cart Class > GetCustom Method : GetCustom(String) Method

name
Gets the value of a cart level custom field based on its name in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal name As String _
) As Object
C#
public object GetCustom(
   string name
)

Parameters

name

Return Value

Custom's object

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members
Overload List


%%PageItemTitle%%

GetCustom(Int32) Method
[image]
dotnetCART Namespace > Cart Class > GetCustom Method : GetCustom(Int32) Method

customIndex
Gets the value of a cart level custom field based on its index in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal customIndex As Integer _
) As Object
C#
public object GetCustom(
   int customIndex
)

Parameters

customIndex

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members
Overload List


%%PageItemTitle%%

GetItemStockDB Method
[image]
dotnetCART Namespace > Cart Class : GetItemStockDB Method

strItemNameOrID
Item's ID or name.
Returns the available item's stock.

Syntax

Visual Basic (Declaration)
Public Function GetItemStockDB( _
   ByVal strItemNameOrID As String _
) As Double
C#
public double GetItemStockDB(
   string strItemNameOrID
)

Parameters

strItemNameOrID
Item's ID or name.

Return Value

Number of item's stock or -1 if there is an error. For more information see Errors property.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

Load Method
[image]
dotnetCART Namespace > Cart Class : Load Method

Loads the XML representation of the cart back into the cart object.

Overload List

Overload | Description
Load(Object) | Loads the XML representation of the cart back into the cart object.
Load(String) | Loads the XML representation of the cart back into the cart object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

Load(Object) Method
[image]
dotnetCART Namespace > Cart Class > Load Method : Load(Object) Method

xmlObject
An XmlTextReader or string containing the cart object XML.
Loads the XML representation of the cart back into the cart object.

Syntax

Visual Basic (Declaration)
Public Overloads Function Load( _
   ByVal xmlObject As Object _
) As Boolean
C#
public bool Load(
   object xmlObject
)

Parameters

xmlObject
An XmlTextReader or string containing the cart object XML.

Return Value

A boolean, true on success

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members
Overload List


%%PageItemTitle%%

Load(String) Method
[image]
dotnetCART Namespace > Cart Class > Load Method : Load(String) Method

xmlString
The string containing the cart XML.
Loads the XML representation of the cart back into the cart object.

Syntax

Visual Basic (Declaration)
Public Overloads Function Load( _
   ByVal xmlString As String _
) As Boolean
C#
public bool Load(
   string xmlString
)

Parameters

xmlString
The string containing the cart XML.

Return Value

A boolean, true on success

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members
Overload List


%%PageItemTitle%%

LoadCookieDB Method
[image]
dotnetCART Namespace > Cart Class : LoadCookieDB Method

Gets cart.ID from the Cookie and loads the cart XML string from the cart table using this ID. Then calls Load method.

Syntax

Visual Basic (Declaration)
Public Function LoadCookieDB() As Boolean
C#
public bool LoadCookieDB()

Return Value

A boolean, true on success

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > Cart Class : LoadDB Method

Loads the complete XML string from the cart table by customerID if populated, otherwise by Cart.ID. Then calls Load.

Overload List

Overload | Description
LoadDB() | Loads the complete XML string from the cart table by customerID if populated, otherwise by Cart.ID. Then calls Load.
LoadDB(String) | Loads the complete XML string from the cart table by cartID. Then calls Load.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > Cart Class > LoadDB Method : LoadDB() Method

Loads the complete XML string from the cart table by customerID if populated, otherwise by Cart.ID. Then calls Load.

Syntax

Visual Basic (Declaration)
Public Overloads Function LoadDB() As Boolean
C#
public bool LoadDB()

Return Value

A boolean, true on success

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members
Overload List


%%PageItemTitle%%

LoadDB(String) Method
[image]
dotnetCART Namespace > Cart Class > LoadDB Method : LoadDB(String) Method

cartID
A valid cartID.
Loads the complete XML string from the cart table by cartID. Then calls Load.

Syntax

Visual Basic (Declaration)
Public Overloads Function LoadDB( _
   ByVal cartID As String _
) As Boolean
C#
public bool LoadDB(
   string cartID
)

Parameters

cartID
A valid cartID.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members
Overload List


%%PageItemTitle%%

LoadItems Method
[image]
dotnetCART Namespace > Cart Class : LoadItems Method

Loads the XML representation of the Cart.Items back into the cart.

Overload List

Overload | Description
LoadItems(String) | Loads the XML representation of the Cart.Items back into the cart.
LoadItems(XmlTextReader) | Loads the XML representation of the Cart.Items back into the cart.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

LoadItems(String) Method
[image]
dotnetCART Namespace > Cart Class > LoadItems Method : LoadItems(String) Method

xmlString
A valid XML string of Items.
Loads the XML representation of the Cart.Items back into the cart.

Syntax

Visual Basic (Declaration)
Public Overloads Function LoadItems( _
   ByVal xmlString As String _
) As Boolean
C#
public bool LoadItems(
   string xmlString
)

Parameters

xmlString
A valid XML string of Items.

Return Value

A boolean, true on success

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members
Overload List


%%PageItemTitle%%

LoadItems(XmlTextReader) Method
[image]
dotnetCART Namespace > Cart Class > LoadItems Method : LoadItems(XmlTextReader) Method

reader
Loads the XML representation of the Cart.Items back into the cart.

Syntax

Visual Basic (Declaration)
Public Overloads Function LoadItems( _
   ByVal reader As XmlTextReader _
) As Boolean
C#
public bool LoadItems(
   XmlTextReader reader
)

Parameters

reader

Return Value

A boolean, true on success

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members
Overload List


%%PageItemTitle%%

LoadItemsCookieDB Method
[image]
dotnetCART Namespace > Cart Class : LoadItemsCookieDB Method

Gets cart.ID from the Cookie and loads the items XML string from the cart table using this ID. Then calls LoadItems.

Syntax

Visual Basic (Declaration)
Public Function LoadItemsCookieDB() As Boolean
C#
public bool LoadItemsCookieDB()

Return Value

A boolean, true on success

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

LoadItemsDB Method
[image]
dotnetCART Namespace > Cart Class : LoadItemsDB Method

Loads the items XML string from the cart table by customerID if populated, otherwise by Cart.ID. Then calls LoadItems.

Syntax

Visual Basic (Declaration)
Public Function LoadItemsDB() As Boolean
C#
public bool LoadItemsDB()

Return Value

A boolean, true on success

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

ReloadItemsDB Method
[image]
dotnetCART Namespace > Cart Class : ReloadItemsDB Method

Reloads the current items in the cart from the db. If an item doesn't exist in the db, it will be removed from the cart. If the options for an item are different from the db, it overrides the options with the db options. It persists all the quantity, address and custom address data for the current items.

Syntax

Visual Basic (Declaration)
Public Function ReloadItemsDB() As Integer
C#
public int ReloadItemsDB()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

Remove Method
[image]
dotnetCART Namespace > Cart Class : Remove Method

Decrements the quantity of the specified itemID in the cart.Items collection.

Overload List

Overload | Description
Remove(String,Int32) | Decrements the quantity of the specified itemID in the cart.Items collection.
Remove(String) | Removes the item with the specified itemID from the cart.Items collection.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

Remove(String,Int32) Method
[image]
dotnetCART Namespace > Cart Class > Remove Method : Remove(String,Int32) Method

itemID
The itemID in the Items collection.
qty
A positive integer.
Decrements the quantity of the specified itemID in the cart.Items collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Remove( _
   ByVal itemID As String, _
   ByVal qty As Integer _
) As Boolean
C#
public bool Remove(
   string itemID,
   int qty
)

Parameters

itemID
The itemID in the Items collection.
qty
A positive integer.

Return Value

A Boolean indicates whether the operation is successful or not.

Remarks

If the result of the quantity becomes 0 or less, the item will be removed from the cart.Items collection.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members
Overload List


%%PageItemTitle%%

Remove(String) Method
[image]
dotnetCART Namespace > Cart Class > Remove Method : Remove(String) Method

itemID
The itemID in the Items collection.
Removes the item with the specified itemID from the cart.Items collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Remove( _
   ByVal itemID As String _
) As Boolean
C#
public bool Remove(
   string itemID
)

Parameters

itemID
The itemID in the Items collection.

Return Value

A Boolean indicates whether the operation is successful or not.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members
Overload List


%%PageItemTitle%%

Save Method
[image]
dotnetCART Namespace > Cart Class : Save Method

Serialize cart object to an XML string.

Syntax

Visual Basic (Declaration)
Public Function Save() As String
C#
public string Save()

Return Value

Returns an XML representation of the cart object.

Remarks

Save works in conjunction with load to enable .netCART's powerful state maintenance features.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

SaveCookieDB Method
[image]
dotnetCART Namespace > Cart Class : SaveCookieDB Method

Calls Save and pushes items XML to the cart table with Customer.ID if populated and otherwise uses Cart.ID, then storing Cart.ID in a Cookie.

Syntax

Visual Basic (Declaration)
Public Function SaveCookieDB() As Boolean
C#
public bool SaveCookieDB()

Return Value

A boolean, true on success

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

SaveDB Method
[image]
dotnetCART Namespace > Cart Class : SaveDB Method

Calls Save and pushes cart XML to the cart table with Customer.ID if populated and otherwise uses Cart.ID

Syntax

Visual Basic (Declaration)
Public Function SaveDB() As Boolean
C#
public bool SaveDB()

Return Value

A boolean, true on success

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

SaveItems Method
[image]
dotnetCART Namespace > Cart Class : SaveItems Method

Serialize cart.Items to an XML string.

Overload List

Overload | Description
SaveItems() | Serialize cart.Items to an XML string.
SaveItems(Boolean) | Serialize cart.Items to an XML string.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

SaveItems() Method
[image]
dotnetCART Namespace > Cart Class > SaveItems Method : SaveItems() Method

Serialize cart.Items to an XML string.

Syntax

Visual Basic (Declaration)
Public Overloads Function SaveItems() As String
C#
public string SaveItems()

Return Value

Returns an XML representation of the cart's items only.

Remarks

SaveItems works in conjunction with LoadItems to enable cart items to be saved / loaded from any source.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members
Overload List


%%PageItemTitle%%

SaveItems(Boolean) Method
[image]
dotnetCART Namespace > Cart Class > SaveItems Method : SaveItems(Boolean) Method

saveAddress
Determines whether Item.Address is serialized or not.
Serialize cart.Items to an XML string.

Syntax

Visual Basic (Declaration)
Public Overloads Function SaveItems( _
   ByVal saveAddress As Boolean _
) As String
C#
public string SaveItems(
   bool saveAddress
)

Parameters

saveAddress
Determines whether Item.Address is serialized or not.

Return Value

Returns an XML representation of the cart's items only.

Remarks

SaveItems works in conjunction with LoadItems to enable cart items to be saved / loaded from any source.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members
Overload List


%%PageItemTitle%%

SaveItemsCookieDB Method
[image]
dotnetCART Namespace > Cart Class : SaveItemsCookieDB Method

Calls SaveItems and pushes items XML to the cart table with Customer.ID if populated and otherwise uses Cart.ID, then storing Cart.ID in a Cookie.

Syntax

Visual Basic (Declaration)
Public Function SaveItemsCookieDB() As Boolean
C#
public bool SaveItemsCookieDB()

Return Value

A boolean, true on success

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

SaveItemsDB Method
[image]
dotnetCART Namespace > Cart Class : SaveItemsDB Method

Calls SaveItems and pushes items XML to the cart table with Customer.ID if populated and otherwise uses Cart.ID

Syntax

Visual Basic (Declaration)
Public Function SaveItemsDB() As Boolean
C#
public bool SaveItemsDB()

Return Value

A boolean, true on success

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

SaveOrderDB Method
[image]
dotnetCART Namespace > Cart Class : SaveOrderDB Method

Saves a complete order to the relational database back end. This method saves customer, address, item, orderitem, option, payment and all other data for the order.

Overload List

Overload | Description
SaveOrderDB() | Saves a complete order to the relational database back end. This method saves customer, address, item, orderitem, option, payment and all other data for the order.
SaveOrderDB(Boolean) | Saves a complete order to the relational database back end. This method saves customer, address, item, orderitem, option, payment and all other data for the order.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

SaveOrderDB() Method
[image]
dotnetCART Namespace > Cart Class > SaveOrderDB Method : SaveOrderDB() Method

Saves a complete order to the relational database back end. This method saves customer, address, item, orderitem, option, payment and all other data for the order.

Syntax

Visual Basic (Declaration)
Public Overloads Function SaveOrderDB() As String
C#
public string SaveOrderDB()

Return Value

An end user error string. For the developer's error, Cart.Errors collection.

Remarks

This method saves the referrer querystring and domain for this customer by loading the last link from Referrers table. For more inforamtion see Referrer.SaveDB. This data is used in Reports->Referrer to show which links have been derived the most sales.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members
Overload List


%%PageItemTitle%%

SaveOrderDB(Boolean) Method
[image]
dotnetCART Namespace > Cart Class > SaveOrderDB Method : SaveOrderDB(Boolean) Method

inlineRegistration
If it is set to true, customer's information including customer.Addresses are saved in Customers and Addresses tables.
Saves a complete order to the relational database back end. This method saves customer, address, item, orderitem, option, payment and all other data for the order.

Syntax

Visual Basic (Declaration)
Public Overloads Function SaveOrderDB( _
   ByVal inlineRegistration As Boolean _
) As String
C#
public string SaveOrderDB(
   bool inlineRegistration
)

Parameters

inlineRegistration
If it is set to true, customer's information including customer.Addresses are saved in Customers and Addresses tables.

Return Value

An end user error string. For the developer's error, Cart.Errors collection.

Remarks

This method saves the referrer querystring and domain for this customer by loading the last link from Referrers table. For more inforamtion see Referrer.SaveDB. This data is used in Reports->Referrer to show which links have been derived the most sales.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members
Overload List


%%PageItemTitle%%

SetCustom Method
[image]
dotnetCART Namespace > Cart Class : SetCustom Method

name
The name of the field.
newValue
The new value for the custom field.
Sets the value of a custom field based on the key and value provided. If it finds a key with the same name already exists it updates the value, if there is no such value a new entry will be added.

Syntax

Visual Basic (Declaration)
Public Function SetCustom( _
   ByVal name As String, _
   ByVal newValue As Object _
) As Object
C#
public object SetCustom(
   string name,
   object newValue
)

Parameters

name
The name of the field.
newValue
The new value for the custom field.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%% $$Properties$$

Cart Class Properties
[image]
dotnetCART Namespace : Cart Class

For a list of all members of this type, see Cart members.

Public Properties

 | Name | Description
Public Property | Adjust | Gets or sets an Adjust amount associated with this cart. The total cart level adjustment calculated based on the AdjustRate value or formula. This property is populated by a calculate method call and typically would be treated as read only.
Public Property | AdjustRate | The cart level adjust rate can be set as a dollar amount or percentage based on dollar or quantity ranges. This formula accepts quantity and price ranges and adjusts based on a fixed amount or percentage. Ranges can be defined as quantity (1-10), dollars ($1-10) and also support open ended ranges e.g. 10 and up (10-). Adjustments can also be made as surcharges by using "+" rather than "-".
Public Property | BillAddress | Gets or sets the current billing address.
Public Property | CatalogUrl | The URL of the catalog page, this property can be used to link back to the last area in the catalog the customer was shopping in prior to adding an item to the cart.
Public Property | Country | A referecne to the Country object.
Public Property | Coupon | Gets or sets a Coupon which is added to the cart's Coupons when the cart.Coupons.Add() method is invoked.
Public Property | Coupons | Collection of Coupon objects associated with this cart.
Public Property | Currency | A referecne to the Currency object.
Public Property | Custom | Gets or sets a Custom which is added to the cart's Customs when the cart.Customs.Add() method is invoked.
Public Property | Customer | Gets or sets a Customer associated with this cart.
Public Property | Customs | A collection of Custom objects associated with Orders and OrdersHistory tables.
Public Property | Error | Returns an object with the error information.
Public Property | Errors | A collection of Error object.
Public Property | FraudScore | A reference to the FraudScore object.
Public Property | ID | Unique ID assigned to each cart. This ID is generated by .netCART.
Public Property | IsBillingSameAsShipping | Determines whether cart ShipAddress is the same as BillAddress or not.
Public Property | Item | Gets or sets an Item which is added to the cart's Items when the cart.Items.Add() method is invoked.
Public Property | Items | Collection of Item objects associated with this cart.
Public Property | LiveHelp | A reference to the LiveHelp object for setting its properties.
Public Property | OrderID | Gets or sets an orderID associated with this cart.
Public Property | Payment | Gets or sets a Payment associated with this cart.
Public Property | Ship | A referecne to the Ship.
Public Property | ShipAddress | Gets or sets the current shipping address.
Public Property | SubTotal | Gets or sets a SubTotal amount associated with this cart.
Public Property | Tax | Gets or sets a Tax which is added to the cart's Taxes when the cart.Taxes.Add() method is invoked.
Public Property | Taxes | A collection of Tax objects associated with this cart.
Public Property | Total | Gets or sets a Total amount associated with this cart.
Public Property | TotalAdjust | Calculates all items and cart adjust.
Public Property | TotalCoupon | Gets or sets a TotalCoupon amount associated with this cart.
Public Property | TotalQuantity | Total items in the cart.
Public Property | TotalShipping | Total shipping charges for the cart.
Public Property | TotalTax | Gets or sets a TotalTax amount associated with this cart.
Public Property | TotalWeight | Gets or sets a TotalWeight amount associated with this cart.
Top

See Also

Reference

Cart Class
dotnetCART Namespace


%%PageItemTitle%%

Adjust Property
[image]
dotnetCART Namespace > Cart Class : Adjust Property

Gets or sets an Adjust amount associated with this cart. The total cart level adjustment calculated based on the AdjustRate value or formula. This property is populated by a calculate method call and typically would be treated as read only.

Syntax

Visual Basic (Declaration)
Public Property Adjust As Decimal
C#
public decimal Adjust {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

AdjustRate Property
See Also Example
[image]
dotnetCART Namespace > Cart Class : AdjustRate Property

The cart level adjust rate can be set as a dollar amount or percentage based on dollar or quantity ranges. This formula accepts quantity and price ranges and adjusts based on a fixed amount or percentage. Ranges can be defined as quantity (1-10), dollars ($1-10) and also support open ended ranges e.g. 10 and up (10-). Adjustments can also be made as surcharges by using "+" rather than "-".

Syntax

Visual Basic (Declaration)
Public Property AdjustRate As String
C#
public string AdjustRate {get; set;}

Example

C# Copy Code
Cart.AdjustRate = "$1=-10%;$2=-20%;$3=-30%;";
Cart.AdjustRate = "1=-10%;2=-20%;3-=-30%;";
Cart.AdjustRate = "1=10;2=20;3=30;4-100=35;101-=40;";

Visual Basic Copy Code
Cart.AdjustRate = "$1=-10%;$2=-20%;$3=-30%;"
Cart.AdjustRate = "1=-10%;2=-20%;3-=-30%;"
Cart.AdjustRate = "1=10;2=20;3=30;4-100=35;101-=40;"

Remarks

In Calculate() method, if this property is empty, Settings.AdjustRate property is used.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

BillAddress Property
[image]
dotnetCART Namespace > Cart Class : BillAddress Property

Gets or sets the current billing address.

Syntax

Visual Basic (Declaration)
Public Property BillAddress As Address
C#
public Address BillAddress {get; set;}

Remarks

The billing address is stored in Addresses. DefaultBillAddressID can be set to the Address.ID of the current billing address.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

CatalogUrl Property
[image]
dotnetCART Namespace > Cart Class : CatalogUrl Property

The URL of the catalog page, this property can be used to link back to the last area in the catalog the customer was shopping in prior to adding an item to the cart.

Syntax

Visual Basic (Declaration)
Public Property CatalogUrl As String
C#
public string CatalogUrl {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

Country Property
[image]
dotnetCART Namespace > Cart Class : Country Property

A referecne to the Country object.

Syntax

Visual Basic (Declaration)
Public Property Country As Country
C#
public Country Country {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

Coupon Property
[image]
dotnetCART Namespace > Cart Class : Coupon Property

Gets or sets a Coupon which is added to the cart's Coupons when the cart.Coupons.Add() method is invoked.

Syntax

Visual Basic (Declaration)
Public Property Coupon As Coupon
C#
public Coupon Coupon {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members
Coupons


%%PageItemTitle%%

Coupons Property
[image]
dotnetCART Namespace > Cart Class : Coupons Property

Collection of Coupon objects associated with this cart.

Syntax

Visual Basic (Declaration)
Public Property Coupons As Coupons
C#
public Coupons Coupons {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

Currency Property
[image]
dotnetCART Namespace > Cart Class : Currency Property

A referecne to the Currency object.

Syntax

Visual Basic (Declaration)
Public Property Currency As CartCurrency
C#
public CartCurrency Currency {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

Custom Property
[image]
dotnetCART Namespace > Cart Class : Custom Property

Gets or sets a Custom which is added to the cart's Customs when the cart.Customs.Add() method is invoked.

Syntax

Visual Basic (Declaration)
Public Property Custom As Custom
C#
public Custom Custom {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members
Customs


%%PageItemTitle%%

Customer Property
[image]
dotnetCART Namespace > Cart Class : Customer Property

Gets or sets a Customer associated with this cart.

Syntax

Visual Basic (Declaration)
Public Property Customer As Customer
C#
public Customer Customer {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

Customs Property
[image]
dotnetCART Namespace > Cart Class : Customs Property

A collection of Custom objects associated with Orders and OrdersHistory tables.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Customs As Customs
C#
public Customs Customs {get;}

Remarks

They are saved automatically to Orders and OrdersHistory tables when calling SaveOrderDB method. The custom fields should be added manually to Orders and OrdersHistory tables. For more information see custom fields

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > Cart Class : Error Property

Returns an object with the error information.

Syntax

Visual Basic (Declaration)
Public Property Error As Error
C#
public Error Error {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

Errors Property
[image]
dotnetCART Namespace > Cart Class : Errors Property

A collection of Error object.

Syntax

Visual Basic (Declaration)
Public Property Errors As Errors
C#
public Errors Errors {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

FraudScore Property
[image]
dotnetCART Namespace > Cart Class : FraudScore Property

A reference to the FraudScore object.

Syntax

Visual Basic (Declaration)
Public Property FraudScore As FraudScore
C#
public FraudScore FraudScore {get; set;}

Remarks

The FraudScore system provides fraud analysis which can be used to perform realtime order processing adjustments. Of great benefit to stores offering softgood delivery the FraudScore system is also useful for any type of order processing and is another tool for fulfillment to use when processing an order. By calling Calculate, Total is calculated based on cart and customer's information and Settings.FraudScore which is usually set through StoreAdmin->Settings->FraudScore tab. For the usage sample, see Billing.aspx.cs/vb page.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

ID Property
[image]
dotnetCART Namespace > Cart Class : ID Property

Unique ID assigned to each cart. This ID is generated by .netCART.

Syntax

Visual Basic (Declaration)
Public Property ID As String
C#
public string ID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

IsBillingSameAsShipping Property
[image]
dotnetCART Namespace > Cart Class : IsBillingSameAsShipping Property

Determines whether cart ShipAddress is the same as BillAddress or not.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsBillingSameAsShipping As Boolean
C#
public bool IsBillingSameAsShipping {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

Item Property
[image]
dotnetCART Namespace > Cart Class : Item Property

Gets or sets an Item which is added to the cart's Items when the cart.Items.Add() method is invoked.

Syntax

Visual Basic (Declaration)
Public Property Item As Item
C#
public Item Item {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members
Items


%%PageItemTitle%%

Items Property
See Also Example
[image]
dotnetCART Namespace > Cart Class : Items Property

Collection of Item objects associated with this cart.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Items As Items
C#
public Items Items {get;}

Example

The follwoing code add an item to cart.Items collection.
C# Copy Code
cartObject.Item.ID ="Item1";
cartObject.Item.Name="Item 1";
cartObject.Item.Quantity=2;
cartObject.Items.Add();

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

LiveHelp Property
[image]
dotnetCART Namespace > Cart Class : LiveHelp Property

A reference to the LiveHelp object for setting its properties.

Syntax

Visual Basic (Declaration)
Public Property LiveHelp As CartLiveHelp
C#
public CartLiveHelp LiveHelp {get; set;}

Remarks

.netCART includes .netLIVEHELP integration support. .netLIVEHELP is a solution for providing live help or assistance in your online store. It can assist with greater sales and customer satisfaction. Seamless integration between .netLIVEHELP and .netCART enables you to view and modify the carts of customers you assist using .netLIVEHELP. For example, you could put live help chat on your order form and provide an adjustment to their order prior to submission or save abandoned carts by offering a special incentive for completing the order. More information

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

OrderID Property
[image]
dotnetCART Namespace > Cart Class : OrderID Property

Gets or sets an orderID associated with this cart.

Syntax

Visual Basic (Declaration)
Public Property OrderID As String
C#
public string OrderID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

Payment Property
[image]
dotnetCART Namespace > Cart Class : Payment Property

Gets or sets a Payment associated with this cart.

Syntax

Visual Basic (Declaration)
Public Property Payment As Payment
C#
public Payment Payment {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

Ship Property
[image]
dotnetCART Namespace > Cart Class : Ship Property

A referecne to the Ship.

Syntax

Visual Basic (Declaration)
Public Property Ship As CartShip
C#
public CartShip Ship {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

ShipAddress Property
[image]
dotnetCART Namespace > Cart Class : ShipAddress Property

Gets or sets the current shipping address.

Syntax

Visual Basic (Declaration)
Public Property ShipAddress As Address
C#
public Address ShipAddress {get; set;}

Remarks

The shipping address is stored in Addresses. DefaultShipAddressID can be set to the Address.ID of the default shipping address. Address can be set to a different shipping address.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

SubTotal Property
[image]
dotnetCART Namespace > Cart Class : SubTotal Property

Gets or sets a SubTotal amount associated with this cart.

Syntax

Visual Basic (Declaration)
Public Property SubTotal As Decimal
C#
public decimal SubTotal {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

Tax Property
[image]
dotnetCART Namespace > Cart Class : Tax Property

Gets or sets a Tax which is added to the cart's Taxes when the cart.Taxes.Add() method is invoked.

Syntax

Visual Basic (Declaration)
Public Property Tax As Tax
C#
public Tax Tax {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members
Taxes


%%PageItemTitle%%

Taxes Property
[image]
dotnetCART Namespace > Cart Class : Taxes Property

A collection of Tax objects associated with this cart.

Syntax

Visual Basic (Declaration)
Public Property Taxes As Taxes
C#
public Taxes Taxes {get; set;}

Remarks

Calls cart.Taxes.LoadDB to load the associated taxes from db

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

Total Property
[image]
dotnetCART Namespace > Cart Class : Total Property

Gets or sets a Total amount associated with this cart.

Syntax

Visual Basic (Declaration)
Public Property Total As Decimal
C#
public decimal Total {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

TotalAdjust Property
[image]
dotnetCART Namespace > Cart Class : TotalAdjust Property

Calculates all items and cart adjust.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TotalAdjust As Decimal
C#
public decimal TotalAdjust {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

TotalCoupon Property
[image]
dotnetCART Namespace > Cart Class : TotalCoupon Property

Gets or sets a TotalCoupon amount associated with this cart.

Syntax

Visual Basic (Declaration)
Public Property TotalCoupon As Decimal
C#
public decimal TotalCoupon {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

TotalQuantity Property
[image]
dotnetCART Namespace > Cart Class : TotalQuantity Property

Total items in the cart.

Syntax

Visual Basic (Declaration)
Public Property TotalQuantity As Double
C#
public double TotalQuantity {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

TotalShipping Property
[image]
dotnetCART Namespace > Cart Class : TotalShipping Property

Total shipping charges for the cart.

Syntax

Visual Basic (Declaration)
Public Property TotalShipping As Decimal
C#
public decimal TotalShipping {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

TotalTax Property
[image]
dotnetCART Namespace > Cart Class : TotalTax Property

Gets or sets a TotalTax amount associated with this cart.

Syntax

Visual Basic (Declaration)
Public Property TotalTax As Decimal
C#
public decimal TotalTax {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

TotalWeight Property
[image]
dotnetCART Namespace > Cart Class : TotalWeight Property

Gets or sets a TotalWeight amount associated with this cart.

Syntax

Visual Basic (Declaration)
Public Property TotalWeight As Double
C#
public double TotalWeight {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Cart Class
Cart Members


%%PageItemTitle%%

CartCurrency Class
See Also Members
[image]
dotnetCART Namespace : CartCurrency Class

Represents a Currency object.

Object Model

Syntax

Visual Basic (Declaration)
Public Class CartCurrency
C#
public class CartCurrency

Inheritance Hierarchy

System.Object
dotnetCART.CartCurrency

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartCurrency Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

CartCurrency Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : CartCurrency Class

The following tables list the members exposed by CartCurrency.

Public Constructors

 | Name | Description
Public Constructor | CartCurrency Constructor | Creates a new instance of the Currency Object.
Top

Public Properties

 | Name | Description
Public Property | AdjustRate | Controls if the returned currency calculation will be adjusted plus or minus a fixed amount or percentage. For example if you wish to display conversions between common currencies however the rates are consistently higher than your banks rates you may wish to set the adjust property.
Public Property | Base | A 3 character currency code.
Public Property | Error | Gets the error object.
Public Property | Host | Set to a URL for updating XML currency rates. This property should not be set except after confirming with .netCART support.
Public Property | LastUpdate | Returns the date and time of the last real-time update. Read only.
Public Property | Timeout | An integer which controls the timeout in seconds while waiting for the updated rates response. Default is 45 seconds.
Public Property | UpdateStatus | Returns true or false, this property will indicate if the last update was sucessful or not. Read only.
Public Property | Xml | Set the file name or path for the currency XML. By default, it is stored in App_Data\currencies.xml.
Public Property | XmlDocument | Returns the loaded XmlDocument from xml currency rates. Read only.
Top

Public Methods

 | Name | Description
Public Method | CodeToCulture | Returns the applicable culture name from the provided currency code.
Public Method | CodeToCurrency | Returns the applicable full currency name from the provided currency code.
Public Method | CodeToSymbol | Overloaded. Returns the applicable currency symbol from the provided currency code.
Public Method | Convert | Overloaded. Converts the amount provided to the currency specified or uses the base currency if it is not specified.
Public Method | ConvertFormat | Overloaded. Returns a formatted string after converting the amount to the currency specified in Customer.Currency if exists, otherwise uses Store.Settings.Currency.Base.
Public Method | CurrencyToCode | Returns the applicable currency code from the provided full currency name.
Public Method | Format | Overloaded. Returns a formatted string as the currency should be formatted including decimals, seperator, and currency symbol.
Public Method | GetAmount | Returns a decimal number from a formmatted currency string.
Public Method | Rate | Overloaded. Returns the current exchange rate for the specified currency code for the base currency in use.
Public Method | Update | Updates the local XML currency rates from Oanda site.
Top

See Also

Reference

CartCurrency Class
dotnetCART Namespace


%%PageItemTitle%%

CartCurrency Constructor
[image]
dotnetCART Namespace > CartCurrency Class : CartCurrency Constructor

Creates a new instance of the Currency Object.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public CartCurrency()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartCurrency Class
CartCurrency Members


%%PageItemTitle%% $$Methods$$

CartCurrency Class Methods
[image]
dotnetCART Namespace : CartCurrency Class

For a list of all members of this type, see CartCurrency members.

Public Methods

 | Name | Description
Public Method | CodeToCulture | Returns the applicable culture name from the provided currency code.
Public Method | CodeToCurrency | Returns the applicable full currency name from the provided currency code.
Public Method | CodeToSymbol | Overloaded. Returns the applicable currency symbol from the provided currency code.
Public Method | Convert | Overloaded. Converts the amount provided to the currency specified or uses the base currency if it is not specified.
Public Method | ConvertFormat | Overloaded. Returns a formatted string after converting the amount to the currency specified in Customer.Currency if exists, otherwise uses Store.Settings.Currency.Base.
Public Method | CurrencyToCode | Returns the applicable currency code from the provided full currency name.
Public Method | Format | Overloaded. Returns a formatted string as the currency should be formatted including decimals, seperator, and currency symbol.
Public Method | GetAmount | Returns a decimal number from a formmatted currency string.
Public Method | Rate | Overloaded. Returns the current exchange rate for the specified currency code for the base currency in use.
Public Method | Update | Updates the local XML currency rates from Oanda site.
Top

See Also

Reference

CartCurrency Class
dotnetCART Namespace


%%PageItemTitle%%

CodeToCulture Method
[image]
dotnetCART Namespace > CartCurrency Class : CodeToCulture Method

code
A 3 character currency code
Returns the applicable culture name from the provided currency code.

Syntax

Visual Basic (Declaration)
Public Function CodeToCulture( _
   ByVal code As String _
) As String
C#
public string CodeToCulture(
   string code
)

Parameters

code
A 3 character currency code

Return Value

A culture name.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartCurrency Class
CartCurrency Members


%%PageItemTitle%%

CodeToCurrency Method
[image]
dotnetCART Namespace > CartCurrency Class : CodeToCurrency Method

code
A 3 character currency code.
Returns the applicable full currency name from the provided currency code.

Syntax

Visual Basic (Declaration)
Public Function CodeToCurrency( _
   ByVal code As String _
) As String
C#
public string CodeToCurrency(
   string code
)

Parameters

code
A 3 character currency code.

Return Value

Full currency name.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartCurrency Class
CartCurrency Members


%%PageItemTitle%%

CodeToSymbol Method
[image]
dotnetCART Namespace > CartCurrency Class : CodeToSymbol Method

Returns the applicable currency symbol from the provided currency code.

Overload List

Overload | Description
CodeToSymbol(String) | Returns the applicable currency symbol from the provided currency code.
CodeToSymbol() | Returns the applicable currency symbol from the provided currency code.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartCurrency Class
CartCurrency Members


%%PageItemTitle%%

CodeToSymbol(String) Method
[image]
dotnetCART Namespace > CartCurrency Class > CodeToSymbol Method : CodeToSymbol(String) Method

code
A 3 character currency code.
Returns the applicable currency symbol from the provided currency code.

Syntax

Visual Basic (Declaration)
Public Overloads Function CodeToSymbol( _
   ByVal code As String _
) As String
C#
public string CodeToSymbol(
   string code
)

Parameters

code
A 3 character currency code.

Return Value

Currency symbol.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartCurrency Class
CartCurrency Members
Overload List


%%PageItemTitle%%

CodeToSymbol() Method
[image]
dotnetCART Namespace > CartCurrency Class > CodeToSymbol Method : CodeToSymbol() Method

Returns the applicable currency symbol from the provided currency code.

Syntax

Visual Basic (Declaration)
Public Overloads Function CodeToSymbol() As String
C#
public string CodeToSymbol()

Return Value

Currency symbol.

Remarks

For base currency, it uses Customer.Currency if exists, otherwise uses Store.Settings.Currency.Base

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartCurrency Class
CartCurrency Members
Overload List


%%PageItemTitle%%

Convert Method
[image]
dotnetCART Namespace > CartCurrency Class : Convert Method

Converts the amount provided to the currency specified or uses the base currency if it is not specified.

Overload List

Overload | Description
Convert(Decimal,String) | Converts the amount provided to the currency specified or uses the base currency if it is not specified.
Convert(String) | Converts the amount provided.
Convert(Decimal) | Converts the amount provided.
Convert(Decimal,String,Int32) | Converts the amount provided.
Convert(Decimal,String,Int32,String) | Converts the amount provided.
Convert(Decimal,String,String) |

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartCurrency Class
CartCurrency Members


%%PageItemTitle%%

Convert(Decimal,String) Method
[image]
dotnetCART Namespace > CartCurrency Class > Convert Method : Convert(Decimal,String) Method

amount
A decimal number.
code
A 3 character currency code.
Converts the amount provided to the currency specified or uses the base currency if it is not specified.

Syntax

Visual Basic (Declaration)
Public Overloads Function Convert( _
   ByVal amount As Decimal, _
   ByVal code As String _
) As Decimal
C#
public decimal Convert(
   decimal amount,
   string code
)

Parameters

amount
A decimal number.
code
A 3 character currency code.

Return Value

A decimal number.

Remarks

For the currency precision, uses Settings.Precision.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartCurrency Class
CartCurrency Members
Overload List


%%PageItemTitle%%

Convert(String) Method
[image]
dotnetCART Namespace > CartCurrency Class > Convert Method : Convert(String) Method

strAmount
>A string number.
Converts the amount provided.

Syntax

Visual Basic (Declaration)
Public Overloads Function Convert( _
   ByVal strAmount As String _
) As Decimal
C#
public decimal Convert(
   string strAmount
)

Parameters

strAmount
>A string number.

Return Value

A decimal number.

Remarks

For base currency, it uses Customer.Currency if exists, otherwise uses Base.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartCurrency Class
CartCurrency Members
Overload List


%%PageItemTitle%%

Convert(Decimal) Method
[image]
dotnetCART Namespace > CartCurrency Class > Convert Method : Convert(Decimal) Method

amount
>A decimal number.
Converts the amount provided.

Syntax

Visual Basic (Declaration)
Public Overloads Function Convert( _
   ByVal amount As Decimal _
) As Decimal
C#
public decimal Convert(
   decimal amount
)

Parameters

amount
>A decimal number.

Return Value

A decimal number.

Remarks

For base currency, it uses Customer.Currency if exists, otherwise uses Store.Settings.Currency.Base.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartCurrency Class
CartCurrency Members
Overload List


%%PageItemTitle%%

Convert(Decimal,String,Int32) Method
[image]
dotnetCART Namespace > CartCurrency Class > Convert Method : Convert(Decimal,String,Int32) Method

amount
>A decimal number.
code
A 3 character currency code.
decimalPoint
An integer for the decimal points.
Converts the amount provided.

Syntax

Visual Basic (Declaration)
Public Overloads Function Convert( _
   ByVal amount As Decimal, _
   ByVal code As String, _
   ByVal decimalPoint As Integer _
) As Decimal
C#
public decimal Convert(
   decimal amount,
   string code,
   int decimalPoint
)

Parameters

amount
>A decimal number.
code
A 3 character currency code.
decimalPoint
An integer for the decimal points.

Return Value

A decimal number.

Remarks

It uses Store.Settings.Currency.Base for the base currency.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartCurrency Class
CartCurrency Members
Overload List


%%PageItemTitle%%

Convert(Decimal,String,Int32,String) Method
[image]
dotnetCART Namespace > CartCurrency Class > Convert Method : Convert(Decimal,String,Int32,String) Method

amount
>A decimal number.
code
A 3 character currency code.
decimalPoint
An integer for the decimal points.
baseCode
A 3 character currency code.
Converts the amount provided.

Syntax

Visual Basic (Declaration)
Public Overloads Function Convert( _
   ByVal amount As Decimal, _
   ByVal code As String, _
   ByVal decimalPoint As Integer, _
   ByVal baseCode As String _
) As Decimal
C#
public decimal Convert(
   decimal amount,
   string code,
   int decimalPoint,
   string baseCode
)

Parameters

amount
>A decimal number.
code
A 3 character currency code.
decimalPoint
An integer for the decimal points.
baseCode
A 3 character currency code.

Return Value

A decimal number.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartCurrency Class
CartCurrency Members
Overload List


%%PageItemTitle%%

Convert(Decimal,String,String) Method
[image]
dotnetCART Namespace > CartCurrency Class > Convert Method : Convert(Decimal,String,String) Method

amount
code
baseCode

Syntax

Visual Basic (Declaration)
Public Overloads Function Convert( _
   ByVal amount As Decimal, _
   ByVal code As String, _
   ByVal baseCode As String _
) As Decimal
C#
public decimal Convert(
   decimal amount,
   string code,
   string baseCode
)

Parameters

amount
code
baseCode

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartCurrency Class
CartCurrency Members
Overload List


%%PageItemTitle%%

ConvertFormat Method
[image]
dotnetCART Namespace > CartCurrency Class : ConvertFormat Method

Returns a formatted string after converting the amount to the currency specified in Customer.Currency if exists, otherwise uses Store.Settings.Currency.Base.

Overload List

Overload | Description
ConvertFormat(Decimal,Int32) | Returns a formatted string after converting the amount to the currency specified in Customer.Currency if exists, otherwise uses Store.Settings.Currency.Base.
ConvertFormat(Decimal) | Returns a formatted string after converting the amount to the currency specified in Customer.Currency if exists, otherwise uses Store.Settings.Currency.Base.
ConvertFormat(String) | Returns a formatted string after converting the amount to the currency specified in Customer.Currency if exists, otherwise uses Store.Settings.Currency.Base.
ConvertFormat(Decimal,String) | Returns a formatted string after converting the amount to the currency specified in Customer.Currency if exists, otherwise uses Store.Settings.Currency.Base.
ConvertFormat(Decimal,String,String) | Returns a formatted string after converting the amount to the curCode from the baseCode.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartCurrency Class
CartCurrency Members


%%PageItemTitle%%

ConvertFormat(Decimal,Int32) Method
[image]
dotnetCART Namespace > CartCurrency Class > ConvertFormat Method : ConvertFormat(Decimal,Int32) Method

amount
A decimal number.
decimalPoint
An integer for the decimal points.
Returns a formatted string after converting the amount to the currency specified in Customer.Currency if exists, otherwise uses Store.Settings.Currency.Base.

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFormat( _
   ByVal amount As Decimal, _
   ByVal decimalPoint As Integer _
) As String
C#
public string ConvertFormat(
   decimal amount,
   int decimalPoint
)

Parameters

amount
A decimal number.
decimalPoint
An integer for the decimal points.

Return Value

Formatted amount string.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartCurrency Class
CartCurrency Members
Overload List


%%PageItemTitle%%

ConvertFormat(Decimal) Method
[image]
dotnetCART Namespace > CartCurrency Class > ConvertFormat Method : ConvertFormat(Decimal) Method

amount
A decimal number.
Returns a formatted string after converting the amount to the currency specified in Customer.Currency if exists, otherwise uses Store.Settings.Currency.Base.

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFormat( _
   ByVal amount As Decimal _
) As String
C#
public string ConvertFormat(
   decimal amount
)

Parameters

amount
A decimal number.

Return Value

Formatted amount string.

Remarks

For the currency precision, uses Settings.Precision.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartCurrency Class
CartCurrency Members
Overload List


%%PageItemTitle%%

ConvertFormat(String) Method
[image]
dotnetCART Namespace > CartCurrency Class > ConvertFormat Method : ConvertFormat(String) Method

strAmount
A decimal number in a string.
Returns a formatted string after converting the amount to the currency specified in Customer.Currency if exists, otherwise uses Store.Settings.Currency.Base.

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFormat( _
   ByVal strAmount As String _
) As String
C#
public string ConvertFormat(
   string strAmount
)

Parameters

strAmount
A decimal number in a string.

Return Value

Formatted amount string.

Remarks

For the currency precision, uses Settings.Precision.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartCurrency Class
CartCurrency Members
Overload List


%%PageItemTitle%%

ConvertFormat(Decimal,String) Method
[image]
dotnetCART Namespace > CartCurrency Class > ConvertFormat Method : ConvertFormat(Decimal,String) Method

amount
A decimal number.
curCode
>A 3 character currency code.
Returns a formatted string after converting the amount to the currency specified in Customer.Currency if exists, otherwise uses Store.Settings.Currency.Base.

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFormat( _
   ByVal amount As Decimal, _
   ByVal curCode As String _
) As String
C#
public string ConvertFormat(
   decimal amount,
   string curCode
)

Parameters

amount
A decimal number.
curCode
>A 3 character currency code.

Return Value

Formatted amount string.

Remarks

For the currency precision, uses Settings.Precision.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartCurrency Class
CartCurrency Members
Overload List


%%PageItemTitle%%

ConvertFormat(Decimal,String,String) Method
[image]
dotnetCART Namespace > CartCurrency Class > ConvertFormat Method : ConvertFormat(Decimal,String,String) Method

amount
A decimal number.
curCode
A 3 character currency code.
baseCode
A 3 character currency code.
Returns a formatted string after converting the amount to the curCode from the baseCode.

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFormat( _
   ByVal amount As Decimal, _
   ByVal curCode As String, _
   ByVal baseCode As String _
) As String
C#
public string ConvertFormat(
   decimal amount,
   string curCode,
   string baseCode
)

Parameters

amount
A decimal number.
curCode
A 3 character currency code.
baseCode
A 3 character currency code.

Return Value

Formatted amount string.

Remarks

For the currency precision, uses Settings.Precision.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartCurrency Class
CartCurrency Members
Overload List


%%PageItemTitle%%

CurrencyToCode Method
[image]
dotnetCART Namespace > CartCurrency Class : CurrencyToCode Method

Currency
A full currency name.
Returns the applicable currency code from the provided full currency name.

Syntax

Visual Basic (Declaration)
Public Function CurrencyToCode( _
   ByVal Currency As String _
) As String
C#
public string CurrencyToCode(
   string Currency
)

Parameters

Currency
A full currency name.

Return Value

A 3 character currency code.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartCurrency Class
CartCurrency Members


%%PageItemTitle%%

Format Method
[image]
dotnetCART Namespace > CartCurrency Class : Format Method

Returns a formatted string as the currency should be formatted including decimals, seperator, and currency symbol.

Overload List

Overload | Description
Format(Decimal) | Returns a formatted string as the currency should be formatted including decimals, seperator, and currency symbol.
Format(Decimal,Int32) | Returns a formatted string as the currency should be formatted including decimals, seperator, and currency symbol.
Format(String) | Returns a formatted string as the currency should be formatted including decimals, seperator, and currency symbol.
Format(Decimal,String) | Returns a formatted string as the currency should be formatted including decimals, seperator, and currency symbol.
Format(Decimal,String,Int32) | Returns a formatted string as the currency should be formatted including decimals, seperator, and currency symbol.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartCurrency Class
CartCurrency Members


%%PageItemTitle%%

Format(Decimal) Method
[image]
dotnetCART Namespace > CartCurrency Class > Format Method : Format(Decimal) Method

amount
A decimal number.
Returns a formatted string as the currency should be formatted including decimals, seperator, and currency symbol.

Syntax

Visual Basic (Declaration)
Public Overloads Function Format( _
   ByVal amount As Decimal _
) As String
C#
public string Format(
   decimal amount
)

Parameters

amount
A decimal number.

Return Value

Formatted amount string.

Remarks

For base currency, it uses Customer.Currency if exists, otherwise uses Store.Settings.Currency.Base. For the currency precision, uses Settings.Precision.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartCurrency Class
CartCurrency Members
Overload List


%%PageItemTitle%%

Format(Decimal,Int32) Method
[image]
dotnetCART Namespace > CartCurrency Class > Format Method : Format(Decimal,Int32) Method

amount
A decimal number.
decimalPoint
An integer for the decimal points.
Returns a formatted string as the currency should be formatted including decimals, seperator, and currency symbol.

Syntax

Visual Basic (Declaration)
Public Overloads Function Format( _
   ByVal amount As Decimal, _
   ByVal decimalPoint As Integer _
) As String
C#
public string Format(
   decimal amount,
   int decimalPoint
)

Parameters

amount
A decimal number.
decimalPoint
An integer for the decimal points.

Return Value

Formatted amount string.

Remarks

For base currency, it uses Customer.Currency if exists, otherwise uses Store.Settings.Currency.Base.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartCurrency Class
CartCurrency Members
Overload List


%%PageItemTitle%%

Format(String) Method
[image]
dotnetCART Namespace > CartCurrency Class > Format Method : Format(String) Method

strAmount
A string number.
Returns a formatted string as the currency should be formatted including decimals, seperator, and currency symbol.

Syntax

Visual Basic (Declaration)
Public Overloads Function Format( _
   ByVal strAmount As String _
) As String
C#
public string Format(
   string strAmount
)

Parameters

strAmount
A string number.

Return Value

Formatted amount string.

Remarks

For base currency, it uses Customer.Currency if exists, otherwise uses Store.Settings.Currency.Base. For the currency precision, uses Settings.Precision.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartCurrency Class
CartCurrency Members
Overload List


%%PageItemTitle%%

Format(Decimal,String) Method
[image]
dotnetCART Namespace > CartCurrency Class > Format Method : Format(Decimal,String) Method

amount
A decimal number.
curCode
A 3 character currency code.
Returns a formatted string as the currency should be formatted including decimals, seperator, and currency symbol.

Syntax

Visual Basic (Declaration)
Public Overloads Function Format( _
   ByVal amount As Decimal, _
   ByVal curCode As String _
) As String
C#
public string Format(
   decimal amount,
   string curCode
)

Parameters

amount
A decimal number.
curCode
A 3 character currency code.

Return Value

Formatted amount string.

Remarks

For the currency precision, uses Settings.Precision.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartCurrency Class
CartCurrency Members
Overload List


%%PageItemTitle%%

Format(Decimal,String,Int32) Method
[image]
dotnetCART Namespace > CartCurrency Class > Format Method : Format(Decimal,String,Int32) Method

amount
A decimal number.
curCode
A 3 character currency code.
decimalPoint
An integer for the decimal points.
Returns a formatted string as the currency should be formatted including decimals, seperator, and currency symbol.

Syntax

Visual Basic (Declaration)
Public Overloads Function Format( _
   ByVal amount As Decimal, _
   ByVal curCode As String, _
   ByVal decimalPoint As Integer _
) As String
C#
public string Format(
   decimal amount,
   string curCode,
   int decimalPoint
)

Parameters

amount
A decimal number.
curCode
A 3 character currency code.
decimalPoint
An integer for the decimal points.

Remarks

For the currency precision, uses Settings.Precision.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartCurrency Class
CartCurrency Members
Overload List


%%PageItemTitle%%

GetAmount Method
[image]
dotnetCART Namespace > CartCurrency Class : GetAmount Method

strAmount
A currency string.
Returns a decimal number from a formmatted currency string.

Syntax

Visual Basic (Declaration)
Public Function GetAmount( _
   ByVal strAmount As String _
) As Decimal
C#
public decimal GetAmount(
   string strAmount
)

Parameters

strAmount
A currency string.

Return Value

A decimal number.

Remarks

For base currency, it uses Customer.Currency if exists, otherwise uses Store.Settings.Currency.Base.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartCurrency Class
CartCurrency Members


%%PageItemTitle%%

Rate Method
[image]
dotnetCART Namespace > CartCurrency Class : Rate Method

Returns the current exchange rate for the specified currency code for the base currency in use.

Overload List

Overload | Description
Rate(String,String) | Returns the current exchange rate for the specified currency code for the base currency in use.
Rate(String) | Returns the current exchange rate for the specified currency code for the base currency in use.
Rate(String,String,Boolean) | Returns the current exchange rate for the specified currency code for the base currency in use.
Rate(String,Boolean) | Returns the current exchange rate for the specified currency code for the base currency in use.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartCurrency Class
CartCurrency Members


%%PageItemTitle%%

Rate(String,String) Method
[image]
dotnetCART Namespace > CartCurrency Class > Rate Method : Rate(String,String) Method

Code
A 3 character currency code.
baseCode
A 3 character currency code.
Returns the current exchange rate for the specified currency code for the base currency in use.

Syntax

Visual Basic (Declaration)
Public Overloads Function Rate( _
   ByVal Code As String, _
   ByVal baseCode As String _
) As Double
C#
public double Rate(
   string Code,
   string baseCode
)

Parameters

Code
A 3 character currency code.
baseCode
A 3 character currency code.

Return Value

A rate number.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartCurrency Class
CartCurrency Members
Overload List


%%PageItemTitle%%

Rate(String) Method
[image]
dotnetCART Namespace > CartCurrency Class > Rate Method : Rate(String) Method

Code
A 3 character currency code.
Returns the current exchange rate for the specified currency code for the base currency in use.

Syntax

Visual Basic (Declaration)
Public Overloads Function Rate( _
   ByVal Code As String _
) As Double
C#
public double Rate(
   string Code
)

Parameters

Code
A 3 character currency code.

Return Value

A rate number.

Remarks

It uses Store.Settings.Currency.Base for the base currency.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartCurrency Class
CartCurrency Members
Overload List


%%PageItemTitle%%

Rate(String,String,Boolean) Method
[image]
dotnetCART Namespace > CartCurrency Class > Rate Method : Rate(String,String,Boolean) Method

Code
A 3 character currency code.
baseCode
A 3 character currency code.
format
Returns the current exchange rate for the specified currency code for the base currency in use.

Syntax

Visual Basic (Declaration)
Public Overloads Function Rate( _
   ByVal Code As String, _
   ByVal baseCode As String, _
   ByVal format As Boolean _
) As Double
C#
public double Rate(
   string Code,
   string baseCode,
   bool format
)

Parameters

Code
A 3 character currency code.
baseCode
A 3 character currency code.
format

Return Value

A rate number.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartCurrency Class
CartCurrency Members
Overload List


%%PageItemTitle%%

Rate(String,Boolean) Method
[image]
dotnetCART Namespace > CartCurrency Class > Rate Method : Rate(String,Boolean) Method

Code
A 3 character currency code.
format
Returns the current exchange rate for the specified currency code for the base currency in use.

Syntax

Visual Basic (Declaration)
Public Overloads Function Rate( _
   ByVal Code As String, _
   ByVal format As Boolean _
) As Double
C#
public double Rate(
   string Code,
   bool format
)

Parameters

Code
A 3 character currency code.
format

Return Value

A rate number.

Remarks

It uses Store.Settings.Currency.Base for the base currency.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartCurrency Class
CartCurrency Members
Overload List


%%PageItemTitle%%

Update Method
[image]
dotnetCART Namespace > CartCurrency Class : Update Method

updatePriod
Determines the update priod. "10,H" update if the lastupdate is more than 10 hours. "1,D" update if the lastupdate is more than 1 day.
Updates the local XML currency rates from Oanda site.

Syntax

Visual Basic (Declaration)
Public Function Update( _
   ByVal updatePriod As String _
) As Boolean
C#
public bool Update(
   string updatePriod
)

Parameters

updatePriod
Determines the update priod. "10,H" update if the lastupdate is more than 10 hours. "1,D" update if the lastupdate is more than 1 day.

Return Value

Indicates whether the update was successfull or not.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartCurrency Class
CartCurrency Members


%%PageItemTitle%% $$Properties$$

CartCurrency Class Properties
[image]
dotnetCART Namespace : CartCurrency Class

For a list of all members of this type, see CartCurrency members.

Public Properties

 | Name | Description
Public Property | AdjustRate | Controls if the returned currency calculation will be adjusted plus or minus a fixed amount or percentage. For example if you wish to display conversions between common currencies however the rates are consistently higher than your banks rates you may wish to set the adjust property.
Public Property | Base | A 3 character currency code.
Public Property | Error | Gets the error object.
Public Property | Host | Set to a URL for updating XML currency rates. This property should not be set except after confirming with .netCART support.
Public Property | LastUpdate | Returns the date and time of the last real-time update. Read only.
Public Property | Timeout | An integer which controls the timeout in seconds while waiting for the updated rates response. Default is 45 seconds.
Public Property | UpdateStatus | Returns true or false, this property will indicate if the last update was sucessful or not. Read only.
Public Property | Xml | Set the file name or path for the currency XML. By default, it is stored in App_Data\currencies.xml.
Public Property | XmlDocument | Returns the loaded XmlDocument from xml currency rates. Read only.
Top

See Also

Reference

CartCurrency Class
dotnetCART Namespace


%%PageItemTitle%%

AdjustRate Property
See Also Example
[image]
dotnetCART Namespace > CartCurrency Class : AdjustRate Property

Controls if the returned currency calculation will be adjusted plus or minus a fixed amount or percentage. For example if you wish to display conversions between common currencies however the rates are consistently higher than your banks rates you may wish to set the adjust property.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property AdjustRate As String
C#
public string AdjustRate {set;}

Example

The follwoing code set adjust rate:
C# Copy Code
obj.AdjustRate = "10%"
obj.AdjustRate = "1.25"
obj.AdjustRate = "-5%"
Visual Basic Copy Code
obj.AdjustRate = "10%"
obj.AdjustRate = "1.25"
obj.AdjustRate = "-5%"

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartCurrency Class
CartCurrency Members


%%PageItemTitle%%

Base Property
[image]
dotnetCART Namespace > CartCurrency Class : Base Property

A 3 character currency code.

Syntax

Visual Basic (Declaration)
Public Property Base As String
C#
public string Base {get; set;}

Remarks

If it is not set, it uses Customer.Currency if exists, otherwise uses Store.Settings.Currency.Base.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartCurrency Class
CartCurrency Members


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > CartCurrency Class : Error Property

Gets the error object.

Syntax

Visual Basic (Declaration)
Public Property Error As Error
C#
public Error Error {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartCurrency Class
CartCurrency Members


%%PageItemTitle%%

Host Property
[image]
dotnetCART Namespace > CartCurrency Class : Host Property

Set to a URL for updating XML currency rates. This property should not be set except after confirming with .netCART support.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property Host As String
C#
public string Host {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartCurrency Class
CartCurrency Members


%%PageItemTitle%%

LastUpdate Property
[image]
dotnetCART Namespace > CartCurrency Class : LastUpdate Property

Returns the date and time of the last real-time update. Read only.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LastUpdate As String
C#
public string LastUpdate {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartCurrency Class
CartCurrency Members


%%PageItemTitle%%

Timeout Property
[image]
dotnetCART Namespace > CartCurrency Class : Timeout Property

An integer which controls the timeout in seconds while waiting for the updated rates response. Default is 45 seconds.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property Timeout As Integer
C#
public int Timeout {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartCurrency Class
CartCurrency Members


%%PageItemTitle%%

UpdateStatus Property
[image]
dotnetCART Namespace > CartCurrency Class : UpdateStatus Property

Returns true or false, this property will indicate if the last update was sucessful or not. Read only.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UpdateStatus As Boolean
C#
public bool UpdateStatus {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartCurrency Class
CartCurrency Members


%%PageItemTitle%%

Xml Property
[image]
dotnetCART Namespace > CartCurrency Class : Xml Property

Set the file name or path for the currency XML. By default, it is stored in App_Data\currencies.xml.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property Xml As String
C#
public string Xml {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartCurrency Class
CartCurrency Members


%%PageItemTitle%%

XmlDocument Property
[image]
dotnetCART Namespace > CartCurrency Class : XmlDocument Property

Returns the loaded XmlDocument from xml currency rates. Read only.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property XmlDocument As XmlDocument
C#
public XmlDocument XmlDocument {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartCurrency Class
CartCurrency Members


%%PageItemTitle%%

CartLiveHelp Class
See Also Members
[image]
dotnetCART Namespace : CartLiveHelp Class

Represent a CartLiveHelp object for communicating between Cart and LiveHelp.

Syntax

Visual Basic (Declaration)
Public Class CartLiveHelp
C#
public class CartLiveHelp

Remarks

.netCART includes .netLIVEHELP integration support. .netLIVEHELP is a solution for providing live help or assistance in your online store. It can assist with greater sales and customer satisfaction. Seamless integration between .netLIVEHELP and .netCART enables you to view and modify the carts of customers you assist using .netLIVEHELP. For example, you could put live help chat on your order form and provide an adjustment to their order prior to submission or save abandoned carts by offering a special incentive for completing the order.

Inheritance Hierarchy

System.Object
dotnetCART.CartLiveHelp

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartLiveHelp Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

CartLiveHelp Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : CartLiveHelp Class

The following tables list the members exposed by CartLiveHelp.

Public Constructors

 | Name | Description
Public Constructor | CartLiveHelp Constructor |
Top

Public Properties

 | Name | Description
Public Property | Url | Get or set the LiveHelpUrl to the URL for your .netLIVEHELP deployment (the same address you use to login .netLIVEHELP from the .netLIVEHELP operator console).
Public Property | Xslt | Get or set the Xslt.
Top

Public Methods

 | Name | Description
Public Method | Register | Overloaded. Register the livehelp path. You need to invoke this method only to first aspx page (typically your default.apx) . For example, you have page1.aspx , page2.aspx and page3.aspx . page1 redirects to page2.aspx and page2.aspx redirects to page3.aspx You add cart.LiveHelp.Register(); to page1.aspx only.
Top

See Also

Reference

CartLiveHelp Class
dotnetCART Namespace


%%PageItemTitle%%

CartLiveHelp Constructor
[image]
dotnetCART Namespace > CartLiveHelp Class : CartLiveHelp Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public CartLiveHelp()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartLiveHelp Class
CartLiveHelp Members


%%PageItemTitle%% $$Methods$$

CartLiveHelp Class Methods
[image]
dotnetCART Namespace : CartLiveHelp Class

For a list of all members of this type, see CartLiveHelp members.

Public Methods

 | Name | Description
Public Method | Register | Overloaded. Register the livehelp path. You need to invoke this method only to first aspx page (typically your default.apx) . For example, you have page1.aspx , page2.aspx and page3.aspx . page1 redirects to page2.aspx and page2.aspx redirects to page3.aspx You add cart.LiveHelp.Register(); to page1.aspx only.
Top

See Also

Reference

CartLiveHelp Class
dotnetCART Namespace


%%PageItemTitle%%

Register Method
[image]
dotnetCART Namespace > CartLiveHelp Class : Register Method

Register the livehelp path. You need to invoke this method only to first aspx page (typically your default.apx) . For example, you have page1.aspx , page2.aspx and page3.aspx . page1 redirects to page2.aspx and page2.aspx redirects to page3.aspx You add cart.LiveHelp.Register(); to page1.aspx only.

Overload List

Overload | Description
Register(String) | Register the livehelp path. You need to invoke this method only to first aspx page (typically your default.apx) . For example, you have page1.aspx , page2.aspx and page3.aspx . page1 redirects to page2.aspx and page2.aspx redirects to page3.aspx You add cart.LiveHelp.Register(); to page1.aspx only.
Register() |
Register(Type) |

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartLiveHelp Class
CartLiveHelp Members


%%PageItemTitle%%

Register(String) Method
[image]
dotnetCART Namespace > CartLiveHelp Class > Register Method : Register(String) Method

liveHelpPath
Register the livehelp path. You need to invoke this method only to first aspx page (typically your default.apx) . For example, you have page1.aspx , page2.aspx and page3.aspx . page1 redirects to page2.aspx and page2.aspx redirects to page3.aspx You add cart.LiveHelp.Register(); to page1.aspx only.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Register( _
   ByVal liveHelpPath As String _
)
C#
public void Register(
   string liveHelpPath
)

Parameters

liveHelpPath

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartLiveHelp Class
CartLiveHelp Members
Overload List


%%PageItemTitle%%

Register() Method
[image]
dotnetCART Namespace > CartLiveHelp Class > Register Method : Register() Method

Syntax

Visual Basic (Declaration)
Public Overloads Sub Register()
C#
public void Register()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartLiveHelp Class
CartLiveHelp Members
Overload List


%%PageItemTitle%%

Register(Type) Method
[image]
dotnetCART Namespace > CartLiveHelp Class > Register Method : Register(Type) Method

dxType

Syntax

Visual Basic (Declaration)
Public Overloads Sub Register( _
   ByVal dxType As Type _
)
C#
public void Register(
   Type dxType
)

Parameters

dxType

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartLiveHelp Class
CartLiveHelp Members
Overload List


%%PageItemTitle%% $$Properties$$

CartLiveHelp Class Properties
[image]
dotnetCART Namespace : CartLiveHelp Class

For a list of all members of this type, see CartLiveHelp members.

Public Properties

 | Name | Description
Public Property | Url | Get or set the LiveHelpUrl to the URL for your .netLIVEHELP deployment (the same address you use to login .netLIVEHELP from the .netLIVEHELP operator console).
Public Property | Xslt | Get or set the Xslt.
Top

See Also

Reference

CartLiveHelp Class
dotnetCART Namespace


%%PageItemTitle%%

Url Property
[image]
dotnetCART Namespace > CartLiveHelp Class : Url Property

Get or set the LiveHelpUrl to the URL for your .netLIVEHELP deployment (the same address you use to login .netLIVEHELP from the .netLIVEHELP operator console).

Syntax

Visual Basic (Declaration)
Public Property Url As String
C#
public string Url {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartLiveHelp Class
CartLiveHelp Members


%%PageItemTitle%%

Xslt Property
[image]
dotnetCART Namespace > CartLiveHelp Class : Xslt Property

Get or set the Xslt.

Syntax

Visual Basic (Declaration)
Public Property Xslt As String
C#
public string Xslt {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartLiveHelp Class
CartLiveHelp Members


%%PageItemTitle%%

CartShip Class
See Also Members
[image]
dotnetCART Namespace : CartShip Class

Represents a ship object.

Object Model

Syntax

Visual Basic (Declaration)
Public Class CartShip
C#
public class CartShip

Remarks

For a typical usage, configure one or more real-time or custom shipping in StoreAdmin->Shipping.
Then in checkout page, the shipping rates are calculated based on the items in the shopping cart and the customer shipping address, and displayed in the shipping dropdown list.

Inheritance Hierarchy

System.Object
dotnetCART.CartShip

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

CartShip Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : CartShip Class

The following tables list the members exposed by CartShip.

Public Constructors

 | Name | Description
Public Constructor | CartShip Constructor | Initializes a new instance of the CartShip class.
Top

Public Properties

 | Name | Description
Public Property | AdjustRate | Adjusts realtime rates by the specified rate (fixed amount or %).
Public Property | Amount | Gets or sets the shipping amount.
Public Property | CanadaPostlogin | This property must be set if you wish to return Canada Post rates. You can get your free merchant ID by emailing eparcel@canadapost.ca your request.
Public Property | DeclaredValue | Gets or sets the shipping declared value.
Public Property | Description |
Public Property | DestAddress | Sets the shipping destination Address.
Public Property | DestCity | Sets the shipping destination city.
Public Property | DestCountry | Sets the shipping destination country.
Public Property | DestName | Sets the shipping destination Phone.
Public Property | DestPhone | Sets the shipping destination Phone.
Public Property | DestStateProvince | Gets or sets the shipping destination StateProvince.
Public Property | DestZipPostal | Sets the shipping destination ZipPostal.
Public Property | DHLLogin | This property must be set if you wish to return rates / tracking information from DHL / Airborne. e.g. "username,password,customer number,domestic shipping key,international shipping key" See Registration for requirements.
Public Property | DHLTestMode | When certifying your usage you may need to process transactions in test mode. Set this property to true to connect to the test server.
Public Property | DHLURL | Enables you to override the URL used for DHL xml communication. Default value is https://xmlapi.dhl-usa.com/ApiLanding.asp and https://xmlapi.dhl-usa.com/APILandingTest.asp is used for the test server.
Public Property | EasyPostLogin |
Public Property | EasyPostShipmentID |
Public Property | Error | Returns an object with the error information.
Public Property | ExcludeRates | Accepts a comma delimited list of rate names. Any rate names listed here will be excluded from the return if this property is set. The LimitRates property has the opposite functionality and can be used instead of this property to control the returned rates. The rate name from the rates collection is what needs to be specified. For a list of rate names run rate without setting this property and then set this property to any rate names returned that you wish to be excluded. By default this property is not set and all available rates are returned.
Public Property | FailCount | This property maintains the total number of times that a failover or backup occured. If you wish to reset this property it can be set directly.
Public Property | FailStatus | This property serves two purposes - it will return a comma delimited list of processors which did a failover or backup in the previous transaction and can also be set for testing purposes to force a failover or backup. The property accepts the following format: "company=failover,company2=backup"
Public Property | FedExGround | Determines if FedEx ground rates are returned along with FedEx rate calculations. Defaults to false. If you wish to return only FedEx ground then you can use FedExGround in place of FedEx the shipping company string used with the rate method / control property. This saves the overhead of calling and returning FedEx Express rates when they are not required.
Public Property | FedExHomeDeliveryDate | Sets a home delivery date for FedEx as a date/time object e.g. New DateTime(2012, 7, 13)
Public Property | FedExHomeDeliveryPremiumType | Sets a home delivery options for FedEx: DATE_CERTAIN, APPOINTMENT, EVENING
Public Property | FedExLogin | Accepts your FedEx account number, meter number, production key and password comma delimited. See Registration for requirements.
Public Property | FedExPack | Packing Options for FedEx include: 1) "FedEx Express Envelope" or "FedEx Letter" , 2) "FedEx Express Pak" or "FedEx Pak" 3) "FedEx Express Box" or "FedEx Box" , 4) "FedEx Express Tube" or "FedEx Tube" 5) "My Packaging" or "Your Packaging". The default for this property is "My Packaging"
Public Property | FedExPhoneNumber | Sets A home phone number for FedEx, hypen delimited as a string value such as 555-555-5555
Public Property | FedExPickup | Pickup options for FedEx include 1) "regularpickup, 2) "requestcourier", 3) "dropbox", 4) "businessservice center" 5) "station"
Public Property | FedExRateType | RateType options for FedEx: 1) "List, 2) "Account"
Public Property | FedExSmartPostAncillaryEndorsement |
Public Property | FedExSmartPostHubId | The HubId provides by FedEx when after enabling the Smart Post in your account. Required for Smart Post.
Public Property | FedExSmartPostIndicia |
Public Property | FedExURL | Enables you to override the URL used for FedEx API communication. Default value is https://ws.fedex.com:443/web-services and https://wsbeta.fedex.com:443/web-services is used for the test server. FedEx may provide you with an alternate URL in which case you shoudl use the value they provide with this property.
Public Property | Height |
Public Property | InsuredValue | Set to the insured value amount.
Public Property | Insurrance | Indicates whether to apply insurance to the shippment or not.
Public Property | Label |
Public Property | Length |
Public Property | LimitRates | Accepts a comma delimited list of rate names. Only rate names listed here will be returned if this property is set. The rate name from the rates collection is what needs to be specified in this string. For a list of rate names run a rating without setting this property and then set this property to any rate names returned that you wish to be included. The rate names are not case sensitive for use with this property and can be set with or with the company name prefix. By default this property is not set and all available rates are returned.
Public Property | Message | Returns the end user error message.
Public Property | OrigAddress | Sets the origin address (shipped from).
Public Property | OrigCity | Sets the origin City (shipped from).
Public Property | OrigCountry | Sets the origin Country (shipped from). This must be a 2 letter country code.
Public Property | OrigName | Sets the origin name (shipped from).
Public Property | OrigPhone | Sets the origin phone (shipped from).
Public Property | OrigStateProvince | Origin State / Province (shipped from). For US and Canada this should be a 2 letter code.
Public Property | OrigZipPostal | Sets the origin Zip / Postal Code (shipped from).
Public Property | Pack | Packing Options for UPS include: "shipper supplied packaging", "ups letter envelope", "ups letter", "your packaging", "package", "ups tube", "ups pak", "ups express box", "international ups 25kg box, "ups 25kg box", "international ups 10kg box", "ups 10kg box"
Public Property | Quantity | Gets or sets the shipping quantity.
Public Property | RateBackup | If real-time rating fails for any reason (network outage etc) then the specified backup shipcompany services are applied as defined in custom rates.
Public Property | RateFailover | Rate failover defines which company will be called if a given ship company fails to return rates. This would commonly be used if you returned rates for only 1 processor but still wanted realtime rates if they did not return. You could set a failover for that 1 processor to an alternative one. Unlike backup, which ensures that rates are always returned as it accepts only algorithm based custom rates, Failover accepts either a custom rate or another real-time company name.
Public Property | Rates | Returns the populated shipping rates after invoking Rates method.
Public Property | Residential | Set if the package is intended for a residential address (true / false)
Public Property | Sort | The default sort order is based on price and shipcompany (obj.sort="price,true") It gets two parameters 1) ("price" or "name" ) 2) "true" (base on shipcompany) or "false" (sort globaly). For example: Sort="name,false", will sort the collection based on service name and globally (without grouping by shipcompany)
Public Property | TariffNumber |
Public Property | Timeout | Time in seconds to wait for real-time rates to return. The default is 30 seconds.
Public Property | UPSCustomer | Customer classification container. Valid only if shipping from US. Possible options: "wholesale", "occasional", "retail"
Public Property | UPSLogin | This property must be set if you wish to return any UPS rates. Accepts your UPS account user name, password and access code. Before you request an Access Key you will need a UPS.com User ID and Password and a UPS account number. Click on the "Request an access key" link, located in the How to Get Started section. Set them in this format: "username,password,accesscode"
Public Property | UPSPack | Packing Options for UPS include: "shipper supplied packaging", "ups letter envelope", "ups letter", "your packaging", "package", "ups tube", "ups pak", "ups express box", "international ups 25kg box, "ups 25kg box", "international ups 10kg box", "ups 10kg box"
Public Property | UPSPickup | Pickup options for UPS include: "daily pickup", "customer counter", "one time pickup", "on call air", "authorized shipping outlet", "suggested retail rates", "letter center", "air service center"
Public Property | USPSLogin | This property must be set if you wish to return any USPS rates. You can get your free username and password from USPS by registering at http://www.shippingapis.com . After registration you must contact USPS to gain access to their production server before you will be able to return rates. If only username is provided by USPS, use this for both username and password in this format: "username,password"
Public Property | Weight | Gets or sets the shipping weight.
Public Property | Width |
Top

Public Methods

 | Name | Description
Public Method | CodeToCountry | Overloaded. Returns the full text for a country from the provided 2 letter country code.
Public Method | CountryList | Overloaded. Generates a list of countries in a combobox.
Public Method | CountryToCode | Overloaded. Returns the 2 letter country code from a provided full country name.
Public Method | DisplayRates | Overloaded. Displays the calculated rates for the shipping companies configured in StoreAdmin->Shipping tab in a combobox control.
Public Method | DisplayRatesFormat | Displays the calculated rates for the shipping companies configured in StoreAdmin->Shipping tab in a combo or radio control.
Public Method | DisplayTracking | Displays a simple table with the tracking collections location, date and status.
Public Method | GetLabel |
Public Method | Rate | All applicable rates will be calculated and added to the rates collection for each company included in the ShipCompany parameter.
Public Method | SetRates | Overloaded. All applicable rates will be calculated and added to the Address.Rates collection for the specified shipping companies.
Public Method | Track | Returns the populated Tracking collection.
Top

See Also

Reference

CartShip Class
dotnetCART Namespace


%%PageItemTitle%%

CartShip Constructor
[image]
dotnetCART Namespace > CartShip Class : CartShip Constructor

Initializes a new instance of the CartShip class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public CartShip()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%% $$Methods$$

CartShip Class Methods
[image]
dotnetCART Namespace : CartShip Class

For a list of all members of this type, see CartShip members.

Public Methods

 | Name | Description
Public Method | CodeToCountry | Overloaded. Returns the full text for a country from the provided 2 letter country code.
Public Method | CountryList | Overloaded. Generates a list of countries in a combobox.
Public Method | CountryToCode | Overloaded. Returns the 2 letter country code from a provided full country name.
Public Method | DisplayRates | Overloaded. Displays the calculated rates for the shipping companies configured in StoreAdmin->Shipping tab in a combobox control.
Public Method | DisplayRatesFormat | Displays the calculated rates for the shipping companies configured in StoreAdmin->Shipping tab in a combo or radio control.
Public Method | DisplayTracking | Displays a simple table with the tracking collections location, date and status.
Public Method | GetLabel |
Public Method | Rate | All applicable rates will be calculated and added to the rates collection for each company included in the ShipCompany parameter.
Public Method | SetRates | Overloaded. All applicable rates will be calculated and added to the Address.Rates collection for the specified shipping companies.
Public Method | Track | Returns the populated Tracking collection.
Top

See Also

Reference

CartShip Class
dotnetCART Namespace


%%PageItemTitle%%

CodeToCountry Method
[image]
dotnetCART Namespace > CartShip Class : CodeToCountry Method

Returns the full text for a country from the provided 2 letter country code.

Overload List

Overload | Description
CodeToCountry(String) | Returns the full text for a country from the provided 2 letter country code.
CodeToCountry(String,String) |

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

CodeToCountry(String) Method
[image]
dotnetCART Namespace > CartShip Class > CodeToCountry Method : CodeToCountry(String) Method

strCode
A 2 letter country code.
Returns the full text for a country from the provided 2 letter country code.

Syntax

Visual Basic (Declaration)
Public Overloads Function CodeToCountry( _
   ByVal strCode As String _
) As String
C#
public string CodeToCountry(
   string strCode
)

Parameters

strCode
A 2 letter country code.

Return Value

The country name.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members
Overload List


%%PageItemTitle%%

CodeToCountry(String,String) Method
[image]
dotnetCART Namespace > CartShip Class > CodeToCountry Method : CodeToCountry(String,String) Method

strCode
A 2 letter country code.
strXMLFile
An XML path of the country XML file for the source data. This accepts the file name or virtual path and file name to the country override xml file. e.g. "country.xml" or "/yourdir/country.xml"

Syntax

Visual Basic (Declaration)
Public Overloads Function CodeToCountry( _
   ByVal strCode As String, _
   ByVal strXMLFile As String _
) As String
C#
public string CodeToCountry(
   string strCode,
   string strXMLFile
)

Parameters

strCode
A 2 letter country code.
strXMLFile
An XML path of the country XML file for the source data. This accepts the file name or virtual path and file name to the country override xml file. e.g. "country.xml" or "/yourdir/country.xml"

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members
Overload List


%%PageItemTitle%%

CountryList Method
[image]
dotnetCART Namespace > CartShip Class : CountryList Method

Generates a list of countries in a combobox.

Overload List

Overload | Description
CountryList(String) | Generates a list of countries in a combobox.
CountryList() | Generates a list of countries in a combobox.
CountryList(String,String) | Generates a list of countries in a combobox.
CountryList(String,String,String) | Generates a list of countries in a combobox.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

CountryList(String) Method
[image]
dotnetCART Namespace > CartShip Class > CountryList Method : CountryList(String) Method

strComboName
The name for the comobbox.
Generates a list of countries in a combobox.

Syntax

Visual Basic (Declaration)
Public Overloads Function CountryList( _
   ByVal strComboName As String _
) As String
C#
public string CountryList(
   string strComboName
)

Parameters

strComboName
The name for the comobbox.

Return Value

Returns the serialized control of the country list.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members
Overload List


%%PageItemTitle%%

CountryList() Method
[image]
dotnetCART Namespace > CartShip Class > CountryList Method : CountryList() Method

Generates a list of countries in a combobox.

Syntax

Visual Basic (Declaration)
Public Overloads Function CountryList() As String
C#
public string CountryList()

Return Value

Returns the serialized control of the country list.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members
Overload List


%%PageItemTitle%%

CountryList(String,String) Method
[image]
dotnetCART Namespace > CartShip Class > CountryList Method : CountryList(String,String) Method

strComboName
The name for the comobbox.
strCountry
Generates a list of countries in a combobox.

Syntax

Visual Basic (Declaration)
Public Overloads Function CountryList( _
   ByVal strComboName As String, _
   ByVal strCountry As String _
) As String
C#
public string CountryList(
   string strComboName,
   string strCountry
)

Parameters

strComboName
The name for the comobbox.
strCountry

Return Value

Returns the serialized control of the country list.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members
Overload List


%%PageItemTitle%%

CountryList(String,String,String) Method
[image]
dotnetCART Namespace > CartShip Class > CountryList Method : CountryList(String,String,String) Method

strComboName
The name for the comobbox.
strCountry
The default coutnry code.
strXMLFile
An XML path of the country XML file for the source data. This accepts the file name or virtual path and file name to the country override xml file. e.g. "country.xml" or "/yourdir/country.xml"
Generates a list of countries in a combobox.

Syntax

Visual Basic (Declaration)
Public Overloads Function CountryList( _
   ByVal strComboName As String, _
   ByVal strCountry As String, _
   ByVal strXMLFile As String _
) As String
C#
public string CountryList(
   string strComboName,
   string strCountry,
   string strXMLFile
)

Parameters

strComboName
The name for the comobbox.
strCountry
The default coutnry code.
strXMLFile
An XML path of the country XML file for the source data. This accepts the file name or virtual path and file name to the country override xml file. e.g. "country.xml" or "/yourdir/country.xml"

Return Value

Returns the serialized control of the country list.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members
Overload List


%%PageItemTitle%%

CountryToCode Method
[image]
dotnetCART Namespace > CartShip Class : CountryToCode Method

Returns the 2 letter country code from a provided full country name.

Overload List

Overload | Description
CountryToCode(String) | Returns the 2 letter country code from a provided full country name.
CountryToCode(String,String) | Returns the 2 letter country code from a provided full country name.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

CountryToCode(String) Method
[image]
dotnetCART Namespace > CartShip Class > CountryToCode Method : CountryToCode(String) Method

strCountry
A country name.
Returns the 2 letter country code from a provided full country name.

Syntax

Visual Basic (Declaration)
Public Overloads Function CountryToCode( _
   ByVal strCountry As String _
) As String
C#
public string CountryToCode(
   string strCountry
)

Parameters

strCountry
A country name.

Return Value

The 2 letter contry code.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members
Overload List


%%PageItemTitle%%

CountryToCode(String,String) Method
[image]
dotnetCART Namespace > CartShip Class > CountryToCode Method : CountryToCode(String,String) Method

strCountry
A country name.
strXMLFile
An XML path of the country XML file for the source data. This accepts the file name or virtual path and file name to the country override xml file. e.g. "country.xml" or "/yourdir/country.xml"
Returns the 2 letter country code from a provided full country name.

Syntax

Visual Basic (Declaration)
Public Overloads Function CountryToCode( _
   ByVal strCountry As String, _
   ByVal strXMLFile As String _
) As String
C#
public string CountryToCode(
   string strCountry,
   string strXMLFile
)

Parameters

strCountry
A country name.
strXMLFile
An XML path of the country XML file for the source data. This accepts the file name or virtual path and file name to the country override xml file. e.g. "country.xml" or "/yourdir/country.xml"

Return Value

The 2 letter contry code.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members
Overload List


%%PageItemTitle%%

DisplayRates Method
[image]
dotnetCART Namespace > CartShip Class : DisplayRates Method

Displays the calculated rates for the shipping companies configured in StoreAdmin->Shipping tab in a combobox control.

Overload List

Overload | Description
DisplayRates() | Displays the calculated rates for the shipping companies configured in StoreAdmin->Shipping tab in a combobox control.
DisplayRates(String) | Displays the calculated rates for the specified shipping companies in a combobox control.
DisplayRates(String,String,String) | Displays the calculated rates for the specified shipping companies in a combobox control.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

DisplayRates() Method
[image]
dotnetCART Namespace > CartShip Class > DisplayRates Method : DisplayRates() Method

Displays the calculated rates for the shipping companies configured in StoreAdmin->Shipping tab in a combobox control.

Syntax

Visual Basic (Declaration)
Public Overloads Function DisplayRates() As String
C#
public string DisplayRates()

Return Value

Returns the serialized control of the shipping rates.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members
Overload List


%%PageItemTitle%%

DisplayRates(String) Method
[image]
dotnetCART Namespace > CartShip Class > DisplayRates Method : DisplayRates(String) Method

shipCompany
A comma delimited list of shipping companies. Optional values include FedEx, USPS, AIRBORNE, DHL, CanadaPost and any other custom shipping.
Displays the calculated rates for the specified shipping companies in a combobox control.

Syntax

Visual Basic (Declaration)
Public Overloads Function DisplayRates( _
   ByVal shipCompany As String _
) As String
C#
public string DisplayRates(
   string shipCompany
)

Parameters

shipCompany
A comma delimited list of shipping companies. Optional values include FedEx, USPS, AIRBORNE, DHL, CanadaPost and any other custom shipping.

Return Value

Returns the serialized control of the shipping rates.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members
Overload List


%%PageItemTitle%%

DisplayRates(String,String,String) Method
[image]
dotnetCART Namespace > CartShip Class > DisplayRates Method : DisplayRates(String,String,String) Method

company
A comma delimited list of shipping companies. Optional values include FedEx, USPS, AIRBORNE, DHL, CanadaPost and any other custom shipping.
strType
A type of Combo or Radio controls the type of HTML element that will be rendered.
strName
The name of the HTML combobox / radio collection.
Displays the calculated rates for the specified shipping companies in a combobox control.

Syntax

Visual Basic (Declaration)
Public Overloads Function DisplayRates( _
   ByVal company As String, _
   ByVal strType As String, _
   ByVal strName As String _
) As String
C#
public string DisplayRates(
   string company,
   string strType,
   string strName
)

Parameters

company
A comma delimited list of shipping companies. Optional values include FedEx, USPS, AIRBORNE, DHL, CanadaPost and any other custom shipping.
strType
A type of Combo or Radio controls the type of HTML element that will be rendered.
strName
The name of the HTML combobox / radio collection.

Return Value

Returns the serialized control of the shipping rates.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members
Overload List


%%PageItemTitle%%

DisplayRatesFormat Method
[image]
dotnetCART Namespace > CartShip Class : DisplayRatesFormat Method

strType
A type of Combo or Radio controls the type of HTML element that will be rendered.
strName
The name of the HTML combobox / radio collection.
Displays the calculated rates for the shipping companies configured in StoreAdmin->Shipping tab in a combo or radio control.

Syntax

Visual Basic (Declaration)
Public Function DisplayRatesFormat( _
   ByVal strType As String, _
   ByVal strName As String _
) As String
C#
public string DisplayRatesFormat(
   string strType,
   string strName
)

Parameters

strType
A type of Combo or Radio controls the type of HTML element that will be rendered.
strName
The name of the HTML combobox / radio collection.

Return Value

Returns the serialized control of the shipping rates.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

DisplayTracking Method
[image]
dotnetCART Namespace > CartShip Class : DisplayTracking Method

Displays a simple table with the tracking collections location, date and status.

Syntax

Visual Basic (Declaration)
Public Function DisplayTracking() As String
C#
public string DisplayTracking()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

GetLabel Method
[image]
dotnetCART Namespace > CartShip Class : GetLabel Method

trackingNumberOrShipmentID
rateID
format

Syntax

Visual Basic (Declaration)
Public Function GetLabel( _
   ByVal trackingNumberOrShipmentID As String, _
   ByVal rateID As String, _
   ByVal format As String _
) As Boolean
C#
public bool GetLabel(
   string trackingNumberOrShipmentID,
   string rateID,
   string format
)

Parameters

trackingNumberOrShipmentID
rateID
format

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

Rate Method
[image]
dotnetCART Namespace > CartShip Class : Rate Method

strShipCompany
A comma delimited list of shipping companies. Optional values include FedEx, USPS, AIRBORNE, DHL, CanadaPost and any other custom shipping.
All applicable rates will be calculated and added to the rates collection for each company included in the ShipCompany parameter.

Syntax

Visual Basic (Declaration)
Public Sub Rate( _
   ByVal strShipCompany As String _
)
C#
public void Rate(
   string strShipCompany
)

Parameters

strShipCompany
A comma delimited list of shipping companies. Optional values include FedEx, USPS, AIRBORNE, DHL, CanadaPost and any other custom shipping.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

SetRates Method
[image]
dotnetCART Namespace > CartShip Class : SetRates Method

All applicable rates will be calculated and added to the Address.Rates collection for the specified shipping companies.

Overload List

Overload | Description
SetRates() |
SetRates(String) | All applicable rates will be calculated and added to the Address.Rates collection for the specified shipping companies.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

SetRates() Method
[image]
dotnetCART Namespace > CartShip Class > SetRates Method : SetRates() Method

Syntax

Visual Basic (Declaration)
Public Overloads Function SetRates() As Boolean
C#
public bool SetRates()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members
Overload List


%%PageItemTitle%%

SetRates(String) Method
[image]
dotnetCART Namespace > CartShip Class > SetRates Method : SetRates(String) Method

shippingCompanies
A comma delimited list of shipping companies. Optional values include FedEx, USPS, AIRBORNE, DHL, CanadaPost and any other custom shipping.
All applicable rates will be calculated and added to the Address.Rates collection for the specified shipping companies.

Syntax

Visual Basic (Declaration)
Public Overloads Function SetRates( _
   ByVal shippingCompanies As String _
) As Boolean
C#
public bool SetRates(
   string shippingCompanies
)

Parameters

shippingCompanies
A comma delimited list of shipping companies. Optional values include FedEx, USPS, AIRBORNE, DHL, CanadaPost and any other custom shipping.

Return Value

Indicates whether the rates calculation has been completed successfully or not.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members
Overload List


%%PageItemTitle%%

Track Method
[image]
dotnetCART Namespace > CartShip Class : Track Method

ShipCompany
The name of the ship company.
TrackID
The track ID.
Returns the populated Tracking collection.

Syntax

Visual Basic (Declaration)
Public Function Track( _
   ByVal ShipCompany As String, _
   ByVal TrackID As String _
) As Ship.TrackingCollection
C#
public Ship.TrackingCollection Track(
   string ShipCompany,
   string TrackID
)

Parameters

ShipCompany
The name of the ship company.
TrackID
The track ID.

Return Value

Tracking collection.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%% $$Properties$$

CartShip Class Properties
[image]
dotnetCART Namespace : CartShip Class

For a list of all members of this type, see CartShip members.

Public Properties

 | Name | Description
Public Property | AdjustRate | Adjusts realtime rates by the specified rate (fixed amount or %).
Public Property | Amount | Gets or sets the shipping amount.
Public Property | CanadaPostlogin | This property must be set if you wish to return Canada Post rates. You can get your free merchant ID by emailing eparcel@canadapost.ca your request.
Public Property | DeclaredValue | Gets or sets the shipping declared value.
Public Property | Description |
Public Property | DestAddress | Sets the shipping destination Address.
Public Property | DestCity | Sets the shipping destination city.
Public Property | DestCountry | Sets the shipping destination country.
Public Property | DestName | Sets the shipping destination Phone.
Public Property | DestPhone | Sets the shipping destination Phone.
Public Property | DestStateProvince | Gets or sets the shipping destination StateProvince.
Public Property | DestZipPostal | Sets the shipping destination ZipPostal.
Public Property | DHLLogin | This property must be set if you wish to return rates / tracking information from DHL / Airborne. e.g. "username,password,customer number,domestic shipping key,international shipping key" See Registration for requirements.
Public Property | DHLTestMode | When certifying your usage you may need to process transactions in test mode. Set this property to true to connect to the test server.
Public Property | DHLURL | Enables you to override the URL used for DHL xml communication. Default value is https://xmlapi.dhl-usa.com/ApiLanding.asp and https://xmlapi.dhl-usa.com/APILandingTest.asp is used for the test server.
Public Property | EasyPostLogin |
Public Property | EasyPostShipmentID |
Public Property | Error | Returns an object with the error information.
Public Property | ExcludeRates | Accepts a comma delimited list of rate names. Any rate names listed here will be excluded from the return if this property is set. The LimitRates property has the opposite functionality and can be used instead of this property to control the returned rates. The rate name from the rates collection is what needs to be specified. For a list of rate names run rate without setting this property and then set this property to any rate names returned that you wish to be excluded. By default this property is not set and all available rates are returned.
Public Property | FailCount | This property maintains the total number of times that a failover or backup occured. If you wish to reset this property it can be set directly.
Public Property | FailStatus | This property serves two purposes - it will return a comma delimited list of processors which did a failover or backup in the previous transaction and can also be set for testing purposes to force a failover or backup. The property accepts the following format: "company=failover,company2=backup"
Public Property | FedExGround | Determines if FedEx ground rates are returned along with FedEx rate calculations. Defaults to false. If you wish to return only FedEx ground then you can use FedExGround in place of FedEx the shipping company string used with the rate method / control property. This saves the overhead of calling and returning FedEx Express rates when they are not required.
Public Property | FedExHomeDeliveryDate | Sets a home delivery date for FedEx as a date/time object e.g. New DateTime(2012, 7, 13)
Public Property | FedExHomeDeliveryPremiumType | Sets a home delivery options for FedEx: DATE_CERTAIN, APPOINTMENT, EVENING
Public Property | FedExLogin | Accepts your FedEx account number, meter number, production key and password comma delimited. See Registration for requirements.
Public Property | FedExPack | Packing Options for FedEx include: 1) "FedEx Express Envelope" or "FedEx Letter" , 2) "FedEx Express Pak" or "FedEx Pak" 3) "FedEx Express Box" or "FedEx Box" , 4) "FedEx Express Tube" or "FedEx Tube" 5) "My Packaging" or "Your Packaging". The default for this property is "My Packaging"
Public Property | FedExPhoneNumber | Sets A home phone number for FedEx, hypen delimited as a string value such as 555-555-5555
Public Property | FedExPickup | Pickup options for FedEx include 1) "regularpickup, 2) "requestcourier", 3) "dropbox", 4) "businessservice center" 5) "station"
Public Property | FedExRateType | RateType options for FedEx: 1) "List, 2) "Account"
Public Property | FedExSmartPostAncillaryEndorsement |
Public Property | FedExSmartPostHubId | The HubId provides by FedEx when after enabling the Smart Post in your account. Required for Smart Post.
Public Property | FedExSmartPostIndicia |
Public Property | FedExURL | Enables you to override the URL used for FedEx API communication. Default value is https://ws.fedex.com:443/web-services and https://wsbeta.fedex.com:443/web-services is used for the test server. FedEx may provide you with an alternate URL in which case you shoudl use the value they provide with this property.
Public Property | Height |
Public Property | InsuredValue | Set to the insured value amount.
Public Property | Insurrance | Indicates whether to apply insurance to the shippment or not.
Public Property | Label |
Public Property | Length |
Public Property | LimitRates | Accepts a comma delimited list of rate names. Only rate names listed here will be returned if this property is set. The rate name from the rates collection is what needs to be specified in this string. For a list of rate names run a rating without setting this property and then set this property to any rate names returned that you wish to be included. The rate names are not case sensitive for use with this property and can be set with or with the company name prefix. By default this property is not set and all available rates are returned.
Public Property | Message | Returns the end user error message.
Public Property | OrigAddress | Sets the origin address (shipped from).
Public Property | OrigCity | Sets the origin City (shipped from).
Public Property | OrigCountry | Sets the origin Country (shipped from). This must be a 2 letter country code.
Public Property | OrigName | Sets the origin name (shipped from).
Public Property | OrigPhone | Sets the origin phone (shipped from).
Public Property | OrigStateProvince | Origin State / Province (shipped from). For US and Canada this should be a 2 letter code.
Public Property | OrigZipPostal | Sets the origin Zip / Postal Code (shipped from).
Public Property | Pack | Packing Options for UPS include: "shipper supplied packaging", "ups letter envelope", "ups letter", "your packaging", "package", "ups tube", "ups pak", "ups express box", "international ups 25kg box, "ups 25kg box", "international ups 10kg box", "ups 10kg box"
Public Property | Quantity | Gets or sets the shipping quantity.
Public Property | RateBackup | If real-time rating fails for any reason (network outage etc) then the specified backup shipcompany services are applied as defined in custom rates.
Public Property | RateFailover | Rate failover defines which company will be called if a given ship company fails to return rates. This would commonly be used if you returned rates for only 1 processor but still wanted realtime rates if they did not return. You could set a failover for that 1 processor to an alternative one. Unlike backup, which ensures that rates are always returned as it accepts only algorithm based custom rates, Failover accepts either a custom rate or another real-time company name.
Public Property | Rates | Returns the populated shipping rates after invoking Rates method.
Public Property | Residential | Set if the package is intended for a residential address (true / false)
Public Property | Sort | The default sort order is based on price and shipcompany (obj.sort="price,true") It gets two parameters 1) ("price" or "name" ) 2) "true" (base on shipcompany) or "false" (sort globaly). For example: Sort="name,false", will sort the collection based on service name and globally (without grouping by shipcompany)
Public Property | TariffNumber |
Public Property | Timeout | Time in seconds to wait for real-time rates to return. The default is 30 seconds.
Public Property | UPSCustomer | Customer classification container. Valid only if shipping from US. Possible options: "wholesale", "occasional", "retail"
Public Property | UPSLogin | This property must be set if you wish to return any UPS rates. Accepts your UPS account user name, password and access code. Before you request an Access Key you will need a UPS.com User ID and Password and a UPS account number. Click on the "Request an access key" link, located in the How to Get Started section. Set them in this format: "username,password,accesscode"
Public Property | UPSPack | Packing Options for UPS include: "shipper supplied packaging", "ups letter envelope", "ups letter", "your packaging", "package", "ups tube", "ups pak", "ups express box", "international ups 25kg box, "ups 25kg box", "international ups 10kg box", "ups 10kg box"
Public Property | UPSPickup | Pickup options for UPS include: "daily pickup", "customer counter", "one time pickup", "on call air", "authorized shipping outlet", "suggested retail rates", "letter center", "air service center"
Public Property | USPSLogin | This property must be set if you wish to return any USPS rates. You can get your free username and password from USPS by registering at http://www.shippingapis.com . After registration you must contact USPS to gain access to their production server before you will be able to return rates. If only username is provided by USPS, use this for both username and password in this format: "username,password"
Public Property | Weight | Gets or sets the shipping weight.
Public Property | Width |
Top

See Also

Reference

CartShip Class
dotnetCART Namespace


%%PageItemTitle%%

AdjustRate Property
See Also Example
[image]
dotnetCART Namespace > CartShip Class : AdjustRate Property

Adjusts realtime rates by the specified rate (fixed amount or %).

Syntax

Visual Basic (Declaration)
Public WriteOnly Property AdjustRate As String
C#
public string AdjustRate {set;}

Example

The follwoing code set adjust rate:
C# Copy Code
obj.AdjustRate = "10%";
obj.AdjustRate = "1.25";
obj.AdjustRate = "-5%";
Visual Basic Copy Code
obj.AdjustRate = "10%"
obj.AdjustRate = "1.25"
obj.AdjustRate = "-5%"

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

Amount Property
[image]
dotnetCART Namespace > CartShip Class : Amount Property

Gets or sets the shipping amount.

Syntax

Visual Basic (Declaration)
Public Property Amount As Double
C#
public double Amount {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

CanadaPostlogin Property
[image]
dotnetCART Namespace > CartShip Class : CanadaPostlogin Property

This property must be set if you wish to return Canada Post rates. You can get your free merchant ID by emailing eparcel@canadapost.ca your request.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property CanadaPostlogin As String
C#
public string CanadaPostlogin {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

DeclaredValue Property
[image]
dotnetCART Namespace > CartShip Class : DeclaredValue Property

Gets or sets the shipping declared value.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property DeclaredValue As Double
C#
public double DeclaredValue {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

Description Property
[image]
dotnetCART Namespace > CartShip Class : Description Property

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

DestAddress Property
[image]
dotnetCART Namespace > CartShip Class : DestAddress Property

Sets the shipping destination Address.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property DestAddress As String
C#
public string DestAddress {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

DestCity Property
[image]
dotnetCART Namespace > CartShip Class : DestCity Property

Sets the shipping destination city.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property DestCity As String
C#
public string DestCity {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

DestCountry Property
[image]
dotnetCART Namespace > CartShip Class : DestCountry Property

Sets the shipping destination country.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property DestCountry As String
C#
public string DestCountry {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

DestName Property
[image]
dotnetCART Namespace > CartShip Class : DestName Property

Sets the shipping destination Phone.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property DestName As String
C#
public string DestName {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

DestPhone Property
[image]
dotnetCART Namespace > CartShip Class : DestPhone Property

Sets the shipping destination Phone.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property DestPhone As String
C#
public string DestPhone {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

DestStateProvince Property
[image]
dotnetCART Namespace > CartShip Class : DestStateProvince Property

Gets or sets the shipping destination StateProvince.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property DestStateProvince As String
C#
public string DestStateProvince {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

DestZipPostal Property
[image]
dotnetCART Namespace > CartShip Class : DestZipPostal Property

Sets the shipping destination ZipPostal.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property DestZipPostal As String
C#
public string DestZipPostal {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

DHLLogin Property
[image]
dotnetCART Namespace > CartShip Class : DHLLogin Property

This property must be set if you wish to return rates / tracking information from DHL / Airborne. e.g. "username,password,customer number,domestic shipping key,international shipping key" See Registration for requirements.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property DHLLogin As String
C#
public string DHLLogin {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

DHLTestMode Property
[image]
dotnetCART Namespace > CartShip Class : DHLTestMode Property

When certifying your usage you may need to process transactions in test mode. Set this property to true to connect to the test server.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property DHLTestMode As Boolean
C#
public bool DHLTestMode {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

DHLURL Property
[image]
dotnetCART Namespace > CartShip Class : DHLURL Property

Enables you to override the URL used for DHL xml communication. Default value is https://xmlapi.dhl-usa.com/ApiLanding.asp and https://xmlapi.dhl-usa.com/APILandingTest.asp is used for the test server.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property DHLURL As String
C#
public string DHLURL {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

EasyPostLogin Property
[image]
dotnetCART Namespace > CartShip Class : EasyPostLogin Property

Syntax

Visual Basic (Declaration)
Public Property EasyPostLogin As String
C#
public string EasyPostLogin {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

EasyPostShipmentID Property
[image]
dotnetCART Namespace > CartShip Class : EasyPostShipmentID Property

Syntax

Visual Basic (Declaration)
Public Property EasyPostShipmentID As String
C#
public string EasyPostShipmentID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > CartShip Class : Error Property

Returns an object with the error information.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

ExcludeRates Property
See Also Example
[image]
dotnetCART Namespace > CartShip Class : ExcludeRates Property

Accepts a comma delimited list of rate names. Any rate names listed here will be excluded from the return if this property is set. The LimitRates property has the opposite functionality and can be used instead of this property to control the returned rates. The rate name from the rates collection is what needs to be specified. For a list of rate names run rate without setting this property and then set this property to any rate names returned that you wish to be excluded. By default this property is not set and all available rates are returned.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property ExcludeRates As String
C#
public string ExcludeRates {set;}

Example

The follwoing code set ExcludeRates:
C# Copy Code
obj.ExcludeRates="Express";
Visual Basic Copy Code
obj.ExcludeRates="Express"

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

FailCount Property
[image]
dotnetCART Namespace > CartShip Class : FailCount Property

This property maintains the total number of times that a failover or backup occured. If you wish to reset this property it can be set directly.

Syntax

Visual Basic (Declaration)
Public Property FailCount As Integer
C#
public int FailCount {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

FailStatus Property
[image]
dotnetCART Namespace > CartShip Class : FailStatus Property

This property serves two purposes - it will return a comma delimited list of processors which did a failover or backup in the previous transaction and can also be set for testing purposes to force a failover or backup. The property accepts the following format:
"company=failover,company2=backup"

Syntax

Visual Basic (Declaration)
Public Property FailStatus As String
C#
public string FailStatus {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

FedExGround Property
[image]
dotnetCART Namespace > CartShip Class : FedExGround Property

Determines if FedEx ground rates are returned along with FedEx rate calculations. Defaults to false. If you wish to return only FedEx ground then you can use FedExGround in place of FedEx the shipping company string used with the rate method / control property. This saves the overhead of calling and returning FedEx Express rates when they are not required.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property FedExGround As Boolean
C#
public bool FedExGround {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

FedExHomeDeliveryDate Property
[image]
dotnetCART Namespace > CartShip Class : FedExHomeDeliveryDate Property

Sets a home delivery date for FedEx as a date/time object e.g. New DateTime(2012, 7, 13)

Syntax

Visual Basic (Declaration)
Public WriteOnly Property FedExHomeDeliveryDate As Date
C#
public DateTime FedExHomeDeliveryDate {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

FedExHomeDeliveryPremiumType Property
[image]
dotnetCART Namespace > CartShip Class : FedExHomeDeliveryPremiumType Property

Sets a home delivery options for FedEx: DATE_CERTAIN, APPOINTMENT, EVENING

Syntax

Visual Basic (Declaration)
Public WriteOnly Property FedExHomeDeliveryPremiumType As String
C#
public string FedExHomeDeliveryPremiumType {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

FedExLogin Property
[image]
dotnetCART Namespace > CartShip Class : FedExLogin Property

Accepts your FedEx account number, meter number, production key and password comma delimited. See Registration for requirements.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property FedExLogin As String
C#
public string FedExLogin {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

FedExPack Property
[image]
dotnetCART Namespace > CartShip Class : FedExPack Property

Packing Options for FedEx include: 1) "FedEx Express Envelope" or "FedEx Letter" , 2) "FedEx Express Pak" or "FedEx Pak" 3) "FedEx Express Box" or "FedEx Box" , 4) "FedEx Express Tube" or "FedEx Tube" 5) "My Packaging" or "Your Packaging". The default for this property is "My Packaging"

Syntax

Visual Basic (Declaration)
Public WriteOnly Property FedExPack As String
C#
public string FedExPack {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

FedExPhoneNumber Property
[image]
dotnetCART Namespace > CartShip Class : FedExPhoneNumber Property

Sets A home phone number for FedEx, hypen delimited as a string value such as 555-555-5555

Syntax

Visual Basic (Declaration)
Public WriteOnly Property FedExPhoneNumber As String
C#
public string FedExPhoneNumber {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

FedExPickup Property
[image]
dotnetCART Namespace > CartShip Class : FedExPickup Property

Pickup options for FedEx include 1) "regularpickup, 2) "requestcourier", 3) "dropbox", 4) "businessservice center" 5) "station"

Syntax

Visual Basic (Declaration)
Public WriteOnly Property FedExPickup As String
C#
public string FedExPickup {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

FedExRateType Property
[image]
dotnetCART Namespace > CartShip Class : FedExRateType Property

RateType options for FedEx: 1) "List, 2) "Account"

Syntax

Visual Basic (Declaration)
Public WriteOnly Property FedExRateType As String
C#
public string FedExRateType {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

FedExSmartPostAncillaryEndorsement Property
[image]
dotnetCART Namespace > CartShip Class : FedExSmartPostAncillaryEndorsement Property

Syntax

Visual Basic (Declaration)
Public WriteOnly Property FedExSmartPostAncillaryEndorsement As String
C#
public string FedExSmartPostAncillaryEndorsement {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

FedExSmartPostHubId Property
[image]
dotnetCART Namespace > CartShip Class : FedExSmartPostHubId Property

The HubId provides by FedEx when after enabling the Smart Post in your account. Required for Smart Post.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property FedExSmartPostHubId As String
C#
public string FedExSmartPostHubId {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

FedExSmartPostIndicia Property
[image]
dotnetCART Namespace > CartShip Class : FedExSmartPostIndicia Property

Syntax

Visual Basic (Declaration)
Public WriteOnly Property FedExSmartPostIndicia As String
C#
public string FedExSmartPostIndicia {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

FedExURL Property
[image]
dotnetCART Namespace > CartShip Class : FedExURL Property

Enables you to override the URL used for FedEx API communication. Default value is https://ws.fedex.com:443/web-services and https://wsbeta.fedex.com:443/web-services is used for the test server. FedEx may provide you with an alternate URL in which case you shoudl use the value they provide with this property.

Syntax

Visual Basic (Declaration)
Public Property FedExURL As String
C#
public string FedExURL {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

Height Property
[image]
dotnetCART Namespace > CartShip Class : Height Property

Syntax

Visual Basic (Declaration)
Public WriteOnly Property Height As Single
C#
public float Height {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

InsuredValue Property
[image]
dotnetCART Namespace > CartShip Class : InsuredValue Property

Set to the insured value amount.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property InsuredValue As Single
C#
public float InsuredValue {set;}

Remarks

If Insurrance set to true, when invoking SetRates, the totol amount for each shipping destination is set to the insuredValue.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

Insurrance Property
[image]
dotnetCART Namespace > CartShip Class : Insurrance Property

Indicates whether to apply insurance to the shippment or not.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property Insurrance As Boolean
C#
public bool Insurrance {set;}

Remarks

If set to true, when invoking SetRates, the totol amount for each shipping destination is set to the InsuredValue.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

Label Property
[image]
dotnetCART Namespace > CartShip Class : Label Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Label As MailLabel
C#
public MailLabel Label {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

Length Property
[image]
dotnetCART Namespace > CartShip Class : Length Property

Syntax

Visual Basic (Declaration)
Public WriteOnly Property Length As Single
C#
public float Length {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

LimitRates Property
See Also Example
[image]
dotnetCART Namespace > CartShip Class : LimitRates Property

Accepts a comma delimited list of rate names. Only rate names listed here will be returned if this property is set. The rate name from the rates collection is what needs to be specified in this string. For a list of rate names run a rating without setting this property and then set this property to any rate names returned that you wish to be included. The rate names are not case sensitive for use with this property and can be set with or with the company name prefix. By default this property is not set and all available rates are returned.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property LimitRates As String
C#
public string LimitRates {set;}

Example

The follwoing code set LimitRates:
C# Copy Code
obj.ExcludeRates="Express";
Visual Basic Copy Code
obj.ExcludeRates="Express"

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

Message Property
[image]
dotnetCART Namespace > CartShip Class : Message Property

Returns the end user error message.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Message As String
C#
public string Message {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

OrigAddress Property
[image]
dotnetCART Namespace > CartShip Class : OrigAddress Property

Sets the origin address (shipped from).

Syntax

Visual Basic (Declaration)
Public WriteOnly Property OrigAddress As String
C#
public string OrigAddress {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

OrigCity Property
[image]
dotnetCART Namespace > CartShip Class : OrigCity Property

Sets the origin City (shipped from).

Syntax

Visual Basic (Declaration)
Public WriteOnly Property OrigCity As String
C#
public string OrigCity {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

OrigCountry Property
[image]
dotnetCART Namespace > CartShip Class : OrigCountry Property

Sets the origin Country (shipped from). This must be a 2 letter country code.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property OrigCountry As String
C#
public string OrigCountry {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

OrigName Property
[image]
dotnetCART Namespace > CartShip Class : OrigName Property

Sets the origin name (shipped from).

Syntax

Visual Basic (Declaration)
Public WriteOnly Property OrigName As String
C#
public string OrigName {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

OrigPhone Property
[image]
dotnetCART Namespace > CartShip Class : OrigPhone Property

Sets the origin phone (shipped from).

Syntax

Visual Basic (Declaration)
Public WriteOnly Property OrigPhone As String
C#
public string OrigPhone {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

OrigStateProvince Property
[image]
dotnetCART Namespace > CartShip Class : OrigStateProvince Property

Origin State / Province (shipped from). For US and Canada this should be a 2 letter code.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property OrigStateProvince As String
C#
public string OrigStateProvince {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

OrigZipPostal Property
[image]
dotnetCART Namespace > CartShip Class : OrigZipPostal Property

Sets the origin Zip / Postal Code (shipped from).

Syntax

Visual Basic (Declaration)
Public WriteOnly Property OrigZipPostal As String
C#
public string OrigZipPostal {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

Pack Property
[image]
dotnetCART Namespace > CartShip Class : Pack Property

Packing Options for UPS include: "shipper supplied packaging", "ups letter envelope", "ups letter", "your packaging", "package", "ups tube", "ups pak", "ups express box", "international ups 25kg box, "ups 25kg box", "international ups 10kg box", "ups 10kg box"

Syntax

Visual Basic (Declaration)
Public WriteOnly Property Pack As String
C#
public string Pack {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

Quantity Property
[image]
dotnetCART Namespace > CartShip Class : Quantity Property

Gets or sets the shipping quantity.

Syntax

Visual Basic (Declaration)
Public Property Quantity As Double
C#
public double Quantity {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

RateBackup Property
See Also Example
[image]
dotnetCART Namespace > CartShip Class : RateBackup Property

If real-time rating fails for any reason (network outage etc) then the specified backup shipcompany services are applied as defined in custom rates.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property RateBackup As String
C#
public string RateBackup {set;}

Example

The follwoing code set RateBackup:
C# Copy Code
obj.RateBackup = "dhl=myDHL,usps=CustomUSPS";
Visual Basic Copy Code
obj.RateBackup = "dhl=myDHL,usps=CustomUSPS"

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

RateFailover Property
See Also Example
[image]
dotnetCART Namespace > CartShip Class : RateFailover Property

Rate failover defines which company will be called if a given ship company fails to return rates. This would commonly be used if you returned rates for only 1 processor but still wanted realtime rates if they did not return. You could set a failover for that 1 processor to an alternative one. Unlike backup, which ensures that rates are always returned as it accepts only algorithm based custom rates, Failover accepts either a custom rate or another real-time company name.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property RateFailover As String
C#
public string RateFailover {set;}

Example

The follwoing code set RateFailover:
C# Copy Code
obj.RateFailOver = "usps=fedex,dhl=mycustom";
Visual Basic Copy Code
obj.RateFailOver = "usps=fedex,dhl=mycustom"

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

Rates Property
[image]
dotnetCART Namespace > CartShip Class : Rates Property

Returns the populated shipping rates after invoking Rates method.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Rates As Rates
C#
public Rates Rates {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

Residential Property
[image]
dotnetCART Namespace > CartShip Class : Residential Property

Set if the package is intended for a residential address (true / false)

Syntax

Visual Basic (Declaration)
Public WriteOnly Property Residential As Boolean
C#
public bool Residential {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

Sort Property
See Also Example
[image]
dotnetCART Namespace > CartShip Class : Sort Property

The default sort order is based on price and shipcompany (obj.sort="price,true") It gets two parameters 1) ("price" or "name" ) 2) "true" (base on shipcompany) or "false" (sort globaly). For example: Sort="name,false", will sort the collection based on service name and globally (without grouping by shipcompany)

Syntax

Visual Basic (Declaration)
Public WriteOnly Property Sort As String
C#
public string Sort {set;}

Example

The follwoing code set sort:
C# Copy Code
obj.Sort = "name,false";
Visual Basic Copy Code
obj.Sort = "name,false"

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

TariffNumber Property
[image]
dotnetCART Namespace > CartShip Class : TariffNumber Property

Syntax

Visual Basic (Declaration)
Public Property TariffNumber As String
C#
public string TariffNumber {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

Timeout Property
[image]
dotnetCART Namespace > CartShip Class : Timeout Property

Time in seconds to wait for real-time rates to return. The default is 30 seconds.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property Timeout As Integer
C#
public int Timeout {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

UPSCustomer Property
[image]
dotnetCART Namespace > CartShip Class : UPSCustomer Property

Customer classification container. Valid only if shipping from US. Possible options: "wholesale", "occasional", "retail"

Syntax

Visual Basic (Declaration)
Public WriteOnly Property UPSCustomer As String
C#
public string UPSCustomer {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

UPSLogin Property
[image]
dotnetCART Namespace > CartShip Class : UPSLogin Property

This property must be set if you wish to return any UPS rates. Accepts your UPS account user name, password and access code. Before you request an Access Key you will need a UPS.com User ID and Password and a UPS account number. Click on the "Request an access key" link, located in the How to Get Started section. Set them in this format: "username,password,accesscode"

Syntax

Visual Basic (Declaration)
Public WriteOnly Property UPSLogin As String
C#
public string UPSLogin {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

UPSPack Property
[image]
dotnetCART Namespace > CartShip Class : UPSPack Property

Packing Options for UPS include: "shipper supplied packaging", "ups letter envelope", "ups letter", "your packaging", "package", "ups tube", "ups pak", "ups express box", "international ups 25kg box, "ups 25kg box", "international ups 10kg box", "ups 10kg box"

Syntax

Visual Basic (Declaration)
Public WriteOnly Property UPSPack As String
C#
public string UPSPack {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

UPSPickup Property
[image]
dotnetCART Namespace > CartShip Class : UPSPickup Property

Pickup options for UPS include: "daily pickup", "customer counter", "one time pickup", "on call air", "authorized shipping outlet", "suggested retail rates", "letter center", "air service center"

Syntax

Visual Basic (Declaration)
Public WriteOnly Property UPSPickup As String
C#
public string UPSPickup {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

USPSLogin Property
[image]
dotnetCART Namespace > CartShip Class : USPSLogin Property

This property must be set if you wish to return any USPS rates. You can get your free username and password from USPS by registering at http://www.shippingapis.com . After registration you must contact USPS to gain access to their production server before you will be able to return rates. If only username is provided by USPS, use this for both username and password in this format: "username,password"

Syntax

Visual Basic (Declaration)
Public WriteOnly Property USPSLogin As String
C#
public string USPSLogin {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

Weight Property
[image]
dotnetCART Namespace > CartShip Class : Weight Property

Gets or sets the shipping weight.

Syntax

Visual Basic (Declaration)
Public Property Weight As Single
C#
public float Weight {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

Width Property
[image]
dotnetCART Namespace > CartShip Class : Width Property

Syntax

Visual Basic (Declaration)
Public WriteOnly Property Width As Single
C#
public float Width {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CartShip Class
CartShip Members


%%PageItemTitle%%

Catalog Class
See Also Members
[image]
dotnetCART Namespace : Catalog Class

This class used for the store catalog.

Object Model

Syntax

Visual Basic (Declaration)
Public Class Catalog
C#
public class Catalog

Inheritance Hierarchy

System.Object
dotnetCART.Catalog

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Catalog Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

Catalog Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : Catalog Class

The following tables list the members exposed by Catalog.

Public Constructors

 | Name | Description
Public Constructor | Catalog Constructor | Initializes a new instance of the Catalog class.
Top

Public Properties

 | Name | Description
Public Property | Category | Reference to the top category in the catalog.
Public Property | Error | Returns an object with the error information.
Public Property | Language | Sets or gets the language for category name.
Public Property | NavigationList | Get a the current NavigationList.
Public Property | NavigationString | Get a formatted string of the current NavigationList transforming by internal navigation.XSLT file. You can customize the format by setting the NavigationXslt property to a custom xslt file.
Public Property | NavigationXslt | Set an XSLT file used to format the Navigation list. When calling NavigationString property, Navigation list converted to an XML format and uses the XSLT file to transform it to an HTML format.
Top

Public Methods

 | Name | Description
Public Method | GetBreadcrumbsDB | Get a the NavigationList from Categories table for the category with this ID.
Top

See Also

Reference

Catalog Class
dotnetCART Namespace


%%PageItemTitle%%

Catalog Constructor
[image]
dotnetCART Namespace > Catalog Class : Catalog Constructor

Initializes a new instance of the Catalog class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Catalog()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Catalog Class
Catalog Members


%%PageItemTitle%% $$Methods$$

Catalog Class Methods
[image]
dotnetCART Namespace : Catalog Class

For a list of all members of this type, see Catalog members.

Public Methods

 | Name | Description
Public Method | GetBreadcrumbsDB | Get a the NavigationList from Categories table for the category with this ID.
Top

See Also

Reference

Catalog Class
dotnetCART Namespace


%%PageItemTitle%%

GetBreadcrumbsDB Method
[image]
dotnetCART Namespace > Catalog Class : GetBreadcrumbsDB Method

categoryId
Get a the NavigationList from Categories table for the category with this ID.

Syntax

Visual Basic (Declaration)
Public Function GetBreadcrumbsDB( _
   ByVal categoryId As Long _
) As ListDictionary
C#
public ListDictionary GetBreadcrumbsDB(
   long categoryId
)

Parameters

categoryId

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Catalog Class
Catalog Members


%%PageItemTitle%% $$Properties$$

Catalog Class Properties
[image]
dotnetCART Namespace : Catalog Class

For a list of all members of this type, see Catalog members.

Public Properties

 | Name | Description
Public Property | Category | Reference to the top category in the catalog.
Public Property | Error | Returns an object with the error information.
Public Property | Language | Sets or gets the language for category name.
Public Property | NavigationList | Get a the current NavigationList.
Public Property | NavigationString | Get a formatted string of the current NavigationList transforming by internal navigation.XSLT file. You can customize the format by setting the NavigationXslt property to a custom xslt file.
Public Property | NavigationXslt | Set an XSLT file used to format the Navigation list. When calling NavigationString property, Navigation list converted to an XML format and uses the XSLT file to transform it to an HTML format.
Top

See Also

Reference

Catalog Class
dotnetCART Namespace


%%PageItemTitle%%

Category Property
[image]
dotnetCART Namespace > Catalog Class : Category Property

Reference to the top category in the catalog.

Syntax

Visual Basic (Declaration)
Public Property Category As Category
C#
public Category Category {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Catalog Class
Catalog Members


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > Catalog Class : Error Property

Returns an object with the error information.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Catalog Class
Catalog Members


%%PageItemTitle%%

Language Property
[image]
dotnetCART Namespace > Catalog Class : Language Property

Sets or gets the language for category name.

Syntax

Visual Basic (Declaration)
Public Property Language As String
C#
public string Language {get; set;}

Remarks

When this property is set, it is used in GetBreadcrumbsDB method For loading different values for category name from the Categories table. For each language, you need to create the following a new field in the Categories table with the language suffix: e.g. Name becomes Name_fr for french.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Catalog Class
Catalog Members


%%PageItemTitle%%

NavigationList Property
[image]
dotnetCART Namespace > Catalog Class : NavigationList Property

Get a the current NavigationList.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NavigationList As ListDictionary
C#
public ListDictionary NavigationList {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Catalog Class
Catalog Members


%%PageItemTitle%%

NavigationString Property
[image]
dotnetCART Namespace > Catalog Class : NavigationString Property

Get a formatted string of the current NavigationList transforming by internal navigation.XSLT file. You can customize the format by setting the NavigationXslt property to a custom xslt file.

Syntax

Visual Basic (Declaration)
Public Property NavigationString As String
C#
public string NavigationString {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Catalog Class
Catalog Members


%%PageItemTitle%%

NavigationXslt Property
[image]
dotnetCART Namespace > Catalog Class : NavigationXslt Property

Set an XSLT file used to format the Navigation list. When calling NavigationString property, Navigation list converted to an XML format and uses the XSLT file to transform it to an HTML format.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property NavigationXslt As String
C#
public string NavigationXslt {set;}

Remarks

Default XSLT file used for transforming the XML navigation to the HTML:

<xmlns:xsl="http://www.w3.org/1999/XSL/Transform">
<xsl:templatematch="/">
<xsl:for-eachselect="navigations/navigation">
<xsl:iftest="position()!=last()">
<a><xsl:attributename="href"><xsl:value-ofselect="@page"/>?CategoryID=<xsl:value-ofselect="@id"/></xsl:attribute><xsl:value-ofselect="@name"/></a>
<xsl:iftest="position()+1!=last()">
>
</xsl:if>
</xsl:if>
<xsl:iftest="position()=last()">
<xsl:iftest="position()!=1">
<xsl:iftest="@id!=0">
>
</xsl:if>
<xsl:iftest="@id=0">
:
</xsl:if>
</xsl:if>
<xsl:value-ofselect="@name"/>
</xsl:if>
</xsl:for-each>
</xsl:template>
</xsl:stylesheet>

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Catalog Class
Catalog Members


%%PageItemTitle%%

Categories Class
See Also Members
[image]
dotnetCART Namespace : Categories Class

A collection of Category objects.

Object Model

Syntax

Visual Basic (Declaration)
Public Class Categories
   Inherits ListBase(Of Category)
C#
public class Categories : ListBase<Category>

Inheritance Hierarchy

System.Object
System.Collections.Generic.List<Category>
dotnetCART.ListBase<Category>
dotnetCART.Categories

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

Categories Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : Categories Class

The following tables list the members exposed by Categories.

Public Constructors

 | Name | Description
Public Constructor | Categories Constructor | Initializes a new instance of the Categories.
Top

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from dotnetCART.ListBase<Category>)
Public Property | Count | Gets the number of elements actually contained in the collection. (Inherited from dotnetCART.ListBase<Category>)
Public Property | Error | Returns an object with the error information. (Inherited from dotnetCART.ListBase<Category>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from dotnetCART.ListBase<Category>)
Top

Public Methods

 | Name | Description
Public Method | Add | Adds an object to the end of the collection. (Inherited from dotnetCART.ListBase<Category>)
Public Method | AddRange | Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetCART.ListBase<Category>)
Public Method | AsReadOnly | Returns a read-only IList wrapper for the current collection. (Inherited from dotnetCART.ListBase<Category>)
Public Method | BinarySearch | Overloaded. (Inherited from dotnetCART.ListBase<Category>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetCART.ListBase<Category>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetCART.ListBase<Category>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<Category>)
Public Method | CopyTo | Overloaded. (Inherited from dotnetCART.ListBase<Category>)
Public Method | DeleteDB | Deletes all the categories in this collection from Categories table.
Public Method | GetCountDB | Overloaded. Gets the total number of categories in the Categories table.
Public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from dotnetCART.ListBase<Category>)
Public Method | IndexOf | Overloaded. (Inherited from dotnetCART.ListBase<Category>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetCART.ListBase<Category>)
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from dotnetCART.ListBase<Category>)
Public Method | LastIndexOf | Overloaded. (Inherited from dotnetCART.ListBase<Category>)
Public Method | LoadDB | Overloaded. Overridden. Loads all the categories from Categories table. If this method is called through a category object, it only loads its sub-categories. If this method is called through an item object, it only loads the categries the item belongs to them.
Public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from dotnetCART.ListBase<Category>)
Public Method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from dotnetCART.ListBase<Category>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetCART.ListBase<Category>)
Public Method | RemoveRange | Removes a range of elements from the List. (Inherited from dotnetCART.ListBase<Category>)
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<Category>)
Public Method | SaveDB | Saves all the categories in this collection to Categories table.
Public Method | Sort | Overloaded.
Top

See Also

Reference

Categories Class
dotnetCART Namespace


%%PageItemTitle%%

Categories Constructor
[image]
dotnetCART Namespace > Categories Class : Categories Constructor

Initializes a new instance of the Categories.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Categories()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Class
Categories Members


%%PageItemTitle%% $$Methods$$

Categories Class Methods
[image]
dotnetCART Namespace : Categories Class

For a list of all members of this type, see Categories members.

Public Methods

 | Name | Description
Public Method | Add | Adds an object to the end of the collection. (Inherited from dotnetCART.ListBase<Category>)
Public Method | AddRange | Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetCART.ListBase<Category>)
Public Method | AsReadOnly | Returns a read-only IList wrapper for the current collection. (Inherited from dotnetCART.ListBase<Category>)
Public Method | BinarySearch | Overloaded. (Inherited from dotnetCART.ListBase<Category>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetCART.ListBase<Category>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetCART.ListBase<Category>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<Category>)
Public Method | CopyTo | Overloaded. (Inherited from dotnetCART.ListBase<Category>)
Public Method | DeleteDB | Deletes all the categories in this collection from Categories table.
Public Method | GetCountDB | Overloaded. Gets the total number of categories in the Categories table.
Public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from dotnetCART.ListBase<Category>)
Public Method | IndexOf | Overloaded. (Inherited from dotnetCART.ListBase<Category>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetCART.ListBase<Category>)
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from dotnetCART.ListBase<Category>)
Public Method | LastIndexOf | Overloaded. (Inherited from dotnetCART.ListBase<Category>)
Public Method | LoadDB | Overloaded. Overridden. Loads all the categories from Categories table. If this method is called through a category object, it only loads its sub-categories. If this method is called through an item object, it only loads the categries the item belongs to them.
Public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from dotnetCART.ListBase<Category>)
Public Method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from dotnetCART.ListBase<Category>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetCART.ListBase<Category>)
Public Method | RemoveRange | Removes a range of elements from the List. (Inherited from dotnetCART.ListBase<Category>)
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<Category>)
Public Method | SaveDB | Saves all the categories in this collection to Categories table.
Public Method | Sort | Overloaded.
Top

See Also

Reference

Categories Class
dotnetCART Namespace


%%PageItemTitle%%

DeleteDB Method
[image]
dotnetCART Namespace > Categories Class : DeleteDB Method

Deletes all the categories in this collection from Categories table.

Syntax

Visual Basic (Declaration)
Public Function DeleteDB() As Integer
C#
public int DeleteDB()

Return Value

Returns the number of categories have been deleted.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Class
Categories Members


%%PageItemTitle%%

GetCountDB Method
[image]
dotnetCART Namespace > Categories Class : GetCountDB Method

Gets the total number of categories in the Categories table.

Overload List

Overload | Description
GetCountDB() | Gets the total number of categories in the Categories table.
GetCountDB(Where,Boolean) | Gets the total number of categories in the Categories table.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Class
Categories Members


%%PageItemTitle%%

GetCountDB() Method
[image]
dotnetCART Namespace > Categories Class > GetCountDB Method : GetCountDB() Method

Gets the total number of categories in the Categories table.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCountDB() As Integer
C#
public int GetCountDB()

Return Value

Returns the number of elements in the Categories table.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Class
Categories Members
Overload List


%%PageItemTitle%%

GetCountDB(Where,Boolean) Method
[image]
dotnetCART Namespace > Categories Class > GetCountDB Method : GetCountDB(Where,Boolean) Method

whereClause
The where clause to filter the categories.
includeDisabled
Determines whether to load disabled categories or not. Defaults is false.
Gets the total number of categories in the Categories table.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCountDB( _
   ByVal whereClause As Where, _
   ByVal includeDisabled As Boolean _
) As Integer
C#
public int GetCountDB(
   Where whereClause,
   bool includeDisabled
)

Parameters

whereClause
The where clause to filter the categories.
includeDisabled
Determines whether to load disabled categories or not. Defaults is false.

Return Value

Returns the number of elements in the Categories table.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Class
Categories Members
Overload List


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > Categories Class : LoadDB Method

Loads all the categories from Categories table. If this method is called through a category object, it only loads its sub-categories. If this method is called through an item object, it only loads the categries the item belongs to them.

Overload List

Overload | Description
LoadDB() | Loads all the categories from Categories table. If this method is called through a category object, it only loads its sub-categories. If this method is called through an item object, it only loads the categries the item belongs to them.
LoadDB(Int64) | Loads all the sub-categories for this category ID from Categories table.
LoadDB(Where,Int32,Int32,String,OrderDirection) | Loads all the categories based on the parameters from Categories table.
LoadDB(Int32,Int32) | Loads the count number of categories from start value from Categories table.
LoadDB(Int64,Where,Int32,Int32,String,OrderDirection) | Loads all the categories based on the parameters from Categories table.
LoadDB(Int64,Where,Int32,Int32,String,OrderDirection,Boolean) | Loads all the categories based on the parameters from Categories table.
LoadDB(Where) | Loads all the items from its associated table based on the where clause. (Inherited from dotnetCART.ListBase<Category>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Class
Categories Members


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > Categories Class > LoadDB Method : LoadDB() Method

Loads all the categories from Categories table. If this method is called through a category object, it only loads its sub-categories. If this method is called through an item object, it only loads the categries the item belongs to them.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function LoadDB() As Integer
C#
public override int LoadDB()

Return Value

The total number of categories have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Class
Categories Members
Overload List


%%PageItemTitle%%

LoadDB(Int64) Method
[image]
dotnetCART Namespace > Categories Class > LoadDB Method : LoadDB(Int64) Method

parentCategoryID
The category ID.
Loads all the sub-categories for this category ID from Categories table.

Syntax

Visual Basic (Declaration)
Public Overloads Function LoadDB( _
   ByVal parentCategoryID As Long _
) As Integer
C#
public int LoadDB(
   long parentCategoryID
)

Parameters

parentCategoryID
The category ID.

Return Value

The total number of categories have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Class
Categories Members
Overload List


%%PageItemTitle%%

LoadDB(Where,Int32,Int32,String,OrderDirection) Method
[image]
dotnetCART Namespace > Categories Class > LoadDB Method : LoadDB(Where,Int32,Int32,String,OrderDirection) Method

whereClause
The where clause to filter the categories.
start
The start page which starts from 0.
count
The number of categories in the page.
orderBy
The order of the loaded categories.
orderDirection
The order direction of the loaded categories. Defaults is Asc.
Loads all the categories based on the parameters from Categories table.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function LoadDB( _
   ByVal whereClause As Where, _
   ByVal start As Integer, _
   ByVal count As Integer, _
   ByVal orderBy As String, _
   ByVal orderDirection As OrderDirection _
) As Integer
C#
public override int LoadDB(
   Where whereClause,
   int start,
   int count,
   string orderBy,
   OrderDirection orderDirection
)

Parameters

whereClause
The where clause to filter the categories.
start
The start page which starts from 0.
count
The number of categories in the page.
orderBy
The order of the loaded categories.
orderDirection
The order direction of the loaded categories. Defaults is Asc.

Return Value

The total number of categories have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Class
Categories Members
Overload List


%%PageItemTitle%%

LoadDB(Int32,Int32) Method
[image]
dotnetCART Namespace > Categories Class > LoadDB Method : LoadDB(Int32,Int32) Method

start
The start page which starts from 0.
count
The number of categories in the page.
Loads the count number of categories from start value from Categories table.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function LoadDB( _
   ByVal start As Integer, _
   ByVal count As Integer _
) As Integer
C#
public override int LoadDB(
   int start,
   int count
)

Parameters

start
The start page which starts from 0.
count
The number of categories in the page.

Return Value

The total number of categories have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Class
Categories Members
Overload List


%%PageItemTitle%%

LoadDB(Int64,Where,Int32,Int32,String,OrderDirection) Method
[image]
dotnetCART Namespace > Categories Class > LoadDB Method : LoadDB(Int64,Where,Int32,Int32,String,OrderDirection) Method

parentCategoryID
The parent category ID.
whereClause
The where clause to filter the categories.
start
The start page which starts from 0.
count
The number of categories in the page.
orderBy
The order of the loaded categories.
orderDirection
The order direction of the loaded categories. Defaults is Asc.
Loads all the categories based on the parameters from Categories table.

Syntax

Visual Basic (Declaration)
Public Overloads Function LoadDB( _
   ByVal parentCategoryID As Long, _
   ByVal whereClause As Where, _
   ByVal start As Integer, _
   ByVal count As Integer, _
   ByVal orderBy As String, _
   ByVal orderDirection As OrderDirection _
) As Integer
C#
public int LoadDB(
   long parentCategoryID,
   Where whereClause,
   int start,
   int count,
   string orderBy,
   OrderDirection orderDirection
)

Parameters

parentCategoryID
The parent category ID.
whereClause
The where clause to filter the categories.
start
The start page which starts from 0.
count
The number of categories in the page.
orderBy
The order of the loaded categories.
orderDirection
The order direction of the loaded categories. Defaults is Asc.

Return Value

The total number of categories have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Class
Categories Members
Overload List


%%PageItemTitle%%

LoadDB(Int64,Where,Int32,Int32,String,OrderDirection,Boolean) Method
See Also
[image]
dotnetCART Namespace > Categories Class > LoadDB Method : LoadDB(Int64,Where,Int32,Int32,String,OrderDirection,Boolean) Method

parentCategoryID
The parent category ID.
whereClause
The where clause to filter the categories.
start
The start page which starts from 0.
count
The number of categories in the page.
orderBy
The order of the loaded categories.
orderDirection
The order direction of the loaded categories. Defaults is Asc.
includeDisabled
Determine whether to load disabled categories or not. Defaults is false.
Loads all the categories based on the parameters from Categories table.

Syntax

Visual Basic (Declaration)
Public Overloads Function LoadDB( _
   ByVal parentCategoryID As Long, _
   ByVal whereClause As Where, _
   ByVal start As Integer, _
   ByVal count As Integer, _
   ByVal orderBy As String, _
   ByVal orderDirection As OrderDirection, _
   ByVal includeDisabled As Boolean _
) As Integer
C#
public int LoadDB(
   long parentCategoryID,
   Where whereClause,
   int start,
   int count,
   string orderBy,
   OrderDirection orderDirection,
   bool includeDisabled
)

Parameters

parentCategoryID
The parent category ID.
whereClause
The where clause to filter the categories.
start
The start page which starts from 0.
count
The number of categories in the page.
orderBy
The order of the loaded categories.
orderDirection
The order direction of the loaded categories. Defaults is Asc.
includeDisabled
Determine whether to load disabled categories or not. Defaults is false.

Return Value

The total number of categories have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Class
Categories Members
Overload List


%%PageItemTitle%%

SaveDB Method
[image]
dotnetCART Namespace > Categories Class : SaveDB Method

Saves all the categories in this collection to Categories table.

Syntax

Visual Basic (Declaration)
Public Function SaveDB() As Integer
C#
public int SaveDB()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Class
Categories Members


%%PageItemTitle%%

Sort Method
[image]
dotnetCART Namespace > Categories Class : Sort Method

Overload List

Overload | Description
Sort(String) |
Sort(String,OrderDirection) |

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Class
Categories Members


%%PageItemTitle%%

Sort(String) Method
[image]
dotnetCART Namespace > Categories Class > Sort Method : Sort(String) Method

requestSort

Syntax

Visual Basic (Declaration)
Public Overloads Sub Sort( _
   ByVal requestSort As String _
)
C#
public void Sort(
   string requestSort
)

Parameters

requestSort

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Class
Categories Members
Overload List


%%PageItemTitle%%

Sort(String,OrderDirection) Method
[image]
dotnetCART Namespace > Categories Class > Sort Method : Sort(String,OrderDirection) Method

requestSort
orderDirection

Syntax

Visual Basic (Declaration)
Public Overloads Sub Sort( _
   ByVal requestSort As String, _
   ByVal orderDirection As OrderDirection _
)
C#
public void Sort(
   string requestSort,
   OrderDirection orderDirection
)

Parameters

requestSort
orderDirection

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Class
Categories Members
Overload List


%%PageItemTitle%%

Categories.categoryComparerClass Class
See Also Members
[image]
dotnetCART Namespace : Categories.categoryComparerClass Class

Syntax

Visual Basic (Declaration)
Private Class Categories.categoryComparerClass
C#
private class Categories.categoryComparerClass

Inheritance Hierarchy

System.Object
dotnetCART.Categories.categoryComparerClass

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories.categoryComparerClass Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

Categories.categoryComparerClass Class Members
See Also Methods
[image]
dotnetCART Namespace : Categories.categoryComparerClass Class

The following tables list the members exposed by Categories.categoryComparerClass.

Public Constructors

 | Name | Description
Public Constructor | Categories.categoryComparerClass Constructor | Overloaded.
Top

Public Methods

 | Name | Description
Public Method | Compare |
Top

See Also

Reference

Categories.categoryComparerClass Class
dotnetCART Namespace


%%PageItemTitle%%

Categories.categoryComparerClass Constructor
[image]
dotnetCART Namespace > Categories.categoryComparerClass Class : Categories.categoryComparerClass Constructor

Overload List

Overload | Description
Categories.categoryComparerClass Constructor() |
Categories.categoryComparerClass Constructor(String) |
Categories.categoryComparerClass Constructor(String,OrderDirection) |

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories.categoryComparerClass Class
Categories.categoryComparerClass Members


%%PageItemTitle%%

Categories.categoryComparerClass Constructor()
See Also
[image]
dotnetCART Namespace > Categories.categoryComparerClass Class > Categories.categoryComparerClass Constructor : Categories.categoryComparerClass Constructor()

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Categories.categoryComparerClass()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories.categoryComparerClass Class
Categories.categoryComparerClass Members
Overload List


%%PageItemTitle%%

Categories.categoryComparerClass Constructor(String)
See Also
[image]
dotnetCART Namespace > Categories.categoryComparerClass Class > Categories.categoryComparerClass Constructor : Categories.categoryComparerClass Constructor(String)

sortOption

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal sortOption As String _
)
C#
public Categories.categoryComparerClass(
   string sortOption
)

Parameters

sortOption

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories.categoryComparerClass Class
Categories.categoryComparerClass Members
Overload List


%%PageItemTitle%%

Categories.categoryComparerClass Constructor(String,OrderDirection)
See Also
[image]
dotnetCART Namespace > Categories.categoryComparerClass Class > Categories.categoryComparerClass Constructor : Categories.categoryComparerClass Constructor(String,OrderDirection)

sortOption
orderDirection

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal sortOption As String, _
   ByVal orderDirection As OrderDirection _
)
C#
public Categories.categoryComparerClass(
   string sortOption,
   OrderDirection orderDirection
)

Parameters

sortOption
orderDirection

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories.categoryComparerClass Class
Categories.categoryComparerClass Members
Overload List


%%PageItemTitle%% $$Methods$$

Categories.categoryComparerClass Class Methods
[image]
dotnetCART Namespace : Categories.categoryComparerClass Class

For a list of all members of this type, see Categories.categoryComparerClass members.

Public Methods

 | Name | Description
Public Method | Compare |
Top

See Also

Reference

Categories.categoryComparerClass Class
dotnetCART Namespace


%%PageItemTitle%%

Compare Method
[image]
dotnetCART Namespace > Categories.categoryComparerClass Class : Compare Method

category1
category2

Syntax

Visual Basic (Declaration)
Public Function Compare( _
   ByVal category1 As Category, _
   ByVal category2 As Category _
) As Integer
C#
public int Compare(
   Category category1,
   Category category2
)

Parameters

category1
category2

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories.categoryComparerClass Class
Categories.categoryComparerClass Members


%%PageItemTitle%%

Category Class
See Also Members
[image]
dotnetCART Namespace : Category Class

Represents a Category object.

Object Model

Syntax

Visual Basic (Declaration)
Public Class Category
   Inherits DbTableCart(Of Category, Long)
C#
public class Category : DbTableCart<Category, long>

Inheritance Hierarchy

System.Object
dotnetDATA.DbTable<Int64>
dotnetDATA.DbTable<Category, Int64>
dotnetCART.DbTableCart<Category, Int64>
dotnetCART.Category

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Category Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

Category Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : Category Class

The following tables list the members exposed by Category.

Public Constructors

 | Name | Description
Public Constructor | Category Constructor | Initializes a new instance of the Category class.
Top

Public Properties

 | Name | Description
Public Property | AdjustRate | Formula for category level price adjustments on items quantity / price. This formula accepts quantity and price ranges and adjusts based on a fixed amount or percentage. Ranges can be defined as quantity (1-10), dollars ($1-10) and also support open ended ranges e.g. 10 and up (10-). Adjustments can also be made as surcharges by using "+" rather than "-".
Public Property | Categories | A reference to the child Category objects.
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<Category, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<Category, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<Category, Int64>)
Public Property | Description | Gets or sets this category's description.
Public Property | Disabled | Determines whether this category is disabled or not.
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<Category, Int64>)
Public Property | ID | Overridden. The auto number ID populated from the database.
Public Property | Images | A collection of image objects. LoadDB method, loads all the images for this category from Images table. For saving a new image for a category in the database, the image.ParentObject must be set to the category object, then calling image.SaveDB() method. category.SaveDB() method doesn't save any image to Images table.
Public Property | Items |
Public Property | MultiAdd | Determines whether the items in this category can be added to the cart together or not.
Public Property | Name | Gets or sets this category's name.
Public Property | ParentID | Sets or gets the parent category ID.
Top

Public Methods

 | Name | Description
Public Method | Clear | Overridden. Initializes all the properties without recreating the object.
Public Method | Clone | Creates a copy of the current Category
Public Method | DeleteDB | Overloaded. Overridden. Deletes this category and all the records for this category in ItemCategories table.
Public Method | GetBreadcrumbsDB | Returns a listDictionary of the breadcruumbs for the current category ID.
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<Category, Int64>)
Public Method | LoadDB | Overloaded. Overridden. Loads this category, child categories and the items belongs to this category from database. By default only enabled (Disabled=flase) categories and items are loaded.
Public Method | SaveDB | Overloaded. Overridden. Inserts or updates this object into the Categories table. For the Items Property, if the item already exist in Items table, it just bind it to this category by adding to ItemCategories table.
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<Category, Int64>)
Top

See Also

Reference

Category Class
dotnetCART Namespace


%%PageItemTitle%%

Category Constructor
[image]
dotnetCART Namespace > Category Class : Category Constructor

Initializes a new instance of the Category class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Category()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Category Class
Category Members


%%PageItemTitle%% $$Methods$$

Category Class Methods
[image]
dotnetCART Namespace : Category Class

For a list of all members of this type, see Category members.

Public Methods

 | Name | Description
Public Method | Clear | Overridden. Initializes all the properties without recreating the object.
Public Method | Clone | Creates a copy of the current Category
Public Method | DeleteDB | Overloaded. Overridden. Deletes this category and all the records for this category in ItemCategories table.
Public Method | GetBreadcrumbsDB | Returns a listDictionary of the breadcruumbs for the current category ID.
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<Category, Int64>)
Public Method | LoadDB | Overloaded. Overridden. Loads this category, child categories and the items belongs to this category from database. By default only enabled (Disabled=flase) categories and items are loaded.
Public Method | SaveDB | Overloaded. Overridden. Inserts or updates this object into the Categories table. For the Items Property, if the item already exist in Items table, it just bind it to this category by adding to ItemCategories table.
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<Category, Int64>)
Top

See Also

Reference

Category Class
dotnetCART Namespace


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > Category Class : Clear Method

Initializes all the properties without recreating the object.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Clear()
C#
public override void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Category Class
Category Members


%%PageItemTitle%%

Clone Method
[image]
dotnetCART Namespace > Category Class : Clone Method

Creates a copy of the current Category

Syntax

Visual Basic (Declaration)
Public Function Clone() As Category
C#
public Category Clone()

Return Value

Returns a Category object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Category Class
Category Members


%%PageItemTitle%%

DeleteDB Method
[image]
dotnetCART Namespace > Category Class : DeleteDB Method

Deletes this category and all the records for this category in ItemCategories table.

Overload List

Overload | Description
DeleteDB() | Deletes this category and all the records for this category in ItemCategories table.
DeleteDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Category Class
Category Members


%%PageItemTitle%%

DeleteDB() Method
[image]
dotnetCART Namespace > Category Class > DeleteDB Method : DeleteDB() Method

Deletes this category and all the records for this category in ItemCategories table.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function DeleteDB() As Integer
C#
public override int DeleteDB()

Return Value

In case of error -1, check Error property, otherwise the number of records deleted.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Category Class
Category Members
Overload List


%%PageItemTitle%%

GetBreadcrumbsDB Method
[image]
dotnetCART Namespace > Category Class : GetBreadcrumbsDB Method

Returns a listDictionary of the breadcruumbs for the current category ID.

Syntax

Visual Basic (Declaration)
Public Function GetBreadcrumbsDB() As ListDictionary
C#
public ListDictionary GetBreadcrumbsDB()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Category Class
Category Members


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > Category Class : LoadDB Method

Loads this category, child categories and the items belongs to this category from database. By default only enabled (Disabled=flase) categories and items are loaded.

Overload List

Overload | Description
LoadDB() | Loads this category, child categories and the items belongs to this category from database. By default only enabled (Disabled=flase) categories and items are loaded.
LoadDB(Int64,Boolean) | Loads this category, child categories and the items belongs to this category from database.
LoadDB(Int64) | (Inherited from dotnetCART.DbTableCart<Category, Int64>)
Generic LoadDB() | (Inherited from dotnetDATA.DbTable<Int64>)
Generic LoadDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Category Class
Category Members


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > Category Class > LoadDB Method : LoadDB() Method

Loads this category, child categories and the items belongs to this category from database. By default only enabled (Disabled=flase) categories and items are loaded.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function LoadDB() As Integer
C#
public override int LoadDB()

Return Value

Returns 1 for the success, and -1 if failed. For the reason of fail, check the Errorproperty.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Category Class
Category Members
Overload List


%%PageItemTitle%%

LoadDB(Int64,Boolean) Method
[image]
dotnetCART Namespace > Category Class > LoadDB Method : LoadDB(Int64,Boolean) Method

categoryID
The ID of the category.
includeDisabled
Determinses whether to load the disabled categories and items or not.
Loads this category, child categories and the items belongs to this category from database.

Syntax

Visual Basic (Declaration)
Public Overloads Function LoadDB( _
   ByVal categoryID As Long, _
   ByVal includeDisabled As Boolean _
) As Integer
C#
public int LoadDB(
   long categoryID,
   bool includeDisabled
)

Parameters

categoryID
The ID of the category.
includeDisabled
Determinses whether to load the disabled categories and items or not.

Return Value

Returns 1 for the success, and -1 if failed. For the reason of fail, check the Errorproperty.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Category Class
Category Members
Overload List


%%PageItemTitle%%

SaveDB Method
[image]
dotnetCART Namespace > Category Class : SaveDB Method

Inserts or updates this object into the Categories table. For the Items Property, if the item already exist in Items table, it just bind it to this category by adding to ItemCategories table.

Overload List

Overload | Description
SaveDB() | Inserts or updates this object into the Categories table. For the Items Property, if the item already exist in Items table, it just bind it to this category by adding to ItemCategories table.
SaveDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Category Class
Category Members


%%PageItemTitle%%

SaveDB() Method
[image]
dotnetCART Namespace > Category Class > SaveDB Method : SaveDB() Method

Inserts or updates this object into the Categories table. For the Items Property, if the item already exist in Items table, it just bind it to this category by adding to ItemCategories table.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function SaveDB() As Integer
C#
public override int SaveDB()

Return Value

Returns the generated ID or 1 for the update, returns -1 if failed. For the reason of fail, check the Error Property.

Remarks

If ID greater than 0, it updates the associated category in the table, otherwise inserts a new category.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Category Class
Category Members
Overload List


%%PageItemTitle%% $$Properties$$

Category Class Properties
[image]
dotnetCART Namespace : Category Class

For a list of all members of this type, see Category members.

Public Properties

 | Name | Description
Public Property | AdjustRate | Formula for category level price adjustments on items quantity / price. This formula accepts quantity and price ranges and adjusts based on a fixed amount or percentage. Ranges can be defined as quantity (1-10), dollars ($1-10) and also support open ended ranges e.g. 10 and up (10-). Adjustments can also be made as surcharges by using "+" rather than "-".
Public Property | Categories | A reference to the child Category objects.
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<Category, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<Category, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<Category, Int64>)
Public Property | Description | Gets or sets this category's description.
Public Property | Disabled | Determines whether this category is disabled or not.
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<Category, Int64>)
Public Property | ID | Overridden. The auto number ID populated from the database.
Public Property | Images | A collection of image objects. LoadDB method, loads all the images for this category from Images table. For saving a new image for a category in the database, the image.ParentObject must be set to the category object, then calling image.SaveDB() method. category.SaveDB() method doesn't save any image to Images table.
Public Property | Items |
Public Property | MultiAdd | Determines whether the items in this category can be added to the cart together or not.
Public Property | Name | Gets or sets this category's name.
Public Property | ParentID | Sets or gets the parent category ID.
Top

See Also

Reference

Category Class
dotnetCART Namespace


%%PageItemTitle%%

AdjustRate Property
See Also Example
[image]
dotnetCART Namespace > Category Class : AdjustRate Property

Formula for category level price adjustments on items quantity / price. This formula accepts quantity and price ranges and adjusts based on a fixed amount or percentage. Ranges can be defined as quantity (1-10), dollars ($1-10) and also support open ended ranges e.g. 10 and up (10-). Adjustments can also be made as surcharges by using "+" rather than "-".

Syntax

Visual Basic (Declaration)
Public Property AdjustRate As String
C#
public string AdjustRate {get; set;}

Example

C# Copy Code
Category.AdjustRate = "$1=-10%;$2=-20%;$3=-30%;";
Category.AdjustRate = "1=-10%;$2=-20%;3-=-30%;";
Category.AdjustRate = "1=10;2=20;3=30;4-100=35;101-=40;";

Visual Basic Copy Code
Category.AdjustRate = "$1=-10%;$2=-20%;$3=-30%;"
Category.AdjustRate = "1=-10%;$2=-20%;3-=-30%;"
Category.AdjustRate = "1=10;2=20;3=30;4-100=35;101-=40;"

Remarks

In Calculate() method, if an Item.AdjustRate is empty, this property is used.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Category Class
Category Members


%%PageItemTitle%%

Categories Property
[image]
dotnetCART Namespace > Category Class : Categories Property

A reference to the child Category objects.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Categories As Categories
C#
public Categories Categories {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Category Class
Category Members


%%PageItemTitle%%

Description Property
[image]
dotnetCART Namespace > Category Class : Description Property

Gets or sets this category's description.

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Category Class
Category Members


%%PageItemTitle%%

Disabled Property
[image]
dotnetCART Namespace > Category Class : Disabled Property

Determines whether this category is disabled or not.

Syntax

Visual Basic (Declaration)
Public Property Disabled As Boolean
C#
public bool Disabled {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Category Class
Category Members


%%PageItemTitle%%

ID Property
[image]
dotnetCART Namespace > Category Class : ID Property

The auto number ID populated from the database.

Syntax

Visual Basic (Declaration)
Public Overrides Property ID As Long
C#
public override long ID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Category Class
Category Members


%%PageItemTitle%%

Images Property
[image]
dotnetCART Namespace > Category Class : Images Property

A collection of image objects. LoadDB method, loads all the images for this category from Images table. For saving a new image for a category in the database, the image.ParentObject must be set to the category object, then calling image.SaveDB() method. category.SaveDB() method doesn't save any image to Images table.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Images As Images
C#
public Images Images {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Category Class
Category Members


%%PageItemTitle%%

Items Property
[image]
dotnetCART Namespace > Category Class : Items Property

Syntax

Visual Basic (Declaration)
Public Property Items As Items
C#
public Items Items {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Category Class
Category Members


%%PageItemTitle%%

MultiAdd Property
[image]
dotnetCART Namespace > Category Class : MultiAdd Property

Determines whether the items in this category can be added to the cart together or not.

Syntax

Visual Basic (Declaration)
Public Property MultiAdd As Boolean
C#
public bool MultiAdd {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Category Class
Category Members


%%PageItemTitle%%

Name Property
[image]
dotnetCART Namespace > Category Class : Name Property

Gets or sets this category's name.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Category Class
Category Members


%%PageItemTitle%%

ParentID Property
[image]
dotnetCART Namespace > Category Class : ParentID Property

Sets or gets the parent category ID.

Syntax

Visual Basic (Declaration)
Public Property ParentID As Long
C#
public long ParentID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Category Class
Category Members


%%PageItemTitle%%

Choice Class
See Also Members
[image]
dotnetCART Namespace : Choice Class

Represents a Choice object.

Object Model

Syntax

Visual Basic (Declaration)
Public Class Choice
   Inherits DbTableCart(Of Choice, Long)
C#
public class Choice : DbTableCart<Choice, long>

Inheritance Hierarchy

System.Object
dotnetDATA.DbTable<Int64>
dotnetDATA.DbTable<Choice, Int64>
dotnetCART.DbTableCart<Choice, Int64>
dotnetCART.Choice

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choice Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

Choice Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : Choice Class

The following tables list the members exposed by Choice.

Public Constructors

 | Name | Description
Public Constructor | Choice Constructor | Initializes a new instance of the Choice class.
Top

Public Properties

 | Name | Description
Public Property | AdjustCost | Gets or sets the cost adjustment for this choice.
Public Property | AdjustPrice | Gets or sets the price adjustment for this choice.
Public Property | AdjustWeight | Gets or sets the weight adjustment for this choice.
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<Choice, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<Choice, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<Choice, Int64>)
Public Property | Description | Gets or sets this choice description.
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<Choice, Int64>)
Public Property | ID | Overridden. The auto number ID populated from the database.
Public Property | Image | Gets or sets the image object for this choice.
Public Property | Name | Gets or sets this choice name.
Public Property | Option | The parent option for this choice.
Public Property | Selected | Indicates whether this choice is selected or not.
Public Property | SwatchImage | Gets or sets this choice swatch image URL.
Top

Public Methods

 | Name | Description
Public Method | Clear | Initializes all the properties without recreating the object. (Inherited from dotnetCART.DbTableCart<Choice, Int64>)
Public Method | Clone | Creates a copy of the current Choice
Public Method | DeleteDB | Overloaded. Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<Choice, Int64>)
Public Method | GetAdjust | Get the price adjustment value for this choice.
Public Method | GetAdjustWeight | Get the weight adjustment value for this choice.
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<Choice, Int64>)
Public Method | LoadDB | Overloaded. Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<Choice, Int64>)
Public Method | SaveDB | Overloaded. Inserts or updates this object into the database. (Inherited from dotnetCART.DbTableCart<Choice, Int64>)
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<Choice, Int64>)
Top

See Also

Reference

Choice Class
dotnetCART Namespace


%%PageItemTitle%%

Choice Constructor
[image]
dotnetCART Namespace > Choice Class : Choice Constructor

Initializes a new instance of the Choice class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Choice()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choice Class
Choice Members


%%PageItemTitle%% $$Methods$$

Choice Class Methods
[image]
dotnetCART Namespace : Choice Class

For a list of all members of this type, see Choice members.

Public Methods

 | Name | Description
Public Method | Clear | Initializes all the properties without recreating the object. (Inherited from dotnetCART.DbTableCart<Choice, Int64>)
Public Method | Clone | Creates a copy of the current Choice
Public Method | DeleteDB | Overloaded. Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<Choice, Int64>)
Public Method | GetAdjust | Get the price adjustment value for this choice.
Public Method | GetAdjustWeight | Get the weight adjustment value for this choice.
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<Choice, Int64>)
Public Method | LoadDB | Overloaded. Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<Choice, Int64>)
Public Method | SaveDB | Overloaded. Inserts or updates this object into the database. (Inherited from dotnetCART.DbTableCart<Choice, Int64>)
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<Choice, Int64>)
Top

See Also

Reference

Choice Class
dotnetCART Namespace


%%PageItemTitle%%

Clone Method
[image]
dotnetCART Namespace > Choice Class : Clone Method

Creates a copy of the current Choice

Syntax

Visual Basic (Declaration)
Public Function Clone() As Choice
C#
public Choice Clone()

Return Value

Returns a Choice object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choice Class
Choice Members


%%PageItemTitle%%

GetAdjust Method
[image]
dotnetCART Namespace > Choice Class : GetAdjust Method

itemPrice
Get the price adjustment value for this choice.

Syntax

Visual Basic (Declaration)
Public Function GetAdjust( _
   ByVal itemPrice As Double _
) As Double
C#
public double GetAdjust(
   double itemPrice
)

Parameters

itemPrice

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choice Class
Choice Members


%%PageItemTitle%%

GetAdjustWeight Method
[image]
dotnetCART Namespace > Choice Class : GetAdjustWeight Method

itemWeight
Get the weight adjustment value for this choice.

Syntax

Visual Basic (Declaration)
Public Function GetAdjustWeight( _
   ByVal itemWeight As Double _
) As Double
C#
public double GetAdjustWeight(
   double itemWeight
)

Parameters

itemWeight

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choice Class
Choice Members


%%PageItemTitle%% $$Properties$$

Choice Class Properties
[image]
dotnetCART Namespace : Choice Class

For a list of all members of this type, see Choice members.

Public Properties

 | Name | Description
Public Property | AdjustCost | Gets or sets the cost adjustment for this choice.
Public Property | AdjustPrice | Gets or sets the price adjustment for this choice.
Public Property | AdjustWeight | Gets or sets the weight adjustment for this choice.
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<Choice, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<Choice, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<Choice, Int64>)
Public Property | Description | Gets or sets this choice description.
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<Choice, Int64>)
Public Property | ID | Overridden. The auto number ID populated from the database.
Public Property | Image | Gets or sets the image object for this choice.
Public Property | Name | Gets or sets this choice name.
Public Property | Option | The parent option for this choice.
Public Property | Selected | Indicates whether this choice is selected or not.
Public Property | SwatchImage | Gets or sets this choice swatch image URL.
Top

See Also

Reference

Choice Class
dotnetCART Namespace


%%PageItemTitle%%

AdjustCost Property
See Also Example
[image]
dotnetCART Namespace > Choice Class : AdjustCost Property

Gets or sets the cost adjustment for this choice.

Syntax

Visual Basic (Declaration)
Public Property AdjustCost As String
C#
public string AdjustCost {get; set;}

Example

The cost adjustment value can be a single number or a percentage.
C# Copy Code
Cart.Item.Option.Choice.AdjustCost = "10.50";

Cart.Item.Option.Choice.AdjustCost = "10%";

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choice Class
Choice Members


%%PageItemTitle%%

AdjustPrice Property
See Also Example
[image]
dotnetCART Namespace > Choice Class : AdjustPrice Property

Gets or sets the price adjustment for this choice.

Syntax

Visual Basic (Declaration)
Public Property AdjustPrice As String
C#
public string AdjustPrice {get; set;}

Example

The price adjustment value can be a single number or a percentage.
C# Copy Code
Cart.Item.Option.Choice.AdjustPrice = "10.50";

Cart.Item.Option.Choice.AdjustPrice = "10%";

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choice Class
Choice Members


%%PageItemTitle%%

AdjustWeight Property
See Also Example
[image]
dotnetCART Namespace > Choice Class : AdjustWeight Property

Gets or sets the weight adjustment for this choice.

Syntax

Visual Basic (Declaration)
Public Property AdjustWeight As String
C#
public string AdjustWeight {get; set;}

Example

The weight adjustment value can be a single number or a percentage.
C# Copy Code
Cart.Item.Option.Choice.AdjustWeight = "1.5";

Cart.Item.Option.Choice.AdjustWeight = "15%";

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choice Class
Choice Members


%%PageItemTitle%%

Description Property
[image]
dotnetCART Namespace > Choice Class : Description Property

Gets or sets this choice description.

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choice Class
Choice Members


%%PageItemTitle%%

ID Property
[image]
dotnetCART Namespace > Choice Class : ID Property

The auto number ID populated from the database.

Syntax

Visual Basic (Declaration)
Public Overrides Property ID As Long
C#
public override long ID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choice Class
Choice Members


%%PageItemTitle%%

Image Property
[image]
dotnetCART Namespace > Choice Class : Image Property

Gets or sets the image object for this choice.

Syntax

Visual Basic (Declaration)
Public Property Image As Image
C#
public Image Image {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choice Class
Choice Members


%%PageItemTitle%%

Name Property
[image]
dotnetCART Namespace > Choice Class : Name Property

Gets or sets this choice name.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choice Class
Choice Members


%%PageItemTitle%%

Option Property
[image]
dotnetCART Namespace > Choice Class : Option Property

The parent option for this choice.

Syntax

Visual Basic (Declaration)
Public Property Option As Option
C#
public Option Option {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choice Class
Choice Members


%%PageItemTitle%%

Selected Property
[image]
dotnetCART Namespace > Choice Class : Selected Property

Indicates whether this choice is selected or not.

Syntax

Visual Basic (Declaration)
Public Property Selected As Boolean
C#
public bool Selected {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choice Class
Choice Members


%%PageItemTitle%%

SwatchImage Property
[image]
dotnetCART Namespace > Choice Class : SwatchImage Property

Gets or sets this choice swatch image URL.

Syntax

Visual Basic (Declaration)
Public Property SwatchImage As String
C#
public string SwatchImage {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choice Class
Choice Members


%%PageItemTitle%%

Choices Class
See Also Members
[image]
dotnetCART Namespace : Choices Class

A collection of Choice objects.

Object Model

Syntax

Visual Basic (Declaration)
Public Class Choices
   Inherits EntitySet(Of Choice)
C#
public class Choices : EntitySet<Choice>

Inheritance Hierarchy

System.Object
dotnetDATA.EntitySet<Choice>
dotnetCART.Choices

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choices Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

Choices Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : Choices Class

The following tables list the members exposed by Choices.

Public Constructors

 | Name | Description
Public Constructor | Choices Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Count | Returns the number of items in the collection. (Inherited from dotnetDATA.EntitySet<Choice>)
Public Property | Item | Overloaded. Gets the choice with specified name.
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Add a new choice to this collection.
Public Method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetDATA.EntitySet<Choice>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetDATA.EntitySet<Choice>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetDATA.EntitySet<Choice>)
Public Method | GetChoice | Gets the choice with specified ID.
Public Method | IndexOf | Returns the index of this item in the list. (Inherited from dotnetDATA.EntitySet<Choice>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetDATA.EntitySet<Choice>)
Public Method | Remove | Removes the item from the collection. (Inherited from dotnetDATA.EntitySet<Choice>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetDATA.EntitySet<Choice>)
Top

See Also

Reference

Choices Class
dotnetCART Namespace


%%PageItemTitle%%

Choices Constructor
[image]
dotnetCART Namespace > Choices Class : Choices Constructor

Overload List

Overload | Description
Choices Constructor(IDbTable) |
Choices Constructor(IDbTable,DbLoadType) |

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choices Class
Choices Members


%%PageItemTitle%%

Choices Constructor(IDbTable)
See Also
[image]
dotnetCART Namespace > Choices Class > Choices Constructor : Choices Constructor(IDbTable)

parentTable

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parentTable As IDbTable _
)
C#
public Choices(
   IDbTable parentTable
)

Parameters

parentTable

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choices Class
Choices Members
Overload List


%%PageItemTitle%%

Choices Constructor(IDbTable,DbLoadType)
See Also
[image]
dotnetCART Namespace > Choices Class > Choices Constructor : Choices Constructor(IDbTable,DbLoadType)

parentTable
loadType

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parentTable As IDbTable, _
   ByVal loadType As DbLoadType _
)
C#
public Choices(
   IDbTable parentTable,
   DbLoadType loadType
)

Parameters

parentTable
loadType

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choices Class
Choices Members
Overload List


%%PageItemTitle%% $$Methods$$

Choices Class Methods
[image]
dotnetCART Namespace : Choices Class

For a list of all members of this type, see Choices members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Add a new choice to this collection.
Public Method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetDATA.EntitySet<Choice>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetDATA.EntitySet<Choice>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetDATA.EntitySet<Choice>)
Public Method | GetChoice | Gets the choice with specified ID.
Public Method | IndexOf | Returns the index of this item in the list. (Inherited from dotnetDATA.EntitySet<Choice>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetDATA.EntitySet<Choice>)
Public Method | Remove | Removes the item from the collection. (Inherited from dotnetDATA.EntitySet<Choice>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetDATA.EntitySet<Choice>)
Top

See Also

Reference

Choices Class
dotnetCART Namespace


%%PageItemTitle%%

Add Method
[image]
dotnetCART Namespace > Choices Class : Add Method

Add a new choice to this collection.

Overload List

Overload | Description
Add() | Add a new choice to this collection.
Add(Choice) | (Inherited from dotnetDATA.EntitySet<Choice>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choices Class
Choices Members


%%PageItemTitle%%

Add() Method
[image]
dotnetCART Namespace > Choices Class > Add Method : Add() Method

Add a new choice to this collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add()
C#
public void Add()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choices Class
Choices Members
Overload List


%%PageItemTitle%%

GetChoice Method
[image]
dotnetCART Namespace > Choices Class : GetChoice Method

choiceID
Gets the choice with specified ID.

Syntax

Visual Basic (Declaration)
Public Function GetChoice( _
   ByVal choiceID As Long _
) As Choice
C#
public Choice GetChoice(
   long choiceID
)

Parameters

choiceID

Return Value

A choice object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choices Class
Choices Members


%%PageItemTitle%% $$Properties$$

Choices Class Properties
[image]
dotnetCART Namespace : Choices Class

For a list of all members of this type, see Choices members.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of items in the collection. (Inherited from dotnetDATA.EntitySet<Choice>)
Public Property | Item | Overloaded. Gets the choice with specified name.
Top

See Also

Reference

Choices Class
dotnetCART Namespace


%%PageItemTitle%%

Item Property
[image]
dotnetCART Namespace > Choices Class : Item Property

Gets the choice with specified name.

Overload List

Overload | Description
Item(String) | Gets the choice with specified name.
Item(Int32) | Gets the element at the specified index. (Inherited from dotnetDATA.EntitySet<Choice>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choices Class
Choices Members


%%PageItemTitle%%

Item(String) Property
[image]
dotnetCART Namespace > Choices Class > Item Property : Item(String) Property

name
A choice name.
Gets the choice with specified name.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal name As String _
) As Choice
C#
public Choice Item(
   string name
) {get;}

Parameters

name
A choice name.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choices Class
Choices Members
Overload List


%%PageItemTitle%%

Coupon Class
See Also Members
[image]
dotnetCART Namespace : Coupon Class

Represents a Coupon object.

Object Model

Syntax

Visual Basic (Declaration)
Public Class Coupon
   Inherits DbTableCart(Of Coupon, Long)
C#
public class Coupon : DbTableCart<Coupon, long>

Remarks

For a typical usage, add one or more coupons in StoreAdmin->Coupons.
Then customers can enter the coupon code in display cart coupon textbox.

Inheritance Hierarchy

System.Object
dotnetDATA.DbTable<Int64>
dotnetDATA.DbTable<Coupon, Int64>
dotnetCART.DbTableCart<Coupon, Int64>
dotnetCART.Coupon

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupon Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

Coupon Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : Coupon Class

The following tables list the members exposed by Coupon.

Public Constructors

 | Name | Description
Public Constructor | Coupon Constructor | Initializes a new instance of the Coupon class.
Top

Public Properties

 | Name | Description
Public Property | Adjust | Gets the result of AdjustRate after process by Calculate method.
Public Property | AdjustRate | Gets or sets the adjust rate of this coupon.
Public Property | Code | Gets or sets this coupon's code.
Public Property | Comment | Gets or sets a comment for this coupon.
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<Coupon, Int64>)
Public Property | CustomerGroup | Sets or gets a customer group. If it is set, the coupon only applies to that group.
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<Coupon, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<Coupon, Int64>)
Public Property | EndDate | Gets or sets the end date of this coupon.
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<Coupon, Int64>)
Public Property | Exempt | Determines whether the coupon should apply to the Items or not.
Public Property | ID | Overridden. The auto number ID populated from the database.
Public Property | Items | A collection of Item included or excluded for this coupon.
Public Property | Name | Gets or sets this coupon's name.
Public Property | Quota | The number of available coupons. If not set or set to -1, an unlimited number maybe redeemed.
Public Property | QuotaCustomer | Gets or sets the number times this coupon can be used by a T:customer.
Public Property | StartDate | Gets or sets the start date of this coupon.
Public Property | Type | Gets or sets the coupon type.
Top

Public Methods

 | Name | Description
Public Method | AddItems |
Public Method | Clear | Overridden. Initializes all the properties without recreating the object.
Public Method | Clone | Creates a copy of the current Coupon
Public Method | DecQuotaDB | Decrements the coupon quota by 1 and save it to Coupons table.
Public Method | DeleteDB | Overloaded. Overridden. Deletes this coupon and all the associated items from CouponItems table.
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<Coupon, Int64>)
Public Method | LoadDB | Overloaded. Overridden.
Public Method | SaveDB | Overloaded. Overridden. Inserts or updates this object into the Coupons table.
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<Coupon, Int64>)
Public Method | UpdateGiftBalanceDB |
Top

See Also

Reference

Coupon Class
dotnetCART Namespace


%%PageItemTitle%%

Coupon Constructor
[image]
dotnetCART Namespace > Coupon Class : Coupon Constructor

Initializes a new instance of the Coupon class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Coupon()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupon Class
Coupon Members


%%PageItemTitle%% $$Methods$$

Coupon Class Methods
[image]
dotnetCART Namespace : Coupon Class

For a list of all members of this type, see Coupon members.

Public Methods

 | Name | Description
Public Method | AddItems |
Public Method | Clear | Overridden. Initializes all the properties without recreating the object.
Public Method | Clone | Creates a copy of the current Coupon
Public Method | DecQuotaDB | Decrements the coupon quota by 1 and save it to Coupons table.
Public Method | DeleteDB | Overloaded. Overridden. Deletes this coupon and all the associated items from CouponItems table.
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<Coupon, Int64>)
Public Method | LoadDB | Overloaded. Overridden.
Public Method | SaveDB | Overloaded. Overridden. Inserts or updates this object into the Coupons table.
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<Coupon, Int64>)
Public Method | UpdateGiftBalanceDB |
Top

See Also

Reference

Coupon Class
dotnetCART Namespace


%%PageItemTitle%%

AddItems Method
[image]
dotnetCART Namespace > Coupon Class : AddItems Method

item

Syntax

Visual Basic (Declaration)
Public Sub AddItems( _
   ByVal item As Object _
)
C#
public void AddItems(
   object item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupon Class
Coupon Members


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > Coupon Class : Clear Method

Initializes all the properties without recreating the object.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Clear()
C#
public override void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupon Class
Coupon Members


%%PageItemTitle%%

Clone Method
[image]
dotnetCART Namespace > Coupon Class : Clone Method

Creates a copy of the current Coupon

Syntax

Visual Basic (Declaration)
Public Function Clone() As Coupon
C#
public Coupon Clone()

Return Value

Returns a Coupon object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupon Class
Coupon Members


%%PageItemTitle%%

DecQuotaDB Method
[image]
dotnetCART Namespace > Coupon Class : DecQuotaDB Method

code
The code of the coupon.
Decrements the coupon quota by 1 and save it to Coupons table.

Syntax

Visual Basic (Declaration)
Public Function DecQuotaDB( _
   ByVal code As String _
) As Boolean
C#
public bool DecQuotaDB(
   string code
)

Parameters

code
The code of the coupon.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupon Class
Coupon Members


%%PageItemTitle%%

DeleteDB Method
[image]
dotnetCART Namespace > Coupon Class : DeleteDB Method

Deletes this coupon and all the associated items from CouponItems table.

Overload List

Overload | Description
DeleteDB() | Deletes this coupon and all the associated items from CouponItems table.
DeleteDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupon Class
Coupon Members


%%PageItemTitle%%

DeleteDB() Method
[image]
dotnetCART Namespace > Coupon Class > DeleteDB Method : DeleteDB() Method

Deletes this coupon and all the associated items from CouponItems table.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function DeleteDB() As Integer
C#
public override int DeleteDB()

Return Value

In case of error -1, check Error property, otherwise the number of records deleted.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupon Class
Coupon Members
Overload List


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > Coupon Class : LoadDB Method

Overload List

Overload | Description
LoadDB() |
LoadDB(Int64) |
LoadDB(String) |
Generic LoadDB() | (Inherited from dotnetDATA.DbTable<Int64>)
Generic LoadDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupon Class
Coupon Members


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > Coupon Class > LoadDB Method : LoadDB() Method

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function LoadDB() As Integer
C#
public override int LoadDB()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupon Class
Coupon Members
Overload List


%%PageItemTitle%%

LoadDB(Int64) Method
[image]
dotnetCART Namespace > Coupon Class > LoadDB Method : LoadDB(Int64) Method

id

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function LoadDB( _
   ByVal id As Long _
) As Integer
C#
public override int LoadDB(
   long id
)

Parameters

id

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupon Class
Coupon Members
Overload List


%%PageItemTitle%%

LoadDB(String) Method
[image]
dotnetCART Namespace > Coupon Class > LoadDB Method : LoadDB(String) Method

code

Syntax

Visual Basic (Declaration)
Public Overloads Function LoadDB( _
   ByVal code As String _
) As Integer
C#
public int LoadDB(
   string code
)

Parameters

code

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupon Class
Coupon Members
Overload List


%%PageItemTitle%%

SaveDB Method
[image]
dotnetCART Namespace > Coupon Class : SaveDB Method

Inserts or updates this object into the Coupons table.

Overload List

Overload | Description
SaveDB() | Inserts or updates this object into the Coupons table.
SaveDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupon Class
Coupon Members


%%PageItemTitle%%

SaveDB() Method
[image]
dotnetCART Namespace > Coupon Class > SaveDB Method : SaveDB() Method

Inserts or updates this object into the Coupons table.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function SaveDB() As Integer
C#
public override int SaveDB()

Return Value

Returns the generated ID or 1 for the update, returns -1 if failed. For the reason of fail, check the Error property.

Remarks

If ID greater than 0, it updates the associated coupon in the table, otherwise inserts a new coupon.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupon Class
Coupon Members
Overload List


%%PageItemTitle%%

UpdateGiftBalanceDB Method
[image]
dotnetCART Namespace > Coupon Class : UpdateGiftBalanceDB Method

giftCode
balance

Syntax

Visual Basic (Declaration)
Public Function UpdateGiftBalanceDB( _
   ByVal giftCode As String, _
   ByVal balance As Double _
) As Boolean
C#
public bool UpdateGiftBalanceDB(
   string giftCode,
   double balance
)

Parameters

giftCode
balance

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupon Class
Coupon Members


%%PageItemTitle%% $$Properties$$

Coupon Class Properties
[image]
dotnetCART Namespace : Coupon Class

For a list of all members of this type, see Coupon members.

Public Properties

 | Name | Description
Public Property | Adjust | Gets the result of AdjustRate after process by Calculate method.
Public Property | AdjustRate | Gets or sets the adjust rate of this coupon.
Public Property | Code | Gets or sets this coupon's code.
Public Property | Comment | Gets or sets a comment for this coupon.
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<Coupon, Int64>)
Public Property | CustomerGroup | Sets or gets a customer group. If it is set, the coupon only applies to that group.
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<Coupon, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<Coupon, Int64>)
Public Property | EndDate | Gets or sets the end date of this coupon.
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<Coupon, Int64>)
Public Property | Exempt | Determines whether the coupon should apply to the Items or not.
Public Property | ID | Overridden. The auto number ID populated from the database.
Public Property | Items | A collection of Item included or excluded for this coupon.
Public Property | Name | Gets or sets this coupon's name.
Public Property | Quota | The number of available coupons. If not set or set to -1, an unlimited number maybe redeemed.
Public Property | QuotaCustomer | Gets or sets the number times this coupon can be used by a T:customer.
Public Property | StartDate | Gets or sets the start date of this coupon.
Public Property | Type | Gets or sets the coupon type.
Top

See Also

Reference

Coupon Class
dotnetCART Namespace


%%PageItemTitle%%

Adjust Property
[image]
dotnetCART Namespace > Coupon Class : Adjust Property

Gets the result of AdjustRate after process by Calculate method.

Syntax

Visual Basic (Declaration)
Public Property Adjust As Decimal
C#
public decimal Adjust {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupon Class
Coupon Members


%%PageItemTitle%%

AdjustRate Property
See Also Example
[image]
dotnetCART Namespace > Coupon Class : AdjustRate Property

Gets or sets the adjust rate of this coupon.

Syntax

Visual Basic (Declaration)
Public Property AdjustRate As String
C#
public string AdjustRate {get; set;}

Example

The follwoing code set adjust rate formula for a coupon.
C# Copy Code
cartObject.Coupon.AdjustRate = "$1-100=-10%;$101-200=-20%;$201-=-30%;";//different discounts based on the purchase value.
cartObject.Coupon.AdjustRate = "1-10=-10%;11-=-20%;"; //10% discount for 1 to 10 items, %20 discount for 20 or more items
cartObject.Coupon.AdjustRate = "5-10=10;11-=-20;"; //$10 discount for 5 to 10 items, $20 discount for 20 or more items
cartObject.Coupon.AdjustRate = "100-=-10%;"; //10% discount with any purchase of $100 or more
cartObject.Coupon.AdjustRate = "100-=-10;"; //$10 discount with any purchase of $100 or more

Visual Basic Copy Code
cartObject.Coupon.AdjustRate = "$1-100=-10%;$101-200=-20%;$201-=-30%;" 'different discounts based on the purchase value.
cartObject.Coupon.AdjustRate = "1-10=-10%;11-=-20%;" '10% discount for 1 to 10 items, %20 discount for 20 or more items
cartObject.Coupon.AdjustRate = "5-10=10;11-=-20;" '$10 discount for 5 to 10 items, $20 discount for 20 or more items
cartObject.Coupon.AdjustRate = "100-=-10%;" '10% discount with any purchase of $100 or more
cartObject.Coupon.AdjustRate = "100-=-10;" '$10 discount with any purchase of $100 or more

Remarks

It can be set as a dollar amount or percentage based on dollar or quantity ranges.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupon Class
Coupon Members


%%PageItemTitle%%

Code Property
[image]
dotnetCART Namespace > Coupon Class : Code Property

Gets or sets this coupon's code.

Syntax

Visual Basic (Declaration)
Public Property Code As String
C#
public string Code {get; set;}

Remarks

This is the value usually the site visitor must enter to redeem the coupon.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupon Class
Coupon Members


%%PageItemTitle%%

Comment Property
[image]
dotnetCART Namespace > Coupon Class : Comment Property

Gets or sets a comment for this coupon.

Syntax

Visual Basic (Declaration)
Public Property Comment As String
C#
public string Comment {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupon Class
Coupon Members


%%PageItemTitle%%

CustomerGroup Property
[image]
dotnetCART Namespace > Coupon Class : CustomerGroup Property

Sets or gets a customer group. If it is set, the coupon only applies to that group.

Syntax

Visual Basic (Declaration)
Public Property CustomerGroup As String
C#
public string CustomerGroup {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupon Class
Coupon Members


%%PageItemTitle%%

EndDate Property
[image]
dotnetCART Namespace > Coupon Class : EndDate Property

Gets or sets the end date of this coupon.

Syntax

Visual Basic (Declaration)
Public Property EndDate As Date
C#
public DateTime EndDate {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupon Class
Coupon Members


%%PageItemTitle%%

Exempt Property
[image]
dotnetCART Namespace > Coupon Class : Exempt Property

Determines whether the coupon should apply to the Items or not.

Syntax

Visual Basic (Declaration)
Public Property Exempt As Boolean
C#
public bool Exempt {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupon Class
Coupon Members


%%PageItemTitle%%

ID Property
[image]
dotnetCART Namespace > Coupon Class : ID Property

The auto number ID populated from the database.

Syntax

Visual Basic (Declaration)
Public Overrides Property ID As Long
C#
public override long ID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupon Class
Coupon Members


%%PageItemTitle%%

Items Property
[image]
dotnetCART Namespace > Coupon Class : Items Property

A collection of Item included or excluded for this coupon.

Syntax

Visual Basic (Declaration)
Public Property Items As Items
C#
public Items Items {get; set;}

Remarks

This property is works with Exempt property. If Exempt property is true, the coupon applies to all the items except the items in this collection. If Exempt property is false, the coupon applies only to the items in this collection.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupon Class
Coupon Members


%%PageItemTitle%%

Name Property
[image]
dotnetCART Namespace > Coupon Class : Name Property

Gets or sets this coupon's name.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupon Class
Coupon Members


%%PageItemTitle%%

Quota Property
[image]
dotnetCART Namespace > Coupon Class : Quota Property

The number of available coupons. If not set or set to -1, an unlimited number maybe redeemed.

Syntax

Visual Basic (Declaration)
Public Property Quota As Integer
C#
public int Quota {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupon Class
Coupon Members


%%PageItemTitle%%

QuotaCustomer Property
[image]
dotnetCART Namespace > Coupon Class : QuotaCustomer Property

Gets or sets the number times this coupon can be used by a T:customer.

Syntax

Visual Basic (Declaration)
Public Property QuotaCustomer As Integer
C#
public int QuotaCustomer {get; set;}

Remarks

If QuotaCustomer is not used set it to -1 (the default).

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupon Class
Coupon Members


%%PageItemTitle%%

StartDate Property
[image]
dotnetCART Namespace > Coupon Class : StartDate Property

Gets or sets the start date of this coupon.

Syntax

Visual Basic (Declaration)
Public Property StartDate As Date
C#
public DateTime StartDate {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupon Class
Coupon Members


%%PageItemTitle%%

Type Property
[image]
dotnetCART Namespace > Coupon Class : Type Property

Gets or sets the coupon type.

Syntax

Visual Basic (Declaration)
Public Property Type As CouponType
C#
public CouponType Type {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupon Class
Coupon Members


%%PageItemTitle%%

Coupons Class
See Also Members
[image]
dotnetCART Namespace : Coupons Class

A collection of Coupon objects.

Object Model

Syntax

Visual Basic (Declaration)
Public Class Coupons
   Inherits ListBase(Of Coupon)
C#
public class Coupons : ListBase<Coupon>

Inheritance Hierarchy

System.Object
System.Collections.Generic.List<Coupon>
dotnetCART.ListBase<Coupon>
dotnetCART.Coupons

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupons Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

Coupons Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : Coupons Class

The following tables list the members exposed by Coupons.

Public Constructors

 | Name | Description
Public Constructor | Coupons Constructor | Initializes a new instance of the Coupons.
Top

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from dotnetCART.ListBase<Coupon>)
Public Property | Count | Gets the number of elements actually contained in the collection. (Inherited from dotnetCART.ListBase<Coupon>)
Public Property | Error | Returns an object with the error information. (Inherited from dotnetCART.ListBase<Coupon>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from dotnetCART.ListBase<Coupon>)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Add the new coupon object to this collection.
Public Method | AddRange | Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetCART.ListBase<Coupon>)
Public Method | AsReadOnly | Returns a read-only IList wrapper for the current collection. (Inherited from dotnetCART.ListBase<Coupon>)
Public Method | BinarySearch | Overloaded. (Inherited from dotnetCART.ListBase<Coupon>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetCART.ListBase<Coupon>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetCART.ListBase<Coupon>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<Coupon>)
Public Method | CopyTo | Overloaded. (Inherited from dotnetCART.ListBase<Coupon>)
Public Method | GetCountDB | Overloaded. Gets the total number of items in the Coupons table.
Public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from dotnetCART.ListBase<Coupon>)
Public Method | IndexOf | Overloaded. (Inherited from dotnetCART.ListBase<Coupon>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetCART.ListBase<Coupon>)
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from dotnetCART.ListBase<Coupon>)
Public Method | LastIndexOf | Overloaded. (Inherited from dotnetCART.ListBase<Coupon>)
Public Method | LoadDB | Overloaded. Overridden. Loads all the items based on the parameters from Coupons table.
Public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from dotnetCART.ListBase<Coupon>)
Public Method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from dotnetCART.ListBase<Coupon>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetCART.ListBase<Coupon>)
Public Method | RemoveRange | Removes a range of elements from the List. (Inherited from dotnetCART.ListBase<Coupon>)
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<Coupon>)
Top

See Also

Reference

Coupons Class
dotnetCART Namespace


%%PageItemTitle%%

Coupons Constructor
[image]
dotnetCART Namespace > Coupons Class : Coupons Constructor

Initializes a new instance of the Coupons.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Coupons()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupons Class
Coupons Members


%%PageItemTitle%% $$Methods$$

Coupons Class Methods
[image]
dotnetCART Namespace : Coupons Class

For a list of all members of this type, see Coupons members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Add the new coupon object to this collection.
Public Method | AddRange | Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetCART.ListBase<Coupon>)
Public Method | AsReadOnly | Returns a read-only IList wrapper for the current collection. (Inherited from dotnetCART.ListBase<Coupon>)
Public Method | BinarySearch | Overloaded. (Inherited from dotnetCART.ListBase<Coupon>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetCART.ListBase<Coupon>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetCART.ListBase<Coupon>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<Coupon>)
Public Method | CopyTo | Overloaded. (Inherited from dotnetCART.ListBase<Coupon>)
Public Method | GetCountDB | Overloaded. Gets the total number of items in the Coupons table.
Public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from dotnetCART.ListBase<Coupon>)
Public Method | IndexOf | Overloaded. (Inherited from dotnetCART.ListBase<Coupon>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetCART.ListBase<Coupon>)
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from dotnetCART.ListBase<Coupon>)
Public Method | LastIndexOf | Overloaded. (Inherited from dotnetCART.ListBase<Coupon>)
Public Method | LoadDB | Overloaded. Overridden. Loads all the items based on the parameters from Coupons table.
Public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from dotnetCART.ListBase<Coupon>)
Public Method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from dotnetCART.ListBase<Coupon>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetCART.ListBase<Coupon>)
Public Method | RemoveRange | Removes a range of elements from the List. (Inherited from dotnetCART.ListBase<Coupon>)
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<Coupon>)
Top

See Also

Reference

Coupons Class
dotnetCART Namespace


%%PageItemTitle%%

Add Method
[image]
dotnetCART Namespace > Coupons Class : Add Method

Add the new coupon object to this collection.

Overload List

Overload | Description
Add(Coupon) | Add the new coupon object to this collection.
Add() | Add Coupon object to this collection. This method should be called through Coupons

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupons Class
Coupons Members


%%PageItemTitle%%

Add(Coupon) Method
[image]
dotnetCART Namespace > Coupons Class > Add Method : Add(Coupon) Method

newCoupon
New coupon object.
Add the new coupon object to this collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add( _
   ByVal newCoupon As Coupon _
)
C#
public void Add(
   Coupon newCoupon
)

Parameters

newCoupon
New coupon object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupons Class
Coupons Members
Overload List


%%PageItemTitle%%

Add() Method
[image]
dotnetCART Namespace > Coupons Class > Add Method : Add() Method

Add Coupon object to this collection. This method should be called through Coupons

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add()
C#
public void Add()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupons Class
Coupons Members
Overload List


%%PageItemTitle%%

GetCountDB Method
[image]
dotnetCART Namespace > Coupons Class : GetCountDB Method

Gets the total number of items in the Coupons table.

Overload List

Overload | Description
GetCountDB() | Gets the total number of items in the Coupons table.
GetCountDB(Where) | Gets the total number of items in the Coupons table.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupons Class
Coupons Members


%%PageItemTitle%%

GetCountDB() Method
[image]
dotnetCART Namespace > Coupons Class > GetCountDB Method : GetCountDB() Method

Gets the total number of items in the Coupons table.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCountDB() As Integer
C#
public int GetCountDB()

Return Value

Returns the number of elements in the Coupons table.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupons Class
Coupons Members
Overload List


%%PageItemTitle%%

GetCountDB(Where) Method
[image]
dotnetCART Namespace > Coupons Class > GetCountDB Method : GetCountDB(Where) Method

whereClause
The where clause to filter the items.
Gets the total number of items in the Coupons table.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCountDB( _
   ByVal whereClause As Where _
) As Integer
C#
public int GetCountDB(
   Where whereClause
)

Parameters

whereClause
The where clause to filter the items.

Return Value

Returns the number of elements in the Coupons table.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupons Class
Coupons Members
Overload List


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > Coupons Class : LoadDB Method

Loads all the items based on the parameters from Coupons table.

Overload List

Overload | Description
LoadDB(Where,Int32,Int32,String,OrderDirection) | Loads all the items based on the parameters from Coupons table.
LoadDB() | Loads all the items from its associated table. (Inherited from dotnetCART.ListBase<Coupon>)
LoadDB(Where) | Loads all the items from its associated table based on the where clause. (Inherited from dotnetCART.ListBase<Coupon>)
LoadDB(Int32,Int32) | Loads the count number of elements from start value. (Inherited from dotnetCART.ListBase<Coupon>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupons Class
Coupons Members


%%PageItemTitle%%

LoadDB(Where,Int32,Int32,String,OrderDirection) Method
[image]
dotnetCART Namespace > Coupons Class > LoadDB Method : LoadDB(Where,Int32,Int32,String,OrderDirection) Method

whereClause
The where clause to filter the items.
start
The start page which starts from 0.
count
The number of items in the page.
orderBy
The order of the loaded items.
orderDirection
The order direction of the loaded items. Defaults is Asc.
Loads all the items based on the parameters from Coupons table.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function LoadDB( _
   ByVal whereClause As Where, _
   ByVal start As Integer, _
   ByVal count As Integer, _
   ByVal orderBy As String, _
   ByVal orderDirection As OrderDirection _
) As Integer
C#
public override int LoadDB(
   Where whereClause,
   int start,
   int count,
   string orderBy,
   OrderDirection orderDirection
)

Parameters

whereClause
The where clause to filter the items.
start
The start page which starts from 0.
count
The number of items in the page.
orderBy
The order of the loaded items.
orderDirection
The order direction of the loaded items. Defaults is Asc.

Return Value

The total number of items have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupons Class
Coupons Members
Overload List


%%PageItemTitle%%

Custom Class
See Also Members
[image]
dotnetCART Namespace : Custom Class

Defines a custom property for different objects.

Syntax

Visual Basic (Declaration)
Public Class Custom
C#
public class Custom

Remarks

Custom fields used to store name/value pairs for any type of custom data. There is no limit to the number of user defined custom fields. Custom fields can be defined at various levels including order, item, option, customer, address and payment. They are automatically stored and handled by .netCART and even written to the database (a field should exist in the appropriate table with a name matching the custom name). For more information see custom fields

Inheritance Hierarchy

System.Object
dotnetCART.Custom

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Custom Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

Custom Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : Custom Class

The following tables list the members exposed by Custom.

Public Constructors

 | Name | Description
Public Constructor | Custom Constructor | Overloaded. Initializes a new instance of the Custom class.
Top

Public Properties

 | Name | Description
Public Property | Name | Gets or sets this custom's name.
Public Property | Value | Gets or sets this custom's value.
Top

Public Methods

 | Name | Description
Public Method | Clear | Initializes all the properties without recreating the object.
Public Method | Clone | Creates a copy of the current Custom
Top

See Also

Reference

Custom Class
dotnetCART Namespace


%%PageItemTitle%%

Custom Constructor
[image]
dotnetCART Namespace > Custom Class : Custom Constructor

Initializes a new instance of the Custom class.

Overload List

Overload | Description
Custom Constructor() | Initializes a new instance of the Custom class.
Custom Constructor(String,Object) |

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Custom Class
Custom Members


%%PageItemTitle%%

Custom Constructor()
See Also
[image]
dotnetCART Namespace > Custom Class > Custom Constructor : Custom Constructor()

Initializes a new instance of the Custom class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Custom()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Custom Class
Custom Members
Overload List


%%PageItemTitle%%

Custom Constructor(String,Object)
See Also
[image]
dotnetCART Namespace > Custom Class > Custom Constructor : Custom Constructor(String,Object)

customName
customValue

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal customName As String, _
   ByVal customValue As Object _
)
C#
public Custom(
   string customName,
   object customValue
)

Parameters

customName
customValue

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Custom Class
Custom Members
Overload List


%%PageItemTitle%% $$Methods$$

Custom Class Methods
[image]
dotnetCART Namespace : Custom Class

For a list of all members of this type, see Custom members.

Public Methods

 | Name | Description
Public Method | Clear | Initializes all the properties without recreating the object.
Public Method | Clone | Creates a copy of the current Custom
Top

See Also

Reference

Custom Class
dotnetCART Namespace


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > Custom Class : Clear Method

Initializes all the properties without recreating the object.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Custom Class
Custom Members


%%PageItemTitle%%

Clone Method
[image]
dotnetCART Namespace > Custom Class : Clone Method

Creates a copy of the current Custom

Syntax

Visual Basic (Declaration)
Public Function Clone() As Custom
C#
public Custom Clone()

Return Value

Returns a Custom object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Custom Class
Custom Members


%%PageItemTitle%% $$Properties$$

Custom Class Properties
[image]
dotnetCART Namespace : Custom Class

For a list of all members of this type, see Custom members.

Public Properties

 | Name | Description
Public Property | Name | Gets or sets this custom's name.
Public Property | Value | Gets or sets this custom's value.
Top

See Also

Reference

Custom Class
dotnetCART Namespace


%%PageItemTitle%%

Name Property
[image]
dotnetCART Namespace > Custom Class : Name Property

Gets or sets this custom's name.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Custom Class
Custom Members


%%PageItemTitle%%

Value Property
[image]
dotnetCART Namespace > Custom Class : Value Property

Gets or sets this custom's value.

Syntax

Visual Basic (Declaration)
Public Property Value As Object
C#
public object Value {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Custom Class
Custom Members


%%PageItemTitle%%

Customer Class
See Also Members
[image]
dotnetCART Namespace : Customer Class

Represents a Customer object.

Object Model

Syntax

Visual Basic (Declaration)
Public Class Customer
   Inherits DbTableCart(Of Customer, Long)
C#
public class Customer : DbTableCart<Customer, long>

Inheritance Hierarchy

System.Object
dotnetDATA.DbTable<Int64>
dotnetDATA.DbTable<Customer, Int64>
dotnetCART.DbTableCart<Customer, Int64>
dotnetCART.Customer

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

Customer Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : Customer Class

The following tables list the members exposed by Customer.

Public Constructors

 | Name | Description
Public Constructor | Customer Constructor | Initializes a new instance of the Customer class.
Top

Public Properties

 | Name | Description
Public Property | Addresses | A collection of all Address objects for this customer.
Public Property | Company | The company name of the customer.
Public Property | CreditLimit | The credit limit of the customer. It can be used by store administrator to ship the products before the customer's payment.
Public Property | Currency | The currency preference of the customer.
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<Customer, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<Customer, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<Customer, Int64>)
Public Property | DefaultBillAddressID | The ID of the default billing address.
Public Property | DefaultShipAddressID | The ID of the default shipping address.
Public Property | Email | The email of the customer. By default, it is used to load the customer's information form database. But you can set Store.Settings.UserNameField to the other customer's property as well.
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<Customer, Int64>)
Public Property | Fax | The customers fax number.
Public Property | FirstName | The first name of the customer.
Public Property | Group | Customer specific pricing can be set with this property (previously this property was called Price).
Public Property | ID | Overridden. The auto number ID populated from the database.
Public Property | Language | The language preference of the customer.
Public Property | LastName | The last name of the customer.
Public Property | Password | The password of the customer's account.
Public Property | Phone | The customers phone number.
Public Property | ProfileID | The payments profile ID.
Public Property | Referrer | A Referrer object to allow saving customer's referrer information to Referrers table.
Public Property | UserName | An alternative field for loading the customer's information from database. By default, Email is used, but you can set Store.Settings.UserNameField to the other customer's property as well.
Top

Public Methods

 | Name | Description
Public Method | Clear | Overridden. Initializes all the properties without recreating the object.
Public Method | DeleteCookie | Deletes dotnetcartCustomer Cookie which is used to store the encrypted Customer.ID.
Public Method | DeleteDB | Overloaded. Overridden. Deletes this customer and all the associated addresses.
Public Method | GenerateNewPasswordDB | Generates a new password and updates the customer's record.
Public Method | GetCouponUsage | Overloaded. Returns the number of all the coupons have been used by this customer.
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<Customer, Int64>)
Public Method | IsRegistered | Determines whether a customer with this username has been already registered or not.
Public Method | LoadCookie | Loads Customer.ID from dotnetcartCustomer Cookie.
Public Method | LoadDB | Overloaded. Overridden. Loads the customer's information from database.
Public Method | SaveCookie | Overloaded. Encrypt the Customer.ID and stores in dotnetcartCustomer cookie.
Public Method | SaveDB | Overloaded. Overridden. Inserts or updates this customer into the Customers table.
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<Customer, Int64>)
Public Method | SetPasswordDB | Set the new password for this customer.
Top

See Also

Reference

Customer Class
dotnetCART Namespace


%%PageItemTitle%%

Customer Constructor
[image]
dotnetCART Namespace > Customer Class : Customer Constructor

Initializes a new instance of the Customer class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Customer()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members


%%PageItemTitle%% $$Methods$$

Customer Class Methods
[image]
dotnetCART Namespace : Customer Class

For a list of all members of this type, see Customer members.

Public Methods

 | Name | Description
Public Method | Clear | Overridden. Initializes all the properties without recreating the object.
Public Method | DeleteCookie | Deletes dotnetcartCustomer Cookie which is used to store the encrypted Customer.ID.
Public Method | DeleteDB | Overloaded. Overridden. Deletes this customer and all the associated addresses.
Public Method | GenerateNewPasswordDB | Generates a new password and updates the customer's record.
Public Method | GetCouponUsage | Overloaded. Returns the number of all the coupons have been used by this customer.
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<Customer, Int64>)
Public Method | IsRegistered | Determines whether a customer with this username has been already registered or not.
Public Method | LoadCookie | Loads Customer.ID from dotnetcartCustomer Cookie.
Public Method | LoadDB | Overloaded. Overridden. Loads the customer's information from database.
Public Method | SaveCookie | Overloaded. Encrypt the Customer.ID and stores in dotnetcartCustomer cookie.
Public Method | SaveDB | Overloaded. Overridden. Inserts or updates this customer into the Customers table.
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<Customer, Int64>)
Public Method | SetPasswordDB | Set the new password for this customer.
Top

See Also

Reference

Customer Class
dotnetCART Namespace


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > Customer Class : Clear Method

Initializes all the properties without recreating the object.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Clear()
C#
public override void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members


%%PageItemTitle%%

DeleteCookie Method
[image]
dotnetCART Namespace > Customer Class : DeleteCookie Method

Deletes dotnetcartCustomer Cookie which is used to store the encrypted Customer.ID.

Syntax

Visual Basic (Declaration)
Public Function DeleteCookie() As Boolean
C#
public bool DeleteCookie()

Return Value

Retuns true if the cookie found and deleted or the cookie doesn't exist. If there is any error, returns false. See Error for more information about the error.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members


%%PageItemTitle%%

DeleteDB Method
[image]
dotnetCART Namespace > Customer Class : DeleteDB Method

Deletes this customer and all the associated addresses.

Overload List

Overload | Description
DeleteDB() | Deletes this customer and all the associated addresses.
DeleteDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members


%%PageItemTitle%%

DeleteDB() Method
[image]
dotnetCART Namespace > Customer Class > DeleteDB Method : DeleteDB() Method

Deletes this customer and all the associated addresses.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function DeleteDB() As Integer
C#
public override int DeleteDB()

Return Value

In case of error -1, check Error property, otherwise the number of records deleted.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members
Overload List


%%PageItemTitle%%

GenerateNewPasswordDB Method
[image]
dotnetCART Namespace > Customer Class : GenerateNewPasswordDB Method

UserEmail
Customre's email.
Generates a new password and updates the customer's record.

Syntax

Visual Basic (Declaration)
Public Function GenerateNewPasswordDB( _
   ByVal UserEmail As String _
) As String
C#
public string GenerateNewPasswordDB(
   string UserEmail
)

Parameters

UserEmail
Customre's email.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members


%%PageItemTitle%%

GetCouponUsage Method
[image]
dotnetCART Namespace > Customer Class : GetCouponUsage Method

Returns the number of all the coupons have been used by this customer.

Overload List

Overload | Description
GetCouponUsage() | Returns the number of all the coupons have been used by this customer.
GetCouponUsage(Int64) | Returns the number of all the coupons have been used by the customer.
GetCouponUsage(String) | Returns the number of times the coupon has been used by this customer.
GetCouponUsage(Int64,String) | Returns the number of times the coupon has been used by the customer.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members


%%PageItemTitle%%

GetCouponUsage() Method
[image]
dotnetCART Namespace > Customer Class > GetCouponUsage Method : GetCouponUsage() Method

Returns the number of all the coupons have been used by this customer.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCouponUsage() As Integer
C#
public int GetCouponUsage()

Return Value

Number of times the coupon has been used by the customer.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members
Overload List


%%PageItemTitle%%

GetCouponUsage(Int64) Method
[image]
dotnetCART Namespace > Customer Class > GetCouponUsage Method : GetCouponUsage(Int64) Method

customerID
Returns the number of all the coupons have been used by the customer.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCouponUsage( _
   ByVal customerID As Long _
) As Integer
C#
public int GetCouponUsage(
   long customerID
)

Parameters

customerID

Return Value

Number of times the coupon has been used by the customer.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members
Overload List


%%PageItemTitle%%

GetCouponUsage(String) Method
[image]
dotnetCART Namespace > Customer Class > GetCouponUsage Method : GetCouponUsage(String) Method

couponCode
Returns the number of times the coupon has been used by this customer.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCouponUsage( _
   ByVal couponCode As String _
) As Integer
C#
public int GetCouponUsage(
   string couponCode
)

Parameters

couponCode

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members
Overload List


%%PageItemTitle%%

GetCouponUsage(Int64,String) Method
[image]
dotnetCART Namespace > Customer Class > GetCouponUsage Method : GetCouponUsage(Int64,String) Method

customerID
couponCode
Returns the number of times the coupon has been used by the customer.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCouponUsage( _
   ByVal customerID As Long, _
   ByVal couponCode As String _
) As Integer
C#
public int GetCouponUsage(
   long customerID,
   string couponCode
)

Parameters

customerID
couponCode

Return Value

Number of times the coupon has been used by the customer.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members
Overload List


%%PageItemTitle%%

IsRegistered Method
[image]
dotnetCART Namespace > Customer Class : IsRegistered Method

userName
The value of the property specified in Store.Settings.UserNameField.
Determines whether a customer with this username has been already registered or not.

Syntax

Visual Basic (Declaration)
Public Function IsRegistered( _
   ByVal userName As String _
) As Boolean
C#
public bool IsRegistered(
   string userName
)

Parameters

userName
The value of the property specified in Store.Settings.UserNameField.

Return Value

A boolean indicating whether the customer has been registered or not.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members


%%PageItemTitle%%

LoadCookie Method
[image]
dotnetCART Namespace > Customer Class : LoadCookie Method

Loads Customer.ID from dotnetcartCustomer Cookie.

Syntax

Visual Basic (Declaration)
Public Function LoadCookie() As Long
C#
public long LoadCookie()

Return Value

Returns the customer's ID, if not found returns 0.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > Customer Class : LoadDB Method

Loads the customer's information from database.

Overload List

Overload | Description
LoadDB() | Loads the customer's information from database.
LoadDB(String,String) | Loads the customer's information from database.
LoadDB(String,String,String) | Loads the customer's information from database.
LoadDB(Int64) | (Inherited from dotnetCART.DbTableCart<Customer, Int64>)
Generic LoadDB() | (Inherited from dotnetDATA.DbTable<Int64>)
Generic LoadDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > Customer Class > LoadDB Method : LoadDB() Method

Loads the customer's information from database.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function LoadDB() As Integer
C#
public override int LoadDB()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members
Overload List


%%PageItemTitle%%

LoadDB(String,String) Method
[image]
dotnetCART Namespace > Customer Class > LoadDB Method : LoadDB(String,String) Method

userName
The value of the property specified in Store.Settings.UserNameField.
password
The password of the customer.
Loads the customer's information from database.

Syntax

Visual Basic (Declaration)
Public Overloads Function LoadDB( _
   ByVal userName As String, _
   ByVal password As String _
) As String
C#
public string LoadDB(
   string userName,
   string password
)

Parameters

userName
The value of the property specified in Store.Settings.UserNameField.
password
The password of the customer.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members
Overload List


%%PageItemTitle%%

LoadDB(String,String,String) Method
[image]
dotnetCART Namespace > Customer Class > LoadDB Method : LoadDB(String,String,String) Method

userName
The value of the property specified in Store.Settings.UserNameField
password
The password of the customer.
userNameField
The customer's property for validating the username.
Loads the customer's information from database.

Syntax

Visual Basic (Declaration)
Public Overloads Function LoadDB( _
   ByVal userName As String, _
   ByVal password As String, _
   ByVal userNameField As String _
) As String
C#
public string LoadDB(
   string userName,
   string password,
   string userNameField
)

Parameters

userName
The value of the property specified in Store.Settings.UserNameField
password
The password of the customer.
userNameField
The customer's property for validating the username.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members
Overload List


%%PageItemTitle%%

SaveCookie Method
[image]
dotnetCART Namespace > Customer Class : SaveCookie Method

Encrypt the Customer.ID and stores in dotnetcartCustomer cookie.

Overload List

Overload | Description
SaveCookie() | Encrypt the Customer.ID and stores in dotnetcartCustomer cookie.
SaveCookie(Boolean) | Encrypt the Customer.ID and stores in dotnetcartCustomer cookie.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members


%%PageItemTitle%%

SaveCookie() Method
[image]
dotnetCART Namespace > Customer Class > SaveCookie Method : SaveCookie() Method

Encrypt the Customer.ID and stores in dotnetcartCustomer cookie.

Syntax

Visual Basic (Declaration)
Public Overloads Function SaveCookie() As Boolean
C#
public bool SaveCookie()

Return Value

Retuns true if the customer.ID stored in the dotnetcartCustomer cookie successfully. If there is any error, returns false. See Error for more information about the error.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members
Overload List


%%PageItemTitle%%

SaveCookie(Boolean) Method
[image]
dotnetCART Namespace > Customer Class > SaveCookie Method : SaveCookie(Boolean) Method

isPersistent
Determines whether the cookie saved across browser sessions or not.
Encrypt the Customer.ID and stores in dotnetcartCustomer cookie.

Syntax

Visual Basic (Declaration)
Public Overloads Function SaveCookie( _
   ByVal isPersistent As Boolean _
) As Boolean
C#
public bool SaveCookie(
   bool isPersistent
)

Parameters

isPersistent
Determines whether the cookie saved across browser sessions or not.

Return Value

Retuns true if the customer.ID stored in the dotnetcartCustomer cookie successfully. If there is any error, returns false. See Error for more information about the error.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members
Overload List


%%PageItemTitle%%

SaveDB Method
[image]
dotnetCART Namespace > Customer Class : SaveDB Method

Inserts or updates this customer into the Customers table.

Overload List

Overload | Description
SaveDB() | Inserts or updates this customer into the Customers table.
SaveDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members


%%PageItemTitle%%

SaveDB() Method
[image]
dotnetCART Namespace > Customer Class > SaveDB Method : SaveDB() Method

Inserts or updates this customer into the Customers table.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function SaveDB() As Integer
C#
public override int SaveDB()

Return Value

Returns the generated ID or 1 for the update, returns -1 if failed. For the reason of fail, check the Error property.

Remarks

If ID greater than 0, it updates the associated customer in the table, otherwise inserts a new customer.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members
Overload List


%%PageItemTitle%%

SetPasswordDB Method
[image]
dotnetCART Namespace > Customer Class : SetPasswordDB Method

strNewPassword
New password.
strNewPassConfirm
New password confirmation.
customerID
Customer id.
Set the new password for this customer.

Syntax

Visual Basic (Declaration)
Public Function SetPasswordDB( _
   ByVal strNewPassword As String, _
   ByVal strNewPassConfirm As String, _
   ByVal customerID As Long _
) As String
C#
public string SetPasswordDB(
   string strNewPassword,
   string strNewPassConfirm,
   long customerID
)

Parameters

strNewPassword
New password.
strNewPassConfirm
New password confirmation.
customerID
Customer id.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members


%%PageItemTitle%% $$Properties$$

Customer Class Properties
[image]
dotnetCART Namespace : Customer Class

For a list of all members of this type, see Customer members.

Public Properties

 | Name | Description
Public Property | Addresses | A collection of all Address objects for this customer.
Public Property | Company | The company name of the customer.
Public Property | CreditLimit | The credit limit of the customer. It can be used by store administrator to ship the products before the customer's payment.
Public Property | Currency | The currency preference of the customer.
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<Customer, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<Customer, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<Customer, Int64>)
Public Property | DefaultBillAddressID | The ID of the default billing address.
Public Property | DefaultShipAddressID | The ID of the default shipping address.
Public Property | Email | The email of the customer. By default, it is used to load the customer's information form database. But you can set Store.Settings.UserNameField to the other customer's property as well.
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<Customer, Int64>)
Public Property | Fax | The customers fax number.
Public Property | FirstName | The first name of the customer.
Public Property | Group | Customer specific pricing can be set with this property (previously this property was called Price).
Public Property | ID | Overridden. The auto number ID populated from the database.
Public Property | Language | The language preference of the customer.
Public Property | LastName | The last name of the customer.
Public Property | Password | The password of the customer's account.
Public Property | Phone | The customers phone number.
Public Property | ProfileID | The payments profile ID.
Public Property | Referrer | A Referrer object to allow saving customer's referrer information to Referrers table.
Public Property | UserName | An alternative field for loading the customer's information from database. By default, Email is used, but you can set Store.Settings.UserNameField to the other customer's property as well.
Top

See Also

Reference

Customer Class
dotnetCART Namespace


%%PageItemTitle%%

Addresses Property
[image]
dotnetCART Namespace > Customer Class : Addresses Property

A collection of all Address objects for this customer.

Syntax

Visual Basic (Declaration)
Public Property Addresses As Addresses
C#
public Addresses Addresses {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members


%%PageItemTitle%%

Company Property
[image]
dotnetCART Namespace > Customer Class : Company Property

The company name of the customer.

Syntax

Visual Basic (Declaration)
Public Property Company As String
C#
public string Company {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members


%%PageItemTitle%%

CreditLimit Property
[image]
dotnetCART Namespace > Customer Class : CreditLimit Property

The credit limit of the customer. It can be used by store administrator to ship the products before the customer's payment.

Syntax

Visual Basic (Declaration)
Public Property CreditLimit As Double
C#
public double CreditLimit {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members


%%PageItemTitle%%

Currency Property
[image]
dotnetCART Namespace > Customer Class : Currency Property

The currency preference of the customer.

Syntax

Visual Basic (Declaration)
Public Property Currency As String
C#
public string Currency {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members


%%PageItemTitle%%

DefaultBillAddressID Property
[image]
dotnetCART Namespace > Customer Class : DefaultBillAddressID Property

The ID of the default billing address.

Syntax

Visual Basic (Declaration)
Public Property DefaultBillAddressID As Long
C#
public long DefaultBillAddressID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members


%%PageItemTitle%%

DefaultShipAddressID Property
[image]
dotnetCART Namespace > Customer Class : DefaultShipAddressID Property

The ID of the default shipping address.

Syntax

Visual Basic (Declaration)
Public Property DefaultShipAddressID As Long
C#
public long DefaultShipAddressID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members


%%PageItemTitle%%

Email Property
[image]
dotnetCART Namespace > Customer Class : Email Property

The email of the customer. By default, it is used to load the customer's information form database. But you can set Store.Settings.UserNameField to the other customer's property as well.

Syntax

Visual Basic (Declaration)
Public Property Email As String
C#
public string Email {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members


%%PageItemTitle%%

Fax Property
[image]
dotnetCART Namespace > Customer Class : Fax Property

The customers fax number.

Syntax

Visual Basic (Declaration)
Public Property Fax As String
C#
public string Fax {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members


%%PageItemTitle%%

FirstName Property
[image]
dotnetCART Namespace > Customer Class : FirstName Property

The first name of the customer.

Syntax

Visual Basic (Declaration)
Public Property FirstName As String
C#
public string FirstName {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members


%%PageItemTitle%%

Group Property
[image]
dotnetCART Namespace > Customer Class : Group Property

Customer specific pricing can be set with this property (previously this property was called Price).

Syntax

Visual Basic (Declaration)
Public Property Group As String
C#
public string Group {get; set;}

Remarks

This will affect the catalog display pricing shown to the user along with the pricing added to the customers cart. Since you can define any number of fields, you can create pricing groups, or even individual pricing per customer. If your special pricing does not vary on a per item basis you can instead use the cart level AdjustRate property to give a percentage discount for specific customers. More information

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members


%%PageItemTitle%%

ID Property
[image]
dotnetCART Namespace > Customer Class : ID Property

The auto number ID populated from the database.

Syntax

Visual Basic (Declaration)
Public Overrides Property ID As Long
C#
public override long ID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members


%%PageItemTitle%%

Language Property
[image]
dotnetCART Namespace > Customer Class : Language Property

The language preference of the customer.

Syntax

Visual Basic (Declaration)
Public Property Language As String
C#
public string Language {get; set;}

Remarks

For loading different values from the database based on cart.Customer.Language, create the following fields in the table with language suffix: e.g. Name becomes Name_fr for french.
Items table: Name, Description, DescriptionShort fields
Options table: Label field
OptionChoices table: Name field

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members


%%PageItemTitle%%

LastName Property
[image]
dotnetCART Namespace > Customer Class : LastName Property

The last name of the customer.

Syntax

Visual Basic (Declaration)
Public Property LastName As String
C#
public string LastName {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members


%%PageItemTitle%%

Password Property
[image]
dotnetCART Namespace > Customer Class : Password Property

The password of the customer's account.

Syntax

Visual Basic (Declaration)
Public Property Password As String
C#
public string Password {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members


%%PageItemTitle%%

Phone Property
[image]
dotnetCART Namespace > Customer Class : Phone Property

The customers phone number.

Syntax

Visual Basic (Declaration)
Public Property Phone As String
C#
public string Phone {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members


%%PageItemTitle%%

ProfileID Property
[image]
dotnetCART Namespace > Customer Class : ProfileID Property

The payments profile ID.

Syntax

Visual Basic (Declaration)
Public Property ProfileID As String
C#
public string ProfileID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members


%%PageItemTitle%%

Referrer Property
[image]
dotnetCART Namespace > Customer Class : Referrer Property

A Referrer object to allow saving customer's referrer information to Referrers table.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Referrer As Referrer
C#
public Referrer Referrer {get;}

Remarks

SaveDB parse out the domain, the advertise querystring keyword and save it to Referrers table with the full referreral URL.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members


%%PageItemTitle%%

UserName Property
[image]
dotnetCART Namespace > Customer Class : UserName Property

An alternative field for loading the customer's information from database. By default, Email is used, but you can set Store.Settings.UserNameField to the other customer's property as well.

Syntax

Visual Basic (Declaration)
Public Property UserName As String
C#
public string UserName {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members


%%PageItemTitle%%

Customers Class
See Also Members
[image]
dotnetCART Namespace : Customers Class

A collection of Customer objects.

Object Model

Syntax

Visual Basic (Declaration)
Public Class Customers
   Inherits ListBase(Of Customer)
C#
public class Customers : ListBase<Customer>

Inheritance Hierarchy

System.Object
System.Collections.Generic.List<Customer>
dotnetCART.ListBase<Customer>
dotnetCART.Customers

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customers Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

Customers Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : Customers Class

The following tables list the members exposed by Customers.

Public Constructors

 | Name | Description
Public Constructor | Customers Constructor | Initializes a new instance of the Customers.
Top

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from dotnetCART.ListBase<Customer>)
Public Property | Count | Gets the number of elements actually contained in the collection. (Inherited from dotnetCART.ListBase<Customer>)
Public Property | Error | Returns an object with the error information. (Inherited from dotnetCART.ListBase<Customer>)
Public Property | Item | Overloaded. Gets the customer with the specified name.
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Add Customer object to this collection. This method should be called through Customers
Public Method | AddRange | Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetCART.ListBase<Customer>)
Public Method | AsReadOnly | Returns a read-only IList wrapper for the current collection. (Inherited from dotnetCART.ListBase<Customer>)
Public Method | BinarySearch | Overloaded. (Inherited from dotnetCART.ListBase<Customer>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetCART.ListBase<Customer>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetCART.ListBase<Customer>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<Customer>)
Public Method | CopyTo | Overloaded. (Inherited from dotnetCART.ListBase<Customer>)
Public Method | GetCountDB | Overloaded. Gets the total number of items in the Customers table.
Public Method | GetCustomer | Gets the customer with the specified name.
Public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from dotnetCART.ListBase<Customer>)
Public Method | IndexOf | Overloaded. (Inherited from dotnetCART.ListBase<Customer>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetCART.ListBase<Customer>)
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from dotnetCART.ListBase<Customer>)
Public Method | LastIndexOf | Overloaded. (Inherited from dotnetCART.ListBase<Customer>)
Public Method | LoadDB | Overloaded. Overridden. Loads all the items based on the parameters from Customers table.
Public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from dotnetCART.ListBase<Customer>)
Public Method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from dotnetCART.ListBase<Customer>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetCART.ListBase<Customer>)
Public Method | RemoveRange | Removes a range of elements from the List. (Inherited from dotnetCART.ListBase<Customer>)
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<Customer>)
Top

See Also

Reference

Customers Class
dotnetCART Namespace


%%PageItemTitle%%

Customers Constructor
[image]
dotnetCART Namespace > Customers Class : Customers Constructor

Initializes a new instance of the Customers.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Customers()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customers Class
Customers Members


%%PageItemTitle%% $$Methods$$

Customers Class Methods
[image]
dotnetCART Namespace : Customers Class

For a list of all members of this type, see Customers members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Add Customer object to this collection. This method should be called through Customers
Public Method | AddRange | Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetCART.ListBase<Customer>)
Public Method | AsReadOnly | Returns a read-only IList wrapper for the current collection. (Inherited from dotnetCART.ListBase<Customer>)
Public Method | BinarySearch | Overloaded. (Inherited from dotnetCART.ListBase<Customer>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetCART.ListBase<Customer>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetCART.ListBase<Customer>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<Customer>)
Public Method | CopyTo | Overloaded. (Inherited from dotnetCART.ListBase<Customer>)
Public Method | GetCountDB | Overloaded. Gets the total number of items in the Customers table.
Public Method | GetCustomer | Gets the customer with the specified name.
Public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from dotnetCART.ListBase<Customer>)
Public Method | IndexOf | Overloaded. (Inherited from dotnetCART.ListBase<Customer>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetCART.ListBase<Customer>)
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from dotnetCART.ListBase<Customer>)
Public Method | LastIndexOf | Overloaded. (Inherited from dotnetCART.ListBase<Customer>)
Public Method | LoadDB | Overloaded. Overridden. Loads all the items based on the parameters from Customers table.
Public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from dotnetCART.ListBase<Customer>)
Public Method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from dotnetCART.ListBase<Customer>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetCART.ListBase<Customer>)
Public Method | RemoveRange | Removes a range of elements from the List. (Inherited from dotnetCART.ListBase<Customer>)
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<Customer>)
Top

See Also

Reference

Customers Class
dotnetCART Namespace


%%PageItemTitle%%

Add Method
[image]
dotnetCART Namespace > Customers Class : Add Method

Add Customer object to this collection. This method should be called through Customers

Overload List

Overload | Description
Add() | Add Customer object to this collection. This method should be called through Customers
Add(Customer) | (Inherited from dotnetCART.ListBase<Customer>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customers Class
Customers Members


%%PageItemTitle%%

Add() Method
[image]
dotnetCART Namespace > Customers Class > Add Method : Add() Method

Add Customer object to this collection. This method should be called through Customers

Syntax

Visual Basic (Declaration)
Public Overloads Function Add() As Integer
C#
public int Add()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customers Class
Customers Members
Overload List


%%PageItemTitle%%

GetCountDB Method
[image]
dotnetCART Namespace > Customers Class : GetCountDB Method

Gets the total number of items in the Customers table.

Overload List

Overload | Description
GetCountDB() | Gets the total number of items in the Customers table.
GetCountDB(Where) | Gets the total number of items in the Customers table.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customers Class
Customers Members


%%PageItemTitle%%

GetCountDB() Method
[image]
dotnetCART Namespace > Customers Class > GetCountDB Method : GetCountDB() Method

Gets the total number of items in the Customers table.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCountDB() As Integer
C#
public int GetCountDB()

Return Value

Returns the number of elements in the Customers table.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customers Class
Customers Members
Overload List


%%PageItemTitle%%

GetCountDB(Where) Method
[image]
dotnetCART Namespace > Customers Class > GetCountDB Method : GetCountDB(Where) Method

whereClause
The where clause to filter the items.
Gets the total number of items in the Customers table.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCountDB( _
   ByVal whereClause As Where _
) As Integer
C#
public int GetCountDB(
   Where whereClause
)

Parameters

whereClause
The where clause to filter the items.

Return Value

Returns the number of elements in the Customers table.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customers Class
Customers Members
Overload List


%%PageItemTitle%%

GetCustomer Method
[image]
dotnetCART Namespace > Customers Class : GetCustomer Method

name
The name of the customer.
Gets the customer with the specified name.

Syntax

Visual Basic (Declaration)
Public Function GetCustomer( _
   ByVal name As String _
) As Customer
C#
public Customer GetCustomer(
   string name
)

Parameters

name
The name of the customer.

Return Value

Returns the supplier with the customer name.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customers Class
Customers Members


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > Customers Class : LoadDB Method

Loads all the items based on the parameters from Customers table.

Overload List

Overload | Description
LoadDB(Where,Int32,Int32,String,OrderDirection) | Loads all the items based on the parameters from Customers table.
LoadDB() | Loads all the items from its associated table. (Inherited from dotnetCART.ListBase<Customer>)
LoadDB(Where) | Loads all the items from its associated table based on the where clause. (Inherited from dotnetCART.ListBase<Customer>)
LoadDB(Int32,Int32) | Loads the count number of elements from start value. (Inherited from dotnetCART.ListBase<Customer>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customers Class
Customers Members


%%PageItemTitle%%

LoadDB(Where,Int32,Int32,String,OrderDirection) Method
[image]
dotnetCART Namespace > Customers Class > LoadDB Method : LoadDB(Where,Int32,Int32,String,OrderDirection) Method

whereClause
The where clause to filter the items.
start
The start page which starts from 0.
count
The number of items in the page.
orderBy
The order of the loaded items.
orderDirection
The order direction of the loaded items. Defaults is Asc.
Loads all the items based on the parameters from Customers table.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function LoadDB( _
   ByVal whereClause As Where, _
   ByVal start As Integer, _
   ByVal count As Integer, _
   ByVal orderBy As String, _
   ByVal orderDirection As OrderDirection _
) As Integer
C#
public override int LoadDB(
   Where whereClause,
   int start,
   int count,
   string orderBy,
   OrderDirection orderDirection
)

Parameters

whereClause
The where clause to filter the items.
start
The start page which starts from 0.
count
The number of items in the page.
orderBy
The order of the loaded items.
orderDirection
The order direction of the loaded items. Defaults is Asc.

Return Value

The total number of items have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customers Class
Customers Members
Overload List


%%PageItemTitle%% $$Properties$$

Customers Class Properties
[image]
dotnetCART Namespace : Customers Class

For a list of all members of this type, see Customers members.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from dotnetCART.ListBase<Customer>)
Public Property | Count | Gets the number of elements actually contained in the collection. (Inherited from dotnetCART.ListBase<Customer>)
Public Property | Error | Returns an object with the error information. (Inherited from dotnetCART.ListBase<Customer>)
Public Property | Item | Overloaded. Gets the customer with the specified name.
Top

See Also

Reference

Customers Class
dotnetCART Namespace


%%PageItemTitle%%

Item Property
[image]
dotnetCART Namespace > Customers Class : Item Property

Gets the customer with the specified name.

Overload List

Overload | Description
Item(String) | Gets the customer with the specified name.
Item(Int32) | Gets or sets the element at the specified index. (Inherited from dotnetCART.ListBase<Customer>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customers Class
Customers Members


%%PageItemTitle%%

Item(String) Property
[image]
dotnetCART Namespace > Customers Class > Item Property : Item(String) Property

name
The name of the customer.
Gets the customer with the specified name.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal name As String _
) As Customer
C#
public Customer Item(
   string name
) {get;}

Parameters

name
The name of the customer.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customers Class
Customers Members
Overload List


%%PageItemTitle%%

CustomFields Class
See Also Members
[image]
dotnetCART Namespace : CustomFields Class

Defines custom fields for different tables. For more information see custom fields

Syntax

Visual Basic (Declaration)
Public Class CustomFields
C#
public class CustomFields

Inheritance Hierarchy

System.Object
dotnetCART.CustomFields

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CustomFields Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

CustomFields Class Members
See Also Methods
[image]
dotnetCART Namespace : CustomFields Class

The following tables list the members exposed by CustomFields.

Public Constructors

 | Name | Description
Public Constructor | CustomFields Constructor |
Top

Public Methods

 | Name | Description
Public Method | Add | Adds the names of custom fields for a table.
Top

See Also

Reference

CustomFields Class
dotnetCART Namespace


%%PageItemTitle%%

CustomFields Constructor
[image]
dotnetCART Namespace > CustomFields Class : CustomFields Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public CustomFields()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CustomFields Class
CustomFields Members


%%PageItemTitle%% $$Methods$$

CustomFields Class Methods
[image]
dotnetCART Namespace : CustomFields Class

For a list of all members of this type, see CustomFields members.

Public Methods

 | Name | Description
Public Method | Add | Adds the names of custom fields for a table.
Top

See Also

Reference

CustomFields Class
dotnetCART Namespace


%%PageItemTitle%%

Add Method
See Also Example
[image]
dotnetCART Namespace > CustomFields Class : Add Method

table
The table name associated with the custom fields.
fields
A comma deleminated string of the custom fields.
Adds the names of custom fields for a table.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal table As Tables, _
   ByVal fields As String _
)
C#
public void Add(
   Tables table,
   string fields
)

Parameters

table
The table name associated with the custom fields.
fields
A comma deleminated string of the custom fields.

Example

C# Copy Code
Store.CustomFields.Add(Tables.Customer,"CellPhone,Favorites");

Visual Basic Copy Code
Store.CustomFields.Add(Tables.Customer,"CellPhone,Favorites")

Remarks

Custom fields must be added to the table manualy.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

CustomFields Class
CustomFields Members


%%PageItemTitle%%

Customs Class
See Also Members
[image]
dotnetCART Namespace : Customs Class

A collection of Custom objects.

Syntax

Visual Basic (Declaration)
Public Class Customs
   Inherits ListBase(Of Custom)
C#
public class Customs : ListBase<Custom>

Inheritance Hierarchy

System.Object
System.Collections.Generic.List<Custom>
dotnetCART.ListBase<Custom>
dotnetCART.Customs

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customs Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

Customs Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : Customs Class

The following tables list the members exposed by Customs.

Public Constructors

 | Name | Description
Public Constructor | Customs Constructor | Initializes a new instance of the Customs.
Top

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from dotnetCART.ListBase<Custom>)
Public Property | Count | Gets the number of elements actually contained in the collection. (Inherited from dotnetCART.ListBase<Custom>)
Public Property | Error | Returns an object with the error information. (Inherited from dotnetCART.ListBase<Custom>)
Public Property | Item | Overloaded. Returns the custom value with this name, if doesn't exist, return empty string.
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Add the new custom object to this collection. If already exsits, set the new value.
Public Method | AddRange | Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetCART.ListBase<Custom>)
Public Method | AsReadOnly | Returns a read-only IList wrapper for the current collection. (Inherited from dotnetCART.ListBase<Custom>)
Public Method | BinarySearch | Overloaded. (Inherited from dotnetCART.ListBase<Custom>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetCART.ListBase<Custom>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetCART.ListBase<Custom>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<Custom>)
Public Method | CopyTo | Overloaded. (Inherited from dotnetCART.ListBase<Custom>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from dotnetCART.ListBase<Custom>)
Public Method | GetValue | Gets the value of the custom.
Public Method | IndexOf | Overloaded. (Inherited from dotnetCART.ListBase<Custom>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetCART.ListBase<Custom>)
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from dotnetCART.ListBase<Custom>)
Public Method | IsExist | Determines whether a custom with this name exists in the collection or not.
Public Method | LastIndexOf | Overloaded. (Inherited from dotnetCART.ListBase<Custom>)
Public Method | LoadDB | Overloaded. Loads all the items from its associated table. (Inherited from dotnetCART.ListBase<Custom>)
Public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from dotnetCART.ListBase<Custom>)
Public Method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from dotnetCART.ListBase<Custom>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetCART.ListBase<Custom>)
Public Method | RemoveRange | Removes a range of elements from the List. (Inherited from dotnetCART.ListBase<Custom>)
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<Custom>)
Public Method | SetValue |
Top

See Also

Reference

Customs Class
dotnetCART Namespace


%%PageItemTitle%%

Customs Constructor
[image]
dotnetCART Namespace > Customs Class : Customs Constructor

Initializes a new instance of the Customs.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Customs()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customs Class
Customs Members


%%PageItemTitle%% $$Methods$$

Customs Class Methods
[image]
dotnetCART Namespace : Customs Class

For a list of all members of this type, see Customs members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Add the new custom object to this collection. If already exsits, set the new value.
Public Method | AddRange | Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetCART.ListBase<Custom>)
Public Method | AsReadOnly | Returns a read-only IList wrapper for the current collection. (Inherited from dotnetCART.ListBase<Custom>)
Public Method | BinarySearch | Overloaded. (Inherited from dotnetCART.ListBase<Custom>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetCART.ListBase<Custom>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetCART.ListBase<Custom>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<Custom>)
Public Method | CopyTo | Overloaded. (Inherited from dotnetCART.ListBase<Custom>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from dotnetCART.ListBase<Custom>)
Public Method | GetValue | Gets the value of the custom.
Public Method | IndexOf | Overloaded. (Inherited from dotnetCART.ListBase<Custom>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetCART.ListBase<Custom>)
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from dotnetCART.ListBase<Custom>)
Public Method | IsExist | Determines whether a custom with this name exists in the collection or not.
Public Method | LastIndexOf | Overloaded. (Inherited from dotnetCART.ListBase<Custom>)
Public Method | LoadDB | Overloaded. Loads all the items from its associated table. (Inherited from dotnetCART.ListBase<Custom>)
Public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from dotnetCART.ListBase<Custom>)
Public Method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from dotnetCART.ListBase<Custom>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetCART.ListBase<Custom>)
Public Method | RemoveRange | Removes a range of elements from the List. (Inherited from dotnetCART.ListBase<Custom>)
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<Custom>)
Public Method | SetValue |
Top

See Also

Reference

Customs Class
dotnetCART Namespace


%%PageItemTitle%%

Add Method
[image]
dotnetCART Namespace > Customs Class : Add Method

Add the new custom object to this collection. If already exsits, set the new value.

Overload List

Overload | Description
Add(Custom) | Add the new custom object to this collection. If already exsits, set the new value.
Add() | Add the new custom object to this collection.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customs Class
Customs Members


%%PageItemTitle%%

Add(Custom) Method
[image]
dotnetCART Namespace > Customs Class > Add Method : Add(Custom) Method

newCustom
Add the new custom object to this collection. If already exsits, set the new value.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add( _
   ByVal newCustom As Custom _
)
C#
public void Add(
   Custom newCustom
)

Parameters

newCustom

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customs Class
Customs Members
Overload List


%%PageItemTitle%%

Add() Method
[image]
dotnetCART Namespace > Customs Class > Add Method : Add() Method

Add the new custom object to this collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add()
C#
public void Add()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customs Class
Customs Members
Overload List


%%PageItemTitle%%

GetValue Method
[image]
dotnetCART Namespace > Customs Class : GetValue Method

index
The index of the custom in the collection.
Gets the value of the custom.

Syntax

Visual Basic (Declaration)
Public Function GetValue( _
   ByVal index As Integer _
) As Object
C#
public object GetValue(
   int index
)

Parameters

index
The index of the custom in the collection.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customs Class
Customs Members


%%PageItemTitle%%

IsExist Method
[image]
dotnetCART Namespace > Customs Class : IsExist Method

name
The name of the custom.
Determines whether a custom with this name exists in the collection or not.

Syntax

Visual Basic (Declaration)
Public Function IsExist( _
   ByVal name As String _
) As Boolean
C#
public bool IsExist(
   string name
)

Parameters

name
The name of the custom.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customs Class
Customs Members


%%PageItemTitle%%

SetValue Method
[image]
dotnetCART Namespace > Customs Class : SetValue Method

name
The name of the custom.
newValue
The new value of the custom.

Syntax

Visual Basic (Declaration)
Public Function SetValue( _
   ByVal name As String, _
   ByVal newValue As Object _
) As Object
C#
public object SetValue(
   string name,
   object newValue
)

Parameters

name
The name of the custom.
newValue
The new value of the custom.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customs Class
Customs Members


%%PageItemTitle%% $$Properties$$

Customs Class Properties
[image]
dotnetCART Namespace : Customs Class

For a list of all members of this type, see Customs members.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from dotnetCART.ListBase<Custom>)
Public Property | Count | Gets the number of elements actually contained in the collection. (Inherited from dotnetCART.ListBase<Custom>)
Public Property | Error | Returns an object with the error information. (Inherited from dotnetCART.ListBase<Custom>)
Public Property | Item | Overloaded. Returns the custom value with this name, if doesn't exist, return empty string.
Top

See Also

Reference

Customs Class
dotnetCART Namespace


%%PageItemTitle%%

Item Property
[image]
dotnetCART Namespace > Customs Class : Item Property

Returns the custom value with this name, if doesn't exist, return empty string.

Overload List

Overload | Description
Item(String) | Returns the custom value with this name, if doesn't exist, return empty string.
Item(Int32) | Gets or sets the element at the specified index. (Inherited from dotnetCART.ListBase<Custom>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customs Class
Customs Members


%%PageItemTitle%%

Item(String) Property
[image]
dotnetCART Namespace > Customs Class > Item Property : Item(String) Property

name
The name of the custom.
Returns the custom value with this name, if doesn't exist, return empty string.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal name As String _
) As Object
C#
public object Item(
   string name
) {get;}

Parameters

name
The name of the custom.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customs Class
Customs Members
Overload List


%%PageItemTitle%%

Error Class
See Also Members
[image]
dotnetCART Namespace : Error Class

Represents an Error object.

Syntax

Visual Basic (Declaration)
Public Class Error
C#
public class Error

Inheritance Hierarchy

System.Object
dotnetCART.Error

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Error Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

Error Class Members
See Also Properties
[image]
dotnetCART Namespace : Error Class

The following tables list the members exposed by Error.

Public Constructors

 | Name | Description
Public Constructor | Error Constructor | Initializes a new instance of the Error class.
Top

Public Properties

 | Name | Description
Public Property | Code | A numeric error code.
Public Property | Message | The error description.
Public Property | Source | The source of the error.
Top

See Also

Reference

Error Class
dotnetCART Namespace


%%PageItemTitle%%

Error Constructor
[image]
dotnetCART Namespace > Error Class : Error Constructor

Initializes a new instance of the Error class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Error()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Error Class
Error Members


%%PageItemTitle%% $$Properties$$

Error Class Properties
[image]
dotnetCART Namespace : Error Class

For a list of all members of this type, see Error members.

Public Properties

 | Name | Description
Public Property | Code | A numeric error code.
Public Property | Message | The error description.
Public Property | Source | The source of the error.
Top

See Also

Reference

Error Class
dotnetCART Namespace


%%PageItemTitle%%

Code Property
[image]
dotnetCART Namespace > Error Class : Code Property

A numeric error code.

Syntax

Visual Basic (Declaration)
Public Property Code As Integer
C#
public int Code {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Error Class
Error Members


%%PageItemTitle%%

Message Property
[image]
dotnetCART Namespace > Error Class : Message Property

The error description.

Syntax

Visual Basic (Declaration)
Public Property Message As String
C#
public string Message {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Error Class
Error Members


%%PageItemTitle%%

Source Property
[image]
dotnetCART Namespace > Error Class : Source Property

The source of the error.

Syntax

Visual Basic (Declaration)
Public Property Source As String
C#
public string Source {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Error Class
Error Members


%%PageItemTitle%%

Image Class
See Also Members
[image]
dotnetCART Namespace : Image Class

Represents an Image object.

Object Model

Syntax

Visual Basic (Declaration)
Public Class Image
   Inherits DbTableCart(Of Image, Long)
C#
public class Image : DbTableCart<Image, long>

Inheritance Hierarchy

System.Object
dotnetDATA.DbTable<Int64>
dotnetDATA.DbTable<Image, Int64>
dotnetCART.DbTableCart<Image, Int64>
dotnetCART.Image

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Image Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

Image Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : Image Class

The following tables list the members exposed by Image.

Public Constructors

 | Name | Description
Public Constructor | Image Constructor | Initializes a new instance of the Image class.
Top

Public Properties

 | Name | Description
Public Property | AlternateText | Gets or sets the alternate text when the image is not available.
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<Image, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<Image, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<Image, Int64>)
Public Property | Description | Gets or sets this image description.
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<Image, Int64>)
Public Property | FileName | Gets or sets this image Url.
Public Property | Height | Gets this image height.
Public Property | ID | Overridden. The auto number ID populated from the database.
Public Property | Name | Gets or sets this image name.
Public Property | ParentObject | The parent object for this image. It can be an item or a Category object.
Public Property | TemplateID | Gets or sets this images TemplateID. An image can be generated using ImageTemplate class.
Public Property | Width | Gets this image width.
Top

Public Methods

 | Name | Description
Public Method | Clear | Initializes all the properties without recreating the object.
Public Method | Clone | Creates a copy of the current Image
Public Method | DeleteDB | Overloaded. Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<Image, Int64>)
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<Image, Int64>)
Public Method | GetSize | Set the Width and Height properties.
Public Method | LoadDB | Overloaded. Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<Image, Int64>)
Public Method | SaveDB | Overloaded. Overridden. Inserts or updates this object into the Images table.
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<Image, Int64>)
Top

See Also

Reference

Image Class
dotnetCART Namespace


%%PageItemTitle%%

Image Constructor
[image]
dotnetCART Namespace > Image Class : Image Constructor

Initializes a new instance of the Image class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Image()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Image Class
Image Members


%%PageItemTitle%% $$Methods$$

Image Class Methods
[image]
dotnetCART Namespace : Image Class

For a list of all members of this type, see Image members.

Public Methods

 | Name | Description
Public Method | Clear | Initializes all the properties without recreating the object.
Public Method | Clone | Creates a copy of the current Image
Public Method | DeleteDB | Overloaded. Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<Image, Int64>)
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<Image, Int64>)
Public Method | GetSize | Set the Width and Height properties.
Public Method | LoadDB | Overloaded. Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<Image, Int64>)
Public Method | SaveDB | Overloaded. Overridden. Inserts or updates this object into the Images table.
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<Image, Int64>)
Top

See Also

Reference

Image Class
dotnetCART Namespace


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > Image Class : Clear Method

Initializes all the properties without recreating the object.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Image Class
Image Members


%%PageItemTitle%%

Clone Method
[image]
dotnetCART Namespace > Image Class : Clone Method

Creates a copy of the current Image

Syntax

Visual Basic (Declaration)
Public Function Clone() As Image
C#
public Image Clone()

Return Value

Returns an Image object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Image Class
Image Members


%%PageItemTitle%%

GetSize Method
[image]
dotnetCART Namespace > Image Class : GetSize Method

pathImage
The full or relative path of the image.
Set the Width and Height properties.

Syntax

Visual Basic (Declaration)
Public Function GetSize( _
   ByVal pathImage As String _
) As String
C#
public string GetSize(
   string pathImage
)

Parameters

pathImage
The full or relative path of the image.

Return Value

The size of the image in "widthxheight" format.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Image Class
Image Members


%%PageItemTitle%%

SaveDB Method
[image]
dotnetCART Namespace > Image Class : SaveDB Method

Inserts or updates this object into the Images table.

Overload List

Overload | Description
SaveDB() | Inserts or updates this object into the Images table.
SaveDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Image Class
Image Members


%%PageItemTitle%%

SaveDB() Method
[image]
dotnetCART Namespace > Image Class > SaveDB Method : SaveDB() Method

Inserts or updates this object into the Images table.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function SaveDB() As Integer
C#
public override int SaveDB()

Return Value

Returns the generated ID or 1 for the update, returns -1 if failed. For the reason of fail, check the Error property.

Remarks

If ID greater than 0, it updates the associated image in the table, otherwise inserts a new image.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Image Class
Image Members
Overload List


%%PageItemTitle%% $$Properties$$

Image Class Properties
[image]
dotnetCART Namespace : Image Class

For a list of all members of this type, see Image members.

Public Properties

 | Name | Description
Public Property | AlternateText | Gets or sets the alternate text when the image is not available.
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<Image, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<Image, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<Image, Int64>)
Public Property | Description | Gets or sets this image description.
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<Image, Int64>)
Public Property | FileName | Gets or sets this image Url.
Public Property | Height | Gets this image height.
Public Property | ID | Overridden. The auto number ID populated from the database.
Public Property | Name | Gets or sets this image name.
Public Property | ParentObject | The parent object for this image. It can be an item or a Category object.
Public Property | TemplateID | Gets or sets this images TemplateID. An image can be generated using ImageTemplate class.
Public Property | Width | Gets this image width.
Top

See Also

Reference

Image Class
dotnetCART Namespace


%%PageItemTitle%%

AlternateText Property
[image]
dotnetCART Namespace > Image Class : AlternateText Property

Gets or sets the alternate text when the image is not available.

Syntax

Visual Basic (Declaration)
Public Property AlternateText As String
C#
public string AlternateText {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Image Class
Image Members


%%PageItemTitle%%

Description Property
[image]
dotnetCART Namespace > Image Class : Description Property

Gets or sets this image description.

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Image Class
Image Members


%%PageItemTitle%%

FileName Property
[image]
dotnetCART Namespace > Image Class : FileName Property

Gets or sets this image Url.

Syntax

Visual Basic (Declaration)
Public Property FileName As String
C#
public string FileName {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Image Class
Image Members


%%PageItemTitle%%

Height Property
[image]
dotnetCART Namespace > Image Class : Height Property

Gets this image height.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Height As Integer
C#
public int Height {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Image Class
Image Members


%%PageItemTitle%%

ID Property
[image]
dotnetCART Namespace > Image Class : ID Property

The auto number ID populated from the database.

Syntax

Visual Basic (Declaration)
Public Overrides Property ID As Long
C#
public override long ID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Image Class
Image Members


%%PageItemTitle%%

Name Property
[image]
dotnetCART Namespace > Image Class : Name Property

Gets or sets this image name.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Image Class
Image Members


%%PageItemTitle%%

ParentObject Property
[image]
dotnetCART Namespace > Image Class : ParentObject Property

The parent object for this image. It can be an item or a Category object.

Syntax

Visual Basic (Declaration)
Public Property ParentObject As Object
C#
public object ParentObject {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Image Class
Image Members


%%PageItemTitle%%

TemplateID Property
[image]
dotnetCART Namespace > Image Class : TemplateID Property

Gets or sets this images TemplateID. An image can be generated using ImageTemplate class.

Syntax

Visual Basic (Declaration)
Public Property TemplateID As Long
C#
public long TemplateID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Image Class
Image Members


%%PageItemTitle%%

Width Property
[image]
dotnetCART Namespace > Image Class : Width Property

Gets this image width.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Width As Integer
C#
public int Width {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Image Class
Image Members


%%PageItemTitle%%

Images Class
See Also Members
[image]
dotnetCART Namespace : Images Class

A collection of Image objects.

Object Model

Syntax

Visual Basic (Declaration)
Public Class Images
   Inherits ListBase(Of Image)
C#
public class Images : ListBase<Image>

Inheritance Hierarchy

System.Object
System.Collections.Generic.List<Image>
dotnetCART.ListBase<Image>
dotnetCART.Images

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Images Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

Images Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : Images Class

The following tables list the members exposed by Images.

Public Constructors

 | Name | Description
Public Constructor | Images Constructor | Initializes a new instance of the Images class.
Top

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from dotnetCART.ListBase<Image>)
Public Property | Count | Gets the number of elements actually contained in the collection. (Inherited from dotnetCART.ListBase<Image>)
Public Property | Error | Returns an object with the error information. (Inherited from dotnetCART.ListBase<Image>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from dotnetCART.ListBase<Image>)
Top

Public Methods

 | Name | Description
Public Method | Add | Add an Image object to the images collection.
Public Method | AddRange | Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetCART.ListBase<Image>)
Public Method | AsReadOnly | Returns a read-only IList wrapper for the current collection. (Inherited from dotnetCART.ListBase<Image>)
Public Method | BinarySearch | Overloaded. (Inherited from dotnetCART.ListBase<Image>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetCART.ListBase<Image>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetCART.ListBase<Image>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<Image>)
Public Method | CopyTo | Overloaded. (Inherited from dotnetCART.ListBase<Image>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from dotnetCART.ListBase<Image>)
Public Method | GetFileName | Get the FileName for the specified image name.
Public Method | GetImage | Overloaded. Get the image object for the specified image name.
Public Method | IndexOf | Overloaded. (Inherited from dotnetCART.ListBase<Image>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetCART.ListBase<Image>)
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from dotnetCART.ListBase<Image>)
Public Method | LastIndexOf | Overloaded. (Inherited from dotnetCART.ListBase<Image>)
Public Method | LoadDB | Overloaded. Loads the images assosiated with the ParentObject.
Public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from dotnetCART.ListBase<Image>)
Public Method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from dotnetCART.ListBase<Image>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetCART.ListBase<Image>)
Public Method | RemoveRange | Removes a range of elements from the List. (Inherited from dotnetCART.ListBase<Image>)
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<Image>)
Public Method | SetUrl | Set the new URL for the image, and return the old URL. if an image with the provided name doesn't exist, it creates a new image.
Top

See Also

Reference

Images Class
dotnetCART Namespace


%%PageItemTitle%%

Images Constructor
[image]
dotnetCART Namespace > Images Class : Images Constructor

Initializes a new instance of the Images class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Images()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Images Class
Images Members


%%PageItemTitle%% $$Methods$$

Images Class Methods
[image]
dotnetCART Namespace : Images Class

For a list of all members of this type, see Images members.

Public Methods

 | Name | Description
Public Method | Add | Add an Image object to the images collection.
Public Method | AddRange | Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetCART.ListBase<Image>)
Public Method | AsReadOnly | Returns a read-only IList wrapper for the current collection. (Inherited from dotnetCART.ListBase<Image>)
Public Method | BinarySearch | Overloaded. (Inherited from dotnetCART.ListBase<Image>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetCART.ListBase<Image>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetCART.ListBase<Image>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<Image>)
Public Method | CopyTo | Overloaded. (Inherited from dotnetCART.ListBase<Image>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from dotnetCART.ListBase<Image>)
Public Method | GetFileName | Get the FileName for the specified image name.
Public Method | GetImage | Overloaded. Get the image object for the specified image name.
Public Method | IndexOf | Overloaded. (Inherited from dotnetCART.ListBase<Image>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetCART.ListBase<Image>)
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from dotnetCART.ListBase<Image>)
Public Method | LastIndexOf | Overloaded. (Inherited from dotnetCART.ListBase<Image>)
Public Method | LoadDB | Overloaded. Loads the images assosiated with the ParentObject.
Public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from dotnetCART.ListBase<Image>)
Public Method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from dotnetCART.ListBase<Image>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetCART.ListBase<Image>)
Public Method | RemoveRange | Removes a range of elements from the List. (Inherited from dotnetCART.ListBase<Image>)
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<Image>)
Public Method | SetUrl | Set the new URL for the image, and return the old URL. if an image with the provided name doesn't exist, it creates a new image.
Top

See Also

Reference

Images Class
dotnetCART Namespace


%%PageItemTitle%%

Add Method
[image]
dotnetCART Namespace > Images Class : Add Method

newImage
A new Image
Add an Image object to the images collection.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal newImage As Image _
)
C#
public void Add(
   Image newImage
)

Parameters

newImage
A new Image

Remarks

If an image with the same image name already exist in the images collection, the old one is replaced by the new one.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Images Class
Images Members


%%PageItemTitle%%

GetFileName Method
[image]
dotnetCART Namespace > Images Class : GetFileName Method

name
An image name.
Get the FileName for the specified image name.

Syntax

Visual Basic (Declaration)
Public Function GetFileName( _
   ByVal name As String _
) As String
C#
public string GetFileName(
   string name
)

Parameters

name
An image name.

Return Value

The FileName for the specified image name.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Images Class
Images Members


%%PageItemTitle%%

GetImage Method
[image]
dotnetCART Namespace > Images Class : GetImage Method

Get the image object for the specified image name.

Overload List

Overload | Description
GetImage(String) | Get the image object for the specified image name.
GetImage(Int64) | Get the image object for the specified image id.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Images Class
Images Members


%%PageItemTitle%%

GetImage(String) Method
[image]
dotnetCART Namespace > Images Class > GetImage Method : GetImage(String) Method

name
The image name.
Get the image object for the specified image name.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetImage( _
   ByVal name As String _
) As Image
C#
public Image GetImage(
   string name
)

Parameters

name
The image name.

Return Value

The image object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Images Class
Images Members
Overload List


%%PageItemTitle%%

GetImage(Int64) Method
[image]
dotnetCART Namespace > Images Class > GetImage Method : GetImage(Int64) Method

id
The image id.
Get the image object for the specified image id.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetImage( _
   ByVal id As Long _
) As Image
C#
public Image GetImage(
   long id
)

Parameters

id
The image id.

Return Value

The image object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Images Class
Images Members
Overload List


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > Images Class : LoadDB Method

Loads the images assosiated with the ParentObject.

Overload List

Overload | Description
LoadDB() | Loads the images assosiated with the ParentObject.
LoadDB(Where) | Loads all the items from its associated table based on the where clause. (Inherited from dotnetCART.ListBase<Image>)
LoadDB(Int32,Int32) | Loads the count number of elements from start value. (Inherited from dotnetCART.ListBase<Image>)
LoadDB(Where,Int32,Int32,String,OrderDirection) | Loads all the items based on the parameters. (Inherited from dotnetCART.ListBase<Image>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Images Class
Images Members


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > Images Class > LoadDB Method : LoadDB() Method

Loads the images assosiated with the ParentObject.

Syntax

Visual Basic (Declaration)
Public Overloads Function LoadDB() As Integer
C#
public int LoadDB()

Return Value

Returns the total loaded iamges, or -1 if there is an error or ParentObject is null.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Images Class
Images Members
Overload List


%%PageItemTitle%%

SetUrl Method
[image]
dotnetCART Namespace > Images Class : SetUrl Method

name
The image name.
newValue
New image URL.
Set the new URL for the image, and return the old URL. if an image with the provided name doesn't exist, it creates a new image.

Syntax

Visual Basic (Declaration)
Public Function SetUrl( _
   ByVal name As String, _
   ByVal newValue As String _
) As String
C#
public string SetUrl(
   string name,
   string newValue
)

Parameters

name
The image name.
newValue
New image URL.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Images Class
Images Members


%%PageItemTitle%%

ImageTemplate Class
See Also Members
[image]
dotnetCART Namespace : ImageTemplate Class

An image template for generating different images for Item or Category.

Object Model

Syntax

Visual Basic (Declaration)
Public Class ImageTemplate
   Inherits DbTableCart(Of ImageTemplate, Long)
C#
public class ImageTemplate : DbTableCart<ImageTemplate, long>

Remarks

For a typical usage, add a template in StoreAdmin->Images tab, then uses the templae for generating a new image from an original image for an item or category in its images tab.

Inheritance Hierarchy

System.Object
dotnetDATA.DbTable<Int64>
dotnetDATA.DbTable<ImageTemplate, Int64>
dotnetCART.DbTableCart<ImageTemplate, Int64>
dotnetCART.ImageTemplate

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplate Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

ImageTemplate Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : ImageTemplate Class

The following tables list the members exposed by ImageTemplate.

Public Constructors

 | Name | Description
Public Constructor | ImageTemplate Constructor | Initializes a new instance of the ImageTemplate class.
Top

Public Properties

 | Name | Description
Public Property | AlternateText | An item or category property name determine which value should be displayed for an alternate text.
Public Property | BackgroundColor | Sets or gets the image background color. Default is Color.White
Public Property | BorderColor | Sets or gets the color of the image border color. Color, Default is Color.Black.
Public Property | BorderSize | Sets or gets the border size in pixels.
Public Property | Crop | A boolean determines if the image will be cropped so it best fits the full new image size as set by width and height. Default is false.
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<ImageTemplate, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<ImageTemplate, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<ImageTemplate, Int64>)
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<ImageTemplate, Int64>)
Public Property | FixedHeight | Determines if the image should scale by a fixed height. This means that the height will remain constant however the width of different images may vary based on the proportions of the input image. Default is false.
Public Property | FixedWidth | Determines if the image should scale by a fixed width. This means that the width will remain constant however the height of different images may vary based on the proportions of the input image. Default is false.
Public Property | Format | The output image format for the generated image.
Public Property | Height | Sets or gets the new image height.
Public Property | ID | Overridden. The auto number ID populated from the database.
Public Property | Name | The name of the image template for getting the image or ImageUrl.
Public Property | PaddingColor | Sets or gets the color of the padding for the image. Color, Default is Color.White.
Public Property | PaddingSize | Sets or gets the amound of padding in pixels.
Public Property | Quality | Determines the quality of the newly generated image. The higher the quality, the larger the generated file size. The default is 80 out of a maximum of 100.
Public Property | TypeID | Bind the imageTemplate to item or category object.
Public Property | UseCanvas | A boolean determines whether to use canvas or not. Default is true.
Public Property | Width | Sets or gets the new image height.
Top

Public Methods

 | Name | Description
Public Method | Clear | Initializes all the properties without recreating the object. (Inherited from dotnetCART.DbTableCart<ImageTemplate, Int64>)
Public Method | Delete | Deletes an imageTemplate from the configration File.
Public Method | DeleteDB | Overloaded. Overridden. Deletes this object from the ImageTemplates table.
Public Method | Generate | Overloaded. Generates an image based on the properties defined in this imageTemplate object.
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<ImageTemplate, Int64>)
Public Method | GetEncoderInfo | Returns an ImageCodecInfo object that contain information about the image encoders built into GDI+.
Public Method | LoadDB | Overloaded. Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<ImageTemplate, Int64>)
Public Method | SaveDB | Overloaded. Overridden. Inserts or updates this object into the ImageTemplates table.
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<ImageTemplate, Int64>)
Public Method | ViewImageFrame | View the bitmap image frame.
Top

See Also

Reference

ImageTemplate Class
dotnetCART Namespace


%%PageItemTitle%%

ImageTemplate Constructor
[image]
dotnetCART Namespace > ImageTemplate Class : ImageTemplate Constructor

Initializes a new instance of the ImageTemplate class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ImageTemplate()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplate Class
ImageTemplate Members


%%PageItemTitle%% $$Methods$$

ImageTemplate Class Methods
[image]
dotnetCART Namespace : ImageTemplate Class

For a list of all members of this type, see ImageTemplate members.

Public Methods

 | Name | Description
Public Method | Clear | Initializes all the properties without recreating the object. (Inherited from dotnetCART.DbTableCart<ImageTemplate, Int64>)
Public Method | Delete | Deletes an imageTemplate from the configration File.
Public Method | DeleteDB | Overloaded. Overridden. Deletes this object from the ImageTemplates table.
Public Method | Generate | Overloaded. Generates an image based on the properties defined in this imageTemplate object.
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<ImageTemplate, Int64>)
Public Method | GetEncoderInfo | Returns an ImageCodecInfo object that contain information about the image encoders built into GDI+.
Public Method | LoadDB | Overloaded. Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<ImageTemplate, Int64>)
Public Method | SaveDB | Overloaded. Overridden. Inserts or updates this object into the ImageTemplates table.
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<ImageTemplate, Int64>)
Public Method | ViewImageFrame | View the bitmap image frame.
Top

See Also

Reference

ImageTemplate Class
dotnetCART Namespace


%%PageItemTitle%%

Delete Method
[image]
dotnetCART Namespace > ImageTemplate Class : Delete Method

Deletes an imageTemplate from the configration File.

Syntax

Visual Basic (Declaration)
Public Function Delete() As Boolean
C#
public bool Delete()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplate Class
ImageTemplate Members


%%PageItemTitle%%

DeleteDB Method
[image]
dotnetCART Namespace > ImageTemplate Class : DeleteDB Method

Deletes this object from the ImageTemplates table.

Overload List

Overload | Description
DeleteDB() | Deletes this object from the ImageTemplates table.
DeleteDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplate Class
ImageTemplate Members


%%PageItemTitle%%

DeleteDB() Method
[image]
dotnetCART Namespace > ImageTemplate Class > DeleteDB Method : DeleteDB() Method

Deletes this object from the ImageTemplates table.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function DeleteDB() As Integer
C#
public override int DeleteDB()

Return Value

Returns 1 if the record deleted successfully, 0 if the record not found, -1 if faild. For the reason of fail, check the Error property.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplate Class
ImageTemplate Members
Overload List


%%PageItemTitle%%

Generate Method
[image]
dotnetCART Namespace > ImageTemplate Class : Generate Method

Generates an image based on the properties defined in this imageTemplate object.

Overload List

Overload | Description
Generate(Bitmap,String) | Generates an image from the bitmap object based on the properties defined in this imageTemplate class and saves it to the specified file.
Generate(String,String) | Generates an image from the specified image file based on the properties defined in this imageTemplate class and saves it to the specified file.
Generate(Bitmap,Bitmap) | Generates an image from the bitmap object based on the properties defined in this imageTemplate class and saves it to the provided bitmap object.
Generate(String,Bitmap) | Generates an image from the specified image file based on the properties defined in this imageTemplate class and saves it to the provided bitmap object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplate Class
ImageTemplate Members


%%PageItemTitle%%

Generate(Bitmap,String) Method
[image]
dotnetCART Namespace > ImageTemplate Class > Generate Method : Generate(Bitmap,String) Method

objInBitMap
A bitmap object.
outputPath
A virtual path to the image (relative to the calling script), or a physical path to the image. The output image file type is automatically set based on the extension selected or optionaly with the Format Property. Options includes .jpg, .tif, .bmp and .png.
Generates an image from the bitmap object based on the properties defined in this imageTemplate class and saves it to the specified file.

Syntax

Visual Basic (Declaration)
Public Overloads Function Generate( _
   ByVal objInBitMap As Bitmap, _
   ByVal outputPath As String _
) As String
C#
public string Generate(
   Bitmap objInBitMap,
   string outputPath
)

Parameters

objInBitMap
A bitmap object.
outputPath
A virtual path to the image (relative to the calling script), or a physical path to the image. The output image file type is automatically set based on the extension selected or optionaly with the Format Property. Options includes .jpg, .tif, .bmp and .png.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplate Class
ImageTemplate Members
Overload List


%%PageItemTitle%%

Generate(String,String) Method
[image]
dotnetCART Namespace > ImageTemplate Class > Generate Method : Generate(String,String) Method

inputImage
outputPath
A virtual path to the image (relative to the calling script), or a physical path to the image. The output image file type is automatically set based on the extension selected or optionaly with the Format Property. Options includes .jpg, .tif, .bmp and .png.
Generates an image from the specified image file based on the properties defined in this imageTemplate class and saves it to the specified file.

Syntax

Visual Basic (Declaration)
Public Overloads Function Generate( _
   ByVal inputImage As String, _
   ByVal outputPath As String _
) As String
C#
public string Generate(
   string inputImage,
   string outputPath
)

Parameters

inputImage
outputPath
A virtual path to the image (relative to the calling script), or a physical path to the image. The output image file type is automatically set based on the extension selected or optionaly with the Format Property. Options includes .jpg, .tif, .bmp and .png.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplate Class
ImageTemplate Members
Overload List


%%PageItemTitle%%

Generate(Bitmap,Bitmap) Method
[image]
dotnetCART Namespace > ImageTemplate Class > Generate Method : Generate(Bitmap,Bitmap) Method

objInBitMap
A bitmap object.
objOutBitmap
A reference to a bitmap object.
Generates an image from the bitmap object based on the properties defined in this imageTemplate class and saves it to the provided bitmap object.

Syntax

Visual Basic (Declaration)
Public Overloads Function Generate( _
   ByVal objInBitMap As Bitmap, _
   ByRef objOutBitmap As Bitmap _
) As String
C#
public string Generate(
   Bitmap objInBitMap,
   ref Bitmap objOutBitmap
)

Parameters

objInBitMap
A bitmap object.
objOutBitmap
A reference to a bitmap object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplate Class
ImageTemplate Members
Overload List


%%PageItemTitle%%

Generate(String,Bitmap) Method
[image]
dotnetCART Namespace > ImageTemplate Class > Generate Method : Generate(String,Bitmap) Method

inputImage
A virtual path to the image (relative to the calling script), or a physical path to the image.
objOutBitmap
A reference to a bitmap object.
Generates an image from the specified image file based on the properties defined in this imageTemplate class and saves it to the provided bitmap object.

Syntax

Visual Basic (Declaration)
Public Overloads Function Generate( _
   ByVal inputImage As String, _
   ByRef objOutBitmap As Bitmap _
) As String
C#
public string Generate(
   string inputImage,
   ref Bitmap objOutBitmap
)

Parameters

inputImage
A virtual path to the image (relative to the calling script), or a physical path to the image.
objOutBitmap
A reference to a bitmap object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplate Class
ImageTemplate Members
Overload List


%%PageItemTitle%%

GetEncoderInfo Method
[image]
dotnetCART Namespace > ImageTemplate Class : GetEncoderInfo Method

mimeType
A string that contains the codec Multipurpose Internet Mail Extensions (MIME) type.
Returns an ImageCodecInfo object that contain information about the image encoders built into GDI+.

Syntax

Visual Basic (Declaration)
Public Function GetEncoderInfo( _
   ByVal mimeType As String _
) As ImageCodecInfo
C#
public ImageCodecInfo GetEncoderInfo(
   string mimeType
)

Parameters

mimeType
A string that contains the codec Multipurpose Internet Mail Extensions (MIME) type.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplate Class
ImageTemplate Members


%%PageItemTitle%%

SaveDB Method
[image]
dotnetCART Namespace > ImageTemplate Class : SaveDB Method

Inserts or updates this object into the ImageTemplates table.

Overload List

Overload | Description
SaveDB() | Inserts or updates this object into the ImageTemplates table.
SaveDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplate Class
ImageTemplate Members


%%PageItemTitle%%

SaveDB() Method
[image]
dotnetCART Namespace > ImageTemplate Class > SaveDB Method : SaveDB() Method

Inserts or updates this object into the ImageTemplates table.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function SaveDB() As Integer
C#
public override int SaveDB()

Return Value

Returns the generated ID or 1 for the update, returns -1 if failed. For the reason of fail, check the Error property.

Remarks

If the ID property greater than 0, it updates the associated record in the table, otherwise inserts a new record.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplate Class
ImageTemplate Members
Overload List


%%PageItemTitle%%

ViewImageFrame Method
[image]
dotnetCART Namespace > ImageTemplate Class : ViewImageFrame Method

myBitmap
A reference to a bitmap objet.
View the bitmap image frame.

Syntax

Visual Basic (Declaration)
Public Function ViewImageFrame( _
   ByRef myBitmap As Bitmap _
) As String
C#
public string ViewImageFrame(
   ref Bitmap myBitmap
)

Parameters

myBitmap
A reference to a bitmap objet.

Return Value

Returns error string.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplate Class
ImageTemplate Members


%%PageItemTitle%% $$Properties$$

ImageTemplate Class Properties
[image]
dotnetCART Namespace : ImageTemplate Class

For a list of all members of this type, see ImageTemplate members.

Public Properties

 | Name | Description
Public Property | AlternateText | An item or category property name determine which value should be displayed for an alternate text.
Public Property | BackgroundColor | Sets or gets the image background color. Default is Color.White
Public Property | BorderColor | Sets or gets the color of the image border color. Color, Default is Color.Black.
Public Property | BorderSize | Sets or gets the border size in pixels.
Public Property | Crop | A boolean determines if the image will be cropped so it best fits the full new image size as set by width and height. Default is false.
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<ImageTemplate, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<ImageTemplate, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<ImageTemplate, Int64>)
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<ImageTemplate, Int64>)
Public Property | FixedHeight | Determines if the image should scale by a fixed height. This means that the height will remain constant however the width of different images may vary based on the proportions of the input image. Default is false.
Public Property | FixedWidth | Determines if the image should scale by a fixed width. This means that the width will remain constant however the height of different images may vary based on the proportions of the input image. Default is false.
Public Property | Format | The output image format for the generated image.
Public Property | Height | Sets or gets the new image height.
Public Property | ID | Overridden. The auto number ID populated from the database.
Public Property | Name | The name of the image template for getting the image or ImageUrl.
Public Property | PaddingColor | Sets or gets the color of the padding for the image. Color, Default is Color.White.
Public Property | PaddingSize | Sets or gets the amound of padding in pixels.
Public Property | Quality | Determines the quality of the newly generated image. The higher the quality, the larger the generated file size. The default is 80 out of a maximum of 100.
Public Property | TypeID | Bind the imageTemplate to item or category object.
Public Property | UseCanvas | A boolean determines whether to use canvas or not. Default is true.
Public Property | Width | Sets or gets the new image height.
Top

See Also

Reference

ImageTemplate Class
dotnetCART Namespace


%%PageItemTitle%%

AlternateText Property
[image]
dotnetCART Namespace > ImageTemplate Class : AlternateText Property

An item or category property name determine which value should be displayed for an alternate text.

Syntax

Visual Basic (Declaration)
Public Property AlternateText As String
C#
public string AlternateText {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplate Class
ImageTemplate Members


%%PageItemTitle%%

BackgroundColor Property
[image]
dotnetCART Namespace > ImageTemplate Class : BackgroundColor Property

Sets or gets the image background color. Default is Color.White

Syntax

Visual Basic (Declaration)
Public Property BackgroundColor As Color
C#
public Color BackgroundColor {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplate Class
ImageTemplate Members


%%PageItemTitle%%

BorderColor Property
[image]
dotnetCART Namespace > ImageTemplate Class : BorderColor Property

Sets or gets the color of the image border color. Color, Default is Color.Black.

Syntax

Visual Basic (Declaration)
Public Property BorderColor As Color
C#
public Color BorderColor {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplate Class
ImageTemplate Members


%%PageItemTitle%%

BorderSize Property
[image]
dotnetCART Namespace > ImageTemplate Class : BorderSize Property

Sets or gets the border size in pixels.

Syntax

Visual Basic (Declaration)
Public Property BorderSize As Integer
C#
public int BorderSize {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplate Class
ImageTemplate Members


%%PageItemTitle%%

Crop Property
[image]
dotnetCART Namespace > ImageTemplate Class : Crop Property

A boolean determines if the image will be cropped so it best fits the full new image size as set by width and height. Default is false.

Syntax

Visual Basic (Declaration)
Public Property Crop As Boolean
C#
public bool Crop {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplate Class
ImageTemplate Members


%%PageItemTitle%%

FixedHeight Property
[image]
dotnetCART Namespace > ImageTemplate Class : FixedHeight Property

Determines if the image should scale by a fixed height. This means that the height will remain constant however the width of different images may vary based on the proportions of the input image. Default is false.

Syntax

Visual Basic (Declaration)
Public Property FixedHeight As Boolean
C#
public bool FixedHeight {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplate Class
ImageTemplate Members


%%PageItemTitle%%

FixedWidth Property
[image]
dotnetCART Namespace > ImageTemplate Class : FixedWidth Property

Determines if the image should scale by a fixed width. This means that the width will remain constant however the height of different images may vary based on the proportions of the input image. Default is false.

Syntax

Visual Basic (Declaration)
Public Property FixedWidth As Boolean
C#
public bool FixedWidth {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplate Class
ImageTemplate Members


%%PageItemTitle%%

Format Property
[image]
dotnetCART Namespace > ImageTemplate Class : Format Property

The output image format for the generated image.

Syntax

Visual Basic (Declaration)
Public Property Format As String
C#
public string Format {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplate Class
ImageTemplate Members


%%PageItemTitle%%

Height Property
[image]
dotnetCART Namespace > ImageTemplate Class : Height Property

Sets or gets the new image height.

Syntax

Visual Basic (Declaration)
Public Property Height As Integer
C#
public int Height {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplate Class
ImageTemplate Members


%%PageItemTitle%%

ID Property
[image]
dotnetCART Namespace > ImageTemplate Class : ID Property

The auto number ID populated from the database.

Syntax

Visual Basic (Declaration)
Public Overrides Property ID As Long
C#
public override long ID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplate Class
ImageTemplate Members


%%PageItemTitle%%

Name Property
[image]
dotnetCART Namespace > ImageTemplate Class : Name Property

The name of the image template for getting the image or ImageUrl.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplate Class
ImageTemplate Members


%%PageItemTitle%%

PaddingColor Property
[image]
dotnetCART Namespace > ImageTemplate Class : PaddingColor Property

Sets or gets the color of the padding for the image. Color, Default is Color.White.

Syntax

Visual Basic (Declaration)
Public Property PaddingColor As Color
C#
public Color PaddingColor {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplate Class
ImageTemplate Members


%%PageItemTitle%%

PaddingSize Property
[image]
dotnetCART Namespace > ImageTemplate Class : PaddingSize Property

Sets or gets the amound of padding in pixels.

Syntax

Visual Basic (Declaration)
Public Property PaddingSize As Integer
C#
public int PaddingSize {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplate Class
ImageTemplate Members


%%PageItemTitle%%

Quality Property
[image]
dotnetCART Namespace > ImageTemplate Class : Quality Property

Determines the quality of the newly generated image. The higher the quality, the larger the generated file size. The default is 80 out of a maximum of 100.

Syntax

Visual Basic (Declaration)
Public Property Quality As Long
C#
public long Quality {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplate Class
ImageTemplate Members


%%PageItemTitle%%

TypeID Property
[image]
dotnetCART Namespace > ImageTemplate Class : TypeID Property

Bind the imageTemplate to item or category object.

Syntax

Visual Basic (Declaration)
Public Property TypeID As Integer
C#
public int TypeID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplate Class
ImageTemplate Members


%%PageItemTitle%%

UseCanvas Property
[image]
dotnetCART Namespace > ImageTemplate Class : UseCanvas Property

A boolean determines whether to use canvas or not. Default is true.

Syntax

Visual Basic (Declaration)
Public Property UseCanvas As Boolean
C#
public bool UseCanvas {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplate Class
ImageTemplate Members


%%PageItemTitle%%

Width Property
[image]
dotnetCART Namespace > ImageTemplate Class : Width Property

Sets or gets the new image height.

Syntax

Visual Basic (Declaration)
Public Property Width As Integer
C#
public int Width {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplate Class
ImageTemplate Members


%%PageItemTitle%%

ImageTemplates Class
See Also Members
[image]
dotnetCART Namespace : ImageTemplates Class

A collection of ImageTemplate objects.

Object Model

Syntax

Visual Basic (Declaration)
Public Class ImageTemplates
   Inherits ListBase(Of ImageTemplate)
C#
public class ImageTemplates : ListBase<ImageTemplate>

Remarks

For a typical usage, see StoreAdmin->Images

Inheritance Hierarchy

System.Object
System.Collections.Generic.List<ImageTemplate>
dotnetCART.ListBase<ImageTemplate>
dotnetCART.ImageTemplates

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplates Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

ImageTemplates Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : ImageTemplates Class

The following tables list the members exposed by ImageTemplates.

Public Constructors

 | Name | Description
Public Constructor | ImageTemplates Constructor |
Top

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from dotnetCART.ListBase<ImageTemplate>)
Public Property | Count | Gets the number of elements actually contained in the collection. (Inherited from dotnetCART.ListBase<ImageTemplate>)
Public Property | Error | Returns an object with the error information. (Inherited from dotnetCART.ListBase<ImageTemplate>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from dotnetCART.ListBase<ImageTemplate>)
Public Property | Path | The related path for store images.
Public Property | PathStoreAdmin | The related path for the StoreAdmin images.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds an object to the end of the collection. (Inherited from dotnetCART.ListBase<ImageTemplate>)
Public Method | AddRange | Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetCART.ListBase<ImageTemplate>)
Public Method | AsReadOnly | Returns a read-only IList wrapper for the current collection. (Inherited from dotnetCART.ListBase<ImageTemplate>)
Public Method | BinarySearch | Overloaded. (Inherited from dotnetCART.ListBase<ImageTemplate>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetCART.ListBase<ImageTemplate>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetCART.ListBase<ImageTemplate>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<ImageTemplate>)
Public Method | CopyTo | Overloaded. (Inherited from dotnetCART.ListBase<ImageTemplate>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from dotnetCART.ListBase<ImageTemplate>)
Public Method | GetID | Gets the id of the template.
Public Method | GetName | Gets the name of the template.
Public Method | GetTemplate | Gets the image template.
Public Method | IndexOf | Overloaded. (Inherited from dotnetCART.ListBase<ImageTemplate>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetCART.ListBase<ImageTemplate>)
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from dotnetCART.ListBase<ImageTemplate>)
Public Method | LastIndexOf | Overloaded. (Inherited from dotnetCART.ListBase<ImageTemplate>)
Public Method | Load | Loads all the images setting from the configration File.
Public Method | LoadDB | Overloaded. Loads all the imageTemplates from ImageTemplates table.
Public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from dotnetCART.ListBase<ImageTemplate>)
Public Method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from dotnetCART.ListBase<ImageTemplate>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetCART.ListBase<ImageTemplate>)
Public Method | RemoveRange | Removes a range of elements from the List. (Inherited from dotnetCART.ListBase<ImageTemplate>)
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<ImageTemplate>)
Public Method | Save | Saves all the images setting to the configration File.
Top

See Also

Reference

ImageTemplates Class
dotnetCART Namespace


%%PageItemTitle%%

ImageTemplates Constructor
[image]
dotnetCART Namespace > ImageTemplates Class : ImageTemplates Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ImageTemplates()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplates Class
ImageTemplates Members


%%PageItemTitle%% $$Methods$$

ImageTemplates Class Methods
[image]
dotnetCART Namespace : ImageTemplates Class

For a list of all members of this type, see ImageTemplates members.

Public Methods

 | Name | Description
Public Method | Add | Adds an object to the end of the collection. (Inherited from dotnetCART.ListBase<ImageTemplate>)
Public Method | AddRange | Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetCART.ListBase<ImageTemplate>)
Public Method | AsReadOnly | Returns a read-only IList wrapper for the current collection. (Inherited from dotnetCART.ListBase<ImageTemplate>)
Public Method | BinarySearch | Overloaded. (Inherited from dotnetCART.ListBase<ImageTemplate>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetCART.ListBase<ImageTemplate>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetCART.ListBase<ImageTemplate>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<ImageTemplate>)
Public Method | CopyTo | Overloaded. (Inherited from dotnetCART.ListBase<ImageTemplate>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from dotnetCART.ListBase<ImageTemplate>)
Public Method | GetID | Gets the id of the template.
Public Method | GetName | Gets the name of the template.
Public Method | GetTemplate | Gets the image template.
Public Method | IndexOf | Overloaded. (Inherited from dotnetCART.ListBase<ImageTemplate>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetCART.ListBase<ImageTemplate>)
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from dotnetCART.ListBase<ImageTemplate>)
Public Method | LastIndexOf | Overloaded. (Inherited from dotnetCART.ListBase<ImageTemplate>)
Public Method | Load | Loads all the images setting from the configration File.
Public Method | LoadDB | Overloaded. Loads all the imageTemplates from ImageTemplates table.
Public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from dotnetCART.ListBase<ImageTemplate>)
Public Method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from dotnetCART.ListBase<ImageTemplate>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetCART.ListBase<ImageTemplate>)
Public Method | RemoveRange | Removes a range of elements from the List. (Inherited from dotnetCART.ListBase<ImageTemplate>)
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<ImageTemplate>)
Public Method | Save | Saves all the images setting to the configration File.
Top

See Also

Reference

ImageTemplates Class
dotnetCART Namespace


%%PageItemTitle%%

GetID Method
[image]
dotnetCART Namespace > ImageTemplates Class : GetID Method

name
The name of the template.
Gets the id of the template.

Syntax

Visual Basic (Declaration)
Public Function GetID( _
   ByVal name As String _
) As Long
C#
public long GetID(
   string name
)

Parameters

name
The name of the template.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplates Class
ImageTemplates Members


%%PageItemTitle%%

GetName Method
[image]
dotnetCART Namespace > ImageTemplates Class : GetName Method

id
The id of the template.
Gets the name of the template.

Syntax

Visual Basic (Declaration)
Public Function GetName( _
   ByVal id As Long _
) As String
C#
public string GetName(
   long id
)

Parameters

id
The id of the template.

Return Value

Returns the name of the template or empty string.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplates Class
ImageTemplates Members


%%PageItemTitle%%

GetTemplate Method
[image]
dotnetCART Namespace > ImageTemplates Class : GetTemplate Method

name
The name of the template.
Gets the image template.

Syntax

Visual Basic (Declaration)
Public Function GetTemplate( _
   ByVal name As String _
) As ImageTemplate
C#
public ImageTemplate GetTemplate(
   string name
)

Parameters

name
The name of the template.

Return Value

Returns the image template object or null.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplates Class
ImageTemplates Members


%%PageItemTitle%%

Load Method
[image]
dotnetCART Namespace > ImageTemplates Class : Load Method

Loads all the images setting from the configration File.

Syntax

Visual Basic (Declaration)
Public Function Load() As Boolean
C#
public bool Load()

Return Value

A Boolean indicates whether the operation is successful or not.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplates Class
ImageTemplates Members


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > ImageTemplates Class : LoadDB Method

Loads all the imageTemplates from ImageTemplates table.

Overload List

Overload | Description
LoadDB() | Loads all the imageTemplates from ImageTemplates table.
LoadDB(Where) | Loads all the items from its associated table based on the where clause. (Inherited from dotnetCART.ListBase<ImageTemplate>)
LoadDB(Int32,Int32) | Loads the count number of elements from start value. (Inherited from dotnetCART.ListBase<ImageTemplate>)
LoadDB(Where,Int32,Int32,String,OrderDirection) | Loads all the items based on the parameters. (Inherited from dotnetCART.ListBase<ImageTemplate>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplates Class
ImageTemplates Members


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > ImageTemplates Class > LoadDB Method : LoadDB() Method

Loads all the imageTemplates from ImageTemplates table.

Syntax

Visual Basic (Declaration)
Public Overloads Function LoadDB() As Integer
C#
public int LoadDB()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplates Class
ImageTemplates Members
Overload List


%%PageItemTitle%%

Save Method
[image]
dotnetCART Namespace > ImageTemplates Class : Save Method

Saves all the images setting to the configration File.

Syntax

Visual Basic (Declaration)
Public Function Save() As Boolean
C#
public bool Save()

Return Value

A Boolean indicates whether the operation is successful or not.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplates Class
ImageTemplates Members


%%PageItemTitle%% $$Properties$$

ImageTemplates Class Properties
[image]
dotnetCART Namespace : ImageTemplates Class

For a list of all members of this type, see ImageTemplates members.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from dotnetCART.ListBase<ImageTemplate>)
Public Property | Count | Gets the number of elements actually contained in the collection. (Inherited from dotnetCART.ListBase<ImageTemplate>)
Public Property | Error | Returns an object with the error information. (Inherited from dotnetCART.ListBase<ImageTemplate>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from dotnetCART.ListBase<ImageTemplate>)
Public Property | Path | The related path for store images.
Public Property | PathStoreAdmin | The related path for the StoreAdmin images.
Top

See Also

Reference

ImageTemplates Class
dotnetCART Namespace


%%PageItemTitle%%

Path Property
[image]
dotnetCART Namespace > ImageTemplates Class : Path Property

The related path for store images.

Syntax

Visual Basic (Declaration)
Public Property Path As String
C#
public string Path {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplates Class
ImageTemplates Members


%%PageItemTitle%%

PathStoreAdmin Property
[image]
dotnetCART Namespace > ImageTemplates Class : PathStoreAdmin Property

The related path for the StoreAdmin images.

Syntax

Visual Basic (Declaration)
Public Property PathStoreAdmin As String
C#
public string PathStoreAdmin {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplates Class
ImageTemplates Members


%%PageItemTitle%%

IPCheker Class
See Also Members
[image]
dotnetCART Namespace : IPCheker Class

Syntax

Visual Basic (Declaration)
Private Class IPCheker
C#
private class IPCheker

Inheritance Hierarchy

System.Object
dotnetCART.IPCheker

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

IPCheker Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

IPCheker Class Members
See Also Methods
[image]
dotnetCART Namespace : IPCheker Class

The following tables list the members exposed by IPCheker.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetResult |
Top

See Also

Reference

IPCheker Class
dotnetCART Namespace


%%PageItemTitle%% $$Methods$$

IPCheker Class Methods
[image]
dotnetCART Namespace : IPCheker Class

For a list of all members of this type, see IPCheker members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetResult |
Top

See Also

Reference

IPCheker Class
dotnetCART Namespace


%%PageItemTitle%%

GetResult Method
[image]
dotnetCART Namespace > IPCheker Class : GetResult Method

ip

Syntax

Visual Basic (Declaration)
Public Shared Function GetResult( _
   ByVal ip As String _
) As ParseResult
C#
public static ParseResult GetResult(
   string ip
)

Parameters

ip

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

IPCheker Class
IPCheker Members


%%PageItemTitle%%

Item Class
See Also Members
[image]
dotnetCART Namespace : Item Class

Represents an Item object.

Object Model

Syntax

Visual Basic (Declaration)
Public Class Item
   Inherits DbTableCart(Of Item, String)
C#
public class Item : DbTableCart<Item, string>

Inheritance Hierarchy

System.Object
dotnetDATA.DbTable<String>
dotnetDATA.DbTable<Item, String>
dotnetCART.DbTableCart<Item, String>
dotnetCART.Item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

Item Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : Item Class

The following tables list the members exposed by Item.

Public Constructors

 | Name | Description
Public Constructor | Item Constructor | Initializes a new instance of the Item class.
Top

Public Properties

 | Name | Description
Public Property | Address | The shipping address. It is used when adding an item to cart. If it is not set, Cart.ShipAddressis being used.
Public Property | AddressIndex | The zero base index of the shipping address for this item in the Cart.Customer.Addresses collection. If it is negative, it means it is not set, therefore, the shipping address for this item is Cart.ShipAddress
Public Property | Adjust | Total adjustment, this property returns an amount.
Public Property | AdjustedPrice | Get the ajusted price which is Price plus AdjustPerItem.
Public Property | AdjustPerItem | Get the adjust price per unit.
Public Property | AdjustRate | Formula for item level price adjustments on quantity / price. This formula accepts quantity and price ranges and adjusts based on a fixed amount or percentage. Ranges can be defined as quantity (1-10), dollars ($1-10) and also support open ended ranges e.g. 10 and up (10-). Adjustments can also be made as surcharges by using "+" rather than "-".
Public Property | AdjustTaxable | Determines whether the tax should be apply to adjust or not.
Public Property | Categories | The categories this item is belong to them.
Public Property | CategoryID | Gets or sets the item current category ID.
Public Property | CategoryName | Gets or sets the item current category name.
Public Property | Cost | Gets or sets the item cost.
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<Item, String>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<Item, String>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<Item, String>)
Public Property | Description | Gets or sets the item description.
Public Property | DescriptionShort | Gets or sets the item short description.
Public Property | Disabled | Determines whether this item is disabled or not.
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<Item, String>)
Public Property | ID | Overridden. Gets or sets the item ID.
Public Property | Images | A reference to the Images object collection. By default, when calling any LoadDB method, the following 6 images type loaded to this collection: CartImage, ThumbnailImage, DetailsImage, ZoomImage, OriginalImage and IconImage. You can use Images.GetImageUrl or Images.GetImage for getting an image by name. String imageUrl = Item.Images.GetImageUrl("CartImage"); dotnetCART.Image imageObj = Item.Images.GetImageUrl("CartImage");
Public Property | ItemRelationships | A references to ItemRelationships collection.
Public Property | Limit | The quantity limit for this item.
Public Property | Name | Gets or sets the item name.
Public Property | Option | It is used to add an option to Options collection.
Public Property | OptionAdjust | The total price adjustment for all options for a given item. Populated after a Calculate method call.
Public Property | OptionAdjustWeight | The total weight adjustment for all options for a given item. Populated after a Calculate method call.
Public Property | Options | A collection of options for this item.
Public Property | Price | Gets or sets the item price.
Public Property | Prices | A collection of prices for this item.
Public Property | Quantity | Gets or sets the item quantity.
Public Property | ReOrder | Gets or sets a quantity threshold for re-ordering this item.
Public Property | Sequence | Sets or gets the item seuence in each Category.
Public Property | SoftGoodFileName | Gets or sets the item softgood file name.
Public Property | SoldIndividually | Determines whether this item can be sold individually or only in a bundle.
Public Property | Stock | The number of the item available in the stock.
Public Property | SubItemMappings | A reference to SubItemMappings object.
Public Property | SubTotal | Gets the item sub total which is price * quantity.
Public Property | Supplier | The supplier for this item.
Public Property | Tax | It is used to add a tax to Taxes collection.
Public Property | Taxes | A collection of taxes for this item.
Public Property | Total | Gets the item total which is (Price * Quantity) + Adjust.
Public Property | TotalTax | The total tax for this item. It adds all the Tax.Total in Taxes collection. For calculating tax, Cart.Calculate method should be called.
Public Property | URL | The URL for a given items details. This information is passed from the catalog control and passed as itemurl in the forms collection with an addtocart request.
Public Property | Weight | Gets or sets the item weight.
Top

Public Methods

 | Name | Description
Public Method | AddDB | Overloaded. Maps the related item with the specified relationship by adding to ItemRelationships table.
Public Method | CalculateTotal | Calculates the item total amount which is (Price * Quantity) + Adjust.
Public Method | CalculateTotalWeight | Calculates the item total weight which is (quantity * (weight + optionAdjustWeight))
Public Method | Clear | Initializes all the properties without recreating the object.
Public Method | Clone | Creates a copy of the current Item
Public Method | DeleteDB | Overloaded. Deletes the related item with the specified relationship from ItemRelationships table.
Public Method | Equals | Overloaded.
Public Method | GetCategoryIdDB | Get the categoryID this item belongs to it. If this item belongs to more than one categories, it only returns one of them.
Public Method | GetCategoryIdsDB | Get the list of categoryIDs this item belongs to them.
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<Item, String>)
Public Method | GetCustomersAlsoBoughtDB | Returns the other items from the customers who bought this item.
Public Method | GetHtml | Overloaded. Returns an HTML formatted string for "itemURL" and "item_ID" for adding multiple itmes.
Public Method | GetItemsDB | Returns all the items with the specified relationship like Related and Suggested items for this item.
Public Method | GetOption | Return the value for specified option name.
Public Method | GetSubItemsDB | Returns all the items associated with this item.
Public Method | LoadCustomersAlsoBoughtDB | Returns the other items from the customers who bought this item.
Public Method | LoadDB | Overloaded. Loads this item form Items table. If an item with this ID not found and Name property is set, it loads the item with the Name.
Public Method | LoadOptionsDB | Loads the item options from database.
Public Method | SaveDB | Overloaded. Overridden. Inserts or updates this object into the Items table.
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<Item, String>)
Public Method | UpdateDB | Update this item.
Top

See Also

Reference

Item Class
dotnetCART Namespace


%%PageItemTitle%%

Item Constructor
[image]
dotnetCART Namespace > Item Class : Item Constructor

Initializes a new instance of the Item class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Item()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%% $$Methods$$

Item Class Methods
[image]
dotnetCART Namespace : Item Class

For a list of all members of this type, see Item members.

Public Methods

 | Name | Description
Public Method | AddDB | Overloaded. Maps the related item with the specified relationship by adding to ItemRelationships table.
Public Method | CalculateTotal | Calculates the item total amount which is (Price * Quantity) + Adjust.
Public Method | CalculateTotalWeight | Calculates the item total weight which is (quantity * (weight + optionAdjustWeight))
Public Method | Clear | Initializes all the properties without recreating the object.
Public Method | Clone | Creates a copy of the current Item
Public Method | DeleteDB | Overloaded. Deletes the related item with the specified relationship from ItemRelationships table.
Public Method | Equals | Overloaded.
Public Method | GetCategoryIdDB | Get the categoryID this item belongs to it. If this item belongs to more than one categories, it only returns one of them.
Public Method | GetCategoryIdsDB | Get the list of categoryIDs this item belongs to them.
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<Item, String>)
Public Method | GetCustomersAlsoBoughtDB | Returns the other items from the customers who bought this item.
Public Method | GetHtml | Overloaded. Returns an HTML formatted string for "itemURL" and "item_ID" for adding multiple itmes.
Public Method | GetItemsDB | Returns all the items with the specified relationship like Related and Suggested items for this item.
Public Method | GetOption | Return the value for specified option name.
Public Method | GetSubItemsDB | Returns all the items associated with this item.
Public Method | LoadCustomersAlsoBoughtDB | Returns the other items from the customers who bought this item.
Public Method | LoadDB | Overloaded. Loads this item form Items table. If an item with this ID not found and Name property is set, it loads the item with the Name.
Public Method | LoadOptionsDB | Loads the item options from database.
Public Method | SaveDB | Overloaded. Overridden. Inserts or updates this object into the Items table.
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<Item, String>)
Public Method | UpdateDB | Update this item.
Top

See Also

Reference

Item Class
dotnetCART Namespace


%%PageItemTitle%%

AddDB Method
[image]
dotnetCART Namespace > Item Class : AddDB Method

Maps the related item with the specified relationship by adding to ItemRelationships table.

Overload List

Overload | Description
AddDB(String,String) | Maps the related item with the specified relationship by adding to ItemRelationships table.
AddDB() | Add this item to Items table.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

AddDB(String,String) Method
[image]
dotnetCART Namespace > Item Class > AddDB Method : AddDB(String,String) Method

relatedItemID
relationship
Maps the related item with the specified relationship by adding to ItemRelationships table.

Syntax

Visual Basic (Declaration)
Public Overloads Function AddDB( _
   ByVal relatedItemID As String, _
   ByVal relationship As String _
) As Integer
C#
public int AddDB(
   string relatedItemID,
   string relationship
)

Parameters

relatedItemID
relationship

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members
Overload List


%%PageItemTitle%%

AddDB() Method
[image]
dotnetCART Namespace > Item Class > AddDB Method : AddDB() Method

Add this item to Items table.

Syntax

Visual Basic (Declaration)
Public Overloads Function AddDB() As Integer
C#
public int AddDB()

Return Value

Returns 1 for the success, and -1 if failed. For the reason of fail, check the Error property.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members
Overload List


%%PageItemTitle%%

CalculateTotal Method
[image]
dotnetCART Namespace > Item Class : CalculateTotal Method

Calculates the item total amount which is (Price * Quantity) + Adjust.

Syntax

Visual Basic (Declaration)
Public Function CalculateTotal() As Decimal
C#
public decimal CalculateTotal()

Return Value

Returns item total amount.

Remarks

It is used when the item is in the shopping cart. This method doesn't calculate Adjust using AdjustRate, Cart.Calculate method should be called for calcuating item adjust using AdjustRate property.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

CalculateTotalWeight Method
[image]
dotnetCART Namespace > Item Class : CalculateTotalWeight Method

Calculates the item total weight which is (quantity * (weight + optionAdjustWeight))

Syntax

Visual Basic (Declaration)
Public Function CalculateTotalWeight() As Double
C#
public double CalculateTotalWeight()

Return Value

Returns item total weight.

Remarks

It is used when the item is in the shopping cart.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > Item Class : Clear Method

Initializes all the properties without recreating the object.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

Clone Method
[image]
dotnetCART Namespace > Item Class : Clone Method

Creates a copy of the current Item

Syntax

Visual Basic (Declaration)
Public Function Clone() As Item
C#
public Item Clone()

Return Value

Returns an Item object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

DeleteDB Method
[image]
dotnetCART Namespace > Item Class : DeleteDB Method

Deletes the related item with the specified relationship from ItemRelationships table.

Overload List

Overload | Description
DeleteDB(String,String) | Deletes the related item with the specified relationship from ItemRelationships table.
DeleteDB() | Delete this Item and all the records for this item in ItemCategories table.
DeleteDB(DbManager) | (Inherited from dotnetDATA.DbTable<String>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

DeleteDB(String,String) Method
[image]
dotnetCART Namespace > Item Class > DeleteDB Method : DeleteDB(String,String) Method

relatedItemID
relationship
Deletes the related item with the specified relationship from ItemRelationships table.

Syntax

Visual Basic (Declaration)
Public Overloads Function DeleteDB( _
   ByVal relatedItemID As String, _
   ByVal relationship As String _
) As Integer
C#
public int DeleteDB(
   string relatedItemID,
   string relationship
)

Parameters

relatedItemID
relationship

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members
Overload List


%%PageItemTitle%%

DeleteDB() Method
[image]
dotnetCART Namespace > Item Class > DeleteDB Method : DeleteDB() Method

Delete this Item and all the records for this item in ItemCategories table.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function DeleteDB() As Integer
C#
public override int DeleteDB()

Return Value

In case of error -1, check Error property, otherwise the number of records deleted.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members
Overload List


%%PageItemTitle%%

Equals Method
[image]
dotnetCART Namespace > Item Class : Equals Method

Overload List

Overload | Description
Equals(Item) |

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

Equals(Item) Method
[image]
dotnetCART Namespace > Item Class > Equals Method : Equals(Item) Method

itemObj

Syntax

Visual Basic (Declaration)
Public Overloads Function Equals( _
   ByVal itemObj As Item _
) As Boolean
C#
public bool Equals(
   Item itemObj
)

Parameters

itemObj

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members
Overload List


%%PageItemTitle%%

GetCategoryIdDB Method
[image]
dotnetCART Namespace > Item Class : GetCategoryIdDB Method

Get the categoryID this item belongs to it. If this item belongs to more than one categories, it only returns one of them.

Syntax

Visual Basic (Declaration)
Public Function GetCategoryIdDB() As Long
C#
public long GetCategoryIdDB()

Return Value

Returns the categoryID.

Remarks

If the item belongs to more than one category, useGetCategoryIdsDB to get a list of all category ids.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

GetCategoryIdsDB Method
[image]
dotnetCART Namespace > Item Class : GetCategoryIdsDB Method

Get the list of categoryIDs this item belongs to them.

Syntax

Visual Basic (Declaration)
Public Function GetCategoryIdsDB() As List(Of Long)
C#
public List<long> GetCategoryIdsDB()

Return Value

Returns a list of one or more categoryIDs.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

GetCustomersAlsoBoughtDB Method
[image]
dotnetCART Namespace > Item Class : GetCustomersAlsoBoughtDB Method

Returns the other items from the customers who bought this item.

Syntax

Visual Basic (Declaration)
Public Function GetCustomersAlsoBoughtDB() As List(Of Item)
C#
public List<Item> GetCustomersAlsoBoughtDB()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

GetHtml Method
[image]
dotnetCART Namespace > Item Class : GetHtml Method

Returns an HTML formatted string for "itemURL" and "item_ID" for adding multiple itmes.

Overload List

Overload | Description
GetHtml() |
GetHtml(Int32) | Returns an HTML formatted string for "itemURL" and "item_ID" for adding multiple itmes.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

GetHtml() Method
[image]
dotnetCART Namespace > Item Class > GetHtml Method : GetHtml() Method

Syntax

Visual Basic (Declaration)
Public Overloads Function GetHtml() As String
C#
public string GetHtml()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members
Overload List


%%PageItemTitle%%

GetHtml(Int32) Method
[image]
dotnetCART Namespace > Item Class > GetHtml Method : GetHtml(Int32) Method

itemIndex
Returns an HTML formatted string for "itemURL" and "item_ID" for adding multiple itmes.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetHtml( _
   ByVal itemIndex As Integer _
) As String
C#
public string GetHtml(
   int itemIndex
)

Parameters

itemIndex

Remarks

  Usually this method used when iterating though an items collection with item.MutiAdd is true.
  ItemIndex should starts from 1 and increments by one for the next call.
Int ItemIndex=0;
foreach(Item it in CartObject.Catalog.Category.Items)
{
     ItemIndex++;
     Response.Write (GetHtml ());
}
It generates a string like this:
<input type='hidden' name='ItemURL' value='/cart/catalog.aspx?CategoryID=6 />
<Input type='hidden' name='Item1_ID' Value='rose101'/>
<Input type='hidden' name='Item2_ID' Value='rose102'/>
<Input type='hidden' name='Item3_ID' Value='rose103'/>

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members
Overload List


%%PageItemTitle%%

GetItemsDB Method
[image]
dotnetCART Namespace > Item Class : GetItemsDB Method

relationship
Returns all the items with the specified relationship like Related and Suggested items for this item.

Syntax

Visual Basic (Declaration)
Public Function GetItemsDB( _
   ByVal relationship As String _
) As List(Of Item)
C#
public List<Item> GetItemsDB(
   string relationship
)

Parameters

relationship

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

GetOption Method
[image]
dotnetCART Namespace > Item Class : GetOption Method

name
The option name.
Return the value for specified option name.

Syntax

Visual Basic (Declaration)
Public Function GetOption( _
   ByVal name As String _
) As String
C#
public string GetOption(
   string name
)

Parameters

name
The option name.

Return Value

The option value.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

GetSubItemsDB Method
[image]
dotnetCART Namespace > Item Class : GetSubItemsDB Method

Returns all the items associated with this item.

Syntax

Visual Basic (Declaration)
Public Function GetSubItemsDB() As List(Of Item)
C#
public List<Item> GetSubItemsDB()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

LoadCustomersAlsoBoughtDB Method
[image]
dotnetCART Namespace > Item Class : LoadCustomersAlsoBoughtDB Method

itemID
Returns the other items from the customers who bought this item.

Syntax

Visual Basic (Declaration)
Public Function LoadCustomersAlsoBoughtDB( _
   ByVal itemID As String _
) As List(Of Item)
C#
public List<Item> LoadCustomersAlsoBoughtDB(
   string itemID
)

Parameters

itemID

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > Item Class : LoadDB Method

Loads this item form Items table. If an item with this ID not found and Name property is set, it loads the item with the Name.

Overload List

Overload | Description
LoadDB() | Loads this item form Items table. If an item with this ID not found and Name property is set, it loads the item with the Name.
LoadDB(String) | Loads this item form Items table.
LoadDB(String,Int64) | Loads this item form Items table.
Generic LoadDB() | (Inherited from dotnetDATA.DbTable<String>)
Generic LoadDB(DbManager) | (Inherited from dotnetDATA.DbTable<String>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > Item Class > LoadDB Method : LoadDB() Method

Loads this item form Items table. If an item with this ID not found and Name property is set, it loads the item with the Name.

Syntax

Visual Basic (Declaration)
Public Overloads Function LoadDB() As Integer
C#
public int LoadDB()

Return Value

Returns 1 for the success, and -1 if failed. For the reason of fail, check the Error property.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members
Overload List


%%PageItemTitle%%

LoadDB(String) Method
[image]
dotnetCART Namespace > Item Class > LoadDB Method : LoadDB(String) Method

itemID
The ID for the item is loaded.
Loads this item form Items table.

Syntax

Visual Basic (Declaration)
Public Overloads Function LoadDB( _
   ByVal itemID As String _
) As Integer
C#
public int LoadDB(
   string itemID
)

Parameters

itemID
The ID for the item is loaded.

Return Value

Returns 1 for the success, and -1 if failed. For the reason of fail, check the Error property.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members
Overload List


%%PageItemTitle%%

LoadDB(String,Int64) Method
[image]
dotnetCART Namespace > Item Class > LoadDB Method : LoadDB(String,Int64) Method

itemID
The ID for the item is loaded.
categoryID
It is used to update NavigationList.
Loads this item form Items table.

Syntax

Visual Basic (Declaration)
Public Overloads Function LoadDB( _
   ByVal itemID As String, _
   ByVal categoryID As Long _
) As Integer
C#
public int LoadDB(
   string itemID,
   long categoryID
)

Parameters

itemID
The ID for the item is loaded.
categoryID
It is used to update NavigationList.

Return Value

Returns 1 for the success, and -1 if failed. For the reason of fail, check the Error property.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members
Overload List


%%PageItemTitle%%

LoadOptionsDB Method
[image]
dotnetCART Namespace > Item Class : LoadOptionsDB Method

Loads the item options from database.

Syntax

Visual Basic (Declaration)
Public Function LoadOptionsDB() As Integer
C#
public int LoadOptionsDB()

Return Value

Total number of options loaded from database.

Remarks

It ignors the options with the same ID already exist in Options.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

SaveDB Method
[image]
dotnetCART Namespace > Item Class : SaveDB Method

Inserts or updates this object into the Items table.

Overload List

Overload | Description
SaveDB() | Inserts or updates this object into the Items table.
SaveDB(DbManager) | (Inherited from dotnetDATA.DbTable<String>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

SaveDB() Method
[image]
dotnetCART Namespace > Item Class > SaveDB Method : SaveDB() Method

Inserts or updates this object into the Items table.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function SaveDB() As Integer
C#
public override int SaveDB()

Return Value

Returns 1 for the success, and -1 if failed. For the reason of fail, check the Error property.

Remarks

If an item with this ID found, it updates the associated record in the table, otherwise inserts a new record. If ID is empty, it creates an id automatically.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members
Overload List


%%PageItemTitle%%

UpdateDB Method
[image]
dotnetCART Namespace > Item Class : UpdateDB Method

Update this item.

Syntax

Visual Basic (Declaration)
Public Function UpdateDB() As Integer
C#
public int UpdateDB()

Return Value

Returns 1 for the success, and -1 if failed. For the reason of fail, check the Error property.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%% $$Properties$$

Item Class Properties
[image]
dotnetCART Namespace : Item Class

For a list of all members of this type, see Item members.

Public Properties

 | Name | Description
Public Property | Address | The shipping address. It is used when adding an item to cart. If it is not set, Cart.ShipAddressis being used.
Public Property | AddressIndex | The zero base index of the shipping address for this item in the Cart.Customer.Addresses collection. If it is negative, it means it is not set, therefore, the shipping address for this item is Cart.ShipAddress
Public Property | Adjust | Total adjustment, this property returns an amount.
Public Property | AdjustedPrice | Get the ajusted price which is Price plus AdjustPerItem.
Public Property | AdjustPerItem | Get the adjust price per unit.
Public Property | AdjustRate | Formula for item level price adjustments on quantity / price. This formula accepts quantity and price ranges and adjusts based on a fixed amount or percentage. Ranges can be defined as quantity (1-10), dollars ($1-10) and also support open ended ranges e.g. 10 and up (10-). Adjustments can also be made as surcharges by using "+" rather than "-".
Public Property | AdjustTaxable | Determines whether the tax should be apply to adjust or not.
Public Property | Categories | The categories this item is belong to them.
Public Property | CategoryID | Gets or sets the item current category ID.
Public Property | CategoryName | Gets or sets the item current category name.
Public Property | Cost | Gets or sets the item cost.
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<Item, String>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<Item, String>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<Item, String>)
Public Property | Description | Gets or sets the item description.
Public Property | DescriptionShort | Gets or sets the item short description.
Public Property | Disabled | Determines whether this item is disabled or not.
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<Item, String>)
Public Property | ID | Overridden. Gets or sets the item ID.
Public Property | Images | A reference to the Images object collection. By default, when calling any LoadDB method, the following 6 images type loaded to this collection: CartImage, ThumbnailImage, DetailsImage, ZoomImage, OriginalImage and IconImage. You can use Images.GetImageUrl or Images.GetImage for getting an image by name. String imageUrl = Item.Images.GetImageUrl("CartImage"); dotnetCART.Image imageObj = Item.Images.GetImageUrl("CartImage");
Public Property | ItemRelationships | A references to ItemRelationships collection.
Public Property | Limit | The quantity limit for this item.
Public Property | Name | Gets or sets the item name.
Public Property | Option | It is used to add an option to Options collection.
Public Property | OptionAdjust | The total price adjustment for all options for a given item. Populated after a Calculate method call.
Public Property | OptionAdjustWeight | The total weight adjustment for all options for a given item. Populated after a Calculate method call.
Public Property | Options | A collection of options for this item.
Public Property | Price | Gets or sets the item price.
Public Property | Prices | A collection of prices for this item.
Public Property | Quantity | Gets or sets the item quantity.
Public Property | ReOrder | Gets or sets a quantity threshold for re-ordering this item.
Public Property | Sequence | Sets or gets the item seuence in each Category.
Public Property | SoftGoodFileName | Gets or sets the item softgood file name.
Public Property | SoldIndividually | Determines whether this item can be sold individually or only in a bundle.
Public Property | Stock | The number of the item available in the stock.
Public Property | SubItemMappings | A reference to SubItemMappings object.
Public Property | SubTotal | Gets the item sub total which is price * quantity.
Public Property | Supplier | The supplier for this item.
Public Property | Tax | It is used to add a tax to Taxes collection.
Public Property | Taxes | A collection of taxes for this item.
Public Property | Total | Gets the item total which is (Price * Quantity) + Adjust.
Public Property | TotalTax | The total tax for this item. It adds all the Tax.Total in Taxes collection. For calculating tax, Cart.Calculate method should be called.
Public Property | URL | The URL for a given items details. This information is passed from the catalog control and passed as itemurl in the forms collection with an addtocart request.
Public Property | Weight | Gets or sets the item weight.
Top

See Also

Reference

Item Class
dotnetCART Namespace


%%PageItemTitle%%

Address Property
[image]
dotnetCART Namespace > Item Class : Address Property

The shipping address. It is used when adding an item to cart. If it is not set, Cart.ShipAddressis being used.

Syntax

Visual Basic (Declaration)
Public Property Address As Address
C#
public Address Address {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

AddressIndex Property
[image]
dotnetCART Namespace > Item Class : AddressIndex Property

The zero base index of the shipping address for this item in the Cart.Customer.Addresses collection. If it is negative, it means it is not set, therefore, the shipping address for this item is Cart.ShipAddress

Syntax

Visual Basic (Declaration)
Public Property AddressIndex As Integer
C#
public int AddressIndex {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

Adjust Property
[image]
dotnetCART Namespace > Item Class : Adjust Property

Total adjustment, this property returns an amount.

Syntax

Visual Basic (Declaration)
Public Property Adjust As Decimal
C#
public decimal Adjust {get; set;}

Remarks

The adjust amount is calculated by Cart.Calculate method using AdjustRate property.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

AdjustedPrice Property
[image]
dotnetCART Namespace > Item Class : AdjustedPrice Property

Get the ajusted price which is Price plus AdjustPerItem.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AdjustedPrice As Decimal
C#
public decimal AdjustedPrice {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

AdjustPerItem Property
[image]
dotnetCART Namespace > Item Class : AdjustPerItem Property

Get the adjust price per unit.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AdjustPerItem As Decimal
C#
public decimal AdjustPerItem {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

AdjustRate Property
See Also Example
[image]
dotnetCART Namespace > Item Class : AdjustRate Property

Formula for item level price adjustments on quantity / price. This formula accepts quantity and price ranges and adjusts based on a fixed amount or percentage. Ranges can be defined as quantity (1-10), dollars ($1-10) and also support open ended ranges e.g. 10 and up (10-). Adjustments can also be made as surcharges by using "+" rather than "-".

Syntax

Visual Basic (Declaration)
Public Property AdjustRate As String
C#
public string AdjustRate {get; set;}

Example

C# Copy Code
Item.AdjustRate = "$1=-10%;$2=-20%;$3=-30%;";
Item.AdjustRate = "1=-10%;$2=-20%;3-=-30%;";
Item.AdjustRate = "1=10;2=20;3=30;4-100=35;101-=40;";

Visual Basic Copy Code
Item.AdjustRate = "$1=-10%;$2=-20%;$3=-30%;"
Item.AdjustRate = "1=-10%;$2=-20%;3-=-30%;"
Item.AdjustRate = "1=10;2=20;3=30;4-100=35;101-=40;"

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

AdjustTaxable Property
[image]
dotnetCART Namespace > Item Class : AdjustTaxable Property

Determines whether the tax should be apply to adjust or not.

Syntax

Visual Basic (Declaration)
Public Property AdjustTaxable As Boolean
C#
public bool AdjustTaxable {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

Categories Property
[image]
dotnetCART Namespace > Item Class : Categories Property

The categories this item is belong to them.

Syntax

Visual Basic (Declaration)
Public Property Categories As Categories
C#
public Categories Categories {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

CategoryID Property
[image]
dotnetCART Namespace > Item Class : CategoryID Property

Gets or sets the item current category ID.

Syntax

Visual Basic (Declaration)
Public Property CategoryID As Long
C#
public long CategoryID {get; set;}

Remarks

When invoking LoadDB, it is not set automatically from database because an item can be belongs to more than one Category. GetCategoryIdDB returns one of the categoryID.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

CategoryName Property
[image]
dotnetCART Namespace > Item Class : CategoryName Property

Gets or sets the item current category name.

Syntax

Visual Basic (Declaration)
Public Property CategoryName As String
C#
public string CategoryName {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

Cost Property
[image]
dotnetCART Namespace > Item Class : Cost Property

Gets or sets the item cost.

Syntax

Visual Basic (Declaration)
Public Property Cost As Nullable(Of Decimal)
C#
public Nullable<decimal> Cost {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

Description Property
[image]
dotnetCART Namespace > Item Class : Description Property

Gets or sets the item description.

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

DescriptionShort Property
[image]
dotnetCART Namespace > Item Class : DescriptionShort Property

Gets or sets the item short description.

Syntax

Visual Basic (Declaration)
Public Property DescriptionShort As String
C#
public string DescriptionShort {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

Disabled Property
[image]
dotnetCART Namespace > Item Class : Disabled Property

Determines whether this item is disabled or not.

Syntax

Visual Basic (Declaration)
Public Property Disabled As Boolean
C#
public bool Disabled {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

ID Property
[image]
dotnetCART Namespace > Item Class : ID Property

Gets or sets the item ID.

Syntax

Visual Basic (Declaration)
Public Overrides Property ID As String
C#
public override string ID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

Images Property
[image]
dotnetCART Namespace > Item Class : Images Property

A reference to the Images object collection. By default, when calling any LoadDB method, the following 6 images type loaded to this collection: CartImage, ThumbnailImage, DetailsImage, ZoomImage, OriginalImage and IconImage. You can use Images.GetImageUrl or Images.GetImage for getting an image by name. String imageUrl = Item.Images.GetImageUrl("CartImage"); dotnetCART.Image imageObj = Item.Images.GetImageUrl("CartImage");

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Images As Images
C#
public Images Images {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

ItemRelationships Property
[image]
dotnetCART Namespace > Item Class : ItemRelationships Property

A references to ItemRelationships collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ItemRelationships As List(Of ItemRelationships)
C#
public List<ItemRelationships> ItemRelationships {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

Limit Property
[image]
dotnetCART Namespace > Item Class : Limit Property

The quantity limit for this item.

Syntax

Visual Basic (Declaration)
Public Property Limit As String
C#
public string Limit {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

Name Property
[image]
dotnetCART Namespace > Item Class : Name Property

Gets or sets the item name.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

Option Property
[image]
dotnetCART Namespace > Item Class : Option Property

It is used to add an option to Options collection.

Syntax

Visual Basic (Declaration)
Public Property Option As Option
C#
public Option Option {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

OptionAdjust Property
[image]
dotnetCART Namespace > Item Class : OptionAdjust Property

The total price adjustment for all options for a given item. Populated after a Calculate method call.

Syntax

Visual Basic (Declaration)
Public Property OptionAdjust As Decimal
C#
public decimal OptionAdjust {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

OptionAdjustWeight Property
[image]
dotnetCART Namespace > Item Class : OptionAdjustWeight Property

The total weight adjustment for all options for a given item. Populated after a Calculate method call.

Syntax

Visual Basic (Declaration)
Public Property OptionAdjustWeight As Double
C#
public double OptionAdjustWeight {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

Options Property
[image]
dotnetCART Namespace > Item Class : Options Property

A collection of options for this item.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Options As Options
C#
public Options Options {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

Price Property
[image]
dotnetCART Namespace > Item Class : Price Property

Gets or sets the item price.

Syntax

Visual Basic (Declaration)
Public Property Price As Nullable(Of Decimal)
C#
public Nullable<decimal> Price {get; set;}

Remarks

In LoadDB method, if there is price field associated with the Cart.Customer.Group, it is set to this property. e.g. If Cart.Customer.Group is "Whole", and WholePrice field exist in the Items table with a valid value, it is set to this property.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

Prices Property
[image]
dotnetCART Namespace > Item Class : Prices Property

A collection of prices for this item.

Syntax

Visual Basic (Declaration)
Public Property Prices As Prices
C#
public Prices Prices {get; set;}

Remarks

This property populates when loading items to the catalog using LoadDB method. For all the items in the catalog, beside the item.Price property, all the fields end with 'Price' inlcuding the 'Price' field will be added to the Item.Prices collection. Also, if Customer.Group has been set to a group and the same value exist in the items table as a filed name or 'Sale' + group exist as a filed name, the field and the value will be added to the Prices collection as well.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

Quantity Property
[image]
dotnetCART Namespace > Item Class : Quantity Property

Gets or sets the item quantity.

Syntax

Visual Basic (Declaration)
Public Property Quantity As Double
C#
public double Quantity {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

ReOrder Property
[image]
dotnetCART Namespace > Item Class : ReOrder Property

Gets or sets a quantity threshold for re-ordering this item.

Syntax

Visual Basic (Declaration)
Public Property ReOrder As Double
C#
public double ReOrder {get; set;}

Remarks

It can be used with Stockproperty for automating ordering process. StoreAdmin/Inventory/Report, shows items based on these properties.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

Sequence Property
[image]
dotnetCART Namespace > Item Class : Sequence Property

Sets or gets the item seuence in each Category.

Syntax

Visual Basic (Declaration)
Public Property Sequence As Long
C#
public long Sequence {get; set;}

Remarks

The value of this property is saved to ItemCategories table.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

SoftGoodFileName Property
[image]
dotnetCART Namespace > Item Class : SoftGoodFileName Property

Gets or sets the item softgood file name.

Syntax

Visual Basic (Declaration)
Public Property SoftGoodFileName As String
C#
public string SoftGoodFileName {get; set;}

Remarks

It is used for creating an email attachment or ticket for a softgood item like software.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

SoldIndividually Property
[image]
dotnetCART Namespace > Item Class : SoldIndividually Property

Determines whether this item can be sold individually or only in a bundle.

Syntax

Visual Basic (Declaration)
Public Property SoldIndividually As Boolean
C#
public bool SoldIndividually {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

Stock Property
[image]
dotnetCART Namespace > Item Class : Stock Property

The number of the item available in the stock.

Syntax

Visual Basic (Declaration)
Public Property Stock As Double
C#
public double Stock {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

SubItemMappings Property
[image]
dotnetCART Namespace > Item Class : SubItemMappings Property

A reference to SubItemMappings object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SubItemMappings As SubItemMappings
C#
public SubItemMappings SubItemMappings {get;}

Remarks

Sub items are optionally created based on the combinations of an item options' choices and enable setting different Prices, Images, or Stock values for each subitem variation. The sub items are the physical items and the parent item acts as a container to display the subitems as a single item with options in the store catalog. In this way, highly related items can show as a single item and provide easy to use options for selecting size, color or other variations which in the background are seamlessly mapped to the appropriate subitems. More information

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

SubTotal Property
[image]
dotnetCART Namespace > Item Class : SubTotal Property

Gets the item sub total which is price * quantity.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SubTotal As Decimal
C#
public decimal SubTotal {get;}

Remarks

It is used when the item is in the shopping cart.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

Supplier Property
[image]
dotnetCART Namespace > Item Class : Supplier Property

The supplier for this item.

Syntax

Visual Basic (Declaration)
Public Property Supplier As Supplier
C#
public Supplier Supplier {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

Tax Property
[image]
dotnetCART Namespace > Item Class : Tax Property

It is used to add a tax to Taxes collection.

Syntax

Visual Basic (Declaration)
Public Property Tax As Tax
C#
public Tax Tax {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

Taxes Property
[image]
dotnetCART Namespace > Item Class : Taxes Property

A collection of taxes for this item.

Syntax

Visual Basic (Declaration)
Public Property Taxes As Taxes
C#
public Taxes Taxes {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

Total Property
[image]
dotnetCART Namespace > Item Class : Total Property

Gets the item total which is (Price * Quantity) + Adjust.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Total As Decimal
C#
public decimal Total {get;}

Remarks

It is used when the item is in the shopping cart. Adjust is calculated by Cart.Calculate method using AdjustRate property.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

TotalTax Property
[image]
dotnetCART Namespace > Item Class : TotalTax Property

The total tax for this item. It adds all the Tax.Total in Taxes collection. For calculating tax, Cart.Calculate method should be called.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TotalTax As Decimal
C#
public decimal TotalTax {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

URL Property
[image]
dotnetCART Namespace > Item Class : URL Property

The URL for a given items details. This information is passed from the catalog control and passed as itemurl in the forms collection with an addtocart request.

Syntax

Visual Basic (Declaration)
Public Property URL As String
C#
public string URL {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

Weight Property
[image]
dotnetCART Namespace > Item Class : Weight Property

Gets or sets the item weight.

Syntax

Visual Basic (Declaration)
Public Property Weight As Double
C#
public double Weight {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

ItemRelationships Class
See Also Members
[image]
dotnetCART Namespace : ItemRelationships Class

A collection of Item objects for an ItemRelationshipType ItemRelationshipType.

Object Model

Syntax

Visual Basic (Declaration)
Public Class ItemRelationships
   Inherits ListBase(Of Item)
C#
public class ItemRelationships : ListBase<Item>

Inheritance Hierarchy

System.Object
System.Collections.Generic.List<Item>
dotnetCART.ListBase<Item>
dotnetCART.ItemRelationships

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationships Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

ItemRelationships Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : ItemRelationships Class

The following tables list the members exposed by ItemRelationships.

Public Constructors

 | Name | Description
Public Constructor | ItemRelationships Constructor | Initializes a new instance of the ItemRelationships class.
Top

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from dotnetCART.ListBase<Item>)
Public Property | Count | Gets the number of elements actually contained in the collection. (Inherited from dotnetCART.ListBase<Item>)
Public Property | Error | Returns an object with the error information. (Inherited from dotnetCART.ListBase<Item>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from dotnetCART.ListBase<Item>)
Public Property | Name | Gets or sets this ItemRelationship's name.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds an object to the end of the collection. (Inherited from dotnetCART.ListBase<Item>)
Public Method | AddRange | Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetCART.ListBase<Item>)
Public Method | AsReadOnly | Returns a read-only IList wrapper for the current collection. (Inherited from dotnetCART.ListBase<Item>)
Public Method | BinarySearch | Overloaded. (Inherited from dotnetCART.ListBase<Item>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetCART.ListBase<Item>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetCART.ListBase<Item>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<Item>)
Public Method | CopyTo | Overloaded. (Inherited from dotnetCART.ListBase<Item>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from dotnetCART.ListBase<Item>)
Public Method | IndexOf | Overloaded. (Inherited from dotnetCART.ListBase<Item>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetCART.ListBase<Item>)
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from dotnetCART.ListBase<Item>)
Public Method | LastIndexOf | Overloaded. (Inherited from dotnetCART.ListBase<Item>)
Public Method | LoadDB | Overloaded. Loads all the items from its associated table. (Inherited from dotnetCART.ListBase<Item>)
Public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from dotnetCART.ListBase<Item>)
Public Method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from dotnetCART.ListBase<Item>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetCART.ListBase<Item>)
Public Method | RemoveRange | Removes a range of elements from the List. (Inherited from dotnetCART.ListBase<Item>)
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<Item>)
Top

See Also

Reference

ItemRelationships Class
dotnetCART Namespace


%%PageItemTitle%%

ItemRelationships Constructor
[image]
dotnetCART Namespace > ItemRelationships Class : ItemRelationships Constructor

relationship
The name of the ItemRelationshipType.
Initializes a new instance of the ItemRelationships class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal relationship As String _
)
C#
public ItemRelationships(
   string relationship
)

Parameters

relationship
The name of the ItemRelationshipType.

Remarks

The name of the ItemRelationshipType must already exist in ItemRelationshipTypes.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationships Class
ItemRelationships Members


%%PageItemTitle%% $$Properties$$

ItemRelationships Class Properties
[image]
dotnetCART Namespace : ItemRelationships Class

For a list of all members of this type, see ItemRelationships members.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from dotnetCART.ListBase<Item>)
Public Property | Count | Gets the number of elements actually contained in the collection. (Inherited from dotnetCART.ListBase<Item>)
Public Property | Error | Returns an object with the error information. (Inherited from dotnetCART.ListBase<Item>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from dotnetCART.ListBase<Item>)
Public Property | Name | Gets or sets this ItemRelationship's name.
Top

See Also

Reference

ItemRelationships Class
dotnetCART Namespace


%%PageItemTitle%%

Name Property
[image]
dotnetCART Namespace > ItemRelationships Class : Name Property

Gets or sets this ItemRelationship's name.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationships Class
ItemRelationships Members


%%PageItemTitle%%

ItemRelationshipType Class
See Also Members
[image]
dotnetCART Namespace : ItemRelationshipType Class

Represents an ItemRelationshipType.

Object Model

Syntax

Visual Basic (Declaration)
Public Class ItemRelationshipType
   Inherits DbTableCart(Of ItemRelationshipType, Long)
C#
public class ItemRelationshipType : DbTableCart<ItemRelationshipType, long>

Remarks

This class defines any arbitary relations between items like Related, Suggested or Bundle.

Inheritance Hierarchy

System.Object
dotnetDATA.DbTable<Int64>
dotnetDATA.DbTable<ItemRelationshipType, Int64>
dotnetCART.DbTableCart<ItemRelationshipType, Int64>
dotnetCART.ItemRelationshipType

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationshipType Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

ItemRelationshipType Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : ItemRelationshipType Class

The following tables list the members exposed by ItemRelationshipType.

Public Constructors

 | Name | Description
Public Constructor | ItemRelationshipType Constructor | Initializes a new instance of the ItemRelationshipType.
Top

Public Properties

 | Name | Description
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<ItemRelationshipType, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<ItemRelationshipType, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<ItemRelationshipType, Int64>)
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<ItemRelationshipType, Int64>)
Public Property | ID | Overridden. The auto number ID populated from the database.
Public Property | Name | Gets or sets a unique name for an item relationship type.
Top

Public Methods

 | Name | Description
Public Method | Clear | Initializes all the properties without recreating the object. (Inherited from dotnetCART.DbTableCart<ItemRelationshipType, Int64>)
Public Method | DeleteDB | Overloaded. Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<ItemRelationshipType, Int64>)
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<ItemRelationshipType, Int64>)
Public Method | LoadDB | Overloaded. Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<ItemRelationshipType, Int64>)
Public Method | SaveDB | Overloaded. Inserts or updates this object into the database. (Inherited from dotnetCART.DbTableCart<ItemRelationshipType, Int64>)
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<ItemRelationshipType, Int64>)
Top

See Also

Reference

ItemRelationshipType Class
dotnetCART Namespace


%%PageItemTitle%%

ItemRelationshipType Constructor
[image]
dotnetCART Namespace > ItemRelationshipType Class : ItemRelationshipType Constructor

Initializes a new instance of the ItemRelationshipType.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ItemRelationshipType()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationshipType Class
ItemRelationshipType Members


%%PageItemTitle%% $$Properties$$

ItemRelationshipType Class Properties
[image]
dotnetCART Namespace : ItemRelationshipType Class

For a list of all members of this type, see ItemRelationshipType members.

Public Properties

 | Name | Description
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<ItemRelationshipType, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<ItemRelationshipType, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<ItemRelationshipType, Int64>)
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<ItemRelationshipType, Int64>)
Public Property | ID | Overridden. The auto number ID populated from the database.
Public Property | Name | Gets or sets a unique name for an item relationship type.
Top

See Also

Reference

ItemRelationshipType Class
dotnetCART Namespace


%%PageItemTitle%%

ID Property
[image]
dotnetCART Namespace > ItemRelationshipType Class : ID Property

The auto number ID populated from the database.

Syntax

Visual Basic (Declaration)
Public Overrides Property ID As Long
C#
public override long ID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationshipType Class
ItemRelationshipType Members


%%PageItemTitle%%

Name Property
[image]
dotnetCART Namespace > ItemRelationshipType Class : Name Property

Gets or sets a unique name for an item relationship type.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationshipType Class
ItemRelationshipType Members


%%PageItemTitle%%

Items Class
See Also Members
[image]
dotnetCART Namespace : Items Class

A collection of Item objects.

Object Model

Syntax

Visual Basic (Declaration)
Public Class Items
   Inherits ListBase(Of Item)
C#
public class Items : ListBase<Item>

Inheritance Hierarchy

System.Object
System.Collections.Generic.List<Item>
dotnetCART.ListBase<Item>
dotnetCART.Items

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

Items Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : Items Class

The following tables list the members exposed by Items.

Public Constructors

 | Name | Description
Public Constructor | Items Constructor | Initializes a new instance of the Items.
Top

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from dotnetCART.ListBase<Item>)
Public Property | Count | Gets the number of elements actually contained in the collection. (Inherited from dotnetCART.ListBase<Item>)
Public Property | Error | Returns an object with the error information. (Inherited from dotnetCART.ListBase<Item>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from dotnetCART.ListBase<Item>)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Add the newItem to this collection. If the same item already exist in the this collection, the newItem.Quantity is added to the quantity of the same item in the collection. If newItem.ID is empty, a random id is generated and assigned to it.
Public Method | AddRange | Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetCART.ListBase<Item>)
Public Method | AsReadOnly | Returns a read-only IList wrapper for the current collection. (Inherited from dotnetCART.ListBase<Item>)
Public Method | BinarySearch | Overloaded. (Inherited from dotnetCART.ListBase<Item>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetCART.ListBase<Item>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetCART.ListBase<Item>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<Item>)
Public Method | CopyTo | Overloaded. (Inherited from dotnetCART.ListBase<Item>)
Public Method | DeleteDB | Deletes all the items in this collection from Items table.
Public Method | GetCountDB | Overloaded. Gets the total number of items in the Items table.
Public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from dotnetCART.ListBase<Item>)
Public Method | IndexOf | Overloaded. (Inherited from dotnetCART.ListBase<Item>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetCART.ListBase<Item>)
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from dotnetCART.ListBase<Item>)
Public Method | LastIndexOf | Overloaded. (Inherited from dotnetCART.ListBase<Item>)
Public Method | LoadDB | Overloaded. Overridden. Loads all the items in home category from Items table. If this method is called through category object, it only loads the items in that category.
Public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from dotnetCART.ListBase<Item>)
Public Method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from dotnetCART.ListBase<Item>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetCART.ListBase<Item>)
Public Method | RemoveRange | Removes a range of elements from the List. (Inherited from dotnetCART.ListBase<Item>)
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<Item>)
Public Method | Sort | Overloaded. Sort items by name in this collection.
Top

See Also

Reference

Items Class
dotnetCART Namespace


%%PageItemTitle%%

Items Constructor
[image]
dotnetCART Namespace > Items Class : Items Constructor

Initializes a new instance of the Items.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Items()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members


%%PageItemTitle%% $$Methods$$

Items Class Methods
[image]
dotnetCART Namespace : Items Class

For a list of all members of this type, see Items members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Add the newItem to this collection. If the same item already exist in the this collection, the newItem.Quantity is added to the quantity of the same item in the collection. If newItem.ID is empty, a random id is generated and assigned to it.
Public Method | AddRange | Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetCART.ListBase<Item>)
Public Method | AsReadOnly | Returns a read-only IList wrapper for the current collection. (Inherited from dotnetCART.ListBase<Item>)
Public Method | BinarySearch | Overloaded. (Inherited from dotnetCART.ListBase<Item>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetCART.ListBase<Item>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetCART.ListBase<Item>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<Item>)
Public Method | CopyTo | Overloaded. (Inherited from dotnetCART.ListBase<Item>)
Public Method | DeleteDB | Deletes all the items in this collection from Items table.
Public Method | GetCountDB | Overloaded. Gets the total number of items in the Items table.
Public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from dotnetCART.ListBase<Item>)
Public Method | IndexOf | Overloaded. (Inherited from dotnetCART.ListBase<Item>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetCART.ListBase<Item>)
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from dotnetCART.ListBase<Item>)
Public Method | LastIndexOf | Overloaded. (Inherited from dotnetCART.ListBase<Item>)
Public Method | LoadDB | Overloaded. Overridden. Loads all the items in home category from Items table. If this method is called through category object, it only loads the items in that category.
Public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from dotnetCART.ListBase<Item>)
Public Method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from dotnetCART.ListBase<Item>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetCART.ListBase<Item>)
Public Method | RemoveRange | Removes a range of elements from the List. (Inherited from dotnetCART.ListBase<Item>)
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<Item>)
Public Method | Sort | Overloaded. Sort items by name in this collection.
Top

See Also

Reference

Items Class
dotnetCART Namespace


%%PageItemTitle%%

Add Method
[image]
dotnetCART Namespace > Items Class : Add Method

Add the newItem to this collection. If the same item already exist in the this collection, the newItem.Quantity is added to the quantity of the same item in the collection. If newItem.ID is empty, a random id is generated and assigned to it.

Overload List

Overload | Description
Add(Item) | Add the newItem to this collection. If the same item already exist in the this collection, the newItem.Quantity is added to the quantity of the same item in the collection. If newItem.ID is empty, a random id is generated and assigned to it.
Add(String) | Add the item with this itemID from database to this collection. This method should be called through cartObject.Items If the same item already exist in the cartObject.Items collection, the quantity of the same item in the cartObject.Items collection is increased by one.
Add(String,Int32) | Add the item with this itemID from database to this collection. This method should be called through cartObject.Items If the same item already exist in the cartObject.Items collection, the quantity is added to the quantity of the same item in the cartObject.Items collection.
Add() | Add the item in cart object item to this collection. This method should be called through cartObject.Items If the same item already exist in the cartObject.Items collection, the cartObject.Item.Quantity is added to the quantity of the same item in the cartObject.Items collection.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members


%%PageItemTitle%%

Add(Item) Method
See Also Example
[image]
dotnetCART Namespace > Items Class > Add Method : Add(Item) Method

newItem
Add the newItem to this collection. If the same item already exist in the this collection, the newItem.Quantity is added to the quantity of the same item in the collection. If newItem.ID is empty, a random id is generated and assigned to it.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal newItem As Item _
) As Integer
C#
public int Add(
   Item newItem
)

Parameters

newItem

Example

C# Copy Code
Item newItem = new Item();
newItem.Item.ID="Item1";
newItem.Item.Name="Frame";
newItem.Item.Price=4.99M;
newItem.Item.Quantity=2;
newItem.Item.Weight=1;
newItem.Item.Description="A perfect frame for pictures.";
newItem.Items.Add();

Visual Basic Copy Code
Item newItem = new Item()
newItem.Item.ID="Item1"
newItem.Item.Name="Frame"
newItem.Item.Price=4.99M
newItem.Item.Quantity=2
newItem.Item.Weight=1
newItem.Item.Description="A perfect frame for pictures."
newItem.Items.Add()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members
Overload List


%%PageItemTitle%%

Add(String) Method
See Also Example
[image]
dotnetCART Namespace > Items Class > Add Method : Add(String) Method

itemID
The itemID for the item.
Add the item with this itemID from database to this collection. This method should be called through cartObject.Items If the same item already exist in the cartObject.Items collection, the quantity of the same item in the cartObject.Items collection is increased by one.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add( _
   ByVal itemID As String _
)
C#
public void Add(
   string itemID
)

Parameters

itemID
The itemID for the item.

Example

C# Copy Code
cartObj.Items.Add("rose03943");

Visual Basic Copy Code
cartObj.Items.Add("rose03943")

Remarks

This method is usually used when adding an item to the shipping cart, and an item with the same itemID must be exist in the Items table.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members
Overload List


%%PageItemTitle%%

Add(String,Int32) Method
See Also Example
[image]
dotnetCART Namespace > Items Class > Add Method : Add(String,Int32) Method

itemID
The itemID for the item.
quantity
The quantity of the item.
Add the item with this itemID from database to this collection. This method should be called through cartObject.Items If the same item already exist in the cartObject.Items collection, the quantity is added to the quantity of the same item in the cartObject.Items collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add( _
   ByVal itemID As String, _
   ByVal quantity As Integer _
)
C#
public void Add(
   string itemID,
   int quantity
)

Parameters

itemID
The itemID for the item.
quantity
The quantity of the item.

Example

C# Copy Code
cartObj.Items.Add("rose03943", 2);

Visual Basic Copy Code
cartObj.Items.Add("rose03943", 2)

Remarks

This method is usually used when adding an item to the shipping cart, and an item with the same itemID must be exist in the Items table.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members
Overload List


%%PageItemTitle%%

Add() Method
See Also Example
[image]
dotnetCART Namespace > Items Class > Add Method : Add() Method

Add the item in cart object item to this collection. This method should be called through cartObject.Items If the same item already exist in the cartObject.Items collection, the cartObject.Item.Quantity is added to the quantity of the same item in the cartObject.Items collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add()
C#
public void Add()

Example

C# Copy Code
cartObj.Item.ID="Item1";
cartObj.Item.Name="Frame";
cartObj.Item.Price=4.99M;
cartObj.Item.Quantity=2;
cartObj.Item.Weight=1;
cartObj.Item.Description="A perfect frame for pictures.";
cartObj.Items.Add();

Visual Basic Copy Code
cartObj.Item.ID="Item1"
cartObj.Item.Name="Frame"
cartObj.Item.Price=4.99M
cartObj.Item.Quantity=2
cartObj.Item.Weight=1
cartObj.Item.Description="A perfect frame for pictures."
cartObj.Items.Add()

Remarks

This method is usually used when adding an item to the shipping cart.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members
Overload List


%%PageItemTitle%%

DeleteDB Method
[image]
dotnetCART Namespace > Items Class : DeleteDB Method

Deletes all the items in this collection from Items table.

Syntax

Visual Basic (Declaration)
Public Function DeleteDB() As Integer
C#
public int DeleteDB()

Return Value

Returns the number of items have been deleted.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members


%%PageItemTitle%%

GetCountDB Method
[image]
dotnetCART Namespace > Items Class : GetCountDB Method

Gets the total number of items in the Items table.

Overload List

Overload | Description
GetCountDB() | Gets the total number of items in the Items table.
GetCountDB(Where,Boolean) | Gets the total number of items in the Items table.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members


%%PageItemTitle%%

GetCountDB() Method
[image]
dotnetCART Namespace > Items Class > GetCountDB Method : GetCountDB() Method

Gets the total number of items in the Items table.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCountDB() As Integer
C#
public int GetCountDB()

Return Value

Returns the number of elements in the Items table.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members
Overload List


%%PageItemTitle%%

GetCountDB(Where,Boolean) Method
[image]
dotnetCART Namespace > Items Class > GetCountDB Method : GetCountDB(Where,Boolean) Method

whereClause
The where clause to filter the items.
includeDisabled
Determines whether to load disabled items or not. Defaults is false.
Gets the total number of items in the Items table.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCountDB( _
   ByVal whereClause As Where, _
   ByVal includeDisabled As Boolean _
) As Integer
C#
public int GetCountDB(
   Where whereClause,
   bool includeDisabled
)

Parameters

whereClause
The where clause to filter the items.
includeDisabled
Determines whether to load disabled items or not. Defaults is false.

Return Value

Returns the number of elements in the Items table.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members
Overload List


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > Items Class : LoadDB Method

Loads all the items in home category from Items table. If this method is called through category object, it only loads the items in that category.

Overload List

Overload | Description
LoadDB() | Loads all the items in home category from Items table. If this method is called through category object, it only loads the items in that category.
LoadDB(Int64) | Loads all the items with this category from Items table.
LoadDB(Int32,Int32) | Loads the count number of items from start value from Items table.
LoadDB(Where,Int32,Int32,String,OrderDirection) | Loads all the items based on the parameters from Items table.
LoadDB(Int64,Where,Int32,Int32,String,OrderDirection) | Loads all the items based on the parameters from Items table.
LoadDB(Int64,Where,Int32,Int32,String,OrderDirection,Boolean) | Loads all the items based on the parameters from Items table.
LoadDB(Int64,Where,Int32,Int32,String,OrderDirection,Boolean,Boolean) | Loads all the items based on the parameters from Items table.
LoadDB(Where) | Loads all the items from its associated table based on the where clause. (Inherited from dotnetCART.ListBase<Item>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > Items Class > LoadDB Method : LoadDB() Method

Loads all the items in home category from Items table. If this method is called through category object, it only loads the items in that category.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function LoadDB() As Integer
C#
public override int LoadDB()

Return Value

The total number of items have been loaded.

Remarks

If you want to load all the items regardless of category, use items.LoadDB(new dotnetDATA.Where())

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members
Overload List


%%PageItemTitle%%

LoadDB(Int64) Method
[image]
dotnetCART Namespace > Items Class > LoadDB Method : LoadDB(Int64) Method

categoryID
The categoryID for the items.
Loads all the items with this category from Items table.

Syntax

Visual Basic (Declaration)
Public Overloads Function LoadDB( _
   ByVal categoryID As Long _
) As Integer
C#
public int LoadDB(
   long categoryID
)

Parameters

categoryID
The categoryID for the items.

Return Value

The total number of items have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members
Overload List


%%PageItemTitle%%

LoadDB(Int32,Int32) Method
[image]
dotnetCART Namespace > Items Class > LoadDB Method : LoadDB(Int32,Int32) Method

start
The start page which starts from 0.
count
The number of items in the page.
Loads the count number of items from start value from Items table.

Syntax

Visual Basic (Declaration)
Public Overloads Function LoadDB( _
   ByVal start As Integer, _
   ByVal count As Integer _
) As Integer
C#
public int LoadDB(
   int start,
   int count
)

Parameters

start
The start page which starts from 0.
count
The number of items in the page.

Return Value

The total number of items have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members
Overload List


%%PageItemTitle%%

LoadDB(Where,Int32,Int32,String,OrderDirection) Method
[image]
dotnetCART Namespace > Items Class > LoadDB Method : LoadDB(Where,Int32,Int32,String,OrderDirection) Method

whereClause
The where clause to filter the items.
start
The start page which starts from 0.
count
The number of items in the page.
orderBy
The order of the loaded items.
orderDirection
The order direction of the loaded items. Defaults is Asc.
Loads all the items based on the parameters from Items table.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function LoadDB( _
   ByVal whereClause As Where, _
   ByVal start As Integer, _
   ByVal count As Integer, _
   ByVal orderBy As String, _
   ByVal orderDirection As OrderDirection _
) As Integer
C#
public override int LoadDB(
   Where whereClause,
   int start,
   int count,
   string orderBy,
   OrderDirection orderDirection
)

Parameters

whereClause
The where clause to filter the items.
start
The start page which starts from 0.
count
The number of items in the page.
orderBy
The order of the loaded items.
orderDirection
The order direction of the loaded items. Defaults is Asc.

Return Value

The total number of items have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members
Overload List


%%PageItemTitle%%

LoadDB(Int64,Where,Int32,Int32,String,OrderDirection) Method
[image]
dotnetCART Namespace > Items Class > LoadDB Method : LoadDB(Int64,Where,Int32,Int32,String,OrderDirection) Method

categoryID
The categoryID for the items.
whereClause
The where clause to filter the items.
start
The start page which starts from 0.
count
The number of items in the page.
orderBy
The order of the loaded items.
orderDirection
The order direction of the loaded items. Defaults is Asc.
Loads all the items based on the parameters from Items table.

Syntax

Visual Basic (Declaration)
Public Overloads Function LoadDB( _
   ByVal categoryID As Long, _
   ByVal whereClause As Where, _
   ByVal start As Integer, _
   ByVal count As Integer, _
   ByVal orderBy As String, _
   ByVal orderDirection As OrderDirection _
) As Integer
C#
public int LoadDB(
   long categoryID,
   Where whereClause,
   int start,
   int count,
   string orderBy,
   OrderDirection orderDirection
)

Parameters

categoryID
The categoryID for the items.
whereClause
The where clause to filter the items.
start
The start page which starts from 0.
count
The number of items in the page.
orderBy
The order of the loaded items.
orderDirection
The order direction of the loaded items. Defaults is Asc.

Return Value

The total number of items have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members
Overload List


%%PageItemTitle%%

LoadDB(Int64,Where,Int32,Int32,String,OrderDirection,Boolean) Method
See Also
[image]
dotnetCART Namespace > Items Class > LoadDB Method : LoadDB(Int64,Where,Int32,Int32,String,OrderDirection,Boolean) Method

categoryID
The categoryID for the items.
whereClause
The where clause to filter the items.
start
The start page which starts from 0.
count
The number of items in the page.
orderBy
The order of the loaded items. This parameter sorts while loading from database, use Sort method if you want to sort the items in the memory.
orderDirection
The order direction of the loaded items. Defaults is Asc.
includeDisabled
Determines whether to load disabled items or not. Defaults is false.
Loads all the items based on the parameters from Items table.

Syntax

Visual Basic (Declaration)
Public Overloads Function LoadDB( _
   ByVal categoryID As Long, _
   ByVal whereClause As Where, _
   ByVal start As Integer, _
   ByVal count As Integer, _
   ByVal orderBy As String, _
   ByVal orderDirection As OrderDirection, _
   ByVal includeDisabled As Boolean _
) As Integer
C#
public int LoadDB(
   long categoryID,
   Where whereClause,
   int start,
   int count,
   string orderBy,
   OrderDirection orderDirection,
   bool includeDisabled
)

Parameters

categoryID
The categoryID for the items.
whereClause
The where clause to filter the items.
start
The start page which starts from 0.
count
The number of items in the page.
orderBy
The order of the loaded items. This parameter sorts while loading from database, use Sort method if you want to sort the items in the memory.
orderDirection
The order direction of the loaded items. Defaults is Asc.
includeDisabled
Determines whether to load disabled items or not. Defaults is false.

Return Value

The total number of items have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members
Overload List


%%PageItemTitle%%

LoadDB(Int64,Where,Int32,Int32,String,OrderDirection,Boolean,Boolean) Method
See Also
[image]
dotnetCART Namespace > Items Class > LoadDB Method : LoadDB(Int64,Where,Int32,Int32,String,OrderDirection,Boolean,Boolean) Method

categoryID
The categoryID for the items.
whereClause
The where clause to filter the items.
start
The start page which starts from 0.
count
The number of items in the page.
orderBy
The order of the loaded items. This parameter sorts while loading from database, use Sort method if you want to sort the items in the memory.
orderDirection
The order direction of the loaded items. Defaults is Asc.
includeDisabled
Determines whether to load disabled items or not. Defaults is false.
includeSubItems
Determines whether to include SubItems in search or not. Defaults is false. A typical usage is for searching all items and subItems.
Loads all the items based on the parameters from Items table.

Syntax

Visual Basic (Declaration)
Public Overloads Function LoadDB( _
   ByVal categoryID As Long, _
   ByVal whereClause As Where, _
   ByVal start As Integer, _
   ByVal count As Integer, _
   ByVal orderBy As String, _
   ByVal orderDirection As OrderDirection, _
   ByVal includeDisabled As Boolean, _
   ByVal includeSubItems As Boolean _
) As Integer
C#
public int LoadDB(
   long categoryID,
   Where whereClause,
   int start,
   int count,
   string orderBy,
   OrderDirection orderDirection,
   bool includeDisabled,
   bool includeSubItems
)

Parameters

categoryID
The categoryID for the items.
whereClause
The where clause to filter the items.
start
The start page which starts from 0.
count
The number of items in the page.
orderBy
The order of the loaded items. This parameter sorts while loading from database, use Sort method if you want to sort the items in the memory.
orderDirection
The order direction of the loaded items. Defaults is Asc.
includeDisabled
Determines whether to load disabled items or not. Defaults is false.
includeSubItems
Determines whether to include SubItems in search or not. Defaults is false. A typical usage is for searching all items and subItems.

Return Value

The total number of items have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members
Overload List


%%PageItemTitle%%

Sort Method
[image]
dotnetCART Namespace > Items Class : Sort Method

Sort items by name in this collection.

Overload List

Overload | Description
Sort() | Sort items by name in this collection.
Sort(String) | Sort items by requestSort parameter in this collection.
Sort(String,OrderDirection) | Sort items by requestSort parameter in this collection.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members


%%PageItemTitle%%

Sort() Method
[image]
dotnetCART Namespace > Items Class > Sort Method : Sort() Method

Sort items by name in this collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Sort()
C#
public void Sort()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members
Overload List


%%PageItemTitle%%

Sort(String) Method
See Also Example
[image]
dotnetCART Namespace > Items Class > Sort Method : Sort(String) Method

requestSort
Valid requestSort values are: ID, Name, Price, Total, Weight, Quantity, AddressID, CategoryName, CategoryID and Sequece. The sequence is a field in ItemCatagoies table.
Sort items by requestSort parameter in this collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Sort( _
   ByVal requestSort As String _
)
C#
public void Sort(
   string requestSort
)

Parameters

requestSort
Valid requestSort values are: ID, Name, Price, Total, Weight, Quantity, AddressID, CategoryName, CategoryID and Sequece. The sequence is a field in ItemCatagoies table.

Example

C# Copy Code
items.Sort("Price");

Visual Basic Copy Code
items.Sort("Price")

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members
Overload List


%%PageItemTitle%%

Sort(String,OrderDirection) Method
See Also Example
[image]
dotnetCART Namespace > Items Class > Sort Method : Sort(String,OrderDirection) Method

requestSort
Valid requestSort values are: ID, Name, Price, Total, Weight, Quantity, AddressID, CategoryName, CategoryID, Sequece and any custom field adding to Items table. The sequence is a field in ItemCatagoies table.
orderDirection
Sort options: Asc or Desc.
Sort items by requestSort parameter in this collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Sort( _
   ByVal requestSort As String, _
   ByVal orderDirection As OrderDirection _
)
C#
public void Sort(
   string requestSort,
   OrderDirection orderDirection
)

Parameters

requestSort
Valid requestSort values are: ID, Name, Price, Total, Weight, Quantity, AddressID, CategoryName, CategoryID, Sequece and any custom field adding to Items table. The sequence is a field in ItemCatagoies table.
orderDirection
Sort options: Asc or Desc.

Example

C# Copy Code
items.Sort("Price", OrderDirection.Asc);

Visual Basic Copy Code
items.Sort("Price", OrderDirection.Desc)

Remarks

This method sort the items in the memory, if you want to sort while loading from database, use orderBy parameter in LoadDB method.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members
Overload List


%%PageItemTitle%%

LacnicRir Class
See Also Members
[image]
dotnetCART Namespace : LacnicRir Class

Syntax

Visual Basic (Declaration)
Private Class LacnicRir
   Inherits BaseRir
C#
private class LacnicRir : BaseRir

Inheritance Hierarchy

System.Object
dotnetCART.BaseRir
dotnetCART.LacnicRir

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LacnicRir Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

LacnicRir Class Members
See Also Methods
[image]
dotnetCART Namespace : LacnicRir Class

The following tables list the members exposed by LacnicRir.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Parse |
Top

See Also

Reference

LacnicRir Class
dotnetCART Namespace


%%PageItemTitle%% $$Methods$$

LacnicRir Class Methods
[image]
dotnetCART Namespace : LacnicRir Class

For a list of all members of this type, see LacnicRir members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Parse |
Top

See Also

Reference

LacnicRir Class
dotnetCART Namespace


%%PageItemTitle%%

Parse Method
[image]
dotnetCART Namespace > LacnicRir Class : Parse Method

ip

Syntax

Visual Basic (Declaration)
Public Shared Function Parse( _
   ByVal ip As String _
) As ParseResult
C#
public static ParseResult Parse(
   string ip
)

Parameters

ip

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LacnicRir Class
LacnicRir Members


%%PageItemTitle%%

Location Class
See Also Members
[image]
dotnetCART Namespace : Location Class

Represents a location object.

Object Model

Syntax

Visual Basic (Declaration)
Public Class Location
   Inherits DbTableCart(Of Location, Long)
C#
public class Location : DbTableCart<Location, long>

Inheritance Hierarchy

System.Object
dotnetDATA.DbTable<Int64>
dotnetDATA.DbTable<Location, Int64>
dotnetCART.DbTableCart<Location, Int64>
dotnetCART.Location

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Location Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

Location Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : Location Class

The following tables list the members exposed by Location.

Public Constructors

 | Name | Description
Public Constructor | Location Constructor | Initializes a new instance of the Location class.
Top

Public Properties

 | Name | Description
Public Property | Code | Gets or sets this location code.
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<Location, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<Location, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<Location, Int64>)
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<Location, Int64>)
Public Property | ID | Overridden. The auto number ID populated from the database.
Public Property | Name | Gets or sets this location's name.
Public Property | Parent | Gets or sets this location parent ID.
Public Property | Phone | Gets or sets this location's phone area code.
Public Property | Tax | Gets or sets the tax associated with this location. It is added to Taxes when invoking Taxes.Add() method.
Public Property | Taxes | A collection of Taxes associate with this location.
Top

Public Methods

 | Name | Description
Public Method | Clear | Initializes all the properties without recreating the object. (Inherited from dotnetCART.DbTableCart<Location, Int64>)
Public Method | DeleteDB | Overloaded. Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<Location, Int64>)
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<Location, Int64>)
Public Method | LoadDB | Overloaded. Loads a location from database.
Public Method | SaveDB | Overloaded. Saves this location to database.
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<Location, Int64>)
Top

See Also

Reference

Location Class
dotnetCART Namespace


%%PageItemTitle%%

Location Constructor
[image]
dotnetCART Namespace > Location Class : Location Constructor

Initializes a new instance of the Location class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Location()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Location Class
Location Members


%%PageItemTitle%% $$Methods$$

Location Class Methods
[image]
dotnetCART Namespace : Location Class

For a list of all members of this type, see Location members.

Public Methods

 | Name | Description
Public Method | Clear | Initializes all the properties without recreating the object. (Inherited from dotnetCART.DbTableCart<Location, Int64>)
Public Method | DeleteDB | Overloaded. Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<Location, Int64>)
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<Location, Int64>)
Public Method | LoadDB | Overloaded. Loads a location from database.
Public Method | SaveDB | Overloaded. Saves this location to database.
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<Location, Int64>)
Top

See Also

Reference

Location Class
dotnetCART Namespace


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > Location Class : LoadDB Method

Loads a location from database.

Overload List

Overload | Description
LoadDB(String,String) | Loads a location from database.
LoadDB(String) |
LoadDB(Int32) |
LoadDB(Int64) | (Inherited from dotnetCART.DbTableCart<Location, Int64>)
LoadDB() | Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<Location, Int64>)
Generic LoadDB() | (Inherited from dotnetDATA.DbTable<Int64>)
Generic LoadDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Location Class
Location Members


%%PageItemTitle%%

LoadDB(String,String) Method
[image]
dotnetCART Namespace > Location Class > LoadDB Method : LoadDB(String,String) Method

locationType
The location type like Country, Province
locationCode
The location code like US, CA,...
Loads a location from database.

Syntax

Visual Basic (Declaration)
Public Overloads Function LoadDB( _
   ByVal locationType As String, _
   ByVal locationCode As String _
) As Integer
C#
public int LoadDB(
   string locationType,
   string locationCode
)

Parameters

locationType
The location type like Country, Province
locationCode
The location code like US, CA,...

Return Value

Returns 1 for success and -1 for failed.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Location Class
Location Members
Overload List


%%PageItemTitle%%

LoadDB(String) Method
[image]
dotnetCART Namespace > Location Class > LoadDB Method : LoadDB(String) Method

areaCode

Syntax

Visual Basic (Declaration)
Public Overloads Function LoadDB( _
   ByVal areaCode As String _
) As Integer
C#
public int LoadDB(
   string areaCode
)

Parameters

areaCode

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Location Class
Location Members
Overload List


%%PageItemTitle%%

LoadDB(Int32) Method
[image]
dotnetCART Namespace > Location Class > LoadDB Method : LoadDB(Int32) Method

areaCode

Syntax

Visual Basic (Declaration)
Public Overloads Function LoadDB( _
   ByVal areaCode As Integer _
) As Integer
C#
public int LoadDB(
   int areaCode
)

Parameters

areaCode

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Location Class
Location Members
Overload List


%%PageItemTitle%%

SaveDB Method
[image]
dotnetCART Namespace > Location Class : SaveDB Method

Saves this location to database.

Overload List

Overload | Description
SaveDB(String) | Saves this location to database.
SaveDB() | Inserts or updates this object into the database. (Inherited from dotnetCART.DbTableCart<Location, Int64>)
SaveDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Location Class
Location Members


%%PageItemTitle%%

SaveDB(String) Method
[image]
dotnetCART Namespace > Location Class > SaveDB Method : SaveDB(String) Method

locationType
The location type like Country, Province
Saves this location to database.

Syntax

Visual Basic (Declaration)
Public Overloads Function SaveDB( _
   ByVal locationType As String _
) As Integer
C#
public int SaveDB(
   string locationType
)

Parameters

locationType
The location type like Country, Province

Return Value

Returns 1 for success and -1 for failed.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Location Class
Location Members
Overload List


%%PageItemTitle%% $$Properties$$

Location Class Properties
[image]
dotnetCART Namespace : Location Class

For a list of all members of this type, see Location members.

Public Properties

 | Name | Description
Public Property | Code | Gets or sets this location code.
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<Location, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<Location, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<Location, Int64>)
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<Location, Int64>)
Public Property | ID | Overridden. The auto number ID populated from the database.
Public Property | Name | Gets or sets this location's name.
Public Property | Parent | Gets or sets this location parent ID.
Public Property | Phone | Gets or sets this location's phone area code.
Public Property | Tax | Gets or sets the tax associated with this location. It is added to Taxes when invoking Taxes.Add() method.
Public Property | Taxes | A collection of Taxes associate with this location.
Top

See Also

Reference

Location Class
dotnetCART Namespace


%%PageItemTitle%%

Code Property
[image]
dotnetCART Namespace > Location Class : Code Property

Gets or sets this location code.

Syntax

Visual Basic (Declaration)
Public Property Code As String
C#
public string Code {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Location Class
Location Members


%%PageItemTitle%%

ID Property
[image]
dotnetCART Namespace > Location Class : ID Property

The auto number ID populated from the database.

Syntax

Visual Basic (Declaration)
Public Overrides Property ID As Long
C#
public override long ID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Location Class
Location Members


%%PageItemTitle%%

Name Property
[image]
dotnetCART Namespace > Location Class : Name Property

Gets or sets this location's name.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Location Class
Location Members


%%PageItemTitle%%

Parent Property
[image]
dotnetCART Namespace > Location Class : Parent Property

Gets or sets this location parent ID.

Syntax

Visual Basic (Declaration)
Public Property Parent As Long
C#
public long Parent {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Location Class
Location Members


%%PageItemTitle%%

Phone Property
[image]
dotnetCART Namespace > Location Class : Phone Property

Gets or sets this location's phone area code.

Syntax

Visual Basic (Declaration)
Public Property Phone As String
C#
public string Phone {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Location Class
Location Members


%%PageItemTitle%%

Tax Property
[image]
dotnetCART Namespace > Location Class : Tax Property

Gets or sets the tax associated with this location. It is added to Taxes when invoking Taxes.Add() method.

Syntax

Visual Basic (Declaration)
Public Property Tax As Tax
C#
public Tax Tax {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Location Class
Location Members


%%PageItemTitle%%

Taxes Property
[image]
dotnetCART Namespace > Location Class : Taxes Property

A collection of Taxes associate with this location.

Syntax

Visual Basic (Declaration)
Public Property Taxes As Taxes
C#
public Taxes Taxes {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Location Class
Location Members


%%PageItemTitle%%

LocationType Class
See Also Members
[image]
dotnetCART Namespace : LocationType Class

Represents a location type object.

Object Model

Syntax

Visual Basic (Declaration)
Public Class LocationType
   Inherits DbTableCart(Of LocationType, Long)
C#
public class LocationType : DbTableCart<LocationType, long>

Inheritance Hierarchy

System.Object
dotnetDATA.DbTable<Int64>
dotnetDATA.DbTable<LocationType, Int64>
dotnetCART.DbTableCart<LocationType, Int64>
dotnetCART.LocationType

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationType Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

LocationType Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : LocationType Class

The following tables list the members exposed by LocationType.

Public Constructors

 | Name | Description
Public Constructor | LocationType Constructor | Initializes a new instance of the LocationType class.
Top

Public Properties

 | Name | Description
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<LocationType, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<LocationType, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<LocationType, Int64>)
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<LocationType, Int64>)
Public Property | ID | Overridden. The auto number ID populated from the database.
Public Property | Locations | A collection of Location associate with this location type.
Public Property | Name | Gets or sets this locationType's name.
Public Property | SelectedCode | Defaults location code for the locations associate with this location type.
Public Property | Source | A property in Cart.BillAddress object associate with this location type. e.g BillAddress.Country for Country type.
Top

Public Methods

 | Name | Description
Public Method | Clear | Initializes all the properties without recreating the object. (Inherited from dotnetCART.DbTableCart<LocationType, Int64>)
Public Method | DeleteDB | Overloaded. Overridden. Deletes this locationType and all the associated locations to this locationType.
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<LocationType, Int64>)
Public Method | LoadDB | Overloaded. Overridden. Loads all the Location associate with this location type.
Public Method | SaveDB | Overloaded. Overridden. Inserts or updates this object into the LocationTypes table.
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<LocationType, Int64>)
Top

See Also

Reference

LocationType Class
dotnetCART Namespace


%%PageItemTitle%%

LocationType Constructor
[image]
dotnetCART Namespace > LocationType Class : LocationType Constructor

Initializes a new instance of the LocationType class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public LocationType()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationType Class
LocationType Members


%%PageItemTitle%% $$Methods$$

LocationType Class Methods
[image]
dotnetCART Namespace : LocationType Class

For a list of all members of this type, see LocationType members.

Public Methods

 | Name | Description
Public Method | Clear | Initializes all the properties without recreating the object. (Inherited from dotnetCART.DbTableCart<LocationType, Int64>)
Public Method | DeleteDB | Overloaded. Overridden. Deletes this locationType and all the associated locations to this locationType.
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<LocationType, Int64>)
Public Method | LoadDB | Overloaded. Overridden. Loads all the Location associate with this location type.
Public Method | SaveDB | Overloaded. Overridden. Inserts or updates this object into the LocationTypes table.
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<LocationType, Int64>)
Top

See Also

Reference

LocationType Class
dotnetCART Namespace


%%PageItemTitle%%

DeleteDB Method
[image]
dotnetCART Namespace > LocationType Class : DeleteDB Method

Deletes this locationType and all the associated locations to this locationType.

Overload List

Overload | Description
DeleteDB() | Deletes this locationType and all the associated locations to this locationType.
DeleteDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationType Class
LocationType Members


%%PageItemTitle%%

DeleteDB() Method
[image]
dotnetCART Namespace > LocationType Class > DeleteDB Method : DeleteDB() Method

Deletes this locationType and all the associated locations to this locationType.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function DeleteDB() As Integer
C#
public override int DeleteDB()

Return Value

In case of error -1, check Error property, otherwise the number of records deleted.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationType Class
LocationType Members
Overload List


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > LocationType Class : LoadDB Method

Loads all the Location associate with this location type.

Overload List

Overload | Description
LoadDB() | Loads all the Location associate with this location type.
LoadDB(Int64) | Loads all the Location associate with this location type.
LoadDB(Int64,Int64) | Loads all the Location associate with this location type.
Generic LoadDB() | (Inherited from dotnetDATA.DbTable<Int64>)
Generic LoadDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationType Class
LocationType Members


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > LocationType Class > LoadDB Method : LoadDB() Method

Loads all the Location associate with this location type.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function LoadDB() As Integer
C#
public override int LoadDB()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationType Class
LocationType Members
Overload List


%%PageItemTitle%%

LoadDB(Int64) Method
[image]
dotnetCART Namespace > LocationType Class > LoadDB Method : LoadDB(Int64) Method

id
The id of the location type.
Loads all the Location associate with this location type.

Syntax

Visual Basic (Declaration)
Public Overloads Function LoadDB( _
   ByVal id As Long _
) As Integer
C#
public int LoadDB(
   long id
)

Parameters

id
The id of the location type.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationType Class
LocationType Members
Overload List


%%PageItemTitle%%

LoadDB(Int64,Int64) Method
[image]
dotnetCART Namespace > LocationType Class > LoadDB Method : LoadDB(Int64,Int64) Method

id
The id of the location type.
parentID
The parent id of the Location
Loads all the Location associate with this location type.

Syntax

Visual Basic (Declaration)
Public Overloads Function LoadDB( _
   ByVal id As Long, _
   ByVal parentID As Long _
) As Integer
C#
public int LoadDB(
   long id,
   long parentID
)

Parameters

id
The id of the location type.
parentID
The parent id of the Location

Remarks

For more inforamtion about adding a new location type and tax configuration, please see Location->Taxes

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationType Class
LocationType Members
Overload List


%%PageItemTitle%%

SaveDB Method
[image]
dotnetCART Namespace > LocationType Class : SaveDB Method

Inserts or updates this object into the LocationTypes table.

Overload List

Overload | Description
SaveDB() | Inserts or updates this object into the LocationTypes table.
SaveDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationType Class
LocationType Members


%%PageItemTitle%%

SaveDB() Method
[image]
dotnetCART Namespace > LocationType Class > SaveDB Method : SaveDB() Method

Inserts or updates this object into the LocationTypes table.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function SaveDB() As Integer
C#
public override int SaveDB()

Return Value

Returns the generated ID or 1 for the update, returns -1 if failed. For the reason of fail, check the Error property.

Remarks

If ID greater than 0, it updates the associated record in the table, otherwise inserts a new record.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationType Class
LocationType Members
Overload List


%%PageItemTitle%% $$Properties$$

LocationType Class Properties
[image]
dotnetCART Namespace : LocationType Class

For a list of all members of this type, see LocationType members.

Public Properties

 | Name | Description
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<LocationType, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<LocationType, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<LocationType, Int64>)
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<LocationType, Int64>)
Public Property | ID | Overridden. The auto number ID populated from the database.
Public Property | Locations | A collection of Location associate with this location type.
Public Property | Name | Gets or sets this locationType's name.
Public Property | SelectedCode | Defaults location code for the locations associate with this location type.
Public Property | Source | A property in Cart.BillAddress object associate with this location type. e.g BillAddress.Country for Country type.
Top

See Also

Reference

LocationType Class
dotnetCART Namespace


%%PageItemTitle%%

ID Property
[image]
dotnetCART Namespace > LocationType Class : ID Property

The auto number ID populated from the database.

Syntax

Visual Basic (Declaration)
Public Overrides Property ID As Long
C#
public override long ID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationType Class
LocationType Members


%%PageItemTitle%%

Locations Property
[image]
dotnetCART Namespace > LocationType Class : Locations Property

A collection of Location associate with this location type.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Locations As List(Of Location)
C#
public List<Location> Locations {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationType Class
LocationType Members


%%PageItemTitle%%

Name Property
[image]
dotnetCART Namespace > LocationType Class : Name Property

Gets or sets this locationType's name.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationType Class
LocationType Members


%%PageItemTitle%%

SelectedCode Property
[image]
dotnetCART Namespace > LocationType Class : SelectedCode Property

Defaults location code for the locations associate with this location type.

Syntax

Visual Basic (Declaration)
Public Property SelectedCode As String
C#
public string SelectedCode {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationType Class
LocationType Members


%%PageItemTitle%%

Source Property
[image]
dotnetCART Namespace > LocationType Class : Source Property

A property in Cart.BillAddress object associate with this location type. e.g BillAddress.Country for Country type.

Syntax

Visual Basic (Declaration)
Public Property Source As String
C#
public string Source {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationType Class
LocationType Members


%%PageItemTitle%%

LocationTypes Class
See Also Members
[image]
dotnetCART Namespace : LocationTypes Class

A collection of LocationType objects.

Object Model

Syntax

Visual Basic (Declaration)
Public Class LocationTypes
   Inherits ListBase(Of LocationType)
C#
public class LocationTypes : ListBase<LocationType>

Inheritance Hierarchy

System.Object
System.Collections.Generic.List<LocationType>
dotnetCART.ListBase<LocationType>
dotnetCART.LocationTypes

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationTypes Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

LocationTypes Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : LocationTypes Class

The following tables list the members exposed by LocationTypes.

Public Constructors

 | Name | Description
Public Constructor | LocationTypes Constructor | Initializes a new instance of the LocationTypes class.
Top

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from dotnetCART.ListBase<LocationType>)
Public Property | Count | Gets the number of elements actually contained in the collection. (Inherited from dotnetCART.ListBase<LocationType>)
Public Property | Error | Returns an object with the error information. (Inherited from dotnetCART.ListBase<LocationType>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from dotnetCART.ListBase<LocationType>)
Top

Public Methods

 | Name | Description
Public Method | Add | Adds an object to the end of the collection. (Inherited from dotnetCART.ListBase<LocationType>)
Public Method | AddRange | Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetCART.ListBase<LocationType>)
Public Method | AsReadOnly | Returns a read-only IList wrapper for the current collection. (Inherited from dotnetCART.ListBase<LocationType>)
Public Method | BinarySearch | Overloaded. (Inherited from dotnetCART.ListBase<LocationType>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetCART.ListBase<LocationType>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetCART.ListBase<LocationType>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<LocationType>)
Public Method | CopyTo | Overloaded. (Inherited from dotnetCART.ListBase<LocationType>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from dotnetCART.ListBase<LocationType>)
Public Method | IndexOf | Overloaded. (Inherited from dotnetCART.ListBase<LocationType>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetCART.ListBase<LocationType>)
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from dotnetCART.ListBase<LocationType>)
Public Method | LastIndexOf | Overloaded. (Inherited from dotnetCART.ListBase<LocationType>)
Public Method | LoadDB | Overloaded. Loads all the location types.
Public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from dotnetCART.ListBase<LocationType>)
Public Method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from dotnetCART.ListBase<LocationType>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetCART.ListBase<LocationType>)
Public Method | RemoveRange | Removes a range of elements from the List. (Inherited from dotnetCART.ListBase<LocationType>)
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<LocationType>)
Top

See Also

Reference

LocationTypes Class
dotnetCART Namespace


%%PageItemTitle%%

LocationTypes Constructor
[image]
dotnetCART Namespace > LocationTypes Class : LocationTypes Constructor

Initializes a new instance of the LocationTypes class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public LocationTypes()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationTypes Class
LocationTypes Members


%%PageItemTitle%% $$Methods$$

LocationTypes Class Methods
[image]
dotnetCART Namespace : LocationTypes Class

For a list of all members of this type, see LocationTypes members.

Public Methods

 | Name | Description
Public Method | Add | Adds an object to the end of the collection. (Inherited from dotnetCART.ListBase<LocationType>)
Public Method | AddRange | Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetCART.ListBase<LocationType>)
Public Method | AsReadOnly | Returns a read-only IList wrapper for the current collection. (Inherited from dotnetCART.ListBase<LocationType>)
Public Method | BinarySearch | Overloaded. (Inherited from dotnetCART.ListBase<LocationType>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetCART.ListBase<LocationType>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetCART.ListBase<LocationType>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<LocationType>)
Public Method | CopyTo | Overloaded. (Inherited from dotnetCART.ListBase<LocationType>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from dotnetCART.ListBase<LocationType>)
Public Method | IndexOf | Overloaded. (Inherited from dotnetCART.ListBase<LocationType>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetCART.ListBase<LocationType>)
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from dotnetCART.ListBase<LocationType>)
Public Method | LastIndexOf | Overloaded. (Inherited from dotnetCART.ListBase<LocationType>)
Public Method | LoadDB | Overloaded. Loads all the location types.
Public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from dotnetCART.ListBase<LocationType>)
Public Method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from dotnetCART.ListBase<LocationType>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetCART.ListBase<LocationType>)
Public Method | RemoveRange | Removes a range of elements from the List. (Inherited from dotnetCART.ListBase<LocationType>)
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<LocationType>)
Top

See Also

Reference

LocationTypes Class
dotnetCART Namespace


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > LocationTypes Class : LoadDB Method

Loads all the location types.

Overload List

Overload | Description
LoadDB() | Loads all the location types.
LoadDB(Where) | Loads all the items from its associated table based on the where clause. (Inherited from dotnetCART.ListBase<LocationType>)
LoadDB(Int32,Int32) | Loads the count number of elements from start value. (Inherited from dotnetCART.ListBase<LocationType>)
LoadDB(Where,Int32,Int32,String,OrderDirection) | Loads all the items based on the parameters. (Inherited from dotnetCART.ListBase<LocationType>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationTypes Class
LocationTypes Members


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > LocationTypes Class > LoadDB Method : LoadDB() Method

Loads all the location types.

Syntax

Visual Basic (Declaration)
Public Overloads Function LoadDB() As Integer
C#
public int LoadDB()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationTypes Class
LocationTypes Members
Overload List


%%PageItemTitle%%

Mail Class
See Also Members
[image]
dotnetCART Namespace : Mail Class

Represents an email object.

Object Model

Syntax

Visual Basic (Declaration)
Public Class Mail
C#
public class Mail

Remarks

For a typical usage like sending order receipts to your customers, set the global mail settings in StoreAdmin->Settings->Mail.

Inheritance Hierarchy

System.Object
dotnetCART.Mail

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Mail Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

Mail Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : Mail Class

The following tables list the members exposed by Mail.

Public Constructors

 | Name | Description
Public Constructor | Mail Constructor | Creates a new instance of the Mail class.
Top

Public Properties

 | Name | Description
Public Property | Bcc | A copy of the email is sent to this address list without the addresses appear in the respective header lines.
Public Property | BodyFormat | Sets the body format as text or html. The default is text.
Public Property | Cc | A copy of the email is sent to this address list as well.
Public Property | Error | Returns an object with the error information.
Public Property | Filter | Filter list for domains that are not accepted for email addresses.
Public Property | From | From address for the email.
Public Property | FromName | From name for the email.
Public Property | Host | SMTP mail server address.
Public Property | Message | The body of the email.
Public Property | Port | If you are using a non standard port you can set this. Defaults to 25.
Public Property | Subject | Subject for the email.
Public Property | To | To address for the email.
Top

Public Methods

 | Name | Description
Public Method | AddAttachment | Overloaded. Attaches a file to the email.
Public Method | AddToFilter | Adds a domain to the filter.
Public Method | IsFreeMail | This method returns a boolean (true / false) if the email address provides is within the free mail list defined by the Filter property.
Public Method | IsValid | Returns whether the provided email has a valid pathern or not.
Public Method | Login | Overloaded. Used for optional SMTP authentication for servers that require it.
Public Method | Send | Sends the email based on the setting properties.
Top

See Also

Reference

Mail Class
dotnetCART Namespace


%%PageItemTitle%%

Mail Constructor
[image]
dotnetCART Namespace > Mail Class : Mail Constructor

Creates a new instance of the Mail class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Mail()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Mail Class
Mail Members


%%PageItemTitle%% $$Methods$$

Mail Class Methods
[image]
dotnetCART Namespace : Mail Class

For a list of all members of this type, see Mail members.

Public Methods

 | Name | Description
Public Method | AddAttachment | Overloaded. Attaches a file to the email.
Public Method | AddToFilter | Adds a domain to the filter.
Public Method | IsFreeMail | This method returns a boolean (true / false) if the email address provides is within the free mail list defined by the Filter property.
Public Method | IsValid | Returns whether the provided email has a valid pathern or not.
Public Method | Login | Overloaded. Used for optional SMTP authentication for servers that require it.
Public Method | Send | Sends the email based on the setting properties.
Top

See Also

Reference

Mail Class
dotnetCART Namespace


%%PageItemTitle%%

AddAttachment Method
[image]
dotnetCART Namespace > Mail Class : AddAttachment Method

Attaches a file to the email.

Overload List

Overload | Description
AddAttachment(String) | Attaches a file to the email.
AddAttachment(MemoryStream) | Attaches a memory stream to the email.
AddAttachment(MemoryStream,String) | Attaches a memory stream to the email.
AddAttachment(FileStream) | Attaches a file stream to the email.
AddAttachment(FileStream,String) | Attaches a file stream to the email.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Mail Class
Mail Members


%%PageItemTitle%%

AddAttachment(String) Method
[image]
dotnetCART Namespace > Mail Class > AddAttachment Method : AddAttachment(String) Method

fileName
A file name.
Attaches a file to the email.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddAttachment( _
   ByVal fileName As String _
)
C#
public void AddAttachment(
   string fileName
)

Parameters

fileName
A file name.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Mail Class
Mail Members
Overload List


%%PageItemTitle%%

AddAttachment(MemoryStream) Method
[image]
dotnetCART Namespace > Mail Class > AddAttachment Method : AddAttachment(MemoryStream) Method

fs
Attaches a memory stream to the email.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddAttachment( _
   ByVal fs As MemoryStream _
)
C#
public void AddAttachment(
   MemoryStream fs
)

Parameters

fs

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Mail Class
Mail Members
Overload List


%%PageItemTitle%%

AddAttachment(MemoryStream,String) Method
[image]
dotnetCART Namespace > Mail Class > AddAttachment Method : AddAttachment(MemoryStream,String) Method

fs
A memory stream object.
fileName
A file name.
Attaches a memory stream to the email.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddAttachment( _
   ByVal fs As MemoryStream, _
   ByVal fileName As String _
)
C#
public void AddAttachment(
   MemoryStream fs,
   string fileName
)

Parameters

fs
A memory stream object.
fileName
A file name.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Mail Class
Mail Members
Overload List


%%PageItemTitle%%

AddAttachment(FileStream) Method
[image]
dotnetCART Namespace > Mail Class > AddAttachment Method : AddAttachment(FileStream) Method

fs
A File stream object.
Attaches a file stream to the email.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddAttachment( _
   ByVal fs As FileStream _
)
C#
public void AddAttachment(
   FileStream fs
)

Parameters

fs
A File stream object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Mail Class
Mail Members
Overload List


%%PageItemTitle%%

AddAttachment(FileStream,String) Method
[image]
dotnetCART Namespace > Mail Class > AddAttachment Method : AddAttachment(FileStream,String) Method

fs
A file stream object.
fileName
A file name.
Attaches a file stream to the email.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddAttachment( _
   ByVal fs As FileStream, _
   ByVal fileName As String _
)
C#
public void AddAttachment(
   FileStream fs,
   string fileName
)

Parameters

fs
A file stream object.
fileName
A file name.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Mail Class
Mail Members
Overload List


%%PageItemTitle%%

AddToFilter Method
[image]
dotnetCART Namespace > Mail Class : AddToFilter Method

name
The domain name. e.g. hotmail.com
Adds a domain to the filter.

Syntax

Visual Basic (Declaration)
Public Sub AddToFilter( _
   ByVal name As String _
)
C#
public void AddToFilter(
   string name
)

Parameters

name
The domain name. e.g. hotmail.com

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Mail Class
Mail Members


%%PageItemTitle%%

IsFreeMail Method
[image]
dotnetCART Namespace > Mail Class : IsFreeMail Method

email
An email address.
This method returns a boolean (true / false) if the email address provides is within the free mail list defined by the Filter property.

Syntax

Visual Basic (Declaration)
Public Function IsFreeMail( _
   ByVal email As String _
) As Boolean
C#
public bool IsFreeMail(
   string email
)

Parameters

email
An email address.

Return Value

Whether it is a free email or not.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Mail Class
Mail Members


%%PageItemTitle%%

IsValid Method
[image]
dotnetCART Namespace > Mail Class : IsValid Method

email
Returns whether the provided email has a valid pathern or not.

Syntax

Visual Basic (Declaration)
Public Function IsValid( _
   ByVal email As String _
) As Boolean
C#
public bool IsValid(
   string email
)

Parameters

email

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Mail Class
Mail Members


%%PageItemTitle%%

Login Method
[image]
dotnetCART Namespace > Mail Class : Login Method

Used for optional SMTP authentication for servers that require it.

Overload List

Overload | Description
Login(String,String) | Used for optional SMTP authentication for servers that require it.
Login(String,String,AuthenticateMethod,Boolean) | Used for optional SMTP authentication for servers that require it.
Login(String,String,AuthenticateMethod) | Used for optional SMTP authentication for servers that require it.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Mail Class
Mail Members


%%PageItemTitle%%

Login(String,String) Method
[image]
dotnetCART Namespace > Mail Class > Login Method : Login(String,String) Method

userName
The username to be used for authentication.
password
The password to be used for authentication.
Used for optional SMTP authentication for servers that require it.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Login( _
   ByVal userName As String, _
   ByVal password As String _
)
C#
public void Login(
   string userName,
   string password
)

Parameters

userName
The username to be used for authentication.
password
The password to be used for authentication.

Remarks

This is usually set globally using StoreAdmin->Settings->Mail or through the API Store.Settings.Mail

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Mail Class
Mail Members
Overload List


%%PageItemTitle%%

Login(String,String,AuthenticateMethod,Boolean) Method
[image]
dotnetCART Namespace > Mail Class > Login Method : Login(String,String,AuthenticateMethod,Boolean) Method

userName
The username to be used for authentication.
password
The password to be used for authentication.
myMethod
SASL Mechanism to be used for authentication. It enables selection of CramMD5 or Login depending on your mail server requirements you can select the appropriate setting. The default is login.
useSSL
Determines whether to use SSL for connecting to the mail server or not.
Used for optional SMTP authentication for servers that require it.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Login( _
   ByVal userName As String, _
   ByVal password As String, _
   ByVal myMethod As AuthenticateMethod, _
   ByVal useSSL As Boolean _
)
C#
public void Login(
   string userName,
   string password,
   AuthenticateMethod myMethod,
   bool useSSL
)

Parameters

userName
The username to be used for authentication.
password
The password to be used for authentication.
myMethod
SASL Mechanism to be used for authentication. It enables selection of CramMD5 or Login depending on your mail server requirements you can select the appropriate setting. The default is login.
useSSL
Determines whether to use SSL for connecting to the mail server or not.

Remarks

This is usually set globally using StoreAdmin->Settings->Mail or through the API Store.Settings.Mail

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Mail Class
Mail Members
Overload List


%%PageItemTitle%%

Login(String,String,AuthenticateMethod) Method
[image]
dotnetCART Namespace > Mail Class > Login Method : Login(String,String,AuthenticateMethod) Method

userName
The username to be used for authentication.
password
The password to be used for authentication.
myMethod
SASL Mechanism to be used for authentication. It enables selection of CramMD5 or Login depending on your mail server requirements you can select the appropriate setting. The default is login.
Used for optional SMTP authentication for servers that require it.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Login( _
   ByVal userName As String, _
   ByVal password As String, _
   ByVal myMethod As AuthenticateMethod _
)
C#
public void Login(
   string userName,
   string password,
   AuthenticateMethod myMethod
)

Parameters

userName
The username to be used for authentication.
password
The password to be used for authentication.
myMethod
SASL Mechanism to be used for authentication. It enables selection of CramMD5 or Login depending on your mail server requirements you can select the appropriate setting. The default is login.

Remarks

This is usually set globally using StoreAdmin->Settings->Mail or through the API Store.Settings.Mail

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Mail Class
Mail Members
Overload List


%%PageItemTitle%%

Send Method
[image]
dotnetCART Namespace > Mail Class : Send Method

Sends the email based on the setting properties.

Syntax

Visual Basic (Declaration)
Public Function Send() As String
C#
public string Send()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Mail Class
Mail Members


%%PageItemTitle%% $$Properties$$

Mail Class Properties
[image]
dotnetCART Namespace : Mail Class

For a list of all members of this type, see Mail members.

Public Properties

 | Name | Description
Public Property | Bcc | A copy of the email is sent to this address list without the addresses appear in the respective header lines.
Public Property | BodyFormat | Sets the body format as text or html. The default is text.
Public Property | Cc | A copy of the email is sent to this address list as well.
Public Property | Error | Returns an object with the error information.
Public Property | Filter | Filter list for domains that are not accepted for email addresses.
Public Property | From | From address for the email.
Public Property | FromName | From name for the email.
Public Property | Host | SMTP mail server address.
Public Property | Message | The body of the email.
Public Property | Port | If you are using a non standard port you can set this. Defaults to 25.
Public Property | Subject | Subject for the email.
Public Property | To | To address for the email.
Top

See Also

Reference

Mail Class
dotnetCART Namespace


%%PageItemTitle%%

Bcc Property
[image]
dotnetCART Namespace > Mail Class : Bcc Property

A copy of the email is sent to this address list without the addresses appear in the respective header lines.

Syntax

Visual Basic (Declaration)
Public Property Bcc As String
C#
public string Bcc {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Mail Class
Mail Members


%%PageItemTitle%%

BodyFormat Property
[image]
dotnetCART Namespace > Mail Class : BodyFormat Property

Sets the body format as text or html. The default is text.

Syntax

Visual Basic (Declaration)
Public Property BodyFormat As String
C#
public string BodyFormat {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Mail Class
Mail Members


%%PageItemTitle%%

Cc Property
[image]
dotnetCART Namespace > Mail Class : Cc Property

A copy of the email is sent to this address list as well.

Syntax

Visual Basic (Declaration)
Public Property Cc As String
C#
public string Cc {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Mail Class
Mail Members


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > Mail Class : Error Property

Returns an object with the error information.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Mail Class
Mail Members


%%PageItemTitle%%

Filter Property
[image]
dotnetCART Namespace > Mail Class : Filter Property

Filter list for domains that are not accepted for email addresses.

Syntax

Visual Basic (Declaration)
Public Property Filter As String
C#
public string Filter {get; set;}

Remarks

Emails to be filtered as a comma delimited list. Default value: "hotmail.com, mail.com, email.com, netscape.net, yahoo.com, usa.net, netaddress.net, canada.com, freemail.com, rediffmail.com, excite.com"

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Mail Class
Mail Members


%%PageItemTitle%%

From Property
[image]
dotnetCART Namespace > Mail Class : From Property

From address for the email.

Syntax

Visual Basic (Declaration)
Public Property From As String
C#
public string From {get; set;}

Remarks

This is usually set globally using StoreAdmin->Settings->Mail or through the API Store.Settings.Mail

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Mail Class
Mail Members


%%PageItemTitle%%

FromName Property
[image]
dotnetCART Namespace > Mail Class : FromName Property

From name for the email.

Syntax

Visual Basic (Declaration)
Public Property FromName As String
C#
public string FromName {get; set;}

Remarks

This is usually set globally using StoreAdmin->Settings->Mail or through the API Store.Settings.Mail

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Mail Class
Mail Members


%%PageItemTitle%%

Host Property
[image]
dotnetCART Namespace > Mail Class : Host Property

SMTP mail server address.

Syntax

Visual Basic (Declaration)
Public Property Host As String
C#
public string Host {get; set;}

Remarks

This is usually set globally using StoreAdmin->Settings->Mail or through the API Store.Settings.Mail

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Mail Class
Mail Members


%%PageItemTitle%%

Message Property
[image]
dotnetCART Namespace > Mail Class : Message Property

The body of the email.

Syntax

Visual Basic (Declaration)
Public Property Message As String
C#
public string Message {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Mail Class
Mail Members


%%PageItemTitle%%

Port Property
[image]
dotnetCART Namespace > Mail Class : Port Property

If you are using a non standard port you can set this. Defaults to 25.

Syntax

Visual Basic (Declaration)
Public Property Port As Integer
C#
public int Port {get; set;}

Remarks

This is usually set globally using StoreAdmin->Settings->Mail or through the API Store.Settings.Mail

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Mail Class
Mail Members


%%PageItemTitle%%

Subject Property
[image]
dotnetCART Namespace > Mail Class : Subject Property

Subject for the email.

Syntax

Visual Basic (Declaration)
Public Property Subject As String
C#
public string Subject {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Mail Class
Mail Members


%%PageItemTitle%%

To Property
[image]
dotnetCART Namespace > Mail Class : To Property

To address for the email.

Syntax

Visual Basic (Declaration)
Public Property To As String
C#
public string To {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Mail Class
Mail Members


%%PageItemTitle%%

MailLabel Class
See Also Members
[image]
dotnetCART Namespace : MailLabel Class

Syntax

Visual Basic (Declaration)
Public Class MailLabel
C#
public class MailLabel

Inheritance Hierarchy

System.Object
dotnetCART.MailLabel

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

MailLabel Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

MailLabel Class Members
[image]
dotnetCART Namespace : MailLabel Class

The following tables list the members exposed by MailLabel.

Public Constructors

 | Name | Description
Public Constructor | MailLabel Constructor |
Top

See Also

Reference

MailLabel Class
dotnetCART Namespace


%%PageItemTitle%%

MailLabel Constructor
[image]
dotnetCART Namespace > MailLabel Class : MailLabel Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MailLabel()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

MailLabel Class
MailLabel Members


%%PageItemTitle%%

Option Class
See Also Members
[image]
dotnetCART Namespace : Option Class

Represents an Option object.

Object Model

Syntax

Visual Basic (Declaration)
Public Class Option
   Inherits DbTableCart(Of Option, Long)
C#
public class Option : DbTableCart<Option, long>

Inheritance Hierarchy

System.Object
dotnetDATA.DbTable<Int64>
dotnetDATA.DbTable<Option, Int64>
dotnetCART.DbTableCart<Option, Int64>
dotnetCART.Option

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Option Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

Option Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : Option Class

The following tables list the members exposed by Option.

Public Constructors

 | Name | Description
Public Constructor | Option Constructor | Initializes a new instance of the Option class.
Top

Public Properties

 | Name | Description
Public Property | AddOn | Determines whether this option is an add-on (like frame for a picture) or part of the item characteristic. (like color for T-shirt)
Public Property | Choice | A reference to the Choice associated with this option. It is added to the Option.Choices when invoking %"Option.Add():T:Option.Add()% method.
Public Property | Choices | A reference to the Choices associated with this option.
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<Option, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<Option, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<Option, Int64>)
Public Property | Description | Gets or sets a description for this option.
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<Option, Int64>)
Public Property | ID | Overridden. The auto number ID populated from the database.
Public Property | Items | A reference to the Items associated with this option.
Public Property | Label | Gets or sets this option label.
Public Property | Name | Gets or sets this option name.
Public Property | Required | Determines if the option is required or not. Defaults to false.
Public Property | Type | Gets or sets this option type.
Public Property | Value | Gets or sets this option value. This is usually the name of the selected choice.
Top

Public Methods

 | Name | Description
Public Method | Clear | Overridden. Initializes all the properties without recreating the object.
Public Method | Clone | Creates a copy of the current Option
Public Method | DeleteDB | Overloaded. Deletes this object from the Options table and the binding from the specified itemID.
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<Option, Int64>)
Public Method | GetHtml | Overloaded. Returns an HTML formatted string for the option and its choices for adding a single item.
Public Method | LoadDB | Overloaded. Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<Option, Int64>)
Public Method | SaveDB | Overloaded. Overridden. Inserts or updates this object into the Options table.
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<Option, Int64>)
Public Method | SetValue | Sets the option value based on the selected choice. For dropdown and radio, if there is no selected choice, the first choice is set for the value.
Top

See Also

Reference

Option Class
dotnetCART Namespace


%%PageItemTitle%%

Option Constructor
[image]
dotnetCART Namespace > Option Class : Option Constructor

Initializes a new instance of the Option class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Option()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Option Class
Option Members


%%PageItemTitle%% $$Methods$$

Option Class Methods
[image]
dotnetCART Namespace : Option Class

For a list of all members of this type, see Option members.

Public Methods

 | Name | Description
Public Method | Clear | Overridden. Initializes all the properties without recreating the object.
Public Method | Clone | Creates a copy of the current Option
Public Method | DeleteDB | Overloaded. Deletes this object from the Options table and the binding from the specified itemID.
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<Option, Int64>)
Public Method | GetHtml | Overloaded. Returns an HTML formatted string for the option and its choices for adding a single item.
Public Method | LoadDB | Overloaded. Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<Option, Int64>)
Public Method | SaveDB | Overloaded. Overridden. Inserts or updates this object into the Options table.
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<Option, Int64>)
Public Method | SetValue | Sets the option value based on the selected choice. For dropdown and radio, if there is no selected choice, the first choice is set for the value.
Top

See Also

Reference

Option Class
dotnetCART Namespace


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > Option Class : Clear Method

Initializes all the properties without recreating the object.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Clear()
C#
public override void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Option Class
Option Members


%%PageItemTitle%%

Clone Method
[image]
dotnetCART Namespace > Option Class : Clone Method

Creates a copy of the current Option

Syntax

Visual Basic (Declaration)
Public Function Clone() As Option
C#
public Option Clone()

Return Value

Returns an Option object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Option Class
Option Members


%%PageItemTitle%%

DeleteDB Method
[image]
dotnetCART Namespace > Option Class : DeleteDB Method

Deletes this object from the Options table and the binding from the specified itemID.

Overload List

Overload | Description
DeleteDB(String) | Deletes this object from the Options table and the binding from the specified itemID.
DeleteDB() | Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<Option, Int64>)
DeleteDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Option Class
Option Members


%%PageItemTitle%%

DeleteDB(String) Method
[image]
dotnetCART Namespace > Option Class > DeleteDB Method : DeleteDB(String) Method

itemID
The itemID for binding to this option.
Deletes this object from the Options table and the binding from the specified itemID.

Syntax

Visual Basic (Declaration)
Public Overloads Function DeleteDB( _
   ByVal itemID As String _
) As Integer
C#
public int DeleteDB(
   string itemID
)

Parameters

itemID
The itemID for binding to this option.

Return Value

Returns 1 for the delete, returns -1 if failed. For the reason of fail, check the Error property.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Option Class
Option Members
Overload List


%%PageItemTitle%%

GetHtml Method
[image]
dotnetCART Namespace > Option Class : GetHtml Method

Returns an HTML formatted string for the option and its choices for adding a single item.

Overload List

Overload | Description
GetHtml(Int32) | Returns an HTML formatted string for the option and its choices for adding a single item.
GetHtml(Int32,Int32) |

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Option Class
Option Members


%%PageItemTitle%%

GetHtml(Int32) Method
[image]
dotnetCART Namespace > Option Class > GetHtml Method : GetHtml(Int32) Method

optionIndex
Returns an HTML formatted string for the option and its choices for adding a single item.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetHtml( _
   ByVal optionIndex As Integer _
) As String
C#
public string GetHtml(
   int optionIndex
)

Parameters

optionIndex

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Option Class
Option Members
Overload List


%%PageItemTitle%%

GetHtml(Int32,Int32) Method
[image]
dotnetCART Namespace > Option Class > GetHtml Method : GetHtml(Int32,Int32) Method

optionIndex
itemIndex

Syntax

Visual Basic (Declaration)
Public Overloads Function GetHtml( _
   ByVal optionIndex As Integer, _
   ByVal itemIndex As Integer _
) As String
C#
public string GetHtml(
   int optionIndex,
   int itemIndex
)

Parameters

optionIndex
itemIndex

Remarks

 Usually this method used when iterating though an items collection with one or more options when item.MutiAdd is true. ItemIndex should starts from 1 and increments by one for the next call.
The hidden fields' names are:
ITEM1_OPTION_ID, ITEM1_OPTION1_NAME, ITEM1_OPTION1_TYPE, ITEM1_OPTION1_LABEL, ITEM1_OPTION1_REQUIRED
ITEM1_OPTION1_CHOICE_ID, ITEM1_OPTION1_CHOICE_NAME, ITEM1_OPTION1_CHOICE_ADJUSTPRICE, ITEM1_OPTION1_CHOICE_ADJUSTWEIGHT

Int ItemIndex=0;
foreach(Item it in CartObject.Catalog.Category.Items)
{
     ItemIndex++;
     Response.Write (GetHtml (ItemIndex));
     Int OptionIndex=0;
     foreach (Option opt in CartObject.Catalog.Category.Item.Options)
     {
         OptionIndex++;
         Response.Write (opt.GetHtml (OptionIndex));
     }
 }

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Option Class
Option Members
Overload List


%%PageItemTitle%%

SaveDB Method
[image]
dotnetCART Namespace > Option Class : SaveDB Method

Inserts or updates this object into the Options table.

Overload List

Overload | Description
SaveDB() | Inserts or updates this object into the Options table.
SaveDB(String) | Inserts or updates this object into the Options table and binding to the specified itemID.
SaveDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Option Class
Option Members


%%PageItemTitle%%

SaveDB() Method
[image]
dotnetCART Namespace > Option Class > SaveDB Method : SaveDB() Method

Inserts or updates this object into the Options table.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function SaveDB() As Integer
C#
public override int SaveDB()

Return Value

Returns the generated ID or 1 for the update, returns -1 if failed. For the reason of fail, check the Error property.

Remarks

If ID greater than 0, it updates the associated record in the table, otherwise inserts a new record.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Option Class
Option Members
Overload List


%%PageItemTitle%%

SaveDB(String) Method
[image]
dotnetCART Namespace > Option Class > SaveDB Method : SaveDB(String) Method

itemID
The itemID for binding to this option.
Inserts or updates this object into the Options table and binding to the specified itemID.

Syntax

Visual Basic (Declaration)
Public Overloads Function SaveDB( _
   ByVal itemID As String _
) As Integer
C#
public int SaveDB(
   string itemID
)

Parameters

itemID
The itemID for binding to this option.

Return Value

Returns the generated ID or 1 for the update, returns -1 if failed. For the reason of fail, check the Error property.

Remarks

If ID greater than 0, it updates the associated record in the table, otherwise inserts a new record.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Option Class
Option Members
Overload List


%%PageItemTitle%%

SetValue Method
[image]
dotnetCART Namespace > Option Class : SetValue Method

Sets the option value based on the selected choice. For dropdown and radio, if there is no selected choice, the first choice is set for the value.

Syntax

Visual Basic (Declaration)
Public Sub SetValue()
C#
public void SetValue()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Option Class
Option Members


%%PageItemTitle%% $$Properties$$

Option Class Properties
[image]
dotnetCART Namespace : Option Class

For a list of all members of this type, see Option members.

Public Properties

 | Name | Description
Public Property | AddOn | Determines whether this option is an add-on (like frame for a picture) or part of the item characteristic. (like color for T-shirt)
Public Property | Choice | A reference to the Choice associated with this option. It is added to the Option.Choices when invoking %"Option.Add():T:Option.Add()% method.
Public Property | Choices | A reference to the Choices associated with this option.
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<Option, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<Option, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<Option, Int64>)
Public Property | Description | Gets or sets a description for this option.
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<Option, Int64>)
Public Property | ID | Overridden. The auto number ID populated from the database.
Public Property | Items | A reference to the Items associated with this option.
Public Property | Label | Gets or sets this option label.
Public Property | Name | Gets or sets this option name.
Public Property | Required | Determines if the option is required or not. Defaults to false.
Public Property | Type | Gets or sets this option type.
Public Property | Value | Gets or sets this option value. This is usually the name of the selected choice.
Top

See Also

Reference

Option Class
dotnetCART Namespace


%%PageItemTitle%%

AddOn Property
[image]
dotnetCART Namespace > Option Class : AddOn Property

Determines whether this option is an add-on (like frame for a picture) or part of the item characteristic. (like color for T-shirt)

Syntax

Visual Basic (Declaration)
Public Property AddOn As Boolean
C#
public bool AddOn {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Option Class
Option Members


%%PageItemTitle%%

Choice Property
[image]
dotnetCART Namespace > Option Class : Choice Property

A reference to the Choice associated with this option. It is added to the Option.Choices when invoking %"Option.Add():T:Option.Add()% method.

Syntax

Visual Basic (Declaration)
Public Property Choice As Choice
C#
public Choice Choice {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Option Class
Option Members


%%PageItemTitle%%

Choices Property
[image]
dotnetCART Namespace > Option Class : Choices Property

A reference to the Choices associated with this option.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Choices As Choices
C#
public Choices Choices {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Option Class
Option Members


%%PageItemTitle%%

Description Property
[image]
dotnetCART Namespace > Option Class : Description Property

Gets or sets a description for this option.

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Option Class
Option Members


%%PageItemTitle%%

ID Property
[image]
dotnetCART Namespace > Option Class : ID Property

The auto number ID populated from the database.

Syntax

Visual Basic (Declaration)
Public Overrides Property ID As Long
C#
public override long ID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Option Class
Option Members


%%PageItemTitle%%

Items Property
[image]
dotnetCART Namespace > Option Class : Items Property

A reference to the Items associated with this option.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Items As EntitySet(Of Item)
C#
public EntitySet<Item> Items {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Option Class
Option Members


%%PageItemTitle%%

Label Property
[image]
dotnetCART Namespace > Option Class : Label Property

Gets or sets this option label.

Syntax

Visual Basic (Declaration)
Public Property Label As String
C#
public string Label {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Option Class
Option Members


%%PageItemTitle%%

Name Property
[image]
dotnetCART Namespace > Option Class : Name Property

Gets or sets this option name.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Option Class
Option Members


%%PageItemTitle%%

Required Property
[image]
dotnetCART Namespace > Option Class : Required Property

Determines if the option is required or not. Defaults to false.

Syntax

Visual Basic (Declaration)
Public Property Required As Boolean
C#
public bool Required {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Option Class
Option Members


%%PageItemTitle%%

Type Property
[image]
dotnetCART Namespace > Option Class : Type Property

Gets or sets this option type.

Syntax

Visual Basic (Declaration)
Public Property Type As OptionType
C#
public OptionType Type {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Option Class
Option Members


%%PageItemTitle%%

Value Property
[image]
dotnetCART Namespace > Option Class : Value Property

Gets or sets this option value. This is usually the name of the selected choice.

Syntax

Visual Basic (Declaration)
Public Property Value As String
C#
public string Value {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Option Class
Option Members


%%PageItemTitle%%

Options Class
See Also Members
[image]
dotnetCART Namespace : Options Class

A collection of Option objects.

Object Model

Syntax

Visual Basic (Declaration)
Public Class Options
   Inherits EntitySet(Of Option)
C#
public class Options : EntitySet<Option>

Inheritance Hierarchy

System.Object
dotnetDATA.EntitySet<Option>
dotnetCART.Options

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Options Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

Options Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : Options Class

The following tables list the members exposed by Options.

Public Constructors

 | Name | Description
Public Constructor | Options Constructor | Overloaded. Initializes a new instance of the Options.
Top

Public Properties

 | Name | Description
Public Property | Count | Returns the number of items in the collection. (Inherited from dotnetDATA.EntitySet<Option>)
Public Property | Error | Gets the error object.
Public Property | Item | Overloaded. Gets the option at the specified index.
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds the OrderItem.Options to this collection.
Public Method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetDATA.EntitySet<Option>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetDATA.EntitySet<Option>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetDATA.EntitySet<Option>)
Public Method | DeleteDB | Deletes all the options from Options table.
Public Method | GetIndex | Returns the Option index for with the specified name.
Public Method | GetOption | Overloaded. Gets the option with the specified name.
Public Method | IndexOf | Returns the index of this item in the list. (Inherited from dotnetDATA.EntitySet<Option>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetDATA.EntitySet<Option>)
Public Method | LoadDB | Loads all the options from database.
Public Method | Remove | Removes the item from the collection. (Inherited from dotnetDATA.EntitySet<Option>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetDATA.EntitySet<Option>)
Top

See Also

Reference

Options Class
dotnetCART Namespace


%%PageItemTitle%%

Options Constructor
[image]
dotnetCART Namespace > Options Class : Options Constructor

Initializes a new instance of the Options.

Overload List

Overload | Description
Options Constructor() | Initializes a new instance of the Options.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Options Class
Options Members


%%PageItemTitle%%

Options Constructor()
See Also
[image]
dotnetCART Namespace > Options Class > Options Constructor : Options Constructor()

Initializes a new instance of the Options.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Options()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Options Class
Options Members
Overload List


%%PageItemTitle%% $$Methods$$

Options Class Methods
[image]
dotnetCART Namespace : Options Class

For a list of all members of this type, see Options members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds the OrderItem.Options to this collection.
Public Method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetDATA.EntitySet<Option>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetDATA.EntitySet<Option>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetDATA.EntitySet<Option>)
Public Method | DeleteDB | Deletes all the options from Options table.
Public Method | GetIndex | Returns the Option index for with the specified name.
Public Method | GetOption | Overloaded. Gets the option with the specified name.
Public Method | IndexOf | Returns the index of this item in the list. (Inherited from dotnetDATA.EntitySet<Option>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetDATA.EntitySet<Option>)
Public Method | LoadDB | Loads all the options from database.
Public Method | Remove | Removes the item from the collection. (Inherited from dotnetDATA.EntitySet<Option>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetDATA.EntitySet<Option>)
Top

See Also

Reference

Options Class
dotnetCART Namespace


%%PageItemTitle%%

Add Method
[image]
dotnetCART Namespace > Options Class : Add Method

Adds the OrderItem.Options to this collection.

Overload List

Overload | Description
Add(Generic EntitySet) | Adds the OrderItem.Options to this collection.
Add() | Adds the Item.Option to this collection.
Add(Option) | (Inherited from dotnetDATA.EntitySet<Option>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Options Class
Options Members


%%PageItemTitle%%

Add(Generic EntitySet) Method
[image]
dotnetCART Namespace > Options Class > Add Method : Add(Generic EntitySet) Method

orderItemOptions
Adds the OrderItem.Options to this collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add( _
   ByVal orderItemOptions As EntitySet(Of OrderItemOption) _
)
C#
public void Add(
   EntitySet<OrderItemOption> orderItemOptions
)

Parameters

orderItemOptions

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Options Class
Options Members
Overload List


%%PageItemTitle%%

Add() Method
[image]
dotnetCART Namespace > Options Class > Add Method : Add() Method

Adds the Item.Option to this collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add()
C#
public void Add()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Options Class
Options Members
Overload List


%%PageItemTitle%%

DeleteDB Method
[image]
dotnetCART Namespace > Options Class : DeleteDB Method

Deletes all the options from Options table.

Syntax

Visual Basic (Declaration)
Public Function DeleteDB() As Integer
C#
public int DeleteDB()

Return Value

Total number of deleted options.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Options Class
Options Members


%%PageItemTitle%%

GetIndex Method
[image]
dotnetCART Namespace > Options Class : GetIndex Method

name
The name of the option.
Returns the Option index for with the specified name.

Syntax

Visual Basic (Declaration)
Public Function GetIndex( _
   ByVal name As String _
) As Integer
C#
public int GetIndex(
   string name
)

Parameters

name
The name of the option.

Return Value

If found, returns the index, otherwise -1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Options Class
Options Members


%%PageItemTitle%%

GetOption Method
[image]
dotnetCART Namespace > Options Class : GetOption Method

Gets the option with the specified name.

Overload List

Overload | Description
GetOption(String) | Gets the option with the specified name.
GetOption(Int64) | Returns the Option with the specified ID.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Options Class
Options Members


%%PageItemTitle%%

GetOption(String) Method
[image]
dotnetCART Namespace > Options Class > GetOption Method : GetOption(String) Method

name
The name of the option.
Gets the option with the specified name.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetOption( _
   ByVal name As String _
) As Option
C#
public Option GetOption(
   string name
)

Parameters

name
The name of the option.

Return Value

Returns the option with the specified name.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Options Class
Options Members
Overload List


%%PageItemTitle%%

GetOption(Int64) Method
[image]
dotnetCART Namespace > Options Class > GetOption Method : GetOption(Int64) Method

optionID
An option ID.
Returns the Option with the specified ID.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetOption( _
   ByVal optionID As Long _
) As Option
C#
public Option GetOption(
   long optionID
)

Parameters

optionID
An option ID.

Return Value

An option object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Options Class
Options Members
Overload List


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > Options Class : LoadDB Method

Loads all the options from database.

Syntax

Visual Basic (Declaration)
Public Function LoadDB() As Integer
C#
public int LoadDB()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Options Class
Options Members


%%PageItemTitle%% $$Properties$$

Options Class Properties
[image]
dotnetCART Namespace : Options Class

For a list of all members of this type, see Options members.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of items in the collection. (Inherited from dotnetDATA.EntitySet<Option>)
Public Property | Error | Gets the error object.
Public Property | Item | Overloaded. Gets the option at the specified index.
Top

See Also

Reference

Options Class
dotnetCART Namespace


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > Options Class : Error Property

Gets the error object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Options Class
Options Members


%%PageItemTitle%%

Item Property
[image]
dotnetCART Namespace > Options Class : Item Property

Gets the option at the specified index.

Overload List

Overload | Description
Item(Int32) | Gets the option at the specified index.
Item(String) | Gets the option's value with the specified name.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Options Class
Options Members


%%PageItemTitle%%

Item(Int32) Property
[image]
dotnetCART Namespace > Options Class > Item Property : Item(Int32) Property

index
The zero-based index of the element to get.
Gets the option at the specified index.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As Option
C#
public Option Item(
   int index
) {get;}

Parameters

index
The zero-based index of the element to get.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Options Class
Options Members
Overload List


%%PageItemTitle%%

Item(String) Property
[image]
dotnetCART Namespace > Options Class > Item Property : Item(String) Property

name
The name of the option.
Gets the option's value with the specified name.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal name As String _
) As String
C#
public string Item(
   string name
) {get;}

Parameters

name
The name of the option.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Options Class
Options Members
Overload List


%%PageItemTitle%%

OptionSelection Class
See Also Members
[image]
dotnetCART Namespace : OptionSelection Class

Represents an option's selction object.

Syntax

Visual Basic (Declaration)
Public Class OptionSelection
C#
public class OptionSelection

Remarks

This object is used in SubItemMapping.OptionSelections collection to create sub items./>

Inheritance Hierarchy

System.Object
dotnetCART.OptionSelection

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OptionSelection Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

OptionSelection Class Members
See Also Properties
[image]
dotnetCART Namespace : OptionSelection Class

The following tables list the members exposed by OptionSelection.

Public Constructors

 | Name | Description
Public Constructor | OptionSelection Constructor |
Top

Public Properties

 | Name | Description
Public Property | ChoiceID | The ID for the choice.
Public Property | OptionID | The ID for the option.
Top

See Also

Reference

OptionSelection Class
dotnetCART Namespace


%%PageItemTitle%%

OptionSelection Constructor
[image]
dotnetCART Namespace > OptionSelection Class : OptionSelection Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OptionSelection()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OptionSelection Class
OptionSelection Members


%%PageItemTitle%% $$Properties$$

OptionSelection Class Properties
[image]
dotnetCART Namespace : OptionSelection Class

For a list of all members of this type, see OptionSelection members.

Public Properties

 | Name | Description
Public Property | ChoiceID | The ID for the choice.
Public Property | OptionID | The ID for the option.
Top

See Also

Reference

OptionSelection Class
dotnetCART Namespace


%%PageItemTitle%%

ChoiceID Property
[image]
dotnetCART Namespace > OptionSelection Class : ChoiceID Property

The ID for the choice.

Syntax

Visual Basic (Declaration)
Public Property ChoiceID As Long
C#
public long ChoiceID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OptionSelection Class
OptionSelection Members


%%PageItemTitle%%

OptionID Property
[image]
dotnetCART Namespace > OptionSelection Class : OptionID Property

The ID for the option.

Syntax

Visual Basic (Declaration)
Public Property OptionID As Long
C#
public long OptionID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OptionSelection Class
OptionSelection Members


%%PageItemTitle%%

Order Class
See Also Members
[image]
dotnetCART Namespace : Order Class

Represents an order object.

Object Model

Syntax

Visual Basic (Declaration)
Public Class Order
   Inherits DbTableCart(Of Order, Long)
C#
public class Order : DbTableCart<Order, long>

Inheritance Hierarchy

System.Object
dotnetDATA.DbTable<Int64>
dotnetDATA.DbTable<Order, Int64>
dotnetCART.DbTableCart<Order, Int64>
dotnetCART.Order

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

Order Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : Order Class

The following tables list the members exposed by Order.

Public Constructors

 | Name | Description
Public Constructor | Order Constructor | Initializes a new instance of the Order class.
Top

Public Properties

 | Name | Description
Public Property | Addresses | A reference to the Addresses in this order.
Public Property | Adjust | Gets or sets the order adjust. It is saved/loaded from orders table. It can be re-calculated using Calculate method.
Public Property | AdjustRate | The order level adjust rate code which can be set as a dollar amount or percentage based on dollar or quantity ranges. Adjustment is a discount if negative or surcharge if positive. It is used by Calculate method to calculate Ajust value.
Public Property | BillAddress | Reference to the billing address. The following properties are exposed: Name, Street, ZipPostal, StateProvince, City, Country, Fax, Phone, Email and Customs.
Public Property | CartID | It is a unique ID which is used to manage an order before adding it to the database and having auto number order ID.
Public Property | ClientIP | Gets or sets the client IP. It is saved/loaded from orders table.
Public Property | Coupons | Collection of OrderCoupon objects. It is saved/loaded from OrderCoupons table.
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<Order, Int64>)
Public Property | Customer | Reference to Customer properties. It is saved/loaded from orders table.
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<Order, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<Order, Int64>)
Public Property | Date | Gets or sets the order Date. It is saved/loaded from the OrderDate field of the orders table.
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<Order, Int64>)
Public Property | FraudScore | Gets or sets the order fraud score. It is saved/loaded from FraudScore field of the orders table.
Public Property | ID | Overridden. The auto number ID populated from the database.
Public Property | InBoundQuery | Gets or sets the referrer InBoundQuery for this order.
Public Property | Item | Represents an Item object and can be used for adding an item to Items property.
Public Property | Items | Collection of Item objects including options and address and loaded from OrderItems, OrderItemOptions and OrderAddresses tables.
Public Property | Notes | Gets or sets the Order Notes. It is saved/loaded from orders table.
Public Property | Payment | Reference to Payment properties and loaded from orders table.
Public Property | ReferrerDomain | Gets or sets the referrer domain for this order.
Public Property | ShipAddress | Reference to the shipping address. The following properties are exposed: Name, Street, ZipPostal, StateProvince, City, Country, Fax, Phone, Email, ShipBy, ShipAmount, ShipDate, ShipTracking and Customs.
Public Property | Status | Order status and loaded from orders table.
Public Property | SubTotal | Total charge amount for all the items the cart.
Public Property | Taxes | Collection ofOrderTax objects that apply to the Order. It is saved/loaded from OrderTaxes table.
Public Property | Total | Total charge amount for the cart including all taxes, shipping, discounts etc and loaded from Total field of the Orders table. It can be re-calculated using Calculate method.
Public Property | TotalAdjust | Calculates all items and order adjust.
Public Property | TotalCost | Total charge amount for the cart including all taxes, shipping, discounts etc. It is saved/loaded from Total field of the Orders table. It can be re-calculated using Calculate method.
Public Property | TotalCoupon | TotalCoupon value based on coupons applied to the items in the Order. It is saved/loaded from TotalCoupon field of the orders table.
Public Property | TotalQuantity | Total quantity of the items in the order.
Public Property | TotalShipping | Total shipping charges for the Order. It is saved/loaded from TotalShipping field of the orders table.
Public Property | TotalTax | Total amount of tax for the Order Order. It is saved/loaded from TotalTax field of the orders table.
Public Property | TotalWeight | Total wieght of the Order and loaded from TotalWeight field of the orders table.
Public Property | Transactions | Collection of OrderTransaction objects that apply to the Order and loaded from OrderTransactions table.
Top

Public Methods

 | Name | Description
Public Method | Calculate | Calculates the derived order values (total, adjustments, shipping etc) based on the items, tax and shipping details that exist in the cart. This method sets SubTotal, TotalTax, TotalShipping, TotalCoupon and Adjust. Note if you have manually set one of the subtotal properties calculate will recognise this and not calculate it, instead the provided value will be used and totaled with any other calculated values.
Public Method | CalculateDB | Calculates the derived order values (total, adjustments, shipping etc) based on the items, tax and shipping details that exist in the cart. This method sets SubTotal, TotalTax, TotalShipping, TotalCoupon and Adjust. Note if you have manually set one of the subtotal properties calculate will recognise this and not calculate it, instead the provided value will be used and totaled with any other calculated values. This method loads the original item, tax, coupon data from the database.
Public Method | CalculateShipping | Calculates and sets TotalShipping based on the current values in ShipAmount in Addresses. Note, this method does not calculate the actual ShipAmount, it just adds them and sets Cart.TotalShipping.
Public Method | CalculateTotal | Calculates and sets Total based on the current values in SubTotal, TotalTax, TotalShipping, TotalCoupon and Adjust. Note, this method does not calculate the actual values the Total is based on, it just adds them and sets Order.Total. If you wish to calculate the values based on the current cart the Calculate method should be used instead.
Public Method | Clear | Initializes all the properties without recreating the object. (Inherited from dotnetCART.DbTableCart<Order, Int64>)
Public Method | DeleteCookie | Deletes dotnetcartCustomerOrderID Cookie which is used to store the encrypted Order.ID.
Public Method | DeleteDB | Overloaded. Overridden. Deletes this order and all the associated records from database.
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<Order, Int64>)
Public Method | GroupItemsByAddress | Groups items by their ship address in Addressescollection. Add all the items for each address to Address.Items collection. Only Item.Address.ID is compared for grouping the items.
Public Method | LoadCookie | Loads Order.ID from dotnetcartCustomerOrderID Cookie.
Public Method | LoadDB | Overloaded. Overridden.
Public Method | LoadTaxesDB | Loads taxes from Taxes table. This method is being used when the order is updated and the order tax should be recalcuated.
Public Method | SaveCookie | Encrypt the Order.ID and stores in dotnetcartCustomerOrderID cookie.
Public Method | SaveDB | Overloaded. Overridden. Inserts or updates this object into the Orders table.
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<Order, Int64>)
Top

See Also

Reference

Order Class
dotnetCART Namespace


%%PageItemTitle%%

Order Constructor
[image]
dotnetCART Namespace > Order Class : Order Constructor

Initializes a new instance of the Order class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Order()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members


%%PageItemTitle%% $$Methods$$

Order Class Methods
[image]
dotnetCART Namespace : Order Class

For a list of all members of this type, see Order members.

Public Methods

 | Name | Description
Public Method | Calculate | Calculates the derived order values (total, adjustments, shipping etc) based on the items, tax and shipping details that exist in the cart. This method sets SubTotal, TotalTax, TotalShipping, TotalCoupon and Adjust. Note if you have manually set one of the subtotal properties calculate will recognise this and not calculate it, instead the provided value will be used and totaled with any other calculated values.
Public Method | CalculateDB | Calculates the derived order values (total, adjustments, shipping etc) based on the items, tax and shipping details that exist in the cart. This method sets SubTotal, TotalTax, TotalShipping, TotalCoupon and Adjust. Note if you have manually set one of the subtotal properties calculate will recognise this and not calculate it, instead the provided value will be used and totaled with any other calculated values. This method loads the original item, tax, coupon data from the database.
Public Method | CalculateShipping | Calculates and sets TotalShipping based on the current values in ShipAmount in Addresses. Note, this method does not calculate the actual ShipAmount, it just adds them and sets Cart.TotalShipping.
Public Method | CalculateTotal | Calculates and sets Total based on the current values in SubTotal, TotalTax, TotalShipping, TotalCoupon and Adjust. Note, this method does not calculate the actual values the Total is based on, it just adds them and sets Order.Total. If you wish to calculate the values based on the current cart the Calculate method should be used instead.
Public Method | Clear | Initializes all the properties without recreating the object. (Inherited from dotnetCART.DbTableCart<Order, Int64>)
Public Method | DeleteCookie | Deletes dotnetcartCustomerOrderID Cookie which is used to store the encrypted Order.ID.
Public Method | DeleteDB | Overloaded. Overridden. Deletes this order and all the associated records from database.
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<Order, Int64>)
Public Method | GroupItemsByAddress | Groups items by their ship address in Addressescollection. Add all the items for each address to Address.Items collection. Only Item.Address.ID is compared for grouping the items.
Public Method | LoadCookie | Loads Order.ID from dotnetcartCustomerOrderID Cookie.
Public Method | LoadDB | Overloaded. Overridden.
Public Method | LoadTaxesDB | Loads taxes from Taxes table. This method is being used when the order is updated and the order tax should be recalcuated.
Public Method | SaveCookie | Encrypt the Order.ID and stores in dotnetcartCustomerOrderID cookie.
Public Method | SaveDB | Overloaded. Overridden. Inserts or updates this object into the Orders table.
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<Order, Int64>)
Top

See Also

Reference

Order Class
dotnetCART Namespace


%%PageItemTitle%%

Calculate Method
[image]
dotnetCART Namespace > Order Class : Calculate Method

Calculates the derived order values (total, adjustments, shipping etc) based on the items, tax and shipping details that exist in the cart. This method sets SubTotal, TotalTax, TotalShipping, TotalCoupon and Adjust. Note if you have manually set one of the subtotal properties calculate will recognise this and not calculate it, instead the provided value will be used and totaled with any other calculated values.

Syntax

Visual Basic (Declaration)
Public Function Calculate() As Boolean
C#
public bool Calculate()

Return Value

A Boolean indicates whether the operation is successful or not.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members


%%PageItemTitle%%

CalculateDB Method
[image]
dotnetCART Namespace > Order Class : CalculateDB Method

Calculates the derived order values (total, adjustments, shipping etc) based on the items, tax and shipping details that exist in the cart. This method sets SubTotal, TotalTax, TotalShipping, TotalCoupon and Adjust. Note if you have manually set one of the subtotal properties calculate will recognise this and not calculate it, instead the provided value will be used and totaled with any other calculated values. This method loads the original item, tax, coupon data from the database.

Syntax

Visual Basic (Declaration)
Public Function CalculateDB() As Boolean
C#
public bool CalculateDB()

Return Value

A Boolean indicates whether the operation is successful or not.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members


%%PageItemTitle%%

CalculateShipping Method
[image]
dotnetCART Namespace > Order Class : CalculateShipping Method

Calculates and sets TotalShipping based on the current values in ShipAmount in Addresses. Note, this method does not calculate the actual ShipAmount, it just adds them and sets Cart.TotalShipping.

Syntax

Visual Basic (Declaration)
Public Function CalculateShipping() As Decimal
C#
public decimal CalculateShipping()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members


%%PageItemTitle%%

CalculateTotal Method
[image]
dotnetCART Namespace > Order Class : CalculateTotal Method

Calculates and sets Total based on the current values in SubTotal, TotalTax, TotalShipping, TotalCoupon and Adjust. Note, this method does not calculate the actual values the Total is based on, it just adds them and sets Order.Total. If you wish to calculate the values based on the current cart the Calculate method should be used instead.

Syntax

Visual Basic (Declaration)
Public Function CalculateTotal() As Decimal
C#
public decimal CalculateTotal()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members


%%PageItemTitle%%

DeleteCookie Method
[image]
dotnetCART Namespace > Order Class : DeleteCookie Method

Deletes dotnetcartCustomerOrderID Cookie which is used to store the encrypted Order.ID.

Syntax

Visual Basic (Declaration)
Public Function DeleteCookie() As Boolean
C#
public bool DeleteCookie()

Return Value

Retuns true if the cookie found and deleted or the cookie doesn't exist. If there is any error, returns false. See Error for more information about the error.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members


%%PageItemTitle%%

DeleteDB Method
[image]
dotnetCART Namespace > Order Class : DeleteDB Method

Deletes this order and all the associated records from database.

Overload List

Overload | Description
DeleteDB() | Deletes this order and all the associated records from database.
DeleteDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members


%%PageItemTitle%%

DeleteDB() Method
[image]
dotnetCART Namespace > Order Class > DeleteDB Method : DeleteDB() Method

Deletes this order and all the associated records from database.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function DeleteDB() As Integer
C#
public override int DeleteDB()

Return Value

In case of error -1, check Error property, otherwise the number of records deleted.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members
Overload List


%%PageItemTitle%%

GroupItemsByAddress Method
[image]
dotnetCART Namespace > Order Class : GroupItemsByAddress Method

Groups items by their ship address in Addressescollection. Add all the items for each address to Address.Items collection. Only Item.Address.ID is compared for grouping the items.

Syntax

Visual Basic (Declaration)
Public Sub GroupItemsByAddress()
C#
public void GroupItemsByAddress()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members


%%PageItemTitle%%

LoadCookie Method
[image]
dotnetCART Namespace > Order Class : LoadCookie Method

Loads Order.ID from dotnetcartCustomerOrderID Cookie.

Syntax

Visual Basic (Declaration)
Public Function LoadCookie() As Long
C#
public long LoadCookie()

Return Value

Returns the order ID, if not found returns 0.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > Order Class : LoadDB Method

Overload List

Overload | Description
LoadDB() |
LoadDB(Int64) |
Generic LoadDB() | (Inherited from dotnetDATA.DbTable<Int64>)
Generic LoadDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > Order Class > LoadDB Method : LoadDB() Method

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function LoadDB() As Integer
C#
public override int LoadDB()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members
Overload List


%%PageItemTitle%%

LoadDB(Int64) Method
[image]
dotnetCART Namespace > Order Class > LoadDB Method : LoadDB(Int64) Method

orderID

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function LoadDB( _
   ByVal orderID As Long _
) As Integer
C#
public override int LoadDB(
   long orderID
)

Parameters

orderID

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members
Overload List


%%PageItemTitle%%

LoadTaxesDB Method
[image]
dotnetCART Namespace > Order Class : LoadTaxesDB Method

Loads taxes from Taxes table. This method is being used when the order is updated and the order tax should be recalcuated.

Syntax

Visual Basic (Declaration)
Public Sub LoadTaxesDB()
C#
public void LoadTaxesDB()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members


%%PageItemTitle%%

SaveCookie Method
[image]
dotnetCART Namespace > Order Class : SaveCookie Method

Encrypt the Order.ID and stores in dotnetcartCustomerOrderID cookie.

Syntax

Visual Basic (Declaration)
Public Function SaveCookie() As Boolean
C#
public bool SaveCookie()

Return Value

Retuns true if the Order.ID stored in the dotnetcartCustomerOrderID cookie successfully. If there is any error, returns false. See Error for more information about the error.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members


%%PageItemTitle%%

SaveDB Method
[image]
dotnetCART Namespace > Order Class : SaveDB Method

Inserts or updates this object into the Orders table.

Overload List

Overload | Description
SaveDB() | Inserts or updates this object into the Orders table.
SaveDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members


%%PageItemTitle%%

SaveDB() Method
[image]
dotnetCART Namespace > Order Class > SaveDB Method : SaveDB() Method

Inserts or updates this object into the Orders table.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function SaveDB() As Integer
C#
public override int SaveDB()

Return Value

Returns the generated ID or 1 for the update, returns -1 if failed. For the reason of fail, check the Error property.

Remarks

If ID greater than 0, it updates the associated record in the table, otherwise inserts a new record.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members
Overload List


%%PageItemTitle%% $$Properties$$

Order Class Properties
[image]
dotnetCART Namespace : Order Class

For a list of all members of this type, see Order members.

Public Properties

 | Name | Description
Public Property | Addresses | A reference to the Addresses in this order.
Public Property | Adjust | Gets or sets the order adjust. It is saved/loaded from orders table. It can be re-calculated using Calculate method.
Public Property | AdjustRate | The order level adjust rate code which can be set as a dollar amount or percentage based on dollar or quantity ranges. Adjustment is a discount if negative or surcharge if positive. It is used by Calculate method to calculate Ajust value.
Public Property | BillAddress | Reference to the billing address. The following properties are exposed: Name, Street, ZipPostal, StateProvince, City, Country, Fax, Phone, Email and Customs.
Public Property | CartID | It is a unique ID which is used to manage an order before adding it to the database and having auto number order ID.
Public Property | ClientIP | Gets or sets the client IP. It is saved/loaded from orders table.
Public Property | Coupons | Collection of OrderCoupon objects. It is saved/loaded from OrderCoupons table.
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<Order, Int64>)
Public Property | Customer | Reference to Customer properties. It is saved/loaded from orders table.
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<Order, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<Order, Int64>)
Public Property | Date | Gets or sets the order Date. It is saved/loaded from the OrderDate field of the orders table.
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<Order, Int64>)
Public Property | FraudScore | Gets or sets the order fraud score. It is saved/loaded from FraudScore field of the orders table.
Public Property | ID | Overridden. The auto number ID populated from the database.
Public Property | InBoundQuery | Gets or sets the referrer InBoundQuery for this order.
Public Property | Item | Represents an Item object and can be used for adding an item to Items property.
Public Property | Items | Collection of Item objects including options and address and loaded from OrderItems, OrderItemOptions and OrderAddresses tables.
Public Property | Notes | Gets or sets the Order Notes. It is saved/loaded from orders table.
Public Property | Payment | Reference to Payment properties and loaded from orders table.
Public Property | ReferrerDomain | Gets or sets the referrer domain for this order.
Public Property | ShipAddress | Reference to the shipping address. The following properties are exposed: Name, Street, ZipPostal, StateProvince, City, Country, Fax, Phone, Email, ShipBy, ShipAmount, ShipDate, ShipTracking and Customs.
Public Property | Status | Order status and loaded from orders table.
Public Property | SubTotal | Total charge amount for all the items the cart.
Public Property | Taxes | Collection ofOrderTax objects that apply to the Order. It is saved/loaded from OrderTaxes table.
Public Property | Total | Total charge amount for the cart including all taxes, shipping, discounts etc and loaded from Total field of the Orders table. It can be re-calculated using Calculate method.
Public Property | TotalAdjust | Calculates all items and order adjust.
Public Property | TotalCost | Total charge amount for the cart including all taxes, shipping, discounts etc. It is saved/loaded from Total field of the Orders table. It can be re-calculated using Calculate method.
Public Property | TotalCoupon | TotalCoupon value based on coupons applied to the items in the Order. It is saved/loaded from TotalCoupon field of the orders table.
Public Property | TotalQuantity | Total quantity of the items in the order.
Public Property | TotalShipping | Total shipping charges for the Order. It is saved/loaded from TotalShipping field of the orders table.
Public Property | TotalTax | Total amount of tax for the Order Order. It is saved/loaded from TotalTax field of the orders table.
Public Property | TotalWeight | Total wieght of the Order and loaded from TotalWeight field of the orders table.
Public Property | Transactions | Collection of OrderTransaction objects that apply to the Order and loaded from OrderTransactions table.
Top

See Also

Reference

Order Class
dotnetCART Namespace


%%PageItemTitle%%

Addresses Property
[image]
dotnetCART Namespace > Order Class : Addresses Property

A reference to the Addresses in this order.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Addresses As List(Of OrderAddress)
C#
public List<OrderAddress> Addresses {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members


%%PageItemTitle%%

Adjust Property
[image]
dotnetCART Namespace > Order Class : Adjust Property

Gets or sets the order adjust. It is saved/loaded from orders table. It can be re-calculated using Calculate method.

Syntax

Visual Basic (Declaration)
Public Property Adjust As Decimal
C#
public decimal Adjust {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members


%%PageItemTitle%%

AdjustRate Property
[image]
dotnetCART Namespace > Order Class : AdjustRate Property

The order level adjust rate code which can be set as a dollar amount or percentage based on dollar or quantity ranges. Adjustment is a discount if negative or surcharge if positive. It is used by Calculate method to calculate Ajust value.

Syntax

Visual Basic (Declaration)
Public Property AdjustRate As String
C#
public string AdjustRate {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members


%%PageItemTitle%%

BillAddress Property
[image]
dotnetCART Namespace > Order Class : BillAddress Property

Reference to the billing address. The following properties are exposed: Name, Street, ZipPostal, StateProvince, City, Country, Fax, Phone, Email and Customs.

Syntax

Visual Basic (Declaration)
Public Property BillAddress As OrderAddress
C#
public OrderAddress BillAddress {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members


%%PageItemTitle%%

CartID Property
[image]
dotnetCART Namespace > Order Class : CartID Property

It is a unique ID which is used to manage an order before adding it to the database and having auto number order ID.

Syntax

Visual Basic (Declaration)
Public Property CartID As String
C#
public string CartID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members


%%PageItemTitle%%

ClientIP Property
[image]
dotnetCART Namespace > Order Class : ClientIP Property

Gets or sets the client IP. It is saved/loaded from orders table.

Syntax

Visual Basic (Declaration)
Public Property ClientIP As String
C#
public string ClientIP {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members


%%PageItemTitle%%

Coupons Property
[image]
dotnetCART Namespace > Order Class : Coupons Property

Collection of OrderCoupon objects. It is saved/loaded from OrderCoupons table.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Coupons As OrderCoupons
C#
public OrderCoupons Coupons {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members


%%PageItemTitle%%

Customer Property
[image]
dotnetCART Namespace > Order Class : Customer Property

Reference to Customer properties. It is saved/loaded from orders table.

Syntax

Visual Basic (Declaration)
Public Property Customer As Customer
C#
public Customer Customer {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members


%%PageItemTitle%%

Date Property
[image]
dotnetCART Namespace > Order Class : Date Property

Gets or sets the order Date. It is saved/loaded from the OrderDate field of the orders table.

Syntax

Visual Basic (Declaration)
Public Property Date As Date
C#
public DateTime Date {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members


%%PageItemTitle%%

FraudScore Property
[image]
dotnetCART Namespace > Order Class : FraudScore Property

Gets or sets the order fraud score. It is saved/loaded from FraudScore field of the orders table.

Syntax

Visual Basic (Declaration)
Public Property FraudScore As Long
C#
public long FraudScore {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members


%%PageItemTitle%%

ID Property
[image]
dotnetCART Namespace > Order Class : ID Property

The auto number ID populated from the database.

Syntax

Visual Basic (Declaration)
Public Overrides Property ID As Long
C#
public override long ID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members


%%PageItemTitle%%

InBoundQuery Property
[image]
dotnetCART Namespace > Order Class : InBoundQuery Property

Gets or sets the referrer InBoundQuery for this order.

Syntax

Visual Basic (Declaration)
Public Property InBoundQuery As String
C#
public string InBoundQuery {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members


%%PageItemTitle%%

Item Property
[image]
dotnetCART Namespace > Order Class : Item Property

Represents an Item object and can be used for adding an item to Items property.

Syntax

Visual Basic (Declaration)
Public Property Item As OrderItem
C#
public OrderItem Item {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members


%%PageItemTitle%%

Items Property
[image]
dotnetCART Namespace > Order Class : Items Property

Collection of Item objects including options and address and loaded from OrderItems, OrderItemOptions and OrderAddresses tables.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Items As OrderItems
C#
public OrderItems Items {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members


%%PageItemTitle%%

Notes Property
[image]
dotnetCART Namespace > Order Class : Notes Property

Gets or sets the Order Notes. It is saved/loaded from orders table.

Syntax

Visual Basic (Declaration)
Public Property Notes As String
C#
public string Notes {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members


%%PageItemTitle%%

Payment Property
[image]
dotnetCART Namespace > Order Class : Payment Property

Reference to Payment properties and loaded from orders table.

Syntax

Visual Basic (Declaration)
Public Property Payment As Payment
C#
public Payment Payment {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members


%%PageItemTitle%%

ReferrerDomain Property
[image]
dotnetCART Namespace > Order Class : ReferrerDomain Property

Gets or sets the referrer domain for this order.

Syntax

Visual Basic (Declaration)
Public Property ReferrerDomain As String
C#
public string ReferrerDomain {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members


%%PageItemTitle%%

ShipAddress Property
[image]
dotnetCART Namespace > Order Class : ShipAddress Property

Reference to the shipping address. The following properties are exposed: Name, Street, ZipPostal, StateProvince, City, Country, Fax, Phone, Email, ShipBy, ShipAmount, ShipDate, ShipTracking and Customs.

Syntax

Visual Basic (Declaration)
Public Property ShipAddress As OrderAddress
C#
public OrderAddress ShipAddress {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members


%%PageItemTitle%%

Status Property
[image]
dotnetCART Namespace > Order Class : Status Property

Order status and loaded from orders table.

Syntax

Visual Basic (Declaration)
Public Property Status As String
C#
public string Status {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members


%%PageItemTitle%%

SubTotal Property
[image]
dotnetCART Namespace > Order Class : SubTotal Property

Total charge amount for all the items the cart.

Syntax

Visual Basic (Declaration)
Public Property SubTotal As Decimal
C#
public decimal SubTotal {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members


%%PageItemTitle%%

Taxes Property
[image]
dotnetCART Namespace > Order Class : Taxes Property

Collection ofOrderTax objects that apply to the Order. It is saved/loaded from OrderTaxes table.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Taxes As OrderTaxes
C#
public OrderTaxes Taxes {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members


%%PageItemTitle%%

Total Property
[image]
dotnetCART Namespace > Order Class : Total Property

Total charge amount for the cart including all taxes, shipping, discounts etc and loaded from Total field of the Orders table. It can be re-calculated using Calculate method.

Syntax

Visual Basic (Declaration)
Public Property Total As Decimal
C#
public decimal Total {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members


%%PageItemTitle%%

TotalAdjust Property
[image]
dotnetCART Namespace > Order Class : TotalAdjust Property

Calculates all items and order adjust.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TotalAdjust As Decimal
C#
public decimal TotalAdjust {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members


%%PageItemTitle%%

TotalCost Property
[image]
dotnetCART Namespace > Order Class : TotalCost Property

Total charge amount for the cart including all taxes, shipping, discounts etc. It is saved/loaded from Total field of the Orders table. It can be re-calculated using Calculate method.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TotalCost As Decimal
C#
public decimal TotalCost {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members


%%PageItemTitle%%

TotalCoupon Property
[image]
dotnetCART Namespace > Order Class : TotalCoupon Property

TotalCoupon value based on coupons applied to the items in the Order. It is saved/loaded from TotalCoupon field of the orders table.

Syntax

Visual Basic (Declaration)
Public Property TotalCoupon As Decimal
C#
public decimal TotalCoupon {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members


%%PageItemTitle%%

TotalQuantity Property
[image]
dotnetCART Namespace > Order Class : TotalQuantity Property

Total quantity of the items in the order.

Syntax

Visual Basic (Declaration)
Public Property TotalQuantity As Double
C#
public double TotalQuantity {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members


%%PageItemTitle%%

TotalShipping Property
[image]
dotnetCART Namespace > Order Class : TotalShipping Property

Total shipping charges for the Order. It is saved/loaded from TotalShipping field of the orders table.

Syntax

Visual Basic (Declaration)
Public Property TotalShipping As Decimal
C#
public decimal TotalShipping {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members


%%PageItemTitle%%

TotalTax Property
[image]
dotnetCART Namespace > Order Class : TotalTax Property

Total amount of tax for the Order Order. It is saved/loaded from TotalTax field of the orders table.

Syntax

Visual Basic (Declaration)
Public Property TotalTax As Decimal
C#
public decimal TotalTax {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members


%%PageItemTitle%%

TotalWeight Property
[image]
dotnetCART Namespace > Order Class : TotalWeight Property

Total wieght of the Order and loaded from TotalWeight field of the orders table.

Syntax

Visual Basic (Declaration)
Public Property TotalWeight As Double
C#
public double TotalWeight {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members


%%PageItemTitle%%

Transactions Property
[image]
dotnetCART Namespace > Order Class : Transactions Property

Collection of OrderTransaction objects that apply to the Order and loaded from OrderTransactions table.

Syntax

Visual Basic (Declaration)
Public Property Transactions As OrderTransactions
C#
public OrderTransactions Transactions {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members


%%PageItemTitle%%

OrderAddress Class
See Also Members
[image]
dotnetCART Namespace : OrderAddress Class

Represents an address object in an Order object.

Object Model

Syntax

Visual Basic (Declaration)
Public Class OrderAddress
   Inherits BaseAddress(Of OrderAddress)
C#
public class OrderAddress : BaseAddress<OrderAddress>

Inheritance Hierarchy

System.Object
dotnetDATA.DbTable<Int64>
dotnetDATA.DbTable<OrderAddress, Int64>
dotnetCART.DbTableCart<OrderAddress, Int64>
dotnetCART.BaseAddress<OrderAddress>
dotnetCART.OrderAddress

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderAddress Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

OrderAddress Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : OrderAddress Class

The following tables list the members exposed by OrderAddress.

Public Constructors

 | Name | Description
Public Constructor | OrderAddress Constructor | Overloaded. Initializes a new instance of the OrderAddress.
Top

Public Properties

 | Name | Description
Public Property | City | Gets or sets this address's city. (Inherited from dotnetCART.BaseAddress<OrderAddress>)
Public Property | Company | The company name of the address.
Public Property | Country | Gets or sets this address's county. (Inherited from dotnetCART.BaseAddress<OrderAddress>)
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<OrderAddress, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<OrderAddress, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<OrderAddress, Int64>)
Public Property | Email | Gets or sets this address's email. (Inherited from dotnetCART.BaseAddress<OrderAddress>)
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<OrderAddress, Int64>)
Public Property | Fax | Gets or sets this address's fax. (Inherited from dotnetCART.BaseAddress<OrderAddress>)
Public Property | ID | Overridden. The auto number ID populated from the database.
Public Property | Items | A reference to the Items associated with this order address.
Public Property | Name | Gets or sets the address name.
Public Property | Phone | Gets or sets this address's phone. (Inherited from dotnetCART.BaseAddress<OrderAddress>)
Public Property | Residential | Gets or sets a boolean that specifies whether this address is residential or not. (Inherited from dotnetCART.BaseAddress<OrderAddress>)
Public Property | ShipAmount | Gets or sets the shipping amount.
Public Property | ShipBy | Gets or sets the shipping company.
Public Property | ShipDate | Gets or sets the shipping date.
Public Property | ShipTracking | Gets or sets the tracking for the shipment.
Public Property | StateProvince | Gets or sets this address's state. (Inherited from dotnetCART.BaseAddress<OrderAddress>)
Public Property | Street | Gets or sets this address's street. (Inherited from dotnetCART.BaseAddress<OrderAddress>)
Public Property | ZipPostal | Gets or sets this address's zip postal code. (Inherited from dotnetCART.BaseAddress<OrderAddress>)
Top

Public Methods

 | Name | Description
Public Method | Clear | Overridden. Initializes all the properties without recreating the object.
Public Method | Clone | Creates a copy of the current OrderAddress
Public Method | DeleteDB | Overloaded. Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<OrderAddress, Int64>)
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<OrderAddress, Int64>)
Public Method | LoadDB | Overloaded. Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<OrderAddress, Int64>)
Public Method | SaveDB | Overloaded. Inserts or updates this object into the database. (Inherited from dotnetCART.DbTableCart<OrderAddress, Int64>)
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<OrderAddress, Int64>)
Top

See Also

Reference

OrderAddress Class
dotnetCART Namespace


%%PageItemTitle%%

OrderAddress Constructor
[image]
dotnetCART Namespace > OrderAddress Class : OrderAddress Constructor

Initializes a new instance of the OrderAddress.

Overload List

Overload | Description
OrderAddress Constructor() | Initializes a new instance of the OrderAddress.
OrderAddress Constructor(Address) | Initializes a new instance of the OrderAddress from Address object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderAddress Class
OrderAddress Members


%%PageItemTitle%%

OrderAddress Constructor()
See Also
[image]
dotnetCART Namespace > OrderAddress Class > OrderAddress Constructor : OrderAddress Constructor()

Initializes a new instance of the OrderAddress.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OrderAddress()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderAddress Class
OrderAddress Members
Overload List


%%PageItemTitle%%

OrderAddress Constructor(Address)
See Also
[image]
dotnetCART Namespace > OrderAddress Class > OrderAddress Constructor : OrderAddress Constructor(Address)

addressObject
Initializes a new instance of the OrderAddress from Address object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal addressObject As Address _
)
C#
public OrderAddress(
   Address addressObject
)

Parameters

addressObject

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderAddress Class
OrderAddress Members
Overload List


%%PageItemTitle%% $$Methods$$

OrderAddress Class Methods
[image]
dotnetCART Namespace : OrderAddress Class

For a list of all members of this type, see OrderAddress members.

Public Methods

 | Name | Description
Public Method | Clear | Overridden. Initializes all the properties without recreating the object.
Public Method | Clone | Creates a copy of the current OrderAddress
Public Method | DeleteDB | Overloaded. Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<OrderAddress, Int64>)
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<OrderAddress, Int64>)
Public Method | LoadDB | Overloaded. Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<OrderAddress, Int64>)
Public Method | SaveDB | Overloaded. Inserts or updates this object into the database. (Inherited from dotnetCART.DbTableCart<OrderAddress, Int64>)
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<OrderAddress, Int64>)
Top

See Also

Reference

OrderAddress Class
dotnetCART Namespace


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > OrderAddress Class : Clear Method

Initializes all the properties without recreating the object.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Clear()
C#
public override void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderAddress Class
OrderAddress Members


%%PageItemTitle%%

Clone Method
[image]
dotnetCART Namespace > OrderAddress Class : Clone Method

Creates a copy of the current OrderAddress

Syntax

Visual Basic (Declaration)
Public Function Clone() As OrderAddress
C#
public OrderAddress Clone()

Return Value

Returns an OrderAddress object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderAddress Class
OrderAddress Members


%%PageItemTitle%% $$Properties$$

OrderAddress Class Properties
[image]
dotnetCART Namespace : OrderAddress Class

For a list of all members of this type, see OrderAddress members.

Public Properties

 | Name | Description
Public Property | City | Gets or sets this address's city. (Inherited from dotnetCART.BaseAddress<OrderAddress>)
Public Property | Company | The company name of the address.
Public Property | Country | Gets or sets this address's county. (Inherited from dotnetCART.BaseAddress<OrderAddress>)
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<OrderAddress, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<OrderAddress, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<OrderAddress, Int64>)
Public Property | Email | Gets or sets this address's email. (Inherited from dotnetCART.BaseAddress<OrderAddress>)
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<OrderAddress, Int64>)
Public Property | Fax | Gets or sets this address's fax. (Inherited from dotnetCART.BaseAddress<OrderAddress>)
Public Property | ID | Overridden. The auto number ID populated from the database.
Public Property | Items | A reference to the Items associated with this order address.
Public Property | Name | Gets or sets the address name.
Public Property | Phone | Gets or sets this address's phone. (Inherited from dotnetCART.BaseAddress<OrderAddress>)
Public Property | Residential | Gets or sets a boolean that specifies whether this address is residential or not. (Inherited from dotnetCART.BaseAddress<OrderAddress>)
Public Property | ShipAmount | Gets or sets the shipping amount.
Public Property | ShipBy | Gets or sets the shipping company.
Public Property | ShipDate | Gets or sets the shipping date.
Public Property | ShipTracking | Gets or sets the tracking for the shipment.
Public Property | StateProvince | Gets or sets this address's state. (Inherited from dotnetCART.BaseAddress<OrderAddress>)
Public Property | Street | Gets or sets this address's street. (Inherited from dotnetCART.BaseAddress<OrderAddress>)
Public Property | ZipPostal | Gets or sets this address's zip postal code. (Inherited from dotnetCART.BaseAddress<OrderAddress>)
Top

See Also

Reference

OrderAddress Class
dotnetCART Namespace


%%PageItemTitle%%

Company Property
[image]
dotnetCART Namespace > OrderAddress Class : Company Property

The company name of the address.

Syntax

Visual Basic (Declaration)
Public Property Company As String
C#
public string Company {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderAddress Class
OrderAddress Members


%%PageItemTitle%%

ID Property
[image]
dotnetCART Namespace > OrderAddress Class : ID Property

The auto number ID populated from the database.

Syntax

Visual Basic (Declaration)
Public Overrides Property ID As Long
C#
public override long ID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderAddress Class
OrderAddress Members


%%PageItemTitle%%

Items Property
[image]
dotnetCART Namespace > OrderAddress Class : Items Property

A reference to the Items associated with this order address.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Items As OrderItems
C#
public OrderItems Items {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderAddress Class
OrderAddress Members


%%PageItemTitle%%

Name Property
[image]
dotnetCART Namespace > OrderAddress Class : Name Property

Gets or sets the address name.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderAddress Class
OrderAddress Members


%%PageItemTitle%%

ShipAmount Property
[image]
dotnetCART Namespace > OrderAddress Class : ShipAmount Property

Gets or sets the shipping amount.

Syntax

Visual Basic (Declaration)
Public Property ShipAmount As Decimal
C#
public decimal ShipAmount {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderAddress Class
OrderAddress Members


%%PageItemTitle%%

ShipBy Property
[image]
dotnetCART Namespace > OrderAddress Class : ShipBy Property

Gets or sets the shipping company.

Syntax

Visual Basic (Declaration)
Public Property ShipBy As String
C#
public string ShipBy {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderAddress Class
OrderAddress Members


%%PageItemTitle%%

ShipDate Property
[image]
dotnetCART Namespace > OrderAddress Class : ShipDate Property

Gets or sets the shipping date.

Syntax

Visual Basic (Declaration)
Public Property ShipDate As Date
C#
public DateTime ShipDate {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderAddress Class
OrderAddress Members


%%PageItemTitle%%

ShipTracking Property
[image]
dotnetCART Namespace > OrderAddress Class : ShipTracking Property

Gets or sets the tracking for the shipment.

Syntax

Visual Basic (Declaration)
Public Property ShipTracking As String
C#
public string ShipTracking {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderAddress Class
OrderAddress Members


%%PageItemTitle%%

OrderCoupon Class
See Also Members
[image]
dotnetCART Namespace : OrderCoupon Class

Represents a coupon in an Order object.

Object Model

Syntax

Visual Basic (Declaration)
Public Class OrderCoupon
   Inherits DbTableCart(Of OrderCoupon, Long)
C#
public class OrderCoupon : DbTableCart<OrderCoupon, long>

Inheritance Hierarchy

System.Object
dotnetDATA.DbTable<Int64>
dotnetDATA.DbTable<OrderCoupon, Int64>
dotnetCART.DbTableCart<OrderCoupon, Int64>
dotnetCART.OrderCoupon

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderCoupon Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

OrderCoupon Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : OrderCoupon Class

The following tables list the members exposed by OrderCoupon.

Public Constructors

 | Name | Description
Public Constructor | OrderCoupon Constructor | Initializes a new instance of the OrderCoupon class.
Top

Public Properties

 | Name | Description
Public Property | Adjust | Gets or sets the adjust of this coupon.
Public Property | AdjustRate | Gets or sets the adjust rate of this coupon.
Public Property | Code | Gets or sets this coupon code.
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<OrderCoupon, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<OrderCoupon, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<OrderCoupon, Int64>)
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<OrderCoupon, Int64>)
Public Property | ID | Overridden. The auto number ID populated from the database.
Public Property | Name | Gets or sets this orderCoupon name.
Public Property | Type | Gets or sets the coupon type.
Top

Public Methods

 | Name | Description
Public Method | Clear | Overridden. Initializes all the properties without recreating the object.
Public Method | Clone | Creates a copy of the current OrderCoupon
Public Method | DeleteDB | Overloaded. Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<OrderCoupon, Int64>)
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<OrderCoupon, Int64>)
Public Method | LoadDB | Overloaded. Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<OrderCoupon, Int64>)
Public Method | SaveDB | Overloaded. Inserts or updates this object into the database. (Inherited from dotnetCART.DbTableCart<OrderCoupon, Int64>)
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<OrderCoupon, Int64>)
Top

See Also

Reference

OrderCoupon Class
dotnetCART Namespace


%%PageItemTitle%%

OrderCoupon Constructor
[image]
dotnetCART Namespace > OrderCoupon Class : OrderCoupon Constructor

Initializes a new instance of the OrderCoupon class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OrderCoupon()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderCoupon Class
OrderCoupon Members


%%PageItemTitle%% $$Methods$$

OrderCoupon Class Methods
[image]
dotnetCART Namespace : OrderCoupon Class

For a list of all members of this type, see OrderCoupon members.

Public Methods

 | Name | Description
Public Method | Clear | Overridden. Initializes all the properties without recreating the object.
Public Method | Clone | Creates a copy of the current OrderCoupon
Public Method | DeleteDB | Overloaded. Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<OrderCoupon, Int64>)
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<OrderCoupon, Int64>)
Public Method | LoadDB | Overloaded. Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<OrderCoupon, Int64>)
Public Method | SaveDB | Overloaded. Inserts or updates this object into the database. (Inherited from dotnetCART.DbTableCart<OrderCoupon, Int64>)
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<OrderCoupon, Int64>)
Top

See Also

Reference

OrderCoupon Class
dotnetCART Namespace


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > OrderCoupon Class : Clear Method

Initializes all the properties without recreating the object.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Clear()
C#
public override void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderCoupon Class
OrderCoupon Members


%%PageItemTitle%%

Clone Method
[image]
dotnetCART Namespace > OrderCoupon Class : Clone Method

Creates a copy of the current OrderCoupon

Syntax

Visual Basic (Declaration)
Public Function Clone() As OrderCoupon
C#
public OrderCoupon Clone()

Return Value

Returns an OrderCoupon object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderCoupon Class
OrderCoupon Members


%%PageItemTitle%% $$Properties$$

OrderCoupon Class Properties
[image]
dotnetCART Namespace : OrderCoupon Class

For a list of all members of this type, see OrderCoupon members.

Public Properties

 | Name | Description
Public Property | Adjust | Gets or sets the adjust of this coupon.
Public Property | AdjustRate | Gets or sets the adjust rate of this coupon.
Public Property | Code | Gets or sets this coupon code.
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<OrderCoupon, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<OrderCoupon, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<OrderCoupon, Int64>)
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<OrderCoupon, Int64>)
Public Property | ID | Overridden. The auto number ID populated from the database.
Public Property | Name | Gets or sets this orderCoupon name.
Public Property | Type | Gets or sets the coupon type.
Top

See Also

Reference

OrderCoupon Class
dotnetCART Namespace


%%PageItemTitle%%

Adjust Property
[image]
dotnetCART Namespace > OrderCoupon Class : Adjust Property

Gets or sets the adjust of this coupon.

Syntax

Visual Basic (Declaration)
Public Property Adjust As Decimal
C#
public decimal Adjust {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderCoupon Class
OrderCoupon Members


%%PageItemTitle%%

AdjustRate Property
[image]
dotnetCART Namespace > OrderCoupon Class : AdjustRate Property

Gets or sets the adjust rate of this coupon.

Syntax

Visual Basic (Declaration)
Public Property AdjustRate As String
C#
public string AdjustRate {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderCoupon Class
OrderCoupon Members


%%PageItemTitle%%

Code Property
[image]
dotnetCART Namespace > OrderCoupon Class : Code Property

Gets or sets this coupon code.

Syntax

Visual Basic (Declaration)
Public Property Code As String
C#
public string Code {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderCoupon Class
OrderCoupon Members


%%PageItemTitle%%

ID Property
[image]
dotnetCART Namespace > OrderCoupon Class : ID Property

The auto number ID populated from the database.

Syntax

Visual Basic (Declaration)
Public Overrides Property ID As Long
C#
public override long ID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderCoupon Class
OrderCoupon Members


%%PageItemTitle%%

Name Property
[image]
dotnetCART Namespace > OrderCoupon Class : Name Property

Gets or sets this orderCoupon name.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderCoupon Class
OrderCoupon Members


%%PageItemTitle%%

Type Property
[image]
dotnetCART Namespace > OrderCoupon Class : Type Property

Gets or sets the coupon type.

Syntax

Visual Basic (Declaration)
Public Property Type As CouponType
C#
public CouponType Type {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderCoupon Class
OrderCoupon Members


%%PageItemTitle%%

OrderCoupons Class
See Also Members
[image]
dotnetCART Namespace : OrderCoupons Class

A collection of OrderCoupon objects.

Object Model

Syntax

Visual Basic (Declaration)
Public Class OrderCoupons
   Inherits EntitySet(Of OrderCoupon)
C#
public class OrderCoupons : EntitySet<OrderCoupon>

Inheritance Hierarchy

System.Object
dotnetDATA.EntitySet<OrderCoupon>
dotnetCART.OrderCoupons

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderCoupons Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

OrderCoupons Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : OrderCoupons Class

The following tables list the members exposed by OrderCoupons.

Public Constructors

 | Name | Description
Public Constructor | OrderCoupons Constructor | Overloaded. Initializes a new instance of the OrderCoupons.
Top

Public Properties

 | Name | Description
Public Property | Count | Returns the number of items in the collection. (Inherited from dotnetDATA.EntitySet<OrderCoupon>)
Public Property | Item | Gets the element at the specified index. (Inherited from dotnetDATA.EntitySet<OrderCoupon>)
Top

Public Methods

 | Name | Description
Public Method | Add | Add the newItem to this collection. (Inherited from dotnetDATA.EntitySet<OrderCoupon>)
Public Method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetDATA.EntitySet<OrderCoupon>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetDATA.EntitySet<OrderCoupon>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetDATA.EntitySet<OrderCoupon>)
Public Method | IndexOf | Returns the index of this item in the list. (Inherited from dotnetDATA.EntitySet<OrderCoupon>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetDATA.EntitySet<OrderCoupon>)
Public Method | Remove | Removes the item from the collection. (Inherited from dotnetDATA.EntitySet<OrderCoupon>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetDATA.EntitySet<OrderCoupon>)
Top

See Also

Reference

OrderCoupons Class
dotnetCART Namespace


%%PageItemTitle%%

OrderCoupons Constructor
[image]
dotnetCART Namespace > OrderCoupons Class : OrderCoupons Constructor

Initializes a new instance of the OrderCoupons.

Overload List

Overload | Description
OrderCoupons Constructor() | Initializes a new instance of the OrderCoupons.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderCoupons Class
OrderCoupons Members


%%PageItemTitle%%

OrderCoupons Constructor()
See Also
[image]
dotnetCART Namespace > OrderCoupons Class > OrderCoupons Constructor : OrderCoupons Constructor()

Initializes a new instance of the OrderCoupons.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OrderCoupons()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderCoupons Class
OrderCoupons Members
Overload List


%%PageItemTitle%%

OrderItem Class
See Also Members
[image]
dotnetCART Namespace : OrderItem Class

Represents an item in Order object.

Object Model

Syntax

Visual Basic (Declaration)
Public Class OrderItem
   Inherits DbTableCart(Of OrderItem, Long)
C#
public class OrderItem : DbTableCart<OrderItem, long>

Inheritance Hierarchy

System.Object
dotnetDATA.DbTable<Int64>
dotnetDATA.DbTable<OrderItem, Int64>
dotnetCART.DbTableCart<OrderItem, Int64>
dotnetCART.OrderItem

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItem Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

OrderItem Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : OrderItem Class

The following tables list the members exposed by OrderItem.

Public Constructors

 | Name | Description
Public Constructor | OrderItem Constructor | Initializes a new instance of the OrderItem class.
Top

Public Properties

 | Name | Description
Public Property | Address | Gets or sets the order item shipping address.
Public Property | Adjust | Gets or sets the order item adjust
Public Property | AdjustRate | Gets or sets the order item adjust rate.
Public Property | CategoryID | Gets or sets the categoryID for this item.
Public Property | CategoryName | Gets or sets the order item category name.
Public Property | Cost | Gets or sets the order item cost.
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<OrderItem, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<OrderItem, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<OrderItem, Int64>)
Public Property | Description | Gets or sets the order item description.
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<OrderItem, Int64>)
Public Property | ID | The auto number ID populated from the database.
Public Property | ItemID | Gets or sets the string itemID.
Public Property | Name | Gets or sets the order item name.
Public Property | Option | A reference to the Option which is added to Options when invoking Options.Add() method.
Public Property | OptionAdjust | Gets the item option adjust amount.
Public Property | OptionAdjustCost | Gets the item option adjust cost.
Public Property | OptionAdjustWeight | Gets the item option adjust weight.
Public Property | Options | A reference to the Options associated with this order item.
Public Property | OrderAddressID | Gets or sets the order item shipping address id.
Public Property | Price | Gets or sets the order item price.
Public Property | Quantity | Gets or sets the order item quantity.
Public Property | SoftGoodFileName | Gets or sets the item softgood file name.
Public Property | Tax | Gets or sets the order item tax.
Public Property | Taxes | Gets or sets the item taxes.
Public Property | Total | Gets the item total. The totol is calculated by: (Price*Quantity) + Adjust
Public Property | TotalCost | Gets the item total cost. It is calculated by: (Cost+OptionAdjustCost)*Quantity
Public Property | Weight | Gets or sets the order item weight.
Top

Public Methods

 | Name | Description
Public Method | Clear | Overridden. Initializes all the properties without recreating the object.
Public Method | Clone | Creates a copy of the current OrderItem
Public Method | DeleteDB | Overloaded. Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<OrderItem, Int64>)
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<OrderItem, Int64>)
Public Method | LoadDB | Overloaded. Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<OrderItem, Int64>)
Public Method | SaveDB | Overloaded. Overridden. Inserts or updates this object into the OrderItems table.
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<OrderItem, Int64>)
Top

See Also

Reference

OrderItem Class
dotnetCART Namespace


%%PageItemTitle%%

OrderItem Constructor
[image]
dotnetCART Namespace > OrderItem Class : OrderItem Constructor

Initializes a new instance of the OrderItem class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OrderItem()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItem Class
OrderItem Members


%%PageItemTitle%% $$Methods$$

OrderItem Class Methods
[image]
dotnetCART Namespace : OrderItem Class

For a list of all members of this type, see OrderItem members.

Public Methods

 | Name | Description
Public Method | Clear | Overridden. Initializes all the properties without recreating the object.
Public Method | Clone | Creates a copy of the current OrderItem
Public Method | DeleteDB | Overloaded. Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<OrderItem, Int64>)
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<OrderItem, Int64>)
Public Method | LoadDB | Overloaded. Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<OrderItem, Int64>)
Public Method | SaveDB | Overloaded. Overridden. Inserts or updates this object into the OrderItems table.
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<OrderItem, Int64>)
Top

See Also

Reference

OrderItem Class
dotnetCART Namespace


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > OrderItem Class : Clear Method

Initializes all the properties without recreating the object.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Clear()
C#
public override void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItem Class
OrderItem Members


%%PageItemTitle%%

Clone Method
[image]
dotnetCART Namespace > OrderItem Class : Clone Method

Creates a copy of the current OrderItem

Syntax

Visual Basic (Declaration)
Public Function Clone() As OrderItem
C#
public OrderItem Clone()

Return Value

Returns an OrderItem object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItem Class
OrderItem Members


%%PageItemTitle%%

SaveDB Method
[image]
dotnetCART Namespace > OrderItem Class : SaveDB Method

Inserts or updates this object into the OrderItems table.

Overload List

Overload | Description
SaveDB() | Inserts or updates this object into the OrderItems table.
SaveDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItem Class
OrderItem Members


%%PageItemTitle%%

SaveDB() Method
[image]
dotnetCART Namespace > OrderItem Class > SaveDB Method : SaveDB() Method

Inserts or updates this object into the OrderItems table.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function SaveDB() As Integer
C#
public override int SaveDB()

Return Value

Returns the generated ID or 1 for the update, returns -1 if failed. For the reason of fail, check the Error property.

Remarks

If ID greater than 0, it updates the associated record in the table, otherwise inserts a new record.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItem Class
OrderItem Members
Overload List


%%PageItemTitle%% $$Properties$$

OrderItem Class Properties
[image]
dotnetCART Namespace : OrderItem Class

For a list of all members of this type, see OrderItem members.

Public Properties

 | Name | Description
Public Property | Address | Gets or sets the order item shipping address.
Public Property | Adjust | Gets or sets the order item adjust
Public Property | AdjustRate | Gets or sets the order item adjust rate.
Public Property | CategoryID | Gets or sets the categoryID for this item.
Public Property | CategoryName | Gets or sets the order item category name.
Public Property | Cost | Gets or sets the order item cost.
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<OrderItem, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<OrderItem, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<OrderItem, Int64>)
Public Property | Description | Gets or sets the order item description.
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<OrderItem, Int64>)
Public Property | ID | The auto number ID populated from the database.
Public Property | ItemID | Gets or sets the string itemID.
Public Property | Name | Gets or sets the order item name.
Public Property | Option | A reference to the Option which is added to Options when invoking Options.Add() method.
Public Property | OptionAdjust | Gets the item option adjust amount.
Public Property | OptionAdjustCost | Gets the item option adjust cost.
Public Property | OptionAdjustWeight | Gets the item option adjust weight.
Public Property | Options | A reference to the Options associated with this order item.
Public Property | OrderAddressID | Gets or sets the order item shipping address id.
Public Property | Price | Gets or sets the order item price.
Public Property | Quantity | Gets or sets the order item quantity.
Public Property | SoftGoodFileName | Gets or sets the item softgood file name.
Public Property | Tax | Gets or sets the order item tax.
Public Property | Taxes | Gets or sets the item taxes.
Public Property | Total | Gets the item total. The totol is calculated by: (Price*Quantity) + Adjust
Public Property | TotalCost | Gets the item total cost. It is calculated by: (Cost+OptionAdjustCost)*Quantity
Public Property | Weight | Gets or sets the order item weight.
Top

See Also

Reference

OrderItem Class
dotnetCART Namespace


%%PageItemTitle%%

Address Property
[image]
dotnetCART Namespace > OrderItem Class : Address Property

Gets or sets the order item shipping address.

Syntax

Visual Basic (Declaration)
Public Property Address As OrderAddress
C#
public OrderAddress Address {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItem Class
OrderItem Members


%%PageItemTitle%%

Adjust Property
[image]
dotnetCART Namespace > OrderItem Class : Adjust Property

Gets or sets the order item adjust

Syntax

Visual Basic (Declaration)
Public Property Adjust As Decimal
C#
public decimal Adjust {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItem Class
OrderItem Members


%%PageItemTitle%%

AdjustRate Property
[image]
dotnetCART Namespace > OrderItem Class : AdjustRate Property

Gets or sets the order item adjust rate.

Syntax

Visual Basic (Declaration)
Public Property AdjustRate As String
C#
public string AdjustRate {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItem Class
OrderItem Members


%%PageItemTitle%%

CategoryID Property
[image]
dotnetCART Namespace > OrderItem Class : CategoryID Property

Gets or sets the categoryID for this item.

Syntax

Visual Basic (Declaration)
Public Property CategoryID As Long
C#
public long CategoryID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItem Class
OrderItem Members


%%PageItemTitle%%

CategoryName Property
[image]
dotnetCART Namespace > OrderItem Class : CategoryName Property

Gets or sets the order item category name.

Syntax

Visual Basic (Declaration)
Public Property CategoryName As String
C#
public string CategoryName {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItem Class
OrderItem Members


%%PageItemTitle%%

Cost Property
[image]
dotnetCART Namespace > OrderItem Class : Cost Property

Gets or sets the order item cost.

Syntax

Visual Basic (Declaration)
Public Property Cost As Nullable(Of Decimal)
C#
public Nullable<decimal> Cost {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItem Class
OrderItem Members


%%PageItemTitle%%

Description Property
[image]
dotnetCART Namespace > OrderItem Class : Description Property

Gets or sets the order item description.

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItem Class
OrderItem Members


%%PageItemTitle%%

ID Property
[image]
dotnetCART Namespace > OrderItem Class : ID Property

The auto number ID populated from the database.

Syntax

Visual Basic (Declaration)
Public Property ID As Long
C#
public long ID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItem Class
OrderItem Members


%%PageItemTitle%%

ItemID Property
[image]
dotnetCART Namespace > OrderItem Class : ItemID Property

Gets or sets the string itemID.

Syntax

Visual Basic (Declaration)
Public Property ItemID As String
C#
public string ItemID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItem Class
OrderItem Members


%%PageItemTitle%%

Name Property
[image]
dotnetCART Namespace > OrderItem Class : Name Property

Gets or sets the order item name.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItem Class
OrderItem Members


%%PageItemTitle%%

Option Property
[image]
dotnetCART Namespace > OrderItem Class : Option Property

A reference to the Option which is added to Options when invoking Options.Add() method.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Option As OrderItemOption
C#
public OrderItemOption Option {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItem Class
OrderItem Members


%%PageItemTitle%%

OptionAdjust Property
[image]
dotnetCART Namespace > OrderItem Class : OptionAdjust Property

Gets the item option adjust amount.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OptionAdjust As Decimal
C#
public decimal OptionAdjust {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItem Class
OrderItem Members


%%PageItemTitle%%

OptionAdjustCost Property
[image]
dotnetCART Namespace > OrderItem Class : OptionAdjustCost Property

Gets the item option adjust cost.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OptionAdjustCost As Decimal
C#
public decimal OptionAdjustCost {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItem Class
OrderItem Members


%%PageItemTitle%%

OptionAdjustWeight Property
[image]
dotnetCART Namespace > OrderItem Class : OptionAdjustWeight Property

Gets the item option adjust weight.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OptionAdjustWeight As Double
C#
public double OptionAdjustWeight {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItem Class
OrderItem Members


%%PageItemTitle%%

Options Property
[image]
dotnetCART Namespace > OrderItem Class : Options Property

A reference to the Options associated with this order item.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Options As OrderItemOptions
C#
public OrderItemOptions Options {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItem Class
OrderItem Members


%%PageItemTitle%%

OrderAddressID Property
[image]
dotnetCART Namespace > OrderItem Class : OrderAddressID Property

Gets or sets the order item shipping address id.

Syntax

Visual Basic (Declaration)
Public Property OrderAddressID As Long
C#
public long OrderAddressID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItem Class
OrderItem Members


%%PageItemTitle%%

Price Property
[image]
dotnetCART Namespace > OrderItem Class : Price Property

Gets or sets the order item price.

Syntax

Visual Basic (Declaration)
Public Property Price As Nullable(Of Decimal)
C#
public Nullable<decimal> Price {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItem Class
OrderItem Members


%%PageItemTitle%%

Quantity Property
[image]
dotnetCART Namespace > OrderItem Class : Quantity Property

Gets or sets the order item quantity.

Syntax

Visual Basic (Declaration)
Public Property Quantity As Double
C#
public double Quantity {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItem Class
OrderItem Members


%%PageItemTitle%%

SoftGoodFileName Property
[image]
dotnetCART Namespace > OrderItem Class : SoftGoodFileName Property

Gets or sets the item softgood file name.

Syntax

Visual Basic (Declaration)
Public Property SoftGoodFileName As String
C#
public string SoftGoodFileName {get; set;}

Remarks

It is used for creating an email attachment or ticket for a softgood item like software.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItem Class
OrderItem Members


%%PageItemTitle%%

Tax Property
[image]
dotnetCART Namespace > OrderItem Class : Tax Property

Gets or sets the order item tax.

Syntax

Visual Basic (Declaration)
Public Property Tax As OrderTax
C#
public OrderTax Tax {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItem Class
OrderItem Members


%%PageItemTitle%%

Taxes Property
[image]
dotnetCART Namespace > OrderItem Class : Taxes Property

Gets or sets the item taxes.

Syntax

Visual Basic (Declaration)
Public Property Taxes As OrderTaxes
C#
public OrderTaxes Taxes {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItem Class
OrderItem Members


%%PageItemTitle%%

Total Property
[image]
dotnetCART Namespace > OrderItem Class : Total Property

Gets the item total. The totol is calculated by: (Price*Quantity) + Adjust

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Total As Decimal
C#
public decimal Total {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItem Class
OrderItem Members


%%PageItemTitle%%

TotalCost Property
[image]
dotnetCART Namespace > OrderItem Class : TotalCost Property

Gets the item total cost. It is calculated by: (Cost+OptionAdjustCost)*Quantity

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TotalCost As Decimal
C#
public decimal TotalCost {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItem Class
OrderItem Members


%%PageItemTitle%%

Weight Property
[image]
dotnetCART Namespace > OrderItem Class : Weight Property

Gets or sets the order item weight.

Syntax

Visual Basic (Declaration)
Public Property Weight As Double
C#
public double Weight {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItem Class
OrderItem Members


%%PageItemTitle%%

OrderItemOption Class
See Also Members
[image]
dotnetCART Namespace : OrderItemOption Class

Represents an option in an item in an Order object.

Object Model

Syntax

Visual Basic (Declaration)
Public Class OrderItemOption
   Inherits DbTableCart(Of OrderItemOption, Long)
C#
public class OrderItemOption : DbTableCart<OrderItemOption, long>

Inheritance Hierarchy

System.Object
dotnetDATA.DbTable<Int64>
dotnetDATA.DbTable<OrderItemOption, Int64>
dotnetCART.DbTableCart<OrderItemOption, Int64>
dotnetCART.OrderItemOption

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItemOption Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

OrderItemOption Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : OrderItemOption Class

The following tables list the members exposed by OrderItemOption.

Public Constructors

 | Name | Description
Public Constructor | OrderItemOption Constructor | Initializes a new instance of the OrderItemOption class.
Top

Public Properties

 | Name | Description
Public Property | AdjustCost | Gets or sets the option cost. It is used for calculating the item cost.
Public Property | AdjustPrice | Gets or sets the adjust price.
Public Property | AdjustWeight | Gets or sets the adjust weight.
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<OrderItemOption, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<OrderItemOption, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<OrderItemOption, Int64>)
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<OrderItemOption, Int64>)
Public Property | ID | Overridden. The auto number ID populated from the database.
Public Property | Name | Gets or sets this OrderItemOption's name.
Public Property | Value | Gets or sets this option value. This is usually the name of the selected choice.
Top

Public Methods

 | Name | Description
Public Method | Clear | Overridden. Initializes all the properties without recreating the object.
Public Method | Clone | Creates a copy of the current OrderItemOption
Public Method | DeleteDB | Overloaded. Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<OrderItemOption, Int64>)
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<OrderItemOption, Int64>)
Public Method | LoadDB | Overloaded. Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<OrderItemOption, Int64>)
Public Method | SaveDB | Overloaded. Inserts or updates this object into the database. (Inherited from dotnetCART.DbTableCart<OrderItemOption, Int64>)
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<OrderItemOption, Int64>)
Top

See Also

Reference

OrderItemOption Class
dotnetCART Namespace


%%PageItemTitle%%

OrderItemOption Constructor
[image]
dotnetCART Namespace > OrderItemOption Class : OrderItemOption Constructor

Initializes a new instance of the OrderItemOption class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OrderItemOption()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItemOption Class
OrderItemOption Members


%%PageItemTitle%% $$Methods$$

OrderItemOption Class Methods
[image]
dotnetCART Namespace : OrderItemOption Class

For a list of all members of this type, see OrderItemOption members.

Public Methods

 | Name | Description
Public Method | Clear | Overridden. Initializes all the properties without recreating the object.
Public Method | Clone | Creates a copy of the current OrderItemOption
Public Method | DeleteDB | Overloaded. Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<OrderItemOption, Int64>)
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<OrderItemOption, Int64>)
Public Method | LoadDB | Overloaded. Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<OrderItemOption, Int64>)
Public Method | SaveDB | Overloaded. Inserts or updates this object into the database. (Inherited from dotnetCART.DbTableCart<OrderItemOption, Int64>)
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<OrderItemOption, Int64>)
Top

See Also

Reference

OrderItemOption Class
dotnetCART Namespace


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > OrderItemOption Class : Clear Method

Initializes all the properties without recreating the object.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Clear()
C#
public override void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItemOption Class
OrderItemOption Members


%%PageItemTitle%%

Clone Method
[image]
dotnetCART Namespace > OrderItemOption Class : Clone Method

Creates a copy of the current OrderItemOption

Syntax

Visual Basic (Declaration)
Public Function Clone() As OrderItemOption
C#
public OrderItemOption Clone()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItemOption Class
OrderItemOption Members


%%PageItemTitle%% $$Properties$$

OrderItemOption Class Properties
[image]
dotnetCART Namespace : OrderItemOption Class

For a list of all members of this type, see OrderItemOption members.

Public Properties

 | Name | Description
Public Property | AdjustCost | Gets or sets the option cost. It is used for calculating the item cost.
Public Property | AdjustPrice | Gets or sets the adjust price.
Public Property | AdjustWeight | Gets or sets the adjust weight.
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<OrderItemOption, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<OrderItemOption, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<OrderItemOption, Int64>)
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<OrderItemOption, Int64>)
Public Property | ID | Overridden. The auto number ID populated from the database.
Public Property | Name | Gets or sets this OrderItemOption's name.
Public Property | Value | Gets or sets this option value. This is usually the name of the selected choice.
Top

See Also

Reference

OrderItemOption Class
dotnetCART Namespace


%%PageItemTitle%%

AdjustCost Property
[image]
dotnetCART Namespace > OrderItemOption Class : AdjustCost Property

Gets or sets the option cost. It is used for calculating the item cost.

Syntax

Visual Basic (Declaration)
Public Property AdjustCost As Decimal
C#
public decimal AdjustCost {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItemOption Class
OrderItemOption Members


%%PageItemTitle%%

AdjustPrice Property
[image]
dotnetCART Namespace > OrderItemOption Class : AdjustPrice Property

Gets or sets the adjust price.

Syntax

Visual Basic (Declaration)
Public Property AdjustPrice As Decimal
C#
public decimal AdjustPrice {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItemOption Class
OrderItemOption Members


%%PageItemTitle%%

AdjustWeight Property
[image]
dotnetCART Namespace > OrderItemOption Class : AdjustWeight Property

Gets or sets the adjust weight.

Syntax

Visual Basic (Declaration)
Public Property AdjustWeight As Double
C#
public double AdjustWeight {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItemOption Class
OrderItemOption Members


%%PageItemTitle%%

ID Property
[image]
dotnetCART Namespace > OrderItemOption Class : ID Property

The auto number ID populated from the database.

Syntax

Visual Basic (Declaration)
Public Overrides Property ID As Long
C#
public override long ID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItemOption Class
OrderItemOption Members


%%PageItemTitle%%

Name Property
[image]
dotnetCART Namespace > OrderItemOption Class : Name Property

Gets or sets this OrderItemOption's name.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItemOption Class
OrderItemOption Members


%%PageItemTitle%%

Value Property
[image]
dotnetCART Namespace > OrderItemOption Class : Value Property

Gets or sets this option value. This is usually the name of the selected choice.

Syntax

Visual Basic (Declaration)
Public Property Value As String
C#
public string Value {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItemOption Class
OrderItemOption Members


%%PageItemTitle%%

OrderItemOptions Class
See Also Members
[image]
dotnetCART Namespace : OrderItemOptions Class

A collection of OrderItemOption objects.

Syntax

Visual Basic (Declaration)
Public Class OrderItemOptions
   Inherits EntitySet(Of OrderItemOption)
C#
public class OrderItemOptions : EntitySet<OrderItemOption>

Inheritance Hierarchy

System.Object
dotnetDATA.EntitySet<OrderItemOption>
dotnetCART.OrderItemOptions

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItemOptions Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

OrderItemOptions Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : OrderItemOptions Class

The following tables list the members exposed by OrderItemOptions.

Public Constructors

 | Name | Description
Public Constructor | OrderItemOptions Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Count | Returns the number of items in the collection. (Inherited from dotnetDATA.EntitySet<OrderItemOption>)
Public Property | Item | Overloaded. Gets the value with specified name.
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds the order.Items.Option this collection.
Public Method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetDATA.EntitySet<OrderItemOption>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetDATA.EntitySet<OrderItemOption>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetDATA.EntitySet<OrderItemOption>)
Public Method | GetOption |
Public Method | IndexOf | Returns the index of this item in the list. (Inherited from dotnetDATA.EntitySet<OrderItemOption>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetDATA.EntitySet<OrderItemOption>)
Public Method | Remove | Removes the item from the collection. (Inherited from dotnetDATA.EntitySet<OrderItemOption>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetDATA.EntitySet<OrderItemOption>)
Top

See Also

Reference

OrderItemOptions Class
dotnetCART Namespace


%%PageItemTitle%%

OrderItemOptions Constructor
[image]
dotnetCART Namespace > OrderItemOptions Class : OrderItemOptions Constructor

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItemOptions Class
OrderItemOptions Members


%%PageItemTitle%% $$Methods$$

OrderItemOptions Class Methods
[image]
dotnetCART Namespace : OrderItemOptions Class

For a list of all members of this type, see OrderItemOptions members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds the order.Items.Option this collection.
Public Method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetDATA.EntitySet<OrderItemOption>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetDATA.EntitySet<OrderItemOption>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetDATA.EntitySet<OrderItemOption>)
Public Method | GetOption |
Public Method | IndexOf | Returns the index of this item in the list. (Inherited from dotnetDATA.EntitySet<OrderItemOption>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetDATA.EntitySet<OrderItemOption>)
Public Method | Remove | Removes the item from the collection. (Inherited from dotnetDATA.EntitySet<OrderItemOption>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetDATA.EntitySet<OrderItemOption>)
Top

See Also

Reference

OrderItemOptions Class
dotnetCART Namespace


%%PageItemTitle%%

Add Method
[image]
dotnetCART Namespace > OrderItemOptions Class : Add Method

Adds the order.Items.Option this collection.

Overload List

Overload | Description
Add() | Adds the order.Items.Option this collection.
Add(OrderItemOption) | (Inherited from dotnetDATA.EntitySet<OrderItemOption>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItemOptions Class
OrderItemOptions Members


%%PageItemTitle%%

Add() Method
[image]
dotnetCART Namespace > OrderItemOptions Class > Add Method : Add() Method

Adds the order.Items.Option this collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add()
C#
public void Add()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItemOptions Class
OrderItemOptions Members
Overload List


%%PageItemTitle%%

GetOption Method
[image]
dotnetCART Namespace > OrderItemOptions Class : GetOption Method

name

Syntax

Visual Basic (Declaration)
Public Function GetOption( _
   ByVal name As String _
) As OrderItemOption
C#
public OrderItemOption GetOption(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItemOptions Class
OrderItemOptions Members


%%PageItemTitle%% $$Properties$$

OrderItemOptions Class Properties
[image]
dotnetCART Namespace : OrderItemOptions Class

For a list of all members of this type, see OrderItemOptions members.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of items in the collection. (Inherited from dotnetDATA.EntitySet<OrderItemOption>)
Public Property | Item | Overloaded. Gets the value with specified name.
Top

See Also

Reference

OrderItemOptions Class
dotnetCART Namespace


%%PageItemTitle%%

Item Property
[image]
dotnetCART Namespace > OrderItemOptions Class : Item Property

Gets the value with specified name.

Overload List

Overload | Description
Item(String) | Gets the value with specified name.
Item(Int32) | Gets the element at the specified index. (Inherited from dotnetDATA.EntitySet<OrderItemOption>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItemOptions Class
OrderItemOptions Members


%%PageItemTitle%%

Item(String) Property
[image]
dotnetCART Namespace > OrderItemOptions Class > Item Property : Item(String) Property

name
Gets the value with specified name.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal name As String _
) As String
C#
public string Item(
   string name
) {get;}

Parameters

name

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItemOptions Class
OrderItemOptions Members
Overload List


%%PageItemTitle%%

OrderItems Class
See Also Members
[image]
dotnetCART Namespace : OrderItems Class

A collection of OrderItem objects.

Object Model

Syntax

Visual Basic (Declaration)
Public Class OrderItems
   Inherits EntitySet(Of OrderItem)
C#
public class OrderItems : EntitySet<OrderItem>

Inheritance Hierarchy

System.Object
dotnetDATA.EntitySet<OrderItem>
dotnetCART.OrderItems

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItems Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

OrderItems Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : OrderItems Class

The following tables list the members exposed by OrderItems.

Public Constructors

 | Name | Description
Public Constructor | OrderItems Constructor | Overloaded. Initializes a new instance of the OrderItems.
Top

Public Properties

 | Name | Description
Public Property | Count | Returns the number of items in the collection. (Inherited from dotnetDATA.EntitySet<OrderItem>)
Public Property | Item | Gets the element at the specified index. (Inherited from dotnetDATA.EntitySet<OrderItem>)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Add the item in orderObject.Item to this collection. This method should be called through orderObject.Items If the same item already exist in the orderObject.Items collection, the orderObject.Item.Quantity is added to the quantity of the same item in the orderObject.Items collection.
Public Method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetDATA.EntitySet<OrderItem>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetDATA.EntitySet<OrderItem>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetDATA.EntitySet<OrderItem>)
Public Method | IndexOf | Returns the index of this item in the list. (Inherited from dotnetDATA.EntitySet<OrderItem>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetDATA.EntitySet<OrderItem>)
Public Method | Remove | Removes the item from the collection. (Inherited from dotnetDATA.EntitySet<OrderItem>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetDATA.EntitySet<OrderItem>)
Public Method | Sort | Overloaded. Sort items by name in this collection.
Top

See Also

Reference

OrderItems Class
dotnetCART Namespace


%%PageItemTitle%%

OrderItems Constructor
[image]
dotnetCART Namespace > OrderItems Class : OrderItems Constructor

Initializes a new instance of the OrderItems.

Overload List

Overload | Description
OrderItems Constructor() | Initializes a new instance of the OrderItems.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItems Class
OrderItems Members


%%PageItemTitle%%

OrderItems Constructor()
See Also
[image]
dotnetCART Namespace > OrderItems Class > OrderItems Constructor : OrderItems Constructor()

Initializes a new instance of the OrderItems.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OrderItems()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItems Class
OrderItems Members
Overload List


%%PageItemTitle%% $$Methods$$

OrderItems Class Methods
[image]
dotnetCART Namespace : OrderItems Class

For a list of all members of this type, see OrderItems members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Add the item in orderObject.Item to this collection. This method should be called through orderObject.Items If the same item already exist in the orderObject.Items collection, the orderObject.Item.Quantity is added to the quantity of the same item in the orderObject.Items collection.
Public Method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetDATA.EntitySet<OrderItem>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetDATA.EntitySet<OrderItem>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetDATA.EntitySet<OrderItem>)
Public Method | IndexOf | Returns the index of this item in the list. (Inherited from dotnetDATA.EntitySet<OrderItem>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetDATA.EntitySet<OrderItem>)
Public Method | Remove | Removes the item from the collection. (Inherited from dotnetDATA.EntitySet<OrderItem>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetDATA.EntitySet<OrderItem>)
Public Method | Sort | Overloaded. Sort items by name in this collection.
Top

See Also

Reference

OrderItems Class
dotnetCART Namespace


%%PageItemTitle%%

Add Method
[image]
dotnetCART Namespace > OrderItems Class : Add Method

Add the item in orderObject.Item to this collection. This method should be called through orderObject.Items If the same item already exist in the orderObject.Items collection, the orderObject.Item.Quantity is added to the quantity of the same item in the orderObject.Items collection.

Overload List

Overload | Description
Add() | Add the item in orderObject.Item to this collection. This method should be called through orderObject.Items If the same item already exist in the orderObject.Items collection, the orderObject.Item.Quantity is added to the quantity of the same item in the orderObject.Items collection.
Add(OrderItem) | Add the newItem to this collection. If the same item already exist in the this collection, the newItem.Quantity is added to the quantity of the same item in the collection.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItems Class
OrderItems Members


%%PageItemTitle%%

Add() Method
[image]
dotnetCART Namespace > OrderItems Class > Add Method : Add() Method

Add the item in orderObject.Item to this collection. This method should be called through orderObject.Items If the same item already exist in the orderObject.Items collection, the orderObject.Item.Quantity is added to the quantity of the same item in the orderObject.Items collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add()
C#
public void Add()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItems Class
OrderItems Members
Overload List


%%PageItemTitle%%

Add(OrderItem) Method
[image]
dotnetCART Namespace > OrderItems Class > Add Method : Add(OrderItem) Method

newItem
Add the newItem to this collection. If the same item already exist in the this collection, the newItem.Quantity is added to the quantity of the same item in the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add( _
   ByVal newItem As OrderItem _
)
C#
public void Add(
   OrderItem newItem
)

Parameters

newItem

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItems Class
OrderItems Members
Overload List


%%PageItemTitle%%

Sort Method
[image]
dotnetCART Namespace > OrderItems Class : Sort Method

Sort items by name in this collection.

Overload List

Overload | Description
Sort() | Sort items by name in this collection.
Sort(String) | Sort items by requestSort parameter in this collection.
Sort(String,OrderDirection) | Sort items by requestSort parameter in this collection.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItems Class
OrderItems Members


%%PageItemTitle%%

Sort() Method
[image]
dotnetCART Namespace > OrderItems Class > Sort Method : Sort() Method

Sort items by name in this collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Sort()
C#
public void Sort()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItems Class
OrderItems Members
Overload List


%%PageItemTitle%%

Sort(String) Method
See Also Example
[image]
dotnetCART Namespace > OrderItems Class > Sort Method : Sort(String) Method

requestSort
Valid requestSort values are: ID, ItemID, Name, Price, Total, Weight, Quantity, AddressID, CategoryName, CategoryID.
Sort items by requestSort parameter in this collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Sort( _
   ByVal requestSort As String _
)
C#
public void Sort(
   string requestSort
)

Parameters

requestSort
Valid requestSort values are: ID, ItemID, Name, Price, Total, Weight, Quantity, AddressID, CategoryName, CategoryID.

Example

C# Copy Code
orderItems.Sort("Price");

Visual Basic Copy Code
orderItems.Sort("Price")

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItems Class
OrderItems Members
Overload List


%%PageItemTitle%%

Sort(String,OrderDirection) Method
See Also Example
[image]
dotnetCART Namespace > OrderItems Class > Sort Method : Sort(String,OrderDirection) Method

requestSort
Valid requestSort values are: ID, ItemID, Name, Price, Total, Weight, Quantity, AddressID, CategoryName, CategoryID.
orderDirection
Sort options: Asc or Desc.
Sort items by requestSort parameter in this collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Sort( _
   ByVal requestSort As String, _
   ByVal orderDirection As OrderDirection _
)
C#
public void Sort(
   string requestSort,
   OrderDirection orderDirection
)

Parameters

requestSort
Valid requestSort values are: ID, ItemID, Name, Price, Total, Weight, Quantity, AddressID, CategoryName, CategoryID.
orderDirection
Sort options: Asc or Desc.

Example

C# Copy Code
orderItems.Sort("Price", OrderDirection.Asc);

Visual Basic Copy Code
orderItems.Sort("Price", OrderDirection.Asc)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItems Class
OrderItems Members
Overload List


%%PageItemTitle%%

Orders Class
See Also Members
[image]
dotnetCART Namespace : Orders Class

A collection of Order objects.

Object Model

Syntax

Visual Basic (Declaration)
Public Class Orders
   Inherits ListBase(Of Order)
C#
public class Orders : ListBase<Order>

Inheritance Hierarchy

System.Object
System.Collections.Generic.List<Order>
dotnetCART.ListBase<Order>
dotnetCART.Orders

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Orders Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

Orders Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : Orders Class

The following tables list the members exposed by Orders.

Public Constructors

 | Name | Description
Public Constructor | Orders Constructor | Initializes a new instance of the Orders.
Top

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from dotnetCART.ListBase<Order>)
Public Property | Count | Gets the number of elements actually contained in the collection. (Inherited from dotnetCART.ListBase<Order>)
Public Property | DetailsNavigation | Determines whether to load or not the order IDs to ListID in LoadDB. Default is false.
Public Property | Error | Returns an object with the error information. (Inherited from dotnetCART.ListBase<Order>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from dotnetCART.ListBase<Order>)
Public Property | ListID | An array list of the IDs of the loaded orders.
Top

Public Methods

 | Name | Description
Public Method | Add | Add the new order object to this collection.
Public Method | AddRange | Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetCART.ListBase<Order>)
Public Method | AsReadOnly | Returns a read-only IList wrapper for the current collection. (Inherited from dotnetCART.ListBase<Order>)
Public Method | BinarySearch | Overloaded. (Inherited from dotnetCART.ListBase<Order>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetCART.ListBase<Order>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetCART.ListBase<Order>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<Order>)
Public Method | CopyTo | Overloaded. (Inherited from dotnetCART.ListBase<Order>)
Public Method | DeleteOrderDB | Deletes all the orders with this customerID.
Public Method | GetCountDB | Overloaded. Gets the total number of items in the Orders table.
Public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from dotnetCART.ListBase<Order>)
Public Method | IndexOf | Overloaded. (Inherited from dotnetCART.ListBase<Order>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetCART.ListBase<Order>)
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from dotnetCART.ListBase<Order>)
Public Method | LastIndexOf | Overloaded. (Inherited from dotnetCART.ListBase<Order>)
Public Method | LoadDB | Overloaded. Loads all the items based on the parameters from Orders table.
Public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from dotnetCART.ListBase<Order>)
Public Method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from dotnetCART.ListBase<Order>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetCART.ListBase<Order>)
Public Method | RemoveRange | Removes a range of elements from the List. (Inherited from dotnetCART.ListBase<Order>)
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<Order>)
Public Method | UpdateEncryptedDataDB | Update CardNumber for all orders with the new encryption key.
Top

See Also

Reference

Orders Class
dotnetCART Namespace


%%PageItemTitle%%

Orders Constructor
[image]
dotnetCART Namespace > Orders Class : Orders Constructor

Initializes a new instance of the Orders.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Orders()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Orders Class
Orders Members


%%PageItemTitle%% $$Methods$$

Orders Class Methods
[image]
dotnetCART Namespace : Orders Class

For a list of all members of this type, see Orders members.

Public Methods

 | Name | Description
Public Method | Add | Add the new order object to this collection.
Public Method | AddRange | Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetCART.ListBase<Order>)
Public Method | AsReadOnly | Returns a read-only IList wrapper for the current collection. (Inherited from dotnetCART.ListBase<Order>)
Public Method | BinarySearch | Overloaded. (Inherited from dotnetCART.ListBase<Order>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetCART.ListBase<Order>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetCART.ListBase<Order>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<Order>)
Public Method | CopyTo | Overloaded. (Inherited from dotnetCART.ListBase<Order>)
Public Method | DeleteOrderDB | Deletes all the orders with this customerID.
Public Method | GetCountDB | Overloaded. Gets the total number of items in the Orders table.
Public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from dotnetCART.ListBase<Order>)
Public Method | IndexOf | Overloaded. (Inherited from dotnetCART.ListBase<Order>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetCART.ListBase<Order>)
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from dotnetCART.ListBase<Order>)
Public Method | LastIndexOf | Overloaded. (Inherited from dotnetCART.ListBase<Order>)
Public Method | LoadDB | Overloaded. Loads all the items based on the parameters from Orders table.
Public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from dotnetCART.ListBase<Order>)
Public Method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from dotnetCART.ListBase<Order>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetCART.ListBase<Order>)
Public Method | RemoveRange | Removes a range of elements from the List. (Inherited from dotnetCART.ListBase<Order>)
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<Order>)
Public Method | UpdateEncryptedDataDB | Update CardNumber for all orders with the new encryption key.
Top

See Also

Reference

Orders Class
dotnetCART Namespace


%%PageItemTitle%%

Add Method
[image]
dotnetCART Namespace > Orders Class : Add Method

newOrder
An order object.
Add the new order object to this collection.

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal newOrder As Order _
) As Integer
C#
public int Add(
   Order newOrder
)

Parameters

newOrder
An order object.

Return Value

Returns the index of the new added order.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Orders Class
Orders Members


%%PageItemTitle%%

DeleteOrderDB Method
[image]
dotnetCART Namespace > Orders Class : DeleteOrderDB Method

customerID
Deletes all the orders with this customerID.

Syntax

Visual Basic (Declaration)
Public Function DeleteOrderDB( _
   ByVal customerID As String _
) As Integer
C#
public int DeleteOrderDB(
   string customerID
)

Parameters

customerID

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Orders Class
Orders Members


%%PageItemTitle%%

GetCountDB Method
[image]
dotnetCART Namespace > Orders Class : GetCountDB Method

Gets the total number of items in the Orders table.

Overload List

Overload | Description
GetCountDB() | Gets the total number of items in the Orders table.
GetCountDB(Where) | Gets the total number of items in the Orders table.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Orders Class
Orders Members


%%PageItemTitle%%

GetCountDB() Method
[image]
dotnetCART Namespace > Orders Class > GetCountDB Method : GetCountDB() Method

Gets the total number of items in the Orders table.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCountDB() As Integer
C#
public int GetCountDB()

Return Value

Returns the number of elements in the Orders table.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Orders Class
Orders Members
Overload List


%%PageItemTitle%%

GetCountDB(Where) Method
[image]
dotnetCART Namespace > Orders Class > GetCountDB Method : GetCountDB(Where) Method

whereClause
The where clause to filter the items.
Gets the total number of items in the Orders table.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCountDB( _
   ByVal whereClause As Where _
) As Integer
C#
public int GetCountDB(
   Where whereClause
)

Parameters

whereClause
The where clause to filter the items.

Return Value

Returns the number of elements in the Orders table.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Orders Class
Orders Members
Overload List


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > Orders Class : LoadDB Method

Loads all the items based on the parameters from Orders table.

Overload List

Overload | Description
LoadDB(Where,Int32,Int32,String,OrderDirection,Int64) | Loads all the items based on the parameters from Orders table.
LoadDB(Where,Int32,Int32,String,OrderDirection) | Loads all the items based on the parameters from Orders table.
LoadDB() | Loads all the items from its associated table. (Inherited from dotnetCART.ListBase<Order>)
LoadDB(Where) | Loads all the items from its associated table based on the where clause. (Inherited from dotnetCART.ListBase<Order>)
LoadDB(Int32,Int32) | Loads the count number of elements from start value. (Inherited from dotnetCART.ListBase<Order>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Orders Class
Orders Members


%%PageItemTitle%%

LoadDB(Where,Int32,Int32,String,OrderDirection,Int64) Method
[image]
dotnetCART Namespace > Orders Class > LoadDB Method : LoadDB(Where,Int32,Int32,String,OrderDirection,Int64) Method

whereClause
The where clause to filter the items.
start
The start page which starts from 0.
count
The number of items in the page.
orderBy
The order of the loaded items.
orderDirection
The order direction of the loaded items. Defaults is Asc.
customerID
The customerID associated with the orders.
Loads all the items based on the parameters from Orders table.

Syntax

Visual Basic (Declaration)
Public Overloads Function LoadDB( _
   ByVal whereClause As Where, _
   ByVal start As Integer, _
   ByVal count As Integer, _
   ByVal orderBy As String, _
   ByVal orderDirection As OrderDirection, _
   ByVal customerID As Long _
) As Integer
C#
public int LoadDB(
   Where whereClause,
   int start,
   int count,
   string orderBy,
   OrderDirection orderDirection,
   long customerID
)

Parameters

whereClause
The where clause to filter the items.
start
The start page which starts from 0.
count
The number of items in the page.
orderBy
The order of the loaded items.
orderDirection
The order direction of the loaded items. Defaults is Asc.
customerID
The customerID associated with the orders.

Return Value

The total number of items have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Orders Class
Orders Members
Overload List


%%PageItemTitle%%

LoadDB(Where,Int32,Int32,String,OrderDirection) Method
[image]
dotnetCART Namespace > Orders Class > LoadDB Method : LoadDB(Where,Int32,Int32,String,OrderDirection) Method

whereClause
The where clause to filter the items.
start
The start page which starts from 0.
count
The number of items in the page.
orderBy
The order of the loaded items.
orderDirection
The order direction of the loaded items. Defaults is Asc.
Loads all the items based on the parameters from Orders table.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function LoadDB( _
   ByVal whereClause As Where, _
   ByVal start As Integer, _
   ByVal count As Integer, _
   ByVal orderBy As String, _
   ByVal orderDirection As OrderDirection _
) As Integer
C#
public override int LoadDB(
   Where whereClause,
   int start,
   int count,
   string orderBy,
   OrderDirection orderDirection
)

Parameters

whereClause
The where clause to filter the items.
start
The start page which starts from 0.
count
The number of items in the page.
orderBy
The order of the loaded items.
orderDirection
The order direction of the loaded items. Defaults is Asc.

Return Value

The total number of items have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Orders Class
Orders Members
Overload List


%%PageItemTitle%%

UpdateEncryptedDataDB Method
[image]
dotnetCART Namespace > Orders Class : UpdateEncryptedDataDB Method

oldEncryptionKey
newEncryptionKey
confirmNewEncryptionKey
Update CardNumber for all orders with the new encryption key.

Syntax

Visual Basic (Declaration)
Public Function UpdateEncryptedDataDB( _
   ByVal oldEncryptionKey As String, _
   ByVal newEncryptionKey As String, _
   ByVal confirmNewEncryptionKey As String _
) As Integer
C#
public int UpdateEncryptedDataDB(
   string oldEncryptionKey,
   string newEncryptionKey,
   string confirmNewEncryptionKey
)

Parameters

oldEncryptionKey
newEncryptionKey
confirmNewEncryptionKey

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Orders Class
Orders Members


%%PageItemTitle%% $$Properties$$

Orders Class Properties
[image]
dotnetCART Namespace : Orders Class

For a list of all members of this type, see Orders members.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from dotnetCART.ListBase<Order>)
Public Property | Count | Gets the number of elements actually contained in the collection. (Inherited from dotnetCART.ListBase<Order>)
Public Property | DetailsNavigation | Determines whether to load or not the order IDs to ListID in LoadDB. Default is false.
Public Property | Error | Returns an object with the error information. (Inherited from dotnetCART.ListBase<Order>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from dotnetCART.ListBase<Order>)
Public Property | ListID | An array list of the IDs of the loaded orders.
Top

See Also

Reference

Orders Class
dotnetCART Namespace


%%PageItemTitle%%

DetailsNavigation Property
[image]
dotnetCART Namespace > Orders Class : DetailsNavigation Property

Determines whether to load or not the order IDs to ListID in LoadDB. Default is false.

Syntax

Visual Basic (Declaration)
Public Property DetailsNavigation As Boolean
C#
public bool DetailsNavigation {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Orders Class
Orders Members


%%PageItemTitle%%

ListID Property
[image]
dotnetCART Namespace > Orders Class : ListID Property

An array list of the IDs of the loaded orders.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ListID As ArrayList
C#
public ArrayList ListID {get;}

Remarks

To populate the IDs, first set DetailsNavigation to true, then call LoadDB. ListID can be used to implement manual orders navigation. For more information, see OrderDetails.aspx page in StoreAdmin samples.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Orders Class
Orders Members


%%PageItemTitle%%

OrderTax Class
See Also Members
[image]
dotnetCART Namespace : OrderTax Class

Represents a tax in an item in an Order object.

Object Model

Syntax

Visual Basic (Declaration)
Public Class OrderTax
   Inherits DbTableCart(Of OrderTax, Long)
C#
public class OrderTax : DbTableCart<OrderTax, long>

Inheritance Hierarchy

System.Object
dotnetDATA.DbTable<Int64>
dotnetDATA.DbTable<OrderTax, Int64>
dotnetCART.DbTableCart<OrderTax, Int64>
dotnetCART.OrderTax

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTax Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

OrderTax Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : OrderTax Class

The following tables list the members exposed by OrderTax.

Public Constructors

 | Name | Description
Public Constructor | OrderTax Constructor | Initializes a new instance of the OrderTax class.
Top

Public Properties

 | Name | Description
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<OrderTax, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<OrderTax, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<OrderTax, Int64>)
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<OrderTax, Int64>)
Public Property | ID | Overridden. The auto number ID populated from the database.
Public Property | Name | Gets or sets this orderTax name.
Public Property | Total | Gets or sets the total tax amount.
Top

Public Methods

 | Name | Description
Public Method | Clear | Overridden. Initializes all the properties without recreating the object.
Public Method | Clone | Creates a copy of the current OrderTax
Public Method | DeleteDB | Overloaded. Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<OrderTax, Int64>)
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<OrderTax, Int64>)
Public Method | LoadDB | Overloaded. Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<OrderTax, Int64>)
Public Method | SaveDB | Overloaded. Inserts or updates this object into the database. (Inherited from dotnetCART.DbTableCart<OrderTax, Int64>)
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<OrderTax, Int64>)
Top

See Also

Reference

OrderTax Class
dotnetCART Namespace


%%PageItemTitle%%

OrderTax Constructor
[image]
dotnetCART Namespace > OrderTax Class : OrderTax Constructor

Initializes a new instance of the OrderTax class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OrderTax()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTax Class
OrderTax Members


%%PageItemTitle%% $$Methods$$

OrderTax Class Methods
[image]
dotnetCART Namespace : OrderTax Class

For a list of all members of this type, see OrderTax members.

Public Methods

 | Name | Description
Public Method | Clear | Overridden. Initializes all the properties without recreating the object.
Public Method | Clone | Creates a copy of the current OrderTax
Public Method | DeleteDB | Overloaded. Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<OrderTax, Int64>)
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<OrderTax, Int64>)
Public Method | LoadDB | Overloaded. Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<OrderTax, Int64>)
Public Method | SaveDB | Overloaded. Inserts or updates this object into the database. (Inherited from dotnetCART.DbTableCart<OrderTax, Int64>)
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<OrderTax, Int64>)
Top

See Also

Reference

OrderTax Class
dotnetCART Namespace


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > OrderTax Class : Clear Method

Initializes all the properties without recreating the object.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Clear()
C#
public override void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTax Class
OrderTax Members


%%PageItemTitle%%

Clone Method
[image]
dotnetCART Namespace > OrderTax Class : Clone Method

Creates a copy of the current OrderTax

Syntax

Visual Basic (Declaration)
Public Function Clone() As OrderTax
C#
public OrderTax Clone()

Return Value

Returns an OrderTax object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTax Class
OrderTax Members


%%PageItemTitle%% $$Properties$$

OrderTax Class Properties
[image]
dotnetCART Namespace : OrderTax Class

For a list of all members of this type, see OrderTax members.

Public Properties

 | Name | Description
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<OrderTax, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<OrderTax, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<OrderTax, Int64>)
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<OrderTax, Int64>)
Public Property | ID | Overridden. The auto number ID populated from the database.
Public Property | Name | Gets or sets this orderTax name.
Public Property | Total | Gets or sets the total tax amount.
Top

See Also

Reference

OrderTax Class
dotnetCART Namespace


%%PageItemTitle%%

ID Property
[image]
dotnetCART Namespace > OrderTax Class : ID Property

The auto number ID populated from the database.

Syntax

Visual Basic (Declaration)
Public Overrides Property ID As Long
C#
public override long ID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTax Class
OrderTax Members


%%PageItemTitle%%

Name Property
[image]
dotnetCART Namespace > OrderTax Class : Name Property

Gets or sets this orderTax name.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTax Class
OrderTax Members


%%PageItemTitle%%

Total Property
[image]
dotnetCART Namespace > OrderTax Class : Total Property

Gets or sets the total tax amount.

Syntax

Visual Basic (Declaration)
Public Property Total As Decimal
C#
public decimal Total {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTax Class
OrderTax Members


%%PageItemTitle%%

OrderTaxes Class
See Also Members
[image]
dotnetCART Namespace : OrderTaxes Class

A collection of OrderTax objects.

Object Model

Syntax

Visual Basic (Declaration)
Public Class OrderTaxes
   Inherits EntitySet(Of OrderTax)
C#
public class OrderTaxes : EntitySet<OrderTax>

Inheritance Hierarchy

System.Object
dotnetDATA.EntitySet<OrderTax>
dotnetCART.OrderTaxes

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTaxes Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

OrderTaxes Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : OrderTaxes Class

The following tables list the members exposed by OrderTaxes.

Public Constructors

 | Name | Description
Public Constructor | OrderTaxes Constructor | Overloaded. Initializes a new instance of the OrderTaxes class.
Top

Public Properties

 | Name | Description
Public Property | Count | Returns the number of items in the collection. (Inherited from dotnetDATA.EntitySet<OrderTax>)
Public Property | Error | Gets the Error object.
Public Property | Item | Overloaded. Gets the tax for specified name.
Top

Public Methods

 | Name | Description
Public Method | Add | Add the newItem to this collection. (Inherited from dotnetDATA.EntitySet<OrderTax>)
Public Method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetDATA.EntitySet<OrderTax>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetDATA.EntitySet<OrderTax>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetDATA.EntitySet<OrderTax>)
Public Method | IndexOf | Returns the index of this item in the list. (Inherited from dotnetDATA.EntitySet<OrderTax>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetDATA.EntitySet<OrderTax>)
Public Method | Remove | Removes the item from the collection. (Inherited from dotnetDATA.EntitySet<OrderTax>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetDATA.EntitySet<OrderTax>)
Top

See Also

Reference

OrderTaxes Class
dotnetCART Namespace


%%PageItemTitle%%

OrderTaxes Constructor
[image]
dotnetCART Namespace > OrderTaxes Class : OrderTaxes Constructor

Initializes a new instance of the OrderTaxes class.

Overload List

Overload | Description
OrderTaxes Constructor() | Initializes a new instance of the OrderTaxes class.
OrderTaxes Constructor(IDbTable) | Initializes a new instance of the OrderTaxes class.
OrderTaxes Constructor(IDbTable,DbLoadType) | Initializes a new instance of the OrderTaxes class.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTaxes Class
OrderTaxes Members


%%PageItemTitle%%

OrderTaxes Constructor()
See Also
[image]
dotnetCART Namespace > OrderTaxes Class > OrderTaxes Constructor : OrderTaxes Constructor()

Initializes a new instance of the OrderTaxes class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OrderTaxes()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTaxes Class
OrderTaxes Members
Overload List


%%PageItemTitle%%

OrderTaxes Constructor(IDbTable)
See Also
[image]
dotnetCART Namespace > OrderTaxes Class > OrderTaxes Constructor : OrderTaxes Constructor(IDbTable)

parentTable
Initializes a new instance of the OrderTaxes class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parentTable As IDbTable _
)
C#
public OrderTaxes(
   IDbTable parentTable
)

Parameters

parentTable

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTaxes Class
OrderTaxes Members
Overload List


%%PageItemTitle%%

OrderTaxes Constructor(IDbTable,DbLoadType)
See Also
[image]
dotnetCART Namespace > OrderTaxes Class > OrderTaxes Constructor : OrderTaxes Constructor(IDbTable,DbLoadType)

parentTable
loadType
Initializes a new instance of the OrderTaxes class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parentTable As IDbTable, _
   ByVal loadType As DbLoadType _
)
C#
public OrderTaxes(
   IDbTable parentTable,
   DbLoadType loadType
)

Parameters

parentTable
loadType

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTaxes Class
OrderTaxes Members
Overload List


%%PageItemTitle%% $$Properties$$

OrderTaxes Class Properties
[image]
dotnetCART Namespace : OrderTaxes Class

For a list of all members of this type, see OrderTaxes members.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of items in the collection. (Inherited from dotnetDATA.EntitySet<OrderTax>)
Public Property | Error | Gets the Error object.
Public Property | Item | Overloaded. Gets the tax for specified name.
Top

See Also

Reference

OrderTaxes Class
dotnetCART Namespace


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > OrderTaxes Class : Error Property

Gets the Error object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTaxes Class
OrderTaxes Members


%%PageItemTitle%%

Item Property
[image]
dotnetCART Namespace > OrderTaxes Class : Item Property

Gets the tax for specified name.

Overload List

Overload | Description
Item(String) | Gets the tax for specified name.
Item(Int32) | Gets the element at the specified index. (Inherited from dotnetDATA.EntitySet<OrderTax>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTaxes Class
OrderTaxes Members


%%PageItemTitle%%

Item(String) Property
[image]
dotnetCART Namespace > OrderTaxes Class > Item Property : Item(String) Property

name
Gets the tax for specified name.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal name As String _
) As OrderTax
C#
public OrderTax Item(
   string name
) {get;}

Parameters

name

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTaxes Class
OrderTaxes Members
Overload List


%%PageItemTitle%%

OrderTransaction Class
See Also Members
[image]
dotnetCART Namespace : OrderTransaction Class

Represents an OrderTransaction object.

Object Model

Syntax

Visual Basic (Declaration)
Public Class OrderTransaction
   Inherits DbTableCart(Of OrderTransaction, Long)
C#
public class OrderTransaction : DbTableCart<OrderTransaction, long>

Inheritance Hierarchy

System.Object
dotnetDATA.DbTable<Int64>
dotnetDATA.DbTable<OrderTransaction, Int64>
dotnetCART.DbTableCart<OrderTransaction, Int64>
dotnetCART.OrderTransaction

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransaction Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

OrderTransaction Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : OrderTransaction Class

The following tables list the members exposed by OrderTransaction.

Public Constructors

 | Name | Description
Public Constructor | OrderTransaction Constructor | Initializes a new instance of the OrderTransaction class.
Top

Public Properties

 | Name | Description
Public Property | Amount | Gets or sets the Amount for this transaction.
Public Property | AuthCode | Gets or sets the AuthCode for this transaction.
Public Property | AvsCode | Gets or sets the AvsCode (Address verification result code) for this transaction.
Public Property | CartID | Gets or sets the CartID associated with this transaction.
Public Property | Code | Gets or sets the result of CVV2 code for this transaction.
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<OrderTransaction, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<OrderTransaction, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<OrderTransaction, Int64>)
Public Property | Date | Gets or sets the date for this transaction.
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<OrderTransaction, Int64>)
Public Property | ID | Overridden. The auto number ID populated from the database.
Public Property | Notes | Gets or sets the Notes for this transaction.
Public Property | PaymentID | Gets or sets the PaymentID for this transaction.
Public Property | ReferenceNumber | Gets or sets the ReferenceNumber for this transaction.
Public Property | Status | Gets or sets the Status for this transaction.
Public Property | TransactionID | Gets or sets the TransactionID for this transaction.
Top

Public Methods

 | Name | Description
Public Method | Clear | Initializes all the properties without recreating the object. (Inherited from dotnetCART.DbTableCart<OrderTransaction, Int64>)
Public Method | DeleteDB | Overloaded. Deletes all the transactions with this CartID.
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<OrderTransaction, Int64>)
Public Method | LoadDB | Overloaded. Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<OrderTransaction, Int64>)
Public Method | SaveDB | Overloaded. Overridden. Inserts or updates this object into the OrderTransactions table.
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<OrderTransaction, Int64>)
Top

See Also

Reference

OrderTransaction Class
dotnetCART Namespace


%%PageItemTitle%%

OrderTransaction Constructor
[image]
dotnetCART Namespace > OrderTransaction Class : OrderTransaction Constructor

Initializes a new instance of the OrderTransaction class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OrderTransaction()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransaction Class
OrderTransaction Members


%%PageItemTitle%% $$Methods$$

OrderTransaction Class Methods
[image]
dotnetCART Namespace : OrderTransaction Class

For a list of all members of this type, see OrderTransaction members.

Public Methods

 | Name | Description
Public Method | Clear | Initializes all the properties without recreating the object. (Inherited from dotnetCART.DbTableCart<OrderTransaction, Int64>)
Public Method | DeleteDB | Overloaded. Deletes all the transactions with this CartID.
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<OrderTransaction, Int64>)
Public Method | LoadDB | Overloaded. Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<OrderTransaction, Int64>)
Public Method | SaveDB | Overloaded. Overridden. Inserts or updates this object into the OrderTransactions table.
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<OrderTransaction, Int64>)
Top

See Also

Reference

OrderTransaction Class
dotnetCART Namespace


%%PageItemTitle%%

DeleteDB Method
[image]
dotnetCART Namespace > OrderTransaction Class : DeleteDB Method

Deletes all the transactions with this CartID.

Overload List

Overload | Description
DeleteDB(String) | Deletes all the transactions with this CartID.
DeleteDB() | Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<OrderTransaction, Int64>)
DeleteDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransaction Class
OrderTransaction Members


%%PageItemTitle%%

DeleteDB(String) Method
[image]
dotnetCART Namespace > OrderTransaction Class > DeleteDB Method : DeleteDB(String) Method

cartID
The string cartID
Deletes all the transactions with this CartID.

Syntax

Visual Basic (Declaration)
Public Overloads Function DeleteDB( _
   ByVal cartID As String _
) As Integer
C#
public int DeleteDB(
   string cartID
)

Parameters

cartID
The string cartID

Return Value

The total number of deleted transactions.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransaction Class
OrderTransaction Members
Overload List


%%PageItemTitle%%

SaveDB Method
[image]
dotnetCART Namespace > OrderTransaction Class : SaveDB Method

Inserts or updates this object into the OrderTransactions table.

Overload List

Overload | Description
SaveDB() | Inserts or updates this object into the OrderTransactions table.
SaveDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransaction Class
OrderTransaction Members


%%PageItemTitle%%

SaveDB() Method
[image]
dotnetCART Namespace > OrderTransaction Class > SaveDB Method : SaveDB() Method

Inserts or updates this object into the OrderTransactions table.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function SaveDB() As Integer
C#
public override int SaveDB()

Return Value

Returns the generated ID or 1 for the update, returns -1 if failed. For the reason of fail, check the Error property.

Remarks

If ID greater than 0, it updates the associated record in the table, otherwise inserts a new record.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransaction Class
OrderTransaction Members
Overload List


%%PageItemTitle%% $$Properties$$

OrderTransaction Class Properties
[image]
dotnetCART Namespace : OrderTransaction Class

For a list of all members of this type, see OrderTransaction members.

Public Properties

 | Name | Description
Public Property | Amount | Gets or sets the Amount for this transaction.
Public Property | AuthCode | Gets or sets the AuthCode for this transaction.
Public Property | AvsCode | Gets or sets the AvsCode (Address verification result code) for this transaction.
Public Property | CartID | Gets or sets the CartID associated with this transaction.
Public Property | Code | Gets or sets the result of CVV2 code for this transaction.
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<OrderTransaction, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<OrderTransaction, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<OrderTransaction, Int64>)
Public Property | Date | Gets or sets the date for this transaction.
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<OrderTransaction, Int64>)
Public Property | ID | Overridden. The auto number ID populated from the database.
Public Property | Notes | Gets or sets the Notes for this transaction.
Public Property | PaymentID | Gets or sets the PaymentID for this transaction.
Public Property | ReferenceNumber | Gets or sets the ReferenceNumber for this transaction.
Public Property | Status | Gets or sets the Status for this transaction.
Public Property | TransactionID | Gets or sets the TransactionID for this transaction.
Top

See Also

Reference

OrderTransaction Class
dotnetCART Namespace


%%PageItemTitle%%

Amount Property
[image]
dotnetCART Namespace > OrderTransaction Class : Amount Property

Gets or sets the Amount for this transaction.

Syntax

Visual Basic (Declaration)
Public Property Amount As Decimal
C#
public decimal Amount {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransaction Class
OrderTransaction Members


%%PageItemTitle%%

AuthCode Property
[image]
dotnetCART Namespace > OrderTransaction Class : AuthCode Property

Gets or sets the AuthCode for this transaction.

Syntax

Visual Basic (Declaration)
Public Property AuthCode As String
C#
public string AuthCode {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransaction Class
OrderTransaction Members


%%PageItemTitle%%

AvsCode Property
[image]
dotnetCART Namespace > OrderTransaction Class : AvsCode Property

Gets or sets the AvsCode (Address verification result code) for this transaction.

Syntax

Visual Basic (Declaration)
Public Property AvsCode As String
C#
public string AvsCode {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransaction Class
OrderTransaction Members


%%PageItemTitle%%

CartID Property
[image]
dotnetCART Namespace > OrderTransaction Class : CartID Property

Gets or sets the CartID associated with this transaction.

Syntax

Visual Basic (Declaration)
Public Property CartID As String
C#
public string CartID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransaction Class
OrderTransaction Members


%%PageItemTitle%%

Code Property
[image]
dotnetCART Namespace > OrderTransaction Class : Code Property

Gets or sets the result of CVV2 code for this transaction.

Syntax

Visual Basic (Declaration)
Public Property Code As String
C#
public string Code {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransaction Class
OrderTransaction Members


%%PageItemTitle%%

Date Property
[image]
dotnetCART Namespace > OrderTransaction Class : Date Property

Gets or sets the date for this transaction.

Syntax

Visual Basic (Declaration)
Public Property Date As Date
C#
public DateTime Date {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransaction Class
OrderTransaction Members


%%PageItemTitle%%

ID Property
[image]
dotnetCART Namespace > OrderTransaction Class : ID Property

The auto number ID populated from the database.

Syntax

Visual Basic (Declaration)
Public Overrides Property ID As Long
C#
public override long ID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransaction Class
OrderTransaction Members


%%PageItemTitle%%

Notes Property
[image]
dotnetCART Namespace > OrderTransaction Class : Notes Property

Gets or sets the Notes for this transaction.

Syntax

Visual Basic (Declaration)
Public Property Notes As String
C#
public string Notes {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransaction Class
OrderTransaction Members


%%PageItemTitle%%

PaymentID Property
[image]
dotnetCART Namespace > OrderTransaction Class : PaymentID Property

Gets or sets the PaymentID for this transaction.

Syntax

Visual Basic (Declaration)
Public Property PaymentID As String
C#
public string PaymentID {get; set;}

Remarks

It is usually the cart.Payment.ID which is saved to OrderTransactions table when invoking cartObj.Payment.Charge() method.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransaction Class
OrderTransaction Members


%%PageItemTitle%%

ReferenceNumber Property
[image]
dotnetCART Namespace > OrderTransaction Class : ReferenceNumber Property

Gets or sets the ReferenceNumber for this transaction.

Syntax

Visual Basic (Declaration)
Public Property ReferenceNumber As String
C#
public string ReferenceNumber {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransaction Class
OrderTransaction Members


%%PageItemTitle%%

Status Property
[image]
dotnetCART Namespace > OrderTransaction Class : Status Property

Gets or sets the Status for this transaction.

Syntax

Visual Basic (Declaration)
Public Property Status As String
C#
public string Status {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransaction Class
OrderTransaction Members


%%PageItemTitle%%

TransactionID Property
[image]
dotnetCART Namespace > OrderTransaction Class : TransactionID Property

Gets or sets the TransactionID for this transaction.

Syntax

Visual Basic (Declaration)
Public Property TransactionID As String
C#
public string TransactionID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransaction Class
OrderTransaction Members


%%PageItemTitle%%

OrderTransactions Class
See Also Members
[image]
dotnetCART Namespace : OrderTransactions Class

A collection of OrderTransaction objects.

Object Model

Syntax

Visual Basic (Declaration)
Public Class OrderTransactions
   Inherits ListBase(Of OrderTransaction)
C#
public class OrderTransactions : ListBase<OrderTransaction>

Inheritance Hierarchy

System.Object
System.Collections.Generic.List<OrderTransaction>
dotnetCART.ListBase<OrderTransaction>
dotnetCART.OrderTransactions

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransactions Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

OrderTransactions Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : OrderTransactions Class

The following tables list the members exposed by OrderTransactions.

Public Constructors

 | Name | Description
Public Constructor | OrderTransactions Constructor | Initializes a new instance of the OrderTransactions class.
Top

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from dotnetCART.ListBase<OrderTransaction>)
Public Property | Count | Gets the number of elements actually contained in the collection. (Inherited from dotnetCART.ListBase<OrderTransaction>)
Public Property | Error | Returns an object with the error information. (Inherited from dotnetCART.ListBase<OrderTransaction>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from dotnetCART.ListBase<OrderTransaction>)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds the new OrderTransactions to this collection.
Public Method | AddRange | Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetCART.ListBase<OrderTransaction>)
Public Method | AsReadOnly | Returns a read-only IList wrapper for the current collection. (Inherited from dotnetCART.ListBase<OrderTransaction>)
Public Method | BinarySearch | Overloaded. (Inherited from dotnetCART.ListBase<OrderTransaction>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetCART.ListBase<OrderTransaction>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetCART.ListBase<OrderTransaction>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<OrderTransaction>)
Public Method | CopyTo | Overloaded. (Inherited from dotnetCART.ListBase<OrderTransaction>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from dotnetCART.ListBase<OrderTransaction>)
Public Method | IndexOf | Overloaded. (Inherited from dotnetCART.ListBase<OrderTransaction>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetCART.ListBase<OrderTransaction>)
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from dotnetCART.ListBase<OrderTransaction>)
Public Method | LastIndexOf | Overloaded. (Inherited from dotnetCART.ListBase<OrderTransaction>)
Public Method | LoadDB | Overloaded. Loading all the transactions with specified cartID.
Public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from dotnetCART.ListBase<OrderTransaction>)
Public Method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from dotnetCART.ListBase<OrderTransaction>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetCART.ListBase<OrderTransaction>)
Public Method | RemoveRange | Removes a range of elements from the List. (Inherited from dotnetCART.ListBase<OrderTransaction>)
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<OrderTransaction>)
Top

See Also

Reference

OrderTransactions Class
dotnetCART Namespace


%%PageItemTitle%%

OrderTransactions Constructor
[image]
dotnetCART Namespace > OrderTransactions Class : OrderTransactions Constructor

Initializes a new instance of the OrderTransactions class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OrderTransactions()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransactions Class
OrderTransactions Members


%%PageItemTitle%% $$Methods$$

OrderTransactions Class Methods
[image]
dotnetCART Namespace : OrderTransactions Class

For a list of all members of this type, see OrderTransactions members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds the new OrderTransactions to this collection.
Public Method | AddRange | Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetCART.ListBase<OrderTransaction>)
Public Method | AsReadOnly | Returns a read-only IList wrapper for the current collection. (Inherited from dotnetCART.ListBase<OrderTransaction>)
Public Method | BinarySearch | Overloaded. (Inherited from dotnetCART.ListBase<OrderTransaction>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetCART.ListBase<OrderTransaction>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetCART.ListBase<OrderTransaction>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<OrderTransaction>)
Public Method | CopyTo | Overloaded. (Inherited from dotnetCART.ListBase<OrderTransaction>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from dotnetCART.ListBase<OrderTransaction>)
Public Method | IndexOf | Overloaded. (Inherited from dotnetCART.ListBase<OrderTransaction>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetCART.ListBase<OrderTransaction>)
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from dotnetCART.ListBase<OrderTransaction>)
Public Method | LastIndexOf | Overloaded. (Inherited from dotnetCART.ListBase<OrderTransaction>)
Public Method | LoadDB | Overloaded. Loading all the transactions with specified cartID.
Public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from dotnetCART.ListBase<OrderTransaction>)
Public Method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from dotnetCART.ListBase<OrderTransaction>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetCART.ListBase<OrderTransaction>)
Public Method | RemoveRange | Removes a range of elements from the List. (Inherited from dotnetCART.ListBase<OrderTransaction>)
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<OrderTransaction>)
Top

See Also

Reference

OrderTransactions Class
dotnetCART Namespace


%%PageItemTitle%%

Add Method
[image]
dotnetCART Namespace > OrderTransactions Class : Add Method

Adds the new OrderTransactions to this collection.

Overload List

Overload | Description
Add(Generic List) | Adds the new OrderTransactions to this collection.
Add(OrderTransaction) | (Inherited from dotnetCART.ListBase<OrderTransaction>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransactions Class
OrderTransactions Members


%%PageItemTitle%%

Add(Generic List) Method
[image]
dotnetCART Namespace > OrderTransactions Class > Add Method : Add(Generic List) Method

newOrderTransactions
A collection of OrderTransaction.
Adds the new OrderTransactions to this collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal newOrderTransactions As List(Of OrderTransaction) _
) As Integer
C#
public int Add(
   List<OrderTransaction> newOrderTransactions
)

Parameters

newOrderTransactions
A collection of OrderTransaction.

Return Value

The total number of transactions have been loaded, and -1 if failed. For the reason of fail, check the Error property.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransactions Class
OrderTransactions Members
Overload List


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > OrderTransactions Class : LoadDB Method

Loading all the transactions with specified cartID.

Overload List

Overload | Description
LoadDB(String) | Loading all the transactions with specified cartID.
LoadDB(String,Where) | Loading all the transactions with specified cartID.
LoadDB(Where) | Loading all the transactions matched the where clause.
LoadDB() | Loading all the transactions.
LoadDB(Int32,Int32) | Loads the count number of elements from start value. (Inherited from dotnetCART.ListBase<OrderTransaction>)
LoadDB(Where,Int32,Int32,String,OrderDirection) | Loads all the items based on the parameters. (Inherited from dotnetCART.ListBase<OrderTransaction>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransactions Class
OrderTransactions Members


%%PageItemTitle%%

LoadDB(String) Method
[image]
dotnetCART Namespace > OrderTransactions Class > LoadDB Method : LoadDB(String) Method

cartID
A string cartID.
Loading all the transactions with specified cartID.

Syntax

Visual Basic (Declaration)
Public Overloads Function LoadDB( _
   ByVal cartID As String _
) As Integer
C#
public int LoadDB(
   string cartID
)

Parameters

cartID
A string cartID.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransactions Class
OrderTransactions Members
Overload List


%%PageItemTitle%%

LoadDB(String,Where) Method
[image]
dotnetCART Namespace > OrderTransactions Class > LoadDB Method : LoadDB(String,Where) Method

cartID
A string cartID.
whereClause
The where clause to filter.
Loading all the transactions with specified cartID.

Syntax

Visual Basic (Declaration)
Public Overloads Function LoadDB( _
   ByVal cartID As String, _
   ByVal whereClause As Where _
) As Integer
C#
public int LoadDB(
   string cartID,
   Where whereClause
)

Parameters

cartID
A string cartID.
whereClause
The where clause to filter.

Return Value

The total number of transactions have been loaded, and -1 if failed. For the reason of fail, check the Error property.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransactions Class
OrderTransactions Members
Overload List


%%PageItemTitle%%

LoadDB(Where) Method
[image]
dotnetCART Namespace > OrderTransactions Class > LoadDB Method : LoadDB(Where) Method

whereClause
The where clause to filter.
Loading all the transactions matched the where clause.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function LoadDB( _
   ByVal whereClause As Where _
) As Integer
C#
public override int LoadDB(
   Where whereClause
)

Parameters

whereClause
The where clause to filter.

Return Value

The total number of transactions have been loaded, and -1 if failed. For the reason of fail, check the Error property.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransactions Class
OrderTransactions Members
Overload List


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > OrderTransactions Class > LoadDB Method : LoadDB() Method

Loading all the transactions.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function LoadDB() As Integer
C#
public override int LoadDB()

Return Value

The total number of transactions have been loaded, and -1 if failed. For the reason of fail, check the Error property.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransactions Class
OrderTransactions Members
Overload List


%%PageItemTitle%%

ParseResult Class
See Also Members
[image]
dotnetCART Namespace : ParseResult Class

Syntax

Visual Basic (Declaration)
Public Class ParseResult
C#
public class ParseResult

Inheritance Hierarchy

System.Object
dotnetCART.ParseResult

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ParseResult Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

ParseResult Class Members
See Also Properties
[image]
dotnetCART Namespace : ParseResult Class

The following tables list the members exposed by ParseResult.

Public Constructors

 | Name | Description
Public Constructor | ParseResult Constructor |
Top

Public Properties

 | Name | Description
Public Property | Country |
Public Property | EndIP |
Public Property | Error |
Public Property | Inetnum |
Public Property | Rir |
Public Property | SourceString |
Public Property | StartIP |
Top

See Also

Reference

ParseResult Class
dotnetCART Namespace


%%PageItemTitle%%

ParseResult Constructor
[image]
dotnetCART Namespace > ParseResult Class : ParseResult Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ParseResult()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ParseResult Class
ParseResult Members


%%PageItemTitle%% $$Properties$$

ParseResult Class Properties
[image]
dotnetCART Namespace : ParseResult Class

For a list of all members of this type, see ParseResult members.

Public Properties

 | Name | Description
Public Property | Country |
Public Property | EndIP |
Public Property | Error |
Public Property | Inetnum |
Public Property | Rir |
Public Property | SourceString |
Public Property | StartIP |
Top

See Also

Reference

ParseResult Class
dotnetCART Namespace


%%PageItemTitle%%

Country Property
[image]
dotnetCART Namespace > ParseResult Class : Country Property

Syntax

Visual Basic (Declaration)
Public Property Country As String
C#
public string Country {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ParseResult Class
ParseResult Members


%%PageItemTitle%%

EndIP Property
[image]
dotnetCART Namespace > ParseResult Class : EndIP Property

Syntax

Visual Basic (Declaration)
Public Property EndIP As String
C#
public string EndIP {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ParseResult Class
ParseResult Members


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > ParseResult Class : Error Property

Syntax

Visual Basic (Declaration)
Public Property Error As String
C#
public string Error {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ParseResult Class
ParseResult Members


%%PageItemTitle%%

Inetnum Property
[image]
dotnetCART Namespace > ParseResult Class : Inetnum Property

Syntax

Visual Basic (Declaration)
Public Property Inetnum As String
C#
public string Inetnum {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ParseResult Class
ParseResult Members


%%PageItemTitle%%

Rir Property
[image]
dotnetCART Namespace > ParseResult Class : Rir Property

Syntax

Visual Basic (Declaration)
Public Property Rir As RirType
C#
public RirType Rir {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ParseResult Class
ParseResult Members


%%PageItemTitle%%

SourceString Property
[image]
dotnetCART Namespace > ParseResult Class : SourceString Property

Syntax

Visual Basic (Declaration)
Public Property SourceString As String
C#
public string SourceString {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ParseResult Class
ParseResult Members


%%PageItemTitle%%

StartIP Property
[image]
dotnetCART Namespace > ParseResult Class : StartIP Property

Syntax

Visual Basic (Declaration)
Public Property StartIP As String
C#
public string StartIP {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ParseResult Class
ParseResult Members


%%PageItemTitle%%

Payment Class
See Also Members
[image]
dotnetCART Namespace : Payment Class

Represents a Payment object.

Object Model

Syntax

Visual Basic (Declaration)
Public Class Payment
C#
public class Payment

Remarks

For a typical usage, see payment processing.

Inheritance Hierarchy

System.Object
dotnetCART.Payment

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

Payment Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : Payment Class

The following tables list the members exposed by Payment.

Public Constructors

 | Name | Description
Public Constructor | Payment Constructor | Initializes a new instance of the Payment.
Top

Public Properties

 | Name | Description
Public Property | AcceptedCardTypes | A comma delimited string which controls which credit cards will be accepted by the prevalidator. Options: Visa, MasterCard, AMEX, Diners, Discover, JCB, Switch, Solo, Laser and Maestro.
Public Property | AccountID | Sets or gets the AccountID.
Public Property | AgentBankNumber | Sets or gets the AgentBankNumber.
Public Property | AgentChainNumber | Sets or gets the AgentChainNumber.
Public Property | Amount | Sets or gets the transaction amount.
Public Property | ApplySecure3D | Sets an integer value to apply secure3D.
Public Property | AuthCode | Gets the transaction authorization code.
Public Property | AvsCode | Gets the address verification code.
Public Property | AvsIndicator | Sets or gets the AvsIndicator.
Public Property | BankAccountType | Sets or gets the BankAccountType.
Public Property | BankCode | Gets or sets the Bank Code.
Public Property | BankName | Gets or sets the Bank Name.
Public Property | BillingCount | Number of payments to be made over the life of the agreement.
Public Property | CancelReturnSite | Sets or gets the CancelReturnSite.
Public Property | CardCode | Sets to CVV2 credit card code and gets the result after invoking Charge method.
Public Property | CardName | Gets or sets the credit card number.
Public Property | CardNumber | Gets or sets the credit card number.
Public Property | CardType | Sets or gets the credit card type.
Public Property | CcMonth | Gets or sets the credit expiry month.
Public Property | CcYear | Gets or sets the credit card expiry year.
Public Property | Certificate | Gets or sets the certificate.
Public Property | ClientIP | Sets or gets the ClientIP.
Public Property | CurrencyCode | Sets or gets the currency code.
Public Property | Custom | Gets or sets a custom object. For more information see custom fields
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object.
Public Property | Customs | A reference to the collection of the Custom objects.
Public Property | Description | Sets or gets the Description.
Public Property | DL | Sets or gets the
Public Property | DLDOB | Sets or gets the date of birth on the driver license.
Public Property | DLState | Sets or gets the driver license state.
Public Property | Error | Gets the error object.
Public Property | ErrorCode | Gets the error code related to a transaction process or returns from the gateway/processor.
Public Property | ErrorMessage | Gets the error message related to a transaction process or returns from the gateway/processor.
Public Property | ID | Gets or sets a payment ID.
Public Property | ImageUrl | Sets or gets the ImageUrl.
Public Property | IPNVerificationURL | Sets or gets the IPNVerificationURL.
Public Property | IssueDate | Sets or gets the IssueDate.
Public Property | IssueNumber | Sets or gets the IssueNumber.
Public Property | Login | Gets or sets the login.
Public Property | MerchantCity | Sets or gets the Merchant City.
Public Property | MerchantCountry | Sets or gets the Merchant Country.
Public Property | MerchantName | Sets or gets the Merchant Name.
Public Property | MerchantPhone | Sets or gets the Merchant Phone.
Public Property | MerchantState | Sets or gets the Merchant State.
Public Property | MerchantZipPostal | Sets or gets the Merchant ZipPostal.
Public Property | OrganizationType | Sets or gets the oOrganization type.
Public Property | Partner | Sets or gets the Partner.
Public Property | Password | Gets or sets the Password.
Public Property | PaymentIndicator | Sets or gets the PaymentIndicator.
Public Property | PaymentProfiles |
Public Property | PaymentType | Gets or sets the payment type.
Public Property | Port | Sets or gets the port.
Public Property | PreValidate | Determines whether to validate the required fields before sending the data to the gateway/processor or not.
Public Property | RecurringBilling | Determine whether to enable recurring billing or not. Currently, it only applies to: Authorize.net, PaymentTechOrbital, GlobalPayments, LinkPoint and PayFlowPro
Public Property | ReferenceNumber | Sets or gets the ReferenceNumber.
Public Property | Referrer | Sets or gets the Referrer.
Public Property | ReturnSite | Sets or gets the ReturnSite.
Public Property | Server | Gets or sets the server URL. It is automatically set for the gateway/processr and usually should not be set.
Public Property | Setting | Sets a special setting for some gateways.
Public Property | SettleInterval | Specifies the time period between two billings. The format is depneds on the gateway.
Public Property | StartDate | Beginning date for the recurring billing cycle used to calculate when payments should be made. Default is now.
Public Property | Status | Gets or sets the charge status. It is the same value returns by Charge method.
Public Property | StoreNumber | Sets or gets the StoreNumber.
Public Property | TaxID | Sets or gets the TaxID.
Public Property | TerminalID | Sets or gets the TerminalID.
Public Property | TerminalNumber | Sets or gets the TerminalNumber.
Public Property | TestMode | Determines whether to use the test server or setting for the gateway/processor or not.
Public Property | Timeout | Gets or sets the time out for transaction response time. Defaults to 45 seconds.
Public Property | TimeZone | Gets or sets a TimeZone. Defauts to PST.
Public Property | TransactionID | Sets or gets the TransactionID.
Public Property | TransactionKey | Sets or gets the TransactionKey.
Public Property | TransactionOrigin | Sets or gets the transaction origin.
Public Property | TransactionStatus | Gets or sets a string transaction status which is saved to OrderTransactions table when invoking SaveTransactionDB
Public Property | TransactionType | Gets or sets the transaction type.
Public Property | UserName | Sets or gets the UserName.
Top

Public Methods

 | Name | Description
Public Method | AddParameter | Overloaded. Can be used to pass new or custom parameters to a given gateway.
Public Method | Charge | Overloaded. Performs a realtime transaction of the type defined in TransactionType which defaults to sale (capture).
Public Method | GetCardType | Returns the credit card type
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection.
Public Method | GetParameter | Can be used to get new or custom parameters from a given gateway. This method would typically not be used but is supported in special cases.
Public Method | SavePaymentSettings | Saves payment settings to the settings configuration file specified in Settings.FileName and Settings.Path.
Public Method | SaveTransactionDB | Saves payment transaction to database.
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added.
Top

See Also

Reference

Payment Class
dotnetCART Namespace


%%PageItemTitle%%

Payment Constructor
[image]
dotnetCART Namespace > Payment Class : Payment Constructor

Initializes a new instance of the Payment.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Payment()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%% $$Methods$$

Payment Class Methods
[image]
dotnetCART Namespace : Payment Class

For a list of all members of this type, see Payment members.

Public Methods

 | Name | Description
Public Method | AddParameter | Overloaded. Can be used to pass new or custom parameters to a given gateway.
Public Method | Charge | Overloaded. Performs a realtime transaction of the type defined in TransactionType which defaults to sale (capture).
Public Method | GetCardType | Returns the credit card type
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection.
Public Method | GetParameter | Can be used to get new or custom parameters from a given gateway. This method would typically not be used but is supported in special cases.
Public Method | SavePaymentSettings | Saves payment settings to the settings configuration file specified in Settings.FileName and Settings.Path.
Public Method | SaveTransactionDB | Saves payment transaction to database.
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added.
Top

See Also

Reference

Payment Class
dotnetCART Namespace


%%PageItemTitle%%

AddParameter Method
[image]
dotnetCART Namespace > Payment Class : AddParameter Method

Can be used to pass new or custom parameters to a given gateway.

Overload List

Overload | Description
AddParameter(String) | Can be used to pass new or custom parameters to a given gateway.
AddParameter(String,String) | Can be used to pass new or custom parameters to a given gateway.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

AddParameter(String) Method
[image]
dotnetCART Namespace > Payment Class > AddParameter Method : AddParameter(String) Method

keyValue
A 'key=value' string.
Can be used to pass new or custom parameters to a given gateway.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddParameter( _
   ByVal keyValue As String _
)
C#
public void AddParameter(
   string keyValue
)

Parameters

keyValue
A 'key=value' string.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members
Overload List


%%PageItemTitle%%

AddParameter(String,String) Method
[image]
dotnetCART Namespace > Payment Class > AddParameter Method : AddParameter(String,String) Method

keyName
A key name.
valueName
A string value.
Can be used to pass new or custom parameters to a given gateway.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddParameter( _
   ByVal keyName As String, _
   ByVal valueName As String _
)
C#
public void AddParameter(
   string keyName,
   string valueName
)

Parameters

keyName
A key name.
valueName
A string value.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members
Overload List


%%PageItemTitle%%

Charge Method
[image]
dotnetCART Namespace > Payment Class : Charge Method

Performs a realtime transaction of the type defined in TransactionType which defaults to sale (capture).

Overload List

Overload | Description
Charge() | Performs a realtime transaction of the type defined in TransactionType which defaults to sale (capture).
Charge(Processor) | Performs a realtime transaction of the type defined in TransactionType which defaults to sale (capture).
Charge(String) | Performs a realtime transaction of the type defined in TransactionType which defaults to sale (capture).

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

Charge() Method
[image]
dotnetCART Namespace > Payment Class > Charge Method : Charge() Method

Performs a realtime transaction of the type defined in TransactionType which defaults to sale (capture).

Syntax

Visual Basic (Declaration)
Public Overloads Function Charge() As Integer
C#
public int Charge()

Return Value

Returns 1 for success, 2 for a prevalidation error and 3 for an error from the gateway. The ErrorCode and ErrorMessage properties are populated when the charge methods returns a 2 or 3.

Remarks

The gateway/processor name and associated settings are loaded from StoreAdmin->Payment tab. The Billing address information is set using Cart.BillAddress or Order.BillAddressproperty.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members
Overload List


%%PageItemTitle%%

Charge(Processor) Method
[image]
dotnetCART Namespace > Payment Class > Charge Method : Charge(Processor) Method

myProcessor
One of the Processors.
Performs a realtime transaction of the type defined in TransactionType which defaults to sale (capture).

Syntax

Visual Basic (Declaration)
Public Overloads Function Charge( _
   ByVal myProcessor As Processor _
) As Integer
C#
public int Charge(
   Processor myProcessor
)

Parameters

myProcessor
One of the Processors.

Return Value

Returns 1 for success, 2 for a prevalidation error and 3 for an error from the gateway. The ErrorCode and ErrorMessage properties are populated when the charge methods returns a 2 or 3.

Remarks

If using this overload method, and setting Loginproperty, all other required properties must be set before invoking this method. If Loginproperty is not set, all the settings are loaded from StoreAdmin->Payment The Billing address information is set using Cart.BillAddress or Order.BillAddress property.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members
Overload List


%%PageItemTitle%%

Charge(String) Method
[image]
dotnetCART Namespace > Payment Class > Charge Method : Charge(String) Method

strProcessor
One of the gateway/processor in a string format.
Performs a realtime transaction of the type defined in TransactionType which defaults to sale (capture).

Syntax

Visual Basic (Declaration)
Public Overloads Function Charge( _
   ByVal strProcessor As String _
) As Integer
C#
public int Charge(
   string strProcessor
)

Parameters

strProcessor
One of the gateway/processor in a string format.

Return Value

Returns 1 for success, 2 for a prevalidation error and 3 for an error from the gateway. The ErrorCode and ErrorMessage properties are populated when the charge methods returns a 2 or 3.

Remarks

If using this overload method, the required properties must be set before invoking this method. The Billing address information is set using Cart.BillAddress or Order.BillAddressproperty.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members
Overload List


%%PageItemTitle%%

GetCardType Method
[image]
dotnetCART Namespace > Payment Class : GetCardType Method

creditCardNumber
Returns the credit card type

Syntax

Visual Basic (Declaration)
Public Function GetCardType( _
   ByVal creditCardNumber As String _
) As String
C#
public string GetCardType(
   string creditCardNumber
)

Parameters

creditCardNumber

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

GetCustom Method
[image]
dotnetCART Namespace > Payment Class : GetCustom Method

This method returns the value of a custom field based on its name in the customs collection.

Overload List

Overload | Description
GetCustom(String) | This method returns the value of a custom field based on its name in the customs collection.
GetCustom(Int32) | This method returns the value of a custom field based on its index in the customs collection.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

GetCustom(String) Method
[image]
dotnetCART Namespace > Payment Class > GetCustom Method : GetCustom(String) Method

name
The name of the custom field.
This method returns the value of a custom field based on its name in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal name As String _
) As Object
C#
public object GetCustom(
   string name
)

Parameters

name
The name of the custom field.

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members
Overload List


%%PageItemTitle%%

GetCustom(Int32) Method
[image]
dotnetCART Namespace > Payment Class > GetCustom Method : GetCustom(Int32) Method

customIndex
A one base custom index.
This method returns the value of a custom field based on its index in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal customIndex As Integer _
) As Object
C#
public object GetCustom(
   int customIndex
)

Parameters

customIndex
A one base custom index.

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members
Overload List


%%PageItemTitle%%

GetParameter Method
[image]
dotnetCART Namespace > Payment Class : GetParameter Method

name
The parameter name.
Can be used to get new or custom parameters from a given gateway. This method would typically not be used but is supported in special cases.

Syntax

Visual Basic (Declaration)
Public Function GetParameter( _
   ByVal name As String _
) As String
C#
public string GetParameter(
   string name
)

Parameters

name
The parameter name.

Return Value

The parameter value.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

SavePaymentSettings Method
[image]
dotnetCART Namespace > Payment Class : SavePaymentSettings Method

Saves payment settings to the settings configuration file specified in Settings.FileName and Settings.Path.

Syntax

Visual Basic (Declaration)
Public Function SavePaymentSettings() As Boolean
C#
public bool SavePaymentSettings()

Return Value

If returns false, check Store.Settings.Error.Message for the error information.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

SaveTransactionDB Method
[image]
dotnetCART Namespace > Payment Class : SaveTransactionDB Method

Saves payment transaction to database.

Syntax

Visual Basic (Declaration)
Public Function SaveTransactionDB() As Integer
C#
public int SaveTransactionDB()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

SetCustom Method
[image]
dotnetCART Namespace > Payment Class : SetCustom Method

name
The name of the custom field.
newValue
The new custom field value.
This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added.

Syntax

Visual Basic (Declaration)
Public Function SetCustom( _
   ByVal name As String, _
   ByVal newValue As Object _
) As Object
C#
public object SetCustom(
   string name,
   object newValue
)

Parameters

name
The name of the custom field.
newValue
The new custom field value.

Return Value

Returns the new custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%% $$Properties$$

Payment Class Properties
[image]
dotnetCART Namespace : Payment Class

For a list of all members of this type, see Payment members.

Public Properties

 | Name | Description
Public Property | AcceptedCardTypes | A comma delimited string which controls which credit cards will be accepted by the prevalidator. Options: Visa, MasterCard, AMEX, Diners, Discover, JCB, Switch, Solo, Laser and Maestro.
Public Property | AccountID | Sets or gets the AccountID.
Public Property | AgentBankNumber | Sets or gets the AgentBankNumber.
Public Property | AgentChainNumber | Sets or gets the AgentChainNumber.
Public Property | Amount | Sets or gets the transaction amount.
Public Property | ApplySecure3D | Sets an integer value to apply secure3D.
Public Property | AuthCode | Gets the transaction authorization code.
Public Property | AvsCode | Gets the address verification code.
Public Property | AvsIndicator | Sets or gets the AvsIndicator.
Public Property | BankAccountType | Sets or gets the BankAccountType.
Public Property | BankCode | Gets or sets the Bank Code.
Public Property | BankName | Gets or sets the Bank Name.
Public Property | BillingCount | Number of payments to be made over the life of the agreement.
Public Property | CancelReturnSite | Sets or gets the CancelReturnSite.
Public Property | CardCode | Sets to CVV2 credit card code and gets the result after invoking Charge method.
Public Property | CardName | Gets or sets the credit card number.
Public Property | CardNumber | Gets or sets the credit card number.
Public Property | CardType | Sets or gets the credit card type.
Public Property | CcMonth | Gets or sets the credit expiry month.
Public Property | CcYear | Gets or sets the credit card expiry year.
Public Property | Certificate | Gets or sets the certificate.
Public Property | ClientIP | Sets or gets the ClientIP.
Public Property | CurrencyCode | Sets or gets the currency code.
Public Property | Custom | Gets or sets a custom object. For more information see custom fields
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object.
Public Property | Customs | A reference to the collection of the Custom objects.
Public Property | Description | Sets or gets the Description.
Public Property | DL | Sets or gets the
Public Property | DLDOB | Sets or gets the date of birth on the driver license.
Public Property | DLState | Sets or gets the driver license state.
Public Property | Error | Gets the error object.
Public Property | ErrorCode | Gets the error code related to a transaction process or returns from the gateway/processor.
Public Property | ErrorMessage | Gets the error message related to a transaction process or returns from the gateway/processor.
Public Property | ID | Gets or sets a payment ID.
Public Property | ImageUrl | Sets or gets the ImageUrl.
Public Property | IPNVerificationURL | Sets or gets the IPNVerificationURL.
Public Property | IssueDate | Sets or gets the IssueDate.
Public Property | IssueNumber | Sets or gets the IssueNumber.
Public Property | Login | Gets or sets the login.
Public Property | MerchantCity | Sets or gets the Merchant City.
Public Property | MerchantCountry | Sets or gets the Merchant Country.
Public Property | MerchantName | Sets or gets the Merchant Name.
Public Property | MerchantPhone | Sets or gets the Merchant Phone.
Public Property | MerchantState | Sets or gets the Merchant State.
Public Property | MerchantZipPostal | Sets or gets the Merchant ZipPostal.
Public Property | OrganizationType | Sets or gets the oOrganization type.
Public Property | Partner | Sets or gets the Partner.
Public Property | Password | Gets or sets the Password.
Public Property | PaymentIndicator | Sets or gets the PaymentIndicator.
Public Property | PaymentProfiles |
Public Property | PaymentType | Gets or sets the payment type.
Public Property | Port | Sets or gets the port.
Public Property | PreValidate | Determines whether to validate the required fields before sending the data to the gateway/processor or not.
Public Property | RecurringBilling | Determine whether to enable recurring billing or not. Currently, it only applies to: Authorize.net, PaymentTechOrbital, GlobalPayments, LinkPoint and PayFlowPro
Public Property | ReferenceNumber | Sets or gets the ReferenceNumber.
Public Property | Referrer | Sets or gets the Referrer.
Public Property | ReturnSite | Sets or gets the ReturnSite.
Public Property | Server | Gets or sets the server URL. It is automatically set for the gateway/processr and usually should not be set.
Public Property | Setting | Sets a special setting for some gateways.
Public Property | SettleInterval | Specifies the time period between two billings. The format is depneds on the gateway.
Public Property | StartDate | Beginning date for the recurring billing cycle used to calculate when payments should be made. Default is now.
Public Property | Status | Gets or sets the charge status. It is the same value returns by Charge method.
Public Property | StoreNumber | Sets or gets the StoreNumber.
Public Property | TaxID | Sets or gets the TaxID.
Public Property | TerminalID | Sets or gets the TerminalID.
Public Property | TerminalNumber | Sets or gets the TerminalNumber.
Public Property | TestMode | Determines whether to use the test server or setting for the gateway/processor or not.
Public Property | Timeout | Gets or sets the time out for transaction response time. Defaults to 45 seconds.
Public Property | TimeZone | Gets or sets a TimeZone. Defauts to PST.
Public Property | TransactionID | Sets or gets the TransactionID.
Public Property | TransactionKey | Sets or gets the TransactionKey.
Public Property | TransactionOrigin | Sets or gets the transaction origin.
Public Property | TransactionStatus | Gets or sets a string transaction status which is saved to OrderTransactions table when invoking SaveTransactionDB
Public Property | TransactionType | Gets or sets the transaction type.
Public Property | UserName | Sets or gets the UserName.
Top

See Also

Reference

Payment Class
dotnetCART Namespace


%%PageItemTitle%%

AcceptedCardTypes Property
[image]
dotnetCART Namespace > Payment Class : AcceptedCardTypes Property

A comma delimited string which controls which credit cards will be accepted by the prevalidator. Options: Visa, MasterCard, AMEX, Diners, Discover, JCB, Switch, Solo, Laser and Maestro.

Syntax

Visual Basic (Declaration)
Public Property AcceptedCardTypes As String
C#
public string AcceptedCardTypes {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

AccountID Property
[image]
dotnetCART Namespace > Payment Class : AccountID Property

Sets or gets the AccountID.

Syntax

Visual Basic (Declaration)
Public Property AccountID As String
C#
public string AccountID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

AgentBankNumber Property
[image]
dotnetCART Namespace > Payment Class : AgentBankNumber Property

Sets or gets the AgentBankNumber.

Syntax

Visual Basic (Declaration)
Public Property AgentBankNumber As Integer
C#
public int AgentBankNumber {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

AgentChainNumber Property
[image]
dotnetCART Namespace > Payment Class : AgentChainNumber Property

Sets or gets the AgentChainNumber.

Syntax

Visual Basic (Declaration)
Public Property AgentChainNumber As Integer
C#
public int AgentChainNumber {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

Amount Property
[image]
dotnetCART Namespace > Payment Class : Amount Property

Sets or gets the transaction amount.

Syntax

Visual Basic (Declaration)
Public Property Amount As Decimal
C#
public decimal Amount {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

ApplySecure3D Property
[image]
dotnetCART Namespace > Payment Class : ApplySecure3D Property

Sets an integer value to apply secure3D.

Syntax

Visual Basic (Declaration)
Public Property ApplySecure3D As Integer
C#
public int ApplySecure3D {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

AuthCode Property
[image]
dotnetCART Namespace > Payment Class : AuthCode Property

Gets the transaction authorization code.

Syntax

Visual Basic (Declaration)
Public Property AuthCode As String
C#
public string AuthCode {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

AvsCode Property
[image]
dotnetCART Namespace > Payment Class : AvsCode Property

Gets the address verification code.

Syntax

Visual Basic (Declaration)
Public Property AvsCode As String
C#
public string AvsCode {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

AvsIndicator Property
[image]
dotnetCART Namespace > Payment Class : AvsIndicator Property

Sets or gets the AvsIndicator.

Syntax

Visual Basic (Declaration)
Public Property AvsIndicator As Integer
C#
public int AvsIndicator {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

BankAccountType Property
[image]
dotnetCART Namespace > Payment Class : BankAccountType Property

Sets or gets the BankAccountType.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property BankAccountType As String
C#
public string BankAccountType {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

BankCode Property
[image]
dotnetCART Namespace > Payment Class : BankCode Property

Gets or sets the Bank Code.

Syntax

Visual Basic (Declaration)
Public Property BankCode As String
C#
public string BankCode {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

BankName Property
[image]
dotnetCART Namespace > Payment Class : BankName Property

Gets or sets the Bank Name.

Syntax

Visual Basic (Declaration)
Public Property BankName As String
C#
public string BankName {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

BillingCount Property
[image]
dotnetCART Namespace > Payment Class : BillingCount Property

Number of payments to be made over the life of the agreement.

Syntax

Visual Basic (Declaration)
Public Property BillingCount As Integer
C#
public int BillingCount {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

CancelReturnSite Property
[image]
dotnetCART Namespace > Payment Class : CancelReturnSite Property

Sets or gets the CancelReturnSite.

Syntax

Visual Basic (Declaration)
Public Property CancelReturnSite As String
C#
public string CancelReturnSite {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

CardCode Property
[image]
dotnetCART Namespace > Payment Class : CardCode Property

Sets to CVV2 credit card code and gets the result after invoking Charge method.

Syntax

Visual Basic (Declaration)
Public Property CardCode As String
C#
public string CardCode {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

CardName Property
[image]
dotnetCART Namespace > Payment Class : CardName Property

Gets or sets the credit card number.

Syntax

Visual Basic (Declaration)
Public Property CardName As String
C#
public string CardName {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

CardNumber Property
[image]
dotnetCART Namespace > Payment Class : CardNumber Property

Gets or sets the credit card number.

Syntax

Visual Basic (Declaration)
Public Property CardNumber As String
C#
public string CardNumber {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

CardType Property
[image]
dotnetCART Namespace > Payment Class : CardType Property

Sets or gets the credit card type.

Syntax

Visual Basic (Declaration)
Public Property CardType As String
C#
public string CardType {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

CcMonth Property
[image]
dotnetCART Namespace > Payment Class : CcMonth Property

Gets or sets the credit expiry month.

Syntax

Visual Basic (Declaration)
Public Property CcMonth As Integer
C#
public int CcMonth {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

CcYear Property
[image]
dotnetCART Namespace > Payment Class : CcYear Property

Gets or sets the credit card expiry year.

Syntax

Visual Basic (Declaration)
Public Property CcYear As Integer
C#
public int CcYear {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

Certificate Property
[image]
dotnetCART Namespace > Payment Class : Certificate Property

Gets or sets the certificate.

Syntax

Visual Basic (Declaration)
Public Property Certificate As String
C#
public string Certificate {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

ClientIP Property
[image]
dotnetCART Namespace > Payment Class : ClientIP Property

Sets or gets the ClientIP.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property ClientIP As String
C#
public string ClientIP {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

CurrencyCode Property
[image]
dotnetCART Namespace > Payment Class : CurrencyCode Property

Sets or gets the currency code.

Syntax

Visual Basic (Declaration)
Public Property CurrencyCode As String
C#
public string CurrencyCode {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

Custom Property
[image]
dotnetCART Namespace > Payment Class : Custom Property

Gets or sets a custom object. For more information see custom fields

Syntax

Visual Basic (Declaration)
Public Property Custom As Custom
C#
public Custom Custom {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

CustomFields Property
[image]
dotnetCART Namespace > Payment Class : CustomFields Property

Gets or sets a the names of custom fields for a table associated with the object.

Syntax

Visual Basic (Declaration)
Public Property CustomFields As String
C#
public string CustomFields {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

Customs Property
[image]
dotnetCART Namespace > Payment Class : Customs Property

A reference to the collection of the Custom objects.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Customs As Customs
C#
public Customs Customs {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

Description Property
[image]
dotnetCART Namespace > Payment Class : Description Property

Sets or gets the Description.

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

DL Property
[image]
dotnetCART Namespace > Payment Class : DL Property

Sets or gets the

Syntax

Visual Basic (Declaration)
Public WriteOnly Property DL As String
C#
public string DL {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

DLDOB Property
[image]
dotnetCART Namespace > Payment Class : DLDOB Property

Sets or gets the date of birth on the driver license.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property DLDOB As String
C#
public string DLDOB {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

DLState Property
[image]
dotnetCART Namespace > Payment Class : DLState Property

Sets or gets the driver license state.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property DLState As String
C#
public string DLState {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > Payment Class : Error Property

Gets the error object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Remarks

This error object reports the error not related to performing the realtime transactions like databse error. For the error related to the realtime transaction, check ErrorMessage and T:ErrorCoe after invoking Charge method.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

ErrorCode Property
[image]
dotnetCART Namespace > Payment Class : ErrorCode Property

Gets the error code related to a transaction process or returns from the gateway/processor.

Syntax

Visual Basic (Declaration)
Public Property ErrorCode As String
C#
public string ErrorCode {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

ErrorMessage Property
[image]
dotnetCART Namespace > Payment Class : ErrorMessage Property

Gets the error message related to a transaction process or returns from the gateway/processor.

Syntax

Visual Basic (Declaration)
Public Property ErrorMessage As String
C#
public string ErrorMessage {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

ID Property
[image]
dotnetCART Namespace > Payment Class : ID Property

Gets or sets a payment ID.

Syntax

Visual Basic (Declaration)
Public Property ID As String
C#
public string ID {get; set;}

Remarks

When calling SaveOrderDBCart.SaveOrderDB, the payment.ID will be saved in the PaymentID field of the OrderTransactions table. When calling SaveTransactionDBSaveTransactionDB, the payment.ID will be saved in the PaymentID field of the OrderTransactions table.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

ImageUrl Property
[image]
dotnetCART Namespace > Payment Class : ImageUrl Property

Sets or gets the ImageUrl.

Syntax

Visual Basic (Declaration)
Public Property ImageUrl As String
C#
public string ImageUrl {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

IPNVerificationURL Property
[image]
dotnetCART Namespace > Payment Class : IPNVerificationURL Property

Sets or gets the IPNVerificationURL.

Syntax

Visual Basic (Declaration)
Public Property IPNVerificationURL As String
C#
public string IPNVerificationURL {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

IssueDate Property
[image]
dotnetCART Namespace > Payment Class : IssueDate Property

Sets or gets the IssueDate.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property IssueDate As Date
C#
public DateTime IssueDate {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

IssueNumber Property
[image]
dotnetCART Namespace > Payment Class : IssueNumber Property

Sets or gets the IssueNumber.

Syntax

Visual Basic (Declaration)
Public Property IssueNumber As String
C#
public string IssueNumber {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

Login Property
[image]
dotnetCART Namespace > Payment Class : Login Property

Gets or sets the login.

Syntax

Visual Basic (Declaration)
Public Property Login As String
C#
public string Login {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

MerchantCity Property
[image]
dotnetCART Namespace > Payment Class : MerchantCity Property

Sets or gets the Merchant City.

Syntax

Visual Basic (Declaration)
Public Property MerchantCity As String
C#
public string MerchantCity {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

MerchantCountry Property
[image]
dotnetCART Namespace > Payment Class : MerchantCountry Property

Sets or gets the Merchant Country.

Syntax

Visual Basic (Declaration)
Public Property MerchantCountry As CountryCode
C#
public CountryCode MerchantCountry {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

MerchantName Property
[image]
dotnetCART Namespace > Payment Class : MerchantName Property

Sets or gets the Merchant Name.

Syntax

Visual Basic (Declaration)
Public Property MerchantName As String
C#
public string MerchantName {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

MerchantPhone Property
[image]
dotnetCART Namespace > Payment Class : MerchantPhone Property

Sets or gets the Merchant Phone.

Syntax

Visual Basic (Declaration)
Public Property MerchantPhone As String
C#
public string MerchantPhone {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

MerchantState Property
[image]
dotnetCART Namespace > Payment Class : MerchantState Property

Sets or gets the Merchant State.

Syntax

Visual Basic (Declaration)
Public Property MerchantState As String
C#
public string MerchantState {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

MerchantZipPostal Property
[image]
dotnetCART Namespace > Payment Class : MerchantZipPostal Property

Sets or gets the Merchant ZipPostal.

Syntax

Visual Basic (Declaration)
Public Property MerchantZipPostal As String
C#
public string MerchantZipPostal {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

OrganizationType Property
[image]
dotnetCART Namespace > Payment Class : OrganizationType Property

Sets or gets the oOrganization type.

Syntax

Visual Basic (Declaration)
Public Property OrganizationType As String
C#
public string OrganizationType {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

Partner Property
[image]
dotnetCART Namespace > Payment Class : Partner Property

Sets or gets the Partner.

Syntax

Visual Basic (Declaration)
Public Property Partner As String
C#
public string Partner {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

Password Property
[image]
dotnetCART Namespace > Payment Class : Password Property

Gets or sets the Password.

Syntax

Visual Basic (Declaration)
Public Property Password As String
C#
public string Password {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

PaymentIndicator Property
[image]
dotnetCART Namespace > Payment Class : PaymentIndicator Property

Sets or gets the PaymentIndicator.

Syntax

Visual Basic (Declaration)
Public Property PaymentIndicator As Integer
C#
public int PaymentIndicator {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

PaymentProfiles Property
[image]
dotnetCART Namespace > Payment Class : PaymentProfiles Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PaymentProfiles As List(Of PaymentProfile)
C#
public List<PaymentProfile> PaymentProfiles {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

PaymentType Property
[image]
dotnetCART Namespace > Payment Class : PaymentType Property

Gets or sets the payment type.

Syntax

Visual Basic (Declaration)
Public Property PaymentType As String
C#
public string PaymentType {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

Port Property
[image]
dotnetCART Namespace > Payment Class : Port Property

Sets or gets the port.

Syntax

Visual Basic (Declaration)
Public Property Port As Integer
C#
public int Port {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

PreValidate Property
[image]
dotnetCART Namespace > Payment Class : PreValidate Property

Determines whether to validate the required fields before sending the data to the gateway/processor or not.

Syntax

Visual Basic (Declaration)
Public Property PreValidate As Boolean
C#
public bool PreValidate {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

RecurringBilling Property
[image]
dotnetCART Namespace > Payment Class : RecurringBilling Property

Determine whether to enable recurring billing or not. Currently, it only applies to: Authorize.net, PaymentTechOrbital, GlobalPayments, LinkPoint and PayFlowPro

Syntax

Visual Basic (Declaration)
Public Property RecurringBilling As Boolean
C#
public bool RecurringBilling {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

ReferenceNumber Property
[image]
dotnetCART Namespace > Payment Class : ReferenceNumber Property

Sets or gets the ReferenceNumber.

Syntax

Visual Basic (Declaration)
Public Property ReferenceNumber As String
C#
public string ReferenceNumber {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

Referrer Property
[image]
dotnetCART Namespace > Payment Class : Referrer Property

Sets or gets the Referrer.

Syntax

Visual Basic (Declaration)
Public Property Referrer As String
C#
public string Referrer {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

ReturnSite Property
[image]
dotnetCART Namespace > Payment Class : ReturnSite Property

Sets or gets the ReturnSite.

Syntax

Visual Basic (Declaration)
Public Property ReturnSite As String
C#
public string ReturnSite {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

Server Property
[image]
dotnetCART Namespace > Payment Class : Server Property

Gets or sets the server URL. It is automatically set for the gateway/processr and usually should not be set.

Syntax

Visual Basic (Declaration)
Public Property Server As String
C#
public string Server {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

Setting Property
[image]
dotnetCART Namespace > Payment Class : Setting Property

Sets a special setting for some gateways.

Syntax

Visual Basic (Declaration)
Public Property Setting As String
C#
public string Setting {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

SettleInterval Property
[image]
dotnetCART Namespace > Payment Class : SettleInterval Property

Specifies the time period between two billings. The format is depneds on the gateway.

Syntax

Visual Basic (Declaration)
Public Property SettleInterval As Object
C#
public object SettleInterval {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

StartDate Property
[image]
dotnetCART Namespace > Payment Class : StartDate Property

Beginning date for the recurring billing cycle used to calculate when payments should be made. Default is now.

Syntax

Visual Basic (Declaration)
Public Property StartDate As Date
C#
public DateTime StartDate {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

Status Property
[image]
dotnetCART Namespace > Payment Class : Status Property

Gets or sets the charge status. It is the same value returns by Charge method.

Syntax

Visual Basic (Declaration)
Public Property Status As Integer
C#
public int Status {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

StoreNumber Property
[image]
dotnetCART Namespace > Payment Class : StoreNumber Property

Sets or gets the StoreNumber.

Syntax

Visual Basic (Declaration)
Public Property StoreNumber As Integer
C#
public int StoreNumber {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

TaxID Property
[image]
dotnetCART Namespace > Payment Class : TaxID Property

Sets or gets the TaxID.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property TaxID As String
C#
public string TaxID {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

TerminalID Property
[image]
dotnetCART Namespace > Payment Class : TerminalID Property

Sets or gets the TerminalID.

Syntax

Visual Basic (Declaration)
Public Property TerminalID As String
C#
public string TerminalID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

TerminalNumber Property
[image]
dotnetCART Namespace > Payment Class : TerminalNumber Property

Sets or gets the TerminalNumber.

Syntax

Visual Basic (Declaration)
Public Property TerminalNumber As Integer
C#
public int TerminalNumber {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

TestMode Property
[image]
dotnetCART Namespace > Payment Class : TestMode Property

Determines whether to use the test server or setting for the gateway/processor or not.

Syntax

Visual Basic (Declaration)
Public Property TestMode As Boolean
C#
public bool TestMode {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

Timeout Property
[image]
dotnetCART Namespace > Payment Class : Timeout Property

Gets or sets the time out for transaction response time. Defaults to 45 seconds.

Syntax

Visual Basic (Declaration)
Public Property Timeout As Integer
C#
public int Timeout {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

TimeZone Property
[image]
dotnetCART Namespace > Payment Class : TimeZone Property

Gets or sets a TimeZone. Defauts to PST.

Syntax

Visual Basic (Declaration)
Public Property TimeZone As TimeZone
C#
public TimeZone TimeZone {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

TransactionID Property
[image]
dotnetCART Namespace > Payment Class : TransactionID Property

Sets or gets the TransactionID.

Syntax

Visual Basic (Declaration)
Public Property TransactionID As String
C#
public string TransactionID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

TransactionKey Property
[image]
dotnetCART Namespace > Payment Class : TransactionKey Property

Sets or gets the TransactionKey.

Syntax

Visual Basic (Declaration)
Public Property TransactionKey As String
C#
public string TransactionKey {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

TransactionOrigin Property
[image]
dotnetCART Namespace > Payment Class : TransactionOrigin Property

Sets or gets the transaction origin.

Syntax

Visual Basic (Declaration)
Public Property TransactionOrigin As String
C#
public string TransactionOrigin {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

TransactionStatus Property
[image]
dotnetCART Namespace > Payment Class : TransactionStatus Property

Gets or sets a string transaction status which is saved to OrderTransactions table when invoking SaveTransactionDB

Syntax

Visual Basic (Declaration)
Public Property TransactionStatus As String
C#
public string TransactionStatus {get; set;}

Remarks

It defaults to "Charged". It is automatically set by the Charge method and usually should not be set.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

TransactionType Property
[image]
dotnetCART Namespace > Payment Class : TransactionType Property

Gets or sets the transaction type.

Syntax

Visual Basic (Declaration)
Public Property TransactionType As Object
C#
public object TransactionType {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

UserName Property
[image]
dotnetCART Namespace > Payment Class : UserName Property

Sets or gets the UserName.

Syntax

Visual Basic (Declaration)
Public Property UserName As String
C#
public string UserName {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

Price Class
See Also Members
[image]
dotnetCART Namespace : Price Class

Represents a Price object.

Syntax

Visual Basic (Declaration)
Public Class Price
C#
public class Price

Inheritance Hierarchy

System.Object
dotnetCART.Price

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Price Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

Price Class Members
See Also Properties
[image]
dotnetCART Namespace : Price Class

The following tables list the members exposed by Price.

Public Constructors

 | Name | Description
Public Constructor | Price Constructor | Overloaded. Initializes a new instance of the Price class.
Top

Public Properties

 | Name | Description
Public Property | Name | Gets or sets this price name.
Public Property | Value | Gets or sets this price value.
Top

See Also

Reference

Price Class
dotnetCART Namespace


%%PageItemTitle%%

Price Constructor
[image]
dotnetCART Namespace > Price Class : Price Constructor

Initializes a new instance of the Price class.

Overload List

Overload | Description
Price Constructor() | Initializes a new instance of the Price class.
Price Constructor(String,Generic Nullable) | Creates a new price with this name and value.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Price Class
Price Members


%%PageItemTitle%%

Price Constructor()
See Also
[image]
dotnetCART Namespace > Price Class > Price Constructor : Price Constructor()

Initializes a new instance of the Price class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Price()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Price Class
Price Members
Overload List


%%PageItemTitle%%

Price Constructor(String,Generic Nullable)
See Also
[image]
dotnetCART Namespace > Price Class > Price Constructor : Price Constructor(String,Generic Nullable)

priceName
A price name.
priceValue
A decimal value.
Creates a new price with this name and value.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal priceName As String, _
   ByVal priceValue As Nullable(Of Decimal) _
)
C#
public Price(
   string priceName,
   Nullable<decimal> priceValue
)

Parameters

priceName
A price name.
priceValue
A decimal value.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Price Class
Price Members
Overload List


%%PageItemTitle%% $$Properties$$

Price Class Properties
[image]
dotnetCART Namespace : Price Class

For a list of all members of this type, see Price members.

Public Properties

 | Name | Description
Public Property | Name | Gets or sets this price name.
Public Property | Value | Gets or sets this price value.
Top

See Also

Reference

Price Class
dotnetCART Namespace


%%PageItemTitle%%

Name Property
[image]
dotnetCART Namespace > Price Class : Name Property

Gets or sets this price name.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Price Class
Price Members


%%PageItemTitle%%

Value Property
[image]
dotnetCART Namespace > Price Class : Value Property

Gets or sets this price value.

Syntax

Visual Basic (Declaration)
Public Property Value As Nullable(Of Decimal)
C#
public Nullable<decimal> Value {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Price Class
Price Members


%%PageItemTitle%%

Prices Class
See Also Members
[image]
dotnetCART Namespace : Prices Class

A collection of Price objects.

Syntax

Visual Basic (Declaration)
Public Class Prices
   Inherits ListBase(Of Price)
C#
public class Prices : ListBase<Price>

Inheritance Hierarchy

System.Object
System.Collections.Generic.List<Price>
dotnetCART.ListBase<Price>
dotnetCART.Prices

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Prices Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

Prices Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : Prices Class

The following tables list the members exposed by Prices.

Public Constructors

 | Name | Description
Public Constructor | Prices Constructor | Initializes a new instance of the Prices.
Top

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from dotnetCART.ListBase<Price>)
Public Property | Count | Gets the number of elements actually contained in the collection. (Inherited from dotnetCART.ListBase<Price>)
Public Property | Error | Returns an object with the error information. (Inherited from dotnetCART.ListBase<Price>)
Public Property | Item | Overloaded. Return the price value for this price name.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds an object to the end of the collection. (Inherited from dotnetCART.ListBase<Price>)
Public Method | AddRange | Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetCART.ListBase<Price>)
Public Method | AsReadOnly | Returns a read-only IList wrapper for the current collection. (Inherited from dotnetCART.ListBase<Price>)
Public Method | BinarySearch | Overloaded. (Inherited from dotnetCART.ListBase<Price>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetCART.ListBase<Price>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetCART.ListBase<Price>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<Price>)
Public Method | CopyTo | Overloaded. (Inherited from dotnetCART.ListBase<Price>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from dotnetCART.ListBase<Price>)
Public Method | GetValue | Return the price value for this price index.
Public Method | IndexOf | Overloaded. (Inherited from dotnetCART.ListBase<Price>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetCART.ListBase<Price>)
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from dotnetCART.ListBase<Price>)
Public Method | IsExist | Determines whether the price with this name exists in the collection or not.
Public Method | LastIndexOf | Overloaded. (Inherited from dotnetCART.ListBase<Price>)
Public Method | LoadDB | Overloaded. Loads all the items from its associated table. (Inherited from dotnetCART.ListBase<Price>)
Public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from dotnetCART.ListBase<Price>)
Public Method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from dotnetCART.ListBase<Price>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetCART.ListBase<Price>)
Public Method | RemoveRange | Removes a range of elements from the List. (Inherited from dotnetCART.ListBase<Price>)
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<Price>)
Public Method | SetValue | Sets a new value or creates a new price with this value and returns the old value if exist.
Top

See Also

Reference

Prices Class
dotnetCART Namespace


%%PageItemTitle%%

Prices Constructor
[image]
dotnetCART Namespace > Prices Class : Prices Constructor

Initializes a new instance of the Prices.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Prices()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Prices Class
Prices Members


%%PageItemTitle%% $$Methods$$

Prices Class Methods
[image]
dotnetCART Namespace : Prices Class

For a list of all members of this type, see Prices members.

Public Methods

 | Name | Description
Public Method | Add | Adds an object to the end of the collection. (Inherited from dotnetCART.ListBase<Price>)
Public Method | AddRange | Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetCART.ListBase<Price>)
Public Method | AsReadOnly | Returns a read-only IList wrapper for the current collection. (Inherited from dotnetCART.ListBase<Price>)
Public Method | BinarySearch | Overloaded. (Inherited from dotnetCART.ListBase<Price>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetCART.ListBase<Price>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetCART.ListBase<Price>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<Price>)
Public Method | CopyTo | Overloaded. (Inherited from dotnetCART.ListBase<Price>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from dotnetCART.ListBase<Price>)
Public Method | GetValue | Return the price value for this price index.
Public Method | IndexOf | Overloaded. (Inherited from dotnetCART.ListBase<Price>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetCART.ListBase<Price>)
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from dotnetCART.ListBase<Price>)
Public Method | IsExist | Determines whether the price with this name exists in the collection or not.
Public Method | LastIndexOf | Overloaded. (Inherited from dotnetCART.ListBase<Price>)
Public Method | LoadDB | Overloaded. Loads all the items from its associated table. (Inherited from dotnetCART.ListBase<Price>)
Public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from dotnetCART.ListBase<Price>)
Public Method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from dotnetCART.ListBase<Price>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetCART.ListBase<Price>)
Public Method | RemoveRange | Removes a range of elements from the List. (Inherited from dotnetCART.ListBase<Price>)
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<Price>)
Public Method | SetValue | Sets a new value or creates a new price with this value and returns the old value if exist.
Top

See Also

Reference

Prices Class
dotnetCART Namespace


%%PageItemTitle%%

GetValue Method
[image]
dotnetCART Namespace > Prices Class : GetValue Method

index
A zero base index.
Return the price value for this price index.

Syntax

Visual Basic (Declaration)
Public Function GetValue( _
   ByVal index As Integer _
) As Nullable(Of Decimal)
C#
public Nullable<decimal> GetValue(
   int index
)

Parameters

index
A zero base index.

Return Value

A decimal value.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Prices Class
Prices Members


%%PageItemTitle%%

IsExist Method
[image]
dotnetCART Namespace > Prices Class : IsExist Method

name
A price name.
Determines whether the price with this name exists in the collection or not.

Syntax

Visual Basic (Declaration)
Public Function IsExist( _
   ByVal name As String _
) As Boolean
C#
public bool IsExist(
   string name
)

Parameters

name
A price name.

Return Value

True or false.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Prices Class
Prices Members


%%PageItemTitle%%

SetValue Method
[image]
dotnetCART Namespace > Prices Class : SetValue Method

name
A price name.
value
A decimal value.
Sets a new value or creates a new price with this value and returns the old value if exist.

Syntax

Visual Basic (Declaration)
Public Function SetValue( _
   ByVal name As String, _
   ByVal value As Nullable(Of Decimal) _
) As Nullable(Of Decimal)
C#
public Nullable<decimal> SetValue(
   string name,
   Nullable<decimal> value
)

Parameters

name
A price name.
value
A decimal value.

Return Value

A decimal value.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Prices Class
Prices Members


%%PageItemTitle%% $$Properties$$

Prices Class Properties
[image]
dotnetCART Namespace : Prices Class

For a list of all members of this type, see Prices members.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from dotnetCART.ListBase<Price>)
Public Property | Count | Gets the number of elements actually contained in the collection. (Inherited from dotnetCART.ListBase<Price>)
Public Property | Error | Returns an object with the error information. (Inherited from dotnetCART.ListBase<Price>)
Public Property | Item | Overloaded. Return the price value for this price name.
Top

See Also

Reference

Prices Class
dotnetCART Namespace


%%PageItemTitle%%

Item Property
[image]
dotnetCART Namespace > Prices Class : Item Property

Return the price value for this price name.

Overload List

Overload | Description
Item(String) | Return the price value for this price name.
Item(Int32) | Gets or sets the element at the specified index. (Inherited from dotnetCART.ListBase<Price>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Prices Class
Prices Members


%%PageItemTitle%%

Item(String) Property
[image]
dotnetCART Namespace > Prices Class > Item Property : Item(String) Property

name
A price name.
Return the price value for this price name.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal name As String _
) As Nullable(Of Decimal)
C#
public Nullable<decimal> Item(
   string name
) {get;}

Parameters

name
A price name.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Prices Class
Prices Members
Overload List


%%PageItemTitle%%

Rate Class
See Also Members
[image]
dotnetCART Namespace : Rate Class

Represents a shipping rate object.

Syntax

Visual Basic (Declaration)
Public Class Rate
C#
public class Rate

Inheritance Hierarchy

System.Object
dotnetCART.Rate

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Rate Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

Rate Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : Rate Class

The following tables list the members exposed by Rate.

Public Constructors

 | Name | Description
Public Constructor | Rate Constructor | Initializes a new instance of the Rate.
Top

Public Properties

 | Name | Description
Public Property | Charge | The charge amount of the shipment.
Public Property | Company | The name of the shipping company.
Public Property | ID | The id of the shipment.
Public Property | Name | The name of the shipping type. This value must be unique for a given company.
Public Property | ShipTime | A time commitment or comment string set for the custom shipping rate.
Top

Public Methods

 | Name | Description
Public Method | Clone |
Top

See Also

Reference

Rate Class
dotnetCART Namespace


%%PageItemTitle%%

Rate Constructor
[image]
dotnetCART Namespace > Rate Class : Rate Constructor

Initializes a new instance of the Rate.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Rate()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Rate Class
Rate Members


%%PageItemTitle%% $$Methods$$

Rate Class Methods
[image]
dotnetCART Namespace : Rate Class

For a list of all members of this type, see Rate members.

Public Methods

 | Name | Description
Public Method | Clone |
Top

See Also

Reference

Rate Class
dotnetCART Namespace


%%PageItemTitle%%

Clone Method
[image]
dotnetCART Namespace > Rate Class : Clone Method

Syntax

Visual Basic (Declaration)
Public Function Clone() As Rate
C#
public Rate Clone()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Rate Class
Rate Members


%%PageItemTitle%% $$Properties$$

Rate Class Properties
[image]
dotnetCART Namespace : Rate Class

For a list of all members of this type, see Rate members.

Public Properties

 | Name | Description
Public Property | Charge | The charge amount of the shipment.
Public Property | Company | The name of the shipping company.
Public Property | ID | The id of the shipment.
Public Property | Name | The name of the shipping type. This value must be unique for a given company.
Public Property | ShipTime | A time commitment or comment string set for the custom shipping rate.
Top

See Also

Reference

Rate Class
dotnetCART Namespace


%%PageItemTitle%%

Charge Property
[image]
dotnetCART Namespace > Rate Class : Charge Property

The charge amount of the shipment.

Syntax

Visual Basic (Declaration)
Public Property Charge As String
C#
public string Charge {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Rate Class
Rate Members


%%PageItemTitle%%

Company Property
[image]
dotnetCART Namespace > Rate Class : Company Property

The name of the shipping company.

Syntax

Visual Basic (Declaration)
Public Property Company As String
C#
public string Company {get; set;}

Remarks

This value must be unique and typically would not be set to any of the predefined real-time company names. If you do use a predefined company name, it will check the custom settings, for a match on country / state / province before running the real-time rating. This new feature allows you to enable multiple realtime returns for specific locations only. For example if you ship USPS to Canada, DHL international, and FedEx within the US you can have only those processors return based on destination address.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Rate Class
Rate Members


%%PageItemTitle%%

ID Property
[image]
dotnetCART Namespace > Rate Class : ID Property

The id of the shipment.

Syntax

Visual Basic (Declaration)
Public Property ID As String
C#
public string ID {get; set;}

Remarks

This value only populates for EasyPost.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Rate Class
Rate Members


%%PageItemTitle%%

Name Property
[image]
dotnetCART Namespace > Rate Class : Name Property

The name of the shipping type. This value must be unique for a given company.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Rate Class
Rate Members


%%PageItemTitle%%

ShipTime Property
[image]
dotnetCART Namespace > Rate Class : ShipTime Property

A time commitment or comment string set for the custom shipping rate.

Syntax

Visual Basic (Declaration)
Public Property ShipTime As String
C#
public string ShipTime {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Rate Class
Rate Members


%%PageItemTitle%%

Referrer Class
See Also Members
[image]
dotnetCART Namespace : Referrer Class

Defines a Referrer object.

Object Model

Syntax

Visual Basic (Declaration)
Public Class Referrer
   Inherits DbTableCart(Of Referrer, Long)
C#
public class Referrer : DbTableCart<Referrer, long>

Inheritance Hierarchy

System.Object
dotnetDATA.DbTable<Int64>
dotnetDATA.DbTable<Referrer, Int64>
dotnetCART.DbTableCart<Referrer, Int64>
dotnetCART.Referrer

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrer Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

Referrer Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : Referrer Class

The following tables list the members exposed by Referrer.

Public Constructors

 | Name | Description
Public Constructor | Referrer Constructor | Initializes a new instance of the Referrer class.
Top

Public Properties

 | Name | Description
Public Property | CartID | The CartID of the shopping cart ID using this link.
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<Referrer, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<Referrer, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<Referrer, Int64>)
Public Property | Date | Gets or sets the date/time for this referreral.
Public Property | Domain | Gets or sets the domain for the referrer link.
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<Referrer, Int64>)
Public Property | ID | Overridden. The autonumber ID populated from the database.
Public Property | Querystring | Gets or sets the Inbound guery for the referrer link.
Public Property | URL | Gets or sets the complete URL for this referreral.
Top

Public Methods

 | Name | Description
Public Method | Clear | Initializes all the properties without recreating the object. (Inherited from dotnetCART.DbTableCart<Referrer, Int64>)
Public Method | DeleteDB | Overloaded. Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<Referrer, Int64>)
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<Referrer, Int64>)
Public Method | LoadDB | Overloaded. Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<Referrer, Int64>)
Public Method | SaveDB | Overloaded. Overridden. Saves this object to the Referrers table. This method automatically gets the customer's referrer URL from the remote site, parses out the domain and the adCampaign's keyword from querystring (if present). For the CartID property, it first tries to get the CartID from dotnetCART cookie using cart.LoadCookieDB() method and if it doesn't exist, it will create a new one. When a new CartID is created, it is saved to Cart table using Cart.SaveCookieDB and synchronized between the current cart string and referrer. If the CartID and URL properties have been set explicitly, it will only save to the Referrers table and take no further actions.
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<Referrer, Int64>)
Top

See Also

Reference

Referrer Class
dotnetCART Namespace


%%PageItemTitle%%

Referrer Constructor
[image]
dotnetCART Namespace > Referrer Class : Referrer Constructor

Initializes a new instance of the Referrer class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Referrer()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrer Class
Referrer Members


%%PageItemTitle%% $$Methods$$

Referrer Class Methods
[image]
dotnetCART Namespace : Referrer Class

For a list of all members of this type, see Referrer members.

Public Methods

 | Name | Description
Public Method | Clear | Initializes all the properties without recreating the object. (Inherited from dotnetCART.DbTableCart<Referrer, Int64>)
Public Method | DeleteDB | Overloaded. Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<Referrer, Int64>)
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<Referrer, Int64>)
Public Method | LoadDB | Overloaded. Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<Referrer, Int64>)
Public Method | SaveDB | Overloaded. Overridden. Saves this object to the Referrers table. This method automatically gets the customer's referrer URL from the remote site, parses out the domain and the adCampaign's keyword from querystring (if present). For the CartID property, it first tries to get the CartID from dotnetCART cookie using cart.LoadCookieDB() method and if it doesn't exist, it will create a new one. When a new CartID is created, it is saved to Cart table using Cart.SaveCookieDB and synchronized between the current cart string and referrer. If the CartID and URL properties have been set explicitly, it will only save to the Referrers table and take no further actions.
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<Referrer, Int64>)
Top

See Also

Reference

Referrer Class
dotnetCART Namespace


%%PageItemTitle%%

SaveDB Method
[image]
dotnetCART Namespace > Referrer Class : SaveDB Method

Saves this object to the Referrers table. This method automatically gets the customer's referrer URL from the remote site, parses out the domain and the adCampaign's keyword from querystring (if present). For the CartID property, it first tries to get the CartID from dotnetCART cookie using cart.LoadCookieDB() method and if it doesn't exist, it will create a new one. When a new CartID is created, it is saved to Cart table using Cart.SaveCookieDB and synchronized between the current cart string and referrer. If the CartID and URL properties have been set explicitly, it will only save to the Referrers table and take no further actions.

Overload List

Overload | Description
SaveDB() | Saves this object to the Referrers table. This method automatically gets the customer's referrer URL from the remote site, parses out the domain and the adCampaign's keyword from querystring (if present). For the CartID property, it first tries to get the CartID from dotnetCART cookie using cart.LoadCookieDB() method and if it doesn't exist, it will create a new one. When a new CartID is created, it is saved to Cart table using Cart.SaveCookieDB and synchronized between the current cart string and referrer. If the CartID and URL properties have been set explicitly, it will only save to the Referrers table and take no further actions.
SaveDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrer Class
Referrer Members


%%PageItemTitle%%

SaveDB() Method
[image]
dotnetCART Namespace > Referrer Class > SaveDB Method : SaveDB() Method

Saves this object to the Referrers table. This method automatically gets the customer's referrer URL from the remote site, parses out the domain and the adCampaign's keyword from querystring (if present). For the CartID property, it first tries to get the CartID from dotnetCART cookie using cart.LoadCookieDB() method and if it doesn't exist, it will create a new one. When a new CartID is created, it is saved to Cart table using Cart.SaveCookieDB and synchronized between the current cart string and referrer. If the CartID and URL properties have been set explicitly, it will only save to the Referrers table and take no further actions.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function SaveDB() As Integer
C#
public override int SaveDB()

Remarks

SaveOrderDB method saves the referrer querystring and domain for the customer by loading the last link from Referrers table. This data is used in Reports->Referrer to show which links have been derived the most sales.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrer Class
Referrer Members
Overload List


%%PageItemTitle%% $$Properties$$

Referrer Class Properties
[image]
dotnetCART Namespace : Referrer Class

For a list of all members of this type, see Referrer members.

Public Properties

 | Name | Description
Public Property | CartID | The CartID of the shopping cart ID using this link.
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<Referrer, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<Referrer, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<Referrer, Int64>)
Public Property | Date | Gets or sets the date/time for this referreral.
Public Property | Domain | Gets or sets the domain for the referrer link.
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<Referrer, Int64>)
Public Property | ID | Overridden. The autonumber ID populated from the database.
Public Property | Querystring | Gets or sets the Inbound guery for the referrer link.
Public Property | URL | Gets or sets the complete URL for this referreral.
Top

See Also

Reference

Referrer Class
dotnetCART Namespace


%%PageItemTitle%%

CartID Property
[image]
dotnetCART Namespace > Referrer Class : CartID Property

The CartID of the shopping cart ID using this link.

Syntax

Visual Basic (Declaration)
Public Property CartID As String
C#
public string CartID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrer Class
Referrer Members


%%PageItemTitle%%

Date Property
[image]
dotnetCART Namespace > Referrer Class : Date Property

Gets or sets the date/time for this referreral.

Syntax

Visual Basic (Declaration)
Public Property Date As Date
C#
public DateTime Date {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrer Class
Referrer Members


%%PageItemTitle%%

Domain Property
[image]
dotnetCART Namespace > Referrer Class : Domain Property

Gets or sets the domain for the referrer link.

Syntax

Visual Basic (Declaration)
Public Property Domain As String
C#
public string Domain {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrer Class
Referrer Members


%%PageItemTitle%%

ID Property
[image]
dotnetCART Namespace > Referrer Class : ID Property

The autonumber ID populated from the database.

Syntax

Visual Basic (Declaration)
Public Overrides Property ID As Long
C#
public override long ID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrer Class
Referrer Members


%%PageItemTitle%%

Querystring Property
[image]
dotnetCART Namespace > Referrer Class : Querystring Property

Gets or sets the Inbound guery for the referrer link.

Syntax

Visual Basic (Declaration)
Public Property Querystring As String
C#
public string Querystring {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrer Class
Referrer Members


%%PageItemTitle%%

URL Property
[image]
dotnetCART Namespace > Referrer Class : URL Property

Gets or sets the complete URL for this referreral.

Syntax

Visual Basic (Declaration)
Public Property URL As String
C#
public string URL {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrer Class
Referrer Members


%%PageItemTitle%%

Referrers Class
See Also Members
[image]
dotnetCART Namespace : Referrers Class

A collection of Referrer objects.

Object Model

Syntax

Visual Basic (Declaration)
Public Class Referrers
   Inherits ListBase(Of Referrer)
C#
public class Referrers : ListBase<Referrer>

Inheritance Hierarchy

System.Object
System.Collections.Generic.List<Referrer>
dotnetCART.ListBase<Referrer>
dotnetCART.Referrers

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrers Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

Referrers Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : Referrers Class

The following tables list the members exposed by Referrers.

Public Constructors

 | Name | Description
Public Constructor | Referrers Constructor | Initializes a new instance of the Referrers.
Top

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from dotnetCART.ListBase<Referrer>)
Public Property | Count | Gets the number of elements actually contained in the collection. (Inherited from dotnetCART.ListBase<Referrer>)
Public Property | Error | Returns an object with the error information. (Inherited from dotnetCART.ListBase<Referrer>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from dotnetCART.ListBase<Referrer>)
Top

Public Methods

 | Name | Description
Public Method | Add | Adds an object to the end of the collection. (Inherited from dotnetCART.ListBase<Referrer>)
Public Method | AddRange | Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetCART.ListBase<Referrer>)
Public Method | AsReadOnly | Returns a read-only IList wrapper for the current collection. (Inherited from dotnetCART.ListBase<Referrer>)
Public Method | BinarySearch | Overloaded. (Inherited from dotnetCART.ListBase<Referrer>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetCART.ListBase<Referrer>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetCART.ListBase<Referrer>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<Referrer>)
Public Method | CopyTo | Overloaded. (Inherited from dotnetCART.ListBase<Referrer>)
Public Method | GetCountDB | Overloaded. Gets the total number of items in the Referrers table.
Public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from dotnetCART.ListBase<Referrer>)
Public Method | IndexOf | Overloaded. (Inherited from dotnetCART.ListBase<Referrer>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetCART.ListBase<Referrer>)
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from dotnetCART.ListBase<Referrer>)
Public Method | LastIndexOf | Overloaded. (Inherited from dotnetCART.ListBase<Referrer>)
Public Method | LoadDB | Overloaded. Overridden. Loads all the items based on the parameters from Referrers table.
Public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from dotnetCART.ListBase<Referrer>)
Public Method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from dotnetCART.ListBase<Referrer>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetCART.ListBase<Referrer>)
Public Method | RemoveRange | Removes a range of elements from the List. (Inherited from dotnetCART.ListBase<Referrer>)
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<Referrer>)
Top

See Also

Reference

Referrers Class
dotnetCART Namespace


%%PageItemTitle%%

Referrers Constructor
[image]
dotnetCART Namespace > Referrers Class : Referrers Constructor

Initializes a new instance of the Referrers.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Referrers()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrers Class
Referrers Members


%%PageItemTitle%% $$Methods$$

Referrers Class Methods
[image]
dotnetCART Namespace : Referrers Class

For a list of all members of this type, see Referrers members.

Public Methods

 | Name | Description
Public Method | Add | Adds an object to the end of the collection. (Inherited from dotnetCART.ListBase<Referrer>)
Public Method | AddRange | Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetCART.ListBase<Referrer>)
Public Method | AsReadOnly | Returns a read-only IList wrapper for the current collection. (Inherited from dotnetCART.ListBase<Referrer>)
Public Method | BinarySearch | Overloaded. (Inherited from dotnetCART.ListBase<Referrer>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetCART.ListBase<Referrer>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetCART.ListBase<Referrer>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<Referrer>)
Public Method | CopyTo | Overloaded. (Inherited from dotnetCART.ListBase<Referrer>)
Public Method | GetCountDB | Overloaded. Gets the total number of items in the Referrers table.
Public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from dotnetCART.ListBase<Referrer>)
Public Method | IndexOf | Overloaded. (Inherited from dotnetCART.ListBase<Referrer>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetCART.ListBase<Referrer>)
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from dotnetCART.ListBase<Referrer>)
Public Method | LastIndexOf | Overloaded. (Inherited from dotnetCART.ListBase<Referrer>)
Public Method | LoadDB | Overloaded. Overridden. Loads all the items based on the parameters from Referrers table.
Public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from dotnetCART.ListBase<Referrer>)
Public Method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from dotnetCART.ListBase<Referrer>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetCART.ListBase<Referrer>)
Public Method | RemoveRange | Removes a range of elements from the List. (Inherited from dotnetCART.ListBase<Referrer>)
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<Referrer>)
Top

See Also

Reference

Referrers Class
dotnetCART Namespace


%%PageItemTitle%%

GetCountDB Method
[image]
dotnetCART Namespace > Referrers Class : GetCountDB Method

Gets the total number of items in the Referrers table.

Overload List

Overload | Description
GetCountDB() | Gets the total number of items in the Referrers table.
GetCountDB(Where) | Gets the total number of items in the Referrers table.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrers Class
Referrers Members


%%PageItemTitle%%

GetCountDB() Method
[image]
dotnetCART Namespace > Referrers Class > GetCountDB Method : GetCountDB() Method

Gets the total number of items in the Referrers table.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCountDB() As Integer
C#
public int GetCountDB()

Return Value

Returns the number of elements in the Referrers table.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrers Class
Referrers Members
Overload List


%%PageItemTitle%%

GetCountDB(Where) Method
[image]
dotnetCART Namespace > Referrers Class > GetCountDB Method : GetCountDB(Where) Method

whereClause
The where clause to filter the items.
Gets the total number of items in the Referrers table.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCountDB( _
   ByVal whereClause As Where _
) As Integer
C#
public int GetCountDB(
   Where whereClause
)

Parameters

whereClause
The where clause to filter the items.

Return Value

Returns the number of elements in the Referrers table.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrers Class
Referrers Members
Overload List


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > Referrers Class : LoadDB Method

Loads all the items based on the parameters from Referrers table.

Overload List

Overload | Description
LoadDB(Where,Int32,Int32,String,OrderDirection) | Loads all the items based on the parameters from Referrers table.
LoadDB() | Loads all the items from its associated table. (Inherited from dotnetCART.ListBase<Referrer>)
LoadDB(Where) | Loads all the items from its associated table based on the where clause. (Inherited from dotnetCART.ListBase<Referrer>)
LoadDB(Int32,Int32) | Loads the count number of elements from start value. (Inherited from dotnetCART.ListBase<Referrer>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrers Class
Referrers Members


%%PageItemTitle%%

LoadDB(Where,Int32,Int32,String,OrderDirection) Method
[image]
dotnetCART Namespace > Referrers Class > LoadDB Method : LoadDB(Where,Int32,Int32,String,OrderDirection) Method

whereClause
The where clause to filter the items.
start
The start page which starts from 0.
count
The number of items in the page.
orderBy
The order of the loaded items.
orderDirection
The order direction of the loaded items. Defaults is Asc.
Loads all the items based on the parameters from Referrers table.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function LoadDB( _
   ByVal whereClause As Where, _
   ByVal start As Integer, _
   ByVal count As Integer, _
   ByVal orderBy As String, _
   ByVal orderDirection As OrderDirection _
) As Integer
C#
public override int LoadDB(
   Where whereClause,
   int start,
   int count,
   string orderBy,
   OrderDirection orderDirection
)

Parameters

whereClause
The where clause to filter the items.
start
The start page which starts from 0.
count
The number of items in the page.
orderBy
The order of the loaded items.
orderDirection
The order direction of the loaded items. Defaults is Asc.

Return Value

The total number of items have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrers Class
Referrers Members
Overload List


%%PageItemTitle%%

Review Class
See Also Members
[image]
dotnetCART Namespace : Review Class

Represents a Review object.

Object Model

Syntax

Visual Basic (Declaration)
Public Class Review
   Inherits DbTableCart(Of Review, Long)
C#
public class Review : DbTableCart<Review, long>

Inheritance Hierarchy

System.Object
dotnetDATA.DbTable<Int64>
dotnetDATA.DbTable<Review, Int64>
dotnetCART.DbTableCart<Review, Int64>
dotnetCART.Review

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Review Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

Review Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : Review Class

The following tables list the members exposed by Review.

Public Constructors

 | Name | Description
Public Constructor | Review Constructor | Initializes a new instance of the Review class.
Top

Public Properties

 | Name | Description
Public Property | Content | The customer's review for the item.
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<Review, Int64>)
Public Property | CustomerID | The ID of the customer who wrote this review.
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<Review, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<Review, Int64>)
Public Property | Date | The date when this review has been written.
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<Review, Int64>)
Public Property | HelpfulCount | The total people found this review helpful.
Public Property | ID | Overridden. The autonumber ID populated from the database.
Public Property | ItemID | The ItemID of the Item this review is about it.
Public Property | Rating | The customer's rating for the item.
Public Property | Status | The status of this review: New, Public, Archive,...
Public Property | Title | A title for this review.
Public Property | Views | The total people viewed this review.
Top

Public Methods

 | Name | Description
Public Method | Clear | Initializes all the properties without recreating the object. (Inherited from dotnetCART.DbTableCart<Review, Int64>)
Public Method | DeleteDB | Overloaded. Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<Review, Int64>)
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<Review, Int64>)
Public Method | LoadDB | Overloaded. Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<Review, Int64>)
Public Method | SaveDB | Overloaded. Inserts or updates this object into the database. (Inherited from dotnetCART.DbTableCart<Review, Int64>)
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<Review, Int64>)
Public Method | UpdateDB | Update the review with the specified ItemID and CustomerID
Top

See Also

Reference

Review Class
dotnetCART Namespace


%%PageItemTitle%%

Review Constructor
[image]
dotnetCART Namespace > Review Class : Review Constructor

Initializes a new instance of the Review class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Review()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Review Class
Review Members


%%PageItemTitle%% $$Methods$$

Review Class Methods
[image]
dotnetCART Namespace : Review Class

For a list of all members of this type, see Review members.

Public Methods

 | Name | Description
Public Method | Clear | Initializes all the properties without recreating the object. (Inherited from dotnetCART.DbTableCart<Review, Int64>)
Public Method | DeleteDB | Overloaded. Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<Review, Int64>)
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<Review, Int64>)
Public Method | LoadDB | Overloaded. Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<Review, Int64>)
Public Method | SaveDB | Overloaded. Inserts or updates this object into the database. (Inherited from dotnetCART.DbTableCart<Review, Int64>)
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<Review, Int64>)
Public Method | UpdateDB | Update the review with the specified ItemID and CustomerID
Top

See Also

Reference

Review Class
dotnetCART Namespace


%%PageItemTitle%%

UpdateDB Method
[image]
dotnetCART Namespace > Review Class : UpdateDB Method

Update the review with the specified ItemID and CustomerID

Syntax

Visual Basic (Declaration)
Public Function UpdateDB() As Integer
C#
public int UpdateDB()

Return Value

Returns 1 for the success, and -1 if failed. For the reason of fail, check the Error property.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Review Class
Review Members


%%PageItemTitle%% $$Properties$$

Review Class Properties
[image]
dotnetCART Namespace : Review Class

For a list of all members of this type, see Review members.

Public Properties

 | Name | Description
Public Property | Content | The customer's review for the item.
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<Review, Int64>)
Public Property | CustomerID | The ID of the customer who wrote this review.
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<Review, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<Review, Int64>)
Public Property | Date | The date when this review has been written.
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<Review, Int64>)
Public Property | HelpfulCount | The total people found this review helpful.
Public Property | ID | Overridden. The autonumber ID populated from the database.
Public Property | ItemID | The ItemID of the Item this review is about it.
Public Property | Rating | The customer's rating for the item.
Public Property | Status | The status of this review: New, Public, Archive,...
Public Property | Title | A title for this review.
Public Property | Views | The total people viewed this review.
Top

See Also

Reference

Review Class
dotnetCART Namespace


%%PageItemTitle%%

Content Property
[image]
dotnetCART Namespace > Review Class : Content Property

The customer's review for the item.

Syntax

Visual Basic (Declaration)
Public Property Content As String
C#
public string Content {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Review Class
Review Members


%%PageItemTitle%%

CustomerID Property
[image]
dotnetCART Namespace > Review Class : CustomerID Property

The ID of the customer who wrote this review.

Syntax

Visual Basic (Declaration)
Public Property CustomerID As Long
C#
public long CustomerID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Review Class
Review Members


%%PageItemTitle%%

Date Property
[image]
dotnetCART Namespace > Review Class : Date Property

The date when this review has been written.

Syntax

Visual Basic (Declaration)
Public Property Date As Date
C#
public DateTime Date {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Review Class
Review Members


%%PageItemTitle%%

HelpfulCount Property
[image]
dotnetCART Namespace > Review Class : HelpfulCount Property

The total people found this review helpful.

Syntax

Visual Basic (Declaration)
Public Property HelpfulCount As Integer
C#
public int HelpfulCount {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Review Class
Review Members


%%PageItemTitle%%

ID Property
[image]
dotnetCART Namespace > Review Class : ID Property

The autonumber ID populated from the database.

Syntax

Visual Basic (Declaration)
Public Overrides Property ID As Long
C#
public override long ID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Review Class
Review Members


%%PageItemTitle%%

ItemID Property
[image]
dotnetCART Namespace > Review Class : ItemID Property

The ItemID of the Item this review is about it.

Syntax

Visual Basic (Declaration)
Public Property ItemID As String
C#
public string ItemID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Review Class
Review Members


%%PageItemTitle%%

Rating Property
[image]
dotnetCART Namespace > Review Class : Rating Property

The customer's rating for the item.

Syntax

Visual Basic (Declaration)
Public Property Rating As Integer
C#
public int Rating {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Review Class
Review Members


%%PageItemTitle%%

Status Property
[image]
dotnetCART Namespace > Review Class : Status Property

The status of this review: New, Public, Archive,...

Syntax

Visual Basic (Declaration)
Public Property Status As String
C#
public string Status {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Review Class
Review Members


%%PageItemTitle%%

Title Property
[image]
dotnetCART Namespace > Review Class : Title Property

A title for this review.

Syntax

Visual Basic (Declaration)
Public Property Title As String
C#
public string Title {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Review Class
Review Members


%%PageItemTitle%%

Views Property
[image]
dotnetCART Namespace > Review Class : Views Property

The total people viewed this review.

Syntax

Visual Basic (Declaration)
Public Property Views As Integer
C#
public int Views {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Review Class
Review Members


%%PageItemTitle%%

Reviews Class
See Also Members
[image]
dotnetCART Namespace : Reviews Class

A collection of Review objects.

Object Model

Syntax

Visual Basic (Declaration)
Public Class Reviews
   Inherits ListBase(Of Review)
C#
public class Reviews : ListBase<Review>

Inheritance Hierarchy

System.Object
System.Collections.Generic.List<Review>
dotnetCART.ListBase<Review>
dotnetCART.Reviews

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Reviews Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

Reviews Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : Reviews Class

The following tables list the members exposed by Reviews.

Public Constructors

 | Name | Description
Public Constructor | Reviews Constructor | Initializes a new instance of the
Top

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from dotnetCART.ListBase<Review>)
Public Property | Count | Gets the number of elements actually contained in the collection. (Inherited from dotnetCART.ListBase<Review>)
Public Property | Error | Returns an object with the error information. (Inherited from dotnetCART.ListBase<Review>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from dotnetCART.ListBase<Review>)
Top

Public Methods

 | Name | Description
Public Method | Add | Adds an object to the end of the collection. (Inherited from dotnetCART.ListBase<Review>)
Public Method | AddRange | Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetCART.ListBase<Review>)
Public Method | AsReadOnly | Returns a read-only IList wrapper for the current collection. (Inherited from dotnetCART.ListBase<Review>)
Public Method | BinarySearch | Overloaded. (Inherited from dotnetCART.ListBase<Review>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetCART.ListBase<Review>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetCART.ListBase<Review>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<Review>)
Public Method | CopyTo | Overloaded. (Inherited from dotnetCART.ListBase<Review>)
Public Method | GetAverage |
Public Method | GetCountDB | Overloaded. Gets the total number of reviews in the Reviews table.
Public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from dotnetCART.ListBase<Review>)
Public Method | IndexOf | Overloaded. (Inherited from dotnetCART.ListBase<Review>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetCART.ListBase<Review>)
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from dotnetCART.ListBase<Review>)
Public Method | LastIndexOf | Overloaded. (Inherited from dotnetCART.ListBase<Review>)
Public Method | LoadDB | Overloaded. Loads all the reviews with specified parameters.
Public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from dotnetCART.ListBase<Review>)
Public Method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from dotnetCART.ListBase<Review>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetCART.ListBase<Review>)
Public Method | RemoveRange | Removes a range of elements from the List. (Inherited from dotnetCART.ListBase<Review>)
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<Review>)
Top

See Also

Reference

Reviews Class
dotnetCART Namespace


%%PageItemTitle%%

Reviews Constructor
[image]
dotnetCART Namespace > Reviews Class : Reviews Constructor

Initializes a new instance of the

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Reviews()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Reviews Class
Reviews Members


%%PageItemTitle%% $$Methods$$

Reviews Class Methods
[image]
dotnetCART Namespace : Reviews Class

For a list of all members of this type, see Reviews members.

Public Methods

 | Name | Description
Public Method | Add | Adds an object to the end of the collection. (Inherited from dotnetCART.ListBase<Review>)
Public Method | AddRange | Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetCART.ListBase<Review>)
Public Method | AsReadOnly | Returns a read-only IList wrapper for the current collection. (Inherited from dotnetCART.ListBase<Review>)
Public Method | BinarySearch | Overloaded. (Inherited from dotnetCART.ListBase<Review>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetCART.ListBase<Review>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetCART.ListBase<Review>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<Review>)
Public Method | CopyTo | Overloaded. (Inherited from dotnetCART.ListBase<Review>)
Public Method | GetAverage |
Public Method | GetCountDB | Overloaded. Gets the total number of reviews in the Reviews table.
Public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from dotnetCART.ListBase<Review>)
Public Method | IndexOf | Overloaded. (Inherited from dotnetCART.ListBase<Review>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetCART.ListBase<Review>)
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from dotnetCART.ListBase<Review>)
Public Method | LastIndexOf | Overloaded. (Inherited from dotnetCART.ListBase<Review>)
Public Method | LoadDB | Overloaded. Loads all the reviews with specified parameters.
Public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from dotnetCART.ListBase<Review>)
Public Method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from dotnetCART.ListBase<Review>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetCART.ListBase<Review>)
Public Method | RemoveRange | Removes a range of elements from the List. (Inherited from dotnetCART.ListBase<Review>)
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<Review>)
Top

See Also

Reference

Reviews Class
dotnetCART Namespace


%%PageItemTitle%%

GetAverage Method
[image]
dotnetCART Namespace > Reviews Class : GetAverage Method

Syntax

Visual Basic (Declaration)
Public Function GetAverage() As Single
C#
public float GetAverage()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Reviews Class
Reviews Members


%%PageItemTitle%%

GetCountDB Method
[image]
dotnetCART Namespace > Reviews Class : GetCountDB Method

Gets the total number of reviews in the Reviews table.

Overload List

Overload | Description
GetCountDB() | Gets the total number of reviews in the Reviews table.
GetCountDB(Where) | Gets the total number of reviews in the Reviews table.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Reviews Class
Reviews Members


%%PageItemTitle%%

GetCountDB() Method
[image]
dotnetCART Namespace > Reviews Class > GetCountDB Method : GetCountDB() Method

Gets the total number of reviews in the Reviews table.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCountDB() As Integer
C#
public int GetCountDB()

Return Value

Returns the number of elements in the Reviews table.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Reviews Class
Reviews Members
Overload List


%%PageItemTitle%%

GetCountDB(Where) Method
[image]
dotnetCART Namespace > Reviews Class > GetCountDB Method : GetCountDB(Where) Method

whereClause
The where clause to filter the reviews.
Gets the total number of reviews in the Reviews table.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCountDB( _
   ByVal whereClause As Where _
) As Integer
C#
public int GetCountDB(
   Where whereClause
)

Parameters

whereClause
The where clause to filter the reviews.

Return Value

Returns the number of elements in the Reviews table.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Reviews Class
Reviews Members
Overload List


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > Reviews Class : LoadDB Method

Loads all the reviews with specified parameters.

Overload List

Overload | Description
LoadDB(String,String) | Loads all the reviews with specified parameters.
LoadDB(Int64) | Loads all the reviews have been written by this customer.
LoadDB(Int64,String,String) |
LoadDB(String) | Loads all the reviews from its associated table with this status.
LoadDB(Where,Int32,Int32,String,OrderDirection) | Loads all the reviews from its associated table based on the where clause, start and count values.
LoadDB(Int64,String,Where,Int32,Int32,String,OrderDirection,String) | Loads all the reviews from its associated table based on the where clause, start and count values.
LoadDB() | Loads all the items from its associated table. (Inherited from dotnetCART.ListBase<Review>)
LoadDB(Where) | Loads all the items from its associated table based on the where clause. (Inherited from dotnetCART.ListBase<Review>)
LoadDB(Int32,Int32) | Loads the count number of elements from start value. (Inherited from dotnetCART.ListBase<Review>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Reviews Class
Reviews Members


%%PageItemTitle%%

LoadDB(String,String) Method
[image]
dotnetCART Namespace > Reviews Class > LoadDB Method : LoadDB(String,String) Method

itemID
An ItemID to use for loading all the reviews associated for it.
status
The status of the review: e.g. New, Public, Archive
Loads all the reviews with specified parameters.

Syntax

Visual Basic (Declaration)
Public Overloads Function LoadDB( _
   ByVal itemID As String, _
   ByVal status As String _
) As Integer
C#
public int LoadDB(
   string itemID,
   string status
)

Parameters

itemID
An ItemID to use for loading all the reviews associated for it.
status
The status of the review: e.g. New, Public, Archive

Return Value

The total number of reviews have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Reviews Class
Reviews Members
Overload List


%%PageItemTitle%%

LoadDB(Int64) Method
[image]
dotnetCART Namespace > Reviews Class > LoadDB Method : LoadDB(Int64) Method

customerID
A customer ID.
Loads all the reviews have been written by this customer.

Syntax

Visual Basic (Declaration)
Public Overloads Function LoadDB( _
   ByVal customerID As Long _
) As Integer
C#
public int LoadDB(
   long customerID
)

Parameters

customerID
A customer ID.

Return Value

The total number of reviews have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Reviews Class
Reviews Members
Overload List


%%PageItemTitle%%

LoadDB(Int64,String,String) Method
[image]
dotnetCART Namespace > Reviews Class > LoadDB Method : LoadDB(Int64,String,String) Method

customerID
itemID
status
The status of the review: e.g. New, Public, Archive

Syntax

Visual Basic (Declaration)
Public Overloads Function LoadDB( _
   ByVal customerID As Long, _
   ByVal itemID As String, _
   ByVal status As String _
) As Integer
C#
public int LoadDB(
   long customerID,
   string itemID,
   string status
)

Parameters

customerID
itemID
status
The status of the review: e.g. New, Public, Archive

Return Value

The total number of reviews have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Reviews Class
Reviews Members
Overload List


%%PageItemTitle%%

LoadDB(String) Method
[image]
dotnetCART Namespace > Reviews Class > LoadDB Method : LoadDB(String) Method

status
The status of the review: e.g. New, Public, Archive
Loads all the reviews from its associated table with this status.

Syntax

Visual Basic (Declaration)
Public Overloads Function LoadDB( _
   ByVal status As String _
) As Integer
C#
public int LoadDB(
   string status
)

Parameters

status
The status of the review: e.g. New, Public, Archive

Return Value

The total number of reviews have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Reviews Class
Reviews Members
Overload List


%%PageItemTitle%%

LoadDB(Where,Int32,Int32,String,OrderDirection) Method
[image]
dotnetCART Namespace > Reviews Class > LoadDB Method : LoadDB(Where,Int32,Int32,String,OrderDirection) Method

whereClause
The where clause to filter the reviews.
start
The start page which starts from 0.
count
The number of reviews in the page.
orderBy
The order of the loaded reviews.
orderDirection
The order direction of the loaded reviews. Defaults is Asc.
Loads all the reviews from its associated table based on the where clause, start and count values.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function LoadDB( _
   ByVal whereClause As Where, _
   ByVal start As Integer, _
   ByVal count As Integer, _
   ByVal orderBy As String, _
   ByVal orderDirection As OrderDirection _
) As Integer
C#
public override int LoadDB(
   Where whereClause,
   int start,
   int count,
   string orderBy,
   OrderDirection orderDirection
)

Parameters

whereClause
The where clause to filter the reviews.
start
The start page which starts from 0.
count
The number of reviews in the page.
orderBy
The order of the loaded reviews.
orderDirection
The order direction of the loaded reviews. Defaults is Asc.

Return Value

The total number of reviews have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Reviews Class
Reviews Members
Overload List


%%PageItemTitle%%

LoadDB(Int64,String,Where,Int32,Int32,String,OrderDirection,String) Method
See Also
[image]
dotnetCART Namespace > Reviews Class > LoadDB Method : LoadDB(Int64,String,Where,Int32,Int32,String,OrderDirection,String) Method

customerID
itemID
whereClause
The where clause to filter the reviews.
start
The start page which starts from 0.
count
The number of reviews in the page.
orderBy
The order of the loaded reviews.
orderDirection
The order direction of the loaded reviews. Defaults is Asc.
status
The status of the review: e.g. New, Public, Archive
Loads all the reviews from its associated table based on the where clause, start and count values.

Syntax

Visual Basic (Declaration)
Public Overloads Function LoadDB( _
   ByVal customerID As Long, _
   ByVal itemID As String, _
   ByVal whereClause As Where, _
   ByVal start As Integer, _
   ByVal count As Integer, _
   ByVal orderBy As String, _
   ByVal orderDirection As OrderDirection, _
   ByVal status As String _
) As Integer
C#
public int LoadDB(
   long customerID,
   string itemID,
   Where whereClause,
   int start,
   int count,
   string orderBy,
   OrderDirection orderDirection,
   string status
)

Parameters

customerID
itemID
whereClause
The where clause to filter the reviews.
start
The start page which starts from 0.
count
The number of reviews in the page.
orderBy
The order of the loaded reviews.
orderDirection
The order direction of the loaded reviews. Defaults is Asc.
status
The status of the review: e.g. New, Public, Archive

Return Value

The total number of reviews have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Reviews Class
Reviews Members
Overload List


%%PageItemTitle%%

RipeRir Class
See Also Members
[image]
dotnetCART Namespace : RipeRir Class

Syntax

Visual Basic (Declaration)
Private Class RipeRir
   Inherits BaseRir
C#
private class RipeRir : BaseRir

Inheritance Hierarchy

System.Object
dotnetCART.BaseRir
dotnetCART.RipeRir

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

RipeRir Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

RipeRir Class Members
See Also Methods
[image]
dotnetCART Namespace : RipeRir Class

The following tables list the members exposed by RipeRir.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Parse |
Top

See Also

Reference

RipeRir Class
dotnetCART Namespace


%%PageItemTitle%% $$Methods$$

RipeRir Class Methods
[image]
dotnetCART Namespace : RipeRir Class

For a list of all members of this type, see RipeRir members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Parse |
Top

See Also

Reference

RipeRir Class
dotnetCART Namespace


%%PageItemTitle%%

Parse Method
[image]
dotnetCART Namespace > RipeRir Class : Parse Method

ip

Syntax

Visual Basic (Declaration)
Public Shared Function Parse( _
   ByVal ip As String _
) As ParseResult
C#
public static ParseResult Parse(
   string ip
)

Parameters

ip

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

RipeRir Class
RipeRir Members


%%PageItemTitle%%

Settings Class
See Also Members
[image]
dotnetCART Namespace : Settings Class

Store settings.

Object Model

Syntax

Visual Basic (Declaration)
Public Class Settings
C#
public class Settings

Remarks

For a typical usage, see StoreAdmin->Settings->General tab.

Inheritance Hierarchy

System.Object
dotnetCART.Settings

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Settings Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

Settings Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : Settings Class

The following tables list the members exposed by Settings.

Public Constructors

 | Name | Description
Public Constructor | Settings Constructor |
Top

Public Properties

 | Name | Description
Public Property | AdCampaigns | A reference to the AdCampaigns collection for the store.
Public Property | Address | A reference to the store address setting.
Public Property | AdjustRate | The store level adjust rate can be set as a dollar amount or percentage based on dollar or quantity ranges. This formula accepts quantity and price ranges and adjusts based on a fixed amount or percentage. Ranges can be defined as quantity (1-10), dollars ($1-10) and also support open ended ranges e.g. 10 and up (10-). Adjustments can also be made as surcharges by using "+" rather than "-".
Public Property | Administrator | Gets the main admin user.
Public Property | AppSettings | Gets the application settings after calling Load method. They are stored in web.config
Public Property | AuthorizedServer | Controls which addresses the Cart.Add method will accept information from and prevents remote posts from entering cart data with altered pricing or any other data. This accepts a comma delmited list of URL which the add method will work on.
Public Property | Button | A reference to the Button settings.
Public Property | CarryOverGiftCertificateBalance | Determines whether a gift certificate can be used with more than one order or not.
Public Property | Currency | A reference to the Currency settings.
Public Property | Database | A reference to the Database settings.
Public Property | DataDirectory | The path for storing data like database and xml files.
Public Property | EncryptionKey | The key which is used in Tools.Encrypt and Tools.Decrypt methods.
Public Property | EncryptionKeyCreationDate | The creation date of the EncryptionKey.
Public Property | Error | Error object for Settings and other objects in this class.
Public Property | FileName | The file name with xml format which stores global application settings. Defaults to Settings.config
Public Property | FraudScore | A reference to the FraudScore settings.
Public Property | Images | A collection of ImageTemplate objects.
Public Property | Language | The preference language for your store.
Public Property | LicenseKey | Sets or gets the string license key. It is not for file license key.
Public Property | Location | A reference to the Location settings.
Public Property | Mail | A reference to the Mail settings.
Public Property | Path | The path for storing global application setting file.
Public Property | Payment | A reference to the Payment settings.
Public Property | Payments | A reference to the SettingsPayment collection.
Public Property | Precision | The number of digits of precision used in mathmatical calculations within the cart. Values will be rounded during calculation to this level which defaults to two.
Public Property | Shipping | A reference to the Shipping settings.
Public Property | Tax | A reference to the Tax settings.
Public Property | TimeZoneAdjustment | Adjust the display time.
Public Property | UseDPAPI | Determines whether use DPAPI for storing EncrytionKey in settings configuration or not.
Public Property | UserNameField | Determines which field will be used to load the username from. (defaults to Email).
Public Property | Users | The storeAdmin users. It is saved/loaded from the configration Settings.FileName, AdminUsers section.
Public Property | Version | Returns the version of .netCART currently in use.
Top

Public Methods

 | Name | Description
Public Method | Clear | Clears the global settings from cache.
Public Method | Load | Loads all the settings from the configration File.
Public Method | Save | Saves all the settings to the configration Settings.FileName.
Top

See Also

Reference

Settings Class
dotnetCART Namespace


%%PageItemTitle%%

Settings Constructor
[image]
dotnetCART Namespace > Settings Class : Settings Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Settings()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Settings Class
Settings Members


%%PageItemTitle%% $$Methods$$

Settings Class Methods
[image]
dotnetCART Namespace : Settings Class

For a list of all members of this type, see Settings members.

Public Methods

 | Name | Description
Public Method | Clear | Clears the global settings from cache.
Public Method | Load | Loads all the settings from the configration File.
Public Method | Save | Saves all the settings to the configration Settings.FileName.
Top

See Also

Reference

Settings Class
dotnetCART Namespace


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > Settings Class : Clear Method

Clears the global settings from cache.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Settings Class
Settings Members


%%PageItemTitle%%

Load Method
[image]
dotnetCART Namespace > Settings Class : Load Method

Loads all the settings from the configration File.

Syntax

Visual Basic (Declaration)
Public Function Load() As Boolean
C#
public bool Load()

Return Value

A Boolean indicates whether the operation is successful or not.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Settings Class
Settings Members


%%PageItemTitle%%

Save Method
[image]
dotnetCART Namespace > Settings Class : Save Method

Saves all the settings to the configration Settings.FileName.

Syntax

Visual Basic (Declaration)
Public Function Save() As Boolean
C#
public bool Save()

Return Value

A Boolean indicates whether the operation is successful or not.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Settings Class
Settings Members


%%PageItemTitle%% $$Properties$$

Settings Class Properties
[image]
dotnetCART Namespace : Settings Class

For a list of all members of this type, see Settings members.

Public Properties

 | Name | Description
Public Property | AdCampaigns | A reference to the AdCampaigns collection for the store.
Public Property | Address | A reference to the store address setting.
Public Property | AdjustRate | The store level adjust rate can be set as a dollar amount or percentage based on dollar or quantity ranges. This formula accepts quantity and price ranges and adjusts based on a fixed amount or percentage. Ranges can be defined as quantity (1-10), dollars ($1-10) and also support open ended ranges e.g. 10 and up (10-). Adjustments can also be made as surcharges by using "+" rather than "-".
Public Property | Administrator | Gets the main admin user.
Public Property | AppSettings | Gets the application settings after calling Load method. They are stored in web.config
Public Property | AuthorizedServer | Controls which addresses the Cart.Add method will accept information from and prevents remote posts from entering cart data with altered pricing or any other data. This accepts a comma delmited list of URL which the add method will work on.
Public Property | Button | A reference to the Button settings.
Public Property | CarryOverGiftCertificateBalance | Determines whether a gift certificate can be used with more than one order or not.
Public Property | Currency | A reference to the Currency settings.
Public Property | Database | A reference to the Database settings.
Public Property | DataDirectory | The path for storing data like database and xml files.
Public Property | EncryptionKey | The key which is used in Tools.Encrypt and Tools.Decrypt methods.
Public Property | EncryptionKeyCreationDate | The creation date of the EncryptionKey.
Public Property | Error | Error object for Settings and other objects in this class.
Public Property | FileName | The file name with xml format which stores global application settings. Defaults to Settings.config
Public Property | FraudScore | A reference to the FraudScore settings.
Public Property | Images | A collection of ImageTemplate objects.
Public Property | Language | The preference language for your store.
Public Property | LicenseKey | Sets or gets the string license key. It is not for file license key.
Public Property | Location | A reference to the Location settings.
Public Property | Mail | A reference to the Mail settings.
Public Property | Path | The path for storing global application setting file.
Public Property | Payment | A reference to the Payment settings.
Public Property | Payments | A reference to the SettingsPayment collection.
Public Property | Precision | The number of digits of precision used in mathmatical calculations within the cart. Values will be rounded during calculation to this level which defaults to two.
Public Property | Shipping | A reference to the Shipping settings.
Public Property | Tax | A reference to the Tax settings.
Public Property | TimeZoneAdjustment | Adjust the display time.
Public Property | UseDPAPI | Determines whether use DPAPI for storing EncrytionKey in settings configuration or not.
Public Property | UserNameField | Determines which field will be used to load the username from. (defaults to Email).
Public Property | Users | The storeAdmin users. It is saved/loaded from the configration Settings.FileName, AdminUsers section.
Public Property | Version | Returns the version of .netCART currently in use.
Top

See Also

Reference

Settings Class
dotnetCART Namespace


%%PageItemTitle%%

AdCampaigns Property
[image]
dotnetCART Namespace > Settings Class : AdCampaigns Property

A reference to the AdCampaigns collection for the store.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AdCampaigns As AdCampaigns
C#
public AdCampaigns AdCampaigns {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Settings Class
Settings Members


%%PageItemTitle%%

Address Property
[image]
dotnetCART Namespace > Settings Class : Address Property

A reference to the store address setting.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Address As StoreAddress
C#
public StoreAddress Address {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Settings Class
Settings Members


%%PageItemTitle%%

AdjustRate Property
See Also Example
[image]
dotnetCART Namespace > Settings Class : AdjustRate Property

The store level adjust rate can be set as a dollar amount or percentage based on dollar or quantity ranges. This formula accepts quantity and price ranges and adjusts based on a fixed amount or percentage. Ranges can be defined as quantity (1-10), dollars ($1-10) and also support open ended ranges e.g. 10 and up (10-). Adjustments can also be made as surcharges by using "+" rather than "-".

Syntax

Visual Basic (Declaration)
Public Property AdjustRate As String
C#
public string AdjustRate {get; set;}

Example

C# Copy Code
Settings.AdjustRate = "$1=-10%;$2=-20%;$3=-30%;";
Settings.AdjustRate = "1=-10%;2=-20%;3-=-30%;";
Settings.AdjustRate = "1=10;2=20;3=30;4-100=35;101-=40;";

Visual Basic Copy Code
Settings.AdjustRate = "$1=-10%;$2=-20%;$3=-30%;"
Settings.AdjustRate = "1=-10%;$2=-20%;3-=-30%;"
Settings.AdjustRate = "1=10;2=20;3=30;4-100=35;101-=40;"

Remarks

In Calculate() method, if Cart.AdjustRate is empty, this property is used.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Settings Class
Settings Members


%%PageItemTitle%%

Administrator Property
[image]
dotnetCART Namespace > Settings Class : Administrator Property

Gets the main admin user.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Administrator As String
C#
public string Administrator {get;}

Remarks

The main admin user is set to the first admin user.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Settings Class
Settings Members


%%PageItemTitle%%

AppSettings Property
[image]
dotnetCART Namespace > Settings Class : AppSettings Property

Gets the application settings after calling Load method. They are stored in web.config

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AppSettings As ListDictionary
C#
public ListDictionary AppSettings {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Settings Class
Settings Members


%%PageItemTitle%%

AuthorizedServer Property
[image]
dotnetCART Namespace > Settings Class : AuthorizedServer Property

Controls which addresses the Cart.Add method will accept information from and prevents remote posts from entering cart data with altered pricing or any other data. This accepts a comma delmited list of URL which the add method will work on.

Syntax

Visual Basic (Declaration)
Public Property AuthorizedServer As String
C#
public string AuthorizedServer {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Settings Class
Settings Members


%%PageItemTitle%%

Button Property
[image]
dotnetCART Namespace > Settings Class : Button Property

A reference to the Button settings.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Button As SettingsButton
C#
public SettingsButton Button {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Settings Class
Settings Members


%%PageItemTitle%%

CarryOverGiftCertificateBalance Property
[image]
dotnetCART Namespace > Settings Class : CarryOverGiftCertificateBalance Property

Determines whether a gift certificate can be used with more than one order or not.

Syntax

Visual Basic (Declaration)
Public Property CarryOverGiftCertificateBalance As Boolean
C#
public bool CarryOverGiftCertificateBalance {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Settings Class
Settings Members


%%PageItemTitle%%

Currency Property
[image]
dotnetCART Namespace > Settings Class : Currency Property

A reference to the Currency settings.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Currency As SettingsCurrency
C#
public SettingsCurrency Currency {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Settings Class
Settings Members


%%PageItemTitle%%

Database Property
[image]
dotnetCART Namespace > Settings Class : Database Property

A reference to the Database settings.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Database As SettingsDatabase
C#
public SettingsDatabase Database {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Settings Class
Settings Members


%%PageItemTitle%%

DataDirectory Property
[image]
dotnetCART Namespace > Settings Class : DataDirectory Property

The path for storing data like database and xml files.

Syntax

Visual Basic (Declaration)
Public Property DataDirectory As String
C#
public string DataDirectory {get; set;}

Remarks

By default data directory is App_Data folder. You can change it by setting this property or in appSettings section in web.config, adding key="dotnetCARTData" and setting the value attribute to the relative path of the data directory.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Settings Class
Settings Members


%%PageItemTitle%%

EncryptionKey Property
[image]
dotnetCART Namespace > Settings Class : EncryptionKey Property

The key which is used in Tools.Encrypt and Tools.Decrypt methods.

Syntax

Visual Basic (Declaration)
Public Property EncryptionKey As String
C#
public string EncryptionKey {get; set;}

Remarks

Tools.Encrypt and Tools.Decrypt methods are internally used to encrypt and decrypt Cart.ID in the cookie, credit card number in the database, database connection string, mail server name and SMTP password in the settings.config file.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Settings Class
Settings Members


%%PageItemTitle%%

EncryptionKeyCreationDate Property
[image]
dotnetCART Namespace > Settings Class : EncryptionKeyCreationDate Property

The creation date of the EncryptionKey.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EncryptionKeyCreationDate As Date
C#
public DateTime EncryptionKeyCreationDate {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Settings Class
Settings Members


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > Settings Class : Error Property

Error object for Settings and other objects in this class.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Settings Class
Settings Members


%%PageItemTitle%%

FileName Property
[image]
dotnetCART Namespace > Settings Class : FileName Property

The file name with xml format which stores global application settings. Defaults to Settings.config

Syntax

Visual Basic (Declaration)
Public Property FileName As String
C#
public string FileName {get; set;}

Remarks

This file is stored in the Path

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Settings Class
Settings Members


%%PageItemTitle%%

FraudScore Property
[image]
dotnetCART Namespace > Settings Class : FraudScore Property

A reference to the FraudScore settings.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FraudScore As SettingsFraudScore
C#
public SettingsFraudScore FraudScore {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Settings Class
Settings Members


%%PageItemTitle%%

Images Property
[image]
dotnetCART Namespace > Settings Class : Images Property

A collection of ImageTemplate objects.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Images As ImageTemplates
C#
public ImageTemplates Images {get;}

Remarks

ImageTemplate can be used for generating different images for Items, Categories or any other purpose.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Settings Class
Settings Members


%%PageItemTitle%%

Language Property
[image]
dotnetCART Namespace > Settings Class : Language Property

The preference language for your store.

Syntax

Visual Basic (Declaration)
Public Property Language As String
C#
public string Language {get; set;}

Remarks

You can create and customize a language file through htmStoreAdmin->Settings->Language tab.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Settings Class
Settings Members


%%PageItemTitle%%

LicenseKey Property
[image]
dotnetCART Namespace > Settings Class : LicenseKey Property

Sets or gets the string license key. It is not for file license key.

Syntax

Visual Basic (Declaration)
Public Property LicenseKey As String
C#
public string LicenseKey {get; set;}

Remarks

This is only for string license key, if your license key is a file like 85877885.key, it must copy to the application bin directory

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Settings Class
Settings Members


%%PageItemTitle%%

Location Property
[image]
dotnetCART Namespace > Settings Class : Location Property

A reference to the Location settings.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Location As SettingsLocation
C#
public SettingsLocation Location {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Settings Class
Settings Members


%%PageItemTitle%%

Mail Property
[image]
dotnetCART Namespace > Settings Class : Mail Property

A reference to the Mail settings.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Mail As SettingsMail
C#
public SettingsMail Mail {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Settings Class
Settings Members


%%PageItemTitle%%

Path Property
[image]
dotnetCART Namespace > Settings Class : Path Property

The path for storing global application setting file.

Syntax

Visual Basic (Declaration)
Public Property Path As String
C#
public string Path {get; set;}

Remarks

By default this path is App_Data folder. You can change it by setting this property or in appSettings section in web.config, adding key="dotnetCARTData" and setting the value attribute to the relative path of the data directory.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Settings Class
Settings Members


%%PageItemTitle%%

Payment Property
[image]
dotnetCART Namespace > Settings Class : Payment Property

A reference to the Payment settings.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Payment As SettingsPayment
C#
public SettingsPayment Payment {get;}

Remarks

For a typical usage, see payment processing.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Settings Class
Settings Members


%%PageItemTitle%%

Payments Property
[image]
dotnetCART Namespace > Settings Class : Payments Property

A reference to the SettingsPayment collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Payments As List(Of SettingsPayment)
C#
public List<SettingsPayment> Payments {get;}

Remarks

For a typical usage, see payment processing.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Settings Class
Settings Members


%%PageItemTitle%%

Precision Property
[image]
dotnetCART Namespace > Settings Class : Precision Property

The number of digits of precision used in mathmatical calculations within the cart. Values will be rounded during calculation to this level which defaults to two.

Syntax

Visual Basic (Declaration)
Public Property Precision As Integer
C#
public int Precision {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Settings Class
Settings Members


%%PageItemTitle%%

Shipping Property
[image]
dotnetCART Namespace > Settings Class : Shipping Property

A reference to the Shipping settings.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Shipping As SettingsShip
C#
public SettingsShip Shipping {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Settings Class
Settings Members


%%PageItemTitle%%

Tax Property
[image]
dotnetCART Namespace > Settings Class : Tax Property

A reference to the Tax settings.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Tax As SettingsTax
C#
public SettingsTax Tax {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Settings Class
Settings Members


%%PageItemTitle%%

TimeZoneAdjustment Property
[image]
dotnetCART Namespace > Settings Class : TimeZoneAdjustment Property

Adjust the display time.

Syntax

Visual Basic (Declaration)
Public Property TimeZoneAdjustment As Double
C#
public double TimeZoneAdjustment {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Settings Class
Settings Members


%%PageItemTitle%%

UseDPAPI Property
[image]
dotnetCART Namespace > Settings Class : UseDPAPI Property

Determines whether use DPAPI for storing EncrytionKey in settings configuration or not.

Syntax

Visual Basic (Declaration)
Public Property UseDPAPI As Boolean
C#
public bool UseDPAPI {get; set;}

Remarks

If moving the application to another system and using DPAPI feature, the same EncryptionKey should be set in Settings-> General -> Encryption Key and apply the save button. In some cases, the same database settings should be set and apply the save button.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Settings Class
Settings Members


%%PageItemTitle%%

UserNameField Property
[image]
dotnetCART Namespace > Settings Class : UserNameField Property

Determines which field will be used to load the username from. (defaults to Email).

Syntax

Visual Basic (Declaration)
Public Property UserNameField As String
C#
public string UserNameField {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Settings Class
Settings Members


%%PageItemTitle%%

Users Property
[image]
dotnetCART Namespace > Settings Class : Users Property

The storeAdmin users. It is saved/loaded from the configration Settings.FileName, AdminUsers section.

Syntax

Visual Basic (Declaration)
Public Property Users As ListDictionary
C#
public ListDictionary Users {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Settings Class
Settings Members


%%PageItemTitle%%

Version Property
[image]
dotnetCART Namespace > Settings Class : Version Property

Returns the version of .netCART currently in use.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Version As String
C#
public string Version {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Settings Class
Settings Members


%%PageItemTitle%%

SettingsButton Class
See Also Members
[image]
dotnetCART Namespace : SettingsButton Class

Button Settings.

Syntax

Visual Basic (Declaration)
Public Class SettingsButton
C#
public class SettingsButton

Remarks

The heart of .netCART's dynamic button is its integrated .netBUTTON. If you require stand alone Winforms and Desktop Dynamic Button for another part of your web site, or another project all together, a dedicated license is available for purchase at http://www.dotnetbutton.com/

Inheritance Hierarchy

System.Object
dotnetCART.SettingsButton

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsButton Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

SettingsButton Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : SettingsButton Class

The following tables list the members exposed by SettingsButton.

Public Constructors

 | Name | Description
Public Constructor | SettingsButton Constructor |
Top

Public Properties

 | Name | Description
Public Property | StyleSettings | Sets or gets button style settings which controls the visual appearance of the button.
Top

Public Methods

 | Name | Description
Public Method | Load | Loads button settings from the settings configuration file specified in Settings.FileName and Settings.Path.
Public Method | Save | Saves button settings to the settings configuration file specified in Settings.FileName and Settings.Path.
Top

See Also

Reference

SettingsButton Class
dotnetCART Namespace


%%PageItemTitle%%

SettingsButton Constructor
[image]
dotnetCART Namespace > SettingsButton Class : SettingsButton Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SettingsButton()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsButton Class
SettingsButton Members


%%PageItemTitle%% $$Methods$$

SettingsButton Class Methods
[image]
dotnetCART Namespace : SettingsButton Class

For a list of all members of this type, see SettingsButton members.

Public Methods

 | Name | Description
Public Method | Load | Loads button settings from the settings configuration file specified in Settings.FileName and Settings.Path.
Public Method | Save | Saves button settings to the settings configuration file specified in Settings.FileName and Settings.Path.
Top

See Also

Reference

SettingsButton Class
dotnetCART Namespace


%%PageItemTitle%%

Load Method
[image]
dotnetCART Namespace > SettingsButton Class : Load Method

Loads button settings from the settings configuration file specified in Settings.FileName and Settings.Path.

Syntax

Visual Basic (Declaration)
Public Function Load() As Boolean
C#
public bool Load()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsButton Class
SettingsButton Members


%%PageItemTitle%%

Save Method
[image]
dotnetCART Namespace > SettingsButton Class : Save Method

Saves button settings to the settings configuration file specified in Settings.FileName and Settings.Path.

Syntax

Visual Basic (Declaration)
Public Function Save() As Boolean
C#
public bool Save()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsButton Class
SettingsButton Members


%%PageItemTitle%% $$Properties$$

SettingsButton Class Properties
[image]
dotnetCART Namespace : SettingsButton Class

For a list of all members of this type, see SettingsButton members.

Public Properties

 | Name | Description
Public Property | StyleSettings | Sets or gets button style settings which controls the visual appearance of the button.
Top

See Also

Reference

SettingsButton Class
dotnetCART Namespace


%%PageItemTitle%%

StyleSettings Property
[image]
dotnetCART Namespace > SettingsButton Class : StyleSettings Property

Sets or gets button style settings which controls the visual appearance of the button.

Syntax

Visual Basic (Declaration)
Public Property StyleSettings As StyleSettings
C#
public StyleSettings StyleSettings {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsButton Class
SettingsButton Members


%%PageItemTitle%%

SettingsCurrency Class
See Also Members
[image]
dotnetCART Namespace : SettingsCurrency Class

Currency settings. They usually set through StoreAdmin->Settings.

Syntax

Visual Basic (Declaration)
Public Class SettingsCurrency
C#
public class SettingsCurrency

Remarks

The XML of the currency rates are updated based on the UpdatePeriod when invoking Settings.Load property.

Inheritance Hierarchy

System.Object
dotnetCART.SettingsCurrency

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsCurrency Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

SettingsCurrency Class Members
See Also Properties
[image]
dotnetCART Namespace : SettingsCurrency Class

The following tables list the members exposed by SettingsCurrency.

Public Constructors

 | Name | Description
Public Constructor | SettingsCurrency Constructor |
Top

Public Properties

 | Name | Description
Public Property | Base | A 3 character currency code.
Public Property | Culture | Returns the culture based on the Base property.
Public Property | LastUpdate | Returns the date and time of the last real-time update. Read only.
Public Property | UpdatePeriod | Determines the update priod. "10,H" update if the lastupdate is more than 10 hours. "1,D" update if the lastupdate is more than 1 day.
Top

See Also

Reference

SettingsCurrency Class
dotnetCART Namespace


%%PageItemTitle%%

SettingsCurrency Constructor
[image]
dotnetCART Namespace > SettingsCurrency Class : SettingsCurrency Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SettingsCurrency()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsCurrency Class
SettingsCurrency Members


%%PageItemTitle%% $$Properties$$

SettingsCurrency Class Properties
[image]
dotnetCART Namespace : SettingsCurrency Class

For a list of all members of this type, see SettingsCurrency members.

Public Properties

 | Name | Description
Public Property | Base | A 3 character currency code.
Public Property | Culture | Returns the culture based on the Base property.
Public Property | LastUpdate | Returns the date and time of the last real-time update. Read only.
Public Property | UpdatePeriod | Determines the update priod. "10,H" update if the lastupdate is more than 10 hours. "1,D" update if the lastupdate is more than 1 day.
Top

See Also

Reference

SettingsCurrency Class
dotnetCART Namespace


%%PageItemTitle%%

Base Property
[image]
dotnetCART Namespace > SettingsCurrency Class : Base Property

A 3 character currency code.

Syntax

Visual Basic (Declaration)
Public Property Base As String
C#
public string Base {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsCurrency Class
SettingsCurrency Members


%%PageItemTitle%%

Culture Property
[image]
dotnetCART Namespace > SettingsCurrency Class : Culture Property

Returns the culture based on the Base property.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Culture As String
C#
public string Culture {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsCurrency Class
SettingsCurrency Members


%%PageItemTitle%%

LastUpdate Property
[image]
dotnetCART Namespace > SettingsCurrency Class : LastUpdate Property

Returns the date and time of the last real-time update. Read only.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LastUpdate As String
C#
public string LastUpdate {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsCurrency Class
SettingsCurrency Members


%%PageItemTitle%%

UpdatePeriod Property
[image]
dotnetCART Namespace > SettingsCurrency Class : UpdatePeriod Property

Determines the update priod. "10,H" update if the lastupdate is more than 10 hours. "1,D" update if the lastupdate is more than 1 day.

Syntax

Visual Basic (Declaration)
Public Property UpdatePeriod As String
C#
public string UpdatePeriod {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsCurrency Class
SettingsCurrency Members


%%PageItemTitle%%

SettingsDatabase Class
See Also Members
[image]
dotnetCART Namespace : SettingsDatabase Class

Database settings.

Object Model

Syntax

Visual Basic (Declaration)
Public Class SettingsDatabase
C#
public class SettingsDatabase

Remarks

For a typical usage, see StoreAdmin->Settings->Database tab.

Inheritance Hierarchy

System.Object
dotnetCART.SettingsDatabase

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsDatabase Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

SettingsDatabase Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : SettingsDatabase Class

The following tables list the members exposed by SettingsDatabase.

Public Constructors

 | Name | Description
Public Constructor | SettingsDatabase Constructor |
Top

Public Properties

 | Name | Description
Public Property | AddSampleData | Determines whether to add sample data to a new created database or not.
Public Property | ConnectionString | Gets or sets the database connection string.
Public Property | ConnectionStringSet | Indicates whether the ConnectionString property has been set explicitly or not.
Public Property | CustomFields | Gets a reference to the database CustomFields.
Public Property | Login | Gets or sets the database login.
Public Property | Name | Gets or sets the database name.
Public Property | Password | Gets or sets the database password.
Public Property | Port | Gets or sets the database server port.
Public Property | ProviderType | Gets or sets the database provider type.
Public Property | Server | Gets or sets the database server.
Top

Public Methods

 | Name | Description
Public Method | Clear | Initializes all the database settings to the default values.
Public Method | Load | Loads database settings from the settings configuration file specified in Settings.FileName and Settings.Path.
Public Method | Save | Saves database settings to the settings configuration file specified in Settings.FileName and Settings.Path.
Public Method | TestConnection | Test database connection.
Top

See Also

Reference

SettingsDatabase Class
dotnetCART Namespace


%%PageItemTitle%%

SettingsDatabase Constructor
[image]
dotnetCART Namespace > SettingsDatabase Class : SettingsDatabase Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SettingsDatabase()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsDatabase Class
SettingsDatabase Members


%%PageItemTitle%% $$Methods$$

SettingsDatabase Class Methods
[image]
dotnetCART Namespace : SettingsDatabase Class

For a list of all members of this type, see SettingsDatabase members.

Public Methods

 | Name | Description
Public Method | Clear | Initializes all the database settings to the default values.
Public Method | Load | Loads database settings from the settings configuration file specified in Settings.FileName and Settings.Path.
Public Method | Save | Saves database settings to the settings configuration file specified in Settings.FileName and Settings.Path.
Public Method | TestConnection | Test database connection.
Top

See Also

Reference

SettingsDatabase Class
dotnetCART Namespace


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > SettingsDatabase Class : Clear Method

Initializes all the database settings to the default values.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsDatabase Class
SettingsDatabase Members


%%PageItemTitle%%

Load Method
[image]
dotnetCART Namespace > SettingsDatabase Class : Load Method

Loads database settings from the settings configuration file specified in Settings.FileName and Settings.Path.

Syntax

Visual Basic (Declaration)
Public Function Load() As Boolean
C#
public bool Load()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsDatabase Class
SettingsDatabase Members


%%PageItemTitle%%

Save Method
[image]
dotnetCART Namespace > SettingsDatabase Class : Save Method

Saves database settings to the settings configuration file specified in Settings.FileName and Settings.Path.

Syntax

Visual Basic (Declaration)
Public Function Save() As Boolean
C#
public bool Save()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsDatabase Class
SettingsDatabase Members


%%PageItemTitle%%

TestConnection Method
[image]
dotnetCART Namespace > SettingsDatabase Class : TestConnection Method

Test database connection.

Syntax

Visual Basic (Declaration)
Public Function TestConnection() As Boolean
C#
public bool TestConnection()

Return Value

Returns the result of the test.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsDatabase Class
SettingsDatabase Members


%%PageItemTitle%% $$Properties$$

SettingsDatabase Class Properties
[image]
dotnetCART Namespace : SettingsDatabase Class

For a list of all members of this type, see SettingsDatabase members.

Public Properties

 | Name | Description
Public Property | AddSampleData | Determines whether to add sample data to a new created database or not.
Public Property | ConnectionString | Gets or sets the database connection string.
Public Property | ConnectionStringSet | Indicates whether the ConnectionString property has been set explicitly or not.
Public Property | CustomFields | Gets a reference to the database CustomFields.
Public Property | Login | Gets or sets the database login.
Public Property | Name | Gets or sets the database name.
Public Property | Password | Gets or sets the database password.
Public Property | Port | Gets or sets the database server port.
Public Property | ProviderType | Gets or sets the database provider type.
Public Property | Server | Gets or sets the database server.
Top

See Also

Reference

SettingsDatabase Class
dotnetCART Namespace


%%PageItemTitle%%

AddSampleData Property
[image]
dotnetCART Namespace > SettingsDatabase Class : AddSampleData Property

Determines whether to add sample data to a new created database or not.

Syntax

Visual Basic (Declaration)
Public Property AddSampleData As Boolean
C#
public bool AddSampleData {get; set;}

Remarks

If you wish to create a blank database without the sample data, specify a new database name, then set this property to false and call Save() method. A new blank database will automatically be created.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsDatabase Class
SettingsDatabase Members


%%PageItemTitle%%

ConnectionString Property
[image]
dotnetCART Namespace > SettingsDatabase Class : ConnectionString Property

Gets or sets the database connection string.

Syntax

Visual Basic (Declaration)
Public Property ConnectionString As String
C#
public string ConnectionString {get; set;}

Remarks

This property can be set to a full connectin string instead of setting other properties like Name, Password, etc.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsDatabase Class
SettingsDatabase Members


%%PageItemTitle%%

ConnectionStringSet Property
[image]
dotnetCART Namespace > SettingsDatabase Class : ConnectionStringSet Property

Indicates whether the ConnectionString property has been set explicitly or not.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ConnectionStringSet As Boolean
C#
public bool ConnectionStringSet {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsDatabase Class
SettingsDatabase Members


%%PageItemTitle%%

CustomFields Property
[image]
dotnetCART Namespace > SettingsDatabase Class : CustomFields Property

Gets a reference to the database CustomFields.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CustomFields As CustomFields
C#
public CustomFields CustomFields {get;}

Remarks

Custom fields used to store name/value pairs for any type of custom data. There is no limit to the number of user defined custom fields. Custom fields can be defined at various levels including order, item, option, customer, address and payment. They are automatically stored and handled by .netCART and even written to the database (a field should exist in the appropriate table with a name matching the custom name). For more information see custom fields

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsDatabase Class
SettingsDatabase Members


%%PageItemTitle%%

Login Property
[image]
dotnetCART Namespace > SettingsDatabase Class : Login Property

Gets or sets the database login.

Syntax

Visual Basic (Declaration)
Public Property Login As String
C#
public string Login {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsDatabase Class
SettingsDatabase Members


%%PageItemTitle%%

Name Property
[image]
dotnetCART Namespace > SettingsDatabase Class : Name Property

Gets or sets the database name.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsDatabase Class
SettingsDatabase Members


%%PageItemTitle%%

Password Property
[image]
dotnetCART Namespace > SettingsDatabase Class : Password Property

Gets or sets the database password.

Syntax

Visual Basic (Declaration)
Public Property Password As String
C#
public string Password {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsDatabase Class
SettingsDatabase Members


%%PageItemTitle%%

Port Property
[image]
dotnetCART Namespace > SettingsDatabase Class : Port Property

Gets or sets the database server port.

Syntax

Visual Basic (Declaration)
Public Property Port As Integer
C#
public int Port {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsDatabase Class
SettingsDatabase Members


%%PageItemTitle%%

ProviderType Property
[image]
dotnetCART Namespace > SettingsDatabase Class : ProviderType Property

Gets or sets the database provider type.

Syntax

Visual Basic (Declaration)
Public Property ProviderType As DataProviderType
C#
public DataProviderType ProviderType {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsDatabase Class
SettingsDatabase Members


%%PageItemTitle%%

Server Property
[image]
dotnetCART Namespace > SettingsDatabase Class : Server Property

Gets or sets the database server.

Syntax

Visual Basic (Declaration)
Public Property Server As String
C#
public string Server {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsDatabase Class
SettingsDatabase Members


%%PageItemTitle%%

SettingsFraudScore Class
See Also Members
[image]
dotnetCART Namespace : SettingsFraudScore Class

Fraud score settings.

Syntax

Visual Basic (Declaration)
Public Class SettingsFraudScore
C#
public class SettingsFraudScore

Remarks

For a typical usage, see StoreAdmin->Settings->FraudScore tab.
It allows to set formulas or values to control all aspects of the system to ensure the most effective FraudScore calculation. The FraudScore system works most effectively with minimal validation at the store level. Analysis is performed on the input data and, using characteristics common to fraudulant orders, scores are assigned for a number of unique factors. The FraudScore is cummulative and it is expected that every order will have at least a minimal score. With your ecommerce implemetnatino you can control the score thresholds which you take action on. For example, for scores of less than 500 you may choose to process the order as usual with real-time delivery. At scores between 500-1000 you may have more stringent rules on payment processing, on scores over 1000 you may elect to defer realtime delivery so that a human can review the order before shipment. Or, on higher scores perhaps you would like to send an automated a credit card faxback authorization form or email confirmation validation request.

Inheritance Hierarchy

System.Object
dotnetCART.SettingsFraudScore

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsFraudScore Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

SettingsFraudScore Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : SettingsFraudScore Class

The following tables list the members exposed by SettingsFraudScore.

Public Constructors

 | Name | Description
Public Constructor | SettingsFraudScore Constructor |
Top

Public Properties

 | Name | Description
Public Property | Address | The score defined for this property is added if the address appears invalid. It is expected that an address will contain both letters and numbers and not be less than 10 characters in length.
Public Property | Amount | This fraudscore is a ranged formula which assigns a specific score based on the total dollar amount of all items in the cart. In many stores orders over a given dollar value are unheard of and this property allows you to reflect this rarity as part of the overall fraudscore.
Public Property | AnonymousProxy | Using the built in .netCOUNTRY support the fraudscore system is able to determine if the IP address is from one of many documented anonymous proxy systems. In such a case the web user is specifically attempting to mask their identity and fraud is highly likely. The score defined for this property is added in such a case.
Public Property | BillingShipping | It has been found that orders using the same address for billing and shipping are less prone to being fraudulant. For this reason this score is added if the billing and shipping addresses differ.
Public Property | BrowserCountry | Using the built in .netCOUNTRY support the fraudscore system is able to determine the country based on the users culture configuration in their web browser. If this does not match the country provided the score is added.
Public Property | CreditCardCodeAttempts | A fixed score is added with each extra credit card security code attempts.
Public Property | CreditCardExpiryAttempts | A fixed score is added with each extra credit card expiry attempts.
Public Property | CreditCardNumberAttempts | A fixed score is added with each extra credit card number attempts.
Public Property | DuplicateInputs | This property assigns a score based on duplicate inputs, that is inputs that are the same across seperate input fields. The likelyhood that the address would be the same as the telephone number is extremely low as such the fraudscore system can be set to treat such cases appropriately.
Public Property | FreeMail | A fixed score is added per unique email address in the order that is from a free email provider such as hotmail.com. Typically fraudulant orders originate from free email accounts.
Public Property | HomeRow | This analysis examines the total number of homerow characters used as a percentage of total inputs. A high percentage of homerow characters typically indicates that the input is fraudulent.
Public Property | InputLength | This fraudscore is a ranged formula which assigns a specific score based on the total quantity of items in the cart. In many stores order over a given quantity are unheard of and this property allows you to reflect this rarity as part of the overall fraudscore.
Public Property | IpCountry | Using the built in .netCOUNTRY support the fraudscore system is able to determine, with 90+% accuracy, the location of the visitor based on their IP address. This score is added if the supplied country does not match the country indicated.
Public Property | Items | For many ecommerce implementations certain item combinations or high profile items are rarely ordered. You may wish to assign such items or combinations a high fraudscore to ensure human processing. This is particularly true for softgood delivery. If you sell a number of softgood packages and your total number of unique items is low a combination of 1 of every package almost certainly indicates fraud. Also, if you have multiple version of a product it may be highly unlikely that they would be ordered in combination within 1 order. This property can be used to assign an appropriate fraudscrore addition for such cases.
Public Property | LetterRepeats | This property accepts a ranged formula for the score to be added based on percentage of letter repeats. Valid input would typically have a minimal repeats. Above a certain range invalid data is a certainty.
Public Property | NameOnCardMatch | A fixed score is added if the first or last name of the billing address do not match the name on the credit card. For example, if the fixed value is defined as 100 and both FirstName and LastName are located within the NameOnCard the score is not increased. If FirstName is not found, score is incremented by the fixed value and if both FirstName and LastName are not found, it is incremented by twice the fixed value.
Public Property | Quantity | This fraudscore is a ranged formula which assigns a specific score based on the total quantity of items in the cart. In many stores order over a given quantity are unheard of and this property allows you to reflect this rarity as part of the overall fraudscore.
Public Property | Symbols | This property examines the total number of symbols (non alpha-numeric) characters used as a percentage of total inputs. A high percentage of symbols typically indicates that the input is fraudulent.
Public Property | ValidMail | A fixed score is added if the email address provided is not valid. Validity is determined through a syntatical check of the address provided.
Public Property | VowelConsonant | Within any given language there is an expected ration of vowels to consonants. This property examines are ranged percentage formula and assigns the appropriate score.
Top

Public Methods

 | Name | Description
Public Method | Load | Loads fraud score settings from the settings configuration file specified in Settings.FileName and Settings.Path.
Public Method | Save | Saves fraud score settings to the settings configuration file specified in Settings.FileName and Settings.Path.
Top

See Also

Reference

SettingsFraudScore Class
dotnetCART Namespace


%%PageItemTitle%%

SettingsFraudScore Constructor
[image]
dotnetCART Namespace > SettingsFraudScore Class : SettingsFraudScore Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SettingsFraudScore()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsFraudScore Class
SettingsFraudScore Members


%%PageItemTitle%% $$Methods$$

SettingsFraudScore Class Methods
[image]
dotnetCART Namespace : SettingsFraudScore Class

For a list of all members of this type, see SettingsFraudScore members.

Public Methods

 | Name | Description
Public Method | Load | Loads fraud score settings from the settings configuration file specified in Settings.FileName and Settings.Path.
Public Method | Save | Saves fraud score settings to the settings configuration file specified in Settings.FileName and Settings.Path.
Top

See Also

Reference

SettingsFraudScore Class
dotnetCART Namespace


%%PageItemTitle%%

Load Method
[image]
dotnetCART Namespace > SettingsFraudScore Class : Load Method

Loads fraud score settings from the settings configuration file specified in Settings.FileName and Settings.Path.

Syntax

Visual Basic (Declaration)
Public Function Load() As Boolean
C#
public bool Load()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsFraudScore Class
SettingsFraudScore Members


%%PageItemTitle%%

Save Method
[image]
dotnetCART Namespace > SettingsFraudScore Class : Save Method

Saves fraud score settings to the settings configuration file specified in Settings.FileName and Settings.Path.

Syntax

Visual Basic (Declaration)
Public Function Save() As Boolean
C#
public bool Save()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsFraudScore Class
SettingsFraudScore Members


%%PageItemTitle%% $$Properties$$

SettingsFraudScore Class Properties
[image]
dotnetCART Namespace : SettingsFraudScore Class

For a list of all members of this type, see SettingsFraudScore members.

Public Properties

 | Name | Description
Public Property | Address | The score defined for this property is added if the address appears invalid. It is expected that an address will contain both letters and numbers and not be less than 10 characters in length.
Public Property | Amount | This fraudscore is a ranged formula which assigns a specific score based on the total dollar amount of all items in the cart. In many stores orders over a given dollar value are unheard of and this property allows you to reflect this rarity as part of the overall fraudscore.
Public Property | AnonymousProxy | Using the built in .netCOUNTRY support the fraudscore system is able to determine if the IP address is from one of many documented anonymous proxy systems. In such a case the web user is specifically attempting to mask their identity and fraud is highly likely. The score defined for this property is added in such a case.
Public Property | BillingShipping | It has been found that orders using the same address for billing and shipping are less prone to being fraudulant. For this reason this score is added if the billing and shipping addresses differ.
Public Property | BrowserCountry | Using the built in .netCOUNTRY support the fraudscore system is able to determine the country based on the users culture configuration in their web browser. If this does not match the country provided the score is added.
Public Property | CreditCardCodeAttempts | A fixed score is added with each extra credit card security code attempts.
Public Property | CreditCardExpiryAttempts | A fixed score is added with each extra credit card expiry attempts.
Public Property | CreditCardNumberAttempts | A fixed score is added with each extra credit card number attempts.
Public Property | DuplicateInputs | This property assigns a score based on duplicate inputs, that is inputs that are the same across seperate input fields. The likelyhood that the address would be the same as the telephone number is extremely low as such the fraudscore system can be set to treat such cases appropriately.
Public Property | FreeMail | A fixed score is added per unique email address in the order that is from a free email provider such as hotmail.com. Typically fraudulant orders originate from free email accounts.
Public Property | HomeRow | This analysis examines the total number of homerow characters used as a percentage of total inputs. A high percentage of homerow characters typically indicates that the input is fraudulent.
Public Property | InputLength | This fraudscore is a ranged formula which assigns a specific score based on the total quantity of items in the cart. In many stores order over a given quantity are unheard of and this property allows you to reflect this rarity as part of the overall fraudscore.
Public Property | IpCountry | Using the built in .netCOUNTRY support the fraudscore system is able to determine, with 90+% accuracy, the location of the visitor based on their IP address. This score is added if the supplied country does not match the country indicated.
Public Property | Items | For many ecommerce implementations certain item combinations or high profile items are rarely ordered. You may wish to assign such items or combinations a high fraudscore to ensure human processing. This is particularly true for softgood delivery. If you sell a number of softgood packages and your total number of unique items is low a combination of 1 of every package almost certainly indicates fraud. Also, if you have multiple version of a product it may be highly unlikely that they would be ordered in combination within 1 order. This property can be used to assign an appropriate fraudscrore addition for such cases.
Public Property | LetterRepeats | This property accepts a ranged formula for the score to be added based on percentage of letter repeats. Valid input would typically have a minimal repeats. Above a certain range invalid data is a certainty.
Public Property | NameOnCardMatch | A fixed score is added if the first or last name of the billing address do not match the name on the credit card. For example, if the fixed value is defined as 100 and both FirstName and LastName are located within the NameOnCard the score is not increased. If FirstName is not found, score is incremented by the fixed value and if both FirstName and LastName are not found, it is incremented by twice the fixed value.
Public Property | Quantity | This fraudscore is a ranged formula which assigns a specific score based on the total quantity of items in the cart. In many stores order over a given quantity are unheard of and this property allows you to reflect this rarity as part of the overall fraudscore.
Public Property | Symbols | This property examines the total number of symbols (non alpha-numeric) characters used as a percentage of total inputs. A high percentage of symbols typically indicates that the input is fraudulent.
Public Property | ValidMail | A fixed score is added if the email address provided is not valid. Validity is determined through a syntatical check of the address provided.
Public Property | VowelConsonant | Within any given language there is an expected ration of vowels to consonants. This property examines are ranged percentage formula and assigns the appropriate score.
Top

See Also

Reference

SettingsFraudScore Class
dotnetCART Namespace


%%PageItemTitle%%

Address Property
[image]
dotnetCART Namespace > SettingsFraudScore Class : Address Property

The score defined for this property is added if the address appears invalid. It is expected that an address will contain both letters and numbers and not be less than 10 characters in length.

Syntax

Visual Basic (Declaration)
Public Property Address As Long
C#
public long Address {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsFraudScore Class
SettingsFraudScore Members


%%PageItemTitle%%

Amount Property
See Also Example
[image]
dotnetCART Namespace > SettingsFraudScore Class : Amount Property

This fraudscore is a ranged formula which assigns a specific score based on the total dollar amount of all items in the cart. In many stores orders over a given dollar value are unheard of and this property allows you to reflect this rarity as part of the overall fraudscore.

Syntax

Visual Basic (Declaration)
Public Property Amount As String
C#
public string Amount {get; set;}

Example

C# Copy Code
cart.FraudScore.Amount="1-2=1;3-13=90;14-=1000;";

Visual Basic Copy Code
cart.FraudScore.Amount="1-2=1;3-13=90;14-=1000;"

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsFraudScore Class
SettingsFraudScore Members


%%PageItemTitle%%

AnonymousProxy Property
[image]
dotnetCART Namespace > SettingsFraudScore Class : AnonymousProxy Property

Using the built in .netCOUNTRY support the fraudscore system is able to determine if the IP address is from one of many documented anonymous proxy systems. In such a case the web user is specifically attempting to mask their identity and fraud is highly likely. The score defined for this property is added in such a case.

Syntax

Visual Basic (Declaration)
Public Property AnonymousProxy As Long
C#
public long AnonymousProxy {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsFraudScore Class
SettingsFraudScore Members


%%PageItemTitle%%

BillingShipping Property
[image]
dotnetCART Namespace > SettingsFraudScore Class : BillingShipping Property

It has been found that orders using the same address for billing and shipping are less prone to being fraudulant. For this reason this score is added if the billing and shipping addresses differ.

Syntax

Visual Basic (Declaration)
Public Property BillingShipping As Long
C#
public long BillingShipping {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsFraudScore Class
SettingsFraudScore Members


%%PageItemTitle%%

BrowserCountry Property
[image]
dotnetCART Namespace > SettingsFraudScore Class : BrowserCountry Property

Using the built in .netCOUNTRY support the fraudscore system is able to determine the country based on the users culture configuration in their web browser. If this does not match the country provided the score is added.

Syntax

Visual Basic (Declaration)
Public Property BrowserCountry As Long
C#
public long BrowserCountry {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsFraudScore Class
SettingsFraudScore Members


%%PageItemTitle%%

CreditCardCodeAttempts Property
[image]
dotnetCART Namespace > SettingsFraudScore Class : CreditCardCodeAttempts Property

A fixed score is added with each extra credit card security code attempts.

Syntax

Visual Basic (Declaration)
Public Property CreditCardCodeAttempts As Long
C#
public long CreditCardCodeAttempts {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsFraudScore Class
SettingsFraudScore Members


%%PageItemTitle%%

CreditCardExpiryAttempts Property
[image]
dotnetCART Namespace > SettingsFraudScore Class : CreditCardExpiryAttempts Property

A fixed score is added with each extra credit card expiry attempts.

Syntax

Visual Basic (Declaration)
Public Property CreditCardExpiryAttempts As Long
C#
public long CreditCardExpiryAttempts {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsFraudScore Class
SettingsFraudScore Members


%%PageItemTitle%%

CreditCardNumberAttempts Property
[image]
dotnetCART Namespace > SettingsFraudScore Class : CreditCardNumberAttempts Property

A fixed score is added with each extra credit card number attempts.

Syntax

Visual Basic (Declaration)
Public Property CreditCardNumberAttempts As Long
C#
public long CreditCardNumberAttempts {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsFraudScore Class
SettingsFraudScore Members


%%PageItemTitle%%

DuplicateInputs Property
[image]
dotnetCART Namespace > SettingsFraudScore Class : DuplicateInputs Property

This property assigns a score based on duplicate inputs, that is inputs that are the same across seperate input fields. The likelyhood that the address would be the same as the telephone number is extremely low as such the fraudscore system can be set to treat such cases appropriately.

Syntax

Visual Basic (Declaration)
Public Property DuplicateInputs As String
C#
public string DuplicateInputs {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsFraudScore Class
SettingsFraudScore Members


%%PageItemTitle%%

FreeMail Property
[image]
dotnetCART Namespace > SettingsFraudScore Class : FreeMail Property

A fixed score is added per unique email address in the order that is from a free email provider such as hotmail.com. Typically fraudulant orders originate from free email accounts.

Syntax

Visual Basic (Declaration)
Public Property FreeMail As Long
C#
public long FreeMail {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsFraudScore Class
SettingsFraudScore Members


%%PageItemTitle%%

HomeRow Property
[image]
dotnetCART Namespace > SettingsFraudScore Class : HomeRow Property

This analysis examines the total number of homerow characters used as a percentage of total inputs. A high percentage of homerow characters typically indicates that the input is fraudulent.

Syntax

Visual Basic (Declaration)
Public Property HomeRow As String
C#
public string HomeRow {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsFraudScore Class
SettingsFraudScore Members


%%PageItemTitle%%

InputLength Property
[image]
dotnetCART Namespace > SettingsFraudScore Class : InputLength Property

This fraudscore is a ranged formula which assigns a specific score based on the total quantity of items in the cart. In many stores order over a given quantity are unheard of and this property allows you to reflect this rarity as part of the overall fraudscore.

Syntax

Visual Basic (Declaration)
Public Property InputLength As String
C#
public string InputLength {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsFraudScore Class
SettingsFraudScore Members


%%PageItemTitle%%

IpCountry Property
[image]
dotnetCART Namespace > SettingsFraudScore Class : IpCountry Property

Using the built in .netCOUNTRY support the fraudscore system is able to determine, with 90+% accuracy, the location of the visitor based on their IP address. This score is added if the supplied country does not match the country indicated.

Syntax

Visual Basic (Declaration)
Public Property IpCountry As Long
C#
public long IpCountry {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsFraudScore Class
SettingsFraudScore Members


%%PageItemTitle%%

Items Property
[image]
dotnetCART Namespace > SettingsFraudScore Class : Items Property

For many ecommerce implementations certain item combinations or high profile items are rarely ordered. You may wish to assign such items or combinations a high fraudscore to ensure human processing. This is particularly true for softgood delivery. If you sell a number of softgood packages and your total number of unique items is low a combination of 1 of every package almost certainly indicates fraud. Also, if you have multiple version of a product it may be highly unlikely that they would be ordered in combination within 1 order. This property can be used to assign an appropriate fraudscrore addition for such cases.

Syntax

Visual Basic (Declaration)
Public Property Items As String
C#
public string Items {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsFraudScore Class
SettingsFraudScore Members


%%PageItemTitle%%

LetterRepeats Property
[image]
dotnetCART Namespace > SettingsFraudScore Class : LetterRepeats Property

This property accepts a ranged formula for the score to be added based on percentage of letter repeats. Valid input would typically have a minimal repeats. Above a certain range invalid data is a certainty.

Syntax

Visual Basic (Declaration)
Public Property LetterRepeats As String
C#
public string LetterRepeats {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsFraudScore Class
SettingsFraudScore Members


%%PageItemTitle%%

NameOnCardMatch Property
[image]
dotnetCART Namespace > SettingsFraudScore Class : NameOnCardMatch Property

A fixed score is added if the first or last name of the billing address do not match the name on the credit card. For example, if the fixed value is defined as 100 and both FirstName and LastName are located within the NameOnCard the score is not increased. If FirstName is not found, score is incremented by the fixed value and if both FirstName and LastName are not found, it is incremented by twice the fixed value.

Syntax

Visual Basic (Declaration)
Public Property NameOnCardMatch As Long
C#
public long NameOnCardMatch {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsFraudScore Class
SettingsFraudScore Members


%%PageItemTitle%%

Quantity Property
See Also Example
[image]
dotnetCART Namespace > SettingsFraudScore Class : Quantity Property

This fraudscore is a ranged formula which assigns a specific score based on the total quantity of items in the cart. In many stores order over a given quantity are unheard of and this property allows you to reflect this rarity as part of the overall fraudscore.

Syntax

Visual Basic (Declaration)
Public Property Quantity As String
C#
public string Quantity {get; set;}

Example

C# Copy Code
cart.FraudScore.Quantity="1-2=1;3-13=90;14-=1000;";

Visual Basic Copy Code
cart.FraudScore.Quantity="1-2=1;3-13=90;14-=1000;"

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsFraudScore Class
SettingsFraudScore Members


%%PageItemTitle%%

Symbols Property
[image]
dotnetCART Namespace > SettingsFraudScore Class : Symbols Property

This property examines the total number of symbols (non alpha-numeric) characters used as a percentage of total inputs. A high percentage of symbols typically indicates that the input is fraudulent.

Syntax

Visual Basic (Declaration)
Public Property Symbols As String
C#
public string Symbols {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsFraudScore Class
SettingsFraudScore Members


%%PageItemTitle%%

ValidMail Property
[image]
dotnetCART Namespace > SettingsFraudScore Class : ValidMail Property

A fixed score is added if the email address provided is not valid. Validity is determined through a syntatical check of the address provided.

Syntax

Visual Basic (Declaration)
Public Property ValidMail As Long
C#
public long ValidMail {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsFraudScore Class
SettingsFraudScore Members


%%PageItemTitle%%

VowelConsonant Property
[image]
dotnetCART Namespace > SettingsFraudScore Class : VowelConsonant Property

Within any given language there is an expected ration of vowels to consonants. This property examines are ranged percentage formula and assigns the appropriate score.

Syntax

Visual Basic (Declaration)
Public Property VowelConsonant As String
C#
public string VowelConsonant {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsFraudScore Class
SettingsFraudScore Members


%%PageItemTitle%%

SettingsLocation Class
See Also Members
[image]
dotnetCART Namespace : SettingsLocation Class

Location settings.

Syntax

Visual Basic (Declaration)
Public Class SettingsLocation
C#
public class SettingsLocation

Inheritance Hierarchy

System.Object
dotnetCART.SettingsLocation

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsLocation Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

SettingsLocation Class Members
See Also Properties
[image]
dotnetCART Namespace : SettingsLocation Class

The following tables list the members exposed by SettingsLocation.

Public Constructors

 | Name | Description
Public Constructor | SettingsLocation Constructor |
Top

Public Properties

 | Name | Description
Public Property | DefaultCountry | Sets or gets the default country.
Public Property | DefaultStateProvince | Sets or gets the default state/province.
Public Property | SetCountryByIP | Determines whether the default country is set by using the remote IP address or not.
Top

See Also

Reference

SettingsLocation Class
dotnetCART Namespace


%%PageItemTitle%%

SettingsLocation Constructor
[image]
dotnetCART Namespace > SettingsLocation Class : SettingsLocation Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SettingsLocation()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsLocation Class
SettingsLocation Members


%%PageItemTitle%% $$Properties$$

SettingsLocation Class Properties
[image]
dotnetCART Namespace : SettingsLocation Class

For a list of all members of this type, see SettingsLocation members.

Public Properties

 | Name | Description
Public Property | DefaultCountry | Sets or gets the default country.
Public Property | DefaultStateProvince | Sets or gets the default state/province.
Public Property | SetCountryByIP | Determines whether the default country is set by using the remote IP address or not.
Top

See Also

Reference

SettingsLocation Class
dotnetCART Namespace


%%PageItemTitle%%

DefaultCountry Property
[image]
dotnetCART Namespace > SettingsLocation Class : DefaultCountry Property

Sets or gets the default country.

Syntax

Visual Basic (Declaration)
Public Property DefaultCountry As String
C#
public string DefaultCountry {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsLocation Class
SettingsLocation Members


%%PageItemTitle%%

DefaultStateProvince Property
[image]
dotnetCART Namespace > SettingsLocation Class : DefaultStateProvince Property

Sets or gets the default state/province.

Syntax

Visual Basic (Declaration)
Public Property DefaultStateProvince As String
C#
public string DefaultStateProvince {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsLocation Class
SettingsLocation Members


%%PageItemTitle%%

SetCountryByIP Property
[image]
dotnetCART Namespace > SettingsLocation Class : SetCountryByIP Property

Determines whether the default country is set by using the remote IP address or not.

Syntax

Visual Basic (Declaration)
Public Property SetCountryByIP As Boolean
C#
public bool SetCountryByIP {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsLocation Class
SettingsLocation Members


%%PageItemTitle%%

SettingsMail Class
See Also Members
[image]
dotnetCART Namespace : SettingsMail Class

Mail settings.

Syntax

Visual Basic (Declaration)
Public Class SettingsMail
C#
public class SettingsMail

Remarks

For a typical usage, see StoreAdmin->Settings->Mail tab.

Inheritance Hierarchy

System.Object
dotnetCART.SettingsMail

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsMail Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

SettingsMail Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : SettingsMail Class

The following tables list the members exposed by SettingsMail.

Public Constructors

 | Name | Description
Public Constructor | SettingsMail Constructor |
Top

Public Properties

 | Name | Description
Public Property | AdminEmailAddress | Gets or sets the admin email address.
Public Property | AdminEmailName | Gets or sets the admin email name.
Public Property | BodyFormat | Sets the body format as text or html. The default is text.
Public Property | Password | Gets or sets the mail SMTP password.
Public Property | Port | Gets or sets the mail SMTP server port.
Public Property | Server | Gets or sets the mail SMTP server name.
Public Property | TimeZoneAdjustment | Adjusts the email time. It can be set in case mail server is different than web server for timing.
Public Property | UserName | Gets or sets the mail SMTP user name.
Public Property | UseSSL | Determines whether to use SSL for connecting to the mail server or not.
Top

Public Methods

 | Name | Description
Public Method | Load | Loads email settings from the settings configuration file specified in Settings.FileName and Settings.Path.
Public Method | Save | Saves email settings to the settings configuration file specified in Settings.FileName and Settings.Path.
Top

See Also

Reference

SettingsMail Class
dotnetCART Namespace


%%PageItemTitle%%

SettingsMail Constructor
[image]
dotnetCART Namespace > SettingsMail Class : SettingsMail Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SettingsMail()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsMail Class
SettingsMail Members


%%PageItemTitle%% $$Methods$$

SettingsMail Class Methods
[image]
dotnetCART Namespace : SettingsMail Class

For a list of all members of this type, see SettingsMail members.

Public Methods

 | Name | Description
Public Method | Load | Loads email settings from the settings configuration file specified in Settings.FileName and Settings.Path.
Public Method | Save | Saves email settings to the settings configuration file specified in Settings.FileName and Settings.Path.
Top

See Also

Reference

SettingsMail Class
dotnetCART Namespace


%%PageItemTitle%%

Load Method
[image]
dotnetCART Namespace > SettingsMail Class : Load Method

Loads email settings from the settings configuration file specified in Settings.FileName and Settings.Path.

Syntax

Visual Basic (Declaration)
Public Function Load() As Boolean
C#
public bool Load()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsMail Class
SettingsMail Members


%%PageItemTitle%%

Save Method
[image]
dotnetCART Namespace > SettingsMail Class : Save Method

Saves email settings to the settings configuration file specified in Settings.FileName and Settings.Path.

Syntax

Visual Basic (Declaration)
Public Function Save() As Boolean
C#
public bool Save()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsMail Class
SettingsMail Members


%%PageItemTitle%% $$Properties$$

SettingsMail Class Properties
[image]
dotnetCART Namespace : SettingsMail Class

For a list of all members of this type, see SettingsMail members.

Public Properties

 | Name | Description
Public Property | AdminEmailAddress | Gets or sets the admin email address.
Public Property | AdminEmailName | Gets or sets the admin email name.
Public Property | BodyFormat | Sets the body format as text or html. The default is text.
Public Property | Password | Gets or sets the mail SMTP password.
Public Property | Port | Gets or sets the mail SMTP server port.
Public Property | Server | Gets or sets the mail SMTP server name.
Public Property | TimeZoneAdjustment | Adjusts the email time. It can be set in case mail server is different than web server for timing.
Public Property | UserName | Gets or sets the mail SMTP user name.
Public Property | UseSSL | Determines whether to use SSL for connecting to the mail server or not.
Top

See Also

Reference

SettingsMail Class
dotnetCART Namespace


%%PageItemTitle%%

AdminEmailAddress Property
[image]
dotnetCART Namespace > SettingsMail Class : AdminEmailAddress Property

Gets or sets the admin email address.

Syntax

Visual Basic (Declaration)
Public Property AdminEmailAddress As String
C#
public string AdminEmailAddress {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsMail Class
SettingsMail Members


%%PageItemTitle%%

AdminEmailName Property
[image]
dotnetCART Namespace > SettingsMail Class : AdminEmailName Property

Gets or sets the admin email name.

Syntax

Visual Basic (Declaration)
Public Property AdminEmailName As String
C#
public string AdminEmailName {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsMail Class
SettingsMail Members


%%PageItemTitle%%

BodyFormat Property
[image]
dotnetCART Namespace > SettingsMail Class : BodyFormat Property

Sets the body format as text or html. The default is text.

Syntax

Visual Basic (Declaration)
Public Property BodyFormat As String
C#
public string BodyFormat {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsMail Class
SettingsMail Members


%%PageItemTitle%%

Password Property
[image]
dotnetCART Namespace > SettingsMail Class : Password Property

Gets or sets the mail SMTP password.

Syntax

Visual Basic (Declaration)
Public Property Password As String
C#
public string Password {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsMail Class
SettingsMail Members


%%PageItemTitle%%

Port Property
[image]
dotnetCART Namespace > SettingsMail Class : Port Property

Gets or sets the mail SMTP server port.

Syntax

Visual Basic (Declaration)
Public Property Port As Integer
C#
public int Port {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsMail Class
SettingsMail Members


%%PageItemTitle%%

Server Property
[image]
dotnetCART Namespace > SettingsMail Class : Server Property

Gets or sets the mail SMTP server name.

Syntax

Visual Basic (Declaration)
Public Property Server As String
C#
public string Server {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsMail Class
SettingsMail Members


%%PageItemTitle%%

TimeZoneAdjustment Property
[image]
dotnetCART Namespace > SettingsMail Class : TimeZoneAdjustment Property

Adjusts the email time. It can be set in case mail server is different than web server for timing.

Syntax

Visual Basic (Declaration)
Public Property TimeZoneAdjustment As Double
C#
public double TimeZoneAdjustment {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsMail Class
SettingsMail Members


%%PageItemTitle%%

UserName Property
[image]
dotnetCART Namespace > SettingsMail Class : UserName Property

Gets or sets the mail SMTP user name.

Syntax

Visual Basic (Declaration)
Public Property UserName As String
C#
public string UserName {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsMail Class
SettingsMail Members


%%PageItemTitle%%

UseSSL Property
[image]
dotnetCART Namespace > SettingsMail Class : UseSSL Property

Determines whether to use SSL for connecting to the mail server or not.

Syntax

Visual Basic (Declaration)
Public Property UseSSL As Boolean
C#
public bool UseSSL {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsMail Class
SettingsMail Members


%%PageItemTitle%%

SettingsPayment Class
See Also Members
[image]
dotnetCART Namespace : SettingsPayment Class

Payment settings.

Syntax

Visual Basic (Declaration)
Public Class SettingsPayment
C#
public class SettingsPayment

Remarks

For a typical usage, see payment processing.

Inheritance Hierarchy

System.Object
dotnetCART.SettingsPayment

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsPayment Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

SettingsPayment Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : SettingsPayment Class

The following tables list the members exposed by SettingsPayment.

Public Constructors

 | Name | Description
Public Constructor | SettingsPayment Constructor |
Top

Public Properties

 | Name | Description
Public Property | AcceptedCardTypes | A comma delimited string which controls which credit cards will be accepted by the prevalidator. Options: Visa, MasterCard, AMEX, Diners, Discover, JCB, Switch, Solo, Laser and Maestro.
Public Property | AccountID | Sets or gets the AccountID.
Public Property | AgentBankNumber | Sets or gets the AgentBankNumber.
Public Property | AgentChainNumber | Sets or gets the AgentChainNumber.
Public Property | ApplySecure3D | Sets an integer value to apply secure3D. It only supports for Protx, SagePay, PayflowPro and Realex.
Public Property | CancelReturnSite | Sets or gets the CancelReturnSite.
Public Property | CardNumberStorage | When database is used, this property controls how the credit card number should stored in database. Options are: Disabled, FullEncrypted, FullHashOnly, Last4Digits, FirstLast4Digits. When setting to FullEncrypted, T:EncryptionKey property must set.
Public Property | Certificate | Gets or sets the certificate.
Public Property | ImageUrl | Sets or gets the ImageUrl.
Public Property | IPNVerificationURL | Sets or gets the IPNVerificationURL.
Public Property | Login | Gets or sets the login.
Public Property | MerchantCity | Sets or gets the Merchant City.
Public Property | MerchantCountry | Sets or gets the Merchant Country.
Public Property | MerchantName | Sets or gets the Merchant Name.
Public Property | MerchantPhone | Sets or gets the Merchant Phone.
Public Property | MerchantState | Sets or gets the Merchant State.
Public Property | MerchantZipPostal | Sets or gets the Merchant ZipPostal.
Public Property | Partner | Sets or gets the Partner.
Public Property | Password | Gets or sets the Password.
Public Property | Port | Sets or gets the port.
Public Property | Processor | Sets a gateway or processor.
Public Property | Referrer | Sets or gets the Referrer.
Public Property | ReturnSite | Sets or gets the ReturnSite.
Public Property | Setting | Sets a special setting for some gateways.
Public Property | SettleHourInterval | Sets or gets the Settle Hour Interval.
Public Property | SettleInterval | Sets or gets the Settle Interval.
Public Property | StoreNumber | Sets or gets the StoreNumber.
Public Property | TerminalID | Sets or gets the TerminalID.
Public Property | TerminalNumber | Sets or gets the TerminalNumber.
Public Property | TestMode | Determines whether to use the test server or setting for the gateway/processor or not.
Public Property | Timeout | Gets or sets the time out for transaction response time. Defaults to 45 seconds.
Public Property | TimeZone | Gets or sets a TimeZone. Defauts to PST.
Public Property | TransactionKey | Sets or gets the TransactionKey.
Public Property | TransactionOrigin | Sets or gets the transaction origin.
Public Property | TransactionType | Gets or sets the transaction type.
Public Property | UserName | Sets or gets the UserName.
Top

Public Methods

 | Name | Description
Public Method | Clear | Initializes all the properties without recreating the object.
Public Method | Load | Loads payment settings from the settings configuration file specified in Settings.FileName and Settings.Path.
Public Method | Save | Saves payment settings to the settings configuration file specified in Settings.FileName and Settings.Path.
Top

See Also

Reference

SettingsPayment Class
dotnetCART Namespace


%%PageItemTitle%%

SettingsPayment Constructor
[image]
dotnetCART Namespace > SettingsPayment Class : SettingsPayment Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SettingsPayment()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsPayment Class
SettingsPayment Members


%%PageItemTitle%% $$Methods$$

SettingsPayment Class Methods
[image]
dotnetCART Namespace : SettingsPayment Class

For a list of all members of this type, see SettingsPayment members.

Public Methods

 | Name | Description
Public Method | Clear | Initializes all the properties without recreating the object.
Public Method | Load | Loads payment settings from the settings configuration file specified in Settings.FileName and Settings.Path.
Public Method | Save | Saves payment settings to the settings configuration file specified in Settings.FileName and Settings.Path.
Top

See Also

Reference

SettingsPayment Class
dotnetCART Namespace


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > SettingsPayment Class : Clear Method

Initializes all the properties without recreating the object.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsPayment Class
SettingsPayment Members


%%PageItemTitle%%

Load Method
[image]
dotnetCART Namespace > SettingsPayment Class : Load Method

Loads payment settings from the settings configuration file specified in Settings.FileName and Settings.Path.

Syntax

Visual Basic (Declaration)
Public Function Load() As Boolean
C#
public bool Load()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsPayment Class
SettingsPayment Members


%%PageItemTitle%%

Save Method
[image]
dotnetCART Namespace > SettingsPayment Class : Save Method

Saves payment settings to the settings configuration file specified in Settings.FileName and Settings.Path.

Syntax

Visual Basic (Declaration)
Public Function Save() As Boolean
C#
public bool Save()

Return Value

If returns false, check Store.Settings.Error.Message for the error information.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsPayment Class
SettingsPayment Members


%%PageItemTitle%% $$Properties$$

SettingsPayment Class Properties
[image]
dotnetCART Namespace : SettingsPayment Class

For a list of all members of this type, see SettingsPayment members.

Public Properties

 | Name | Description
Public Property | AcceptedCardTypes | A comma delimited string which controls which credit cards will be accepted by the prevalidator. Options: Visa, MasterCard, AMEX, Diners, Discover, JCB, Switch, Solo, Laser and Maestro.
Public Property | AccountID | Sets or gets the AccountID.
Public Property | AgentBankNumber | Sets or gets the AgentBankNumber.
Public Property | AgentChainNumber | Sets or gets the AgentChainNumber.
Public Property | ApplySecure3D | Sets an integer value to apply secure3D. It only supports for Protx, SagePay, PayflowPro and Realex.
Public Property | CancelReturnSite | Sets or gets the CancelReturnSite.
Public Property | CardNumberStorage | When database is used, this property controls how the credit card number should stored in database. Options are: Disabled, FullEncrypted, FullHashOnly, Last4Digits, FirstLast4Digits. When setting to FullEncrypted, T:EncryptionKey property must set.
Public Property | Certificate | Gets or sets the certificate.
Public Property | ImageUrl | Sets or gets the ImageUrl.
Public Property | IPNVerificationURL | Sets or gets the IPNVerificationURL.
Public Property | Login | Gets or sets the login.
Public Property | MerchantCity | Sets or gets the Merchant City.
Public Property | MerchantCountry | Sets or gets the Merchant Country.
Public Property | MerchantName | Sets or gets the Merchant Name.
Public Property | MerchantPhone | Sets or gets the Merchant Phone.
Public Property | MerchantState | Sets or gets the Merchant State.
Public Property | MerchantZipPostal | Sets or gets the Merchant ZipPostal.
Public Property | Partner | Sets or gets the Partner.
Public Property | Password | Gets or sets the Password.
Public Property | Port | Sets or gets the port.
Public Property | Processor | Sets a gateway or processor.
Public Property | Referrer | Sets or gets the Referrer.
Public Property | ReturnSite | Sets or gets the ReturnSite.
Public Property | Setting | Sets a special setting for some gateways.
Public Property | SettleHourInterval | Sets or gets the Settle Hour Interval.
Public Property | SettleInterval | Sets or gets the Settle Interval.
Public Property | StoreNumber | Sets or gets the StoreNumber.
Public Property | TerminalID | Sets or gets the TerminalID.
Public Property | TerminalNumber | Sets or gets the TerminalNumber.
Public Property | TestMode | Determines whether to use the test server or setting for the gateway/processor or not.
Public Property | Timeout | Gets or sets the time out for transaction response time. Defaults to 45 seconds.
Public Property | TimeZone | Gets or sets a TimeZone. Defauts to PST.
Public Property | TransactionKey | Sets or gets the TransactionKey.
Public Property | TransactionOrigin | Sets or gets the transaction origin.
Public Property | TransactionType | Gets or sets the transaction type.
Public Property | UserName | Sets or gets the UserName.
Top

See Also

Reference

SettingsPayment Class
dotnetCART Namespace


%%PageItemTitle%%

AcceptedCardTypes Property
[image]
dotnetCART Namespace > SettingsPayment Class : AcceptedCardTypes Property

A comma delimited string which controls which credit cards will be accepted by the prevalidator. Options: Visa, MasterCard, AMEX, Diners, Discover, JCB, Switch, Solo, Laser and Maestro.

Syntax

Visual Basic (Declaration)
Public Property AcceptedCardTypes As String
C#
public string AcceptedCardTypes {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsPayment Class
SettingsPayment Members


%%PageItemTitle%%

AccountID Property
[image]
dotnetCART Namespace > SettingsPayment Class : AccountID Property

Sets or gets the AccountID.

Syntax

Visual Basic (Declaration)
Public Property AccountID As String
C#
public string AccountID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsPayment Class
SettingsPayment Members


%%PageItemTitle%%

AgentBankNumber Property
[image]
dotnetCART Namespace > SettingsPayment Class : AgentBankNumber Property

Sets or gets the AgentBankNumber.

Syntax

Visual Basic (Declaration)
Public Property AgentBankNumber As Integer
C#
public int AgentBankNumber {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsPayment Class
SettingsPayment Members


%%PageItemTitle%%

AgentChainNumber Property
[image]
dotnetCART Namespace > SettingsPayment Class : AgentChainNumber Property

Sets or gets the AgentChainNumber.

Syntax

Visual Basic (Declaration)
Public Property AgentChainNumber As Integer
C#
public int AgentChainNumber {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsPayment Class
SettingsPayment Members


%%PageItemTitle%%

ApplySecure3D Property
[image]
dotnetCART Namespace > SettingsPayment Class : ApplySecure3D Property

Sets an integer value to apply secure3D. It only supports for Protx, SagePay, PayflowPro and Realex.

Syntax

Visual Basic (Declaration)
Public Property ApplySecure3D As Integer
C#
public int ApplySecure3D {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsPayment Class
SettingsPayment Members


%%PageItemTitle%%

CancelReturnSite Property
[image]
dotnetCART Namespace > SettingsPayment Class : CancelReturnSite Property

Sets or gets the CancelReturnSite.

Syntax

Visual Basic (Declaration)
Public Property CancelReturnSite As String
C#
public string CancelReturnSite {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsPayment Class
SettingsPayment Members


%%PageItemTitle%%

CardNumberStorage Property
[image]
dotnetCART Namespace > SettingsPayment Class : CardNumberStorage Property

When database is used, this property controls how the credit card number should stored in database. Options are: Disabled, FullEncrypted, FullHashOnly, Last4Digits, FirstLast4Digits. When setting to FullEncrypted, T:EncryptionKey property must set.

Syntax

Visual Basic (Declaration)
Public Property CardNumberStorage As CardNumberStorage
C#
public CardNumberStorage CardNumberStorage {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsPayment Class
SettingsPayment Members


%%PageItemTitle%%

Certificate Property
[image]
dotnetCART Namespace > SettingsPayment Class : Certificate Property

Gets or sets the certificate.

Syntax

Visual Basic (Declaration)
Public Property Certificate As String
C#
public string Certificate {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsPayment Class
SettingsPayment Members


%%PageItemTitle%%

ImageUrl Property
[image]
dotnetCART Namespace > SettingsPayment Class : ImageUrl Property

Sets or gets the ImageUrl.

Syntax

Visual Basic (Declaration)
Public Property ImageUrl As String
C#
public string ImageUrl {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsPayment Class
SettingsPayment Members


%%PageItemTitle%%

IPNVerificationURL Property
[image]
dotnetCART Namespace > SettingsPayment Class : IPNVerificationURL Property

Sets or gets the IPNVerificationURL.

Syntax

Visual Basic (Declaration)
Public Property IPNVerificationURL As String
C#
public string IPNVerificationURL {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsPayment Class
SettingsPayment Members


%%PageItemTitle%%

Login Property
[image]
dotnetCART Namespace > SettingsPayment Class : Login Property

Gets or sets the login.

Syntax

Visual Basic (Declaration)
Public Property Login As String
C#
public string Login {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsPayment Class
SettingsPayment Members


%%PageItemTitle%%

MerchantCity Property
[image]
dotnetCART Namespace > SettingsPayment Class : MerchantCity Property

Sets or gets the Merchant City.

Syntax

Visual Basic (Declaration)
Public Property MerchantCity As String
C#
public string MerchantCity {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsPayment Class
SettingsPayment Members


%%PageItemTitle%%

MerchantCountry Property
[image]
dotnetCART Namespace > SettingsPayment Class : MerchantCountry Property

Sets or gets the Merchant Country.

Syntax

Visual Basic (Declaration)
Public Property MerchantCountry As CountryCode
C#
public CountryCode MerchantCountry {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsPayment Class
SettingsPayment Members


%%PageItemTitle%%

MerchantName Property
[image]
dotnetCART Namespace > SettingsPayment Class : MerchantName Property

Sets or gets the Merchant Name.

Syntax

Visual Basic (Declaration)
Public Property MerchantName As String
C#
public string MerchantName {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsPayment Class
SettingsPayment Members


%%PageItemTitle%%

MerchantPhone Property
[image]
dotnetCART Namespace > SettingsPayment Class : MerchantPhone Property

Sets or gets the Merchant Phone.

Syntax

Visual Basic (Declaration)
Public Property MerchantPhone As String
C#
public string MerchantPhone {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsPayment Class
SettingsPayment Members


%%PageItemTitle%%

MerchantState Property
[image]
dotnetCART Namespace > SettingsPayment Class : MerchantState Property

Sets or gets the Merchant State.

Syntax

Visual Basic (Declaration)
Public Property MerchantState As String
C#
public string MerchantState {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsPayment Class
SettingsPayment Members


%%PageItemTitle%%

MerchantZipPostal Property
[image]
dotnetCART Namespace > SettingsPayment Class : MerchantZipPostal Property

Sets or gets the Merchant ZipPostal.

Syntax

Visual Basic (Declaration)
Public Property MerchantZipPostal As String
C#
public string MerchantZipPostal {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsPayment Class
SettingsPayment Members


%%PageItemTitle%%

Partner Property
[image]
dotnetCART Namespace > SettingsPayment Class : Partner Property

Sets or gets the Partner.

Syntax

Visual Basic (Declaration)
Public Property Partner As String
C#
public string Partner {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsPayment Class
SettingsPayment Members


%%PageItemTitle%%

Password Property
[image]
dotnetCART Namespace > SettingsPayment Class : Password Property

Gets or sets the Password.

Syntax

Visual Basic (Declaration)
Public Property Password As String
C#
public string Password {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsPayment Class
SettingsPayment Members


%%PageItemTitle%%

Port Property
[image]
dotnetCART Namespace > SettingsPayment Class : Port Property

Sets or gets the port.

Syntax

Visual Basic (Declaration)
Public Property Port As Integer
C#
public int Port {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsPayment Class
SettingsPayment Members


%%PageItemTitle%%

Processor Property
[image]
dotnetCART Namespace > SettingsPayment Class : Processor Property

Sets a gateway or processor.

Syntax

Visual Basic (Declaration)
Public Property Processor As String
C#
public string Processor {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsPayment Class
SettingsPayment Members


%%PageItemTitle%%

Referrer Property
[image]
dotnetCART Namespace > SettingsPayment Class : Referrer Property

Sets or gets the Referrer.

Syntax

Visual Basic (Declaration)
Public Property Referrer As String
C#
public string Referrer {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsPayment Class
SettingsPayment Members


%%PageItemTitle%%

ReturnSite Property
[image]
dotnetCART Namespace > SettingsPayment Class : ReturnSite Property

Sets or gets the ReturnSite.

Syntax

Visual Basic (Declaration)
Public Property ReturnSite As String
C#
public string ReturnSite {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsPayment Class
SettingsPayment Members


%%PageItemTitle%%

Setting Property
[image]
dotnetCART Namespace > SettingsPayment Class : Setting Property

Sets a special setting for some gateways.

Syntax

Visual Basic (Declaration)
Public Property Setting As String
C#
public string Setting {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsPayment Class
SettingsPayment Members


%%PageItemTitle%%

SettleHourInterval Property
[image]
dotnetCART Namespace > SettingsPayment Class : SettleHourInterval Property

Sets or gets the Settle Hour Interval.

Syntax

Visual Basic (Declaration)
Public Property SettleHourInterval As Double
C#
public double SettleHourInterval {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsPayment Class
SettingsPayment Members


%%PageItemTitle%%

SettleInterval Property
[image]
dotnetCART Namespace > SettingsPayment Class : SettleInterval Property

Sets or gets the Settle Interval.

Syntax

Visual Basic (Declaration)
Public Property SettleInterval As Integer
C#
public int SettleInterval {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsPayment Class
SettingsPayment Members


%%PageItemTitle%%

StoreNumber Property
[image]
dotnetCART Namespace > SettingsPayment Class : StoreNumber Property

Sets or gets the StoreNumber.

Syntax

Visual Basic (Declaration)
Public Property StoreNumber As Integer
C#
public int StoreNumber {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsPayment Class
SettingsPayment Members


%%PageItemTitle%%

TerminalID Property
[image]
dotnetCART Namespace > SettingsPayment Class : TerminalID Property

Sets or gets the TerminalID.

Syntax

Visual Basic (Declaration)
Public Property TerminalID As String
C#
public string TerminalID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsPayment Class
SettingsPayment Members


%%PageItemTitle%%

TerminalNumber Property
[image]
dotnetCART Namespace > SettingsPayment Class : TerminalNumber Property

Sets or gets the TerminalNumber.

Syntax

Visual Basic (Declaration)
Public Property TerminalNumber As Integer
C#
public int TerminalNumber {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsPayment Class
SettingsPayment Members


%%PageItemTitle%%

TestMode Property
[image]
dotnetCART Namespace > SettingsPayment Class : TestMode Property

Determines whether to use the test server or setting for the gateway/processor or not.

Syntax

Visual Basic (Declaration)
Public Property TestMode As Boolean
C#
public bool TestMode {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsPayment Class
SettingsPayment Members


%%PageItemTitle%%

Timeout Property
[image]
dotnetCART Namespace > SettingsPayment Class : Timeout Property

Gets or sets the time out for transaction response time. Defaults to 45 seconds.

Syntax

Visual Basic (Declaration)
Public Property Timeout As Integer
C#
public int Timeout {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsPayment Class
SettingsPayment Members


%%PageItemTitle%%

TimeZone Property
[image]
dotnetCART Namespace > SettingsPayment Class : TimeZone Property

Gets or sets a TimeZone. Defauts to PST.

Syntax

Visual Basic (Declaration)
Public Property TimeZone As TimeZone
C#
public TimeZone TimeZone {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsPayment Class
SettingsPayment Members


%%PageItemTitle%%

TransactionKey Property
[image]
dotnetCART Namespace > SettingsPayment Class : TransactionKey Property

Sets or gets the TransactionKey.

Syntax

Visual Basic (Declaration)
Public Property TransactionKey As String
C#
public string TransactionKey {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsPayment Class
SettingsPayment Members


%%PageItemTitle%%

TransactionOrigin Property
[image]
dotnetCART Namespace > SettingsPayment Class : TransactionOrigin Property

Sets or gets the transaction origin.

Syntax

Visual Basic (Declaration)
Public Property TransactionOrigin As String
C#
public string TransactionOrigin {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsPayment Class
SettingsPayment Members


%%PageItemTitle%%

TransactionType Property
[image]
dotnetCART Namespace > SettingsPayment Class : TransactionType Property

Gets or sets the transaction type.

Syntax

Visual Basic (Declaration)
Public Property TransactionType As String
C#
public string TransactionType {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsPayment Class
SettingsPayment Members


%%PageItemTitle%%

UserName Property
[image]
dotnetCART Namespace > SettingsPayment Class : UserName Property

Sets or gets the UserName.

Syntax

Visual Basic (Declaration)
Public Property UserName As String
C#
public string UserName {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsPayment Class
SettingsPayment Members


%%PageItemTitle%%

SettingsShip Class
See Also Members
[image]
dotnetCART Namespace : SettingsShip Class

Shipping settings.

Object Model

Syntax

Visual Basic (Declaration)
Public Class SettingsShip
C#
public class SettingsShip

Remarks

For a typical usage, see StoreAdmin->Shipping tab.

Inheritance Hierarchy

System.Object
dotnetCART.SettingsShip

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsShip Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

SettingsShip Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : SettingsShip Class

The following tables list the members exposed by SettingsShip.

Public Constructors

 | Name | Description
Public Constructor | SettingsShip Constructor |
Top

Public Properties

 | Name | Description
Public Property | AdjustRates | Adjusts realtime rates by the specified rate (fixed amount or %).
Public Property | Companies | The collection of all realtime and custom shipping companies.
Public Property | Error | Gets the error object.
Public Property | ExcludeRates | Accepts a comma delimited list of rate names. Any rate names listed here will be excluded from the return if this property is set. The LimitRates property has the opposite functionality and can be used instead of this property to control the returned rates. The rate name from the rates collection is what needs to be specified. For a list of rate names run rate without setting this property and then set this property to any rate names returned that you wish to be excluded. By default this property is not set and all available rates are returned.
Public Property | LimitRates | Accepts a comma delimited list of rate names. Only rate names listed here will be returned if this property is set. The rate name from the rates collection is what needs to be specified in this string. For a list of rate names run a rating without setting this property and then set this property to any rate names returned that you wish to be included. The rate names are not case sensitive for use with this property and can be set with or with the company name prefix. By default this property is not set and all available rates are returned.
Public Property | OriginAddress | Origin Address (shipped from).
Public Property | OriginCity | Origin City (shipped from).
Public Property | OriginCountry | Origin Country (shipped from). This must be a 2 letter country code.
Public Property | OriginName | Origin Name (shipped from).
Public Property | OriginPhone | Origin Phone (shipped from).
Public Property | OriginStateProvince | Origin State / Province (shipped from). For US and Canada this should be a 2 letter code.
Public Property | OriginZipPostal | Origin Zip / Postal Code (shipped from).
Public Property | RateBackup | If real-time rating fails for any reason (network outage etc) then the specified backup shipcompany services are applied as defined in custom rates.
Public Property | RateFailover | Rate failover defines which company will be called if a given ship company fails to return rates. This would commonly be used if you returned rates for only 1 processor but still wanted realtime rates if they did not return. You could set a failover for that 1 processor to an alternative one. Unlike backup, which ensures that rates are always returned as it accepts only algorithm based custom rates, Failover accepts either a custom rate or another real-time company name.
Public Property | Sort | The default sort order is based on price and shipcompany (Store.Settings.Shipping.sort="price,true") It gets two parameters 1) ("price" or "name" ) 2) "true" (base on shipcompany) or "false" (sort globaly). For example: Sort="name,false", will sort the collection based on service name and globally (without grouping by shipcompany)
Top

Public Methods

 | Name | Description
Public Method | Load | Loads shipping settings from the settings configuration file specified in Settings.FileName and Settings.Path.
Public Method | Save | Saves shipping settings to the settings configuration file specified in Settings.FileName and Settings.Path.
Top

See Also

Reference

SettingsShip Class
dotnetCART Namespace


%%PageItemTitle%%

SettingsShip Constructor
[image]
dotnetCART Namespace > SettingsShip Class : SettingsShip Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SettingsShip()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsShip Class
SettingsShip Members


%%PageItemTitle%% $$Methods$$

SettingsShip Class Methods
[image]
dotnetCART Namespace : SettingsShip Class

For a list of all members of this type, see SettingsShip members.

Public Methods

 | Name | Description
Public Method | Load | Loads shipping settings from the settings configuration file specified in Settings.FileName and Settings.Path.
Public Method | Save | Saves shipping settings to the settings configuration file specified in Settings.FileName and Settings.Path.
Top

See Also

Reference

SettingsShip Class
dotnetCART Namespace


%%PageItemTitle%%

Load Method
[image]
dotnetCART Namespace > SettingsShip Class : Load Method

Loads shipping settings from the settings configuration file specified in Settings.FileName and Settings.Path.

Syntax

Visual Basic (Declaration)
Public Function Load() As Boolean
C#
public bool Load()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsShip Class
SettingsShip Members


%%PageItemTitle%%

Save Method
[image]
dotnetCART Namespace > SettingsShip Class : Save Method

Saves shipping settings to the settings configuration file specified in Settings.FileName and Settings.Path.

Syntax

Visual Basic (Declaration)
Public Function Save() As Boolean
C#
public bool Save()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsShip Class
SettingsShip Members


%%PageItemTitle%% $$Properties$$

SettingsShip Class Properties
[image]
dotnetCART Namespace : SettingsShip Class

For a list of all members of this type, see SettingsShip members.

Public Properties

 | Name | Description
Public Property | AdjustRates | Adjusts realtime rates by the specified rate (fixed amount or %).
Public Property | Companies | The collection of all realtime and custom shipping companies.
Public Property | Error | Gets the error object.
Public Property | ExcludeRates | Accepts a comma delimited list of rate names. Any rate names listed here will be excluded from the return if this property is set. The LimitRates property has the opposite functionality and can be used instead of this property to control the returned rates. The rate name from the rates collection is what needs to be specified. For a list of rate names run rate without setting this property and then set this property to any rate names returned that you wish to be excluded. By default this property is not set and all available rates are returned.
Public Property | LimitRates | Accepts a comma delimited list of rate names. Only rate names listed here will be returned if this property is set. The rate name from the rates collection is what needs to be specified in this string. For a list of rate names run a rating without setting this property and then set this property to any rate names returned that you wish to be included. The rate names are not case sensitive for use with this property and can be set with or with the company name prefix. By default this property is not set and all available rates are returned.
Public Property | OriginAddress | Origin Address (shipped from).
Public Property | OriginCity | Origin City (shipped from).
Public Property | OriginCountry | Origin Country (shipped from). This must be a 2 letter country code.
Public Property | OriginName | Origin Name (shipped from).
Public Property | OriginPhone | Origin Phone (shipped from).
Public Property | OriginStateProvince | Origin State / Province (shipped from). For US and Canada this should be a 2 letter code.
Public Property | OriginZipPostal | Origin Zip / Postal Code (shipped from).
Public Property | RateBackup | If real-time rating fails for any reason (network outage etc) then the specified backup shipcompany services are applied as defined in custom rates.
Public Property | RateFailover | Rate failover defines which company will be called if a given ship company fails to return rates. This would commonly be used if you returned rates for only 1 processor but still wanted realtime rates if they did not return. You could set a failover for that 1 processor to an alternative one. Unlike backup, which ensures that rates are always returned as it accepts only algorithm based custom rates, Failover accepts either a custom rate or another real-time company name.
Public Property | Sort | The default sort order is based on price and shipcompany (Store.Settings.Shipping.sort="price,true") It gets two parameters 1) ("price" or "name" ) 2) "true" (base on shipcompany) or "false" (sort globaly). For example: Sort="name,false", will sort the collection based on service name and globally (without grouping by shipcompany)
Top

See Also

Reference

SettingsShip Class
dotnetCART Namespace


%%PageItemTitle%%

AdjustRates Property
See Also Example
[image]
dotnetCART Namespace > SettingsShip Class : AdjustRates Property

Adjusts realtime rates by the specified rate (fixed amount or %).

Syntax

Visual Basic (Declaration)
Public Property AdjustRates As String
C#
public string AdjustRates {get; set;}

Example

The follwoing code set AdjustRate:
C# Copy Code
Store.Settings.Shipping.AdjustRate = "10%";
Store.Settings.Shipping.AdjustRate = "1.25";
Store.Settings.Shipping.AdjustRate = "-5%";
Visual Basic Copy Code
Store.Settings.Shipping.AdjustRate = "10%"
Store.Settings.Shipping.AdjustRate = "1.25"
Store.Settings.Shipping.AdjustRate = "-5%"

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsShip Class
SettingsShip Members


%%PageItemTitle%%

Companies Property
[image]
dotnetCART Namespace > SettingsShip Class : Companies Property

The collection of all realtime and custom shipping companies.

Syntax

Visual Basic (Declaration)
Public Property Companies As ShipCompanies
C#
public ShipCompanies Companies {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsShip Class
SettingsShip Members


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > SettingsShip Class : Error Property

Gets the error object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsShip Class
SettingsShip Members


%%PageItemTitle%%

ExcludeRates Property
See Also Example
[image]
dotnetCART Namespace > SettingsShip Class : ExcludeRates Property

Accepts a comma delimited list of rate names. Any rate names listed here will be excluded from the return if this property is set. The LimitRates property has the opposite functionality and can be used instead of this property to control the returned rates. The rate name from the rates collection is what needs to be specified. For a list of rate names run rate without setting this property and then set this property to any rate names returned that you wish to be excluded. By default this property is not set and all available rates are returned.

Syntax

Visual Basic (Declaration)
Public Property ExcludeRates As String
C#
public string ExcludeRates {get; set;}

Example

The follwoing code set ExcludeRates:
C# Copy Code
Store.Settings.Shipping.ExcludeRates="Express";
Visual Basic Copy Code
Store.Settings.Shipping.ExcludeRates="Express"

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsShip Class
SettingsShip Members


%%PageItemTitle%%

LimitRates Property
See Also Example
[image]
dotnetCART Namespace > SettingsShip Class : LimitRates Property

Accepts a comma delimited list of rate names. Only rate names listed here will be returned if this property is set. The rate name from the rates collection is what needs to be specified in this string. For a list of rate names run a rating without setting this property and then set this property to any rate names returned that you wish to be included. The rate names are not case sensitive for use with this property and can be set with or with the company name prefix. By default this property is not set and all available rates are returned.

Syntax

Visual Basic (Declaration)
Public Property LimitRates As String
C#
public string LimitRates {get; set;}

Example

The follwoing code set LimitRates:
C# Copy Code
Store.Settings.Shipping.ExcludeRates="Express";
Visual Basic Copy Code
Store.Settings.Shipping.ExcludeRates="Express"

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsShip Class
SettingsShip Members


%%PageItemTitle%%

OriginAddress Property
[image]
dotnetCART Namespace > SettingsShip Class : OriginAddress Property

Origin Address (shipped from).

Syntax

Visual Basic (Declaration)
Public Property OriginAddress As String
C#
public string OriginAddress {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsShip Class
SettingsShip Members


%%PageItemTitle%%

OriginCity Property
[image]
dotnetCART Namespace > SettingsShip Class : OriginCity Property

Origin City (shipped from).

Syntax

Visual Basic (Declaration)
Public Property OriginCity As String
C#
public string OriginCity {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsShip Class
SettingsShip Members


%%PageItemTitle%%

OriginCountry Property
[image]
dotnetCART Namespace > SettingsShip Class : OriginCountry Property

Origin Country (shipped from). This must be a 2 letter country code.

Syntax

Visual Basic (Declaration)
Public Property OriginCountry As String
C#
public string OriginCountry {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsShip Class
SettingsShip Members


%%PageItemTitle%%

OriginName Property
[image]
dotnetCART Namespace > SettingsShip Class : OriginName Property

Origin Name (shipped from).

Syntax

Visual Basic (Declaration)
Public Property OriginName As String
C#
public string OriginName {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsShip Class
SettingsShip Members


%%PageItemTitle%%

OriginPhone Property
[image]
dotnetCART Namespace > SettingsShip Class : OriginPhone Property

Origin Phone (shipped from).

Syntax

Visual Basic (Declaration)
Public Property OriginPhone As String
C#
public string OriginPhone {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsShip Class
SettingsShip Members


%%PageItemTitle%%

OriginStateProvince Property
[image]
dotnetCART Namespace > SettingsShip Class : OriginStateProvince Property

Origin State / Province (shipped from). For US and Canada this should be a 2 letter code.

Syntax

Visual Basic (Declaration)
Public Property OriginStateProvince As String
C#
public string OriginStateProvince {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsShip Class
SettingsShip Members


%%PageItemTitle%%

OriginZipPostal Property
[image]
dotnetCART Namespace > SettingsShip Class : OriginZipPostal Property

Origin Zip / Postal Code (shipped from).

Syntax

Visual Basic (Declaration)
Public Property OriginZipPostal As String
C#
public string OriginZipPostal {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsShip Class
SettingsShip Members


%%PageItemTitle%%

RateBackup Property
See Also Example
[image]
dotnetCART Namespace > SettingsShip Class : RateBackup Property

If real-time rating fails for any reason (network outage etc) then the specified backup shipcompany services are applied as defined in custom rates.

Syntax

Visual Basic (Declaration)
Public Property RateBackup As String
C#
public string RateBackup {get; set;}

Example

The follwoing code set RateBackup:
C# Copy Code
Store.Settings.Shipping.RateBackup = "dhl=myDHL,usps=CustomUSPS";
Visual Basic Copy Code
Store.Settings.Shipping.RateBackup = "dhl=myDHL,usps=CustomUSPS"

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsShip Class
SettingsShip Members


%%PageItemTitle%%

RateFailover Property
See Also Example
[image]
dotnetCART Namespace > SettingsShip Class : RateFailover Property

Rate failover defines which company will be called if a given ship company fails to return rates. This would commonly be used if you returned rates for only 1 processor but still wanted realtime rates if they did not return. You could set a failover for that 1 processor to an alternative one. Unlike backup, which ensures that rates are always returned as it accepts only algorithm based custom rates, Failover accepts either a custom rate or another real-time company name.

Syntax

Visual Basic (Declaration)
Public Property RateFailover As String
C#
public string RateFailover {get; set;}

Example

The follwoing code set RateFailover:
C# Copy Code
Store.Settings.Shipping.RateFailOver = "usps=fedex,dhl=mycustom";
Visual Basic Copy Code
Store.Settings.Shipping.RateFailOver = "usps=fedex,dhl=mycustom"

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsShip Class
SettingsShip Members


%%PageItemTitle%%

Sort Property
See Also Example
[image]
dotnetCART Namespace > SettingsShip Class : Sort Property

The default sort order is based on price and shipcompany (Store.Settings.Shipping.sort="price,true") It gets two parameters 1) ("price" or "name" ) 2) "true" (base on shipcompany) or "false" (sort globaly). For example: Sort="name,false", will sort the collection based on service name and globally (without grouping by shipcompany)

Syntax

Visual Basic (Declaration)
Public Property Sort As String
C#
public string Sort {get; set;}

Example

The follwoing code set sort:
C# Copy Code
Store.Settings.Shipping.Sort = "name,false";
Visual Basic Copy Code
Store.Settings.Shipping.Sort = "name,false"

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsShip Class
SettingsShip Members


%%PageItemTitle%%

SettingsTax Class
See Also Members
[image]
dotnetCART Namespace : SettingsTax Class

Tax settings.

Syntax

Visual Basic (Declaration)
Public Class SettingsTax
C#
public class SettingsTax

Remarks

For a typical usage, see StoreAdmin->Locations->Taxes tab.

Inheritance Hierarchy

System.Object
dotnetCART.SettingsTax

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsTax Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

SettingsTax Class Members
See Also Properties
[image]
dotnetCART Namespace : SettingsTax Class

The following tables list the members exposed by SettingsTax.

Public Constructors

 | Name | Description
Public Constructor | SettingsTax Constructor |
Top

Public Properties

 | Name | Description
Public Property | ApplyAfterAdjust | Determines whether to apply tax after Cart.Adjust or before it in Cart.Calculate method.
Public Property | ApplyAfterCoupon | Determines whether to apply tax after Cart.TotalCoupon or before it in Cart.Calculate method.
Public Property | ApplyAfterShipping | Determines whether to apply tax after Cart.TotalShipping or before it in Cart.Calculate method.
Top

See Also

Reference

SettingsTax Class
dotnetCART Namespace


%%PageItemTitle%%

SettingsTax Constructor
[image]
dotnetCART Namespace > SettingsTax Class : SettingsTax Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SettingsTax()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsTax Class
SettingsTax Members


%%PageItemTitle%% $$Properties$$

SettingsTax Class Properties
[image]
dotnetCART Namespace : SettingsTax Class

For a list of all members of this type, see SettingsTax members.

Public Properties

 | Name | Description
Public Property | ApplyAfterAdjust | Determines whether to apply tax after Cart.Adjust or before it in Cart.Calculate method.
Public Property | ApplyAfterCoupon | Determines whether to apply tax after Cart.TotalCoupon or before it in Cart.Calculate method.
Public Property | ApplyAfterShipping | Determines whether to apply tax after Cart.TotalShipping or before it in Cart.Calculate method.
Top

See Also

Reference

SettingsTax Class
dotnetCART Namespace


%%PageItemTitle%%

ApplyAfterAdjust Property
[image]
dotnetCART Namespace > SettingsTax Class : ApplyAfterAdjust Property

Determines whether to apply tax after Cart.Adjust or before it in Cart.Calculate method.

Syntax

Visual Basic (Declaration)
Public Property ApplyAfterAdjust As Boolean
C#
public bool ApplyAfterAdjust {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsTax Class
SettingsTax Members


%%PageItemTitle%%

ApplyAfterCoupon Property
[image]
dotnetCART Namespace > SettingsTax Class : ApplyAfterCoupon Property

Determines whether to apply tax after Cart.TotalCoupon or before it in Cart.Calculate method.

Syntax

Visual Basic (Declaration)
Public Property ApplyAfterCoupon As Boolean
C#
public bool ApplyAfterCoupon {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsTax Class
SettingsTax Members


%%PageItemTitle%%

ApplyAfterShipping Property
[image]
dotnetCART Namespace > SettingsTax Class : ApplyAfterShipping Property

Determines whether to apply tax after Cart.TotalShipping or before it in Cart.Calculate method.

Syntax

Visual Basic (Declaration)
Public Property ApplyAfterShipping As Boolean
C#
public bool ApplyAfterShipping {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SettingsTax Class
SettingsTax Members


%%PageItemTitle%%

ShipCompanies Class
See Also Members
[image]
dotnetCART Namespace : ShipCompanies Class

A collection of ShipCompany objects.

Object Model

Syntax

Visual Basic (Declaration)
Public Class ShipCompanies
   Inherits ListBase(Of ShipCompany)
C#
public class ShipCompanies : ListBase<ShipCompany>

Inheritance Hierarchy

System.Object
System.Collections.Generic.List<ShipCompany>
dotnetCART.ListBase<ShipCompany>
dotnetCART.ShipCompanies

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompanies Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

ShipCompanies Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : ShipCompanies Class

The following tables list the members exposed by ShipCompanies.

Public Constructors

 | Name | Description
Public Constructor | ShipCompanies Constructor |
Top

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from dotnetCART.ListBase<ShipCompany>)
Public Property | Count | Gets the number of elements actually contained in the collection. (Inherited from dotnetCART.ListBase<ShipCompany>)
Public Property | Error | Returns an object with the error information. (Inherited from dotnetCART.ListBase<ShipCompany>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from dotnetCART.ListBase<ShipCompany>)
Top

Public Methods

 | Name | Description
Public Method | Add | Add the new shipCompany object to this collection.
Public Method | AddRange | Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetCART.ListBase<ShipCompany>)
Public Method | AsReadOnly | Returns a read-only IList wrapper for the current collection. (Inherited from dotnetCART.ListBase<ShipCompany>)
Public Method | BinarySearch | Overloaded. (Inherited from dotnetCART.ListBase<ShipCompany>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetCART.ListBase<ShipCompany>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetCART.ListBase<ShipCompany>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<ShipCompany>)
Public Method | CopyTo | Overloaded. (Inherited from dotnetCART.ListBase<ShipCompany>)
Public Method | GetCountDB | Overloaded. Gets the total number of items in the ShipCompanies table.
Public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from dotnetCART.ListBase<ShipCompany>)
Public Method | IndexOf | Overloaded. (Inherited from dotnetCART.ListBase<ShipCompany>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetCART.ListBase<ShipCompany>)
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from dotnetCART.ListBase<ShipCompany>)
Public Method | LastIndexOf | Overloaded. (Inherited from dotnetCART.ListBase<ShipCompany>)
Public Method | LoadDB | Overloaded. Loads real time, custom or all shipping companies from Shipping table.
Public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from dotnetCART.ListBase<ShipCompany>)
Public Method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from dotnetCART.ListBase<ShipCompany>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetCART.ListBase<ShipCompany>)
Public Method | RemoveRange | Removes a range of elements from the List. (Inherited from dotnetCART.ListBase<ShipCompany>)
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<ShipCompany>)
Top

See Also

Reference

ShipCompanies Class
dotnetCART Namespace


%%PageItemTitle%%

ShipCompanies Constructor
[image]
dotnetCART Namespace > ShipCompanies Class : ShipCompanies Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ShipCompanies()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompanies Class
ShipCompanies Members


%%PageItemTitle%% $$Methods$$

ShipCompanies Class Methods
[image]
dotnetCART Namespace : ShipCompanies Class

For a list of all members of this type, see ShipCompanies members.

Public Methods

 | Name | Description
Public Method | Add | Add the new shipCompany object to this collection.
Public Method | AddRange | Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetCART.ListBase<ShipCompany>)
Public Method | AsReadOnly | Returns a read-only IList wrapper for the current collection. (Inherited from dotnetCART.ListBase<ShipCompany>)
Public Method | BinarySearch | Overloaded. (Inherited from dotnetCART.ListBase<ShipCompany>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetCART.ListBase<ShipCompany>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetCART.ListBase<ShipCompany>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<ShipCompany>)
Public Method | CopyTo | Overloaded. (Inherited from dotnetCART.ListBase<ShipCompany>)
Public Method | GetCountDB | Overloaded. Gets the total number of items in the ShipCompanies table.
Public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from dotnetCART.ListBase<ShipCompany>)
Public Method | IndexOf | Overloaded. (Inherited from dotnetCART.ListBase<ShipCompany>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetCART.ListBase<ShipCompany>)
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from dotnetCART.ListBase<ShipCompany>)
Public Method | LastIndexOf | Overloaded. (Inherited from dotnetCART.ListBase<ShipCompany>)
Public Method | LoadDB | Overloaded. Loads real time, custom or all shipping companies from Shipping table.
Public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from dotnetCART.ListBase<ShipCompany>)
Public Method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from dotnetCART.ListBase<ShipCompany>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetCART.ListBase<ShipCompany>)
Public Method | RemoveRange | Removes a range of elements from the List. (Inherited from dotnetCART.ListBase<ShipCompany>)
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<ShipCompany>)
Top

See Also

Reference

ShipCompanies Class
dotnetCART Namespace


%%PageItemTitle%%

Add Method
[image]
dotnetCART Namespace > ShipCompanies Class : Add Method

shipCompany
Add the new shipCompany object to this collection.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal shipCompany As ShipCompany _
)
C#
public void Add(
   ShipCompany shipCompany
)

Parameters

shipCompany

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompanies Class
ShipCompanies Members


%%PageItemTitle%%

GetCountDB Method
[image]
dotnetCART Namespace > ShipCompanies Class : GetCountDB Method

Gets the total number of items in the ShipCompanies table.

Overload List

Overload | Description
GetCountDB() | Gets the total number of items in the ShipCompanies table.
GetCountDB(Where) | Gets the total number of items in the ShipCompanies table.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompanies Class
ShipCompanies Members


%%PageItemTitle%%

GetCountDB() Method
[image]
dotnetCART Namespace > ShipCompanies Class > GetCountDB Method : GetCountDB() Method

Gets the total number of items in the ShipCompanies table.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCountDB() As Integer
C#
public int GetCountDB()

Return Value

Returns the number of elements in the ShipCompanies table.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompanies Class
ShipCompanies Members
Overload List


%%PageItemTitle%%

GetCountDB(Where) Method
[image]
dotnetCART Namespace > ShipCompanies Class > GetCountDB Method : GetCountDB(Where) Method

whereClause
The where clause to filter the items.
Gets the total number of items in the ShipCompanies table.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCountDB( _
   ByVal whereClause As Where _
) As Integer
C#
public int GetCountDB(
   Where whereClause
)

Parameters

whereClause
The where clause to filter the items.

Return Value

Returns the number of elements in the ShipCompanies table.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompanies Class
ShipCompanies Members
Overload List


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > ShipCompanies Class : LoadDB Method

Loads real time, custom or all shipping companies from Shipping table.

Overload List

Overload | Description
LoadDB(ShipCompanyType) | Loads real time, custom or all shipping companies from Shipping table.
LoadDB(Where,Int32,Int32,String,OrderDirection) | Loads shipping compnaies from shipping table.
LoadDB() | Loads all the items from its associated table. (Inherited from dotnetCART.ListBase<ShipCompany>)
LoadDB(Where) | Loads all the items from its associated table based on the where clause. (Inherited from dotnetCART.ListBase<ShipCompany>)
LoadDB(Int32,Int32) | Loads the count number of elements from start value. (Inherited from dotnetCART.ListBase<ShipCompany>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompanies Class
ShipCompanies Members


%%PageItemTitle%%

LoadDB(ShipCompanyType) Method
[image]
dotnetCART Namespace > ShipCompanies Class > LoadDB Method : LoadDB(ShipCompanyType) Method

companyType
Filter real time or custom ship companies.
Loads real time, custom or all shipping companies from Shipping table.

Syntax

Visual Basic (Declaration)
Public Overloads Function LoadDB( _
   ByVal companyType As ShipCompanyType _
) As Integer
C#
public int LoadDB(
   ShipCompanyType companyType
)

Parameters

companyType
Filter real time or custom ship companies.

Return Value

The total number of the loaded shipping companies.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompanies Class
ShipCompanies Members
Overload List


%%PageItemTitle%%

LoadDB(Where,Int32,Int32,String,OrderDirection) Method
[image]
dotnetCART Namespace > ShipCompanies Class > LoadDB Method : LoadDB(Where,Int32,Int32,String,OrderDirection) Method

whereClause
start
count
orderBy
orderDirection
Loads shipping compnaies from shipping table.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function LoadDB( _
   ByVal whereClause As Where, _
   ByVal start As Integer, _
   ByVal count As Integer, _
   ByVal orderBy As String, _
   ByVal orderDirection As OrderDirection _
) As Integer
C#
public override int LoadDB(
   Where whereClause,
   int start,
   int count,
   string orderBy,
   OrderDirection orderDirection
)

Parameters

whereClause
start
count
orderBy
orderDirection

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompanies Class
ShipCompanies Members
Overload List


%%PageItemTitle%%

ShipCompany Class
See Also Members
[image]
dotnetCART Namespace : ShipCompany Class

Represents a ShipCompany object. .netSHIP supports an advanced custom shipping rating system for rateback and failover purposes as well as custom defined algorithm based shipping implementations. Common uses of this system include providing backup for a real-time processor, providing free shipping for certain cases, providing shipping or special messages for overweight packages that can't be rated through the realtime systems or simply to provide your own custom rating based on a variety of criteria.

Object Model

Syntax

Visual Basic (Declaration)
Public Class ShipCompany
   Inherits DbTableCart(Of ShipCompany, Long)
C#
public class ShipCompany : DbTableCart<ShipCompany, long>

Remarks

This class is used for real time and custom shipping companies. Pickup, Pack, TestMode, Ground, Login, Password and URL properties are used only for real time compnies like USPS, FedEx, CanadaPost and DHL. For more information see Shipping Foumula, Country, StateProvince, Minimum, ShipTime properties only apply for custom shipping companies.

Inheritance Hierarchy

System.Object
dotnetDATA.DbTable<Int64>
dotnetDATA.DbTable<ShipCompany, Int64>
dotnetCART.DbTableCart<ShipCompany, Int64>
dotnetCART.ShipCompany

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompany Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

ShipCompany Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : ShipCompany Class

The following tables list the members exposed by ShipCompany.

Public Constructors

 | Name | Description
Public Constructor | ShipCompany Constructor | Initializes a new instance of the ShipCompany class.
Top

Public Properties

Name | Description
Public Property | AdjustRate | Adjusts realtime rates by the specified rate (fixed amount or %).
Public Property | Company | The name of the shipping company, this name is returned in the rates collection as Company. This value must be unique and typically would not be set to any of the predefined real-time company names. If you do use a predefined company name, it will check the custom settings, for a match on country / state / province before running the real-time rating. This new feature allows you to enable multiple realtime returns for specific locations only. For example if you ship USPS to Canada, DHL international, and FedEx within the US you can have only those processors return based on destination address.
Public Property | Country | A comma delimited list of Countryvalues, if the distination country matches a value defined in this property then this custom shipping choice will be calculated and return in the rates collection. If you wish to include all countries except those listed with this property enclose the values in brackets. Note: Country and StateProvince can be used together and a rate will only return if it matches the criteria defined in both options.
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<ShipCompany, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<ShipCompany, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<ShipCompany, Int64>)
Public Property | Disabled | Determines whether this ship company is disabled or not.
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<ShipCompany, Int64>)
Public Property | Formula | Sets or gets the formula for custom shippings. Rate calculation formula based on weight, quantity or pricing ranges. This formula is built in the following way "type range = base charge + per unit charge, type range2 = base charge2 + per unit charge2 etc." Where type is w for weight (also default if no type is set), q for quantity, and $ for amount. The amount, quantity and weight are obtained by the ship level properties of the same names. Range is a numeric range such as 0-10 and can also include open ended ranges such as 10- (everything over 10). Base charge is a fixed amount for the package and the per unit charge is the value the actual w,q,$ will be multiplied by to determine that part of the rating. For example "0-5=5.25+.50,5-10=2.00+.40,10-=0+.20" Here for 0 to 5 pounds the base charge is $5.25 and they are charged $0.50 per pound on top of the base charge. Between 5 and 10 pounds the base charge is only $2.00 and they get charged $0.40 per pound. By adding a Q or $ in front of the ranges the item quantity or dollar amount would be used for the ranges in place of the weight.
Public Property | Ground | Determines if FedEx ground rates are returned along with FedEx rate calculations. Defaults to false. If you wish to return only FedEx ground then you can use FedExGround in place of FedEx the shipping company string used with the rate method / control property. This saves the overhead of calling and returning FedEx Express rates when they are not required.
Public Property | ID | Overridden. The auto number ID populated from the database.
Public Property | Login | Sets the login for real time ship companies.
Public Property | Minimum | A minimum amount that the custom rate will return, if the amount is less than the minimum, the value set will be returned instead.
Public Property | Name | Gets or sets this shipCompany's name. The name of the shipping type, this name is returned in the rates collection as Name. This value must be unique for a given company.
Public Property | Pack | Packing Options for FedEx include: 1) "FedEx Express Envelope" or "FedEx Letter" , 2) "FedEx Express Pak" or "FedEx Pak" 3) "FedEx Express Box" or "FedEx Box" , 4) "FedEx Express Tube" or "FedEx Tube" 5) "My Packaging" or "Your Packaging". The default for this property is "My Packaging"
Public Property | Password | Sets the password for USPS.
Public Property | Pickup | Pickup options for FedEx include 1) "regularpickup, 2) "requestcourier", 3) "dropbox", 4) "businessservice center" 5) "station"
Public Property | RateType | RateType options for FedEx: 1) "List, 2) "Account"
Public Property | ResidentialAddress | Determines whether the shipping address is residential or not.
Public Property | ShipTime | A time commitment or comment string set for the custom shipping rate. This string is returned in the rates collection if this custom rate is added.
Public Property | StateProvince | A comma delimited list of StateProvince values, if the distination StateProvince matches a value defined in this property then this custom shipping choice will be calculated and return in the rates collection. If you wish to include all StateProvince values except those listed here, enclose the values in brackets. Note: Country and StateProvince can be used together and a rate will only return if it matches the criteria defined in both options.
Public Property | TestMode | Determines whether use the real-time shipping test mode or not.
Public Property | Url | Enables you to override the URL used for FedEx API communication. Default value is https://gateway.fedex.com/GatewayDC" and "https://gatewaybeta.fedex.com/GatewayDC" is used for the test server. FedEx may provide you with an alternate URL in which case you shoudl use the value they provide with this property. objShip.FedExURL ="https://gatewaybeta.fedex.com/GatewayDC"
Top

Public Methods

 | Name | Description
Public Method | Clear | Overridden. Initializes all the properties without recreating the object.
Public Method | Clone | Creates a copy of the current ShipCompany
Public Method | DeleteDB | Overloaded. Overridden. Deletes all the records from Shipping table with the same Company or Name or both properties.
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<ShipCompany, Int64>)
Public Method | LoadDB | Overloaded. Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<ShipCompany, Int64>)
Public Method | SaveDB | Overloaded. Overridden. Inserts or updates this object into the Shipping table.
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<ShipCompany, Int64>)
Top

See Also

Reference

ShipCompany Class
dotnetCART Namespace


%%PageItemTitle%%

ShipCompany Constructor
[image]
dotnetCART Namespace > ShipCompany Class : ShipCompany Constructor

Initializes a new instance of the ShipCompany class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ShipCompany()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompany Class
ShipCompany Members


%%PageItemTitle%% $$Methods$$

ShipCompany Class Methods
[image]
dotnetCART Namespace : ShipCompany Class

For a list of all members of this type, see ShipCompany members.

Public Methods

 | Name | Description
Public Method | Clear | Overridden. Initializes all the properties without recreating the object.
Public Method | Clone | Creates a copy of the current ShipCompany
Public Method | DeleteDB | Overloaded. Overridden. Deletes all the records from Shipping table with the same Company or Name or both properties.
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<ShipCompany, Int64>)
Public Method | LoadDB | Overloaded. Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<ShipCompany, Int64>)
Public Method | SaveDB | Overloaded. Overridden. Inserts or updates this object into the Shipping table.
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<ShipCompany, Int64>)
Top

See Also

Reference

ShipCompany Class
dotnetCART Namespace


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > ShipCompany Class : Clear Method

Initializes all the properties without recreating the object.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Clear()
C#
public override void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompany Class
ShipCompany Members


%%PageItemTitle%%

Clone Method
[image]
dotnetCART Namespace > ShipCompany Class : Clone Method

Creates a copy of the current ShipCompany

Syntax

Visual Basic (Declaration)
Public Function Clone() As ShipCompany
C#
public ShipCompany Clone()

Return Value

Returns a ShipCompany object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompany Class
ShipCompany Members


%%PageItemTitle%%

DeleteDB Method
[image]
dotnetCART Namespace > ShipCompany Class : DeleteDB Method

Deletes all the records from Shipping table with the same Company or Name or both properties.

Overload List

Overload | Description
DeleteDB() | Deletes all the records from Shipping table with the same Company or Name or both properties.
DeleteDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompany Class
ShipCompany Members


%%PageItemTitle%%

DeleteDB() Method
[image]
dotnetCART Namespace > ShipCompany Class > DeleteDB Method : DeleteDB() Method

Deletes all the records from Shipping table with the same Company or Name or both properties.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function DeleteDB() As Integer
C#
public override int DeleteDB()

Return Value

In case of error -1, check Error property, otherwise the number of records deleted.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompany Class
ShipCompany Members
Overload List


%%PageItemTitle%%

SaveDB Method
[image]
dotnetCART Namespace > ShipCompany Class : SaveDB Method

Inserts or updates this object into the Shipping table.

Overload List

Overload | Description
SaveDB() | Inserts or updates this object into the Shipping table.
SaveDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompany Class
ShipCompany Members


%%PageItemTitle%%

SaveDB() Method
[image]
dotnetCART Namespace > ShipCompany Class > SaveDB Method : SaveDB() Method

Inserts or updates this object into the Shipping table.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function SaveDB() As Integer
C#
public override int SaveDB()

Return Value

Returns the generated ID or 1 for the update, returns -1 if failed. For the reason of fail, check the Error property.

Remarks

If ID greater than 0, it updates the associated record in the table, otherwise inserts a new record.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompany Class
ShipCompany Members
Overload List


%%PageItemTitle%% $$Properties$$

ShipCompany Class Properties
[image]
dotnetCART Namespace : ShipCompany Class

For a list of all members of this type, see ShipCompany members.

Public Properties

Name | Description
Public Property | AdjustRate | Adjusts realtime rates by the specified rate (fixed amount or %).
Public Property | Company | The name of the shipping company, this name is returned in the rates collection as Company. This value must be unique and typically would not be set to any of the predefined real-time company names. If you do use a predefined company name, it will check the custom settings, for a match on country / state / province before running the real-time rating. This new feature allows you to enable multiple realtime returns for specific locations only. For example if you ship USPS to Canada, DHL international, and FedEx within the US you can have only those processors return based on destination address.
Public Property | Country | A comma delimited list of Countryvalues, if the distination country matches a value defined in this property then this custom shipping choice will be calculated and return in the rates collection. If you wish to include all countries except those listed with this property enclose the values in brackets. Note: Country and StateProvince can be used together and a rate will only return if it matches the criteria defined in both options.
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<ShipCompany, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<ShipCompany, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<ShipCompany, Int64>)
Public Property | Disabled | Determines whether this ship company is disabled or not.
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<ShipCompany, Int64>)
Public Property | Formula | Sets or gets the formula for custom shippings. Rate calculation formula based on weight, quantity or pricing ranges. This formula is built in the following way "type range = base charge + per unit charge, type range2 = base charge2 + per unit charge2 etc." Where type is w for weight (also default if no type is set), q for quantity, and $ for amount. The amount, quantity and weight are obtained by the ship level properties of the same names. Range is a numeric range such as 0-10 and can also include open ended ranges such as 10- (everything over 10). Base charge is a fixed amount for the package and the per unit charge is the value the actual w,q,$ will be multiplied by to determine that part of the rating. For example "0-5=5.25+.50,5-10=2.00+.40,10-=0+.20" Here for 0 to 5 pounds the base charge is $5.25 and they are charged $0.50 per pound on top of the base charge. Between 5 and 10 pounds the base charge is only $2.00 and they get charged $0.40 per pound. By adding a Q or $ in front of the ranges the item quantity or dollar amount would be used for the ranges in place of the weight.
Public Property | Ground | Determines if FedEx ground rates are returned along with FedEx rate calculations. Defaults to false. If you wish to return only FedEx ground then you can use FedExGround in place of FedEx the shipping company string used with the rate method / control property. This saves the overhead of calling and returning FedEx Express rates when they are not required.
Public Property | ID | Overridden. The auto number ID populated from the database.
Public Property | Login | Sets the login for real time ship companies.
Public Property | Minimum | A minimum amount that the custom rate will return, if the amount is less than the minimum, the value set will be returned instead.
Public Property | Name | Gets or sets this shipCompany's name. The name of the shipping type, this name is returned in the rates collection as Name. This value must be unique for a given company.
Public Property | Pack | Packing Options for FedEx include: 1) "FedEx Express Envelope" or "FedEx Letter" , 2) "FedEx Express Pak" or "FedEx Pak" 3) "FedEx Express Box" or "FedEx Box" , 4) "FedEx Express Tube" or "FedEx Tube" 5) "My Packaging" or "Your Packaging". The default for this property is "My Packaging"
Public Property | Password | Sets the password for USPS.
Public Property | Pickup | Pickup options for FedEx include 1) "regularpickup, 2) "requestcourier", 3) "dropbox", 4) "businessservice center" 5) "station"
Public Property | RateType | RateType options for FedEx: 1) "List, 2) "Account"
Public Property | ResidentialAddress | Determines whether the shipping address is residential or not.
Public Property | ShipTime | A time commitment or comment string set for the custom shipping rate. This string is returned in the rates collection if this custom rate is added.
Public Property | StateProvince | A comma delimited list of StateProvince values, if the distination StateProvince matches a value defined in this property then this custom shipping choice will be calculated and return in the rates collection. If you wish to include all StateProvince values except those listed here, enclose the values in brackets. Note: Country and StateProvince can be used together and a rate will only return if it matches the criteria defined in both options.
Public Property | TestMode | Determines whether use the real-time shipping test mode or not.
Public Property | Url | Enables you to override the URL used for FedEx API communication. Default value is https://gateway.fedex.com/GatewayDC" and "https://gatewaybeta.fedex.com/GatewayDC" is used for the test server. FedEx may provide you with an alternate URL in which case you shoudl use the value they provide with this property. objShip.FedExURL ="https://gatewaybeta.fedex.com/GatewayDC"
Top

See Also

Reference

ShipCompany Class
dotnetCART Namespace


%%PageItemTitle%%

AdjustRate Property
[image]
dotnetCART Namespace > ShipCompany Class : AdjustRate Property

Adjusts realtime rates by the specified rate (fixed amount or %).

Syntax

Visual Basic (Declaration)
Public Property AdjustRate As String
C#
public string AdjustRate {get; set;}

Remarks

This property overrides the application AdjustRate setting.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompany Class
ShipCompany Members


%%PageItemTitle%%

Company Property
[image]
dotnetCART Namespace > ShipCompany Class : Company Property

The name of the shipping company, this name is returned in the rates collection as Company. This value must be unique and typically would not be set to any of the predefined real-time company names. If you do use a predefined company name, it will check the custom settings, for a match on country / state / province before running the real-time rating. This new feature allows you to enable multiple realtime returns for specific locations only. For example if you ship USPS to Canada, DHL international, and FedEx within the US you can have only those processors return based on destination address.

Syntax

Visual Basic (Declaration)
Public Property Company As String
C#
public string Company {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompany Class
ShipCompany Members


%%PageItemTitle%%

Country Property
[image]
dotnetCART Namespace > ShipCompany Class : Country Property

A comma delimited list of Countryvalues, if the distination country matches a value defined in this property then this custom shipping choice will be calculated and return in the rates collection. If you wish to include all countries except those listed with this property enclose the values in brackets. Note: Country and StateProvince can be used together and a rate will only return if it matches the criteria defined in both options.

Syntax

Visual Basic (Declaration)
Public Property Country As String
C#
public string Country {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompany Class
ShipCompany Members


%%PageItemTitle%%

Disabled Property
[image]
dotnetCART Namespace > ShipCompany Class : Disabled Property

Determines whether this ship company is disabled or not.

Syntax

Visual Basic (Declaration)
Public Property Disabled As Boolean
C#
public bool Disabled {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompany Class
ShipCompany Members


%%PageItemTitle%%

Formula Property
[image]
dotnetCART Namespace > ShipCompany Class : Formula Property

Sets or gets the formula for custom shippings. Rate calculation formula based on weight, quantity or pricing ranges. This formula is built in the following way "type range = base charge + per unit charge, type range2 = base charge2 + per unit charge2 etc." Where type is w for weight (also default if no type is set), q for quantity, and $ for amount. The amount, quantity and weight are obtained by the ship level properties of the same names. Range is a numeric range such as 0-10 and can also include open ended ranges such as 10- (everything over 10). Base charge is a fixed amount for the package and the per unit charge is the value the actual w,q,$ will be multiplied by to determine that part of the rating. For example "0-5=5.25+.50,5-10=2.00+.40,10-=0+.20" Here for 0 to 5 pounds the base charge is $5.25 and they are charged $0.50 per pound on top of the base charge. Between 5 and 10 pounds the base charge is only $2.00 and they get charged $0.40 per pound. By adding a Q or $ in front of the ranges the item quantity or dollar amount would be used for the ranges in place of the weight.

Syntax

Visual Basic (Declaration)
Public Property Formula As String
C#
public string Formula {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompany Class
ShipCompany Members


%%PageItemTitle%%

Ground Property
[image]
dotnetCART Namespace > ShipCompany Class : Ground Property

Determines if FedEx ground rates are returned along with FedEx rate calculations. Defaults to false. If you wish to return only FedEx ground then you can use FedExGround in place of FedEx the shipping company string used with the rate method / control property. This saves the overhead of calling and returning FedEx Express rates when they are not required.

Syntax

Visual Basic (Declaration)
Public Property Ground As Boolean
C#
public bool Ground {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompany Class
ShipCompany Members


%%PageItemTitle%%

ID Property
[image]
dotnetCART Namespace > ShipCompany Class : ID Property

The auto number ID populated from the database.

Syntax

Visual Basic (Declaration)
Public Overrides Property ID As Long
C#
public override long ID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompany Class
ShipCompany Members


%%PageItemTitle%%

Login Property
[image]
dotnetCART Namespace > ShipCompany Class : Login Property

Sets the login for real time ship companies.

Syntax

Visual Basic (Declaration)
Public Property Login As String
C#
public string Login {get; set;}

Remarks

For more information see Shipping

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompany Class
ShipCompany Members


%%PageItemTitle%%

Minimum Property
[image]
dotnetCART Namespace > ShipCompany Class : Minimum Property

A minimum amount that the custom rate will return, if the amount is less than the minimum, the value set will be returned instead.

Syntax

Visual Basic (Declaration)
Public Property Minimum As Single
C#
public float Minimum {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompany Class
ShipCompany Members


%%PageItemTitle%%

Name Property
[image]
dotnetCART Namespace > ShipCompany Class : Name Property

Gets or sets this shipCompany's name. The name of the shipping type, this name is returned in the rates collection as Name. This value must be unique for a given company.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompany Class
ShipCompany Members


%%PageItemTitle%%

Pack Property
[image]
dotnetCART Namespace > ShipCompany Class : Pack Property

Packing Options for FedEx include: 1) "FedEx Express Envelope" or "FedEx Letter" , 2) "FedEx Express Pak" or "FedEx Pak" 3) "FedEx Express Box" or "FedEx Box" , 4) "FedEx Express Tube" or "FedEx Tube" 5) "My Packaging" or "Your Packaging". The default for this property is "My Packaging"

Syntax

Visual Basic (Declaration)
Public Property Pack As String
C#
public string Pack {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompany Class
ShipCompany Members


%%PageItemTitle%%

Password Property
[image]
dotnetCART Namespace > ShipCompany Class : Password Property

Sets the password for USPS.

Syntax

Visual Basic (Declaration)
Public Property Password As String
C#
public string Password {get; set;}

Remarks

For more information see Shipping

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompany Class
ShipCompany Members


%%PageItemTitle%%

Pickup Property
[image]
dotnetCART Namespace > ShipCompany Class : Pickup Property

Pickup options for FedEx include 1) "regularpickup, 2) "requestcourier", 3) "dropbox", 4) "businessservice center" 5) "station"

Syntax

Visual Basic (Declaration)
Public Property Pickup As String
C#
public string Pickup {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompany Class
ShipCompany Members


%%PageItemTitle%%

RateType Property
[image]
dotnetCART Namespace > ShipCompany Class : RateType Property

RateType options for FedEx: 1) "List, 2) "Account"

Syntax

Visual Basic (Declaration)
Public Property RateType As String
C#
public string RateType {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompany Class
ShipCompany Members


%%PageItemTitle%%

ResidentialAddress Property
[image]
dotnetCART Namespace > ShipCompany Class : ResidentialAddress Property

Determines whether the shipping address is residential or not.

Syntax

Visual Basic (Declaration)
Public Property ResidentialAddress As Boolean
C#
public bool ResidentialAddress {get; set;}

Remarks

It is usually set dynamically by the customer's address.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompany Class
ShipCompany Members


%%PageItemTitle%%

ShipTime Property
[image]
dotnetCART Namespace > ShipCompany Class : ShipTime Property

A time commitment or comment string set for the custom shipping rate. This string is returned in the rates collection if this custom rate is added.

Syntax

Visual Basic (Declaration)
Public Property ShipTime As String
C#
public string ShipTime {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompany Class
ShipCompany Members


%%PageItemTitle%%

StateProvince Property
[image]
dotnetCART Namespace > ShipCompany Class : StateProvince Property

A comma delimited list of StateProvince values, if the distination StateProvince matches a value defined in this property then this custom shipping choice will be calculated and return in the rates collection. If you wish to include all StateProvince values except those listed here, enclose the values in brackets. Note: Country and StateProvince can be used together and a rate will only return if it matches the criteria defined in both options.

Syntax

Visual Basic (Declaration)
Public Property StateProvince As String
C#
public string StateProvince {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompany Class
ShipCompany Members


%%PageItemTitle%%

TestMode Property
[image]
dotnetCART Namespace > ShipCompany Class : TestMode Property

Determines whether use the real-time shipping test mode or not.

Syntax

Visual Basic (Declaration)
Public Property TestMode As Boolean
C#
public bool TestMode {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompany Class
ShipCompany Members


%%PageItemTitle%%

Url Property
[image]
dotnetCART Namespace > ShipCompany Class : Url Property

Enables you to override the URL used for FedEx API communication. Default value is https://gateway.fedex.com/GatewayDC" and "https://gatewaybeta.fedex.com/GatewayDC" is used for the test server. FedEx may provide you with an alternate URL in which case you shoudl use the value they provide with this property. objShip.FedExURL ="https://gatewaybeta.fedex.com/GatewayDC"

Syntax

Visual Basic (Declaration)
Public Property Url As String
C#
public string Url {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompany Class
ShipCompany Members


%%PageItemTitle%%

SoftGood Class
See Also Members
[image]
dotnetCART Namespace : SoftGood Class

Represents a SoftGood object.

Object Model

Syntax

Visual Basic (Declaration)
Public Class SoftGood
   Inherits DbTableCart(Of SoftGood, Long)
C#
public class SoftGood : DbTableCart<SoftGood, long>

Inheritance Hierarchy

System.Object
dotnetDATA.DbTable<Int64>
dotnetDATA.DbTable<SoftGood, Int64>
dotnetCART.DbTableCart<SoftGood, Int64>
dotnetCART.SoftGood

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGood Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

SoftGood Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : SoftGood Class

The following tables list the members exposed by SoftGood.

Public Constructors

 | Name | Description
Public Constructor | SoftGood Constructor | Initializes a new instance of the SoftGood class.
Top

Public Properties

 | Name | Description
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<SoftGood, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<SoftGood, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<SoftGood, Int64>)
Public Property | EndDate | Sets or gets the date the softgood's file download is expired.
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<SoftGood, Int64>)
Public Property | FileName | Sets or gets the softgood's file name.
Public Property | ID | Overridden. The auto number ID populated from the database.
Public Property | NoOfDownLoad | Sets or gets the number of permitted downloads.
Public Property | OrderItemID | Sets or gets the item's ID. It is ID which is an auto generated number in OrderItems table.
Public Property | Quota | Sets or gets the softgood's file download quota.
Public Property | StartDate | Sets or gets the date the softgood's file can be downloaded.
Public Property | Ticket | Sets or gets the ticket for a softgood's download file.
Top

Public Methods

 | Name | Description
Public Method | Clear | Initializes all the properties without recreating the object. (Inherited from dotnetCART.DbTableCart<SoftGood, Int64>)
Public Method | DeleteDB | Overloaded. Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<SoftGood, Int64>)
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<SoftGood, Int64>)
Public Method | LoadDB | Overloaded. Loads the softgood's download data from SoftGoods table with the matching item's ID.
Public Method | SaveDB | Overloaded. Inserts or updates this object into the database. (Inherited from dotnetCART.DbTableCart<SoftGood, Int64>)
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<SoftGood, Int64>)
Top

See Also

Reference

SoftGood Class
dotnetCART Namespace


%%PageItemTitle%%

SoftGood Constructor
[image]
dotnetCART Namespace > SoftGood Class : SoftGood Constructor

Initializes a new instance of the SoftGood class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SoftGood()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGood Class
SoftGood Members


%%PageItemTitle%% $$Methods$$

SoftGood Class Methods
[image]
dotnetCART Namespace : SoftGood Class

For a list of all members of this type, see SoftGood members.

Public Methods

 | Name | Description
Public Method | Clear | Initializes all the properties without recreating the object. (Inherited from dotnetCART.DbTableCart<SoftGood, Int64>)
Public Method | DeleteDB | Overloaded. Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<SoftGood, Int64>)
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<SoftGood, Int64>)
Public Method | LoadDB | Overloaded. Loads the softgood's download data from SoftGoods table with the matching item's ID.
Public Method | SaveDB | Overloaded. Inserts or updates this object into the database. (Inherited from dotnetCART.DbTableCart<SoftGood, Int64>)
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<SoftGood, Int64>)
Top

See Also

Reference

SoftGood Class
dotnetCART Namespace


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > SoftGood Class : LoadDB Method

Loads the softgood's download data from SoftGoods table with the matching item's ID.

Overload List

Overload | Description
LoadDB(Int64) | Loads the softgood's download data from SoftGoods table with the matching item's ID.
LoadDB() | Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<SoftGood, Int64>)
Generic LoadDB() | (Inherited from dotnetDATA.DbTable<Int64>)
Generic LoadDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGood Class
SoftGood Members


%%PageItemTitle%%

LoadDB(Int64) Method
[image]
dotnetCART Namespace > SoftGood Class > LoadDB Method : LoadDB(Int64) Method

orderItemID
It is ID which is an auto generated number in OrderItems table.
Loads the softgood's download data from SoftGoods table with the matching item's ID.

Syntax

Visual Basic (Declaration)
Public Overloads Function LoadDB( _
   ByVal orderItemID As Long _
) As Integer
C#
public int LoadDB(
   long orderItemID
)

Parameters

orderItemID
It is ID which is an auto generated number in OrderItems table.

Return Value

If a matching recored has been found, reuturns 1, otherwise 0. In case of error, returns -1, for error information, see Error property.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGood Class
SoftGood Members
Overload List


%%PageItemTitle%% $$Properties$$

SoftGood Class Properties
[image]
dotnetCART Namespace : SoftGood Class

For a list of all members of this type, see SoftGood members.

Public Properties

 | Name | Description
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<SoftGood, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<SoftGood, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<SoftGood, Int64>)
Public Property | EndDate | Sets or gets the date the softgood's file download is expired.
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<SoftGood, Int64>)
Public Property | FileName | Sets or gets the softgood's file name.
Public Property | ID | Overridden. The auto number ID populated from the database.
Public Property | NoOfDownLoad | Sets or gets the number of permitted downloads.
Public Property | OrderItemID | Sets or gets the item's ID. It is ID which is an auto generated number in OrderItems table.
Public Property | Quota | Sets or gets the softgood's file download quota.
Public Property | StartDate | Sets or gets the date the softgood's file can be downloaded.
Public Property | Ticket | Sets or gets the ticket for a softgood's download file.
Top

See Also

Reference

SoftGood Class
dotnetCART Namespace


%%PageItemTitle%%

EndDate Property
[image]
dotnetCART Namespace > SoftGood Class : EndDate Property

Sets or gets the date the softgood's file download is expired.

Syntax

Visual Basic (Declaration)
Public Property EndDate As Date
C#
public DateTime EndDate {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGood Class
SoftGood Members


%%PageItemTitle%%

FileName Property
[image]
dotnetCART Namespace > SoftGood Class : FileName Property

Sets or gets the softgood's file name.

Syntax

Visual Basic (Declaration)
Public Property FileName As String
C#
public string FileName {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGood Class
SoftGood Members


%%PageItemTitle%%

ID Property
[image]
dotnetCART Namespace > SoftGood Class : ID Property

The auto number ID populated from the database.

Syntax

Visual Basic (Declaration)
Public Overrides Property ID As Long
C#
public override long ID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGood Class
SoftGood Members


%%PageItemTitle%%

NoOfDownLoad Property
[image]
dotnetCART Namespace > SoftGood Class : NoOfDownLoad Property

Sets or gets the number of permitted downloads.

Syntax

Visual Basic (Declaration)
Public Property NoOfDownLoad As Integer
C#
public int NoOfDownLoad {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGood Class
SoftGood Members


%%PageItemTitle%%

OrderItemID Property
[image]
dotnetCART Namespace > SoftGood Class : OrderItemID Property

Sets or gets the item's ID. It is ID which is an auto generated number in OrderItems table.

Syntax

Visual Basic (Declaration)
Public Property OrderItemID As Long
C#
public long OrderItemID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGood Class
SoftGood Members


%%PageItemTitle%%

Quota Property
[image]
dotnetCART Namespace > SoftGood Class : Quota Property

Sets or gets the softgood's file download quota.

Syntax

Visual Basic (Declaration)
Public Property Quota As String
C#
public string Quota {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGood Class
SoftGood Members


%%PageItemTitle%%

StartDate Property
[image]
dotnetCART Namespace > SoftGood Class : StartDate Property

Sets or gets the date the softgood's file can be downloaded.

Syntax

Visual Basic (Declaration)
Public Property StartDate As Date
C#
public DateTime StartDate {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGood Class
SoftGood Members


%%PageItemTitle%%

Ticket Property
[image]
dotnetCART Namespace > SoftGood Class : Ticket Property

Sets or gets the ticket for a softgood's download file.

Syntax

Visual Basic (Declaration)
Public Property Ticket As String
C#
public string Ticket {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGood Class
SoftGood Members


%%PageItemTitle%%

SoftGoods Class
See Also Members
[image]
dotnetCART Namespace : SoftGoods Class

A collection of SoftGood objects.

Object Model

Syntax

Visual Basic (Declaration)
Public Class SoftGoods
   Inherits List(Of SoftGood)
C#
public class SoftGoods : List<SoftGood>

Remarks

SoftGood or digital goods delivery is now common on the internet. From software to memberships, ebooks to data of all kinds there are now thousands of goods delivered immediately without human intervention or expense. .netCART's softgood delivery system offers a two pronged approach to softgood fulfillment: 1) deliver goods in a highly convenient and flexible manner 2) minimize system abuse and fraudulent orders. Two delivery systems are offered: email attachment and file streaming. With email attachment when the order is fulfilled each package will be attached to an email and sent to the user. This is a one time operation and works best for small deliverables as many email accounts have a limit on the size of an email attachment they can receive. The second method is file streaming and this system also provides enhanced delivery and access controls. Rather than emailing the files directory this system emails download links but unlike traditional download links which could be posted on the internet these are ticket based and have limits on the total number of requests that can be made and the date they are active. For example, you could allow only a single request and then the ticket would be invalid, any subsequent request to access the file would fail. Combined with the fraudscore system .netCART is an ideal platform for softgood delivery.

Inheritance Hierarchy

System.Object
System.Collections.Generic.List<SoftGood>
dotnetCART.SoftGoods

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoods Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

SoftGoods Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : SoftGoods Class

The following tables list the members exposed by SoftGoods.

Public Constructors

 | Name | Description
Public Constructor | SoftGoods Constructor | Initializes a new instance of the SoftGoods.
Top

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing.
Public Property | CartObject | Sets the cart object.
Public Property | ContentType | The content type of the streaming file. The default is: Application/zip-compressed
Public Property | Count | Gets the number of elements actually contained in the collection.
Public Property | Directory | Sets the full or relative directory path for the softgoods files.
Public Property | Error | Returns an object with the error information.
Public Property | Item | Gets or sets the element at the specified index.
Public Property | Message | Returns a message to the end user if it fails to send the file.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds an object to the end of the collection.
Public Method | AddRange | Adds the elements of the specified collection to the end of the collection.
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List<SoftGood>)
Public Method | BinarySearch | Overloaded.
Public Method | Clear | Removes all elements from the List.
Public Method | Contains | Determines whether an element is in the List.
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<SoftGood>)
Public Method | CopyTo | Overloaded.
Public Method | CreateTicket | Overloaded. Creates a softgood ticket and saves it to SoftGoods table.
Public Method | FindIndex | Overloaded.
Public Method | FindLastIndex | Overloaded.
Public Method | GetEnumerator | Returns an enumerator that iterates through the List.
Public Method | GetFileName | Get the softgood's file name from SoftGoods table.
Public Method | IndexOf | Overloaded.
Public Method | Insert | Inserts an element into the List at the specified index.
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index.
Public Method | LastIndexOf | Overloaded.
Public Method | Remove | Removes the first occurrence of a specific object from the List.
Public Method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate.
Public Method | RemoveAt | Removes the element at the specified index of the List.
Public Method | RemoveRange | Removes a range of elements from the List.
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List.
Public Method | SendFile | Overloaded. Sends the requested file to the client.
Public Method | Sort | Overloaded.
Public Method | UpdateSoftGoodsLog | Overloaded. Creates and saves a softgood object to SoftGoodsLog table.
Top

See Also

Reference

SoftGoods Class
dotnetCART Namespace


%%PageItemTitle%%

SoftGoods Constructor
[image]
dotnetCART Namespace > SoftGoods Class : SoftGoods Constructor

Initializes a new instance of the SoftGoods.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SoftGoods()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoods Class
SoftGoods Members


%%PageItemTitle%% $$Methods$$

SoftGoods Class Methods
[image]
dotnetCART Namespace : SoftGoods Class

For a list of all members of this type, see SoftGoods members.

Public Methods

 | Name | Description
Public Method | Add | Adds an object to the end of the collection.
Public Method | AddRange | Adds the elements of the specified collection to the end of the collection.
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List<SoftGood>)
Public Method | BinarySearch | Overloaded.
Public Method | Clear | Removes all elements from the List.
Public Method | Contains | Determines whether an element is in the List.
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<SoftGood>)
Public Method | CopyTo | Overloaded.
Public Method | CreateTicket | Overloaded. Creates a softgood ticket and saves it to SoftGoods table.
Public Method | FindIndex | Overloaded.
Public Method | FindLastIndex | Overloaded.
Public Method | GetEnumerator | Returns an enumerator that iterates through the List.
Public Method | GetFileName | Get the softgood's file name from SoftGoods table.
Public Method | IndexOf | Overloaded.
Public Method | Insert | Inserts an element into the List at the specified index.
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index.
Public Method | LastIndexOf | Overloaded.
Public Method | Remove | Removes the first occurrence of a specific object from the List.
Public Method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate.
Public Method | RemoveAt | Removes the element at the specified index of the List.
Public Method | RemoveRange | Removes a range of elements from the List.
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List.
Public Method | SendFile | Overloaded. Sends the requested file to the client.
Public Method | Sort | Overloaded.
Public Method | UpdateSoftGoodsLog | Overloaded. Creates and saves a softgood object to SoftGoodsLog table.
Top

See Also

Reference

SoftGoods Class
dotnetCART Namespace


%%PageItemTitle%%

Add Method
[image]
dotnetCART Namespace > SoftGoods Class : Add Method

item
The object to be added to the end of the List. The value can be a null reference (Nothing in Visual Basic) for reference types.
Adds an object to the end of the collection.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal item As SoftGood _
)
C#
public void Add(
   SoftGood item
)

Parameters

item
The object to be added to the end of the List. The value can be a null reference (Nothing in Visual Basic) for reference types.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoods Class
SoftGoods Members


%%PageItemTitle%%

AddRange Method
[image]
dotnetCART Namespace > SoftGoods Class : AddRange Method

collection
The collection whose elements should be added to the end of the List. The collection itself cannot be a null reference (Nothing in Visual Basic), but it can contain elements that are a null reference (Nothing in Visual Basic), if type SoftGood is a reference type.
Adds the elements of the specified collection to the end of the collection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal collection As IEnumerable(Of SoftGood) _
)
C#
public void AddRange(
   IEnumerable<SoftGood> collection
)

Parameters

collection
The collection whose elements should be added to the end of the List. The collection itself cannot be a null reference (Nothing in Visual Basic), but it can contain elements that are a null reference (Nothing in Visual Basic), if type SoftGood is a reference type.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoods Class
SoftGoods Members


%%PageItemTitle%%

BinarySearch Method
[image]
dotnetCART Namespace > SoftGoods Class : BinarySearch Method

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoods Class
SoftGoods Members


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > SoftGoods Class : Clear Method

Removes all elements from the List.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoods Class
SoftGoods Members


%%PageItemTitle%%

Contains Method
[image]
dotnetCART Namespace > SoftGoods Class : Contains Method

item
The object to locate in the List. The value can be a null reference (Nothing in Visual Basic) for reference types.
Determines whether an element is in the List.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal item As SoftGood _
) As Boolean
C#
public bool Contains(
   SoftGood item
)

Parameters

item
The object to locate in the List. The value can be a null reference (Nothing in Visual Basic) for reference types.

Return Value

true if item is found in the List; otherwise, false.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoods Class
SoftGoods Members


%%PageItemTitle%%

CopyTo Method
[image]
dotnetCART Namespace > SoftGoods Class : CopyTo Method

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoods Class
SoftGoods Members


%%PageItemTitle%%

CreateTicket Method
[image]
dotnetCART Namespace > SoftGoods Class : CreateTicket Method

Creates a softgood ticket and saves it to SoftGoods table.

Overload List

Overload | Description
CreateTicket(String,String,DateTime,DateTime,Int32) | Creates a softgood ticket and saves it to SoftGoods table.
CreateTicket(String,DateTime,DateTime,Int32) | Creates a softgood ticket and saves it to SoftGoods table.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoods Class
SoftGoods Members


%%PageItemTitle%%

CreateTicket(String,String,DateTime,DateTime,Int32) Method
[image]
dotnetCART Namespace > SoftGoods Class > CreateTicket Method : CreateTicket(String,String,DateTime,DateTime,Int32) Method

orderID
Order ID for the softgood.
itemID
Softgood's item ID.
startDate
The date the softgood can be started to download.
endDate
The date the softdood's download is expired.
iNoOfDownLoad
The number of downloads for the softgood.
Creates a softgood ticket and saves it to SoftGoods table.

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateTicket( _
   ByVal orderID As String, _
   ByVal itemID As String, _
   ByVal startDate As Date, _
   ByVal endDate As Date, _
   ByVal iNoOfDownLoad As Integer _
) As String
C#
public string CreateTicket(
   string orderID,
   string itemID,
   DateTime startDate,
   DateTime endDate,
   int iNoOfDownLoad
)

Parameters

orderID
Order ID for the softgood.
itemID
Softgood's item ID.
startDate
The date the softgood can be started to download.
endDate
The date the softdood's download is expired.
iNoOfDownLoad
The number of downloads for the softgood.

Return Value

Returns the ticket. It returns empty string if there is an error. For error information, see Error property.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoods Class
SoftGoods Members
Overload List


%%PageItemTitle%%

CreateTicket(String,DateTime,DateTime,Int32) Method
[image]
dotnetCART Namespace > SoftGoods Class > CreateTicket Method : CreateTicket(String,DateTime,DateTime,Int32) Method

keyName
Softgood license key name.
startDate
The date the softgood can be started to download.
endDate
The date the softdood's download is expired.
iNoOfDownLoad
The number of downloads for the softgood.
Creates a softgood ticket and saves it to SoftGoods table.

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateTicket( _
   ByVal keyName As String, _
   ByVal startDate As Date, _
   ByVal endDate As Date, _
   ByVal iNoOfDownLoad As Integer _
) As String
C#
public string CreateTicket(
   string keyName,
   DateTime startDate,
   DateTime endDate,
   int iNoOfDownLoad
)

Parameters

keyName
Softgood license key name.
startDate
The date the softgood can be started to download.
endDate
The date the softdood's download is expired.
iNoOfDownLoad
The number of downloads for the softgood.

Return Value

Returns the ticket. It returns empty string if there is an error. For error information, see Error property.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoods Class
SoftGoods Members
Overload List


%%PageItemTitle%%

FindIndex Method
[image]
dotnetCART Namespace > SoftGoods Class : FindIndex Method

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoods Class
SoftGoods Members


%%PageItemTitle%%

FindLastIndex Method
[image]
dotnetCART Namespace > SoftGoods Class : FindLastIndex Method

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoods Class
SoftGoods Members


%%PageItemTitle%%

GetEnumerator Method
[image]
dotnetCART Namespace > SoftGoods Class : GetEnumerator Method

Returns an enumerator that iterates through the List.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As List.Enumerator(Of SoftGood)
C#
public List.Enumerator<SoftGood> GetEnumerator()

Return Value

A List.Enumerator for the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoods Class
SoftGoods Members


%%PageItemTitle%%

GetFileName Method
[image]
dotnetCART Namespace > SoftGoods Class : GetFileName Method

strTicket
The string ticket for the softgood's download.
Get the softgood's file name from SoftGoods table.

Syntax

Visual Basic (Declaration)
Public Function GetFileName( _
   ByVal strTicket As String _
) As String
C#
public string GetFileName(
   string strTicket
)

Parameters

strTicket
The string ticket for the softgood's download.

Return Value

Returns the softgood's file name. It returns empty string if the ticket is invalid, or the number of downloads exceed the number of allowable downloads or if the download date period has been expired.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoods Class
SoftGoods Members


%%PageItemTitle%%

IndexOf Method
[image]
dotnetCART Namespace > SoftGoods Class : IndexOf Method

Overload List

Overload | Description
IndexOf(SoftGood,Int32) |

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoods Class
SoftGoods Members


%%PageItemTitle%%

IndexOf(SoftGood,Int32) Method
[image]
dotnetCART Namespace > SoftGoods Class > IndexOf Method : IndexOf(SoftGood,Int32) Method

item
index

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As SoftGood, _
   ByVal index As Integer _
) As Integer
C#
public int IndexOf(
   SoftGood item,
   int index
)

Parameters

item
index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoods Class
SoftGoods Members
Overload List


%%PageItemTitle%%

Insert Method
[image]
dotnetCART Namespace > SoftGoods Class : Insert Method

index
The zero-based index at which item should be inserted.
item
The object to insert. The value can be a null reference (Nothing in Visual Basic) for reference types.
Inserts an element into the List at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As SoftGood _
)
C#
public void Insert(
   int index,
   SoftGood item
)

Parameters

index
The zero-based index at which item should be inserted.
item
The object to insert. The value can be a null reference (Nothing in Visual Basic) for reference types.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoods Class
SoftGoods Members


%%PageItemTitle%%

InsertRange Method
[image]
dotnetCART Namespace > SoftGoods Class : InsertRange Method

index
The zero-based index at which the new elements should be inserted.
collection
The collection whose elements should be inserted into the List. The collection itself cannot be a null reference (Nothing in Visual Basic), but it can contain elements that are a null reference (Nothing in Visual Basic), if type SoftGood is a reference type.
Inserts the elements of a collection into the List at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub InsertRange( _
   ByVal index As Integer, _
   ByVal collection As IEnumerable(Of SoftGood) _
)
C#
public void InsertRange(
   int index,
   IEnumerable<SoftGood> collection
)

Parameters

index
The zero-based index at which the new elements should be inserted.
collection
The collection whose elements should be inserted into the List. The collection itself cannot be a null reference (Nothing in Visual Basic), but it can contain elements that are a null reference (Nothing in Visual Basic), if type SoftGood is a reference type.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoods Class
SoftGoods Members


%%PageItemTitle%%

LastIndexOf Method
[image]
dotnetCART Namespace > SoftGoods Class : LastIndexOf Method

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoods Class
SoftGoods Members


%%PageItemTitle%%

Remove Method
[image]
dotnetCART Namespace > SoftGoods Class : Remove Method

item
The object to remove from the List. The value can be a null reference (Nothing in Visual Basic) for reference types.
Removes the first occurrence of a specific object from the List.

Syntax

Visual Basic (Declaration)
Public Function Remove( _
   ByVal item As SoftGood _
) As Boolean
C#
public bool Remove(
   SoftGood item
)

Parameters

item
The object to remove from the List. The value can be a null reference (Nothing in Visual Basic) for reference types.

Return Value

true if item is successfully removed; otherwise, false. This method also returns false if item was not found in the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoods Class
SoftGoods Members


%%PageItemTitle%%

RemoveAll Method
[image]
dotnetCART Namespace > SoftGoods Class : RemoveAll Method

match
The Predicate delegate that defines the conditions of the elements to remove.
Removes the all the elements that match the conditions defined by the specified predicate.

Syntax

Visual Basic (Declaration)
Public Function RemoveAll( _
   ByVal match As Predicate(Of SoftGood) _
) As Integer
C#
public int RemoveAll(
   Predicate<SoftGood> match
)

Parameters

match
The Predicate delegate that defines the conditions of the elements to remove.

Return Value

The number of elements removed from the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoods Class
SoftGoods Members


%%PageItemTitle%%

RemoveAt Method
[image]
dotnetCART Namespace > SoftGoods Class : RemoveAt Method

index
The zero-based index of the element to remove.
Removes the element at the specified index of the List.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index
The zero-based index of the element to remove.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoods Class
SoftGoods Members


%%PageItemTitle%%

RemoveRange Method
[image]
dotnetCART Namespace > SoftGoods Class : RemoveRange Method

index
The zero-based starting index of the range of elements to remove.
count
The number of elements to remove.
Removes a range of elements from the List.

Syntax

Visual Basic (Declaration)
Public Sub RemoveRange( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
C#
public void RemoveRange(
   int index,
   int count
)

Parameters

index
The zero-based starting index of the range of elements to remove.
count
The number of elements to remove.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoods Class
SoftGoods Members


%%PageItemTitle%%

Reverse Method
[image]
dotnetCART Namespace > SoftGoods Class : Reverse Method

Reverses the order of the elements in the entire List.

Overload List

Overload | Description
Reverse() | Reverses the order of the elements in the entire List.
Reverse(Int32,Int32) | Reverses the order of the elements in the specified range.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoods Class
SoftGoods Members


%%PageItemTitle%%

Reverse() Method
[image]
dotnetCART Namespace > SoftGoods Class > Reverse Method : Reverse() Method

Reverses the order of the elements in the entire List.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Reverse()
C#
public void Reverse()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoods Class
SoftGoods Members
Overload List


%%PageItemTitle%%

Reverse(Int32,Int32) Method
[image]
dotnetCART Namespace > SoftGoods Class > Reverse Method : Reverse(Int32,Int32) Method

index
The zero-based starting index of the range to reverse.
count
The number of elements in the range to reverse.
Reverses the order of the elements in the specified range.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Reverse( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
C#
public void Reverse(
   int index,
   int count
)

Parameters

index
The zero-based starting index of the range to reverse.
count
The number of elements in the range to reverse.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoods Class
SoftGoods Members
Overload List


%%PageItemTitle%%

SendFile Method
[image]
dotnetCART Namespace > SoftGoods Class : SendFile Method

Sends the requested file to the client.

Overload List

Overload | Description
SendFile(String) |
SendFile() | Sends the requested file to the client.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoods Class
SoftGoods Members


%%PageItemTitle%%

SendFile(String) Method
[image]
dotnetCART Namespace > SoftGoods Class > SendFile Method : SendFile(String) Method

fileNameOutput

Syntax

Visual Basic (Declaration)
Public Overloads Function SendFile( _
   ByVal fileNameOutput As String _
) As Boolean
C#
public bool SendFile(
   string fileNameOutput
)

Parameters

fileNameOutput

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoods Class
SoftGoods Members
Overload List


%%PageItemTitle%%

SendFile() Method
[image]
dotnetCART Namespace > SoftGoods Class > SendFile Method : SendFile() Method

Sends the requested file to the client.

Syntax

Visual Basic (Declaration)
Public Overloads Function SendFile() As Boolean
C#
public bool SendFile()

Return Value

Returns true if the file has been sent to the client successfully, otherwise false.

Remarks

This method retrieve the download ticket from 'ID' query string. If the ticket in the download link is invalid, or expired, it sets Message property to the strings language SoftGoods_SendFile_InvalidDownloadLinkMessage. If it fails to find the softgood's file, it sets Message property to the strings language SoftGoods_SendFile_InvalidFilePath It sets Error property if there is any error.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoods Class
SoftGoods Members
Overload List


%%PageItemTitle%%

Sort Method
[image]
dotnetCART Namespace > SoftGoods Class : Sort Method

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoods Class
SoftGoods Members


%%PageItemTitle%%

UpdateSoftGoodsLog Method
[image]
dotnetCART Namespace > SoftGoods Class : UpdateSoftGoodsLog Method

Creates and saves a softgood object to SoftGoodsLog table.

Overload List

Overload | Description
UpdateSoftGoodsLog(String) | Creates and saves a softgood object to SoftGoodsLog table.
UpdateSoftGoodsLog(String,Boolean) | Creates and saves a softgood object to SoftGoodsLog table.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoods Class
SoftGoods Members


%%PageItemTitle%%

UpdateSoftGoodsLog(String) Method
[image]
dotnetCART Namespace > SoftGoods Class > UpdateSoftGoodsLog Method : UpdateSoftGoodsLog(String) Method

strTicket
The ticket for the softgood download.
Creates and saves a softgood object to SoftGoodsLog table.

Syntax

Visual Basic (Declaration)
Public Overloads Function UpdateSoftGoodsLog( _
   ByVal strTicket As String _
) As String
C#
public string UpdateSoftGoodsLog(
   string strTicket
)

Parameters

strTicket
The ticket for the softgood download.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoods Class
SoftGoods Members
Overload List


%%PageItemTitle%%

UpdateSoftGoodsLog(String,Boolean) Method
[image]
dotnetCART Namespace > SoftGoods Class > UpdateSoftGoodsLog Method : UpdateSoftGoodsLog(String,Boolean) Method

strTicket
The ticket for the softgood download.
deliveredItem
Indicates whether the file has been sent to the client or not.
Creates and saves a softgood object to SoftGoodsLog table.

Syntax

Visual Basic (Declaration)
Public Overloads Function UpdateSoftGoodsLog( _
   ByVal strTicket As String, _
   ByVal deliveredItem As Boolean _
) As String
C#
public string UpdateSoftGoodsLog(
   string strTicket,
   bool deliveredItem
)

Parameters

strTicket
The ticket for the softgood download.
deliveredItem
Indicates whether the file has been sent to the client or not.

Remarks

This method is automatically called in SendFile method to log the number of success and failed downloads.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoods Class
SoftGoods Members
Overload List


%%PageItemTitle%% $$Properties$$

SoftGoods Class Properties
[image]
dotnetCART Namespace : SoftGoods Class

For a list of all members of this type, see SoftGoods members.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing.
Public Property | CartObject | Sets the cart object.
Public Property | ContentType | The content type of the streaming file. The default is: Application/zip-compressed
Public Property | Count | Gets the number of elements actually contained in the collection.
Public Property | Directory | Sets the full or relative directory path for the softgoods files.
Public Property | Error | Returns an object with the error information.
Public Property | Item | Gets or sets the element at the specified index.
Public Property | Message | Returns a message to the end user if it fails to send the file.
Top

See Also

Reference

SoftGoods Class
dotnetCART Namespace


%%PageItemTitle%%

Capacity Property
[image]
dotnetCART Namespace > SoftGoods Class : Capacity Property

Gets or sets the total number of elements the internal data structure can hold without resizing.

Syntax

Visual Basic (Declaration)
Public Property Capacity As Integer
C#
public int Capacity {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoods Class
SoftGoods Members


%%PageItemTitle%%

CartObject Property
[image]
dotnetCART Namespace > SoftGoods Class : CartObject Property

Sets the cart object.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property CartObject As Cart
C#
public Cart CartObject {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoods Class
SoftGoods Members


%%PageItemTitle%%

ContentType Property
[image]
dotnetCART Namespace > SoftGoods Class : ContentType Property

The content type of the streaming file. The default is: Application/zip-compressed

Syntax

Visual Basic (Declaration)
Public Property ContentType As String
C#
public string ContentType {get; set;}

Remarks

It is used in SendFile method for setting Response.ContentType.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoods Class
SoftGoods Members


%%PageItemTitle%%

Count Property
[image]
dotnetCART Namespace > SoftGoods Class : Count Property

Gets the number of elements actually contained in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoods Class
SoftGoods Members


%%PageItemTitle%%

Directory Property
[image]
dotnetCART Namespace > SoftGoods Class : Directory Property

Sets the full or relative directory path for the softgoods files.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property Directory As String
C#
public string Directory {set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoods Class
SoftGoods Members


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > SoftGoods Class : Error Property

Returns an object with the error information.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoods Class
SoftGoods Members


%%PageItemTitle%%

Item Property
[image]
dotnetCART Namespace > SoftGoods Class : Item Property

index
The zero-based index of the element to get or set.
Gets or sets the element at the specified index.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As SoftGood
C#
public SoftGood this[
   int index
]; {get; set;}

Parameters

index
The zero-based index of the element to get or set.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoods Class
SoftGoods Members


%%PageItemTitle%%

Message Property
[image]
dotnetCART Namespace > SoftGoods Class : Message Property

Returns a message to the end user if it fails to send the file.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Message As String
C#
public string Message {get;}

Remarks

This property is set in SendFile method. If the link is invalid, it is set to strings language SoftGoods_SendFile_InvalidDownloadLinkMessage. If it fails to find the softgood's file, it sets to the strings language SoftGoods_SendFile_InvalidFilePath

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoods Class
SoftGoods Members


%%PageItemTitle%%

SoftGoodsLog Class
See Also Members
[image]
dotnetCART Namespace : SoftGoodsLog Class

Represents a SoftGoodsLog object which is used for tracking softgoods downloads.

Object Model

Syntax

Visual Basic (Declaration)
Public Class SoftGoodsLog
   Inherits DbTableCart(Of SoftGoodsLog, Long)
C#
public class SoftGoodsLog : DbTableCart<SoftGoodsLog, long>

Inheritance Hierarchy

System.Object
dotnetDATA.DbTable<Int64>
dotnetDATA.DbTable<SoftGoodsLog, Int64>
dotnetCART.DbTableCart<SoftGoodsLog, Int64>
dotnetCART.SoftGoodsLog

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoodsLog Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

SoftGoodsLog Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : SoftGoodsLog Class

The following tables list the members exposed by SoftGoodsLog.

Public Constructors

 | Name | Description
Public Constructor | SoftGoodsLog Constructor | Initializes a new instance of the SoftGoodsLog class.
Top

Public Properties

 | Name | Description
Public Property | ClientIP | Sets or gets the client's IP address.
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<SoftGoodsLog, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<SoftGoodsLog, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<SoftGoodsLog, Int64>)
Public Property | Date | Sets or gets the download's date.
Public Property | Delivered | Sets or gets whether the requested file has been sent to the client or not.
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<SoftGoodsLog, Int64>)
Public Property | ID | Overridden. The auto number ID populated from the database.
Public Property | Ticket | Sets or gets the softgood download ticket.
Top

Public Methods

 | Name | Description
Public Method | Clear | Initializes all the properties without recreating the object. (Inherited from dotnetCART.DbTableCart<SoftGoodsLog, Int64>)
Public Method | Clone | Creates a copy of the current SoftGoodsLog
Public Method | DeleteDB | Overloaded. Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<SoftGoodsLog, Int64>)
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<SoftGoodsLog, Int64>)
Public Method | GetTotalDownload | Gets the total number of successful downloads for the specified ticket.
Public Method | LoadDB | Overloaded. Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<SoftGoodsLog, Int64>)
Public Method | SaveDB | Overloaded. Inserts or updates this object into the database. (Inherited from dotnetCART.DbTableCart<SoftGoodsLog, Int64>)
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<SoftGoodsLog, Int64>)
Top

See Also

Reference

SoftGoodsLog Class
dotnetCART Namespace


%%PageItemTitle%%

SoftGoodsLog Constructor
[image]
dotnetCART Namespace > SoftGoodsLog Class : SoftGoodsLog Constructor

Initializes a new instance of the SoftGoodsLog class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SoftGoodsLog()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoodsLog Class
SoftGoodsLog Members


%%PageItemTitle%% $$Methods$$

SoftGoodsLog Class Methods
[image]
dotnetCART Namespace : SoftGoodsLog Class

For a list of all members of this type, see SoftGoodsLog members.

Public Methods

 | Name | Description
Public Method | Clear | Initializes all the properties without recreating the object. (Inherited from dotnetCART.DbTableCart<SoftGoodsLog, Int64>)
Public Method | Clone | Creates a copy of the current SoftGoodsLog
Public Method | DeleteDB | Overloaded. Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<SoftGoodsLog, Int64>)
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<SoftGoodsLog, Int64>)
Public Method | GetTotalDownload | Gets the total number of successful downloads for the specified ticket.
Public Method | LoadDB | Overloaded. Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<SoftGoodsLog, Int64>)
Public Method | SaveDB | Overloaded. Inserts or updates this object into the database. (Inherited from dotnetCART.DbTableCart<SoftGoodsLog, Int64>)
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<SoftGoodsLog, Int64>)
Top

See Also

Reference

SoftGoodsLog Class
dotnetCART Namespace


%%PageItemTitle%%

Clone Method
[image]
dotnetCART Namespace > SoftGoodsLog Class : Clone Method

Creates a copy of the current SoftGoodsLog

Syntax

Visual Basic (Declaration)
Public Function Clone() As SoftGoodsLog
C#
public SoftGoodsLog Clone()

Return Value

Returns a SoftGoodsLog object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoodsLog Class
SoftGoodsLog Members


%%PageItemTitle%%

GetTotalDownload Method
[image]
dotnetCART Namespace > SoftGoodsLog Class : GetTotalDownload Method

strTicket
The string ticket for the softgood's download.
Gets the total number of successful downloads for the specified ticket.

Syntax

Visual Basic (Declaration)
Public Function GetTotalDownload( _
   ByVal strTicket As String _
) As Integer
C#
public int GetTotalDownload(
   string strTicket
)

Parameters

strTicket
The string ticket for the softgood's download.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoodsLog Class
SoftGoodsLog Members


%%PageItemTitle%% $$Properties$$

SoftGoodsLog Class Properties
[image]
dotnetCART Namespace : SoftGoodsLog Class

For a list of all members of this type, see SoftGoodsLog members.

Public Properties

 | Name | Description
Public Property | ClientIP | Sets or gets the client's IP address.
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<SoftGoodsLog, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<SoftGoodsLog, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<SoftGoodsLog, Int64>)
Public Property | Date | Sets or gets the download's date.
Public Property | Delivered | Sets or gets whether the requested file has been sent to the client or not.
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<SoftGoodsLog, Int64>)
Public Property | ID | Overridden. The auto number ID populated from the database.
Public Property | Ticket | Sets or gets the softgood download ticket.
Top

See Also

Reference

SoftGoodsLog Class
dotnetCART Namespace


%%PageItemTitle%%

ClientIP Property
[image]
dotnetCART Namespace > SoftGoodsLog Class : ClientIP Property

Sets or gets the client's IP address.

Syntax

Visual Basic (Declaration)
Public Property ClientIP As String
C#
public string ClientIP {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoodsLog Class
SoftGoodsLog Members


%%PageItemTitle%%

Date Property
[image]
dotnetCART Namespace > SoftGoodsLog Class : Date Property

Sets or gets the download's date.

Syntax

Visual Basic (Declaration)
Public Property Date As Date
C#
public DateTime Date {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoodsLog Class
SoftGoodsLog Members


%%PageItemTitle%%

Delivered Property
[image]
dotnetCART Namespace > SoftGoodsLog Class : Delivered Property

Sets or gets whether the requested file has been sent to the client or not.

Syntax

Visual Basic (Declaration)
Public Property Delivered As Boolean
C#
public bool Delivered {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoodsLog Class
SoftGoodsLog Members


%%PageItemTitle%%

ID Property
[image]
dotnetCART Namespace > SoftGoodsLog Class : ID Property

The auto number ID populated from the database.

Syntax

Visual Basic (Declaration)
Public Overrides Property ID As Long
C#
public override long ID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoodsLog Class
SoftGoodsLog Members


%%PageItemTitle%%

Ticket Property
[image]
dotnetCART Namespace > SoftGoodsLog Class : Ticket Property

Sets or gets the softgood download ticket.

Syntax

Visual Basic (Declaration)
Public Property Ticket As String
C#
public string Ticket {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoodsLog Class
SoftGoodsLog Members


%%PageItemTitle%%

StockTransaction Class
See Also Members
[image]
dotnetCART Namespace : StockTransaction Class

Represents a StockTransaction object.

Object Model

Syntax

Visual Basic (Declaration)
Public Class StockTransaction
   Inherits DbTableCart(Of StockTransaction, Long)
C#
public class StockTransaction : DbTableCart<StockTransaction, long>

Inheritance Hierarchy

System.Object
dotnetDATA.DbTable<Int64>
dotnetDATA.DbTable<StockTransaction, Int64>
dotnetCART.DbTableCart<StockTransaction, Int64>
dotnetCART.StockTransaction

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransaction Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

StockTransaction Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : StockTransaction Class

The following tables list the members exposed by StockTransaction.

Public Constructors

 | Name | Description
Public Constructor | StockTransaction Constructor | Initializes a new instance of the StockTransaction class.
Top

Public Properties

 | Name | Description
Public Property | Comment | Sets or gets a comment for this transaction.
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<StockTransaction, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<StockTransaction, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<StockTransaction, Int64>)
Public Property | Date | Sets or gets the date for this transaction.
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<StockTransaction, Int64>)
Public Property | ID | Overridden. The auto number ID populated from the database.
Public Property | ItemID | Sets or gets the itemID for this transaction.
Public Property | Quantity | Sets or gets the uantity for this transaction.
Top

Public Methods

 | Name | Description
Public Method | AdjustStockDB | Overloaded. Adjusts the stock for each item in the items collection and insert a record to StockTransactions table for each successful item stock adjustment.
Public Method | Clear | Initializes all the properties without recreating the object. (Inherited from dotnetCART.DbTableCart<StockTransaction, Int64>)
Public Method | DeleteDB | Overloaded. Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<StockTransaction, Int64>)
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<StockTransaction, Int64>)
Public Method | LoadDB | Overloaded. Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<StockTransaction, Int64>)
Public Method | SaveDB | Overloaded. Inserts or updates this object into the database. (Inherited from dotnetCART.DbTableCart<StockTransaction, Int64>)
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<StockTransaction, Int64>)
Top

See Also

Reference

StockTransaction Class
dotnetCART Namespace


%%PageItemTitle%%

StockTransaction Constructor
[image]
dotnetCART Namespace > StockTransaction Class : StockTransaction Constructor

Initializes a new instance of the StockTransaction class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public StockTransaction()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransaction Class
StockTransaction Members


%%PageItemTitle%% $$Methods$$

StockTransaction Class Methods
[image]
dotnetCART Namespace : StockTransaction Class

For a list of all members of this type, see StockTransaction members.

Public Methods

 | Name | Description
Public Method | AdjustStockDB | Overloaded. Adjusts the stock for each item in the items collection and insert a record to StockTransactions table for each successful item stock adjustment.
Public Method | Clear | Initializes all the properties without recreating the object. (Inherited from dotnetCART.DbTableCart<StockTransaction, Int64>)
Public Method | DeleteDB | Overloaded. Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<StockTransaction, Int64>)
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<StockTransaction, Int64>)
Public Method | LoadDB | Overloaded. Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<StockTransaction, Int64>)
Public Method | SaveDB | Overloaded. Inserts or updates this object into the database. (Inherited from dotnetCART.DbTableCart<StockTransaction, Int64>)
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<StockTransaction, Int64>)
Top

See Also

Reference

StockTransaction Class
dotnetCART Namespace


%%PageItemTitle%%

AdjustStockDB Method
[image]
dotnetCART Namespace > StockTransaction Class : AdjustStockDB Method

Adjusts the stock for each item in the items collection and insert a record to StockTransactions table for each successful item stock adjustment.

Overload List

Overload | Description
AdjustStockDB(Items,Boolean) | Adjusts the stock for each item in the items collection and insert a record to StockTransactions table for each successful item stock adjustment.
AdjustStockDB(Items) | Adjusts the stock for each item in the items collection and insert a record to StockTransactions table for each successful item stock adjustment.
AdjustStockDB() | Adjusts the Quantity value to the item stock with ItemID property and insert a record to StockTransactions table after successfully adjusted the item stock.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransaction Class
StockTransaction Members


%%PageItemTitle%%

AdjustStockDB(Items,Boolean) Method
[image]
dotnetCART Namespace > StockTransaction Class > AdjustStockDB Method : AdjustStockDB(Items,Boolean) Method

itemCollection
A items collection.
rollback
Determines whether to rollback the ajustment or not.
Adjusts the stock for each item in the items collection and insert a record to StockTransactions table for each successful item stock adjustment.

Syntax

Visual Basic (Declaration)
Public Overloads Function AdjustStockDB( _
   ByVal itemCollection As Items, _
   ByVal rollback As Boolean _
) As Boolean
C#
public bool AdjustStockDB(
   Items itemCollection,
   bool rollback
)

Parameters

itemCollection
A items collection.
rollback
Determines whether to rollback the ajustment or not.

Return Value

If returns false, check Error.Message for more information.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransaction Class
StockTransaction Members
Overload List


%%PageItemTitle%%

AdjustStockDB(Items) Method
[image]
dotnetCART Namespace > StockTransaction Class > AdjustStockDB Method : AdjustStockDB(Items) Method

itemCollection
A items collection.
Adjusts the stock for each item in the items collection and insert a record to StockTransactions table for each successful item stock adjustment.

Syntax

Visual Basic (Declaration)
Public Overloads Function AdjustStockDB( _
   ByVal itemCollection As Items _
) As Boolean
C#
public bool AdjustStockDB(
   Items itemCollection
)

Parameters

itemCollection
A items collection.

Return Value

If returns false, check Error.Message for more information.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransaction Class
StockTransaction Members
Overload List


%%PageItemTitle%%

AdjustStockDB() Method
[image]
dotnetCART Namespace > StockTransaction Class > AdjustStockDB Method : AdjustStockDB() Method

Adjusts the Quantity value to the item stock with ItemID property and insert a record to StockTransactions table after successfully adjusted the item stock.

Syntax

Visual Basic (Declaration)
Public Overloads Function AdjustStockDB() As Boolean
C#
public bool AdjustStockDB()

Return Value

If returns false, check Error.Message for more information.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransaction Class
StockTransaction Members
Overload List


%%PageItemTitle%% $$Properties$$

StockTransaction Class Properties
[image]
dotnetCART Namespace : StockTransaction Class

For a list of all members of this type, see StockTransaction members.

Public Properties

 | Name | Description
Public Property | Comment | Sets or gets a comment for this transaction.
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<StockTransaction, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<StockTransaction, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<StockTransaction, Int64>)
Public Property | Date | Sets or gets the date for this transaction.
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<StockTransaction, Int64>)
Public Property | ID | Overridden. The auto number ID populated from the database.
Public Property | ItemID | Sets or gets the itemID for this transaction.
Public Property | Quantity | Sets or gets the uantity for this transaction.
Top

See Also

Reference

StockTransaction Class
dotnetCART Namespace


%%PageItemTitle%%

Comment Property
[image]
dotnetCART Namespace > StockTransaction Class : Comment Property

Sets or gets a comment for this transaction.

Syntax

Visual Basic (Declaration)
Public Property Comment As String
C#
public string Comment {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransaction Class
StockTransaction Members


%%PageItemTitle%%

Date Property
[image]
dotnetCART Namespace > StockTransaction Class : Date Property

Sets or gets the date for this transaction.

Syntax

Visual Basic (Declaration)
Public Property Date As Date
C#
public DateTime Date {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransaction Class
StockTransaction Members


%%PageItemTitle%%

ID Property
[image]
dotnetCART Namespace > StockTransaction Class : ID Property

The auto number ID populated from the database.

Syntax

Visual Basic (Declaration)
Public Overrides Property ID As Long
C#
public override long ID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransaction Class
StockTransaction Members


%%PageItemTitle%%

ItemID Property
[image]
dotnetCART Namespace > StockTransaction Class : ItemID Property

Sets or gets the itemID for this transaction.

Syntax

Visual Basic (Declaration)
Public Property ItemID As String
C#
public string ItemID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransaction Class
StockTransaction Members


%%PageItemTitle%%

Quantity Property
[image]
dotnetCART Namespace > StockTransaction Class : Quantity Property

Sets or gets the uantity for this transaction.

Syntax

Visual Basic (Declaration)
Public Property Quantity As Double
C#
public double Quantity {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransaction Class
StockTransaction Members


%%PageItemTitle%%

StockTransactions Class
See Also Members
[image]
dotnetCART Namespace : StockTransactions Class

A collection of StockTransaction objects.

Object Model

Syntax

Visual Basic (Declaration)
Public Class StockTransactions
   Inherits ListBase(Of StockTransaction)
C#
public class StockTransactions : ListBase<StockTransaction>

Inheritance Hierarchy

System.Object
System.Collections.Generic.List<StockTransaction>
dotnetCART.ListBase<StockTransaction>
dotnetCART.StockTransactions

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransactions Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

StockTransactions Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : StockTransactions Class

The following tables list the members exposed by StockTransactions.

Public Constructors

 | Name | Description
Public Constructor | StockTransactions Constructor | Initializes a new instance of the StockTransactions class.
Top

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from dotnetCART.ListBase<StockTransaction>)
Public Property | Count | Gets the number of elements actually contained in the collection. (Inherited from dotnetCART.ListBase<StockTransaction>)
Public Property | Error | Returns an object with the error information. (Inherited from dotnetCART.ListBase<StockTransaction>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from dotnetCART.ListBase<StockTransaction>)
Top

Public Methods

 | Name | Description
Public Method | Add | Adds an object to the end of the collection. (Inherited from dotnetCART.ListBase<StockTransaction>)
Public Method | AddRange | Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetCART.ListBase<StockTransaction>)
Public Method | AsReadOnly | Returns a read-only IList wrapper for the current collection. (Inherited from dotnetCART.ListBase<StockTransaction>)
Public Method | BinarySearch | Overloaded. (Inherited from dotnetCART.ListBase<StockTransaction>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetCART.ListBase<StockTransaction>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetCART.ListBase<StockTransaction>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<StockTransaction>)
Public Method | CopyTo | Overloaded. (Inherited from dotnetCART.ListBase<StockTransaction>)
Public Method | GetCountDB | Overloaded. Gets the total number of items in the StockTransactions table.
Public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from dotnetCART.ListBase<StockTransaction>)
Public Method | IndexOf | Overloaded. (Inherited from dotnetCART.ListBase<StockTransaction>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetCART.ListBase<StockTransaction>)
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from dotnetCART.ListBase<StockTransaction>)
Public Method | LastIndexOf | Overloaded. (Inherited from dotnetCART.ListBase<StockTransaction>)
Public Method | LoadDB | Overloaded. Loads all the stock transactions for this itemID.
Public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from dotnetCART.ListBase<StockTransaction>)
Public Method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from dotnetCART.ListBase<StockTransaction>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetCART.ListBase<StockTransaction>)
Public Method | RemoveRange | Removes a range of elements from the List. (Inherited from dotnetCART.ListBase<StockTransaction>)
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<StockTransaction>)
Top

See Also

Reference

StockTransactions Class
dotnetCART Namespace


%%PageItemTitle%%

StockTransactions Constructor
[image]
dotnetCART Namespace > StockTransactions Class : StockTransactions Constructor

Initializes a new instance of the StockTransactions class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public StockTransactions()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransactions Class
StockTransactions Members


%%PageItemTitle%% $$Methods$$

StockTransactions Class Methods
[image]
dotnetCART Namespace : StockTransactions Class

For a list of all members of this type, see StockTransactions members.

Public Methods

 | Name | Description
Public Method | Add | Adds an object to the end of the collection. (Inherited from dotnetCART.ListBase<StockTransaction>)
Public Method | AddRange | Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetCART.ListBase<StockTransaction>)
Public Method | AsReadOnly | Returns a read-only IList wrapper for the current collection. (Inherited from dotnetCART.ListBase<StockTransaction>)
Public Method | BinarySearch | Overloaded. (Inherited from dotnetCART.ListBase<StockTransaction>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetCART.ListBase<StockTransaction>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetCART.ListBase<StockTransaction>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<StockTransaction>)
Public Method | CopyTo | Overloaded. (Inherited from dotnetCART.ListBase<StockTransaction>)
Public Method | GetCountDB | Overloaded. Gets the total number of items in the StockTransactions table.
Public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from dotnetCART.ListBase<StockTransaction>)
Public Method | IndexOf | Overloaded. (Inherited from dotnetCART.ListBase<StockTransaction>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetCART.ListBase<StockTransaction>)
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from dotnetCART.ListBase<StockTransaction>)
Public Method | LastIndexOf | Overloaded. (Inherited from dotnetCART.ListBase<StockTransaction>)
Public Method | LoadDB | Overloaded. Loads all the stock transactions for this itemID.
Public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from dotnetCART.ListBase<StockTransaction>)
Public Method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from dotnetCART.ListBase<StockTransaction>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetCART.ListBase<StockTransaction>)
Public Method | RemoveRange | Removes a range of elements from the List. (Inherited from dotnetCART.ListBase<StockTransaction>)
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<StockTransaction>)
Top

See Also

Reference

StockTransactions Class
dotnetCART Namespace


%%PageItemTitle%%

GetCountDB Method
[image]
dotnetCART Namespace > StockTransactions Class : GetCountDB Method

Gets the total number of items in the StockTransactions table.

Overload List

Overload | Description
GetCountDB() | Gets the total number of items in the StockTransactions table.
GetCountDB(Where) | Gets the total number of items in the StockTransactions table.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransactions Class
StockTransactions Members


%%PageItemTitle%%

GetCountDB() Method
[image]
dotnetCART Namespace > StockTransactions Class > GetCountDB Method : GetCountDB() Method

Gets the total number of items in the StockTransactions table.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCountDB() As Integer
C#
public int GetCountDB()

Return Value

Returns the number of elements in the StockTransactions table.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransactions Class
StockTransactions Members
Overload List


%%PageItemTitle%%

GetCountDB(Where) Method
[image]
dotnetCART Namespace > StockTransactions Class > GetCountDB Method : GetCountDB(Where) Method

whereClause
The where clause to filter the items.
Gets the total number of items in the StockTransactions table.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCountDB( _
   ByVal whereClause As Where _
) As Integer
C#
public int GetCountDB(
   Where whereClause
)

Parameters

whereClause
The where clause to filter the items.

Return Value

Returns the number of elements in the StockTransactions table.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransactions Class
StockTransactions Members
Overload List


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > StockTransactions Class : LoadDB Method

Loads all the stock transactions for this itemID.

Overload List

Overload | Description
LoadDB(String) | Loads all the stock transactions for this itemID.
LoadDB(Where,Int32,Int32,String,OrderDirection) | Loads all the items based on the parameters from StockTransactions table.
LoadDB(String,Where,Int32,Int32,String,OrderDirection) | Loads all the items based on the parameters from StockTransactions table.
LoadDB() | Loads all the items from its associated table. (Inherited from dotnetCART.ListBase<StockTransaction>)
LoadDB(Where) | Loads all the items from its associated table based on the where clause. (Inherited from dotnetCART.ListBase<StockTransaction>)
LoadDB(Int32,Int32) | Loads the count number of elements from start value. (Inherited from dotnetCART.ListBase<StockTransaction>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransactions Class
StockTransactions Members


%%PageItemTitle%%

LoadDB(String) Method
[image]
dotnetCART Namespace > StockTransactions Class > LoadDB Method : LoadDB(String) Method

itemID
A string itemID.
Loads all the stock transactions for this itemID.

Syntax

Visual Basic (Declaration)
Public Overloads Function LoadDB( _
   ByVal itemID As String _
) As Integer
C#
public int LoadDB(
   string itemID
)

Parameters

itemID
A string itemID.

Return Value

The total number of items have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransactions Class
StockTransactions Members
Overload List


%%PageItemTitle%%

LoadDB(Where,Int32,Int32,String,OrderDirection) Method
[image]
dotnetCART Namespace > StockTransactions Class > LoadDB Method : LoadDB(Where,Int32,Int32,String,OrderDirection) Method

whereClause
The where clause to filter the items.
start
The start page which starts from 0.
count
The number of items in the page.
orderBy
The order of the loaded items.
orderDirection
The order direction of the loaded items. Defaults is Asc.
Loads all the items based on the parameters from StockTransactions table.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function LoadDB( _
   ByVal whereClause As Where, _
   ByVal start As Integer, _
   ByVal count As Integer, _
   ByVal orderBy As String, _
   ByVal orderDirection As OrderDirection _
) As Integer
C#
public override int LoadDB(
   Where whereClause,
   int start,
   int count,
   string orderBy,
   OrderDirection orderDirection
)

Parameters

whereClause
The where clause to filter the items.
start
The start page which starts from 0.
count
The number of items in the page.
orderBy
The order of the loaded items.
orderDirection
The order direction of the loaded items. Defaults is Asc.

Return Value

The total number of items have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransactions Class
StockTransactions Members
Overload List


%%PageItemTitle%%

LoadDB(String,Where,Int32,Int32,String,OrderDirection) Method
See Also
[image]
dotnetCART Namespace > StockTransactions Class > LoadDB Method : LoadDB(String,Where,Int32,Int32,String,OrderDirection) Method

itemID
A string itemID.
whereClause
The where clause to filter the items.
start
The start page which starts from 0.
count
The number of items in the page.
orderBy
The order of the loaded items.
orderDirection
The order direction of the loaded items. Defaults is Asc.
Loads all the items based on the parameters from StockTransactions table.

Syntax

Visual Basic (Declaration)
Public Overloads Function LoadDB( _
   ByVal itemID As String, _
   ByVal whereClause As Where, _
   ByVal start As Integer, _
   ByVal count As Integer, _
   ByVal orderBy As String, _
   ByVal orderDirection As OrderDirection _
) As Integer
C#
public int LoadDB(
   string itemID,
   Where whereClause,
   int start,
   int count,
   string orderBy,
   OrderDirection orderDirection
)

Parameters

itemID
A string itemID.
whereClause
The where clause to filter the items.
start
The start page which starts from 0.
count
The number of items in the page.
orderBy
The order of the loaded items.
orderDirection
The order direction of the loaded items. Defaults is Asc.

Return Value

The total number of items have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransactions Class
StockTransactions Members
Overload List


%%PageItemTitle%%

Store Class
See Also Members
[image]
dotnetCART Namespace : Store Class

This high level class allows you to access the store Settings and Catalog.

Object Model

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Store
C#
public sealed class Store

Inheritance Hierarchy

System.Object
dotnetCART.Store

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Store Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

Store Class Members
See Also Properties
[image]
dotnetCART Namespace : Store Class

The following tables list the members exposed by Store.

Public Constructors

 | Name | Description
Public Constructor | Store Constructor |
Top

Public Properties

 | Name | Description
Public Property | Catalog | Store's catalog.
static (Shared in Visual Basic) | Settings | Store's Settings.
Top

See Also

Reference

Store Class
dotnetCART Namespace


%%PageItemTitle%%

Store Constructor
[image]
dotnetCART Namespace > Store Class : Store Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Store()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Store Class
Store Members


%%PageItemTitle%% $$Properties$$

Store Class Properties
[image]
dotnetCART Namespace : Store Class

For a list of all members of this type, see Store members.

Public Properties

 | Name | Description
Public Property | Catalog | Store's catalog.
static (Shared in Visual Basic) | Settings | Store's Settings.
Top

See Also

Reference

Store Class
dotnetCART Namespace


%%PageItemTitle%%

Catalog Property
[image]
dotnetCART Namespace > Store Class : Catalog Property

Store's catalog.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Catalog As Catalog
C#
public Catalog Catalog {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Store Class
Store Members


%%PageItemTitle%%

Settings Property
[image]
dotnetCART Namespace > Store Class : Settings Property

Store's Settings.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Settings As Settings
C#
public static Settings Settings {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Store Class
Store Members


%%PageItemTitle%%

StoreAddress Class
See Also Members
[image]
dotnetCART Namespace : StoreAddress Class

Store Address

Object Model

Syntax

Visual Basic (Declaration)
Public Class StoreAddress
C#
public class StoreAddress

Inheritance Hierarchy

System.Object
dotnetCART.StoreAddress

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StoreAddress Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

StoreAddress Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : StoreAddress Class

The following tables list the members exposed by StoreAddress.

Public Constructors

 | Name | Description
Public Constructor | StoreAddress Constructor |
Top

Public Properties

 | Name | Description
Public Property | City | The city for a given address.
Public Property | Company | The company name of the address.
Public Property | Country | The county for a given address.
Public Property | Email | The email for a given address.
Public Property | Error | Gets the error object.
Public Property | Fax | The fax for a given address.
Public Property | Name | The name of the person at a given address.
Public Property | Phone | The phone for a given address.
Public Property | StateProvince | The state for a given address.
Public Property | Street | The street for a given address.
Public Property | ZipPostal | The zip postal code for a given address.
Top

Public Methods

 | Name | Description
Public Method | Load | Loads store address setting from the settings configuration file specified in Settings.FileName and Settings.Path.
Public Method | Save | Saves store address setting to the settings configuration file specified in Settings.FileName and Settings.Path.
Top

See Also

Reference

StoreAddress Class
dotnetCART Namespace


%%PageItemTitle%%

StoreAddress Constructor
[image]
dotnetCART Namespace > StoreAddress Class : StoreAddress Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public StoreAddress()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StoreAddress Class
StoreAddress Members


%%PageItemTitle%% $$Methods$$

StoreAddress Class Methods
[image]
dotnetCART Namespace : StoreAddress Class

For a list of all members of this type, see StoreAddress members.

Public Methods

 | Name | Description
Public Method | Load | Loads store address setting from the settings configuration file specified in Settings.FileName and Settings.Path.
Public Method | Save | Saves store address setting to the settings configuration file specified in Settings.FileName and Settings.Path.
Top

See Also

Reference

StoreAddress Class
dotnetCART Namespace


%%PageItemTitle%%

Load Method
[image]
dotnetCART Namespace > StoreAddress Class : Load Method

Loads store address setting from the settings configuration file specified in Settings.FileName and Settings.Path.

Syntax

Visual Basic (Declaration)
Public Function Load() As Boolean
C#
public bool Load()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StoreAddress Class
StoreAddress Members


%%PageItemTitle%%

Save Method
[image]
dotnetCART Namespace > StoreAddress Class : Save Method

Saves store address setting to the settings configuration file specified in Settings.FileName and Settings.Path.

Syntax

Visual Basic (Declaration)
Public Function Save() As Boolean
C#
public bool Save()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StoreAddress Class
StoreAddress Members


%%PageItemTitle%% $$Properties$$

StoreAddress Class Properties
[image]
dotnetCART Namespace : StoreAddress Class

For a list of all members of this type, see StoreAddress members.

Public Properties

 | Name | Description
Public Property | City | The city for a given address.
Public Property | Company | The company name of the address.
Public Property | Country | The county for a given address.
Public Property | Email | The email for a given address.
Public Property | Error | Gets the error object.
Public Property | Fax | The fax for a given address.
Public Property | Name | The name of the person at a given address.
Public Property | Phone | The phone for a given address.
Public Property | StateProvince | The state for a given address.
Public Property | Street | The street for a given address.
Public Property | ZipPostal | The zip postal code for a given address.
Top

See Also

Reference

StoreAddress Class
dotnetCART Namespace


%%PageItemTitle%%

City Property
[image]
dotnetCART Namespace > StoreAddress Class : City Property

The city for a given address.

Syntax

Visual Basic (Declaration)
Public Property City As String
C#
public string City {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StoreAddress Class
StoreAddress Members


%%PageItemTitle%%

Company Property
[image]
dotnetCART Namespace > StoreAddress Class : Company Property

The company name of the address.

Syntax

Visual Basic (Declaration)
Public Property Company As String
C#
public string Company {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StoreAddress Class
StoreAddress Members


%%PageItemTitle%%

Country Property
[image]
dotnetCART Namespace > StoreAddress Class : Country Property

The county for a given address.

Syntax

Visual Basic (Declaration)
Public Property Country As String
C#
public string Country {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StoreAddress Class
StoreAddress Members


%%PageItemTitle%%

Email Property
[image]
dotnetCART Namespace > StoreAddress Class : Email Property

The email for a given address.

Syntax

Visual Basic (Declaration)
Public Property Email As String
C#
public string Email {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StoreAddress Class
StoreAddress Members


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > StoreAddress Class : Error Property

Gets the error object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StoreAddress Class
StoreAddress Members


%%PageItemTitle%%

Fax Property
[image]
dotnetCART Namespace > StoreAddress Class : Fax Property

The fax for a given address.

Syntax

Visual Basic (Declaration)
Public Property Fax As String
C#
public string Fax {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StoreAddress Class
StoreAddress Members


%%PageItemTitle%%

Name Property
[image]
dotnetCART Namespace > StoreAddress Class : Name Property

The name of the person at a given address.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StoreAddress Class
StoreAddress Members


%%PageItemTitle%%

Phone Property
[image]
dotnetCART Namespace > StoreAddress Class : Phone Property

The phone for a given address.

Syntax

Visual Basic (Declaration)
Public Property Phone As String
C#
public string Phone {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StoreAddress Class
StoreAddress Members


%%PageItemTitle%%

StateProvince Property
[image]
dotnetCART Namespace > StoreAddress Class : StateProvince Property

The state for a given address.

Syntax

Visual Basic (Declaration)
Public Property StateProvince As String
C#
public string StateProvince {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StoreAddress Class
StoreAddress Members


%%PageItemTitle%%

Street Property
[image]
dotnetCART Namespace > StoreAddress Class : Street Property

The street for a given address.

Syntax

Visual Basic (Declaration)
Public Property Street As String
C#
public string Street {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StoreAddress Class
StoreAddress Members


%%PageItemTitle%%

ZipPostal Property
[image]
dotnetCART Namespace > StoreAddress Class : ZipPostal Property

The zip postal code for a given address.

Syntax

Visual Basic (Declaration)
Public Property ZipPostal As String
C#
public string ZipPostal {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StoreAddress Class
StoreAddress Members


%%PageItemTitle%%

SubItemMapping Class
See Also Members
[image]
dotnetCART Namespace : SubItemMapping Class

Represents a sub-item mapping object.

Object Model

Syntax

Visual Basic (Declaration)
Public Class SubItemMapping
   Inherits DbTableCart(Of SubItemMapping, Long)
C#
public class SubItemMapping : DbTableCart<SubItemMapping, long>

Remarks

Sub items are optionally created based on the combinations of an item options' choices and enable setting different Prices, Images, or Stock values for each subitem variation. The sub items are the physical items and the parent item acts as a container to display the subitems as a single item with options in the store catalog. In this way, highly related items can show as a single item and provide easy to use options for selecting size, color or other variations which in the background are seamlessly mapped to the appropriate subitems. More information

Inheritance Hierarchy

System.Object
dotnetDATA.DbTable<Int64>
dotnetDATA.DbTable<SubItemMapping, Int64>
dotnetCART.DbTableCart<SubItemMapping, Int64>
dotnetCART.SubItemMapping

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SubItemMapping Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

SubItemMapping Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : SubItemMapping Class

The following tables list the members exposed by SubItemMapping.

Public Constructors

 | Name | Description
Public Constructor | SubItemMapping Constructor |
Top

Public Properties

 | Name | Description
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<SubItemMapping, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<SubItemMapping, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<SubItemMapping, Int64>)
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<SubItemMapping, Int64>)
Public Property | Item | An Item object which represents the sub-item.
Public Property | ItemID | Gets or sets the ItemID of this sub-item.
Public Property | OptionSelections | The option's choice combinations for this sub-item.
Public Property | ParentItemID | Gets or sets the parent ItemID of this sub-item.
Top

Public Methods

 | Name | Description
Public Method | Clear | Initializes all the properties without recreating the object. (Inherited from dotnetCART.DbTableCart<SubItemMapping, Int64>)
Public Method | Clone | Create a copy of this SubItemMapping.
Public Method | DeleteDB | Overloaded. Overridden. Deletes this sub-item mapping from SubItemMappings table.
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<SubItemMapping, Int64>)
Public Method | LoadDB | Overloaded. Overridden. Loads the sub-item mapping with the ItemID property value from SubItemMappings table.
Public Method | SaveDB | Overloaded. Overridden. Saves this sub-item mapping to SubItemMappings table.
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<SubItemMapping, Int64>)
Top

See Also

Reference

SubItemMapping Class
dotnetCART Namespace


%%PageItemTitle%%

SubItemMapping Constructor
[image]
dotnetCART Namespace > SubItemMapping Class : SubItemMapping Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SubItemMapping()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SubItemMapping Class
SubItemMapping Members


%%PageItemTitle%% $$Methods$$

SubItemMapping Class Methods
[image]
dotnetCART Namespace : SubItemMapping Class

For a list of all members of this type, see SubItemMapping members.

Public Methods

 | Name | Description
Public Method | Clear | Initializes all the properties without recreating the object. (Inherited from dotnetCART.DbTableCart<SubItemMapping, Int64>)
Public Method | Clone | Create a copy of this SubItemMapping.
Public Method | DeleteDB | Overloaded. Overridden. Deletes this sub-item mapping from SubItemMappings table.
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<SubItemMapping, Int64>)
Public Method | LoadDB | Overloaded. Overridden. Loads the sub-item mapping with the ItemID property value from SubItemMappings table.
Public Method | SaveDB | Overloaded. Overridden. Saves this sub-item mapping to SubItemMappings table.
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<SubItemMapping, Int64>)
Top

See Also

Reference

SubItemMapping Class
dotnetCART Namespace


%%PageItemTitle%%

Clone Method
[image]
dotnetCART Namespace > SubItemMapping Class : Clone Method

Create a copy of this SubItemMapping.

Syntax

Visual Basic (Declaration)
Public Function Clone() As SubItemMapping
C#
public SubItemMapping Clone()

Return Value

Returns a SubItemMapping object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SubItemMapping Class
SubItemMapping Members


%%PageItemTitle%%

DeleteDB Method
[image]
dotnetCART Namespace > SubItemMapping Class : DeleteDB Method

Deletes this sub-item mapping from SubItemMappings table.

Overload List

Overload | Description
DeleteDB() | Deletes this sub-item mapping from SubItemMappings table.
DeleteDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SubItemMapping Class
SubItemMapping Members


%%PageItemTitle%%

DeleteDB() Method
[image]
dotnetCART Namespace > SubItemMapping Class > DeleteDB Method : DeleteDB() Method

Deletes this sub-item mapping from SubItemMappings table.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function DeleteDB() As Integer
C#
public override int DeleteDB()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SubItemMapping Class
SubItemMapping Members
Overload List


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > SubItemMapping Class : LoadDB Method

Loads the sub-item mapping with the ItemID property value from SubItemMappings table.

Overload List

Overload | Description
LoadDB() | Loads the sub-item mapping with the ItemID property value from SubItemMappings table.
LoadDB(Int64) | (Inherited from dotnetCART.DbTableCart<SubItemMapping, Int64>)
Generic LoadDB() | (Inherited from dotnetDATA.DbTable<Int64>)
Generic LoadDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SubItemMapping Class
SubItemMapping Members


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > SubItemMapping Class > LoadDB Method : LoadDB() Method

Loads the sub-item mapping with the ItemID property value from SubItemMappings table.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function LoadDB() As Integer
C#
public override int LoadDB()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SubItemMapping Class
SubItemMapping Members
Overload List


%%PageItemTitle%%

SaveDB Method
[image]
dotnetCART Namespace > SubItemMapping Class : SaveDB Method

Saves this sub-item mapping to SubItemMappings table.

Overload List

Overload | Description
SaveDB() | Saves this sub-item mapping to SubItemMappings table.
SaveDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SubItemMapping Class
SubItemMapping Members


%%PageItemTitle%%

SaveDB() Method
[image]
dotnetCART Namespace > SubItemMapping Class > SaveDB Method : SaveDB() Method

Saves this sub-item mapping to SubItemMappings table.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function SaveDB() As Integer
C#
public override int SaveDB()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SubItemMapping Class
SubItemMapping Members
Overload List


%%PageItemTitle%% $$Properties$$

SubItemMapping Class Properties
[image]
dotnetCART Namespace : SubItemMapping Class

For a list of all members of this type, see SubItemMapping members.

Public Properties

 | Name | Description
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<SubItemMapping, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<SubItemMapping, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<SubItemMapping, Int64>)
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<SubItemMapping, Int64>)
Public Property | Item | An Item object which represents the sub-item.
Public Property | ItemID | Gets or sets the ItemID of this sub-item.
Public Property | OptionSelections | The option's choice combinations for this sub-item.
Public Property | ParentItemID | Gets or sets the parent ItemID of this sub-item.
Top

See Also

Reference

SubItemMapping Class
dotnetCART Namespace


%%PageItemTitle%%

Item Property
[image]
dotnetCART Namespace > SubItemMapping Class : Item Property

An Item object which represents the sub-item.

Syntax

Visual Basic (Declaration)
Public Property Item As Item
C#
public Item Item {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SubItemMapping Class
SubItemMapping Members


%%PageItemTitle%%

ItemID Property
[image]
dotnetCART Namespace > SubItemMapping Class : ItemID Property

Gets or sets the ItemID of this sub-item.

Syntax

Visual Basic (Declaration)
Public Property ItemID As String
C#
public string ItemID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SubItemMapping Class
SubItemMapping Members


%%PageItemTitle%%

OptionSelections Property
[image]
dotnetCART Namespace > SubItemMapping Class : OptionSelections Property

The option's choice combinations for this sub-item.

Syntax

Visual Basic (Declaration)
Public Property OptionSelections As List(Of OptionSelection)
C#
public List<OptionSelection> OptionSelections {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SubItemMapping Class
SubItemMapping Members


%%PageItemTitle%%

ParentItemID Property
[image]
dotnetCART Namespace > SubItemMapping Class : ParentItemID Property

Gets or sets the parent ItemID of this sub-item.

Syntax

Visual Basic (Declaration)
Public Property ParentItemID As String
C#
public string ParentItemID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SubItemMapping Class
SubItemMapping Members


%%PageItemTitle%%

SubItemMappings Class
See Also Members
[image]
dotnetCART Namespace : SubItemMappings Class

A collection of SubItemMapping objects.

Object Model

Syntax

Visual Basic (Declaration)
Public Class SubItemMappings
   Inherits List(Of SubItemMapping)
C#
public class SubItemMappings : List<SubItemMapping>

Remarks

Sub items are optionally created based on the combinations of an item options' choices and enable setting different Prices, Images, or Stock values for each subitem variation. The sub items are the physical items and the parent item acts as a container to display the subitems as a single item with options in the store catalog. In this way, highly related items can show as a single item and provide easy to use options for selecting size, color or other variations which in the background are seamlessly mapped to the appropriate subitems. More information

Inheritance Hierarchy

System.Object
System.Collections.Generic.List<SubItemMapping>
dotnetCART.SubItemMappings

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SubItemMappings Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

SubItemMappings Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : SubItemMappings Class

The following tables list the members exposed by SubItemMappings.

Public Constructors

 | Name | Description
Public Constructor | SubItemMappings Constructor |
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Property | Count | (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Property | Error | Gets the error object.
Public Property | Item | (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Property | ParentItem | Sets or gets the parent item of these subItems.
Top

Public Methods

 | Name | Description
Public Method | Add | Add a new SubItemMapping.
Public Method | AddRange | (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | CalculateOptionCombinations | Returns all the combinations of all the options. It applies only to the options with AddOn=false
Public Method | Clear | (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | Contains | (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | Create | Creates subItems for all the options combination. It applies only to the options with AddOn=false
Public Method | CreateDB | Creates subItems for all the options combination and saves them to database. It applies only to the options with AddOn=false
Public Method | Exists | (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | Find | (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | FindAll | (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | FindLast | (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | ForEach | (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | GetRange | (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | GetSelectedItem | Returns the selected subItem base on T:OptionSelections values.
Public Method | GetSelectedSubItem | Returns the selected subItem base on T:OptionSelections values.
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | Insert | (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | LoadDB | Loads all the subitems for the parentItem.
Public Method | Remove | (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | ToArray | (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List<SubItemMapping>)
Top

See Also

Reference

SubItemMappings Class
dotnetCART Namespace


%%PageItemTitle%%

SubItemMappings Constructor
[image]
dotnetCART Namespace > SubItemMappings Class : SubItemMappings Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SubItemMappings()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SubItemMappings Class
SubItemMappings Members


%%PageItemTitle%% $$Methods$$

SubItemMappings Class Methods
[image]
dotnetCART Namespace : SubItemMappings Class

For a list of all members of this type, see SubItemMappings members.

Public Methods

 | Name | Description
Public Method | Add | Add a new SubItemMapping.
Public Method | AddRange | (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | CalculateOptionCombinations | Returns all the combinations of all the options. It applies only to the options with AddOn=false
Public Method | Clear | (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | Contains | (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | Create | Creates subItems for all the options combination. It applies only to the options with AddOn=false
Public Method | CreateDB | Creates subItems for all the options combination and saves them to database. It applies only to the options with AddOn=false
Public Method | Exists | (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | Find | (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | FindAll | (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | FindLast | (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | ForEach | (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | GetRange | (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | GetSelectedItem | Returns the selected subItem base on T:OptionSelections values.
Public Method | GetSelectedSubItem | Returns the selected subItem base on T:OptionSelections values.
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | Insert | (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | LoadDB | Loads all the subitems for the parentItem.
Public Method | Remove | (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | ToArray | (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List<SubItemMapping>)
Top

See Also

Reference

SubItemMappings Class
dotnetCART Namespace


%%PageItemTitle%%

Add Method
[image]
dotnetCART Namespace > SubItemMappings Class : Add Method

newItem
A SubItemMapping object.
Add a new SubItemMapping.

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal newItem As SubItemMapping _
) As Integer
C#
public int Add(
   SubItemMapping newItem
)

Parameters

newItem
A SubItemMapping object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SubItemMappings Class
SubItemMappings Members


%%PageItemTitle%%

CalculateOptionCombinations Method
[image]
dotnetCART Namespace > SubItemMappings Class : CalculateOptionCombinations Method

Returns all the combinations of all the options. It applies only to the options with AddOn=false

Syntax

Visual Basic (Declaration)
Public Function CalculateOptionCombinations() As Dictionary(Of String, String)
C#
public Dictionary<string, string> CalculateOptionCombinations()

Return Value

Returns a key value dictionary for the option combinations.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SubItemMappings Class
SubItemMappings Members


%%PageItemTitle%%

Create Method
[image]
dotnetCART Namespace > SubItemMappings Class : Create Method

Creates subItems for all the options combination. It applies only to the options with AddOn=false

Syntax

Visual Basic (Declaration)
Public Function Create() As Integer
C#
public int Create()

Return Value

The total number of subItems.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SubItemMappings Class
SubItemMappings Members


%%PageItemTitle%%

CreateDB Method
[image]
dotnetCART Namespace > SubItemMappings Class : CreateDB Method

Creates subItems for all the options combination and saves them to database. It applies only to the options with AddOn=false

Syntax

Visual Basic (Declaration)
Public Function CreateDB() As Integer
C#
public int CreateDB()

Return Value

The total number of subItems.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SubItemMappings Class
SubItemMappings Members


%%PageItemTitle%%

GetSelectedItem Method
[image]
dotnetCART Namespace > SubItemMappings Class : GetSelectedItem Method

Returns the selected subItem base on T:OptionSelections values.

Syntax

Visual Basic (Declaration)
Public Function GetSelectedItem() As Item
C#
public Item GetSelectedItem()

Return Value

Return an item object or the parent item if there is no matching.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SubItemMappings Class
SubItemMappings Members


%%PageItemTitle%%

GetSelectedSubItem Method
[image]
dotnetCART Namespace > SubItemMappings Class : GetSelectedSubItem Method

Returns the selected subItem base on T:OptionSelections values.

Syntax

Visual Basic (Declaration)
Public Function GetSelectedSubItem() As Item
C#
public Item GetSelectedSubItem()

Return Value

Return an item object or null if there is no matching.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SubItemMappings Class
SubItemMappings Members


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > SubItemMappings Class : LoadDB Method

Loads all the subitems for the parentItem.

Syntax

Visual Basic (Declaration)
Public Function LoadDB() As Integer
C#
public int LoadDB()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SubItemMappings Class
SubItemMappings Members


%%PageItemTitle%% $$Properties$$

SubItemMappings Class Properties
[image]
dotnetCART Namespace : SubItemMappings Class

For a list of all members of this type, see SubItemMappings members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Property | Count | (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Property | Error | Gets the error object.
Public Property | Item | (Inherited from System.Collections.Generic.List<SubItemMapping>)
Public Property | ParentItem | Sets or gets the parent item of these subItems.
Top

See Also

Reference

SubItemMappings Class
dotnetCART Namespace


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > SubItemMappings Class : Error Property

Gets the error object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SubItemMappings Class
SubItemMappings Members


%%PageItemTitle%%

ParentItem Property
[image]
dotnetCART Namespace > SubItemMappings Class : ParentItem Property

Sets or gets the parent item of these subItems.

Syntax

Visual Basic (Declaration)
Public Property ParentItem As Item
C#
public Item ParentItem {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SubItemMappings Class
SubItemMappings Members


%%PageItemTitle%%

Supplier Class
See Also Members
[image]
dotnetCART Namespace : Supplier Class

Represents a supplier object.

Object Model

Syntax

Visual Basic (Declaration)
Public Class Supplier
   Inherits DbTableCart(Of Supplier, Long)
C#
public class Supplier : DbTableCart<Supplier, long>

Inheritance Hierarchy

System.Object
dotnetDATA.DbTable<Int64>
dotnetDATA.DbTable<Supplier, Int64>
dotnetCART.DbTableCart<Supplier, Int64>
dotnetCART.Supplier

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Supplier Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

Supplier Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : Supplier Class

The following tables list the members exposed by Supplier.

Public Constructors

 | Name | Description
Public Constructor | Supplier Constructor | Initializes a new instance of the Supplier class.
Top

Public Properties

 | Name | Description
Public Property | Addresses | A collection of all Address objects for this supplier.
Public Property | Company | Gets or sets the supplier company name.
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<Supplier, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<Supplier, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<Supplier, Int64>)
Public Property | Disabled | Determines whether this supplier is disabled or not.
Public Property | Email | Gets or sets the supplier company email.
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<Supplier, Int64>)
Public Property | Fax | Gets or sets the supplier fax number.
Public Property | ID | Overridden. The auto number ID populated from the database.
Public Property | Items | A collection of all Item objects for this supplier.
Public Property | Name | Gets or sets this supplier's name.
Public Property | Phone | Gets or sets the supplier phone number.
Top

Public Methods

 | Name | Description
Public Method | Clear | Overridden. Initializes all the properties without recreating the object.
Public Method | Clone | Creates a copy of the current Supplier
Public Method | DeleteDB | Overloaded. Overridden. Deletes this supplier and all the associated addresses.
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<Supplier, Int64>)
Public Method | LoadDB | Overloaded. Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<Supplier, Int64>)
Public Method | SaveDB | Overloaded. Overridden. Inserts or updates this object into the Suppliers table.
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<Supplier, Int64>)
Top

See Also

Reference

Supplier Class
dotnetCART Namespace


%%PageItemTitle%%

Supplier Constructor
[image]
dotnetCART Namespace > Supplier Class : Supplier Constructor

Initializes a new instance of the Supplier class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Supplier()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Supplier Class
Supplier Members


%%PageItemTitle%% $$Methods$$

Supplier Class Methods
[image]
dotnetCART Namespace : Supplier Class

For a list of all members of this type, see Supplier members.

Public Methods

 | Name | Description
Public Method | Clear | Overridden. Initializes all the properties without recreating the object.
Public Method | Clone | Creates a copy of the current Supplier
Public Method | DeleteDB | Overloaded. Overridden. Deletes this supplier and all the associated addresses.
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<Supplier, Int64>)
Public Method | LoadDB | Overloaded. Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<Supplier, Int64>)
Public Method | SaveDB | Overloaded. Overridden. Inserts or updates this object into the Suppliers table.
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<Supplier, Int64>)
Top

See Also

Reference

Supplier Class
dotnetCART Namespace


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > Supplier Class : Clear Method

Initializes all the properties without recreating the object.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Clear()
C#
public override void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Supplier Class
Supplier Members


%%PageItemTitle%%

Clone Method
[image]
dotnetCART Namespace > Supplier Class : Clone Method

Creates a copy of the current Supplier

Syntax

Visual Basic (Declaration)
Public Function Clone() As Supplier
C#
public Supplier Clone()

Return Value

Returns a Supplier object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Supplier Class
Supplier Members


%%PageItemTitle%%

DeleteDB Method
[image]
dotnetCART Namespace > Supplier Class : DeleteDB Method

Deletes this supplier and all the associated addresses.

Overload List

Overload | Description
DeleteDB() | Deletes this supplier and all the associated addresses.
DeleteDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Supplier Class
Supplier Members


%%PageItemTitle%%

DeleteDB() Method
[image]
dotnetCART Namespace > Supplier Class > DeleteDB Method : DeleteDB() Method

Deletes this supplier and all the associated addresses.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function DeleteDB() As Integer
C#
public override int DeleteDB()

Return Value

In case of error -1, check Error property, otherwise the number of records deleted.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Supplier Class
Supplier Members
Overload List


%%PageItemTitle%%

SaveDB Method
[image]
dotnetCART Namespace > Supplier Class : SaveDB Method

Inserts or updates this object into the Suppliers table.

Overload List

Overload | Description
SaveDB() | Inserts or updates this object into the Suppliers table.
SaveDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Supplier Class
Supplier Members


%%PageItemTitle%%

SaveDB() Method
[image]
dotnetCART Namespace > Supplier Class > SaveDB Method : SaveDB() Method

Inserts or updates this object into the Suppliers table.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function SaveDB() As Integer
C#
public override int SaveDB()

Return Value

Returns the generated ID or 1 for the update, returns -1 if failed. For the reason of fail, check the Error property.

Remarks

If ID greater than 0, it updates the associated record in the table, otherwise inserts a new record.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Supplier Class
Supplier Members
Overload List


%%PageItemTitle%% $$Properties$$

Supplier Class Properties
[image]
dotnetCART Namespace : Supplier Class

For a list of all members of this type, see Supplier members.

Public Properties

 | Name | Description
Public Property | Addresses | A collection of all Address objects for this supplier.
Public Property | Company | Gets or sets the supplier company name.
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<Supplier, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<Supplier, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<Supplier, Int64>)
Public Property | Disabled | Determines whether this supplier is disabled or not.
Public Property | Email | Gets or sets the supplier company email.
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<Supplier, Int64>)
Public Property | Fax | Gets or sets the supplier fax number.
Public Property | ID | Overridden. The auto number ID populated from the database.
Public Property | Items | A collection of all Item objects for this supplier.
Public Property | Name | Gets or sets this supplier's name.
Public Property | Phone | Gets or sets the supplier phone number.
Top

See Also

Reference

Supplier Class
dotnetCART Namespace


%%PageItemTitle%%

Addresses Property
[image]
dotnetCART Namespace > Supplier Class : Addresses Property

A collection of all Address objects for this supplier.

Syntax

Visual Basic (Declaration)
Public Property Addresses As Addresses
C#
public Addresses Addresses {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Supplier Class
Supplier Members


%%PageItemTitle%%

Company Property
[image]
dotnetCART Namespace > Supplier Class : Company Property

Gets or sets the supplier company name.

Syntax

Visual Basic (Declaration)
Public Property Company As String
C#
public string Company {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Supplier Class
Supplier Members


%%PageItemTitle%%

Disabled Property
[image]
dotnetCART Namespace > Supplier Class : Disabled Property

Determines whether this supplier is disabled or not.

Syntax

Visual Basic (Declaration)
Public Property Disabled As Boolean
C#
public bool Disabled {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Supplier Class
Supplier Members


%%PageItemTitle%%

Email Property
[image]
dotnetCART Namespace > Supplier Class : Email Property

Gets or sets the supplier company email.

Syntax

Visual Basic (Declaration)
Public Property Email As String
C#
public string Email {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Supplier Class
Supplier Members


%%PageItemTitle%%

Fax Property
[image]
dotnetCART Namespace > Supplier Class : Fax Property

Gets or sets the supplier fax number.

Syntax

Visual Basic (Declaration)
Public Property Fax As String
C#
public string Fax {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Supplier Class
Supplier Members


%%PageItemTitle%%

ID Property
[image]
dotnetCART Namespace > Supplier Class : ID Property

The auto number ID populated from the database.

Syntax

Visual Basic (Declaration)
Public Overrides Property ID As Long
C#
public override long ID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Supplier Class
Supplier Members


%%PageItemTitle%%

Items Property
[image]
dotnetCART Namespace > Supplier Class : Items Property

A collection of all Item objects for this supplier.

Syntax

Visual Basic (Declaration)
Public Property Items As Items
C#
public Items Items {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Supplier Class
Supplier Members


%%PageItemTitle%%

Name Property
[image]
dotnetCART Namespace > Supplier Class : Name Property

Gets or sets this supplier's name.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Supplier Class
Supplier Members


%%PageItemTitle%%

Phone Property
[image]
dotnetCART Namespace > Supplier Class : Phone Property

Gets or sets the supplier phone number.

Syntax

Visual Basic (Declaration)
Public Property Phone As String
C#
public string Phone {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Supplier Class
Supplier Members


%%PageItemTitle%%

SupplierItem Class
See Also Members
[image]
dotnetCART Namespace : SupplierItem Class

Represents a SupplierItem object for storing an item order information to its supplier.

Object Model

Syntax

Visual Basic (Declaration)
Public Class SupplierItem
   Inherits DbTableCart(Of SupplierItem, Long)
C#
public class SupplierItem : DbTableCart<SupplierItem, long>

Inheritance Hierarchy

System.Object
dotnetDATA.DbTable<Int64>
dotnetDATA.DbTable<SupplierItem, Int64>
dotnetCART.DbTableCart<SupplierItem, Int64>
dotnetCART.SupplierItem

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItem Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

SupplierItem Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : SupplierItem Class

The following tables list the members exposed by SupplierItem.

Public Constructors

 | Name | Description
Public Constructor | SupplierItem Constructor | Initializes a new instance of SupplierItem object.
Top

Public Properties

 | Name | Description
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<SupplierItem, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<SupplierItem, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<SupplierItem, Int64>)
Public Property | DeliveryDate | The date the Item has been delivered to the store.
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<SupplierItem, Int64>)
Public Property | ID | Overridden. The auto number ID populated from the database.
Public Property | ItemID | The ItemID for the Item which is provided by the Supplier with this SupplierID.
Public Property | OrderDate | The date an Item has been orderd to a Supplier.
Public Property | Price | The purchase price of the Item.
Public Property | Quantity | The quantity of the Item has been ordered.
Public Property | SupplierID | The SupplierID for the Supplier supplies the Item with this ItemID.
Top

Public Methods

 | Name | Description
Public Method | Clear | Initializes all the properties without recreating the object. (Inherited from dotnetCART.DbTableCart<SupplierItem, Int64>)
Public Method | DeleteDB | Overloaded. Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<SupplierItem, Int64>)
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<SupplierItem, Int64>)
Public Method | LoadDB | Overloaded. Overridden. Loads a SupplierItem based on ID or SupplierID or ItemID properties from SupplierItems table.
Public Method | SaveDB | Overloaded. Inserts or updates this object into the database. (Inherited from dotnetCART.DbTableCart<SupplierItem, Int64>)
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<SupplierItem, Int64>)
Top

See Also

Reference

SupplierItem Class
dotnetCART Namespace


%%PageItemTitle%%

SupplierItem Constructor
[image]
dotnetCART Namespace > SupplierItem Class : SupplierItem Constructor

Initializes a new instance of SupplierItem object.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SupplierItem()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItem Class
SupplierItem Members


%%PageItemTitle%% $$Methods$$

SupplierItem Class Methods
[image]
dotnetCART Namespace : SupplierItem Class

For a list of all members of this type, see SupplierItem members.

Public Methods

 | Name | Description
Public Method | Clear | Initializes all the properties without recreating the object. (Inherited from dotnetCART.DbTableCart<SupplierItem, Int64>)
Public Method | DeleteDB | Overloaded. Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<SupplierItem, Int64>)
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<SupplierItem, Int64>)
Public Method | LoadDB | Overloaded. Overridden. Loads a SupplierItem based on ID or SupplierID or ItemID properties from SupplierItems table.
Public Method | SaveDB | Overloaded. Inserts or updates this object into the database. (Inherited from dotnetCART.DbTableCart<SupplierItem, Int64>)
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<SupplierItem, Int64>)
Top

See Also

Reference

SupplierItem Class
dotnetCART Namespace


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > SupplierItem Class : LoadDB Method

Loads a SupplierItem based on ID or SupplierID or ItemID properties from SupplierItems table.

Overload List

Overload | Description
LoadDB() | Loads a SupplierItem based on ID or SupplierID or ItemID properties from SupplierItems table.
LoadDB(Int64,Int64,String) | Loads the SupplierItem based on the parameters from SupplierItems table.
LoadDB(Int64) | (Inherited from dotnetCART.DbTableCart<SupplierItem, Int64>)
Generic LoadDB() | (Inherited from dotnetDATA.DbTable<Int64>)
Generic LoadDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItem Class
SupplierItem Members


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > SupplierItem Class > LoadDB Method : LoadDB() Method

Loads a SupplierItem based on ID or SupplierID or ItemID properties from SupplierItems table.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function LoadDB() As Integer
C#
public override int LoadDB()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItem Class
SupplierItem Members
Overload List


%%PageItemTitle%%

LoadDB(Int64,Int64,String) Method
[image]
dotnetCART Namespace > SupplierItem Class > LoadDB Method : LoadDB(Int64,Int64,String) Method

supplierItemID
The auto number ID for the supplierItem.
supplierID
The ID for the supplier.
itemID
The ItemID for the item.
Loads the SupplierItem based on the parameters from SupplierItems table.

Syntax

Visual Basic (Declaration)
Public Overloads Function LoadDB( _
   ByVal supplierItemID As Long, _
   ByVal supplierID As Long, _
   ByVal itemID As String _
) As Integer
C#
public int LoadDB(
   long supplierItemID,
   long supplierID,
   string itemID
)

Parameters

supplierItemID
The auto number ID for the supplierItem.
supplierID
The ID for the supplier.
itemID
The ItemID for the item.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItem Class
SupplierItem Members
Overload List


%%PageItemTitle%% $$Properties$$

SupplierItem Class Properties
[image]
dotnetCART Namespace : SupplierItem Class

For a list of all members of this type, see SupplierItem members.

Public Properties

 | Name | Description
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<SupplierItem, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<SupplierItem, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<SupplierItem, Int64>)
Public Property | DeliveryDate | The date the Item has been delivered to the store.
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<SupplierItem, Int64>)
Public Property | ID | Overridden. The auto number ID populated from the database.
Public Property | ItemID | The ItemID for the Item which is provided by the Supplier with this SupplierID.
Public Property | OrderDate | The date an Item has been orderd to a Supplier.
Public Property | Price | The purchase price of the Item.
Public Property | Quantity | The quantity of the Item has been ordered.
Public Property | SupplierID | The SupplierID for the Supplier supplies the Item with this ItemID.
Top

See Also

Reference

SupplierItem Class
dotnetCART Namespace


%%PageItemTitle%%

DeliveryDate Property
[image]
dotnetCART Namespace > SupplierItem Class : DeliveryDate Property

The date the Item has been delivered to the store.

Syntax

Visual Basic (Declaration)
Public Property DeliveryDate As Date
C#
public DateTime DeliveryDate {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItem Class
SupplierItem Members


%%PageItemTitle%%

ID Property
[image]
dotnetCART Namespace > SupplierItem Class : ID Property

The auto number ID populated from the database.

Syntax

Visual Basic (Declaration)
Public Overrides Property ID As Long
C#
public override long ID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItem Class
SupplierItem Members


%%PageItemTitle%%

ItemID Property
[image]
dotnetCART Namespace > SupplierItem Class : ItemID Property

The ItemID for the Item which is provided by the Supplier with this SupplierID.

Syntax

Visual Basic (Declaration)
Public Property ItemID As String
C#
public string ItemID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItem Class
SupplierItem Members


%%PageItemTitle%%

OrderDate Property
[image]
dotnetCART Namespace > SupplierItem Class : OrderDate Property

The date an Item has been orderd to a Supplier.

Syntax

Visual Basic (Declaration)
Public Property OrderDate As Date
C#
public DateTime OrderDate {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItem Class
SupplierItem Members


%%PageItemTitle%%

Price Property
[image]
dotnetCART Namespace > SupplierItem Class : Price Property

The purchase price of the Item.

Syntax

Visual Basic (Declaration)
Public Property Price As Nullable(Of Decimal)
C#
public Nullable<decimal> Price {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItem Class
SupplierItem Members


%%PageItemTitle%%

Quantity Property
[image]
dotnetCART Namespace > SupplierItem Class : Quantity Property

The quantity of the Item has been ordered.

Syntax

Visual Basic (Declaration)
Public Property Quantity As Double
C#
public double Quantity {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItem Class
SupplierItem Members


%%PageItemTitle%%

SupplierID Property
[image]
dotnetCART Namespace > SupplierItem Class : SupplierID Property

The SupplierID for the Supplier supplies the Item with this ItemID.

Syntax

Visual Basic (Declaration)
Public Property SupplierID As Long
C#
public long SupplierID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItem Class
SupplierItem Members


%%PageItemTitle%%

SupplierItems Class
See Also Members
[image]
dotnetCART Namespace : SupplierItems Class

A collection of SupplierItem objects.

Object Model

Syntax

Visual Basic (Declaration)
Public Class SupplierItems
   Inherits ListBase(Of SupplierItem)
C#
public class SupplierItems : ListBase<SupplierItem>

Inheritance Hierarchy

System.Object
System.Collections.Generic.List<SupplierItem>
dotnetCART.ListBase<SupplierItem>
dotnetCART.SupplierItems

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItems Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

SupplierItems Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : SupplierItems Class

The following tables list the members exposed by SupplierItems.

Public Constructors

 | Name | Description
Public Constructor | SupplierItems Constructor | Initializes a new instance of SupplierItems object.
Top

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from dotnetCART.ListBase<SupplierItem>)
Public Property | Count | Gets the number of elements actually contained in the collection. (Inherited from dotnetCART.ListBase<SupplierItem>)
Public Property | Error | Returns an object with the error information. (Inherited from dotnetCART.ListBase<SupplierItem>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from dotnetCART.ListBase<SupplierItem>)
Top

Public Methods

 | Name | Description
Public Method | Add | Adds an object to the end of the collection. (Inherited from dotnetCART.ListBase<SupplierItem>)
Public Method | AddRange | Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetCART.ListBase<SupplierItem>)
Public Method | AsReadOnly | Returns a read-only IList wrapper for the current collection. (Inherited from dotnetCART.ListBase<SupplierItem>)
Public Method | BinarySearch | Overloaded. (Inherited from dotnetCART.ListBase<SupplierItem>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetCART.ListBase<SupplierItem>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetCART.ListBase<SupplierItem>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<SupplierItem>)
Public Method | CopyTo | Overloaded. (Inherited from dotnetCART.ListBase<SupplierItem>)
Public Method | GetCountDB | Overloaded. Gets the total number of items in the SupplierItems table.
Public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from dotnetCART.ListBase<SupplierItem>)
Public Method | IndexOf | Overloaded. (Inherited from dotnetCART.ListBase<SupplierItem>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetCART.ListBase<SupplierItem>)
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from dotnetCART.ListBase<SupplierItem>)
Public Method | LastIndexOf | Overloaded. (Inherited from dotnetCART.ListBase<SupplierItem>)
Public Method | LoadDB | Overloaded. Overridden. Loads all the items based on the parameters from SupplierItems table.
Public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from dotnetCART.ListBase<SupplierItem>)
Public Method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from dotnetCART.ListBase<SupplierItem>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetCART.ListBase<SupplierItem>)
Public Method | RemoveRange | Removes a range of elements from the List. (Inherited from dotnetCART.ListBase<SupplierItem>)
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<SupplierItem>)
Top

See Also

Reference

SupplierItems Class
dotnetCART Namespace


%%PageItemTitle%%

SupplierItems Constructor
[image]
dotnetCART Namespace > SupplierItems Class : SupplierItems Constructor

Initializes a new instance of SupplierItems object.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SupplierItems()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItems Class
SupplierItems Members


%%PageItemTitle%% $$Methods$$

SupplierItems Class Methods
[image]
dotnetCART Namespace : SupplierItems Class

For a list of all members of this type, see SupplierItems members.

Public Methods

 | Name | Description
Public Method | Add | Adds an object to the end of the collection. (Inherited from dotnetCART.ListBase<SupplierItem>)
Public Method | AddRange | Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetCART.ListBase<SupplierItem>)
Public Method | AsReadOnly | Returns a read-only IList wrapper for the current collection. (Inherited from dotnetCART.ListBase<SupplierItem>)
Public Method | BinarySearch | Overloaded. (Inherited from dotnetCART.ListBase<SupplierItem>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetCART.ListBase<SupplierItem>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetCART.ListBase<SupplierItem>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<SupplierItem>)
Public Method | CopyTo | Overloaded. (Inherited from dotnetCART.ListBase<SupplierItem>)
Public Method | GetCountDB | Overloaded. Gets the total number of items in the SupplierItems table.
Public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from dotnetCART.ListBase<SupplierItem>)
Public Method | IndexOf | Overloaded. (Inherited from dotnetCART.ListBase<SupplierItem>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetCART.ListBase<SupplierItem>)
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from dotnetCART.ListBase<SupplierItem>)
Public Method | LastIndexOf | Overloaded. (Inherited from dotnetCART.ListBase<SupplierItem>)
Public Method | LoadDB | Overloaded. Overridden. Loads all the items based on the parameters from SupplierItems table.
Public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from dotnetCART.ListBase<SupplierItem>)
Public Method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from dotnetCART.ListBase<SupplierItem>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetCART.ListBase<SupplierItem>)
Public Method | RemoveRange | Removes a range of elements from the List. (Inherited from dotnetCART.ListBase<SupplierItem>)
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<SupplierItem>)
Top

See Also

Reference

SupplierItems Class
dotnetCART Namespace


%%PageItemTitle%%

GetCountDB Method
[image]
dotnetCART Namespace > SupplierItems Class : GetCountDB Method

Gets the total number of items in the SupplierItems table.

Overload List

Overload | Description
GetCountDB() | Gets the total number of items in the SupplierItems table.
GetCountDB(Where) | Gets the total number of items in the SupplierItems table.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItems Class
SupplierItems Members


%%PageItemTitle%%

GetCountDB() Method
[image]
dotnetCART Namespace > SupplierItems Class > GetCountDB Method : GetCountDB() Method

Gets the total number of items in the SupplierItems table.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCountDB() As Integer
C#
public int GetCountDB()

Return Value

Returns the number of elements in the SupplierItems table.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItems Class
SupplierItems Members
Overload List


%%PageItemTitle%%

GetCountDB(Where) Method
[image]
dotnetCART Namespace > SupplierItems Class > GetCountDB Method : GetCountDB(Where) Method

whereClause
The where clause to filter the items.
Gets the total number of items in the SupplierItems table.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCountDB( _
   ByVal whereClause As Where _
) As Integer
C#
public int GetCountDB(
   Where whereClause
)

Parameters

whereClause
The where clause to filter the items.

Return Value

Returns the number of elements in the SupplierItems table.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItems Class
SupplierItems Members
Overload List


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > SupplierItems Class : LoadDB Method

Loads all the items based on the parameters from SupplierItems table.

Overload List

Overload | Description
LoadDB(Where,Int32,Int32,String,OrderDirection) | Loads all the items based on the parameters from SupplierItems table.
LoadDB(Int64,String) | Loads all the items based on the parameters from SupplierItems table.
LoadDB(Int64,String,Where,Int32,Int32,String,OrderDirection) | Loads all the items based on the parameters from SupplierItems table.
LoadDB() | Loads all the items from its associated table. (Inherited from dotnetCART.ListBase<SupplierItem>)
LoadDB(Where) | Loads all the items from its associated table based on the where clause. (Inherited from dotnetCART.ListBase<SupplierItem>)
LoadDB(Int32,Int32) | Loads the count number of elements from start value. (Inherited from dotnetCART.ListBase<SupplierItem>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItems Class
SupplierItems Members


%%PageItemTitle%%

LoadDB(Where,Int32,Int32,String,OrderDirection) Method
[image]
dotnetCART Namespace > SupplierItems Class > LoadDB Method : LoadDB(Where,Int32,Int32,String,OrderDirection) Method

whereClause
The where clause to filter the items.
start
The start page which starts from 0.
count
The number of items in the page.
orderBy
The order of the loaded items.
orderDirection
The order direction of the loaded items. Defaults is Asc.
Loads all the items based on the parameters from SupplierItems table.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function LoadDB( _
   ByVal whereClause As Where, _
   ByVal start As Integer, _
   ByVal count As Integer, _
   ByVal orderBy As String, _
   ByVal orderDirection As OrderDirection _
) As Integer
C#
public override int LoadDB(
   Where whereClause,
   int start,
   int count,
   string orderBy,
   OrderDirection orderDirection
)

Parameters

whereClause
The where clause to filter the items.
start
The start page which starts from 0.
count
The number of items in the page.
orderBy
The order of the loaded items.
orderDirection
The order direction of the loaded items. Defaults is Asc.

Return Value

The total number of items have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItems Class
SupplierItems Members
Overload List


%%PageItemTitle%%

LoadDB(Int64,String) Method
[image]
dotnetCART Namespace > SupplierItems Class > LoadDB Method : LoadDB(Int64,String) Method

supplierID
A supplier ID to use for loading all the SupplierItems transactions which associated to this Supplier
itemID
An ItemID to use for loading all the SupplierItems transactions which associated to this Item
Loads all the items based on the parameters from SupplierItems table.

Syntax

Visual Basic (Declaration)
Public Overloads Function LoadDB( _
   ByVal supplierID As Long, _
   ByVal itemID As String _
) As Integer
C#
public int LoadDB(
   long supplierID,
   string itemID
)

Parameters

supplierID
A supplier ID to use for loading all the SupplierItems transactions which associated to this Supplier
itemID
An ItemID to use for loading all the SupplierItems transactions which associated to this Item

Return Value

The total number of items have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItems Class
SupplierItems Members
Overload List


%%PageItemTitle%%

LoadDB(Int64,String,Where,Int32,Int32,String,OrderDirection) Method
See Also
[image]
dotnetCART Namespace > SupplierItems Class > LoadDB Method : LoadDB(Int64,String,Where,Int32,Int32,String,OrderDirection) Method

supplierID
A supplier ID to use for loading all the SupplierItems transactions which associated to this Supplier
itemID
An ItemID to use for loading all the SupplierItems transactions which associated to this Item
whereClause
The where clause to filter the items.
start
The start page which starts from 0.
count
The number of items in the page.
orderBy
The order of the loaded items.
orderDirection
The order direction of the loaded items. Defaults is Asc.
Loads all the items based on the parameters from SupplierItems table.

Syntax

Visual Basic (Declaration)
Public Overloads Function LoadDB( _
   ByVal supplierID As Long, _
   ByVal itemID As String, _
   ByVal whereClause As Where, _
   ByVal start As Integer, _
   ByVal count As Integer, _
   ByVal orderBy As String, _
   ByVal orderDirection As OrderDirection _
) As Integer
C#
public int LoadDB(
   long supplierID,
   string itemID,
   Where whereClause,
   int start,
   int count,
   string orderBy,
   OrderDirection orderDirection
)

Parameters

supplierID
A supplier ID to use for loading all the SupplierItems transactions which associated to this Supplier
itemID
An ItemID to use for loading all the SupplierItems transactions which associated to this Item
whereClause
The where clause to filter the items.
start
The start page which starts from 0.
count
The number of items in the page.
orderBy
The order of the loaded items.
orderDirection
The order direction of the loaded items. Defaults is Asc.

Return Value

The total number of items have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItems Class
SupplierItems Members
Overload List


%%PageItemTitle%%

Suppliers Class
See Also Members
[image]
dotnetCART Namespace : Suppliers Class

A collection of Supplier objects.

Object Model

Syntax

Visual Basic (Declaration)
Public Class Suppliers
   Inherits ListBase(Of Supplier)
C#
public class Suppliers : ListBase<Supplier>

Inheritance Hierarchy

System.Object
System.Collections.Generic.List<Supplier>
dotnetCART.ListBase<Supplier>
dotnetCART.Suppliers

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Suppliers Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

Suppliers Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : Suppliers Class

The following tables list the members exposed by Suppliers.

Public Constructors

 | Name | Description
Public Constructor | Suppliers Constructor | Initializes a new instance of the Suppliers class.
Top

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from dotnetCART.ListBase<Supplier>)
Public Property | Count | Gets the number of elements actually contained in the collection. (Inherited from dotnetCART.ListBase<Supplier>)
Public Property | Error | Returns an object with the error information. (Inherited from dotnetCART.ListBase<Supplier>)
Public Property | Item | Overloaded. Gets the supplier with the specified name.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds an object to the end of the collection. (Inherited from dotnetCART.ListBase<Supplier>)
Public Method | AddRange | Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetCART.ListBase<Supplier>)
Public Method | AsReadOnly | Returns a read-only IList wrapper for the current collection. (Inherited from dotnetCART.ListBase<Supplier>)
Public Method | BinarySearch | Overloaded. (Inherited from dotnetCART.ListBase<Supplier>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetCART.ListBase<Supplier>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetCART.ListBase<Supplier>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<Supplier>)
Public Method | CopyTo | Overloaded. (Inherited from dotnetCART.ListBase<Supplier>)
Public Method | GetCountDB | Overloaded. Gets the total number of items in the Suppliers table.
Public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from dotnetCART.ListBase<Supplier>)
Public Method | IndexOf | Overloaded. (Inherited from dotnetCART.ListBase<Supplier>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetCART.ListBase<Supplier>)
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from dotnetCART.ListBase<Supplier>)
Public Method | LastIndexOf | Overloaded. (Inherited from dotnetCART.ListBase<Supplier>)
Public Method | LoadDB | Overloaded. Overridden. Loads all the items from its associated table based on the where clause, start and count values.
Public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from dotnetCART.ListBase<Supplier>)
Public Method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from dotnetCART.ListBase<Supplier>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetCART.ListBase<Supplier>)
Public Method | RemoveRange | Removes a range of elements from the List. (Inherited from dotnetCART.ListBase<Supplier>)
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<Supplier>)
Top

See Also

Reference

Suppliers Class
dotnetCART Namespace


%%PageItemTitle%%

Suppliers Constructor
[image]
dotnetCART Namespace > Suppliers Class : Suppliers Constructor

Initializes a new instance of the Suppliers class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Suppliers()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Suppliers Class
Suppliers Members


%%PageItemTitle%% $$Methods$$

Suppliers Class Methods
[image]
dotnetCART Namespace : Suppliers Class

For a list of all members of this type, see Suppliers members.

Public Methods

 | Name | Description
Public Method | Add | Adds an object to the end of the collection. (Inherited from dotnetCART.ListBase<Supplier>)
Public Method | AddRange | Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetCART.ListBase<Supplier>)
Public Method | AsReadOnly | Returns a read-only IList wrapper for the current collection. (Inherited from dotnetCART.ListBase<Supplier>)
Public Method | BinarySearch | Overloaded. (Inherited from dotnetCART.ListBase<Supplier>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetCART.ListBase<Supplier>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetCART.ListBase<Supplier>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<Supplier>)
Public Method | CopyTo | Overloaded. (Inherited from dotnetCART.ListBase<Supplier>)
Public Method | GetCountDB | Overloaded. Gets the total number of items in the Suppliers table.
Public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from dotnetCART.ListBase<Supplier>)
Public Method | IndexOf | Overloaded. (Inherited from dotnetCART.ListBase<Supplier>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetCART.ListBase<Supplier>)
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from dotnetCART.ListBase<Supplier>)
Public Method | LastIndexOf | Overloaded. (Inherited from dotnetCART.ListBase<Supplier>)
Public Method | LoadDB | Overloaded. Overridden. Loads all the items from its associated table based on the where clause, start and count values.
Public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from dotnetCART.ListBase<Supplier>)
Public Method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from dotnetCART.ListBase<Supplier>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetCART.ListBase<Supplier>)
Public Method | RemoveRange | Removes a range of elements from the List. (Inherited from dotnetCART.ListBase<Supplier>)
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<Supplier>)
Top

See Also

Reference

Suppliers Class
dotnetCART Namespace


%%PageItemTitle%%

GetCountDB Method
[image]
dotnetCART Namespace > Suppliers Class : GetCountDB Method

Gets the total number of items in the Suppliers table.

Overload List

Overload | Description
GetCountDB() | Gets the total number of items in the Suppliers table.
GetCountDB(Where) | Gets the total number of items in the Suppliers table.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Suppliers Class
Suppliers Members


%%PageItemTitle%%

GetCountDB() Method
[image]
dotnetCART Namespace > Suppliers Class > GetCountDB Method : GetCountDB() Method

Gets the total number of items in the Suppliers table.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCountDB() As Integer
C#
public int GetCountDB()

Return Value

Returns the number of elements in the Suppliers table.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Suppliers Class
Suppliers Members
Overload List


%%PageItemTitle%%

GetCountDB(Where) Method
[image]
dotnetCART Namespace > Suppliers Class > GetCountDB Method : GetCountDB(Where) Method

whereClause
The where clause to filter the items.
Gets the total number of items in the Suppliers table.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCountDB( _
   ByVal whereClause As Where _
) As Integer
C#
public int GetCountDB(
   Where whereClause
)

Parameters

whereClause
The where clause to filter the items.

Return Value

Returns the number of elements in the Suppliers table.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Suppliers Class
Suppliers Members
Overload List


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > Suppliers Class : LoadDB Method

Loads all the items from its associated table based on the where clause, start and count values.

Overload List

Overload | Description
LoadDB(Where,Int32,Int32,String,OrderDirection) | Loads all the items from its associated table based on the where clause, start and count values.
LoadDB() | Loads all the items from its associated table. (Inherited from dotnetCART.ListBase<Supplier>)
LoadDB(Where) | Loads all the items from its associated table based on the where clause. (Inherited from dotnetCART.ListBase<Supplier>)
LoadDB(Int32,Int32) | Loads the count number of elements from start value. (Inherited from dotnetCART.ListBase<Supplier>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Suppliers Class
Suppliers Members


%%PageItemTitle%%

LoadDB(Where,Int32,Int32,String,OrderDirection) Method
[image]
dotnetCART Namespace > Suppliers Class > LoadDB Method : LoadDB(Where,Int32,Int32,String,OrderDirection) Method

whereClause
The where clause to filter the items.
start
The start page which starts from 0.
count
The number of items in the page.
orderBy
The order of the loaded items.
orderDirection
The order direction of the loaded items. Defaults is Asc.
Loads all the items from its associated table based on the where clause, start and count values.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function LoadDB( _
   ByVal whereClause As Where, _
   ByVal start As Integer, _
   ByVal count As Integer, _
   ByVal orderBy As String, _
   ByVal orderDirection As OrderDirection _
) As Integer
C#
public override int LoadDB(
   Where whereClause,
   int start,
   int count,
   string orderBy,
   OrderDirection orderDirection
)

Parameters

whereClause
The where clause to filter the items.
start
The start page which starts from 0.
count
The number of items in the page.
orderBy
The order of the loaded items.
orderDirection
The order direction of the loaded items. Defaults is Asc.

Return Value

The total number of items have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Suppliers Class
Suppliers Members
Overload List


%%PageItemTitle%% $$Properties$$

Suppliers Class Properties
[image]
dotnetCART Namespace : Suppliers Class

For a list of all members of this type, see Suppliers members.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from dotnetCART.ListBase<Supplier>)
Public Property | Count | Gets the number of elements actually contained in the collection. (Inherited from dotnetCART.ListBase<Supplier>)
Public Property | Error | Returns an object with the error information. (Inherited from dotnetCART.ListBase<Supplier>)
Public Property | Item | Overloaded. Gets the supplier with the specified name.
Top

See Also

Reference

Suppliers Class
dotnetCART Namespace


%%PageItemTitle%%

Item Property
[image]
dotnetCART Namespace > Suppliers Class : Item Property

Gets the supplier with the specified name.

Overload List

Overload | Description
Item(String) | Gets the supplier with the specified name.
Item(Int32) | Gets or sets the element at the specified index. (Inherited from dotnetCART.ListBase<Supplier>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Suppliers Class
Suppliers Members


%%PageItemTitle%%

Item(String) Property
[image]
dotnetCART Namespace > Suppliers Class > Item Property : Item(String) Property

name
The name of the supplier.
Gets the supplier with the specified name.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal name As String _
) As Supplier
C#
public Supplier Item(
   string name
) {get;}

Parameters

name
The name of the supplier.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Suppliers Class
Suppliers Members
Overload List


%%PageItemTitle%%

Tax Class
See Also Members
[image]
dotnetCART Namespace : Tax Class

Represents a tax object.

Object Model

Syntax

Visual Basic (Declaration)
Public Class Tax
   Inherits DbTableCart(Of Tax, Long)
C#
public class Tax : DbTableCart<Tax, long>

Inheritance Hierarchy

System.Object
dotnetDATA.DbTable<Int64>
dotnetDATA.DbTable<Tax, Int64>
dotnetCART.DbTableCart<Tax, Int64>
dotnetCART.Tax

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Tax Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

Tax Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : Tax Class

The following tables list the members exposed by Tax.

Public Constructors

 | Name | Description
Public Constructor | Tax Constructor | Initializes a new instance of the Tax class.
Top

Public Properties

 | Name | Description
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<Tax, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<Tax, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<Tax, Int64>)
Public Property | Default | Determines if the tax is a default tax for all items that don't have an item level tax override.
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<Tax, Int64>)
Public Property | ID | Overridden. ID is not being used for Tax and it doesn't exist in Taxes table.
Public Property | Included | Determinse whether the tax is included in the total or not.
Public Property | ItemID | Sets or gets the ItemID
Public Property | LocationID | Sets or gets the LocationID
Public Property | Name | Gets or sets this tax's name.
Public Property | Rate | Gets or sets the rate (percentage) for this tax.
Public Property | Total | The total amount of tax for a given tax name, this can be manually set or it can be calculated automatically by the calculate method.
Top

Public Methods

 | Name | Description
Public Method | Calculate | Calculate the tax for this amount with the value in Rate property.
Public Method | Clear | Overridden. Initializes all the properties without recreating the object.
Public Method | Clone | Creates a copy of the current Tax
Public Method | DeleteDB | Overloaded. Overridden. Deletes all the records from Taxes table with the same Name and LocationID or ItemID properties.
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<Tax, Int64>)
Public Method | LoadDB | Overloaded. Overridden.
Public Method | SaveDB | Overloaded. Overridden. Inserts or updates this object into the Taxes table.
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<Tax, Int64>)
Top

See Also

Reference

Tax Class
dotnetCART Namespace


%%PageItemTitle%%

Tax Constructor
[image]
dotnetCART Namespace > Tax Class : Tax Constructor

Initializes a new instance of the Tax class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Tax()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Tax Class
Tax Members


%%PageItemTitle%% $$Methods$$

Tax Class Methods
[image]
dotnetCART Namespace : Tax Class

For a list of all members of this type, see Tax members.

Public Methods

 | Name | Description
Public Method | Calculate | Calculate the tax for this amount with the value in Rate property.
Public Method | Clear | Overridden. Initializes all the properties without recreating the object.
Public Method | Clone | Creates a copy of the current Tax
Public Method | DeleteDB | Overloaded. Overridden. Deletes all the records from Taxes table with the same Name and LocationID or ItemID properties.
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<Tax, Int64>)
Public Method | LoadDB | Overloaded. Overridden.
Public Method | SaveDB | Overloaded. Overridden. Inserts or updates this object into the Taxes table.
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<Tax, Int64>)
Top

See Also

Reference

Tax Class
dotnetCART Namespace


%%PageItemTitle%%

Calculate Method
[image]
dotnetCART Namespace > Tax Class : Calculate Method

amount
An amount to be calculated.
Calculate the tax for this amount with the value in Rate property.

Syntax

Visual Basic (Declaration)
Public Function Calculate( _
   ByVal amount As Double _
) As Double
C#
public double Calculate(
   double amount
)

Parameters

amount
An amount to be calculated.

Return Value

The calculated amount.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Tax Class
Tax Members


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > Tax Class : Clear Method

Initializes all the properties without recreating the object.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Clear()
C#
public override void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Tax Class
Tax Members


%%PageItemTitle%%

Clone Method
[image]
dotnetCART Namespace > Tax Class : Clone Method

Creates a copy of the current Tax

Syntax

Visual Basic (Declaration)
Public Function Clone() As Tax
C#
public Tax Clone()

Return Value

Returns a Tax object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Tax Class
Tax Members


%%PageItemTitle%%

DeleteDB Method
[image]
dotnetCART Namespace > Tax Class : DeleteDB Method

Deletes all the records from Taxes table with the same Name and LocationID or ItemID properties.

Overload List

Overload | Description
DeleteDB() | Deletes all the records from Taxes table with the same Name and LocationID or ItemID properties.
DeleteDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Tax Class
Tax Members


%%PageItemTitle%%

DeleteDB() Method
[image]
dotnetCART Namespace > Tax Class > DeleteDB Method : DeleteDB() Method

Deletes all the records from Taxes table with the same Name and LocationID or ItemID properties.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function DeleteDB() As Integer
C#
public override int DeleteDB()

Return Value

In case of error -1, check Error property, otherwise the number of records deleted.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Tax Class
Tax Members
Overload List


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > Tax Class : LoadDB Method

Overload List

Overload | Description
LoadDB() |
LoadDB(Int64) | (Inherited from dotnetCART.DbTableCart<Tax, Int64>)
Generic LoadDB() | (Inherited from dotnetDATA.DbTable<Int64>)
Generic LoadDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Tax Class
Tax Members


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > Tax Class > LoadDB Method : LoadDB() Method

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function LoadDB() As Integer
C#
public override int LoadDB()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Tax Class
Tax Members
Overload List


%%PageItemTitle%%

SaveDB Method
[image]
dotnetCART Namespace > Tax Class : SaveDB Method

Inserts or updates this object into the Taxes table.

Overload List

Overload | Description
SaveDB() | Inserts or updates this object into the Taxes table.
SaveDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Tax Class
Tax Members


%%PageItemTitle%%

SaveDB() Method
[image]
dotnetCART Namespace > Tax Class > SaveDB Method : SaveDB() Method

Inserts or updates this object into the Taxes table.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function SaveDB() As Integer
C#
public override int SaveDB()

Return Value

Returns 1 for the success, and -1 if failed. For the reason of fail, check the Error property.

Remarks

If ID greater than 0, it updates the associated record in the table, otherwise inserts a new record.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Tax Class
Tax Members
Overload List


%%PageItemTitle%% $$Properties$$

Tax Class Properties
[image]
dotnetCART Namespace : Tax Class

For a list of all members of this type, see Tax members.

Public Properties

 | Name | Description
Public Property | Custom | Gets or sets a custom object. For more information see custom fields (Inherited from dotnetCART.DbTableCart<Tax, Int64>)
Public Property | CustomFields | Gets or sets a the names of custom fields for a table associated with the object. (Inherited from dotnetCART.DbTableCart<Tax, Int64>)
Public Property | Customs | A reference to the collection of the Custom objects. (Inherited from dotnetCART.DbTableCart<Tax, Int64>)
Public Property | Default | Determines if the tax is a default tax for all items that don't have an item level tax override.
Public Property | Error | Gets the error object. (Inherited from dotnetCART.DbTableCart<Tax, Int64>)
Public Property | ID | Overridden. ID is not being used for Tax and it doesn't exist in Taxes table.
Public Property | Included | Determinse whether the tax is included in the total or not.
Public Property | ItemID | Sets or gets the ItemID
Public Property | LocationID | Sets or gets the LocationID
Public Property | Name | Gets or sets this tax's name.
Public Property | Rate | Gets or sets the rate (percentage) for this tax.
Public Property | Total | The total amount of tax for a given tax name, this can be manually set or it can be calculated automatically by the calculate method.
Top

See Also

Reference

Tax Class
dotnetCART Namespace


%%PageItemTitle%%

Default Property
[image]
dotnetCART Namespace > Tax Class : Default Property

Determines if the tax is a default tax for all items that don't have an item level tax override.

Syntax

Visual Basic (Declaration)
Public Property Default As Boolean
C#
public bool Default {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Tax Class
Tax Members


%%PageItemTitle%%

ID Property
[image]
dotnetCART Namespace > Tax Class : ID Property

ID is not being used for Tax and it doesn't exist in Taxes table.

Syntax

Visual Basic (Declaration)
Public Overrides Property ID As Long
C#
public override long ID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Tax Class
Tax Members


%%PageItemTitle%%

Included Property
[image]
dotnetCART Namespace > Tax Class : Included Property

Determinse whether the tax is included in the total or not.

Syntax

Visual Basic (Declaration)
Public Property Included As Boolean
C#
public bool Included {get; set;}

Remarks

This boolean value controls if a given tax is calculated as included in the total or in addition to the total. This property defaults to false. For example a $25.00 item with 1050 when included is false already be included so the total would be $10.00 and back calculating the tax would give you $2.27.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Tax Class
Tax Members


%%PageItemTitle%%

ItemID Property
[image]
dotnetCART Namespace > Tax Class : ItemID Property

Sets or gets the ItemID

Syntax

Visual Basic (Declaration)
Public Property ItemID As String
C#
public string ItemID {get; set;}

Remarks

Tax name must exist at Cart.Tax level in order for an item level tax to apply. If the default=true at the Cart level, any item with default=false, will be tax exempt. When default=false at the Cart level, any item with default=true, is taxed for that specific tax. Included is defined at a per tax level only and has no effect at the item level.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Tax Class
Tax Members


%%PageItemTitle%%

LocationID Property
[image]
dotnetCART Namespace > Tax Class : LocationID Property

Sets or gets the LocationID

Syntax

Visual Basic (Declaration)
Public Property LocationID As Long
C#
public long LocationID {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Tax Class
Tax Members


%%PageItemTitle%%

Name Property
[image]
dotnetCART Namespace > Tax Class : Name Property

Gets or sets this tax's name.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Tax Class
Tax Members


%%PageItemTitle%%

Rate Property
[image]
dotnetCART Namespace > Tax Class : Rate Property

Gets or sets the rate (percentage) for this tax.

Syntax

Visual Basic (Declaration)
Public Property Rate As String
C#
public string Rate {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Tax Class
Tax Members


%%PageItemTitle%%

Total Property
[image]
dotnetCART Namespace > Tax Class : Total Property

The total amount of tax for a given tax name, this can be manually set or it can be calculated automatically by the calculate method.

Syntax

Visual Basic (Declaration)
Public Property Total As Decimal
C#
public decimal Total {get; set;}

Remarks

Typically this property is populated by a calculate method call.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Tax Class
Tax Members


%%PageItemTitle%%

Taxes Class
See Also Members
[image]
dotnetCART Namespace : Taxes Class

A collection of Tax objects.

Object Model

Syntax

Visual Basic (Declaration)
Public Class Taxes
   Inherits List(Of Tax)
C#
public class Taxes : List<Tax>

Inheritance Hierarchy

System.Object
System.Collections.Generic.List<Tax>
dotnetCART.Taxes

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Taxes Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

Taxes Class Members
See Also Properties Methods
[image]
dotnetCART Namespace : Taxes Class

The following tables list the members exposed by Taxes.

Public Constructors

 | Name | Description
Public Constructor | Taxes Constructor | Initializes a new instance of the Taxes class.
Top

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing.
Public Property | Count | Gets the number of elements actually contained in the collection.
Public Property | Error | Returns an object with the error information.
Public Property | Item | Overloaded. Returns the tax with the name.
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds an object to the end of the collection.
Public Method | AddRange | Adds the elements of the specified collection to the end of the collection.
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List<Tax>)
Public Method | BinarySearch | Overloaded.
Public Method | Clear | Removes all elements from the List.
Public Method | Contains | Determines whether an element is in the List.
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<Tax>)
Public Method | CopyTo | Overloaded.
Public Method | FindIndex | Overloaded.
Public Method | FindLastIndex | Overloaded.
Public Method | GetEnumerator | Returns an enumerator that iterates through the List.
Public Method | IndexOf | Overloaded.
Public Method | Insert | Inserts an element into the List at the specified index.
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index.
Public Method | LastIndexOf | Overloaded.
Public Method | LoadDB | Overloaded. Loads any applicable taxes from the database into the parent object.
Public Method | Remove | Removes the first occurrence of a specific object from the List.
Public Method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate.
Public Method | RemoveAt | Removes the element at the specified index of the List.
Public Method | RemoveRange | Removes a range of elements from the List.
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List.
Public Method | Sort | Overloaded.
Top

See Also

Reference

Taxes Class
dotnetCART Namespace


%%PageItemTitle%%

Taxes Constructor
[image]
dotnetCART Namespace > Taxes Class : Taxes Constructor

Initializes a new instance of the Taxes class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Taxes()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Taxes Class
Taxes Members


%%PageItemTitle%% $$Methods$$

Taxes Class Methods
[image]
dotnetCART Namespace : Taxes Class

For a list of all members of this type, see Taxes members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds an object to the end of the collection.
Public Method | AddRange | Adds the elements of the specified collection to the end of the collection.
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List<Tax>)
Public Method | BinarySearch | Overloaded.
Public Method | Clear | Removes all elements from the List.
Public Method | Contains | Determines whether an element is in the List.
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<Tax>)
Public Method | CopyTo | Overloaded.
Public Method | FindIndex | Overloaded.
Public Method | FindLastIndex | Overloaded.
Public Method | GetEnumerator | Returns an enumerator that iterates through the List.
Public Method | IndexOf | Overloaded.
Public Method | Insert | Inserts an element into the List at the specified index.
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index.
Public Method | LastIndexOf | Overloaded.
Public Method | LoadDB | Overloaded. Loads any applicable taxes from the database into the parent object.
Public Method | Remove | Removes the first occurrence of a specific object from the List.
Public Method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate.
Public Method | RemoveAt | Removes the element at the specified index of the List.
Public Method | RemoveRange | Removes a range of elements from the List.
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List.
Public Method | Sort | Overloaded.
Top

See Also

Reference

Taxes Class
dotnetCART Namespace


%%PageItemTitle%%

Add Method
[image]
dotnetCART Namespace > Taxes Class : Add Method

Adds an object to the end of the collection.

Overload List

Overload | Description
Add() | Adds an object to the end of the collection.
Add(Tax) | Adds an object to the end of the collection.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Taxes Class
Taxes Members


%%PageItemTitle%%

Add() Method
[image]
dotnetCART Namespace > Taxes Class > Add Method : Add() Method

Adds an object to the end of the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add()
C#
public void Add()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Taxes Class
Taxes Members
Overload List


%%PageItemTitle%%

Add(Tax) Method
[image]
dotnetCART Namespace > Taxes Class > Add Method : Add(Tax) Method

item
The object to be added to the end of the List. The value can be a null reference (Nothing in Visual Basic) for reference types.
Adds an object to the end of the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add( _
   ByVal item As Tax _
)
C#
public void Add(
   Tax item
)

Parameters

item
The object to be added to the end of the List. The value can be a null reference (Nothing in Visual Basic) for reference types.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Taxes Class
Taxes Members
Overload List


%%PageItemTitle%%

AddRange Method
[image]
dotnetCART Namespace > Taxes Class : AddRange Method

collection
The collection whose elements should be added to the end of the List. The collection itself cannot be a null reference (Nothing in Visual Basic), but it can contain elements that are a null reference (Nothing in Visual Basic), if type Tax is a reference type.
Adds the elements of the specified collection to the end of the collection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal collection As IEnumerable(Of Tax) _
)
C#
public void AddRange(
   IEnumerable<Tax> collection
)

Parameters

collection
The collection whose elements should be added to the end of the List. The collection itself cannot be a null reference (Nothing in Visual Basic), but it can contain elements that are a null reference (Nothing in Visual Basic), if type Tax is a reference type.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Taxes Class
Taxes Members


%%PageItemTitle%%

BinarySearch Method
[image]
dotnetCART Namespace > Taxes Class : BinarySearch Method

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Taxes Class
Taxes Members


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > Taxes Class : Clear Method

Removes all elements from the List.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Taxes Class
Taxes Members


%%PageItemTitle%%

Contains Method
[image]
dotnetCART Namespace > Taxes Class : Contains Method

item
The object to locate in the List. The value can be a null reference (Nothing in Visual Basic) for reference types.
Determines whether an element is in the List.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal item As Tax _
) As Boolean
C#
public bool Contains(
   Tax item
)

Parameters

item
The object to locate in the List. The value can be a null reference (Nothing in Visual Basic) for reference types.

Return Value

true if item is found in the List; otherwise, false.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Taxes Class
Taxes Members


%%PageItemTitle%%

CopyTo Method
[image]
dotnetCART Namespace > Taxes Class : CopyTo Method

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Taxes Class
Taxes Members


%%PageItemTitle%%

FindIndex Method
[image]
dotnetCART Namespace > Taxes Class : FindIndex Method

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Taxes Class
Taxes Members


%%PageItemTitle%%

FindLastIndex Method
[image]
dotnetCART Namespace > Taxes Class : FindLastIndex Method

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Taxes Class
Taxes Members


%%PageItemTitle%%

GetEnumerator Method
[image]
dotnetCART Namespace > Taxes Class : GetEnumerator Method

Returns an enumerator that iterates through the List.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As List.Enumerator(Of Tax)
C#
public List.Enumerator<Tax> GetEnumerator()

Return Value

A List.Enumerator for the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Taxes Class
Taxes Members


%%PageItemTitle%%

IndexOf Method
[image]
dotnetCART Namespace > Taxes Class : IndexOf Method

Overload List

Overload | Description
IndexOf(Tax,Int32) |

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Taxes Class
Taxes Members


%%PageItemTitle%%

IndexOf(Tax,Int32) Method
[image]
dotnetCART Namespace > Taxes Class > IndexOf Method : IndexOf(Tax,Int32) Method

item
index

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As Tax, _
   ByVal index As Integer _
) As Integer
C#
public int IndexOf(
   Tax item,
   int index
)

Parameters

item
index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Taxes Class
Taxes Members
Overload List


%%PageItemTitle%%

Insert Method
[image]
dotnetCART Namespace > Taxes Class : Insert Method

index
The zero-based index at which item should be inserted.
item
The object to insert. The value can be a null reference (Nothing in Visual Basic) for reference types.
Inserts an element into the List at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As Tax _
)
C#
public void Insert(
   int index,
   Tax item
)

Parameters

index
The zero-based index at which item should be inserted.
item
The object to insert. The value can be a null reference (Nothing in Visual Basic) for reference types.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Taxes Class
Taxes Members


%%PageItemTitle%%

InsertRange Method
[image]
dotnetCART Namespace > Taxes Class : InsertRange Method

index
The zero-based index at which the new elements should be inserted.
collection
The collection whose elements should be inserted into the List. The collection itself cannot be a null reference (Nothing in Visual Basic), but it can contain elements that are a null reference (Nothing in Visual Basic), if type Tax is a reference type.
Inserts the elements of a collection into the List at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub InsertRange( _
   ByVal index As Integer, _
   ByVal collection As IEnumerable(Of Tax) _
)
C#
public void InsertRange(
   int index,
   IEnumerable<Tax> collection
)

Parameters

index
The zero-based index at which the new elements should be inserted.
collection
The collection whose elements should be inserted into the List. The collection itself cannot be a null reference (Nothing in Visual Basic), but it can contain elements that are a null reference (Nothing in Visual Basic), if type Tax is a reference type.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Taxes Class
Taxes Members


%%PageItemTitle%%

LastIndexOf Method
[image]
dotnetCART Namespace > Taxes Class : LastIndexOf Method

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Taxes Class
Taxes Members


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > Taxes Class : LoadDB Method

Loads any applicable taxes from the database into the parent object.

Overload List

Overload | Description
LoadDB() | Loads any applicable taxes from the database into the parent object.
LoadDB(Boolean) |

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Taxes Class
Taxes Members


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > Taxes Class > LoadDB Method : LoadDB() Method

Loads any applicable taxes from the database into the parent object.

Syntax

Visual Basic (Declaration)
Public Overloads Function LoadDB() As Integer
C#
public int LoadDB()

Return Value

The total number of loaded tax. In case of error -1, then see the parent Error object for more information.

Remarks

If calling from Cart.Taxes, it loads applicable taxes which applies due to a location match with the Cart.BillAddress. If calling from Item.Taxes, it loads the associated taxes with the item. If calling from Location.Taxes, it loads all the taxes associated with that location. For more inforamtion about tax configuration, please see Locations->Taxes

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Taxes Class
Taxes Members
Overload List


%%PageItemTitle%%

LoadDB(Boolean) Method
[image]
dotnetCART Namespace > Taxes Class > LoadDB Method : LoadDB(Boolean) Method

includeChildren

Syntax

Visual Basic (Declaration)
Public Overloads Function LoadDB( _
   ByVal includeChildren As Boolean _
) As Integer
C#
public int LoadDB(
   bool includeChildren
)

Parameters

includeChildren

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Taxes Class
Taxes Members
Overload List


%%PageItemTitle%%

Remove Method
[image]
dotnetCART Namespace > Taxes Class : Remove Method

item
The object to remove from the List. The value can be a null reference (Nothing in Visual Basic) for reference types.
Removes the first occurrence of a specific object from the List.

Syntax

Visual Basic (Declaration)
Public Function Remove( _
   ByVal item As Tax _
) As Boolean
C#
public bool Remove(
   Tax item
)

Parameters

item
The object to remove from the List. The value can be a null reference (Nothing in Visual Basic) for reference types.

Return Value

true if item is successfully removed; otherwise, false. This method also returns false if item was not found in the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Taxes Class
Taxes Members


%%PageItemTitle%%

RemoveAll Method
[image]
dotnetCART Namespace > Taxes Class : RemoveAll Method

match
The Predicate delegate that defines the conditions of the elements to remove.
Removes the all the elements that match the conditions defined by the specified predicate.

Syntax

Visual Basic (Declaration)
Public Function RemoveAll( _
   ByVal match As Predicate(Of Tax) _
) As Integer
C#
public int RemoveAll(
   Predicate<Tax> match
)

Parameters

match
The Predicate delegate that defines the conditions of the elements to remove.

Return Value

The number of elements removed from the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Taxes Class
Taxes Members


%%PageItemTitle%%

RemoveAt Method
[image]
dotnetCART Namespace > Taxes Class : RemoveAt Method

index
The zero-based index of the element to remove.
Removes the element at the specified index of the List.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index
The zero-based index of the element to remove.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Taxes Class
Taxes Members


%%PageItemTitle%%

RemoveRange Method
[image]
dotnetCART Namespace > Taxes Class : RemoveRange Method

index
The zero-based starting index of the range of elements to remove.
count
The number of elements to remove.
Removes a range of elements from the List.

Syntax

Visual Basic (Declaration)
Public Sub RemoveRange( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
C#
public void RemoveRange(
   int index,
   int count
)

Parameters

index
The zero-based starting index of the range of elements to remove.
count
The number of elements to remove.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Taxes Class
Taxes Members


%%PageItemTitle%%

Reverse Method
[image]
dotnetCART Namespace > Taxes Class : Reverse Method

Reverses the order of the elements in the entire List.

Overload List

Overload | Description
Reverse() | Reverses the order of the elements in the entire List.
Reverse(Int32,Int32) | Reverses the order of the elements in the specified range.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Taxes Class
Taxes Members


%%PageItemTitle%%

Reverse() Method
[image]
dotnetCART Namespace > Taxes Class > Reverse Method : Reverse() Method

Reverses the order of the elements in the entire List.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Reverse()
C#
public void Reverse()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Taxes Class
Taxes Members
Overload List


%%PageItemTitle%%

Reverse(Int32,Int32) Method
[image]
dotnetCART Namespace > Taxes Class > Reverse Method : Reverse(Int32,Int32) Method

index
The zero-based starting index of the range to reverse.
count
The number of elements in the range to reverse.
Reverses the order of the elements in the specified range.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Reverse( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
C#
public void Reverse(
   int index,
   int count
)

Parameters

index
The zero-based starting index of the range to reverse.
count
The number of elements in the range to reverse.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Taxes Class
Taxes Members
Overload List


%%PageItemTitle%%

Sort Method
[image]
dotnetCART Namespace > Taxes Class : Sort Method

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Taxes Class
Taxes Members


%%PageItemTitle%% $$Properties$$

Taxes Class Properties
[image]
dotnetCART Namespace : Taxes Class

For a list of all members of this type, see Taxes members.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing.
Public Property | Count | Gets the number of elements actually contained in the collection.
Public Property | Error | Returns an object with the error information.
Public Property | Item | Overloaded. Returns the tax with the name.
Top

See Also

Reference

Taxes Class
dotnetCART Namespace


%%PageItemTitle%%

Capacity Property
[image]
dotnetCART Namespace > Taxes Class : Capacity Property

Gets or sets the total number of elements the internal data structure can hold without resizing.

Syntax

Visual Basic (Declaration)
Public Property Capacity As Integer
C#
public int Capacity {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Taxes Class
Taxes Members


%%PageItemTitle%%

Count Property
[image]
dotnetCART Namespace > Taxes Class : Count Property

Gets the number of elements actually contained in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Taxes Class
Taxes Members


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > Taxes Class : Error Property

Returns an object with the error information.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Taxes Class
Taxes Members


%%PageItemTitle%%

Item Property
[image]
dotnetCART Namespace > Taxes Class : Item Property

Returns the tax with the name.

Overload List

Overload | Description
Item(String) | Returns the tax with the name.
Item(Int32) | Gets or sets the element at the specified index.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Taxes Class
Taxes Members


%%PageItemTitle%%

Item(String) Property
[image]
dotnetCART Namespace > Taxes Class > Item Property : Item(String) Property

name
Returns the tax with the name.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal name As String _
) As Tax
C#
public Tax Item(
   string name
) {get;}

Parameters

name

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Taxes Class
Taxes Members
Overload List


%%PageItemTitle%%

Item(Int32) Property
[image]
dotnetCART Namespace > Taxes Class > Item Property : Item(Int32) Property

index
The zero-based index of the element to get or set.
Gets or sets the element at the specified index.

Syntax

Visual Basic (Declaration)
Public Overloads Property Item( _
   ByVal index As Integer _
) As Tax
C#
public Tax Item(
   int index
) {get; set;}

Parameters

index
The zero-based index of the element to get or set.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Taxes Class
Taxes Members
Overload List


%%PageItemTitle%%

Tools Class
See Also Members
[image]
dotnetCART Namespace : Tools Class

Provide a reference to Tools object.

Syntax

Visual Basic (Declaration)
Public Class Tools
C#
public class Tools

Inheritance Hierarchy

System.Object
dotnetCART.Tools

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Tools Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

Tools Class Members
See Also Methods
[image]
dotnetCART Namespace : Tools Class

The following tables list the members exposed by Tools.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CreateID | Overloaded. Create a unique ID.
static (Shared in Visual Basic) | Decrypt | Overloaded. Decrypt data base on Rijndael algorithm by using Store.Settings.EncryptionKey.
static (Shared in Visual Basic) | Encrypt | Overloaded. Encrypt data bsed on Rijndael algorithm by using Store.Settings.EncryptionKey.
static (Shared in Visual Basic) | Hash | Hash the string.
static (Shared in Visual Basic) | Protect | Overloaded. Protects the inputData parameter and returns a string.
static (Shared in Visual Basic) | Unprotect | Overloaded. Unprotects the inputData parameter and returns a string.
static (Shared in Visual Basic) | ValidateServer | Use Settings.AuthorizedServer property and server variable "HTTP_REFERER" to validate the remote post.
Top

See Also

Reference

Tools Class
dotnetCART Namespace


%%PageItemTitle%% $$Methods$$

Tools Class Methods
[image]
dotnetCART Namespace : Tools Class

For a list of all members of this type, see Tools members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CreateID | Overloaded. Create a unique ID.
static (Shared in Visual Basic) | Decrypt | Overloaded. Decrypt data base on Rijndael algorithm by using Store.Settings.EncryptionKey.
static (Shared in Visual Basic) | Encrypt | Overloaded. Encrypt data bsed on Rijndael algorithm by using Store.Settings.EncryptionKey.
static (Shared in Visual Basic) | Hash | Hash the string.
static (Shared in Visual Basic) | Protect | Overloaded. Protects the inputData parameter and returns a string.
static (Shared in Visual Basic) | Unprotect | Overloaded. Unprotects the inputData parameter and returns a string.
static (Shared in Visual Basic) | ValidateServer | Use Settings.AuthorizedServer property and server variable "HTTP_REFERER" to validate the remote post.
Top

See Also

Reference

Tools Class
dotnetCART Namespace


%%PageItemTitle%%

CreateID Method
[image]
dotnetCART Namespace > Tools Class : CreateID Method

Create a unique ID.

Overload List

Overload | Description
CreateID() | Create a unique ID.
CreateID(Int32) | Create a unique ID.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Tools Class
Tools Members


%%PageItemTitle%%

CreateID() Method
[image]
dotnetCART Namespace > Tools Class > CreateID Method : CreateID() Method

Create a unique ID.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CreateID() As String
C#
public static string CreateID()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Tools Class
Tools Members
Overload List


%%PageItemTitle%%

CreateID(Int32) Method
[image]
dotnetCART Namespace > Tools Class > CreateID Method : CreateID(Int32) Method

numBytes
The length of the ID.
Create a unique ID.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CreateID( _
   ByVal numBytes As Integer _
) As String
C#
public static string CreateID(
   int numBytes
)

Parameters

numBytes
The length of the ID.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Tools Class
Tools Members
Overload List


%%PageItemTitle%%

Decrypt Method
[image]
dotnetCART Namespace > Tools Class : Decrypt Method

Decrypt data base on Rijndael algorithm by using Store.Settings.EncryptionKey.

Overload List

Overload | Description
Decrypt(String) | Decrypt data base on Rijndael algorithm by using Store.Settings.EncryptionKey.
Decrypt(String,String) | Decrypt data bsed on Rijndael algorithm by using Store.Settings.EncryptionKey.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Tools Class
Tools Members


%%PageItemTitle%%

Decrypt(String) Method
[image]
dotnetCART Namespace > Tools Class > Decrypt Method : Decrypt(String) Method

inputData
Encrypted data
Decrypt data base on Rijndael algorithm by using Store.Settings.EncryptionKey.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Decrypt( _
   ByVal inputData As String _
) As String
C#
public static string Decrypt(
   string inputData
)

Parameters

inputData
Encrypted data

Return Value

Decrypted data, if it fails to decrypt the inputData returns empty string.

Remarks

This method is internally used to decrypt Cart.IDfrom the cookie, credit card number from the database, database connection string, mail server name and SMTP password from the settings.config file.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Tools Class
Tools Members
Overload List


%%PageItemTitle%%

Decrypt(String,String) Method
[image]
dotnetCART Namespace > Tools Class > Decrypt Method : Decrypt(String,String) Method

inputData
Encrypted data.
inputKey
Encryption key.
Decrypt data bsed on Rijndael algorithm by using Store.Settings.EncryptionKey.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Decrypt( _
   ByVal inputData As String, _
   ByVal inputKey As String _
) As String
C#
public static string Decrypt(
   string inputData,
   string inputKey
)

Parameters

inputData
Encrypted data.
inputKey
Encryption key.

Return Value

Decrypted data, if it fails to decrypt the inputData returns empty string.

Remarks

This method is internally used to decrypt Cart.IDfrom the cookie, credit card number from the database, database connection string, mail server name and SMTP password from the settings.config file.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Tools Class
Tools Members
Overload List


%%PageItemTitle%%

Encrypt Method
[image]
dotnetCART Namespace > Tools Class : Encrypt Method

Encrypt data bsed on Rijndael algorithm by using Store.Settings.EncryptionKey.

Overload List

Overload | Description
Encrypt(String) | Encrypt data bsed on Rijndael algorithm by using Store.Settings.EncryptionKey.
Encrypt(String,String) | Encrypt data bsed on Rijndael algorithm.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Tools Class
Tools Members


%%PageItemTitle%%

Encrypt(String) Method
[image]
dotnetCART Namespace > Tools Class > Encrypt Method : Encrypt(String) Method

inputData
The data for encryption.
Encrypt data bsed on Rijndael algorithm by using Store.Settings.EncryptionKey.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Encrypt( _
   ByVal inputData As String _
) As String
C#
public static string Encrypt(
   string inputData
)

Parameters

inputData
The data for encryption.

Return Value

Encrypted data,if it fails to encrypt the inputData returns empty string.

Remarks

This method is internally used to encrypt Cart.IDin the cookie, credit card number in the database, database connection string, mail server name and SMTP password in the settings.config file. If Store.Settings.EncryptionKey (StoreAdmin->Settings->General) is empty or null, it returns empty string.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Tools Class
Tools Members
Overload List


%%PageItemTitle%%

Encrypt(String,String) Method
[image]
dotnetCART Namespace > Tools Class > Encrypt Method : Encrypt(String,String) Method

inputData
The data for encryption.
inputKey
Encryption key.
Encrypt data bsed on Rijndael algorithm.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Encrypt( _
   ByVal inputData As String, _
   ByVal inputKey As String _
) As String
C#
public static string Encrypt(
   string inputData,
   string inputKey
)

Parameters

inputData
The data for encryption.
inputKey
Encryption key.

Return Value

Encrypted data,if it fails to encrypt the inputData returns empty string.

Remarks

This method is internally used to encrypt Cart.IDin the cookie, credit card number in the database, database connection string, mail server name and SMTP password in the settings.config file.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Tools Class
Tools Members
Overload List


%%PageItemTitle%%

Hash Method
[image]
dotnetCART Namespace > Tools Class : Hash Method

stringToHash
The string for hash
Hash the string.

Syntax

Visual Basic (Declaration)
Public Shared Function Hash( _
   ByVal stringToHash As String _
) As String
C#
public static string Hash(
   string stringToHash
)

Parameters

stringToHash
The string for hash

Return Value

The hash of the string.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Tools Class
Tools Members


%%PageItemTitle%%

Protect Method
[image]
dotnetCART Namespace > Tools Class : Protect Method

Protects the inputData parameter and returns a string.

Overload List

Overload | Description
Protect(String,String) | Protects the inputData parameter and returns a string.
Protect(String) | Protects the inputData parameter and returns a string.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Tools Class
Tools Members


%%PageItemTitle%%

Protect(String,String) Method
[image]
dotnetCART Namespace > Tools Class > Protect Method : Protect(String,String) Method

inputData
The data should be protected.
error
Error object.
Protects the inputData parameter and returns a string.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Protect( _
   ByVal inputData As String, _
   ByRef error As String _
) As String
C#
public static string Protect(
   string inputData,
   ref string error
)

Parameters

inputData
The data should be protected.
error
Error object.

Return Value

The protected data. In case of error, returns inputData.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Tools Class
Tools Members
Overload List


%%PageItemTitle%%

Protect(String) Method
[image]
dotnetCART Namespace > Tools Class > Protect Method : Protect(String) Method

inputData
The data should be protected.
Protects the inputData parameter and returns a string.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Protect( _
   ByVal inputData As String _
) As String
C#
public static string Protect(
   string inputData
)

Parameters

inputData
The data should be protected.

Return Value

The protected data. In case of error, returns empty string.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Tools Class
Tools Members
Overload List


%%PageItemTitle%%

Unprotect Method
[image]
dotnetCART Namespace > Tools Class : Unprotect Method

Unprotects the inputData parameter and returns a string.

Overload List

Overload | Description
Unprotect(String) | Unprotects the inputData parameter and returns a string.
Unprotect(String,String) | Unprotects the inputData parameter and returns a string.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Tools Class
Tools Members


%%PageItemTitle%%

Unprotect(String) Method
[image]
dotnetCART Namespace > Tools Class > Unprotect Method : Unprotect(String) Method

inputData
The protected data.
Unprotects the inputData parameter and returns a string.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Unprotect( _
   ByVal inputData As String _
) As String
C#
public static string Unprotect(
   string inputData
)

Parameters

inputData
The protected data.

Return Value

Unprotected data. In case of error, returns empty string.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Tools Class
Tools Members
Overload List


%%PageItemTitle%%

Unprotect(String,String) Method
[image]
dotnetCART Namespace > Tools Class > Unprotect Method : Unprotect(String,String) Method

inputData
The protected data.
error
Error object.
Unprotects the inputData parameter and returns a string.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Unprotect( _
   ByVal inputData As String, _
   ByRef error As String _
) As String
C#
public static string Unprotect(
   string inputData,
   ref string error
)

Parameters

inputData
The protected data.
error
Error object.

Return Value

Unprotected data. In case of error, returns inputData.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Tools Class
Tools Members
Overload List


%%PageItemTitle%%

ValidateServer Method
[image]
dotnetCART Namespace > Tools Class : ValidateServer Method

Use Settings.AuthorizedServer property and server variable "HTTP_REFERER" to validate the remote post.

Syntax

Visual Basic (Declaration)
Public Shared Function ValidateServer() As Boolean
C#
public static bool ValidateServer()

Return Value

Returns true if the referrer exists in authorized server string, otherwise false.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Tools Class
Tools Members


%%PageItemTitle%%

CardNumberStorage Enumeration
[image]
dotnetCART Namespace : CardNumberStorage Enumeration

Defines different credit card number storage options.

Syntax

Visual Basic (Declaration)
Public Enum CardNumberStorage
   Inherits Enum
C#
public enum CardNumberStorage : Enum

Members

Member | Description
Disabled |
FullEncrypted |
FullHashOnly |
Last4Digits |
FirstLast4Digits |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCART.CardNumberStorage

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

dotnetCART Namespace


%%PageItemTitle%%

CouponType Enumeration
[image]
dotnetCART Namespace : CouponType Enumeration

Defines the type of the coupon.

Syntax

Visual Basic (Declaration)
Public Enum CouponType
   Inherits Enum
C#
public enum CouponType : Enum

Members

Member | Description
GiftCertificate |
Coupon |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCART.CouponType

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

dotnetCART Namespace


%%PageItemTitle%%

DataProviderType Enumeration
[image]
dotnetCART Namespace : DataProviderType Enumeration

Specifies a database type.

Syntax

Visual Basic (Declaration)
Public Enum DataProviderType
   Inherits Enum
C#
public enum DataProviderType : Enum

Members

Member | Description
MsSql | MS SQL database.
OleDb | OleDb Connection
MsAccess | Microsoft Access database.
MySql | MySql database.
Oracle | Oracle database.
MsOracle | Microsoft oracle provider.
Odbc | Odbc Drivers is being used when connecting to a DSN.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCART.DataProviderType

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

dotnetCART Namespace


%%PageItemTitle%%

OptionType Enumeration
[image]
dotnetCART Namespace : OptionType Enumeration

Defines different option types.

Syntax

Visual Basic (Declaration)
Public Enum OptionType
   Inherits Enum
C#
public enum OptionType : Enum

Members

Member | Description
DropDown |
Radio |
CheckBox |
TextBox |
TextArea |
Text |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCART.OptionType

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

dotnetCART Namespace


%%PageItemTitle%%

PaymentMethod Enumeration
[image]
dotnetCART Namespace : PaymentMethod Enumeration

Defines different payment methods.

Syntax

Visual Basic (Declaration)
Public Enum PaymentMethod
   Inherits Enum
C#
public enum PaymentMethod : Enum

Members

Member | Description
CreditCard |
Echeck |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCART.PaymentMethod

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

dotnetCART Namespace


%%PageItemTitle%%

Processor Enumeration
[image]
dotnetCART Namespace : Processor Enumeration

A list of the processors or gateways, for full documentation please see .netCHARGE documentation

Syntax

Visual Basic (Declaration)
Public Enum Processor
   Inherits Enum
C#
public enum Processor : Enum

Members

Member | Description
Amazon | For service and pricing information please see Amazon site Updated to API Version 2010-08-28
AuthorizeNet | Pricing and service information can be found here
Barclays | Pricing and service information can be found here.
CyberSource | Pricing and service information can be found here.
Echo | Pricing and service information can be found here.
ePoch | Pricing and service information can be found here.
eProcessing | Pricing and service information can be found here.
eSecPayments | Pricing and service information can be found here.
ElavonNative | Previously known as Nova Native, now Elavon Native (the company changed names). Pricing and service information can be found here.
ElavonConverge | Previously known as Virtual Merchant. Pricing and service information can be found here.
FirstData | Pricing and service information can be found here.
FirstDataGlobalGateway | Pricing and service information can be found here.
FirstDataGlobalGatewaye4 | Rebranded to Payeezy. Pricing and service information can be found here.
GlobalPayments | Pricing and service information can be found here.
HSBC | Pricing and service information can be found here.
Innovative | Pricing and service information can be found here.
Intellipay | Pricing and service information can be found here.
ingenico | Previously known as Ogone. Pricing and service information can be found here.
Itransact | Pricing and service information can be found here.
ItransactXml | Pricing and service information can be found here.
LinkPoint | Pricing and service information can be found here.
Mcps | Pricing and service information can be found here.
Moneris | Pricing and service information can be found here.
NaviGate | Pricing and service information can be found here.
NetBilling | Pricing and service information can be found here.
Ogone | Pricing and service information can be found here.
OptimalPayment | Pricing and service information can be found here.
Payeezy | Previously known as Global Gateway e4. Pricing and service information can be found here.
PayCom | Pricing and service information can be found here.
PayflowLink | Pricing and service information can be found here.
PayflowPro | Pricing and service information can be found here.
PayflowProExpress | Pricing and service information can be found here.
PaymentechNative | Pricing and service information can be found here.
PaymentechOrbital | Pricing and service information can be found here.
PayPal | Pricing and service information can be found here.
PayPalAdvanced | Pricing and service information can be found here.
PayPalPro | Pricing and service information can be found here.
PayPalProExpress | Pricing and service information can be found here.
PayReady | Pricing and service information can be found here.
PlanetPayment | Pricing and service information can be found here.
PlugnPay | Pricing and service information can be found here.
PSiGate | Pricing and service information can be found here.
QuickBooks | Pricing and service information can be found here.
QuickCommerce | Pricing and service information can be found here.
Realex | Pricing and service information can be found here.
SagePay | Pricing and service information can be found here.
SecurePay | Pricing and service information can be found here.
SkipJack | Pricing and service information can be found here.
Stripe | Pricing and service information can be found here.
TransFirst | Pricing and service information can be found here.
TrustCommerce | Pricing and service information can be found here.
Vital | Pricing and service information can be found here.
RbsWorldPay | Pricing and service information can be found here.
Validate | Validates credit card number and expiry date.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCART.Processor

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

dotnetCART Namespace


%%PageItemTitle%%

ShipCompanyType Enumeration
[image]
dotnetCART Namespace : ShipCompanyType Enumeration

Defines the type of ship company.

Syntax

Visual Basic (Declaration)
Public Enum ShipCompanyType
   Inherits Enum
C#
public enum ShipCompanyType : Enum

Members

Member | Description
All |
Real |
Custom |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCART.ShipCompanyType

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

dotnetCART Namespace


%%PageItemTitle%%

SortOrder Enumeration
[image]
dotnetCART Namespace : SortOrder Enumeration

Syntax

Visual Basic (Declaration)
Public Enum SortOrder
   Inherits Enum
C#
public enum SortOrder : Enum

Members

Member | Description
None |
Ascending |
Descending |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCART.SortOrder

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

dotnetCART Namespace


%%PageItemTitle%%

Tables Enumeration
[image]
dotnetCART Namespace : Tables Enumeration

A list of the tables with custom fields support. For more information see custom fields

Syntax

Visual Basic (Declaration)
Public Enum Tables
   Inherits Enum
C#
public enum Tables : Enum

Members

Member | Description
ActivityLogs |
AdCampaigns |
Addresses |
Categories |
Coupons |
Customers |
Images |
ImageTemplates |
ItemRelationshipTypes |
Items |
Locations |
LocationTypes |
OptionChoices |
Options |
OrderAddresses |
OrderCoupons |
OrderItemOptions |
OrderItems |
Orders |
OrderTaxes |
OrderTransactions |
OrderCustomers |
OrderPayments |
Reviews |
Referrers |
Shipping |
SoftGoods |
SoftGoodsLog |
StockTransactions |
SubItemMappings |
Suppliers |
SupplierItems |
Taxes |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCART.Tables

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

dotnetCART Namespace


%%PageItemTitle%%

TimeZone Enumeration
[image]
dotnetCART Namespace : TimeZone Enumeration

The list of different time zones.

Syntax

Visual Basic (Declaration)
Public Enum TimeZone
   Inherits Enum
C#
public enum TimeZone : Enum

Members

Member | Description
AST |
EST |
CST |
MST |
PST |
AKST |
HAST |
Indiana |
Arizona |
GMT |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCART.TimeZone

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

dotnetCART Namespace


%%PageItemTitle%%

TransactionType Enumeration
[image]
dotnetCART Namespace : TransactionType Enumeration

Defines different transaction types.

Syntax

Visual Basic (Declaration)
Public Enum TransactionType
   Inherits Enum
C#
public enum TransactionType : Enum

Members

Member | Description
Sale |
Authorize |
PostAuthorize |
Return |
Refund |
Void |
Credit |
Reversal |
PreAuthorize |
Force |
Settle |
Cancel |
Abort |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCART.TransactionType

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

dotnetCART Namespace


%%PageItemTitle%%

PaymentProfile Structure
See Also Members
[image]
dotnetCART Namespace : PaymentProfile Structure

Syntax

Visual Basic (Declaration)
Public Structure PaymentProfile
   Inherits ValueType
C#
public struct PaymentProfile : ValueType

Inheritance Hierarchy

System.Object
System.ValueType
dotnetCART.PaymentProfile

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

PaymentProfile Members
dotnetCART Namespace


%%PageItemTitle%% $$Members$$

PaymentProfile Structure Members
See Also Properties Methods
[image]
dotnetCART Namespace : PaymentProfile Structure

The following tables list the members exposed by PaymentProfile.

Public Properties

 | Name | Description
Public Property | CardNumber |
Public Property | ID |
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.ValueType)
Public Method | GetHashCode | (Inherited from System.ValueType)
Public Method | ToString | (Inherited from System.ValueType)
Top

See Also

Reference

PaymentProfile Structure
dotnetCART Namespace


%%PageItemTitle%% $$Properties$$

PaymentProfile Structure Properties
[image]
dotnetCART Namespace : PaymentProfile Structure

For a list of all members of this type, see PaymentProfile members.

Public Properties

 | Name | Description
Public Property | CardNumber |
Public Property | ID |
Top

See Also

Reference

PaymentProfile Structure
dotnetCART Namespace


%%PageItemTitle%%

CardNumber Property
[image]
dotnetCART Namespace > PaymentProfile Structure : CardNumber Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CardNumber As String
C#
public string CardNumber {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

PaymentProfile Structure
PaymentProfile Members


%%PageItemTitle%%

ID Property
[image]
dotnetCART Namespace > PaymentProfile Structure : ID Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ID As String
C#
public string ID {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

PaymentProfile Structure
PaymentProfile Members


Frequent Questions

Can I use .netCART in a regular ASP page?
No, .netCART must be used in an ASP.NET page with a supported .NET language such as VB.NET or C#.

Does .netCART require cookies?
No, there is total flexibility for how you maintain state in .netCART.

Is .netCART a native .NET Solution?
Yes, .netCART is fully managed and developed in C# with usage samples provided in both C# and VB.NET. .netCART was built from the ground up and designed specifically for ASP.NET.

Can I use .netCART with VB.NET?
Yes, .netCART bundles are provided in both C# and VB.NET.

Can I use .netCART with C#?
Yes, .netCART bundles are provided in both C# and VB.NET.

I am not able to save orders / I get a permissions error, why?
.netCART requires that write permissions be granted on the included database in order for web site visitors to save orders or for you to manage the store through the web interface. The ASPNET user must be granted write permissions on the file level (NTFS) permissions for the data directory. If you are using a web hosting provider email their support and indicate that you require write permissions on your /data directory where you placed the .netCART files. In addition, write permissions are required on the /images directory if you use the admin file upload or image generation features..

I am moving my site to production, what is required for a secure implementation?
Please be sure to follow the provided security checklist .

I am looking for a feature in .netCART, but can not find it?
Please send an email to info@dotnetecommerce.com with a complete description of the feature, we will let you know if we can implement it for you.

Can I use .netCART in .NET 4 or 4.5?
Yes, it is completely combatable with .NET 4, please see NET 4 notes for some specific settings in the bundle.

I am getting "A potentially dangerous Request.Form value was detected from the client" error in StoreAdmin/Settings/Language, why?
Probabley using <br> in your string, to fix this error, please add the following settings to StoreAdmin/web.cofnig after <system.web>:
<pages validateRequest="false" />
In .NET 4 or above, you may need to add:
<httpRuntime requestValidationMode="2.0" />

Why redirecting for authentication doesn't work for my payment processor using 3D Secure feature?
Try to remove extra page attributes like "MaintainScrollPositionOnPostback" from billing page. If still having problem, please send an email to support@dotnetecommerce.com

How can handle the callback after the 3D secure authentication?
Create a page similar to this and set it to Return URL in StoreAdmin/Payment for the gateway/processor. If still having problem, please send an email to support@dotnetecommerce.com

I am getting 'Error loading progress data.' for uploading image for a category or item?
Upload image depends on a custom handler and module, verify the following setting exist in your application web.config:

Internet Information Services (IIS) 7.0 or newer with Integrated mode:

<system.webServer>
<handlers>
<add name="dotnetCARTUploadProgressHandler" type="dotnetCART.Web.UI.UploadProgressHandler,dotnetCART" path="dotnetCARTUploadProgress.axd" verb="*"/>
</handlers>
<modules>
<add name="dotnetCARTUploadModule" type="dotnetCART.Web.UI.UploadModule,dotnetCART"/>
</modules>
</system.webServer>

Internet Information Services (IIS) 6.0 or older, or newer IIS versions with Classic mode:
 *For these IIS versions, the above <handlers> and <modules> in <system.webServer> section should not be exist.

<system.web>
<httpHandlers>
<add verb="*" type="dotnetCART.Web.UI.UploadProgressHandler,dotnetCART" path="dotnetCARTUploadProgress.axd" />
</httpHandlers>
<httpModules>
<add type="dotnetCART.Web.UI.UploadModule,dotnetCART" name="dotnetCARTUploadModule" />
</httpModules>
</system.web>

I am getting 'VirtualPath was outside the current application root.' in Visual studio 2013 or newer?
There is a new feature “Enable Browser Link” option in Visual Studio 2013 or newer, this error only happens while Visual Studio is open, to resolve this issue, you need to deselect “Enable Browser Link” option inside Visual Studio.

Getting Error: “The request was aborted: Could not create SSL/TLS secure channel.”
Add the following setting to global.ascx, .NET 4 or newer required for adding this setting:

protected void Application_Start()
{
System.Net.ServicePointManager.SecurityProtocol = System.Net.SecurityProtocolType.Tls12;
}

Please let us know if you have any questions / comments or suggestions!


Contacting Support

You can contact support by emailing support@dotnetecommerce.com

Please be sure to include the following information:

  • Your order ID provided when you purchased .netEcommerce.
  • A detailed description of your problem
  • An exact error message reported by the Error property of the object
  • Specifics of your server environment and configuration

Our goal is to provide rapid resolution, if you ensure the aforementioned information is included we can meet this goal.


Add Data Elements

Add("BillAddress");
BILLADDRESS_NAME,BILLADDRESS_STREET,BILLADDRESS_CITY,BILLADDRESS_PHONE,BILLADDRESS_ZIPPOSTAL,BILLADDRESS_PHONE,BILLADDRESS_EMAIL,BILLADDRESS_FAX,BILLADDRESS_CUSTOM_X
BILLADDRESS_LOCATION:COUNTRYLIST,BILLADDRESS_LOCATION:STATEPROVINCELIST or
BILLADDRESS_COUNTRY,BILLADDRESS_STATEPROVINCE

Add("ShipAddress");
SHIPADDRESS_NAME,SHIPADDRESS_STREET,SHIPADDRESS_CITY,SHIPADDRESS_PHONE,SHIPADDRESS_ZIPPOSTAL,SHIPADDRESS_PHONE,SHIPADDRESS_EMAIL,SHIPADDRESS_FAX,SHIPADDRESS_CUSTOM_X
SHIPADDRESS_LOCATION:COUNTRYLIST,SHIPADDRESS_LOCATION:STATEPROVINCELIST or
SHPADDRESS_COUNTRY,SHIPADDRESS_STATEPROVINCE

Add("Customer");
CUSTOMER_ID, CUSTOMER_COMPANY, CUSTOMER_EMAIL, CUSTOMER_CURRENCY, CUSTOMER_FIRSTNAME, CUSTOMER_LASTNAME, CUSTOMER_USERNAME, CUSTOMER_PASSWORD, CUSTOMER_CUSTOM_X

Add("Payment");
PAYMENT_TYPE, PAYMENT_BANKCODE, PAYMENT_CARDNAME, PAYMENT_CARDNUMBER, PAYMENT_CCMONTH, PAYMENT_CCYEAR, PAYMENT_CARDCODE, PAYMENT_CUSTOM_X

Add("Items");
For adding a single item:
ITEM_ID, ITEM_NAME, ITEM_DESCRIPTION, ITEM_PRICE, ITEM_QUANTITY, ITEM_WEIGHT, ITEM_MINIIMAGE, ITEM_ADJUSTRATE, ITEM_TAX, ITEM_CATEGORYID,ITEM_CUSTOM_X

ITEM_OPTION1_ID, ITEM_OPTION1_NAME, ITEM_OPTION1_TYPE, ITEM_OPTION1_LABEL, ITEM_OPTION1_REQUIRED, ITEM_OPTION1_CUSTOM_X ITEM_OPTION1_CHOICE1_ID, ITEM_OPTION1_CHOICE1_NAME, ITEM_OPTION1_CHOICE1_ADJUSTPRICE, ITEM_OPTION1_CHOICE1_ADJUSTWEIGHT, ITEM_OPTION1_CHOICE1_CUSTOM_X

ITEM_SHIP_NAME, ITEM_SHIP_STREET, ITEM_SHIP_CITY, ITEM_SHIP_STATEPROVINCE, ITEM_SHIP_ZIPPOSTAL, ITEM_SHIP_PHONE, ITEM_SHIP_EMAIL, ITEM_SHIP_FAX, ITEM_SHIP_CUSTOM_X

Adding multiple items:
ITEM1_ID, ITEM1_NAME, ITEM1_DESCRIPTION, ITEM1_PRICE, ITEM1_QUANTITY, ITEM1_WEIGHT, ITEM1_MINIIMAGE, ITEM1_ADJUSTRATE, ITEM1_TAX, ITEM1_CATEGORYID, ITEM1_CUSTOM_X

ITEM1_OPTION_ID, ITEM1_OPTION1_NAME, ITEM1_OPTION1_TYPE, ITEM1_OPTION1_LABEL, ITEM1_OPTION1_REQUIRED
ITEM1_OPTION1_CHOICE_ID, ITEM1_OPTION1_CHOICE_NAME, ITEM1_OPTION1_CHOICE_ADJUSTPRICE, ITEM1_OPTION1_CHOICE_ADJUSTWEIGHT

ITEM1_SHIP_NAME, ITEM1_SHIP_STREET, ITEM1_SHIP_CITY, ITEM1_SHIP_STATEPROVINCE, ITEM1_SHIP_ZIPPOSTAL, ITEM1_SHIP_PHONE, ITEM1_SHIP_EMAIL, ITEM1_SHIP_FAX, ITEM1_SHIP_CUSTOM_X

Note, each item should be uniquely identified e.g. ITEM1_ID, ITEM2_ID etc. The item elements should also be in contiguous blocks i.e. do not mix up ITEM1 inputs with ITEM2 inputs.

Add("ItemsDB");
Works in the same fashion as Items with the addition that options are automatically added from the database and merged with any options passed in.

Add("Shipping")
Field Name : RATELIST0 , Field value format: company,service,amount
RATELIST1, RATELIST2 etc up to total number of shipping rates listed.


.NET 4 Notes

.NET Framework 4 / 4.5 notes:

-StoreAdmin/OrderDetails.aspx: To make the popup calendar works correctly in this page, please add ClientIDMode="AutoID" to 1st line of StoreAdmin/CalendarStoreAdmin.ascx page.

-RequestValidationMode="2.0": If adding ValidateRequest="false" to a page to prevent error: "A potentially dangerous Request.Form value was detected from the client.", in .NET 4 the following setting should be added to web.config as well: <httpRuntime requestValidationMode="2.0" />


%%phrase%%

dotnetCART Assembly

Namespaces

Namespace | Description
dotnetCART |


$$GETTING_STARTED$$ - %%projecttitle%%

Getting Started


$$INTRODUCTION$$ - %%projecttitle%%

Introduction


%%PageItemTitle%% $$Properties$$

ActivityLogs Class Properties
[image]
dotnetCART Namespace : ActivityLogs Class

For a list of all members of this type, see ActivityLogs members.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from dotnetCART.ListBase<ActivityLog>)
Public Property | Count | Gets the number of elements actually contained in the collection. (Inherited from dotnetCART.ListBase<ActivityLog>)
Public Property | Error | Returns an object with the error information. (Inherited from dotnetCART.ListBase<ActivityLog>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from dotnetCART.ListBase<ActivityLog>)
Top

See Also

Reference

ActivityLogs Class
dotnetCART Namespace


%%PageItemTitle%%

Add Method
[image]
dotnetCART Namespace > ActivityLogs Class : Add Method

item
Adds an object to the end of the collection.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal item As ActivityLog _
)
C#
public void Add(
   ActivityLog item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLogs Class
ActivityLogs Members


%%PageItemTitle%%

AddRange Method
[image]
dotnetCART Namespace > ActivityLogs Class : AddRange Method

collection
Adds the elements of the specified collection to the end of the collection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal collection As IEnumerable(Of ActivityLog) _
)
C#
public void AddRange(
   IEnumerable<ActivityLog> collection
)

Parameters

collection

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLogs Class
ActivityLogs Members


%%PageItemTitle%%

AsReadOnly Method
[image]
dotnetCART Namespace > ActivityLogs Class : AsReadOnly Method

Returns a read-only IList wrapper for the current collection.

Syntax

Visual Basic (Declaration)
Public Function AsReadOnly() As ReadOnlyCollection(Of ActivityLog)
C#
public ReadOnlyCollection<ActivityLog> AsReadOnly()

Return Value

A ReadOnlyCollection that acts as a read-only wrapper around the current List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLogs Class
ActivityLogs Members


%%PageItemTitle%%

BinarySearch Method
[image]
dotnetCART Namespace > ActivityLogs Class : BinarySearch Method

Overload List

Overload | Description
BinarySearch(ActivityLog) | (Inherited from dotnetCART.ListBase<ActivityLog>)
BinarySearch(ActivityLog,Generic IComparer) | (Inherited from dotnetCART.ListBase<ActivityLog>)
BinarySearch(Int32,Int32,ActivityLog,Generic IComparer) | (Inherited from dotnetCART.ListBase<ActivityLog>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLogs Class
ActivityLogs Members


%%PageItemTitle%%

BinarySearch(ActivityLog) Method
[image]
dotnetCART Namespace > ActivityLogs Class > BinarySearch Method : BinarySearch(ActivityLog) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal item As ActivityLog _
) As Integer
C#
public int BinarySearch(
   ActivityLog item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLogs Class
ActivityLogs Members
Overload List


%%PageItemTitle%%

BinarySearch(ActivityLog,Generic IComparer) Method
[image]
dotnetCART Namespace > ActivityLogs Class > BinarySearch Method : BinarySearch(ActivityLog,Generic IComparer) Method

item
comparer

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal item As ActivityLog, _
   ByVal comparer As IComparer(Of ActivityLog) _
) As Integer
C#
public int BinarySearch(
   ActivityLog item,
   IComparer<ActivityLog> comparer
)

Parameters

item
comparer

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLogs Class
ActivityLogs Members
Overload List


%%PageItemTitle%%

BinarySearch(Int32,Int32,ActivityLog,Generic IComparer) Method
See Also
[image]
dotnetCART Namespace > ActivityLogs Class > BinarySearch Method : BinarySearch(Int32,Int32,ActivityLog,Generic IComparer) Method

index
count
item
comparer

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal index As Integer, _
   ByVal count As Integer, _
   ByVal item As ActivityLog, _
   ByVal comparer As IComparer(Of ActivityLog) _
) As Integer
C#
public int BinarySearch(
   int index,
   int count,
   ActivityLog item,
   IComparer<ActivityLog> comparer
)

Parameters

index
count
item
comparer

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLogs Class
ActivityLogs Members
Overload List


%%PageItemTitle%%

Capacity Property
[image]
dotnetCART Namespace > ActivityLogs Class : Capacity Property

Gets or sets the total number of elements the internal data structure can hold without resizing.

Syntax

Visual Basic (Declaration)
Public Property Capacity As Integer
C#
public int Capacity {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLogs Class
ActivityLogs Members


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > ActivityLogs Class : Clear Method

Removes all elements from the List.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLogs Class
ActivityLogs Members


%%PageItemTitle%%

Contains Method
[image]
dotnetCART Namespace > ActivityLogs Class : Contains Method

item
Determines whether an element is in the List.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal item As ActivityLog _
) As Boolean
C#
public bool Contains(
   ActivityLog item
)

Parameters

item

Return Value

true if item is found in the List; otherwise, false.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLogs Class
ActivityLogs Members


%%PageItemTitle%%

CopyTo Method
[image]
dotnetCART Namespace > ActivityLogs Class : CopyTo Method

Overload List

Overload | Description
CopyTo(ActivityLog[]) | (Inherited from dotnetCART.ListBase<ActivityLog>)
CopyTo(ActivityLog[],Int32) | (Inherited from dotnetCART.ListBase<ActivityLog>)
CopyTo(Int32,ActivityLog[],Int32,Int32) | (Inherited from dotnetCART.ListBase<ActivityLog>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLogs Class
ActivityLogs Members


%%PageItemTitle%%

CopyTo(ActivityLog[]) Method
[image]
dotnetCART Namespace > ActivityLogs Class > CopyTo Method : CopyTo(ActivityLog[]) Method

array

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array() As ActivityLog _
)
C#
public void CopyTo(
   ActivityLog[] array
)

Parameters

array

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLogs Class
ActivityLogs Members
Overload List


%%PageItemTitle%%

CopyTo(ActivityLog[],Int32) Method
[image]
dotnetCART Namespace > ActivityLogs Class > CopyTo Method : CopyTo(ActivityLog[],Int32) Method

array
arrayIndex

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array() As ActivityLog, _
   ByVal arrayIndex As Integer _
)
C#
public void CopyTo(
   ActivityLog[] array,
   int arrayIndex
)

Parameters

array
arrayIndex

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLogs Class
ActivityLogs Members
Overload List


%%PageItemTitle%%

CopyTo(Int32,ActivityLog[],Int32,Int32) Method
[image]
dotnetCART Namespace > ActivityLogs Class > CopyTo Method : CopyTo(Int32,ActivityLog[],Int32,Int32) Method

index
array
arrayIndex
count

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal index As Integer, _
   ByVal array() As ActivityLog, _
   ByVal arrayIndex As Integer, _
   ByVal count As Integer _
)
C#
public void CopyTo(
   int index,
   ActivityLog[] array,
   int arrayIndex,
   int count
)

Parameters

index
array
arrayIndex
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLogs Class
ActivityLogs Members
Overload List


%%PageItemTitle%%

Count Property
[image]
dotnetCART Namespace > ActivityLogs Class : Count Property

Gets the number of elements actually contained in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLogs Class
ActivityLogs Members


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > ActivityLogs Class : Error Property

Returns an object with the error information.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLogs Class
ActivityLogs Members


%%PageItemTitle%%

GetEnumerator Method
[image]
dotnetCART Namespace > ActivityLogs Class : GetEnumerator Method

Returns an enumerator that iterates through the List.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As List.Enumerator(Of ActivityLog)
C#
public List.Enumerator<ActivityLog> GetEnumerator()

Return Value

A List.Enumerator for the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLogs Class
ActivityLogs Members


%%PageItemTitle%%

IndexOf Method
[image]
dotnetCART Namespace > ActivityLogs Class : IndexOf Method

Overload List

Overload | Description
IndexOf(ActivityLog) | (Inherited from dotnetCART.ListBase<ActivityLog>)
IndexOf(ActivityLog,Int32) | (Inherited from dotnetCART.ListBase<ActivityLog>)
IndexOf(ActivityLog,Int32,Int32) | (Inherited from dotnetCART.ListBase<ActivityLog>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLogs Class
ActivityLogs Members


%%PageItemTitle%%

IndexOf(ActivityLog) Method
[image]
dotnetCART Namespace > ActivityLogs Class > IndexOf Method : IndexOf(ActivityLog) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As ActivityLog _
) As Integer
C#
public int IndexOf(
   ActivityLog item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLogs Class
ActivityLogs Members
Overload List


%%PageItemTitle%%

IndexOf(ActivityLog,Int32) Method
[image]
dotnetCART Namespace > ActivityLogs Class > IndexOf Method : IndexOf(ActivityLog,Int32) Method

item
index

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As ActivityLog, _
   ByVal index As Integer _
) As Integer
C#
public int IndexOf(
   ActivityLog item,
   int index
)

Parameters

item
index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLogs Class
ActivityLogs Members
Overload List


%%PageItemTitle%%

IndexOf(ActivityLog,Int32,Int32) Method
[image]
dotnetCART Namespace > ActivityLogs Class > IndexOf Method : IndexOf(ActivityLog,Int32,Int32) Method

item
index
count

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As ActivityLog, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
C#
public int IndexOf(
   ActivityLog item,
   int index,
   int count
)

Parameters

item
index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLogs Class
ActivityLogs Members
Overload List


%%PageItemTitle%%

Insert Method
[image]
dotnetCART Namespace > ActivityLogs Class : Insert Method

index
item
Inserts an element into the List at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As ActivityLog _
)
C#
public void Insert(
   int index,
   ActivityLog item
)

Parameters

index
item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLogs Class
ActivityLogs Members


%%PageItemTitle%%

InsertRange Method
[image]
dotnetCART Namespace > ActivityLogs Class : InsertRange Method

index
collection
Inserts the elements of a collection into the List at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub InsertRange( _
   ByVal index As Integer, _
   ByVal collection As IEnumerable(Of ActivityLog) _
)
C#
public void InsertRange(
   int index,
   IEnumerable<ActivityLog> collection
)

Parameters

index
collection

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLogs Class
ActivityLogs Members


%%PageItemTitle%%

Item Property
[image]
dotnetCART Namespace > ActivityLogs Class : Item Property

index
Gets or sets the element at the specified index.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As ActivityLog
C#
public ActivityLog this[
   int index
]; {get; set;}

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLogs Class
ActivityLogs Members


%%PageItemTitle%%

LastIndexOf Method
[image]
dotnetCART Namespace > ActivityLogs Class : LastIndexOf Method

Overload List

Overload | Description
LastIndexOf(ActivityLog) | (Inherited from dotnetCART.ListBase<ActivityLog>)
LastIndexOf(ActivityLog,Int32) | (Inherited from dotnetCART.ListBase<ActivityLog>)
LastIndexOf(ActivityLog,Int32,Int32) | (Inherited from dotnetCART.ListBase<ActivityLog>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLogs Class
ActivityLogs Members


%%PageItemTitle%%

LastIndexOf(ActivityLog) Method
[image]
dotnetCART Namespace > ActivityLogs Class > LastIndexOf Method : LastIndexOf(ActivityLog) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As ActivityLog _
) As Integer
C#
public int LastIndexOf(
   ActivityLog item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLogs Class
ActivityLogs Members
Overload List


%%PageItemTitle%%

LastIndexOf(ActivityLog,Int32) Method
[image]
dotnetCART Namespace > ActivityLogs Class > LastIndexOf Method : LastIndexOf(ActivityLog,Int32) Method

item
index

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As ActivityLog, _
   ByVal index As Integer _
) As Integer
C#
public int LastIndexOf(
   ActivityLog item,
   int index
)

Parameters

item
index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLogs Class
ActivityLogs Members
Overload List


%%PageItemTitle%%

LastIndexOf(ActivityLog,Int32,Int32) Method
[image]
dotnetCART Namespace > ActivityLogs Class > LastIndexOf Method : LastIndexOf(ActivityLog,Int32,Int32) Method

item
index
count

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As ActivityLog, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
C#
public int LastIndexOf(
   ActivityLog item,
   int index,
   int count
)

Parameters

item
index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLogs Class
ActivityLogs Members
Overload List


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > ActivityLogs Class > LoadDB Method : LoadDB() Method

Loads all the items from its associated table.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB() As Integer
C#
public virtual int LoadDB()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLogs Class
ActivityLogs Members
Overload List


%%PageItemTitle%%

LoadDB(Int32,Int32) Method
[image]
dotnetCART Namespace > ActivityLogs Class > LoadDB Method : LoadDB(Int32,Int32) Method

start
count
Loads the count number of elements from start value.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal start As Integer, _
   ByVal count As Integer _
) As Integer
C#
public virtual int LoadDB(
   int start,
   int count
)

Parameters

start
count

Return Value

The total number of elements have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLogs Class
ActivityLogs Members
Overload List


%%PageItemTitle%%

LoadDB(Where) Method
[image]
dotnetCART Namespace > ActivityLogs Class > LoadDB Method : LoadDB(Where) Method

whereClause
Loads all the items from its associated table based on the where clause.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal whereClause As Where _
) As Integer
C#
public virtual int LoadDB(
   Where whereClause
)

Parameters

whereClause

Return Value

The total number of items have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLogs Class
ActivityLogs Members
Overload List


%%PageItemTitle%%

Remove Method
[image]
dotnetCART Namespace > ActivityLogs Class : Remove Method

item
Removes the first occurrence of a specific object from the List.

Syntax

Visual Basic (Declaration)
Public Function Remove( _
   ByVal item As ActivityLog _
) As Boolean
C#
public bool Remove(
   ActivityLog item
)

Parameters

item

Return Value

true if item is successfully removed; otherwise, false. This method also returns false if item was not found in the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLogs Class
ActivityLogs Members


%%PageItemTitle%%

RemoveAll Method
[image]
dotnetCART Namespace > ActivityLogs Class : RemoveAll Method

match
Removes the all the elements that match the conditions defined by the specified predicate.

Syntax

Visual Basic (Declaration)
Public Function RemoveAll( _
   ByVal match As Predicate(Of ActivityLog) _
) As Integer
C#
public int RemoveAll(
   Predicate<ActivityLog> match
)

Parameters

match

Return Value

The number of elements removed from the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLogs Class
ActivityLogs Members


%%PageItemTitle%%

RemoveAt Method
[image]
dotnetCART Namespace > ActivityLogs Class : RemoveAt Method

index
Removes the element at the specified index of the List.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLogs Class
ActivityLogs Members


%%PageItemTitle%%

RemoveRange Method
[image]
dotnetCART Namespace > ActivityLogs Class : RemoveRange Method

index
count
Removes a range of elements from the List.

Syntax

Visual Basic (Declaration)
Public Sub RemoveRange( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
C#
public void RemoveRange(
   int index,
   int count
)

Parameters

index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLogs Class
ActivityLogs Members


%%PageItemTitle%%

Reverse Method
[image]
dotnetCART Namespace > ActivityLogs Class : Reverse Method

Reverses the order of the elements in the entire List.

Overload List

Overload | Description
Reverse() | Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<ActivityLog>)
Reverse(Int32,Int32) | Reverses the order of the elements in the specified range. (Inherited from dotnetCART.ListBase<ActivityLog>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLogs Class
ActivityLogs Members


%%PageItemTitle%%

Reverse() Method
[image]
dotnetCART Namespace > ActivityLogs Class > Reverse Method : Reverse() Method

Reverses the order of the elements in the entire List.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Reverse()
C#
public void Reverse()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLogs Class
ActivityLogs Members
Overload List


%%PageItemTitle%%

Reverse(Int32,Int32) Method
[image]
dotnetCART Namespace > ActivityLogs Class > Reverse Method : Reverse(Int32,Int32) Method

index
count
Reverses the order of the elements in the specified range.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Reverse( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
C#
public void Reverse(
   int index,
   int count
)

Parameters

index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLogs Class
ActivityLogs Members
Overload List


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > ActivityLog Class : Clear Method

Initializes all the properties without recreating the object.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Clear()
C#
public virtual void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLog Class
ActivityLog Members


%%PageItemTitle%%

Custom Property
[image]
dotnetCART Namespace > ActivityLog Class : Custom Property

Gets or sets a custom object. For more information see custom fields

Syntax

Visual Basic (Declaration)
Public Property Custom As Custom
C#
public Custom Custom {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLog Class
ActivityLog Members


%%PageItemTitle%%

CustomFields Property
See Also Example
[image]
dotnetCART Namespace > ActivityLog Class : CustomFields Property

Gets or sets a the names of custom fields for a table associated with the object.

Syntax

Visual Basic (Declaration)
Public Property CustomFields As String
C#
public string CustomFields {get; set;}

Example

C# Copy Code
Customer.CustomFields = "CellPhone,Favorites";

Visual Basic Copy Code
Customer.CustomFields = "CellPhone,Favorites"

Remarks

Custom fields must be added to the table manualy. Custom fields are usually set at store level using CustomFields

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLog Class
ActivityLog Members


%%PageItemTitle%%

Customs Property
[image]
dotnetCART Namespace > ActivityLog Class : Customs Property

A reference to the collection of the Custom objects.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Customs As Customs
C#
public Customs Customs {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLog Class
ActivityLog Members


%%PageItemTitle%%

DeleteDB Method
[image]
dotnetCART Namespace > ActivityLog Class : DeleteDB Method

Deletes this object with ID from the database.

Overload List

Overload | Description
DeleteDB() | Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<ActivityLog, Int64>)
DeleteDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLog Class
ActivityLog Members


%%PageItemTitle%%

DeleteDB() Method
[image]
dotnetCART Namespace > ActivityLog Class > DeleteDB Method : DeleteDB() Method

Deletes this object with ID from the database.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function DeleteDB() As Integer
C#
public virtual int DeleteDB()

Return Value

In case of error -1, check Error property, otherwise the number of objects deleted.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLog Class
ActivityLog Members
Overload List


%%PageItemTitle%%

DeleteDB(DbManager) Method
[image]
dotnetCART Namespace > ActivityLog Class > DeleteDB Method : DeleteDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function DeleteDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int DeleteDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLog Class
ActivityLog Members
Overload List


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > ActivityLog Class : Error Property

Gets the error object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLog Class
ActivityLog Members


%%PageItemTitle%%

GetCustom Method
[image]
dotnetCART Namespace > ActivityLog Class : GetCustom Method

This method returns the value of a custom field based on its name in the customs collection.

Overload List

Overload | Description
GetCustom(String) | This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<ActivityLog, Int64>)
GetCustom(Int32) | This method returns the value of a custom field based on its index in the customs collection. (Inherited from dotnetCART.DbTableCart<ActivityLog, Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLog Class
ActivityLog Members


%%PageItemTitle%%

GetCustom(Int32) Method
[image]
dotnetCART Namespace > ActivityLog Class > GetCustom Method : GetCustom(Int32) Method

customIndex
This method returns the value of a custom field based on its index in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal customIndex As Integer _
) As Object
C#
public object GetCustom(
   int customIndex
)

Parameters

customIndex

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLog Class
ActivityLog Members
Overload List


%%PageItemTitle%%

GetCustom(String) Method
[image]
dotnetCART Namespace > ActivityLog Class > GetCustom Method : GetCustom(String) Method

name
This method returns the value of a custom field based on its name in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal name As String _
) As Object
C#
public object GetCustom(
   string name
)

Parameters

name

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLog Class
ActivityLog Members
Overload List


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > ActivityLog Class : LoadDB Method

Loads this object from database using the ID property.

Overload List

Overload | Description
LoadDB(Int64) | (Inherited from dotnetCART.DbTableCart<ActivityLog, Int64>)
LoadDB() | Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<ActivityLog, Int64>)
Generic LoadDB() | (Inherited from dotnetDATA.DbTable<Int64>)
Generic LoadDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLog Class
ActivityLog Members


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > ActivityLog Class > LoadDB Method : LoadDB() Method

Loads this object from database using the ID property.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB() As Integer
C#
public virtual int LoadDB()

Return Value

In case of error -1, check Error property, if the object with the ID property not found 0, otherwise 1.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLog Class
ActivityLog Members
Overload List


%%PageItemTitle%%

LoadDB(Int64) Method
[image]
dotnetCART Namespace > ActivityLog Class > LoadDB Method : LoadDB(Int64) Method

id

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal id As Long _
) As Integer
C#
public virtual int LoadDB(
   long id
)

Parameters

id

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLog Class
ActivityLog Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB() Method
See Also
[image]
dotnetCART Namespace > ActivityLog Class > LoadDB Method : Generic LoadDB() Method

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)() As Integer
C#
public virtual int LoadDB<T1>()where T1: IDbTable

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLog Class
ActivityLog Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB(DbManager) Method
See Also
[image]
dotnetCART Namespace > ActivityLog Class > LoadDB Method : Generic LoadDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int LoadDB<T1>(
   DbManager manager
)where T1: IDbTable

Parameters

manager

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLog Class
ActivityLog Members
Overload List


%%PageItemTitle%%

SaveDB(DbManager) Method
[image]
dotnetCART Namespace > ActivityLog Class > SaveDB Method : SaveDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function SaveDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int SaveDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLog Class
ActivityLog Members
Overload List


%%PageItemTitle%%

SetCustom Method
[image]
dotnetCART Namespace > ActivityLog Class : SetCustom Method

name
newValue
This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added.

Syntax

Visual Basic (Declaration)
Public Function SetCustom( _
   ByVal name As String, _
   ByVal newValue As Object _
) As Object
C#
public object SetCustom(
   string name,
   object newValue
)

Parameters

name
newValue

Return Value

Returns the new custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ActivityLog Class
ActivityLog Members


%%PageItemTitle%%

Add Method
[image]
dotnetCART Namespace > AdCampaigns Class : Add Method

item
Adds an object to the end of the collection.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal item As AdCampaign _
)
C#
public void Add(
   AdCampaign item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaigns Class
AdCampaigns Members


%%PageItemTitle%%

AddRange Method
[image]
dotnetCART Namespace > AdCampaigns Class : AddRange Method

collection
Adds the elements of the specified collection to the end of the collection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal collection As IEnumerable(Of AdCampaign) _
)
C#
public void AddRange(
   IEnumerable<AdCampaign> collection
)

Parameters

collection

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaigns Class
AdCampaigns Members


%%PageItemTitle%%

AsReadOnly Method
[image]
dotnetCART Namespace > AdCampaigns Class : AsReadOnly Method

Returns a read-only IList wrapper for the current collection.

Syntax

Visual Basic (Declaration)
Public Function AsReadOnly() As ReadOnlyCollection(Of AdCampaign)
C#
public ReadOnlyCollection<AdCampaign> AsReadOnly()

Return Value

A ReadOnlyCollection that acts as a read-only wrapper around the current List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaigns Class
AdCampaigns Members


%%PageItemTitle%%

BinarySearch Method
[image]
dotnetCART Namespace > AdCampaigns Class : BinarySearch Method

Overload List

Overload | Description
BinarySearch(AdCampaign) | (Inherited from dotnetCART.ListBase<AdCampaign>)
BinarySearch(AdCampaign,Generic IComparer) | (Inherited from dotnetCART.ListBase<AdCampaign>)
BinarySearch(Int32,Int32,AdCampaign,Generic IComparer) | (Inherited from dotnetCART.ListBase<AdCampaign>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaigns Class
AdCampaigns Members


%%PageItemTitle%%

BinarySearch(AdCampaign) Method
[image]
dotnetCART Namespace > AdCampaigns Class > BinarySearch Method : BinarySearch(AdCampaign) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal item As AdCampaign _
) As Integer
C#
public int BinarySearch(
   AdCampaign item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaigns Class
AdCampaigns Members
Overload List


%%PageItemTitle%%

BinarySearch(AdCampaign,Generic IComparer) Method
[image]
dotnetCART Namespace > AdCampaigns Class > BinarySearch Method : BinarySearch(AdCampaign,Generic IComparer) Method

item
comparer

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal item As AdCampaign, _
   ByVal comparer As IComparer(Of AdCampaign) _
) As Integer
C#
public int BinarySearch(
   AdCampaign item,
   IComparer<AdCampaign> comparer
)

Parameters

item
comparer

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaigns Class
AdCampaigns Members
Overload List


%%PageItemTitle%%

BinarySearch(Int32,Int32,AdCampaign,Generic IComparer) Method
See Also
[image]
dotnetCART Namespace > AdCampaigns Class > BinarySearch Method : BinarySearch(Int32,Int32,AdCampaign,Generic IComparer) Method

index
count
item
comparer

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal index As Integer, _
   ByVal count As Integer, _
   ByVal item As AdCampaign, _
   ByVal comparer As IComparer(Of AdCampaign) _
) As Integer
C#
public int BinarySearch(
   int index,
   int count,
   AdCampaign item,
   IComparer<AdCampaign> comparer
)

Parameters

index
count
item
comparer

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaigns Class
AdCampaigns Members
Overload List


%%PageItemTitle%%

Capacity Property
[image]
dotnetCART Namespace > AdCampaigns Class : Capacity Property

Gets or sets the total number of elements the internal data structure can hold without resizing.

Syntax

Visual Basic (Declaration)
Public Property Capacity As Integer
C#
public int Capacity {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaigns Class
AdCampaigns Members


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > AdCampaigns Class : Clear Method

Removes all elements from the List.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaigns Class
AdCampaigns Members


%%PageItemTitle%%

Contains Method
[image]
dotnetCART Namespace > AdCampaigns Class : Contains Method

item
Determines whether an element is in the List.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal item As AdCampaign _
) As Boolean
C#
public bool Contains(
   AdCampaign item
)

Parameters

item

Return Value

true if item is found in the List; otherwise, false.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaigns Class
AdCampaigns Members


%%PageItemTitle%%

CopyTo Method
[image]
dotnetCART Namespace > AdCampaigns Class : CopyTo Method

Overload List

Overload | Description
CopyTo(AdCampaign[]) | (Inherited from dotnetCART.ListBase<AdCampaign>)
CopyTo(AdCampaign[],Int32) | (Inherited from dotnetCART.ListBase<AdCampaign>)
CopyTo(Int32,AdCampaign[],Int32,Int32) | (Inherited from dotnetCART.ListBase<AdCampaign>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaigns Class
AdCampaigns Members


%%PageItemTitle%%

CopyTo(AdCampaign[]) Method
[image]
dotnetCART Namespace > AdCampaigns Class > CopyTo Method : CopyTo(AdCampaign[]) Method

array

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array() As AdCampaign _
)
C#
public void CopyTo(
   AdCampaign[] array
)

Parameters

array

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaigns Class
AdCampaigns Members
Overload List


%%PageItemTitle%%

CopyTo(AdCampaign[],Int32) Method
[image]
dotnetCART Namespace > AdCampaigns Class > CopyTo Method : CopyTo(AdCampaign[],Int32) Method

array
arrayIndex

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array() As AdCampaign, _
   ByVal arrayIndex As Integer _
)
C#
public void CopyTo(
   AdCampaign[] array,
   int arrayIndex
)

Parameters

array
arrayIndex

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaigns Class
AdCampaigns Members
Overload List


%%PageItemTitle%%

CopyTo(Int32,AdCampaign[],Int32,Int32) Method
[image]
dotnetCART Namespace > AdCampaigns Class > CopyTo Method : CopyTo(Int32,AdCampaign[],Int32,Int32) Method

index
array
arrayIndex
count

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal index As Integer, _
   ByVal array() As AdCampaign, _
   ByVal arrayIndex As Integer, _
   ByVal count As Integer _
)
C#
public void CopyTo(
   int index,
   AdCampaign[] array,
   int arrayIndex,
   int count
)

Parameters

index
array
arrayIndex
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaigns Class
AdCampaigns Members
Overload List


%%PageItemTitle%%

Count Property
[image]
dotnetCART Namespace > AdCampaigns Class : Count Property

Gets the number of elements actually contained in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaigns Class
AdCampaigns Members


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > AdCampaigns Class : Error Property

Returns an object with the error information.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaigns Class
AdCampaigns Members


%%PageItemTitle%%

GetEnumerator Method
[image]
dotnetCART Namespace > AdCampaigns Class : GetEnumerator Method

Returns an enumerator that iterates through the List.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As List.Enumerator(Of AdCampaign)
C#
public List.Enumerator<AdCampaign> GetEnumerator()

Return Value

A List.Enumerator for the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaigns Class
AdCampaigns Members


%%PageItemTitle%%

IndexOf Method
[image]
dotnetCART Namespace > AdCampaigns Class : IndexOf Method

Overload List

Overload | Description
IndexOf(AdCampaign) | (Inherited from dotnetCART.ListBase<AdCampaign>)
IndexOf(AdCampaign,Int32) | (Inherited from dotnetCART.ListBase<AdCampaign>)
IndexOf(AdCampaign,Int32,Int32) | (Inherited from dotnetCART.ListBase<AdCampaign>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaigns Class
AdCampaigns Members


%%PageItemTitle%%

IndexOf(AdCampaign) Method
[image]
dotnetCART Namespace > AdCampaigns Class > IndexOf Method : IndexOf(AdCampaign) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As AdCampaign _
) As Integer
C#
public int IndexOf(
   AdCampaign item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaigns Class
AdCampaigns Members
Overload List


%%PageItemTitle%%

IndexOf(AdCampaign,Int32) Method
[image]
dotnetCART Namespace > AdCampaigns Class > IndexOf Method : IndexOf(AdCampaign,Int32) Method

item
index

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As AdCampaign, _
   ByVal index As Integer _
) As Integer
C#
public int IndexOf(
   AdCampaign item,
   int index
)

Parameters

item
index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaigns Class
AdCampaigns Members
Overload List


%%PageItemTitle%%

IndexOf(AdCampaign,Int32,Int32) Method
[image]
dotnetCART Namespace > AdCampaigns Class > IndexOf Method : IndexOf(AdCampaign,Int32,Int32) Method

item
index
count

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As AdCampaign, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
C#
public int IndexOf(
   AdCampaign item,
   int index,
   int count
)

Parameters

item
index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaigns Class
AdCampaigns Members
Overload List


%%PageItemTitle%%

Insert Method
[image]
dotnetCART Namespace > AdCampaigns Class : Insert Method

index
item
Inserts an element into the List at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As AdCampaign _
)
C#
public void Insert(
   int index,
   AdCampaign item
)

Parameters

index
item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaigns Class
AdCampaigns Members


%%PageItemTitle%%

InsertRange Method
[image]
dotnetCART Namespace > AdCampaigns Class : InsertRange Method

index
collection
Inserts the elements of a collection into the List at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub InsertRange( _
   ByVal index As Integer, _
   ByVal collection As IEnumerable(Of AdCampaign) _
)
C#
public void InsertRange(
   int index,
   IEnumerable<AdCampaign> collection
)

Parameters

index
collection

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaigns Class
AdCampaigns Members


%%PageItemTitle%%

Item(Int32) Property
[image]
dotnetCART Namespace > AdCampaigns Class > Item Property : Item(Int32) Property

index
Gets or sets the element at the specified index.

Syntax

Visual Basic (Declaration)
Public Overloads Property Item( _
   ByVal index As Integer _
) As AdCampaign
C#
public AdCampaign Item(
   int index
) {get; set;}

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaigns Class
AdCampaigns Members
Overload List


%%PageItemTitle%%

LastIndexOf Method
[image]
dotnetCART Namespace > AdCampaigns Class : LastIndexOf Method

Overload List

Overload | Description
LastIndexOf(AdCampaign) | (Inherited from dotnetCART.ListBase<AdCampaign>)
LastIndexOf(AdCampaign,Int32) | (Inherited from dotnetCART.ListBase<AdCampaign>)
LastIndexOf(AdCampaign,Int32,Int32) | (Inherited from dotnetCART.ListBase<AdCampaign>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaigns Class
AdCampaigns Members


%%PageItemTitle%%

LastIndexOf(AdCampaign) Method
[image]
dotnetCART Namespace > AdCampaigns Class > LastIndexOf Method : LastIndexOf(AdCampaign) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As AdCampaign _
) As Integer
C#
public int LastIndexOf(
   AdCampaign item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaigns Class
AdCampaigns Members
Overload List


%%PageItemTitle%%

LastIndexOf(AdCampaign,Int32) Method
[image]
dotnetCART Namespace > AdCampaigns Class > LastIndexOf Method : LastIndexOf(AdCampaign,Int32) Method

item
index

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As AdCampaign, _
   ByVal index As Integer _
) As Integer
C#
public int LastIndexOf(
   AdCampaign item,
   int index
)

Parameters

item
index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaigns Class
AdCampaigns Members
Overload List


%%PageItemTitle%%

LastIndexOf(AdCampaign,Int32,Int32) Method
[image]
dotnetCART Namespace > AdCampaigns Class > LastIndexOf Method : LastIndexOf(AdCampaign,Int32,Int32) Method

item
index
count

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As AdCampaign, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
C#
public int LastIndexOf(
   AdCampaign item,
   int index,
   int count
)

Parameters

item
index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaigns Class
AdCampaigns Members
Overload List


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > AdCampaigns Class > LoadDB Method : LoadDB() Method

Loads all the items from its associated table.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB() As Integer
C#
public virtual int LoadDB()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaigns Class
AdCampaigns Members
Overload List


%%PageItemTitle%%

LoadDB(Int32,Int32) Method
[image]
dotnetCART Namespace > AdCampaigns Class > LoadDB Method : LoadDB(Int32,Int32) Method

start
count
Loads the count number of elements from start value.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal start As Integer, _
   ByVal count As Integer _
) As Integer
C#
public virtual int LoadDB(
   int start,
   int count
)

Parameters

start
count

Return Value

The total number of elements have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaigns Class
AdCampaigns Members
Overload List


%%PageItemTitle%%

LoadDB(Where) Method
[image]
dotnetCART Namespace > AdCampaigns Class > LoadDB Method : LoadDB(Where) Method

whereClause
Loads all the items from its associated table based on the where clause.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal whereClause As Where _
) As Integer
C#
public virtual int LoadDB(
   Where whereClause
)

Parameters

whereClause

Return Value

The total number of items have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaigns Class
AdCampaigns Members
Overload List


%%PageItemTitle%%

Remove Method
[image]
dotnetCART Namespace > AdCampaigns Class : Remove Method

item
Removes the first occurrence of a specific object from the List.

Syntax

Visual Basic (Declaration)
Public Function Remove( _
   ByVal item As AdCampaign _
) As Boolean
C#
public bool Remove(
   AdCampaign item
)

Parameters

item

Return Value

true if item is successfully removed; otherwise, false. This method also returns false if item was not found in the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaigns Class
AdCampaigns Members


%%PageItemTitle%%

RemoveAll Method
[image]
dotnetCART Namespace > AdCampaigns Class : RemoveAll Method

match
Removes the all the elements that match the conditions defined by the specified predicate.

Syntax

Visual Basic (Declaration)
Public Function RemoveAll( _
   ByVal match As Predicate(Of AdCampaign) _
) As Integer
C#
public int RemoveAll(
   Predicate<AdCampaign> match
)

Parameters

match

Return Value

The number of elements removed from the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaigns Class
AdCampaigns Members


%%PageItemTitle%%

RemoveAt Method
[image]
dotnetCART Namespace > AdCampaigns Class : RemoveAt Method

index
Removes the element at the specified index of the List.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaigns Class
AdCampaigns Members


%%PageItemTitle%%

RemoveRange Method
[image]
dotnetCART Namespace > AdCampaigns Class : RemoveRange Method

index
count
Removes a range of elements from the List.

Syntax

Visual Basic (Declaration)
Public Sub RemoveRange( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
C#
public void RemoveRange(
   int index,
   int count
)

Parameters

index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaigns Class
AdCampaigns Members


%%PageItemTitle%%

Reverse Method
[image]
dotnetCART Namespace > AdCampaigns Class : Reverse Method

Reverses the order of the elements in the entire List.

Overload List

Overload | Description
Reverse() | Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<AdCampaign>)
Reverse(Int32,Int32) | Reverses the order of the elements in the specified range. (Inherited from dotnetCART.ListBase<AdCampaign>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaigns Class
AdCampaigns Members


%%PageItemTitle%%

Reverse() Method
[image]
dotnetCART Namespace > AdCampaigns Class > Reverse Method : Reverse() Method

Reverses the order of the elements in the entire List.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Reverse()
C#
public void Reverse()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaigns Class
AdCampaigns Members
Overload List


%%PageItemTitle%%

Reverse(Int32,Int32) Method
[image]
dotnetCART Namespace > AdCampaigns Class > Reverse Method : Reverse(Int32,Int32) Method

index
count
Reverses the order of the elements in the specified range.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Reverse( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
C#
public void Reverse(
   int index,
   int count
)

Parameters

index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaigns Class
AdCampaigns Members
Overload List


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > AdCampaign Class : Clear Method

Initializes all the properties without recreating the object.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Clear()
C#
public virtual void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaign Class
AdCampaign Members


%%PageItemTitle%%

Custom Property
[image]
dotnetCART Namespace > AdCampaign Class : Custom Property

Gets or sets a custom object. For more information see custom fields

Syntax

Visual Basic (Declaration)
Public Property Custom As Custom
C#
public Custom Custom {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaign Class
AdCampaign Members


%%PageItemTitle%%

CustomFields Property
See Also Example
[image]
dotnetCART Namespace > AdCampaign Class : CustomFields Property

Gets or sets a the names of custom fields for a table associated with the object.

Syntax

Visual Basic (Declaration)
Public Property CustomFields As String
C#
public string CustomFields {get; set;}

Example

C# Copy Code
Customer.CustomFields = "CellPhone,Favorites";

Visual Basic Copy Code
Customer.CustomFields = "CellPhone,Favorites"

Remarks

Custom fields must be added to the table manualy. Custom fields are usually set at store level using CustomFields

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaign Class
AdCampaign Members


%%PageItemTitle%%

Customs Property
[image]
dotnetCART Namespace > AdCampaign Class : Customs Property

A reference to the collection of the Custom objects.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Customs As Customs
C#
public Customs Customs {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaign Class
AdCampaign Members


%%PageItemTitle%%

DeleteDB Method
[image]
dotnetCART Namespace > AdCampaign Class : DeleteDB Method

Deletes this object with ID from the database.

Overload List

Overload | Description
DeleteDB() | Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<AdCampaign, Int64>)
DeleteDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaign Class
AdCampaign Members


%%PageItemTitle%%

DeleteDB() Method
[image]
dotnetCART Namespace > AdCampaign Class > DeleteDB Method : DeleteDB() Method

Deletes this object with ID from the database.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function DeleteDB() As Integer
C#
public virtual int DeleteDB()

Return Value

In case of error -1, check Error property, otherwise the number of objects deleted.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaign Class
AdCampaign Members
Overload List


%%PageItemTitle%%

DeleteDB(DbManager) Method
[image]
dotnetCART Namespace > AdCampaign Class > DeleteDB Method : DeleteDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function DeleteDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int DeleteDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaign Class
AdCampaign Members
Overload List


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > AdCampaign Class : Error Property

Gets the error object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaign Class
AdCampaign Members


%%PageItemTitle%%

GetCustom Method
[image]
dotnetCART Namespace > AdCampaign Class : GetCustom Method

This method returns the value of a custom field based on its name in the customs collection.

Overload List

Overload | Description
GetCustom(String) | This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<AdCampaign, Int64>)
GetCustom(Int32) | This method returns the value of a custom field based on its index in the customs collection. (Inherited from dotnetCART.DbTableCart<AdCampaign, Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaign Class
AdCampaign Members


%%PageItemTitle%%

GetCustom(Int32) Method
[image]
dotnetCART Namespace > AdCampaign Class > GetCustom Method : GetCustom(Int32) Method

customIndex
This method returns the value of a custom field based on its index in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal customIndex As Integer _
) As Object
C#
public object GetCustom(
   int customIndex
)

Parameters

customIndex

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaign Class
AdCampaign Members
Overload List


%%PageItemTitle%%

GetCustom(String) Method
[image]
dotnetCART Namespace > AdCampaign Class > GetCustom Method : GetCustom(String) Method

name
This method returns the value of a custom field based on its name in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal name As String _
) As Object
C#
public object GetCustom(
   string name
)

Parameters

name

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaign Class
AdCampaign Members
Overload List


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > AdCampaign Class : LoadDB Method

Loads this object from database using the ID property.

Overload List

Overload | Description
LoadDB(Int64) | (Inherited from dotnetCART.DbTableCart<AdCampaign, Int64>)
LoadDB() | Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<AdCampaign, Int64>)
Generic LoadDB() | (Inherited from dotnetDATA.DbTable<Int64>)
Generic LoadDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaign Class
AdCampaign Members


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > AdCampaign Class > LoadDB Method : LoadDB() Method

Loads this object from database using the ID property.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB() As Integer
C#
public virtual int LoadDB()

Return Value

In case of error -1, check Error property, if the object with the ID property not found 0, otherwise 1.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaign Class
AdCampaign Members
Overload List


%%PageItemTitle%%

LoadDB(Int64) Method
[image]
dotnetCART Namespace > AdCampaign Class > LoadDB Method : LoadDB(Int64) Method

id

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal id As Long _
) As Integer
C#
public virtual int LoadDB(
   long id
)

Parameters

id

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaign Class
AdCampaign Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB() Method
See Also
[image]
dotnetCART Namespace > AdCampaign Class > LoadDB Method : Generic LoadDB() Method

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)() As Integer
C#
public virtual int LoadDB<T1>()where T1: IDbTable

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaign Class
AdCampaign Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB(DbManager) Method
See Also
[image]
dotnetCART Namespace > AdCampaign Class > LoadDB Method : Generic LoadDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int LoadDB<T1>(
   DbManager manager
)where T1: IDbTable

Parameters

manager

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaign Class
AdCampaign Members
Overload List


%%PageItemTitle%%

SaveDB(DbManager) Method
[image]
dotnetCART Namespace > AdCampaign Class > SaveDB Method : SaveDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function SaveDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int SaveDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaign Class
AdCampaign Members
Overload List


%%PageItemTitle%%

SetCustom Method
[image]
dotnetCART Namespace > AdCampaign Class : SetCustom Method

name
newValue
This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added.

Syntax

Visual Basic (Declaration)
Public Function SetCustom( _
   ByVal name As String, _
   ByVal newValue As Object _
) As Object
C#
public object SetCustom(
   string name,
   object newValue
)

Parameters

name
newValue

Return Value

Returns the new custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

AdCampaign Class
AdCampaign Members


%%PageItemTitle%%

Add Method
[image]
dotnetCART Namespace > Addresses Class : Add Method

item
Adds an object to the end of the collection.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal item As Address _
)
C#
public void Add(
   Address item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members


%%PageItemTitle%%

AddRange Method
[image]
dotnetCART Namespace > Addresses Class : AddRange Method

collection
Adds the elements of the specified collection to the end of the collection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal collection As IEnumerable(Of Address) _
)
C#
public void AddRange(
   IEnumerable<Address> collection
)

Parameters

collection

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members


%%PageItemTitle%%

AsReadOnly Method
[image]
dotnetCART Namespace > Addresses Class : AsReadOnly Method

Returns a read-only IList wrapper for the current collection.

Syntax

Visual Basic (Declaration)
Public Function AsReadOnly() As ReadOnlyCollection(Of Address)
C#
public ReadOnlyCollection<Address> AsReadOnly()

Return Value

A ReadOnlyCollection that acts as a read-only wrapper around the current List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members


%%PageItemTitle%%

BinarySearch Method
[image]
dotnetCART Namespace > Addresses Class : BinarySearch Method

Overload List

Overload | Description
BinarySearch(Address) | (Inherited from dotnetCART.ListBase<Address>)
BinarySearch(Address,Generic IComparer) | (Inherited from dotnetCART.ListBase<Address>)
BinarySearch(Int32,Int32,Address,Generic IComparer) | (Inherited from dotnetCART.ListBase<Address>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members


%%PageItemTitle%%

BinarySearch(Address) Method
[image]
dotnetCART Namespace > Addresses Class > BinarySearch Method : BinarySearch(Address) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal item As Address _
) As Integer
C#
public int BinarySearch(
   Address item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members
Overload List


%%PageItemTitle%%

BinarySearch(Address,Generic IComparer) Method
[image]
dotnetCART Namespace > Addresses Class > BinarySearch Method : BinarySearch(Address,Generic IComparer) Method

item
comparer

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal item As Address, _
   ByVal comparer As IComparer(Of Address) _
) As Integer
C#
public int BinarySearch(
   Address item,
   IComparer<Address> comparer
)

Parameters

item
comparer

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members
Overload List


%%PageItemTitle%%

BinarySearch(Int32,Int32,Address,Generic IComparer) Method
[image]
dotnetCART Namespace > Addresses Class > BinarySearch Method : BinarySearch(Int32,Int32,Address,Generic IComparer) Method

index
count
item
comparer

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal index As Integer, _
   ByVal count As Integer, _
   ByVal item As Address, _
   ByVal comparer As IComparer(Of Address) _
) As Integer
C#
public int BinarySearch(
   int index,
   int count,
   Address item,
   IComparer<Address> comparer
)

Parameters

index
count
item
comparer

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members
Overload List


%%PageItemTitle%%

Capacity Property
[image]
dotnetCART Namespace > Addresses Class : Capacity Property

Gets or sets the total number of elements the internal data structure can hold without resizing.

Syntax

Visual Basic (Declaration)
Public Property Capacity As Integer
C#
public int Capacity {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > Addresses Class : Clear Method

Removes all elements from the List.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members


%%PageItemTitle%%

Contains Method
[image]
dotnetCART Namespace > Addresses Class : Contains Method

item
Determines whether an element is in the List.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal item As Address _
) As Boolean
C#
public bool Contains(
   Address item
)

Parameters

item

Return Value

true if item is found in the List; otherwise, false.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members


%%PageItemTitle%%

CopyTo Method
[image]
dotnetCART Namespace > Addresses Class : CopyTo Method

Overload List

Overload | Description
CopyTo(Address[]) | (Inherited from dotnetCART.ListBase<Address>)
CopyTo(Address[],Int32) | (Inherited from dotnetCART.ListBase<Address>)
CopyTo(Int32,Address[],Int32,Int32) | (Inherited from dotnetCART.ListBase<Address>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members


%%PageItemTitle%%

CopyTo(Address[]) Method
[image]
dotnetCART Namespace > Addresses Class > CopyTo Method : CopyTo(Address[]) Method

array

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array() As Address _
)
C#
public void CopyTo(
   Address[] array
)

Parameters

array

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members
Overload List


%%PageItemTitle%%

CopyTo(Address[],Int32) Method
[image]
dotnetCART Namespace > Addresses Class > CopyTo Method : CopyTo(Address[],Int32) Method

array
arrayIndex

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array() As Address, _
   ByVal arrayIndex As Integer _
)
C#
public void CopyTo(
   Address[] array,
   int arrayIndex
)

Parameters

array
arrayIndex

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members
Overload List


%%PageItemTitle%%

CopyTo(Int32,Address[],Int32,Int32) Method
[image]
dotnetCART Namespace > Addresses Class > CopyTo Method : CopyTo(Int32,Address[],Int32,Int32) Method

index
array
arrayIndex
count

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal index As Integer, _
   ByVal array() As Address, _
   ByVal arrayIndex As Integer, _
   ByVal count As Integer _
)
C#
public void CopyTo(
   int index,
   Address[] array,
   int arrayIndex,
   int count
)

Parameters

index
array
arrayIndex
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members
Overload List


%%PageItemTitle%%

Count Property
[image]
dotnetCART Namespace > Addresses Class : Count Property

Gets the number of elements actually contained in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > Addresses Class : Error Property

Returns an object with the error information.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members


%%PageItemTitle%%

GetEnumerator Method
[image]
dotnetCART Namespace > Addresses Class : GetEnumerator Method

Returns an enumerator that iterates through the List.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As List.Enumerator(Of Address)
C#
public List.Enumerator<Address> GetEnumerator()

Return Value

A List.Enumerator for the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members


%%PageItemTitle%%

IndexOf Method
[image]
dotnetCART Namespace > Addresses Class : IndexOf Method

Overload List

Overload | Description
IndexOf(Address) | (Inherited from dotnetCART.ListBase<Address>)
IndexOf(Address,Int32) | (Inherited from dotnetCART.ListBase<Address>)
IndexOf(Address,Int32,Int32) | (Inherited from dotnetCART.ListBase<Address>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members


%%PageItemTitle%%

IndexOf(Address) Method
[image]
dotnetCART Namespace > Addresses Class > IndexOf Method : IndexOf(Address) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As Address _
) As Integer
C#
public int IndexOf(
   Address item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members
Overload List


%%PageItemTitle%%

IndexOf(Address,Int32) Method
[image]
dotnetCART Namespace > Addresses Class > IndexOf Method : IndexOf(Address,Int32) Method

item
index

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As Address, _
   ByVal index As Integer _
) As Integer
C#
public int IndexOf(
   Address item,
   int index
)

Parameters

item
index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members
Overload List


%%PageItemTitle%%

IndexOf(Address,Int32,Int32) Method
[image]
dotnetCART Namespace > Addresses Class > IndexOf Method : IndexOf(Address,Int32,Int32) Method

item
index
count

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As Address, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
C#
public int IndexOf(
   Address item,
   int index,
   int count
)

Parameters

item
index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members
Overload List


%%PageItemTitle%%

Insert Method
[image]
dotnetCART Namespace > Addresses Class : Insert Method

index
item
Inserts an element into the List at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As Address _
)
C#
public void Insert(
   int index,
   Address item
)

Parameters

index
item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members


%%PageItemTitle%%

InsertRange Method
[image]
dotnetCART Namespace > Addresses Class : InsertRange Method

index
collection
Inserts the elements of a collection into the List at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub InsertRange( _
   ByVal index As Integer, _
   ByVal collection As IEnumerable(Of Address) _
)
C#
public void InsertRange(
   int index,
   IEnumerable<Address> collection
)

Parameters

index
collection

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members


%%PageItemTitle%%

Item(Int32) Property
[image]
dotnetCART Namespace > Addresses Class > Item Property : Item(Int32) Property

index
Gets or sets the element at the specified index.

Syntax

Visual Basic (Declaration)
Public Overloads Property Item( _
   ByVal index As Integer _
) As Address
C#
public Address Item(
   int index
) {get; set;}

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members
Overload List


%%PageItemTitle%%

LastIndexOf Method
[image]
dotnetCART Namespace > Addresses Class : LastIndexOf Method

Overload List

Overload | Description
LastIndexOf(Address) | (Inherited from dotnetCART.ListBase<Address>)
LastIndexOf(Address,Int32) | (Inherited from dotnetCART.ListBase<Address>)
LastIndexOf(Address,Int32,Int32) | (Inherited from dotnetCART.ListBase<Address>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members


%%PageItemTitle%%

LastIndexOf(Address) Method
[image]
dotnetCART Namespace > Addresses Class > LastIndexOf Method : LastIndexOf(Address) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As Address _
) As Integer
C#
public int LastIndexOf(
   Address item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members
Overload List


%%PageItemTitle%%

LastIndexOf(Address,Int32) Method
[image]
dotnetCART Namespace > Addresses Class > LastIndexOf Method : LastIndexOf(Address,Int32) Method

item
index

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As Address, _
   ByVal index As Integer _
) As Integer
C#
public int LastIndexOf(
   Address item,
   int index
)

Parameters

item
index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members
Overload List


%%PageItemTitle%%

LastIndexOf(Address,Int32,Int32) Method
[image]
dotnetCART Namespace > Addresses Class > LastIndexOf Method : LastIndexOf(Address,Int32,Int32) Method

item
index
count

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As Address, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
C#
public int LastIndexOf(
   Address item,
   int index,
   int count
)

Parameters

item
index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members
Overload List


%%PageItemTitle%%

LoadDB(Int32,Int32) Method
[image]
dotnetCART Namespace > Addresses Class > LoadDB Method : LoadDB(Int32,Int32) Method

start
count
Loads the count number of elements from start value.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal start As Integer, _
   ByVal count As Integer _
) As Integer
C#
public virtual int LoadDB(
   int start,
   int count
)

Parameters

start
count

Return Value

The total number of elements have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members
Overload List


%%PageItemTitle%%

LoadDB(Where) Method
[image]
dotnetCART Namespace > Addresses Class > LoadDB Method : LoadDB(Where) Method

whereClause
Loads all the items from its associated table based on the where clause.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal whereClause As Where _
) As Integer
C#
public virtual int LoadDB(
   Where whereClause
)

Parameters

whereClause

Return Value

The total number of items have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members
Overload List


%%PageItemTitle%%

Remove Method
[image]
dotnetCART Namespace > Addresses Class : Remove Method

item
Removes the first occurrence of a specific object from the List.

Syntax

Visual Basic (Declaration)
Public Function Remove( _
   ByVal item As Address _
) As Boolean
C#
public bool Remove(
   Address item
)

Parameters

item

Return Value

true if item is successfully removed; otherwise, false. This method also returns false if item was not found in the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members


%%PageItemTitle%%

RemoveAll Method
[image]
dotnetCART Namespace > Addresses Class : RemoveAll Method

match
Removes the all the elements that match the conditions defined by the specified predicate.

Syntax

Visual Basic (Declaration)
Public Function RemoveAll( _
   ByVal match As Predicate(Of Address) _
) As Integer
C#
public int RemoveAll(
   Predicate<Address> match
)

Parameters

match

Return Value

The number of elements removed from the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members


%%PageItemTitle%%

RemoveAt Method
[image]
dotnetCART Namespace > Addresses Class : RemoveAt Method

index
Removes the element at the specified index of the List.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members


%%PageItemTitle%%

RemoveRange Method
[image]
dotnetCART Namespace > Addresses Class : RemoveRange Method

index
count
Removes a range of elements from the List.

Syntax

Visual Basic (Declaration)
Public Sub RemoveRange( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
C#
public void RemoveRange(
   int index,
   int count
)

Parameters

index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members


%%PageItemTitle%%

Reverse Method
[image]
dotnetCART Namespace > Addresses Class : Reverse Method

Reverses the order of the elements in the entire List.

Overload List

Overload | Description
Reverse() | Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<Address>)
Reverse(Int32,Int32) | Reverses the order of the elements in the specified range. (Inherited from dotnetCART.ListBase<Address>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members


%%PageItemTitle%%

Reverse() Method
[image]
dotnetCART Namespace > Addresses Class > Reverse Method : Reverse() Method

Reverses the order of the elements in the entire List.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Reverse()
C#
public void Reverse()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members
Overload List


%%PageItemTitle%%

Reverse(Int32,Int32) Method
[image]
dotnetCART Namespace > Addresses Class > Reverse Method : Reverse(Int32,Int32) Method

index
count
Reverses the order of the elements in the specified range.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Reverse( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
C#
public void Reverse(
   int index,
   int count
)

Parameters

index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Addresses Class
Addresses Members
Overload List


%%PageItemTitle%%

City Property
[image]
dotnetCART Namespace > Address Class : City Property

Gets or sets this address's city.

Syntax

Visual Basic (Declaration)
Public Property City As String
C#
public string City {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Address Class
Address Members


%%PageItemTitle%%

Country Property
[image]
dotnetCART Namespace > Address Class : Country Property

Gets or sets this address's county.

Syntax

Visual Basic (Declaration)
Public Property Country As String
C#
public string Country {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Address Class
Address Members


%%PageItemTitle%%

Custom Property
[image]
dotnetCART Namespace > Address Class : Custom Property

Gets or sets a custom object. For more information see custom fields

Syntax

Visual Basic (Declaration)
Public Property Custom As Custom
C#
public Custom Custom {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Address Class
Address Members


%%PageItemTitle%%

CustomFields Property
See Also Example
[image]
dotnetCART Namespace > Address Class : CustomFields Property

Gets or sets a the names of custom fields for a table associated with the object.

Syntax

Visual Basic (Declaration)
Public Property CustomFields As String
C#
public string CustomFields {get; set;}

Example

C# Copy Code
Customer.CustomFields = "CellPhone,Favorites";

Visual Basic Copy Code
Customer.CustomFields = "CellPhone,Favorites"

Remarks

Custom fields must be added to the table manualy. Custom fields are usually set at store level using CustomFields

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Address Class
Address Members


%%PageItemTitle%%

Customs Property
[image]
dotnetCART Namespace > Address Class : Customs Property

A reference to the collection of the Custom objects.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Customs As Customs
C#
public Customs Customs {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Address Class
Address Members


%%PageItemTitle%%

DeleteDB Method
[image]
dotnetCART Namespace > Address Class : DeleteDB Method

Deletes this object with ID from the database.

Overload List

Overload | Description
DeleteDB() | Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<Address, Int64>)
DeleteDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Address Class
Address Members


%%PageItemTitle%%

DeleteDB() Method
[image]
dotnetCART Namespace > Address Class > DeleteDB Method : DeleteDB() Method

Deletes this object with ID from the database.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function DeleteDB() As Integer
C#
public virtual int DeleteDB()

Return Value

In case of error -1, check Error property, otherwise the number of objects deleted.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Address Class
Address Members
Overload List


%%PageItemTitle%%

DeleteDB(DbManager) Method
[image]
dotnetCART Namespace > Address Class > DeleteDB Method : DeleteDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function DeleteDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int DeleteDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Address Class
Address Members
Overload List


%%PageItemTitle%%

Email Property
[image]
dotnetCART Namespace > Address Class : Email Property

Gets or sets this address's email.

Syntax

Visual Basic (Declaration)
Public Property Email As String
C#
public string Email {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Address Class
Address Members


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > Address Class : Error Property

Gets the error object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Address Class
Address Members


%%PageItemTitle%%

Fax Property
[image]
dotnetCART Namespace > Address Class : Fax Property

Gets or sets this address's fax.

Syntax

Visual Basic (Declaration)
Public Property Fax As String
C#
public string Fax {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Address Class
Address Members


%%PageItemTitle%%

GetCustom Method
[image]
dotnetCART Namespace > Address Class : GetCustom Method

This method returns the value of a custom field based on its name in the customs collection.

Overload List

Overload | Description
GetCustom(String) | This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<Address, Int64>)
GetCustom(Int32) | This method returns the value of a custom field based on its index in the customs collection. (Inherited from dotnetCART.DbTableCart<Address, Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Address Class
Address Members


%%PageItemTitle%%

GetCustom(Int32) Method
[image]
dotnetCART Namespace > Address Class > GetCustom Method : GetCustom(Int32) Method

customIndex
This method returns the value of a custom field based on its index in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal customIndex As Integer _
) As Object
C#
public object GetCustom(
   int customIndex
)

Parameters

customIndex

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Address Class
Address Members
Overload List


%%PageItemTitle%%

GetCustom(String) Method
[image]
dotnetCART Namespace > Address Class > GetCustom Method : GetCustom(String) Method

name
This method returns the value of a custom field based on its name in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal name As String _
) As Object
C#
public object GetCustom(
   string name
)

Parameters

name

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Address Class
Address Members
Overload List


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > Address Class : LoadDB Method

Loads this object from database using the ID property.

Overload List

Overload | Description
LoadDB(Int64) | (Inherited from dotnetCART.DbTableCart<Address, Int64>)
LoadDB() | Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<Address, Int64>)
Generic LoadDB() | (Inherited from dotnetDATA.DbTable<Int64>)
Generic LoadDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Address Class
Address Members


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > Address Class > LoadDB Method : LoadDB() Method

Loads this object from database using the ID property.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB() As Integer
C#
public virtual int LoadDB()

Return Value

In case of error -1, check Error property, if the object with the ID property not found 0, otherwise 1.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Address Class
Address Members
Overload List


%%PageItemTitle%%

LoadDB(Int64) Method
[image]
dotnetCART Namespace > Address Class > LoadDB Method : LoadDB(Int64) Method

id

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal id As Long _
) As Integer
C#
public virtual int LoadDB(
   long id
)

Parameters

id

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Address Class
Address Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB() Method
See Also
[image]
dotnetCART Namespace > Address Class > LoadDB Method : Generic LoadDB() Method

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)() As Integer
C#
public virtual int LoadDB<T1>()where T1: IDbTable

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Address Class
Address Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB(DbManager) Method
See Also
[image]
dotnetCART Namespace > Address Class > LoadDB Method : Generic LoadDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int LoadDB<T1>(
   DbManager manager
)where T1: IDbTable

Parameters

manager

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Address Class
Address Members
Overload List


%%PageItemTitle%%

Phone Property
[image]
dotnetCART Namespace > Address Class : Phone Property

Gets or sets this address's phone.

Syntax

Visual Basic (Declaration)
Public Property Phone As String
C#
public string Phone {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Address Class
Address Members


%%PageItemTitle%%

Residential Property
[image]
dotnetCART Namespace > Address Class : Residential Property

Gets or sets a boolean that specifies whether this address is residential or not.

Syntax

Visual Basic (Declaration)
Public Property Residential As Boolean
C#
public bool Residential {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Address Class
Address Members


%%PageItemTitle%%

SaveDB() Method
[image]
dotnetCART Namespace > Address Class > SaveDB Method : SaveDB() Method

Inserts or updates this object into the database.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function SaveDB() As Integer
C#
public virtual int SaveDB()

Return Value

Returns the generated ID or 1 for the update, returns -1 if failed. For the reason of fail, check the Generic DbTableCart.Error property.

Remarks

If Generic DbTableCart.ID greater than 0, it updates the associated object in the table, otherwise inserts a new object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Address Class
Address Members
Overload List


%%PageItemTitle%%

SaveDB(DbManager) Method
[image]
dotnetCART Namespace > Address Class > SaveDB Method : SaveDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function SaveDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int SaveDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Address Class
Address Members
Overload List


%%PageItemTitle%%

SetCustom Method
[image]
dotnetCART Namespace > Address Class : SetCustom Method

name
newValue
This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added.

Syntax

Visual Basic (Declaration)
Public Function SetCustom( _
   ByVal name As String, _
   ByVal newValue As Object _
) As Object
C#
public object SetCustom(
   string name,
   object newValue
)

Parameters

name
newValue

Return Value

Returns the new custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Address Class
Address Members


%%PageItemTitle%%

StateProvince Property
[image]
dotnetCART Namespace > Address Class : StateProvince Property

Gets or sets this address's state.

Syntax

Visual Basic (Declaration)
Public Property StateProvince As String
C#
public string StateProvince {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Address Class
Address Members


%%PageItemTitle%%

Street Property
[image]
dotnetCART Namespace > Address Class : Street Property

Gets or sets this address's street.

Syntax

Visual Basic (Declaration)
Public Property Street As String
C#
public string Street {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Address Class
Address Members


%%PageItemTitle%%

ZipPostal Property
[image]
dotnetCART Namespace > Address Class : ZipPostal Property

Gets or sets this address's zip postal code.

Syntax

Visual Basic (Declaration)
Public Property ZipPostal As String
C#
public string ZipPostal {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Address Class
Address Members


%%PageItemTitle%%

SortDirection Field
[image]
dotnetCART Namespace > Categories.categoryComparerClass Class : SortDirection Field

Syntax

Visual Basic (Declaration)
Public SortDirection As OrderDirection
C#
public OrderDirection SortDirection

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories.categoryComparerClass Class
Categories.categoryComparerClass Members


%%PageItemTitle%%

SortOption Field
[image]
dotnetCART Namespace > Categories.categoryComparerClass Class : SortOption Field

Syntax

Visual Basic (Declaration)
Public SortOption As String
C#
public string SortOption

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories.categoryComparerClass Class
Categories.categoryComparerClass Members


%%PageItemTitle%% $$Properties$$

Categories Class Properties
[image]
dotnetCART Namespace : Categories Class

For a list of all members of this type, see Categories members.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from dotnetCART.ListBase<Category>)
Public Property | Count | Gets the number of elements actually contained in the collection. (Inherited from dotnetCART.ListBase<Category>)
Public Property | Error | Returns an object with the error information. (Inherited from dotnetCART.ListBase<Category>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from dotnetCART.ListBase<Category>)
Top

See Also

Reference

Categories Class
dotnetCART Namespace


%%PageItemTitle%%

Add Method
[image]
dotnetCART Namespace > Categories Class : Add Method

item
Adds an object to the end of the collection.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal item As Category _
)
C#
public void Add(
   Category item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Class
Categories Members


%%PageItemTitle%%

AddRange Method
[image]
dotnetCART Namespace > Categories Class : AddRange Method

collection
Adds the elements of the specified collection to the end of the collection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal collection As IEnumerable(Of Category) _
)
C#
public void AddRange(
   IEnumerable<Category> collection
)

Parameters

collection

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Class
Categories Members


%%PageItemTitle%%

AsReadOnly Method
[image]
dotnetCART Namespace > Categories Class : AsReadOnly Method

Returns a read-only IList wrapper for the current collection.

Syntax

Visual Basic (Declaration)
Public Function AsReadOnly() As ReadOnlyCollection(Of Category)
C#
public ReadOnlyCollection<Category> AsReadOnly()

Return Value

A ReadOnlyCollection that acts as a read-only wrapper around the current List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Class
Categories Members


%%PageItemTitle%%

BinarySearch Method
[image]
dotnetCART Namespace > Categories Class : BinarySearch Method

Overload List

Overload | Description
BinarySearch(Category) | (Inherited from dotnetCART.ListBase<Category>)
BinarySearch(Category,Generic IComparer) | (Inherited from dotnetCART.ListBase<Category>)
BinarySearch(Int32,Int32,Category,Generic IComparer) | (Inherited from dotnetCART.ListBase<Category>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Class
Categories Members


%%PageItemTitle%%

BinarySearch(Category) Method
[image]
dotnetCART Namespace > Categories Class > BinarySearch Method : BinarySearch(Category) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal item As Category _
) As Integer
C#
public int BinarySearch(
   Category item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Class
Categories Members
Overload List


%%PageItemTitle%%

BinarySearch(Category,Generic IComparer) Method
[image]
dotnetCART Namespace > Categories Class > BinarySearch Method : BinarySearch(Category,Generic IComparer) Method

item
comparer

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal item As Category, _
   ByVal comparer As IComparer(Of Category) _
) As Integer
C#
public int BinarySearch(
   Category item,
   IComparer<Category> comparer
)

Parameters

item
comparer

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Class
Categories Members
Overload List


%%PageItemTitle%%

BinarySearch(Int32,Int32,Category,Generic IComparer) Method
[image]
dotnetCART Namespace > Categories Class > BinarySearch Method : BinarySearch(Int32,Int32,Category,Generic IComparer) Method

index
count
item
comparer

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal index As Integer, _
   ByVal count As Integer, _
   ByVal item As Category, _
   ByVal comparer As IComparer(Of Category) _
) As Integer
C#
public int BinarySearch(
   int index,
   int count,
   Category item,
   IComparer<Category> comparer
)

Parameters

index
count
item
comparer

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Class
Categories Members
Overload List


%%PageItemTitle%%

Capacity Property
[image]
dotnetCART Namespace > Categories Class : Capacity Property

Gets or sets the total number of elements the internal data structure can hold without resizing.

Syntax

Visual Basic (Declaration)
Public Property Capacity As Integer
C#
public int Capacity {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Class
Categories Members


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > Categories Class : Clear Method

Removes all elements from the List.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Class
Categories Members


%%PageItemTitle%%

Contains Method
[image]
dotnetCART Namespace > Categories Class : Contains Method

item
Determines whether an element is in the List.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal item As Category _
) As Boolean
C#
public bool Contains(
   Category item
)

Parameters

item

Return Value

true if item is found in the List; otherwise, false.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Class
Categories Members


%%PageItemTitle%%

CopyTo Method
[image]
dotnetCART Namespace > Categories Class : CopyTo Method

Overload List

Overload | Description
CopyTo(Category[]) | (Inherited from dotnetCART.ListBase<Category>)
CopyTo(Category[],Int32) | (Inherited from dotnetCART.ListBase<Category>)
CopyTo(Int32,Category[],Int32,Int32) | (Inherited from dotnetCART.ListBase<Category>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Class
Categories Members


%%PageItemTitle%%

CopyTo(Category[]) Method
[image]
dotnetCART Namespace > Categories Class > CopyTo Method : CopyTo(Category[]) Method

array

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array() As Category _
)
C#
public void CopyTo(
   Category[] array
)

Parameters

array

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Class
Categories Members
Overload List


%%PageItemTitle%%

CopyTo(Category[],Int32) Method
[image]
dotnetCART Namespace > Categories Class > CopyTo Method : CopyTo(Category[],Int32) Method

array
arrayIndex

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array() As Category, _
   ByVal arrayIndex As Integer _
)
C#
public void CopyTo(
   Category[] array,
   int arrayIndex
)

Parameters

array
arrayIndex

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Class
Categories Members
Overload List


%%PageItemTitle%%

CopyTo(Int32,Category[],Int32,Int32) Method
[image]
dotnetCART Namespace > Categories Class > CopyTo Method : CopyTo(Int32,Category[],Int32,Int32) Method

index
array
arrayIndex
count

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal index As Integer, _
   ByVal array() As Category, _
   ByVal arrayIndex As Integer, _
   ByVal count As Integer _
)
C#
public void CopyTo(
   int index,
   Category[] array,
   int arrayIndex,
   int count
)

Parameters

index
array
arrayIndex
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Class
Categories Members
Overload List


%%PageItemTitle%%

Count Property
[image]
dotnetCART Namespace > Categories Class : Count Property

Gets the number of elements actually contained in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Class
Categories Members


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > Categories Class : Error Property

Returns an object with the error information.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Class
Categories Members


%%PageItemTitle%%

GetEnumerator Method
[image]
dotnetCART Namespace > Categories Class : GetEnumerator Method

Returns an enumerator that iterates through the List.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As List.Enumerator(Of Category)
C#
public List.Enumerator<Category> GetEnumerator()

Return Value

A List.Enumerator for the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Class
Categories Members


%%PageItemTitle%%

IndexOf Method
[image]
dotnetCART Namespace > Categories Class : IndexOf Method

Overload List

Overload | Description
IndexOf(Category) | (Inherited from dotnetCART.ListBase<Category>)
IndexOf(Category,Int32) | (Inherited from dotnetCART.ListBase<Category>)
IndexOf(Category,Int32,Int32) | (Inherited from dotnetCART.ListBase<Category>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Class
Categories Members


%%PageItemTitle%%

IndexOf(Category) Method
[image]
dotnetCART Namespace > Categories Class > IndexOf Method : IndexOf(Category) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As Category _
) As Integer
C#
public int IndexOf(
   Category item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Class
Categories Members
Overload List


%%PageItemTitle%%

IndexOf(Category,Int32) Method
[image]
dotnetCART Namespace > Categories Class > IndexOf Method : IndexOf(Category,Int32) Method

item
index

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As Category, _
   ByVal index As Integer _
) As Integer
C#
public int IndexOf(
   Category item,
   int index
)

Parameters

item
index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Class
Categories Members
Overload List


%%PageItemTitle%%

IndexOf(Category,Int32,Int32) Method
[image]
dotnetCART Namespace > Categories Class > IndexOf Method : IndexOf(Category,Int32,Int32) Method

item
index
count

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As Category, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
C#
public int IndexOf(
   Category item,
   int index,
   int count
)

Parameters

item
index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Class
Categories Members
Overload List


%%PageItemTitle%%

Insert Method
[image]
dotnetCART Namespace > Categories Class : Insert Method

index
item
Inserts an element into the List at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As Category _
)
C#
public void Insert(
   int index,
   Category item
)

Parameters

index
item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Class
Categories Members


%%PageItemTitle%%

InsertRange Method
[image]
dotnetCART Namespace > Categories Class : InsertRange Method

index
collection
Inserts the elements of a collection into the List at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub InsertRange( _
   ByVal index As Integer, _
   ByVal collection As IEnumerable(Of Category) _
)
C#
public void InsertRange(
   int index,
   IEnumerable<Category> collection
)

Parameters

index
collection

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Class
Categories Members


%%PageItemTitle%%

Item Property
[image]
dotnetCART Namespace > Categories Class : Item Property

index
Gets or sets the element at the specified index.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As Category
C#
public Category this[
   int index
]; {get; set;}

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Class
Categories Members


%%PageItemTitle%%

LastIndexOf Method
[image]
dotnetCART Namespace > Categories Class : LastIndexOf Method

Overload List

Overload | Description
LastIndexOf(Category) | (Inherited from dotnetCART.ListBase<Category>)
LastIndexOf(Category,Int32) | (Inherited from dotnetCART.ListBase<Category>)
LastIndexOf(Category,Int32,Int32) | (Inherited from dotnetCART.ListBase<Category>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Class
Categories Members


%%PageItemTitle%%

LastIndexOf(Category) Method
[image]
dotnetCART Namespace > Categories Class > LastIndexOf Method : LastIndexOf(Category) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As Category _
) As Integer
C#
public int LastIndexOf(
   Category item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Class
Categories Members
Overload List


%%PageItemTitle%%

LastIndexOf(Category,Int32) Method
[image]
dotnetCART Namespace > Categories Class > LastIndexOf Method : LastIndexOf(Category,Int32) Method

item
index

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As Category, _
   ByVal index As Integer _
) As Integer
C#
public int LastIndexOf(
   Category item,
   int index
)

Parameters

item
index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Class
Categories Members
Overload List


%%PageItemTitle%%

LastIndexOf(Category,Int32,Int32) Method
[image]
dotnetCART Namespace > Categories Class > LastIndexOf Method : LastIndexOf(Category,Int32,Int32) Method

item
index
count

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As Category, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
C#
public int LastIndexOf(
   Category item,
   int index,
   int count
)

Parameters

item
index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Class
Categories Members
Overload List


%%PageItemTitle%%

LoadDB(Where) Method
[image]
dotnetCART Namespace > Categories Class > LoadDB Method : LoadDB(Where) Method

whereClause
Loads all the items from its associated table based on the where clause.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal whereClause As Where _
) As Integer
C#
public virtual int LoadDB(
   Where whereClause
)

Parameters

whereClause

Return Value

The total number of items have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Class
Categories Members
Overload List


%%PageItemTitle%%

Remove Method
[image]
dotnetCART Namespace > Categories Class : Remove Method

item
Removes the first occurrence of a specific object from the List.

Syntax

Visual Basic (Declaration)
Public Function Remove( _
   ByVal item As Category _
) As Boolean
C#
public bool Remove(
   Category item
)

Parameters

item

Return Value

true if item is successfully removed; otherwise, false. This method also returns false if item was not found in the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Class
Categories Members


%%PageItemTitle%%

RemoveAll Method
[image]
dotnetCART Namespace > Categories Class : RemoveAll Method

match
Removes the all the elements that match the conditions defined by the specified predicate.

Syntax

Visual Basic (Declaration)
Public Function RemoveAll( _
   ByVal match As Predicate(Of Category) _
) As Integer
C#
public int RemoveAll(
   Predicate<Category> match
)

Parameters

match

Return Value

The number of elements removed from the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Class
Categories Members


%%PageItemTitle%%

RemoveAt Method
[image]
dotnetCART Namespace > Categories Class : RemoveAt Method

index
Removes the element at the specified index of the List.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Class
Categories Members


%%PageItemTitle%%

RemoveRange Method
[image]
dotnetCART Namespace > Categories Class : RemoveRange Method

index
count
Removes a range of elements from the List.

Syntax

Visual Basic (Declaration)
Public Sub RemoveRange( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
C#
public void RemoveRange(
   int index,
   int count
)

Parameters

index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Class
Categories Members


%%PageItemTitle%%

Reverse Method
[image]
dotnetCART Namespace > Categories Class : Reverse Method

Reverses the order of the elements in the entire List.

Overload List

Overload | Description
Reverse() | Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<Category>)
Reverse(Int32,Int32) | Reverses the order of the elements in the specified range. (Inherited from dotnetCART.ListBase<Category>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Class
Categories Members


%%PageItemTitle%%

Reverse() Method
[image]
dotnetCART Namespace > Categories Class > Reverse Method : Reverse() Method

Reverses the order of the elements in the entire List.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Reverse()
C#
public void Reverse()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Class
Categories Members
Overload List


%%PageItemTitle%%

Reverse(Int32,Int32) Method
[image]
dotnetCART Namespace > Categories Class > Reverse Method : Reverse(Int32,Int32) Method

index
count
Reverses the order of the elements in the specified range.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Reverse( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
C#
public void Reverse(
   int index,
   int count
)

Parameters

index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Categories Class
Categories Members
Overload List


%%PageItemTitle%%

Custom Property
[image]
dotnetCART Namespace > Category Class : Custom Property

Gets or sets a custom object. For more information see custom fields

Syntax

Visual Basic (Declaration)
Public Property Custom As Custom
C#
public Custom Custom {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Category Class
Category Members


%%PageItemTitle%%

CustomFields Property
See Also Example
[image]
dotnetCART Namespace > Category Class : CustomFields Property

Gets or sets a the names of custom fields for a table associated with the object.

Syntax

Visual Basic (Declaration)
Public Property CustomFields As String
C#
public string CustomFields {get; set;}

Example

C# Copy Code
Customer.CustomFields = "CellPhone,Favorites";

Visual Basic Copy Code
Customer.CustomFields = "CellPhone,Favorites"

Remarks

Custom fields must be added to the table manualy. Custom fields are usually set at store level using CustomFields

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Category Class
Category Members


%%PageItemTitle%%

Customs Property
[image]
dotnetCART Namespace > Category Class : Customs Property

A reference to the collection of the Custom objects.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Customs As Customs
C#
public Customs Customs {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Category Class
Category Members


%%PageItemTitle%%

DeleteDB(DbManager) Method
[image]
dotnetCART Namespace > Category Class > DeleteDB Method : DeleteDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function DeleteDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int DeleteDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Category Class
Category Members
Overload List


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > Category Class : Error Property

Gets the error object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Category Class
Category Members


%%PageItemTitle%%

GetCustom Method
[image]
dotnetCART Namespace > Category Class : GetCustom Method

This method returns the value of a custom field based on its name in the customs collection.

Overload List

Overload | Description
GetCustom(String) | This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<Category, Int64>)
GetCustom(Int32) | This method returns the value of a custom field based on its index in the customs collection. (Inherited from dotnetCART.DbTableCart<Category, Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Category Class
Category Members


%%PageItemTitle%%

GetCustom(Int32) Method
[image]
dotnetCART Namespace > Category Class > GetCustom Method : GetCustom(Int32) Method

customIndex
This method returns the value of a custom field based on its index in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal customIndex As Integer _
) As Object
C#
public object GetCustom(
   int customIndex
)

Parameters

customIndex

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Category Class
Category Members
Overload List


%%PageItemTitle%%

GetCustom(String) Method
[image]
dotnetCART Namespace > Category Class > GetCustom Method : GetCustom(String) Method

name
This method returns the value of a custom field based on its name in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal name As String _
) As Object
C#
public object GetCustom(
   string name
)

Parameters

name

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Category Class
Category Members
Overload List


%%PageItemTitle%%

LoadDB(Int64) Method
[image]
dotnetCART Namespace > Category Class > LoadDB Method : LoadDB(Int64) Method

id

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal id As Long _
) As Integer
C#
public virtual int LoadDB(
   long id
)

Parameters

id

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Category Class
Category Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB() Method
See Also
[image]
dotnetCART Namespace > Category Class > LoadDB Method : Generic LoadDB() Method

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)() As Integer
C#
public virtual int LoadDB<T1>()where T1: IDbTable

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Category Class
Category Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB(DbManager) Method
See Also
[image]
dotnetCART Namespace > Category Class > LoadDB Method : Generic LoadDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int LoadDB<T1>(
   DbManager manager
)where T1: IDbTable

Parameters

manager

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Category Class
Category Members
Overload List


%%PageItemTitle%%

SaveDB(DbManager) Method
[image]
dotnetCART Namespace > Category Class > SaveDB Method : SaveDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function SaveDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int SaveDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Category Class
Category Members
Overload List


%%PageItemTitle%%

SetCustom Method
[image]
dotnetCART Namespace > Category Class : SetCustom Method

name
newValue
This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added.

Syntax

Visual Basic (Declaration)
Public Function SetCustom( _
   ByVal name As String, _
   ByVal newValue As Object _
) As Object
C#
public object SetCustom(
   string name,
   object newValue
)

Parameters

name
newValue

Return Value

Returns the new custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Category Class
Category Members


%%PageItemTitle%%

Add(Choice) Method
[image]
dotnetCART Namespace > Choices Class > Add Method : Add(Choice) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add( _
   ByVal item As Choice _
)
C#
public void Add(
   Choice item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choices Class
Choices Members
Overload List


%%PageItemTitle%%

AddRange Method
[image]
dotnetCART Namespace > Choices Class : AddRange Method

Adds the elements of the specified collection to the end of the collection.

Overload List

Overload | Description
AddRange(Choice[]) | (Inherited from dotnetDATA.EntitySet<Choice>)
AddRange(Generic EntitySet) | Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetDATA.EntitySet<Choice>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choices Class
Choices Members


%%PageItemTitle%%

AddRange(Choice[]) Method
[image]
dotnetCART Namespace > Choices Class > AddRange Method : AddRange(Choice[]) Method

items

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddRange( _
   ByVal items() As Choice _
)
C#
public void AddRange(
   Choice[] items
)

Parameters

items

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choices Class
Choices Members
Overload List


%%PageItemTitle%%

AddRange(Generic EntitySet) Method
[image]
dotnetCART Namespace > Choices Class > AddRange Method : AddRange(Generic EntitySet) Method

items
Adds the elements of the specified collection to the end of the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddRange( _
   ByVal items As EntitySet(Of Choice) _
)
C#
public void AddRange(
   EntitySet<Choice> items
)

Parameters

items

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choices Class
Choices Members
Overload List


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > Choices Class : Clear Method

Removes all elements from the List.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choices Class
Choices Members


%%PageItemTitle%%

Contains Method
[image]
dotnetCART Namespace > Choices Class : Contains Method

item
Determines whether an element is in the List.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal item As Choice _
) As Boolean
C#
public bool Contains(
   Choice item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choices Class
Choices Members


%%PageItemTitle%%

Count Property
[image]
dotnetCART Namespace > Choices Class : Count Property

Returns the number of items in the collection.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Count As Integer
C#
public virtual int Count {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choices Class
Choices Members


%%PageItemTitle%%

IndexOf Method
[image]
dotnetCART Namespace > Choices Class : IndexOf Method

item
Returns the index of this item in the list.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal item As Choice _
) As Integer
C#
public int IndexOf(
   Choice item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choices Class
Choices Members


%%PageItemTitle%%

Insert Method
[image]
dotnetCART Namespace > Choices Class : Insert Method

index
item
Inserts an element into the List at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As Choice _
)
C#
public void Insert(
   int index,
   Choice item
)

Parameters

index
item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choices Class
Choices Members


%%PageItemTitle%%

Item(Int32) Property
[image]
dotnetCART Namespace > Choices Class > Item Property : Item(Int32) Property

index
Gets the element at the specified index.

Syntax

Visual Basic (Declaration)
Public Overloads Property Item( _
   ByVal index As Integer _
) As Choice
C#
public Choice Item(
   int index
) {get; set;}

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choices Class
Choices Members
Overload List


%%PageItemTitle%%

optionChoice Field
[image]
dotnetCART Namespace > Choices Class : optionChoice Field

Syntax

Visual Basic (Declaration)
Public optionChoice As Option
C#
public Option optionChoice

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choices Class
Choices Members


%%PageItemTitle%%

Remove Method
[image]
dotnetCART Namespace > Choices Class : Remove Method

item
Removes the item from the collection.

Syntax

Visual Basic (Declaration)
Public Function Remove( _
   ByVal item As Choice _
) As Boolean
C#
public bool Remove(
   Choice item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choices Class
Choices Members


%%PageItemTitle%%

RemoveAt Method
[image]
dotnetCART Namespace > Choices Class : RemoveAt Method

index
Removes the element at the specified index of the List.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choices Class
Choices Members


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > Choice Class : Clear Method

Initializes all the properties without recreating the object.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Clear()
C#
public virtual void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choice Class
Choice Members


%%PageItemTitle%%

Custom Property
[image]
dotnetCART Namespace > Choice Class : Custom Property

Gets or sets a custom object. For more information see custom fields

Syntax

Visual Basic (Declaration)
Public Property Custom As Custom
C#
public Custom Custom {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choice Class
Choice Members


%%PageItemTitle%%

CustomFields Property
See Also Example
[image]
dotnetCART Namespace > Choice Class : CustomFields Property

Gets or sets a the names of custom fields for a table associated with the object.

Syntax

Visual Basic (Declaration)
Public Property CustomFields As String
C#
public string CustomFields {get; set;}

Example

C# Copy Code
Customer.CustomFields = "CellPhone,Favorites";

Visual Basic Copy Code
Customer.CustomFields = "CellPhone,Favorites"

Remarks

Custom fields must be added to the table manualy. Custom fields are usually set at store level using CustomFields

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choice Class
Choice Members


%%PageItemTitle%%

Customs Property
[image]
dotnetCART Namespace > Choice Class : Customs Property

A reference to the collection of the Custom objects.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Customs As Customs
C#
public Customs Customs {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choice Class
Choice Members


%%PageItemTitle%%

DeleteDB Method
[image]
dotnetCART Namespace > Choice Class : DeleteDB Method

Deletes this object with ID from the database.

Overload List

Overload | Description
DeleteDB() | Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<Choice, Int64>)
DeleteDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choice Class
Choice Members


%%PageItemTitle%%

DeleteDB() Method
[image]
dotnetCART Namespace > Choice Class > DeleteDB Method : DeleteDB() Method

Deletes this object with ID from the database.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function DeleteDB() As Integer
C#
public virtual int DeleteDB()

Return Value

In case of error -1, check Error property, otherwise the number of objects deleted.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choice Class
Choice Members
Overload List


%%PageItemTitle%%

DeleteDB(DbManager) Method
[image]
dotnetCART Namespace > Choice Class > DeleteDB Method : DeleteDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function DeleteDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int DeleteDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choice Class
Choice Members
Overload List


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > Choice Class : Error Property

Gets the error object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choice Class
Choice Members


%%PageItemTitle%%

GetCustom Method
[image]
dotnetCART Namespace > Choice Class : GetCustom Method

This method returns the value of a custom field based on its name in the customs collection.

Overload List

Overload | Description
GetCustom(String) | This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<Choice, Int64>)
GetCustom(Int32) | This method returns the value of a custom field based on its index in the customs collection. (Inherited from dotnetCART.DbTableCart<Choice, Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choice Class
Choice Members


%%PageItemTitle%%

GetCustom(Int32) Method
[image]
dotnetCART Namespace > Choice Class > GetCustom Method : GetCustom(Int32) Method

customIndex
This method returns the value of a custom field based on its index in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal customIndex As Integer _
) As Object
C#
public object GetCustom(
   int customIndex
)

Parameters

customIndex

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choice Class
Choice Members
Overload List


%%PageItemTitle%%

GetCustom(String) Method
[image]
dotnetCART Namespace > Choice Class > GetCustom Method : GetCustom(String) Method

name
This method returns the value of a custom field based on its name in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal name As String _
) As Object
C#
public object GetCustom(
   string name
)

Parameters

name

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choice Class
Choice Members
Overload List


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > Choice Class : LoadDB Method

Loads this object from database using the ID property.

Overload List

Overload | Description
LoadDB(Int64) | (Inherited from dotnetCART.DbTableCart<Choice, Int64>)
LoadDB() | Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<Choice, Int64>)
Generic LoadDB() | (Inherited from dotnetDATA.DbTable<Int64>)
Generic LoadDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choice Class
Choice Members


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > Choice Class > LoadDB Method : LoadDB() Method

Loads this object from database using the ID property.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB() As Integer
C#
public virtual int LoadDB()

Return Value

In case of error -1, check Error property, if the object with the ID property not found 0, otherwise 1.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choice Class
Choice Members
Overload List


%%PageItemTitle%%

LoadDB(Int64) Method
[image]
dotnetCART Namespace > Choice Class > LoadDB Method : LoadDB(Int64) Method

id

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal id As Long _
) As Integer
C#
public virtual int LoadDB(
   long id
)

Parameters

id

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choice Class
Choice Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB() Method
See Also
[image]
dotnetCART Namespace > Choice Class > LoadDB Method : Generic LoadDB() Method

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)() As Integer
C#
public virtual int LoadDB<T1>()where T1: IDbTable

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choice Class
Choice Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB(DbManager) Method
See Also
[image]
dotnetCART Namespace > Choice Class > LoadDB Method : Generic LoadDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int LoadDB<T1>(
   DbManager manager
)where T1: IDbTable

Parameters

manager

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choice Class
Choice Members
Overload List


%%PageItemTitle%%

SaveDB Method
[image]
dotnetCART Namespace > Choice Class : SaveDB Method

Inserts or updates this object into the database.

Overload List

Overload | Description
SaveDB() | Inserts or updates this object into the database. (Inherited from dotnetCART.DbTableCart<Choice, Int64>)
SaveDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choice Class
Choice Members


%%PageItemTitle%%

SaveDB() Method
[image]
dotnetCART Namespace > Choice Class > SaveDB Method : SaveDB() Method

Inserts or updates this object into the database.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function SaveDB() As Integer
C#
public virtual int SaveDB()

Return Value

Returns the generated ID or 1 for the update, returns -1 if failed. For the reason of fail, check the Generic DbTableCart.Error property.

Remarks

If Generic DbTableCart.ID greater than 0, it updates the associated object in the table, otherwise inserts a new object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choice Class
Choice Members
Overload List


%%PageItemTitle%%

SaveDB(DbManager) Method
[image]
dotnetCART Namespace > Choice Class > SaveDB Method : SaveDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function SaveDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int SaveDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choice Class
Choice Members
Overload List


%%PageItemTitle%%

SetCustom Method
[image]
dotnetCART Namespace > Choice Class : SetCustom Method

name
newValue
This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added.

Syntax

Visual Basic (Declaration)
Public Function SetCustom( _
   ByVal name As String, _
   ByVal newValue As Object _
) As Object
C#
public object SetCustom(
   string name,
   object newValue
)

Parameters

name
newValue

Return Value

Returns the new custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Choice Class
Choice Members


%%PageItemTitle%% $$Properties$$

Coupons Class Properties
[image]
dotnetCART Namespace : Coupons Class

For a list of all members of this type, see Coupons members.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from dotnetCART.ListBase<Coupon>)
Public Property | Count | Gets the number of elements actually contained in the collection. (Inherited from dotnetCART.ListBase<Coupon>)
Public Property | Error | Returns an object with the error information. (Inherited from dotnetCART.ListBase<Coupon>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from dotnetCART.ListBase<Coupon>)
Top

See Also

Reference

Coupons Class
dotnetCART Namespace


%%PageItemTitle%%

AddRange Method
[image]
dotnetCART Namespace > Coupons Class : AddRange Method

collection
Adds the elements of the specified collection to the end of the collection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal collection As IEnumerable(Of Coupon) _
)
C#
public void AddRange(
   IEnumerable<Coupon> collection
)

Parameters

collection

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupons Class
Coupons Members


%%PageItemTitle%%

AsReadOnly Method
[image]
dotnetCART Namespace > Coupons Class : AsReadOnly Method

Returns a read-only IList wrapper for the current collection.

Syntax

Visual Basic (Declaration)
Public Function AsReadOnly() As ReadOnlyCollection(Of Coupon)
C#
public ReadOnlyCollection<Coupon> AsReadOnly()

Return Value

A ReadOnlyCollection that acts as a read-only wrapper around the current List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupons Class
Coupons Members


%%PageItemTitle%%

BinarySearch Method
[image]
dotnetCART Namespace > Coupons Class : BinarySearch Method

Overload List

Overload | Description
BinarySearch(Coupon) | (Inherited from dotnetCART.ListBase<Coupon>)
BinarySearch(Coupon,Generic IComparer) | (Inherited from dotnetCART.ListBase<Coupon>)
BinarySearch(Int32,Int32,Coupon,Generic IComparer) | (Inherited from dotnetCART.ListBase<Coupon>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupons Class
Coupons Members


%%PageItemTitle%%

BinarySearch(Coupon) Method
[image]
dotnetCART Namespace > Coupons Class > BinarySearch Method : BinarySearch(Coupon) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal item As Coupon _
) As Integer
C#
public int BinarySearch(
   Coupon item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupons Class
Coupons Members
Overload List


%%PageItemTitle%%

BinarySearch(Coupon,Generic IComparer) Method
[image]
dotnetCART Namespace > Coupons Class > BinarySearch Method : BinarySearch(Coupon,Generic IComparer) Method

item
comparer

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal item As Coupon, _
   ByVal comparer As IComparer(Of Coupon) _
) As Integer
C#
public int BinarySearch(
   Coupon item,
   IComparer<Coupon> comparer
)

Parameters

item
comparer

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupons Class
Coupons Members
Overload List


%%PageItemTitle%%

BinarySearch(Int32,Int32,Coupon,Generic IComparer) Method
[image]
dotnetCART Namespace > Coupons Class > BinarySearch Method : BinarySearch(Int32,Int32,Coupon,Generic IComparer) Method

index
count
item
comparer

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal index As Integer, _
   ByVal count As Integer, _
   ByVal item As Coupon, _
   ByVal comparer As IComparer(Of Coupon) _
) As Integer
C#
public int BinarySearch(
   int index,
   int count,
   Coupon item,
   IComparer<Coupon> comparer
)

Parameters

index
count
item
comparer

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupons Class
Coupons Members
Overload List


%%PageItemTitle%%

Capacity Property
[image]
dotnetCART Namespace > Coupons Class : Capacity Property

Gets or sets the total number of elements the internal data structure can hold without resizing.

Syntax

Visual Basic (Declaration)
Public Property Capacity As Integer
C#
public int Capacity {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupons Class
Coupons Members


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > Coupons Class : Clear Method

Removes all elements from the List.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupons Class
Coupons Members


%%PageItemTitle%%

Contains Method
[image]
dotnetCART Namespace > Coupons Class : Contains Method

item
Determines whether an element is in the List.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal item As Coupon _
) As Boolean
C#
public bool Contains(
   Coupon item
)

Parameters

item

Return Value

true if item is found in the List; otherwise, false.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupons Class
Coupons Members


%%PageItemTitle%%

CopyTo Method
[image]
dotnetCART Namespace > Coupons Class : CopyTo Method

Overload List

Overload | Description
CopyTo(Coupon[]) | (Inherited from dotnetCART.ListBase<Coupon>)
CopyTo(Coupon[],Int32) | (Inherited from dotnetCART.ListBase<Coupon>)
CopyTo(Int32,Coupon[],Int32,Int32) | (Inherited from dotnetCART.ListBase<Coupon>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupons Class
Coupons Members


%%PageItemTitle%%

CopyTo(Coupon[]) Method
[image]
dotnetCART Namespace > Coupons Class > CopyTo Method : CopyTo(Coupon[]) Method

array

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array() As Coupon _
)
C#
public void CopyTo(
   Coupon[] array
)

Parameters

array

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupons Class
Coupons Members
Overload List


%%PageItemTitle%%

CopyTo(Coupon[],Int32) Method
[image]
dotnetCART Namespace > Coupons Class > CopyTo Method : CopyTo(Coupon[],Int32) Method

array
arrayIndex

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array() As Coupon, _
   ByVal arrayIndex As Integer _
)
C#
public void CopyTo(
   Coupon[] array,
   int arrayIndex
)

Parameters

array
arrayIndex

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupons Class
Coupons Members
Overload List


%%PageItemTitle%%

CopyTo(Int32,Coupon[],Int32,Int32) Method
[image]
dotnetCART Namespace > Coupons Class > CopyTo Method : CopyTo(Int32,Coupon[],Int32,Int32) Method

index
array
arrayIndex
count

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal index As Integer, _
   ByVal array() As Coupon, _
   ByVal arrayIndex As Integer, _
   ByVal count As Integer _
)
C#
public void CopyTo(
   int index,
   Coupon[] array,
   int arrayIndex,
   int count
)

Parameters

index
array
arrayIndex
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupons Class
Coupons Members
Overload List


%%PageItemTitle%%

Count Property
[image]
dotnetCART Namespace > Coupons Class : Count Property

Gets the number of elements actually contained in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupons Class
Coupons Members


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > Coupons Class : Error Property

Returns an object with the error information.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupons Class
Coupons Members


%%PageItemTitle%%

GetEnumerator Method
[image]
dotnetCART Namespace > Coupons Class : GetEnumerator Method

Returns an enumerator that iterates through the List.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As List.Enumerator(Of Coupon)
C#
public List.Enumerator<Coupon> GetEnumerator()

Return Value

A List.Enumerator for the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupons Class
Coupons Members


%%PageItemTitle%%

IndexOf Method
[image]
dotnetCART Namespace > Coupons Class : IndexOf Method

Overload List

Overload | Description
IndexOf(Coupon) | (Inherited from dotnetCART.ListBase<Coupon>)
IndexOf(Coupon,Int32) | (Inherited from dotnetCART.ListBase<Coupon>)
IndexOf(Coupon,Int32,Int32) | (Inherited from dotnetCART.ListBase<Coupon>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupons Class
Coupons Members


%%PageItemTitle%%

IndexOf(Coupon) Method
[image]
dotnetCART Namespace > Coupons Class > IndexOf Method : IndexOf(Coupon) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As Coupon _
) As Integer
C#
public int IndexOf(
   Coupon item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupons Class
Coupons Members
Overload List


%%PageItemTitle%%

IndexOf(Coupon,Int32) Method
[image]
dotnetCART Namespace > Coupons Class > IndexOf Method : IndexOf(Coupon,Int32) Method

item
index

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As Coupon, _
   ByVal index As Integer _
) As Integer
C#
public int IndexOf(
   Coupon item,
   int index
)

Parameters

item
index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupons Class
Coupons Members
Overload List


%%PageItemTitle%%

IndexOf(Coupon,Int32,Int32) Method
[image]
dotnetCART Namespace > Coupons Class > IndexOf Method : IndexOf(Coupon,Int32,Int32) Method

item
index
count

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As Coupon, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
C#
public int IndexOf(
   Coupon item,
   int index,
   int count
)

Parameters

item
index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupons Class
Coupons Members
Overload List


%%PageItemTitle%%

Insert Method
[image]
dotnetCART Namespace > Coupons Class : Insert Method

index
item
Inserts an element into the List at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As Coupon _
)
C#
public void Insert(
   int index,
   Coupon item
)

Parameters

index
item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupons Class
Coupons Members


%%PageItemTitle%%

InsertRange Method
[image]
dotnetCART Namespace > Coupons Class : InsertRange Method

index
collection
Inserts the elements of a collection into the List at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub InsertRange( _
   ByVal index As Integer, _
   ByVal collection As IEnumerable(Of Coupon) _
)
C#
public void InsertRange(
   int index,
   IEnumerable<Coupon> collection
)

Parameters

index
collection

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupons Class
Coupons Members


%%PageItemTitle%%

Item Property
[image]
dotnetCART Namespace > Coupons Class : Item Property

index
Gets or sets the element at the specified index.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As Coupon
C#
public Coupon this[
   int index
]; {get; set;}

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupons Class
Coupons Members


%%PageItemTitle%%

LastIndexOf Method
[image]
dotnetCART Namespace > Coupons Class : LastIndexOf Method

Overload List

Overload | Description
LastIndexOf(Coupon) | (Inherited from dotnetCART.ListBase<Coupon>)
LastIndexOf(Coupon,Int32) | (Inherited from dotnetCART.ListBase<Coupon>)
LastIndexOf(Coupon,Int32,Int32) | (Inherited from dotnetCART.ListBase<Coupon>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupons Class
Coupons Members


%%PageItemTitle%%

LastIndexOf(Coupon) Method
[image]
dotnetCART Namespace > Coupons Class > LastIndexOf Method : LastIndexOf(Coupon) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As Coupon _
) As Integer
C#
public int LastIndexOf(
   Coupon item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupons Class
Coupons Members
Overload List


%%PageItemTitle%%

LastIndexOf(Coupon,Int32) Method
[image]
dotnetCART Namespace > Coupons Class > LastIndexOf Method : LastIndexOf(Coupon,Int32) Method

item
index

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As Coupon, _
   ByVal index As Integer _
) As Integer
C#
public int LastIndexOf(
   Coupon item,
   int index
)

Parameters

item
index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupons Class
Coupons Members
Overload List


%%PageItemTitle%%

LastIndexOf(Coupon,Int32,Int32) Method
[image]
dotnetCART Namespace > Coupons Class > LastIndexOf Method : LastIndexOf(Coupon,Int32,Int32) Method

item
index
count

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As Coupon, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
C#
public int LastIndexOf(
   Coupon item,
   int index,
   int count
)

Parameters

item
index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupons Class
Coupons Members
Overload List


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > Coupons Class > LoadDB Method : LoadDB() Method

Loads all the items from its associated table.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB() As Integer
C#
public virtual int LoadDB()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupons Class
Coupons Members
Overload List


%%PageItemTitle%%

LoadDB(Int32,Int32) Method
[image]
dotnetCART Namespace > Coupons Class > LoadDB Method : LoadDB(Int32,Int32) Method

start
count
Loads the count number of elements from start value.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal start As Integer, _
   ByVal count As Integer _
) As Integer
C#
public virtual int LoadDB(
   int start,
   int count
)

Parameters

start
count

Return Value

The total number of elements have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupons Class
Coupons Members
Overload List


%%PageItemTitle%%

LoadDB(Where) Method
[image]
dotnetCART Namespace > Coupons Class > LoadDB Method : LoadDB(Where) Method

whereClause
Loads all the items from its associated table based on the where clause.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal whereClause As Where _
) As Integer
C#
public virtual int LoadDB(
   Where whereClause
)

Parameters

whereClause

Return Value

The total number of items have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupons Class
Coupons Members
Overload List


%%PageItemTitle%%

Remove Method
[image]
dotnetCART Namespace > Coupons Class : Remove Method

item
Removes the first occurrence of a specific object from the List.

Syntax

Visual Basic (Declaration)
Public Function Remove( _
   ByVal item As Coupon _
) As Boolean
C#
public bool Remove(
   Coupon item
)

Parameters

item

Return Value

true if item is successfully removed; otherwise, false. This method also returns false if item was not found in the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupons Class
Coupons Members


%%PageItemTitle%%

RemoveAll Method
[image]
dotnetCART Namespace > Coupons Class : RemoveAll Method

match
Removes the all the elements that match the conditions defined by the specified predicate.

Syntax

Visual Basic (Declaration)
Public Function RemoveAll( _
   ByVal match As Predicate(Of Coupon) _
) As Integer
C#
public int RemoveAll(
   Predicate<Coupon> match
)

Parameters

match

Return Value

The number of elements removed from the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupons Class
Coupons Members


%%PageItemTitle%%

RemoveAt Method
[image]
dotnetCART Namespace > Coupons Class : RemoveAt Method

index
Removes the element at the specified index of the List.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupons Class
Coupons Members


%%PageItemTitle%%

RemoveRange Method
[image]
dotnetCART Namespace > Coupons Class : RemoveRange Method

index
count
Removes a range of elements from the List.

Syntax

Visual Basic (Declaration)
Public Sub RemoveRange( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
C#
public void RemoveRange(
   int index,
   int count
)

Parameters

index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupons Class
Coupons Members


%%PageItemTitle%%

Reverse Method
[image]
dotnetCART Namespace > Coupons Class : Reverse Method

Reverses the order of the elements in the entire List.

Overload List

Overload | Description
Reverse() | Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<Coupon>)
Reverse(Int32,Int32) | Reverses the order of the elements in the specified range. (Inherited from dotnetCART.ListBase<Coupon>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupons Class
Coupons Members


%%PageItemTitle%%

Reverse() Method
[image]
dotnetCART Namespace > Coupons Class > Reverse Method : Reverse() Method

Reverses the order of the elements in the entire List.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Reverse()
C#
public void Reverse()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupons Class
Coupons Members
Overload List


%%PageItemTitle%%

Reverse(Int32,Int32) Method
[image]
dotnetCART Namespace > Coupons Class > Reverse Method : Reverse(Int32,Int32) Method

index
count
Reverses the order of the elements in the specified range.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Reverse( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
C#
public void Reverse(
   int index,
   int count
)

Parameters

index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupons Class
Coupons Members
Overload List


%%PageItemTitle%%

Custom Property
[image]
dotnetCART Namespace > Coupon Class : Custom Property

Gets or sets a custom object. For more information see custom fields

Syntax

Visual Basic (Declaration)
Public Property Custom As Custom
C#
public Custom Custom {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupon Class
Coupon Members


%%PageItemTitle%%

CustomFields Property
See Also Example
[image]
dotnetCART Namespace > Coupon Class : CustomFields Property

Gets or sets a the names of custom fields for a table associated with the object.

Syntax

Visual Basic (Declaration)
Public Property CustomFields As String
C#
public string CustomFields {get; set;}

Example

C# Copy Code
Customer.CustomFields = "CellPhone,Favorites";

Visual Basic Copy Code
Customer.CustomFields = "CellPhone,Favorites"

Remarks

Custom fields must be added to the table manualy. Custom fields are usually set at store level using CustomFields

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupon Class
Coupon Members


%%PageItemTitle%%

Customs Property
[image]
dotnetCART Namespace > Coupon Class : Customs Property

A reference to the collection of the Custom objects.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Customs As Customs
C#
public Customs Customs {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupon Class
Coupon Members


%%PageItemTitle%%

DeleteDB(DbManager) Method
[image]
dotnetCART Namespace > Coupon Class > DeleteDB Method : DeleteDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function DeleteDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int DeleteDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupon Class
Coupon Members
Overload List


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > Coupon Class : Error Property

Gets the error object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupon Class
Coupon Members


%%PageItemTitle%%

GetCustom Method
[image]
dotnetCART Namespace > Coupon Class : GetCustom Method

This method returns the value of a custom field based on its name in the customs collection.

Overload List

Overload | Description
GetCustom(String) | This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<Coupon, Int64>)
GetCustom(Int32) | This method returns the value of a custom field based on its index in the customs collection. (Inherited from dotnetCART.DbTableCart<Coupon, Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupon Class
Coupon Members


%%PageItemTitle%%

GetCustom(Int32) Method
[image]
dotnetCART Namespace > Coupon Class > GetCustom Method : GetCustom(Int32) Method

customIndex
This method returns the value of a custom field based on its index in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal customIndex As Integer _
) As Object
C#
public object GetCustom(
   int customIndex
)

Parameters

customIndex

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupon Class
Coupon Members
Overload List


%%PageItemTitle%%

GetCustom(String) Method
[image]
dotnetCART Namespace > Coupon Class > GetCustom Method : GetCustom(String) Method

name
This method returns the value of a custom field based on its name in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal name As String _
) As Object
C#
public object GetCustom(
   string name
)

Parameters

name

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupon Class
Coupon Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB() Method
See Also
[image]
dotnetCART Namespace > Coupon Class > LoadDB Method : Generic LoadDB() Method

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)() As Integer
C#
public virtual int LoadDB<T1>()where T1: IDbTable

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupon Class
Coupon Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB(DbManager) Method
See Also
[image]
dotnetCART Namespace > Coupon Class > LoadDB Method : Generic LoadDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int LoadDB<T1>(
   DbManager manager
)where T1: IDbTable

Parameters

manager

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupon Class
Coupon Members
Overload List


%%PageItemTitle%%

SaveDB(DbManager) Method
[image]
dotnetCART Namespace > Coupon Class > SaveDB Method : SaveDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function SaveDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int SaveDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupon Class
Coupon Members
Overload List


%%PageItemTitle%%

SetCustom Method
[image]
dotnetCART Namespace > Coupon Class : SetCustom Method

name
newValue
This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added.

Syntax

Visual Basic (Declaration)
Public Function SetCustom( _
   ByVal name As String, _
   ByVal newValue As Object _
) As Object
C#
public object SetCustom(
   string name,
   object newValue
)

Parameters

name
newValue

Return Value

Returns the new custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Coupon Class
Coupon Members


%%PageItemTitle%%

Add(Customer) Method
[image]
dotnetCART Namespace > Customers Class > Add Method : Add(Customer) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add( _
   ByVal item As Customer _
)
C#
public void Add(
   Customer item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customers Class
Customers Members
Overload List


%%PageItemTitle%%

AddRange Method
[image]
dotnetCART Namespace > Customers Class : AddRange Method

collection
Adds the elements of the specified collection to the end of the collection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal collection As IEnumerable(Of Customer) _
)
C#
public void AddRange(
   IEnumerable<Customer> collection
)

Parameters

collection

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customers Class
Customers Members


%%PageItemTitle%%

AsReadOnly Method
[image]
dotnetCART Namespace > Customers Class : AsReadOnly Method

Returns a read-only IList wrapper for the current collection.

Syntax

Visual Basic (Declaration)
Public Function AsReadOnly() As ReadOnlyCollection(Of Customer)
C#
public ReadOnlyCollection<Customer> AsReadOnly()

Return Value

A ReadOnlyCollection that acts as a read-only wrapper around the current List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customers Class
Customers Members


%%PageItemTitle%%

BinarySearch Method
[image]
dotnetCART Namespace > Customers Class : BinarySearch Method

Overload List

Overload | Description
BinarySearch(Customer) | (Inherited from dotnetCART.ListBase<Customer>)
BinarySearch(Customer,Generic IComparer) | (Inherited from dotnetCART.ListBase<Customer>)
BinarySearch(Int32,Int32,Customer,Generic IComparer) | (Inherited from dotnetCART.ListBase<Customer>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customers Class
Customers Members


%%PageItemTitle%%

BinarySearch(Customer) Method
[image]
dotnetCART Namespace > Customers Class > BinarySearch Method : BinarySearch(Customer) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal item As Customer _
) As Integer
C#
public int BinarySearch(
   Customer item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customers Class
Customers Members
Overload List


%%PageItemTitle%%

BinarySearch(Customer,Generic IComparer) Method
[image]
dotnetCART Namespace > Customers Class > BinarySearch Method : BinarySearch(Customer,Generic IComparer) Method

item
comparer

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal item As Customer, _
   ByVal comparer As IComparer(Of Customer) _
) As Integer
C#
public int BinarySearch(
   Customer item,
   IComparer<Customer> comparer
)

Parameters

item
comparer

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customers Class
Customers Members
Overload List


%%PageItemTitle%%

BinarySearch(Int32,Int32,Customer,Generic IComparer) Method
[image]
dotnetCART Namespace > Customers Class > BinarySearch Method : BinarySearch(Int32,Int32,Customer,Generic IComparer) Method

index
count
item
comparer

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal index As Integer, _
   ByVal count As Integer, _
   ByVal item As Customer, _
   ByVal comparer As IComparer(Of Customer) _
) As Integer
C#
public int BinarySearch(
   int index,
   int count,
   Customer item,
   IComparer<Customer> comparer
)

Parameters

index
count
item
comparer

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customers Class
Customers Members
Overload List


%%PageItemTitle%%

Capacity Property
[image]
dotnetCART Namespace > Customers Class : Capacity Property

Gets or sets the total number of elements the internal data structure can hold without resizing.

Syntax

Visual Basic (Declaration)
Public Property Capacity As Integer
C#
public int Capacity {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customers Class
Customers Members


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > Customers Class : Clear Method

Removes all elements from the List.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customers Class
Customers Members


%%PageItemTitle%%

Contains Method
[image]
dotnetCART Namespace > Customers Class : Contains Method

item
Determines whether an element is in the List.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal item As Customer _
) As Boolean
C#
public bool Contains(
   Customer item
)

Parameters

item

Return Value

true if item is found in the List; otherwise, false.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customers Class
Customers Members


%%PageItemTitle%%

CopyTo Method
[image]
dotnetCART Namespace > Customers Class : CopyTo Method

Overload List

Overload | Description
CopyTo(Customer[]) | (Inherited from dotnetCART.ListBase<Customer>)
CopyTo(Customer[],Int32) | (Inherited from dotnetCART.ListBase<Customer>)
CopyTo(Int32,Customer[],Int32,Int32) | (Inherited from dotnetCART.ListBase<Customer>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customers Class
Customers Members


%%PageItemTitle%%

CopyTo(Customer[]) Method
[image]
dotnetCART Namespace > Customers Class > CopyTo Method : CopyTo(Customer[]) Method

array

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array() As Customer _
)
C#
public void CopyTo(
   Customer[] array
)

Parameters

array

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customers Class
Customers Members
Overload List


%%PageItemTitle%%

CopyTo(Customer[],Int32) Method
[image]
dotnetCART Namespace > Customers Class > CopyTo Method : CopyTo(Customer[],Int32) Method

array
arrayIndex

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array() As Customer, _
   ByVal arrayIndex As Integer _
)
C#
public void CopyTo(
   Customer[] array,
   int arrayIndex
)

Parameters

array
arrayIndex

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customers Class
Customers Members
Overload List


%%PageItemTitle%%

CopyTo(Int32,Customer[],Int32,Int32) Method
[image]
dotnetCART Namespace > Customers Class > CopyTo Method : CopyTo(Int32,Customer[],Int32,Int32) Method

index
array
arrayIndex
count

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal index As Integer, _
   ByVal array() As Customer, _
   ByVal arrayIndex As Integer, _
   ByVal count As Integer _
)
C#
public void CopyTo(
   int index,
   Customer[] array,
   int arrayIndex,
   int count
)

Parameters

index
array
arrayIndex
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customers Class
Customers Members
Overload List


%%PageItemTitle%%

Count Property
[image]
dotnetCART Namespace > Customers Class : Count Property

Gets the number of elements actually contained in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customers Class
Customers Members


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > Customers Class : Error Property

Returns an object with the error information.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customers Class
Customers Members


%%PageItemTitle%%

GetEnumerator Method
[image]
dotnetCART Namespace > Customers Class : GetEnumerator Method

Returns an enumerator that iterates through the List.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As List.Enumerator(Of Customer)
C#
public List.Enumerator<Customer> GetEnumerator()

Return Value

A List.Enumerator for the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customers Class
Customers Members


%%PageItemTitle%%

IndexOf Method
[image]
dotnetCART Namespace > Customers Class : IndexOf Method

Overload List

Overload | Description
IndexOf(Customer) | (Inherited from dotnetCART.ListBase<Customer>)
IndexOf(Customer,Int32) | (Inherited from dotnetCART.ListBase<Customer>)
IndexOf(Customer,Int32,Int32) | (Inherited from dotnetCART.ListBase<Customer>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customers Class
Customers Members


%%PageItemTitle%%

IndexOf(Customer) Method
[image]
dotnetCART Namespace > Customers Class > IndexOf Method : IndexOf(Customer) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As Customer _
) As Integer
C#
public int IndexOf(
   Customer item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customers Class
Customers Members
Overload List


%%PageItemTitle%%

IndexOf(Customer,Int32) Method
[image]
dotnetCART Namespace > Customers Class > IndexOf Method : IndexOf(Customer,Int32) Method

item
index

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As Customer, _
   ByVal index As Integer _
) As Integer
C#
public int IndexOf(
   Customer item,
   int index
)

Parameters

item
index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customers Class
Customers Members
Overload List


%%PageItemTitle%%

IndexOf(Customer,Int32,Int32) Method
[image]
dotnetCART Namespace > Customers Class > IndexOf Method : IndexOf(Customer,Int32,Int32) Method

item
index
count

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As Customer, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
C#
public int IndexOf(
   Customer item,
   int index,
   int count
)

Parameters

item
index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customers Class
Customers Members
Overload List


%%PageItemTitle%%

Insert Method
[image]
dotnetCART Namespace > Customers Class : Insert Method

index
item
Inserts an element into the List at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As Customer _
)
C#
public void Insert(
   int index,
   Customer item
)

Parameters

index
item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customers Class
Customers Members


%%PageItemTitle%%

InsertRange Method
[image]
dotnetCART Namespace > Customers Class : InsertRange Method

index
collection
Inserts the elements of a collection into the List at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub InsertRange( _
   ByVal index As Integer, _
   ByVal collection As IEnumerable(Of Customer) _
)
C#
public void InsertRange(
   int index,
   IEnumerable<Customer> collection
)

Parameters

index
collection

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customers Class
Customers Members


%%PageItemTitle%%

Item(Int32) Property
[image]
dotnetCART Namespace > Customers Class > Item Property : Item(Int32) Property

index
Gets or sets the element at the specified index.

Syntax

Visual Basic (Declaration)
Public Overloads Property Item( _
   ByVal index As Integer _
) As Customer
C#
public Customer Item(
   int index
) {get; set;}

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customers Class
Customers Members
Overload List


%%PageItemTitle%%

LastIndexOf Method
[image]
dotnetCART Namespace > Customers Class : LastIndexOf Method

Overload List

Overload | Description
LastIndexOf(Customer) | (Inherited from dotnetCART.ListBase<Customer>)
LastIndexOf(Customer,Int32) | (Inherited from dotnetCART.ListBase<Customer>)
LastIndexOf(Customer,Int32,Int32) | (Inherited from dotnetCART.ListBase<Customer>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customers Class
Customers Members


%%PageItemTitle%%

LastIndexOf(Customer) Method
[image]
dotnetCART Namespace > Customers Class > LastIndexOf Method : LastIndexOf(Customer) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As Customer _
) As Integer
C#
public int LastIndexOf(
   Customer item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customers Class
Customers Members
Overload List


%%PageItemTitle%%

LastIndexOf(Customer,Int32) Method
[image]
dotnetCART Namespace > Customers Class > LastIndexOf Method : LastIndexOf(Customer,Int32) Method

item
index

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As Customer, _
   ByVal index As Integer _
) As Integer
C#
public int LastIndexOf(
   Customer item,
   int index
)

Parameters

item
index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customers Class
Customers Members
Overload List


%%PageItemTitle%%

LastIndexOf(Customer,Int32,Int32) Method
[image]
dotnetCART Namespace > Customers Class > LastIndexOf Method : LastIndexOf(Customer,Int32,Int32) Method

item
index
count

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As Customer, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
C#
public int LastIndexOf(
   Customer item,
   int index,
   int count
)

Parameters

item
index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customers Class
Customers Members
Overload List


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > Customers Class > LoadDB Method : LoadDB() Method

Loads all the items from its associated table.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB() As Integer
C#
public virtual int LoadDB()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customers Class
Customers Members
Overload List


%%PageItemTitle%%

LoadDB(Int32,Int32) Method
[image]
dotnetCART Namespace > Customers Class > LoadDB Method : LoadDB(Int32,Int32) Method

start
count
Loads the count number of elements from start value.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal start As Integer, _
   ByVal count As Integer _
) As Integer
C#
public virtual int LoadDB(
   int start,
   int count
)

Parameters

start
count

Return Value

The total number of elements have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customers Class
Customers Members
Overload List


%%PageItemTitle%%

LoadDB(Where) Method
[image]
dotnetCART Namespace > Customers Class > LoadDB Method : LoadDB(Where) Method

whereClause
Loads all the items from its associated table based on the where clause.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal whereClause As Where _
) As Integer
C#
public virtual int LoadDB(
   Where whereClause
)

Parameters

whereClause

Return Value

The total number of items have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customers Class
Customers Members
Overload List


%%PageItemTitle%%

Remove Method
[image]
dotnetCART Namespace > Customers Class : Remove Method

item
Removes the first occurrence of a specific object from the List.

Syntax

Visual Basic (Declaration)
Public Function Remove( _
   ByVal item As Customer _
) As Boolean
C#
public bool Remove(
   Customer item
)

Parameters

item

Return Value

true if item is successfully removed; otherwise, false. This method also returns false if item was not found in the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customers Class
Customers Members


%%PageItemTitle%%

RemoveAll Method
[image]
dotnetCART Namespace > Customers Class : RemoveAll Method

match
Removes the all the elements that match the conditions defined by the specified predicate.

Syntax

Visual Basic (Declaration)
Public Function RemoveAll( _
   ByVal match As Predicate(Of Customer) _
) As Integer
C#
public int RemoveAll(
   Predicate<Customer> match
)

Parameters

match

Return Value

The number of elements removed from the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customers Class
Customers Members


%%PageItemTitle%%

RemoveAt Method
[image]
dotnetCART Namespace > Customers Class : RemoveAt Method

index
Removes the element at the specified index of the List.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customers Class
Customers Members


%%PageItemTitle%%

RemoveRange Method
[image]
dotnetCART Namespace > Customers Class : RemoveRange Method

index
count
Removes a range of elements from the List.

Syntax

Visual Basic (Declaration)
Public Sub RemoveRange( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
C#
public void RemoveRange(
   int index,
   int count
)

Parameters

index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customers Class
Customers Members


%%PageItemTitle%%

Reverse Method
[image]
dotnetCART Namespace > Customers Class : Reverse Method

Reverses the order of the elements in the entire List.

Overload List

Overload | Description
Reverse() | Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<Customer>)
Reverse(Int32,Int32) | Reverses the order of the elements in the specified range. (Inherited from dotnetCART.ListBase<Customer>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customers Class
Customers Members


%%PageItemTitle%%

Reverse() Method
[image]
dotnetCART Namespace > Customers Class > Reverse Method : Reverse() Method

Reverses the order of the elements in the entire List.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Reverse()
C#
public void Reverse()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customers Class
Customers Members
Overload List


%%PageItemTitle%%

Reverse(Int32,Int32) Method
[image]
dotnetCART Namespace > Customers Class > Reverse Method : Reverse(Int32,Int32) Method

index
count
Reverses the order of the elements in the specified range.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Reverse( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
C#
public void Reverse(
   int index,
   int count
)

Parameters

index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customers Class
Customers Members
Overload List


%%PageItemTitle%%

Custom Property
[image]
dotnetCART Namespace > Customer Class : Custom Property

Gets or sets a custom object. For more information see custom fields

Syntax

Visual Basic (Declaration)
Public Property Custom As Custom
C#
public Custom Custom {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members


%%PageItemTitle%%

CustomFields Property
See Also Example
[image]
dotnetCART Namespace > Customer Class : CustomFields Property

Gets or sets a the names of custom fields for a table associated with the object.

Syntax

Visual Basic (Declaration)
Public Property CustomFields As String
C#
public string CustomFields {get; set;}

Example

C# Copy Code
Customer.CustomFields = "CellPhone,Favorites";

Visual Basic Copy Code
Customer.CustomFields = "CellPhone,Favorites"

Remarks

Custom fields must be added to the table manualy. Custom fields are usually set at store level using CustomFields

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members


%%PageItemTitle%%

Customs Property
[image]
dotnetCART Namespace > Customer Class : Customs Property

A reference to the collection of the Custom objects.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Customs As Customs
C#
public Customs Customs {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members


%%PageItemTitle%%

DeleteDB(DbManager) Method
[image]
dotnetCART Namespace > Customer Class > DeleteDB Method : DeleteDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function DeleteDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int DeleteDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members
Overload List


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > Customer Class : Error Property

Gets the error object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members


%%PageItemTitle%%

GetCustom Method
[image]
dotnetCART Namespace > Customer Class : GetCustom Method

This method returns the value of a custom field based on its name in the customs collection.

Overload List

Overload | Description
GetCustom(String) | This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<Customer, Int64>)
GetCustom(Int32) | This method returns the value of a custom field based on its index in the customs collection. (Inherited from dotnetCART.DbTableCart<Customer, Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members


%%PageItemTitle%%

GetCustom(Int32) Method
[image]
dotnetCART Namespace > Customer Class > GetCustom Method : GetCustom(Int32) Method

customIndex
This method returns the value of a custom field based on its index in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal customIndex As Integer _
) As Object
C#
public object GetCustom(
   int customIndex
)

Parameters

customIndex

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members
Overload List


%%PageItemTitle%%

GetCustom(String) Method
[image]
dotnetCART Namespace > Customer Class > GetCustom Method : GetCustom(String) Method

name
This method returns the value of a custom field based on its name in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal name As String _
) As Object
C#
public object GetCustom(
   string name
)

Parameters

name

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members
Overload List


%%PageItemTitle%%

LoadDB(Int64) Method
[image]
dotnetCART Namespace > Customer Class > LoadDB Method : LoadDB(Int64) Method

id

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal id As Long _
) As Integer
C#
public virtual int LoadDB(
   long id
)

Parameters

id

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB() Method
See Also
[image]
dotnetCART Namespace > Customer Class > LoadDB Method : Generic LoadDB() Method

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)() As Integer
C#
public virtual int LoadDB<T1>()where T1: IDbTable

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB(DbManager) Method
See Also
[image]
dotnetCART Namespace > Customer Class > LoadDB Method : Generic LoadDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int LoadDB<T1>(
   DbManager manager
)where T1: IDbTable

Parameters

manager

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members
Overload List


%%PageItemTitle%%

SaveDB(DbManager) Method
[image]
dotnetCART Namespace > Customer Class > SaveDB Method : SaveDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function SaveDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int SaveDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members
Overload List


%%PageItemTitle%%

SetCustom Method
[image]
dotnetCART Namespace > Customer Class : SetCustom Method

name
newValue
This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added.

Syntax

Visual Basic (Declaration)
Public Function SetCustom( _
   ByVal name As String, _
   ByVal newValue As Object _
) As Object
C#
public object SetCustom(
   string name,
   object newValue
)

Parameters

name
newValue

Return Value

Returns the new custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customer Class
Customer Members


%%PageItemTitle%%

AddRange Method
[image]
dotnetCART Namespace > Customs Class : AddRange Method

collection
Adds the elements of the specified collection to the end of the collection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal collection As IEnumerable(Of Custom) _
)
C#
public void AddRange(
   IEnumerable<Custom> collection
)

Parameters

collection

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customs Class
Customs Members


%%PageItemTitle%%

AsReadOnly Method
[image]
dotnetCART Namespace > Customs Class : AsReadOnly Method

Returns a read-only IList wrapper for the current collection.

Syntax

Visual Basic (Declaration)
Public Function AsReadOnly() As ReadOnlyCollection(Of Custom)
C#
public ReadOnlyCollection<Custom> AsReadOnly()

Return Value

A ReadOnlyCollection that acts as a read-only wrapper around the current List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customs Class
Customs Members


%%PageItemTitle%%

BinarySearch Method
[image]
dotnetCART Namespace > Customs Class : BinarySearch Method

Overload List

Overload | Description
BinarySearch(Custom) | (Inherited from dotnetCART.ListBase<Custom>)
BinarySearch(Custom,Generic IComparer) | (Inherited from dotnetCART.ListBase<Custom>)
BinarySearch(Int32,Int32,Custom,Generic IComparer) | (Inherited from dotnetCART.ListBase<Custom>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customs Class
Customs Members


%%PageItemTitle%%

BinarySearch(Custom) Method
[image]
dotnetCART Namespace > Customs Class > BinarySearch Method : BinarySearch(Custom) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal item As Custom _
) As Integer
C#
public int BinarySearch(
   Custom item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customs Class
Customs Members
Overload List


%%PageItemTitle%%

BinarySearch(Custom,Generic IComparer) Method
[image]
dotnetCART Namespace > Customs Class > BinarySearch Method : BinarySearch(Custom,Generic IComparer) Method

item
comparer

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal item As Custom, _
   ByVal comparer As IComparer(Of Custom) _
) As Integer
C#
public int BinarySearch(
   Custom item,
   IComparer<Custom> comparer
)

Parameters

item
comparer

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customs Class
Customs Members
Overload List


%%PageItemTitle%%

BinarySearch(Int32,Int32,Custom,Generic IComparer) Method
[image]
dotnetCART Namespace > Customs Class > BinarySearch Method : BinarySearch(Int32,Int32,Custom,Generic IComparer) Method

index
count
item
comparer

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal index As Integer, _
   ByVal count As Integer, _
   ByVal item As Custom, _
   ByVal comparer As IComparer(Of Custom) _
) As Integer
C#
public int BinarySearch(
   int index,
   int count,
   Custom item,
   IComparer<Custom> comparer
)

Parameters

index
count
item
comparer

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customs Class
Customs Members
Overload List


%%PageItemTitle%%

Capacity Property
[image]
dotnetCART Namespace > Customs Class : Capacity Property

Gets or sets the total number of elements the internal data structure can hold without resizing.

Syntax

Visual Basic (Declaration)
Public Property Capacity As Integer
C#
public int Capacity {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customs Class
Customs Members


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > Customs Class : Clear Method

Removes all elements from the List.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customs Class
Customs Members


%%PageItemTitle%%

Contains Method
[image]
dotnetCART Namespace > Customs Class : Contains Method

item
Determines whether an element is in the List.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal item As Custom _
) As Boolean
C#
public bool Contains(
   Custom item
)

Parameters

item

Return Value

true if item is found in the List; otherwise, false.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customs Class
Customs Members


%%PageItemTitle%%

CopyTo Method
[image]
dotnetCART Namespace > Customs Class : CopyTo Method

Overload List

Overload | Description
CopyTo(Custom[]) | (Inherited from dotnetCART.ListBase<Custom>)
CopyTo(Custom[],Int32) | (Inherited from dotnetCART.ListBase<Custom>)
CopyTo(Int32,Custom[],Int32,Int32) | (Inherited from dotnetCART.ListBase<Custom>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customs Class
Customs Members


%%PageItemTitle%%

CopyTo(Custom[]) Method
[image]
dotnetCART Namespace > Customs Class > CopyTo Method : CopyTo(Custom[]) Method

array

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array() As Custom _
)
C#
public void CopyTo(
   Custom[] array
)

Parameters

array

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customs Class
Customs Members
Overload List


%%PageItemTitle%%

CopyTo(Custom[],Int32) Method
[image]
dotnetCART Namespace > Customs Class > CopyTo Method : CopyTo(Custom[],Int32) Method

array
arrayIndex

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array() As Custom, _
   ByVal arrayIndex As Integer _
)
C#
public void CopyTo(
   Custom[] array,
   int arrayIndex
)

Parameters

array
arrayIndex

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customs Class
Customs Members
Overload List


%%PageItemTitle%%

CopyTo(Int32,Custom[],Int32,Int32) Method
[image]
dotnetCART Namespace > Customs Class > CopyTo Method : CopyTo(Int32,Custom[],Int32,Int32) Method

index
array
arrayIndex
count

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal index As Integer, _
   ByVal array() As Custom, _
   ByVal arrayIndex As Integer, _
   ByVal count As Integer _
)
C#
public void CopyTo(
   int index,
   Custom[] array,
   int arrayIndex,
   int count
)

Parameters

index
array
arrayIndex
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customs Class
Customs Members
Overload List


%%PageItemTitle%%

Count Property
[image]
dotnetCART Namespace > Customs Class : Count Property

Gets the number of elements actually contained in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customs Class
Customs Members


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > Customs Class : Error Property

Returns an object with the error information.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customs Class
Customs Members


%%PageItemTitle%%

GetEnumerator Method
[image]
dotnetCART Namespace > Customs Class : GetEnumerator Method

Returns an enumerator that iterates through the List.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As List.Enumerator(Of Custom)
C#
public List.Enumerator<Custom> GetEnumerator()

Return Value

A List.Enumerator for the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customs Class
Customs Members


%%PageItemTitle%%

IndexOf Method
[image]
dotnetCART Namespace > Customs Class : IndexOf Method

Overload List

Overload | Description
IndexOf(Custom) | (Inherited from dotnetCART.ListBase<Custom>)
IndexOf(Custom,Int32) | (Inherited from dotnetCART.ListBase<Custom>)
IndexOf(Custom,Int32,Int32) | (Inherited from dotnetCART.ListBase<Custom>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customs Class
Customs Members


%%PageItemTitle%%

IndexOf(Custom) Method
[image]
dotnetCART Namespace > Customs Class > IndexOf Method : IndexOf(Custom) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As Custom _
) As Integer
C#
public int IndexOf(
   Custom item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customs Class
Customs Members
Overload List


%%PageItemTitle%%

IndexOf(Custom,Int32) Method
[image]
dotnetCART Namespace > Customs Class > IndexOf Method : IndexOf(Custom,Int32) Method

item
index

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As Custom, _
   ByVal index As Integer _
) As Integer
C#
public int IndexOf(
   Custom item,
   int index
)

Parameters

item
index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customs Class
Customs Members
Overload List


%%PageItemTitle%%

IndexOf(Custom,Int32,Int32) Method
[image]
dotnetCART Namespace > Customs Class > IndexOf Method : IndexOf(Custom,Int32,Int32) Method

item
index
count

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As Custom, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
C#
public int IndexOf(
   Custom item,
   int index,
   int count
)

Parameters

item
index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customs Class
Customs Members
Overload List


%%PageItemTitle%%

Insert Method
[image]
dotnetCART Namespace > Customs Class : Insert Method

index
item
Inserts an element into the List at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As Custom _
)
C#
public void Insert(
   int index,
   Custom item
)

Parameters

index
item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customs Class
Customs Members


%%PageItemTitle%%

InsertRange Method
[image]
dotnetCART Namespace > Customs Class : InsertRange Method

index
collection
Inserts the elements of a collection into the List at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub InsertRange( _
   ByVal index As Integer, _
   ByVal collection As IEnumerable(Of Custom) _
)
C#
public void InsertRange(
   int index,
   IEnumerable<Custom> collection
)

Parameters

index
collection

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customs Class
Customs Members


%%PageItemTitle%%

Item(Int32) Property
[image]
dotnetCART Namespace > Customs Class > Item Property : Item(Int32) Property

index
Gets or sets the element at the specified index.

Syntax

Visual Basic (Declaration)
Public Overloads Property Item( _
   ByVal index As Integer _
) As Custom
C#
public Custom Item(
   int index
) {get; set;}

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customs Class
Customs Members
Overload List


%%PageItemTitle%%

LastIndexOf Method
[image]
dotnetCART Namespace > Customs Class : LastIndexOf Method

Overload List

Overload | Description
LastIndexOf(Custom) | (Inherited from dotnetCART.ListBase<Custom>)
LastIndexOf(Custom,Int32) | (Inherited from dotnetCART.ListBase<Custom>)
LastIndexOf(Custom,Int32,Int32) | (Inherited from dotnetCART.ListBase<Custom>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customs Class
Customs Members


%%PageItemTitle%%

LastIndexOf(Custom) Method
[image]
dotnetCART Namespace > Customs Class > LastIndexOf Method : LastIndexOf(Custom) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As Custom _
) As Integer
C#
public int LastIndexOf(
   Custom item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customs Class
Customs Members
Overload List


%%PageItemTitle%%

LastIndexOf(Custom,Int32) Method
[image]
dotnetCART Namespace > Customs Class > LastIndexOf Method : LastIndexOf(Custom,Int32) Method

item
index

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As Custom, _
   ByVal index As Integer _
) As Integer
C#
public int LastIndexOf(
   Custom item,
   int index
)

Parameters

item
index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customs Class
Customs Members
Overload List


%%PageItemTitle%%

LastIndexOf(Custom,Int32,Int32) Method
[image]
dotnetCART Namespace > Customs Class > LastIndexOf Method : LastIndexOf(Custom,Int32,Int32) Method

item
index
count

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As Custom, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
C#
public int LastIndexOf(
   Custom item,
   int index,
   int count
)

Parameters

item
index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customs Class
Customs Members
Overload List


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > Customs Class : LoadDB Method

Loads all the items from its associated table.

Overload List

Overload | Description
LoadDB() | Loads all the items from its associated table. (Inherited from dotnetCART.ListBase<Custom>)
LoadDB(Where) | Loads all the items from its associated table based on the where clause. (Inherited from dotnetCART.ListBase<Custom>)
LoadDB(Int32,Int32) | Loads the count number of elements from start value. (Inherited from dotnetCART.ListBase<Custom>)
LoadDB(Where,Int32,Int32,String,OrderDirection) | Loads all the items based on the parameters. (Inherited from dotnetCART.ListBase<Custom>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customs Class
Customs Members


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > Customs Class > LoadDB Method : LoadDB() Method

Loads all the items from its associated table.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB() As Integer
C#
public virtual int LoadDB()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customs Class
Customs Members
Overload List


%%PageItemTitle%%

LoadDB(Int32,Int32) Method
[image]
dotnetCART Namespace > Customs Class > LoadDB Method : LoadDB(Int32,Int32) Method

start
count
Loads the count number of elements from start value.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal start As Integer, _
   ByVal count As Integer _
) As Integer
C#
public virtual int LoadDB(
   int start,
   int count
)

Parameters

start
count

Return Value

The total number of elements have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customs Class
Customs Members
Overload List


%%PageItemTitle%%

LoadDB(Where) Method
[image]
dotnetCART Namespace > Customs Class > LoadDB Method : LoadDB(Where) Method

whereClause
Loads all the items from its associated table based on the where clause.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal whereClause As Where _
) As Integer
C#
public virtual int LoadDB(
   Where whereClause
)

Parameters

whereClause

Return Value

The total number of items have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customs Class
Customs Members
Overload List


%%PageItemTitle%%

LoadDB(Where,Int32,Int32,String,OrderDirection) Method
[image]
dotnetCART Namespace > Customs Class > LoadDB Method : LoadDB(Where,Int32,Int32,String,OrderDirection) Method

whereClause
count
start
orderBy
orderDirection
Loads all the items based on the parameters.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal whereClause As Where, _
   ByVal count As Integer, _
   ByVal start As Integer, _
   ByVal orderBy As String, _
   ByVal orderDirection As OrderDirection _
) As Integer
C#
public virtual int LoadDB(
   Where whereClause,
   int count,
   int start,
   string orderBy,
   OrderDirection orderDirection
)

Parameters

whereClause
count
start
orderBy
orderDirection

Return Value

The total number of items have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customs Class
Customs Members
Overload List


%%PageItemTitle%%

Remove Method
[image]
dotnetCART Namespace > Customs Class : Remove Method

item
Removes the first occurrence of a specific object from the List.

Syntax

Visual Basic (Declaration)
Public Function Remove( _
   ByVal item As Custom _
) As Boolean
C#
public bool Remove(
   Custom item
)

Parameters

item

Return Value

true if item is successfully removed; otherwise, false. This method also returns false if item was not found in the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customs Class
Customs Members


%%PageItemTitle%%

RemoveAll Method
[image]
dotnetCART Namespace > Customs Class : RemoveAll Method

match
Removes the all the elements that match the conditions defined by the specified predicate.

Syntax

Visual Basic (Declaration)
Public Function RemoveAll( _
   ByVal match As Predicate(Of Custom) _
) As Integer
C#
public int RemoveAll(
   Predicate<Custom> match
)

Parameters

match

Return Value

The number of elements removed from the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customs Class
Customs Members


%%PageItemTitle%%

RemoveAt Method
[image]
dotnetCART Namespace > Customs Class : RemoveAt Method

index
Removes the element at the specified index of the List.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customs Class
Customs Members


%%PageItemTitle%%

RemoveRange Method
[image]
dotnetCART Namespace > Customs Class : RemoveRange Method

index
count
Removes a range of elements from the List.

Syntax

Visual Basic (Declaration)
Public Sub RemoveRange( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
C#
public void RemoveRange(
   int index,
   int count
)

Parameters

index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customs Class
Customs Members


%%PageItemTitle%%

Reverse Method
[image]
dotnetCART Namespace > Customs Class : Reverse Method

Reverses the order of the elements in the entire List.

Overload List

Overload | Description
Reverse() | Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<Custom>)
Reverse(Int32,Int32) | Reverses the order of the elements in the specified range. (Inherited from dotnetCART.ListBase<Custom>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customs Class
Customs Members


%%PageItemTitle%%

Reverse() Method
[image]
dotnetCART Namespace > Customs Class > Reverse Method : Reverse() Method

Reverses the order of the elements in the entire List.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Reverse()
C#
public void Reverse()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customs Class
Customs Members
Overload List


%%PageItemTitle%%

Reverse(Int32,Int32) Method
[image]
dotnetCART Namespace > Customs Class > Reverse Method : Reverse(Int32,Int32) Method

index
count
Reverses the order of the elements in the specified range.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Reverse( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
C#
public void Reverse(
   int index,
   int count
)

Parameters

index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Customs Class
Customs Members
Overload List


%%PageItemTitle%% $$Properties$$

Images Class Properties
[image]
dotnetCART Namespace : Images Class

For a list of all members of this type, see Images members.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from dotnetCART.ListBase<Image>)
Public Property | Count | Gets the number of elements actually contained in the collection. (Inherited from dotnetCART.ListBase<Image>)
Public Property | Error | Returns an object with the error information. (Inherited from dotnetCART.ListBase<Image>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from dotnetCART.ListBase<Image>)
Top

See Also

Reference

Images Class
dotnetCART Namespace


%%PageItemTitle%%

AddRange Method
[image]
dotnetCART Namespace > Images Class : AddRange Method

collection
Adds the elements of the specified collection to the end of the collection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal collection As IEnumerable(Of Image) _
)
C#
public void AddRange(
   IEnumerable<Image> collection
)

Parameters

collection

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Images Class
Images Members


%%PageItemTitle%%

AsReadOnly Method
[image]
dotnetCART Namespace > Images Class : AsReadOnly Method

Returns a read-only IList wrapper for the current collection.

Syntax

Visual Basic (Declaration)
Public Function AsReadOnly() As ReadOnlyCollection(Of Image)
C#
public ReadOnlyCollection<Image> AsReadOnly()

Return Value

A ReadOnlyCollection that acts as a read-only wrapper around the current List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Images Class
Images Members


%%PageItemTitle%%

BinarySearch Method
[image]
dotnetCART Namespace > Images Class : BinarySearch Method

Overload List

Overload | Description
BinarySearch(Image) | (Inherited from dotnetCART.ListBase<Image>)
BinarySearch(Image,Generic IComparer) | (Inherited from dotnetCART.ListBase<Image>)
BinarySearch(Int32,Int32,Image,Generic IComparer) | (Inherited from dotnetCART.ListBase<Image>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Images Class
Images Members


%%PageItemTitle%%

BinarySearch(Image) Method
[image]
dotnetCART Namespace > Images Class > BinarySearch Method : BinarySearch(Image) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal item As Image _
) As Integer
C#
public int BinarySearch(
   Image item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Images Class
Images Members
Overload List


%%PageItemTitle%%

BinarySearch(Image,Generic IComparer) Method
[image]
dotnetCART Namespace > Images Class > BinarySearch Method : BinarySearch(Image,Generic IComparer) Method

item
comparer

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal item As Image, _
   ByVal comparer As IComparer(Of Image) _
) As Integer
C#
public int BinarySearch(
   Image item,
   IComparer<Image> comparer
)

Parameters

item
comparer

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Images Class
Images Members
Overload List


%%PageItemTitle%%

BinarySearch(Int32,Int32,Image,Generic IComparer) Method
[image]
dotnetCART Namespace > Images Class > BinarySearch Method : BinarySearch(Int32,Int32,Image,Generic IComparer) Method

index
count
item
comparer

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal index As Integer, _
   ByVal count As Integer, _
   ByVal item As Image, _
   ByVal comparer As IComparer(Of Image) _
) As Integer
C#
public int BinarySearch(
   int index,
   int count,
   Image item,
   IComparer<Image> comparer
)

Parameters

index
count
item
comparer

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Images Class
Images Members
Overload List


%%PageItemTitle%%

Capacity Property
[image]
dotnetCART Namespace > Images Class : Capacity Property

Gets or sets the total number of elements the internal data structure can hold without resizing.

Syntax

Visual Basic (Declaration)
Public Property Capacity As Integer
C#
public int Capacity {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Images Class
Images Members


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > Images Class : Clear Method

Removes all elements from the List.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Images Class
Images Members


%%PageItemTitle%%

Contains Method
[image]
dotnetCART Namespace > Images Class : Contains Method

item
Determines whether an element is in the List.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal item As Image _
) As Boolean
C#
public bool Contains(
   Image item
)

Parameters

item

Return Value

true if item is found in the List; otherwise, false.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Images Class
Images Members


%%PageItemTitle%%

CopyTo Method
[image]
dotnetCART Namespace > Images Class : CopyTo Method

Overload List

Overload | Description
CopyTo(Image[]) | (Inherited from dotnetCART.ListBase<Image>)
CopyTo(Image[],Int32) | (Inherited from dotnetCART.ListBase<Image>)
CopyTo(Int32,Image[],Int32,Int32) | (Inherited from dotnetCART.ListBase<Image>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Images Class
Images Members


%%PageItemTitle%%

CopyTo(Image[]) Method
[image]
dotnetCART Namespace > Images Class > CopyTo Method : CopyTo(Image[]) Method

array

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array() As Image _
)
C#
public void CopyTo(
   Image[] array
)

Parameters

array

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Images Class
Images Members
Overload List


%%PageItemTitle%%

CopyTo(Image[],Int32) Method
[image]
dotnetCART Namespace > Images Class > CopyTo Method : CopyTo(Image[],Int32) Method

array
arrayIndex

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array() As Image, _
   ByVal arrayIndex As Integer _
)
C#
public void CopyTo(
   Image[] array,
   int arrayIndex
)

Parameters

array
arrayIndex

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Images Class
Images Members
Overload List


%%PageItemTitle%%

CopyTo(Int32,Image[],Int32,Int32) Method
[image]
dotnetCART Namespace > Images Class > CopyTo Method : CopyTo(Int32,Image[],Int32,Int32) Method

index
array
arrayIndex
count

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal index As Integer, _
   ByVal array() As Image, _
   ByVal arrayIndex As Integer, _
   ByVal count As Integer _
)
C#
public void CopyTo(
   int index,
   Image[] array,
   int arrayIndex,
   int count
)

Parameters

index
array
arrayIndex
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Images Class
Images Members
Overload List


%%PageItemTitle%%

Count Property
[image]
dotnetCART Namespace > Images Class : Count Property

Gets the number of elements actually contained in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Images Class
Images Members


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > Images Class : Error Property

Returns an object with the error information.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Images Class
Images Members


%%PageItemTitle%%

GetEnumerator Method
[image]
dotnetCART Namespace > Images Class : GetEnumerator Method

Returns an enumerator that iterates through the List.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As List.Enumerator(Of Image)
C#
public List.Enumerator<Image> GetEnumerator()

Return Value

A List.Enumerator for the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Images Class
Images Members


%%PageItemTitle%%

IndexOf Method
[image]
dotnetCART Namespace > Images Class : IndexOf Method

Overload List

Overload | Description
IndexOf(Image) | (Inherited from dotnetCART.ListBase<Image>)
IndexOf(Image,Int32) | (Inherited from dotnetCART.ListBase<Image>)
IndexOf(Image,Int32,Int32) | (Inherited from dotnetCART.ListBase<Image>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Images Class
Images Members


%%PageItemTitle%%

IndexOf(Image) Method
[image]
dotnetCART Namespace > Images Class > IndexOf Method : IndexOf(Image) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As Image _
) As Integer
C#
public int IndexOf(
   Image item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Images Class
Images Members
Overload List


%%PageItemTitle%%

IndexOf(Image,Int32) Method
[image]
dotnetCART Namespace > Images Class > IndexOf Method : IndexOf(Image,Int32) Method

item
index

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As Image, _
   ByVal index As Integer _
) As Integer
C#
public int IndexOf(
   Image item,
   int index
)

Parameters

item
index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Images Class
Images Members
Overload List


%%PageItemTitle%%

IndexOf(Image,Int32,Int32) Method
[image]
dotnetCART Namespace > Images Class > IndexOf Method : IndexOf(Image,Int32,Int32) Method

item
index
count

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As Image, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
C#
public int IndexOf(
   Image item,
   int index,
   int count
)

Parameters

item
index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Images Class
Images Members
Overload List


%%PageItemTitle%%

Insert Method
[image]
dotnetCART Namespace > Images Class : Insert Method

index
item
Inserts an element into the List at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As Image _
)
C#
public void Insert(
   int index,
   Image item
)

Parameters

index
item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Images Class
Images Members


%%PageItemTitle%%

InsertRange Method
[image]
dotnetCART Namespace > Images Class : InsertRange Method

index
collection
Inserts the elements of a collection into the List at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub InsertRange( _
   ByVal index As Integer, _
   ByVal collection As IEnumerable(Of Image) _
)
C#
public void InsertRange(
   int index,
   IEnumerable<Image> collection
)

Parameters

index
collection

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Images Class
Images Members


%%PageItemTitle%%

Item Property
[image]
dotnetCART Namespace > Images Class : Item Property

index
Gets or sets the element at the specified index.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As Image
C#
public Image this[
   int index
]; {get; set;}

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Images Class
Images Members


%%PageItemTitle%%

LastIndexOf Method
[image]
dotnetCART Namespace > Images Class : LastIndexOf Method

Overload List

Overload | Description
LastIndexOf(Image) | (Inherited from dotnetCART.ListBase<Image>)
LastIndexOf(Image,Int32) | (Inherited from dotnetCART.ListBase<Image>)
LastIndexOf(Image,Int32,Int32) | (Inherited from dotnetCART.ListBase<Image>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Images Class
Images Members


%%PageItemTitle%%

LastIndexOf(Image) Method
[image]
dotnetCART Namespace > Images Class > LastIndexOf Method : LastIndexOf(Image) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As Image _
) As Integer
C#
public int LastIndexOf(
   Image item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Images Class
Images Members
Overload List


%%PageItemTitle%%

LastIndexOf(Image,Int32) Method
[image]
dotnetCART Namespace > Images Class > LastIndexOf Method : LastIndexOf(Image,Int32) Method

item
index

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As Image, _
   ByVal index As Integer _
) As Integer
C#
public int LastIndexOf(
   Image item,
   int index
)

Parameters

item
index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Images Class
Images Members
Overload List


%%PageItemTitle%%

LastIndexOf(Image,Int32,Int32) Method
[image]
dotnetCART Namespace > Images Class > LastIndexOf Method : LastIndexOf(Image,Int32,Int32) Method

item
index
count

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As Image, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
C#
public int LastIndexOf(
   Image item,
   int index,
   int count
)

Parameters

item
index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Images Class
Images Members
Overload List


%%PageItemTitle%%

LoadDB(Int32,Int32) Method
[image]
dotnetCART Namespace > Images Class > LoadDB Method : LoadDB(Int32,Int32) Method

start
count
Loads the count number of elements from start value.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal start As Integer, _
   ByVal count As Integer _
) As Integer
C#
public virtual int LoadDB(
   int start,
   int count
)

Parameters

start
count

Return Value

The total number of elements have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Images Class
Images Members
Overload List


%%PageItemTitle%%

LoadDB(Where) Method
[image]
dotnetCART Namespace > Images Class > LoadDB Method : LoadDB(Where) Method

whereClause
Loads all the items from its associated table based on the where clause.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal whereClause As Where _
) As Integer
C#
public virtual int LoadDB(
   Where whereClause
)

Parameters

whereClause

Return Value

The total number of items have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Images Class
Images Members
Overload List


%%PageItemTitle%%

LoadDB(Where,Int32,Int32,String,OrderDirection) Method
[image]
dotnetCART Namespace > Images Class > LoadDB Method : LoadDB(Where,Int32,Int32,String,OrderDirection) Method

whereClause
count
start
orderBy
orderDirection
Loads all the items based on the parameters.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal whereClause As Where, _
   ByVal count As Integer, _
   ByVal start As Integer, _
   ByVal orderBy As String, _
   ByVal orderDirection As OrderDirection _
) As Integer
C#
public virtual int LoadDB(
   Where whereClause,
   int count,
   int start,
   string orderBy,
   OrderDirection orderDirection
)

Parameters

whereClause
count
start
orderBy
orderDirection

Return Value

The total number of items have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Images Class
Images Members
Overload List


%%PageItemTitle%%

Remove Method
[image]
dotnetCART Namespace > Images Class : Remove Method

item
Removes the first occurrence of a specific object from the List.

Syntax

Visual Basic (Declaration)
Public Function Remove( _
   ByVal item As Image _
) As Boolean
C#
public bool Remove(
   Image item
)

Parameters

item

Return Value

true if item is successfully removed; otherwise, false. This method also returns false if item was not found in the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Images Class
Images Members


%%PageItemTitle%%

RemoveAll Method
[image]
dotnetCART Namespace > Images Class : RemoveAll Method

match
Removes the all the elements that match the conditions defined by the specified predicate.

Syntax

Visual Basic (Declaration)
Public Function RemoveAll( _
   ByVal match As Predicate(Of Image) _
) As Integer
C#
public int RemoveAll(
   Predicate<Image> match
)

Parameters

match

Return Value

The number of elements removed from the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Images Class
Images Members


%%PageItemTitle%%

RemoveAt Method
[image]
dotnetCART Namespace > Images Class : RemoveAt Method

index
Removes the element at the specified index of the List.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Images Class
Images Members


%%PageItemTitle%%

RemoveRange Method
[image]
dotnetCART Namespace > Images Class : RemoveRange Method

index
count
Removes a range of elements from the List.

Syntax

Visual Basic (Declaration)
Public Sub RemoveRange( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
C#
public void RemoveRange(
   int index,
   int count
)

Parameters

index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Images Class
Images Members


%%PageItemTitle%%

Reverse Method
[image]
dotnetCART Namespace > Images Class : Reverse Method

Reverses the order of the elements in the entire List.

Overload List

Overload | Description
Reverse() | Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<Image>)
Reverse(Int32,Int32) | Reverses the order of the elements in the specified range. (Inherited from dotnetCART.ListBase<Image>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Images Class
Images Members


%%PageItemTitle%%

Reverse() Method
[image]
dotnetCART Namespace > Images Class > Reverse Method : Reverse() Method

Reverses the order of the elements in the entire List.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Reverse()
C#
public void Reverse()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Images Class
Images Members
Overload List


%%PageItemTitle%%

Reverse(Int32,Int32) Method
[image]
dotnetCART Namespace > Images Class > Reverse Method : Reverse(Int32,Int32) Method

index
count
Reverses the order of the elements in the specified range.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Reverse( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
C#
public void Reverse(
   int index,
   int count
)

Parameters

index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Images Class
Images Members
Overload List


%%PageItemTitle%%

Add Method
[image]
dotnetCART Namespace > ImageTemplates Class : Add Method

item
Adds an object to the end of the collection.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal item As ImageTemplate _
)
C#
public void Add(
   ImageTemplate item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplates Class
ImageTemplates Members


%%PageItemTitle%%

AddRange Method
[image]
dotnetCART Namespace > ImageTemplates Class : AddRange Method

collection
Adds the elements of the specified collection to the end of the collection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal collection As IEnumerable(Of ImageTemplate) _
)
C#
public void AddRange(
   IEnumerable<ImageTemplate> collection
)

Parameters

collection

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplates Class
ImageTemplates Members


%%PageItemTitle%%

AsReadOnly Method
[image]
dotnetCART Namespace > ImageTemplates Class : AsReadOnly Method

Returns a read-only IList wrapper for the current collection.

Syntax

Visual Basic (Declaration)
Public Function AsReadOnly() As ReadOnlyCollection(Of ImageTemplate)
C#
public ReadOnlyCollection<ImageTemplate> AsReadOnly()

Return Value

A ReadOnlyCollection that acts as a read-only wrapper around the current List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplates Class
ImageTemplates Members


%%PageItemTitle%%

BinarySearch Method
[image]
dotnetCART Namespace > ImageTemplates Class : BinarySearch Method

Overload List

Overload | Description
BinarySearch(ImageTemplate) | (Inherited from dotnetCART.ListBase<ImageTemplate>)
BinarySearch(ImageTemplate,Generic IComparer) | (Inherited from dotnetCART.ListBase<ImageTemplate>)
BinarySearch(Int32,Int32,ImageTemplate,Generic IComparer) | (Inherited from dotnetCART.ListBase<ImageTemplate>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplates Class
ImageTemplates Members


%%PageItemTitle%%

BinarySearch(ImageTemplate) Method
[image]
dotnetCART Namespace > ImageTemplates Class > BinarySearch Method : BinarySearch(ImageTemplate) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal item As ImageTemplate _
) As Integer
C#
public int BinarySearch(
   ImageTemplate item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplates Class
ImageTemplates Members
Overload List


%%PageItemTitle%%

BinarySearch(ImageTemplate,Generic IComparer) Method
[image]
dotnetCART Namespace > ImageTemplates Class > BinarySearch Method : BinarySearch(ImageTemplate,Generic IComparer) Method

item
comparer

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal item As ImageTemplate, _
   ByVal comparer As IComparer(Of ImageTemplate) _
) As Integer
C#
public int BinarySearch(
   ImageTemplate item,
   IComparer<ImageTemplate> comparer
)

Parameters

item
comparer

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplates Class
ImageTemplates Members
Overload List


%%PageItemTitle%%

BinarySearch(Int32,Int32,ImageTemplate,Generic IComparer) Method
See Also
[image]
dotnetCART Namespace > ImageTemplates Class > BinarySearch Method : BinarySearch(Int32,Int32,ImageTemplate,Generic IComparer) Method

index
count
item
comparer

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal index As Integer, _
   ByVal count As Integer, _
   ByVal item As ImageTemplate, _
   ByVal comparer As IComparer(Of ImageTemplate) _
) As Integer
C#
public int BinarySearch(
   int index,
   int count,
   ImageTemplate item,
   IComparer<ImageTemplate> comparer
)

Parameters

index
count
item
comparer

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplates Class
ImageTemplates Members
Overload List


%%PageItemTitle%%

Capacity Property
[image]
dotnetCART Namespace > ImageTemplates Class : Capacity Property

Gets or sets the total number of elements the internal data structure can hold without resizing.

Syntax

Visual Basic (Declaration)
Public Property Capacity As Integer
C#
public int Capacity {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplates Class
ImageTemplates Members


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > ImageTemplates Class : Clear Method

Removes all elements from the List.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplates Class
ImageTemplates Members


%%PageItemTitle%%

Contains Method
[image]
dotnetCART Namespace > ImageTemplates Class : Contains Method

item
Determines whether an element is in the List.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal item As ImageTemplate _
) As Boolean
C#
public bool Contains(
   ImageTemplate item
)

Parameters

item

Return Value

true if item is found in the List; otherwise, false.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplates Class
ImageTemplates Members


%%PageItemTitle%%

CopyTo Method
[image]
dotnetCART Namespace > ImageTemplates Class : CopyTo Method

Overload List

Overload | Description
CopyTo(ImageTemplate[]) | (Inherited from dotnetCART.ListBase<ImageTemplate>)
CopyTo(ImageTemplate[],Int32) | (Inherited from dotnetCART.ListBase<ImageTemplate>)
CopyTo(Int32,ImageTemplate[],Int32,Int32) | (Inherited from dotnetCART.ListBase<ImageTemplate>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplates Class
ImageTemplates Members


%%PageItemTitle%%

CopyTo(ImageTemplate[]) Method
[image]
dotnetCART Namespace > ImageTemplates Class > CopyTo Method : CopyTo(ImageTemplate[]) Method

array

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array() As ImageTemplate _
)
C#
public void CopyTo(
   ImageTemplate[] array
)

Parameters

array

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplates Class
ImageTemplates Members
Overload List


%%PageItemTitle%%

CopyTo(ImageTemplate[],Int32) Method
[image]
dotnetCART Namespace > ImageTemplates Class > CopyTo Method : CopyTo(ImageTemplate[],Int32) Method

array
arrayIndex

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array() As ImageTemplate, _
   ByVal arrayIndex As Integer _
)
C#
public void CopyTo(
   ImageTemplate[] array,
   int arrayIndex
)

Parameters

array
arrayIndex

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplates Class
ImageTemplates Members
Overload List


%%PageItemTitle%%

CopyTo(Int32,ImageTemplate[],Int32,Int32) Method
[image]
dotnetCART Namespace > ImageTemplates Class > CopyTo Method : CopyTo(Int32,ImageTemplate[],Int32,Int32) Method

index
array
arrayIndex
count

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal index As Integer, _
   ByVal array() As ImageTemplate, _
   ByVal arrayIndex As Integer, _
   ByVal count As Integer _
)
C#
public void CopyTo(
   int index,
   ImageTemplate[] array,
   int arrayIndex,
   int count
)

Parameters

index
array
arrayIndex
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplates Class
ImageTemplates Members
Overload List


%%PageItemTitle%%

Count Property
[image]
dotnetCART Namespace > ImageTemplates Class : Count Property

Gets the number of elements actually contained in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplates Class
ImageTemplates Members


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > ImageTemplates Class : Error Property

Returns an object with the error information.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplates Class
ImageTemplates Members


%%PageItemTitle%%

GetEnumerator Method
[image]
dotnetCART Namespace > ImageTemplates Class : GetEnumerator Method

Returns an enumerator that iterates through the List.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As List.Enumerator(Of ImageTemplate)
C#
public List.Enumerator<ImageTemplate> GetEnumerator()

Return Value

A List.Enumerator for the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplates Class
ImageTemplates Members


%%PageItemTitle%%

IndexOf Method
[image]
dotnetCART Namespace > ImageTemplates Class : IndexOf Method

Overload List

Overload | Description
IndexOf(ImageTemplate) | (Inherited from dotnetCART.ListBase<ImageTemplate>)
IndexOf(ImageTemplate,Int32) | (Inherited from dotnetCART.ListBase<ImageTemplate>)
IndexOf(ImageTemplate,Int32,Int32) | (Inherited from dotnetCART.ListBase<ImageTemplate>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplates Class
ImageTemplates Members


%%PageItemTitle%%

IndexOf(ImageTemplate) Method
[image]
dotnetCART Namespace > ImageTemplates Class > IndexOf Method : IndexOf(ImageTemplate) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As ImageTemplate _
) As Integer
C#
public int IndexOf(
   ImageTemplate item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplates Class
ImageTemplates Members
Overload List


%%PageItemTitle%%

IndexOf(ImageTemplate,Int32) Method
[image]
dotnetCART Namespace > ImageTemplates Class > IndexOf Method : IndexOf(ImageTemplate,Int32) Method

item
index

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As ImageTemplate, _
   ByVal index As Integer _
) As Integer
C#
public int IndexOf(
   ImageTemplate item,
   int index
)

Parameters

item
index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplates Class
ImageTemplates Members
Overload List


%%PageItemTitle%%

IndexOf(ImageTemplate,Int32,Int32) Method
[image]
dotnetCART Namespace > ImageTemplates Class > IndexOf Method : IndexOf(ImageTemplate,Int32,Int32) Method

item
index
count

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As ImageTemplate, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
C#
public int IndexOf(
   ImageTemplate item,
   int index,
   int count
)

Parameters

item
index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplates Class
ImageTemplates Members
Overload List


%%PageItemTitle%%

Insert Method
[image]
dotnetCART Namespace > ImageTemplates Class : Insert Method

index
item
Inserts an element into the List at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As ImageTemplate _
)
C#
public void Insert(
   int index,
   ImageTemplate item
)

Parameters

index
item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplates Class
ImageTemplates Members


%%PageItemTitle%%

InsertRange Method
[image]
dotnetCART Namespace > ImageTemplates Class : InsertRange Method

index
collection
Inserts the elements of a collection into the List at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub InsertRange( _
   ByVal index As Integer, _
   ByVal collection As IEnumerable(Of ImageTemplate) _
)
C#
public void InsertRange(
   int index,
   IEnumerable<ImageTemplate> collection
)

Parameters

index
collection

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplates Class
ImageTemplates Members


%%PageItemTitle%%

Item Property
[image]
dotnetCART Namespace > ImageTemplates Class : Item Property

index
Gets or sets the element at the specified index.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As ImageTemplate
C#
public ImageTemplate this[
   int index
]; {get; set;}

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplates Class
ImageTemplates Members


%%PageItemTitle%%

LastIndexOf Method
[image]
dotnetCART Namespace > ImageTemplates Class : LastIndexOf Method

Overload List

Overload | Description
LastIndexOf(ImageTemplate) | (Inherited from dotnetCART.ListBase<ImageTemplate>)
LastIndexOf(ImageTemplate,Int32) | (Inherited from dotnetCART.ListBase<ImageTemplate>)
LastIndexOf(ImageTemplate,Int32,Int32) | (Inherited from dotnetCART.ListBase<ImageTemplate>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplates Class
ImageTemplates Members


%%PageItemTitle%%

LastIndexOf(ImageTemplate) Method
[image]
dotnetCART Namespace > ImageTemplates Class > LastIndexOf Method : LastIndexOf(ImageTemplate) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As ImageTemplate _
) As Integer
C#
public int LastIndexOf(
   ImageTemplate item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplates Class
ImageTemplates Members
Overload List


%%PageItemTitle%%

LastIndexOf(ImageTemplate,Int32) Method
[image]
dotnetCART Namespace > ImageTemplates Class > LastIndexOf Method : LastIndexOf(ImageTemplate,Int32) Method

item
index

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As ImageTemplate, _
   ByVal index As Integer _
) As Integer
C#
public int LastIndexOf(
   ImageTemplate item,
   int index
)

Parameters

item
index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplates Class
ImageTemplates Members
Overload List


%%PageItemTitle%%

LastIndexOf(ImageTemplate,Int32,Int32) Method
[image]
dotnetCART Namespace > ImageTemplates Class > LastIndexOf Method : LastIndexOf(ImageTemplate,Int32,Int32) Method

item
index
count

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As ImageTemplate, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
C#
public int LastIndexOf(
   ImageTemplate item,
   int index,
   int count
)

Parameters

item
index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplates Class
ImageTemplates Members
Overload List


%%PageItemTitle%%

LoadDB(Int32,Int32) Method
[image]
dotnetCART Namespace > ImageTemplates Class > LoadDB Method : LoadDB(Int32,Int32) Method

start
count
Loads the count number of elements from start value.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal start As Integer, _
   ByVal count As Integer _
) As Integer
C#
public virtual int LoadDB(
   int start,
   int count
)

Parameters

start
count

Return Value

The total number of elements have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplates Class
ImageTemplates Members
Overload List


%%PageItemTitle%%

LoadDB(Where) Method
[image]
dotnetCART Namespace > ImageTemplates Class > LoadDB Method : LoadDB(Where) Method

whereClause
Loads all the items from its associated table based on the where clause.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal whereClause As Where _
) As Integer
C#
public virtual int LoadDB(
   Where whereClause
)

Parameters

whereClause

Return Value

The total number of items have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplates Class
ImageTemplates Members
Overload List


%%PageItemTitle%%

LoadDB(Where,Int32,Int32,String,OrderDirection) Method
[image]
dotnetCART Namespace > ImageTemplates Class > LoadDB Method : LoadDB(Where,Int32,Int32,String,OrderDirection) Method

whereClause
count
start
orderBy
orderDirection
Loads all the items based on the parameters.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal whereClause As Where, _
   ByVal count As Integer, _
   ByVal start As Integer, _
   ByVal orderBy As String, _
   ByVal orderDirection As OrderDirection _
) As Integer
C#
public virtual int LoadDB(
   Where whereClause,
   int count,
   int start,
   string orderBy,
   OrderDirection orderDirection
)

Parameters

whereClause
count
start
orderBy
orderDirection

Return Value

The total number of items have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplates Class
ImageTemplates Members
Overload List


%%PageItemTitle%%

Remove Method
[image]
dotnetCART Namespace > ImageTemplates Class : Remove Method

item
Removes the first occurrence of a specific object from the List.

Syntax

Visual Basic (Declaration)
Public Function Remove( _
   ByVal item As ImageTemplate _
) As Boolean
C#
public bool Remove(
   ImageTemplate item
)

Parameters

item

Return Value

true if item is successfully removed; otherwise, false. This method also returns false if item was not found in the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplates Class
ImageTemplates Members


%%PageItemTitle%%

RemoveAll Method
[image]
dotnetCART Namespace > ImageTemplates Class : RemoveAll Method

match
Removes the all the elements that match the conditions defined by the specified predicate.

Syntax

Visual Basic (Declaration)
Public Function RemoveAll( _
   ByVal match As Predicate(Of ImageTemplate) _
) As Integer
C#
public int RemoveAll(
   Predicate<ImageTemplate> match
)

Parameters

match

Return Value

The number of elements removed from the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplates Class
ImageTemplates Members


%%PageItemTitle%%

RemoveAt Method
[image]
dotnetCART Namespace > ImageTemplates Class : RemoveAt Method

index
Removes the element at the specified index of the List.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplates Class
ImageTemplates Members


%%PageItemTitle%%

RemoveRange Method
[image]
dotnetCART Namespace > ImageTemplates Class : RemoveRange Method

index
count
Removes a range of elements from the List.

Syntax

Visual Basic (Declaration)
Public Sub RemoveRange( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
C#
public void RemoveRange(
   int index,
   int count
)

Parameters

index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplates Class
ImageTemplates Members


%%PageItemTitle%%

Reverse Method
[image]
dotnetCART Namespace > ImageTemplates Class : Reverse Method

Reverses the order of the elements in the entire List.

Overload List

Overload | Description
Reverse() | Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<ImageTemplate>)
Reverse(Int32,Int32) | Reverses the order of the elements in the specified range. (Inherited from dotnetCART.ListBase<ImageTemplate>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplates Class
ImageTemplates Members


%%PageItemTitle%%

Reverse() Method
[image]
dotnetCART Namespace > ImageTemplates Class > Reverse Method : Reverse() Method

Reverses the order of the elements in the entire List.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Reverse()
C#
public void Reverse()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplates Class
ImageTemplates Members
Overload List


%%PageItemTitle%%

Reverse(Int32,Int32) Method
[image]
dotnetCART Namespace > ImageTemplates Class > Reverse Method : Reverse(Int32,Int32) Method

index
count
Reverses the order of the elements in the specified range.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Reverse( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
C#
public void Reverse(
   int index,
   int count
)

Parameters

index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplates Class
ImageTemplates Members
Overload List


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > ImageTemplate Class : Clear Method

Initializes all the properties without recreating the object.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Clear()
C#
public virtual void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplate Class
ImageTemplate Members


%%PageItemTitle%%

Custom Property
[image]
dotnetCART Namespace > ImageTemplate Class : Custom Property

Gets or sets a custom object. For more information see custom fields

Syntax

Visual Basic (Declaration)
Public Property Custom As Custom
C#
public Custom Custom {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplate Class
ImageTemplate Members


%%PageItemTitle%%

CustomFields Property
See Also Example
[image]
dotnetCART Namespace > ImageTemplate Class : CustomFields Property

Gets or sets a the names of custom fields for a table associated with the object.

Syntax

Visual Basic (Declaration)
Public Property CustomFields As String
C#
public string CustomFields {get; set;}

Example

C# Copy Code
Customer.CustomFields = "CellPhone,Favorites";

Visual Basic Copy Code
Customer.CustomFields = "CellPhone,Favorites"

Remarks

Custom fields must be added to the table manualy. Custom fields are usually set at store level using CustomFields

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplate Class
ImageTemplate Members


%%PageItemTitle%%

Customs Property
[image]
dotnetCART Namespace > ImageTemplate Class : Customs Property

A reference to the collection of the Custom objects.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Customs As Customs
C#
public Customs Customs {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplate Class
ImageTemplate Members


%%PageItemTitle%%

DeleteDB(DbManager) Method
[image]
dotnetCART Namespace > ImageTemplate Class > DeleteDB Method : DeleteDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function DeleteDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int DeleteDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplate Class
ImageTemplate Members
Overload List


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > ImageTemplate Class : Error Property

Gets the error object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplate Class
ImageTemplate Members


%%PageItemTitle%%

GetCustom Method
[image]
dotnetCART Namespace > ImageTemplate Class : GetCustom Method

This method returns the value of a custom field based on its name in the customs collection.

Overload List

Overload | Description
GetCustom(String) | This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<ImageTemplate, Int64>)
GetCustom(Int32) | This method returns the value of a custom field based on its index in the customs collection. (Inherited from dotnetCART.DbTableCart<ImageTemplate, Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplate Class
ImageTemplate Members


%%PageItemTitle%%

GetCustom(Int32) Method
[image]
dotnetCART Namespace > ImageTemplate Class > GetCustom Method : GetCustom(Int32) Method

customIndex
This method returns the value of a custom field based on its index in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal customIndex As Integer _
) As Object
C#
public object GetCustom(
   int customIndex
)

Parameters

customIndex

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplate Class
ImageTemplate Members
Overload List


%%PageItemTitle%%

GetCustom(String) Method
[image]
dotnetCART Namespace > ImageTemplate Class > GetCustom Method : GetCustom(String) Method

name
This method returns the value of a custom field based on its name in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal name As String _
) As Object
C#
public object GetCustom(
   string name
)

Parameters

name

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplate Class
ImageTemplate Members
Overload List


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > ImageTemplate Class : LoadDB Method

Loads this object from database using the ID property.

Overload List

Overload | Description
LoadDB(Int64) | (Inherited from dotnetCART.DbTableCart<ImageTemplate, Int64>)
LoadDB() | Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<ImageTemplate, Int64>)
Generic LoadDB() | (Inherited from dotnetDATA.DbTable<Int64>)
Generic LoadDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplate Class
ImageTemplate Members


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > ImageTemplate Class > LoadDB Method : LoadDB() Method

Loads this object from database using the ID property.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB() As Integer
C#
public virtual int LoadDB()

Return Value

In case of error -1, check Error property, if the object with the ID property not found 0, otherwise 1.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplate Class
ImageTemplate Members
Overload List


%%PageItemTitle%%

LoadDB(Int64) Method
[image]
dotnetCART Namespace > ImageTemplate Class > LoadDB Method : LoadDB(Int64) Method

id

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal id As Long _
) As Integer
C#
public virtual int LoadDB(
   long id
)

Parameters

id

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplate Class
ImageTemplate Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB() Method
See Also
[image]
dotnetCART Namespace > ImageTemplate Class > LoadDB Method : Generic LoadDB() Method

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)() As Integer
C#
public virtual int LoadDB<T1>()where T1: IDbTable

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplate Class
ImageTemplate Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB(DbManager) Method
See Also
[image]
dotnetCART Namespace > ImageTemplate Class > LoadDB Method : Generic LoadDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int LoadDB<T1>(
   DbManager manager
)where T1: IDbTable

Parameters

manager

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplate Class
ImageTemplate Members
Overload List


%%PageItemTitle%%

SaveDB(DbManager) Method
[image]
dotnetCART Namespace > ImageTemplate Class > SaveDB Method : SaveDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function SaveDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int SaveDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplate Class
ImageTemplate Members
Overload List


%%PageItemTitle%%

SetCustom Method
[image]
dotnetCART Namespace > ImageTemplate Class : SetCustom Method

name
newValue
This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added.

Syntax

Visual Basic (Declaration)
Public Function SetCustom( _
   ByVal name As String, _
   ByVal newValue As Object _
) As Object
C#
public object SetCustom(
   string name,
   object newValue
)

Parameters

name
newValue

Return Value

Returns the new custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ImageTemplate Class
ImageTemplate Members


%%PageItemTitle%%

Custom Property
[image]
dotnetCART Namespace > Image Class : Custom Property

Gets or sets a custom object. For more information see custom fields

Syntax

Visual Basic (Declaration)
Public Property Custom As Custom
C#
public Custom Custom {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Image Class
Image Members


%%PageItemTitle%%

CustomFields Property
See Also Example
[image]
dotnetCART Namespace > Image Class : CustomFields Property

Gets or sets a the names of custom fields for a table associated with the object.

Syntax

Visual Basic (Declaration)
Public Property CustomFields As String
C#
public string CustomFields {get; set;}

Example

C# Copy Code
Customer.CustomFields = "CellPhone,Favorites";

Visual Basic Copy Code
Customer.CustomFields = "CellPhone,Favorites"

Remarks

Custom fields must be added to the table manualy. Custom fields are usually set at store level using CustomFields

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Image Class
Image Members


%%PageItemTitle%%

Customs Property
[image]
dotnetCART Namespace > Image Class : Customs Property

A reference to the collection of the Custom objects.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Customs As Customs
C#
public Customs Customs {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Image Class
Image Members


%%PageItemTitle%%

DeleteDB Method
[image]
dotnetCART Namespace > Image Class : DeleteDB Method

Deletes this object with ID from the database.

Overload List

Overload | Description
DeleteDB() | Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<Image, Int64>)
DeleteDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Image Class
Image Members


%%PageItemTitle%%

DeleteDB() Method
[image]
dotnetCART Namespace > Image Class > DeleteDB Method : DeleteDB() Method

Deletes this object with ID from the database.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function DeleteDB() As Integer
C#
public virtual int DeleteDB()

Return Value

In case of error -1, check Error property, otherwise the number of objects deleted.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Image Class
Image Members
Overload List


%%PageItemTitle%%

DeleteDB(DbManager) Method
[image]
dotnetCART Namespace > Image Class > DeleteDB Method : DeleteDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function DeleteDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int DeleteDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Image Class
Image Members
Overload List


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > Image Class : Error Property

Gets the error object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Image Class
Image Members


%%PageItemTitle%%

GetCustom Method
[image]
dotnetCART Namespace > Image Class : GetCustom Method

This method returns the value of a custom field based on its name in the customs collection.

Overload List

Overload | Description
GetCustom(String) | This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<Image, Int64>)
GetCustom(Int32) | This method returns the value of a custom field based on its index in the customs collection. (Inherited from dotnetCART.DbTableCart<Image, Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Image Class
Image Members


%%PageItemTitle%%

GetCustom(Int32) Method
[image]
dotnetCART Namespace > Image Class > GetCustom Method : GetCustom(Int32) Method

customIndex
This method returns the value of a custom field based on its index in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal customIndex As Integer _
) As Object
C#
public object GetCustom(
   int customIndex
)

Parameters

customIndex

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Image Class
Image Members
Overload List


%%PageItemTitle%%

GetCustom(String) Method
[image]
dotnetCART Namespace > Image Class > GetCustom Method : GetCustom(String) Method

name
This method returns the value of a custom field based on its name in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal name As String _
) As Object
C#
public object GetCustom(
   string name
)

Parameters

name

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Image Class
Image Members
Overload List


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > Image Class : LoadDB Method

Loads this object from database using the ID property.

Overload List

Overload | Description
LoadDB(Int64) | (Inherited from dotnetCART.DbTableCart<Image, Int64>)
LoadDB() | Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<Image, Int64>)
Generic LoadDB() | (Inherited from dotnetDATA.DbTable<Int64>)
Generic LoadDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Image Class
Image Members


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > Image Class > LoadDB Method : LoadDB() Method

Loads this object from database using the ID property.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB() As Integer
C#
public virtual int LoadDB()

Return Value

In case of error -1, check Error property, if the object with the ID property not found 0, otherwise 1.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Image Class
Image Members
Overload List


%%PageItemTitle%%

LoadDB(Int64) Method
[image]
dotnetCART Namespace > Image Class > LoadDB Method : LoadDB(Int64) Method

id

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal id As Long _
) As Integer
C#
public virtual int LoadDB(
   long id
)

Parameters

id

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Image Class
Image Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB() Method
See Also
[image]
dotnetCART Namespace > Image Class > LoadDB Method : Generic LoadDB() Method

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)() As Integer
C#
public virtual int LoadDB<T1>()where T1: IDbTable

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Image Class
Image Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB(DbManager) Method
See Also
[image]
dotnetCART Namespace > Image Class > LoadDB Method : Generic LoadDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int LoadDB<T1>(
   DbManager manager
)where T1: IDbTable

Parameters

manager

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Image Class
Image Members
Overload List


%%PageItemTitle%%

SaveDB(DbManager) Method
[image]
dotnetCART Namespace > Image Class > SaveDB Method : SaveDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function SaveDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int SaveDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Image Class
Image Members
Overload List


%%PageItemTitle%%

SetCustom Method
[image]
dotnetCART Namespace > Image Class : SetCustom Method

name
newValue
This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added.

Syntax

Visual Basic (Declaration)
Public Function SetCustom( _
   ByVal name As String, _
   ByVal newValue As Object _
) As Object
C#
public object SetCustom(
   string name,
   object newValue
)

Parameters

name
newValue

Return Value

Returns the new custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Image Class
Image Members


%%PageItemTitle%% $$Methods$$

ItemRelationships Class Methods
[image]
dotnetCART Namespace : ItemRelationships Class

For a list of all members of this type, see ItemRelationships members.

Public Methods

 | Name | Description
Public Method | Add | Adds an object to the end of the collection. (Inherited from dotnetCART.ListBase<Item>)
Public Method | AddRange | Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetCART.ListBase<Item>)
Public Method | AsReadOnly | Returns a read-only IList wrapper for the current collection. (Inherited from dotnetCART.ListBase<Item>)
Public Method | BinarySearch | Overloaded. (Inherited from dotnetCART.ListBase<Item>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetCART.ListBase<Item>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetCART.ListBase<Item>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<Item>)
Public Method | CopyTo | Overloaded. (Inherited from dotnetCART.ListBase<Item>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from dotnetCART.ListBase<Item>)
Public Method | IndexOf | Overloaded. (Inherited from dotnetCART.ListBase<Item>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetCART.ListBase<Item>)
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from dotnetCART.ListBase<Item>)
Public Method | LastIndexOf | Overloaded. (Inherited from dotnetCART.ListBase<Item>)
Public Method | LoadDB | Overloaded. Loads all the items from its associated table. (Inherited from dotnetCART.ListBase<Item>)
Public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from dotnetCART.ListBase<Item>)
Public Method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from dotnetCART.ListBase<Item>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetCART.ListBase<Item>)
Public Method | RemoveRange | Removes a range of elements from the List. (Inherited from dotnetCART.ListBase<Item>)
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<Item>)
Top

See Also

Reference

ItemRelationships Class
dotnetCART Namespace


%%PageItemTitle%%

Add Method
[image]
dotnetCART Namespace > ItemRelationships Class : Add Method

item
Adds an object to the end of the collection.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal item As Item _
)
C#
public void Add(
   Item item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationships Class
ItemRelationships Members


%%PageItemTitle%%

AddRange Method
[image]
dotnetCART Namespace > ItemRelationships Class : AddRange Method

collection
Adds the elements of the specified collection to the end of the collection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal collection As IEnumerable(Of Item) _
)
C#
public void AddRange(
   IEnumerable<Item> collection
)

Parameters

collection

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationships Class
ItemRelationships Members


%%PageItemTitle%%

AsReadOnly Method
[image]
dotnetCART Namespace > ItemRelationships Class : AsReadOnly Method

Returns a read-only IList wrapper for the current collection.

Syntax

Visual Basic (Declaration)
Public Function AsReadOnly() As ReadOnlyCollection(Of Item)
C#
public ReadOnlyCollection<Item> AsReadOnly()

Return Value

A ReadOnlyCollection that acts as a read-only wrapper around the current List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationships Class
ItemRelationships Members


%%PageItemTitle%%

BinarySearch Method
[image]
dotnetCART Namespace > ItemRelationships Class : BinarySearch Method

Overload List

Overload | Description
BinarySearch(Item) | (Inherited from dotnetCART.ListBase<Item>)
BinarySearch(Item,Generic IComparer) | (Inherited from dotnetCART.ListBase<Item>)
BinarySearch(Int32,Int32,Item,Generic IComparer) | (Inherited from dotnetCART.ListBase<Item>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationships Class
ItemRelationships Members


%%PageItemTitle%%

BinarySearch(Int32,Int32,Item,Generic IComparer) Method
[image]
dotnetCART Namespace > ItemRelationships Class > BinarySearch Method : BinarySearch(Int32,Int32,Item,Generic IComparer) Method

index
count
item
comparer

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal index As Integer, _
   ByVal count As Integer, _
   ByVal item As Item, _
   ByVal comparer As IComparer(Of Item) _
) As Integer
C#
public int BinarySearch(
   int index,
   int count,
   Item item,
   IComparer<Item> comparer
)

Parameters

index
count
item
comparer

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationships Class
ItemRelationships Members
Overload List


%%PageItemTitle%%

BinarySearch(Item) Method
[image]
dotnetCART Namespace > ItemRelationships Class > BinarySearch Method : BinarySearch(Item) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal item As Item _
) As Integer
C#
public int BinarySearch(
   Item item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationships Class
ItemRelationships Members
Overload List


%%PageItemTitle%%

BinarySearch(Item,Generic IComparer) Method
[image]
dotnetCART Namespace > ItemRelationships Class > BinarySearch Method : BinarySearch(Item,Generic IComparer) Method

item
comparer

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal item As Item, _
   ByVal comparer As IComparer(Of Item) _
) As Integer
C#
public int BinarySearch(
   Item item,
   IComparer<Item> comparer
)

Parameters

item
comparer

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationships Class
ItemRelationships Members
Overload List


%%PageItemTitle%%

Capacity Property
[image]
dotnetCART Namespace > ItemRelationships Class : Capacity Property

Gets or sets the total number of elements the internal data structure can hold without resizing.

Syntax

Visual Basic (Declaration)
Public Property Capacity As Integer
C#
public int Capacity {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationships Class
ItemRelationships Members


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > ItemRelationships Class : Clear Method

Removes all elements from the List.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationships Class
ItemRelationships Members


%%PageItemTitle%%

Contains Method
[image]
dotnetCART Namespace > ItemRelationships Class : Contains Method

item
Determines whether an element is in the List.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal item As Item _
) As Boolean
C#
public bool Contains(
   Item item
)

Parameters

item

Return Value

true if item is found in the List; otherwise, false.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationships Class
ItemRelationships Members


%%PageItemTitle%%

CopyTo Method
[image]
dotnetCART Namespace > ItemRelationships Class : CopyTo Method

Overload List

Overload | Description
CopyTo(Item[]) | (Inherited from dotnetCART.ListBase<Item>)
CopyTo(Item[],Int32) | (Inherited from dotnetCART.ListBase<Item>)
CopyTo(Int32,Item[],Int32,Int32) | (Inherited from dotnetCART.ListBase<Item>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationships Class
ItemRelationships Members


%%PageItemTitle%%

CopyTo(Int32,Item[],Int32,Int32) Method
[image]
dotnetCART Namespace > ItemRelationships Class > CopyTo Method : CopyTo(Int32,Item[],Int32,Int32) Method

index
array
arrayIndex
count

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal index As Integer, _
   ByVal array() As Item, _
   ByVal arrayIndex As Integer, _
   ByVal count As Integer _
)
C#
public void CopyTo(
   int index,
   Item[] array,
   int arrayIndex,
   int count
)

Parameters

index
array
arrayIndex
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationships Class
ItemRelationships Members
Overload List


%%PageItemTitle%%

CopyTo(Item[]) Method
[image]
dotnetCART Namespace > ItemRelationships Class > CopyTo Method : CopyTo(Item[]) Method

array

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array() As Item _
)
C#
public void CopyTo(
   Item[] array
)

Parameters

array

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationships Class
ItemRelationships Members
Overload List


%%PageItemTitle%%

CopyTo(Item[],Int32) Method
[image]
dotnetCART Namespace > ItemRelationships Class > CopyTo Method : CopyTo(Item[],Int32) Method

array
arrayIndex

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array() As Item, _
   ByVal arrayIndex As Integer _
)
C#
public void CopyTo(
   Item[] array,
   int arrayIndex
)

Parameters

array
arrayIndex

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationships Class
ItemRelationships Members
Overload List


%%PageItemTitle%%

Count Property
[image]
dotnetCART Namespace > ItemRelationships Class : Count Property

Gets the number of elements actually contained in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationships Class
ItemRelationships Members


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > ItemRelationships Class : Error Property

Returns an object with the error information.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationships Class
ItemRelationships Members


%%PageItemTitle%%

GetEnumerator Method
[image]
dotnetCART Namespace > ItemRelationships Class : GetEnumerator Method

Returns an enumerator that iterates through the List.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As List.Enumerator(Of Item)
C#
public List.Enumerator<Item> GetEnumerator()

Return Value

A List.Enumerator for the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationships Class
ItemRelationships Members


%%PageItemTitle%%

IndexOf Method
[image]
dotnetCART Namespace > ItemRelationships Class : IndexOf Method

Overload List

Overload | Description
IndexOf(Item) | (Inherited from dotnetCART.ListBase<Item>)
IndexOf(Item,Int32) | (Inherited from dotnetCART.ListBase<Item>)
IndexOf(Item,Int32,Int32) | (Inherited from dotnetCART.ListBase<Item>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationships Class
ItemRelationships Members


%%PageItemTitle%%

IndexOf(Item) Method
[image]
dotnetCART Namespace > ItemRelationships Class > IndexOf Method : IndexOf(Item) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As Item _
) As Integer
C#
public int IndexOf(
   Item item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationships Class
ItemRelationships Members
Overload List


%%PageItemTitle%%

IndexOf(Item,Int32) Method
[image]
dotnetCART Namespace > ItemRelationships Class > IndexOf Method : IndexOf(Item,Int32) Method

item
index

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As Item, _
   ByVal index As Integer _
) As Integer
C#
public int IndexOf(
   Item item,
   int index
)

Parameters

item
index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationships Class
ItemRelationships Members
Overload List


%%PageItemTitle%%

IndexOf(Item,Int32,Int32) Method
[image]
dotnetCART Namespace > ItemRelationships Class > IndexOf Method : IndexOf(Item,Int32,Int32) Method

item
index
count

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As Item, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
C#
public int IndexOf(
   Item item,
   int index,
   int count
)

Parameters

item
index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationships Class
ItemRelationships Members
Overload List


%%PageItemTitle%%

Insert Method
[image]
dotnetCART Namespace > ItemRelationships Class : Insert Method

index
item
Inserts an element into the List at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As Item _
)
C#
public void Insert(
   int index,
   Item item
)

Parameters

index
item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationships Class
ItemRelationships Members


%%PageItemTitle%%

InsertRange Method
[image]
dotnetCART Namespace > ItemRelationships Class : InsertRange Method

index
collection
Inserts the elements of a collection into the List at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub InsertRange( _
   ByVal index As Integer, _
   ByVal collection As IEnumerable(Of Item) _
)
C#
public void InsertRange(
   int index,
   IEnumerable<Item> collection
)

Parameters

index
collection

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationships Class
ItemRelationships Members


%%PageItemTitle%%

Item Property
[image]
dotnetCART Namespace > ItemRelationships Class : Item Property

index
Gets or sets the element at the specified index.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As Item
C#
public Item this[
   int index
]; {get; set;}

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationships Class
ItemRelationships Members


%%PageItemTitle%%

LastIndexOf Method
[image]
dotnetCART Namespace > ItemRelationships Class : LastIndexOf Method

Overload List

Overload | Description
LastIndexOf(Item) | (Inherited from dotnetCART.ListBase<Item>)
LastIndexOf(Item,Int32) | (Inherited from dotnetCART.ListBase<Item>)
LastIndexOf(Item,Int32,Int32) | (Inherited from dotnetCART.ListBase<Item>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationships Class
ItemRelationships Members


%%PageItemTitle%%

LastIndexOf(Item) Method
[image]
dotnetCART Namespace > ItemRelationships Class > LastIndexOf Method : LastIndexOf(Item) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As Item _
) As Integer
C#
public int LastIndexOf(
   Item item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationships Class
ItemRelationships Members
Overload List


%%PageItemTitle%%

LastIndexOf(Item,Int32) Method
[image]
dotnetCART Namespace > ItemRelationships Class > LastIndexOf Method : LastIndexOf(Item,Int32) Method

item
index

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As Item, _
   ByVal index As Integer _
) As Integer
C#
public int LastIndexOf(
   Item item,
   int index
)

Parameters

item
index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationships Class
ItemRelationships Members
Overload List


%%PageItemTitle%%

LastIndexOf(Item,Int32,Int32) Method
[image]
dotnetCART Namespace > ItemRelationships Class > LastIndexOf Method : LastIndexOf(Item,Int32,Int32) Method

item
index
count

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As Item, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
C#
public int LastIndexOf(
   Item item,
   int index,
   int count
)

Parameters

item
index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationships Class
ItemRelationships Members
Overload List


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > ItemRelationships Class : LoadDB Method

Loads all the items from its associated table.

Overload List

Overload | Description
LoadDB() | Loads all the items from its associated table. (Inherited from dotnetCART.ListBase<Item>)
LoadDB(Where) | Loads all the items from its associated table based on the where clause. (Inherited from dotnetCART.ListBase<Item>)
LoadDB(Int32,Int32) | Loads the count number of elements from start value. (Inherited from dotnetCART.ListBase<Item>)
LoadDB(Where,Int32,Int32,String,OrderDirection) | Loads all the items based on the parameters. (Inherited from dotnetCART.ListBase<Item>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationships Class
ItemRelationships Members


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > ItemRelationships Class > LoadDB Method : LoadDB() Method

Loads all the items from its associated table.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB() As Integer
C#
public virtual int LoadDB()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationships Class
ItemRelationships Members
Overload List


%%PageItemTitle%%

LoadDB(Int32,Int32) Method
[image]
dotnetCART Namespace > ItemRelationships Class > LoadDB Method : LoadDB(Int32,Int32) Method

start
count
Loads the count number of elements from start value.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal start As Integer, _
   ByVal count As Integer _
) As Integer
C#
public virtual int LoadDB(
   int start,
   int count
)

Parameters

start
count

Return Value

The total number of elements have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationships Class
ItemRelationships Members
Overload List


%%PageItemTitle%%

LoadDB(Where) Method
[image]
dotnetCART Namespace > ItemRelationships Class > LoadDB Method : LoadDB(Where) Method

whereClause
Loads all the items from its associated table based on the where clause.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal whereClause As Where _
) As Integer
C#
public virtual int LoadDB(
   Where whereClause
)

Parameters

whereClause

Return Value

The total number of items have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationships Class
ItemRelationships Members
Overload List


%%PageItemTitle%%

LoadDB(Where,Int32,Int32,String,OrderDirection) Method
[image]
dotnetCART Namespace > ItemRelationships Class > LoadDB Method : LoadDB(Where,Int32,Int32,String,OrderDirection) Method

whereClause
count
start
orderBy
orderDirection
Loads all the items based on the parameters.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal whereClause As Where, _
   ByVal count As Integer, _
   ByVal start As Integer, _
   ByVal orderBy As String, _
   ByVal orderDirection As OrderDirection _
) As Integer
C#
public virtual int LoadDB(
   Where whereClause,
   int count,
   int start,
   string orderBy,
   OrderDirection orderDirection
)

Parameters

whereClause
count
start
orderBy
orderDirection

Return Value

The total number of items have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationships Class
ItemRelationships Members
Overload List


%%PageItemTitle%%

Remove Method
[image]
dotnetCART Namespace > ItemRelationships Class : Remove Method

item
Removes the first occurrence of a specific object from the List.

Syntax

Visual Basic (Declaration)
Public Function Remove( _
   ByVal item As Item _
) As Boolean
C#
public bool Remove(
   Item item
)

Parameters

item

Return Value

true if item is successfully removed; otherwise, false. This method also returns false if item was not found in the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationships Class
ItemRelationships Members


%%PageItemTitle%%

RemoveAll Method
[image]
dotnetCART Namespace > ItemRelationships Class : RemoveAll Method

match
Removes the all the elements that match the conditions defined by the specified predicate.

Syntax

Visual Basic (Declaration)
Public Function RemoveAll( _
   ByVal match As Predicate(Of Item) _
) As Integer
C#
public int RemoveAll(
   Predicate<Item> match
)

Parameters

match

Return Value

The number of elements removed from the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationships Class
ItemRelationships Members


%%PageItemTitle%%

RemoveAt Method
[image]
dotnetCART Namespace > ItemRelationships Class : RemoveAt Method

index
Removes the element at the specified index of the List.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationships Class
ItemRelationships Members


%%PageItemTitle%%

RemoveRange Method
[image]
dotnetCART Namespace > ItemRelationships Class : RemoveRange Method

index
count
Removes a range of elements from the List.

Syntax

Visual Basic (Declaration)
Public Sub RemoveRange( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
C#
public void RemoveRange(
   int index,
   int count
)

Parameters

index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationships Class
ItemRelationships Members


%%PageItemTitle%%

Reverse Method
[image]
dotnetCART Namespace > ItemRelationships Class : Reverse Method

Reverses the order of the elements in the entire List.

Overload List

Overload | Description
Reverse() | Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<Item>)
Reverse(Int32,Int32) | Reverses the order of the elements in the specified range. (Inherited from dotnetCART.ListBase<Item>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationships Class
ItemRelationships Members


%%PageItemTitle%%

Reverse() Method
[image]
dotnetCART Namespace > ItemRelationships Class > Reverse Method : Reverse() Method

Reverses the order of the elements in the entire List.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Reverse()
C#
public void Reverse()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationships Class
ItemRelationships Members
Overload List


%%PageItemTitle%%

Reverse(Int32,Int32) Method
[image]
dotnetCART Namespace > ItemRelationships Class > Reverse Method : Reverse(Int32,Int32) Method

index
count
Reverses the order of the elements in the specified range.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Reverse( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
C#
public void Reverse(
   int index,
   int count
)

Parameters

index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationships Class
ItemRelationships Members
Overload List


%%PageItemTitle%% $$Methods$$

ItemRelationshipType Class Methods
[image]
dotnetCART Namespace : ItemRelationshipType Class

For a list of all members of this type, see ItemRelationshipType members.

Public Methods

 | Name | Description
Public Method | Clear | Initializes all the properties without recreating the object. (Inherited from dotnetCART.DbTableCart<ItemRelationshipType, Int64>)
Public Method | DeleteDB | Overloaded. Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<ItemRelationshipType, Int64>)
Public Method | GetCustom | Overloaded. This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<ItemRelationshipType, Int64>)
Public Method | LoadDB | Overloaded. Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<ItemRelationshipType, Int64>)
Public Method | SaveDB | Overloaded. Inserts or updates this object into the database. (Inherited from dotnetCART.DbTableCart<ItemRelationshipType, Int64>)
Public Method | SetCustom | This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added. (Inherited from dotnetCART.DbTableCart<ItemRelationshipType, Int64>)
Top

See Also

Reference

ItemRelationshipType Class
dotnetCART Namespace


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > ItemRelationshipType Class : Clear Method

Initializes all the properties without recreating the object.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Clear()
C#
public virtual void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationshipType Class
ItemRelationshipType Members


%%PageItemTitle%%

Custom Property
[image]
dotnetCART Namespace > ItemRelationshipType Class : Custom Property

Gets or sets a custom object. For more information see custom fields

Syntax

Visual Basic (Declaration)
Public Property Custom As Custom
C#
public Custom Custom {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationshipType Class
ItemRelationshipType Members


%%PageItemTitle%%

CustomFields Property
See Also Example
[image]
dotnetCART Namespace > ItemRelationshipType Class : CustomFields Property

Gets or sets a the names of custom fields for a table associated with the object.

Syntax

Visual Basic (Declaration)
Public Property CustomFields As String
C#
public string CustomFields {get; set;}

Example

C# Copy Code
Customer.CustomFields = "CellPhone,Favorites";

Visual Basic Copy Code
Customer.CustomFields = "CellPhone,Favorites"

Remarks

Custom fields must be added to the table manualy. Custom fields are usually set at store level using CustomFields

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationshipType Class
ItemRelationshipType Members


%%PageItemTitle%%

Customs Property
[image]
dotnetCART Namespace > ItemRelationshipType Class : Customs Property

A reference to the collection of the Custom objects.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Customs As Customs
C#
public Customs Customs {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationshipType Class
ItemRelationshipType Members


%%PageItemTitle%%

DeleteDB Method
[image]
dotnetCART Namespace > ItemRelationshipType Class : DeleteDB Method

Deletes this object with ID from the database.

Overload List

Overload | Description
DeleteDB() | Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<ItemRelationshipType, Int64>)
DeleteDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationshipType Class
ItemRelationshipType Members


%%PageItemTitle%%

DeleteDB() Method
[image]
dotnetCART Namespace > ItemRelationshipType Class > DeleteDB Method : DeleteDB() Method

Deletes this object with ID from the database.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function DeleteDB() As Integer
C#
public virtual int DeleteDB()

Return Value

In case of error -1, check Error property, otherwise the number of objects deleted.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationshipType Class
ItemRelationshipType Members
Overload List


%%PageItemTitle%%

DeleteDB(DbManager) Method
[image]
dotnetCART Namespace > ItemRelationshipType Class > DeleteDB Method : DeleteDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function DeleteDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int DeleteDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationshipType Class
ItemRelationshipType Members
Overload List


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > ItemRelationshipType Class : Error Property

Gets the error object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationshipType Class
ItemRelationshipType Members


%%PageItemTitle%%

GetCustom Method
[image]
dotnetCART Namespace > ItemRelationshipType Class : GetCustom Method

This method returns the value of a custom field based on its name in the customs collection.

Overload List

Overload | Description
GetCustom(String) | This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<ItemRelationshipType, Int64>)
GetCustom(Int32) | This method returns the value of a custom field based on its index in the customs collection. (Inherited from dotnetCART.DbTableCart<ItemRelationshipType, Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationshipType Class
ItemRelationshipType Members


%%PageItemTitle%%

GetCustom(Int32) Method
[image]
dotnetCART Namespace > ItemRelationshipType Class > GetCustom Method : GetCustom(Int32) Method

customIndex
This method returns the value of a custom field based on its index in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal customIndex As Integer _
) As Object
C#
public object GetCustom(
   int customIndex
)

Parameters

customIndex

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationshipType Class
ItemRelationshipType Members
Overload List


%%PageItemTitle%%

GetCustom(String) Method
[image]
dotnetCART Namespace > ItemRelationshipType Class > GetCustom Method : GetCustom(String) Method

name
This method returns the value of a custom field based on its name in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal name As String _
) As Object
C#
public object GetCustom(
   string name
)

Parameters

name

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationshipType Class
ItemRelationshipType Members
Overload List


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > ItemRelationshipType Class : LoadDB Method

Loads this object from database using the ID property.

Overload List

Overload | Description
LoadDB(Int64) | (Inherited from dotnetCART.DbTableCart<ItemRelationshipType, Int64>)
LoadDB() | Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<ItemRelationshipType, Int64>)
Generic LoadDB() | (Inherited from dotnetDATA.DbTable<Int64>)
Generic LoadDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationshipType Class
ItemRelationshipType Members


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > ItemRelationshipType Class > LoadDB Method : LoadDB() Method

Loads this object from database using the ID property.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB() As Integer
C#
public virtual int LoadDB()

Return Value

In case of error -1, check Error property, if the object with the ID property not found 0, otherwise 1.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationshipType Class
ItemRelationshipType Members
Overload List


%%PageItemTitle%%

LoadDB(Int64) Method
[image]
dotnetCART Namespace > ItemRelationshipType Class > LoadDB Method : LoadDB(Int64) Method

id

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal id As Long _
) As Integer
C#
public virtual int LoadDB(
   long id
)

Parameters

id

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationshipType Class
ItemRelationshipType Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB() Method
See Also
[image]
dotnetCART Namespace > ItemRelationshipType Class > LoadDB Method : Generic LoadDB() Method

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)() As Integer
C#
public virtual int LoadDB<T1>()where T1: IDbTable

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationshipType Class
ItemRelationshipType Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB(DbManager) Method
See Also
[image]
dotnetCART Namespace > ItemRelationshipType Class > LoadDB Method : Generic LoadDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int LoadDB<T1>(
   DbManager manager
)where T1: IDbTable

Parameters

manager

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationshipType Class
ItemRelationshipType Members
Overload List


%%PageItemTitle%%

SaveDB Method
[image]
dotnetCART Namespace > ItemRelationshipType Class : SaveDB Method

Inserts or updates this object into the database.

Overload List

Overload | Description
SaveDB() | Inserts or updates this object into the database. (Inherited from dotnetCART.DbTableCart<ItemRelationshipType, Int64>)
SaveDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationshipType Class
ItemRelationshipType Members


%%PageItemTitle%%

SaveDB() Method
[image]
dotnetCART Namespace > ItemRelationshipType Class > SaveDB Method : SaveDB() Method

Inserts or updates this object into the database.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function SaveDB() As Integer
C#
public virtual int SaveDB()

Return Value

Returns the generated ID or 1 for the update, returns -1 if failed. For the reason of fail, check the Generic DbTableCart.Error property.

Remarks

If Generic DbTableCart.ID greater than 0, it updates the associated object in the table, otherwise inserts a new object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationshipType Class
ItemRelationshipType Members
Overload List


%%PageItemTitle%%

SaveDB(DbManager) Method
[image]
dotnetCART Namespace > ItemRelationshipType Class > SaveDB Method : SaveDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function SaveDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int SaveDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationshipType Class
ItemRelationshipType Members
Overload List


%%PageItemTitle%%

SetCustom Method
[image]
dotnetCART Namespace > ItemRelationshipType Class : SetCustom Method

name
newValue
This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added.

Syntax

Visual Basic (Declaration)
Public Function SetCustom( _
   ByVal name As String, _
   ByVal newValue As Object _
) As Object
C#
public object SetCustom(
   string name,
   object newValue
)

Parameters

name
newValue

Return Value

Returns the new custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ItemRelationshipType Class
ItemRelationshipType Members


%%PageItemTitle%% $$Properties$$

Items Class Properties
[image]
dotnetCART Namespace : Items Class

For a list of all members of this type, see Items members.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from dotnetCART.ListBase<Item>)
Public Property | Count | Gets the number of elements actually contained in the collection. (Inherited from dotnetCART.ListBase<Item>)
Public Property | Error | Returns an object with the error information. (Inherited from dotnetCART.ListBase<Item>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from dotnetCART.ListBase<Item>)
Top

See Also

Reference

Items Class
dotnetCART Namespace


%%PageItemTitle%%

AddRange Method
[image]
dotnetCART Namespace > Items Class : AddRange Method

collection
Adds the elements of the specified collection to the end of the collection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal collection As IEnumerable(Of Item) _
)
C#
public void AddRange(
   IEnumerable<Item> collection
)

Parameters

collection

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members


%%PageItemTitle%%

AsReadOnly Method
[image]
dotnetCART Namespace > Items Class : AsReadOnly Method

Returns a read-only IList wrapper for the current collection.

Syntax

Visual Basic (Declaration)
Public Function AsReadOnly() As ReadOnlyCollection(Of Item)
C#
public ReadOnlyCollection<Item> AsReadOnly()

Return Value

A ReadOnlyCollection that acts as a read-only wrapper around the current List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members


%%PageItemTitle%%

BinarySearch Method
[image]
dotnetCART Namespace > Items Class : BinarySearch Method

Overload List

Overload | Description
BinarySearch(Item) | (Inherited from dotnetCART.ListBase<Item>)
BinarySearch(Item,Generic IComparer) | (Inherited from dotnetCART.ListBase<Item>)
BinarySearch(Int32,Int32,Item,Generic IComparer) | (Inherited from dotnetCART.ListBase<Item>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members


%%PageItemTitle%%

BinarySearch(Int32,Int32,Item,Generic IComparer) Method
[image]
dotnetCART Namespace > Items Class > BinarySearch Method : BinarySearch(Int32,Int32,Item,Generic IComparer) Method

index
count
item
comparer

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal index As Integer, _
   ByVal count As Integer, _
   ByVal item As Item, _
   ByVal comparer As IComparer(Of Item) _
) As Integer
C#
public int BinarySearch(
   int index,
   int count,
   Item item,
   IComparer<Item> comparer
)

Parameters

index
count
item
comparer

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members
Overload List


%%PageItemTitle%%

BinarySearch(Item) Method
[image]
dotnetCART Namespace > Items Class > BinarySearch Method : BinarySearch(Item) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal item As Item _
) As Integer
C#
public int BinarySearch(
   Item item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members
Overload List


%%PageItemTitle%%

BinarySearch(Item,Generic IComparer) Method
[image]
dotnetCART Namespace > Items Class > BinarySearch Method : BinarySearch(Item,Generic IComparer) Method

item
comparer

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal item As Item, _
   ByVal comparer As IComparer(Of Item) _
) As Integer
C#
public int BinarySearch(
   Item item,
   IComparer<Item> comparer
)

Parameters

item
comparer

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members
Overload List


%%PageItemTitle%%

Capacity Property
[image]
dotnetCART Namespace > Items Class : Capacity Property

Gets or sets the total number of elements the internal data structure can hold without resizing.

Syntax

Visual Basic (Declaration)
Public Property Capacity As Integer
C#
public int Capacity {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > Items Class : Clear Method

Removes all elements from the List.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members


%%PageItemTitle%%

Contains Method
[image]
dotnetCART Namespace > Items Class : Contains Method

item
Determines whether an element is in the List.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal item As Item _
) As Boolean
C#
public bool Contains(
   Item item
)

Parameters

item

Return Value

true if item is found in the List; otherwise, false.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members


%%PageItemTitle%%

CopyTo Method
[image]
dotnetCART Namespace > Items Class : CopyTo Method

Overload List

Overload | Description
CopyTo(Item[]) | (Inherited from dotnetCART.ListBase<Item>)
CopyTo(Item[],Int32) | (Inherited from dotnetCART.ListBase<Item>)
CopyTo(Int32,Item[],Int32,Int32) | (Inherited from dotnetCART.ListBase<Item>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members


%%PageItemTitle%%

CopyTo(Int32,Item[],Int32,Int32) Method
[image]
dotnetCART Namespace > Items Class > CopyTo Method : CopyTo(Int32,Item[],Int32,Int32) Method

index
array
arrayIndex
count

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal index As Integer, _
   ByVal array() As Item, _
   ByVal arrayIndex As Integer, _
   ByVal count As Integer _
)
C#
public void CopyTo(
   int index,
   Item[] array,
   int arrayIndex,
   int count
)

Parameters

index
array
arrayIndex
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members
Overload List


%%PageItemTitle%%

CopyTo(Item[]) Method
[image]
dotnetCART Namespace > Items Class > CopyTo Method : CopyTo(Item[]) Method

array

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array() As Item _
)
C#
public void CopyTo(
   Item[] array
)

Parameters

array

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members
Overload List


%%PageItemTitle%%

CopyTo(Item[],Int32) Method
[image]
dotnetCART Namespace > Items Class > CopyTo Method : CopyTo(Item[],Int32) Method

array
arrayIndex

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array() As Item, _
   ByVal arrayIndex As Integer _
)
C#
public void CopyTo(
   Item[] array,
   int arrayIndex
)

Parameters

array
arrayIndex

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members
Overload List


%%PageItemTitle%%

Count Property
[image]
dotnetCART Namespace > Items Class : Count Property

Gets the number of elements actually contained in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > Items Class : Error Property

Returns an object with the error information.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members


%%PageItemTitle%%

GetEnumerator Method
[image]
dotnetCART Namespace > Items Class : GetEnumerator Method

Returns an enumerator that iterates through the List.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As List.Enumerator(Of Item)
C#
public List.Enumerator<Item> GetEnumerator()

Return Value

A List.Enumerator for the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members


%%PageItemTitle%%

IndexOf Method
[image]
dotnetCART Namespace > Items Class : IndexOf Method

Overload List

Overload | Description
IndexOf(Item) | (Inherited from dotnetCART.ListBase<Item>)
IndexOf(Item,Int32) | (Inherited from dotnetCART.ListBase<Item>)
IndexOf(Item,Int32,Int32) | (Inherited from dotnetCART.ListBase<Item>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members


%%PageItemTitle%%

IndexOf(Item) Method
[image]
dotnetCART Namespace > Items Class > IndexOf Method : IndexOf(Item) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As Item _
) As Integer
C#
public int IndexOf(
   Item item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members
Overload List


%%PageItemTitle%%

IndexOf(Item,Int32) Method
[image]
dotnetCART Namespace > Items Class > IndexOf Method : IndexOf(Item,Int32) Method

item
index

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As Item, _
   ByVal index As Integer _
) As Integer
C#
public int IndexOf(
   Item item,
   int index
)

Parameters

item
index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members
Overload List


%%PageItemTitle%%

IndexOf(Item,Int32,Int32) Method
[image]
dotnetCART Namespace > Items Class > IndexOf Method : IndexOf(Item,Int32,Int32) Method

item
index
count

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As Item, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
C#
public int IndexOf(
   Item item,
   int index,
   int count
)

Parameters

item
index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members
Overload List


%%PageItemTitle%%

Insert Method
[image]
dotnetCART Namespace > Items Class : Insert Method

index
item
Inserts an element into the List at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As Item _
)
C#
public void Insert(
   int index,
   Item item
)

Parameters

index
item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members


%%PageItemTitle%%

InsertRange Method
[image]
dotnetCART Namespace > Items Class : InsertRange Method

index
collection
Inserts the elements of a collection into the List at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub InsertRange( _
   ByVal index As Integer, _
   ByVal collection As IEnumerable(Of Item) _
)
C#
public void InsertRange(
   int index,
   IEnumerable<Item> collection
)

Parameters

index
collection

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members


%%PageItemTitle%%

Item Property
[image]
dotnetCART Namespace > Items Class : Item Property

index
Gets or sets the element at the specified index.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As Item
C#
public Item this[
   int index
]; {get; set;}

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members


%%PageItemTitle%%

LastIndexOf Method
[image]
dotnetCART Namespace > Items Class : LastIndexOf Method

Overload List

Overload | Description
LastIndexOf(Item) | (Inherited from dotnetCART.ListBase<Item>)
LastIndexOf(Item,Int32) | (Inherited from dotnetCART.ListBase<Item>)
LastIndexOf(Item,Int32,Int32) | (Inherited from dotnetCART.ListBase<Item>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members


%%PageItemTitle%%

LastIndexOf(Item) Method
[image]
dotnetCART Namespace > Items Class > LastIndexOf Method : LastIndexOf(Item) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As Item _
) As Integer
C#
public int LastIndexOf(
   Item item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members
Overload List


%%PageItemTitle%%

LastIndexOf(Item,Int32) Method
[image]
dotnetCART Namespace > Items Class > LastIndexOf Method : LastIndexOf(Item,Int32) Method

item
index

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As Item, _
   ByVal index As Integer _
) As Integer
C#
public int LastIndexOf(
   Item item,
   int index
)

Parameters

item
index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members
Overload List


%%PageItemTitle%%

LastIndexOf(Item,Int32,Int32) Method
[image]
dotnetCART Namespace > Items Class > LastIndexOf Method : LastIndexOf(Item,Int32,Int32) Method

item
index
count

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As Item, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
C#
public int LastIndexOf(
   Item item,
   int index,
   int count
)

Parameters

item
index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members
Overload List


%%PageItemTitle%%

LoadDB(Where) Method
[image]
dotnetCART Namespace > Items Class > LoadDB Method : LoadDB(Where) Method

whereClause
Loads all the items from its associated table based on the where clause.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal whereClause As Where _
) As Integer
C#
public virtual int LoadDB(
   Where whereClause
)

Parameters

whereClause

Return Value

The total number of items have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members
Overload List


%%PageItemTitle%%

Remove Method
[image]
dotnetCART Namespace > Items Class : Remove Method

item
Removes the first occurrence of a specific object from the List.

Syntax

Visual Basic (Declaration)
Public Function Remove( _
   ByVal item As Item _
) As Boolean
C#
public bool Remove(
   Item item
)

Parameters

item

Return Value

true if item is successfully removed; otherwise, false. This method also returns false if item was not found in the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members


%%PageItemTitle%%

RemoveAll Method
[image]
dotnetCART Namespace > Items Class : RemoveAll Method

match
Removes the all the elements that match the conditions defined by the specified predicate.

Syntax

Visual Basic (Declaration)
Public Function RemoveAll( _
   ByVal match As Predicate(Of Item) _
) As Integer
C#
public int RemoveAll(
   Predicate<Item> match
)

Parameters

match

Return Value

The number of elements removed from the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members


%%PageItemTitle%%

RemoveAt Method
[image]
dotnetCART Namespace > Items Class : RemoveAt Method

index
Removes the element at the specified index of the List.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members


%%PageItemTitle%%

RemoveRange Method
[image]
dotnetCART Namespace > Items Class : RemoveRange Method

index
count
Removes a range of elements from the List.

Syntax

Visual Basic (Declaration)
Public Sub RemoveRange( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
C#
public void RemoveRange(
   int index,
   int count
)

Parameters

index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members


%%PageItemTitle%%

Reverse Method
[image]
dotnetCART Namespace > Items Class : Reverse Method

Reverses the order of the elements in the entire List.

Overload List

Overload | Description
Reverse() | Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<Item>)
Reverse(Int32,Int32) | Reverses the order of the elements in the specified range. (Inherited from dotnetCART.ListBase<Item>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members


%%PageItemTitle%%

Reverse() Method
[image]
dotnetCART Namespace > Items Class > Reverse Method : Reverse() Method

Reverses the order of the elements in the entire List.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Reverse()
C#
public void Reverse()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members
Overload List


%%PageItemTitle%%

Reverse(Int32,Int32) Method
[image]
dotnetCART Namespace > Items Class > Reverse Method : Reverse(Int32,Int32) Method

index
count
Reverses the order of the elements in the specified range.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Reverse( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
C#
public void Reverse(
   int index,
   int count
)

Parameters

index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Items Class
Items Members
Overload List


%%PageItemTitle%%

Custom Property
[image]
dotnetCART Namespace > Item Class : Custom Property

Gets or sets a custom object. For more information see custom fields

Syntax

Visual Basic (Declaration)
Public Property Custom As Custom
C#
public Custom Custom {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

CustomFields Property
See Also Example
[image]
dotnetCART Namespace > Item Class : CustomFields Property

Gets or sets a the names of custom fields for a table associated with the object.

Syntax

Visual Basic (Declaration)
Public Property CustomFields As String
C#
public string CustomFields {get; set;}

Example

C# Copy Code
Customer.CustomFields = "CellPhone,Favorites";

Visual Basic Copy Code
Customer.CustomFields = "CellPhone,Favorites"

Remarks

Custom fields must be added to the table manualy. Custom fields are usually set at store level using CustomFields

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

Customs Property
[image]
dotnetCART Namespace > Item Class : Customs Property

A reference to the collection of the Custom objects.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Customs As Customs
C#
public Customs Customs {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

DeleteDB(DbManager) Method
[image]
dotnetCART Namespace > Item Class > DeleteDB Method : DeleteDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function DeleteDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int DeleteDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members
Overload List


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > Item Class : Error Property

Gets the error object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

GetCustom Method
[image]
dotnetCART Namespace > Item Class : GetCustom Method

This method returns the value of a custom field based on its name in the customs collection.

Overload List

Overload | Description
GetCustom(String) | This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<Item, String>)
GetCustom(Int32) | This method returns the value of a custom field based on its index in the customs collection. (Inherited from dotnetCART.DbTableCart<Item, String>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%%

GetCustom(Int32) Method
[image]
dotnetCART Namespace > Item Class > GetCustom Method : GetCustom(Int32) Method

customIndex
This method returns the value of a custom field based on its index in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal customIndex As Integer _
) As Object
C#
public object GetCustom(
   int customIndex
)

Parameters

customIndex

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members
Overload List


%%PageItemTitle%%

GetCustom(String) Method
[image]
dotnetCART Namespace > Item Class > GetCustom Method : GetCustom(String) Method

name
This method returns the value of a custom field based on its name in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal name As String _
) As Object
C#
public object GetCustom(
   string name
)

Parameters

name

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB() Method
See Also
[image]
dotnetCART Namespace > Item Class > LoadDB Method : Generic LoadDB() Method

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)() As Integer
C#
public virtual int LoadDB<T1>()where T1: IDbTable

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB(DbManager) Method
See Also
[image]
dotnetCART Namespace > Item Class > LoadDB Method : Generic LoadDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int LoadDB<T1>(
   DbManager manager
)where T1: IDbTable

Parameters

manager

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members
Overload List


%%PageItemTitle%%

SaveDB(DbManager) Method
[image]
dotnetCART Namespace > Item Class > SaveDB Method : SaveDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function SaveDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int SaveDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members
Overload List


%%PageItemTitle%%

SetCustom Method
[image]
dotnetCART Namespace > Item Class : SetCustom Method

name
newValue
This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added.

Syntax

Visual Basic (Declaration)
Public Function SetCustom( _
   ByVal name As String, _
   ByVal newValue As Object _
) As Object
C#
public object SetCustom(
   string name,
   object newValue
)

Parameters

name
newValue

Return Value

Returns the new custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Item Class
Item Members


%%PageItemTitle%% $$Properties$$

LocationTypes Class Properties
[image]
dotnetCART Namespace : LocationTypes Class

For a list of all members of this type, see LocationTypes members.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from dotnetCART.ListBase<LocationType>)
Public Property | Count | Gets the number of elements actually contained in the collection. (Inherited from dotnetCART.ListBase<LocationType>)
Public Property | Error | Returns an object with the error information. (Inherited from dotnetCART.ListBase<LocationType>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from dotnetCART.ListBase<LocationType>)
Top

See Also

Reference

LocationTypes Class
dotnetCART Namespace


%%PageItemTitle%%

Add Method
[image]
dotnetCART Namespace > LocationTypes Class : Add Method

item
Adds an object to the end of the collection.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal item As LocationType _
)
C#
public void Add(
   LocationType item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationTypes Class
LocationTypes Members


%%PageItemTitle%%

AddRange Method
[image]
dotnetCART Namespace > LocationTypes Class : AddRange Method

collection
Adds the elements of the specified collection to the end of the collection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal collection As IEnumerable(Of LocationType) _
)
C#
public void AddRange(
   IEnumerable<LocationType> collection
)

Parameters

collection

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationTypes Class
LocationTypes Members


%%PageItemTitle%%

AsReadOnly Method
[image]
dotnetCART Namespace > LocationTypes Class : AsReadOnly Method

Returns a read-only IList wrapper for the current collection.

Syntax

Visual Basic (Declaration)
Public Function AsReadOnly() As ReadOnlyCollection(Of LocationType)
C#
public ReadOnlyCollection<LocationType> AsReadOnly()

Return Value

A ReadOnlyCollection that acts as a read-only wrapper around the current List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationTypes Class
LocationTypes Members


%%PageItemTitle%%

BinarySearch Method
[image]
dotnetCART Namespace > LocationTypes Class : BinarySearch Method

Overload List

Overload | Description
BinarySearch(LocationType) | (Inherited from dotnetCART.ListBase<LocationType>)
BinarySearch(LocationType,Generic IComparer) | (Inherited from dotnetCART.ListBase<LocationType>)
BinarySearch(Int32,Int32,LocationType,Generic IComparer) | (Inherited from dotnetCART.ListBase<LocationType>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationTypes Class
LocationTypes Members


%%PageItemTitle%%

BinarySearch(Int32,Int32,LocationType,Generic IComparer) Method
See Also
[image]
dotnetCART Namespace > LocationTypes Class > BinarySearch Method : BinarySearch(Int32,Int32,LocationType,Generic IComparer) Method

index
count
item
comparer

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal index As Integer, _
   ByVal count As Integer, _
   ByVal item As LocationType, _
   ByVal comparer As IComparer(Of LocationType) _
) As Integer
C#
public int BinarySearch(
   int index,
   int count,
   LocationType item,
   IComparer<LocationType> comparer
)

Parameters

index
count
item
comparer

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationTypes Class
LocationTypes Members
Overload List


%%PageItemTitle%%

BinarySearch(LocationType) Method
[image]
dotnetCART Namespace > LocationTypes Class > BinarySearch Method : BinarySearch(LocationType) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal item As LocationType _
) As Integer
C#
public int BinarySearch(
   LocationType item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationTypes Class
LocationTypes Members
Overload List


%%PageItemTitle%%

BinarySearch(LocationType,Generic IComparer) Method
[image]
dotnetCART Namespace > LocationTypes Class > BinarySearch Method : BinarySearch(LocationType,Generic IComparer) Method

item
comparer

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal item As LocationType, _
   ByVal comparer As IComparer(Of LocationType) _
) As Integer
C#
public int BinarySearch(
   LocationType item,
   IComparer<LocationType> comparer
)

Parameters

item
comparer

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationTypes Class
LocationTypes Members
Overload List


%%PageItemTitle%%

Capacity Property
[image]
dotnetCART Namespace > LocationTypes Class : Capacity Property

Gets or sets the total number of elements the internal data structure can hold without resizing.

Syntax

Visual Basic (Declaration)
Public Property Capacity As Integer
C#
public int Capacity {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationTypes Class
LocationTypes Members


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > LocationTypes Class : Clear Method

Removes all elements from the List.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationTypes Class
LocationTypes Members


%%PageItemTitle%%

Contains Method
[image]
dotnetCART Namespace > LocationTypes Class : Contains Method

item
Determines whether an element is in the List.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal item As LocationType _
) As Boolean
C#
public bool Contains(
   LocationType item
)

Parameters

item

Return Value

true if item is found in the List; otherwise, false.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationTypes Class
LocationTypes Members


%%PageItemTitle%%

CopyTo Method
[image]
dotnetCART Namespace > LocationTypes Class : CopyTo Method

Overload List

Overload | Description
CopyTo(LocationType[]) | (Inherited from dotnetCART.ListBase<LocationType>)
CopyTo(LocationType[],Int32) | (Inherited from dotnetCART.ListBase<LocationType>)
CopyTo(Int32,LocationType[],Int32,Int32) | (Inherited from dotnetCART.ListBase<LocationType>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationTypes Class
LocationTypes Members


%%PageItemTitle%%

CopyTo(Int32,LocationType[],Int32,Int32) Method
[image]
dotnetCART Namespace > LocationTypes Class > CopyTo Method : CopyTo(Int32,LocationType[],Int32,Int32) Method

index
array
arrayIndex
count

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal index As Integer, _
   ByVal array() As LocationType, _
   ByVal arrayIndex As Integer, _
   ByVal count As Integer _
)
C#
public void CopyTo(
   int index,
   LocationType[] array,
   int arrayIndex,
   int count
)

Parameters

index
array
arrayIndex
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationTypes Class
LocationTypes Members
Overload List


%%PageItemTitle%%

CopyTo(LocationType[]) Method
[image]
dotnetCART Namespace > LocationTypes Class > CopyTo Method : CopyTo(LocationType[]) Method

array

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array() As LocationType _
)
C#
public void CopyTo(
   LocationType[] array
)

Parameters

array

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationTypes Class
LocationTypes Members
Overload List


%%PageItemTitle%%

CopyTo(LocationType[],Int32) Method
[image]
dotnetCART Namespace > LocationTypes Class > CopyTo Method : CopyTo(LocationType[],Int32) Method

array
arrayIndex

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array() As LocationType, _
   ByVal arrayIndex As Integer _
)
C#
public void CopyTo(
   LocationType[] array,
   int arrayIndex
)

Parameters

array
arrayIndex

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationTypes Class
LocationTypes Members
Overload List


%%PageItemTitle%%

Count Property
[image]
dotnetCART Namespace > LocationTypes Class : Count Property

Gets the number of elements actually contained in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationTypes Class
LocationTypes Members


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > LocationTypes Class : Error Property

Returns an object with the error information.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationTypes Class
LocationTypes Members


%%PageItemTitle%%

GetEnumerator Method
[image]
dotnetCART Namespace > LocationTypes Class : GetEnumerator Method

Returns an enumerator that iterates through the List.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As List.Enumerator(Of LocationType)
C#
public List.Enumerator<LocationType> GetEnumerator()

Return Value

A List.Enumerator for the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationTypes Class
LocationTypes Members


%%PageItemTitle%%

IndexOf Method
[image]
dotnetCART Namespace > LocationTypes Class : IndexOf Method

Overload List

Overload | Description
IndexOf(LocationType) | (Inherited from dotnetCART.ListBase<LocationType>)
IndexOf(LocationType,Int32) | (Inherited from dotnetCART.ListBase<LocationType>)
IndexOf(LocationType,Int32,Int32) | (Inherited from dotnetCART.ListBase<LocationType>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationTypes Class
LocationTypes Members


%%PageItemTitle%%

IndexOf(LocationType) Method
[image]
dotnetCART Namespace > LocationTypes Class > IndexOf Method : IndexOf(LocationType) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As LocationType _
) As Integer
C#
public int IndexOf(
   LocationType item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationTypes Class
LocationTypes Members
Overload List


%%PageItemTitle%%

IndexOf(LocationType,Int32) Method
[image]
dotnetCART Namespace > LocationTypes Class > IndexOf Method : IndexOf(LocationType,Int32) Method

item
index

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As LocationType, _
   ByVal index As Integer _
) As Integer
C#
public int IndexOf(
   LocationType item,
   int index
)

Parameters

item
index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationTypes Class
LocationTypes Members
Overload List


%%PageItemTitle%%

IndexOf(LocationType,Int32,Int32) Method
[image]
dotnetCART Namespace > LocationTypes Class > IndexOf Method : IndexOf(LocationType,Int32,Int32) Method

item
index
count

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As LocationType, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
C#
public int IndexOf(
   LocationType item,
   int index,
   int count
)

Parameters

item
index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationTypes Class
LocationTypes Members
Overload List


%%PageItemTitle%%

Insert Method
[image]
dotnetCART Namespace > LocationTypes Class : Insert Method

index
item
Inserts an element into the List at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As LocationType _
)
C#
public void Insert(
   int index,
   LocationType item
)

Parameters

index
item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationTypes Class
LocationTypes Members


%%PageItemTitle%%

InsertRange Method
[image]
dotnetCART Namespace > LocationTypes Class : InsertRange Method

index
collection
Inserts the elements of a collection into the List at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub InsertRange( _
   ByVal index As Integer, _
   ByVal collection As IEnumerable(Of LocationType) _
)
C#
public void InsertRange(
   int index,
   IEnumerable<LocationType> collection
)

Parameters

index
collection

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationTypes Class
LocationTypes Members


%%PageItemTitle%%

Item Property
[image]
dotnetCART Namespace > LocationTypes Class : Item Property

index
Gets or sets the element at the specified index.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As LocationType
C#
public LocationType this[
   int index
]; {get; set;}

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationTypes Class
LocationTypes Members


%%PageItemTitle%%

LastIndexOf Method
[image]
dotnetCART Namespace > LocationTypes Class : LastIndexOf Method

Overload List

Overload | Description
LastIndexOf(LocationType) | (Inherited from dotnetCART.ListBase<LocationType>)
LastIndexOf(LocationType,Int32) | (Inherited from dotnetCART.ListBase<LocationType>)
LastIndexOf(LocationType,Int32,Int32) | (Inherited from dotnetCART.ListBase<LocationType>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationTypes Class
LocationTypes Members


%%PageItemTitle%%

LastIndexOf(LocationType) Method
[image]
dotnetCART Namespace > LocationTypes Class > LastIndexOf Method : LastIndexOf(LocationType) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As LocationType _
) As Integer
C#
public int LastIndexOf(
   LocationType item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationTypes Class
LocationTypes Members
Overload List


%%PageItemTitle%%

LastIndexOf(LocationType,Int32) Method
[image]
dotnetCART Namespace > LocationTypes Class > LastIndexOf Method : LastIndexOf(LocationType,Int32) Method

item
index

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As LocationType, _
   ByVal index As Integer _
) As Integer
C#
public int LastIndexOf(
   LocationType item,
   int index
)

Parameters

item
index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationTypes Class
LocationTypes Members
Overload List


%%PageItemTitle%%

LastIndexOf(LocationType,Int32,Int32) Method
[image]
dotnetCART Namespace > LocationTypes Class > LastIndexOf Method : LastIndexOf(LocationType,Int32,Int32) Method

item
index
count

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As LocationType, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
C#
public int LastIndexOf(
   LocationType item,
   int index,
   int count
)

Parameters

item
index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationTypes Class
LocationTypes Members
Overload List


%%PageItemTitle%%

LoadDB(Int32,Int32) Method
[image]
dotnetCART Namespace > LocationTypes Class > LoadDB Method : LoadDB(Int32,Int32) Method

start
count
Loads the count number of elements from start value.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal start As Integer, _
   ByVal count As Integer _
) As Integer
C#
public virtual int LoadDB(
   int start,
   int count
)

Parameters

start
count

Return Value

The total number of elements have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationTypes Class
LocationTypes Members
Overload List


%%PageItemTitle%%

LoadDB(Where) Method
[image]
dotnetCART Namespace > LocationTypes Class > LoadDB Method : LoadDB(Where) Method

whereClause
Loads all the items from its associated table based on the where clause.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal whereClause As Where _
) As Integer
C#
public virtual int LoadDB(
   Where whereClause
)

Parameters

whereClause

Return Value

The total number of items have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationTypes Class
LocationTypes Members
Overload List


%%PageItemTitle%%

LoadDB(Where,Int32,Int32,String,OrderDirection) Method
[image]
dotnetCART Namespace > LocationTypes Class > LoadDB Method : LoadDB(Where,Int32,Int32,String,OrderDirection) Method

whereClause
count
start
orderBy
orderDirection
Loads all the items based on the parameters.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal whereClause As Where, _
   ByVal count As Integer, _
   ByVal start As Integer, _
   ByVal orderBy As String, _
   ByVal orderDirection As OrderDirection _
) As Integer
C#
public virtual int LoadDB(
   Where whereClause,
   int count,
   int start,
   string orderBy,
   OrderDirection orderDirection
)

Parameters

whereClause
count
start
orderBy
orderDirection

Return Value

The total number of items have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationTypes Class
LocationTypes Members
Overload List


%%PageItemTitle%%

Remove Method
[image]
dotnetCART Namespace > LocationTypes Class : Remove Method

item
Removes the first occurrence of a specific object from the List.

Syntax

Visual Basic (Declaration)
Public Function Remove( _
   ByVal item As LocationType _
) As Boolean
C#
public bool Remove(
   LocationType item
)

Parameters

item

Return Value

true if item is successfully removed; otherwise, false. This method also returns false if item was not found in the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationTypes Class
LocationTypes Members


%%PageItemTitle%%

RemoveAll Method
[image]
dotnetCART Namespace > LocationTypes Class : RemoveAll Method

match
Removes the all the elements that match the conditions defined by the specified predicate.

Syntax

Visual Basic (Declaration)
Public Function RemoveAll( _
   ByVal match As Predicate(Of LocationType) _
) As Integer
C#
public int RemoveAll(
   Predicate<LocationType> match
)

Parameters

match

Return Value

The number of elements removed from the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationTypes Class
LocationTypes Members


%%PageItemTitle%%

RemoveAt Method
[image]
dotnetCART Namespace > LocationTypes Class : RemoveAt Method

index
Removes the element at the specified index of the List.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationTypes Class
LocationTypes Members


%%PageItemTitle%%

RemoveRange Method
[image]
dotnetCART Namespace > LocationTypes Class : RemoveRange Method

index
count
Removes a range of elements from the List.

Syntax

Visual Basic (Declaration)
Public Sub RemoveRange( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
C#
public void RemoveRange(
   int index,
   int count
)

Parameters

index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationTypes Class
LocationTypes Members


%%PageItemTitle%%

Reverse Method
[image]
dotnetCART Namespace > LocationTypes Class : Reverse Method

Reverses the order of the elements in the entire List.

Overload List

Overload | Description
Reverse() | Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<LocationType>)
Reverse(Int32,Int32) | Reverses the order of the elements in the specified range. (Inherited from dotnetCART.ListBase<LocationType>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationTypes Class
LocationTypes Members


%%PageItemTitle%%

Reverse() Method
[image]
dotnetCART Namespace > LocationTypes Class > Reverse Method : Reverse() Method

Reverses the order of the elements in the entire List.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Reverse()
C#
public void Reverse()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationTypes Class
LocationTypes Members
Overload List


%%PageItemTitle%%

Reverse(Int32,Int32) Method
[image]
dotnetCART Namespace > LocationTypes Class > Reverse Method : Reverse(Int32,Int32) Method

index
count
Reverses the order of the elements in the specified range.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Reverse( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
C#
public void Reverse(
   int index,
   int count
)

Parameters

index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationTypes Class
LocationTypes Members
Overload List


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > LocationType Class : Clear Method

Initializes all the properties without recreating the object.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Clear()
C#
public virtual void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationType Class
LocationType Members


%%PageItemTitle%%

Custom Property
[image]
dotnetCART Namespace > LocationType Class : Custom Property

Gets or sets a custom object. For more information see custom fields

Syntax

Visual Basic (Declaration)
Public Property Custom As Custom
C#
public Custom Custom {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationType Class
LocationType Members


%%PageItemTitle%%

CustomFields Property
See Also Example
[image]
dotnetCART Namespace > LocationType Class : CustomFields Property

Gets or sets a the names of custom fields for a table associated with the object.

Syntax

Visual Basic (Declaration)
Public Property CustomFields As String
C#
public string CustomFields {get; set;}

Example

C# Copy Code
Customer.CustomFields = "CellPhone,Favorites";

Visual Basic Copy Code
Customer.CustomFields = "CellPhone,Favorites"

Remarks

Custom fields must be added to the table manualy. Custom fields are usually set at store level using CustomFields

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationType Class
LocationType Members


%%PageItemTitle%%

Customs Property
[image]
dotnetCART Namespace > LocationType Class : Customs Property

A reference to the collection of the Custom objects.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Customs As Customs
C#
public Customs Customs {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationType Class
LocationType Members


%%PageItemTitle%%

DeleteDB(DbManager) Method
[image]
dotnetCART Namespace > LocationType Class > DeleteDB Method : DeleteDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function DeleteDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int DeleteDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationType Class
LocationType Members
Overload List


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > LocationType Class : Error Property

Gets the error object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationType Class
LocationType Members


%%PageItemTitle%%

GetCustom Method
[image]
dotnetCART Namespace > LocationType Class : GetCustom Method

This method returns the value of a custom field based on its name in the customs collection.

Overload List

Overload | Description
GetCustom(String) | This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<LocationType, Int64>)
GetCustom(Int32) | This method returns the value of a custom field based on its index in the customs collection. (Inherited from dotnetCART.DbTableCart<LocationType, Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationType Class
LocationType Members


%%PageItemTitle%%

GetCustom(Int32) Method
[image]
dotnetCART Namespace > LocationType Class > GetCustom Method : GetCustom(Int32) Method

customIndex
This method returns the value of a custom field based on its index in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal customIndex As Integer _
) As Object
C#
public object GetCustom(
   int customIndex
)

Parameters

customIndex

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationType Class
LocationType Members
Overload List


%%PageItemTitle%%

GetCustom(String) Method
[image]
dotnetCART Namespace > LocationType Class > GetCustom Method : GetCustom(String) Method

name
This method returns the value of a custom field based on its name in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal name As String _
) As Object
C#
public object GetCustom(
   string name
)

Parameters

name

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationType Class
LocationType Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB() Method
See Also
[image]
dotnetCART Namespace > LocationType Class > LoadDB Method : Generic LoadDB() Method

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)() As Integer
C#
public virtual int LoadDB<T1>()where T1: IDbTable

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationType Class
LocationType Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB(DbManager) Method
See Also
[image]
dotnetCART Namespace > LocationType Class > LoadDB Method : Generic LoadDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int LoadDB<T1>(
   DbManager manager
)where T1: IDbTable

Parameters

manager

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationType Class
LocationType Members
Overload List


%%PageItemTitle%%

SaveDB(DbManager) Method
[image]
dotnetCART Namespace > LocationType Class > SaveDB Method : SaveDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function SaveDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int SaveDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationType Class
LocationType Members
Overload List


%%PageItemTitle%%

SetCustom Method
[image]
dotnetCART Namespace > LocationType Class : SetCustom Method

name
newValue
This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added.

Syntax

Visual Basic (Declaration)
Public Function SetCustom( _
   ByVal name As String, _
   ByVal newValue As Object _
) As Object
C#
public object SetCustom(
   string name,
   object newValue
)

Parameters

name
newValue

Return Value

Returns the new custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

LocationType Class
LocationType Members


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > Location Class : Clear Method

Initializes all the properties without recreating the object.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Clear()
C#
public virtual void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Location Class
Location Members


%%PageItemTitle%%

Custom Property
[image]
dotnetCART Namespace > Location Class : Custom Property

Gets or sets a custom object. For more information see custom fields

Syntax

Visual Basic (Declaration)
Public Property Custom As Custom
C#
public Custom Custom {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Location Class
Location Members


%%PageItemTitle%%

CustomFields Property
See Also Example
[image]
dotnetCART Namespace > Location Class : CustomFields Property

Gets or sets a the names of custom fields for a table associated with the object.

Syntax

Visual Basic (Declaration)
Public Property CustomFields As String
C#
public string CustomFields {get; set;}

Example

C# Copy Code
Customer.CustomFields = "CellPhone,Favorites";

Visual Basic Copy Code
Customer.CustomFields = "CellPhone,Favorites"

Remarks

Custom fields must be added to the table manualy. Custom fields are usually set at store level using CustomFields

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Location Class
Location Members


%%PageItemTitle%%

Customs Property
[image]
dotnetCART Namespace > Location Class : Customs Property

A reference to the collection of the Custom objects.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Customs As Customs
C#
public Customs Customs {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Location Class
Location Members


%%PageItemTitle%%

DeleteDB Method
[image]
dotnetCART Namespace > Location Class : DeleteDB Method

Deletes this object with ID from the database.

Overload List

Overload | Description
DeleteDB() | Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<Location, Int64>)
DeleteDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Location Class
Location Members


%%PageItemTitle%%

DeleteDB() Method
[image]
dotnetCART Namespace > Location Class > DeleteDB Method : DeleteDB() Method

Deletes this object with ID from the database.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function DeleteDB() As Integer
C#
public virtual int DeleteDB()

Return Value

In case of error -1, check Error property, otherwise the number of objects deleted.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Location Class
Location Members
Overload List


%%PageItemTitle%%

DeleteDB(DbManager) Method
[image]
dotnetCART Namespace > Location Class > DeleteDB Method : DeleteDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function DeleteDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int DeleteDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Location Class
Location Members
Overload List


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > Location Class : Error Property

Gets the error object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Location Class
Location Members


%%PageItemTitle%%

GetCustom Method
[image]
dotnetCART Namespace > Location Class : GetCustom Method

This method returns the value of a custom field based on its name in the customs collection.

Overload List

Overload | Description
GetCustom(String) | This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<Location, Int64>)
GetCustom(Int32) | This method returns the value of a custom field based on its index in the customs collection. (Inherited from dotnetCART.DbTableCart<Location, Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Location Class
Location Members


%%PageItemTitle%%

GetCustom(Int32) Method
[image]
dotnetCART Namespace > Location Class > GetCustom Method : GetCustom(Int32) Method

customIndex
This method returns the value of a custom field based on its index in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal customIndex As Integer _
) As Object
C#
public object GetCustom(
   int customIndex
)

Parameters

customIndex

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Location Class
Location Members
Overload List


%%PageItemTitle%%

GetCustom(String) Method
[image]
dotnetCART Namespace > Location Class > GetCustom Method : GetCustom(String) Method

name
This method returns the value of a custom field based on its name in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal name As String _
) As Object
C#
public object GetCustom(
   string name
)

Parameters

name

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Location Class
Location Members
Overload List


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > Location Class > LoadDB Method : LoadDB() Method

Loads this object from database using the ID property.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB() As Integer
C#
public virtual int LoadDB()

Return Value

In case of error -1, check Error property, if the object with the ID property not found 0, otherwise 1.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Location Class
Location Members
Overload List


%%PageItemTitle%%

LoadDB(Int64) Method
[image]
dotnetCART Namespace > Location Class > LoadDB Method : LoadDB(Int64) Method

id

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal id As Long _
) As Integer
C#
public virtual int LoadDB(
   long id
)

Parameters

id

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Location Class
Location Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB() Method
See Also
[image]
dotnetCART Namespace > Location Class > LoadDB Method : Generic LoadDB() Method

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)() As Integer
C#
public virtual int LoadDB<T1>()where T1: IDbTable

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Location Class
Location Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB(DbManager) Method
See Also
[image]
dotnetCART Namespace > Location Class > LoadDB Method : Generic LoadDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int LoadDB<T1>(
   DbManager manager
)where T1: IDbTable

Parameters

manager

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Location Class
Location Members
Overload List


%%PageItemTitle%%

SaveDB() Method
[image]
dotnetCART Namespace > Location Class > SaveDB Method : SaveDB() Method

Inserts or updates this object into the database.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function SaveDB() As Integer
C#
public virtual int SaveDB()

Return Value

Returns the generated ID or 1 for the update, returns -1 if failed. For the reason of fail, check the Generic DbTableCart.Error property.

Remarks

If Generic DbTableCart.ID greater than 0, it updates the associated object in the table, otherwise inserts a new object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Location Class
Location Members
Overload List


%%PageItemTitle%%

SaveDB(DbManager) Method
[image]
dotnetCART Namespace > Location Class > SaveDB Method : SaveDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function SaveDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int SaveDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Location Class
Location Members
Overload List


%%PageItemTitle%%

SetCustom Method
[image]
dotnetCART Namespace > Location Class : SetCustom Method

name
newValue
This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added.

Syntax

Visual Basic (Declaration)
Public Function SetCustom( _
   ByVal name As String, _
   ByVal newValue As Object _
) As Object
C#
public object SetCustom(
   string name,
   object newValue
)

Parameters

name
newValue

Return Value

Returns the new custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Location Class
Location Members


%%PageItemTitle%%

ID Field
[image]
dotnetCART Namespace > MailLabel Class : ID Field

Syntax

Visual Basic (Declaration)
Public ID As String
C#
public string ID

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

MailLabel Class
MailLabel Members


%%PageItemTitle%%

TrackingCode Field
[image]
dotnetCART Namespace > MailLabel Class : TrackingCode Field

Syntax

Visual Basic (Declaration)
Public TrackingCode As String
C#
public string TrackingCode

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

MailLabel Class
MailLabel Members


%%PageItemTitle%%

URL Field
[image]
dotnetCART Namespace > MailLabel Class : URL Field

Syntax

Visual Basic (Declaration)
Public URL As String
C#
public string URL

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

MailLabel Class
MailLabel Members


%%PageItemTitle%%

Add(Option) Method
[image]
dotnetCART Namespace > Options Class > Add Method : Add(Option) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add( _
   ByVal item As Option _
)
C#
public void Add(
   Option item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Options Class
Options Members
Overload List


%%PageItemTitle%%

AddRange Method
[image]
dotnetCART Namespace > Options Class : AddRange Method

Adds the elements of the specified collection to the end of the collection.

Overload List

Overload | Description
AddRange(Option[]) | (Inherited from dotnetDATA.EntitySet<Option>)
AddRange(Generic EntitySet) | Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetDATA.EntitySet<Option>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Options Class
Options Members


%%PageItemTitle%%

AddRange(Generic EntitySet) Method
[image]
dotnetCART Namespace > Options Class > AddRange Method : AddRange(Generic EntitySet) Method

items
Adds the elements of the specified collection to the end of the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddRange( _
   ByVal items As EntitySet(Of Option) _
)
C#
public void AddRange(
   EntitySet<Option> items
)

Parameters

items

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Options Class
Options Members
Overload List


%%PageItemTitle%%

AddRange(Option[]) Method
[image]
dotnetCART Namespace > Options Class > AddRange Method : AddRange(Option[]) Method

items

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddRange( _
   ByVal items() As Option _
)
C#
public void AddRange(
   Option[] items
)

Parameters

items

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Options Class
Options Members
Overload List


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > Options Class : Clear Method

Removes all elements from the List.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Options Class
Options Members


%%PageItemTitle%%

Contains Method
[image]
dotnetCART Namespace > Options Class : Contains Method

item
Determines whether an element is in the List.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal item As Option _
) As Boolean
C#
public bool Contains(
   Option item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Options Class
Options Members


%%PageItemTitle%%

Count Property
[image]
dotnetCART Namespace > Options Class : Count Property

Returns the number of items in the collection.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Count As Integer
C#
public virtual int Count {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Options Class
Options Members


%%PageItemTitle%%

IndexOf Method
[image]
dotnetCART Namespace > Options Class : IndexOf Method

item
Returns the index of this item in the list.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal item As Option _
) As Integer
C#
public int IndexOf(
   Option item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Options Class
Options Members


%%PageItemTitle%%

Insert Method
[image]
dotnetCART Namespace > Options Class : Insert Method

index
item
Inserts an element into the List at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As Option _
)
C#
public void Insert(
   int index,
   Option item
)

Parameters

index
item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Options Class
Options Members


%%PageItemTitle%%

Remove Method
[image]
dotnetCART Namespace > Options Class : Remove Method

item
Removes the item from the collection.

Syntax

Visual Basic (Declaration)
Public Function Remove( _
   ByVal item As Option _
) As Boolean
C#
public bool Remove(
   Option item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Options Class
Options Members


%%PageItemTitle%%

RemoveAt Method
[image]
dotnetCART Namespace > Options Class : RemoveAt Method

index
Removes the element at the specified index of the List.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Options Class
Options Members


%%PageItemTitle%%

Custom Property
[image]
dotnetCART Namespace > Option Class : Custom Property

Gets or sets a custom object. For more information see custom fields

Syntax

Visual Basic (Declaration)
Public Property Custom As Custom
C#
public Custom Custom {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Option Class
Option Members


%%PageItemTitle%%

CustomFields Property
See Also Example
[image]
dotnetCART Namespace > Option Class : CustomFields Property

Gets or sets a the names of custom fields for a table associated with the object.

Syntax

Visual Basic (Declaration)
Public Property CustomFields As String
C#
public string CustomFields {get; set;}

Example

C# Copy Code
Customer.CustomFields = "CellPhone,Favorites";

Visual Basic Copy Code
Customer.CustomFields = "CellPhone,Favorites"

Remarks

Custom fields must be added to the table manualy. Custom fields are usually set at store level using CustomFields

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Option Class
Option Members


%%PageItemTitle%%

Customs Property
[image]
dotnetCART Namespace > Option Class : Customs Property

A reference to the collection of the Custom objects.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Customs As Customs
C#
public Customs Customs {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Option Class
Option Members


%%PageItemTitle%%

DeleteDB() Method
[image]
dotnetCART Namespace > Option Class > DeleteDB Method : DeleteDB() Method

Deletes this object with ID from the database.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function DeleteDB() As Integer
C#
public virtual int DeleteDB()

Return Value

In case of error -1, check Error property, otherwise the number of objects deleted.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Option Class
Option Members
Overload List


%%PageItemTitle%%

DeleteDB(DbManager) Method
[image]
dotnetCART Namespace > Option Class > DeleteDB Method : DeleteDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function DeleteDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int DeleteDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Option Class
Option Members
Overload List


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > Option Class : Error Property

Gets the error object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Option Class
Option Members


%%PageItemTitle%%

GetCustom Method
[image]
dotnetCART Namespace > Option Class : GetCustom Method

This method returns the value of a custom field based on its name in the customs collection.

Overload List

Overload | Description
GetCustom(String) | This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<Option, Int64>)
GetCustom(Int32) | This method returns the value of a custom field based on its index in the customs collection. (Inherited from dotnetCART.DbTableCart<Option, Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Option Class
Option Members


%%PageItemTitle%%

GetCustom(Int32) Method
[image]
dotnetCART Namespace > Option Class > GetCustom Method : GetCustom(Int32) Method

customIndex
This method returns the value of a custom field based on its index in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal customIndex As Integer _
) As Object
C#
public object GetCustom(
   int customIndex
)

Parameters

customIndex

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Option Class
Option Members
Overload List


%%PageItemTitle%%

GetCustom(String) Method
[image]
dotnetCART Namespace > Option Class > GetCustom Method : GetCustom(String) Method

name
This method returns the value of a custom field based on its name in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal name As String _
) As Object
C#
public object GetCustom(
   string name
)

Parameters

name

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Option Class
Option Members
Overload List


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > Option Class : LoadDB Method

Loads this object from database using the ID property.

Overload List

Overload | Description
LoadDB(Int64) | (Inherited from dotnetCART.DbTableCart<Option, Int64>)
LoadDB() | Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<Option, Int64>)
Generic LoadDB() | (Inherited from dotnetDATA.DbTable<Int64>)
Generic LoadDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Option Class
Option Members


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > Option Class > LoadDB Method : LoadDB() Method

Loads this object from database using the ID property.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB() As Integer
C#
public virtual int LoadDB()

Return Value

In case of error -1, check Error property, if the object with the ID property not found 0, otherwise 1.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Option Class
Option Members
Overload List


%%PageItemTitle%%

LoadDB(Int64) Method
[image]
dotnetCART Namespace > Option Class > LoadDB Method : LoadDB(Int64) Method

id

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal id As Long _
) As Integer
C#
public virtual int LoadDB(
   long id
)

Parameters

id

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Option Class
Option Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB() Method
See Also
[image]
dotnetCART Namespace > Option Class > LoadDB Method : Generic LoadDB() Method

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)() As Integer
C#
public virtual int LoadDB<T1>()where T1: IDbTable

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Option Class
Option Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB(DbManager) Method
See Also
[image]
dotnetCART Namespace > Option Class > LoadDB Method : Generic LoadDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int LoadDB<T1>(
   DbManager manager
)where T1: IDbTable

Parameters

manager

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Option Class
Option Members
Overload List


%%PageItemTitle%%

SaveDB(DbManager) Method
[image]
dotnetCART Namespace > Option Class > SaveDB Method : SaveDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function SaveDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int SaveDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Option Class
Option Members
Overload List


%%PageItemTitle%%

SetCustom Method
[image]
dotnetCART Namespace > Option Class : SetCustom Method

name
newValue
This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added.

Syntax

Visual Basic (Declaration)
Public Function SetCustom( _
   ByVal name As String, _
   ByVal newValue As Object _
) As Object
C#
public object SetCustom(
   string name,
   object newValue
)

Parameters

name
newValue

Return Value

Returns the new custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Option Class
Option Members


%%PageItemTitle%%

City Property
[image]
dotnetCART Namespace > OrderAddress Class : City Property

Gets or sets this address's city.

Syntax

Visual Basic (Declaration)
Public Property City As String
C#
public string City {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderAddress Class
OrderAddress Members


%%PageItemTitle%%

Country Property
[image]
dotnetCART Namespace > OrderAddress Class : Country Property

Gets or sets this address's county.

Syntax

Visual Basic (Declaration)
Public Property Country As String
C#
public string Country {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderAddress Class
OrderAddress Members


%%PageItemTitle%%

Custom Property
[image]
dotnetCART Namespace > OrderAddress Class : Custom Property

Gets or sets a custom object. For more information see custom fields

Syntax

Visual Basic (Declaration)
Public Property Custom As Custom
C#
public Custom Custom {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderAddress Class
OrderAddress Members


%%PageItemTitle%%

CustomFields Property
See Also Example
[image]
dotnetCART Namespace > OrderAddress Class : CustomFields Property

Gets or sets a the names of custom fields for a table associated with the object.

Syntax

Visual Basic (Declaration)
Public Property CustomFields As String
C#
public string CustomFields {get; set;}

Example

C# Copy Code
Customer.CustomFields = "CellPhone,Favorites";

Visual Basic Copy Code
Customer.CustomFields = "CellPhone,Favorites"

Remarks

Custom fields must be added to the table manualy. Custom fields are usually set at store level using CustomFields

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderAddress Class
OrderAddress Members


%%PageItemTitle%%

Customs Property
[image]
dotnetCART Namespace > OrderAddress Class : Customs Property

A reference to the collection of the Custom objects.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Customs As Customs
C#
public Customs Customs {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderAddress Class
OrderAddress Members


%%PageItemTitle%%

DeleteDB Method
[image]
dotnetCART Namespace > OrderAddress Class : DeleteDB Method

Deletes this object with ID from the database.

Overload List

Overload | Description
DeleteDB() | Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<OrderAddress, Int64>)
DeleteDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderAddress Class
OrderAddress Members


%%PageItemTitle%%

DeleteDB() Method
[image]
dotnetCART Namespace > OrderAddress Class > DeleteDB Method : DeleteDB() Method

Deletes this object with ID from the database.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function DeleteDB() As Integer
C#
public virtual int DeleteDB()

Return Value

In case of error -1, check Error property, otherwise the number of objects deleted.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderAddress Class
OrderAddress Members
Overload List


%%PageItemTitle%%

DeleteDB(DbManager) Method
[image]
dotnetCART Namespace > OrderAddress Class > DeleteDB Method : DeleteDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function DeleteDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int DeleteDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderAddress Class
OrderAddress Members
Overload List


%%PageItemTitle%%

Email Property
[image]
dotnetCART Namespace > OrderAddress Class : Email Property

Gets or sets this address's email.

Syntax

Visual Basic (Declaration)
Public Property Email As String
C#
public string Email {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderAddress Class
OrderAddress Members


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > OrderAddress Class : Error Property

Gets the error object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderAddress Class
OrderAddress Members


%%PageItemTitle%%

Fax Property
[image]
dotnetCART Namespace > OrderAddress Class : Fax Property

Gets or sets this address's fax.

Syntax

Visual Basic (Declaration)
Public Property Fax As String
C#
public string Fax {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderAddress Class
OrderAddress Members


%%PageItemTitle%%

GetCustom Method
[image]
dotnetCART Namespace > OrderAddress Class : GetCustom Method

This method returns the value of a custom field based on its name in the customs collection.

Overload List

Overload | Description
GetCustom(String) | This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<OrderAddress, Int64>)
GetCustom(Int32) | This method returns the value of a custom field based on its index in the customs collection. (Inherited from dotnetCART.DbTableCart<OrderAddress, Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderAddress Class
OrderAddress Members


%%PageItemTitle%%

GetCustom(Int32) Method
[image]
dotnetCART Namespace > OrderAddress Class > GetCustom Method : GetCustom(Int32) Method

customIndex
This method returns the value of a custom field based on its index in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal customIndex As Integer _
) As Object
C#
public object GetCustom(
   int customIndex
)

Parameters

customIndex

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderAddress Class
OrderAddress Members
Overload List


%%PageItemTitle%%

GetCustom(String) Method
[image]
dotnetCART Namespace > OrderAddress Class > GetCustom Method : GetCustom(String) Method

name
This method returns the value of a custom field based on its name in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal name As String _
) As Object
C#
public object GetCustom(
   string name
)

Parameters

name

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderAddress Class
OrderAddress Members
Overload List


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > OrderAddress Class : LoadDB Method

Loads this object from database using the ID property.

Overload List

Overload | Description
LoadDB(Int64) | (Inherited from dotnetCART.DbTableCart<OrderAddress, Int64>)
LoadDB() | Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<OrderAddress, Int64>)
Generic LoadDB() | (Inherited from dotnetDATA.DbTable<Int64>)
Generic LoadDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderAddress Class
OrderAddress Members


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > OrderAddress Class > LoadDB Method : LoadDB() Method

Loads this object from database using the ID property.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB() As Integer
C#
public virtual int LoadDB()

Return Value

In case of error -1, check Error property, if the object with the ID property not found 0, otherwise 1.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderAddress Class
OrderAddress Members
Overload List


%%PageItemTitle%%

LoadDB(Int64) Method
[image]
dotnetCART Namespace > OrderAddress Class > LoadDB Method : LoadDB(Int64) Method

id

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal id As Long _
) As Integer
C#
public virtual int LoadDB(
   long id
)

Parameters

id

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderAddress Class
OrderAddress Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB() Method
See Also
[image]
dotnetCART Namespace > OrderAddress Class > LoadDB Method : Generic LoadDB() Method

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)() As Integer
C#
public virtual int LoadDB<T1>()where T1: IDbTable

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderAddress Class
OrderAddress Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB(DbManager) Method
See Also
[image]
dotnetCART Namespace > OrderAddress Class > LoadDB Method : Generic LoadDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int LoadDB<T1>(
   DbManager manager
)where T1: IDbTable

Parameters

manager

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderAddress Class
OrderAddress Members
Overload List


%%PageItemTitle%%

Phone Property
[image]
dotnetCART Namespace > OrderAddress Class : Phone Property

Gets or sets this address's phone.

Syntax

Visual Basic (Declaration)
Public Property Phone As String
C#
public string Phone {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderAddress Class
OrderAddress Members


%%PageItemTitle%%

Residential Property
[image]
dotnetCART Namespace > OrderAddress Class : Residential Property

Gets or sets a boolean that specifies whether this address is residential or not.

Syntax

Visual Basic (Declaration)
Public Property Residential As Boolean
C#
public bool Residential {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderAddress Class
OrderAddress Members


%%PageItemTitle%%

SaveDB Method
[image]
dotnetCART Namespace > OrderAddress Class : SaveDB Method

Inserts or updates this object into the database.

Overload List

Overload | Description
SaveDB() | Inserts or updates this object into the database. (Inherited from dotnetCART.DbTableCart<OrderAddress, Int64>)
SaveDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderAddress Class
OrderAddress Members


%%PageItemTitle%%

SaveDB() Method
[image]
dotnetCART Namespace > OrderAddress Class > SaveDB Method : SaveDB() Method

Inserts or updates this object into the database.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function SaveDB() As Integer
C#
public virtual int SaveDB()

Return Value

Returns the generated ID or 1 for the update, returns -1 if failed. For the reason of fail, check the Generic DbTableCart.Error property.

Remarks

If Generic DbTableCart.ID greater than 0, it updates the associated object in the table, otherwise inserts a new object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderAddress Class
OrderAddress Members
Overload List


%%PageItemTitle%%

SaveDB(DbManager) Method
[image]
dotnetCART Namespace > OrderAddress Class > SaveDB Method : SaveDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function SaveDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int SaveDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderAddress Class
OrderAddress Members
Overload List


%%PageItemTitle%%

SetCustom Method
[image]
dotnetCART Namespace > OrderAddress Class : SetCustom Method

name
newValue
This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added.

Syntax

Visual Basic (Declaration)
Public Function SetCustom( _
   ByVal name As String, _
   ByVal newValue As Object _
) As Object
C#
public object SetCustom(
   string name,
   object newValue
)

Parameters

name
newValue

Return Value

Returns the new custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderAddress Class
OrderAddress Members


%%PageItemTitle%%

StateProvince Property
[image]
dotnetCART Namespace > OrderAddress Class : StateProvince Property

Gets or sets this address's state.

Syntax

Visual Basic (Declaration)
Public Property StateProvince As String
C#
public string StateProvince {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderAddress Class
OrderAddress Members


%%PageItemTitle%%

Street Property
[image]
dotnetCART Namespace > OrderAddress Class : Street Property

Gets or sets this address's street.

Syntax

Visual Basic (Declaration)
Public Property Street As String
C#
public string Street {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderAddress Class
OrderAddress Members


%%PageItemTitle%%

ZipPostal Property
[image]
dotnetCART Namespace > OrderAddress Class : ZipPostal Property

Gets or sets this address's zip postal code.

Syntax

Visual Basic (Declaration)
Public Property ZipPostal As String
C#
public string ZipPostal {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderAddress Class
OrderAddress Members


%%PageItemTitle%% $$Methods$$

OrderCoupons Class Methods
[image]
dotnetCART Namespace : OrderCoupons Class

For a list of all members of this type, see OrderCoupons members.

Public Methods

 | Name | Description
Public Method | Add | Add the newItem to this collection. (Inherited from dotnetDATA.EntitySet<OrderCoupon>)
Public Method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetDATA.EntitySet<OrderCoupon>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetDATA.EntitySet<OrderCoupon>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetDATA.EntitySet<OrderCoupon>)
Public Method | IndexOf | Returns the index of this item in the list. (Inherited from dotnetDATA.EntitySet<OrderCoupon>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetDATA.EntitySet<OrderCoupon>)
Public Method | Remove | Removes the item from the collection. (Inherited from dotnetDATA.EntitySet<OrderCoupon>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetDATA.EntitySet<OrderCoupon>)
Top

See Also

Reference

OrderCoupons Class
dotnetCART Namespace


%%PageItemTitle%% $$Properties$$

OrderCoupons Class Properties
[image]
dotnetCART Namespace : OrderCoupons Class

For a list of all members of this type, see OrderCoupons members.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of items in the collection. (Inherited from dotnetDATA.EntitySet<OrderCoupon>)
Public Property | Item | Gets the element at the specified index. (Inherited from dotnetDATA.EntitySet<OrderCoupon>)
Top

See Also

Reference

OrderCoupons Class
dotnetCART Namespace


%%PageItemTitle%%

Add Method
[image]
dotnetCART Namespace > OrderCoupons Class : Add Method

item
Add the newItem to this collection.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal item As OrderCoupon _
)
C#
public void Add(
   OrderCoupon item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderCoupons Class
OrderCoupons Members


%%PageItemTitle%%

AddRange Method
[image]
dotnetCART Namespace > OrderCoupons Class : AddRange Method

Adds the elements of the specified collection to the end of the collection.

Overload List

Overload | Description
AddRange(OrderCoupon[]) | (Inherited from dotnetDATA.EntitySet<OrderCoupon>)
AddRange(Generic EntitySet) | Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetDATA.EntitySet<OrderCoupon>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderCoupons Class
OrderCoupons Members


%%PageItemTitle%%

AddRange(Generic EntitySet) Method
[image]
dotnetCART Namespace > OrderCoupons Class > AddRange Method : AddRange(Generic EntitySet) Method

items
Adds the elements of the specified collection to the end of the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddRange( _
   ByVal items As EntitySet(Of OrderCoupon) _
)
C#
public void AddRange(
   EntitySet<OrderCoupon> items
)

Parameters

items

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderCoupons Class
OrderCoupons Members
Overload List


%%PageItemTitle%%

AddRange(OrderCoupon[]) Method
[image]
dotnetCART Namespace > OrderCoupons Class > AddRange Method : AddRange(OrderCoupon[]) Method

items

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddRange( _
   ByVal items() As OrderCoupon _
)
C#
public void AddRange(
   OrderCoupon[] items
)

Parameters

items

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderCoupons Class
OrderCoupons Members
Overload List


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > OrderCoupons Class : Clear Method

Removes all elements from the List.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderCoupons Class
OrderCoupons Members


%%PageItemTitle%%

Contains Method
[image]
dotnetCART Namespace > OrderCoupons Class : Contains Method

item
Determines whether an element is in the List.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal item As OrderCoupon _
) As Boolean
C#
public bool Contains(
   OrderCoupon item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderCoupons Class
OrderCoupons Members


%%PageItemTitle%%

Count Property
[image]
dotnetCART Namespace > OrderCoupons Class : Count Property

Returns the number of items in the collection.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Count As Integer
C#
public virtual int Count {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderCoupons Class
OrderCoupons Members


%%PageItemTitle%%

IndexOf Method
[image]
dotnetCART Namespace > OrderCoupons Class : IndexOf Method

item
Returns the index of this item in the list.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal item As OrderCoupon _
) As Integer
C#
public int IndexOf(
   OrderCoupon item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderCoupons Class
OrderCoupons Members


%%PageItemTitle%%

Insert Method
[image]
dotnetCART Namespace > OrderCoupons Class : Insert Method

index
item
Inserts an element into the List at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As OrderCoupon _
)
C#
public void Insert(
   int index,
   OrderCoupon item
)

Parameters

index
item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderCoupons Class
OrderCoupons Members


%%PageItemTitle%%

Item Property
[image]
dotnetCART Namespace > OrderCoupons Class : Item Property

index
Gets the element at the specified index.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As OrderCoupon
C#
public OrderCoupon this[
   int index
]; {get; set;}

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderCoupons Class
OrderCoupons Members


%%PageItemTitle%%

Remove Method
[image]
dotnetCART Namespace > OrderCoupons Class : Remove Method

item
Removes the item from the collection.

Syntax

Visual Basic (Declaration)
Public Function Remove( _
   ByVal item As OrderCoupon _
) As Boolean
C#
public bool Remove(
   OrderCoupon item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderCoupons Class
OrderCoupons Members


%%PageItemTitle%%

RemoveAt Method
[image]
dotnetCART Namespace > OrderCoupons Class : RemoveAt Method

index
Removes the element at the specified index of the List.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderCoupons Class
OrderCoupons Members


%%PageItemTitle%%

Custom Property
[image]
dotnetCART Namespace > OrderCoupon Class : Custom Property

Gets or sets a custom object. For more information see custom fields

Syntax

Visual Basic (Declaration)
Public Property Custom As Custom
C#
public Custom Custom {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderCoupon Class
OrderCoupon Members


%%PageItemTitle%%

CustomFields Property
See Also Example
[image]
dotnetCART Namespace > OrderCoupon Class : CustomFields Property

Gets or sets a the names of custom fields for a table associated with the object.

Syntax

Visual Basic (Declaration)
Public Property CustomFields As String
C#
public string CustomFields {get; set;}

Example

C# Copy Code
Customer.CustomFields = "CellPhone,Favorites";

Visual Basic Copy Code
Customer.CustomFields = "CellPhone,Favorites"

Remarks

Custom fields must be added to the table manualy. Custom fields are usually set at store level using CustomFields

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderCoupon Class
OrderCoupon Members


%%PageItemTitle%%

Customs Property
[image]
dotnetCART Namespace > OrderCoupon Class : Customs Property

A reference to the collection of the Custom objects.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Customs As Customs
C#
public Customs Customs {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderCoupon Class
OrderCoupon Members


%%PageItemTitle%%

DeleteDB Method
[image]
dotnetCART Namespace > OrderCoupon Class : DeleteDB Method

Deletes this object with ID from the database.

Overload List

Overload | Description
DeleteDB() | Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<OrderCoupon, Int64>)
DeleteDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderCoupon Class
OrderCoupon Members


%%PageItemTitle%%

DeleteDB() Method
[image]
dotnetCART Namespace > OrderCoupon Class > DeleteDB Method : DeleteDB() Method

Deletes this object with ID from the database.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function DeleteDB() As Integer
C#
public virtual int DeleteDB()

Return Value

In case of error -1, check Error property, otherwise the number of objects deleted.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderCoupon Class
OrderCoupon Members
Overload List


%%PageItemTitle%%

DeleteDB(DbManager) Method
[image]
dotnetCART Namespace > OrderCoupon Class > DeleteDB Method : DeleteDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function DeleteDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int DeleteDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderCoupon Class
OrderCoupon Members
Overload List


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > OrderCoupon Class : Error Property

Gets the error object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderCoupon Class
OrderCoupon Members


%%PageItemTitle%%

GetCustom Method
[image]
dotnetCART Namespace > OrderCoupon Class : GetCustom Method

This method returns the value of a custom field based on its name in the customs collection.

Overload List

Overload | Description
GetCustom(String) | This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<OrderCoupon, Int64>)
GetCustom(Int32) | This method returns the value of a custom field based on its index in the customs collection. (Inherited from dotnetCART.DbTableCart<OrderCoupon, Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderCoupon Class
OrderCoupon Members


%%PageItemTitle%%

GetCustom(Int32) Method
[image]
dotnetCART Namespace > OrderCoupon Class > GetCustom Method : GetCustom(Int32) Method

customIndex
This method returns the value of a custom field based on its index in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal customIndex As Integer _
) As Object
C#
public object GetCustom(
   int customIndex
)

Parameters

customIndex

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderCoupon Class
OrderCoupon Members
Overload List


%%PageItemTitle%%

GetCustom(String) Method
[image]
dotnetCART Namespace > OrderCoupon Class > GetCustom Method : GetCustom(String) Method

name
This method returns the value of a custom field based on its name in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal name As String _
) As Object
C#
public object GetCustom(
   string name
)

Parameters

name

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderCoupon Class
OrderCoupon Members
Overload List


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > OrderCoupon Class : LoadDB Method

Loads this object from database using the ID property.

Overload List

Overload | Description
LoadDB(Int64) | (Inherited from dotnetCART.DbTableCart<OrderCoupon, Int64>)
LoadDB() | Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<OrderCoupon, Int64>)
Generic LoadDB() | (Inherited from dotnetDATA.DbTable<Int64>)
Generic LoadDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderCoupon Class
OrderCoupon Members


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > OrderCoupon Class > LoadDB Method : LoadDB() Method

Loads this object from database using the ID property.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB() As Integer
C#
public virtual int LoadDB()

Return Value

In case of error -1, check Error property, if the object with the ID property not found 0, otherwise 1.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderCoupon Class
OrderCoupon Members
Overload List


%%PageItemTitle%%

LoadDB(Int64) Method
[image]
dotnetCART Namespace > OrderCoupon Class > LoadDB Method : LoadDB(Int64) Method

id

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal id As Long _
) As Integer
C#
public virtual int LoadDB(
   long id
)

Parameters

id

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderCoupon Class
OrderCoupon Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB() Method
See Also
[image]
dotnetCART Namespace > OrderCoupon Class > LoadDB Method : Generic LoadDB() Method

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)() As Integer
C#
public virtual int LoadDB<T1>()where T1: IDbTable

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderCoupon Class
OrderCoupon Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB(DbManager) Method
See Also
[image]
dotnetCART Namespace > OrderCoupon Class > LoadDB Method : Generic LoadDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int LoadDB<T1>(
   DbManager manager
)where T1: IDbTable

Parameters

manager

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderCoupon Class
OrderCoupon Members
Overload List


%%PageItemTitle%%

SaveDB Method
[image]
dotnetCART Namespace > OrderCoupon Class : SaveDB Method

Inserts or updates this object into the database.

Overload List

Overload | Description
SaveDB() | Inserts or updates this object into the database. (Inherited from dotnetCART.DbTableCart<OrderCoupon, Int64>)
SaveDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderCoupon Class
OrderCoupon Members


%%PageItemTitle%%

SaveDB() Method
[image]
dotnetCART Namespace > OrderCoupon Class > SaveDB Method : SaveDB() Method

Inserts or updates this object into the database.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function SaveDB() As Integer
C#
public virtual int SaveDB()

Return Value

Returns the generated ID or 1 for the update, returns -1 if failed. For the reason of fail, check the Generic DbTableCart.Error property.

Remarks

If Generic DbTableCart.ID greater than 0, it updates the associated object in the table, otherwise inserts a new object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderCoupon Class
OrderCoupon Members
Overload List


%%PageItemTitle%%

SaveDB(DbManager) Method
[image]
dotnetCART Namespace > OrderCoupon Class > SaveDB Method : SaveDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function SaveDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int SaveDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderCoupon Class
OrderCoupon Members
Overload List


%%PageItemTitle%%

SetCustom Method
[image]
dotnetCART Namespace > OrderCoupon Class : SetCustom Method

name
newValue
This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added.

Syntax

Visual Basic (Declaration)
Public Function SetCustom( _
   ByVal name As String, _
   ByVal newValue As Object _
) As Object
C#
public object SetCustom(
   string name,
   object newValue
)

Parameters

name
newValue

Return Value

Returns the new custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderCoupon Class
OrderCoupon Members


%%PageItemTitle%%

Add(OrderItemOption) Method
[image]
dotnetCART Namespace > OrderItemOptions Class > Add Method : Add(OrderItemOption) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add( _
   ByVal item As OrderItemOption _
)
C#
public void Add(
   OrderItemOption item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItemOptions Class
OrderItemOptions Members
Overload List


%%PageItemTitle%%

AddRange Method
[image]
dotnetCART Namespace > OrderItemOptions Class : AddRange Method

Adds the elements of the specified collection to the end of the collection.

Overload List

Overload | Description
AddRange(OrderItemOption[]) | (Inherited from dotnetDATA.EntitySet<OrderItemOption>)
AddRange(Generic EntitySet) | Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetDATA.EntitySet<OrderItemOption>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItemOptions Class
OrderItemOptions Members


%%PageItemTitle%%

AddRange(Generic EntitySet) Method
[image]
dotnetCART Namespace > OrderItemOptions Class > AddRange Method : AddRange(Generic EntitySet) Method

items
Adds the elements of the specified collection to the end of the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddRange( _
   ByVal items As EntitySet(Of OrderItemOption) _
)
C#
public void AddRange(
   EntitySet<OrderItemOption> items
)

Parameters

items

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItemOptions Class
OrderItemOptions Members
Overload List


%%PageItemTitle%%

AddRange(OrderItemOption[]) Method
[image]
dotnetCART Namespace > OrderItemOptions Class > AddRange Method : AddRange(OrderItemOption[]) Method

items

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddRange( _
   ByVal items() As OrderItemOption _
)
C#
public void AddRange(
   OrderItemOption[] items
)

Parameters

items

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItemOptions Class
OrderItemOptions Members
Overload List


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > OrderItemOptions Class : Clear Method

Removes all elements from the List.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItemOptions Class
OrderItemOptions Members


%%PageItemTitle%%

Contains Method
[image]
dotnetCART Namespace > OrderItemOptions Class : Contains Method

item
Determines whether an element is in the List.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal item As OrderItemOption _
) As Boolean
C#
public bool Contains(
   OrderItemOption item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItemOptions Class
OrderItemOptions Members


%%PageItemTitle%%

Count Property
[image]
dotnetCART Namespace > OrderItemOptions Class : Count Property

Returns the number of items in the collection.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Count As Integer
C#
public virtual int Count {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItemOptions Class
OrderItemOptions Members


%%PageItemTitle%%

IndexOf Method
[image]
dotnetCART Namespace > OrderItemOptions Class : IndexOf Method

item
Returns the index of this item in the list.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal item As OrderItemOption _
) As Integer
C#
public int IndexOf(
   OrderItemOption item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItemOptions Class
OrderItemOptions Members


%%PageItemTitle%%

Insert Method
[image]
dotnetCART Namespace > OrderItemOptions Class : Insert Method

index
item
Inserts an element into the List at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As OrderItemOption _
)
C#
public void Insert(
   int index,
   OrderItemOption item
)

Parameters

index
item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItemOptions Class
OrderItemOptions Members


%%PageItemTitle%%

Item(Int32) Property
[image]
dotnetCART Namespace > OrderItemOptions Class > Item Property : Item(Int32) Property

index
Gets the element at the specified index.

Syntax

Visual Basic (Declaration)
Public Overloads Property Item( _
   ByVal index As Integer _
) As OrderItemOption
C#
public OrderItemOption Item(
   int index
) {get; set;}

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItemOptions Class
OrderItemOptions Members
Overload List


%%PageItemTitle%%

Remove Method
[image]
dotnetCART Namespace > OrderItemOptions Class : Remove Method

item
Removes the item from the collection.

Syntax

Visual Basic (Declaration)
Public Function Remove( _
   ByVal item As OrderItemOption _
) As Boolean
C#
public bool Remove(
   OrderItemOption item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItemOptions Class
OrderItemOptions Members


%%PageItemTitle%%

RemoveAt Method
[image]
dotnetCART Namespace > OrderItemOptions Class : RemoveAt Method

index
Removes the element at the specified index of the List.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItemOptions Class
OrderItemOptions Members


%%PageItemTitle%%

Custom Property
[image]
dotnetCART Namespace > OrderItemOption Class : Custom Property

Gets or sets a custom object. For more information see custom fields

Syntax

Visual Basic (Declaration)
Public Property Custom As Custom
C#
public Custom Custom {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItemOption Class
OrderItemOption Members


%%PageItemTitle%%

CustomFields Property
See Also Example
[image]
dotnetCART Namespace > OrderItemOption Class : CustomFields Property

Gets or sets a the names of custom fields for a table associated with the object.

Syntax

Visual Basic (Declaration)
Public Property CustomFields As String
C#
public string CustomFields {get; set;}

Example

C# Copy Code
Customer.CustomFields = "CellPhone,Favorites";

Visual Basic Copy Code
Customer.CustomFields = "CellPhone,Favorites"

Remarks

Custom fields must be added to the table manualy. Custom fields are usually set at store level using CustomFields

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItemOption Class
OrderItemOption Members


%%PageItemTitle%%

Customs Property
[image]
dotnetCART Namespace > OrderItemOption Class : Customs Property

A reference to the collection of the Custom objects.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Customs As Customs
C#
public Customs Customs {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItemOption Class
OrderItemOption Members


%%PageItemTitle%%

DeleteDB Method
[image]
dotnetCART Namespace > OrderItemOption Class : DeleteDB Method

Deletes this object with ID from the database.

Overload List

Overload | Description
DeleteDB() | Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<OrderItemOption, Int64>)
DeleteDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItemOption Class
OrderItemOption Members


%%PageItemTitle%%

DeleteDB() Method
[image]
dotnetCART Namespace > OrderItemOption Class > DeleteDB Method : DeleteDB() Method

Deletes this object with ID from the database.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function DeleteDB() As Integer
C#
public virtual int DeleteDB()

Return Value

In case of error -1, check Error property, otherwise the number of objects deleted.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItemOption Class
OrderItemOption Members
Overload List


%%PageItemTitle%%

DeleteDB(DbManager) Method
[image]
dotnetCART Namespace > OrderItemOption Class > DeleteDB Method : DeleteDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function DeleteDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int DeleteDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItemOption Class
OrderItemOption Members
Overload List


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > OrderItemOption Class : Error Property

Gets the error object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItemOption Class
OrderItemOption Members


%%PageItemTitle%%

GetCustom Method
[image]
dotnetCART Namespace > OrderItemOption Class : GetCustom Method

This method returns the value of a custom field based on its name in the customs collection.

Overload List

Overload | Description
GetCustom(String) | This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<OrderItemOption, Int64>)
GetCustom(Int32) | This method returns the value of a custom field based on its index in the customs collection. (Inherited from dotnetCART.DbTableCart<OrderItemOption, Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItemOption Class
OrderItemOption Members


%%PageItemTitle%%

GetCustom(Int32) Method
[image]
dotnetCART Namespace > OrderItemOption Class > GetCustom Method : GetCustom(Int32) Method

customIndex
This method returns the value of a custom field based on its index in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal customIndex As Integer _
) As Object
C#
public object GetCustom(
   int customIndex
)

Parameters

customIndex

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItemOption Class
OrderItemOption Members
Overload List


%%PageItemTitle%%

GetCustom(String) Method
[image]
dotnetCART Namespace > OrderItemOption Class > GetCustom Method : GetCustom(String) Method

name
This method returns the value of a custom field based on its name in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal name As String _
) As Object
C#
public object GetCustom(
   string name
)

Parameters

name

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItemOption Class
OrderItemOption Members
Overload List


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > OrderItemOption Class : LoadDB Method

Loads this object from database using the ID property.

Overload List

Overload | Description
LoadDB(Int64) | (Inherited from dotnetCART.DbTableCart<OrderItemOption, Int64>)
LoadDB() | Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<OrderItemOption, Int64>)
Generic LoadDB() | (Inherited from dotnetDATA.DbTable<Int64>)
Generic LoadDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItemOption Class
OrderItemOption Members


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > OrderItemOption Class > LoadDB Method : LoadDB() Method

Loads this object from database using the ID property.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB() As Integer
C#
public virtual int LoadDB()

Return Value

In case of error -1, check Error property, if the object with the ID property not found 0, otherwise 1.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItemOption Class
OrderItemOption Members
Overload List


%%PageItemTitle%%

LoadDB(Int64) Method
[image]
dotnetCART Namespace > OrderItemOption Class > LoadDB Method : LoadDB(Int64) Method

id

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal id As Long _
) As Integer
C#
public virtual int LoadDB(
   long id
)

Parameters

id

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItemOption Class
OrderItemOption Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB() Method
See Also
[image]
dotnetCART Namespace > OrderItemOption Class > LoadDB Method : Generic LoadDB() Method

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)() As Integer
C#
public virtual int LoadDB<T1>()where T1: IDbTable

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItemOption Class
OrderItemOption Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB(DbManager) Method
See Also
[image]
dotnetCART Namespace > OrderItemOption Class > LoadDB Method : Generic LoadDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int LoadDB<T1>(
   DbManager manager
)where T1: IDbTable

Parameters

manager

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItemOption Class
OrderItemOption Members
Overload List


%%PageItemTitle%%

SaveDB Method
[image]
dotnetCART Namespace > OrderItemOption Class : SaveDB Method

Inserts or updates this object into the database.

Overload List

Overload | Description
SaveDB() | Inserts or updates this object into the database. (Inherited from dotnetCART.DbTableCart<OrderItemOption, Int64>)
SaveDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItemOption Class
OrderItemOption Members


%%PageItemTitle%%

SaveDB() Method
[image]
dotnetCART Namespace > OrderItemOption Class > SaveDB Method : SaveDB() Method

Inserts or updates this object into the database.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function SaveDB() As Integer
C#
public virtual int SaveDB()

Return Value

Returns the generated ID or 1 for the update, returns -1 if failed. For the reason of fail, check the Generic DbTableCart.Error property.

Remarks

If Generic DbTableCart.ID greater than 0, it updates the associated object in the table, otherwise inserts a new object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItemOption Class
OrderItemOption Members
Overload List


%%PageItemTitle%%

SaveDB(DbManager) Method
[image]
dotnetCART Namespace > OrderItemOption Class > SaveDB Method : SaveDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function SaveDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int SaveDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItemOption Class
OrderItemOption Members
Overload List


%%PageItemTitle%%

SetCustom Method
[image]
dotnetCART Namespace > OrderItemOption Class : SetCustom Method

name
newValue
This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added.

Syntax

Visual Basic (Declaration)
Public Function SetCustom( _
   ByVal name As String, _
   ByVal newValue As Object _
) As Object
C#
public object SetCustom(
   string name,
   object newValue
)

Parameters

name
newValue

Return Value

Returns the new custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItemOption Class
OrderItemOption Members


%%PageItemTitle%% $$Properties$$

OrderItems Class Properties
[image]
dotnetCART Namespace : OrderItems Class

For a list of all members of this type, see OrderItems members.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of items in the collection. (Inherited from dotnetDATA.EntitySet<OrderItem>)
Public Property | Item | Gets the element at the specified index. (Inherited from dotnetDATA.EntitySet<OrderItem>)
Top

See Also

Reference

OrderItems Class
dotnetCART Namespace


%%PageItemTitle%%

AddRange Method
[image]
dotnetCART Namespace > OrderItems Class : AddRange Method

Adds the elements of the specified collection to the end of the collection.

Overload List

Overload | Description
AddRange(OrderItem[]) | (Inherited from dotnetDATA.EntitySet<OrderItem>)
AddRange(Generic EntitySet) | Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetDATA.EntitySet<OrderItem>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItems Class
OrderItems Members


%%PageItemTitle%%

AddRange(Generic EntitySet) Method
[image]
dotnetCART Namespace > OrderItems Class > AddRange Method : AddRange(Generic EntitySet) Method

items
Adds the elements of the specified collection to the end of the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddRange( _
   ByVal items As EntitySet(Of OrderItem) _
)
C#
public void AddRange(
   EntitySet<OrderItem> items
)

Parameters

items

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItems Class
OrderItems Members
Overload List


%%PageItemTitle%%

AddRange(OrderItem[]) Method
[image]
dotnetCART Namespace > OrderItems Class > AddRange Method : AddRange(OrderItem[]) Method

items

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddRange( _
   ByVal items() As OrderItem _
)
C#
public void AddRange(
   OrderItem[] items
)

Parameters

items

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItems Class
OrderItems Members
Overload List


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > OrderItems Class : Clear Method

Removes all elements from the List.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItems Class
OrderItems Members


%%PageItemTitle%%

Contains Method
[image]
dotnetCART Namespace > OrderItems Class : Contains Method

item
Determines whether an element is in the List.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal item As OrderItem _
) As Boolean
C#
public bool Contains(
   OrderItem item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItems Class
OrderItems Members


%%PageItemTitle%%

Count Property
[image]
dotnetCART Namespace > OrderItems Class : Count Property

Returns the number of items in the collection.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Count As Integer
C#
public virtual int Count {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItems Class
OrderItems Members


%%PageItemTitle%%

IndexOf Method
[image]
dotnetCART Namespace > OrderItems Class : IndexOf Method

item
Returns the index of this item in the list.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal item As OrderItem _
) As Integer
C#
public int IndexOf(
   OrderItem item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItems Class
OrderItems Members


%%PageItemTitle%%

Insert Method
[image]
dotnetCART Namespace > OrderItems Class : Insert Method

index
item
Inserts an element into the List at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As OrderItem _
)
C#
public void Insert(
   int index,
   OrderItem item
)

Parameters

index
item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItems Class
OrderItems Members


%%PageItemTitle%%

Item Property
[image]
dotnetCART Namespace > OrderItems Class : Item Property

index
Gets the element at the specified index.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As OrderItem
C#
public OrderItem this[
   int index
]; {get; set;}

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItems Class
OrderItems Members


%%PageItemTitle%%

Remove Method
[image]
dotnetCART Namespace > OrderItems Class : Remove Method

item
Removes the item from the collection.

Syntax

Visual Basic (Declaration)
Public Function Remove( _
   ByVal item As OrderItem _
) As Boolean
C#
public bool Remove(
   OrderItem item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItems Class
OrderItems Members


%%PageItemTitle%%

RemoveAt Method
[image]
dotnetCART Namespace > OrderItems Class : RemoveAt Method

index
Removes the element at the specified index of the List.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItems Class
OrderItems Members


%%PageItemTitle%%

Custom Property
[image]
dotnetCART Namespace > OrderItem Class : Custom Property

Gets or sets a custom object. For more information see custom fields

Syntax

Visual Basic (Declaration)
Public Property Custom As Custom
C#
public Custom Custom {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItem Class
OrderItem Members


%%PageItemTitle%%

CustomFields Property
See Also Example
[image]
dotnetCART Namespace > OrderItem Class : CustomFields Property

Gets or sets a the names of custom fields for a table associated with the object.

Syntax

Visual Basic (Declaration)
Public Property CustomFields As String
C#
public string CustomFields {get; set;}

Example

C# Copy Code
Customer.CustomFields = "CellPhone,Favorites";

Visual Basic Copy Code
Customer.CustomFields = "CellPhone,Favorites"

Remarks

Custom fields must be added to the table manualy. Custom fields are usually set at store level using CustomFields

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItem Class
OrderItem Members


%%PageItemTitle%%

Customs Property
[image]
dotnetCART Namespace > OrderItem Class : Customs Property

A reference to the collection of the Custom objects.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Customs As Customs
C#
public Customs Customs {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItem Class
OrderItem Members


%%PageItemTitle%%

DeleteDB Method
[image]
dotnetCART Namespace > OrderItem Class : DeleteDB Method

Deletes this object with ID from the database.

Overload List

Overload | Description
DeleteDB() | Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<OrderItem, Int64>)
DeleteDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItem Class
OrderItem Members


%%PageItemTitle%%

DeleteDB() Method
[image]
dotnetCART Namespace > OrderItem Class > DeleteDB Method : DeleteDB() Method

Deletes this object with ID from the database.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function DeleteDB() As Integer
C#
public virtual int DeleteDB()

Return Value

In case of error -1, check Error property, otherwise the number of objects deleted.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItem Class
OrderItem Members
Overload List


%%PageItemTitle%%

DeleteDB(DbManager) Method
[image]
dotnetCART Namespace > OrderItem Class > DeleteDB Method : DeleteDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function DeleteDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int DeleteDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItem Class
OrderItem Members
Overload List


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > OrderItem Class : Error Property

Gets the error object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItem Class
OrderItem Members


%%PageItemTitle%%

GetCustom Method
[image]
dotnetCART Namespace > OrderItem Class : GetCustom Method

This method returns the value of a custom field based on its name in the customs collection.

Overload List

Overload | Description
GetCustom(String) | This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<OrderItem, Int64>)
GetCustom(Int32) | This method returns the value of a custom field based on its index in the customs collection. (Inherited from dotnetCART.DbTableCart<OrderItem, Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItem Class
OrderItem Members


%%PageItemTitle%%

GetCustom(Int32) Method
[image]
dotnetCART Namespace > OrderItem Class > GetCustom Method : GetCustom(Int32) Method

customIndex
This method returns the value of a custom field based on its index in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal customIndex As Integer _
) As Object
C#
public object GetCustom(
   int customIndex
)

Parameters

customIndex

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItem Class
OrderItem Members
Overload List


%%PageItemTitle%%

GetCustom(String) Method
[image]
dotnetCART Namespace > OrderItem Class > GetCustom Method : GetCustom(String) Method

name
This method returns the value of a custom field based on its name in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal name As String _
) As Object
C#
public object GetCustom(
   string name
)

Parameters

name

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItem Class
OrderItem Members
Overload List


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > OrderItem Class : LoadDB Method

Loads this object from database using the ID property.

Overload List

Overload | Description
LoadDB(Int64) | (Inherited from dotnetCART.DbTableCart<OrderItem, Int64>)
LoadDB() | Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<OrderItem, Int64>)
Generic LoadDB() | (Inherited from dotnetDATA.DbTable<Int64>)
Generic LoadDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItem Class
OrderItem Members


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > OrderItem Class > LoadDB Method : LoadDB() Method

Loads this object from database using the ID property.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB() As Integer
C#
public virtual int LoadDB()

Return Value

In case of error -1, check Error property, if the object with the ID property not found 0, otherwise 1.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItem Class
OrderItem Members
Overload List


%%PageItemTitle%%

LoadDB(Int64) Method
[image]
dotnetCART Namespace > OrderItem Class > LoadDB Method : LoadDB(Int64) Method

id

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal id As Long _
) As Integer
C#
public virtual int LoadDB(
   long id
)

Parameters

id

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItem Class
OrderItem Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB() Method
See Also
[image]
dotnetCART Namespace > OrderItem Class > LoadDB Method : Generic LoadDB() Method

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)() As Integer
C#
public virtual int LoadDB<T1>()where T1: IDbTable

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItem Class
OrderItem Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB(DbManager) Method
See Also
[image]
dotnetCART Namespace > OrderItem Class > LoadDB Method : Generic LoadDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int LoadDB<T1>(
   DbManager manager
)where T1: IDbTable

Parameters

manager

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItem Class
OrderItem Members
Overload List


%%PageItemTitle%%

SaveDB(DbManager) Method
[image]
dotnetCART Namespace > OrderItem Class > SaveDB Method : SaveDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function SaveDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int SaveDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItem Class
OrderItem Members
Overload List


%%PageItemTitle%%

SetCustom Method
[image]
dotnetCART Namespace > OrderItem Class : SetCustom Method

name
newValue
This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added.

Syntax

Visual Basic (Declaration)
Public Function SetCustom( _
   ByVal name As String, _
   ByVal newValue As Object _
) As Object
C#
public object SetCustom(
   string name,
   object newValue
)

Parameters

name
newValue

Return Value

Returns the new custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderItem Class
OrderItem Members


%%PageItemTitle%%

AddRange Method
[image]
dotnetCART Namespace > Orders Class : AddRange Method

collection
Adds the elements of the specified collection to the end of the collection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal collection As IEnumerable(Of Order) _
)
C#
public void AddRange(
   IEnumerable<Order> collection
)

Parameters

collection

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Orders Class
Orders Members


%%PageItemTitle%%

AsReadOnly Method
[image]
dotnetCART Namespace > Orders Class : AsReadOnly Method

Returns a read-only IList wrapper for the current collection.

Syntax

Visual Basic (Declaration)
Public Function AsReadOnly() As ReadOnlyCollection(Of Order)
C#
public ReadOnlyCollection<Order> AsReadOnly()

Return Value

A ReadOnlyCollection that acts as a read-only wrapper around the current List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Orders Class
Orders Members


%%PageItemTitle%%

BinarySearch Method
[image]
dotnetCART Namespace > Orders Class : BinarySearch Method

Overload List

Overload | Description
BinarySearch(Order) | (Inherited from dotnetCART.ListBase<Order>)
BinarySearch(Order,Generic IComparer) | (Inherited from dotnetCART.ListBase<Order>)
BinarySearch(Int32,Int32,Order,Generic IComparer) | (Inherited from dotnetCART.ListBase<Order>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Orders Class
Orders Members


%%PageItemTitle%%

BinarySearch(Int32,Int32,Order,Generic IComparer) Method
[image]
dotnetCART Namespace > Orders Class > BinarySearch Method : BinarySearch(Int32,Int32,Order,Generic IComparer) Method

index
count
item
comparer

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal index As Integer, _
   ByVal count As Integer, _
   ByVal item As Order, _
   ByVal comparer As IComparer(Of Order) _
) As Integer
C#
public int BinarySearch(
   int index,
   int count,
   Order item,
   IComparer<Order> comparer
)

Parameters

index
count
item
comparer

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Orders Class
Orders Members
Overload List


%%PageItemTitle%%

BinarySearch(Order) Method
[image]
dotnetCART Namespace > Orders Class > BinarySearch Method : BinarySearch(Order) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal item As Order _
) As Integer
C#
public int BinarySearch(
   Order item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Orders Class
Orders Members
Overload List


%%PageItemTitle%%

BinarySearch(Order,Generic IComparer) Method
[image]
dotnetCART Namespace > Orders Class > BinarySearch Method : BinarySearch(Order,Generic IComparer) Method

item
comparer

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal item As Order, _
   ByVal comparer As IComparer(Of Order) _
) As Integer
C#
public int BinarySearch(
   Order item,
   IComparer<Order> comparer
)

Parameters

item
comparer

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Orders Class
Orders Members
Overload List


%%PageItemTitle%%

Capacity Property
[image]
dotnetCART Namespace > Orders Class : Capacity Property

Gets or sets the total number of elements the internal data structure can hold without resizing.

Syntax

Visual Basic (Declaration)
Public Property Capacity As Integer
C#
public int Capacity {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Orders Class
Orders Members


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > Orders Class : Clear Method

Removes all elements from the List.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Orders Class
Orders Members


%%PageItemTitle%%

Contains Method
[image]
dotnetCART Namespace > Orders Class : Contains Method

item
Determines whether an element is in the List.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal item As Order _
) As Boolean
C#
public bool Contains(
   Order item
)

Parameters

item

Return Value

true if item is found in the List; otherwise, false.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Orders Class
Orders Members


%%PageItemTitle%%

CopyTo Method
[image]
dotnetCART Namespace > Orders Class : CopyTo Method

Overload List

Overload | Description
CopyTo(Order[]) | (Inherited from dotnetCART.ListBase<Order>)
CopyTo(Order[],Int32) | (Inherited from dotnetCART.ListBase<Order>)
CopyTo(Int32,Order[],Int32,Int32) | (Inherited from dotnetCART.ListBase<Order>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Orders Class
Orders Members


%%PageItemTitle%%

CopyTo(Int32,Order[],Int32,Int32) Method
[image]
dotnetCART Namespace > Orders Class > CopyTo Method : CopyTo(Int32,Order[],Int32,Int32) Method

index
array
arrayIndex
count

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal index As Integer, _
   ByVal array() As Order, _
   ByVal arrayIndex As Integer, _
   ByVal count As Integer _
)
C#
public void CopyTo(
   int index,
   Order[] array,
   int arrayIndex,
   int count
)

Parameters

index
array
arrayIndex
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Orders Class
Orders Members
Overload List


%%PageItemTitle%%

CopyTo(Order[]) Method
[image]
dotnetCART Namespace > Orders Class > CopyTo Method : CopyTo(Order[]) Method

array

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array() As Order _
)
C#
public void CopyTo(
   Order[] array
)

Parameters

array

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Orders Class
Orders Members
Overload List


%%PageItemTitle%%

CopyTo(Order[],Int32) Method
[image]
dotnetCART Namespace > Orders Class > CopyTo Method : CopyTo(Order[],Int32) Method

array
arrayIndex

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array() As Order, _
   ByVal arrayIndex As Integer _
)
C#
public void CopyTo(
   Order[] array,
   int arrayIndex
)

Parameters

array
arrayIndex

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Orders Class
Orders Members
Overload List


%%PageItemTitle%%

Count Property
[image]
dotnetCART Namespace > Orders Class : Count Property

Gets the number of elements actually contained in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Orders Class
Orders Members


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > Orders Class : Error Property

Returns an object with the error information.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Orders Class
Orders Members


%%PageItemTitle%%

GetEnumerator Method
[image]
dotnetCART Namespace > Orders Class : GetEnumerator Method

Returns an enumerator that iterates through the List.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As List.Enumerator(Of Order)
C#
public List.Enumerator<Order> GetEnumerator()

Return Value

A List.Enumerator for the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Orders Class
Orders Members


%%PageItemTitle%%

IndexOf Method
[image]
dotnetCART Namespace > Orders Class : IndexOf Method

Overload List

Overload | Description
IndexOf(Order) | (Inherited from dotnetCART.ListBase<Order>)
IndexOf(Order,Int32) | (Inherited from dotnetCART.ListBase<Order>)
IndexOf(Order,Int32,Int32) | (Inherited from dotnetCART.ListBase<Order>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Orders Class
Orders Members


%%PageItemTitle%%

IndexOf(Order) Method
[image]
dotnetCART Namespace > Orders Class > IndexOf Method : IndexOf(Order) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As Order _
) As Integer
C#
public int IndexOf(
   Order item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Orders Class
Orders Members
Overload List


%%PageItemTitle%%

IndexOf(Order,Int32) Method
[image]
dotnetCART Namespace > Orders Class > IndexOf Method : IndexOf(Order,Int32) Method

item
index

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As Order, _
   ByVal index As Integer _
) As Integer
C#
public int IndexOf(
   Order item,
   int index
)

Parameters

item
index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Orders Class
Orders Members
Overload List


%%PageItemTitle%%

IndexOf(Order,Int32,Int32) Method
[image]
dotnetCART Namespace > Orders Class > IndexOf Method : IndexOf(Order,Int32,Int32) Method

item
index
count

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As Order, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
C#
public int IndexOf(
   Order item,
   int index,
   int count
)

Parameters

item
index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Orders Class
Orders Members
Overload List


%%PageItemTitle%%

Insert Method
[image]
dotnetCART Namespace > Orders Class : Insert Method

index
item
Inserts an element into the List at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As Order _
)
C#
public void Insert(
   int index,
   Order item
)

Parameters

index
item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Orders Class
Orders Members


%%PageItemTitle%%

InsertRange Method
[image]
dotnetCART Namespace > Orders Class : InsertRange Method

index
collection
Inserts the elements of a collection into the List at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub InsertRange( _
   ByVal index As Integer, _
   ByVal collection As IEnumerable(Of Order) _
)
C#
public void InsertRange(
   int index,
   IEnumerable<Order> collection
)

Parameters

index
collection

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Orders Class
Orders Members


%%PageItemTitle%%

Item Property
[image]
dotnetCART Namespace > Orders Class : Item Property

index
Gets or sets the element at the specified index.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As Order
C#
public Order this[
   int index
]; {get; set;}

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Orders Class
Orders Members


%%PageItemTitle%%

LastIndexOf Method
[image]
dotnetCART Namespace > Orders Class : LastIndexOf Method

Overload List

Overload | Description
LastIndexOf(Order) | (Inherited from dotnetCART.ListBase<Order>)
LastIndexOf(Order,Int32) | (Inherited from dotnetCART.ListBase<Order>)
LastIndexOf(Order,Int32,Int32) | (Inherited from dotnetCART.ListBase<Order>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Orders Class
Orders Members


%%PageItemTitle%%

LastIndexOf(Order) Method
[image]
dotnetCART Namespace > Orders Class > LastIndexOf Method : LastIndexOf(Order) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As Order _
) As Integer
C#
public int LastIndexOf(
   Order item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Orders Class
Orders Members
Overload List


%%PageItemTitle%%

LastIndexOf(Order,Int32) Method
[image]
dotnetCART Namespace > Orders Class > LastIndexOf Method : LastIndexOf(Order,Int32) Method

item
index

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As Order, _
   ByVal index As Integer _
) As Integer
C#
public int LastIndexOf(
   Order item,
   int index
)

Parameters

item
index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Orders Class
Orders Members
Overload List


%%PageItemTitle%%

LastIndexOf(Order,Int32,Int32) Method
[image]
dotnetCART Namespace > Orders Class > LastIndexOf Method : LastIndexOf(Order,Int32,Int32) Method

item
index
count

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As Order, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
C#
public int LastIndexOf(
   Order item,
   int index,
   int count
)

Parameters

item
index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Orders Class
Orders Members
Overload List


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > Orders Class > LoadDB Method : LoadDB() Method

Loads all the items from its associated table.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB() As Integer
C#
public virtual int LoadDB()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Orders Class
Orders Members
Overload List


%%PageItemTitle%%

LoadDB(Int32,Int32) Method
[image]
dotnetCART Namespace > Orders Class > LoadDB Method : LoadDB(Int32,Int32) Method

start
count
Loads the count number of elements from start value.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal start As Integer, _
   ByVal count As Integer _
) As Integer
C#
public virtual int LoadDB(
   int start,
   int count
)

Parameters

start
count

Return Value

The total number of elements have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Orders Class
Orders Members
Overload List


%%PageItemTitle%%

LoadDB(Where) Method
[image]
dotnetCART Namespace > Orders Class > LoadDB Method : LoadDB(Where) Method

whereClause
Loads all the items from its associated table based on the where clause.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal whereClause As Where _
) As Integer
C#
public virtual int LoadDB(
   Where whereClause
)

Parameters

whereClause

Return Value

The total number of items have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Orders Class
Orders Members
Overload List


%%PageItemTitle%%

Remove Method
[image]
dotnetCART Namespace > Orders Class : Remove Method

item
Removes the first occurrence of a specific object from the List.

Syntax

Visual Basic (Declaration)
Public Function Remove( _
   ByVal item As Order _
) As Boolean
C#
public bool Remove(
   Order item
)

Parameters

item

Return Value

true if item is successfully removed; otherwise, false. This method also returns false if item was not found in the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Orders Class
Orders Members


%%PageItemTitle%%

RemoveAll Method
[image]
dotnetCART Namespace > Orders Class : RemoveAll Method

match
Removes the all the elements that match the conditions defined by the specified predicate.

Syntax

Visual Basic (Declaration)
Public Function RemoveAll( _
   ByVal match As Predicate(Of Order) _
) As Integer
C#
public int RemoveAll(
   Predicate<Order> match
)

Parameters

match

Return Value

The number of elements removed from the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Orders Class
Orders Members


%%PageItemTitle%%

RemoveAt Method
[image]
dotnetCART Namespace > Orders Class : RemoveAt Method

index
Removes the element at the specified index of the List.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Orders Class
Orders Members


%%PageItemTitle%%

RemoveRange Method
[image]
dotnetCART Namespace > Orders Class : RemoveRange Method

index
count
Removes a range of elements from the List.

Syntax

Visual Basic (Declaration)
Public Sub RemoveRange( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
C#
public void RemoveRange(
   int index,
   int count
)

Parameters

index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Orders Class
Orders Members


%%PageItemTitle%%

Reverse Method
[image]
dotnetCART Namespace > Orders Class : Reverse Method

Reverses the order of the elements in the entire List.

Overload List

Overload | Description
Reverse() | Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<Order>)
Reverse(Int32,Int32) | Reverses the order of the elements in the specified range. (Inherited from dotnetCART.ListBase<Order>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Orders Class
Orders Members


%%PageItemTitle%%

Reverse() Method
[image]
dotnetCART Namespace > Orders Class > Reverse Method : Reverse() Method

Reverses the order of the elements in the entire List.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Reverse()
C#
public void Reverse()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Orders Class
Orders Members
Overload List


%%PageItemTitle%%

Reverse(Int32,Int32) Method
[image]
dotnetCART Namespace > Orders Class > Reverse Method : Reverse(Int32,Int32) Method

index
count
Reverses the order of the elements in the specified range.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Reverse( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
C#
public void Reverse(
   int index,
   int count
)

Parameters

index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Orders Class
Orders Members
Overload List


%%PageItemTitle%% $$Methods$$

OrderTaxes Class Methods
[image]
dotnetCART Namespace : OrderTaxes Class

For a list of all members of this type, see OrderTaxes members.

Public Methods

 | Name | Description
Public Method | Add | Add the newItem to this collection. (Inherited from dotnetDATA.EntitySet<OrderTax>)
Public Method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetDATA.EntitySet<OrderTax>)
Public Method | Clear | Removes all elements from the List. (Inherited from dotnetDATA.EntitySet<OrderTax>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from dotnetDATA.EntitySet<OrderTax>)
Public Method | IndexOf | Returns the index of this item in the list. (Inherited from dotnetDATA.EntitySet<OrderTax>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from dotnetDATA.EntitySet<OrderTax>)
Public Method | Remove | Removes the item from the collection. (Inherited from dotnetDATA.EntitySet<OrderTax>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from dotnetDATA.EntitySet<OrderTax>)
Top

See Also

Reference

OrderTaxes Class
dotnetCART Namespace


%%PageItemTitle%%

Add Method
[image]
dotnetCART Namespace > OrderTaxes Class : Add Method

item
Add the newItem to this collection.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal item As OrderTax _
)
C#
public void Add(
   OrderTax item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTaxes Class
OrderTaxes Members


%%PageItemTitle%%

AddRange Method
[image]
dotnetCART Namespace > OrderTaxes Class : AddRange Method

Adds the elements of the specified collection to the end of the collection.

Overload List

Overload | Description
AddRange(OrderTax[]) | (Inherited from dotnetDATA.EntitySet<OrderTax>)
AddRange(Generic EntitySet) | Adds the elements of the specified collection to the end of the collection. (Inherited from dotnetDATA.EntitySet<OrderTax>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTaxes Class
OrderTaxes Members


%%PageItemTitle%%

AddRange(Generic EntitySet) Method
[image]
dotnetCART Namespace > OrderTaxes Class > AddRange Method : AddRange(Generic EntitySet) Method

items
Adds the elements of the specified collection to the end of the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddRange( _
   ByVal items As EntitySet(Of OrderTax) _
)
C#
public void AddRange(
   EntitySet<OrderTax> items
)

Parameters

items

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTaxes Class
OrderTaxes Members
Overload List


%%PageItemTitle%%

AddRange(OrderTax[]) Method
[image]
dotnetCART Namespace > OrderTaxes Class > AddRange Method : AddRange(OrderTax[]) Method

items

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddRange( _
   ByVal items() As OrderTax _
)
C#
public void AddRange(
   OrderTax[] items
)

Parameters

items

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTaxes Class
OrderTaxes Members
Overload List


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > OrderTaxes Class : Clear Method

Removes all elements from the List.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTaxes Class
OrderTaxes Members


%%PageItemTitle%%

Contains Method
[image]
dotnetCART Namespace > OrderTaxes Class : Contains Method

item
Determines whether an element is in the List.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal item As OrderTax _
) As Boolean
C#
public bool Contains(
   OrderTax item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTaxes Class
OrderTaxes Members


%%PageItemTitle%%

Count Property
[image]
dotnetCART Namespace > OrderTaxes Class : Count Property

Returns the number of items in the collection.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Count As Integer
C#
public virtual int Count {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTaxes Class
OrderTaxes Members


%%PageItemTitle%%

IndexOf Method
[image]
dotnetCART Namespace > OrderTaxes Class : IndexOf Method

item
Returns the index of this item in the list.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal item As OrderTax _
) As Integer
C#
public int IndexOf(
   OrderTax item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTaxes Class
OrderTaxes Members


%%PageItemTitle%%

Insert Method
[image]
dotnetCART Namespace > OrderTaxes Class : Insert Method

index
item
Inserts an element into the List at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As OrderTax _
)
C#
public void Insert(
   int index,
   OrderTax item
)

Parameters

index
item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTaxes Class
OrderTaxes Members


%%PageItemTitle%%

Item(Int32) Property
[image]
dotnetCART Namespace > OrderTaxes Class > Item Property : Item(Int32) Property

index
Gets the element at the specified index.

Syntax

Visual Basic (Declaration)
Public Overloads Property Item( _
   ByVal index As Integer _
) As OrderTax
C#
public OrderTax Item(
   int index
) {get; set;}

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTaxes Class
OrderTaxes Members
Overload List


%%PageItemTitle%%

Remove Method
[image]
dotnetCART Namespace > OrderTaxes Class : Remove Method

item
Removes the item from the collection.

Syntax

Visual Basic (Declaration)
Public Function Remove( _
   ByVal item As OrderTax _
) As Boolean
C#
public bool Remove(
   OrderTax item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTaxes Class
OrderTaxes Members


%%PageItemTitle%%

RemoveAt Method
[image]
dotnetCART Namespace > OrderTaxes Class : RemoveAt Method

index
Removes the element at the specified index of the List.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTaxes Class
OrderTaxes Members


%%PageItemTitle%%

Custom Property
[image]
dotnetCART Namespace > OrderTax Class : Custom Property

Gets or sets a custom object. For more information see custom fields

Syntax

Visual Basic (Declaration)
Public Property Custom As Custom
C#
public Custom Custom {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTax Class
OrderTax Members


%%PageItemTitle%%

CustomFields Property
See Also Example
[image]
dotnetCART Namespace > OrderTax Class : CustomFields Property

Gets or sets a the names of custom fields for a table associated with the object.

Syntax

Visual Basic (Declaration)
Public Property CustomFields As String
C#
public string CustomFields {get; set;}

Example

C# Copy Code
Customer.CustomFields = "CellPhone,Favorites";

Visual Basic Copy Code
Customer.CustomFields = "CellPhone,Favorites"

Remarks

Custom fields must be added to the table manualy. Custom fields are usually set at store level using CustomFields

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTax Class
OrderTax Members


%%PageItemTitle%%

Customs Property
[image]
dotnetCART Namespace > OrderTax Class : Customs Property

A reference to the collection of the Custom objects.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Customs As Customs
C#
public Customs Customs {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTax Class
OrderTax Members


%%PageItemTitle%%

DeleteDB Method
[image]
dotnetCART Namespace > OrderTax Class : DeleteDB Method

Deletes this object with ID from the database.

Overload List

Overload | Description
DeleteDB() | Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<OrderTax, Int64>)
DeleteDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTax Class
OrderTax Members


%%PageItemTitle%%

DeleteDB() Method
[image]
dotnetCART Namespace > OrderTax Class > DeleteDB Method : DeleteDB() Method

Deletes this object with ID from the database.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function DeleteDB() As Integer
C#
public virtual int DeleteDB()

Return Value

In case of error -1, check Error property, otherwise the number of objects deleted.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTax Class
OrderTax Members
Overload List


%%PageItemTitle%%

DeleteDB(DbManager) Method
[image]
dotnetCART Namespace > OrderTax Class > DeleteDB Method : DeleteDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function DeleteDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int DeleteDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTax Class
OrderTax Members
Overload List


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > OrderTax Class : Error Property

Gets the error object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTax Class
OrderTax Members


%%PageItemTitle%%

GetCustom Method
[image]
dotnetCART Namespace > OrderTax Class : GetCustom Method

This method returns the value of a custom field based on its name in the customs collection.

Overload List

Overload | Description
GetCustom(String) | This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<OrderTax, Int64>)
GetCustom(Int32) | This method returns the value of a custom field based on its index in the customs collection. (Inherited from dotnetCART.DbTableCart<OrderTax, Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTax Class
OrderTax Members


%%PageItemTitle%%

GetCustom(Int32) Method
[image]
dotnetCART Namespace > OrderTax Class > GetCustom Method : GetCustom(Int32) Method

customIndex
This method returns the value of a custom field based on its index in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal customIndex As Integer _
) As Object
C#
public object GetCustom(
   int customIndex
)

Parameters

customIndex

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTax Class
OrderTax Members
Overload List


%%PageItemTitle%%

GetCustom(String) Method
[image]
dotnetCART Namespace > OrderTax Class > GetCustom Method : GetCustom(String) Method

name
This method returns the value of a custom field based on its name in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal name As String _
) As Object
C#
public object GetCustom(
   string name
)

Parameters

name

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTax Class
OrderTax Members
Overload List


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > OrderTax Class : LoadDB Method

Loads this object from database using the ID property.

Overload List

Overload | Description
LoadDB(Int64) | (Inherited from dotnetCART.DbTableCart<OrderTax, Int64>)
LoadDB() | Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<OrderTax, Int64>)
Generic LoadDB() | (Inherited from dotnetDATA.DbTable<Int64>)
Generic LoadDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTax Class
OrderTax Members


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > OrderTax Class > LoadDB Method : LoadDB() Method

Loads this object from database using the ID property.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB() As Integer
C#
public virtual int LoadDB()

Return Value

In case of error -1, check Error property, if the object with the ID property not found 0, otherwise 1.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTax Class
OrderTax Members
Overload List


%%PageItemTitle%%

LoadDB(Int64) Method
[image]
dotnetCART Namespace > OrderTax Class > LoadDB Method : LoadDB(Int64) Method

id

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal id As Long _
) As Integer
C#
public virtual int LoadDB(
   long id
)

Parameters

id

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTax Class
OrderTax Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB() Method
See Also
[image]
dotnetCART Namespace > OrderTax Class > LoadDB Method : Generic LoadDB() Method

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)() As Integer
C#
public virtual int LoadDB<T1>()where T1: IDbTable

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTax Class
OrderTax Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB(DbManager) Method
See Also
[image]
dotnetCART Namespace > OrderTax Class > LoadDB Method : Generic LoadDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int LoadDB<T1>(
   DbManager manager
)where T1: IDbTable

Parameters

manager

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTax Class
OrderTax Members
Overload List


%%PageItemTitle%%

SaveDB Method
[image]
dotnetCART Namespace > OrderTax Class : SaveDB Method

Inserts or updates this object into the database.

Overload List

Overload | Description
SaveDB() | Inserts or updates this object into the database. (Inherited from dotnetCART.DbTableCart<OrderTax, Int64>)
SaveDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTax Class
OrderTax Members


%%PageItemTitle%%

SaveDB() Method
[image]
dotnetCART Namespace > OrderTax Class > SaveDB Method : SaveDB() Method

Inserts or updates this object into the database.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function SaveDB() As Integer
C#
public virtual int SaveDB()

Return Value

Returns the generated ID or 1 for the update, returns -1 if failed. For the reason of fail, check the Generic DbTableCart.Error property.

Remarks

If Generic DbTableCart.ID greater than 0, it updates the associated object in the table, otherwise inserts a new object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTax Class
OrderTax Members
Overload List


%%PageItemTitle%%

SaveDB(DbManager) Method
[image]
dotnetCART Namespace > OrderTax Class > SaveDB Method : SaveDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function SaveDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int SaveDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTax Class
OrderTax Members
Overload List


%%PageItemTitle%%

SetCustom Method
[image]
dotnetCART Namespace > OrderTax Class : SetCustom Method

name
newValue
This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added.

Syntax

Visual Basic (Declaration)
Public Function SetCustom( _
   ByVal name As String, _
   ByVal newValue As Object _
) As Object
C#
public object SetCustom(
   string name,
   object newValue
)

Parameters

name
newValue

Return Value

Returns the new custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTax Class
OrderTax Members


%%PageItemTitle%% $$Properties$$

OrderTransactions Class Properties
[image]
dotnetCART Namespace : OrderTransactions Class

For a list of all members of this type, see OrderTransactions members.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from dotnetCART.ListBase<OrderTransaction>)
Public Property | Count | Gets the number of elements actually contained in the collection. (Inherited from dotnetCART.ListBase<OrderTransaction>)
Public Property | Error | Returns an object with the error information. (Inherited from dotnetCART.ListBase<OrderTransaction>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from dotnetCART.ListBase<OrderTransaction>)
Top

See Also

Reference

OrderTransactions Class
dotnetCART Namespace


%%PageItemTitle%%

Add(OrderTransaction) Method
[image]
dotnetCART Namespace > OrderTransactions Class > Add Method : Add(OrderTransaction) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add( _
   ByVal item As OrderTransaction _
)
C#
public void Add(
   OrderTransaction item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransactions Class
OrderTransactions Members
Overload List


%%PageItemTitle%%

AddRange Method
[image]
dotnetCART Namespace > OrderTransactions Class : AddRange Method

collection
Adds the elements of the specified collection to the end of the collection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal collection As IEnumerable(Of OrderTransaction) _
)
C#
public void AddRange(
   IEnumerable<OrderTransaction> collection
)

Parameters

collection

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransactions Class
OrderTransactions Members


%%PageItemTitle%%

AsReadOnly Method
[image]
dotnetCART Namespace > OrderTransactions Class : AsReadOnly Method

Returns a read-only IList wrapper for the current collection.

Syntax

Visual Basic (Declaration)
Public Function AsReadOnly() As ReadOnlyCollection(Of OrderTransaction)
C#
public ReadOnlyCollection<OrderTransaction> AsReadOnly()

Return Value

A ReadOnlyCollection that acts as a read-only wrapper around the current List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransactions Class
OrderTransactions Members


%%PageItemTitle%%

BinarySearch Method
[image]
dotnetCART Namespace > OrderTransactions Class : BinarySearch Method

Overload List

Overload | Description
BinarySearch(OrderTransaction) | (Inherited from dotnetCART.ListBase<OrderTransaction>)
BinarySearch(OrderTransaction,Generic IComparer) | (Inherited from dotnetCART.ListBase<OrderTransaction>)
BinarySearch(Int32,Int32,OrderTransaction,Generic IComparer) | (Inherited from dotnetCART.ListBase<OrderTransaction>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransactions Class
OrderTransactions Members


%%PageItemTitle%%

BinarySearch(Int32,Int32,OrderTransaction,Generic IComparer) Method
See Also
[image]
dotnetCART Namespace > OrderTransactions Class > BinarySearch Method : BinarySearch(Int32,Int32,OrderTransaction,Generic IComparer) Method

index
count
item
comparer

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal index As Integer, _
   ByVal count As Integer, _
   ByVal item As OrderTransaction, _
   ByVal comparer As IComparer(Of OrderTransaction) _
) As Integer
C#
public int BinarySearch(
   int index,
   int count,
   OrderTransaction item,
   IComparer<OrderTransaction> comparer
)

Parameters

index
count
item
comparer

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransactions Class
OrderTransactions Members
Overload List


%%PageItemTitle%%

BinarySearch(OrderTransaction) Method
[image]
dotnetCART Namespace > OrderTransactions Class > BinarySearch Method : BinarySearch(OrderTransaction) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal item As OrderTransaction _
) As Integer
C#
public int BinarySearch(
   OrderTransaction item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransactions Class
OrderTransactions Members
Overload List


%%PageItemTitle%%

BinarySearch(OrderTransaction,Generic IComparer) Method
[image]
dotnetCART Namespace > OrderTransactions Class > BinarySearch Method : BinarySearch(OrderTransaction,Generic IComparer) Method

item
comparer

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal item As OrderTransaction, _
   ByVal comparer As IComparer(Of OrderTransaction) _
) As Integer
C#
public int BinarySearch(
   OrderTransaction item,
   IComparer<OrderTransaction> comparer
)

Parameters

item
comparer

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransactions Class
OrderTransactions Members
Overload List


%%PageItemTitle%%

Capacity Property
[image]
dotnetCART Namespace > OrderTransactions Class : Capacity Property

Gets or sets the total number of elements the internal data structure can hold without resizing.

Syntax

Visual Basic (Declaration)
Public Property Capacity As Integer
C#
public int Capacity {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransactions Class
OrderTransactions Members


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > OrderTransactions Class : Clear Method

Removes all elements from the List.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransactions Class
OrderTransactions Members


%%PageItemTitle%%

Contains Method
[image]
dotnetCART Namespace > OrderTransactions Class : Contains Method

item
Determines whether an element is in the List.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal item As OrderTransaction _
) As Boolean
C#
public bool Contains(
   OrderTransaction item
)

Parameters

item

Return Value

true if item is found in the List; otherwise, false.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransactions Class
OrderTransactions Members


%%PageItemTitle%%

CopyTo Method
[image]
dotnetCART Namespace > OrderTransactions Class : CopyTo Method

Overload List

Overload | Description
CopyTo(OrderTransaction[]) | (Inherited from dotnetCART.ListBase<OrderTransaction>)
CopyTo(OrderTransaction[],Int32) | (Inherited from dotnetCART.ListBase<OrderTransaction>)
CopyTo(Int32,OrderTransaction[],Int32,Int32) | (Inherited from dotnetCART.ListBase<OrderTransaction>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransactions Class
OrderTransactions Members


%%PageItemTitle%%

CopyTo(Int32,OrderTransaction[],Int32,Int32) Method
[image]
dotnetCART Namespace > OrderTransactions Class > CopyTo Method : CopyTo(Int32,OrderTransaction[],Int32,Int32) Method

index
array
arrayIndex
count

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal index As Integer, _
   ByVal array() As OrderTransaction, _
   ByVal arrayIndex As Integer, _
   ByVal count As Integer _
)
C#
public void CopyTo(
   int index,
   OrderTransaction[] array,
   int arrayIndex,
   int count
)

Parameters

index
array
arrayIndex
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransactions Class
OrderTransactions Members
Overload List


%%PageItemTitle%%

CopyTo(OrderTransaction[]) Method
[image]
dotnetCART Namespace > OrderTransactions Class > CopyTo Method : CopyTo(OrderTransaction[]) Method

array

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array() As OrderTransaction _
)
C#
public void CopyTo(
   OrderTransaction[] array
)

Parameters

array

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransactions Class
OrderTransactions Members
Overload List


%%PageItemTitle%%

CopyTo(OrderTransaction[],Int32) Method
[image]
dotnetCART Namespace > OrderTransactions Class > CopyTo Method : CopyTo(OrderTransaction[],Int32) Method

array
arrayIndex

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array() As OrderTransaction, _
   ByVal arrayIndex As Integer _
)
C#
public void CopyTo(
   OrderTransaction[] array,
   int arrayIndex
)

Parameters

array
arrayIndex

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransactions Class
OrderTransactions Members
Overload List


%%PageItemTitle%%

Count Property
[image]
dotnetCART Namespace > OrderTransactions Class : Count Property

Gets the number of elements actually contained in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransactions Class
OrderTransactions Members


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > OrderTransactions Class : Error Property

Returns an object with the error information.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransactions Class
OrderTransactions Members


%%PageItemTitle%%

GetEnumerator Method
[image]
dotnetCART Namespace > OrderTransactions Class : GetEnumerator Method

Returns an enumerator that iterates through the List.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As List.Enumerator(Of OrderTransaction)
C#
public List.Enumerator<OrderTransaction> GetEnumerator()

Return Value

A List.Enumerator for the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransactions Class
OrderTransactions Members


%%PageItemTitle%%

IndexOf Method
[image]
dotnetCART Namespace > OrderTransactions Class : IndexOf Method

Overload List

Overload | Description
IndexOf(OrderTransaction) | (Inherited from dotnetCART.ListBase<OrderTransaction>)
IndexOf(OrderTransaction,Int32) | (Inherited from dotnetCART.ListBase<OrderTransaction>)
IndexOf(OrderTransaction,Int32,Int32) | (Inherited from dotnetCART.ListBase<OrderTransaction>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransactions Class
OrderTransactions Members


%%PageItemTitle%%

IndexOf(OrderTransaction) Method
[image]
dotnetCART Namespace > OrderTransactions Class > IndexOf Method : IndexOf(OrderTransaction) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As OrderTransaction _
) As Integer
C#
public int IndexOf(
   OrderTransaction item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransactions Class
OrderTransactions Members
Overload List


%%PageItemTitle%%

IndexOf(OrderTransaction,Int32) Method
[image]
dotnetCART Namespace > OrderTransactions Class > IndexOf Method : IndexOf(OrderTransaction,Int32) Method

item
index

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As OrderTransaction, _
   ByVal index As Integer _
) As Integer
C#
public int IndexOf(
   OrderTransaction item,
   int index
)

Parameters

item
index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransactions Class
OrderTransactions Members
Overload List


%%PageItemTitle%%

IndexOf(OrderTransaction,Int32,Int32) Method
[image]
dotnetCART Namespace > OrderTransactions Class > IndexOf Method : IndexOf(OrderTransaction,Int32,Int32) Method

item
index
count

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As OrderTransaction, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
C#
public int IndexOf(
   OrderTransaction item,
   int index,
   int count
)

Parameters

item
index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransactions Class
OrderTransactions Members
Overload List


%%PageItemTitle%%

Insert Method
[image]
dotnetCART Namespace > OrderTransactions Class : Insert Method

index
item
Inserts an element into the List at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As OrderTransaction _
)
C#
public void Insert(
   int index,
   OrderTransaction item
)

Parameters

index
item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransactions Class
OrderTransactions Members


%%PageItemTitle%%

InsertRange Method
[image]
dotnetCART Namespace > OrderTransactions Class : InsertRange Method

index
collection
Inserts the elements of a collection into the List at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub InsertRange( _
   ByVal index As Integer, _
   ByVal collection As IEnumerable(Of OrderTransaction) _
)
C#
public void InsertRange(
   int index,
   IEnumerable<OrderTransaction> collection
)

Parameters

index
collection

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransactions Class
OrderTransactions Members


%%PageItemTitle%%

Item Property
[image]
dotnetCART Namespace > OrderTransactions Class : Item Property

index
Gets or sets the element at the specified index.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As OrderTransaction
C#
public OrderTransaction this[
   int index
]; {get; set;}

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransactions Class
OrderTransactions Members


%%PageItemTitle%%

LastIndexOf Method
[image]
dotnetCART Namespace > OrderTransactions Class : LastIndexOf Method

Overload List

Overload | Description
LastIndexOf(OrderTransaction) | (Inherited from dotnetCART.ListBase<OrderTransaction>)
LastIndexOf(OrderTransaction,Int32) | (Inherited from dotnetCART.ListBase<OrderTransaction>)
LastIndexOf(OrderTransaction,Int32,Int32) | (Inherited from dotnetCART.ListBase<OrderTransaction>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransactions Class
OrderTransactions Members


%%PageItemTitle%%

LastIndexOf(OrderTransaction) Method
[image]
dotnetCART Namespace > OrderTransactions Class > LastIndexOf Method : LastIndexOf(OrderTransaction) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As OrderTransaction _
) As Integer
C#
public int LastIndexOf(
   OrderTransaction item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransactions Class
OrderTransactions Members
Overload List


%%PageItemTitle%%

LastIndexOf(OrderTransaction,Int32) Method
[image]
dotnetCART Namespace > OrderTransactions Class > LastIndexOf Method : LastIndexOf(OrderTransaction,Int32) Method

item
index

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As OrderTransaction, _
   ByVal index As Integer _
) As Integer
C#
public int LastIndexOf(
   OrderTransaction item,
   int index
)

Parameters

item
index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransactions Class
OrderTransactions Members
Overload List


%%PageItemTitle%%

LastIndexOf(OrderTransaction,Int32,Int32) Method
[image]
dotnetCART Namespace > OrderTransactions Class > LastIndexOf Method : LastIndexOf(OrderTransaction,Int32,Int32) Method

item
index
count

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As OrderTransaction, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
C#
public int LastIndexOf(
   OrderTransaction item,
   int index,
   int count
)

Parameters

item
index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransactions Class
OrderTransactions Members
Overload List


%%PageItemTitle%%

LoadDB(Int32,Int32) Method
[image]
dotnetCART Namespace > OrderTransactions Class > LoadDB Method : LoadDB(Int32,Int32) Method

start
count
Loads the count number of elements from start value.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal start As Integer, _
   ByVal count As Integer _
) As Integer
C#
public virtual int LoadDB(
   int start,
   int count
)

Parameters

start
count

Return Value

The total number of elements have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransactions Class
OrderTransactions Members
Overload List


%%PageItemTitle%%

LoadDB(Where,Int32,Int32,String,OrderDirection) Method
[image]
dotnetCART Namespace > OrderTransactions Class > LoadDB Method : LoadDB(Where,Int32,Int32,String,OrderDirection) Method

whereClause
count
start
orderBy
orderDirection
Loads all the items based on the parameters.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal whereClause As Where, _
   ByVal count As Integer, _
   ByVal start As Integer, _
   ByVal orderBy As String, _
   ByVal orderDirection As OrderDirection _
) As Integer
C#
public virtual int LoadDB(
   Where whereClause,
   int count,
   int start,
   string orderBy,
   OrderDirection orderDirection
)

Parameters

whereClause
count
start
orderBy
orderDirection

Return Value

The total number of items have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransactions Class
OrderTransactions Members
Overload List


%%PageItemTitle%%

Remove Method
[image]
dotnetCART Namespace > OrderTransactions Class : Remove Method

item
Removes the first occurrence of a specific object from the List.

Syntax

Visual Basic (Declaration)
Public Function Remove( _
   ByVal item As OrderTransaction _
) As Boolean
C#
public bool Remove(
   OrderTransaction item
)

Parameters

item

Return Value

true if item is successfully removed; otherwise, false. This method also returns false if item was not found in the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransactions Class
OrderTransactions Members


%%PageItemTitle%%

RemoveAll Method
[image]
dotnetCART Namespace > OrderTransactions Class : RemoveAll Method

match
Removes the all the elements that match the conditions defined by the specified predicate.

Syntax

Visual Basic (Declaration)
Public Function RemoveAll( _
   ByVal match As Predicate(Of OrderTransaction) _
) As Integer
C#
public int RemoveAll(
   Predicate<OrderTransaction> match
)

Parameters

match

Return Value

The number of elements removed from the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransactions Class
OrderTransactions Members


%%PageItemTitle%%

RemoveAt Method
[image]
dotnetCART Namespace > OrderTransactions Class : RemoveAt Method

index
Removes the element at the specified index of the List.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransactions Class
OrderTransactions Members


%%PageItemTitle%%

RemoveRange Method
[image]
dotnetCART Namespace > OrderTransactions Class : RemoveRange Method

index
count
Removes a range of elements from the List.

Syntax

Visual Basic (Declaration)
Public Sub RemoveRange( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
C#
public void RemoveRange(
   int index,
   int count
)

Parameters

index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransactions Class
OrderTransactions Members


%%PageItemTitle%%

Reverse Method
[image]
dotnetCART Namespace > OrderTransactions Class : Reverse Method

Reverses the order of the elements in the entire List.

Overload List

Overload | Description
Reverse() | Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<OrderTransaction>)
Reverse(Int32,Int32) | Reverses the order of the elements in the specified range. (Inherited from dotnetCART.ListBase<OrderTransaction>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransactions Class
OrderTransactions Members


%%PageItemTitle%%

Reverse() Method
[image]
dotnetCART Namespace > OrderTransactions Class > Reverse Method : Reverse() Method

Reverses the order of the elements in the entire List.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Reverse()
C#
public void Reverse()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransactions Class
OrderTransactions Members
Overload List


%%PageItemTitle%%

Reverse(Int32,Int32) Method
[image]
dotnetCART Namespace > OrderTransactions Class > Reverse Method : Reverse(Int32,Int32) Method

index
count
Reverses the order of the elements in the specified range.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Reverse( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
C#
public void Reverse(
   int index,
   int count
)

Parameters

index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransactions Class
OrderTransactions Members
Overload List


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > OrderTransaction Class : Clear Method

Initializes all the properties without recreating the object.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Clear()
C#
public virtual void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransaction Class
OrderTransaction Members


%%PageItemTitle%%

Custom Property
[image]
dotnetCART Namespace > OrderTransaction Class : Custom Property

Gets or sets a custom object. For more information see custom fields

Syntax

Visual Basic (Declaration)
Public Property Custom As Custom
C#
public Custom Custom {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransaction Class
OrderTransaction Members


%%PageItemTitle%%

CustomFields Property
See Also Example
[image]
dotnetCART Namespace > OrderTransaction Class : CustomFields Property

Gets or sets a the names of custom fields for a table associated with the object.

Syntax

Visual Basic (Declaration)
Public Property CustomFields As String
C#
public string CustomFields {get; set;}

Example

C# Copy Code
Customer.CustomFields = "CellPhone,Favorites";

Visual Basic Copy Code
Customer.CustomFields = "CellPhone,Favorites"

Remarks

Custom fields must be added to the table manualy. Custom fields are usually set at store level using CustomFields

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransaction Class
OrderTransaction Members


%%PageItemTitle%%

Customs Property
[image]
dotnetCART Namespace > OrderTransaction Class : Customs Property

A reference to the collection of the Custom objects.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Customs As Customs
C#
public Customs Customs {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransaction Class
OrderTransaction Members


%%PageItemTitle%%

DeleteDB() Method
[image]
dotnetCART Namespace > OrderTransaction Class > DeleteDB Method : DeleteDB() Method

Deletes this object with ID from the database.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function DeleteDB() As Integer
C#
public virtual int DeleteDB()

Return Value

In case of error -1, check Error property, otherwise the number of objects deleted.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransaction Class
OrderTransaction Members
Overload List


%%PageItemTitle%%

DeleteDB(DbManager) Method
[image]
dotnetCART Namespace > OrderTransaction Class > DeleteDB Method : DeleteDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function DeleteDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int DeleteDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransaction Class
OrderTransaction Members
Overload List


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > OrderTransaction Class : Error Property

Gets the error object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransaction Class
OrderTransaction Members


%%PageItemTitle%%

GetCustom Method
[image]
dotnetCART Namespace > OrderTransaction Class : GetCustom Method

This method returns the value of a custom field based on its name in the customs collection.

Overload List

Overload | Description
GetCustom(String) | This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<OrderTransaction, Int64>)
GetCustom(Int32) | This method returns the value of a custom field based on its index in the customs collection. (Inherited from dotnetCART.DbTableCart<OrderTransaction, Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransaction Class
OrderTransaction Members


%%PageItemTitle%%

GetCustom(Int32) Method
[image]
dotnetCART Namespace > OrderTransaction Class > GetCustom Method : GetCustom(Int32) Method

customIndex
This method returns the value of a custom field based on its index in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal customIndex As Integer _
) As Object
C#
public object GetCustom(
   int customIndex
)

Parameters

customIndex

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransaction Class
OrderTransaction Members
Overload List


%%PageItemTitle%%

GetCustom(String) Method
[image]
dotnetCART Namespace > OrderTransaction Class > GetCustom Method : GetCustom(String) Method

name
This method returns the value of a custom field based on its name in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal name As String _
) As Object
C#
public object GetCustom(
   string name
)

Parameters

name

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransaction Class
OrderTransaction Members
Overload List


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > OrderTransaction Class : LoadDB Method

Loads this object from database using the ID property.

Overload List

Overload | Description
LoadDB(Int64) | (Inherited from dotnetCART.DbTableCart<OrderTransaction, Int64>)
LoadDB() | Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<OrderTransaction, Int64>)
Generic LoadDB() | (Inherited from dotnetDATA.DbTable<Int64>)
Generic LoadDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransaction Class
OrderTransaction Members


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > OrderTransaction Class > LoadDB Method : LoadDB() Method

Loads this object from database using the ID property.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB() As Integer
C#
public virtual int LoadDB()

Return Value

In case of error -1, check Error property, if the object with the ID property not found 0, otherwise 1.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransaction Class
OrderTransaction Members
Overload List


%%PageItemTitle%%

LoadDB(Int64) Method
[image]
dotnetCART Namespace > OrderTransaction Class > LoadDB Method : LoadDB(Int64) Method

id

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal id As Long _
) As Integer
C#
public virtual int LoadDB(
   long id
)

Parameters

id

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransaction Class
OrderTransaction Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB() Method
See Also
[image]
dotnetCART Namespace > OrderTransaction Class > LoadDB Method : Generic LoadDB() Method

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)() As Integer
C#
public virtual int LoadDB<T1>()where T1: IDbTable

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransaction Class
OrderTransaction Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB(DbManager) Method
See Also
[image]
dotnetCART Namespace > OrderTransaction Class > LoadDB Method : Generic LoadDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int LoadDB<T1>(
   DbManager manager
)where T1: IDbTable

Parameters

manager

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransaction Class
OrderTransaction Members
Overload List


%%PageItemTitle%%

SaveDB(DbManager) Method
[image]
dotnetCART Namespace > OrderTransaction Class > SaveDB Method : SaveDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function SaveDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int SaveDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransaction Class
OrderTransaction Members
Overload List


%%PageItemTitle%%

SetCustom Method
[image]
dotnetCART Namespace > OrderTransaction Class : SetCustom Method

name
newValue
This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added.

Syntax

Visual Basic (Declaration)
Public Function SetCustom( _
   ByVal name As String, _
   ByVal newValue As Object _
) As Object
C#
public object SetCustom(
   string name,
   object newValue
)

Parameters

name
newValue

Return Value

Returns the new custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

OrderTransaction Class
OrderTransaction Members


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > Order Class : Clear Method

Initializes all the properties without recreating the object.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Clear()
C#
public virtual void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members


%%PageItemTitle%%

Custom Property
[image]
dotnetCART Namespace > Order Class : Custom Property

Gets or sets a custom object. For more information see custom fields

Syntax

Visual Basic (Declaration)
Public Property Custom As Custom
C#
public Custom Custom {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members


%%PageItemTitle%%

CustomFields Property
See Also Example
[image]
dotnetCART Namespace > Order Class : CustomFields Property

Gets or sets a the names of custom fields for a table associated with the object.

Syntax

Visual Basic (Declaration)
Public Property CustomFields As String
C#
public string CustomFields {get; set;}

Example

C# Copy Code
Customer.CustomFields = "CellPhone,Favorites";

Visual Basic Copy Code
Customer.CustomFields = "CellPhone,Favorites"

Remarks

Custom fields must be added to the table manualy. Custom fields are usually set at store level using CustomFields

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members


%%PageItemTitle%%

Customs Property
[image]
dotnetCART Namespace > Order Class : Customs Property

A reference to the collection of the Custom objects.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Customs As Customs
C#
public Customs Customs {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members


%%PageItemTitle%%

DeleteDB(DbManager) Method
[image]
dotnetCART Namespace > Order Class > DeleteDB Method : DeleteDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function DeleteDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int DeleteDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members
Overload List


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > Order Class : Error Property

Gets the error object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members


%%PageItemTitle%%

GetCustom Method
[image]
dotnetCART Namespace > Order Class : GetCustom Method

This method returns the value of a custom field based on its name in the customs collection.

Overload List

Overload | Description
GetCustom(String) | This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<Order, Int64>)
GetCustom(Int32) | This method returns the value of a custom field based on its index in the customs collection. (Inherited from dotnetCART.DbTableCart<Order, Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members


%%PageItemTitle%%

GetCustom(Int32) Method
[image]
dotnetCART Namespace > Order Class > GetCustom Method : GetCustom(Int32) Method

customIndex
This method returns the value of a custom field based on its index in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal customIndex As Integer _
) As Object
C#
public object GetCustom(
   int customIndex
)

Parameters

customIndex

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members
Overload List


%%PageItemTitle%%

GetCustom(String) Method
[image]
dotnetCART Namespace > Order Class > GetCustom Method : GetCustom(String) Method

name
This method returns the value of a custom field based on its name in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal name As String _
) As Object
C#
public object GetCustom(
   string name
)

Parameters

name

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB() Method
See Also
[image]
dotnetCART Namespace > Order Class > LoadDB Method : Generic LoadDB() Method

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)() As Integer
C#
public virtual int LoadDB<T1>()where T1: IDbTable

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB(DbManager) Method
See Also
[image]
dotnetCART Namespace > Order Class > LoadDB Method : Generic LoadDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int LoadDB<T1>(
   DbManager manager
)where T1: IDbTable

Parameters

manager

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members
Overload List


%%PageItemTitle%%

SaveDB(DbManager) Method
[image]
dotnetCART Namespace > Order Class > SaveDB Method : SaveDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function SaveDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int SaveDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members
Overload List


%%PageItemTitle%%

SetCustom Method
[image]
dotnetCART Namespace > Order Class : SetCustom Method

name
newValue
This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added.

Syntax

Visual Basic (Declaration)
Public Function SetCustom( _
   ByVal name As String, _
   ByVal newValue As Object _
) As Object
C#
public object SetCustom(
   string name,
   object newValue
)

Parameters

name
newValue

Return Value

Returns the new custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Order Class
Order Members


%%PageItemTitle%% $$Methods$$

PaymentProfile Structure Methods
[image]
dotnetCART Namespace : PaymentProfile Structure

For a list of all members of this type, see PaymentProfile members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.ValueType)
Public Method | GetHashCode | (Inherited from System.ValueType)
Public Method | ToString | (Inherited from System.ValueType)
Top

See Also

Reference

PaymentProfile Structure
dotnetCART Namespace


%%PageItemTitle%%

CartIDSet Field
[image]
dotnetCART Namespace > Payment Class : CartIDSet Field

Syntax

Visual Basic (Declaration)
Public CartIDSet As Boolean
C#
public bool CartIDSet

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Payment Class
Payment Members


%%PageItemTitle%%

Add Method
[image]
dotnetCART Namespace > Prices Class : Add Method

item
Adds an object to the end of the collection.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal item As Price _
)
C#
public void Add(
   Price item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Prices Class
Prices Members


%%PageItemTitle%%

AddRange Method
[image]
dotnetCART Namespace > Prices Class : AddRange Method

collection
Adds the elements of the specified collection to the end of the collection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal collection As IEnumerable(Of Price) _
)
C#
public void AddRange(
   IEnumerable<Price> collection
)

Parameters

collection

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Prices Class
Prices Members


%%PageItemTitle%%

AsReadOnly Method
[image]
dotnetCART Namespace > Prices Class : AsReadOnly Method

Returns a read-only IList wrapper for the current collection.

Syntax

Visual Basic (Declaration)
Public Function AsReadOnly() As ReadOnlyCollection(Of Price)
C#
public ReadOnlyCollection<Price> AsReadOnly()

Return Value

A ReadOnlyCollection that acts as a read-only wrapper around the current List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Prices Class
Prices Members


%%PageItemTitle%%

BinarySearch Method
[image]
dotnetCART Namespace > Prices Class : BinarySearch Method

Overload List

Overload | Description
BinarySearch(Price) | (Inherited from dotnetCART.ListBase<Price>)
BinarySearch(Price,Generic IComparer) | (Inherited from dotnetCART.ListBase<Price>)
BinarySearch(Int32,Int32,Price,Generic IComparer) | (Inherited from dotnetCART.ListBase<Price>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Prices Class
Prices Members


%%PageItemTitle%%

BinarySearch(Int32,Int32,Price,Generic IComparer) Method
[image]
dotnetCART Namespace > Prices Class > BinarySearch Method : BinarySearch(Int32,Int32,Price,Generic IComparer) Method

index
count
item
comparer

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal index As Integer, _
   ByVal count As Integer, _
   ByVal item As Price, _
   ByVal comparer As IComparer(Of Price) _
) As Integer
C#
public int BinarySearch(
   int index,
   int count,
   Price item,
   IComparer<Price> comparer
)

Parameters

index
count
item
comparer

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Prices Class
Prices Members
Overload List


%%PageItemTitle%%

BinarySearch(Price) Method
[image]
dotnetCART Namespace > Prices Class > BinarySearch Method : BinarySearch(Price) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal item As Price _
) As Integer
C#
public int BinarySearch(
   Price item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Prices Class
Prices Members
Overload List


%%PageItemTitle%%

BinarySearch(Price,Generic IComparer) Method
[image]
dotnetCART Namespace > Prices Class > BinarySearch Method : BinarySearch(Price,Generic IComparer) Method

item
comparer

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal item As Price, _
   ByVal comparer As IComparer(Of Price) _
) As Integer
C#
public int BinarySearch(
   Price item,
   IComparer<Price> comparer
)

Parameters

item
comparer

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Prices Class
Prices Members
Overload List


%%PageItemTitle%%

Capacity Property
[image]
dotnetCART Namespace > Prices Class : Capacity Property

Gets or sets the total number of elements the internal data structure can hold without resizing.

Syntax

Visual Basic (Declaration)
Public Property Capacity As Integer
C#
public int Capacity {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Prices Class
Prices Members


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > Prices Class : Clear Method

Removes all elements from the List.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Prices Class
Prices Members


%%PageItemTitle%%

Contains Method
[image]
dotnetCART Namespace > Prices Class : Contains Method

item
Determines whether an element is in the List.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal item As Price _
) As Boolean
C#
public bool Contains(
   Price item
)

Parameters

item

Return Value

true if item is found in the List; otherwise, false.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Prices Class
Prices Members


%%PageItemTitle%%

CopyTo Method
[image]
dotnetCART Namespace > Prices Class : CopyTo Method

Overload List

Overload | Description
CopyTo(Price[]) | (Inherited from dotnetCART.ListBase<Price>)
CopyTo(Price[],Int32) | (Inherited from dotnetCART.ListBase<Price>)
CopyTo(Int32,Price[],Int32,Int32) | (Inherited from dotnetCART.ListBase<Price>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Prices Class
Prices Members


%%PageItemTitle%%

CopyTo(Int32,Price[],Int32,Int32) Method
[image]
dotnetCART Namespace > Prices Class > CopyTo Method : CopyTo(Int32,Price[],Int32,Int32) Method

index
array
arrayIndex
count

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal index As Integer, _
   ByVal array() As Price, _
   ByVal arrayIndex As Integer, _
   ByVal count As Integer _
)
C#
public void CopyTo(
   int index,
   Price[] array,
   int arrayIndex,
   int count
)

Parameters

index
array
arrayIndex
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Prices Class
Prices Members
Overload List


%%PageItemTitle%%

CopyTo(Price[]) Method
[image]
dotnetCART Namespace > Prices Class > CopyTo Method : CopyTo(Price[]) Method

array

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array() As Price _
)
C#
public void CopyTo(
   Price[] array
)

Parameters

array

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Prices Class
Prices Members
Overload List


%%PageItemTitle%%

CopyTo(Price[],Int32) Method
[image]
dotnetCART Namespace > Prices Class > CopyTo Method : CopyTo(Price[],Int32) Method

array
arrayIndex

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array() As Price, _
   ByVal arrayIndex As Integer _
)
C#
public void CopyTo(
   Price[] array,
   int arrayIndex
)

Parameters

array
arrayIndex

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Prices Class
Prices Members
Overload List


%%PageItemTitle%%

Count Property
[image]
dotnetCART Namespace > Prices Class : Count Property

Gets the number of elements actually contained in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Prices Class
Prices Members


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > Prices Class : Error Property

Returns an object with the error information.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Prices Class
Prices Members


%%PageItemTitle%%

GetEnumerator Method
[image]
dotnetCART Namespace > Prices Class : GetEnumerator Method

Returns an enumerator that iterates through the List.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As List.Enumerator(Of Price)
C#
public List.Enumerator<Price> GetEnumerator()

Return Value

A List.Enumerator for the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Prices Class
Prices Members


%%PageItemTitle%%

IndexOf Method
[image]
dotnetCART Namespace > Prices Class : IndexOf Method

Overload List

Overload | Description
IndexOf(Price) | (Inherited from dotnetCART.ListBase<Price>)
IndexOf(Price,Int32) | (Inherited from dotnetCART.ListBase<Price>)
IndexOf(Price,Int32,Int32) | (Inherited from dotnetCART.ListBase<Price>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Prices Class
Prices Members


%%PageItemTitle%%

IndexOf(Price) Method
[image]
dotnetCART Namespace > Prices Class > IndexOf Method : IndexOf(Price) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As Price _
) As Integer
C#
public int IndexOf(
   Price item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Prices Class
Prices Members
Overload List


%%PageItemTitle%%

IndexOf(Price,Int32) Method
[image]
dotnetCART Namespace > Prices Class > IndexOf Method : IndexOf(Price,Int32) Method

item
index

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As Price, _
   ByVal index As Integer _
) As Integer
C#
public int IndexOf(
   Price item,
   int index
)

Parameters

item
index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Prices Class
Prices Members
Overload List


%%PageItemTitle%%

IndexOf(Price,Int32,Int32) Method
[image]
dotnetCART Namespace > Prices Class > IndexOf Method : IndexOf(Price,Int32,Int32) Method

item
index
count

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As Price, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
C#
public int IndexOf(
   Price item,
   int index,
   int count
)

Parameters

item
index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Prices Class
Prices Members
Overload List


%%PageItemTitle%%

Insert Method
[image]
dotnetCART Namespace > Prices Class : Insert Method

index
item
Inserts an element into the List at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As Price _
)
C#
public void Insert(
   int index,
   Price item
)

Parameters

index
item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Prices Class
Prices Members


%%PageItemTitle%%

InsertRange Method
[image]
dotnetCART Namespace > Prices Class : InsertRange Method

index
collection
Inserts the elements of a collection into the List at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub InsertRange( _
   ByVal index As Integer, _
   ByVal collection As IEnumerable(Of Price) _
)
C#
public void InsertRange(
   int index,
   IEnumerable<Price> collection
)

Parameters

index
collection

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Prices Class
Prices Members


%%PageItemTitle%%

Item(Int32) Property
[image]
dotnetCART Namespace > Prices Class > Item Property : Item(Int32) Property

index
Gets or sets the element at the specified index.

Syntax

Visual Basic (Declaration)
Public Overloads Property Item( _
   ByVal index As Integer _
) As Price
C#
public Price Item(
   int index
) {get; set;}

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Prices Class
Prices Members
Overload List


%%PageItemTitle%%

LastIndexOf Method
[image]
dotnetCART Namespace > Prices Class : LastIndexOf Method

Overload List

Overload | Description
LastIndexOf(Price) | (Inherited from dotnetCART.ListBase<Price>)
LastIndexOf(Price,Int32) | (Inherited from dotnetCART.ListBase<Price>)
LastIndexOf(Price,Int32,Int32) | (Inherited from dotnetCART.ListBase<Price>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Prices Class
Prices Members


%%PageItemTitle%%

LastIndexOf(Price) Method
[image]
dotnetCART Namespace > Prices Class > LastIndexOf Method : LastIndexOf(Price) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As Price _
) As Integer
C#
public int LastIndexOf(
   Price item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Prices Class
Prices Members
Overload List


%%PageItemTitle%%

LastIndexOf(Price,Int32) Method
[image]
dotnetCART Namespace > Prices Class > LastIndexOf Method : LastIndexOf(Price,Int32) Method

item
index

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As Price, _
   ByVal index As Integer _
) As Integer
C#
public int LastIndexOf(
   Price item,
   int index
)

Parameters

item
index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Prices Class
Prices Members
Overload List


%%PageItemTitle%%

LastIndexOf(Price,Int32,Int32) Method
[image]
dotnetCART Namespace > Prices Class > LastIndexOf Method : LastIndexOf(Price,Int32,Int32) Method

item
index
count

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As Price, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
C#
public int LastIndexOf(
   Price item,
   int index,
   int count
)

Parameters

item
index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Prices Class
Prices Members
Overload List


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > Prices Class : LoadDB Method

Loads all the items from its associated table.

Overload List

Overload | Description
LoadDB() | Loads all the items from its associated table. (Inherited from dotnetCART.ListBase<Price>)
LoadDB(Where) | Loads all the items from its associated table based on the where clause. (Inherited from dotnetCART.ListBase<Price>)
LoadDB(Int32,Int32) | Loads the count number of elements from start value. (Inherited from dotnetCART.ListBase<Price>)
LoadDB(Where,Int32,Int32,String,OrderDirection) | Loads all the items based on the parameters. (Inherited from dotnetCART.ListBase<Price>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Prices Class
Prices Members


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > Prices Class > LoadDB Method : LoadDB() Method

Loads all the items from its associated table.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB() As Integer
C#
public virtual int LoadDB()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Prices Class
Prices Members
Overload List


%%PageItemTitle%%

LoadDB(Int32,Int32) Method
[image]
dotnetCART Namespace > Prices Class > LoadDB Method : LoadDB(Int32,Int32) Method

start
count
Loads the count number of elements from start value.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal start As Integer, _
   ByVal count As Integer _
) As Integer
C#
public virtual int LoadDB(
   int start,
   int count
)

Parameters

start
count

Return Value

The total number of elements have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Prices Class
Prices Members
Overload List


%%PageItemTitle%%

LoadDB(Where) Method
[image]
dotnetCART Namespace > Prices Class > LoadDB Method : LoadDB(Where) Method

whereClause
Loads all the items from its associated table based on the where clause.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal whereClause As Where _
) As Integer
C#
public virtual int LoadDB(
   Where whereClause
)

Parameters

whereClause

Return Value

The total number of items have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Prices Class
Prices Members
Overload List


%%PageItemTitle%%

LoadDB(Where,Int32,Int32,String,OrderDirection) Method
[image]
dotnetCART Namespace > Prices Class > LoadDB Method : LoadDB(Where,Int32,Int32,String,OrderDirection) Method

whereClause
count
start
orderBy
orderDirection
Loads all the items based on the parameters.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal whereClause As Where, _
   ByVal count As Integer, _
   ByVal start As Integer, _
   ByVal orderBy As String, _
   ByVal orderDirection As OrderDirection _
) As Integer
C#
public virtual int LoadDB(
   Where whereClause,
   int count,
   int start,
   string orderBy,
   OrderDirection orderDirection
)

Parameters

whereClause
count
start
orderBy
orderDirection

Return Value

The total number of items have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Prices Class
Prices Members
Overload List


%%PageItemTitle%%

Remove Method
[image]
dotnetCART Namespace > Prices Class : Remove Method

item
Removes the first occurrence of a specific object from the List.

Syntax

Visual Basic (Declaration)
Public Function Remove( _
   ByVal item As Price _
) As Boolean
C#
public bool Remove(
   Price item
)

Parameters

item

Return Value

true if item is successfully removed; otherwise, false. This method also returns false if item was not found in the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Prices Class
Prices Members


%%PageItemTitle%%

RemoveAll Method
[image]
dotnetCART Namespace > Prices Class : RemoveAll Method

match
Removes the all the elements that match the conditions defined by the specified predicate.

Syntax

Visual Basic (Declaration)
Public Function RemoveAll( _
   ByVal match As Predicate(Of Price) _
) As Integer
C#
public int RemoveAll(
   Predicate<Price> match
)

Parameters

match

Return Value

The number of elements removed from the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Prices Class
Prices Members


%%PageItemTitle%%

RemoveAt Method
[image]
dotnetCART Namespace > Prices Class : RemoveAt Method

index
Removes the element at the specified index of the List.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Prices Class
Prices Members


%%PageItemTitle%%

RemoveRange Method
[image]
dotnetCART Namespace > Prices Class : RemoveRange Method

index
count
Removes a range of elements from the List.

Syntax

Visual Basic (Declaration)
Public Sub RemoveRange( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
C#
public void RemoveRange(
   int index,
   int count
)

Parameters

index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Prices Class
Prices Members


%%PageItemTitle%%

Reverse Method
[image]
dotnetCART Namespace > Prices Class : Reverse Method

Reverses the order of the elements in the entire List.

Overload List

Overload | Description
Reverse() | Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<Price>)
Reverse(Int32,Int32) | Reverses the order of the elements in the specified range. (Inherited from dotnetCART.ListBase<Price>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Prices Class
Prices Members


%%PageItemTitle%%

Reverse() Method
[image]
dotnetCART Namespace > Prices Class > Reverse Method : Reverse() Method

Reverses the order of the elements in the entire List.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Reverse()
C#
public void Reverse()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Prices Class
Prices Members
Overload List


%%PageItemTitle%%

Reverse(Int32,Int32) Method
[image]
dotnetCART Namespace > Prices Class > Reverse Method : Reverse(Int32,Int32) Method

index
count
Reverses the order of the elements in the specified range.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Reverse( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
C#
public void Reverse(
   int index,
   int count
)

Parameters

index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Prices Class
Prices Members
Overload List


%%PageItemTitle%% $$Properties$$

Referrers Class Properties
[image]
dotnetCART Namespace : Referrers Class

For a list of all members of this type, see Referrers members.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from dotnetCART.ListBase<Referrer>)
Public Property | Count | Gets the number of elements actually contained in the collection. (Inherited from dotnetCART.ListBase<Referrer>)
Public Property | Error | Returns an object with the error information. (Inherited from dotnetCART.ListBase<Referrer>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from dotnetCART.ListBase<Referrer>)
Top

See Also

Reference

Referrers Class
dotnetCART Namespace


%%PageItemTitle%%

Add Method
[image]
dotnetCART Namespace > Referrers Class : Add Method

item
Adds an object to the end of the collection.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal item As Referrer _
)
C#
public void Add(
   Referrer item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrers Class
Referrers Members


%%PageItemTitle%%

AddRange Method
[image]
dotnetCART Namespace > Referrers Class : AddRange Method

collection
Adds the elements of the specified collection to the end of the collection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal collection As IEnumerable(Of Referrer) _
)
C#
public void AddRange(
   IEnumerable<Referrer> collection
)

Parameters

collection

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrers Class
Referrers Members


%%PageItemTitle%%

AsReadOnly Method
[image]
dotnetCART Namespace > Referrers Class : AsReadOnly Method

Returns a read-only IList wrapper for the current collection.

Syntax

Visual Basic (Declaration)
Public Function AsReadOnly() As ReadOnlyCollection(Of Referrer)
C#
public ReadOnlyCollection<Referrer> AsReadOnly()

Return Value

A ReadOnlyCollection that acts as a read-only wrapper around the current List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrers Class
Referrers Members


%%PageItemTitle%%

BinarySearch Method
[image]
dotnetCART Namespace > Referrers Class : BinarySearch Method

Overload List

Overload | Description
BinarySearch(Referrer) | (Inherited from dotnetCART.ListBase<Referrer>)
BinarySearch(Referrer,Generic IComparer) | (Inherited from dotnetCART.ListBase<Referrer>)
BinarySearch(Int32,Int32,Referrer,Generic IComparer) | (Inherited from dotnetCART.ListBase<Referrer>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrers Class
Referrers Members


%%PageItemTitle%%

BinarySearch(Int32,Int32,Referrer,Generic IComparer) Method
[image]
dotnetCART Namespace > Referrers Class > BinarySearch Method : BinarySearch(Int32,Int32,Referrer,Generic IComparer) Method

index
count
item
comparer

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal index As Integer, _
   ByVal count As Integer, _
   ByVal item As Referrer, _
   ByVal comparer As IComparer(Of Referrer) _
) As Integer
C#
public int BinarySearch(
   int index,
   int count,
   Referrer item,
   IComparer<Referrer> comparer
)

Parameters

index
count
item
comparer

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrers Class
Referrers Members
Overload List


%%PageItemTitle%%

BinarySearch(Referrer) Method
[image]
dotnetCART Namespace > Referrers Class > BinarySearch Method : BinarySearch(Referrer) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal item As Referrer _
) As Integer
C#
public int BinarySearch(
   Referrer item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrers Class
Referrers Members
Overload List


%%PageItemTitle%%

BinarySearch(Referrer,Generic IComparer) Method
[image]
dotnetCART Namespace > Referrers Class > BinarySearch Method : BinarySearch(Referrer,Generic IComparer) Method

item
comparer

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal item As Referrer, _
   ByVal comparer As IComparer(Of Referrer) _
) As Integer
C#
public int BinarySearch(
   Referrer item,
   IComparer<Referrer> comparer
)

Parameters

item
comparer

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrers Class
Referrers Members
Overload List


%%PageItemTitle%%

Capacity Property
[image]
dotnetCART Namespace > Referrers Class : Capacity Property

Gets or sets the total number of elements the internal data structure can hold without resizing.

Syntax

Visual Basic (Declaration)
Public Property Capacity As Integer
C#
public int Capacity {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrers Class
Referrers Members


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > Referrers Class : Clear Method

Removes all elements from the List.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrers Class
Referrers Members


%%PageItemTitle%%

Contains Method
[image]
dotnetCART Namespace > Referrers Class : Contains Method

item
Determines whether an element is in the List.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal item As Referrer _
) As Boolean
C#
public bool Contains(
   Referrer item
)

Parameters

item

Return Value

true if item is found in the List; otherwise, false.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrers Class
Referrers Members


%%PageItemTitle%%

CopyTo Method
[image]
dotnetCART Namespace > Referrers Class : CopyTo Method

Overload List

Overload | Description
CopyTo(Referrer[]) | (Inherited from dotnetCART.ListBase<Referrer>)
CopyTo(Referrer[],Int32) | (Inherited from dotnetCART.ListBase<Referrer>)
CopyTo(Int32,Referrer[],Int32,Int32) | (Inherited from dotnetCART.ListBase<Referrer>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrers Class
Referrers Members


%%PageItemTitle%%

CopyTo(Int32,Referrer[],Int32,Int32) Method
[image]
dotnetCART Namespace > Referrers Class > CopyTo Method : CopyTo(Int32,Referrer[],Int32,Int32) Method

index
array
arrayIndex
count

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal index As Integer, _
   ByVal array() As Referrer, _
   ByVal arrayIndex As Integer, _
   ByVal count As Integer _
)
C#
public void CopyTo(
   int index,
   Referrer[] array,
   int arrayIndex,
   int count
)

Parameters

index
array
arrayIndex
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrers Class
Referrers Members
Overload List


%%PageItemTitle%%

CopyTo(Referrer[]) Method
[image]
dotnetCART Namespace > Referrers Class > CopyTo Method : CopyTo(Referrer[]) Method

array

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array() As Referrer _
)
C#
public void CopyTo(
   Referrer[] array
)

Parameters

array

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrers Class
Referrers Members
Overload List


%%PageItemTitle%%

CopyTo(Referrer[],Int32) Method
[image]
dotnetCART Namespace > Referrers Class > CopyTo Method : CopyTo(Referrer[],Int32) Method

array
arrayIndex

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array() As Referrer, _
   ByVal arrayIndex As Integer _
)
C#
public void CopyTo(
   Referrer[] array,
   int arrayIndex
)

Parameters

array
arrayIndex

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrers Class
Referrers Members
Overload List


%%PageItemTitle%%

Count Property
[image]
dotnetCART Namespace > Referrers Class : Count Property

Gets the number of elements actually contained in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrers Class
Referrers Members


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > Referrers Class : Error Property

Returns an object with the error information.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrers Class
Referrers Members


%%PageItemTitle%%

GetEnumerator Method
[image]
dotnetCART Namespace > Referrers Class : GetEnumerator Method

Returns an enumerator that iterates through the List.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As List.Enumerator(Of Referrer)
C#
public List.Enumerator<Referrer> GetEnumerator()

Return Value

A List.Enumerator for the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrers Class
Referrers Members


%%PageItemTitle%%

IndexOf Method
[image]
dotnetCART Namespace > Referrers Class : IndexOf Method

Overload List

Overload | Description
IndexOf(Referrer) | (Inherited from dotnetCART.ListBase<Referrer>)
IndexOf(Referrer,Int32) | (Inherited from dotnetCART.ListBase<Referrer>)
IndexOf(Referrer,Int32,Int32) | (Inherited from dotnetCART.ListBase<Referrer>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrers Class
Referrers Members


%%PageItemTitle%%

IndexOf(Referrer) Method
[image]
dotnetCART Namespace > Referrers Class > IndexOf Method : IndexOf(Referrer) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As Referrer _
) As Integer
C#
public int IndexOf(
   Referrer item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrers Class
Referrers Members
Overload List


%%PageItemTitle%%

IndexOf(Referrer,Int32) Method
[image]
dotnetCART Namespace > Referrers Class > IndexOf Method : IndexOf(Referrer,Int32) Method

item
index

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As Referrer, _
   ByVal index As Integer _
) As Integer
C#
public int IndexOf(
   Referrer item,
   int index
)

Parameters

item
index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrers Class
Referrers Members
Overload List


%%PageItemTitle%%

IndexOf(Referrer,Int32,Int32) Method
[image]
dotnetCART Namespace > Referrers Class > IndexOf Method : IndexOf(Referrer,Int32,Int32) Method

item
index
count

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As Referrer, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
C#
public int IndexOf(
   Referrer item,
   int index,
   int count
)

Parameters

item
index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrers Class
Referrers Members
Overload List


%%PageItemTitle%%

Insert Method
[image]
dotnetCART Namespace > Referrers Class : Insert Method

index
item
Inserts an element into the List at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As Referrer _
)
C#
public void Insert(
   int index,
   Referrer item
)

Parameters

index
item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrers Class
Referrers Members


%%PageItemTitle%%

InsertRange Method
[image]
dotnetCART Namespace > Referrers Class : InsertRange Method

index
collection
Inserts the elements of a collection into the List at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub InsertRange( _
   ByVal index As Integer, _
   ByVal collection As IEnumerable(Of Referrer) _
)
C#
public void InsertRange(
   int index,
   IEnumerable<Referrer> collection
)

Parameters

index
collection

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrers Class
Referrers Members


%%PageItemTitle%%

Item Property
[image]
dotnetCART Namespace > Referrers Class : Item Property

index
Gets or sets the element at the specified index.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As Referrer
C#
public Referrer this[
   int index
]; {get; set;}

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrers Class
Referrers Members


%%PageItemTitle%%

LastIndexOf Method
[image]
dotnetCART Namespace > Referrers Class : LastIndexOf Method

Overload List

Overload | Description
LastIndexOf(Referrer) | (Inherited from dotnetCART.ListBase<Referrer>)
LastIndexOf(Referrer,Int32) | (Inherited from dotnetCART.ListBase<Referrer>)
LastIndexOf(Referrer,Int32,Int32) | (Inherited from dotnetCART.ListBase<Referrer>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrers Class
Referrers Members


%%PageItemTitle%%

LastIndexOf(Referrer) Method
[image]
dotnetCART Namespace > Referrers Class > LastIndexOf Method : LastIndexOf(Referrer) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As Referrer _
) As Integer
C#
public int LastIndexOf(
   Referrer item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrers Class
Referrers Members
Overload List


%%PageItemTitle%%

LastIndexOf(Referrer,Int32) Method
[image]
dotnetCART Namespace > Referrers Class > LastIndexOf Method : LastIndexOf(Referrer,Int32) Method

item
index

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As Referrer, _
   ByVal index As Integer _
) As Integer
C#
public int LastIndexOf(
   Referrer item,
   int index
)

Parameters

item
index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrers Class
Referrers Members
Overload List


%%PageItemTitle%%

LastIndexOf(Referrer,Int32,Int32) Method
[image]
dotnetCART Namespace > Referrers Class > LastIndexOf Method : LastIndexOf(Referrer,Int32,Int32) Method

item
index
count

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As Referrer, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
C#
public int LastIndexOf(
   Referrer item,
   int index,
   int count
)

Parameters

item
index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrers Class
Referrers Members
Overload List


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > Referrers Class > LoadDB Method : LoadDB() Method

Loads all the items from its associated table.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB() As Integer
C#
public virtual int LoadDB()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrers Class
Referrers Members
Overload List


%%PageItemTitle%%

LoadDB(Int32,Int32) Method
[image]
dotnetCART Namespace > Referrers Class > LoadDB Method : LoadDB(Int32,Int32) Method

start
count
Loads the count number of elements from start value.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal start As Integer, _
   ByVal count As Integer _
) As Integer
C#
public virtual int LoadDB(
   int start,
   int count
)

Parameters

start
count

Return Value

The total number of elements have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrers Class
Referrers Members
Overload List


%%PageItemTitle%%

LoadDB(Where) Method
[image]
dotnetCART Namespace > Referrers Class > LoadDB Method : LoadDB(Where) Method

whereClause
Loads all the items from its associated table based on the where clause.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal whereClause As Where _
) As Integer
C#
public virtual int LoadDB(
   Where whereClause
)

Parameters

whereClause

Return Value

The total number of items have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrers Class
Referrers Members
Overload List


%%PageItemTitle%%

Remove Method
[image]
dotnetCART Namespace > Referrers Class : Remove Method

item
Removes the first occurrence of a specific object from the List.

Syntax

Visual Basic (Declaration)
Public Function Remove( _
   ByVal item As Referrer _
) As Boolean
C#
public bool Remove(
   Referrer item
)

Parameters

item

Return Value

true if item is successfully removed; otherwise, false. This method also returns false if item was not found in the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrers Class
Referrers Members


%%PageItemTitle%%

RemoveAll Method
[image]
dotnetCART Namespace > Referrers Class : RemoveAll Method

match
Removes the all the elements that match the conditions defined by the specified predicate.

Syntax

Visual Basic (Declaration)
Public Function RemoveAll( _
   ByVal match As Predicate(Of Referrer) _
) As Integer
C#
public int RemoveAll(
   Predicate<Referrer> match
)

Parameters

match

Return Value

The number of elements removed from the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrers Class
Referrers Members


%%PageItemTitle%%

RemoveAt Method
[image]
dotnetCART Namespace > Referrers Class : RemoveAt Method

index
Removes the element at the specified index of the List.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrers Class
Referrers Members


%%PageItemTitle%%

RemoveRange Method
[image]
dotnetCART Namespace > Referrers Class : RemoveRange Method

index
count
Removes a range of elements from the List.

Syntax

Visual Basic (Declaration)
Public Sub RemoveRange( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
C#
public void RemoveRange(
   int index,
   int count
)

Parameters

index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrers Class
Referrers Members


%%PageItemTitle%%

Reverse Method
[image]
dotnetCART Namespace > Referrers Class : Reverse Method

Reverses the order of the elements in the entire List.

Overload List

Overload | Description
Reverse() | Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<Referrer>)
Reverse(Int32,Int32) | Reverses the order of the elements in the specified range. (Inherited from dotnetCART.ListBase<Referrer>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrers Class
Referrers Members


%%PageItemTitle%%

Reverse() Method
[image]
dotnetCART Namespace > Referrers Class > Reverse Method : Reverse() Method

Reverses the order of the elements in the entire List.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Reverse()
C#
public void Reverse()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrers Class
Referrers Members
Overload List


%%PageItemTitle%%

Reverse(Int32,Int32) Method
[image]
dotnetCART Namespace > Referrers Class > Reverse Method : Reverse(Int32,Int32) Method

index
count
Reverses the order of the elements in the specified range.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Reverse( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
C#
public void Reverse(
   int index,
   int count
)

Parameters

index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrers Class
Referrers Members
Overload List


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > Referrer Class : Clear Method

Initializes all the properties without recreating the object.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Clear()
C#
public virtual void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrer Class
Referrer Members


%%PageItemTitle%%

Custom Property
[image]
dotnetCART Namespace > Referrer Class : Custom Property

Gets or sets a custom object. For more information see custom fields

Syntax

Visual Basic (Declaration)
Public Property Custom As Custom
C#
public Custom Custom {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrer Class
Referrer Members


%%PageItemTitle%%

CustomFields Property
See Also Example
[image]
dotnetCART Namespace > Referrer Class : CustomFields Property

Gets or sets a the names of custom fields for a table associated with the object.

Syntax

Visual Basic (Declaration)
Public Property CustomFields As String
C#
public string CustomFields {get; set;}

Example

C# Copy Code
Customer.CustomFields = "CellPhone,Favorites";

Visual Basic Copy Code
Customer.CustomFields = "CellPhone,Favorites"

Remarks

Custom fields must be added to the table manualy. Custom fields are usually set at store level using CustomFields

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrer Class
Referrer Members


%%PageItemTitle%%

Customs Property
[image]
dotnetCART Namespace > Referrer Class : Customs Property

A reference to the collection of the Custom objects.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Customs As Customs
C#
public Customs Customs {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrer Class
Referrer Members


%%PageItemTitle%%

DeleteDB Method
[image]
dotnetCART Namespace > Referrer Class : DeleteDB Method

Deletes this object with ID from the database.

Overload List

Overload | Description
DeleteDB() | Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<Referrer, Int64>)
DeleteDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrer Class
Referrer Members


%%PageItemTitle%%

DeleteDB() Method
[image]
dotnetCART Namespace > Referrer Class > DeleteDB Method : DeleteDB() Method

Deletes this object with ID from the database.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function DeleteDB() As Integer
C#
public virtual int DeleteDB()

Return Value

In case of error -1, check Error property, otherwise the number of objects deleted.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrer Class
Referrer Members
Overload List


%%PageItemTitle%%

DeleteDB(DbManager) Method
[image]
dotnetCART Namespace > Referrer Class > DeleteDB Method : DeleteDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function DeleteDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int DeleteDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrer Class
Referrer Members
Overload List


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > Referrer Class : Error Property

Gets the error object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrer Class
Referrer Members


%%PageItemTitle%%

GetCustom Method
[image]
dotnetCART Namespace > Referrer Class : GetCustom Method

This method returns the value of a custom field based on its name in the customs collection.

Overload List

Overload | Description
GetCustom(String) | This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<Referrer, Int64>)
GetCustom(Int32) | This method returns the value of a custom field based on its index in the customs collection. (Inherited from dotnetCART.DbTableCart<Referrer, Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrer Class
Referrer Members


%%PageItemTitle%%

GetCustom(Int32) Method
[image]
dotnetCART Namespace > Referrer Class > GetCustom Method : GetCustom(Int32) Method

customIndex
This method returns the value of a custom field based on its index in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal customIndex As Integer _
) As Object
C#
public object GetCustom(
   int customIndex
)

Parameters

customIndex

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrer Class
Referrer Members
Overload List


%%PageItemTitle%%

GetCustom(String) Method
[image]
dotnetCART Namespace > Referrer Class > GetCustom Method : GetCustom(String) Method

name
This method returns the value of a custom field based on its name in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal name As String _
) As Object
C#
public object GetCustom(
   string name
)

Parameters

name

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrer Class
Referrer Members
Overload List


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > Referrer Class : LoadDB Method

Loads this object from database using the ID property.

Overload List

Overload | Description
LoadDB(Int64) | (Inherited from dotnetCART.DbTableCart<Referrer, Int64>)
LoadDB() | Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<Referrer, Int64>)
Generic LoadDB() | (Inherited from dotnetDATA.DbTable<Int64>)
Generic LoadDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrer Class
Referrer Members


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > Referrer Class > LoadDB Method : LoadDB() Method

Loads this object from database using the ID property.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB() As Integer
C#
public virtual int LoadDB()

Return Value

In case of error -1, check Error property, if the object with the ID property not found 0, otherwise 1.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrer Class
Referrer Members
Overload List


%%PageItemTitle%%

LoadDB(Int64) Method
[image]
dotnetCART Namespace > Referrer Class > LoadDB Method : LoadDB(Int64) Method

id

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal id As Long _
) As Integer
C#
public virtual int LoadDB(
   long id
)

Parameters

id

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrer Class
Referrer Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB() Method
See Also
[image]
dotnetCART Namespace > Referrer Class > LoadDB Method : Generic LoadDB() Method

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)() As Integer
C#
public virtual int LoadDB<T1>()where T1: IDbTable

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrer Class
Referrer Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB(DbManager) Method
See Also
[image]
dotnetCART Namespace > Referrer Class > LoadDB Method : Generic LoadDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int LoadDB<T1>(
   DbManager manager
)where T1: IDbTable

Parameters

manager

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrer Class
Referrer Members
Overload List


%%PageItemTitle%%

SaveDB(DbManager) Method
[image]
dotnetCART Namespace > Referrer Class > SaveDB Method : SaveDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function SaveDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int SaveDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrer Class
Referrer Members
Overload List


%%PageItemTitle%%

SetCustom Method
[image]
dotnetCART Namespace > Referrer Class : SetCustom Method

name
newValue
This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added.

Syntax

Visual Basic (Declaration)
Public Function SetCustom( _
   ByVal name As String, _
   ByVal newValue As Object _
) As Object
C#
public object SetCustom(
   string name,
   object newValue
)

Parameters

name
newValue

Return Value

Returns the new custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Referrer Class
Referrer Members


%%PageItemTitle%% $$Properties$$

Reviews Class Properties
[image]
dotnetCART Namespace : Reviews Class

For a list of all members of this type, see Reviews members.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from dotnetCART.ListBase<Review>)
Public Property | Count | Gets the number of elements actually contained in the collection. (Inherited from dotnetCART.ListBase<Review>)
Public Property | Error | Returns an object with the error information. (Inherited from dotnetCART.ListBase<Review>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from dotnetCART.ListBase<Review>)
Top

See Also

Reference

Reviews Class
dotnetCART Namespace


%%PageItemTitle%%

Add Method
[image]
dotnetCART Namespace > Reviews Class : Add Method

item
Adds an object to the end of the collection.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal item As Review _
)
C#
public void Add(
   Review item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Reviews Class
Reviews Members


%%PageItemTitle%%

AddRange Method
[image]
dotnetCART Namespace > Reviews Class : AddRange Method

collection
Adds the elements of the specified collection to the end of the collection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal collection As IEnumerable(Of Review) _
)
C#
public void AddRange(
   IEnumerable<Review> collection
)

Parameters

collection

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Reviews Class
Reviews Members


%%PageItemTitle%%

AsReadOnly Method
[image]
dotnetCART Namespace > Reviews Class : AsReadOnly Method

Returns a read-only IList wrapper for the current collection.

Syntax

Visual Basic (Declaration)
Public Function AsReadOnly() As ReadOnlyCollection(Of Review)
C#
public ReadOnlyCollection<Review> AsReadOnly()

Return Value

A ReadOnlyCollection that acts as a read-only wrapper around the current List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Reviews Class
Reviews Members


%%PageItemTitle%%

BinarySearch Method
[image]
dotnetCART Namespace > Reviews Class : BinarySearch Method

Overload List

Overload | Description
BinarySearch(Review) | (Inherited from dotnetCART.ListBase<Review>)
BinarySearch(Review,Generic IComparer) | (Inherited from dotnetCART.ListBase<Review>)
BinarySearch(Int32,Int32,Review,Generic IComparer) | (Inherited from dotnetCART.ListBase<Review>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Reviews Class
Reviews Members


%%PageItemTitle%%

BinarySearch(Int32,Int32,Review,Generic IComparer) Method
[image]
dotnetCART Namespace > Reviews Class > BinarySearch Method : BinarySearch(Int32,Int32,Review,Generic IComparer) Method

index
count
item
comparer

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal index As Integer, _
   ByVal count As Integer, _
   ByVal item As Review, _
   ByVal comparer As IComparer(Of Review) _
) As Integer
C#
public int BinarySearch(
   int index,
   int count,
   Review item,
   IComparer<Review> comparer
)

Parameters

index
count
item
comparer

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Reviews Class
Reviews Members
Overload List


%%PageItemTitle%%

BinarySearch(Review) Method
[image]
dotnetCART Namespace > Reviews Class > BinarySearch Method : BinarySearch(Review) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal item As Review _
) As Integer
C#
public int BinarySearch(
   Review item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Reviews Class
Reviews Members
Overload List


%%PageItemTitle%%

BinarySearch(Review,Generic IComparer) Method
[image]
dotnetCART Namespace > Reviews Class > BinarySearch Method : BinarySearch(Review,Generic IComparer) Method

item
comparer

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal item As Review, _
   ByVal comparer As IComparer(Of Review) _
) As Integer
C#
public int BinarySearch(
   Review item,
   IComparer<Review> comparer
)

Parameters

item
comparer

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Reviews Class
Reviews Members
Overload List


%%PageItemTitle%%

Capacity Property
[image]
dotnetCART Namespace > Reviews Class : Capacity Property

Gets or sets the total number of elements the internal data structure can hold without resizing.

Syntax

Visual Basic (Declaration)
Public Property Capacity As Integer
C#
public int Capacity {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Reviews Class
Reviews Members


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > Reviews Class : Clear Method

Removes all elements from the List.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Reviews Class
Reviews Members


%%PageItemTitle%%

Contains Method
[image]
dotnetCART Namespace > Reviews Class : Contains Method

item
Determines whether an element is in the List.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal item As Review _
) As Boolean
C#
public bool Contains(
   Review item
)

Parameters

item

Return Value

true if item is found in the List; otherwise, false.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Reviews Class
Reviews Members


%%PageItemTitle%%

CopyTo Method
[image]
dotnetCART Namespace > Reviews Class : CopyTo Method

Overload List

Overload | Description
CopyTo(Review[]) | (Inherited from dotnetCART.ListBase<Review>)
CopyTo(Review[],Int32) | (Inherited from dotnetCART.ListBase<Review>)
CopyTo(Int32,Review[],Int32,Int32) | (Inherited from dotnetCART.ListBase<Review>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Reviews Class
Reviews Members


%%PageItemTitle%%

CopyTo(Int32,Review[],Int32,Int32) Method
[image]
dotnetCART Namespace > Reviews Class > CopyTo Method : CopyTo(Int32,Review[],Int32,Int32) Method

index
array
arrayIndex
count

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal index As Integer, _
   ByVal array() As Review, _
   ByVal arrayIndex As Integer, _
   ByVal count As Integer _
)
C#
public void CopyTo(
   int index,
   Review[] array,
   int arrayIndex,
   int count
)

Parameters

index
array
arrayIndex
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Reviews Class
Reviews Members
Overload List


%%PageItemTitle%%

CopyTo(Review[]) Method
[image]
dotnetCART Namespace > Reviews Class > CopyTo Method : CopyTo(Review[]) Method

array

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array() As Review _
)
C#
public void CopyTo(
   Review[] array
)

Parameters

array

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Reviews Class
Reviews Members
Overload List


%%PageItemTitle%%

CopyTo(Review[],Int32) Method
[image]
dotnetCART Namespace > Reviews Class > CopyTo Method : CopyTo(Review[],Int32) Method

array
arrayIndex

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array() As Review, _
   ByVal arrayIndex As Integer _
)
C#
public void CopyTo(
   Review[] array,
   int arrayIndex
)

Parameters

array
arrayIndex

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Reviews Class
Reviews Members
Overload List


%%PageItemTitle%%

Count Property
[image]
dotnetCART Namespace > Reviews Class : Count Property

Gets the number of elements actually contained in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Reviews Class
Reviews Members


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > Reviews Class : Error Property

Returns an object with the error information.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Reviews Class
Reviews Members


%%PageItemTitle%%

GetEnumerator Method
[image]
dotnetCART Namespace > Reviews Class : GetEnumerator Method

Returns an enumerator that iterates through the List.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As List.Enumerator(Of Review)
C#
public List.Enumerator<Review> GetEnumerator()

Return Value

A List.Enumerator for the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Reviews Class
Reviews Members


%%PageItemTitle%%

IndexOf Method
[image]
dotnetCART Namespace > Reviews Class : IndexOf Method

Overload List

Overload | Description
IndexOf(Review) | (Inherited from dotnetCART.ListBase<Review>)
IndexOf(Review,Int32) | (Inherited from dotnetCART.ListBase<Review>)
IndexOf(Review,Int32,Int32) | (Inherited from dotnetCART.ListBase<Review>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Reviews Class
Reviews Members


%%PageItemTitle%%

IndexOf(Review) Method
[image]
dotnetCART Namespace > Reviews Class > IndexOf Method : IndexOf(Review) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As Review _
) As Integer
C#
public int IndexOf(
   Review item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Reviews Class
Reviews Members
Overload List


%%PageItemTitle%%

IndexOf(Review,Int32) Method
[image]
dotnetCART Namespace > Reviews Class > IndexOf Method : IndexOf(Review,Int32) Method

item
index

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As Review, _
   ByVal index As Integer _
) As Integer
C#
public int IndexOf(
   Review item,
   int index
)

Parameters

item
index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Reviews Class
Reviews Members
Overload List


%%PageItemTitle%%

IndexOf(Review,Int32,Int32) Method
[image]
dotnetCART Namespace > Reviews Class > IndexOf Method : IndexOf(Review,Int32,Int32) Method

item
index
count

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As Review, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
C#
public int IndexOf(
   Review item,
   int index,
   int count
)

Parameters

item
index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Reviews Class
Reviews Members
Overload List


%%PageItemTitle%%

Insert Method
[image]
dotnetCART Namespace > Reviews Class : Insert Method

index
item
Inserts an element into the List at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As Review _
)
C#
public void Insert(
   int index,
   Review item
)

Parameters

index
item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Reviews Class
Reviews Members


%%PageItemTitle%%

InsertRange Method
[image]
dotnetCART Namespace > Reviews Class : InsertRange Method

index
collection
Inserts the elements of a collection into the List at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub InsertRange( _
   ByVal index As Integer, _
   ByVal collection As IEnumerable(Of Review) _
)
C#
public void InsertRange(
   int index,
   IEnumerable<Review> collection
)

Parameters

index
collection

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Reviews Class
Reviews Members


%%PageItemTitle%%

Item Property
[image]
dotnetCART Namespace > Reviews Class : Item Property

index
Gets or sets the element at the specified index.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As Review
C#
public Review this[
   int index
]; {get; set;}

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Reviews Class
Reviews Members


%%PageItemTitle%%

LastIndexOf Method
[image]
dotnetCART Namespace > Reviews Class : LastIndexOf Method

Overload List

Overload | Description
LastIndexOf(Review) | (Inherited from dotnetCART.ListBase<Review>)
LastIndexOf(Review,Int32) | (Inherited from dotnetCART.ListBase<Review>)
LastIndexOf(Review,Int32,Int32) | (Inherited from dotnetCART.ListBase<Review>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Reviews Class
Reviews Members


%%PageItemTitle%%

LastIndexOf(Review) Method
[image]
dotnetCART Namespace > Reviews Class > LastIndexOf Method : LastIndexOf(Review) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As Review _
) As Integer
C#
public int LastIndexOf(
   Review item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Reviews Class
Reviews Members
Overload List


%%PageItemTitle%%

LastIndexOf(Review,Int32) Method
[image]
dotnetCART Namespace > Reviews Class > LastIndexOf Method : LastIndexOf(Review,Int32) Method

item
index

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As Review, _
   ByVal index As Integer _
) As Integer
C#
public int LastIndexOf(
   Review item,
   int index
)

Parameters

item
index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Reviews Class
Reviews Members
Overload List


%%PageItemTitle%%

LastIndexOf(Review,Int32,Int32) Method
[image]
dotnetCART Namespace > Reviews Class > LastIndexOf Method : LastIndexOf(Review,Int32,Int32) Method

item
index
count

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As Review, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
C#
public int LastIndexOf(
   Review item,
   int index,
   int count
)

Parameters

item
index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Reviews Class
Reviews Members
Overload List


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > Reviews Class > LoadDB Method : LoadDB() Method

Loads all the items from its associated table.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB() As Integer
C#
public virtual int LoadDB()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Reviews Class
Reviews Members
Overload List


%%PageItemTitle%%

LoadDB(Int32,Int32) Method
[image]
dotnetCART Namespace > Reviews Class > LoadDB Method : LoadDB(Int32,Int32) Method

start
count
Loads the count number of elements from start value.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal start As Integer, _
   ByVal count As Integer _
) As Integer
C#
public virtual int LoadDB(
   int start,
   int count
)

Parameters

start
count

Return Value

The total number of elements have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Reviews Class
Reviews Members
Overload List


%%PageItemTitle%%

LoadDB(Where) Method
[image]
dotnetCART Namespace > Reviews Class > LoadDB Method : LoadDB(Where) Method

whereClause
Loads all the items from its associated table based on the where clause.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal whereClause As Where _
) As Integer
C#
public virtual int LoadDB(
   Where whereClause
)

Parameters

whereClause

Return Value

The total number of items have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Reviews Class
Reviews Members
Overload List


%%PageItemTitle%%

Remove Method
[image]
dotnetCART Namespace > Reviews Class : Remove Method

item
Removes the first occurrence of a specific object from the List.

Syntax

Visual Basic (Declaration)
Public Function Remove( _
   ByVal item As Review _
) As Boolean
C#
public bool Remove(
   Review item
)

Parameters

item

Return Value

true if item is successfully removed; otherwise, false. This method also returns false if item was not found in the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Reviews Class
Reviews Members


%%PageItemTitle%%

RemoveAll Method
[image]
dotnetCART Namespace > Reviews Class : RemoveAll Method

match
Removes the all the elements that match the conditions defined by the specified predicate.

Syntax

Visual Basic (Declaration)
Public Function RemoveAll( _
   ByVal match As Predicate(Of Review) _
) As Integer
C#
public int RemoveAll(
   Predicate<Review> match
)

Parameters

match

Return Value

The number of elements removed from the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Reviews Class
Reviews Members


%%PageItemTitle%%

RemoveAt Method
[image]
dotnetCART Namespace > Reviews Class : RemoveAt Method

index
Removes the element at the specified index of the List.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Reviews Class
Reviews Members


%%PageItemTitle%%

RemoveRange Method
[image]
dotnetCART Namespace > Reviews Class : RemoveRange Method

index
count
Removes a range of elements from the List.

Syntax

Visual Basic (Declaration)
Public Sub RemoveRange( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
C#
public void RemoveRange(
   int index,
   int count
)

Parameters

index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Reviews Class
Reviews Members


%%PageItemTitle%%

Reverse Method
[image]
dotnetCART Namespace > Reviews Class : Reverse Method

Reverses the order of the elements in the entire List.

Overload List

Overload | Description
Reverse() | Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<Review>)
Reverse(Int32,Int32) | Reverses the order of the elements in the specified range. (Inherited from dotnetCART.ListBase<Review>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Reviews Class
Reviews Members


%%PageItemTitle%%

Reverse() Method
[image]
dotnetCART Namespace > Reviews Class > Reverse Method : Reverse() Method

Reverses the order of the elements in the entire List.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Reverse()
C#
public void Reverse()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Reviews Class
Reviews Members
Overload List


%%PageItemTitle%%

Reverse(Int32,Int32) Method
[image]
dotnetCART Namespace > Reviews Class > Reverse Method : Reverse(Int32,Int32) Method

index
count
Reverses the order of the elements in the specified range.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Reverse( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
C#
public void Reverse(
   int index,
   int count
)

Parameters

index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Reviews Class
Reviews Members
Overload List


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > Review Class : Clear Method

Initializes all the properties without recreating the object.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Clear()
C#
public virtual void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Review Class
Review Members


%%PageItemTitle%%

Custom Property
[image]
dotnetCART Namespace > Review Class : Custom Property

Gets or sets a custom object. For more information see custom fields

Syntax

Visual Basic (Declaration)
Public Property Custom As Custom
C#
public Custom Custom {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Review Class
Review Members


%%PageItemTitle%%

CustomFields Property
See Also Example
[image]
dotnetCART Namespace > Review Class : CustomFields Property

Gets or sets a the names of custom fields for a table associated with the object.

Syntax

Visual Basic (Declaration)
Public Property CustomFields As String
C#
public string CustomFields {get; set;}

Example

C# Copy Code
Customer.CustomFields = "CellPhone,Favorites";

Visual Basic Copy Code
Customer.CustomFields = "CellPhone,Favorites"

Remarks

Custom fields must be added to the table manualy. Custom fields are usually set at store level using CustomFields

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Review Class
Review Members


%%PageItemTitle%%

Customs Property
[image]
dotnetCART Namespace > Review Class : Customs Property

A reference to the collection of the Custom objects.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Customs As Customs
C#
public Customs Customs {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Review Class
Review Members


%%PageItemTitle%%

DeleteDB Method
[image]
dotnetCART Namespace > Review Class : DeleteDB Method

Deletes this object with ID from the database.

Overload List

Overload | Description
DeleteDB() | Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<Review, Int64>)
DeleteDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Review Class
Review Members


%%PageItemTitle%%

DeleteDB() Method
[image]
dotnetCART Namespace > Review Class > DeleteDB Method : DeleteDB() Method

Deletes this object with ID from the database.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function DeleteDB() As Integer
C#
public virtual int DeleteDB()

Return Value

In case of error -1, check Error property, otherwise the number of objects deleted.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Review Class
Review Members
Overload List


%%PageItemTitle%%

DeleteDB(DbManager) Method
[image]
dotnetCART Namespace > Review Class > DeleteDB Method : DeleteDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function DeleteDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int DeleteDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Review Class
Review Members
Overload List


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > Review Class : Error Property

Gets the error object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Review Class
Review Members


%%PageItemTitle%%

GetCustom Method
[image]
dotnetCART Namespace > Review Class : GetCustom Method

This method returns the value of a custom field based on its name in the customs collection.

Overload List

Overload | Description
GetCustom(String) | This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<Review, Int64>)
GetCustom(Int32) | This method returns the value of a custom field based on its index in the customs collection. (Inherited from dotnetCART.DbTableCart<Review, Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Review Class
Review Members


%%PageItemTitle%%

GetCustom(Int32) Method
[image]
dotnetCART Namespace > Review Class > GetCustom Method : GetCustom(Int32) Method

customIndex
This method returns the value of a custom field based on its index in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal customIndex As Integer _
) As Object
C#
public object GetCustom(
   int customIndex
)

Parameters

customIndex

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Review Class
Review Members
Overload List


%%PageItemTitle%%

GetCustom(String) Method
[image]
dotnetCART Namespace > Review Class > GetCustom Method : GetCustom(String) Method

name
This method returns the value of a custom field based on its name in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal name As String _
) As Object
C#
public object GetCustom(
   string name
)

Parameters

name

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Review Class
Review Members
Overload List


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > Review Class : LoadDB Method

Loads this object from database using the ID property.

Overload List

Overload | Description
LoadDB(Int64) | (Inherited from dotnetCART.DbTableCart<Review, Int64>)
LoadDB() | Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<Review, Int64>)
Generic LoadDB() | (Inherited from dotnetDATA.DbTable<Int64>)
Generic LoadDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Review Class
Review Members


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > Review Class > LoadDB Method : LoadDB() Method

Loads this object from database using the ID property.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB() As Integer
C#
public virtual int LoadDB()

Return Value

In case of error -1, check Error property, if the object with the ID property not found 0, otherwise 1.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Review Class
Review Members
Overload List


%%PageItemTitle%%

LoadDB(Int64) Method
[image]
dotnetCART Namespace > Review Class > LoadDB Method : LoadDB(Int64) Method

id

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal id As Long _
) As Integer
C#
public virtual int LoadDB(
   long id
)

Parameters

id

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Review Class
Review Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB() Method
See Also
[image]
dotnetCART Namespace > Review Class > LoadDB Method : Generic LoadDB() Method

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)() As Integer
C#
public virtual int LoadDB<T1>()where T1: IDbTable

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Review Class
Review Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB(DbManager) Method
See Also
[image]
dotnetCART Namespace > Review Class > LoadDB Method : Generic LoadDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int LoadDB<T1>(
   DbManager manager
)where T1: IDbTable

Parameters

manager

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Review Class
Review Members
Overload List


%%PageItemTitle%%

SaveDB Method
[image]
dotnetCART Namespace > Review Class : SaveDB Method

Inserts or updates this object into the database.

Overload List

Overload | Description
SaveDB() | Inserts or updates this object into the database. (Inherited from dotnetCART.DbTableCart<Review, Int64>)
SaveDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Review Class
Review Members


%%PageItemTitle%%

SaveDB() Method
[image]
dotnetCART Namespace > Review Class > SaveDB Method : SaveDB() Method

Inserts or updates this object into the database.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function SaveDB() As Integer
C#
public virtual int SaveDB()

Return Value

Returns the generated ID or 1 for the update, returns -1 if failed. For the reason of fail, check the Generic DbTableCart.Error property.

Remarks

If Generic DbTableCart.ID greater than 0, it updates the associated object in the table, otherwise inserts a new object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Review Class
Review Members
Overload List


%%PageItemTitle%%

SaveDB(DbManager) Method
[image]
dotnetCART Namespace > Review Class > SaveDB Method : SaveDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function SaveDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int SaveDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Review Class
Review Members
Overload List


%%PageItemTitle%%

SetCustom Method
[image]
dotnetCART Namespace > Review Class : SetCustom Method

name
newValue
This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added.

Syntax

Visual Basic (Declaration)
Public Function SetCustom( _
   ByVal name As String, _
   ByVal newValue As Object _
) As Object
C#
public object SetCustom(
   string name,
   object newValue
)

Parameters

name
newValue

Return Value

Returns the new custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Review Class
Review Members


%%PageItemTitle%% $$Properties$$

ShipCompanies Class Properties
[image]
dotnetCART Namespace : ShipCompanies Class

For a list of all members of this type, see ShipCompanies members.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from dotnetCART.ListBase<ShipCompany>)
Public Property | Count | Gets the number of elements actually contained in the collection. (Inherited from dotnetCART.ListBase<ShipCompany>)
Public Property | Error | Returns an object with the error information. (Inherited from dotnetCART.ListBase<ShipCompany>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from dotnetCART.ListBase<ShipCompany>)
Top

See Also

Reference

ShipCompanies Class
dotnetCART Namespace


%%PageItemTitle%%

AddRange Method
[image]
dotnetCART Namespace > ShipCompanies Class : AddRange Method

collection
Adds the elements of the specified collection to the end of the collection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal collection As IEnumerable(Of ShipCompany) _
)
C#
public void AddRange(
   IEnumerable<ShipCompany> collection
)

Parameters

collection

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompanies Class
ShipCompanies Members


%%PageItemTitle%%

AsReadOnly Method
[image]
dotnetCART Namespace > ShipCompanies Class : AsReadOnly Method

Returns a read-only IList wrapper for the current collection.

Syntax

Visual Basic (Declaration)
Public Function AsReadOnly() As ReadOnlyCollection(Of ShipCompany)
C#
public ReadOnlyCollection<ShipCompany> AsReadOnly()

Return Value

A ReadOnlyCollection that acts as a read-only wrapper around the current List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompanies Class
ShipCompanies Members


%%PageItemTitle%%

BinarySearch Method
[image]
dotnetCART Namespace > ShipCompanies Class : BinarySearch Method

Overload List

Overload | Description
BinarySearch(ShipCompany) | (Inherited from dotnetCART.ListBase<ShipCompany>)
BinarySearch(ShipCompany,Generic IComparer) | (Inherited from dotnetCART.ListBase<ShipCompany>)
BinarySearch(Int32,Int32,ShipCompany,Generic IComparer) | (Inherited from dotnetCART.ListBase<ShipCompany>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompanies Class
ShipCompanies Members


%%PageItemTitle%%

BinarySearch(Int32,Int32,ShipCompany,Generic IComparer) Method
See Also
[image]
dotnetCART Namespace > ShipCompanies Class > BinarySearch Method : BinarySearch(Int32,Int32,ShipCompany,Generic IComparer) Method

index
count
item
comparer

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal index As Integer, _
   ByVal count As Integer, _
   ByVal item As ShipCompany, _
   ByVal comparer As IComparer(Of ShipCompany) _
) As Integer
C#
public int BinarySearch(
   int index,
   int count,
   ShipCompany item,
   IComparer<ShipCompany> comparer
)

Parameters

index
count
item
comparer

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompanies Class
ShipCompanies Members
Overload List


%%PageItemTitle%%

BinarySearch(ShipCompany) Method
[image]
dotnetCART Namespace > ShipCompanies Class > BinarySearch Method : BinarySearch(ShipCompany) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal item As ShipCompany _
) As Integer
C#
public int BinarySearch(
   ShipCompany item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompanies Class
ShipCompanies Members
Overload List


%%PageItemTitle%%

BinarySearch(ShipCompany,Generic IComparer) Method
[image]
dotnetCART Namespace > ShipCompanies Class > BinarySearch Method : BinarySearch(ShipCompany,Generic IComparer) Method

item
comparer

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal item As ShipCompany, _
   ByVal comparer As IComparer(Of ShipCompany) _
) As Integer
C#
public int BinarySearch(
   ShipCompany item,
   IComparer<ShipCompany> comparer
)

Parameters

item
comparer

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompanies Class
ShipCompanies Members
Overload List


%%PageItemTitle%%

Capacity Property
[image]
dotnetCART Namespace > ShipCompanies Class : Capacity Property

Gets or sets the total number of elements the internal data structure can hold without resizing.

Syntax

Visual Basic (Declaration)
Public Property Capacity As Integer
C#
public int Capacity {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompanies Class
ShipCompanies Members


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > ShipCompanies Class : Clear Method

Removes all elements from the List.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompanies Class
ShipCompanies Members


%%PageItemTitle%%

Contains Method
[image]
dotnetCART Namespace > ShipCompanies Class : Contains Method

item
Determines whether an element is in the List.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal item As ShipCompany _
) As Boolean
C#
public bool Contains(
   ShipCompany item
)

Parameters

item

Return Value

true if item is found in the List; otherwise, false.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompanies Class
ShipCompanies Members


%%PageItemTitle%%

CopyTo Method
[image]
dotnetCART Namespace > ShipCompanies Class : CopyTo Method

Overload List

Overload | Description
CopyTo(ShipCompany[]) | (Inherited from dotnetCART.ListBase<ShipCompany>)
CopyTo(ShipCompany[],Int32) | (Inherited from dotnetCART.ListBase<ShipCompany>)
CopyTo(Int32,ShipCompany[],Int32,Int32) | (Inherited from dotnetCART.ListBase<ShipCompany>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompanies Class
ShipCompanies Members


%%PageItemTitle%%

CopyTo(Int32,ShipCompany[],Int32,Int32) Method
[image]
dotnetCART Namespace > ShipCompanies Class > CopyTo Method : CopyTo(Int32,ShipCompany[],Int32,Int32) Method

index
array
arrayIndex
count

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal index As Integer, _
   ByVal array() As ShipCompany, _
   ByVal arrayIndex As Integer, _
   ByVal count As Integer _
)
C#
public void CopyTo(
   int index,
   ShipCompany[] array,
   int arrayIndex,
   int count
)

Parameters

index
array
arrayIndex
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompanies Class
ShipCompanies Members
Overload List


%%PageItemTitle%%

CopyTo(ShipCompany[]) Method
[image]
dotnetCART Namespace > ShipCompanies Class > CopyTo Method : CopyTo(ShipCompany[]) Method

array

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array() As ShipCompany _
)
C#
public void CopyTo(
   ShipCompany[] array
)

Parameters

array

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompanies Class
ShipCompanies Members
Overload List


%%PageItemTitle%%

CopyTo(ShipCompany[],Int32) Method
[image]
dotnetCART Namespace > ShipCompanies Class > CopyTo Method : CopyTo(ShipCompany[],Int32) Method

array
arrayIndex

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array() As ShipCompany, _
   ByVal arrayIndex As Integer _
)
C#
public void CopyTo(
   ShipCompany[] array,
   int arrayIndex
)

Parameters

array
arrayIndex

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompanies Class
ShipCompanies Members
Overload List


%%PageItemTitle%%

Count Property
[image]
dotnetCART Namespace > ShipCompanies Class : Count Property

Gets the number of elements actually contained in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompanies Class
ShipCompanies Members


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > ShipCompanies Class : Error Property

Returns an object with the error information.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompanies Class
ShipCompanies Members


%%PageItemTitle%%

GetEnumerator Method
[image]
dotnetCART Namespace > ShipCompanies Class : GetEnumerator Method

Returns an enumerator that iterates through the List.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As List.Enumerator(Of ShipCompany)
C#
public List.Enumerator<ShipCompany> GetEnumerator()

Return Value

A List.Enumerator for the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompanies Class
ShipCompanies Members


%%PageItemTitle%%

IndexOf Method
[image]
dotnetCART Namespace > ShipCompanies Class : IndexOf Method

Overload List

Overload | Description
IndexOf(ShipCompany) | (Inherited from dotnetCART.ListBase<ShipCompany>)
IndexOf(ShipCompany,Int32) | (Inherited from dotnetCART.ListBase<ShipCompany>)
IndexOf(ShipCompany,Int32,Int32) | (Inherited from dotnetCART.ListBase<ShipCompany>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompanies Class
ShipCompanies Members


%%PageItemTitle%%

IndexOf(ShipCompany) Method
[image]
dotnetCART Namespace > ShipCompanies Class > IndexOf Method : IndexOf(ShipCompany) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As ShipCompany _
) As Integer
C#
public int IndexOf(
   ShipCompany item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompanies Class
ShipCompanies Members
Overload List


%%PageItemTitle%%

IndexOf(ShipCompany,Int32) Method
[image]
dotnetCART Namespace > ShipCompanies Class > IndexOf Method : IndexOf(ShipCompany,Int32) Method

item
index

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As ShipCompany, _
   ByVal index As Integer _
) As Integer
C#
public int IndexOf(
   ShipCompany item,
   int index
)

Parameters

item
index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompanies Class
ShipCompanies Members
Overload List


%%PageItemTitle%%

IndexOf(ShipCompany,Int32,Int32) Method
[image]
dotnetCART Namespace > ShipCompanies Class > IndexOf Method : IndexOf(ShipCompany,Int32,Int32) Method

item
index
count

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As ShipCompany, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
C#
public int IndexOf(
   ShipCompany item,
   int index,
   int count
)

Parameters

item
index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompanies Class
ShipCompanies Members
Overload List


%%PageItemTitle%%

Insert Method
[image]
dotnetCART Namespace > ShipCompanies Class : Insert Method

index
item
Inserts an element into the List at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As ShipCompany _
)
C#
public void Insert(
   int index,
   ShipCompany item
)

Parameters

index
item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompanies Class
ShipCompanies Members


%%PageItemTitle%%

InsertRange Method
[image]
dotnetCART Namespace > ShipCompanies Class : InsertRange Method

index
collection
Inserts the elements of a collection into the List at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub InsertRange( _
   ByVal index As Integer, _
   ByVal collection As IEnumerable(Of ShipCompany) _
)
C#
public void InsertRange(
   int index,
   IEnumerable<ShipCompany> collection
)

Parameters

index
collection

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompanies Class
ShipCompanies Members


%%PageItemTitle%%

Item Property
[image]
dotnetCART Namespace > ShipCompanies Class : Item Property

index
Gets or sets the element at the specified index.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As ShipCompany
C#
public ShipCompany this[
   int index
]; {get; set;}

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompanies Class
ShipCompanies Members


%%PageItemTitle%%

LastIndexOf Method
[image]
dotnetCART Namespace > ShipCompanies Class : LastIndexOf Method

Overload List

Overload | Description
LastIndexOf(ShipCompany) | (Inherited from dotnetCART.ListBase<ShipCompany>)
LastIndexOf(ShipCompany,Int32) | (Inherited from dotnetCART.ListBase<ShipCompany>)
LastIndexOf(ShipCompany,Int32,Int32) | (Inherited from dotnetCART.ListBase<ShipCompany>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompanies Class
ShipCompanies Members


%%PageItemTitle%%

LastIndexOf(ShipCompany) Method
[image]
dotnetCART Namespace > ShipCompanies Class > LastIndexOf Method : LastIndexOf(ShipCompany) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As ShipCompany _
) As Integer
C#
public int LastIndexOf(
   ShipCompany item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompanies Class
ShipCompanies Members
Overload List


%%PageItemTitle%%

LastIndexOf(ShipCompany,Int32) Method
[image]
dotnetCART Namespace > ShipCompanies Class > LastIndexOf Method : LastIndexOf(ShipCompany,Int32) Method

item
index

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As ShipCompany, _
   ByVal index As Integer _
) As Integer
C#
public int LastIndexOf(
   ShipCompany item,
   int index
)

Parameters

item
index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompanies Class
ShipCompanies Members
Overload List


%%PageItemTitle%%

LastIndexOf(ShipCompany,Int32,Int32) Method
[image]
dotnetCART Namespace > ShipCompanies Class > LastIndexOf Method : LastIndexOf(ShipCompany,Int32,Int32) Method

item
index
count

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As ShipCompany, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
C#
public int LastIndexOf(
   ShipCompany item,
   int index,
   int count
)

Parameters

item
index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompanies Class
ShipCompanies Members
Overload List


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > ShipCompanies Class > LoadDB Method : LoadDB() Method

Loads all the items from its associated table.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB() As Integer
C#
public virtual int LoadDB()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompanies Class
ShipCompanies Members
Overload List


%%PageItemTitle%%

LoadDB(Int32,Int32) Method
[image]
dotnetCART Namespace > ShipCompanies Class > LoadDB Method : LoadDB(Int32,Int32) Method

start
count
Loads the count number of elements from start value.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal start As Integer, _
   ByVal count As Integer _
) As Integer
C#
public virtual int LoadDB(
   int start,
   int count
)

Parameters

start
count

Return Value

The total number of elements have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompanies Class
ShipCompanies Members
Overload List


%%PageItemTitle%%

LoadDB(Where) Method
[image]
dotnetCART Namespace > ShipCompanies Class > LoadDB Method : LoadDB(Where) Method

whereClause
Loads all the items from its associated table based on the where clause.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal whereClause As Where _
) As Integer
C#
public virtual int LoadDB(
   Where whereClause
)

Parameters

whereClause

Return Value

The total number of items have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompanies Class
ShipCompanies Members
Overload List


%%PageItemTitle%%

Remove Method
[image]
dotnetCART Namespace > ShipCompanies Class : Remove Method

item
Removes the first occurrence of a specific object from the List.

Syntax

Visual Basic (Declaration)
Public Function Remove( _
   ByVal item As ShipCompany _
) As Boolean
C#
public bool Remove(
   ShipCompany item
)

Parameters

item

Return Value

true if item is successfully removed; otherwise, false. This method also returns false if item was not found in the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompanies Class
ShipCompanies Members


%%PageItemTitle%%

RemoveAll Method
[image]
dotnetCART Namespace > ShipCompanies Class : RemoveAll Method

match
Removes the all the elements that match the conditions defined by the specified predicate.

Syntax

Visual Basic (Declaration)
Public Function RemoveAll( _
   ByVal match As Predicate(Of ShipCompany) _
) As Integer
C#
public int RemoveAll(
   Predicate<ShipCompany> match
)

Parameters

match

Return Value

The number of elements removed from the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompanies Class
ShipCompanies Members


%%PageItemTitle%%

RemoveAt Method
[image]
dotnetCART Namespace > ShipCompanies Class : RemoveAt Method

index
Removes the element at the specified index of the List.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompanies Class
ShipCompanies Members


%%PageItemTitle%%

RemoveRange Method
[image]
dotnetCART Namespace > ShipCompanies Class : RemoveRange Method

index
count
Removes a range of elements from the List.

Syntax

Visual Basic (Declaration)
Public Sub RemoveRange( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
C#
public void RemoveRange(
   int index,
   int count
)

Parameters

index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompanies Class
ShipCompanies Members


%%PageItemTitle%%

Reverse Method
[image]
dotnetCART Namespace > ShipCompanies Class : Reverse Method

Reverses the order of the elements in the entire List.

Overload List

Overload | Description
Reverse() | Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<ShipCompany>)
Reverse(Int32,Int32) | Reverses the order of the elements in the specified range. (Inherited from dotnetCART.ListBase<ShipCompany>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompanies Class
ShipCompanies Members


%%PageItemTitle%%

Reverse() Method
[image]
dotnetCART Namespace > ShipCompanies Class > Reverse Method : Reverse() Method

Reverses the order of the elements in the entire List.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Reverse()
C#
public void Reverse()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompanies Class
ShipCompanies Members
Overload List


%%PageItemTitle%%

Reverse(Int32,Int32) Method
[image]
dotnetCART Namespace > ShipCompanies Class > Reverse Method : Reverse(Int32,Int32) Method

index
count
Reverses the order of the elements in the specified range.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Reverse( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
C#
public void Reverse(
   int index,
   int count
)

Parameters

index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompanies Class
ShipCompanies Members
Overload List


%%PageItemTitle%%

Custom Property
[image]
dotnetCART Namespace > ShipCompany Class : Custom Property

Gets or sets a custom object. For more information see custom fields

Syntax

Visual Basic (Declaration)
Public Property Custom As Custom
C#
public Custom Custom {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompany Class
ShipCompany Members


%%PageItemTitle%%

CustomFields Property
See Also Example
[image]
dotnetCART Namespace > ShipCompany Class : CustomFields Property

Gets or sets a the names of custom fields for a table associated with the object.

Syntax

Visual Basic (Declaration)
Public Property CustomFields As String
C#
public string CustomFields {get; set;}

Example

C# Copy Code
Customer.CustomFields = "CellPhone,Favorites";

Visual Basic Copy Code
Customer.CustomFields = "CellPhone,Favorites"

Remarks

Custom fields must be added to the table manualy. Custom fields are usually set at store level using CustomFields

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompany Class
ShipCompany Members


%%PageItemTitle%%

Customs Property
[image]
dotnetCART Namespace > ShipCompany Class : Customs Property

A reference to the collection of the Custom objects.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Customs As Customs
C#
public Customs Customs {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompany Class
ShipCompany Members


%%PageItemTitle%%

DeleteDB(DbManager) Method
[image]
dotnetCART Namespace > ShipCompany Class > DeleteDB Method : DeleteDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function DeleteDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int DeleteDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompany Class
ShipCompany Members
Overload List


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > ShipCompany Class : Error Property

Gets the error object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompany Class
ShipCompany Members


%%PageItemTitle%%

GetCustom Method
[image]
dotnetCART Namespace > ShipCompany Class : GetCustom Method

This method returns the value of a custom field based on its name in the customs collection.

Overload List

Overload | Description
GetCustom(String) | This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<ShipCompany, Int64>)
GetCustom(Int32) | This method returns the value of a custom field based on its index in the customs collection. (Inherited from dotnetCART.DbTableCart<ShipCompany, Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompany Class
ShipCompany Members


%%PageItemTitle%%

GetCustom(Int32) Method
[image]
dotnetCART Namespace > ShipCompany Class > GetCustom Method : GetCustom(Int32) Method

customIndex
This method returns the value of a custom field based on its index in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal customIndex As Integer _
) As Object
C#
public object GetCustom(
   int customIndex
)

Parameters

customIndex

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompany Class
ShipCompany Members
Overload List


%%PageItemTitle%%

GetCustom(String) Method
[image]
dotnetCART Namespace > ShipCompany Class > GetCustom Method : GetCustom(String) Method

name
This method returns the value of a custom field based on its name in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal name As String _
) As Object
C#
public object GetCustom(
   string name
)

Parameters

name

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompany Class
ShipCompany Members
Overload List


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > ShipCompany Class : LoadDB Method

Loads this object from database using the ID property.

Overload List

Overload | Description
LoadDB(Int64) | (Inherited from dotnetCART.DbTableCart<ShipCompany, Int64>)
LoadDB() | Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<ShipCompany, Int64>)
Generic LoadDB() | (Inherited from dotnetDATA.DbTable<Int64>)
Generic LoadDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompany Class
ShipCompany Members


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > ShipCompany Class > LoadDB Method : LoadDB() Method

Loads this object from database using the ID property.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB() As Integer
C#
public virtual int LoadDB()

Return Value

In case of error -1, check Error property, if the object with the ID property not found 0, otherwise 1.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompany Class
ShipCompany Members
Overload List


%%PageItemTitle%%

LoadDB(Int64) Method
[image]
dotnetCART Namespace > ShipCompany Class > LoadDB Method : LoadDB(Int64) Method

id

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal id As Long _
) As Integer
C#
public virtual int LoadDB(
   long id
)

Parameters

id

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompany Class
ShipCompany Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB() Method
See Also
[image]
dotnetCART Namespace > ShipCompany Class > LoadDB Method : Generic LoadDB() Method

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)() As Integer
C#
public virtual int LoadDB<T1>()where T1: IDbTable

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompany Class
ShipCompany Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB(DbManager) Method
See Also
[image]
dotnetCART Namespace > ShipCompany Class > LoadDB Method : Generic LoadDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int LoadDB<T1>(
   DbManager manager
)where T1: IDbTable

Parameters

manager

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompany Class
ShipCompany Members
Overload List


%%PageItemTitle%%

SaveDB(DbManager) Method
[image]
dotnetCART Namespace > ShipCompany Class > SaveDB Method : SaveDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function SaveDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int SaveDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompany Class
ShipCompany Members
Overload List


%%PageItemTitle%%

SetCustom Method
[image]
dotnetCART Namespace > ShipCompany Class : SetCustom Method

name
newValue
This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added.

Syntax

Visual Basic (Declaration)
Public Function SetCustom( _
   ByVal name As String, _
   ByVal newValue As Object _
) As Object
C#
public object SetCustom(
   string name,
   object newValue
)

Parameters

name
newValue

Return Value

Returns the new custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

ShipCompany Class
ShipCompany Members


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > SoftGoodsLog Class : Clear Method

Initializes all the properties without recreating the object.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Clear()
C#
public virtual void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoodsLog Class
SoftGoodsLog Members


%%PageItemTitle%%

Custom Property
[image]
dotnetCART Namespace > SoftGoodsLog Class : Custom Property

Gets or sets a custom object. For more information see custom fields

Syntax

Visual Basic (Declaration)
Public Property Custom As Custom
C#
public Custom Custom {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoodsLog Class
SoftGoodsLog Members


%%PageItemTitle%%

CustomFields Property
See Also Example
[image]
dotnetCART Namespace > SoftGoodsLog Class : CustomFields Property

Gets or sets a the names of custom fields for a table associated with the object.

Syntax

Visual Basic (Declaration)
Public Property CustomFields As String
C#
public string CustomFields {get; set;}

Example

C# Copy Code
Customer.CustomFields = "CellPhone,Favorites";

Visual Basic Copy Code
Customer.CustomFields = "CellPhone,Favorites"

Remarks

Custom fields must be added to the table manualy. Custom fields are usually set at store level using CustomFields

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoodsLog Class
SoftGoodsLog Members


%%PageItemTitle%%

Customs Property
[image]
dotnetCART Namespace > SoftGoodsLog Class : Customs Property

A reference to the collection of the Custom objects.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Customs As Customs
C#
public Customs Customs {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoodsLog Class
SoftGoodsLog Members


%%PageItemTitle%%

DeleteDB Method
[image]
dotnetCART Namespace > SoftGoodsLog Class : DeleteDB Method

Deletes this object with ID from the database.

Overload List

Overload | Description
DeleteDB() | Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<SoftGoodsLog, Int64>)
DeleteDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoodsLog Class
SoftGoodsLog Members


%%PageItemTitle%%

DeleteDB() Method
[image]
dotnetCART Namespace > SoftGoodsLog Class > DeleteDB Method : DeleteDB() Method

Deletes this object with ID from the database.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function DeleteDB() As Integer
C#
public virtual int DeleteDB()

Return Value

In case of error -1, check Error property, otherwise the number of objects deleted.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoodsLog Class
SoftGoodsLog Members
Overload List


%%PageItemTitle%%

DeleteDB(DbManager) Method
[image]
dotnetCART Namespace > SoftGoodsLog Class > DeleteDB Method : DeleteDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function DeleteDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int DeleteDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoodsLog Class
SoftGoodsLog Members
Overload List


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > SoftGoodsLog Class : Error Property

Gets the error object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoodsLog Class
SoftGoodsLog Members


%%PageItemTitle%%

GetCustom Method
[image]
dotnetCART Namespace > SoftGoodsLog Class : GetCustom Method

This method returns the value of a custom field based on its name in the customs collection.

Overload List

Overload | Description
GetCustom(String) | This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<SoftGoodsLog, Int64>)
GetCustom(Int32) | This method returns the value of a custom field based on its index in the customs collection. (Inherited from dotnetCART.DbTableCart<SoftGoodsLog, Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoodsLog Class
SoftGoodsLog Members


%%PageItemTitle%%

GetCustom(Int32) Method
[image]
dotnetCART Namespace > SoftGoodsLog Class > GetCustom Method : GetCustom(Int32) Method

customIndex
This method returns the value of a custom field based on its index in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal customIndex As Integer _
) As Object
C#
public object GetCustom(
   int customIndex
)

Parameters

customIndex

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoodsLog Class
SoftGoodsLog Members
Overload List


%%PageItemTitle%%

GetCustom(String) Method
[image]
dotnetCART Namespace > SoftGoodsLog Class > GetCustom Method : GetCustom(String) Method

name
This method returns the value of a custom field based on its name in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal name As String _
) As Object
C#
public object GetCustom(
   string name
)

Parameters

name

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoodsLog Class
SoftGoodsLog Members
Overload List


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > SoftGoodsLog Class : LoadDB Method

Loads this object from database using the ID property.

Overload List

Overload | Description
LoadDB(Int64) | (Inherited from dotnetCART.DbTableCart<SoftGoodsLog, Int64>)
LoadDB() | Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<SoftGoodsLog, Int64>)
Generic LoadDB() | (Inherited from dotnetDATA.DbTable<Int64>)
Generic LoadDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoodsLog Class
SoftGoodsLog Members


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > SoftGoodsLog Class > LoadDB Method : LoadDB() Method

Loads this object from database using the ID property.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB() As Integer
C#
public virtual int LoadDB()

Return Value

In case of error -1, check Error property, if the object with the ID property not found 0, otherwise 1.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoodsLog Class
SoftGoodsLog Members
Overload List


%%PageItemTitle%%

LoadDB(Int64) Method
[image]
dotnetCART Namespace > SoftGoodsLog Class > LoadDB Method : LoadDB(Int64) Method

id

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal id As Long _
) As Integer
C#
public virtual int LoadDB(
   long id
)

Parameters

id

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoodsLog Class
SoftGoodsLog Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB() Method
See Also
[image]
dotnetCART Namespace > SoftGoodsLog Class > LoadDB Method : Generic LoadDB() Method

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)() As Integer
C#
public virtual int LoadDB<T1>()where T1: IDbTable

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoodsLog Class
SoftGoodsLog Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB(DbManager) Method
See Also
[image]
dotnetCART Namespace > SoftGoodsLog Class > LoadDB Method : Generic LoadDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int LoadDB<T1>(
   DbManager manager
)where T1: IDbTable

Parameters

manager

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoodsLog Class
SoftGoodsLog Members
Overload List


%%PageItemTitle%%

SaveDB Method
[image]
dotnetCART Namespace > SoftGoodsLog Class : SaveDB Method

Inserts or updates this object into the database.

Overload List

Overload | Description
SaveDB() | Inserts or updates this object into the database. (Inherited from dotnetCART.DbTableCart<SoftGoodsLog, Int64>)
SaveDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoodsLog Class
SoftGoodsLog Members


%%PageItemTitle%%

SaveDB() Method
[image]
dotnetCART Namespace > SoftGoodsLog Class > SaveDB Method : SaveDB() Method

Inserts or updates this object into the database.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function SaveDB() As Integer
C#
public virtual int SaveDB()

Return Value

Returns the generated ID or 1 for the update, returns -1 if failed. For the reason of fail, check the Generic DbTableCart.Error property.

Remarks

If Generic DbTableCart.ID greater than 0, it updates the associated object in the table, otherwise inserts a new object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoodsLog Class
SoftGoodsLog Members
Overload List


%%PageItemTitle%%

SaveDB(DbManager) Method
[image]
dotnetCART Namespace > SoftGoodsLog Class > SaveDB Method : SaveDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function SaveDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int SaveDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoodsLog Class
SoftGoodsLog Members
Overload List


%%PageItemTitle%%

SetCustom Method
[image]
dotnetCART Namespace > SoftGoodsLog Class : SetCustom Method

name
newValue
This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added.

Syntax

Visual Basic (Declaration)
Public Function SetCustom( _
   ByVal name As String, _
   ByVal newValue As Object _
) As Object
C#
public object SetCustom(
   string name,
   object newValue
)

Parameters

name
newValue

Return Value

Returns the new custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGoodsLog Class
SoftGoodsLog Members


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > SoftGood Class : Clear Method

Initializes all the properties without recreating the object.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Clear()
C#
public virtual void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGood Class
SoftGood Members


%%PageItemTitle%%

Custom Property
[image]
dotnetCART Namespace > SoftGood Class : Custom Property

Gets or sets a custom object. For more information see custom fields

Syntax

Visual Basic (Declaration)
Public Property Custom As Custom
C#
public Custom Custom {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGood Class
SoftGood Members


%%PageItemTitle%%

CustomFields Property
See Also Example
[image]
dotnetCART Namespace > SoftGood Class : CustomFields Property

Gets or sets a the names of custom fields for a table associated with the object.

Syntax

Visual Basic (Declaration)
Public Property CustomFields As String
C#
public string CustomFields {get; set;}

Example

C# Copy Code
Customer.CustomFields = "CellPhone,Favorites";

Visual Basic Copy Code
Customer.CustomFields = "CellPhone,Favorites"

Remarks

Custom fields must be added to the table manualy. Custom fields are usually set at store level using CustomFields

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGood Class
SoftGood Members


%%PageItemTitle%%

Customs Property
[image]
dotnetCART Namespace > SoftGood Class : Customs Property

A reference to the collection of the Custom objects.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Customs As Customs
C#
public Customs Customs {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGood Class
SoftGood Members


%%PageItemTitle%%

DeleteDB Method
[image]
dotnetCART Namespace > SoftGood Class : DeleteDB Method

Deletes this object with ID from the database.

Overload List

Overload | Description
DeleteDB() | Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<SoftGood, Int64>)
DeleteDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGood Class
SoftGood Members


%%PageItemTitle%%

DeleteDB() Method
[image]
dotnetCART Namespace > SoftGood Class > DeleteDB Method : DeleteDB() Method

Deletes this object with ID from the database.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function DeleteDB() As Integer
C#
public virtual int DeleteDB()

Return Value

In case of error -1, check Error property, otherwise the number of objects deleted.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGood Class
SoftGood Members
Overload List


%%PageItemTitle%%

DeleteDB(DbManager) Method
[image]
dotnetCART Namespace > SoftGood Class > DeleteDB Method : DeleteDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function DeleteDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int DeleteDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGood Class
SoftGood Members
Overload List


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > SoftGood Class : Error Property

Gets the error object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGood Class
SoftGood Members


%%PageItemTitle%%

GetCustom Method
[image]
dotnetCART Namespace > SoftGood Class : GetCustom Method

This method returns the value of a custom field based on its name in the customs collection.

Overload List

Overload | Description
GetCustom(String) | This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<SoftGood, Int64>)
GetCustom(Int32) | This method returns the value of a custom field based on its index in the customs collection. (Inherited from dotnetCART.DbTableCart<SoftGood, Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGood Class
SoftGood Members


%%PageItemTitle%%

GetCustom(Int32) Method
[image]
dotnetCART Namespace > SoftGood Class > GetCustom Method : GetCustom(Int32) Method

customIndex
This method returns the value of a custom field based on its index in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal customIndex As Integer _
) As Object
C#
public object GetCustom(
   int customIndex
)

Parameters

customIndex

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGood Class
SoftGood Members
Overload List


%%PageItemTitle%%

GetCustom(String) Method
[image]
dotnetCART Namespace > SoftGood Class > GetCustom Method : GetCustom(String) Method

name
This method returns the value of a custom field based on its name in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal name As String _
) As Object
C#
public object GetCustom(
   string name
)

Parameters

name

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGood Class
SoftGood Members
Overload List


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > SoftGood Class > LoadDB Method : LoadDB() Method

Loads this object from database using the ID property.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB() As Integer
C#
public virtual int LoadDB()

Return Value

In case of error -1, check Error property, if the object with the ID property not found 0, otherwise 1.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGood Class
SoftGood Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB() Method
See Also
[image]
dotnetCART Namespace > SoftGood Class > LoadDB Method : Generic LoadDB() Method

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)() As Integer
C#
public virtual int LoadDB<T1>()where T1: IDbTable

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGood Class
SoftGood Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB(DbManager) Method
See Also
[image]
dotnetCART Namespace > SoftGood Class > LoadDB Method : Generic LoadDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int LoadDB<T1>(
   DbManager manager
)where T1: IDbTable

Parameters

manager

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGood Class
SoftGood Members
Overload List


%%PageItemTitle%%

SaveDB Method
[image]
dotnetCART Namespace > SoftGood Class : SaveDB Method

Inserts or updates this object into the database.

Overload List

Overload | Description
SaveDB() | Inserts or updates this object into the database. (Inherited from dotnetCART.DbTableCart<SoftGood, Int64>)
SaveDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGood Class
SoftGood Members


%%PageItemTitle%%

SaveDB() Method
[image]
dotnetCART Namespace > SoftGood Class > SaveDB Method : SaveDB() Method

Inserts or updates this object into the database.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function SaveDB() As Integer
C#
public virtual int SaveDB()

Return Value

Returns the generated ID or 1 for the update, returns -1 if failed. For the reason of fail, check the Generic DbTableCart.Error property.

Remarks

If Generic DbTableCart.ID greater than 0, it updates the associated object in the table, otherwise inserts a new object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGood Class
SoftGood Members
Overload List


%%PageItemTitle%%

SaveDB(DbManager) Method
[image]
dotnetCART Namespace > SoftGood Class > SaveDB Method : SaveDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function SaveDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int SaveDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGood Class
SoftGood Members
Overload List


%%PageItemTitle%%

SetCustom Method
[image]
dotnetCART Namespace > SoftGood Class : SetCustom Method

name
newValue
This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added.

Syntax

Visual Basic (Declaration)
Public Function SetCustom( _
   ByVal name As String, _
   ByVal newValue As Object _
) As Object
C#
public object SetCustom(
   string name,
   object newValue
)

Parameters

name
newValue

Return Value

Returns the new custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SoftGood Class
SoftGood Members


%%PageItemTitle%% $$Properties$$

StockTransactions Class Properties
[image]
dotnetCART Namespace : StockTransactions Class

For a list of all members of this type, see StockTransactions members.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from dotnetCART.ListBase<StockTransaction>)
Public Property | Count | Gets the number of elements actually contained in the collection. (Inherited from dotnetCART.ListBase<StockTransaction>)
Public Property | Error | Returns an object with the error information. (Inherited from dotnetCART.ListBase<StockTransaction>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from dotnetCART.ListBase<StockTransaction>)
Top

See Also

Reference

StockTransactions Class
dotnetCART Namespace


%%PageItemTitle%%

Add Method
[image]
dotnetCART Namespace > StockTransactions Class : Add Method

item
Adds an object to the end of the collection.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal item As StockTransaction _
)
C#
public void Add(
   StockTransaction item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransactions Class
StockTransactions Members


%%PageItemTitle%%

AddRange Method
[image]
dotnetCART Namespace > StockTransactions Class : AddRange Method

collection
Adds the elements of the specified collection to the end of the collection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal collection As IEnumerable(Of StockTransaction) _
)
C#
public void AddRange(
   IEnumerable<StockTransaction> collection
)

Parameters

collection

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransactions Class
StockTransactions Members


%%PageItemTitle%%

AsReadOnly Method
[image]
dotnetCART Namespace > StockTransactions Class : AsReadOnly Method

Returns a read-only IList wrapper for the current collection.

Syntax

Visual Basic (Declaration)
Public Function AsReadOnly() As ReadOnlyCollection(Of StockTransaction)
C#
public ReadOnlyCollection<StockTransaction> AsReadOnly()

Return Value

A ReadOnlyCollection that acts as a read-only wrapper around the current List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransactions Class
StockTransactions Members


%%PageItemTitle%%

BinarySearch Method
[image]
dotnetCART Namespace > StockTransactions Class : BinarySearch Method

Overload List

Overload | Description
BinarySearch(StockTransaction) | (Inherited from dotnetCART.ListBase<StockTransaction>)
BinarySearch(StockTransaction,Generic IComparer) | (Inherited from dotnetCART.ListBase<StockTransaction>)
BinarySearch(Int32,Int32,StockTransaction,Generic IComparer) | (Inherited from dotnetCART.ListBase<StockTransaction>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransactions Class
StockTransactions Members


%%PageItemTitle%%

BinarySearch(Int32,Int32,StockTransaction,Generic IComparer) Method
See Also
[image]
dotnetCART Namespace > StockTransactions Class > BinarySearch Method : BinarySearch(Int32,Int32,StockTransaction,Generic IComparer) Method

index
count
item
comparer

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal index As Integer, _
   ByVal count As Integer, _
   ByVal item As StockTransaction, _
   ByVal comparer As IComparer(Of StockTransaction) _
) As Integer
C#
public int BinarySearch(
   int index,
   int count,
   StockTransaction item,
   IComparer<StockTransaction> comparer
)

Parameters

index
count
item
comparer

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransactions Class
StockTransactions Members
Overload List


%%PageItemTitle%%

BinarySearch(StockTransaction) Method
[image]
dotnetCART Namespace > StockTransactions Class > BinarySearch Method : BinarySearch(StockTransaction) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal item As StockTransaction _
) As Integer
C#
public int BinarySearch(
   StockTransaction item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransactions Class
StockTransactions Members
Overload List


%%PageItemTitle%%

BinarySearch(StockTransaction,Generic IComparer) Method
[image]
dotnetCART Namespace > StockTransactions Class > BinarySearch Method : BinarySearch(StockTransaction,Generic IComparer) Method

item
comparer

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal item As StockTransaction, _
   ByVal comparer As IComparer(Of StockTransaction) _
) As Integer
C#
public int BinarySearch(
   StockTransaction item,
   IComparer<StockTransaction> comparer
)

Parameters

item
comparer

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransactions Class
StockTransactions Members
Overload List


%%PageItemTitle%%

Capacity Property
[image]
dotnetCART Namespace > StockTransactions Class : Capacity Property

Gets or sets the total number of elements the internal data structure can hold without resizing.

Syntax

Visual Basic (Declaration)
Public Property Capacity As Integer
C#
public int Capacity {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransactions Class
StockTransactions Members


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > StockTransactions Class : Clear Method

Removes all elements from the List.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransactions Class
StockTransactions Members


%%PageItemTitle%%

Contains Method
[image]
dotnetCART Namespace > StockTransactions Class : Contains Method

item
Determines whether an element is in the List.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal item As StockTransaction _
) As Boolean
C#
public bool Contains(
   StockTransaction item
)

Parameters

item

Return Value

true if item is found in the List; otherwise, false.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransactions Class
StockTransactions Members


%%PageItemTitle%%

CopyTo Method
[image]
dotnetCART Namespace > StockTransactions Class : CopyTo Method

Overload List

Overload | Description
CopyTo(StockTransaction[]) | (Inherited from dotnetCART.ListBase<StockTransaction>)
CopyTo(StockTransaction[],Int32) | (Inherited from dotnetCART.ListBase<StockTransaction>)
CopyTo(Int32,StockTransaction[],Int32,Int32) | (Inherited from dotnetCART.ListBase<StockTransaction>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransactions Class
StockTransactions Members


%%PageItemTitle%%

CopyTo(Int32,StockTransaction[],Int32,Int32) Method
[image]
dotnetCART Namespace > StockTransactions Class > CopyTo Method : CopyTo(Int32,StockTransaction[],Int32,Int32) Method

index
array
arrayIndex
count

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal index As Integer, _
   ByVal array() As StockTransaction, _
   ByVal arrayIndex As Integer, _
   ByVal count As Integer _
)
C#
public void CopyTo(
   int index,
   StockTransaction[] array,
   int arrayIndex,
   int count
)

Parameters

index
array
arrayIndex
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransactions Class
StockTransactions Members
Overload List


%%PageItemTitle%%

CopyTo(StockTransaction[]) Method
[image]
dotnetCART Namespace > StockTransactions Class > CopyTo Method : CopyTo(StockTransaction[]) Method

array

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array() As StockTransaction _
)
C#
public void CopyTo(
   StockTransaction[] array
)

Parameters

array

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransactions Class
StockTransactions Members
Overload List


%%PageItemTitle%%

CopyTo(StockTransaction[],Int32) Method
[image]
dotnetCART Namespace > StockTransactions Class > CopyTo Method : CopyTo(StockTransaction[],Int32) Method

array
arrayIndex

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array() As StockTransaction, _
   ByVal arrayIndex As Integer _
)
C#
public void CopyTo(
   StockTransaction[] array,
   int arrayIndex
)

Parameters

array
arrayIndex

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransactions Class
StockTransactions Members
Overload List


%%PageItemTitle%%

Count Property
[image]
dotnetCART Namespace > StockTransactions Class : Count Property

Gets the number of elements actually contained in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransactions Class
StockTransactions Members


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > StockTransactions Class : Error Property

Returns an object with the error information.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransactions Class
StockTransactions Members


%%PageItemTitle%%

GetEnumerator Method
[image]
dotnetCART Namespace > StockTransactions Class : GetEnumerator Method

Returns an enumerator that iterates through the List.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As List.Enumerator(Of StockTransaction)
C#
public List.Enumerator<StockTransaction> GetEnumerator()

Return Value

A List.Enumerator for the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransactions Class
StockTransactions Members


%%PageItemTitle%%

IndexOf Method
[image]
dotnetCART Namespace > StockTransactions Class : IndexOf Method

Overload List

Overload | Description
IndexOf(StockTransaction) | (Inherited from dotnetCART.ListBase<StockTransaction>)
IndexOf(StockTransaction,Int32) | (Inherited from dotnetCART.ListBase<StockTransaction>)
IndexOf(StockTransaction,Int32,Int32) | (Inherited from dotnetCART.ListBase<StockTransaction>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransactions Class
StockTransactions Members


%%PageItemTitle%%

IndexOf(StockTransaction) Method
[image]
dotnetCART Namespace > StockTransactions Class > IndexOf Method : IndexOf(StockTransaction) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As StockTransaction _
) As Integer
C#
public int IndexOf(
   StockTransaction item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransactions Class
StockTransactions Members
Overload List


%%PageItemTitle%%

IndexOf(StockTransaction,Int32) Method
[image]
dotnetCART Namespace > StockTransactions Class > IndexOf Method : IndexOf(StockTransaction,Int32) Method

item
index

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As StockTransaction, _
   ByVal index As Integer _
) As Integer
C#
public int IndexOf(
   StockTransaction item,
   int index
)

Parameters

item
index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransactions Class
StockTransactions Members
Overload List


%%PageItemTitle%%

IndexOf(StockTransaction,Int32,Int32) Method
[image]
dotnetCART Namespace > StockTransactions Class > IndexOf Method : IndexOf(StockTransaction,Int32,Int32) Method

item
index
count

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As StockTransaction, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
C#
public int IndexOf(
   StockTransaction item,
   int index,
   int count
)

Parameters

item
index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransactions Class
StockTransactions Members
Overload List


%%PageItemTitle%%

Insert Method
[image]
dotnetCART Namespace > StockTransactions Class : Insert Method

index
item
Inserts an element into the List at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As StockTransaction _
)
C#
public void Insert(
   int index,
   StockTransaction item
)

Parameters

index
item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransactions Class
StockTransactions Members


%%PageItemTitle%%

InsertRange Method
[image]
dotnetCART Namespace > StockTransactions Class : InsertRange Method

index
collection
Inserts the elements of a collection into the List at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub InsertRange( _
   ByVal index As Integer, _
   ByVal collection As IEnumerable(Of StockTransaction) _
)
C#
public void InsertRange(
   int index,
   IEnumerable<StockTransaction> collection
)

Parameters

index
collection

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransactions Class
StockTransactions Members


%%PageItemTitle%%

Item Property
[image]
dotnetCART Namespace > StockTransactions Class : Item Property

index
Gets or sets the element at the specified index.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As StockTransaction
C#
public StockTransaction this[
   int index
]; {get; set;}

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransactions Class
StockTransactions Members


%%PageItemTitle%%

LastIndexOf Method
[image]
dotnetCART Namespace > StockTransactions Class : LastIndexOf Method

Overload List

Overload | Description
LastIndexOf(StockTransaction) | (Inherited from dotnetCART.ListBase<StockTransaction>)
LastIndexOf(StockTransaction,Int32) | (Inherited from dotnetCART.ListBase<StockTransaction>)
LastIndexOf(StockTransaction,Int32,Int32) | (Inherited from dotnetCART.ListBase<StockTransaction>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransactions Class
StockTransactions Members


%%PageItemTitle%%

LastIndexOf(StockTransaction) Method
[image]
dotnetCART Namespace > StockTransactions Class > LastIndexOf Method : LastIndexOf(StockTransaction) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As StockTransaction _
) As Integer
C#
public int LastIndexOf(
   StockTransaction item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransactions Class
StockTransactions Members
Overload List


%%PageItemTitle%%

LastIndexOf(StockTransaction,Int32) Method
[image]
dotnetCART Namespace > StockTransactions Class > LastIndexOf Method : LastIndexOf(StockTransaction,Int32) Method

item
index

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As StockTransaction, _
   ByVal index As Integer _
) As Integer
C#
public int LastIndexOf(
   StockTransaction item,
   int index
)

Parameters

item
index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransactions Class
StockTransactions Members
Overload List


%%PageItemTitle%%

LastIndexOf(StockTransaction,Int32,Int32) Method
[image]
dotnetCART Namespace > StockTransactions Class > LastIndexOf Method : LastIndexOf(StockTransaction,Int32,Int32) Method

item
index
count

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As StockTransaction, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
C#
public int LastIndexOf(
   StockTransaction item,
   int index,
   int count
)

Parameters

item
index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransactions Class
StockTransactions Members
Overload List


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > StockTransactions Class > LoadDB Method : LoadDB() Method

Loads all the items from its associated table.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB() As Integer
C#
public virtual int LoadDB()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransactions Class
StockTransactions Members
Overload List


%%PageItemTitle%%

LoadDB(Int32,Int32) Method
[image]
dotnetCART Namespace > StockTransactions Class > LoadDB Method : LoadDB(Int32,Int32) Method

start
count
Loads the count number of elements from start value.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal start As Integer, _
   ByVal count As Integer _
) As Integer
C#
public virtual int LoadDB(
   int start,
   int count
)

Parameters

start
count

Return Value

The total number of elements have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransactions Class
StockTransactions Members
Overload List


%%PageItemTitle%%

LoadDB(Where) Method
[image]
dotnetCART Namespace > StockTransactions Class > LoadDB Method : LoadDB(Where) Method

whereClause
Loads all the items from its associated table based on the where clause.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal whereClause As Where _
) As Integer
C#
public virtual int LoadDB(
   Where whereClause
)

Parameters

whereClause

Return Value

The total number of items have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransactions Class
StockTransactions Members
Overload List


%%PageItemTitle%%

Remove Method
[image]
dotnetCART Namespace > StockTransactions Class : Remove Method

item
Removes the first occurrence of a specific object from the List.

Syntax

Visual Basic (Declaration)
Public Function Remove( _
   ByVal item As StockTransaction _
) As Boolean
C#
public bool Remove(
   StockTransaction item
)

Parameters

item

Return Value

true if item is successfully removed; otherwise, false. This method also returns false if item was not found in the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransactions Class
StockTransactions Members


%%PageItemTitle%%

RemoveAll Method
[image]
dotnetCART Namespace > StockTransactions Class : RemoveAll Method

match
Removes the all the elements that match the conditions defined by the specified predicate.

Syntax

Visual Basic (Declaration)
Public Function RemoveAll( _
   ByVal match As Predicate(Of StockTransaction) _
) As Integer
C#
public int RemoveAll(
   Predicate<StockTransaction> match
)

Parameters

match

Return Value

The number of elements removed from the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransactions Class
StockTransactions Members


%%PageItemTitle%%

RemoveAt Method
[image]
dotnetCART Namespace > StockTransactions Class : RemoveAt Method

index
Removes the element at the specified index of the List.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransactions Class
StockTransactions Members


%%PageItemTitle%%

RemoveRange Method
[image]
dotnetCART Namespace > StockTransactions Class : RemoveRange Method

index
count
Removes a range of elements from the List.

Syntax

Visual Basic (Declaration)
Public Sub RemoveRange( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
C#
public void RemoveRange(
   int index,
   int count
)

Parameters

index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransactions Class
StockTransactions Members


%%PageItemTitle%%

Reverse Method
[image]
dotnetCART Namespace > StockTransactions Class : Reverse Method

Reverses the order of the elements in the entire List.

Overload List

Overload | Description
Reverse() | Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<StockTransaction>)
Reverse(Int32,Int32) | Reverses the order of the elements in the specified range. (Inherited from dotnetCART.ListBase<StockTransaction>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransactions Class
StockTransactions Members


%%PageItemTitle%%

Reverse() Method
[image]
dotnetCART Namespace > StockTransactions Class > Reverse Method : Reverse() Method

Reverses the order of the elements in the entire List.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Reverse()
C#
public void Reverse()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransactions Class
StockTransactions Members
Overload List


%%PageItemTitle%%

Reverse(Int32,Int32) Method
[image]
dotnetCART Namespace > StockTransactions Class > Reverse Method : Reverse(Int32,Int32) Method

index
count
Reverses the order of the elements in the specified range.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Reverse( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
C#
public void Reverse(
   int index,
   int count
)

Parameters

index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransactions Class
StockTransactions Members
Overload List


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > StockTransaction Class : Clear Method

Initializes all the properties without recreating the object.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Clear()
C#
public virtual void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransaction Class
StockTransaction Members


%%PageItemTitle%%

Custom Property
[image]
dotnetCART Namespace > StockTransaction Class : Custom Property

Gets or sets a custom object. For more information see custom fields

Syntax

Visual Basic (Declaration)
Public Property Custom As Custom
C#
public Custom Custom {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransaction Class
StockTransaction Members


%%PageItemTitle%%

CustomFields Property
See Also Example
[image]
dotnetCART Namespace > StockTransaction Class : CustomFields Property

Gets or sets a the names of custom fields for a table associated with the object.

Syntax

Visual Basic (Declaration)
Public Property CustomFields As String
C#
public string CustomFields {get; set;}

Example

C# Copy Code
Customer.CustomFields = "CellPhone,Favorites";

Visual Basic Copy Code
Customer.CustomFields = "CellPhone,Favorites"

Remarks

Custom fields must be added to the table manualy. Custom fields are usually set at store level using CustomFields

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransaction Class
StockTransaction Members


%%PageItemTitle%%

Customs Property
[image]
dotnetCART Namespace > StockTransaction Class : Customs Property

A reference to the collection of the Custom objects.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Customs As Customs
C#
public Customs Customs {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransaction Class
StockTransaction Members


%%PageItemTitle%%

DeleteDB Method
[image]
dotnetCART Namespace > StockTransaction Class : DeleteDB Method

Deletes this object with ID from the database.

Overload List

Overload | Description
DeleteDB() | Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<StockTransaction, Int64>)
DeleteDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransaction Class
StockTransaction Members


%%PageItemTitle%%

DeleteDB() Method
[image]
dotnetCART Namespace > StockTransaction Class > DeleteDB Method : DeleteDB() Method

Deletes this object with ID from the database.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function DeleteDB() As Integer
C#
public virtual int DeleteDB()

Return Value

In case of error -1, check Error property, otherwise the number of objects deleted.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransaction Class
StockTransaction Members
Overload List


%%PageItemTitle%%

DeleteDB(DbManager) Method
[image]
dotnetCART Namespace > StockTransaction Class > DeleteDB Method : DeleteDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function DeleteDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int DeleteDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransaction Class
StockTransaction Members
Overload List


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > StockTransaction Class : Error Property

Gets the error object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransaction Class
StockTransaction Members


%%PageItemTitle%%

GetCustom Method
[image]
dotnetCART Namespace > StockTransaction Class : GetCustom Method

This method returns the value of a custom field based on its name in the customs collection.

Overload List

Overload | Description
GetCustom(String) | This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<StockTransaction, Int64>)
GetCustom(Int32) | This method returns the value of a custom field based on its index in the customs collection. (Inherited from dotnetCART.DbTableCart<StockTransaction, Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransaction Class
StockTransaction Members


%%PageItemTitle%%

GetCustom(Int32) Method
[image]
dotnetCART Namespace > StockTransaction Class > GetCustom Method : GetCustom(Int32) Method

customIndex
This method returns the value of a custom field based on its index in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal customIndex As Integer _
) As Object
C#
public object GetCustom(
   int customIndex
)

Parameters

customIndex

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransaction Class
StockTransaction Members
Overload List


%%PageItemTitle%%

GetCustom(String) Method
[image]
dotnetCART Namespace > StockTransaction Class > GetCustom Method : GetCustom(String) Method

name
This method returns the value of a custom field based on its name in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal name As String _
) As Object
C#
public object GetCustom(
   string name
)

Parameters

name

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransaction Class
StockTransaction Members
Overload List


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > StockTransaction Class : LoadDB Method

Loads this object from database using the ID property.

Overload List

Overload | Description
LoadDB(Int64) | (Inherited from dotnetCART.DbTableCart<StockTransaction, Int64>)
LoadDB() | Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<StockTransaction, Int64>)
Generic LoadDB() | (Inherited from dotnetDATA.DbTable<Int64>)
Generic LoadDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransaction Class
StockTransaction Members


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > StockTransaction Class > LoadDB Method : LoadDB() Method

Loads this object from database using the ID property.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB() As Integer
C#
public virtual int LoadDB()

Return Value

In case of error -1, check Error property, if the object with the ID property not found 0, otherwise 1.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransaction Class
StockTransaction Members
Overload List


%%PageItemTitle%%

LoadDB(Int64) Method
[image]
dotnetCART Namespace > StockTransaction Class > LoadDB Method : LoadDB(Int64) Method

id

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal id As Long _
) As Integer
C#
public virtual int LoadDB(
   long id
)

Parameters

id

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransaction Class
StockTransaction Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB() Method
See Also
[image]
dotnetCART Namespace > StockTransaction Class > LoadDB Method : Generic LoadDB() Method

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)() As Integer
C#
public virtual int LoadDB<T1>()where T1: IDbTable

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransaction Class
StockTransaction Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB(DbManager) Method
See Also
[image]
dotnetCART Namespace > StockTransaction Class > LoadDB Method : Generic LoadDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int LoadDB<T1>(
   DbManager manager
)where T1: IDbTable

Parameters

manager

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransaction Class
StockTransaction Members
Overload List


%%PageItemTitle%%

SaveDB Method
[image]
dotnetCART Namespace > StockTransaction Class : SaveDB Method

Inserts or updates this object into the database.

Overload List

Overload | Description
SaveDB() | Inserts or updates this object into the database. (Inherited from dotnetCART.DbTableCart<StockTransaction, Int64>)
SaveDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransaction Class
StockTransaction Members


%%PageItemTitle%%

SaveDB() Method
[image]
dotnetCART Namespace > StockTransaction Class > SaveDB Method : SaveDB() Method

Inserts or updates this object into the database.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function SaveDB() As Integer
C#
public virtual int SaveDB()

Return Value

Returns the generated ID or 1 for the update, returns -1 if failed. For the reason of fail, check the Generic DbTableCart.Error property.

Remarks

If Generic DbTableCart.ID greater than 0, it updates the associated object in the table, otherwise inserts a new object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransaction Class
StockTransaction Members
Overload List


%%PageItemTitle%%

SaveDB(DbManager) Method
[image]
dotnetCART Namespace > StockTransaction Class > SaveDB Method : SaveDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function SaveDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int SaveDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransaction Class
StockTransaction Members
Overload List


%%PageItemTitle%%

SetCustom Method
[image]
dotnetCART Namespace > StockTransaction Class : SetCustom Method

name
newValue
This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added.

Syntax

Visual Basic (Declaration)
Public Function SetCustom( _
   ByVal name As String, _
   ByVal newValue As Object _
) As Object
C#
public object SetCustom(
   string name,
   object newValue
)

Parameters

name
newValue

Return Value

Returns the new custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

StockTransaction Class
StockTransaction Members


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > SubItemMapping Class : Clear Method

Initializes all the properties without recreating the object.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Clear()
C#
public virtual void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SubItemMapping Class
SubItemMapping Members


%%PageItemTitle%%

Custom Property
[image]
dotnetCART Namespace > SubItemMapping Class : Custom Property

Gets or sets a custom object. For more information see custom fields

Syntax

Visual Basic (Declaration)
Public Property Custom As Custom
C#
public Custom Custom {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SubItemMapping Class
SubItemMapping Members


%%PageItemTitle%%

CustomFields Property
See Also Example
[image]
dotnetCART Namespace > SubItemMapping Class : CustomFields Property

Gets or sets a the names of custom fields for a table associated with the object.

Syntax

Visual Basic (Declaration)
Public Property CustomFields As String
C#
public string CustomFields {get; set;}

Example

C# Copy Code
Customer.CustomFields = "CellPhone,Favorites";

Visual Basic Copy Code
Customer.CustomFields = "CellPhone,Favorites"

Remarks

Custom fields must be added to the table manualy. Custom fields are usually set at store level using CustomFields

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SubItemMapping Class
SubItemMapping Members


%%PageItemTitle%%

Customs Property
[image]
dotnetCART Namespace > SubItemMapping Class : Customs Property

A reference to the collection of the Custom objects.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Customs As Customs
C#
public Customs Customs {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SubItemMapping Class
SubItemMapping Members


%%PageItemTitle%%

DeleteDB(DbManager) Method
[image]
dotnetCART Namespace > SubItemMapping Class > DeleteDB Method : DeleteDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function DeleteDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int DeleteDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SubItemMapping Class
SubItemMapping Members
Overload List


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > SubItemMapping Class : Error Property

Gets the error object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SubItemMapping Class
SubItemMapping Members


%%PageItemTitle%%

GetCustom Method
[image]
dotnetCART Namespace > SubItemMapping Class : GetCustom Method

This method returns the value of a custom field based on its name in the customs collection.

Overload List

Overload | Description
GetCustom(String) | This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<SubItemMapping, Int64>)
GetCustom(Int32) | This method returns the value of a custom field based on its index in the customs collection. (Inherited from dotnetCART.DbTableCart<SubItemMapping, Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SubItemMapping Class
SubItemMapping Members


%%PageItemTitle%%

GetCustom(Int32) Method
[image]
dotnetCART Namespace > SubItemMapping Class > GetCustom Method : GetCustom(Int32) Method

customIndex
This method returns the value of a custom field based on its index in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal customIndex As Integer _
) As Object
C#
public object GetCustom(
   int customIndex
)

Parameters

customIndex

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SubItemMapping Class
SubItemMapping Members
Overload List


%%PageItemTitle%%

GetCustom(String) Method
[image]
dotnetCART Namespace > SubItemMapping Class > GetCustom Method : GetCustom(String) Method

name
This method returns the value of a custom field based on its name in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal name As String _
) As Object
C#
public object GetCustom(
   string name
)

Parameters

name

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SubItemMapping Class
SubItemMapping Members
Overload List


%%PageItemTitle%%

LoadDB(Int64) Method
[image]
dotnetCART Namespace > SubItemMapping Class > LoadDB Method : LoadDB(Int64) Method

id

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal id As Long _
) As Integer
C#
public virtual int LoadDB(
   long id
)

Parameters

id

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SubItemMapping Class
SubItemMapping Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB() Method
See Also
[image]
dotnetCART Namespace > SubItemMapping Class > LoadDB Method : Generic LoadDB() Method

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)() As Integer
C#
public virtual int LoadDB<T1>()where T1: IDbTable

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SubItemMapping Class
SubItemMapping Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB(DbManager) Method
See Also
[image]
dotnetCART Namespace > SubItemMapping Class > LoadDB Method : Generic LoadDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int LoadDB<T1>(
   DbManager manager
)where T1: IDbTable

Parameters

manager

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SubItemMapping Class
SubItemMapping Members
Overload List


%%PageItemTitle%%

SaveDB(DbManager) Method
[image]
dotnetCART Namespace > SubItemMapping Class > SaveDB Method : SaveDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function SaveDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int SaveDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SubItemMapping Class
SubItemMapping Members
Overload List


%%PageItemTitle%%

SetCustom Method
[image]
dotnetCART Namespace > SubItemMapping Class : SetCustom Method

name
newValue
This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added.

Syntax

Visual Basic (Declaration)
Public Function SetCustom( _
   ByVal name As String, _
   ByVal newValue As Object _
) As Object
C#
public object SetCustom(
   string name,
   object newValue
)

Parameters

name
newValue

Return Value

Returns the new custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SubItemMapping Class
SubItemMapping Members


%%PageItemTitle%% $$Properties$$

SupplierItems Class Properties
[image]
dotnetCART Namespace : SupplierItems Class

For a list of all members of this type, see SupplierItems members.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from dotnetCART.ListBase<SupplierItem>)
Public Property | Count | Gets the number of elements actually contained in the collection. (Inherited from dotnetCART.ListBase<SupplierItem>)
Public Property | Error | Returns an object with the error information. (Inherited from dotnetCART.ListBase<SupplierItem>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from dotnetCART.ListBase<SupplierItem>)
Top

See Also

Reference

SupplierItems Class
dotnetCART Namespace


%%PageItemTitle%%

Add Method
[image]
dotnetCART Namespace > SupplierItems Class : Add Method

item
Adds an object to the end of the collection.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal item As SupplierItem _
)
C#
public void Add(
   SupplierItem item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItems Class
SupplierItems Members


%%PageItemTitle%%

AddRange Method
[image]
dotnetCART Namespace > SupplierItems Class : AddRange Method

collection
Adds the elements of the specified collection to the end of the collection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal collection As IEnumerable(Of SupplierItem) _
)
C#
public void AddRange(
   IEnumerable<SupplierItem> collection
)

Parameters

collection

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItems Class
SupplierItems Members


%%PageItemTitle%%

AsReadOnly Method
[image]
dotnetCART Namespace > SupplierItems Class : AsReadOnly Method

Returns a read-only IList wrapper for the current collection.

Syntax

Visual Basic (Declaration)
Public Function AsReadOnly() As ReadOnlyCollection(Of SupplierItem)
C#
public ReadOnlyCollection<SupplierItem> AsReadOnly()

Return Value

A ReadOnlyCollection that acts as a read-only wrapper around the current List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItems Class
SupplierItems Members


%%PageItemTitle%%

BinarySearch Method
[image]
dotnetCART Namespace > SupplierItems Class : BinarySearch Method

Overload List

Overload | Description
BinarySearch(SupplierItem) | (Inherited from dotnetCART.ListBase<SupplierItem>)
BinarySearch(SupplierItem,Generic IComparer) | (Inherited from dotnetCART.ListBase<SupplierItem>)
BinarySearch(Int32,Int32,SupplierItem,Generic IComparer) | (Inherited from dotnetCART.ListBase<SupplierItem>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItems Class
SupplierItems Members


%%PageItemTitle%%

BinarySearch(Int32,Int32,SupplierItem,Generic IComparer) Method
See Also
[image]
dotnetCART Namespace > SupplierItems Class > BinarySearch Method : BinarySearch(Int32,Int32,SupplierItem,Generic IComparer) Method

index
count
item
comparer

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal index As Integer, _
   ByVal count As Integer, _
   ByVal item As SupplierItem, _
   ByVal comparer As IComparer(Of SupplierItem) _
) As Integer
C#
public int BinarySearch(
   int index,
   int count,
   SupplierItem item,
   IComparer<SupplierItem> comparer
)

Parameters

index
count
item
comparer

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItems Class
SupplierItems Members
Overload List


%%PageItemTitle%%

BinarySearch(SupplierItem) Method
[image]
dotnetCART Namespace > SupplierItems Class > BinarySearch Method : BinarySearch(SupplierItem) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal item As SupplierItem _
) As Integer
C#
public int BinarySearch(
   SupplierItem item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItems Class
SupplierItems Members
Overload List


%%PageItemTitle%%

BinarySearch(SupplierItem,Generic IComparer) Method
[image]
dotnetCART Namespace > SupplierItems Class > BinarySearch Method : BinarySearch(SupplierItem,Generic IComparer) Method

item
comparer

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal item As SupplierItem, _
   ByVal comparer As IComparer(Of SupplierItem) _
) As Integer
C#
public int BinarySearch(
   SupplierItem item,
   IComparer<SupplierItem> comparer
)

Parameters

item
comparer

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItems Class
SupplierItems Members
Overload List


%%PageItemTitle%%

Capacity Property
[image]
dotnetCART Namespace > SupplierItems Class : Capacity Property

Gets or sets the total number of elements the internal data structure can hold without resizing.

Syntax

Visual Basic (Declaration)
Public Property Capacity As Integer
C#
public int Capacity {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItems Class
SupplierItems Members


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > SupplierItems Class : Clear Method

Removes all elements from the List.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItems Class
SupplierItems Members


%%PageItemTitle%%

Contains Method
[image]
dotnetCART Namespace > SupplierItems Class : Contains Method

item
Determines whether an element is in the List.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal item As SupplierItem _
) As Boolean
C#
public bool Contains(
   SupplierItem item
)

Parameters

item

Return Value

true if item is found in the List; otherwise, false.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItems Class
SupplierItems Members


%%PageItemTitle%%

CopyTo Method
[image]
dotnetCART Namespace > SupplierItems Class : CopyTo Method

Overload List

Overload | Description
CopyTo(SupplierItem[]) | (Inherited from dotnetCART.ListBase<SupplierItem>)
CopyTo(SupplierItem[],Int32) | (Inherited from dotnetCART.ListBase<SupplierItem>)
CopyTo(Int32,SupplierItem[],Int32,Int32) | (Inherited from dotnetCART.ListBase<SupplierItem>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItems Class
SupplierItems Members


%%PageItemTitle%%

CopyTo(Int32,SupplierItem[],Int32,Int32) Method
[image]
dotnetCART Namespace > SupplierItems Class > CopyTo Method : CopyTo(Int32,SupplierItem[],Int32,Int32) Method

index
array
arrayIndex
count

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal index As Integer, _
   ByVal array() As SupplierItem, _
   ByVal arrayIndex As Integer, _
   ByVal count As Integer _
)
C#
public void CopyTo(
   int index,
   SupplierItem[] array,
   int arrayIndex,
   int count
)

Parameters

index
array
arrayIndex
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItems Class
SupplierItems Members
Overload List


%%PageItemTitle%%

CopyTo(SupplierItem[]) Method
[image]
dotnetCART Namespace > SupplierItems Class > CopyTo Method : CopyTo(SupplierItem[]) Method

array

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array() As SupplierItem _
)
C#
public void CopyTo(
   SupplierItem[] array
)

Parameters

array

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItems Class
SupplierItems Members
Overload List


%%PageItemTitle%%

CopyTo(SupplierItem[],Int32) Method
[image]
dotnetCART Namespace > SupplierItems Class > CopyTo Method : CopyTo(SupplierItem[],Int32) Method

array
arrayIndex

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array() As SupplierItem, _
   ByVal arrayIndex As Integer _
)
C#
public void CopyTo(
   SupplierItem[] array,
   int arrayIndex
)

Parameters

array
arrayIndex

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItems Class
SupplierItems Members
Overload List


%%PageItemTitle%%

Count Property
[image]
dotnetCART Namespace > SupplierItems Class : Count Property

Gets the number of elements actually contained in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItems Class
SupplierItems Members


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > SupplierItems Class : Error Property

Returns an object with the error information.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItems Class
SupplierItems Members


%%PageItemTitle%%

GetEnumerator Method
[image]
dotnetCART Namespace > SupplierItems Class : GetEnumerator Method

Returns an enumerator that iterates through the List.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As List.Enumerator(Of SupplierItem)
C#
public List.Enumerator<SupplierItem> GetEnumerator()

Return Value

A List.Enumerator for the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItems Class
SupplierItems Members


%%PageItemTitle%%

IndexOf Method
[image]
dotnetCART Namespace > SupplierItems Class : IndexOf Method

Overload List

Overload | Description
IndexOf(SupplierItem) | (Inherited from dotnetCART.ListBase<SupplierItem>)
IndexOf(SupplierItem,Int32) | (Inherited from dotnetCART.ListBase<SupplierItem>)
IndexOf(SupplierItem,Int32,Int32) | (Inherited from dotnetCART.ListBase<SupplierItem>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItems Class
SupplierItems Members


%%PageItemTitle%%

IndexOf(SupplierItem) Method
[image]
dotnetCART Namespace > SupplierItems Class > IndexOf Method : IndexOf(SupplierItem) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As SupplierItem _
) As Integer
C#
public int IndexOf(
   SupplierItem item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItems Class
SupplierItems Members
Overload List


%%PageItemTitle%%

IndexOf(SupplierItem,Int32) Method
[image]
dotnetCART Namespace > SupplierItems Class > IndexOf Method : IndexOf(SupplierItem,Int32) Method

item
index

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As SupplierItem, _
   ByVal index As Integer _
) As Integer
C#
public int IndexOf(
   SupplierItem item,
   int index
)

Parameters

item
index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItems Class
SupplierItems Members
Overload List


%%PageItemTitle%%

IndexOf(SupplierItem,Int32,Int32) Method
[image]
dotnetCART Namespace > SupplierItems Class > IndexOf Method : IndexOf(SupplierItem,Int32,Int32) Method

item
index
count

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As SupplierItem, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
C#
public int IndexOf(
   SupplierItem item,
   int index,
   int count
)

Parameters

item
index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItems Class
SupplierItems Members
Overload List


%%PageItemTitle%%

Insert Method
[image]
dotnetCART Namespace > SupplierItems Class : Insert Method

index
item
Inserts an element into the List at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As SupplierItem _
)
C#
public void Insert(
   int index,
   SupplierItem item
)

Parameters

index
item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItems Class
SupplierItems Members


%%PageItemTitle%%

InsertRange Method
[image]
dotnetCART Namespace > SupplierItems Class : InsertRange Method

index
collection
Inserts the elements of a collection into the List at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub InsertRange( _
   ByVal index As Integer, _
   ByVal collection As IEnumerable(Of SupplierItem) _
)
C#
public void InsertRange(
   int index,
   IEnumerable<SupplierItem> collection
)

Parameters

index
collection

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItems Class
SupplierItems Members


%%PageItemTitle%%

Item Property
[image]
dotnetCART Namespace > SupplierItems Class : Item Property

index
Gets or sets the element at the specified index.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As SupplierItem
C#
public SupplierItem this[
   int index
]; {get; set;}

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItems Class
SupplierItems Members


%%PageItemTitle%%

LastIndexOf Method
[image]
dotnetCART Namespace > SupplierItems Class : LastIndexOf Method

Overload List

Overload | Description
LastIndexOf(SupplierItem) | (Inherited from dotnetCART.ListBase<SupplierItem>)
LastIndexOf(SupplierItem,Int32) | (Inherited from dotnetCART.ListBase<SupplierItem>)
LastIndexOf(SupplierItem,Int32,Int32) | (Inherited from dotnetCART.ListBase<SupplierItem>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItems Class
SupplierItems Members


%%PageItemTitle%%

LastIndexOf(SupplierItem) Method
[image]
dotnetCART Namespace > SupplierItems Class > LastIndexOf Method : LastIndexOf(SupplierItem) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As SupplierItem _
) As Integer
C#
public int LastIndexOf(
   SupplierItem item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItems Class
SupplierItems Members
Overload List


%%PageItemTitle%%

LastIndexOf(SupplierItem,Int32) Method
[image]
dotnetCART Namespace > SupplierItems Class > LastIndexOf Method : LastIndexOf(SupplierItem,Int32) Method

item
index

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As SupplierItem, _
   ByVal index As Integer _
) As Integer
C#
public int LastIndexOf(
   SupplierItem item,
   int index
)

Parameters

item
index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItems Class
SupplierItems Members
Overload List


%%PageItemTitle%%

LastIndexOf(SupplierItem,Int32,Int32) Method
[image]
dotnetCART Namespace > SupplierItems Class > LastIndexOf Method : LastIndexOf(SupplierItem,Int32,Int32) Method

item
index
count

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As SupplierItem, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
C#
public int LastIndexOf(
   SupplierItem item,
   int index,
   int count
)

Parameters

item
index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItems Class
SupplierItems Members
Overload List


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > SupplierItems Class > LoadDB Method : LoadDB() Method

Loads all the items from its associated table.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB() As Integer
C#
public virtual int LoadDB()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItems Class
SupplierItems Members
Overload List


%%PageItemTitle%%

LoadDB(Int32,Int32) Method
[image]
dotnetCART Namespace > SupplierItems Class > LoadDB Method : LoadDB(Int32,Int32) Method

start
count
Loads the count number of elements from start value.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal start As Integer, _
   ByVal count As Integer _
) As Integer
C#
public virtual int LoadDB(
   int start,
   int count
)

Parameters

start
count

Return Value

The total number of elements have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItems Class
SupplierItems Members
Overload List


%%PageItemTitle%%

LoadDB(Where) Method
[image]
dotnetCART Namespace > SupplierItems Class > LoadDB Method : LoadDB(Where) Method

whereClause
Loads all the items from its associated table based on the where clause.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal whereClause As Where _
) As Integer
C#
public virtual int LoadDB(
   Where whereClause
)

Parameters

whereClause

Return Value

The total number of items have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItems Class
SupplierItems Members
Overload List


%%PageItemTitle%%

Remove Method
[image]
dotnetCART Namespace > SupplierItems Class : Remove Method

item
Removes the first occurrence of a specific object from the List.

Syntax

Visual Basic (Declaration)
Public Function Remove( _
   ByVal item As SupplierItem _
) As Boolean
C#
public bool Remove(
   SupplierItem item
)

Parameters

item

Return Value

true if item is successfully removed; otherwise, false. This method also returns false if item was not found in the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItems Class
SupplierItems Members


%%PageItemTitle%%

RemoveAll Method
[image]
dotnetCART Namespace > SupplierItems Class : RemoveAll Method

match
Removes the all the elements that match the conditions defined by the specified predicate.

Syntax

Visual Basic (Declaration)
Public Function RemoveAll( _
   ByVal match As Predicate(Of SupplierItem) _
) As Integer
C#
public int RemoveAll(
   Predicate<SupplierItem> match
)

Parameters

match

Return Value

The number of elements removed from the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItems Class
SupplierItems Members


%%PageItemTitle%%

RemoveAt Method
[image]
dotnetCART Namespace > SupplierItems Class : RemoveAt Method

index
Removes the element at the specified index of the List.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItems Class
SupplierItems Members


%%PageItemTitle%%

RemoveRange Method
[image]
dotnetCART Namespace > SupplierItems Class : RemoveRange Method

index
count
Removes a range of elements from the List.

Syntax

Visual Basic (Declaration)
Public Sub RemoveRange( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
C#
public void RemoveRange(
   int index,
   int count
)

Parameters

index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItems Class
SupplierItems Members


%%PageItemTitle%%

Reverse Method
[image]
dotnetCART Namespace > SupplierItems Class : Reverse Method

Reverses the order of the elements in the entire List.

Overload List

Overload | Description
Reverse() | Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<SupplierItem>)
Reverse(Int32,Int32) | Reverses the order of the elements in the specified range. (Inherited from dotnetCART.ListBase<SupplierItem>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItems Class
SupplierItems Members


%%PageItemTitle%%

Reverse() Method
[image]
dotnetCART Namespace > SupplierItems Class > Reverse Method : Reverse() Method

Reverses the order of the elements in the entire List.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Reverse()
C#
public void Reverse()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItems Class
SupplierItems Members
Overload List


%%PageItemTitle%%

Reverse(Int32,Int32) Method
[image]
dotnetCART Namespace > SupplierItems Class > Reverse Method : Reverse(Int32,Int32) Method

index
count
Reverses the order of the elements in the specified range.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Reverse( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
C#
public void Reverse(
   int index,
   int count
)

Parameters

index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItems Class
SupplierItems Members
Overload List


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > SupplierItem Class : Clear Method

Initializes all the properties without recreating the object.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Clear()
C#
public virtual void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItem Class
SupplierItem Members


%%PageItemTitle%%

Custom Property
[image]
dotnetCART Namespace > SupplierItem Class : Custom Property

Gets or sets a custom object. For more information see custom fields

Syntax

Visual Basic (Declaration)
Public Property Custom As Custom
C#
public Custom Custom {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItem Class
SupplierItem Members


%%PageItemTitle%%

CustomFields Property
See Also Example
[image]
dotnetCART Namespace > SupplierItem Class : CustomFields Property

Gets or sets a the names of custom fields for a table associated with the object.

Syntax

Visual Basic (Declaration)
Public Property CustomFields As String
C#
public string CustomFields {get; set;}

Example

C# Copy Code
Customer.CustomFields = "CellPhone,Favorites";

Visual Basic Copy Code
Customer.CustomFields = "CellPhone,Favorites"

Remarks

Custom fields must be added to the table manualy. Custom fields are usually set at store level using CustomFields

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItem Class
SupplierItem Members


%%PageItemTitle%%

Customs Property
[image]
dotnetCART Namespace > SupplierItem Class : Customs Property

A reference to the collection of the Custom objects.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Customs As Customs
C#
public Customs Customs {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItem Class
SupplierItem Members


%%PageItemTitle%%

DeleteDB Method
[image]
dotnetCART Namespace > SupplierItem Class : DeleteDB Method

Deletes this object with ID from the database.

Overload List

Overload | Description
DeleteDB() | Deletes this object with ID from the database. (Inherited from dotnetCART.DbTableCart<SupplierItem, Int64>)
DeleteDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItem Class
SupplierItem Members


%%PageItemTitle%%

DeleteDB() Method
[image]
dotnetCART Namespace > SupplierItem Class > DeleteDB Method : DeleteDB() Method

Deletes this object with ID from the database.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function DeleteDB() As Integer
C#
public virtual int DeleteDB()

Return Value

In case of error -1, check Error property, otherwise the number of objects deleted.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItem Class
SupplierItem Members
Overload List


%%PageItemTitle%%

DeleteDB(DbManager) Method
[image]
dotnetCART Namespace > SupplierItem Class > DeleteDB Method : DeleteDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function DeleteDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int DeleteDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItem Class
SupplierItem Members
Overload List


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > SupplierItem Class : Error Property

Gets the error object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItem Class
SupplierItem Members


%%PageItemTitle%%

GetCustom Method
[image]
dotnetCART Namespace > SupplierItem Class : GetCustom Method

This method returns the value of a custom field based on its name in the customs collection.

Overload List

Overload | Description
GetCustom(String) | This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<SupplierItem, Int64>)
GetCustom(Int32) | This method returns the value of a custom field based on its index in the customs collection. (Inherited from dotnetCART.DbTableCart<SupplierItem, Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItem Class
SupplierItem Members


%%PageItemTitle%%

GetCustom(Int32) Method
[image]
dotnetCART Namespace > SupplierItem Class > GetCustom Method : GetCustom(Int32) Method

customIndex
This method returns the value of a custom field based on its index in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal customIndex As Integer _
) As Object
C#
public object GetCustom(
   int customIndex
)

Parameters

customIndex

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItem Class
SupplierItem Members
Overload List


%%PageItemTitle%%

GetCustom(String) Method
[image]
dotnetCART Namespace > SupplierItem Class > GetCustom Method : GetCustom(String) Method

name
This method returns the value of a custom field based on its name in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal name As String _
) As Object
C#
public object GetCustom(
   string name
)

Parameters

name

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItem Class
SupplierItem Members
Overload List


%%PageItemTitle%%

LoadDB(Int64) Method
[image]
dotnetCART Namespace > SupplierItem Class > LoadDB Method : LoadDB(Int64) Method

id

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal id As Long _
) As Integer
C#
public virtual int LoadDB(
   long id
)

Parameters

id

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItem Class
SupplierItem Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB() Method
See Also
[image]
dotnetCART Namespace > SupplierItem Class > LoadDB Method : Generic LoadDB() Method

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)() As Integer
C#
public virtual int LoadDB<T1>()where T1: IDbTable

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItem Class
SupplierItem Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB(DbManager) Method
See Also
[image]
dotnetCART Namespace > SupplierItem Class > LoadDB Method : Generic LoadDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int LoadDB<T1>(
   DbManager manager
)where T1: IDbTable

Parameters

manager

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItem Class
SupplierItem Members
Overload List


%%PageItemTitle%%

SaveDB Method
[image]
dotnetCART Namespace > SupplierItem Class : SaveDB Method

Inserts or updates this object into the database.

Overload List

Overload | Description
SaveDB() | Inserts or updates this object into the database. (Inherited from dotnetCART.DbTableCart<SupplierItem, Int64>)
SaveDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItem Class
SupplierItem Members


%%PageItemTitle%%

SaveDB() Method
[image]
dotnetCART Namespace > SupplierItem Class > SaveDB Method : SaveDB() Method

Inserts or updates this object into the database.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function SaveDB() As Integer
C#
public virtual int SaveDB()

Return Value

Returns the generated ID or 1 for the update, returns -1 if failed. For the reason of fail, check the Generic DbTableCart.Error property.

Remarks

If Generic DbTableCart.ID greater than 0, it updates the associated object in the table, otherwise inserts a new object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItem Class
SupplierItem Members
Overload List


%%PageItemTitle%%

SaveDB(DbManager) Method
[image]
dotnetCART Namespace > SupplierItem Class > SaveDB Method : SaveDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function SaveDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int SaveDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItem Class
SupplierItem Members
Overload List


%%PageItemTitle%%

SetCustom Method
[image]
dotnetCART Namespace > SupplierItem Class : SetCustom Method

name
newValue
This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added.

Syntax

Visual Basic (Declaration)
Public Function SetCustom( _
   ByVal name As String, _
   ByVal newValue As Object _
) As Object
C#
public object SetCustom(
   string name,
   object newValue
)

Parameters

name
newValue

Return Value

Returns the new custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

SupplierItem Class
SupplierItem Members


%%PageItemTitle%%

Add Method
[image]
dotnetCART Namespace > Suppliers Class : Add Method

item
Adds an object to the end of the collection.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal item As Supplier _
)
C#
public void Add(
   Supplier item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Suppliers Class
Suppliers Members


%%PageItemTitle%%

AddRange Method
[image]
dotnetCART Namespace > Suppliers Class : AddRange Method

collection
Adds the elements of the specified collection to the end of the collection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal collection As IEnumerable(Of Supplier) _
)
C#
public void AddRange(
   IEnumerable<Supplier> collection
)

Parameters

collection

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Suppliers Class
Suppliers Members


%%PageItemTitle%%

AsReadOnly Method
[image]
dotnetCART Namespace > Suppliers Class : AsReadOnly Method

Returns a read-only IList wrapper for the current collection.

Syntax

Visual Basic (Declaration)
Public Function AsReadOnly() As ReadOnlyCollection(Of Supplier)
C#
public ReadOnlyCollection<Supplier> AsReadOnly()

Return Value

A ReadOnlyCollection that acts as a read-only wrapper around the current List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Suppliers Class
Suppliers Members


%%PageItemTitle%%

BinarySearch Method
[image]
dotnetCART Namespace > Suppliers Class : BinarySearch Method

Overload List

Overload | Description
BinarySearch(Supplier) | (Inherited from dotnetCART.ListBase<Supplier>)
BinarySearch(Supplier,Generic IComparer) | (Inherited from dotnetCART.ListBase<Supplier>)
BinarySearch(Int32,Int32,Supplier,Generic IComparer) | (Inherited from dotnetCART.ListBase<Supplier>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Suppliers Class
Suppliers Members


%%PageItemTitle%%

BinarySearch(Int32,Int32,Supplier,Generic IComparer) Method
[image]
dotnetCART Namespace > Suppliers Class > BinarySearch Method : BinarySearch(Int32,Int32,Supplier,Generic IComparer) Method

index
count
item
comparer

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal index As Integer, _
   ByVal count As Integer, _
   ByVal item As Supplier, _
   ByVal comparer As IComparer(Of Supplier) _
) As Integer
C#
public int BinarySearch(
   int index,
   int count,
   Supplier item,
   IComparer<Supplier> comparer
)

Parameters

index
count
item
comparer

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Suppliers Class
Suppliers Members
Overload List


%%PageItemTitle%%

BinarySearch(Supplier) Method
[image]
dotnetCART Namespace > Suppliers Class > BinarySearch Method : BinarySearch(Supplier) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal item As Supplier _
) As Integer
C#
public int BinarySearch(
   Supplier item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Suppliers Class
Suppliers Members
Overload List


%%PageItemTitle%%

BinarySearch(Supplier,Generic IComparer) Method
[image]
dotnetCART Namespace > Suppliers Class > BinarySearch Method : BinarySearch(Supplier,Generic IComparer) Method

item
comparer

Syntax

Visual Basic (Declaration)
Public Overloads Function BinarySearch( _
   ByVal item As Supplier, _
   ByVal comparer As IComparer(Of Supplier) _
) As Integer
C#
public int BinarySearch(
   Supplier item,
   IComparer<Supplier> comparer
)

Parameters

item
comparer

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Suppliers Class
Suppliers Members
Overload List


%%PageItemTitle%%

Capacity Property
[image]
dotnetCART Namespace > Suppliers Class : Capacity Property

Gets or sets the total number of elements the internal data structure can hold without resizing.

Syntax

Visual Basic (Declaration)
Public Property Capacity As Integer
C#
public int Capacity {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Suppliers Class
Suppliers Members


%%PageItemTitle%%

Clear Method
[image]
dotnetCART Namespace > Suppliers Class : Clear Method

Removes all elements from the List.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Suppliers Class
Suppliers Members


%%PageItemTitle%%

Contains Method
[image]
dotnetCART Namespace > Suppliers Class : Contains Method

item
Determines whether an element is in the List.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal item As Supplier _
) As Boolean
C#
public bool Contains(
   Supplier item
)

Parameters

item

Return Value

true if item is found in the List; otherwise, false.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Suppliers Class
Suppliers Members


%%PageItemTitle%%

CopyTo Method
[image]
dotnetCART Namespace > Suppliers Class : CopyTo Method

Overload List

Overload | Description
CopyTo(Supplier[]) | (Inherited from dotnetCART.ListBase<Supplier>)
CopyTo(Supplier[],Int32) | (Inherited from dotnetCART.ListBase<Supplier>)
CopyTo(Int32,Supplier[],Int32,Int32) | (Inherited from dotnetCART.ListBase<Supplier>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Suppliers Class
Suppliers Members


%%PageItemTitle%%

CopyTo(Int32,Supplier[],Int32,Int32) Method
[image]
dotnetCART Namespace > Suppliers Class > CopyTo Method : CopyTo(Int32,Supplier[],Int32,Int32) Method

index
array
arrayIndex
count

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal index As Integer, _
   ByVal array() As Supplier, _
   ByVal arrayIndex As Integer, _
   ByVal count As Integer _
)
C#
public void CopyTo(
   int index,
   Supplier[] array,
   int arrayIndex,
   int count
)

Parameters

index
array
arrayIndex
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Suppliers Class
Suppliers Members
Overload List


%%PageItemTitle%%

CopyTo(Supplier[]) Method
[image]
dotnetCART Namespace > Suppliers Class > CopyTo Method : CopyTo(Supplier[]) Method

array

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array() As Supplier _
)
C#
public void CopyTo(
   Supplier[] array
)

Parameters

array

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Suppliers Class
Suppliers Members
Overload List


%%PageItemTitle%%

CopyTo(Supplier[],Int32) Method
[image]
dotnetCART Namespace > Suppliers Class > CopyTo Method : CopyTo(Supplier[],Int32) Method

array
arrayIndex

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array() As Supplier, _
   ByVal arrayIndex As Integer _
)
C#
public void CopyTo(
   Supplier[] array,
   int arrayIndex
)

Parameters

array
arrayIndex

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Suppliers Class
Suppliers Members
Overload List


%%PageItemTitle%%

Count Property
[image]
dotnetCART Namespace > Suppliers Class : Count Property

Gets the number of elements actually contained in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Suppliers Class
Suppliers Members


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > Suppliers Class : Error Property

Returns an object with the error information.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Suppliers Class
Suppliers Members


%%PageItemTitle%%

GetEnumerator Method
[image]
dotnetCART Namespace > Suppliers Class : GetEnumerator Method

Returns an enumerator that iterates through the List.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As List.Enumerator(Of Supplier)
C#
public List.Enumerator<Supplier> GetEnumerator()

Return Value

A List.Enumerator for the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Suppliers Class
Suppliers Members


%%PageItemTitle%%

IndexOf Method
[image]
dotnetCART Namespace > Suppliers Class : IndexOf Method

Overload List

Overload | Description
IndexOf(Supplier) | (Inherited from dotnetCART.ListBase<Supplier>)
IndexOf(Supplier,Int32) | (Inherited from dotnetCART.ListBase<Supplier>)
IndexOf(Supplier,Int32,Int32) | (Inherited from dotnetCART.ListBase<Supplier>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Suppliers Class
Suppliers Members


%%PageItemTitle%%

IndexOf(Supplier) Method
[image]
dotnetCART Namespace > Suppliers Class > IndexOf Method : IndexOf(Supplier) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As Supplier _
) As Integer
C#
public int IndexOf(
   Supplier item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Suppliers Class
Suppliers Members
Overload List


%%PageItemTitle%%

IndexOf(Supplier,Int32) Method
[image]
dotnetCART Namespace > Suppliers Class > IndexOf Method : IndexOf(Supplier,Int32) Method

item
index

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As Supplier, _
   ByVal index As Integer _
) As Integer
C#
public int IndexOf(
   Supplier item,
   int index
)

Parameters

item
index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Suppliers Class
Suppliers Members
Overload List


%%PageItemTitle%%

IndexOf(Supplier,Int32,Int32) Method
[image]
dotnetCART Namespace > Suppliers Class > IndexOf Method : IndexOf(Supplier,Int32,Int32) Method

item
index
count

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal item As Supplier, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
C#
public int IndexOf(
   Supplier item,
   int index,
   int count
)

Parameters

item
index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Suppliers Class
Suppliers Members
Overload List


%%PageItemTitle%%

Insert Method
[image]
dotnetCART Namespace > Suppliers Class : Insert Method

index
item
Inserts an element into the List at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As Supplier _
)
C#
public void Insert(
   int index,
   Supplier item
)

Parameters

index
item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Suppliers Class
Suppliers Members


%%PageItemTitle%%

InsertRange Method
[image]
dotnetCART Namespace > Suppliers Class : InsertRange Method

index
collection
Inserts the elements of a collection into the List at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub InsertRange( _
   ByVal index As Integer, _
   ByVal collection As IEnumerable(Of Supplier) _
)
C#
public void InsertRange(
   int index,
   IEnumerable<Supplier> collection
)

Parameters

index
collection

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Suppliers Class
Suppliers Members


%%PageItemTitle%%

Item(Int32) Property
[image]
dotnetCART Namespace > Suppliers Class > Item Property : Item(Int32) Property

index
Gets or sets the element at the specified index.

Syntax

Visual Basic (Declaration)
Public Overloads Property Item( _
   ByVal index As Integer _
) As Supplier
C#
public Supplier Item(
   int index
) {get; set;}

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Suppliers Class
Suppliers Members
Overload List


%%PageItemTitle%%

LastIndexOf Method
[image]
dotnetCART Namespace > Suppliers Class : LastIndexOf Method

Overload List

Overload | Description
LastIndexOf(Supplier) | (Inherited from dotnetCART.ListBase<Supplier>)
LastIndexOf(Supplier,Int32) | (Inherited from dotnetCART.ListBase<Supplier>)
LastIndexOf(Supplier,Int32,Int32) | (Inherited from dotnetCART.ListBase<Supplier>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Suppliers Class
Suppliers Members


%%PageItemTitle%%

LastIndexOf(Supplier) Method
[image]
dotnetCART Namespace > Suppliers Class > LastIndexOf Method : LastIndexOf(Supplier) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As Supplier _
) As Integer
C#
public int LastIndexOf(
   Supplier item
)

Parameters

item

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Suppliers Class
Suppliers Members
Overload List


%%PageItemTitle%%

LastIndexOf(Supplier,Int32) Method
[image]
dotnetCART Namespace > Suppliers Class > LastIndexOf Method : LastIndexOf(Supplier,Int32) Method

item
index

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As Supplier, _
   ByVal index As Integer _
) As Integer
C#
public int LastIndexOf(
   Supplier item,
   int index
)

Parameters

item
index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Suppliers Class
Suppliers Members
Overload List


%%PageItemTitle%%

LastIndexOf(Supplier,Int32,Int32) Method
[image]
dotnetCART Namespace > Suppliers Class > LastIndexOf Method : LastIndexOf(Supplier,Int32,Int32) Method

item
index
count

Syntax

Visual Basic (Declaration)
Public Overloads Function LastIndexOf( _
   ByVal item As Supplier, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
C#
public int LastIndexOf(
   Supplier item,
   int index,
   int count
)

Parameters

item
index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Suppliers Class
Suppliers Members
Overload List


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > Suppliers Class > LoadDB Method : LoadDB() Method

Loads all the items from its associated table.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB() As Integer
C#
public virtual int LoadDB()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Suppliers Class
Suppliers Members
Overload List


%%PageItemTitle%%

LoadDB(Int32,Int32) Method
[image]
dotnetCART Namespace > Suppliers Class > LoadDB Method : LoadDB(Int32,Int32) Method

start
count
Loads the count number of elements from start value.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal start As Integer, _
   ByVal count As Integer _
) As Integer
C#
public virtual int LoadDB(
   int start,
   int count
)

Parameters

start
count

Return Value

The total number of elements have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Suppliers Class
Suppliers Members
Overload List


%%PageItemTitle%%

LoadDB(Where) Method
[image]
dotnetCART Namespace > Suppliers Class > LoadDB Method : LoadDB(Where) Method

whereClause
Loads all the items from its associated table based on the where clause.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal whereClause As Where _
) As Integer
C#
public virtual int LoadDB(
   Where whereClause
)

Parameters

whereClause

Return Value

The total number of items have been loaded.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Suppliers Class
Suppliers Members
Overload List


%%PageItemTitle%%

Remove Method
[image]
dotnetCART Namespace > Suppliers Class : Remove Method

item
Removes the first occurrence of a specific object from the List.

Syntax

Visual Basic (Declaration)
Public Function Remove( _
   ByVal item As Supplier _
) As Boolean
C#
public bool Remove(
   Supplier item
)

Parameters

item

Return Value

true if item is successfully removed; otherwise, false. This method also returns false if item was not found in the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Suppliers Class
Suppliers Members


%%PageItemTitle%%

RemoveAll Method
[image]
dotnetCART Namespace > Suppliers Class : RemoveAll Method

match
Removes the all the elements that match the conditions defined by the specified predicate.

Syntax

Visual Basic (Declaration)
Public Function RemoveAll( _
   ByVal match As Predicate(Of Supplier) _
) As Integer
C#
public int RemoveAll(
   Predicate<Supplier> match
)

Parameters

match

Return Value

The number of elements removed from the List.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Suppliers Class
Suppliers Members


%%PageItemTitle%%

RemoveAt Method
[image]
dotnetCART Namespace > Suppliers Class : RemoveAt Method

index
Removes the element at the specified index of the List.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Suppliers Class
Suppliers Members


%%PageItemTitle%%

RemoveRange Method
[image]
dotnetCART Namespace > Suppliers Class : RemoveRange Method

index
count
Removes a range of elements from the List.

Syntax

Visual Basic (Declaration)
Public Sub RemoveRange( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
C#
public void RemoveRange(
   int index,
   int count
)

Parameters

index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Suppliers Class
Suppliers Members


%%PageItemTitle%%

Reverse Method
[image]
dotnetCART Namespace > Suppliers Class : Reverse Method

Reverses the order of the elements in the entire List.

Overload List

Overload | Description
Reverse() | Reverses the order of the elements in the entire List. (Inherited from dotnetCART.ListBase<Supplier>)
Reverse(Int32,Int32) | Reverses the order of the elements in the specified range. (Inherited from dotnetCART.ListBase<Supplier>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Suppliers Class
Suppliers Members


%%PageItemTitle%%

Reverse() Method
[image]
dotnetCART Namespace > Suppliers Class > Reverse Method : Reverse() Method

Reverses the order of the elements in the entire List.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Reverse()
C#
public void Reverse()

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Suppliers Class
Suppliers Members
Overload List


%%PageItemTitle%%

Reverse(Int32,Int32) Method
[image]
dotnetCART Namespace > Suppliers Class > Reverse Method : Reverse(Int32,Int32) Method

index
count
Reverses the order of the elements in the specified range.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Reverse( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
C#
public void Reverse(
   int index,
   int count
)

Parameters

index
count

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Suppliers Class
Suppliers Members
Overload List


%%PageItemTitle%%

Custom Property
[image]
dotnetCART Namespace > Supplier Class : Custom Property

Gets or sets a custom object. For more information see custom fields

Syntax

Visual Basic (Declaration)
Public Property Custom As Custom
C#
public Custom Custom {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Supplier Class
Supplier Members


%%PageItemTitle%%

CustomFields Property
See Also Example
[image]
dotnetCART Namespace > Supplier Class : CustomFields Property

Gets or sets a the names of custom fields for a table associated with the object.

Syntax

Visual Basic (Declaration)
Public Property CustomFields As String
C#
public string CustomFields {get; set;}

Example

C# Copy Code
Customer.CustomFields = "CellPhone,Favorites";

Visual Basic Copy Code
Customer.CustomFields = "CellPhone,Favorites"

Remarks

Custom fields must be added to the table manualy. Custom fields are usually set at store level using CustomFields

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Supplier Class
Supplier Members


%%PageItemTitle%%

Customs Property
[image]
dotnetCART Namespace > Supplier Class : Customs Property

A reference to the collection of the Custom objects.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Customs As Customs
C#
public Customs Customs {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Supplier Class
Supplier Members


%%PageItemTitle%%

DeleteDB(DbManager) Method
[image]
dotnetCART Namespace > Supplier Class > DeleteDB Method : DeleteDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function DeleteDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int DeleteDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Supplier Class
Supplier Members
Overload List


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > Supplier Class : Error Property

Gets the error object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Supplier Class
Supplier Members


%%PageItemTitle%%

GetCustom Method
[image]
dotnetCART Namespace > Supplier Class : GetCustom Method

This method returns the value of a custom field based on its name in the customs collection.

Overload List

Overload | Description
GetCustom(String) | This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<Supplier, Int64>)
GetCustom(Int32) | This method returns the value of a custom field based on its index in the customs collection. (Inherited from dotnetCART.DbTableCart<Supplier, Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Supplier Class
Supplier Members


%%PageItemTitle%%

GetCustom(Int32) Method
[image]
dotnetCART Namespace > Supplier Class > GetCustom Method : GetCustom(Int32) Method

customIndex
This method returns the value of a custom field based on its index in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal customIndex As Integer _
) As Object
C#
public object GetCustom(
   int customIndex
)

Parameters

customIndex

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Supplier Class
Supplier Members
Overload List


%%PageItemTitle%%

GetCustom(String) Method
[image]
dotnetCART Namespace > Supplier Class > GetCustom Method : GetCustom(String) Method

name
This method returns the value of a custom field based on its name in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal name As String _
) As Object
C#
public object GetCustom(
   string name
)

Parameters

name

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Supplier Class
Supplier Members
Overload List


%%PageItemTitle%%

LoadDB Method
[image]
dotnetCART Namespace > Supplier Class : LoadDB Method

Loads this object from database using the ID property.

Overload List

Overload | Description
LoadDB(Int64) | (Inherited from dotnetCART.DbTableCart<Supplier, Int64>)
LoadDB() | Loads this object from database using the ID property. (Inherited from dotnetCART.DbTableCart<Supplier, Int64>)
Generic LoadDB() | (Inherited from dotnetDATA.DbTable<Int64>)
Generic LoadDB(DbManager) | (Inherited from dotnetDATA.DbTable<Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Supplier Class
Supplier Members


%%PageItemTitle%%

LoadDB() Method
[image]
dotnetCART Namespace > Supplier Class > LoadDB Method : LoadDB() Method

Loads this object from database using the ID property.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB() As Integer
C#
public virtual int LoadDB()

Return Value

In case of error -1, check Error property, if the object with the ID property not found 0, otherwise 1.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Supplier Class
Supplier Members
Overload List


%%PageItemTitle%%

LoadDB(Int64) Method
[image]
dotnetCART Namespace > Supplier Class > LoadDB Method : LoadDB(Int64) Method

id

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal id As Long _
) As Integer
C#
public virtual int LoadDB(
   long id
)

Parameters

id

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Supplier Class
Supplier Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB() Method
See Also
[image]
dotnetCART Namespace > Supplier Class > LoadDB Method : Generic LoadDB() Method

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)() As Integer
C#
public virtual int LoadDB<T1>()where T1: IDbTable

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Supplier Class
Supplier Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB(DbManager) Method
See Also
[image]
dotnetCART Namespace > Supplier Class > LoadDB Method : Generic LoadDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int LoadDB<T1>(
   DbManager manager
)where T1: IDbTable

Parameters

manager

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Supplier Class
Supplier Members
Overload List


%%PageItemTitle%%

SaveDB(DbManager) Method
[image]
dotnetCART Namespace > Supplier Class > SaveDB Method : SaveDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function SaveDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int SaveDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Supplier Class
Supplier Members
Overload List


%%PageItemTitle%%

SetCustom Method
[image]
dotnetCART Namespace > Supplier Class : SetCustom Method

name
newValue
This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added.

Syntax

Visual Basic (Declaration)
Public Function SetCustom( _
   ByVal name As String, _
   ByVal newValue As Object _
) As Object
C#
public object SetCustom(
   string name,
   object newValue
)

Parameters

name
newValue

Return Value

Returns the new custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Supplier Class
Supplier Members


%%PageItemTitle%%

Custom Property
[image]
dotnetCART Namespace > Tax Class : Custom Property

Gets or sets a custom object. For more information see custom fields

Syntax

Visual Basic (Declaration)
Public Property Custom As Custom
C#
public Custom Custom {get; set;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Tax Class
Tax Members


%%PageItemTitle%%

CustomFields Property
See Also Example
[image]
dotnetCART Namespace > Tax Class : CustomFields Property

Gets or sets a the names of custom fields for a table associated with the object.

Syntax

Visual Basic (Declaration)
Public Property CustomFields As String
C#
public string CustomFields {get; set;}

Example

C# Copy Code
Customer.CustomFields = "CellPhone,Favorites";

Visual Basic Copy Code
Customer.CustomFields = "CellPhone,Favorites"

Remarks

Custom fields must be added to the table manualy. Custom fields are usually set at store level using CustomFields

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Tax Class
Tax Members


%%PageItemTitle%%

Customs Property
[image]
dotnetCART Namespace > Tax Class : Customs Property

A reference to the collection of the Custom objects.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Customs As Customs
C#
public Customs Customs {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Tax Class
Tax Members


%%PageItemTitle%%

DeleteDB(DbManager) Method
[image]
dotnetCART Namespace > Tax Class > DeleteDB Method : DeleteDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function DeleteDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int DeleteDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Tax Class
Tax Members
Overload List


%%PageItemTitle%%

Error Property
[image]
dotnetCART Namespace > Tax Class : Error Property

Gets the error object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As Error
C#
public Error Error {get;}

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Tax Class
Tax Members


%%PageItemTitle%%

GetCustom Method
[image]
dotnetCART Namespace > Tax Class : GetCustom Method

This method returns the value of a custom field based on its name in the customs collection.

Overload List

Overload | Description
GetCustom(String) | This method returns the value of a custom field based on its name in the customs collection. (Inherited from dotnetCART.DbTableCart<Tax, Int64>)
GetCustom(Int32) | This method returns the value of a custom field based on its index in the customs collection. (Inherited from dotnetCART.DbTableCart<Tax, Int64>)

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Tax Class
Tax Members


%%PageItemTitle%%

GetCustom(Int32) Method
[image]
dotnetCART Namespace > Tax Class > GetCustom Method : GetCustom(Int32) Method

customIndex
This method returns the value of a custom field based on its index in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal customIndex As Integer _
) As Object
C#
public object GetCustom(
   int customIndex
)

Parameters

customIndex

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Tax Class
Tax Members
Overload List


%%PageItemTitle%%

GetCustom(String) Method
[image]
dotnetCART Namespace > Tax Class > GetCustom Method : GetCustom(String) Method

name
This method returns the value of a custom field based on its name in the customs collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCustom( _
   ByVal name As String _
) As Object
C#
public object GetCustom(
   string name
)

Parameters

name

Return Value

Returns the custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Tax Class
Tax Members
Overload List


%%PageItemTitle%%

LoadDB(Int64) Method
[image]
dotnetCART Namespace > Tax Class > LoadDB Method : LoadDB(Int64) Method

id

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB( _
   ByVal id As Long _
) As Integer
C#
public virtual int LoadDB(
   long id
)

Parameters

id

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Tax Class
Tax Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB() Method
See Also
[image]
dotnetCART Namespace > Tax Class > LoadDB Method : Generic LoadDB() Method

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)() As Integer
C#
public virtual int LoadDB<T1>()where T1: IDbTable

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Tax Class
Tax Members
Overload List


%%PageItemTitle%%

T1
Generic LoadDB(DbManager) Method
See Also
[image]
dotnetCART Namespace > Tax Class > LoadDB Method : Generic LoadDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function LoadDB(Of T1 As IDbTable)( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int LoadDB<T1>(
   DbManager manager
)where T1: IDbTable

Parameters

manager

Type Parameters

T1

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Tax Class
Tax Members
Overload List


%%PageItemTitle%%

SaveDB(DbManager) Method
[image]
dotnetCART Namespace > Tax Class > SaveDB Method : SaveDB(DbManager) Method

manager

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function SaveDB( _
   ByVal manager As DbManager _
) As Integer
C#
public virtual int SaveDB(
   DbManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Tax Class
Tax Members
Overload List


%%PageItemTitle%%

SetCustom Method
[image]
dotnetCART Namespace > Tax Class : SetCustom Method

name
newValue
This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added.

Syntax

Visual Basic (Declaration)
Public Function SetCustom( _
   ByVal name As String, _
   ByVal newValue As Object _
) As Object
C#
public object SetCustom(
   string name,
   object newValue
)

Parameters

name
newValue

Return Value

Returns the new custom field object.

Requirements

Target Platforms: Windows 2000 Server, Windows XP Home Edition, Windows XP, Windows 7, Windows Server 2003, Windows Vista, Windows Server 2008

See Also

Reference

Tax Class
Tax Members


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

dotnetCART Namespace Inheritance Hierarchy

Inheritance Hierarchy

System.Object
dotnetCART.BaseRir
dotnetCART.LacnicRir
dotnetCART.RipeRir
dotnetCART.Cart
dotnetCART.CartCurrency
dotnetCART.CartLiveHelp
dotnetCART.CartShip
dotnetCART.Catalog
dotnetCART.Categories.categoryComparerClass
dotnetCART.Custom
dotnetCART.CustomFields
dotnetCART.Error
dotnetCART.IPCheker
dotnetCART.Mail
dotnetCART.MailLabel
dotnetCART.OptionSelection
dotnetCART.ParseResult
dotnetCART.Payment
dotnetCART.Price
dotnetCART.Rate
dotnetCART.Settings
dotnetCART.SettingsButton
dotnetCART.SettingsCurrency
dotnetCART.SettingsDatabase
dotnetCART.SettingsFraudScore
dotnetCART.SettingsLocation
dotnetCART.SettingsMail
dotnetCART.SettingsPayment
dotnetCART.SettingsShip
dotnetCART.SettingsTax
dotnetCART.Store
dotnetCART.StoreAddress
dotnetCART.Tools
dotnetDATA.DbTable<Int64>
dotnetDATA.DbTable<ActivityLog, Int64>
dotnetCART.DbTableCart<ActivityLog, Int64>
dotnetCART.ActivityLog
dotnetDATA.DbTable<AdCampaign, Int64>
dotnetCART.DbTableCart<AdCampaign, Int64>
dotnetCART.AdCampaign
dotnetDATA.DbTable<Address, Int64>
dotnetCART.DbTableCart<Address, Int64>
dotnetCART.BaseAddress<Address>
dotnetCART.Address
dotnetDATA.DbTable<Category, Int64>
dotnetCART.DbTableCart<Category, Int64>
dotnetCART.Category
dotnetDATA.DbTable<Choice, Int64>
dotnetCART.DbTableCart<Choice, Int64>
dotnetCART.Choice
dotnetDATA.DbTable<Coupon, Int64>
dotnetCART.DbTableCart<Coupon, Int64>
dotnetCART.Coupon
dotnetDATA.DbTable<Customer, Int64>
dotnetCART.DbTableCart<Customer, Int64>
dotnetCART.Customer
dotnetDATA.DbTable<Image, Int64>
dotnetCART.DbTableCart<Image, Int64>
dotnetCART.Image
dotnetDATA.DbTable<ImageTemplate, Int64>
dotnetCART.DbTableCart<ImageTemplate, Int64>
dotnetCART.ImageTemplate
dotnetDATA.DbTable<ItemRelationshipType, Int64>
dotnetCART.DbTableCart<ItemRelationshipType, Int64>
dotnetCART.ItemRelationshipType
dotnetDATA.DbTable<Location, Int64>
dotnetCART.DbTableCart<Location, Int64>
dotnetCART.Location
dotnetDATA.DbTable<LocationType, Int64>
dotnetCART.DbTableCart<LocationType, Int64>
dotnetCART.LocationType
dotnetDATA.DbTable<Option, Int64>
dotnetCART.DbTableCart<Option, Int64>
dotnetCART.Option
dotnetDATA.DbTable<Order, Int64>
dotnetCART.DbTableCart<Order, Int64>
dotnetCART.Order
dotnetDATA.DbTable<OrderAddress, Int64>
dotnetCART.DbTableCart<OrderAddress, Int64>
dotnetCART.BaseAddress<OrderAddress>
dotnetCART.OrderAddress
dotnetDATA.DbTable<OrderCoupon, Int64>
dotnetCART.DbTableCart<OrderCoupon, Int64>
dotnetCART.OrderCoupon
dotnetDATA.DbTable<OrderItem, Int64>
dotnetCART.DbTableCart<OrderItem, Int64>
dotnetCART.OrderItem
dotnetDATA.DbTable<OrderItemOption, Int64>
dotnetCART.DbTableCart<OrderItemOption, Int64>
dotnetCART.OrderItemOption
dotnetDATA.DbTable<OrderTax, Int64>
dotnetCART.DbTableCart<OrderTax, Int64>
dotnetCART.OrderTax
dotnetDATA.DbTable<OrderTransaction, Int64>
dotnetCART.DbTableCart<OrderTransaction, Int64>
dotnetCART.OrderTransaction
dotnetDATA.DbTable<Referrer, Int64>
dotnetCART.DbTableCart<Referrer, Int64>
dotnetCART.Referrer
dotnetDATA.DbTable<Review, Int64>
dotnetCART.DbTableCart<Review, Int64>
dotnetCART.Review
dotnetDATA.DbTable<ShipCompany, Int64>
dotnetCART.DbTableCart<ShipCompany, Int64>
dotnetCART.ShipCompany
dotnetDATA.DbTable<SoftGood, Int64>
dotnetCART.DbTableCart<SoftGood, Int64>
dotnetCART.SoftGood
dotnetDATA.DbTable<SoftGoodsLog, Int64>
dotnetCART.DbTableCart<SoftGoodsLog, Int64>
dotnetCART.SoftGoodsLog
dotnetDATA.DbTable<StockTransaction, Int64>
dotnetCART.DbTableCart<StockTransaction, Int64>
dotnetCART.StockTransaction
dotnetDATA.DbTable<SubItemMapping, Int64>
dotnetCART.DbTableCart<SubItemMapping, Int64>
dotnetCART.SubItemMapping
dotnetDATA.DbTable<Supplier, Int64>
dotnetCART.DbTableCart<Supplier, Int64>
dotnetCART.Supplier
dotnetDATA.DbTable<SupplierItem, Int64>
dotnetCART.DbTableCart<SupplierItem, Int64>
dotnetCART.SupplierItem
dotnetDATA.DbTable<Tax, Int64>
dotnetCART.DbTableCart<Tax, Int64>
dotnetCART.Tax
dotnetDATA.DbTable<String>
dotnetDATA.DbTable<Item, String>
dotnetCART.DbTableCart<Item, String>
dotnetCART.Item
dotnetDATA.EntitySet<Choice>
dotnetCART.Choices
dotnetDATA.EntitySet<Option>
dotnetCART.Options
dotnetDATA.EntitySet<OrderCoupon>
dotnetCART.OrderCoupons
dotnetDATA.EntitySet<OrderItem>
dotnetCART.OrderItems
dotnetDATA.EntitySet<OrderItemOption>
dotnetCART.OrderItemOptions
dotnetDATA.EntitySet<OrderTax>
dotnetCART.OrderTaxes
System.Collections.Generic.List<ActivityLog>
dotnetCART.ListBase<ActivityLog>
dotnetCART.ActivityLogs
System.Collections.Generic.List<AdCampaign>
dotnetCART.ListBase<AdCampaign>
dotnetCART.AdCampaigns
System.Collections.Generic.List<Address>
dotnetCART.ListBase<Address>
dotnetCART.Addresses
System.Collections.Generic.List<Category>
dotnetCART.ListBase<Category>
dotnetCART.Categories
System.Collections.Generic.List<Coupon>
dotnetCART.ListBase<Coupon>
dotnetCART.Coupons
System.Collections.Generic.List<Custom>
dotnetCART.ListBase<Custom>
dotnetCART.Customs
System.Collections.Generic.List<Customer>
dotnetCART.ListBase<Customer>
dotnetCART.Customers
System.Collections.Generic.List<Image>
dotnetCART.ListBase<Image>
dotnetCART.Images
System.Collections.Generic.List<ImageTemplate>
dotnetCART.ListBase<ImageTemplate>
dotnetCART.ImageTemplates
System.Collections.Generic.List<Item>
dotnetCART.ListBase<Item>
dotnetCART.ItemRelationships
dotnetCART.Items
System.Collections.Generic.List<LocationType>
dotnetCART.ListBase<LocationType>
dotnetCART.LocationTypes
System.Collections.Generic.List<Order>
dotnetCART.ListBase<Order>
dotnetCART.Orders
System.Collections.Generic.List<OrderTransaction>
dotnetCART.ListBase<OrderTransaction>
dotnetCART.OrderTransactions
System.Collections.Generic.List<Price>
dotnetCART.ListBase<Price>
dotnetCART.Prices
System.Collections.Generic.List<Referrer>
dotnetCART.ListBase<Referrer>
dotnetCART.Referrers
System.Collections.Generic.List<Review>
dotnetCART.ListBase<Review>
dotnetCART.Reviews
System.Collections.Generic.List<ShipCompany>
dotnetCART.ListBase<ShipCompany>
dotnetCART.ShipCompanies
System.Collections.Generic.List<SoftGood>
dotnetCART.SoftGoods
System.Collections.Generic.List<StockTransaction>
dotnetCART.ListBase<StockTransaction>
dotnetCART.StockTransactions
System.Collections.Generic.List<SubItemMapping>
dotnetCART.SubItemMappings
System.Collections.Generic.List<Supplier>
dotnetCART.ListBase<Supplier>
dotnetCART.Suppliers
System.Collections.Generic.List<SupplierItem>
dotnetCART.ListBase<SupplierItem>
dotnetCART.SupplierItems
System.Collections.Generic.List<Tax>
dotnetCART.Taxes

See Also

Reference

dotnetCART Assembly


Group Specific pricing enables c

Group Specific pricing enables customers that belong to a specific group and are logged in to view and obtain pricing that is specific to that group. This feature operates by creating a field in the items table for the group specific pricing and then setting the customer group to that field name. Pricing will then be obtained from the group field instead of the item price.

For using the WholePrice field for a group of customers:

1-In storeAdmin/Customer tab, set "WholePrice" in the group field for those customers.

2-In storeAdmin/Catalog, set a value for "WholePrice" field for all the items.

3-Arrange your store data flow to enforce the customers login before going to the catalog,

then, the price is set based on the customer's group automatically. If the customer is not logged in, they will see the regular pricing.

(More information: When calling cartObject.Item.LoadDB, if cartObject.Customer.Group has a value,

it tries to find the matching price for that group and sets the item.Price based on that field value.)

Adding a special price for a another group of customers:
-Define a new customer's group which ends with "Price". The name must end with "Price". e.g. "MemberPrice"
-Add the group's name as a new field to the Items table.
-Add the new group to StoreAdmin/EditItem.aspx and EditItem.aspx.cs. There is already a "WholePrice" sample in those pages, just do the same.
-In storeAdmin/Customer tab, set the customers you want to use that price to that group's name.
-A "Sale" price can be added for each group price by adding a new field to the items table with prefix "Sale". For example, you can add a new field "SaleMemberPrice", then in front end catalog for "MemberPrice" group, it displays "SaleMemberPrice".


LiveHelp integration

.netCART includes .netLIVEHELP integration support. .netLIVEHELP is a solution for providing live help or assistance in your online store. It can assist with greater sales and customer satisfaction. Seamless integration between .netLIVEHELP and .netCART enables you to view and modify the carts of customers you assist using .netLIVEHELP. For example, you could put live help chat on your order form and provide an adjustment to their order prior to submission or save abandoned carts by offering a special incentive for completing the order.

See Livehelp in the cart documentation for usage.


cart custom fields

.netCART supports custom fields for the objects associated with a table.

Adding a custom field to the an object:
Custom newCustom = new Custom();
newCustom.Name = "MyCustomField";
newCustom.Value ="MyValue";
myObject.Customs.Add(newCustom);

Accessing a custom field programmatically:
myObject.GetCustom(name/index):This method returns the value of a custom field based on its name or index in the customs collection.

Updating a custom field value programmatically (affects object only, not database):
myObject.SetCustom("key","value"):This method sets the value of a custom field based on the key and value provided. If it finds a key of the same name it updates the value, if there is no such value a new entry will be added.

Saving to the database:
The field should be manually added to the object's associated table and it is automatically saved to the table's database when calling myObject.SaveDB method.

Order object: For order custom fields, the fields must be added to the associated tables:
A list of mapping between the order object's customs and tables:
order.Customs, order.Payments and order.Customer.Customs to Orders and OrdersHistory tables.
order.Items' customs to OrderItems and OrderItemsHistory
order.Items option.Customs in order.Items to OrderItemOptions and OrderItemOptionsHistory
Any cart's address like order.BillAddress.Customs , order.ShipAddress.Customs, and order.Customer.Addresses to OrderAddresses and OrderAddressesHistory tables.
order.Coupons customs to OrderCoupons and OrderCouponsHistory
order.Taxes customs to OrderTaxes and OrderTaxesHistory
order.Transactions' customs to OrderTransactions and OrderTransactionsHistory

Cart object: Cart level custom fields data are automatically saved to the database along with all other order information when calling cart.SaveOrderDB() method however first the custom fields must be added to the associated tables:
A list of mapping between the cart object's customs and tables:
cart.Customs and cart.Customer.Customs to Orders and OrdersHistory tables. If using inline registration feature, the custom fields must be added to Customers table as well.
cart.Items' customs to OrderItems and OrderItemsHistory
cart.Items option.Customs in cart.Items to OrderItemOptions and OrderItemOptionsHistory
Any cart's address like cart.BillAddress.Customs , cart.ShipAddress.Customs, and cart.Customer.Addresses to OrderAddresses and OrderAddressesHistory tables. If using inline registration feature, the custom fields must be added to Addresses table as well.
cart.Coupons customs to OrderCoupons and OrderCouponsHistory
cart.Taxes customs to OrderTaxes and OrderTaxesHistory

Loading from database: myObject.LoadDB loads all the defined custom fields to myObject.Customs collection You can define one or more custom fields for an object using one of the following methods:

1-Set to myObject.CustomFields property: it loads the custom filelds to myObject.Customs collection when calling myObject.LoadDB.
e.g myObject.CustomFields = "OrderCustom1,OrderCustom2"

2- Add to Store.Settings.Database.CustomFields collection per application and it loads the custom fields for all the associated objects.
e.g. Fields "OrderCustom1,OrderCustom2" from Orders table: Store.Settings.Database.CustomFields.Add(Tables.Orders, "OrderCustom1,OrderCustom2");


Medium Trust Customization

In medium trust, some of the features in netCART require extra permissions:

Access Database: OleDbPermission
Add to SecurityClasses section: <SecurityClass Name="ReflectionPermission" Description="System.Security.Permissions.ReflectionPermission, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089"/>
Add to PermissionSet section: <IPermission class="OleDbPermission" version="1" Unrestricted="true" />

Oracle Database: OraclePermission
Add to SecurityClasses section: <SecurityClass Name="OraclePermission" Description="System.Data.OracleClient.OraclePermission, System.Data.OracleClient, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089"/>
Add to PermissionSet section: <IPermission class="OraclePermission" version="1" Unrestricted="true" />

MySql Database: SocketPermission
Add to SecurityClasses section: <SecurityClass Name="SocketPermission"
Description="System.Net.SocketPermission, System, Version=4.0.0.0,
Culture=neutral, PublicKeyToken=b77a5c561934e089"/>
Add to PermissionSet section: <IPermission class="SocketPermission" version="1"
Unrestricted="true" />

Email:
SocketPermission
Add to SecurityClasses section: <SecurityClass Name="SocketPermission"
Description="System.Net.SocketPermission, System, Version=4.0.0.0,
Culture=neutral, PublicKeyToken=b77a5c561934e089"/>
Add to PermissionSet section:  <IPermission class="SocketPermission" version="1" Unrestricted="true" />

DPAPI for protecting encryption key: DataProtectionPermission
Add to SecurityClasses section: <SecurityClass Name="DataProtectionPermission" Description="System.Security.Permissions.DataProtectionPermission, System.Security, Version=4.0.0.0, Culture=neutral,PublicKeyToken=b03f5f7f11d50a3a" />
Add to PermissionSet section: <IPermission class="DataProtectionPermission" version="1" Flags="ProtectData,UnprotectData" />

Payment and real-time shipping: WebPermission: If using .NET framework 4.0 or newer, they work with the default medium permission but if using older .NET framework versions, maybe you need to modify it.
PermissionSet section: <IPermission class="WebPermission" version="1" Unrestricted="true" />

PDF invoice and reporting: Currently only works in full trust environment. In the sample bundle, you can remove the link for PDF invoice in CustomerInvoice.aspx page. (section: <span class="pdfIcon">)


Supported Gateways / Processors

.netCHARGE supports all major payment processors providing extensive flexibility for selecting the service, pricing and features that best suits your needs. Best of all, should there be a need to change processors in the future your application does not need to be developed again. In most cases it is as simple as changing the processor selection to begin clearing your transactions with another company.

Supported Gateways / Processors:
·TransFirst: https://TransFirst.com
·Stripe: https://stripe.com
·NaviGate: http://www.merchantplus.com/
·Realex Payments: http://www.realexpayments.com/
·Barclays ePDQ: http://www.barclaycard.co.uk/
·HSBC UK http://www.ukbusiness.hsbc.co.uk
·PayPal Web Site Payments Pro (direct PayPal): http://www.paypal.com
·InnovativeGateway/Merchant (Quickbooks): http://www.innovativemerchant.com/
·Quickbooks: http://quickbooks.intuit.com/
·SecurePay: http://www.securepay.com
·FirstData Global Gateway: http://www.firstdata.com/ecommerce/
·FirstData Global Gateway E4 (Rebranded to Payeezy): http://www.firstdata.com/ecommerce/
·First Data (Secure Transport Link): http://www.firstdata.com
·CyberSource http://www.cybersource.com
·Trust Commerce http://www.trustcommerce.com
·OptimalPayments: http://www.optimalpayments.com
·ESecPayments: http://www.esecpayments.com.au
·Vital / Visanet Native: http://www.vitalps.com
·Segapay: http://www.sagepay.com/
·Ogone Replaced by ingenico: http://payment-services.ingenico.com
·PlugnPay: http://www.plugnpay.com
·Paymentech Native Processor: http://www.paymentech.com
·Paymentech Orbital Gateway: http://www.paymentech.com
·Echo: http://www.echo-inc.com
·Moneris: http://www.moneris.com
·Authoize.net AIM with eCHECK / Wells Fargo: http://www.authorize.net
·Elavon Native Processor: http://www.elavon.com/ac quiring/
·PayPal: http://www.paypal.com
·WorldPay (International): http://www.worldpay.com
·PayflowPro: https://www.paypal.com/payflow
·LinkPoint: http://www.firstdata.com/linkpoint/
·Itransact: http://www.itransact.com
·PayReady: http://www.PayReady.net
·PayflowLink: https://www.paypal.com/payflow
·Intellipay: http://www.intellipay.com
·Elavon viaKlix: Replaced by Converge
·Elavon Virtual Merchant: Rebranded by Converge http://www.convergepay.com
·Ecx: http://www.ecx.com
·eProcessing: http://www.eprocessingnetwork.com
·PlanetPayment: http://www.planetpayment.com
·Mcps: http://www.merchantcommerce.net
·SkipJack: http://www.skipjack.com
·NetBilling: http://www.netbilling.com
·PSiGate: http://www.psigate.com
·PayCom: http://www.paycom.net
·ePoch: http://www.ePochsystems.com

For complete details on supported processor / gateways specific properties and additional options supported by the integrated .netCHARGE functionality please see the .netCHARGE documentation.


Sample code for Secure 3D Callba

Sample code for Secure 3D Callback:
[C#]
dotnetCART.Cart CartObject = new dotnetCART.Cart();
bool result = CartObject.LoadCookieDB();
if (result)
{
    CartObject.Payment.ApplySecure3D = 1;
    if (CartObject.Payment.Charge(dotnetCART.Processor.SagePay) == 1)
        dotnetCARTmessage.Text = CartObject.SaveOrderDB();
    else
        dotnetCARTmessage.Text = CartObject.Payment.ErrorMessage;

    if (string.IsNullOrEmpty(dotnetCARTmessage.Text))
    {
        if (CartObject.Errors.Count == 0)
        {
            //Delete temprorary cart from cart table.
            CartObject.DeleteTemporaryCart();
            Order newOrder = new Order();
            newOrder.ID = long.Parse(CartObject.OrderID);
            newOrder.SaveCookie();
            //clear customer cookie
            CartObject.Customer.DeleteCookie();

            Response.Redirect(GlobalStore.CustomerInvoicePage);
        }
        else
            dotnetCARTmessage.Text = CartObject.DisplayErrors();
    }
}
else
{
    dotnetCARTmessage.Text = "This page should be set as Return URL in storeAdmin->Payment for the selected processor/gateway.";
}
[VB.NET]
Dim CartObject As New dotnetCART.Cart()
Dim result As Boolean = CartObject.LoadCookieDB()
If result Then
    CartObject.Payment.ApplySecure3D = 1
    If CartObject.Payment.Charge(dotnetCART.Processor.SagePay) = 1 Then
        dotnetCARTmessage.Text = CartObject.SaveOrderDB()
    Else
        dotnetCARTmessage.Text = CartObject.Payment.ErrorMessage
    End If

    If String.IsNullOrEmpty(dotnetCARTmessage.Text) Then
        If CartObject.Errors.Count = 0 Then
            'Delete temprorary cart from cart table.
            CartObject.DeleteTemporaryCart()
            Dim newOrder As New Order()
            newOrder.ID = Long.Parse(CartObject.OrderID)
            newOrder.SaveCookie()
            'clear customer cookie
            CartObject.Customer.DeleteCookie()

            Response.Redirect(GlobalStore.CustomerInvoicePage)
        Else
            dotnetCARTmessage.Text = CartObject.DisplayErrors()
        End If
    End If
Else
    dotnetCARTmessage.Text = "This page should be set as Return URL in storeAdmin->Payment for the selected processor/gateway."
End If


Real Time shipping

Shipping allows you to configure both algorithm based non real-time shipping (StoreAdmin/Shipping tab/Custom) and real-time shipping options (StoreAdmin/Shipping tab/Real Time) through the .netSHIP add-on.

On the real-time shipping tab you can define origin shipping address which is used when calculating rating. The origin information from your store along with the destination shipping address from your customer is passed to determine the rating for a given order. .netCART also supports grouping and rating multiple packages from a single order sent to more than one address.

Each process can be enabled or disabled with a checkbox on the realtime shipping tab. In addition, there are a number of settings specific to each shipping company required before rating can be performed.

The algorithm based shipping system can be used for special shipping offers or custom shipping rate calculations. Custom shipping definitions can be always returned (enable through the check box) or returned only in the case of a backup or failover call.

This ensures that even when depending on a realtime processor your order pipeline will always be functional.

Other common uses for custom shipping definitions include special offers, for example you could define "Free Ground Shipping" as a type and set the condition as total over greater than $100. This way a free shipping option would be presented to the client only if they had more than $100 of items in their cart. They will still be presented with other shipping options should they require a most costly paid shipping option that would get their good to them sooner.

Real-time shipping with .netSHIP add-on Registration Requirements:

In order to return rates from USPS, Canada Post, FedEx, DHL/Airborne or Conway you must complete registration with these shipping companies.

USPS Registration Address: http://www.shippingapis.com
Information Provided by USPS: Username, Password (if only Username is provided use this value for both Username and Password)
Additional Requirements: After registration you will still not be able to return rates, you must contact USPS to request your account be enabled for the production server.
Services Used: XML domestic rating, XML international rating, and XML tracking.

CanadaPost Registration: Email eparcel@canadapost.ca to request a merchant ID for the XML system.
Information Provided by Canada Post: Merchant ID
Services Used: Native XML

FedEx: You must have a FedEx account number to obtain rates from FedEx. Email websupport@fedex.com to have your current FedEx account number setup on the FedEx test servers for XML API / Direct. When setup you can use FedExAPIGetMeter.aspx (run one time only) to get your meter number for use with the FedExLogin property. When you have completed integration and testing with your application you can then email FedEx again to request certification for your store / implementation and be made live on their productions systems. It is important to clairify that you are working with the Direct XML API for available service rating ONLY and are NOT generating labels. Your email should include your full company and contact details, FedEx account number, Meter Number and details on your usage (for example: "We are using the Direct XML API for available service rating to display available services and rates to customers in our online store. Please advise when the account is certified on the production servers so we may go live with the previously tested implementation."
Services Used: Fedex XML API / Direct (Rate Available Services and Tracking)

DHL, Airborne: Your must have a DHL account (customer number) to obtain rates / tracking. Register your DHL account for the ShipIT XML API and obtain your username, password, and shipping key(s) by emailing your request to XMLRequests@dhl.com. If you are shipping to international locations you will require both domestic and international shipping keys. Note: Airborne has been purchased by DHL and its services rolled into DHL.
Services Used: XML Rating and Tracking (ShipIT / TrackIT)

ConWay: You can get your free username and password from ConWay (www.con-way.com).


.netSHIP Supported Countries

.netSHIP supports real-time rating and tracking the US and Canada. USPS, Airborne and DHL a US origin is required. For Canada Post a Canadian origin is required. For FedEx international origins are supported.

The following countries are supported shipping destinations:

AD Andorra
AE United Arab Emirates
AG Antigua and Barbuda
AI Anguilla
Al Albania
AM Armenia
AN Netherlands Antilles
AR Argentina
AS American Samoa
AT Austria
AU Australia
AW Aruba
AZ Azerbaijan
BA Bosnia and Herzegovina
BB Barbados
BD Bangladesh
BE Belgium
BF Burkina Faso
BG Bulgaria
BH Bahrain
BI Burundi
BJ Benin
BL Bonaire
BM Bermuda
BN Brunei Darussalam
BO Bolivia
BR Brazil
BS Bahamas
BT Bhutan
BV Bouvet Island
BW Botswana
BY Belarus
BZ Belize
CA Canada
CB Curacao
CC Cocos (Keeling) Islands
CD Channel Islands
CF Central African Republic
CG Congo
CH Switzerland
CI Cote D' Ivoi re (Ivory Coast)
CK Cook Islands
CL Chile
CM Cameroon
CN China
CO Colombia
CR Costa Rica
CV Cape Verde
CX Christmas Island
CY Cyprus
CZ Czech Republic
DE Germany
DJ Djibouti
DK Denmark
DM Dominica
DO Dominican Republic
DZ Algeria
EC Ecuador
EE Estonia
EG Egypt
EH Western Sahara
EN England
ER Eritrea
ES Spain
ET Ethiopia
EU St. Eustatius
FI Finland
FJ Fiji
FK Falkland Islands (Malvinas)
FM Micronesia
FO Faroe Islands
FR France
GA Gabon
GB Great Britain (UK)
GD Grenada
GE Georgia
GF French Guiana
GH Ghana
GI Gibraltar
GL Greenland
GM Gambia
GN Guinea
GP Guadeloupe
GQ Equatorial Guinea
GR Greece
GS South Georgia and South Sandwich Isls.
GT Guatemala
GU Guam
GW Guinea-Bissau
GY Guyana
HK Hong Kong
HM Heard Island and McDonald Islands
HN Honduras
HR Croatia (Hrvatska)
HT Haiti
HU Hungary
IC Canary Islands
ID Indonesia
IE Ireland
IL Israel
IN India
IO British Indian Ocean Territory
IS Iceland
IT Italy
JM Jamai ca
JO Jordan
JP Japan
KE Kenya
KG Kyrgyzstan
KH Cambodia
KI Kiribati
KM Comoros
KN Saint Kitts and Nevis
KO Kosrae
KR Korea (South)
KW Kuwait
KY Cayman Islands
KZ Kazakhstan
LA Laos
LB Lebanon
LC Saint Lucia
LI Liechtenstein
LK Sri Lanka
LR Liberia LS Lesotho
LT Lithuania
LU Luxembourg
LV Latvia
MA Morocco
MB St. Maarten
MC Monaco
MD Moldova
MG Madagascar
MH Marshall Islands
MK Macedonia
ML Mali
MM Myanmar
MN Mongolia
MO Macau
MP Northern Mariana Islands
MQ Martinique
MR Mauritania
MS Montserrat
MT Malta
MU Mauritius
MV Maldives
MW Malawi
MX Mexico
MY Malaysia
MZ Mozambique
NA Namibia
NB Northern Ireland
NC New Caledonia
NE Niger
NF Norfolk Island
NG Nigeria
NI Nicaragua
NL Netherlands
NO Norway
NP Nepal
NR Nauru
NT Neutral Zone
NU Niue
NZ New Zealand (Aotearoa)
OM Oman
PA Panama
PE Peru
PF French Polynesia
PG Papua New Guinea
PH Philippines
PK Pakistan
PL Poland
PM St. Pierre and Miquelon
PN Pitcairn
PO Ponape
PR Puerto Rico
PT Portugal
PW Palau
PY Paraguay
QA Qatar
RE Reunion
RO Romania
RT Rota
RU Russian Federation
RW Rwanda
SA Saudi Arabia
SB Solomon Islands
SC Seychelles
SD Sudan
SE Sweden
SF Scotland
SG Singapore
SH St. Helena
SI Slovenia
SJ Svalbard and Jan Mayen Islands
SK Slovak Republic
SL Sierra Leone
SM San Marino
SN Senegal
SO Somalia
SP Saipan
SR Suriname
SS Saba
ST Sao Tome and Principe
SU USSR (former)
SV El Salvador
SW St. Christopher
SY Syria
SZ Swaziland
TB St. Martin
TC Turks and Caicos Islands
TD Chad
TF French Southern Territories
TG Togo
TH Thailand
TI Tinian
TJ Tajikistan
TK Tokelau
TM Turkmenistan
TN Tunisia
TO Tonga
TP East Timor
TR Turkey
TU Truk
TT Trinidad and Tobago
TV Tuvalu
TW Taiwan
TZ Tanzania
UA Ukraine
UG Uganda
UM US Minor Outlying Islands
US United States
UY Uruguay
UZ Uzbekistan
VA Vatican City State (Holy See)
VC Saint Vincent and the Grenadines
VE Venezuela
VG Virgin Islands (British)
VI Virgin Islands (U.S.)
VN Vietnam
VU Vanuatu
WF Wallis and Futuna Islands
WS Samoa
YA Yap
YE Yemen
YT Mayotte
YU Yugoslavia
ZA South Africa
ZM Zambia
ZR Zaire
ZW Zimbabwe


Softgood Delivery

.netCART incorporates comprehensive canned support for softgood delivery including fraud screen prevention.

SoftGood or digital goods delivery is now common on the internet. From software to memberships, ebooks to data of all kinds there are now thousands of goods delivered immediately without human intervention or expense. .netCART's softgood delivery system offers a two pronged approach to softgood fulfillment: 1) deliver goods in a highly convenient and flexible manner 2) minimize system abuse and fraudulent orders. Two delivery systems are offered: email attachment and file streaming. With email attachment when the order is fulfilled each package will be attached to an email and sent to the user. This is a one time operation and works best for small deliverables as many email accounts have a limit on the size of an email attachment they can receive. The second method is file streaming and this system also provides enhanced delivery and access controls. Rather than emailing the files directory this system emails download links but unlike traditional download links which could be posted on the internet these are ticket based and have limits on the total number of requests that can be made and the date they are active. For example, you could allow only a single request and then the ticket would be invalid, any subsequent request to access the file would fail. Combined with the fraudscore system .netCART is an ideal platform for softgood delivery.

How to Enable Softgood delivery:

  • Select one of the delivery options in StoreAdmin->Settings->Website
  • Set the softgood file name for all the items through StoreAdmin->Catalog->Item Details
  • Copy all the softgoods files to App_Data\softgoods. The directory can be changed in Billing.cs/vb page in SendSoftgoodsByEmail function.
  • Fraud Score: If you want to use this feature, configure StoreAdmin->Settings->FraudScore settings and in "Fraud score checking" section in Billing.aspx.cs/vb page set the maximum total fraud score and the order processing if it is exceeded the maximum.
  • In StoreAdmin->Settings->Website, un-check the setting for "Shipping Calculation" checkbox and set Checkout Page to "CheckoutNoShipping.aspx" page. You may un-check the setting for "Shipping Address" checkbox as well.
  • By default, billing.aspx.cs/vb only deliver the digital file after successful payment by credit card. You can change this behavior by modifying the codes in CompleteOrder_ButtonClicked event handler method in billing.aspx.cs/vb.
  • In case of any error for sending email, attaching the digital file etc. it is logged to App_Data\error.log

How to handle items with more than one versions: Digital and Physical:

First create the item with an option with multiple choices like "Digital", "Print 5X7", then through the subItems tab, generate the subitems for that item. Finally, click on the Digital subItem link and set SoftGoodsFileName for the digital subItem in the itemDetails page. For more information, see "Yellow Rose" in the sample data catalog which included in the bundle. In Checkout.aspx page, IsAllSoftgoodItems() function determines whether all the items in the bundle are softgoods or not. This function can be used to redirect to customer to CheckoutNoShipping.aspx, if all the items are softgoods and the shipping address is not required. In billing.aspx page, IsAllPhysicalItems() fucntion determines whether all the items in the bundle are physical items or not. If at lease one is not physical (softgood or digital), SendSoftgoodsByEmail funcation can be called to send link for the item. SendSoftgoodsByEmail function only sends link for the items with SoftGoodFileName and for the other items adds an entry to App_Data\error.log.


SubItem Tutorial

When adding items with options and choices a given selection of option choices typically represents a single physical item. For example, if you have a shirt that is large and red, that is a physical item in inventory. You could create only an item for the shirt and options for size and color yet will not be able to track inventory for the various options independently. This is where subitem handling comes into play. After creating your item and options, you can visit the subitem tab to generate subitem variations. Now .netCART will automatically map option selections to subitems. Furthermore, the created subitem variations will take the pricing from the option prices.

Alternatively, if you have already added the items, you can map the subitem variations to the created items by selecting an unassigned combination, then an item or itemid and click the map combination to item button.
Once subitems or created or assigned you can drill into the subitem to add weight, pricing or images which will be utilized by the AJAX display catalog functionality.

Note: subitems are not required. For smaller stores that do not wish to maintain inventory, regular items with options can be used. In this way, the option variations are not tracked. Hybrid support is also possible where subitems are used in some cases and not in others. The catalog and backend admin will continue to price and show images accurately and if there is nothing defined for a subitem, the item value will be used.

Dynamic display: When selecting combinations based on various options the pricing will dynamically adjust in the cart (displaycart) and catalog (displaycatalog). In addition, the images will dynamically change to match (if per subitem images are uploaded) and display in the cart and catalog appropriately.

Option combinations: option combinations are created by the options defined that are not set as add-ons. Add-ons are special option types that are not considered for inventory and don't represent physical variations for the item. For example, gift wrapping, engraving or special delivery instructions. When creating subitem mappings, the add-ons will not be used.

Additional Image Support: Additional images enable you to show alternate views of an item in addition to the main item image. When adding extra images with a predefined template, by default the thumbnails will show in a grid below the item and mouseover or click on the thumbnail will show the zoom image view for the thumbnail as an overlay on the page.


Virtual Directory Creation

To create a virtual directory you should complete the following steps:

1) Open the MMC (Microsoft Management Console) also called Internet Services Management or commonly referred to as the IIS administration.
2) You will see a list of snap ins, one of which will be called Internet Information Server. Under this you will see your server name, select this server to view a list of sites running on the server
3) Select the site you wish to add a virtual directory for, right click on this site and select "new", "virtual directory"
4) You will be prompted to enter the alias, this is the name you want to access the content through for example enter "dotnetcart" and select next
5) You will be promoted to enter the physical path, this is the path where you unpacked .netCART, for example "C:\Program Files\dotnetCART" you want to point to the web directory as this directory contains the web samples
6) Select "next" and "finish" on the final page.

Your virtual directory is now setup, and you can load the samples through http://www.yoursiteaddress.com/dotnetcart/